История версий

Новое в PNA версии 4.87

Новые команды программирования для версии 4.87

Чтобы проверить версию PNA, нажмите Help, затем About Network Analyzer

Новое в PNA версии 4.86

  • Выделенное окно калибровки

  • Проверка Опции H11

  • Метка класса калибровки

  • Основанный на данных калибровочный комплект теперь может быть изменен

  • Безопасное отключение PNA без мыши

Новое в PNA версии 4.83

  • Новые модели PNA-L (N5230A опции 020 / 025 / 120 / 125)

  • Предварительные установки пользователя User Preset с использованием SCPI и COM

  • Смещение по модулю (Magnitude Offset)

  • Калиброванные измерения фиксированного выхода, VMC

  • Новые VMC измерения абсолютной мощности для R1 и B

  • Управление запуском через разъем Material Handler Также доступно использование SCPI и COM

  • Статус Global Pass / Fail Также доступно использование SCPI и COM.

  • Изменения в ECAL - могут повлиять на существующие программы SCPI

    • Настройки по умолчанию для метода Thru

    • Изоляция отключена

    • Удаление адаптера теперь выполняет полную 2-портовую калибровку с обоих сторон адаптера.

    • Unknown Thru и Flush Thru теперь используют два, вместо трех, шага подключения.

  • В диалоговом окне Sweep появилась кнопка Apply

  • Пересмотрены проверки, производимые оператором

  • Процедура запуска VNC

См. Новые команды программирования для версии 4.83

Новое в PNA версии 4.25

  • Связывание во временной области

  • Маркеры расстояния во временной области

  • Сеанс GPIB Pass-through

  • Произвольное сегментированное свипирование

  • Новые возможности внешнего запуска

  • Формирование профиля импульса и другие функции приложения Pulsed Application

  • Поддержка Windows© XP

См. Новые команды программирования для версии 4.25

Новое в PNA версии 4.0

  • Новые номера моделей PNA-L

  • Доступ к ПЧ (опция H11)

  • Поддержка внешнего модуля миллиметровых волн (опция H11)

  • Приложение Pulsed Application (опция H08)

  • Уменьшенная полоса ПЧ на низких частотах

  • Поддержка формата файлов CitiFile (*.cti )

  • Улучшенное сохранение файлов SnP

  • Новые настройки точности калибровки источника

  • Приложение Преобразователь частоты

    • Измерения фиксированного выхода

    • Усовершенствованное управление внешним источником

  • Импортирование устаревших калибровочных комплектов

  • Режим обработки данных в 8510

  • Справка на китайском языке

См. Новые команды программирования для версии 4.0

Новое в PNA версии 3.5

  • Поддержка опций 014, 016, 081 для E8361A (конфигурируемый измерительный пульт, аттенюаторы приемника, и опорный переключатель).

  • Скрытие информации о частоте - отключение отображения информации о частоте в целях безопасности.

  • Улучшенное Local Lockout для GPIB и COM

  • Новые возможности редактирования калибровочного комплекта через SCPI в новых примерах программ. (Имя коннектора, описание комплекта, удаление стандарта, описание стандарта.)

  • Поддержка до восьми подключенных к PNA модулей ECAL.

  • Улучшенная конфигурация смесителя в приложении FCA - (Расчет входной частоты)

  • Изменение в измерениях в приложении FCA с использованием SCPI

Новое в PNA версии 3.1

  • Поддержка новых моделей PNA E8361A - 67 ГГц

  • Приложение Преобразователь частоты (FCA) (опция. 083)

  • Алгоритм калибровки Expanded Math

Новое в PNA версии 3.0

  • Измерения со сдвигом частоты - стимул и отклик могут быть настроены на разные частоты.

  • Поддержка новых моделей PNA - E8362B, E8363B, E8364B.

  • Увеличение количества точек (16,001), каналов (32), и окон (16)
    См. примечание о скорости обработки    .

  • Макрос для приспособлений - помогает компенсировать влияние измерительных приспособлений.

  • Размещение точек на оси X - альтернативный способ отображения сегментированного свипирования.

  • Копирование каналов - копирование настроек канала на новый или существующий канал.

  • Trigger IN / OUT - поддержка запуска по фронту в новых моделях PNA.

  • Улучшение калибровки - объединение калибровочных комплектов (больше нет версии 1 и версии 2). Заменяет Cal Kit Manager.

Новое в PNA версии 2.6

  • Выбор калибровочного стандарта Произвольное сопротивление

  • Множество улучшений в документации справки, включая нахождение команд программирования.

Новое в PNA версии 2.5

  • ECAL - базовая поддержка 4-портового модуля.

  • Пользовательские характеристики ECAL - использование адаптеров с модулем ECAL и сохранение характеристик в памяти модуля.

  • Логарифмическое свипирование по частоте - Логарифмическое свипирование и отображение.

  • Калибровка TRL - добавлены опции импеданса и плоскости отсчета.

  • Мастер калибровки - улучшение сообщений об ошибках.

  • Автоматическая проверка - автоматически проверяет наличие в Интернете новых версий прошивки PNA.

  • Cal Kit Manager - управление калибровочными комплектами версии 1 (удалено в редакции 3.0).

Новое в PNA версии 2.0

Ниже показаны новые и измененные функции PNA версии A.02 (в отличие от A.01.5).

Новые функции

  • 3-портовые измерения - включает выбор всех 9 S-параметров, выбор приемника "C" и связанные отношения, управление уровнем мощности на порту 3.

  • Калибровочные комплекты - концепция подобна примененной в анализаторе цепей 8510 но с большими возможностями и гибкостью.

  • Пользовательские предварительные условия - Вы можете настроить функциональность PRESET на передней панели.

  • AUXILIARY I/O, EXTERNAL TEST SET I/O, и MATERIAL HANDLER I/O - новые разъемы на задней панели.

  • Проверка надежности ECal - гарантирует надежность электронной калибровки.

  • Управление файлами... в меню File предоставляет функциональность File Manager для PNA.

  • Калибровка мощности источника и Калибровка мощности приемника - выравнивание уровня мощности для точных измерений абсолютной мощности.

  • S3P ASCII - формат файла для файлов с данными.

  • Сохранение изображения на экране в формате .jpg.

  • Свернуть - выбор меню View позволяет свернуть приложение PNA.

Измененные функции

  • Мастер калибровки - поддерживает управляемые и неуправляемые калибровки. Управляемые калибровки предоставляют дополнительные функции "удаление адаптера", "unknown thru" и "полную 3-портовую калибровку". Обе, управляемая и неуправляемая калибровки, поддерживают калибровочные стандарты "скользящая нагрузка" и более одного стандарта для данного интервала частот.

  • Граничные линии - теперь могут быть видны на нескольких графиках в одном окне. Также граничные линии теперь обновляются для неактивных графиков.

  • 16 независимых каналов - увеличение с 4-х.

  • Добавлены несколько улучшений для маркеров:
    Связанные маркеры
    Показания маркера
    Графики в памяти     теперь поддерживают маркеры.

  • SYSTem:PRESet - эта команда SCPI больше не восстанавливает дисплей если она отключена из-за DISP:ENAB OFF. Дисплей восстанавливается кнопкой Preset на передней панели или *RST.

  • Обзор моделей PNA - включает новые модели анализаторов в серии PNA. Запускается с рабочего стола PNA.


Учетные записи и пароли пользователей PNA

После включения питания PNA он автоматически входит в Windows, используя заданные по умолчанию имя и пароль пользователя. Это дает полный доступ к анализатору. Для повышения безопасности PNA можно предпринять следующие действия.

  • Потребуйте, чтобы пользователи регистрировались после включения компьютера PNA - См. как включить эту функцию

  • Установите в PNA индивидуальные учетные записи с разными уровнями доступа – Способ установки описан в Добавление или изменение учетной записи и пароля пользователя

Пожалуйста прочтите про антивирусную защиту PNA

Существующие учетные записи

На новых PNA уже существуют следующие учетные записи:

  • Заданная по умолчанию учетная запись пользователя
    Начиная с апреля, 2004, PNA поступают с производства с заданным по умолчанию именем пользователя PNA-Admin и паролем - agilent.
    В более ранних поставках PNA заданное имя пользователя - Administrator пароль - tsunami или оставить пустое пуле.
    Данные учетные записи созданы Windows, их нельзя удалять.
    Мы рекомендуем изменить пароль и, при желании, имя пользователя.
    НЕ ЗАБЫВАЙТЕ СВОЙ НОВЫЙ ПАРОЛЬ. Без него вы не сможете запустить PNA.

  • Agilent Account Это учетная запись администратора, созданная Agilent для целей обслуживания. В каждом PNA уникальный пароль для этой учетной записи. Несмотря на то, что Windows это допускает, не удаляйте данную учетную запись.

  • Guest Account Данная учетная запись дает возможность ввести любое имя без пароля и получить ограниченный доступ к файлам PNA. Эту учетную запись создает Windows, ее нельзя удалять. Ее можно переименовать. При поставке PNA данная учетная запись отключена.

Примечания

  • Несмотря на то, что Windows это допускает, НЕ устанавливайте учетную запись Administrator без пароля. Интернет-вирусы ищут такую ситуацию и пользуются ею.

  • Вы можете создавать необходимое количество пользовательских учетных записей.

  • Имя пользователя не чувствительно к регистру. Пароль ЧУВСТВИТЕЛЕН к регистру.

  • Локальная стратегия PNA настроена так, что при необходимости регистрации при входе в систему, необходимо каждый раз набирать имя пользователя (и пароль). Не меняйте локальные настройки PNA.

Требование регистрации пользователей при включении компьютера PNA.

Как узнать какая операционная система установлена?

Windows 2000 | Windows XP
На панели задач Windows нажмите Start (Пуск), затем Settings (Настройки), затем Control Panel (Панель управления) | На панели задач Windows нажмите Start (Пуск), затем Run (Выполнить)
Дважды щелкните по Users and Passwords (Пользователи и пароли) | Наберите control userpasswords2 затем нажмите OK
Установите флажок в поле Users must enter a user name and password to use this computer (Для использования данного компьютера необходимо ввести имя пользователя и пароль). | Установите флажок в поле Users must enter a user name and password to use this computer (Для использования данного компьютера необходимо ввести имя пользователя и пароль).

Для отключения этой функции выполните ту же процедуру, но снимите флажок. Учетная запись, выделенная, когда снимается флажок, будет автоматически регистрироваться при включении компьютера.

Добавление или изменение учетных записей и паролей пользователей

Если анализатор работает в среде с защитой, можно настроить соответствие имен пользователей PNA и различных уровней доступа. Это особенно важно при дистанционном управлении PNA или доступе по локальной сети.

Можно назначить администратора и сконфигурировать PNA так, чтобы уровень доступа остальных пользователей был ограничен. Это означает, что другие пользователи смогут работать с анализатором, но не будут иметь возможности выполнять все административные функции.

Способ добавления или изменения учетной записи и пароля пользователя

Как узнать какая операционная система установлена?

Windows 2000

Windows XP

В меню анализатора System перейдите к Configure, (Конфигурировать) и нажмите Control Panel (Панель управления).

Нажмите Start, затем перейдите к Settings, затем нажмите Control Panel

В окне Control Panel пройдите вниз по полосе прокрутки и выберите приложение Users and Passwords (Пользователи и пароли).

Нажмите User Accounts (Учетные записи пользователей)

На закладке Users (Пользователи), если кнопка Add (Добавить) затенена, выберите поле Users must enter a user name and password to use this computer (Для использования данного компьютера необходимо ввести имя пользователя и пароль) в верхней части окна.

Следуйте приглашениям, чтобы:

  • Изменить учетную запись

  • Создать новую учетную запись

  • Изменить тип входа пользователей в систему и выхода из нее.

Нажмите Add (Добавить), чтобы ввести свои данные или данные другого пользователя.

ВНИМАНИЕ: Несмотря на то, что в Windows это разрешено, учетная запись Administrator НЕ должна работать без пароля. Интернет-вирусы ищут такую ситуацию и пользуются ею.

В поле User name (Имя пользователя) введите имя пользователя. В поле Full name (Полное имя) введите полное имя пользователя.

В поле Description (Описание) введите описание пользователя. Затем нажмите Next (Дальше).

В поле Password (Пароль) пользователь должен набрать пароль. Пользователь должен повторно ввести пароль в поле Confirm password (Подтвердить пароль). Затем нажмите Next (Дальше).

Выберите уровень доступа, который вы хотите предоставить этому пользователю.

Примечание: Стандартные пользователи и пользователи с ограниченным доступом не могут переключать режимы GPIB и устанавливать встроенные программы.

TВы можете предоставить другие уровни безопасности из списка Other Other (Другое). Описание каждого из таких уровней появляется под полем Other при его выделении. Затем нажмите Finish (Завершить).

В поле Users for this computer (пользователи данного компьютера) подтвердите имя пользователя и группу уровня безопасности пользователя.

Если пользователь должен иметь возможность работать с анализатором без постоянного ввода пароля, снимите флажок в поле Users must enter a user name and password to use this computer (Для использования данного компьютера необходимо ввести имя пользователя и пароль). Нажмите OK.

При появлении окна Automatically Log On новый пользователи должен ввести свой пароль в поле Password и ввести его повторно в поле Confirm Password box.

Нажмите OK, чтобы завершить добавление пользователя.

В меню File нажмите Close, чтобы закрыть панель управления.


Свойства компьютера PNA

PNA использует персональный компьютер и операционную систему Windows. Далее перечислены общие задачи, которые, возможно, будет необходимо выполнить на компьютере PNA.

  • Просмотр или изменение полного имени компьютера

  • Проверка IP-адреса

  • Проверка размера ОЗУ

  • Проверка скорости ЦПУ

  • Установка времени и даты

Другие разделы по администрированию

Просмотр или изменение полного имени компьютера

Ваш PNA имеет уникальное имя компьютера, которое идентифицирует его в сети. Для просмотра или изменения имени компьютера сначала необходимо минимизировать приложение PNA.

Как узнать какая операционная система установлена?

Windows 2000 | Windows XP
На рабочем столе щелкните правой кнопкой мыши по пиктограмме My Computer | На рабочем столе щелкните правой кнопкой мыши по пиктограмме My computer Icon
Нажмите Properties | Нажмите Properties
Щелкните по закладке Network Identification (Сетевая идентификация) в верхней части диалогового окна | Щелкните по закладке Computer Name (Имя компьютера) в верхней части диалогового окна
Нажмите Properties | Нажмите Change (Изменить) возле сообщения "..rename this computer.." (переименовать этот компьютер)
Введите новое Computer Name | Введите новое Computer Name

Примечание: Для добавления компьютера к домену или настройки сетевой конфигурации свяжитесь с отделом ИТ вашей компании. Такая настройка индивидуальна для каждой компании.

Для восстановления приложения PNA нажмите PNA Analyzer на панели задач в нижней части экрана.

Проверка IP-адреса

Если PNA подключен к локальной сети, вы можете просмотреть IP-адрес и другую сетевую информацию.

  1. Минимизируйте приложение PNA

  2. Нажмите Start, затем Run

  3. Введите cmd, затем нажмите OK

  4. В запросе DOS введите ipconfig /all

Проверка размера ОЗУ

Оперативное запоминающее устройство (RAM) – это рабочая память вашего компьютера. Для приложения PNA может потребоваться до 512 MB RAM, в зависимости от используемых настроек. Если на экране открыто больше четырех окон, и компьютер медленно работает, либо вы постоянно используете более 1601 точек данных, возможно, вам потребуется довести RAM до 512 МВ.

Для просмотра объема RAM в PNA сначала необходимо минимизировать приложение PNA.

Windows 2000 или Windows XP

  1. На рабочем столе щелкните правой кнопкой мыши по My Computer

  2. Нажмите Properties

  3. Щелкните на закладке General в верхней части диалогового окна

  4. В нижней части окна появится размер ОЗУ.

TДля восстановления приложения PNA нажмите PNA Analyzer на панели задач в нижней части экрана.

Проверка скорости ЦПУ

Скорость процессора PNA (CPU) – это фактор, определяющий скорость обработки данных PNA. Смотрите Конфигурации PNA, чтобы узнать, надо ли обновлять процессор PNA. Для проверки скорости процессора PNA необходимо сначала минимизировать приложение PNA.

Как узнать какая операционная система установлена?

Windows 2000 | Windows XP
На рабочем столе щелкните правой кнопкой мыши по пиктограмме My Computer | На рабочем столе щелкните правой кнопкой мыши по пиктограмме My computer Icon
Нажмите Manage (Управлять) | Нажмите Properties
Откройте папку System Tools (Системные инструменты), затем нажмите System Information (Системная информация). | Щелкните по закладке General в верхней части диалогового окна
Нажмите System Summary (Сведения о системе). | В нижней части окна появится скорость процессора
После обновления скорость процессора появится в конце записи Processor. |

Для восстановления приложения PNA нажмите PNA Analyzer на панели задач в нижней части экрана.

Установка времени и даты

Для Windows 2000 и Windows XP

Для установки времени и даты PNA необходимо сначала минимизировать приложение PNA.

  1. Передвиньте курсор в нижний угол экрана

  2. Когда появится панель задач, дважды щелкните по индикатору времени. Откроется диалоговое окно Date/Time Properties (Свойства дата/время).

  3. Измените дату, время и временную зону, соответственно.

Для восстановления приложения PNA нажмите PNA Analyzer на панели задач в нижней части экрана.


Устранение проблем с жестким диском PNA

Наиболее частая причина сбоев PNA – проблемы с жестким диском. Эти проблемы обычно можно предупредить (см. Предупреждение сбоев жесткого диска), и, в большинстве случаев, устранить. Ниже приведены рекомендации, позволяющие предотвратить выход из строя жесткого диска.

Ниже приведены три признака возможных проблем с жестким диском. Во-первых попробуйте произвести восстановление операционной системы. Если это сделать не удается, жесткий диск требует замены.

  1. Процесс загрузки прерывается.

    • Если появляется сообщение ‘Couldn’t find NTLDR’, удалите дискету из дисковода анализатора. Если дискета в дисководе отстутсвует, произведите восстановление операционной системы.

    • Если появляется сообщение ‘Operating System not found’, жесткий диск требует замены.

  2. Постоянные "синие экраны" или множество ошибок.

  3. Громкие щелчки или жужжание.

    • Сделайте резервное копирование файлов и замените жесткий диск.

Ниже приведены три признака отсутствия или порчи файлов. Для начала, произведите приведенные ниже действия. Если это не поможет, произведите восстановление операционной системы.

  1. Не найдены важные системные файлы.

  2. Операционная система или приложение PNA не работает.

    • Деинсталлируйте приложение PNA при помощи элемента панели управления Add/Remove Programs. Переустановите приложение PNA, дважды щелкнув D:\Updates\Firmware\ *.msi. или скачав прошивку через AgileUpdate.

  3. PNA работает, но очень медленно.

    • Слышны громкие щелчки или жужжание (см. №3 выше).

    • Проверьте память. Для лучшей производительности анализатор должен иметь минимум 128Мб памяти для прошивки версии 3.0 или ниже; 256Мб для прошивки версии 3.1 или выше. Для подробной информации см. PNAHelp

    • Проверить на вирусы и программы-шпионы.

Восстановление операционной системы

Эта процедура предназначена для полного восстановления операционной системы PNA до заводского состояния. Если жесткий диск поврежден, восстановление системы невозможно.

Важное примечание: Эта процедура полностью перезаписывает диск С: При этом теряется следующая информация:

  • Все изменения и добавления, сделанные в программном обеспечении после покупки (кроме опций)

  • Все учетные записи пользователей и пароли

  • Все добавленные программы

  • Все сохраненные состояния прибора

  • Пользовательские настройки Windows

Эту информацию можно предварительно сохранить на дискету или в папку на диске D:. Диск D: не участвует в процессе восстановления. Кроме того, если калибровка прибора не проводилась, то никаких изменений по сравнению с заводскими значениями внесено не будет. Если были внесены изменения в служебные программы, скопируйте все файлы, начинающиеся на “mxcalfile_” из папки C:\Program Files\Agilent\Network Analyzer в папку D:\Calfiles

Процедура

  1. Нажмите Start, Shutdown, Restart

  2. После появления логотипа Agilent при появлении строки ‘Please select the operating system to start:’ быстро нажмите кнопку "стрелка вниз" и выберите System Recovery partition, (НЕ Recovery Console). Нажмите Enter. ПРИМЕЧАНИЕ: Если этот экран не появляется при загрузке, то можно загрузиться с дискеты. См. раздел Если невозможно загрузиться с жесткого диска ниже.

  3. Появится предупреждающее сообщение с двумя возможностями отказаться. После второго предупреждения сразу начинается процесс восстановления.

  4. Восстановление занимает от 15 до 45 минут. При этом никаких действий пользователя не требуется. Перед окончанием процесса PNA может несколько раз перезагружаться. Не используйте анализатор до тех пор, пока процесс восстановления не завершится и не запустится приложение PNA.

  5. После полного восстановления операционной системы восстановите скопированные ранее файлы. Файлы mxcalfiles, сохраненные в папку D:\Calfiles восстановятся автоматически. Остальные файлы необходимо скопировать вручную.

  6. Если приложение PNA было загружено при помощи AgileUpdate, его необходимо переустановить. Дважды щелкните по файлу D:\Updates\Firmware\ *.msi. или загрузите обновление прошивки через AgileUpdate.

Если невозможно загрузиться с жесткого диска

Во время загрузки сообщение ‘Please select the operating system to start’. может не появиться. Если жесткий диск PNA имеет метку ‘S.02.xx’ и ‘S.05.50’, то можно загрузиться с дискеты. Если метка имеет другой код, процесс завершится неудачно на шаге 2, однако это ничем не угрожает системе.

Сделайте системную дискету на компьютере под управлением DOS или Windows 95/98/ME/XP. Примечание: Windows NT или 2000 не подходят.

Для создания системной дискеты щелкните правой кнопкой на устройстве А: в проводнике Windows, выберите Format, а после этого Make System Disk. Эта опция также может называться copy system files, или Create an MS-DOS startup disk.

Для загрузки с дискеты:

  1. Вставьте созданную системную дискету в PNA и перезагрузитесь. PNA должен определить системную дискету и загрузиться с нее. Если загрузки не происходит, см. ниже.

  2. В командной строке DOS (A:\>)введите CD C: и нажмите Enter. Реально вы перейдете на диск D: поскольку DOS не распознает формат NTFS, и называет первое обнаруженное устройство С:.

  3. Введите C:\minint\bin\recovery.bat и нажмите Enter. Если появится сообщение об ошибке, введите C:\Autoexec.bat

  4. Продолжайте процедуру восстановления операционной системы, как описано выше.

Если PNA не загружается с дискеты, необходимо изменить настройки PNA Bios. В разных версиях bios приведенная ниже процедура может незначительно отличаться:

  1. Перезагрузите PNA.

  2. При появлении логотипа Agilent нажмите F2 на клавиатуре несколько раз. Через несколько секунд появится меню Bios.

  3. При помощи клавиш со стрелками выберите Boot Прочитайте справку для данного элемента и переместите пункт Removable Devices / floppy drive перед Hard Drive.

  4. Выберите Save и Exit.

  5. Для предотвращения сообщения об ошибке во время включения анализатора при вставленной дискете, верните настройки BIOS назад к загрузке с жесткого диска после завершения процедуры восстановления.


Рассмотрение Windows 2000

Рассмотрение Microsoft Windows® XP / 2000

Важные замечания

Операционная система Windows

Примечание: Начиная с апреля 2004, PNA поставляется с модифицированной версией операционной системой Microsoft Windows XP. Раньше PNA поставлялся с Windows 2000. PNA одинаково функционирует с обеими операционными системами.

Для того чтобы определить, какая из операционных систем установлена на вашем PNA:

  1. Сверните приложение PNA

  2. Нажмите Start на рабочем столе PNA.

  3. Рядом с меню Start появится следующее:

    • Windows 2000 Professional

    • Windows XP Professional

ОЧЕНЬ ВАЖНАЯ информация для защиты вашего жесткого диска!

Основная причина сбоев PNA – это проблемы с жестким диском (HDD) PNA. Как правило, такие проблемы можно предотвратить, а во многих случаях можно восстановить жесткий диск. Подробнее о защите PNA.

Использование USB

PNA оснащен как минимум двумя портами USB для подключения устройств: один на передней панели и как минимум один на задней панели. Основные преимущества USB – это "горячее" подключение и отключение, а также высокая скорость передачи данных. На модулях электронной калибровки USB порты не установлены.

При первом подключении устройства к порту USB необходимо некоторое время подождать. Windows сообщает об идентификации оборудования, затем ищет соответствующий драйвер и устанавливает его (если находит).

Повторное подключение того же устройства к тому же порту проходит быстро и просто, но если устройство подключают к другому порту USB, снова необходимо ждать идентификации оборудования и установки драйвера.

Примечание: Для некоторых устройств USB (например, модули ECAL) необходимо, чтобы при их первом подключении к PNA вы были зарегистрированы в системе с правами администратора Это необходимо выполнить для каждого серийного номера. Нажмите Next для выбора заданных по умолчанию настроек при установке новых устройств USB.

Стабильность и безопасность Plug & Play

Возможности Plug & Play подобны Win 95 и 98. Это обеспечивает стабильную и безопасную рабочую среду. Кроме того, вы можете заметить, что это значительно снижает количество необходимых перезагрузок.

Подключения LAN

Windows поддерживает DHCP и фиксированную IP-адресацию. Кроме того, горячее подключение и отключение кабеля локальной сети, а также визуальный индикатор состояния локальной сети в системной области, упрощают подключения LAN. Hardware Wizard (Помощник по аппаратному обеспечению) также помогает пользователю конфигурировать оборудование.

Опция одинарного и двойного щелчка.

Windows допускает метод одинарного щелчка для запуска пиктограмм по умолчанию. Для перехода к двойному щелчку нажмите Start, затем Settings, Control Panel, затем нажмите Mouse. В диалоге Mouse Properties (Свойства мыши) выберите Double-click to open an item (Двойной щелчок, чтобы открыть пункт). Затем нажмите OK.

Печать

Добавление принтера следует выполнить за пределами приложения PNA. Подробнее.


Обзор передней панели

Для получения информации нажмите на область передней панели.


Обзор задней панели

На этом изображении показаны ВСЕ функции задней панели.

Ваш PNA может не иметь всех возможностей или так выглядеть.

Щелкните на коннекторе для получения подробной информации.


Включение выключение PNA

Включение и выключение анализатора PNA

Существует три операционных режима PNA:

  • Hibernate ("спящий" режим)

  • ON (Включено)

  • Shutdown (Отключено)

Примечание: Если клавиатура передней панели PNA или порты USB не реагируют, ОТКЛЮЧИТЕ или ПЕРЕЗАПУСТИТЕ его; не переводите в "спящий" режим. После такого режима драйверы PNA "проснутся" в таком же неработоспособном состоянии.

Способы выхода из системы, отключения, перезапуска или перевода PNA в "спящий" режим.

С ПОМОЩЬЮ МЫШИ

  1. В меню PNA System (Система) нажмите Windows Taskbar

  2. В Windows Taskbar нажмите Shutdown (Отключение)

  3. В перечне What do you want the computer to do? (Что должен делать компьютер?) выберите действие:

    • Log off (закрывает программы и отключает от сети)

    • Shut down (отключение)

    • Restart (отключение и запуск)

    • Hibernate (спящий режим)

  4. Для выполнения действия нажмите OK

БЕЗ МЫШИ

  • • Для перевода в "спящий" режим БЫСТРО нажмите зеленую кнопку питания.

  • Для отключения – ТОЛЬКО в том случае, если PNA заблокирован и невозможно пользоваться мышью или клавиатурой – Нажмите кнопку отключения питания и удерживайте минимум четыре секунды. Необходимо избегать этого способа! При регулярных отключениях таким способом жесткий диск БУДЕТ поврежден. Подробнее о повреждении жесткого диска PNA.

  • Рекомендуется - Для БЕЗОПАСНОГО отключения PNA без мыши сконфигурируйте PNA так, чтобы при кратком нажатии кнопки отключения питания (как в шаге 3 выше) была возможность выбора действия. PNA, поставленные после июня 2005 года уже сконфигурированы таким образом:

    1. На Панели управления Windows выберите Power Options (Опции питания)

    2. Нажмите кнопку Advanced

    3. Под Power buttons, (Кнопки питания) выберите Ask me what to do. (Спросить, как действовать)

    4. Для завершения конфигурирования нажмите OK.

В следующий раз при нажатии кнопки питания появится диалоговое окно с вопросом What do you want the computer to do? (Что должен делать компьютер?) Для выбора действия пользуйтесь кнопками Tab и Enter на передней панели.

"Спящий" режим

  • В "спящем" режиме текущее инструментальное состояние автоматически сохраняется на жесткий диск перед отключением питания PNA.

  • При включении питания PNA загружается данное инструментальное состояние, таким образом, экономится время по сравнению с полной программной начального пуска системы.

  • Для возобновления работы PNA после выхода из "спящего" режима пароль НЕ требуется.

  • "Спящий" режим – это нормальное состояние отключения. В "спящем" режиме PNA потребляет небольшую мощность. Питание в режиме готовности подается только на цепи выключателя питания и генератор опорной частоты, другие цепи компьютера не получают питания. Для того, чтобы измерения соответствовали заданным характеристикам PNA, он должен прогреваться 90 минут после того, как индикатор кнопки питания из желтого станет зеленым.

Режим ВКЛ

  • Для включения PNA нажмите желтую кнопку питания.

  • После включения питания кнопка станет зеленой.

Режим отключения

  • В режиме отключения текущее инструментальное состояние НЕ сохраняется автоматически перед выключением питания PNA.

  • При последующем включении питания PNA выполняется полная программа запуска и PNA запускается с предварительными настройками.

  • После режима отключения для запуска PNA необходим пароль.

  • Для того, чтобы измерения соответствовали заданным характеристикам PNA, он должен прогреваться 90 минут после того, как индикатор кнопки питания из желтого станет зеленым.

  • Отключение PNA требуется только для обслуживания или обеспечения парольной защиты.

  • После отключения питания кнопка станет желтой.

Примечание: Если PNA заблокирован и невозможно пользоваться мышью или клавиатурой, нажмите кнопку отключения питания и удерживайте минимум четыре секунды.
Необходимо избегать этого способа! При регулярных отключениях таким способом жесткий диск БУДЕТ поврежден. Подробнее о повреждении жесткого диска PNA.

Отсоединение PNA

  • Отключайте шнур питания от PNA ТОЛЬКО при желтой кнопке питания в "спящем" режиме или режиме отключения.
    Если шнур питания отключается при зеленой кнопке питания (PNA включен), вероятно повреждение жесткого диска.

  • После отключения шнура питания кнопка будет оставаться желтой в течение нескольких секунд.

  • После повторного подсоединения PNA и нажатия кнопки питания, PNA начинает работать в режиме, в котором находился до отсоединения шнура питания, в "спящем" режиме или режиме отключения.


Пользовательский интерфейс

Интерфейс передней панели

Кнопки передней панели можно использовать тремя способами:

  • Панель Active Entry (Активный ввод) (quickest)

  • Запуск диалоговых окон

  • Меню операций (наиболее полный способ)

Другие разделы

Панель Active Entry (Активный ввод)

Не все настройки могут быть сделаны этим способом. Для ВСЕХ настроек используйте Меню.

Быстро выполнить настройки можно с помощью следующей четырехшаговой процедуры.

( 1 ) Нажмите кнопку

( 2 ) Просмотрите активный ввод

( 3 ) Выберите функцию

( 4 ) Введите значение (при необходимости)

Запуск диалоговых окон

Для быстрого запуска БОЛЬШЕЙ ЧАСТИ диалоговых окон:

( 1 ) Нажмите кнопку Menu/Dialog

( 2 ) Выберите кнопку функции

Меню операций

Ко ВСЕМ функциям PNA можно получить доступ через меню:

( 1 ) Нажмите кнопку Menu/Dialog

( 2 ) Для перемещения по меню пользуйтесь кнопками со стрелками. Для выбора пользуйтесь кнопкой "Click".

( 3 ) Другие командные кнопки используют для отмены или поиска справки (при необходимости)


Графики, каналы и окна PNA

Важно понимать значение следующих терминов, относящихся к PNA.

  • Графики (Traces)

  • Каналы (Channels)

  • Окна (Windows)

  • Управление окнами

Примечание: Комбинация следующих факторов может стать причиной снижения быстродействия компьютера: повышенное количество точек, графиков и векторов ошибок калибровки (полная 2-х или 3-портовая). Если возникает такая проблема, можно увеличить размер ОЗУ в PNA Опция 022. Для того чтобы следить за использованием памяти PNA, нажмите Ctrl Alt Delete, выберите Task Manager, затем нажмите закладку Performance tab.

Другие разделы

Графики это ряд измерений по точкам.

Настройки графика влияют на математическую обработку и представление измеренных данных. Для изменения настроек графика необходимо его выделить (активизировать). Для выделения графика нажмите кнопку Trace Status График можно настраивать по следующим параметрам.

  • Параметр

  • Формат

  • Масштаб

  • Калибровка (ВКЛ/ВЫКЛ)

  • Математическая обработка графика

  • Маркеры

  • Электрическая задержка

  • Сдвиг фаз

  • Сглаживание

  • Преобразование

Графики содержатся в Каналах В PNA может быть до 32 независимых каналов.

Настройки канала определяют, как измеряются данные для графика. Все графики, назначенные каналу, имеют настройки канала. Для изменения настроек канала необходимо его выделить (активный). Для выделения канала нажмите кнопку Trace Status графика для этого канала. Далее указаны настройки канала:

  • Диапазон частот

  • Мощность

  • Данные калибровки

  • Полоса ПЧ

  • Количество точек

  • Настройки свипирования

  • Усреднение

  • Запуск (некоторые настройки)

Окна используются для просмотра графиков.

  • PNA может отображать до 16 окон на экране.

  • В каждом окне может находиться до 4 графиков.

  • Окна полностью независимы от каналов.

  • В основном настройки окна выполняются из меню View За подробной информацией обращайтесь к Модификация экрана PNA.

  • См. создание и управление окнами.

В следующем окне находятся два графика. Оба графика используют настройки одного и того же канала 1, на что указывает аннотация в нижней части окна.

Управление окнами

Создание нового окна

Пользуйтесь одним из следующих методов:

  • Нажмите [image] +

  • Нажмите Trace (График), New Trace (Новый график). Отметьте New Window (Новое окно).

  • Нажмите Window затем New. Появится новое окно с заданным по умолчанию графиком (S11) в том же канале, что и активное окно.

Дополнительная информация об использовании интерфейса передней панели

Просмотр окна в полноэкранном режиме:

Если на экране находится больше четырех окон, панель Trace Status (Состояние графика) скрыта и разрешение становится недостаточным. Для просмотра окна в полноэкранном режиме:

Выберите график:

  • Нажмите [image] +

Затем нажмите [image]. Нажмите еще раз, чтобы уменьшить окно


Руководство по последовательности измерений

Базовая последовательность измерений

Для настройки всех измерений PNA можно применять следующий процесс:

Шаг 1. Настройка измерений
Перезапустите анализатор, создайте состояние измерения и настройте дисплей.

Шаг 2. Оптимизация измерений
Повысьте точность измерения и производительность с помощью методик и функций.

Шаг 3. Выполните калибровку измерений
С помощью калибровки уменьшите погрешность измерений.

Шаг 4. Анализ данных
Проанализируйте результаты измерений, используя маркеры, математические операции и тесты по критерию.

Шаг 5. Печать, сохранение или вызов данных
Сохраните или распечатайте данные измерений.


Использование справки

Редакция справки 2005-10-17

Редакция PNA 4.87

Copyright 2000-2005

Agilent Technologies, Inc.

В данном разделе описано следующее:

  • Распечатка справки

  • Копирование справки на ваш компьютер

  • Запуск справки

  • Перемещение по справке

  • Язык справки

  • Глоссарий

  • Диалоговые окна

  • О сетевом анализаторе

  • Гарантии по документации

  • Ваши предложения, пожалуйста!

Другие разделы

Распечатка справки

Начиная с мая 2005, справочное пособие по PNA в формате .pdf снова можно загружать c http://www.agilent.com/find/pna. Найдите "PNA Help" (Справка по PNA) и перейдите к Manuals (Руководства) и Guides (Инструкции). Нажимая на пиктограмму Print (Печать) в верхней части окна PNA Help (Справка по PNA) можно распечатывать отдельные разделы справки.

Копирование справки на ваш компьютер

Установив справочную систему на свой компьютер, вы сможете напрямую читать информацию о PNA. Кроме того, вы можете напрямую скопировать и вставить программный код данной справочной системы в свою среду программирования.

Файл справки находится на жестком диске вашего PNA C:\ Winnt\ Help\ PNAHelp.chm. Если PNA и компьютер подключены к локальной сети, вы можете подключить диск и скопировать файл напрямую. Справочная система также находится на CD-ROM, который поставляется вместе с PNA.

Запуск справки

Справочную систему можно запустить тремя способами:

  1. С передней панели кнопкой Help.

  2. 2. Из выпадающего меню Help

  3. 3. Из справки Диалоговые окна

Перемещение по справке

В окне справки находится 3 панели (области):

  1. Панель инструментов (Toolbar)

  2. Панель Тема (Topic)

  3. Панель навигации (Navigation)

Панель инструментов

Панель инструментов находится в верхней части окна справки. С ее помощью вы можете менять размер окна, искать и распечатывать выбранную тему.

  1. Скрыть или отобразить панель навигации

  2. Найти тему в содержании

  3. Вернуться к теме, которую просматривали раньше

  4. Возвратиться, если нажать Back (Назад)

  5. Перейти на главную страницу.

  6. Распечатать панель темы.

Панель навигации

Для того чтобы получить доступ к информации справочной системы, нажимайте следующие закладки панели навигации:

Содержание (Contents)

Алфавитный указатель (Index)

Поиск (Search)

Избранное (Favorites)

Содержание

  1. Нажмите, чтобы выделить Table of Contents (Содержание).

  2. Щелкните по книге, чтобы войти в соответствующую тему.

  3. Нажмите, чтобы отобразить тему.

  4. Щелкните правой кнопкой мыши для входа в меню.

  5. Щелкните, чтобы отобразить спецификации

  6. Нажмите, чтобы отобразить глоссарий

Алфавитный указатель

Панель алфавитного указателя дает возможность ввести ключевое слово и перейти к наиболее подходящей теме.

  1. Нажмите, чтобы выделить алфавитный указатель.

  2. Наберите ключевое слово, чтобы найти интересующую вас тему.

  3. Просмотрите предложенные темы. (Дважды щелкните, чтобы отобразить тему.)

  4. Нажмите, чтобы отобразить тему.

Поиск

При использовании полнотекстового поиска применяются следующие правила:

  • Поиск не чувствителен к регистру.

  • Можно проводить поиск по любой комбинации букв (a-z) и чисел (0-9).

  • При поиске знаки пунктуации (точка, двоеточие, точка с запятой, запятая и тире) игнорируются.

  • Искомые слова можно группировать с помощью двойных кавычек или скобок. Примеры: "response calibration" (калибровка частотной неравномерности) или (response calibration). Из-за этого правила поиск кавычек невозможен.

  • Используйте групповые символы в выражениях:
    * Для поиска при одном неопределенном символе используйте знак вопроса (?). Например, при поиске cal? будет обнаружено calc и calf.
    * Для поиска при более, чем одном неопределенном символе используйте звездочку (*). При поиске Cal* будут обнаружены calibration и calculate

  • Для определения взаимоотношения между двумя или более искомыми словами применяйте булевы операторы.

Искать | Пример | В результате будут показаны темы, где содержится:
Два слова по одной теме | response AND calibration | Оба слова "response" и "calibration"
Любое из двух слов по теме | response OR calibration | Слово "response" или слово "calibration", или оба
Первое слово без второго слова по теме | response NOT calibration | Слово "response", но не слово "calibration"
Оба слова по одной теме недалеко друг от друга. | response NEAR calibration | Слово "response", слово "callibration" в пределах восьми слов

Избранное

Панель избранное дает возможность сохранять (помечать) темы, к которым вы обращаетесь чаще всего, таким образом, их можно с легкостью найти.

  1. Нажмите, чтобы просмотреть темы, сохраненные в Favorites (Избранное).

  2. Удалите выбранную тему.

  3. Отобразите выбранную тему.

  4. Добавьте (сохраните) текущую тему.

Панель Тема

Панель Тема дает возможность просматривать содержание выбранной темы.

Язык справки

Справочная система представлена на пяти языках:

  • Английский

  • Французский

  • Немецкий

  • Японский

  • Испанский

  • Китайский

Для обновления до последней версии, или для включения китайского языка, используйте AgileUpdate.

Для выбора языка справки:

В меню Help перейдите к Help Language. (Язык справки) щелкните по названию языка.

Note: Раздел Программирование представлен только на английском. Кроме того, новейшая версия справки будет на английском языке.

Просмотр справки на японском или китайском

В этих языках используется набор символов, отличающийся от других языков. Для просмотра данных языков необходимо изменить следующие настройки:

  1. На PNA нажмите View (Просмотр)

  2. Нажмите Title Bars – Заголовки (если еще не отмечено)

  3. Минимизируйте экран PNA

  4. На рабочем столе PNA нажмите Start / Settings / Control Panel / Regional Options.

  5. Под Language settings for the system (Языковые настройки системы) перейдите к полю (японский или китайский) и отметьте его

  6. Под Your locale (location) ) (месторасположение) выделите Japanese or Chinese

  7. Нажмите Set default... (Установить по умолчанию)

  8. Под Select the appropriate locale(Выберите соответствующее месторасположение) выделите Japanese or Chinese

В Windows 2000 при таких изменениях шрифты могут уменьшиться в размере. Для увеличения размера шрифта измените следующие настройки:

  1. На рабочем столе PNA нажмите Start / Settings / Control Panel

  2. Нажмите Display / Appearance

  3. Под Scheme (Схема) выберите Windows Standard

Для перезапуска приложения PNA нажмите кнопку панели задач PNA Analyzer в нижней части экрана

Глоссарий

В глоссарии находятся определения слов в алфавитном порядке.

Примечание: Для просмотра определений из глоссария, в справке нажимайте слова, выделенные зеленым.

Диалоговые окна

О сетевом анализаторе

Чтобы получить дополнительную информацию о вашем анализаторе, нажмите Help, затем About Network Analyzer:

  • Номер модели • • Опции, установленные в анализаторе • Серийный номер анализатора • Версия установленного программного обеспечения анализатора • Версия жесткого диска анализатора

  • Частотный диапазон

  • Опции, установленные в анализаторе

  • Серийный номер анализатора

  • Версия установленного программного обеспечения анализатора

  • Версия жесткого диска анализатора

Гарантии по документации

Материалы данного документа предоставляются "как есть", и могут быть изменены в следующих редакциях без предупреждения. Далее, до максимальных пределов, допустимых действующим законодательством, Agilent не признает гарантий, касающихся данного руководства и содержащейся в нем информации, выраженных явно либо не явно, включая, но не ограничиваясь этим, предполагаемых гарантий относительно пригодности к продаже и соответствия определенному предназначению. Agilent не несет ответственности за ошибки либо случайные или намеренные повреждения в связи с поставкой, использованием или функционированием данного документа, либо любой информации в нем содержащейся. Если между Agilent и пользователем заключено отдельное письменное соглашение с условиями гарантии, включающее материалы данного документа, противоречащее данным условиям, вопрос регулируется условиями отдельного соглашения.

Ваши предложения, пожалуйста!

Просим сообщать нам о впечатлениях от пользования справкой по PNA. Отправляйте комментарии по адресу: pna_help@am.exch.agilent.com. . Комментируйте все аспекты справочной системы. Предлагаем рассмотреть некоторые темы:

  • Не кажется ли что-нибудь неисправным?

  • Вы нашли то, что искали?

  • Была ли полезной найденная информация?

  • Ваши предложения по усовершенствованию справочной системы?

Ваши комментарии поступают непосредственно к авторам справочной системы. За справками по техническим вопросам обращайтесь в Техническую поддержку.


Предварительная настройка анализатора

Предварительная настройка PNA

При предварительной настройке PNA устанавливаются известные или предварительно заданные условия. Можно использовать заданные по умолчанию на производстве условия, либо определить собственные пользовательские предварительные условия.

  • Заданные по умолчанию предварительные условия

  • Пользовательские предварительные условия

Другие разделы по настройке измерений

Заданные по умолчанию предварительные условия

Способ предварительной настройки PNA

Пользуйтесь одним из следующих методов:

Более подробно см. интерфейс передней панели

Щелкните, чтобы просмотреть предварительные настройки, заданные на производстве.

  • Настройки частоты

  • Настройки мощности

  • Настройки свипирования

  • Настройки сегментированного свипирования

  • Настройки запуска

  • Настройки отображения

  • Настройки отклика

  • Настройки калибровки

  • Настройки маркера

  • Настройки тестирования по критерию

  • Настройки измерений во временной области (Опция 010)

  • Глобальные настройки отображения

Настройки частоты:
Параметр измерения | S11
Стартовая частота | Минимальная частота PNA
Частота останова | Максимальная частота PNA
Частота непрерывного колебания (CW) | 1 ГГц
Минимальная и максимальная частота вашего PNA указаны в Конфигурации PNA
Настройки мощности:
Мощность измерительного порта | 0 dBm для E8356/7/8A 0 dBm для E8801/2/3A 0 dBm для N3381/2/3A -5 dBm для N5230A - 20 ГГц -10 dBm для N5230 - 40 ГГц -15 dBm для N5230 - 50 ГГц -12 dBm для E8362/3/4 A или B, стандарт -15 dBm для E8361A -17 dBm для E8362/3/4 A или B с опцией UNL или 014
Мощность портов связана | Вкл
Автоматическое ослабление | Вкл
Значение ослабления | 0 дБ
Компенсация мощности по частоте | Выкл
Значение компенсации | 0 дБ/ГГц
Настройки свипирования:
Тип | Линейная частота
Режим | Непрерывный
Генерирование | Аналоговое
Автоматическое время свипирования | Вкл
Количество точек | 201
Настройки сегментированного свипирования:
Активные сегменты | 1
Стартовая частота | Стартовая частота PNA
Частота останова | 1 MHz для E8356/7/8A 1 MHz для E8801/2/3A 1 MHz для N3381/2/3A 1 ГГц для E836xA/B
Количество точек | 21
Мощность | Предварительные настройки Мощность измерительного порта
Полоса ПЧ | 50 кГц для N5230A 35 кГц для всех других моделей
Уменьшение полосы ПЧ на низких частотах | Вкл
Время пребывания | 0
Настройки запуска
Источник | Внутренний
Режим | Свипирование

Настройки отображения:

Формат

Лог. ампл.

Данные настройки применяются к выбранным форматам:

Формат | Масштаб | Начальное положение | Начальное значение
Лог. ампл. | 10 дБ/ | 5 | 0 дБ
Фаза | 45 град/ | 5 | 0 град
Групповая задержка | 10 нсек/ | 5 | 0 сек
Линейн. ампл. | 100 минут/ | 0 | 0 ед.
КСВ | 1 ед./ | 0 | 1 ед.
Действит. | 2 ед./ | 5 | 0 ед.
Мнимая | 2 ед./ | 5 | 0 ед.
Полярн. | 1 ед./ | н/д | 1 ед.
Диагр. Смита | 1 ед./ | н/д | 1 ед.
Настройки отклика:
Номер канала | 1
Полоса ПЧ | 50 кГц для N5230A 35 кГц для всех других моделей
Усреднение | Выкл
Коэффициент усреднения | 1
Сглаживание | Выкл
Коэффициент сглаживания | 1% диапазона
Электромагнитная задержка | 0 сек
Коэффициент укорочения | 1.0
Сдвиг фаз | 0 град
Матем/Просмотр графика в памяти | Данные
Настройки калибровки:
Режим коррекции | Выкл
Режим интерполяции | Вкл
Тип калибровки | Нет
Номер комплекта калибровки | Номер текущего комплекта калибровки
Z0 | 50 Ом
Режим расширения порта | Выкл
Значения Расшир. порта Вход A, B Порт 1, 2 | 0
Настройки маркера:
Начальная частота | Текущая центральная частота
Начало отсчета | Нет
Интерполяция | Вкл
Формат | Заданный график
Тип | Обычный
Функция | Макс значение
Область | Полный диапазон
Таблица | Пусто
Связанность | Всегда не связаны
Настройки тестирования по критерию:
Тестирование по критерию | Выкл
Отображение линии | Вкл
Звук при отказе | Выкл
Настройки списка ограничений:
Тип (OFF, MAX, MIN) | OFF
Начальный стимул | 0
Конечный стимул | 0
Начальный отклик | 0
Конечный отклик | 0
Настройки измерений во временной области:
Состояние преобразования | Выкл
Режим преобразования | Полоса пропускания
Запуск преобразования | -10 нсек
Останов преобразования | 10 нсек
Окно | 6.0 (коэффициент Кайзера-Бесселя)
Состояние селекции | Выкл
Начало селекции | -10 нсек
Останов селекции | 10 нсек
Тип селекции (ворот) | Полоса пропускания
Форма селекции (ворот) | Обычная
Глобальные настройки отображения:
Состояние графика | Вкл
Частота/стимул | Выкл
Показание маркера | Вкл (если маркер включен)
Показаны панели инструментов | Активный ввод
Режим панели состояния | Вкл

Пользовательские предварительные условия

Для анализатора можно предварительно задать условия, заданные по умолчанию или пользовательские предварительные условия.

Установка пользовательских предварительных условий

Более подробно см. интерфейс передней панели

User Preset справка по диалоговому окну

Дает возможность выбора пользовательских предварительных условий, а также хранения и восстановления этих условий.

User Preset Enable (Включение пользовательских предварительных условий)
Флажок установлен - Если кнопка Preset нажата, то PNA предварительно установлен на пользовательские предварительные условия (User Preset0.
Флажок снят - Если кнопка Предварительно задано (Preset) нажата, PNA предварительно установлен на Заданные условия (Default).

Save current state as User Preset (Установить текущий режим, как Пользовательские предварительные условия) Щелкните, чтобы сохранить текущее инструментальное состояние, как Пользовательские предварительные условия. Файл сохраняется, как C:\ Program Files\ Agilent\ Network Analyzer\ Documents\ UserPreset.sta.

Load existing file as User Preset (Загрузить существующий файл, как Пользовательские предварительные условия) Щелкните, чтобы установить инструментальное состояние на Пользовательские предварительные условия.


Измеряемые параметры

В данном разделе содержится следующая информация:

  • S-параметры (фиксированные соотношения)

  • Произвольное соотношение (Arbitrary Ratio) (выберите собственное соотношение)

  • Абсолютная мощность (Unratioed Power)

  • Выбор измеряемого параметра

Другие разделы по настройке измерений

S-параметры

S-параметры (параметры рассеивания) используют, чтобы описать изменение сигнала устройством. Для устройства с двумя портами существует четыре S-параметра. (Если у вас модель PNA с 3 портами, смотрите раздел 3-портовые измерения.) Далее описана синтаксическая структура каждого параметра:

S out - in

out = | номер порта, на котором измеряется выходной сигнал (приемник)
in = | номер порта, на который подается сигнал (источник)

Установите курсор мыши на каждый S-параметр, чтобы увидеть прохождение сигнала:

Для устройств с двумя портами:

  • Если источник находится со стороны порта 1, говорят, что измерение идет в прямом направлении.

  • Если источник находится со стороны порта 2, говорят, что измерение идет в обратном направлении.

  • Анализатор автоматически переключает источник и приемник, чтобы выполнять прямое или обратное измерение. Поэтому анализатор может измерять все четыре S-параметра для устройства с двумя портами через одно подключение.

Для PNA с 3-мя измерительными портами смотрите 3-портовые измерения

Обычные измерения с использованием S-параметров

Измерения отражения
(S11 и S22)

Измерения передачи
(S21 и S12)

  • Обратные потери

  • Коэффициент стоячей волны, КСВ (SWR)

  • Коэффициент отражения

  • Им педанс

  • S11, S22

  • Вносимые п отери

  • Коэффициент передачи

  • Усиление/Потери

  • Групповая задержка

  • Отклонение от линейной фазы

  • Э лектрическая задержка

  • S21, S12

Произвольное соотношение (Arbitrary Ratio)

Произвольное соотношение дает вам возможность выбрать собственное соотношение входных и опорных сигналов с помощью приемников A, B, R1 и R2. Ниже показано обычное применение произвольного соотношения:

  • Сравнение фазы между двумя путями прохождения сигнала в устройстве. В качестве примера можно взять что-нибудь простое, например, делитель мощности, или более сложное устройство – двухканальный приемник.

  • Измерения, для которых нужен более высокий динамический диапазон, чем обеспечивает анализатор при измерении S-параметров.

У вашего PNA на передней панели МОГУТ быть перемычки в виде кабелей, которые напрямую идут к приемникам A, B, R1 и R2. Просмотрите информацию о перемычках передней панели вашего PNA.

Абсолютная мощность (Unratioed Power)

Параметр абсолютной мощности дает вам возможность следить за абсолютной мощностью устройства, поступающей к любому из приемников.

Примечание: Относительные параметры нельзя использовать для измерений фазы или групповой задержки, либо любых измерений с включенным усреднением.

Выбор измеряемого параметра

Для создания нового графика пользуйтесь одним из следующих методов:

  • +

Для изменения активного графика пользуйтесь одним из следующих методов:

  • +

Более подробно см. интерфейс передней панели

New Trace и Measure справка по диалоговому окну

Следующее относится к обоим диалоговым окнам New Trace (Новый график) и Measure (Измерение)

S-Parameters Отметьте ОДИН, чтобы создать или изменить активное измерение.

More Types... Нажмите, чтобы открыть диалоговое окно More Types ((для относительных измерений или измерений с произвольным соотношением)

Application... Нажмите, чтобы открыть список измерительных приложений, установленных в анализаторе.

Channel Number (только для нового графика) Выберите канал, к которому добавляется новый график.

Create in New Window (только для нового графика)
Отметьте, чтобы создать новый график в новом окне
Снимите отметку, чтобы создать новый график в активном окне

См. Измеряемые параметры (выше)

More Types справка по диалоговому окну

Source Port Выберите порт PNA, который будет служить источником мощности

Ratioed Type Отметьте, чтобы создать относительное измерение (затем выберите входной и опорный приемники)
Снимите отметку, чтобы создать абсолютное измерение (затем выберите только входной приемник)

Input Выберите приемник PNA, чтобы проводить измерение характеристики тестируемого устройства. Вы можете получить прямой доступ к портам приемников, удалив кабели-перемычки на передней панели.

Reference Выберите опорный приемник PNA, чтобы установить соотношение с входным приемником (только для относительного измерения). Уровень опорного сигнала должен находиться между 0 dBm и –35 dBm

Channel Number (только для нового графика) Выберите канал, к которому добавляется новый график.

Create in New Window (только для нового графика) Отметьте, чтобы создать новый график в новом окне.
Снимите отметку, чтобы создать график в активном окне

См. Измеряемые параметры (выше)


Диапазон частот

Диапазон частот – это интервал частот, указанных вами для проведения измерений прибором.

  • Установка диапазона частот

  • Частоты гармонических колебаний (CW)

  • Разрешение по частоте

  • Индикатор потери фазовой синхронизации

  • Пересечения полос частот

Другие разделы по настройке измерений

Установка диапазона частот

Существует два способа установки диапазона частот:

    1. Укажите начальную и конечную частоты диапазона.

    2. Укажите среднюю частоту и желаемый интервал диапазона.

Следующим завершаются оба метода:

  • +

Следующие настройки откроют диалоговые окна:

Более подробно см. интерфейс передней панели

Смотрите Диапазоны частот всех моделей PNA

Frequency Start/Stop (Начальная/конечная частота) справка по диалоговому окну

Start Указывает начальную частоту диапазона измерений.

Stop Указывает конечную частоту диапазона измерений.

Frequency Center/Span (Центральная частота/интервал) справка по диалоговому окну

Center Указывает значение центра свипирования по частоте. Это значение может находиться в любом месте диапазона анализатора.

Span Указывает интервал значений частоты, измеренных с обеих сторон от центральной частоты.

Частоты гармонических колебаний (CW)

Измерения с CW Time sweep или Power sweep в качестве стимула выполняются в одночастотном режиме, а не в пределах диапазона частот.

Установка частоты гармонического колебания

Сначала укажите CW Sweep Type

Частоту CW можно установить в диалоговом окне типа свипирования (Sweep Type) или

После определения частоты CW в диалоговом окне Sweep type (Тип свипирования), измените частоту CW, выбрав следующее:

Более подробно см. интерфейс передней панели

CW Frequency справка по диалоговому окну

CW Введите значение и первую букву суффикса (k, m или g) или воспользуйтесь стрелками вверх-вниз, чтобы выбрать любое значение из диапазона PNA.

Разрешение по частоте

Разрешение для установки частоты равно 1 Гц.

Индикатор потери фазовой синхронизации

В нормальном рабочем режиме стимул анализатора будет синхронизирован по фазе и будет находиться в пределах технических условий (см. спецификацию по частотам). Если анализатор не способен создать частоту стимула в пределах технических условий, на экране (см. Устранение неполадок PNA) появится сообщение Phase Lock Lost (Потеря фазовой синхронизации).

Пересечения полос частот

Диапазон частот PNA состоит из нескольких внутренних полос частот. Чем больше диапазон частот PNA, тем больше количество полос. Мощность источника не подается на тестируемое устройство, когда частота стимула проходит через пересечение полос частот. За дополнительной информацией обращайтесь к Включение и выключение мощности во время свипирования и обратного хода и Рекомендации по свипированию стимула для тестируемых стройств с петлей АРУ.

Данные перекрытия полос происходят на следующих частотах:

Для моделей PNA 3 ГГц, 6 ГГц, и 9 ГГц:

Полоса | Частота
1 | 10 МГц
2 | 748 МГц
3 | 1500 МГц
4 | 3000 МГц
5 | 4500 МГц
6 | 6500 МГц

Для моделей PNA E8362 / 63/ 64 A/B
(В моделях нет полосы 0)

Полоса | Частота (ГГц) | Полоса | Частота (ГГц) | Полоса | Частота (ГГц)
0 | .045 |  |  |  |
1 | 0.748 | 9 | 7.60 | 17 | 25.60
2 | 1.500 | 10 | 10.00 | 18 | 30.00
3 | 3.00 | 11 | 12.00 | 19 | 32.00
4 | 3.80 | 12 | 12.8 | 20 | 36.00
5 | 4.50 | 13 | 15.20 | 21 | 38.40
6 | 4.80 | 14 | 16.00 | 22 | 40.00
7 | 6.00 | 15 | 20.00 | 23 | 45.60
8 | 6.40 | 16 | 22.80 | 24 | 48.00

Для модели PNA E8361A

Полоса | Частота (ГГц) | Полоса | Частота (ГГц) | Полоса | Частота (ГГц)
0 | .045 | 9 | 10.00 | 18 | 32.00
1 | 0.748 | 10 | 12.00 | 19 | 36.00
2 | 1.500 | 11 | 12.80 | 20 | 40.00
3 | 3.00 | 12 | 15.40 | 21 | 44.70
4 | 3.80 | 13 | 16.00 | 22 | 46.20
5 | 4.00 | 14 | 20.00 | 23 | 51.20
6 | 4.50 | 15 | 24.00 | 24 | 60.00
7 | 6.00 | 16 | 25.60 | 25 | 64.00
8 | 77.00 | 17 | 30.00 |  |

Для модели PNA N5230A

Полоса | Частота (ГГц) | Полоса | Частота (ГГц) | Полоса | Частота (ГГц)
1 | .045 | 11 | 10.500 | 21 | 28.600
2 | .748 | 12 | 12.500 | 22 | 31.250
3 | 1.5 | 13 | 15.750 | 23 | 31.500
4 | 3.125 | 14 | 16.667 | 24 | 33.333
5 | 4.167 | 15 | 18.750 | 25 | 37.000
6 | 5.250 | 16 | 21.000 | 26 | 40.500
7 | 6.250 | 17 | 22.500 | 27 | 41.667
8 | 7.875 | 18 | 25.000 | 28 | 42.000
9 | 8.333 | 19 | 26.250 | 29 | 46.800
10 | 9.375 | 20 | 26.500 | 30 |


Уровень мощности

Уровень мощности – это мощность сигнала источника анализатора на измерительном порту. В следующих пунктах подробно описаны уровни мощности.

  • Настройки мощности

  • Индикатор превышения уровня

  • Связывание мощности между портами

  • Ослабление источника

  • Ослабление для несвязанных портов

  • Ослабление приемника

  • Компенсация мощности по частоте

  • Включение и выключение мощности во время свипирования и обратного хода

Другие разделы по настройке измерений

Настройки мощности

Выходная мощность измерительного порта специфицируется по частоте (Смотрите Диапазон мощностей и Диапазон частот для вашего PNA)

Установка настроек мощности

Пользуйтесь одним из следующих методов:

  • +

Примечание: Если выбрано свипирование по мощности (Power Sweep), (в диалоговом окне Sweep Type) после щелчка по Channel, Power появится диалоговое окно Power (Sweep).

Более подробно см. интерфейс передней панели

Power справка по диалоговому окну

Определяет мощность источника анализатора и управляет им.

Power On Включает и отключает источник мощности.

Примечание: Настройка ВКЛ/ВЫКЛ мощности и сохранение и вызов состояния прибора.

Если мощность отключена, и состояние прибора сохранено, то мощность останется отключенной при вызове состояния прибора.

Если мощность включена, и состояние прибора сохранено, то при вызове состояния прибора настройка мощности останется ТАКОЙ ЖЕ, как текущая. Для защиты вашего тестируемого устройства мощность НЕ будет включаться при повторном вызове состояния прибора, если текущая настройка мощности – ВЫКЛ.

Выбор порта (Port Selection)

Port Указывает порт, к которому применяются значения.

Port Power Coupled Переключает между связанностью и несвязанностью мощности измерительных портов. Если порты связаны, то уровни мощности одинаковы для каждого измерительного порта. Если порты не связаны, вы можете установить разные уровни мощности для каждого измерительного порта. Подробнее о связанных портах.

Test Port Power Устанавливает значение мощности на выходе измерительного порта.

Управление ослаблением (Attenuator Control)

Данная часть диалогового окна недоступна, если для PNA не установлена опция ослабления. Если данная часть окна доступна, то можно автоматически или вручную выбрать значение ослабления помещаемого на пути сигнала аттенюатора. При ручном способе наберите или выберите значение ослабления с приращениями 10 dB. Доступность и диапазон ослабления сигнала с источника для вашего PNA можно просмотреть в Опции PNA.

Auto Выберите, чтобы разрешить автоматическое управление ослаблением. Окно выбора значения ослабления будет недоступным. Снимите отметку, чтобы настроить аттенюатор вручную. Наберите или выберите значение ослабления в соседнем текстовом окне.

Дополнительная информация о ослаблении источника.

Компенсация мощности по частоте (Power Slope)

Компенсирует падение мощности на устройстве при свипировании по частоте увеличением выходной мощности PNA при повышении частоты.

Компенсация (Slope) Отметьте, чтобы установить компенсацию мощности. Снимите отметку, чтобы установить компенсацию мощности в положение ВЫКЛ.

Дополнительная информация о компенсации мощности по частоте.

Ослабление приемника (Receiver Attenuation)

Доступно для моделей PNA опция 015 и опция 016.

Receiver A и Receiver B Введите или выберите независимые значения ослабления для каждого приемника.

Дополнительная информация о ослаблении приемника.

Индикатор превышения уровня (Unleveled Indicator)

Если источник анализатора превышает уровень, то на панели состояния появляются буквы LVL. Чтобы просмотреть строку состояния, нажмите View, (Просмотр), затем Status Bar (Строка состояния).

LVL появляется, если мощность источника больше максимальной заданной мощности. Эту проблему можно решить снижением уровня мощности до уравновешенного состояния (Смотрите Диапазон мощностей) для вашего анализатора.

Если после снижения мощности источника буквы LVL продолжают появляться, просмотрите Устранение неполадок PNA чтобы определить причину превышения уровня.

Связывание мощности между портами

По умолчанию уровень мощности каждого порта cвязывается с портом 1. Это означает, что уровень выходной мощности каждого порта будет таким же, как у порта 1. В некоторых схемах измерений необходимо, чтобы уровни мощности портов отличались. Анализатор дает возможность развязать мощности портов, так что вы можете независимо устанавливать уровни мощности для каждого порта.

Например, если вы хотите измерить усиление и развязку в обратном направлении усилителя с большим коэффициентом усиления, то необходимо отдельно установить мощность каждого порта. Это связано с тем, что мощность, необходимая для входного порта усилителя, намного ниже мощности, необходимой для выходящего порта. Смотрите Ослабление для несвязанных портов.

ВНИМАНИЕ! Если уровни входящей мощности превышают максимальные значения, можно повредить приемники анализатора. Информация о максимальной входящей мощности приемника анализатора находится в технических спецификациях.

Ослабление источника

PNA использует программируемое пошаговое ослабление источника, чтобы покрыть весь диапазон мощности. Аттенюатор устанавливает уровень мощности тестового сигнала на измерямом устройстве без изменения уровня падающей мощности в опорном пути. Таким образом, обеспечиваются:

  • Большая точность и лучшие характеристики сигнала источника

  • Более точное согласование в источнике

Ослабление источника для PNA доступно в разных диапазонах, как стандартное оборудование или как дополнительное. Если ослабление не установлено, в диалоговом окне Power недоступно управление аттенюатором, и оно не отображается на панели Active Entry (Активный ввод). Доступность источника ослабления и его диапазон для вашего PNA можно просмотреть в Опции PNA.

Значение источника ослабления можно устанавливать автоматически или вручную с помощью диалогового окна Power или кнопкой Power на передней панели.

Автоматическое ослабление

Если управление аттенюатором установлено на Auto (по умолчанию), анализатор:

  • Дает возможность выбирать любой уровень мощности в пределах общего рабочего диапазона прибора

  • Автоматически выбирает положение аттенюатора и мощность источника так, что используется оптимальный интервал всего диапазона аттенюатора.

Ручная установка ослабления

В некоторых схемах измерений необходимо вручную устанавливать мощность источника и ослабление. Сюда входит:

  • Тестирование усилителей с положительной обратной связью (генераторы либо усилители с нестабильностью в зависимости от условия). Для этого требуется очень хорошее согласование полного сопротивления с источником (обратные потери 20 дБ) в широком частотном диапазоне. Для обеспечения наилучшего согласования в источнике выбирайте Auto Off(Авто откл) с уровнем ослабления в 10 или 20 дБ (или более).

  • Свипирование по мощности Во время свипирования по мощности не допускается, чтобы аттенюатор переключал свои настройки, чтобы не допустить износа из-за постоянного переключения. Настройка Auto может не давать возможности полного покрытия диапазона свипирования по мощности. Для того чтобы обеспечить полный необходимый для измерения диапазон свипирования по мощности, выберите Auto Off и комбинацию мощности источника и положения аттенюатора.

Диапазоны и значения ослабления

У аттенюатора есть разные положения, которые позволяют устанавливать уровни мощности в разных диапазонах. Количество возможных диапазонов мощности определяется источником ослабления, установленным в PNA. Доступность источника ослабления и его диапазон для вашего PNA можно просмотреть в Опции PNA.

  • В каждом диапазоне есть полный заданный интервал (25 dB на следующем графике значений ослабления).

  • Оптимальная настройка находится в середине диапазона. Данный диапазон обеспечивает наибольшую точность и характеристики системы установки уровня источника. Оптимальные диапазоны – это синие участки на следующем изображении.

  • Настройку аттенюатора можно устанавливать вручную или автоматически. Если выбран автоматический способ, используются синие оптимальные диапазоны (показаны на следующем графике).

(Диапазоны аттенюатора бывают разные, данный диапазон - 70 дБ)

Примечание: Коррекция погрешности дает полную точность только для уровня мощности, при котором выполнялась калибровка. Однако если мощность меняется в пределах диапазона аттенюатора, при котором выполнялась калибровка измерения, относительные измерения можно выполнить с почти полной точностью (абсолютные измерения – с меньшей точностью).

Ослабление источника при свипировании по мощности

Чтобы установить ослабление источника в режиме свипирования по мощности, сначала выберите Power Sweep type, затем нажмите Channel, Power

Power (Sweep) справка по диалоговому окну

Start Power Устанавливает начальное значение свипирования по мощности.

Stop Power Устанавливает конечное значение свипирования по мощности.

Attenuation Устанавливает значение аттенюатора источника для обоих портов источника.

Подробнее об ослаблении источника.

Подробнее о свипировании по мощности.

Ослабление для несвязанных портов

Модели PNA с опцией UNL (и стандартные модели E8356/57/58A) имеют аттенюатор источника на каждом измерительном порту. Уровни мощности измерительных портов можно устанавливать независимо.

Модели PNA с опцией 1E1 имеют единственный аттенюатор источника, который переключается между измерительными портами. Если порты не связаны, то уровни мощности на измерительных портах можно устанавливать по отдельности. Если уровни мощности значительно отличаются, то аттенюатор источника должен будет менять положение при переключении между портами. Чтобы не допустить преждевременного износа механического шагового аттенюатора, PNA выполняет следующее:

  • Не допускает постоянного переключения между диапазонами мощности

  • Автоматически включает режим приостановки после измерения на каждом канале

If Если включено усреднение, то режим приостановки не включается до тех пор, пока для каждого канала не будет выполнено заданное количество свипирований.

Ослабление приемника

Чтобы не допустить повреждения приемников PNA, возможно, потребуется ослаблять выходной сигнал тестируемого устройства.

Модели PNA с опцией 015 или опцией 016 обеспечивают внутреннее ослабление сигналов для обоих портов приемников. Характеристики аттенюатора приемника:

  • Диапазон:

    • от 0 до 50 дБ (только E8361A)

    • от 0 до 35 дБ (остальные модели PNA)

  • Разрешение:

      • o 10 дБ (только E8361A) o 5 дБ (остальные модели PNA)

    • 10 дБ (только E8361A)

    • 5 дБ (остальные модели PNA)

Компенсация мощности по частоте (Power Slope)

Компенсация мощности по частоте помогает компенсировать потери мощности в кабеле и измерительном оборудовании при повышеннии частоты.

  • Если функция компенсации мощности по частоте включена, то выходная мощность порта возрастает (или уменьшается) с ростом частоты свипирования.

  • Компенсация мощности по частоте измеряется в дБ/ГГц.

  • Для компенсации мощности по частоте можно выбирать только значения 0.5, 1, 1.5 или 2 (положительные или отрицательные).

Включение и выключение мощности во время свипирования и обратного хода

Диапазон частот PNA перекрывает несколько внутренних полос частот. Чем выше диапазон частот PNA, тем больше количество полос. Например, PNA с 9 ГГц имеет 6 полос частот, PNA с 50 ГГц имеет 25 полос частот. Смотрите Пересечения полос частот.

Во время изменения полос мощность, подаваемая к тестируемому устройству, устанавливается на минимум, чтобы не допустить бросков мощности на устройстве. Минимальная мощность определяется настройкой аттенюатора.

Обратный ход выполняется, если частота источника доходит до конца выбранного интервала частот и возвращается к стартовой частоте. При обратном ходе по полосам частот мощность, подаваемая на тестируемое устройство, снова устанавливается на минимум.

Поэтому для различных настроек стимула происходит следующее:

  1. Свипирование одной полосы - Даже при обратном ходе мощность, подаваемая на тестируемое устройство всегда в состоянии ВКЛ.

  2. Свипирование по нескольким полосам - При свипировании на пересечениях полос мощность, подаваемая на тестируемое устройство, будет установлена на минимум. Во время обратного хода мощность снова будет установлена на минимум.

  3. Свипирование по мощности - Поскольку свипирование по мощности всегда выполняется на одной частоте, то частота всегда находится в пределах одной полосы и мощность источника всегда включена. После окончания свипирования по мощности мощность немедленно возвращается к стартовому значению. Таким образом, не допускается перегрев тестируемого устройства.

  4. Однократное свипирование - Существует два метода однократного свипирования:

    • Режим ручного запуска – в конце свипирования выполняется настройка для следующего свипирования, и PNA ждет запуска. В процессе настройки многодиапазонного свипирования выполняется смена диапазона и подача мощности на тестируемое устройство снова включается.

    • Режим приостановки (Hold mode) – в конце свипирования мощность остается минимальной до начала следующего свипирования.

Внимание:: Избегайте дорогостоящих ремонтных работ анализатора серии PNA. См. Защита от электростатического разряда.


Свипирование

Настройки свипирования

Свипирование - это ряд последовательных измерений выходных данных, соответствующих определенной последовательности значений стимула. Вы можете установить следующие настройки свипирования:

  • Тип свипирования

  • Время свипирования

  • Настройка свипирования

Другие разделы по настройке измерений

Тип свипирования

Существует пять типов свипирования для PNA:

  • Linear Frequency - (Линейная частота) – устанавливает свипирование по линейной частоте, отображаемое на стандартной сетке с десятью равными делениями по горизонтали. Это заданный по умолчанию тип свипирования.

  • Log Frequency - (Логарифмическая частота) – устанавливает шаг источника с логарифмическими приращениями, данные отображаются на логарифмической шкале х.

  • Power Sweep (Свипирование по мощности) – Включает свипирование по мощности на одной заданной частоте. Вы можете установить любой диапазон мощности < 25 dB. (По умолчанию задано от 10 dBm до 0 dBm.) Свипирование по мощности используют для определения характеристик цепей, чувствительных к мощности, выполняются такие измерения, как нелинейность амплитудной характеристики или наклон характеристики АРУ (AGC - automatic gain control). Подробнее о свипировании по мощности

  • CW Time - (Время гармонического колебания) - устанавливает PNA в одночастотный режим, данные отображаются соответственно изменению времени.

  • Segment Sweep - (Сегментированное свипирование) – устанавливает PNA на свипирование по 30, максимум, сегментам свипирования, заданным пользователем. Подробнее о сегментированном свипировании

Установка типа свипирования

Пользуйтесь одним из следующих методов:

  • +

Более подробно см. интерфейс передней панели

Sweep Type (Тип свипирования) справка по диалоговому окну

Примечание: Настройки свипирования не начнут действовать до нажатия OK или Apply (Применить).

Channel (Канал) Активный канал при выборе типа свипирования. Настройки свипирования будут применяться к данному каналу.

Тип свипирования

Linear Frequency (Линейная частота) – устанавливает свипирование по линейной частоте, отображаемое на стандартной сетке с десятью равными делениями по горизонтали.

  • Start Устанавливает начальное значение свипирования по частоте.

  • Stop Устанавливает конечное значение свипирования по частоте.

  • Points (Точки) Устанавливает количество точек, в которых PNA проводит измерения при свипировании. Диапазон: от 2 до 16001.(По умолчанию задано 201).

Log Frequency (Логарифмическая частота) – установлен шаг источника с логарифмическими приращениями, данные отображаются на логарифмической шкале х. Как правило, этот метод медленнее, чем постоянное свипирование с таким же количеством точек.

  • Start Устанавливает начальное значение свипирования по частоте.

  • Stop Устанавливает конечное значение свипирования по частоте.

  • Points (Точки) Устанавливает количество точек, в которых PNA проводит измерения при свипировании. Диапазон: от 2 до 16001.(По умолчанию задано 201).

Power Sweep (Свипирование по мощности) – Включает свипирование по мощности на одной заданной частоте. Подробнее о свипировании по мощности

  • Start Устанавливает начальное значение свипирования по мощности.

  • Stop Устанавливает конечное значение свипирования по мощности.

  • CW Frequency (Частота гармонического колебания) Устанавливает одночастотный режим для PNA при измерении свипирования.

CW Time Устанавливает PNA в одночастотный режим, данные отображаются соответственно изменению времени.

  • CW Frequency Устанавливает частоту, на которой PNA будет оставаться при измерении.

  • Sweep Time (Время свипирования) Устанавливает длительность измерения, отображаемого на оси X.

  • Points (Точки) Устанавливает количество точек, в которых PNA проводит измерения при свипировании. Диапазон: от 2 до 16001.(По умолчанию задано 201).

Segment Sweep (Сегментированное свипирование) Устанавливает PNA на свипирование по сегментам свипирования, заданным пользователем. Подробнее о сегментированном свипировании

  • Independent Power Levels (Независимые уровни мощности) Отметьте, чтобы установить уровень мощности источника для каждого сегмента.

  • Independent IF Bandwidth (Независимая полоса ПЧ) Отметьте, чтобы установить полосу ПЧ для каждого сегмента.

  • Independent Sweep Time (Независимое время свипирования) Отметьте, чтобы установить длительность измерения для каждого сегмента.

  • X-Axis Point Spacing (Размещение точек на оси Х) Отметьте для определения масштаба оси Х так, чтобы включить только сегменты. Подробнее.

  • Allow Arbitrary Segments (Разрешить произвольные сегменты) Отметьте, чтобы разрешить произвольные частоты (перекрывающиеся или обратные свипирования). Подробнее

  • Show Table (Показать таблицу) Открывает таблицу, где вы можете создавать и редактировать сегменты.

  • Hide Table (Скрыть таблицу) Убирает таблицу сегментов с экрана.

OK Применяет изменения настроек и закрывает диалоговое окно.

Apply (Применить) Применяет изменения настроек и оставляет диалоговое окно открытым для дальнейших изменений.

Cancel (Отмена) Закрывает диалог. Изменения настроек, проведенные с момента последнего нажатия кнопки Apply, НЕ вступают в силу.

Свипирование по мощности

(Свипирование по мощности) – Включает свипирование по мощности на одной заданной частоте. Вы можете установить любой диапазон мощности < 25 dB. (По умолчанию задано от 10 dBm до 0 dBm.) Свипирование по мощности используют для определения характеристик цепей, чувствительных к мощности, выполняются такие измерения, как нелинейность амплитудной характеристики или наклон характеристики АРУ (AGC - automatic gain control).

  • Мощность разбита на интервалы, начиная от стартового значения, до конечного значения на одной частоте.

    • В каждой точке диапазона свипирования по мощности амплитуда источника растет с дискретным приращением по мощности.

    • Размер приращений определяют количество точек данных и диапазон мощности.

  • Для того чтобы получить полный необходимый для измерения диапазон свипирования по мощности, выберите комбинацию диапазона мощности источника и ручную установку положения аттенюатора (если у PNA есть аттенюатор источника).

Примечание:Чтобы установить ослабление источника в режиме свипирования по мощности, выберите Power Sweep (Свипирование по мощности), затем нажмите Channel, Power.

В режиме свипирования по мощности применяются следующие настройки мощности:

  • Настройка Port Power Coupled – связывание мощности портов (ВКЛ/ ВЫКЛ) игнорируется. Для обоих измерительных портов используются одни и те же настройки свипирования по мощности.

  • • Настройка Test Port Power (Мощность измерительного порта) игнорируется. Код использует значения стартовой и конечной мощности для определения уровней мощности на измерительных портах.

  • Управление аттенюатором установлено, как ручное

  • Power Slope - компенсация мощности по частоте (дБ/ГГц) игнорируется. Выходная частота – непрерывное гармоническое колебание (CW).

Подробнее о настройках мощности.

Сегментированное свипирование

Сегментированное свипирование запускает свипирование, состоящее из подинтервалов частоты, которые называются сегментами. Для каждого сегмента вы можете определить независимые уровни мощности, полосу ПЧ и время свипирования.

После выполнения калибровки измерения по всему диапазону свипирования или по всем сегментам, вы можете провести калиброванные измерения для одного или более сегментов.

При сегментированном свипировании анализатор выполняет следующее:

  • Сортирует все определенные сегменты в порядке возрастания частоты

  • Проводит измерение в каждой точке

  • Отображает один график, сформированный из всех полученных данных

Ограничения для сегментированного свипирования:

  • Не допускается, чтобы частотный диапазон сегмента перекрывал частотный диапазон любого другого сегмента.

  • Количество сегментов ограничено только количеством точек данных для всех сегментов свипирования.

  • Общее количество точек данных для всех сегментов свипирования не должно превышать 16001.

  • Уровни мощности всех сегментов должны находиться в пределах одного диапазона аттенюатора, чтобы не допустить преждевременного износа механического шагового аттенюатора. Смотрите Уровень мощности.

Вставка, удаление и модификация сегментов

Вставка и удаление сегментов

Insert Segment (Вставить сегмент) – вставляет сегмент свипирования перед выбранным сегментом.

Примечание - вы также можете нажать стрелку "вниз" на клавиатуре, чтобы быстро добавить несколько сегментов.

Delete Segment (Удалить сегменты) – удаляет выбранный сегмент

Delete All Segments (Удалить все сегменты) – удаляет все сегменты

Модификация существующего сегмента

Для того чтобы следующие настройки меню стали доступными, сначала необходимо открыть таблицу сегментов. Нажмите View (Обзор), перейдите к Tables(Таблицы), затем нажмитеSegment Table (Таблица сегментов).

На приведенном выше рисунке показана таблица сегментов с выбором независимости всех настроек, включая несвязанность мощности источников (две настройки мощности).

STATE (Состояние) Щелкните по окошку на сегменте, подлежащем модификации. Затем с помощью стрелок вверх-вниз переводите сегмент в состояние Вкл или Выкл.

START Щелкните по ячейке, наберите значение и первую букву суффикса (KHz, Mhz, GHz). Либо дважды щелкните по ячейке, чтобы выбрать значение.

STOP Устанавливает конечную частоту для сегмента. Щелкните по ячейке, наберите значение и первую букву суффикса (KHz, Mhz, GHz). Либо дважды щелкните по ячейке, чтобы выбрать значение.

POINTS (Точки) Устанавливает количество точек данных для данного сегмента. Наберите значение или дважды щелкните по ячейке, чтобы выбрать значение.

Независимая установка полосы ПЧ, мощности и времени свипирования для каждого сегмента:

В меню the Sweep нажмите Sweep Type, затем Segment Sweep.
Установите соответствующие флажки в полях Sweep Properties (Свойства свипирования)

Затем щелкните по окошку и наберите значение или дважды щелкните по окошку, чтобы выбрать значение.

Примечание: Если следующие параметры НЕ установлены, при свипировании будут использованы настройки полосы ПЧ, мощности и времени этого канала.

IFBW Устанавливает полосу ПЧ для сегмента.

POWER Устанавливает уровень мощности для сегмента.

TIME Устанавливает время свипирования для сегмента.

Более подробно см. интерфейс передней панели.

Размещение точек на оси X

Данная функция применяется только к сегментированному свипированию и влияет на отображение графика на экране.

Выбор размещения точек на оси Х

В диалоговом окне Sweep Type нажмите Segment Sweep

Затем отметьте X-Axis Point Spacing (Размещение точек на оси Х)

Более подробно см. интерфейс передней панели

Без установки размещения точек по оси Х при свипировании по нескольким сегментам график иногда выражается в виде многих точек измерения, сжатых на небольшом участке оси Х.

При установленном размещении точек по оси Х положение каждой точки на оси Х выбирается так, что все точки измерения равномерно расположены вдоль оси.

Например, рассмотрим два сегмента:

Без размещения точек на оси Х

С размещением точек на оси Х

Произвольное сегментированное свипирование

Данная функция включает ввод произвольных частот в таблицу сегментов свипирования, это дает возможность следующего:

  • частоты сегментов могут перекрываться.

  • реверсивное свипирование (конечная частота может быть меньше стартовой).

Выбор произвольного сегментированного свипирования

В диалоговом окне Sweep Type нажмите Segment Sweep

Затем отметьте Allow Arbitrary Segment Sweep (Разрешить произвольное сегментированное свипирование)

Более подробно см. интерфейс передней панели

Примечание: Для перекрывающихся сегментов и сегментов реверсивного свипирования функции маркеров, дисплея, линий ограничения и калибровки могут выдать необычные результаты.

Если отмечено поле Allow Arbitrary Segment, то X-axis point spacing автоматически переключается в состояние ВКЛ.

Время свипирования

PNA автоматически поддерживает возможность самого быстрого свипирования при выбранных настройках измерения. Однако вы можете увеличить время свипирования.

Установка времени свипирования

Пользуйтесь одним из следующих методов:

  • +

Более подробно см. интерфейс передней панели

Sweep Time справка по диалоговому окну

• Указывает время, необходимое PNA для получения данных для свипирования. Максимальное время свипирования для PNA составляет 86400 секунд (1 день).

Примечание: Если важна точность времени свипирования, для выбора значения, рассчитанного PNA, пользуйтесь ТОЛЬКО стрелками вверх-вниз рядом с окном ввода времени свипирования. НЕ набирайте значение времени свипирования.

  • В фактическое время свипирования включается время получения плюс некоторое "служебное" время.

  • ? PNA автоматически поддерживает возможность самого быстрого свипирования при выбранных настройках измерения. Однако вы можете увеличить время свипирования с помощью данной настройки.

  • Введите 0 секунд, чтобы вернуть анализатор к самому быстрому возможному свипированию.

  • Настройка времени свипирования применяется к активному каналу.

  • Пошаговое свипирование выбирается автоматически, если время свипирования установлено на 8 мсек или больше.

  • Индикатор свипирования [image] появляется на графике, если время свипирования составляет 0.3 секунды или больше, либо запуск установлен на Point Sweep Mode (Режим точечного свипирования). Индикатор расположен на последней точке данных, измеренной приемником. Если индикатор остановлен (режим точечного свипирования), источник уже перешел к следующей точке данных.

Настройка свипирования

Установка настроек свипирования

Пользуйтесь одним из следующих методов:

  • +

Более подробно см. интерфейс передней панели

Sweep Setup (Настройка свипирования) справка по диалоговому окну

Channel (Канал) Указывает канал, к которому применяются настройки.

Stepped Sweep (Пошаговое свипирование) Если функция отмечена, источник PNA настроен, ждет заданное Dwell time (Время задержки), затем принимает ответные данные и настраивает источник на следующую частотную точку. Данный процесс медленнее аналогового свипирования, но более точный для тестирования электрически длинных устройств.

Если флажок снят (Аналоговое свипирование), то PNA принимает ответные данные по мере свипирования источника. Процесс проходит быстрее, чем при пошаговом свипировании, но при тестировании электрически длинных устройств могут появляться ошибки измерения.

При снятой отметке в диалоговом окне PNA может находиться в пошаговом или аналоговом режиме. Пошаговое свипирование выбирается автоматически в одном из следующих вариантов:

  • Полоса ПЧ равна или меньше 100 Гц

  • Время свипирования равно или меньше 8 мсек.

  • Коррекция мощности источника включена.

Dwell Time (Время задержки) Указывает время, в течение которого источник остается в точке измерения прежде, чем анализатор начинает получать данные. Применяется только при пошаговом свипировании. Максимальное время задержки составляет 100 секунд. Смотрите также электрически длинные устройства.

Alternate Sweeps Если поле отмечено, PNA проводит измерение только на одном приемнике за свипирование.
Если флажок снят, PNA измеряет оба приемника А и В (если используются) при каждом свипировании. Смотрите также перекрестные помехи (Crosstalk).

External ALC При установленном флажке анализатор включен на получение внешнего сигнала, который вы подаете для установки уровня выходного сигнала источника. Разъем ввода внешнего сигнала ALC – это External Detector Input задней панели. Доступен ТОЛЬКО для моделей PNA 3 ГГц, 6 ГГц и 9 ГГц . Применяйте, если используете оконечный усилитель (booster amplifier) при настройке теста.


Запуск

Запуск (Trigger)

Запуск – это сигнал, который побуждает PNA выполнять свипирование измерения. PNA предоставляет большую гибкость в конфигурировании функции запуска.

Просмотрите интерактивное воспроизведение модели запуска, чтобы увидеть, как запуск работает в PNA.

  • Установка запуска

  • Источник

  • Область

  • Настройки канала

  • Перезапуск

  • Внешний запуск

Другие разделы по настройке измерений

Установка запуска

Пользуйтесь одним из следующих методов:

  • +

Более подробно см. интерфейс передней панели

Примечание: TНастройки Continuous (Непрерывный), Single (Единичный), Hold (Удержание) применяются только к активному каналу. Доступ к данным настройкам можно получить из показанного выше меню Sweep Trigger (Свипирование запуска) и с клавиш Active Entry (Активный ввод).

Trigger (Запуск) Справка по диалоговому окну

Просмотрите интерактивное воспроизведение модели запуска, чтобы увидеть, как запуск работает в PNA.

Trigger Source (Источник запуска)

Данные настройки определяют место возникновения сигналов запуска для всех существующих каналов. Действительный сигнал запуска может быть генерирован только тогда, когда PNA не проводит свипирование.

Internal (Внутренний) PNA отправляет внутренние непрерывные сигналы запуска сразу после завершения предыдущего измерения.

Manual (Ручной режим) Один сигнал запуска, который отправляется нажатием кнопки Trigger, с активной панели или программной командой.

External (Внешний) Сигналы запуска подаются на разъем Aux I/O connector (pin19) на задней панели. Запуск чувствителен к уровню и может срабатывать как при низком, так и при высоком уровнях TTL.

Trigger Scope (Область запуска)

Данные настройки определяют, на что действует запуск.

Global (Глобальный) Все каналы, не в режиме блокировки (Hold), получают сигнал запуска [заданная по умолчанию настройка]

Channel (Канал) только следующий канал, который не находится в режиме удержания (Hold), принимает сигнал запуска. Это не очень понятно и полезно, если только источник запуска не установлен в ручной режим. Данная настройка включает режим Point Sweep (Точечное свипирование).

Channel Trigger State (Канал, состояние запуска)

Данные настройки определяют, сколько сигналов запуска будет получать канал.

Примечание: ОДИН сигнал запуска вызывает выполнение ВСЕХ изменений в канале; сначала одновременно выполняются прямые измерения (S11, S21), затем обратные измерения (S12, S22). При этом существуют два исключения:

  1. Если выбрано Alternate sweep, то измеряется только один приемник на запуск.

  2. Если выбрано Point Sweep, то измеряется только одна точка данных на запуск.

Continuous (Непрерывный) Канал принимает бесконечное количество сигналов запуска.

Groups (Группы) Канал принимает только то количество сигналов запуска, которое указано в текстовом окне Number of Groups, затем переходит в режим блокировки (Hold). Перед выбором групп надо сначала увеличить показания в текстовом окне Number of Groups более чем на единицу.

Number of Groups Укажите количество сигналов запуска, которое будет получать канал перед переходом в режим удержания. Сначала выберите необходимое число, затем выберите Groups.

Single Канал принимает ОДИН сигнал запуска, затем переходит в режим удержания (Hold).

Hold Канал НЕ принимает сигналов запуска.

Point Sweep (Точечное свипирование) При поступлении сигнала запуска канал измеряет следующую точку данных в свипировании. Последующие сигналы запуска поступают на тот же канал до тех пор, пока все измерения не завершатся. Затем запуск воздействует на следующий канал, который не находится в режиме удержания (Hold). Возможно только при обеих настройках Trigger Scope = CHANNEL и Trigger Source = MANUAL. Примечание: Выбор точечного свипирования не меняет способ вычисления усреднения свипирования. Подробнее.

Trigger! - отправляет на PNA в ручном режиме один сигнал запуска.

External Trigger - (Внешний запуск) – вызывает диалоговое окно External Trigger.

Restart - (Перезапуск) – каналы в режиме удержания установлены на единичный сигнал запуска (канал принимает один сигнал запуска). Все остальные настройки не меняются, включая уменьшение счетчика запуска.

Просмотрите интерактивное воспроизведение модели запуска, чтобы увидеть, как запуск работает в PNA.

External Trigger (Внешний запуск) справка по диалоговому окну

Примечание: Настройки в данном диалоговом окне немедленно влияют на измерение, несмотря на это можно нажать Cancel (Отмена), чтобы восстановить предыдущие настройки.

Input (Вход)

Trigger Delay (Задержка запуска) После начала действия внешнего запуска начало свипирования задерживается на указанный интервал времени плюс внутреннее время задержки.

Channel (Канал) – доступен только, когда выбран Channel trigger. Выберите канал, чтобы присвоить заданное значение задержки запуска. У каждого канала свое значение задержки.

Source (Источник) PNA принимает входящие сигналы запуска через один из следующих входных разъемов:

  • Aux I/O - pin 19

  • Handler I/O - pin 18

  • I/O 1 (TRIG IN) BNC

Level / Edge (Уровень / Фронт)

High Level (Высокий уровень) Запуск воздействует на PNA, если он подготовлен, а сигнал TTL на входе - ВЫСОКИЙ.

Low Level (Низкий уровень) Запуск воздействует на PNA, если он подготовлен, а сигнал TTL на входе - НИЗКИЙ.

Positive Edge (Положительный фронт) После того, как PNA подготовлен, он переключится на следующий положительный фронт. Если установлен Accept Trigger Before Armed и если с момента отбора последних данных получен положительный фронт, PNA переключится, как только будет готов.

Negative Edge (Отрицательный фронт) После того, как PNA подготовлен, он переключится на следующий отрицательный фронт. Если установлен Accept Trigger Before Armed и если с момента отбора последних данных получен отрицательный фронт, PNA переключится, как только будет готов.

Переключение фронта НЕ возможно для следующих моделей PNA: E835xA, E8362A, E8363A, E8364A.

Accept Trigger Before Armed (Принять запуск перед подготовкой) Если поле отмечено то, как только PNA готов к переключению, PNA немедленно переключится, если с момента отбора последних данных поступили любые сигналы запуска. PNA запоминает только один сигнал запуска. Остальные сигналы игнорируются.

Если в данном поле снять флажок, то любой сигнал запуска, полученный до того, как PNA готов, игнорируется.

Данная функция доступна только в том случае, если выбран запуск по положительному или отрицательному ФРОНТУ.

Output (Выход)

Enable Output (Включить выход) Если поле отмечено, PNA может отправлять сигналы запуска с разъема BNC I/O (TRIG OUT) на задней панели.

Polarity (Полярность) Импульса запуска на выходе PNA может быть в положительном или отрицательном направлении.

Position (Позиция) Выходной импульс запуска отправляется ДО или ПОСЛЕ измерения приемника.

Конфигурируйте работу внешнего запуска дистанционно с помощью CONTrol:SIGNal (SCPI) или ExternalTriggerConnectionBehavior (COM).


Формат данных и масштаб

Формат данных – это способ графического представления данных анализатором. Формат данных необходимо выбирать в соответствии с информацией, которую вы хотите узнать о тестируемом устройстве.

  • Форматы в прямоугольной системе координат

  • Полярный

  • Круговая диаграмма (Smith Chart)

  • Установка формата

  • Масштаб, опорный уровень и позиция

  • Смещение по модулю (Magnitude Offset)

Другие разделы по настройке измерений

Форматы в прямоугольной системе координат

Семь из девяти возможных форматов данных используют прямоугольную систему координат для представления данных измерений. Данную систему также называют декартовой, X/Y или прямолинейной. Прямоугольная система координат особенно полезна для ясного отображения информации о частотной характеристике тестируемого устройства.

  • Характеристики стимула (частота, мощность или время) располагаются по оси Х в линейном масштабе

  • Измеренные данные появляются по оси Y.

Формат Log Mag (логарифмический модуль)

  • Отображает модуль (не фазу)

  • Ось Y: дБ

  • Стандартные измерения:

    • Обратные потери

    • Вносимые потери или усиление

Формат фазы

  • Отображает фазу (не модуль)

  • Ось Y: Фаза (градусы)

  • Стандартные измерения:

    • Отклонение от линейной фазы

Формат групповой задержки

  • Отображает время передачи (распространения) по устройству

  • Ось Y: время (секунды)

  • Стандартные измерения:

    • Групповая задержка

Формат линейного модуля (Linear Magnitude)

  • Отображает только положительные значения

  • Ось Y: Безразмерный (U) для относительных измерений
    Ватты (W) для абсолютных измерений.

  • Стандартные измерения:

    • коэффициенты отражения и передачи (модуль)

    • передача во временной области

Формат КСВ (SWR)

  • Отображает данные измерения отражения, рассчитанные по формуле (1+r)/ (1r) где r коэффициент отражения.

  • Действует только для измерений отражения.

  • Ось Y: Безразмерный

  • Стандартные измерения:

    • коэффициент стоячей волны

Формат действительных чисел

  • Отображает только действительную (резистивную) часть измеренных комплексных данных.

  • Может отображать как положительные, так и отрицательные значения.

  • Ось Y: Безразмерный

  • Стандартные измерения:

    • временная область

    • o сигнал напряжения на вспомогательном входе для целей обслуживания

Формат мнимых чисел

  • Отображает только мнимую (реактивную) часть измеренных данных.

  • Ось Y: Безразмерный

  • Стандартные измерения:

    • полное сопротивление для разработки согласующей цепи

Полярный формат (Polar Format)

Полярный формат используют для просмотра модуля и фазы коэффициента отражения (Г), измерения S11 или S22.

Для отображения следующего можно использовать маркеры:

  • Линейный модуль (в единицах) или логарифмический модуль (в дБ)

  • Фаза (в градусах)

  • Пунктирные круги представляют коэффициент отражения (reflection coefficient). Крайний круг представляет коэффициент отражения (Г) равный 1, или полностью отраженный сигнал. Центр круга представляет коэффициент отражения (Г) равный 0, или не отраженный сигнал.

  • Радиальные линии показывают фазовый угол (phase angle) отраженного сигнала. Крайняя справа позиция соответствует нулевому фазовому углу (это означает, что отраженный сигнал имеет ту же фазу, что и входящий сигнал). Разности фаз 90°, ±180° и -90° соответствуют верхней, крайней левой и нижней позициям на полярной системе, соответственно.

Формат круговой диаграммы (Smith Chart)

Круговая диаграмма – это инструмент, отображающий комплексный коэффициент отражения (Г) на полное сопротивление тестируемого устройства.

На круговой диаграмме прямолинейная плоскость полного сопротивления (rectilinear impedance plane) преобразована в форму круговой сетки, на которой можно считывать активное и реактивное сопротивление (R + jX).

Для отображения следующего можно использовать маркеры:

  • Сопротивление (в омах)

  • Сопротивление, как эквивалентная емкость (в фарадах) или индуктивность (в генри)

Интерпретация круговой диаграммы

  • Каждая точка круговой диаграммы представляет собой полное сопротивление (импеданс) в комплексной форме, составленное из действительного сопротивления (r) и мнимого реактивного сопротивления (r+-jX)

  • Горизонтальная ось (сплошная линия) – это действительная часть импеданса - сопротивление. Центр горизонтальной оси всегда представляет собой импеданс системы. Крайнее справа – бесконечное значение в омах (разомкнуто). Крайнее слева – нулевое значение в омах (замыкание)

  • Пунктирные окружности, пересекающие горизонтальную ось, представляют постоянное сопротивление.

  • Пунктирные дуги, касающиеся горизонтальной оси, представляют постоянное реактивное сопротивление.

  • Верхняя половина круговой диаграммы – это зона, где компонента реактивного сопротивления положительна, следовательно, индуктивная.

  • Нижняя половина – это зона, где компонента реактивного сопротивления отрицательна, следовательно, емкостная.

Установка формата

Пользуйтесь одним из следующих методов:

  • +

  • +

Более подробно см. интерфейс передней панели

Format справка по диалоговому окну

Log Mag

Phase

Group Delay

Smith Chart

Polar

Linear Mag

SWR

Real

Imaginary

Масштаб, опорный уровень и позиция

Настройки Scale (Масштаб), Reference Level (Опорный уровень) и Reference Position (Опорная позиция) (а также формат) определяют отображение графика на экране PNA.

Установка масштаба, опорных уровня и позиции

Пользуйтесь одним из следующих методов:

  • +

Более подробно см. интерфейс передней панели

Scale (Масштаб) справка по диалоговому окну

Scale

Per Division (На деление) Устанавливает цену вертикальных делений в формате прямоугольной системы координат. В форматах полярный и круговая диаграмма масштаб устанавливает значение для внешней окружности. Диапазон: от 0.001дБ/дел до 500 дБ/дел

Autoscale (Автомасштабирование) – автоматически устанавливает цену вертикальных делений и опорное значение для совмещения АКТИВНОГО графика и зоны сетки на экране. Значения стимула и опорная позиция не меняются.

Анализатор определяет наименьшую возможную цену деления, при котором все отображаемые данные смогут попасть в 80 процентов вертикальной сетки.

Опорное значение выбирается так, чтобы центрировать график на экране.

Autoscale All (Автомасштабирование всего) Автоматически масштабирует ВСЕ графики в АКТИВНОМ ОКНЕ для совмещения по вертикали с зоной сетки на экране.

Опорные значения

Level (Уровень) В форматах прямоугольной системы устанавливает значение опорной линии, указываемое [image] на экране PNA. Диапазон: от -500 дБ до 500 дБ.

В формате полярной и круговой диаграмм опорный уровень не используется.

Position (Позиция) В форматах прямоугольной системы устанавливает значение опорной линии. Нуль – это нижняя линия экрана, десять – верхняя линия. Заданная по умолчанию позиция – пять (середина).

В форматах полярной и круговой диаграмм опорная позиция не используется.

Смещение по модулю (Magnitude Offset)

Смещение по модулю (амплитуде) дает вам возможность сдвигать данные модуля (не фазы) на фиксированное и/или уменьшающееся значение в дБ. Если формат отображения – линейный модуль или вещественные числа (безразмерный), то выполняется преобразование из дБ и применяется правильное значение сдвига.

Установка смещения по модулю

Более подробно см. интерфейс передней панели

Magnitude Offset справка по диалоговому окну

Смещение по модулю влияет только на активный график.

Offset (Смещение) Сдвигает весь график на указанное значение.

Slope (Наклон) Сдвигает график на значение, изменяющееся с частотой. Уменьшение сдвига начинается с 0 Гц.

Для удобства значение сдвига на стартовой частоте рассчитывается и отображается.

Посмотрите, где данная операция выполняется в последовательности обработки данных.


Предопределенные настройки измерений

  • Предопределенные настройки для НОВЫХ измерений

  • Компоновка существующих измерений

Перед тем, как читать данный раздел, необходимо иметь понятие о графиках, каналах и окнах в PNA.

Другие разделы по настройке измерений

Предопределенные настройки для НОВЫХ измерений

Каждая из следующих настроек создает новые графики. Если предварительно не сохранить существующие графики и их настройки, то они будут утрачены.

Выбор предопределенной настройки измерения

Пользуйтесь одним из следующих методов:

  • +

Более подробно см. интерфейс передней панели

Далее приведены четыре предопределенные настройки измерений:

Компоновка существующих измерений

Следующие компоновки помещают СУЩЕСТВУЮЩИЕ измерения в окно предопределенных компоновок с помощью алгоритма сортировки.

Выбор компоновки существующих измерений

Пользуйтесь одним из следующих методов:

  • +

Более подробно см. интерфейс передней панели

Компоновка наложением

При такой конфигурации все существующие графики размещаются в одном окне, перекрывая друг друга.

Компоновка 2 элементов

При такой конфигурации все существующие графики размещаются в двух "стековых" окнах.

3 разделенных элемента

При такой конфигурации все существующие графики размещаются в трех окнах – два вверху и одно внизу.

Компоновка 4 элементов

При такой конфигурации все существующие графики размещаются в четырех окнах, по одному окну в каждой четверти окна.

Алгоритм сортировки

Алгоритм сортировки для функции компоновки окон (Arrange Windows) предназначен для:

  • Распределения графиков между окнами на основе их свойств

  • Группировки графиков с общими свойствами

Алгоритм сортировки основан на следующих свойствах графиков в порядке приоритета:

  1. Формат: круговой (полярный или круговая диаграмма) или прямолинейный (log mag, lin mag, групповая задержка и т.д.)

  2. Номер канала

  3. Передача или отражение

Примечание: Ограничение анализатора по размещению четырех графиков в одном окне имеет приоритет над данным алгоритмом. Если выбранную компоновку невозможно выполнить с заданным количеством графиков на экране, появляется сообщение об ошибке.


Модификация экрана PNA

Экран PNA можно модифицировать, открывая или скрывая следующие элементы дисплея. Выбор всех элементов выполняется из меню View PNA.

  • Строка текущего состояния

  • Панели инструментов

  • Tables

  • Measurement Display

  • Data and Memory Trace

  • Title Bars

  • Minimize Application

Информация об использовании предопределенных настроек измерений и компоновке окон

Информация о графиках, каналах и окнах PNA

Другие разделы по настройке измерений

Строка текущего состояния

Если функция включена, строка текущего состояния отображается в нижней части экрана PNA. На ней указано следующее:

  • Активный канал

  • Параметр измерения для активного графика

  • Trace Math (обработка графика)

  • Error correction Коррекция погрешности для активного графика

  • Averaging Factor Коэффициент усреднения для активного графика

  • Smoothing Сглаживание в процентах

  • Transform Преобразование (Вкл)

  • Gating Временная селекция (Вкл)

  • Временная селекция на ПЧ для Pulsed App: (G)

  • Ручная фильтрация на ПЧ для Pulsed App: (F)

  • Задержка, если вызвана сдвигом фазы, электрической задержкой, или расширениями порта.

  • Потери, если вызваны смещением по модулю Magnitude Offset.

  • Статус GPIB: локальный (LCL) или дистанционный (RMT)

  • Статус погрешности: (LVL, LCK, и т.д.)

Статус строки состояния (ВКЛ или ВЫКЛ) не будет меняться, если для PNA установлены предварительные условия.

Способ отображения строки текущего состояния

Более подробно см. интерфейс передней панели

Панели инструментов

Можно отображать до пяти различных панелей инструментов, это даст вам возможность простой настройки и модификации измерений.

Способ отображения панелей инструментов

Более подробно см. интерфейс передней панели

Просмотрите информацию о каждой панели инструментов:

  • Active Entry

  • Markers

  • Measurement

  • Sweep Control

  • Stimulus

  • Time Domain

  • All Off

Примечание: Также для Monitoring Error Terms доступна панель инструментов Cal Set.

Панель Active Entry (Активный ввод)

Панель инструментов активного ввода отображается в верхней части экрана под строкой меню. Это дает возможность выбирать из активных функций с помощью мышки или нажимая на кнопку передней панели соответствующего цвета.

Более подробно см. интерфейс передней панели

Панель инструментов Markers (Маркеры)

Панель маркеров дает возможность настраивать и модифицировать маркеры. На ней показаны:

  • Номер маркера

  • Значение стимула

  • Функции маркера

    • Дельта

    • Старт/Стоп

    • Центр/интервал

Совет: Чтобы использовать ручку на передней панели для изменения позиции маркера, сначала щелкните по полю Stimulus (Стимул) на панели инструментов маркера. Затем поверните ручку.

Подробнее о маркерах

Панель инструментов Measurement (Измерение)

Панель инструментов измерений дает возможность создавать новый график для измерения желаемого S-параметра в текущем или новом окне.

Панель инструментов Sweep Control (Управление свипированием)

Кнопки данной панели (слева направо) устанавливают активный канал на:

  • Режим Hold (Удержание)

  • Единичное свипирование, затем режим удержания

  • Непрерывное свипирование

Дополнительная информация о Channel Trigger State.

Панель инструментов Stimulus (Стимул)

Панель инструментов стимула дает возможность просматривать, настраивать и модифицировать свипирование по стимулу. На ней показаны:

  • Стартовое значение

  • Конечное значение

  • Количество точек

Панель инструментов Time Domain (Временная область)

Панель инструментов Time Domain дает возможность выполнять следующее:

  • Включать и отключать преобразование и временную селекцию

  • Изменять время начала/останова для преобразования и временной селекции

  • More... запускает диалоговое окно Time Domain Transform

  • X Закрывает панель инструментов

Клавиши передней панели Tab соответствуют всем настройкам всех панелей инструментов на дисплее. Если Tab не действует, нажмите одну из цветных клавиш активной панели инструментов (Active Toolbar).

Отключить все (All Off)

Дает вам возможность скрыть все панели инструментов одним действием.

Таблицы

Таблицы отображаются в нижней части выбранного окна. В окне может отображаться только одна таблица.

Отображение таблиц

Более подробно см. интерфейс передней панели

Вы можете отображать следующие таблицы:

  • Marker Table

  • Limit Line Table

  • Segment Table

Таблица маркеров

Можно отображать таблицу настроек маркера. Данные настройки включают в себя:

  • Номер маркера

  • Начало отсчета маркера (для дельта измерений)

  • Частота

  • Время и расстояние (для измерений во временной области)

  • Отклик

Дополнительная информация о маркерах

Таблица ограничений

Можно отображать, устанавливать и модифицировать таблицу настроек тестирования по критерию. Сюда входят:

  • Тип (MIN, MAX или OFF)

  • Начальное и конечное значения стимула

  • Начальное и конечное значения отклика

Подробнее об ограничительных линиях

Таблица сегментированного свипирования

Можно отображать, устанавливать и модифицировать таблицу настроек сегментированного свипирования. Сюда входят:

  • Состояние (Вкл/Выкл)

  • Начальная и конечная частоты

  • Количество точек

  • Полоса ПЧ (если уровни независимы)

  • Уровень мощности (если уровни независимы)

  • Время свипирования (если уровни независимы)

Подробнее о сегментированном свипировании

Отображение измерения

Отображение информации об измерении

Более подробно см. интерфейс передней панели

  • Trace Status

  • Frequency Stimulus

  • Marker Readout

  • Limit Test Results

  • Limit Lines

  • Title

Состояние графика

Состояние графика отображается в левой части каждого окна на экране. Указано:

  • Измеряемый параметр

  • Формат

  • Коэффициент масштабирования

  • Опорный уровень

Щелкните по кнопке состояния графика, чтобы измерение стало активным.

Как отобразить кнопки состояния графика

Частота/Стимул

Информация о частоте/стимуле отображается в нижней части каждого окна на экране. Указано:

  • Номер канала

  • Стартовое значение

  • Конечное значение

Как отобразить информацию о частоте/стимуле

Показания маркера

  • Отмечено – отображает следующую информацию о маркере в верхнем правом углу каждого окна.

    • Номер маркера

    • Значение стимула

    • Значение отклика в формате, выбранном для маркера

  • Не отмечено – не отображается экран показаний маркера.

Показания одного маркера на графике

  • Отмечено – отображаются показания одного активного маркера на графике.

  • Не отмечено – отображаются до 5 маркеров на активном графике.

Крупные показания маркера

  • Отмечено – показания маркера отображаются шрифтом большого размера для простоты чтения.

  • Не отмечено – показания маркера отображаются шрифтом обычного размера.

Подробнее о маркерах

Как изменить настройки показаний маркера

Результаты тестирования по критерию

Результаты тестирования по критерию, Pass (годен) или Fail, (не годен) отображаются в правой части соответствующего окна.

Ограничительные линии

Линии ограничения отображаются для активного графика в соответствующем окне. Их положение зависит от:

  • Уровней ограничения

  • Формата

  • Масштаба

  • Опорного уровня

Подробнее об ограничительных линиях

Как отобразить ограничительные линии и результаты

Заголовок

С клавиатуры можно создавать и отображать заголовок для каждого окна измерений. Кроме того, можно использовать следующее диалоговое окно ввода заголовка (Title Entry).

Заголовок отображается в верхнем левом углу выбранного окна.

Чтобы удалить заголовок, удалите его в зоне ввода диалогового окна и нажмите ОК.

Как отобразить заголовок

График данных и график в памяти

Вы можете просмотреть или скрыть активные данные или график в памяти.

  • Установите активное состояние графика, щелкнув по кнопке состояния графика

  • Для просмотра графика в памяти сначала надо сохранить график в памяти. Нажмите Trace (график), затем Math / Memory, затем Data => Memory.

Подробнее о математических операциях

Строки заголовков

В строке заголовка отображается номер окна и пиктограммы Уменьшить / Увеличить.

При установленном флажке будут показаны заголовки всех окон PNA.

Очистите строки заголовков, чтобы скрыть заголовки всех окон на экране. Это дает возможность освободить больше места для отображения результатов измерений.

Как изменить настройку строки заголовка

Свернуть приложение

В меню PNA нажмите Обзор / Минимизировать приложение (View / Minimize Application), чтобы свернуть приложение PNA до строки задач Windows.

Чтобы восстановить приложение PNA:

  • Щелкните по приложению PNA в строке задач Windows

  • Или нажмите [image] на передней панели.


Копирование каналов

Вы можете копировать настройки существующего канала для нового или другого существующего канала.

  • Зачем копировать каналы

  • Способ копирования каналов

  • Перечень настроек канала

Другие разделы по настройке измерений

Зачем копировать каналы

Копируйте настройки каналов, если хотите создать несколько каналов с незначительно отличающимися настройками.

FНапример, у вас есть усилитель, который вы хотите характеризовать в диапазоне частот с несколькими отличающимися уровнями входной мощности.

Выполните следующие действия:

  1. Создайте одно измерение с оптимизированными настройками канала.

  2. Скопируйте этот канал на новые каналы.

  3. Измените уровень мощности новых каналов.

Альтернатива копированию каналов – это создание новых заданных по умолчанию измерений для новых каналов. Затем надо изменить настройку каждого канала в соответствии с вашими новыми требованиями. Это занимает много времени и демонстрирует преимущество функции копирования каналов.

Способ копирования каналов

Более подробно см. интерфейс передней панели

Copy Channel (Копирование канала) справка по диалоговому окну

Копирует настройки существующего канала на другой канал.

Copy channel: Выбрать канал для копирования.

to: Прокрутить, чтобы выбрать канал, на который будут копироваться настройки. Номера каналов, которые используются в данный момент, подсвечены. Их можно выделить и перезаписать.

Примечания:

  • Вы можете копировать настройки канала ТОЛЬКО на один новый или существующий канал. Повторяйте данную операцию, чтобы копировать на более чем один канал.

  • Новый канал ВСЕГДА копируется в активное окно. Если вы хотите, чтобы новый канал находился в собственном окне, сначала создайте новое измерение в новом окне. Перед копированием канала в окно убедитесь, что это активное окно.

  • Измерение в новом канале становится активным измерением.

  • Копируются только настройки канала. График измерения НЕ копируется на новый канал.

    • Если для канала, на который проводится копирование, уже существуют измерения, они не изменятся, а будут считаться с новыми настройками канала.

    • Если выполняется копирование НОВОГО канала, то для просмотра настроек канала создается измерение S11.

Например:

  1. Существующий канал 1: Измерение S21

  2. Скопируйте канал 1 на НОВЫЙ канал 2

  3. Результат: канал 2: измерение S11 со скопированными настройками канала 1. Оба измерения находятся в одном окне. Измерение S11 – активное измерение.

За дополнительной информацией обращайтесь к Графики, каналы и окна PNA

Перечень настроек канала

  • Диапазон частот

  • Мощность

  • Использование Cal Set

  • Данные калибровки мощности источника

  • Полоса ПЧ

  • Количество точек

  • Настройки свипирования

  • Усреднение

  • Запуск (некоторые настройки)


Динамический диапазон

Динамический диапазон – это разница между максимальной мощностью на входе приемника анализатора и минимальной измеряемой мощностью (уровень шума). Для того чтобы измерения были достоверными, входные сигналы должно быть в этих пределах.

Увеличение динамического диапазона важно, если нужно измерить очень большие изменения в амплитуде сигнала, такие как полоса пропускания фильтра и подавление. Ниже показан динамический диапазон в качестве примера измерения.

Чтобы помочь уменьшить погрешности измерения, динамический диапазон анализатора должен быть больше, чем отклик тестируемого устройства. Например, точность измерения увеличивается, если отклик тестируемого устройства хотя бы на 10 дБ выше уровня шума. Следующие методы могут помочь увеличить динамический диапазон.

  • Увеличение мощности на входе устройства

  • Уменьшение уровня шума приемника

  • Использование перемычек на передней панели (если в анализаторе есть конфигурируемый измерительный пульт (Configurable Test Set))

Другие разделы по оптимизации измерений

Увеличение мощности на входе устройства

Увеличьте входную мощность тестируемого устройства, чтобы анализатор мог более точно обнаруживать и измерять выходную мощность. Однако будьте осторожны – слишком высокая мощность может повредить приемник анализатора или вызвать нелинейные искажения.

Внимание! Уровень повреждения входа приемника: +15 dBm.

Чтобы увеличить мощность на входе устройства:

  1. В меню Channel нажать Power

  2. Установить флажок Power On.

  3. Под Port Selection, выбрать порт, который будет использован в качестве выхода источника.

  4. В поле Test Port Power ввести значение или нажать кнопку со стрелкой, чтобы выбрать нужное значение.

  5. 5. Нажать OK.

Совет: Можно еще больше увеличить динамический диапазон, используя внешний усилитель для увеличения мощности на входе тестируемого устройства. См. Измерения с усилителем большой мощности.

Уменьшение уровня шума приемника

Можно использовать следующие техники для понижения уровня шума и увеличения динамического диапазона анализатора.

  • • Уменьшить перекрестные помехи между приемниками анализатора PNA при измерении сигналов близких к уровню шума. (См. Перекрестные помехи в приемнике.)

  • Использовать Усреднение Свипирования - для более подробной информации см. Усреднение свипирования

  • Уменьшить Полосу ПЧ - для более подробной информации см. Полоса ПЧ.

  • В режиме Сегментированное свипирование каждый сегмент может иметь свою полосу ПЧ. Например, при измерении фильтра:

    • В полосе пропускания полоса ПЧ может устанавливаться более широкой для быстрого свипирования, до тех пор, пока высокоуровневый шум графика остается достаточно малым.

    • В полосе подавления, где уровень шума вносит большой вклад в ошибку измерения, полоса ПЧ может устанавливаться достаточно узкой, чтобы достичь желаемого снижения среднего уровня шума.

Использование перемычек на передней панели (если в анализаторе есть конфигурируемый измерительный пульт)

Если в анализаторе PNA есть ЧЕТЫРЕ перемычки на передней панели, можно обойти ответвители тестового порта и подавать сигнал прямо на приемники. См. Динамический диапазон – 4 перемычки. Используя эту конфигурацию, можно достичь динамического диапазона в 143 дБ с калибровкой частотной неравномерности, используя режим сегментированного свипирования.

Если анализатор серии PNA имеет БОЛЕЕ ЧЕТЫРЕХ перемычек на передней панели (Конфигурируемый измерительный пульт), можно использовать перемычки на передней панели, чтобы изменить направление ответвителя измерительного порта. См. Динамический диапазон - опция Конфигурируемый измерительный пульт. Используя эту конфигурацию, можно достичь динамического диапазона в 143 дБ с Полной 2-портовой калибровкой, используя режим сегментированного свипирования.

Примечание: Обход направленного ответвителя порта увеличивает рассогласование порта приблизительно на 15 дБ (коэффициент связи направленного ответвителя).

  • Информацию о модернизации PNA передней панелью с перемычками см. в разделе опции PNA.

  • Узнайте больше о возможностях измерения с использованием перемычек на передней панели.


Динамический диапазон - 4 перемычки

Улучшение динамического диапазона с ЧЕТЫРЬМЯ перемычками на передней панели

Чтобы улучшить динамический диапазон, можно обойти ответвитель измерительного порта и подавать сигнал прямо на приемник. Как показано на схеме ниже, сигнал подается на коннектор перемычки передней панели B In или Rcvr B In, а не на порт 2. Используя эту конфигурацию, можно достичь динамического диапазона до 143 дБ с калибровкой частотной неравномерности, используя режим сегментированного свипирования.

Исследуйте схему с помощью мыши.

Note: В Вашем анализаторе может не быть перемычек передней панели или компонентов, показанных на данной схеме.


Динамический диапазон - опция измерительного пульта

Улучшение динамического диапазона с опцией Конфигурируемый измерительный пульт

Чтобы улучшить динамический диапазон, можно изменить направление пути прохождения сигнала в ответвителе измерительного порта и избежать потерь, обычно связываемых с плечом ответвителя. Как показано на схеме ниже, сигнал подается на порт 2. Сигнал обходит плечо ответвителя через кабель-перемычку, подсоединенный к портам ответвителя (Coupler Thru (или Coupler In)) и приемника (Receiver B In (или B In)). Используя эту конфигурацию, можно увеличить динамический диапазон прямого измерения до 143 дБ с полной 2-портовой калибровкой, используя режим сегментированного свипирования. При проведении измерений с 2-портовой коррекцией погрешности обратное измерение ухудшается на 15 дБ, с динамическим диапазоном до 113 дБ.

Исследуйте схему с помощью мыши.

Примечание: Функциональная схема Вашего анализатора может содержать компоненты, отличные от показанных ниже.


Количество точек

Точка данных или "точка" - это выборка данных, представляющая измерение для одного значения стимулирующего сигнала. Можно определить количество точек, которые измеряет анализатор за одно свипирование, ("свипирование" - серия последовательных измерений точек, соответствующих ряду значений стимулирующих сигналов).

Время свипирования анализатора PNA изменяется пропорционально количеству точек. Однако, общий цикл измерения – нет. Для более подробной информации о том, как влияет количество точек и другие параметры на время свипирования, см. Техническая спецификация.

Примечание: При увеличении количества точек, графиков и калибровочных векторов погрешности (полная 2-портовая или 3-портовая), скорость обработки компьютера может очень сильно снизиться. Если это случится, можно увеличить количество оперативной памяти (RAM) с помощью Опции 022 PNA.

Значение по умолчанию – 201 точка за одну развертку.

Д ругие разделы по оптимизации измерений

Советы:

  • Чтобы получить наибольшее разрешение графика используйте максимальное количество точек.

  • Чтобы получить большую производительность используйте минимальное количество точек, позволяющее получить приемлемую точность.

  • Чтобы определить оптимальное количество точек, ищите значение, при котором получается небольшая разница в измерениях при увеличении количества точек.

  • Для точной калибровки измерения производите калибровку с таким же количеством точек, которое будет использовано для измерения.

Как изменить количество точек

Используйте один из следующих методов:

Выберите количество или нажмите Custom для вызова диалогового окна

  • +

Для более подробной информации см. интерфейс передней панели

Количество точек справка по диалоговому окну

Определяет количество точек, которые собирает анализатор за одну развертку.

Можно установить любое количество: от 2 до 16001.

Значение по умолчанию – 201.


Точность измерения фазы

Можно увеличить точность измерений фазы, используя следующие возможности PNA.

  • Э лектромагнитная задержка

  • Расширения порта

  • Сдвиг фаз

  • Расстояние между точками частоты (наложение спектров)

Более подробно об измерении фаз

Электромагнитная задержка

Электромагнитная задержка – математическая функция, которая моделирует переменную длину линии передачи без потерь.

Используйте электромагнитную задержку для компенсации линейного сдвига по фазе в устройстве. Эта функциональность позволяет видеть только отклонение от линейной фазы устройства.

Можно установить электромагнитную задержку независимо для каждого измерительного графика.

Как установить электромагнитную задержку

Более подробно см. интерфейс передней панели

Электромагнитная задержка – справка по диалоговому окну

Электромагнитная задержка определяет значение задержки, добавленной или удаленной, в единицах времени. Это компенсирует линейный сдвиг по фазе в устройстве. Можно установить электромагнитную задержку независимо для каждого измерительного графика.

Коэффициент укорочения определяет относительную скорость в среде устройства. Значение для полиэтиленового диэлектрического кабеля – 0.66 и 0.7 для фторопластового диэлектрика.

Среда

Coax Выберите Coax, если добавленная длина коаксиальная. Также определите коэффициент укорочения коаксиального кабеля.

Waveguide Выберите Waveguide, если добавленная длина – длина волны в волноводе. Также определите нижнюю критическую частоту волновода.

Cutoff Freq Нижняя критическая частота волновода.

Более подробно о Электромагнитной задержке (выше)

Расширения порта

Используйте расширения порта чтобы электрически переместить измерительную плоскость отсчета (reference plane) после того, как выполнена калибровка. Это позволяет избежать выполнения следующей калибровки. Следующие два сценария показывают, насколько полезными могут быть расширения порта.

  1. Вы уже выполнили калибровку, после чего решаете, что нужно добавить длину кабеля в конфигурации измерения. Используйте расширения порта, чтобы "сообщить" анализатору о том, что Вы добавили длину кабеля к определенному порту.

  2. 2. Вы не можете выполнить калибровку напрямую на устройстве, поскольку оно находится в испытательном приспособлении. Используйте расширения порта для компенсации временной задержки (сдвига по фазе), вызванной приспособлением.

  • Расширения порта автоматически применяют электромагнитную задержку ко всем измерениям, связанным с определенным портом.

  • Можно добавить электрическую длину к приемникам А и Б, если используются коннекторы прямого доступа приемника на передней панели.

  • Расширения порта НЕ компенсируют потери и рассогласования в кабелях, адаптерах и приспособлениях; только добавленную электрическую длину.

Совет: Для того чтобы знать, достаточно ли добавлено задержки:

    1. Присоедините перемычку вместо устройства.

    2. Подстройте расширение порта, чтобы фазовая характеристика стала плоской.

Примечание: Большинство короткозамкнутых калибровочных стандартов (калибровочных мер) имеют ненулевую задержку. Поэтому, регулировка задержки данным методом приводит к искажению времени задержки, равному двойной задержке на коротком замыкании. Определите смещение задержки калибровочной перемычки, посмотрев определение стандарта.

Как установить расширения порта

Более подробно см. интерфейс передней панели

Расширения порта – справка по диалоговому окну

Port extensions Если отмечен, то применяет функцию расширения порта к определенному порту или портам.

Input A Определяет расстояние, на котором находится плоскость отсчета для Входа A.

Input B Определяет расстояние, на котором находится плоскость отсчета для Входа B.

Port 1 Определяет расстояние, на котором находится плоскость отсчета для Порта 1.

Port 2 Определяет расстояние, на котором находится плоскость отсчета для Порта 2.

Velocity Factor Определяет коэффициент укорочения, который применяется к среде устройства, вставленного после калибровки измерения. Значение для полиэтиленового диэлектрического кабеля – 0.66 и 0.7 для фторопластового диэлектрика. 1 0 соответствует скорости света в вакууме.

Более подробно о Расширениях порта (выше)

Сдвиг фазы

Сдвиг ф азы математически корректирует измерение фазы на определенную величину, до 360°. Используйте эту функцию следующим образом:

  • Улучшение отображения измерения фазы. Это подобно изменению начального уровня при измерении амплитуды. Переместите фазовую характеристику в центр или выровняйте ее на экране.

  • Эмулирование предполагаемого сдвига фазы в измерениях. Например, если Вы знаете, что нужно добавить кабель, и что длина этого кабеля добавит определенный сдвиг по фазе в измерениях, можно использовать сдвиг фаз для добавления этой величины и моделирования полного измерения устройства.

Как установить сдвиг фазы

Более подробно о интерфейсе передней панели

Сдвиг фазы – справка по диалоговому окну

Phase Offset Введите значение или используйте стрелки "вверх" - "вниз" для выбора любой величины до 360 градусов.

Более подробно см. Сдвиг фазы (выше)

Расстояние между точками частоты (наложение спектров)

Анализатор замеряет данные в дискретных точках (на отдельных частотах), потом соединяет точки, создавая на экране график.

Если сдвиг фазы в устройстве больше 180° между точками на соседних частотах, то график может выглядеть так, будто фаза имеет обратный наклон. Это происходит потому, что частота выборки данных недостаточна и происходит наложение спектров.

Если измеряется групповая задержка и наклон фазы обратный, тогда групповая задержка поменяет знак. Например, на следующем графике показано измерение полосового фильтра на ПАВ.

  • Измерение слева имеет 51 точку и указывает, что групповая задержка отрицательная, что физически невозможно. То есть, отклик ниже начальной линии 0 сек.

  • На измерении справа показано увеличение до 201 точки, при этом видно, что групповая задержка положительная. То есть, отклик выше начальной линии 0 сек.

Совет: Чтобы проверить, может ли случиться наложение спектров при измерении, необходимо увеличить количество точек или уменьшить диапазон частот.


Электрически длинные устройства

Измерения электрически длинных устройств

Сигнал, выходящий из тестируемого устройства, может не быть точно таким же по частоте, как сигнал, входящий в устройство в данный момент времени. Иногда это может привести к неточным результатам измерения. Можно выбрать одну из двух техник для устранения такой ситуации и увеличения точности измерения.

  • П очему задержка в устройстве может привести к неточностям измерения

  • Способы увеличения точности измерений

    • Замедление скорости свипирования

    • Добавление электрической длины к каналу R

Другие разделы по оптимизации измерений

Почему задержка в устройстве может привести к неточностям измерения

На следующем рисунке представлен пример данной ситуации:

  • В анализаторе цепей источник (source) и приемник (receiver) – синхронизированы по фазе, и развертываются в диапазоне частот одновременно.

  • Прохождение сигнала через тестируемое устройство (DUT) показано разными цветами для разных частот.

  • Можно увидеть, как входной сигнал одной частоты проходит через тестируемое устройство, и анализатор настраивается на новую частоту прямо перед тем, как сигнал поступает в приемник. Это вызывает неточности в измерениях.

.

Если анализатор измеряет длинный кабель, то частота сигнала в конце кабеля отстает от частоты источника анализатора. Если сдвиг частоты ощутим по сравнению с шириной полосы обнаружения ПЧ анализатора (обычно несколько Кгц), тогда измеренный результат будет неправильным из-за спада фильтра промежуточной частоты.

Примечание: Нет фиксированной электрической длины устройства, где это происходит. Это случается из-за того, что есть много переменных, которые влияют на скорость измерения. Если важна высокая точность измерения, то уменьшайте скорость свипирования до тех пор, пока результаты измерений не будут больше меняться.

Способы увеличения точности измерений

Выберите один из следующих методов для компенсации временной задержки электрически длинных устройств.

  • Замедление скорости свипирования

  • Добавление электрической длины к каналу R

Замедление скорости свипирования

Следующие методы уменьшают скорость свипирования.

  • Увеличение времени свипирования

  • Увеличение количества точек

  • Использование пошагового свипирования

  • Установление времени задержки срабатывания

Добавление электрической длины к каналу R

Примечание: Этот метод применяется к моделям анализаторов PNA со шлейфами на передней панели.

Вместо замедления свипирования можно компенсировать электрическую длину кабеля или приспособления.

  1. Удалите перемычку на передней панели анализатора.

  2. Замените перемычку кабелем приблизительной такой же длины, как и тестируемое устройство.

    1. Добавьте кабель на канал R1 для измерений S11 и S21.
    2. 2. Добавьте кабель на канал R2 для измерений S22 и S12.
  3. Настройте анализатор на быстрое свипирование.

Конфигурация для измерений S22 и S12

Этот метод балансирует задержки в опорном и измерительном путях прохождения сигналов, чтобы в относительных измерениях передачи не было ошибки сдвига частоты.

Примечание: Этот метод хорошо работает, если есть задержка в кабеле или приспособлении. Для устройств с большими задержками этот метод подходит только для некалиброванных измерений.


Точность отражения

Точность отражения для 2-портовых устройств с малыми потерями

Для точных измерений отражения, которые имеют 1-портовую калибровку, необходимо установить на не участвующий в измерении порт согласующий терминатор.

  • Зачем согласовывать не измеряемый порт

  • Как согласовать не измеряемый порт

  • Результирующая погрешность измерения

Другие разделы по оптимизации измерений

Зачем согласовывать не измеряемый порт

2-портовая калибровка делает поправку на все 12 компонент вектора погрешностей. 1-портовая калибровка делает поправку на направленность, согласование в источнике и для частотной неравномерности, но не на согласование в нагрузке. Поэтому, для самой высокой точности необходимо, чтобы погрешность согласования в нагрузке была как можно меньше. Это особенно применимо для двусторонних устройств с малыми потерями, таких как полосовые фильтры и кабели. Если же измеряется устройство с высокой развязкой, такое как усилитель, то не стоит беспокоиться о согласовании в нагрузке.

Как согласовать не измеряемый порт

Используйте один из следующих методов:

  • Подсоедините высококачественную оконечную нагрузку (load) (с набора калибровки, например) к не измеряемому порту устройства (test device). С помощью этой техники достигается точность измерения близкая к полной 2-портовой калибровке SOLT.

  • Подсоедините не измеряемый порт устройства прямо к анализатору, вставив прецизионный аттенюатор 10 дБ между выходом устройства и анализатором. Это улучшает эффективное согласование нагрузок анализатора приблизительно в два уровня ослабления аттенюатора, или 20 дБ.

Результирующая погрешность измерения

На следующем рисунке показана погрешность измерения, которая является результатом терминирования с и без прецизионного аттенюатора 10 дБ на выходе из тестируемого устройства.

Обозначения

 | Отражение фильтра
------------- | Погрешность с аттенюатором
................ | Погрешность без аттенюатора

Расчеты ниже показывают, как добавление высококачественного аттенюатора 10дБ улучшает согласование нагрузок анализатора.

Примечание: Соответствующее линейное значение показано в круглых скобках.

Анализатор цепей: |
Согласование в нагрузке (NALM) | = 18 dB (.126)
Направленность (NAD) | = 40 db (.010)
Фильтр: |
Вносимые потери (FIL) | = 1dB (.891)
Обратные потери (FRL) | = 16 dB (.158)
Аттенюатор: |
Вносимые потери (AIL) | = 10 dB (.316)
SWR (ASWR) | = 1.05 (.024) 32.26 dB Обратные потери

Расчеты:

 | Без аттенюатора | С аттенюатором
r NA | = (F IL)*(NA LM)*(F IL) = (.891)*(.126)*(.891) =.100 | = (F IL)*(AIL)*(NA LM)*(AIL)*(F IL) = (.891)*(.316)*(.126)*(.316)*(.891) = .010
r Аттенюатор | NA | = (F IL)*(ASWR)*(F IL) = (.891)*(.126)*(.891) = .019
Наихудший вариант (EWC) | = r NA =.1 | = r NA + rAttn. =.01+.019 =.029
Погрешность добавление | = -20log(FRL)+(EWC)+(NAD) = -20log(.158)+(.100)+(.010) = 11.4 dB | = -20log(FRL)+(EWC)+(NAD) = -20log(.158)+(.029)+(.010) = 14.1 dB
Погрешность вычитание | = -20log(FRL)-(EWC)-(NAD) =-20log(.158)-(.100)-(.010) = 26.4 dB | = -20log(FRL)-(EWC)-(NAD) = -20log(.158)-(.029)-(.010) = 18.5 dB


Стабильность измерений

Существует несколько моментов, которые могут вызвать нестабильность измерений. Чтобы убедиться, что Вы производите повторяющиеся измерения, можно использовать различные методы для создания стабильной среды измерений.

  • Дрейф частоты

  • Дрейф температуры

  • Неточные калибровки измерения

  • Соединения устройств

Другие разделы по оптимизации измерений

Дрейф частоты

Точность частоты анализатора основывается на генераторе внутренней частоты 10 МГц. Характеристики стабильности и старения смотрите в Технических спецификациях.

Если измерение требует большей точности и стабильности частоты, можно заменить стандарт внутренней частоты собственным стабильным внешним источником частоты через 10 МГц опорный входной разъем на задней панели.

Дрейф температуры

Тепловое расширение и сжатие изменяет электрические характеристики следующих компонентов:

  • Устройства в анализаторе

  • Комплекты калибровочных мер (стандартов)

  • Измерительные приборы

  • Кабели

  • Адаптеры

Чтобы уменьшить влияние температурного дрейфа на измерения, выполните следующее.

  • Включите анализатор за полчаса до выполнения калибровки измерения или измерения устройства.

  • За час до выполнения калибровки измерения откройте набор инструментов для калибровки и достаньте эталоны из пенопласта.

  • Используйте среду, где контролируется температура. Все спецификации и характеристики применимы при температуре 25 °C ±5 °C (если не указана другая температура).

  • Удостоверьтесь в стабильности температуры устройств калибровки.

  • Избегайте ненужного обращения с устройствами из калибровочного набора в процессе калибровки.

  • Удостоверьтесь, что температура окружающей среды равна ±1°C температуры калибровки измерения.

Неточные калибровки измерения

Если калибровка измерения неточная, Вы не сможете измерить точную характеристику тестируемого устройства. Чтобы удостовериться, что калибровка точная, рассмотрите следующие пункты:

  • Выполняйте калибровку измерения в точках, где подсоединяется тестируемое устройство, то есть на плоскости отсчета.

  • Если Вы добавили дополнительное устройство (кабель, адаптер, аттенюатор) к схеме проверки после выполнения калибровки измерения, используйте функцию расширений порта для компенсации добавленной электрической длины и задержки.

  • Используйте калибровочные меры, которые соответствуют определениям, использованными во время процесса калибровки.

  • • Проверяйте и чистите коннекторы. См. Уход за коннекторами.

Более подробно см. Точная калибровка измерений.

Соединения устройств

Хорошие соединения необходимы для повторяемости измерений. Чтобы сделать хорошие соединения, выполните следующее:

  • Проверяйте и чистите соединители для всех компонентов в измерительной установке.

  • Используйте правильную технику соединения.

  • Избегайте перемещения кабелей при измерении.


Шум графика

Техники снижения шума

Случайный электрический шум, который появляется в приемнике анализатора, может снижать точность измерения. Следующие функции анализатора помогают уменьшить шум графика (trace noise) и минимальный уровень шума (noise floor), что может улучшить динамический диапазон и дать более точные измерения.

Примечание: шум графика в микроволновых анализаторах серии PNA ухудшается ниже 748 МГц и особенно очевиден в диапазоне 10 – 45 МГц. См. Уменьшение полосы ПЧ (IFBW).

  • Усреднение свипирования

  • Полоса ПЧ

  • Сглаживание графика

Более подробно об улучшении этих важных параметров см. Увеличение динамического диапазона.

Другие разделы по оптимизации измерений

Усреднение свипирования

Усреднение свипирования – это способ, который уменьшает влияние случайных помех на измерение. Анализатор PNA рассчитывает каждую точку, основываясь на среднем значении точки за несколько последовательных свипирований. Количество последовательных разверток определяется установкой коэффициента усреднения. Чем больше коэффициент усреднения, тем больше снижение шума.

  • Когда усреднение ВКЛЮЧЕНО, на экране появляется Счетчик усреднения, который показывает количество усредненных свипирований. Влияние на график сигнала видно при увеличении коэффициента усреднения. Это может помочь при выборе оптимального количества усреднений свипирования.

  • Усреднение применяется ко всем измерениям в канале. Счетчик усреднения показывается для каждого канала.

  • Хотя можно усреднить абсолютные (один приемник) измерения, при этом можно получить неожиданные результаты:

    • Результаты измерения фазы могут стремиться к нулю. Это случается из-за того, что измерения фазы относительны по своей природе. Измерение абсолютной фазы одним приемником является случайным. Усреднение случайных положительных и отрицательных чисел будет стремиться к нулю.

    • Минимальный уровень шума, если усреднять абсолютные измерения, не падает так, как при усреднении относительных измерений.

  • Используйте усреднение и полосу ПЧ для общего снижения шума. Для минимизации очень малого шума использование усреднения эффективнее, чем уменьшение полосы пропускания системы. Обычно усреднение занимает больше времени, чем снижение полосы ПЧ для уменьшения шума, особенно, если требуется много усреднений.

  • • Пока PNA НЕ имеет функции "усреднения в точке ("point-averaging") как у анализатора Agilent 8510 . Эта функция измеряет и усредняет каждую точку ПЕРЕД переходом к следующей точке. Поэтому, все точки усредняются в одном, более медленном свипировании. Чтобы достичь подобных результатов с помощью анализатора серии PNA, попробуйте произвести уменьшение полосы ПЧ.

Влияние усреднения свипирования

Как установить усреднение

Используйте один из следующих методов:

  • +

Более подробно см. Интерфейс передней панели

Average справка по диалоговому окну

Average ON
Выбрано – Усреднение применяется
Сброшено - Усреднение НЕ применяется

Average Factor (Коэффициент усреднения) определяет количество свипирований, которые усредняются. Диапазон от 1 до 1024.

Restart Начинает новую серию измерений, которые используются для усреднения. Эта серия измерений равна коэффициенту усреднения.

Более подробно см. Усреднение (выше)

Полоса ПЧ

Анализатор PNA преобразовывает полученный из источника сигнал в сигнал промежуточной частоты. Полоса пропускания фильтра ПЧ устанавливается от 40 МГц (для большинства моделей серии PNA) до 1Гц.

Уменьшение полосы пропускания ПЧ уменьшает влияние случайного шума на измерение. Каждое десятикратное уменьшение полосы ПЧ снижает уровень шума на 10 дБ. Однако более узкая полоса ПЧ увеличивает время свипирования.

Можно установить полосу ПЧ отдельно для каждого канала или сегмента сегментированного свипирования.

Влияние уменьшения полосы ПЧ

Как установить полосу ПЧ

Более подробно см. Интерфейс передней панели

IF Bandwidth справка по диалоговому окну

IF Bandwidth (Полоса ПЧ) – определяет полосу ПЧ приемника. Значение полосы ПЧ выбирается прокруткой из всех доступных значений в текстовом окне IF bandwidth. Полоса ПЧ устанавливается отдельно для каждого канала.

Перечень значений полосы ПЧ зависит от модели анализатора PNA.

Следующие значения одинаковы для всех моделей:

  • 1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1000 | 1500 | 2000 | 3000 | 5000 | 7000 | 10000 | 15000 | 20000 | 30000

Кроме того, следующие значения зависят от модели анализатора серии PNA:

  • N5230A: 50000 | 70000 | 100000 | 150000| 200000 | 250000

  • Все другие анализаторы PNA: 35000 | 40000 |

Reduce IF BW at Low Frequencies (Уменьшить полосу ПЧ на низких частотах)

В моделях PNA с максимальной частотой 20 ГГц и выше, шум графика становится хуже при частоте ниже 748 МГц. Это особенно видно в диапазоне между 10 – 45 МГц, а также, когда включены измерения во временной области (Time Domain). См. модели PNA/ максимальные частоты.

Если флажок установлен, то анализатор PNA на частотах ниже 748 МГц использует меньшую полосу ПЧ, чем выбранное значение.

Эта настройка:

  • может производиться для каждого канала.

  • включена (установлена) по умолчанию.

  • также применяется к сегментированному свипированию.

Используйте следующие расчеты для определения фактического значения полосы ПЧ, которое используется при частоте ниже 748 МГц.

Если результат НЕ является выбираемой величиной полосы ПЧ, используется следующее, более высокое выбираемое значение.

 | От 10 МГц до 44.999999 МГц | от 45 МГц до 748 МГц
Модели меньше 20 ГГц: | Неприменимо | Неприменимо
ВСЕ 2-портовые модели PNA 20 ГГц*: | Фактическая полоса ПЧ = (выбранная полоса ПЧ) x (.05) | Фактическая полоса ПЧ = выбранная полоса ПЧ (Без уменьшения)
ВСЕ модели 40ГГц и выше: | Фактическая полоса ПЧ = (выбранная полоса ПЧ) x (.025) | Фактическая полоса ПЧ = (выбранная полоса ПЧ) x (.5)

*НЕДОСТУПНО на 4-портовых PNA (модели N5230A Opt 240 и 245).

Пример:

В анализаторе 67 ГГц выбранная полоса ПЧ – 30 КГц.

C установленным флажком Reduce IF BW at Low Frequencies фактические полосы ПЧ, которые используются, следующие:

  • От 10 МГц до 44.999999 МГц: 30,000Гц * .025 = 750 Гц (анализатор PNA использует следующее более высокое выбираемое значение: 1000 Гц.)

  • От 45 МГц до 748 МГц: 30,000Гц * .5 = 15 кГц

  • От 748 МГц до остановки свипирования: 30 кГц

OK выбирает значение полосы ПЧ, показанной в текстовом окне.

Более подробно см. Полоса ПЧ (выше)

Сглаживание графика

Сглаживание графика (Trace smoothing) усредняет ряд смежных точек данных для выравнивания отображаемого графика. Количество смежных точек, которые усредняются, также называется апертурой сглаживания (smoothing aperture). Можно определить апертуру, как количество точек или процентную долю диапазона оси Х.

Сглаживание графика уменьшает амплитудные значения шума при широкополосных измерениях. Оно сглаживает шум графика и не сильно увеличивает время измерения.

Советы:

  • Начинайте с большого количества точек и уменьшайте, пока не будете уверены, что график не дает неверных результатов.

  • Не используйте сглаживание для высокорезонансных устройств или устройств с большими изменениями на графике. Это может привести к ошибкам измерения.

  • Можно установить функцию сглаживания отдельно для каждого графика.

Влияние сглаживания на график

Как установить сглаживание графика

Более подробно см. Интерфейс передней панели

Smoothing справка по диалоговому окну

Smoothing ON Если выбрано, то применяется функция сглаживания, которая усредняет данные частей отображаемого графика.

Percent of Span Определяет апертуру сглаживания, как процент от диапазона свипирования стимула. Например, при 401 точке процент от диапазона – между 0.19% и 25%.

Points Определяет апертуру сглаживания, как процент от общего количества точек в диапазоне свипирования стимула.

Более подробно см. Сглаживание графика (выше)


Перекрестные помехи

Перекрестные помехи – это утечка энергии между путями прохождения сигнала анализатора. Это может вызвать проблемы при измерениях передачи с высокими потерями. Однако, можно уменьшить влияние перекрестных помех, выполнив следующее:

  • Установить попеременное свипирование

  • Выполнить калибровку развязки

Другие разделы по оптимизации измерений

Установка попеременного свипирования

При попеременном свипировании измерение проводится только на одном приемнике за одно свипирование. Пока на одном приемнике проводится измерение, анализатор выключает другой приемник. Это помогает уменьшить перекрестные помехи приемника.

Примечание: Можно установить режим попеременного свипирования отдельно для каждого канала измерения. Если используются несколько каналов, то можно установить попеременное свипирование для каждого канала.

  1. В меню Sweep нажать Sweep Setup.

  2. Установить Alternate Sweeps.

  3. Нажать OK.

Советы:

  • Анализатор измеряет отражение (приемник А) и передачу (приемник В) на отдельных свипированиях. Поэтому, когда анализатор выполняет измерение и отражения и передачи, то попеременное свипирование удваивает время цикла свипирования.

  • Для измерения только передачи или только отражения можно использовать попеременное свипирование, чтобы уменьшить влияние перекрестных помех, не влияя при этом на время цикла свипирования.

  • Уровень шума нужно значительно уменьшить, перед тем, как будут видны перекрестные помехи. Может понадобиться использование функции усреднения или сужение полосы ПЧ.

Выполнение калибровки развязки

При измерении передачи калибровка развязки и неравномерности частотной характеристики помогают уменьшить перекрестные помехи, потому что анализатор измеряет, а потом вычитает паразитный сигнал при калибровке измерения. Калибровка улучшает развязку так, что она ограничивается только минимальным уровнем шума.

См. Погрешность развязки чтобы узнать, как можно уменьшить перекрестные помехи с помощью калибровки.

Обычно погрешность развязки находится ниже уровня шума. Поэтому, когда Вы выполняете калибровку развязки, необходимо использовать технику уменьшения шума, например усреднение свипирования или уменьшение полосы ПЧ.


Влияние дополнительных устройств

Дополнительные устройства в конфигурации могут влиять на результаты измерения устройства. Можно выбрать одну из двух функций анализатора, чтобы уменьшить влияние дополнительных устройств.

  • Ф ункция "Power Slope" для компенсации потерь в кабеле

  • Временная селекция для выборочного удаления откликов

Другие разделы по оптимизации измерений

Функция "Power Slope" для компенсации потерь в кабеле

Если у Вас длинный кабель или другое дополнительное устройство в конфигурации измерения, в котором потери увеличиваются с ростом частоты, примените функцию "Power Slope" (наклон мощности). Эта функция увеличивает мощность источника анализатора на величину, которую Вы определите (дБ/ГГц).

  1. В меню Channel нажать Power.

  2. Если функция наклона еще не включена, отметьте Slope.

  3. В окне dB/GHz ввести степень, на которую нужно увеличивать мощность по мере свипирования частоты. Нажать OK.

Временная селекция для выборочного удаления откликов

Временная селекция (Gating) - функция во временной области (опция 010), которая позволяет анализатору математически удалять отклики. Можно установить селекцию отклика как для отражения так и для передачи, но результаты будут разные.

  • Селекция отклика отражения изолирует необходимый отклик (например, обратные потери фильтра) от нежелательных откликов (такие как отражения от адаптера или рассогласования в коннекторах).

  • Селекция отклика передачи изолирует определенное межсоединение в устройстве с несколькими соединениями, которые имеют большую электрическую длину.

Более подробно см. Временная селекция во временной области.


Быстрое свипирование

Поддержание быстрого свипирования – один из аспектов достижения лучшей производительности измерений.. Можно увеличить скорость свипирования в анализаторе, настроив следующие параметры:

  • Установочные параметры свипирования

  • Установочные параметры снижения шума

  • Выбор калибровки измерения

  • Не обязательные функции

Другие разделы по оптимизации измерений

Установочные параметры свипирования

Рассмотрите изменение каждого из установочных параметров, как предложено ниже.

Диапазон частот - измеряйте только частоты, необходимые для Вашего устройства

Сегментированное свипирование - используйте сегменты для сбора данных тестирования только там, где нужно.

Выключение пошагового свипирования - используйте режим линейного свипирования для уменьшения времени свипирования, когда это возможно.

Время авто свипирования - используйте данное значение для как можно более быстрого свипирования при текущих параметрах настройки.

Количество точек - используйте минимальное количество точек, необходимых для измерения.

Для более подробной информации о том, как влияет количество точек и другие параметры на время цикла свипирования см. Техническая спецификация.

Установочные параметры снижения шума

Используя комбинацию этих параметров, можно уменьшить время свипирования, сохраняя при этом приемлемый уровень измерения.

Полоса ПЧ. Используйте самую широкую полосу, которая создаст приемлемый шум графика и динамический диапазон.

Усреднение. Уменьшите коэффициент усреднения или выключите усреднение.

Выбор калибровки измерения

Выберите самый быстрый вид калибровки для необходимого уровня точности.

  • Время свипирования приблизительно одинаковое для некорректированных измерений и измерений, проведенных с использованием калибровки частотной неравномерности или 1-портовой калибровки.

  • Для полной 2-портовой калибровки необходимо и прямое и обратное свипирование, чтобы обновить все четыре S-параметра для коррекции ошибок, даже если отображается один S-параметр.

Более подробно см. Выбор калибровки.

Не обязательные функции

Анализатор должен обновлять информацию для всех активных функций. Чтобы получить дополнительное увеличение скорости свипирования, необходимо выключить все функции анализатора, которые не нужны для измерения.

Удаление нежелательных графиков

  1. Нажать Trace Status, чтобы активизировать ненужный график.

  2. В меню Trace нажать Delete Trace.

Выключение нежелательных маркеров

  1. В меню Marker нажать Select Marker, и нажать на ненужный маркер в списке.

    • Если нужно выключить все маркеры, нажать All Off.

  2. Отобразите панель маркеров: из меню View нажать Toolbars, а потом - Marker.

  3. Убрать флажок с On для выключения маркера.

Выключение сглаживания

  1. В меню Trace нажать Smoothing.

  2. Нажать Smoothing On, чтобы убрать флажок, который включает функцию сглаживания. Нажать OK.

Выключение тестирования по критерию

  1. В меню Trace нажать Limit Test.

  2. Нажать Limit Test ON, чтобы убрать флажок, который включает функцию предельных условий. Нажать OK.

Выключение математических функций

  • В меню Trace указать список Data Math и нажать Data, чтобы видеть только текущий график измерений.

Скорость свипирования анализатора зависит от различных параметров измерений. Поэкспериментируйте с параметрами, чтобы получить быстрое свипирование и необходимые результаты измерений.


Многократные измерения и производительность

Переключение между многократными измерениями

Если необходимо провести многократные измерения для определения характеристик устройства, можно использовать различные методы для увеличения производительности. Поэкспериментируйте с этими методами, чтобы найти наиболее подходящий.

  • Настройка измерений для увеличения производительности

    • Комплексные измерения

    • Использование сегментированного свипирования

    • Выборочный запуск измерений

  • Автоматизация изменений между измерениями

  • Быстрый вызов измерений

Другие разделы по оптимизации измерений

Настройка измерений для увеличения производительности

Для достижения оптимальной пропускной способности устройств, для которых необходимы многократные измерения, нужно знать, как работает анализатор. Это позволит установить наиболее подходящий процесс измерения.

Более подробно о графиках, каналах и Windows в анализаторе PNA

Комплексные измерения

Если Вы организуете измерения для хранения полного набора измерений устройства в одном инструментальном состоянии, то Вы можете сохранить их, чтобы позже вызвать ряд измерений с помощью одной функции вызова.

Более подробно см. Предварительно сконфигурированнуе комлексы измерений.

Использование сегментированного свипирования

Сегментированное свипирование необходимо, если нужно сменить следующие параметры для характеристики тестируемого устройства.

  • Диапазон частот

  • Уровень мощности

  • Полоса ПЧ

  • Количество точек

Благодаря сегментированному свипированию можно определить набор диапазонов частот, которые имеют независимые атрибуты. Это позволяет использовать одно свипирование для измерения устройства с изменяющимися характеристиками.

Более подробно см. Сегментированное свипирование

Выборочный запуск измерений

Запуск измерений можно использовать для выполнения следующих действий:

  • Постоянное обновление только тех измерений, данные которых быстро меняются.

  • Время от времени обновлять измерения, данные которых не часто меняются.

Например, если у Вас четыре канала, настроенных следующим образом:

  • Два канала для измерения данных, которые используются для настройки фильтра

  • Два канала для измерения данных, которые используются для амплитудно-частотной характеристики вне полосы пропускания фильтра

Вы будете постоянно контролировать только данные измерения, которые используются для настройки фильтра. Если постоянно обновлять все четыре канала, это может замедлить реакцию анализатора, и Вы не сможете эффективно настроить фильтр.

Примечание: Измерения, которые проводятся редко, можно запускать вручную или с помощью команд удаленного интерфейса.

Выборочный запуск измерений:

Данная процедура покажет, как настроить два разные измерения со следующим поведением:

  • Измерение канала 1 постоянно обновляет данные.

  • Измерение канала 2 обновляет данные время от времени.

  1. В меню Windows нажать Meas Setups, Setup D.

Установка запуска измерений для постоянных обновлений

  2. В меню Sweep нажать Trigger, Trigger....

  3. Под Trigger Source, нажать Internal.

  4. Под Channel Trigger State, выбрать Channel 1, и нажать Continuous.

Установка запуска измерений для периодических обновлений

  5. Под Channel Trigger State, выбрать Channel 2, нажать Single, OK.

    • o Если нужно, чтобы анализатор запустил более, чем одно свипирование, нажать Enable Groups и ввести количество свипирований.

  6. В меню System нажать Keys, Trigger.

Обновление измерений

  7. Нажать на нижнее окно, чтобы сделать канал 2 активным каналом.

  8. На активной панели нажать тип запуска, который нужно установить.

    • Нажать Single если устанавливается одно свипирование за один запуск.

    • Нажать Groups если устанавливается несколько свипирований за один запуск.

Примечание: График должен быть активным, если необходимо провести запуск измерения.

Автоматизация изменений между измерениями

Если разница между различными измерениями, которые нужны для описания устройства, небольшая, то быстрее будет сменить настройки, используя программирование.

Быстрый вызов измерений

Лучший способ вызвать измерения - вызвать их как набор измерений (инструментальное состояние).

  • Вызвать инструментальное состояние, включающее многократные измерения, занимает чуть больше времени, чем вызвать инструментальное состояние с одним измерением.

  • Каждая функция вызова имеет связанное с ней время. Можно устранить это время, настроив измерения в виде набора, тогда их можно вызывать как набор.

Более подробно см. Сохранение и вызов файлов.


Скорость передачи данных

Быстрая передача данных помогает получить лучшую производительность измерений.. Попробуйте следующие методы для улучшения скорости передачи данных.

  • Используйте режим однократного свипирования, чтобы убедиться, что измерение завершено перед передачей данных.

  1. В меню Sweep нажать Trigger, Trigger....

  2. Под Trigger Source нажать Manual.

  3. Под Channel Trigger State, выбрать канал для измерения, которое нужно передать, и нажать Continuous, OK.

  4. Обновить измерение

    1. В меню System нажать Keys, Trigger

    2. На активной панели инструментов нажать Single

  • Передавайте минимальное количество необходимых данных Например, кривую с несколькими точками, используя сегментированное свипирование, а не весь график с большим количеством линейно расположенных точек. Также вместо пересылок графика используйте маркеры.

  • Выберите формат данных REAL, чтобы обеспечить самую большую скорость передачи, когда используются программы SCPI для автоматических применений.

  • Используйте SCPI по локальной сети для приложений, автоматизированных программами SCPI.

  • Используйте COM-программы, чтобы обеспечить самую большую скорость передачи, когда используется автоматизированное приложение. См. Время передачи данных.


Использование макросов

Макросы - это исполняемые программы, которые вы пишете, загружаете в анализатор, затем запускаете. Для работы в анализаторе можно настроить и запустить до 12 макросов.

  • Настройка макросов

  • Запуск макросов

  • Пример макроса

Настройка макросов

Для доступа к диалоговому окну Macro Setup (Настройка макроса) пользуйтесь одним из следующих методов:

  2. +

В диалоговом окне Macro Setup:

  1. Щелкните по пустой строке под последней записью. (Возможно, записи НЕ будет.)

  2. Нажмите Edit (Редактировать)

  3. В поле Macro Title (Заголовок макроса) введите описательное название макроса.

  4. Нажмите Browse (Просмотр).

  5. Измените Files of Type (файлы типа)

  6. Найдите свой файл макроса и щелкните по нему

  7. Нажмите OK

  8. Нажмите OK в диалоговом окне Macro Setup.

Изучите дополнительную информацию об использовании интерфейса передней панели

Macro Setup, справка по диалоговому окну

Дает возможность создавать набор из 12 макросов, таким образом, вы можете запускать другие программы в пределах приложения PNA.

Для того чтобы добавить макрос, выберите пустую линию, затем нажмите Edit

Macro Title (Заголовок макроса) При нажатии кнопки Macro отображаются заголовки, появляющиеся в поле активной записи панели инструментов. Эти заголовки связаны с исполняемыми файлами и должны быть описательными, тогда вы с легкостью сможете идентифицировать файлы. Например, если вы хотите запустить главную страницу Agilent, исполняемому файлу можно дать заголовок "Agilent Home."

Macro Executable (Исполняемый макрос) Указывает полный путь к исполняемому файлу. Чтобы выполнить пример запуска главной страницы для PNA серии Agilent, необходимо указать следующий путь к исполняемому файлу "C:\Program Files\Internet Explorer\iexplore.exe.

Macro Runstring Parameters (Параметры строки запуска макроса) Перечислены параметры перехода к программе, связанной с исполняемым файлом. Чтобы снова выполнить пример запуска главной страницы для PNA, можно назначить следующие параметры строки запуска "http://www.agilent.com/find/pna".

Edit (Редактировать) Вызывает диалоговое окно Macro Edit.

Delete (Удалить) Удаление выбранного макроса.

Up (Вверх) Дает возможность изменить порядок макросов, перемещая выбранный макрос на одну строку вверх. При нажатии кнопки Macro обозначается порядок появления 12 возможных макросов (12 строк) в поле активной записи панели инструментов. Поскольку в один момент времени на панели инструментов может отображаться четыре заголовка, то при повторном нажатии кнопки Macro на панели инструментов появится следующий набор из четырех заголовков макросов.

Down (Вниз) Перемещение выбранного макроса на одну строку вниз в списке макросов.

Macro Edit, справка по диалоговому окну

Macro Title (Заголовок макроса) Дает возможность модифицировать заголовок, появляющийся в поле активной записи панели инструментов.

Macro Executable (Исполняемый макрос) Дает возможность изменить полный путь к файлу исполняемого макроса.

Browse (Просмотр) Дает возможность просматривать диски и каталоги, чтобы найти исполняемый макрос и установить полный путь к файлу.

Macro run string parameters (Параметры строки запуска макроса) Дает возможность модифицировать параметры перехода к программе, связанной с исполняемым файлом.

Смотрите Диалоговое окно Macro Setup

Запуск макросов

Для запуска макроса пользуйтесь одним из следующих методов:

    1. Нажимайте, пока не появится ваш макрос, затем

    2. Выберите макрос

Изучите дополнительную информацию об использовании интерфейса передней панели

Пример макроса

Далее представлен пример программы Visual Basic Scripting (vbs), которую вы можете скопировать, установить и запустить на своем PNA

Примечание: распечатайте эти инструкции, если работаете с анализатором. Данная тема будет рассмотрена в разделе Диалоговое окно Macro Setup.

  1. Скопируйте следующий код в файл Notepad (блокнот).

  2. Сохраните файл на жестком диске анализатора в папку C:\Documents. Назовите файл FilterTest.vbs

  3. Закройте Notepad

  4. Настройте макрос в PNA

  5. Запустите макрос

Notepad - это текстовый редактор, установленный на всех компьютерах, использующих операционную систему Microsoft. Для запуска Notepad на анализаторе:

  1. Нажмите View (Обзор), затем нажмите Title Bars (Строки заголовков)

  2. Нажмите кнопку Start на панели задач в окне

  3. Перейдите к Programs (Программы), Accessories (Стандартные).

  4. Щелкните по Notepad

'Начинайте копирование здесь
'Данная программа создает измерение S21 с полосой пропускания
'маркеры для тестирования полосового фильтра 175MHz
'Программа написана на VBscript с использованием команд COM

Set PNA = CreateObject("AgilentPNA835x.Application")
PNA.Preset
Set chan=PNA.activechannel
Set meas=PNA.activemeasurement
Set limts = meas.LimitTest
Set trce = PNA.ActiveNAWindow.ActiveTrace

meas.ChangeParameter "S21",1
chan.StartFrequency = 45e6
chan.StopFrequency = 500e6
trce.ReferencePosition = 8
PNA.TriggerSignal = 3

'Do Test
for t=1 to 5
call measure
call compare
next
msgbox("Done Testing")

sub measure
msgbox("Connect Device " & t & " and press OK")
PNA.ManualTrigger True
meas.SearchFilterBandwidth
end sub

sub compare
BW = meas.FilterBW
if bw>6.5e7 then msgbox("Failed BW: " & BW)
Loss = meas.FilterLoss
if loss>5 then msgbox("Failed Loss: " & Loss)
end sub
'End copying here


Обзор калибровки

В этом разделе обсуждаются следующие темы:

  • Что такое калибровка измерений?

  • Почему калибровка необходима?

  • Условия, в которых рекомендуется калибровка

  • Что такое ECal?

Другие разделы по калибровке

Что такое калибровка измерений?

Калибровка устраняет одну или более систематическую погрешность с помощью уравнения, называемого моделью погрешности. Измерения с высокими стандартами качества (например, по КЗ, ХХ, согласованной нагрузке или перемычке) позволяют анализатору найти члены погрешностей в модели погрешности. См. Погрешности измерений.

Можно выбирать различные типы калибровки в зависимости от вида выполняемого измерения и требуемой точности. См. Выбор типа калибровки.

Точность калиброванных измерений зависит от качества используемых мер калибровочных комплектов, а также точности, с которой меры определены (смоделированы) в файле калибровочного комплекта. Файл калибровочного комплекта сохраняется в анализаторе. Для обеспечения точности измерений файл калибровочного комплекта должен соответствовать реально используемому комплекту. Для дополнительной информации см. Точная калибровка.

Мастер калибровки предоставляет доступ к различным методам калибровки, используемым анализатором. См. Мастер калибровки.

Следующий перечень быстрых проверок позволяет убедиться в точности калибровки измерений. Для дополнительной информации см. Проверка действительности калибровки измерения

При создании собственных специальных мер калибровки (например, при измерениях с использованием приспособлений) необходимо охарактеризовать стандарты калибровки и ввести их определения в изменяемый пользователем файл калибровочного комплекта. Для дополнительной информации об изменении файлов калибровочных комплектов, см. Калибровочные стандарты.

Примечание: Калибровка инструмента обеспечивает, что оборудование анализатора функционирует соответственно спецификациям. Это не то же самое, что и калибровка измерений.

Почему калибровка необходима?

Создать совершенное оборудование, для которого не требовалась бы коррекция погрешностей, невозможно.

Кроме того, на точность анализа цепей существенно влияют внешние относительно анализатора цепей факторы. Элементы конфигурации измерения, такие, как кабели подключения и адаптеры, вносят отклонения по величине и фазе, способные скрыть действительную частотную неравномерность проверяемого устройства.

Лучшим вариантом является создание настолько совершенного устройства, насколько это практически возможно, тем самым обеспечивая баланс характеристик и стоимости. В этом случае калибровка является весьма полезным средством улучшения точности измерений.

Условия, в которых рекомендуется калибровка

В общем калибровка рекомендуется для измерений в следующих ситуациях:

  • Необходима максимальная достижимая точность.

  • Выполняется переход на другой тип соединителя или сопротивления.

  • Подключается кабель между проверяемым устройством и измерительным портом анализатора.

  • Производится измерение по широкой полосе частот или электрически протяженному устройству.

  • Ко входу или выходу устройства подключается ослабление(развязка) или другое подобное устройство.

Если конфигурация измерения соответствует любому из указанных выше условий, это может повлиять на следующие характеристики системы:

  • Амплитуду на входе устройства

  • Частотную характеристику

  • Направленность

  • Перекрестные помехи (изоляцию)

  • Согласование в источнике

  • Согласование нагрузки

Что такое ECAL (электронная калибровка)?

ECal - это метод калибровки, полностью реализованный на твердотельной (полупроводниковой) технологии. Она позволяет легко и быстро выполнять 1-портовую калибровку (калибровку отражения), 2-портовую и 3-портовую калибровку. См. Использование ECal.

  • Она менее подвержена ошибкам оператора.

  • Различные меры (находящиеся в калибровочном модуле) никогда не изнашиваются, так как они подключаются с помощью PIN-диодов или полевых транзисторов.

  • Калибровочные модули характеризуются с помощью TRL-калиброванного анализатора цепей.

  • ECal не так точна, как хорошо выполненная TRL-калибровка.

Для информации о заказе модулей ECal см. Аксессуары анализатора , или свяжитесь с вашим представителем поддержки Agilent


Выбор типа калибровки

В этом разделе содержится информация о типах калибровки, реализованных в анализаторе.

Типы калибровки
Калибровка частотной неравномерности по нагрузке ХХ | 1-портовое отражение
Калибровка частотной неравномерности по нагрузке КЗ | Полная 2-портовая SOLT
Калибровка частотной неравномерности по перемычке | Полная 2-портовая TRL
Калибровка частотной неравномерности по перемычке и изоляции | Полная 3-портовая SOLT

Другие разделы по калибровке

Тип: Частотной неравномерности (собственного нуля) по нагрузке ХХ или КЗ

Метод калибровки: Неуправляемая калибровка

Общая точность: От низкой до средней

Параметры: S11 или S22 (S33 на 3-портовом анализаторе)

Требуемые меры: ХХ или КЗ

Корректируемые систематические погрешности:
· Частотная неравномерность собственного ноля отражения

Применение:
· Измерения характеристик отражения на любом из портов.

Тип: Калибровка частотной неравномерности по перемычке

Метод калибровки: Неуправляемая калибровка

Общая точность: Средняя

Параметры: S12 или S21 (S23, S32, S31, S13 на 3-портовом анализаторе)

Требуемые меры: Перемычка

Корректируемые систематические погрешности:
· Частотная характеристика собственного нуля передачи

Применение:
· Измерения передачи в любом одном направлении.

Примечание: Определение перемычки в предопределенном калибровочном комплекте предполагает нулевую длину и отсутствие потерь. При использовании адаптера как перемычки для повышения точности нужно внести характеристику адаптера в калибровочный комплект. См. Точные калибровки

Тип: Калибровка частотной неравномерности по перемычке и изоляции

Метод калибровки: Неуправляемая калибровка

Общая точность: Средняя

Параметры: S11 или S22 (S23, S32, S31, S13 на 3-портовом PNA)

Требуемые меры: Перемычка, несколько идентичных нагрузок (по одной на каждый измерительный порт анализатора)

Корректируемые систематические погрешности:
· Частотная характеристика собственного нуля передачи
· Перекрестные помехи

Применение:
· Используйте лишь для измерений передачи в любом одном направлении.
· Часть калибровки, относящаяся к изоляции, улучшает измерения с широким динамическим диапазоном.

Примечание: Без наличия нескольких идентичных нагрузок (по одной на каждый входной порт анализатора) этот тип калибровки выполнить нельзя.

Тип: 1-портовая (отражение)

Метод калибровки: Неуправляемая калибровка, Управляемая калибровка, ECal

Общая точность: Высокая

Параметры: S11 или S22 (S33 на 3-портовом анализаторе)

Требуемые меры: (КЗ, ХХ, согласованная нагрузка) или модуль ECal

Корректируемые систематические погрешности:
· Направленность • •
· Согласование в источнике
· Собственный ноль отражения

Применение:
· Измерения отражения на любом отдельном порту.

Модели анализаторов: Все

Тип: Полный SOLT (КЗ, ХХ, согласованная нагрузка, перемычка) 2 порта

Общая точность: Высокая

Метод калибровки: Неуправляемая калибровка, Управляемая калибровка, ECal

Параметры: Все

Требуемые меры: (КЗ, ХХ, согласованная нагрузка, перемычка) или модуль ECal

Корректируемые систематические погрешности:
· Направленность
· Согласование источника
· Изоляция
· Согласование нагрузки
· Собственный ноль передачи
· Собственный ноль отражения

Применение:
· Используется для всех измерений S-параметров.

· Коррекция 12 коэффициентов погрешностей

Тип: Полная TRL 2 порта

Только на анализаторах PNA модели E8356A, E8357A, E8358A, E8362A, E8363A, E8364A

Метод калибровки: Неуправляемая калибровка

Общая точность: Очень высокая

Параметры: Все

Требуемые меры: ПЕРЕМЫЧКА, ОТРАЖЕНИЕ, ЛИНИЯ (THRU, REFLECT, LINE)

Корректируемые систематические погрешности:
· Направленность
· Согласование источника
· Изоляция
· Согласование нагрузки
· Собственный нуль отражения
· Собственный нуль передачи

Применение:
· Используется для всех измерений S-параметров.

· Коррекция 12 коэффициентов погрешностей
· Самая точная из всех калибровок

Для дополнительной информации см. Калибровка TRL

Чтобы выполнить калибровку TRL с типом соединителя, отличным от 3.5 мм и 7 мм, необходимо сначала создать или изменить стандарты и определения TRL. Для дополнительной информации об изменении стандартов, см. Калибровочные стандарты.

Тип: Полный SOLT (КЗ, ХХ, согласованная нагрузка, перемычка) 3 порта

Только на анализаторах PNA моделей N3381A, N3382A, N3383A

Общая точность: высокая

Метод калибровки: Управляемая, ECal

Параметры: Все

Требуемые меры: (КЗ, ХХ, согласованная нагрузка, перемычка) или модуль ECal

Корректируемые систематические погрешности:
· Направленность
· Согласование источника
· Изоляция
· Согласование нагрузки
· Собственный нуль передачи
· Собственный нуль отражения

Применение:
· Используется для всех измерений S-параметров.

· Коррекция 27 коэффициентов погрешностей


Мастер калибровки

Мастер калибровки помогает выбрать метод калибровки и выполнить калибровку.

  • Как запустить мастер калибровки ? ? ? ?

  • Управляемая калибровка: Механические стандарты

  • Неуправляемая калибровка

  • Сохранение калибровки

  • Настройки калибровки

Другие разделы по калибровке.

Как запустить мастер калибровки

Используйте один из следующих методов:

  • +

  • +

Узнайте больше про использование интерфейса передней панели

Cправка по диалоговому окну Calibration Wizard

Позволяет выбрать метод калибровки:

SmartCal (Управляемая калибровка, использование механических стандартов)

Этот метод предоставляет пошаговый интерфейс "мастера". Пользователь описывает контакты тестируемого устройства и используемые калибровочные наборы; последовательно выполняется самая точная возможная калибровка.

  • Поддерживаются все калибровки, КРОМЕ простых калибровок отражения (ХХ, КЗ, согласованная нагрузка).

Дополнительная информация о SmartCal

См. также Калибровка TRL

Неуправляемая калибровка, использование механических стандартов

Этот метод предоставляет знакомый интерфейс калибровки. Можно выбрать тип выполняемой калибровки; допускается измерение стандартов в любом порядке.

  • Поддерживаются все типы калибровки, кроме полной 3-портовой и 4-портовой калибровки.

Дополнительная информация по неуправляемой калибровке

См. также Калибровка TRL

Использование электронной калибровки

Этот метод предоставляет быструю программно управляемую калибровку для 1, 2 и 3 портов.

См. Использование ECal

Калибровка смесителя

Этот метод доступен лишь тогда, когда анализатор содержит Приложение преобразования частот (опция 083).

Создать новый калибровочный комплект

Установите флажок, чтобы создать новый калибровочный комплект для выполняемой калибровки.
Снимите флажок, чтобы перезаписать новые калибровочные данные поверх существующего калибровочного комплекта. Когда флажок убран, щелкните Next, чтобы вызвать диалоговое окно Select Cal Set.

Сохранить предпочтения

Если флажок установлен, выбор метода калибровки будет сохранен. Эта страница не отобразится снова, пока не понадобится изменить метод калибровки. Чтобы изменить его, щелкните Calibration в меню Preferences.
Если флажок снят, страница будет отображаться при последующих калибровках.

Cправка по диалоговому окну Select Cal Set

Позволяет выбрать сохраненный калибровочный комплект, который будет перезаписан.

Select Cal Set Щелкните кнопку, чтобы выбрать калибровочный комплект, который будет перезаписан. Вызывает диалоговое окно Select A Cal Set (Выбор калибровочного комплекта).

Примечание: Если вы НЕ щелкнете Select Cal Set, будет перезаписан активный калибровочный комплект (название которого отображается под кнопкой). Если не выбран активный калибровочный комплект, будет создан новый калибровочный комплект, название которого появится на экране.

Cправка по диалоговому окну Cal Set Stimulus Settings Are Different

Настройки источника выбранного вами калибровочного комплекта отличаются от настроек источника активного канала.

Change channel stimulus settings to match Cal Set (Изменить настройки источников канала для совпадения с калибровочным набором) При этом НЕ применяются данные калибровочного комплекта, лишь изменяются установки источника. Будет завершена и применена выполняемая вами калибровка.

Overwrite cal set with channel stimulus settings. Calibration data currently stored in the cal set will be deleted. (Перезаписать калибровочный комплект настройками источника канала). Текущие калибровочные данные, хранящиеся в калибровочном комплекте, будут удалены. Перезаписывает поверх настроек источника калибровочного комплекта текущие настройки источника канала. Калибровочные данные, хранящиеся в калибровочном комплекте, удаляются.

Управляемая калибровка. Механические стандарты

В зависимости от типов указанных вами соединителей устройств мастер автоматически определит тип калибровки и предложит калибровочный комплект.

Анализатор отображает следующие диалоговые окна при выполнении управляемой калибровки:

  • Выбор соединителей тестируемого устройства

  • Выбор калибровочных комплектов

  • Предварительный просмотр/изменение настроек

  • Последовательность выполнения управляемой калибровки

Cправка по диалоговому окну Select DUT Connectors

Позволяет выбрать типы соединителей тестируемого устройства.

Примечание: Для выполнения полной 1-портовой калибровки необходимо выбрать 'Not Used' (Не используется) для неиспользуемого соединителя.

Если соединители вашего тестируемого устройства:

  • Waveguide Волноводы установите сопротивление системы в 1 ом перед выполнением калибровки. См. Установка системного сопротивления.

  • Not listed Не перечислены (разъемы типа "штекер" и "гнездо") Укажите тип соединителя Type A . Type A требует калибровочного комплекта, содержащего электрические свойства используемых для калибровки мер (см. Калибровочные комплекты).

  • Unspecified (например, для корпусного устройства) Укажите тип соединителя Type B . Type A требует калибровочного комплекта, содержащего электрические свойства используемых для калибровки мер (см. Calibration kits).

  • Non-insertable (Не вставляемые) Управляемая калибровка выполнит калибровку Удаления адаптера. Для этого требуется, чтобы у адаптера были такие же соединители, как и у тестируемого устройства. Чтобы изменить это поведение, установите флажок Preview/Modify Settings в следующем диалоговом окне.

Cправка по диалоговому окну Select Cal Kits

Позволяет выбирать калибровочные комплекты, используемые с каждым из портов измерений. В списке отображаются комплекты для каждого порта (PORT), имеющие тот же тип соединителей, что и тестируемое устройство.

PORT 1 перечислены калибровочные комплекты, доступные для порта 1

PORT 2 перечислены калибровочные комплекты, доступные для порта 2

PORT 3 (для трехпортовых анализаторов) перечислены калибровочные комплекты, доступные для порта 3

Preview/Modify Settings (Предварительный просмотр/изменение настроек) Вызывает диалоговое окно, показывающие калибровки, которые будут выполнены, исходя из сделанных вами в предыдущих диалоговых окнах выборов.

Узнайте о выполнении Калибровки TRL.

Cправка по диалоговому окну Preview/Modify Settings

Примечание: Это диалоговое окно на трехпортовых анализаторах выглядит немного по-другому, однако его функциональность сохраняется.

Select calibration type (Выбор типа калибровки)

Показывает, какие калибровки будут выполнены, исходя из выборов, сделанных вами в предыдущих диалоговых окнах. Щелкните, чтобы выбрать другой тип калибровки. В зависимости от ситуации другие варианты могут быть или НЕ быть доступны.

Возможные варианты включают:

  • Удаление адаптера

  • Неизвестная перемычка

  • Перемычка нулевой длины - (использование перемычки нулевой длины)

  • Перемычка калибровочного комплекта(Определенная перемычка)

Advanced (Расширенные)

Показывает, какие калибровки будут выполнены на портах по отдельности. Щелкните, чтобы выбрать другой тип калибровки. В зависимости от ситуации другие варианты могут быть или НЕ быть доступны. Возможные варианты включают:

  • SOLT (КЗ, ХХ, согласованная нагрузка, перемычка)

  • TRL Узнайте о способе выполнения Калибровки TRL.

View/Modify (Просмотр/изменить) вызывает диалоговое окно Изменить назначения классов калибровки С его помощью просматривают или изменяют комплекты, связанные с калибровочным измерением.

Cправка по диалоговому окну Guided Calibration Steps (Последовательность направляемой калибровки)

Запрашивает комплекты для измерения.

Measure щелкните, чтобы выполнить измерение комплекта.

Done Щелкните после повторного измерения комплекта и завершения всех измерений в калибровке.

Next Щелкните, чтобы перейти к следующему шагу калибровки. НЕ выполняет измерение комплекта.

Неуправляемая калибровка

Неуправляемая калибровка может выполняться для всех типов калибровки, кроме полной 3-портовой и ECal. Анализатор отображает следующие диалоговые окна при выполнении неуправляемой калибровки:

  • Выбор типа калибровки для механических стандартов

  • Выбор калибровочного комплекта

  • Измерение механических стандартов

  • Несколько стандартов

  • Измерение скользящей нагрузки

Cправка по диалоговому окну Select Calibration Type for Mechanical Standards (Выберите тип калибровки для механических комплектов)

Позволяет выбрать метод и установки калибровки . Доступные типы калибровки зависят от установленных параметров активного канала и модели анализатора. Например, если выбрано измерение S11, тип калибровки Thru Response (собственный нуль по перемычке) будет недоступна.

OPEN Response (Калибровка собственного нуля по нагрузке ХХ) (отражение)

SHORT Response (Калибровка собственного нуля по нагрузке КЗ) (отражение)

THRU Response (Калибровка собственного нуля по перемычке) (передача)

THRU Resp + Isol (Калибровка собственного нуля по перемычке + изоляция) (передача)

Full SOLT 2-PORT (1,2) T(Полная SOLT - КЗ, ХХ, перемычка, согласованная нагрузка) Номера в скобках соответствуют паре используемых в калибровке портов.

Full TRL 2-PORT (1,2) Калибровка TRL доступна для анализаторов цепей E835xA и E836xA.

Full SOLT 3-PORT Только для 3-портовых анализаторов

TRL Reference Plane (Плоскость отсчета TRL) (при выборе TRL)

THRU – стандарт THRU (перемычка) используется для установки плоскости отсчета измерения. Установите, если стандарт THRU имеет нулевую длину или является очень коротким.

REFLECT – Стандарт REFLECT (отражение) используется для определения положения плоскости отсчета измерения. Выберите, если стандарт THRU не является соответствующим И задержка для стандарта REFLECT четко определена.

TRL Impedance (Сопротивление TRL) (при выборе TRL)

LINE – сопротивление стандарта линии, используемого как контрольный стандарт, или центр диаграммы Смита. Любое отражение от стандарта линии воспринимается как часть погрешности направления.

SYSTEM – в качестве контрольного сопротивления используется сопротивление системы. Установите, если требуемое сопротивление порта измерения отличается от сопротивления стандарта LINE.

View Selected Cal Kit (Просмотреть выбранный калибровочный комплект) Щелкните, чтобы просмотреть выбранный калибровочный комплект или выбрать другой калибровочный комплект. Вызывает диалоговое окно Select Cal Kit

Have 2 sets of standards (Есть 2 набора стандартов) Установите этот флажок, чтобы использовать два набора калибровочных стандартов, уменьшая количество измерений. Также может понадобиться изменить Порядок назначения классов калибровки.

Снимите флажок, чтобы использовать один набор калибровочных стандартов.

Omit Isolation (Исключить изоляцию) Установите флажок, чтобы НЕ выполнять коррекцию перекрестных помех (изоляции). Используйте, когда для измерения не требуется широкий динамический диапазон. Снимите флажок, чтобы выполнить калибровку и коррекцию на изоляцию. Используйте, когда требуется максимальный динамический диапазон для измерения (> 90 дБ). См. также Часть 2-портовой калибровки, относящаяся к изоляции.

Next (Далее) Щелкните, чтобы перейти к диалоговому окну Измерение механических стандартов.

Примечания:

  • Если тип соединителя тестируемого устройства имеет сопротивление, не равное 50 Ом (волновод = 1 Ом), измените сопротивление системы перед выполнением калибровки. См. Установка системного сопротивления.

  • Тип калибровки Полная SOLT 3-портовая связан с управляемой калибровкой (на 3-портовом анализаторе).

Cправка по диалоговому окну Select Cal Kit

Отображает файлы калибровочного комплекта, доступные для неуправляемой калибровки.

Выберите требуемый калибровочный комплект и щелкните Next

Class Assignments (Назначения классов) Позволяет изменять назначения классов выбранного калибровочного комплекта.

Чтобы узнать, как заменять другие калибровочные комплекты, см. Расширенное редактирование калибровочных комплектов

Cправка по диалоговому окну Measure Mechanical Standards (Измерение механических стандартов)

Отображает файл калибровочного комплекта и требуемые для калибровки стандарты.

  • Стандарты можно подключать и проводить измерения в любом порядке.

  • Подключите стандарт к измерительному порту и щелкните на соответствующую зеленую кнопку. Флажок указывает, что стандарт был измерен.

  • Если тип стандарта содержит несколько стандартов, открывается диалоговое окно, отображающее все стандарты, входящие в файл калибровочного комплекта.

  • Если файл калибровочного комплекта включает скользящую нагрузку, открывается диалоговое окно для выполнения измерений по стандарту.

  • Калибровка собственного нуля по перемычке + изоляции требует наличия нескольких идентичных нагрузок (по одной на каждый измерительный порт анализатора).

Show Prompts (Показывать запросы) Установите флажок, чтобы получать напоминания о необходимости подключения при щелчках по стандартам.

Cправка по диалоговому окну Multiple Standards (Несколько стандартов)

Выберите стандарты, которые будут измерены.

Примечание: могут отображаться как стандарты-вилки, так и стандарты-розетки. Неуправляемая калибровка не располагает информацией о форме ваших соединителей. Укажите вид соединителей тестируемого устройства;, а НЕ измерительного порта. Затем щелкните ОК.

Чтобы изменить этот калибровочный класс для отображения лишь одного стандарта, в меню Calibration(Калибровка) щелкните Advanced Modify Cal Kits (Расширенное изменение калибровочных комплектов). Выберите калибровочный комплект и щелкните Edit Kit (Редактировать комплект). В Class Assignment(Назначении классов), щелкните Edit (Редактировать). Узнайте больше про изменение назначений классов калибровки.

  • Подключите стандарт к измерительному порту и щелкните на соответствующую кнопку. Флажок под названием Acquired (Получено) указывает, что стандарт был измерен.

  • Чтобы покрыть весь частотный диапазон, может понадобиться измерить более одного стандарта. Порядок, в котором стандарты будут измерены, важен. Последний измеренный стандарт получит приоритет относительно других по частотному диапазону определения стандарта. Например: IПри измерении как широкополосной нагрузки, так и скользящей нагрузки, скользящую нагрузку лучше измерить последней. Это так, поскольку частотный диапазон скользящей нагрузки является подмножеством широкополосной нагрузки.

Узнайте больше про изменение назначений классов калибровки

Cправка по диалоговому окну Sliding Load Measurement (Измерение скользящей нагрузки)

Позволяет измерить стандарт скользящей нагрузки.

Чтобы измерить скользящую нагрузку:

  1. Подключите скользящую нагрузку к измерительному порту.

  2. Расположите скользящий элемент, затем щелкните Slide is Set -- Measure(Скользящий установлен -- измерить). Не перемещайте скользящий элемент до завершения измерения.

  3. Выполните измерение скользящей нагрузки в минимум пяти и максимум семи позициях для максимальной точности.

Примечание: Позиции скользящего элемента должны быть расположены неравномерно, чтобы уменьшить возможность перекрытия точек данных.

  5. Щелкните Last Slide -- Done для последнего измерения.

  6. Уберите скользящую нагрузку из измерительного порта.

  7. Выполните измерения остальных стандартов.

Сохранение калибровки

Анализатор отображает следующие диалоговые окна после выполнения калибровки. Можно сохранить только данные калибровочного комплекта, или данные калибровочного комплекта и все настройки инструментов активного канала.

  • Стандарты измерены

  • Калибровка выполнена

  • Сохранение состояния инструментов

Cправка по диалоговому окну Standards Measured (Измеренные стандарты)

Все стандарты, требуемые для управляемой калибровки, были измерены.

Back (Назад) Щелкните, чтобы повторно измерить калибровочный стандарт.

Cancel (Отмена) Выполняет выход из мастера калибровки.

Next (Далее) Щелкните, чтобы продолжить.

Cправка по диалоговому окну Calibration Completed

Позволяет завершить работу мастера калибровки или продолжить, чтобы Сохранить (Save) параметры.

No. Finish now. (Завершить работу сейчас). Выходит из мастера калибровки

Yes Позволяет установить параметры сохранения.

Finish Выполняет следующее:

  • Сохраняет калибровочный комплект в память

  • Включает коррекцию

  • Завершает работу мастера калибровки

Примечание: Данные калибровочного комплекта можно применить к другим каналам. См. использование калибровочных комплектов.

Cправка по диалоговому окну Save Instrument State

Позволяет сохранить калибровочные данные и настройки состояний инструментов в следующие расположения:

  • Внутренний жесткий диск

  • Гибкий диск

  • Внешний привод CD-RW, ПК или сервер, использующие отображаемый сетевой диск

Save As Сохраняет настройки калибровки и инструментов (используется файл с расширением .cst. Необходимо указать имя файла и размещение, где он будет сохранен.

Autosave Автоматически сохраняет настройки инструментов и калибровочный комплект в текущее расположение, назначая новое имя файлу с расширением .cst. На экране временно появляется сообщение, указывающее путь и новое имя файла. Векторы погрешности автоматически сохраняются в виде калибровочного набора в памяти анализатора.

Back Щелкните, чтобы вернуться к предыдущему диалоговому окну.

Cancel Выход из мастера калибровки.

Примечания:

  • Из памяти можно вызвать настройки инструментов и калибровочные данные, а можно вызвать и только калибровочный комплект. См. использование калибровочных комплектов.

  • Для дополнительной информации о сохранении и вызове данных, см. сохранение и вызов.

Настройки калибровки

Как изменить настройки калибровки

Дополнительная информация об интерфейсе передней панели

Cправка по диалоговому окну Cal Preferences (Настройки калибровки)

Настройки калибровки позволяют сохранить следующие параметры, выбранные на странице Begin Calibration мастера калибровки:

  • Метод калибровки (Управляемая, неуправляемая, ECAL)

  • Создать новый калибровочный комплект (выбрано или снято)

Yes. Enable calibration preferences Эти выбранные параметры будут применяться всегда, и страница Begin Calibration не будет показана, пока не будет отключено применение настроек калибровки. Щелкните Next, чтобы выбрать значения на странице Begin Calibration(Начало калибровки).

Примечание: настройки калибровки можно также включить прямо на странице Begin Calibration.

No. Disable calibration preferences Отображать страницу Begin Calibration каждый раз при запуске мастера калибровки. Щелкните Next, чтобы перейти к следующему диалоговому окну, подтверждающему отключение использования настроек.

Cправка по диалоговому окну Cal Preferences Complete

Щелкните Finish, чтобы завершить работу с настройками калибровки.


Использование калибровочных комплектов

Калибровочные комплекты (Cal Sets) позволяют использовать одну калибровку на нескольких каналах.

  • Данные калибровки анализатора, предыдущие и текущие

  • Создание калибровочного набора

  • Управление калибровочными наборами и их применение

  • Примеры использования калибровочных наборов

  • Сохранение архива калибровочных наборов в файлах .cal

Другие разделы по калибровке

Данные калибровки анализатора, предыдущие и текущие

Предыдущие (до версии анализатора 2.0)

Один файл .cst

Настройка анализатора

  • Калибровочные данные сохранялись ТОЛЬКО в файле .cal или .cst.

  • Калибровочные данные нельзя было использовать для нескольких каналов.

Текущие, с калибровочными комплектами

Один калибровочный комплект (на рисунке показана только часть данных, сохраненных в калибровочном комплекте).

Файл калибровочного комплекта

  • Калибровочные данные всегда сохраняются в файле калибровочного набора (PNACalSets.dat).

  • Калибровочный набор можно применить к любому каналу с теми же настройками источника, что и у калибровочного набора.

  • Файлы .cst (состояние инструментов и калибровочные данные) ТЕПЕРЬ содержат "указатели" на калибровочные комплекты. См. типы файлов .cst

  • Калибровочные комплекты позволяют хранить несколько типов калибровок.

Каждый калибровочный набор содержит следующие элементы:

  1. GUID - глобальный уникальный идентификатор

  2. Описание калибровочного набора

  3. Атрибуты калибровочного набора - настройки источника, тип калибровки, назначение портов

  4. Данные по стандартам

  5. Данные вектора погрешностей (Error term)

  6. Интерполированные данные вектора погрешностей

Создание калибровочного набора

После управляемой или неуправляемой калибровки автоматически создается калибровочный набор. В это время можно также сохранить состояние инструментов. Загрузка состояния инструментов автоматически загружает и калибровочный набор.

Калибровочные наборы можно создавать программными средствами:

  1. С помощью интерфейса COM, используя метод Calibrator::SetCalInfo.

  2. С помощью интерфейса COM, используя метод CalManager::CreateCalSet.

  3. 3. С помощью программных средств SCPI, запуская мастер калибровки с помощью SYST:CORR:WIZARD.

После создания калибровочного набора его можно применить к измерению, а затем управлять им.

Управление калибровочными наборами и их применение

Калибровочными наборами можно управлять в диалоговом окне (Select A Cal Set)Выбор калибровочного набора.

Чтобы открыть диалоговое окно, щелкните Calibration, затем Cal Set...

Cправка по диалоговому окну Select a Cal Set (Выбор калибровочного набора)

Позволяет выбрать (применить) калибровочный набор к измерению, а также просматривать доступные калибровочные наборы, их свойства и связанные с ними типы калибровок.

Хотя максимально возможное количество калибровочных наборов равно 100, обычно редко требуется более 10 калибровочных наборов, по одному на каждую из уникальных конфигураций каналов. Устаревшие калибровочные наборы (с устаревшими данными) нужно удалять или перезаписывать.

Columns (Столбцы) щелчок по заголовку сортирует данные по этому столбцу

User Description Имя, определяющее калибровочный набор, установленное пользователем. Чтобы изменить его, щелкните Description. (Описание)

Channels Количество каналов, используемых на данный момент этим калибровочным набором.

CalTypes / Port Association Тип калибровки и номера портов калибровочного набора.

Modified Дата и время последнего изменения калибровочного набора.

GUID Уникальный для каждого калибровочного набора идентификатор.

Current Number of CalSets Количество находящихся в списке калибровочных наборов. Если это количество достигает 100, тогда последний из существующих калибровочных наборов будет перезаписан при сохранении нового калибровочного набора.

Cal Type Abbreviations Описание типа калибровки.

Кнопки

Properties вызывает окно Calibration Properties(Свойства калибровки).

Description Редактировать пользовательское описание набора калибровки.

Delete Необратимо удаляет калибровочный набор после нажатия пользователем ОК в окне-предупреждении.

Delete All Необратимо удаляет ВСЕ перечисленные калибровочные наборы после нажатия пользователем ОК в окне-предупреждении.

Select Применяет калибровочный набор к активному измерению. Если настройки источника калибровочного набора и измерения различаются, необходимо сделать выбор. Если доступно более одного действительного типа калибровки, диалоговое окно Select Calibration Type позволяет сделать выбор.

Exit Закрывает диалоговое окно, не выбирая калибровочный наборt.

Help Вызывает этот раздел справки

Различные настройки источника в измерении и калибровочном наборе

Калибровочный набор содержит настройки измерения, которые использовались на момент калибровки. Эти настройки могут различаться от настроек нового измерения, к которому применяется калибровочный набор. Если различия существуют, можно выбирать между следующими вариантами.

Если диапазон частот Калибровочного набора больше или равен диапазону измерения.

 | Диапазон частот
Калибровочный набор | |---------------|
Измерение | |--------|

Тогда выберите

either:

А Калибровка будет интерполироваться. Дополнительная информация о точности интерполяции

B Измерение будет изменено для соответствия калибровочному набору

Для того, чтобы калибровочные наборы применялись успешно, необходимо включить интерполяцию.

Если диапазон частот калибровочного набора меньше, чем у измерения.

 | Диапазон частот
Калибровочный набор | |--------|
Измерение | |-------------

Тогда выберите:

OK Уменьшить диапазон частот измерения

Cancel Калибровочный набор НЕ будет применяться

Как выбрать тип калибровки

Дополнительная информация о интерфейсе передней панели интерфейсе передней панели

Откроется диалоговое окно Select Calibration Type.

Справка по диалоговому окну Select Calibration Type

Калибровочный набор может иметь более одного типа калибровки. При применении калибровочного набора, который имеет более одного типа калибровки, это диалоговое окно предлагает возможные варианты.

  1. Щелкните один из доступных типов калибровки.

  2. Щелкните OK, чтобы выбрать его, или Cancel , чтобы закрыть диалоговое окно.

Информация о вариантах специальных типов калибровки

Примеры использования калибровочных наборов

Следующие примеры демонстрируют повышение скорости и гибкости измерений с помощью анализатора при использовании калибровочных наборов.

  • Использование одного калибровочного набора при многих измерениях

  • Использование одного измерения со многими калибровочными наборами

Использование одного калибровочного набора для многих измерений

Типичным является выполнение одной калибровки с последующим ее использованием для настройки нескольких измерений, разделяющих общие калибровочные данные.

Пример:

Во время производственного процесса требуется много калиброванных измерений S-параметров. Возможно, понадобится перебирать измерения в цикле и исследовать их по отдельности. Иногда может потребоваться обновить калибровку, не создавая повторно файлы состояния измерений.

Как это сделать: Сначала необходимо выполнить планирование. После исследования настроек источника для группы измерений S-параметров, диапазон источника калибровочного набора создается как надмножество для всей группы. Тогда каждое измерение сможет использовать один и тот же калибровочный набор.

Примечание: Убедитесь, что включена интерполяция Для отдельных измерений S-параметров настройки источника будут являться подмножеством калибровочного набора. Для этих вычислений будут рассчитываться скорректированные погрешности интерполяции.

Обратите внимание, что на следующем рисунке калибровочный набор 78 используется в более чем одном канале, в данном случае это каналы 5 и 16.

Канал Калибровочный набор

Использование одного измерения со многими калибровочными наборами

Недостатком будет использование одного очень большого калибровочного набора, связанного со многими состояниями инструментов, что может привести к падению скорости измерений. В таком случае рассмотрите возможность использования одного измерения со многими калибровочными наборами. Затем можно изменить состояния источника для измерения, применяя различные калибровочные наборы. Другие настройки (конфигурация окон, определения измерений, масштабирование, пределы, маркеры) не изменятся. Это может обеспечить более быстрое изменение состояния, чем при сохранении и вызове файлов *.cst для каждого набора состояний источника

Пример #1: Необходимо выполнить измерения усилителя при нескольких уровнях мощности. Выполните калибровку при нескольких уровнях мощности и сохраните каждую калибровку в отдельный калибровочный набор. Затем последовательно применяйте калибровочные наборы к одному измерению.

Пример #2: Выполняя измерение S21, необходимо измерить характеристики широкого и узкого диапазонов устройства. Один калибровочный набор покрывает настройку с широким диапазоном, другой набор - настройку с узким диапазоном.

Пример #3, многопортовые измерения: Измеряется 6-портовое устройство. У него один входной порт и 5 выходных портов. Выполняется измерение S21 от входа на каждый из выходов при аналогичных условиях измерения (источниках, маркерах, лимитах и т.д.). Создайте калибровочный набор для каждого выбора портов и вызывайте их по одному.

Архивирование калибровочных наборов с помощью файлов .cal

Поскольку калибровочные наборы легко применяются к измерениям, их можно также легко удалить. Для создания дополнительной резервной копии можно также сохранить калибровку в формате .cal (см. сохранение в файл.cal). Все калибровки, используемые на данный момент активными каналами анализатора, сохраняются в одном файле .cal.

Пример:

Один пользователь выполняет калибровку, именует ее и сохраняет как калибровочный набор. Этот калибровочный набор может использоваться любыми другими пользователями. Другой пользователь может случайно изменить или удалить калибровочный набор, после чего первому потребуется повторить калибровку.

Можно обеспечить сохранность калибровочных данных, сохраняя калибровочный набор в файл .cal Позднее можно вызвать файл .cal и восстановить оригинальную калибровку.


Использование ECal

В этом разделе обсуждаются все аспекты использования ECAL:

  • Обзор ECal

  • Подключение модуля ECal к анализатору

  • Выполнение калибровки с помощью ECAL

  • Пользовательские характеристики ECAL

  • Восстановление памяти модуля ECAL

Другие разделы по калибровке

Обзор ECal

ECal - это метод калибровки, полностью реализованный на твердотельной (полупроводниковой) технологии. Каждый модуль ECal содержит электронные эталоны, автоматически включаемые при выполнении анализатором калибровочных измерений. Эти электронные эталоны были измерены при производстве, а данные измерения были сохранены в памяти модуля ECal. Анализатор использует сохраненные данные, вместе с собственными результатами измерений анализатора, для расчета вектора погрешности при калибровочном измерении.

Модули ECal доступны в 2-портовом и 4-портовом исполнениях с различными видами соединителей и различными покрываемыми частотными диапазонами. См. Аксессуары анализатора для дополнительной информации о доступных модулях ECal и возможности их заказа.

С помощью ECal можно выполнять следующие калибровки:

  • 1-портовую (отражение)

  • полную 2-портовую калибровку

  • полную 3-портовую калибровку

Проверить точность механической калибровки или калибровки ECAL можно с помощью Проверки надежности ECAL.

Уход и обращение с модулями ECal

Улучшить точность оборудования, повторяемость результатов и избежать дорогостоящих починок можно следующим образом.

  • Выполняя рекомендации по уходу за соединителями. См. Уход за коннекторами.

  • Защищая оборудование от повреждений от электростатических разрядов. См. Защита от электростатического разряда.

  • Не применяйте излишнего физического усилия к портам. Обратитесь к спецификации, прилагающейся к модулю ECal.

Подключение модуля ECal к анализатору

Модули ECal получают питание и управляются с помощью подключения USB к анализатору. При подключении модуля анализатор автоматически распознает тип модуля, частотный диапазон и вид соединителя.

Примечание: Для некоторых устройств USB (например, модулей ECAL) при первом подключении к анализатору требуются Привилегии администратора Это требуется для каждого экземпляра оборудования с различными серийными номерами.

Модули ECal подключаются к порту USD на передней или задней панели анализатора.

  1. Наденьте антистатический заземленный браслет на время подключения.

  2. Подключите соединитель кабеля USB Типа B к модулю ECal, а соединитель кабеля USB Типа A к разъему USB на передней или задней панели анализатора, как показано на следующих рисунках.

Порт USB модуля ECal Порт USB передней панели анализатора

Примечания:

  • Модули ECAL Agilent 8509x и N4431 при первом подключении потребляют гораздо больший ток, чем другие модули. Это может привести к нарушению работы USB. См. ограничения USB.

  • Неиспользумые модули ECal, которые успешно использовались в калибровке, можно оставлять подключенными к порту USB.

  • Модули ECal можно подключать и отключать при работающем анализаторе. Однако НЕ отключайте или подключайте модули во время передачи данных. Это может привести к повреждению или как минимум потере данных.

  • Для подключения к анализатору более чем одного устройства USB можно использовать USB хаб. См. Аксессуары анализатора для дополнительной информации о периферийном оборудовании с интерфейсом USB.

Справка по диалоговому окну ECal module not found (Модуль ECal не найден)

Отображает сообщение, означающее, что модуль ECal не подключен или не распознается анализатором сетей.

Retry Проверьте соединение USB и щелкните для еще одной попытки.

Примечания:

  • Когда модуль ECal подключается к анализатору цепей в первый раз, анализатору может потребоваться около 30 секунд, чтобы распознать модуль и подготовиться к его использованию при калибровке.

  • Для наилучшей точности нужно дать прогреться модулю ECal, пока он не сообщит о готовности (READY).

  • См. Подключение порта USB модуля ECal к порту USB анализатора.

Выполнение калибровки с помощью ECal

Следующие рисунки демонстрируют типичные подключения для 1-, 2-, 3-портовых калибровок и измерений тестируемых устройств.

Примечание: Неиспользуемые порты ECAL необходимо терминировать нагрузкой в 50 Ом.

Выберите модуль ECal с соединителями того же типа и вида, что и тестируемое устройство. Если такого модуля ECal нет в наличии, можно использовать модуль с соединителями, отличающимися от соединителей тестируемого устройства, с помощью Расширенных настроек или Назначения пользовательской характеристики.

Как выполнять калибровку с помощью ECal:

  1. Подключите модуль ECal кабелем USB к порту USB анализатора. См. Подключение порта USB модуля ECal к порту USB анализатора.

  2. Дайте модулю прогреться, пока он не перейдет в состояние READY.

  3. Введите настройки анализатора. См. настройки измерений.

  4. Запустите мастер калибровки следующим образом:

  5. В диалоговом окне мастера калибровки щелкните Use Electronic Cal (ECal)

Справка по диалоговому окну Select ECAL Module

Если анализатор обнаруживает более одного модуля ECAL, выберите один из модулей и щелкните Next.

Справка по диалоговому окну Select Calibration Type for ECal

Позволяет выбрать тип и установки калибровки.

1-PORT Reflection Щелкните, чтобы выбрать калибровку по отражению по 1 порту. При использовании калибровки по отражению по 1 порту расширенные настройки и изоляция недоступны.

Full SOLT 2-PORT Щелкните, чтобы выбрать полную 2-портовую калибровку.

Full SOLT 3-PORT Щелкните, чтобы выбрать полную 3-портовую калибровку (только для 3-портовых анализаторов).

Show Advanced Settings Щелкните, чтобы отобразить Расширенные настройки для выбранного типа калибровки.

View/Select Characterization Установите флажок, чтобы вызвать диалоговое окно Select Characterization. См. дополнительную информацию о пользовательских характеристиках.

Если дипазон частот активного канала больше, чем у выбранной характеристики, появляется сообщение Caution: Additional Standards Required. Чтобы решить проблему, выполните одно из следующих действий:

  • Уменьшите частотный диапазон активного канала.

  • Выберите другую характеристику, покрывающую требуемый частотный диапазон.

  • Создайте для модуля характеристику с увеличенным частотным диапазоном.

Примечание: Анализатор больше не позволяет выполнять изоляцию ECAL. Внутренняя изоляция анализатора лучше, чем достигаемая с погрешностью при использовании модуля ECAL.

Cправка по диалоговому окну Advanced Settings

Advanced Settings(Дополнительные настройки) являются расширениями, применимыми к полной 2-портовой и 3-портовой калибровке. Некоторые значения настроек ограничены в зависимости от модели анализатора и соединителей модулей ECal.

Recognized ECal module Отображает номер модели и тип соединителя подключенных к анализатору модулей.

Выберите вариант

Следующая информация требует понимания терминов "вставляемые и невставляемые устройства". См. Точность калибровки для информации об этих терминах.

Default Измеряет состояние перемычки модуля ECAL. Это простейший выбор, а также наиболее точный, если у используемой модели анализатора один опорный приемник на порт.

Adapter Removal Можно выполнять с ECAL, когда тестируемое устройство не является вставляемым. Однако модуль ECAL должен быть вставляемым, а соединители адаптера должны точно совпадать с соединителям тестируемого устройства, как показано на следующей диаграмме.

Примечание: В анализаторе версии 4.8 удаление адаптера выполняет 2-портовое измерение с обоих сторон адаптера. Ранее при этом выполнялось 2-портовое измерение с одной стороны, и 1-портовые измерения с другой стороны. Это повышает точность калибровки удаления адаптера.

В случае, когда удаление адаптера не может быть выполнено, назначение пользовательской характеристики ECAL всегда возможно при наличии верных адаптеров. Пользовательское определение характеристик выполняется один раз и записывается в модуль ECAL. Однако точность понижается каждый раз, когда вы удаляете и заново подключаете адаптер к модулю ECAL.

Flush Thru (перемычка нулевой длины) Состояние THRU модуля ECal приводит к большим потерям, чем перемычка нулевой длины, в результате чего ухудшается вектор погрешности собственного нуля передачи. Это значение параметра требует устанавливаемого модуля ECal. Когда это значение установлено, вы получите запрос на удаление модуля ECal и соединение двух плоскостей отсчета напрямую через перемычку нулевой длины.

Unknown Thru Если пара соединителей модуля ECAL не является вставляемой, тогда использование перемычки нулевой длины (или Flush) невозможно. Однако можно использовать значение параметра Unknown Thru, что позволит достичь более высокой точности, чем использование стандартного Thru в модуле ECAL. Модуль ЕCal удаляется, и порты измерения соединяются механическим адаптером-перемычкой. Дополнительная информация про неизвестную перемычку.

Do orientation Когда этот флажок установлен (по умолчанию), анализатор определяет модель ECAL и направление, в котором порт модуля подключен к портам анализатора. Если питание, получаемое модулем ECAL, недостаточно, модуль ECAL может казаться не подключенным. Если питание недостаточно, и возникает эта проблема, уберите флажок, чтобы указать направление вручную.

Направление начинает определяться в центре диапазона частот, в котором выполняется калибровка. Если сигнал не обнаружен, попытки продолжаются на самой низкой частоте диапазона. Для анализаторов E8361A или E836xB при использовании ECAL в частотных диапазонах 10 - 20 МГц или 60 - 67 ГГц может понадобиться указать ориентацию вручную. На этих частотах для ECAL может быть недостаточно получаемого питания для успешной ориентации.

Cправка по диалоговому окну Specify how the ECAL module is connected

Это диалоговое окно появляется, когда сброшен флажок Do orientation в предыдущем диалоговом окне.

Щелкните на Port A или B, чтобы указать направление модуля ECAL.

Cправка по диалоговому окну Select Characterization

Выберите либо заводские заданные характеристики модуля ECAL, либо назначение пользовательской характеристики. После выбора указанный набор характеристик становится выбираемым по умолчанию, пока анализатор не ВЫКЛЮЧАЕТСЯ и перезапускается. После перезапуска значением по умолчанию снова становится Factory (Заводские).

Cправка по диалоговому окну Electronic Calibration Steps (Последовательность направляемой калибровки)

Отображает инструкции для каждого измерения, необходимого для калибровки.

Measure Измеряет стандарты ECal.

Cправка по диалоговому окну Calibration Completed

Позволяет завершить калибровку или продолжить, чтобы сохранить(Save) параметры.

No. Finish now. (Завершить работу сейчас). Завершает калибровку.

Yes Позволяет установить параметры сохранения.

Finish Выполняет следующее:

  • Сохраняет калибровочный набор в память

  • Включает коррекцию

  • Завершает работу мастера калибровки

Cправка по диалоговому окну Save Instrument State

Save As Сохраняет настройки калибровки и инструментов (используется файл с расширением .cst Необходимо указать имя файла и размещение, где он будет сохранен.

Autosave Сохраняет настройки инструментов и калибровочный комплект в текущее расположение, назначая новое имя файлу с расширением .cst. На экране временно появляется сообщение, указывающее путь и новое имя файла.

  • Дополнительная информация про использование калибровочных наборов.

  • Дополнительная информация про сохранение и вызов файлов.

Пользовательские характеристики ECAL

Пользовательские характеристики ECal позволяют добавлять адаптеры к модулю ECal, повторно измерять стандарты ECal, ИСПОЛЬЗУЯ адаптеры, и затем добавлять данные в память ECal. Это перемещает плоскость отсчета от измерительных портов модуля к адаптерам.

Есть несколько причин, по которым может понадобиться назначение пользовательских характеристик:

  • Если необходимо использовать адаптеры вместе с модулем ECAL, можно определить характеристики модуля ECAL с подключенными адаптерами, и выполнять последовательные ECAL за один шаг.

  • Если имеется 4-портовый модуль ECAL, можно настроить модуль с адаптерами различных типов соединителей. Затем выполняется пользовательское определение характеристик модуля. Когда понадобится проверить тестируемое устройство с помощью пары соединителей на модуле, калибровка анализатора может быть выполнена за один шаг с использованием двух соединителей модуля, характеристики которому назначены пользователем.

  • Если вы проверяете устройства в приспособлении, можно внедрить характеристики приспособления в характеристику модуля. Для этого во время части пользовательского назначения характеристики, когда выполняется механическая калибровка, калибруйте на уровне плоскости отсчета устройства, как обычно. Затем уберите приспособление, данные которого будут внедряться, и вставьте модуль ECAL, который получит характеристику. При измерении модуля ECAL анализатор устраняет эффекты приспособления и сохраняет результаты измерения в модуле ECAL с пользовательской характеристикой. При последующих калибровках с данным модулем с пользовательской характеристикой эффекты приспособления также будут устраняться.

Примечания:

  • Пользовательская характеристика не устраняет заводские данные характеристики. Заводские данные хранятся в модуле ECal в дополнение к пользовательским данным характеристики.

  • В одном модуле ECAL можно сохранить до пяти различных пользовательских характеристик. Существуют ограничения по объему памяти; анализатор определяет, поместится ли содержимое пользовательской характеристики в памяти модуля, перед ее созданием. Примечание: Это новая возможность анализатора версии 3.0. Предыдущие версии анализатора НЕ распознают более одной пользовательской характеристики.

  • Как 2-портовые, так и 4-портовые модули ECal поддерживают пользовательские характеристики.

Как выполнить назначение пользовательской характеристики

СВОДКА (подробная процедура описывается далее.)

1. Выберите для модуля адаптеры, подходящие по конфигурации соединителей с тестируемым устройством.

2. Либо выполните управляемую калибровку с использованием механических стандартов, либо вызовите калибровочный набор. Это необходимо для выполнения точных измерений модуля ECAL и адаптеров.

3. Выполните измерение модуля ECal с адаптерами, будто бы он является тестируемым устройством.

4. Результат измерения - это данные характеристики, сохраняемые в модуле.

Подробная последовательность действий по созданию пользовательской характеристики:

  1. Подключите модуль ECal кабелем USB к порту USB анализатора. См. Подключение порта USB модуля ECal к порту USB анализатора.

  2. Дайте модулю прогреться, пока он не перейдет в состояние READY.

  3. Введите предустановленные настройки анализатора.

  4. Настройте измерение.. Для максимальной точности полоса ПЧ должна быть равна 1 кГц или менее.

  5. Запустите мастер Характеристики модуля ECAL:

Cправка по диалоговому окну Select user number for new characterization

Отображает характеристики, уже находящиеся в модуле. Прокрутка позволяет увидеть все параметры сохраненных характеристик. Выберите пустое место или же перезапишите поверх существующей характеристики.

Next щелкните, чтобы перейти к диалоговому окну Select Connectors for the Characterization.

Cправка по диалоговому окну Select Connectors for the Characterization

Позволяет выбирать адаптеры для измерительных портов модуля ECal. Выберите No adapter, если адаптеры на порту не используются.

PORT A Перечисляет типы соединителей, доступных для Порта A.

PORT B Перечисляет типы соединителей, доступных для Порта B.

PORT C Перечисляет типы соединителей, доступных для Порта C (доступно для 4-портовых модулей ECal).

PORT D Перечисляет типы соединителей, доступных для Порта D (доступно для 4-портовых модулей ECal).

Next Щелкните, чтобы перейти к диалоговому окну Calibrations to perform or recall.

Cправка по диалоговому окну Calibrations to perform or recall

Анализатор должен быть откалиброван перед измерением модуля ECAL и требуемых адаптеров. Это диалоговое окно отображает количество и виды механических калибровок, требуемых для создания характеристики.

Guide me through this cal now Щелкните, чтобы выполнить управляемую калибровку. Для каждого вида соединителя требуется калибровочный комплект.

Let me recall this cal from a cal set Щелкните, чтобы выбрать калибровочный набор из предыдущих калибровок различных видов соединителей. Дополнительная информация про использование калибровочных наборов.

Next Щелкните, чтобы перейти к диалоговому окну Select Cal Kits или Select Cal Set.

Cправка по диалоговому окну Select Cal Kits

Выводит список калибровочных комплектов для выполнения калибровки. Выберите калибровочные комплекты, которые будут использоваться для каждого из портов.

Enable Unknown Thru for characterizing the module Щелчок устанавливает этот параметр. При этом уменьшается количество шагов, необходимых для создания характеристики стандарта THRU (перемычки). Дополнительная информация о калибровке с неизвестной перемычкой. Этот параметр доступен только на анализаторах цепей серий E835xA и E836xA.

Next Щелкните, чтобы перейти к диалоговому окну Select Cal Set.

Cправка по диалоговому окну Select Cal Set

Результаты выполняемой калибровки будут записаны в калибровочный набор. Это диалоговое окно позволяет выбрать сохраненный калибровочный набор, который будет перезаписан, или выбрать создание нового калибровочного набора. Текущее значение выбора отображается под кнопкой Select Cal Set .

Select Cal Set Щелкните, чтобы открыть диалоговое окно Select A Cal Set и выбрать калибровочный набор.

Create new Cal Set Установите флажок, чтобы создать новый калибровочный набор, в котором будет храниться калибровка. Уберите флажок, чтобы записать данные поверх выбираемого существующего калибровочного набора.

Next Щелкните, чтобы перейти к диалоговому окну Guided Calibration Steps.

Примечание: Запишите имя калибровочного набора для использования в будущем.

Cправка по диалоговому окну Guided Calibration Steps

Указывает вам последовательность подключения каждого калибровочного стандарта к измерительному порту.

Measure Щелкните, чтобы выполнить измерение стандарта.

Back Щелкните, чтобы повторить один или несколько шагов калибровки.

Done Щелкните после повторного измерения стандарта и завершения всех калибровочных измерений.

Next Щелкните, чтобы перейти к следующему шагу калибровки. (Не выполняет измерение стандарта.)

Cancel Выход из мастера калибровки.

После выполнения этих шагов открывается диалоговое окно Standards measured.

Cправка по диалоговому окну Standards measured

Оно сообщает, что все стандарты, требуемые для калибровки, были измерены.

Back Щелкните, чтобы повторно измерить калибровочный стандарт.

Next Щелкните, чтобы перейти к диалоговому окну Specify nominal delay или Guided Calibration Completed.

Cправка по диалоговому окну Specify nominal delay

Требуется оценка номинальной задержки.

OK Щелкните, чтобы подтвердить значение задержки в адаптере.

Для свипирования гармоническим колебанием (CW) или частотного свипирования с большим шагом частоты введите свое значение оценки поверх данных в поле ввода и нажмите OK.

Вычислите задержку, разделив физическую длину адаптера на скорость распространения.

Задержка = Длина / Скорость распространения

Cправка по диалоговому окну Guided Calibration completed

Позволяет вам закончить калибровку и перейти к следующим шагам создания характеристики.

No. Finish now Выберите, чтобы сохранить данные калибровочного набора.

Yes Позволяет устанавливать параметры сохранения.

Next Щелкните, чтобы перейти к диалоговому окну Exit to Inspect Quality of Calibration.

Cправка по диалоговому окну Exit to Inspect Quality of Calibration

Позволяет вам закончить калибровку и перейти к следующим шагам создания характеристики.

Back Позволяет вам повторить калибровку.

Next Щелкните, чтобы перейти к диалоговому окну Characterization Steps.

Cancel Выход из мастера калибровки.

Чтобы вернуться к текущему шагу:

  1. Начните создание пользовательской характеристики.

  2. В диалоговом окне Select user number for new characterization, щелкните Next.

  3. В диалоговом окне Select Connectors for Characterization, щелкните Next. (Предыдущая запись сохраняется в памяти.)

  4. В диалоговом окне Calibrations to perform or recall вызовите калибровочный набор, с которым вы только что работали.

Cправка по диалоговому окну Characterization Steps

Отображает инструкции для каждого измерения, необходимого для калибровки.

Measure Измеряет модуль ECal.

Next Щелкните, чтобы перейти к диалоговому окну Information for the New Characterization после завершения измерений.

Cправка по диалоговому окну Information for the New Characterization

Позволяет вам описать свойства пользовательской характеристики.

Next Щелкните, чтобы перейти к диалоговому окну Write Characterized Data to the ECal module.

Чтобы уменьшить количество символов, используйте для описания соединителей следующие 3-символьные коды.

Тип соединителя | 3-символьный код
2.4 мм гнездо | 24F
2.4 мм штекер | 24M
3.5 мм гнездо | 35F
3.5 мм штекер | 35M
7-16 гнездо | 16F
7-16 штекер | 16M
Type F гнездо | F7F
Type F штекер | F7M
N50 гнездо | N5F
N50 штекер | N5M
N75 гнездо | N7F
N75 штекер | N7M
APC 7 | 7MM
Волновод K-диапазона | KBW
Волновод P-диапазона | PBW
Волновод Q-диапазона | QBW
Волновод R-диапазона | RBW
Волновод U-диапазона | UBW
Волновод V-диапазона | VBW
Волновод W-диапазона | WBW
Волновод X-диапазона | XBW

Cправка по диалоговому окну Write Characterized Data to the ECal module memory

Анализатор записывает пользовательскую характеристику и данные заводской характеристики в память модуля ECal. Для дополнительной информации см. Восстановление памяти модуля ECAL.

Write Щелкните, чтобы записать данные в модуль ECal.

Диалоговое окно Updated Summary of ECal modules detected on USB откроется после сохранения данных в модуле.

Cправка по диалоговому окну Updated Summary of ECal modules detected on USB

Проверьте состояние модулей ECal, подключенных к анализатору.

Module 1, Module 2 Отображается следующая информация:

  • Номер модели модуля ECal

  • сводная информация из пользовательской характеристики

Cancel Щелкните, чтобы выйти (создание характеристики завершено).

Finish Щелкните, чтобы выйти (создание характеристики завершено).

Восстановление памяти модуля ECAL

Когда данные пользовательской характеристики записываются на модуль ECAL, все содержимое памяти ECAL также дублируется на жестком диске анализатора. В маловероятном случае, если память модуля ECAL будет потеряна, все пользовательские характеристики, помещавшиеся в память ECAL, можно будет восстановить.

Как восстановить память модуля ECAL

Дополнительная информация об интерфейсе передней панели

Cправка по диалоговому окну Module to be restored

Проверьте серийный номер восстанавливаемого модуля. Если к анализатору подключено два модуля, выберите из них тот, на который будут восстанавливаться данные.

Next Щелкните, чтобы записать данные в модуль.


Точность калибровок

Точность калибровок измерений

На точность калибровок влияет тип калибровки, качество эталонов и внимание, с которым выполняется процедура калибровки. В этом разделе содержится дополнительная информация о выполнении точных калибровок.

  • Плоскость отсчета измерения

  • Результаты использования неверных эталонов калибровки

  • Сравнение основанных на данных и полиномиальных калибровочных комплектов

  • Уровень точности интерполируемых измерений

  • Влияние уровня мощности

  • Установка системного сопротивления

  • Использование расширений портов

  • Часть 2-портовой калибровки, относящаяся к изоляции

  • Использование метода перемычки

Узнайте о том, как определить действительность калибровки.

Другие разделы по калибровке

Плоскость отсчета измерения

В большинстве конфигураций измерений НЕЛЬЗЯ подключать тестируемое устройство прямо к измерительным портам на передней панели анализатора. Более типичным является подключение устройства к тестовым приспособлениям или кабелям, которые соединяются с анализатором.

Для максимальной точности измерений калибровку необходимо выполнять в точке, где подключается исследуемое устройство. Это называется плоскостью отсчета измерения (см. рисунок). Если калибровка выполняется в этих точках, погрешности, связанные с тестовой конфигурацией (кабелями, тестовыми приспособлениями и адаптерами, используемыми между портами анализатора и плоскостью отчета измерения), измеряются и устраняются в процессе калибровки.

Результаты использования неверных эталонов калибровки

Обычно калибровка выполняется с помощью калибровочного комплекта, содержащего эталоны с соединителями того же вида и "пола", что и тестируемое устройство.

Однако тип разъемов вашего калибровочного комплекта может не совпадать с типом разъемов устройства. Например, предположим, что у устройства имеются соединители диаметром 3.5 мм, но в наличии есть лишь калибровочный комплект с соединителями типа N. Поэтому для подключения эталонов типа N к тестовому порту диаметром 3.5 мм используется переходник. Поскольку адаптер участвует в калибровке, но НЕ является частью тестовой конфигурации, это приведет к существенным погрешностям при измерении отражения. .

Сравнение основанных на данных и полиномиальных калибровочных комплектов

Диалоговое окно Select Cal Kit позволяет использовать как основанную на данных модель, так и полиномиальную модель при работе с новейшими высокочастотными калибровочными комплектами. См. аксессуары анализатора. Основанные на данных модели обеспечивают более высокую точность описания эталонов калибровки по сравнению с полиномиальными моделями. Если требуются как можно более точные результаты, НАСТОЯТЕЛЬНО рекомендуется использование основанных на данных моделей.

 | Основанная на данных модель | Полиномиальная модель
Насколько точна модель? | Обеспечивает высочайшую точность калибровки Устраняет погрешности, которые могут являться следствием использования приближений полиномиальной модели. | Обеспечивает высокую точность калибровки.
Каким образом модель определяет эталоны калибровки? | Используются измерения S-параметров. | Используется традиционный полиномиальный четырехчленный эталон калибровки.
Каким образом можно вручную редактировать определения калибровочных эталонов при использовании модели? | С помощью функции расширенного редактирования калибровочного комплекта. | С помощью функции расширенного редактирования калибровочного комплекта.
Как мастер калибровки работает с этой моделью? | Только с помощью управляемого метода калибровки (SmartCal). | С помощью управляемого метода калибровки (SmartCal) или неуправляемых методов механической калибровки.

См. функцию “Расширенные математические преобразования”.

Уровень точности интерполируемых измерений

Если текущие установки инструментов не полностью совпадают с теми, при которых была выполнена калибровка, анализатор может автоматически интерполировать вашу калибровку. В этом случае точность измерений предсказать нельзя. Точность измерений может быть существенно нарушена или не нарушена вообще. Определение погрешности измерений в таких ситуациях нужно проводить для каждого случая отдельно.

Существенная неточность в измерениях ОБЯЗАТЕЛЬНО появится, когда сдвиг по фазе между точками измерения возрастет более чем на 180 градусов. В этом случае анализатор будет неверно интерполировать новые фазовые данные. Для дополнительной информации см. фазовая точность.

В общем, вероятность возникновения существенной неточности при интерполяции измерений возрастает при следующих условиях:

  • при увеличении, а не уменьшении частотного диапазона между точками измерений.

  • когда частотный диапазон между точками измерений существенно возрастает.

  • когда частоты измерения очень высоки, особенно выше 10 ГГц.

См. Действительность калибровки для дополнительной информации об уровнях корректировки интерполяцией и определении точности калибровки.

Влияние уровня мощности

Для достижения максимально точной коррекции погрешностей НЕ изменяйте уровень мощности после выполнения калибровки. При изменении мощности без изменения диапазона ослабления измерения S-параметров могут выполняться с минимальной потерей точности. При выборе другого диапазона ослабления точность коррекции погрешностей значительно ухудшится.

Для проверки точности калибровки см. Действительность калибровки.

Установка системного сопротивления

Системное сопротивление можно изменить, чтобы выполнять измерения устройств, сопротивление которых не равно 50 Ом, например, волноводов.

Как изменить системное сопротивление

Дополнительная информация про интерфейс передней панели

Справка по диалоговому окну System Z0

Позволяет изменять системное сопротивление (значение по умолчанию 50 Ом).

Z0 Отображает текущее сопротивление системы.

Для устройств с сопротивлением 75 Ом:

  1. Установите значение Z0 системы в 75 Ом.

  2. Соедините анализатор и тестируемое устройство переходниками минимальных потерь (с сопротивлением 75 Ом).

  3. Выполните калибровку с использованием 75-омных калибровочных эталонов.

Для волноводов:

  1. Установите значение Z0 системы в 1 Ом.

  2. Выполните калибровку с использованием соответствующих волноводных эталонов.

Использование расширений портов

Используйте опцию расширений портов после калибровки, чтобы компенсировать фазовый сдвиг расширенной плоскости отсчета измерений, вызываемый добавлением кабелей, адаптеров и приспособлений.

Расширения портов являются простейшим способом компенсации фазового сдвига между калибровочной плоскостью отсчета и тестируемым устройством. Однако применение расширений портов не компенсирует рассогласование и потерю сигнала между плоскостью отсчета и тестируемым устройством. Поэтому для достижения наилучшей точности измерений необходимо минимизировать потерю сигнала и рассогласование, вызываемые тестовыми приспособлениями.

Для информации об использовании расширений портов см. расширения портов.

Для информации о создании характеристики тестового приспособления, см. приспособления.

Часть 2-портовой калибровки, относящаяся к изоляции

Часть калибровки, относящаяся к изоляции, вносит поправки на перекрестные помехи, утечку сигнала между измерительными портами, происходящую при отсутствии устройства. При выполнении НЕУПРАВЛЯЕМОЙ 2-портовой калибровки пользователь может пропустить часть калибровки, учитывающую изоляцию.

Примечание: Калибровка изоляции никогда не выполняется при интеллектуальной (управляемой) калибровке.

Влияние отсутствия некорректированной изоляции между измерительными портами анализатора является нетипичным (обычно >100 дБ). Поэтому выполнять часть 2-портовой калибровки, относящуюся к изоляции, нужно лишь когда требуется изоляция, лучшая, чем 100 дБ. Выполняйте калибровку изоляции при тестировании устройства с высокими вносимыми потерями, например, частотными фильтрами или разомкнутыми переключателями.

Калибровка изоляции может увеличить шум в модели погрешностей, если уровни измерения близки к уровню шума анализатора. Чтобы улучшить точность измерений, установите узкую полосу ПЧ.

Как выполнять калибровку изоляции

Изоляция измеряется с подключенными к измерительным портам анализатора мерами согласованной нагрузки. Для наилучшей точности, когда выводится запрос на подключение меры согласованной загрузки, подключайте меры согласованной загрузки к ОБОИМ измерительным портам. Если двух мер согласованной нагрузки нет в наличии, подключите к непроверенному порту анализатора любое устройство со сходными характеристиками.

Использование метода перемычки

Для понимания вариантов метода перемычки, нужно понимать описанные ниже термины. Эти определения применимы и для модулей ECal. При этом слова "Модуль ECal" заменяются на "устройство".

Невставляемое устройство - это устройство, соединители которого НЕЛЬЗЯ включить друг в друга. Либо используются соединители различной формы, либо они одного вида (две вилки или две розетки). Это значит, что кабели измерительного порта также нельзя соединить, как показано на следующем рисунке.

Вставляемое устройство - это устройство, соединители которого можно включить друг в друга. Используются соединители одной формы, и противоположного вида (вилка и розетка) или совместимые. В этом случае и кабели измерительного порта можно соединить между собой, как показано на следующем рисунке.

Выбор метода согласованной нагрузки при калибровке

Метод согласованной нагрузки выбирается в мастере калибровки. Установите флажок Preview/ Modify в диалоговом окне Select Cal Kits.

Примечание: Для ECal, следующие варианты имеют другие значения. См. методы перемычки для ECal.

Выбор для вставляемых устройств: FLUSH Thru(Прямая перемычка) (также называется Перемычкой нулевой длины)

При калибровке вставляемого устройства измерительные порты на плоскости отсчета измерения прямо соединяются друг с другом. Это называется перемычкой нулевой длины (zero-length THRU, Flush THRU), поскольку описание электрических характеристик, используемое при калибровке анализатором, имеет нулевую длину: нет задержки, нет потерь, нет емкости и индуктивности.

Хотя определение перемычки нулевой длины существует, в ваш калибровочный набор может не входить мера перемычки, если предполагается, что вы работаете со вставляемыми устройствами и будете использовать перемычку нулевой длины.

Выборы для невставляемых устройств

Для невставляемых устройств доступны следующие методы калибровки:

  • Удаление адаптера Точная, но наименее удобная.

  • Определенная перемычка

  • Калибровка неизвестной перемычкиl Предпочтительный метод.

(НЕ рекомендуется использовать метод обмена одинаковыми адаптерами.)

Калибровка с удалением адаптеров

Этот метод может быть очень точным. Однако он требует большого количества подключений, что повышает вероятность получить неточные данные.

Выполняются две полные 2-портовые калибровки: одна при адаптере, подключенном к порту 1, другая при подключении адаптера к порту 2. Результатом двух калибровок является одна полная 2-портовая калибровка, которая включает в себя создание точной характеристики и удаление создаваемого адаптером рассогласования.

Выполнение калибровки с удалением адаптера требует:

  • адаптера перемычки с такими же соединителями, как и на измеряемом устройстве.

  • стандартов калибровки для обоих соединителей измеряемого устройства.

Defined Thru (Определенная перемычка) (также называется Перемычкой калибровочного комплекта и Перемычкой ECal)

Примечание: При выполнении калибровки ECal этот вариант является стандартом перемычки (THRU) для модуля ECal.

Метод определенной перемычки использует определение перемычки(THRU), хранящееся в файле калибровочного комплекта или модуле ECal. Стандарт перемычки(THRU) со временем может изнашиваться, что делает его менее точным по сравнению с новым.

Метод определенной перемычки более точен, чем метод удаления устройства, но менее точен, чем метод неизвестной перемычки.

Чтобы определить стандарт перемычки (THRU) в калибровочном комплекте (не в модуле ECal):

  1. В меню анализатора выберите Calibration и щелкните Advanced Modify Cal Kits.

  2. Выберите калибровочный комплект.

  3. Щелкните Edit Kit (Редактировать комплект)

  4. Нажмите Add (Добавить)

  5. Выберите THRU (перемычка)

  6. Завершите работу с диалоговым окном.

В следующий раз, когда вы будете выполнять управляемую калибровку, можно будет использовать этот стандарт определенной перемычки (Defined THRU), для этого требуется, чтобы виды соединителей тестируемого устройства совпадали с видом соединителей стандарта перемычки.

Калибровка с неизвестной перемычкой

Калибровка с неизвестной перемычкой является рекомендуемым методом калибровки анализатора для измерения невставляемого устройства. Метод калибровки с неизвестной перемычкой доступен ТОЛЬКО на анализаторах, у которых на каждом измерительном порту установлен опорный приемник. См. модели анализаторов.

Для выполнения калибровки с неизвестной перемычкой анализатор выполняет измерение стандарта перемычки. Получаемые данные используются для уточнения вектора погрешности собственного ноля передачи.

Примечание: Начиная с версии 4.86 программного обеспечения анализатора, измерение калибровочных стандартов выполняется в специальном окне анализатора, появляющемся на время процесса калибровки. Ранее для выполнения измерений неизвестной перемычки использовалось 16-е окно. Теперь его использование не требуется.

В конце калибровки анализатор оценивает электрическую длину адаптера. Эта оценка может оказаться неправильной, если в данном диапазоне частот окажется слишком мало частотных точек.

Можно установить задержку, вычислив ее вручную, разделив физическую длину адаптера на скорость распространения сигнала.

Задержка = Длина / Скорость распространения

См. Использование ECAL для калибровки перемычки ECAL.


Достоверность калибровки

В этом разделе описываются процедуры, помогающие определить, является ли калибровка действительной, и как анализатор отображает информацию об уровне коррекции измерения.

  • Просмотр уровня коррекции

  • Проверка действительности калибровки

    • Быстрая проверка

    • Проверка надежности ECal

    • Комплект проверки надежности

Другие разделы по калибровке

Просмотр уровня коррекции

Уровень коррекции предоставляет информацию о точности активного измерения. Обозначение уровня коррекции выводится в панели состояния при различных типах калибровки, таких, как калибровка отражения, полная 2-портовая, калибровка TRL или калибровка мощности.

Чтобы просмотреть уровни коррекции:

В меню View щелкните Status Bar. Появляется строка состояния, в которой отображается следующее:

  1. Активный канал

  2. Параметр измерения

  3. Уровень коррекции (см. описание ниже)

  4. Тип калибровки

Уровень коррекции | Обозначение в строке состояния | Точность
Полная | C | Наивысшая
Интерполированная | C* | Неизвестна
Нет коррекции | No Cor | Минимальная

Полная коррекция (C)

Полный уровень коррекции появляется сразу после выполнения калибровки, или когда действительная калибровка вызывается из памяти.

Если требуется оптимальная точность, не изменяйте настройки анализатора после калибровки, чтобы изменение сохранило тот же уровень.

Интерполированная коррекция (C*)

Интерполированное измерение обозначается в строке состояния символами (C*). Интерполяция возникает при изменении любого из следующих параметров:

  • Время свипирования

  • Частота (подмножество Пуск/Стоп)

  • полоса ПЧ

  • мощность портов

  • Включение/выключение пошагового свипирования

  • Количество точек

Для информации о влиянии на точность измерения см. уровень точности интерполируемых измерений.

Примечание: Вывод частоты за границы диапазона Пуск/Стоп отключит коррекцию.

Нет коррекции

Если частотный диапазон расширяется за пределы начального диапазона частот (пуск/стоп), или если изменяется тип свипирования, текущая калибровка становится недействительной, и коррекция погрешностей отключается.

Анализатор указывает на отсутствие коррекции символами No Cor в панели состояния.

Включение/выключение интерполяции

Включение (ON) интерполяции в меню калибровки позволяет использовать интерполяцию в текущем измерении. Выключение (OFF), наоборот, отключает ее.

Проверка действительности калибровки

После завершения калибровки или при выборе сохраненного калибровочного комплекта, проверка действительности калибровки может:

Увеличить точность измерений – после завершения калибровки измерения рекомендуется проверить его показатели перед выполнением измерений устройств. Есть несколько источников погрешностей, способных сделать калибровку недействительной: плохие кабели, грязные или износившиеся калибровочные стандарты, уже не соответствующие моделируемым ими стандартам, и ошибки оператора.

Проверить точность интерполяции – Проверить действительность калибровки стоит, если вы выполняете измерения устройства, но достоверность измерений неизвестна из-за использования интерполяции. Для дополнительной информации см. уровень точности интерполируемых измерений.

Проверить точность калибровочных стандартов – Для проверки точности необходимо выполнить измерение устройства с известными значениями величины частотной неравномерности и ее фазы.

Быстрая проверка

Для этого теста нужны лишь несколько калибровочных стандартов. Используемое устройство не должно быть среди этих калибровочных стандартов; измерение одного из этих стандартов является лишь мерой повторяемости результатов. Тесты отражения и передачи можно выполнить на всех измерительных портах.

Для проверки измерений отражения выполните следующие шаги:

  1. Подключите к порту 1 стандарт ХХ или КЗ. Величина S11 должна быть близка к 0 дБ (в пределах нескольких десятых долей дБ).

  2. Подключите стандарт калибровки нагрузки к порту 1. Величина S11 должна быть меньше, чем указанная откалиброванная направленность анализатора (обычно менее -30 дБ).

Для проверки измерений передачи:

  1. Подключите кабель-перемычку (или известное устройство, соответствующее вашему измерению) между портом 1 и портом 2. Проверьте, равны ли характеристики потерь известным показателям кабеля или устройства.

  2. Чтобы проверить изоляцию S21, подключите две нагрузки: одну к порту 1 и одну к порту 2. Измерьте величину S21 и убедитесь, что она меньше, чем указанная изоляция (обычно менее -80 дБ).

Примечание: Для более точных диапазонов ожидаемых значений при этих измерениях обратитесь к спецификации на анализатор.

Проверка надежности ECal

Проверка надежности ECal позволяет проверить точность калибровки, выполненной с помощью механических стандартов или модуля ECal. Проверка надежности позволяет измерить состояние сопротивления модуля ECal (называемое состоянием надежности), и сравнить его с хранящимися в модуле заводскими данными.

Чтобы этот тест был действителен, необходимо подключить измерительные порты модуля ECal напрямую к плоскости отсчета калибровки (без адаптеров).

Чтобы выполнить проверку надежности ECal:

  1. Подключите модуль ECal к анализатору кабелем USB. См. подключение модуля ECal к анализатору. Примечание: Неиспользуемые порты ECAL необходимо терминировать нагрузкой в 50 Ом.

  2. Дайте модулю прогреться в течение 15 минут (20 минут для четырехпортового модуля) или до индикации модулем состояния READY (Готово).

  3. Чтобы начать проверку надежности ECal, нажмите Menu/Dialog, перейдите в меню Calibration и щелкните ECal Confidence Check.

>

Откроется диалоговое окно ECal Confidence Check.

  4. Щелкните Read Module Data. Произойдет следующее:
    · Модуль ECal перейдет в "состояние надежности".
    · Анализатор прочтет и отобразит сохраненные данные.
    · Анализатор измерит и отобразит "состояние надежности".

  5. Если необходимо просмотреть другой параметр, выберите Change Measurement и щелкните флажок для указанного параметра. (По умолчанию выводится параметр активного канала).

  6. Выберите просмотр в блоке Trace View Options.

  7. Сравните сохраненные и измеренные данные для каждого параметра измерения.

Примечания:

  • Если два графика существенно различаются, возможно, соединение в измерительных портах нарушено или загрязнено, или измерительные кабели повреждены. Внимательно осмотрите кабели и соединители. Затем очистите и проверьте каждый соединитель, при необходимости выполните повторную калибровку.

  • Параметр User Characterization использует данные пользовательской характеристики вместо заводской характеристики (он доступен, когда данные пользовательской характеристики сохранены в модуле ECal).

Справка по диалоговому окну ECal Confidence Check

Сравнивает точность откорректированных (калиброванных) данных с сохраненными в модуле ECal данными. Чтобы этот тест был действителен, необходимо подключить измерительные порты напрямую к плоскости отсчета калибровки (без адаптеров).

Measurement (Измерение)

Change Measurement Открывает диалоговое окно Measure (измерение).

Use ECal Module

Read Module Data

  • Копирует сохраненные данные из модуля ECal в память.

  • Переводит модуль ECal в состояние надежности.

  • Измеряет и выводит состояние надежности и трассировку памяти.

User Characterization Выбирает использование данных пользовательской характеристики (хранящихся в модуле) вместо заводских данных характеристики (доступно, когда пользовательская характеристика сохранена в модуле ECal).

Scale Открывает диалоговое окно Scale (Масштаб).

Show Prompts Установите флажок, чтобы получать напоминания для подключений (по умолчанию).

Trace View Options (Параметры просмотра трассировки)

Data and Memory Trace Отображает данные текущего измерения и трассировку памяти.

Data / Memory Выполняет операцию, при этом текущие данные измерения делятся на данные в памяти.

Data + Memory Выполняет операцию, при этом данные текущего измерения добавляются к данным в памяти.

Verification Kit (Проверочный комплект)

Измерение устройств с известными характеристиками, но не калибровочных наборов, является простым способом проверки, правильно ли функционирует анализатор цепей. Проверочные комплекты содержат заведомо точные проверочные стандарты с чётко определенными характеристиками (амплитудой и фазой). В эти наборы входят точные магистрали, магистрали рассогласования и точные фиксированные ослабители. Отслеживаемые данные измерений поставляются на диске с каждым комплектом, при этом Agilent может повторно сертифицировать проверочные комплекты.

См. Аксессуары анализатора для списка проверочных комплектов Agilent.


Погрешности измерений

Можно увеличить точность, если знать, каким образом возникает погрешность и как ввести поправку на неё. В этом разделе обсуждаются источники погрешностей измерения и способы отслеживания вектора погрешности.

  • Погрешности из-за ухода параметров

  • Случайные погрешности

  • Систематические погрешности

  • Отслеживание вектора погрешности

Другие разделы по калибровке

Ошибки из-за ухода параметров

  • Ошибки из-за ухода параметров возникают из-за изменения характеристик инструменов или измерительной системы после выполнения калибровки.

  • Ошибки из-за ухода характеристик возникают главным образом из-за влияния теплового расширения кабелей-соединителей в тестовом наборе и стабильности преобразования в микроволновом преобразователе частот; от них можно избавиться путем повторной калибровки.

  • Период времени, в течение которого калибровка остается точной, зависит от скорости дрейфа, испытываемого измерительной системой в конкретной среде испытаний.

Обычно обеспечение стабильной окружающей температуры минимизирует дрейф. Для дополнительной информации см. стабильность измерений.

Случайные погрешности

Случайные погрешности непредсказуемы и не могут быть устранены с помощью коррекции погрешностей. Однако есть способы, позволяющие уменьшить их влияние на точность измерений. Ниже описаны три основных причины существования случайных погрешностей.

Погрешности шума инструментов

Шум - это нежелательные электрические возмущения, создаваемые в компонентах анализатора. К этим возмущениям относятся:

  • Низкоуровневый шум, связанный с порогом шума приемника.

  • Высокоуровневый шум или дрожание данных трассировки, связанное с порогом шума и фазовым шумом источника LO (гетеродина) в тестовом наборе.

Связанные с шумом ошибки можно уменьшить следующими способами:

  • Увеличив мощность источника, подаваемую на тестируемое устройство.

  • Сузив полосу ПЧ.

  • Применив несколько средних значений свипирования измерения.

Погрешности повтора переключений

  • Механические переключатели РЧ используются в анализаторе для переключения настроек ослабления источника.

  • Иногда при активации механических РЧ переключателей контакты могут замыкаться не таким образом, как в предыдущий раз. Если это происходит в анализаторе, это может существенно повлиять на точность измерения.

  • Эффекты погрешности повтора переключений можно существенно уменьшить, не переключая настройки ослабления во время важных измерений.

Погрешности повтора соединителей

Износ соединителей вызывает изменение электрических характеристик. Погрешности повтора соединителей можно уменьшить, хорошо выполняя уход за соединителями. См. Уход за коннекторами.

Систематические погрешности

Систематические погрешности вызываются несовершенством анализатора и тестовой конфигурации.

  • Они повторяемы (и поэтому предсказуемы), и, предполагается, независимы от времени.

  • Их можно охарактеризовать в процессе калибровки и математически уменьшить во время измерений.

  • Их никогда нельзя убрать полностью. В связи с ограничениями процесса калибровки всегда существует определенная остаточная погрешность. Остаточные (после калибровки измерения) систематические погрешности вызываются:

    • Несовершенством калибровочных стандартов

    • интерфейсами соединителей

    • соединительными кабелями

    • инструментарием

Измерения Отражения (Reflection) порождают три следующие систематические погрешности:

  • Направленность

  • Согласование источника

  • Погрешность собственного нуля отражения

Измерения Передачи (Transmission) порождают три следующие систематические погрешности:

  • Изоляция

  • Согласование нагрузки

  • Погрешность собственного нуля передачи

Примечание: Показатели следующих шести систематических погрешностей указаны для соответствующего оборудования, настроенного для прямого измерения. Для обратных измерений внутренние переключатели анализатора делают порт 2 источником, а порт 1 - приемником. При этом канал 'A' становится приемником переданного сигнала, канал 'B' становится приемником отраженного сигнала, а канал 'R2' становится опорным приемником. Эти шесть систематических погрешностей, умноженные на два направления, дают 12 систематических погрешностей для двухпортового устройства.

Погрешность направленности

Все анализаторы цепей выполняют измерения отражения с помощью направленных ответвителей или мостов.

В идеальном ответвителе в канале 'A' должен появляться лишь отраженный от тестируемого устройства сигнал. В действительности небольшая доля исходного сигнала протекает через цепь прямой передачи ответвителя в канал 'A'.

Эта погрешность измерения называется погрешностью направленности. Её можно измерить в анализаторе и уменьшить.

Каким образом анализатор измеряет и уменьшает погрешность направленности.

  1. При калибровке стандарт согласованной нагрузки подключается к порту 1. Предполагается, что у нагрузки отстутствуют отражения.

  2. Сигнал, измеренный в канале 'A', появляется из-за утечки исходного сигнала через ответвитель.

  3. Погрешность направленности вычитается из последующих измерений отражения.

Погрешность изоляции

В идеале лишь передаваемый через тестируемое устройство сигнал должен измеряться в канале 'B'.

В действительности небольшая доля сигнала протекает через различные цепи в анализаторе в канал 'B'

Утечка сигнала, также известная как перекрестные наводки, является погрешностью изоляции, которая может быть измерена и уменьшена анализатором.

Каким образом анализатор измеряет и уменьшает погрешность изоляции

  1. Во время калибровки стандарты согласованной нагрузки подключаются к портам 1 и 2.

  2. Сигнал, измеряемый в порту 'B', является утечкой сквозь различные цепи анализатора

  3. Эта погрешность изоляции вычитается из последующих измерений передачи.

Погрешность согласования источника

В идеале при измерениях отражения весь отраженный от тестируемого устройства сигнал измеряется в канале 'A'.

В действительности часть сигнала, отраженного от тестируемого устройства, снова отражается от порта 1 и не измеряется в канале 'A'.

Эта погрешность измерения называется погрешностью согласования источника, она которая может быть измерена и уменьшена анализатором

Каким образом анализатор измеряет и уменьшает погрешность согласования источника

  1. При калибровке стандарт КЗ подключается к порту 1. Известные отражения от КЗ измеряются в канале 'A' и сохраняются в анализаторе.

  2. Стандарт ХХ подключается к порту 1 . Известные отражения от КЗ измеряются в канале 'A' и сохраняются в анализаторе.

  3. Анализатор сравнивает два сохраненных сигнала. Разница между двумя сигналами возникает из-за погрешности согласования источника.

  4. Погрешность согласования источника вычитается из последующих измерений отражения и передачи.

Погрешность согласования нагрузки

В идеале при измерениях передачи сигнал передается сквозь тестируемое устройство и измеряется в канале 'B'.

В действительности часть сигнала отражается от порта 2 и не измеряется в канале 'B'.

Эта погрешность измерения называется погрешностью согласования нагрузки, она которая может быть измерена и уменьшена анализатором.

Каким образом анализатор измеряет и уменьшает погрешность согласования нагрузки

  1. Соединители порта 1 и порта 2 подключаются друг к другу, создавая тем самым идеальную перемычку нулевой длины. (если это невозможно, тогда между ними помещается адаптер перемычки). Это создает известный уровень набегающего сигнала в порту 2.

  2. В канале 'А' измеряется сигнал, отражающийся от порта 2

  3. Получаемая погрешность согласования нагрузки вычитается из последующих измерений отражения и передачи.

Погрешность собственного нуля отражения

Измерения отражения производятся путем сравнения сигнала в канале 'A' (канале отражения) с сигналом в канале 'R1' (опорном канале). Это называется измерением отношения, а также "A от R1" (A/R1).

Для идеального выполнения измерений отражения частотные характеристики приемников каналов 'A' и 'R1' должны совпадать.

В действительности они не совпадают, что вызывает погрешность собственного нуля отражения. Это векторная сумма всех вариантов тестов, в которых амплитуда или фаза изменяются в зависимости от частоты. В нее входят вариации, вносимые:

  • устройствами разделения сигналов

  • измерительными кабелями

  • адаптерами

  • различиями между путем прохождения опорного и тестового сигналов

Погрешность собственного нуля отражения может быть измерена и уменьшена анализатором.

Как анализатор изменяет и уменьшает погрешность собственного нуля отражения.

  1. При калибровке стандарт КЗ подключается к порту 1. Известные отражения от КЗ измеряются в канале 'A' и сохраняются в анализаторе.

  2. Стандарт ХХ подключается к порту 1 . Известные отражения от КЗ измеряются в канале 'A' и сохраняются в анализаторе.

  3. Анализатор рассчитывает среднее значение двух сохраненных сигналов канала 'A'.

  4. Средняя характеристика канала 'A' сравнивается с опорным сигналом, измеряемым в 'R1'.

  5. В результате получается разность частотных характеристик каналов 'A' и 'R1' (см рисунок ниже). Эта погрешность собственного нуля отражения вычитается при последующих измерениях тестируемого устройства.

Примечание: При калибровках характеристик отражения выполняется измерение лишь одного калибровочного стандарта (ХХ или перемычки), поэтому при коррекции погрешности учитывается лишь он.

Погрешность собственного нуля передачи

Измерения передачи производятся путем сравнения сигнала в канале 'B' (канале передачи) с сигналом в канале 'R1' (опорном канале). Это называется измерением отношения, а также "B от R1" (B/R1).

Для идеального выполнения измерений передачи частотные характеристики приемников каналов 'B' и 'R1' должны совпадать.

В действительности они не совпадают, что вызывает погрешность собственного нуля передачи. Это векторная сумма всех вариантов тестов, в которых амплитуда и фаза изменяются в зависимости от частоты. В нее входят вариации, вносимые:

    • устройствами разделения сигналов

    • измерительными кабелями

    • адаптерами

    • различиями между путем прохождения опорного и тестового сигналов

Погрешность собственного нуля передачи может быть измерена и уменьшена анализатором.

Как анализатор изменяет и уменьшает погрешность собственного нуля передачи.

  1. Соединители порта 1 и порта 2 подключаются друг к другу, создавая тем самым идеальную перемычку нулевой длины. (если это невозможно, тогда между ними помещается адаптер перемычки). Это создает известный уровень набегающего сигнала в порту 2.

  2. В каналах 'B' и 'R1' выполняются измерения, их результаты сохраняются.

  3. Анализатор сравнивает сигналы в каналах 'R1' и 'B'.

  4. В результате получается разность частотных характеристик каналов 'B' и 'R1' (см. рисунок ниже). Эта погрешность собственного нуля передачи вычитается при последующих измерениях.

.

Отслеживание вектора погрешности с помощью программы просмотра калибровочных наборов

Анализатор вычисляет вектор погрешности, выполняя измерения калибровочных устройств с точно известными характеристиками в требуемом диапазоне частот. Затем он сравнивает данные измерений с идеальной моделью каждого из устройств. Различия, получаемые при сравнении данных, представляют собой систематическую(повторяемую) погрешность системы анализатора. Эти различия сохраняются в виде вектора погрешностей и вычитаются из последующих измерений при включении коррекции погрешностей. Информация о векторах погрешностей.

Программой просмотра калибровочных наборов можно пользоваться для отслеживания данных измерений и рассчитываемого вектора погрешности. Это помогает оценить техническое состояние анализатора и точность измерений.

Сохраняя вектор погрешности или выводя его на печать, можно регулярно сравнивать текущий вектор погрешности с предыдущими, созданными на том же анализаторе с использованием одинаковых настроек измерений и калибровочных комплектов. Если информация по предыдущим значениям отсутствует, обратитесь к типичным данным векторов погрешности в приложении А, "Векторы погрешности", руководства по обслуживанию (Service Guide).

Примечание: Это руководство по обслуживанию анализатора доступно по адресу http://www.agilent.com/find/pna
Оно также находится на компакт-диске, входящем в комплект поставки анализатора.

  • Стабильная система должна выдавать повторяющиеся векторы погрешности в течение более шести месяцев.

  • Внезапные сдвиги в векторе погрешности в одном и том же диапазоне частот, мощности и настройках приемника могут указывать на необходимость проверки состояния компонентов системы. Для информации об определении причины проблем с вектором погрешности см. Приложение А, "Вектор погрешности", Руководства по обслуживанию (Service Guide).

  • Незаметное, постепенное изменение в векторе погрешности часто отражает дрейф либо износ соединителей и кабелей. Часто его можно устранить, всего лишь очистив и проверив соединители, а также проверив кабели.

Как отслеживать вектор погрешности

Нажав "стрелку вниз", выберите калибровочный набор

Щелкните один из вариантов

  • Error Terms - рассчитываемые данные

  • Standards - необработанные данные измерения стандарта

С помощью стрелки вниз выберите необходимый вектор погрешности или стандарт

Установите флажок Enable, чтобы просмотреть данные на экране анализатора.

Дополнительная информация про интерфейс передней панели

Просмотр данных калибровочного набора

  • Существующие графики измерений при использовании программы просмотра калибровочных наборов не изменяются.

  • Графики данных калибровочных наборов отображаются в неиспользуемом канале с наивысшим номером (обычно 32) в активном окне.

  • Графики данных калибровочных наборов маркируются как S11 в строке состояния независимо от типа вектора погрешности или стандарта.

  • Одновременно можно просматривать лишь один вектор погрешности калибровочного набора или данные стандарта. Однако данные графика можно сохранить в памяти и затем сравнить с тем же вектором погрешности из другого калибровочного набора.

  • Данные ECAL не содержат информации по стандарту, они содержать только вектор погрешности.

Автоматическая загрузка вектора погрешностей

Обратитесь к закладке калибровки Command Finder для информации о командах SCPI и COM, загружающих и сохраняющих вектор погрешностей.


Изменение калибровочных комплектов

Файлы калибровочных комплектов можно создавать или изменять с помощью расширенного изменения калибровочных комплектов.

  • Про изменение калибровочных комплектов

  • Создание нового калибровочного комплекта из существующего

  • Создание специальных калибровочных комплектов, использующих новые семейства соединителей

  • Как изменять калибровочные комплекты

Другие разделы по калибровке

Про изменение калибровочных комплектов

Можно изменять файлы калибровочных комплектов или создавать специальные комплекты.

Примечание: ТЕПЕРЬ можно изменять и основанные на данных калибровочные комплекты. Дополнительная информация.

Для большинства применений модели калибровочных комплектов по умолчанию обеспечивают достаточную точность калибровки. Однако существуют ситуации, в которых может потребоваться создание специального калибровочного комплекта:

  • Использование интерфейса соединителя, отличающегося от указанного в предопределенных моделях калибровочных комплектов

  • Использование стандарта (или комбинации стандартов), отличающегося от указанных в предопределенных калибровочных комплектах Например, использование трех КЗ смещения вместо ХХ, КЗ и согласованной нагрузки при выполнении 1-портовой калибровки.

  • Улучшение точности моделей из предопределенных наборов. Когда модель описывает действительные характеристики стандарта, калибровка является более точной. (Пример: 7-мм согласованная нагрузка определяется, как имеющая сопротивление 50.4Ω, а не 50.0Ω.)

  • Изменение определения перемычки при выполнении калибровки невставляемого устройства.

  • Выполнение калибровки TRL.

Создание нового калибровочного комплекта на основе существующего

Можно создать новый специальный калибровочный комплект, используя как исходную точку существующий калибровочный комплект. Как это сделать:

  1. В диалоговом окне Edit PNA Cal Kits щелкните Import Kit, чтобы загрузить калибровочный комплект, который будет использоваться, как исходная точка. Появится сообщение "Duplicate Name..." (Повторяющееся имя). Нажмите OK, чтобы загрузить копию калибровочного комплекта в конец списка в диалоговом окне Edit PNA Cal Kits.

  2. Выберите импортированный комплект.

  3. Щелкните Edit Kit, затем измените имя и описание калибровочного комплекта.

  4. Щелкните Installed Kits - Save As, чтобы сохранить новый калибровочный комплект в файл .ckt.

  5. Рекомендуется: щелкните также Edit PNA Cal Kits - Save As, чтобы сохранить всю коллекцию калибровочных комплектов в файл .wks.

  6. При использовании нового или модифицированного соединителя щелкните Change Family, чтобы изменить семейство соединителя.

  7. Щелкните Add or Edit, чтобы изменить описания и характеристики соединителей.

  8. Внесите необходимые изменения в новый специальный калибровочный комплект. Сохраните изменения, щелкнув Installed Kits - Save As

Создание специальных калибровочных комплектов, использующих новые семейства соединителей

Чтобы создать специальный калибровочный комплект, в котором используются новые типы соединителей, необходимо сначала определить семейство соединителей. Семейство соединителей - это имя типа соединителей в калибровочном комплекте, например:

  • APC7

  • 2.4 мм

  • Тип-N (50Ω)

Хотя допустимо использование более одного семейства соединителей, рекомендуется ограничить количество семейств соединителей одним для каждого калибровочного комплекта.

Если используется семейство соединителей, в котором есть соединители типа "штекер" и типа "гнездо", включите описания обоих типовю Если в используемом семействе нет разделения на типы "штекер" и "гнездо", например, для соединителей APC7, тогда требуется лишь одно описание соединителя.

Выполните следующие шаги, чтобы создать специальный комплект калибровки:

  1. В диалоговом окне Edit PNA Cal Kits dialog box, щелкните Insert New, чтобы добавить новое семейство соединителей.

  2. В диалоговом окне Edit Kit:

    • Введите описание специального калибровочного комплекта.

    • Щелкните Add в части Connectors диалогового окна.

  3. В диалоговом окне Add Connector:

    • Введите имя семейства соединителей.

    • Введите описание соединителя.

    • Выберите тип (штекер/гнездо) одного из соединителей.

    • Введите минимум и максимум диапазона частот.

    • Введите сопротивление.

    • Нажав "стрелку вниз", выберите носитель.

    • Введите критическую частоту.

    • Щелкните Apply.

    • Щелкните OK.

  4. Если требуется добавить и другой тип (штекер/гнездо) соединителя, тогда в диалоговом окне Edit Kit dialog box:

    • Щелкните Add в разделе Connectors, еще раз для дополнительного типа (штекер/гнездо) соединителя.

  5. При добавлении еще одного типа (штекер/гнездо) соединителя повторите шаг 3.

Примечание: Если в семействе есть варианты типа "штекер" и "гнездо" соединителя, вероятно, варианта БЕЗ ТИПА НЕ существует.

  6. После того, как семейство соединителей добавлено в специальный калибровочный набор, можно добавлять новые калибровочные стандарты. В диалоговом окне Edit Kit:

    • Щелкните Add под списком стандартов.

  7. В диалоговом окне Add Standard:

    • Выберите тип стандарта (ХХ, КЗ, согласованная нагрузка или перемычка) (OPEN, SHORT, LOAD, or THRU).

    • Щелкните OK.

  8. В диалоговом окне Edit/Add Standards:

    • Введите в диалоговом окне информацию по выбранному вами стандарту. Учтите, что у полосовых стандартов начальная и конечная частоты могут отличаться от диапазона частот указанного соединителя. По необходимости измените начальные и конечные частоты.

    • Щелкните OK, когда все настройки будут указаны верно.

  9. Повторяйте при необходимости шаги 6 - 8, пока все стандарты и определения не будут добавлены в новый специальный калибровочный набор.

  10. Назначьте каждому из стандартов класс калибровки. Это делается в диалоговом окне Modify Calibration Class Assignment.

  11. Щелкните File, PrintToFile. PrintToFile создаст файл .prn (файл ascii, поля разделены запятыми), который можно импортировать в программу электронных таблиц.

  12. Импортируйте файл .prn в приложение, например, в Microsoft Excel, и распечатайте данные.

  13. Просмотрите электронную таблицу, чтобы убедиться, что каждый стандарт из комплекта принадлежит к одному и тому же семейству стандартов, а тип (штекер/гнездо) каждого стандарта указан верно. Для правильной работы SmartCal (управляемой калибровки) необходимо, чтобы соединители и типы стандартов (штекер/гнездо) были правильно определены и проверены.

Как изменять калибровочные комплекты

Описанные ниже последовательности диалоговых окон позволяют изменять определения стандартов или назначения классов в файлах калибровочных комплектов.

Как начать расширенное изменение калибровочного комплекта

Дополнительная информация про использование интерфейса передней панели

Редактирование калибровочных комплектов анализатора

Справка по диалоговому окну Edit PNA Cal Kits

Обеспечивает доступ ко всем калибровочным комплектам Agilent, позволяет изменять их стандартные определения.

Калибровочные комплекты анализатора и обновления микропрограмм

  • При установке новых микропрограмм используемые по умолчанию "заводские" калибровочные комплекты стираются и перезаписываются. Специальные калибровочные комплекты пользователя (файлы с нестандартными именами) НЕ перезаписываются. Однако необходимо выполнить импорт калибровочных комплектов (щелкните Import Kit) в новые микропрограммы.

  • Все калибровочные комплекты анализатора можно импортировать в текущую и более новые версии микропрограмм. Их НЕЛЬЗЯ импортировать в ПРЕДЫДУЩИЕ версии микропрограмм. После того, как калибровочный комплект импортирован в более позднюю версию микропрограммы, его уже нельзя импортировать в более раннюю версию микропрограммы, включая и ту, в которой он был создан.

  • При выполнении обновления микропрограммы ВСЕ калибровочные комплекты, содержащиеся в анализаторе, как заводские, так и пользовательские, сохраняются в один файл *.wks с уникальным именем. Эти файлы НЕ являются файлами электронных таблиц Excel. Их можно открыть с помощью кнопки Open (см. ниже). Их можно использовать как архивы калибровочных комплектов предыдущих версий микропрограмм.

Open Открывает архив калибровочных комплектов, созданный при предыдущих обновлениях микропрограмм или выполнении операции 'Save As'.

Save As Сохраняет все калибровочные комплекты анализатора в файл *.wks.

Restore Defaults Восстанавливает содержимое по умолчанию (заводское) всех калибровочных комплектов Agilent с жесткого диска анализатора. Заводские калибровочные комплекты Agilent хранятся на жестком диске анализатора в директории C:\Program Files\Agilent\Network Analyzer\PnaCalKits\factory.

Установленные комплекты

Import Kit Вызывает диалоговое окно Import Kit.

Save As Сохраняет выбранный калибровочный комплект и определения (в файл типа .ckt).

Insert New Вызывает пустое диалоговое окно Edit Kit, для создания новых определений калибровочного комплекта.

Print to File Выводит содержимое выбранного калибровочного комплекта в файл .prn

Edit Kit... Вызывает диалоговое окно Edit Kit, позволяющее изменить определения выбранного калибровочного комплекта.

Примечание: ТЕПЕРЬ можно изменять и основанные на данных калибровочные комплекты. Дополнительная информация.

Delete Удаляет выбранный файл калибровочного комплекта.

^ Выбирает предыдущий/следующий калибровочный комплект в списке.

Для дополнительной информации см. Создание специальных калибровочных комплектов, использующих новое семейство соединителей.

Справка по диалоговому окну Import Kit

IИмпортирует определения калибровочного комплекта с жесткого диска или другого устройства, сохраненные в различных форматах. Анализаторы версии 4.0 или более поздней позволяют импортировать четыре типа комплектов.

Примечание: см. калибровочные наборы анализатора и обновление микропрограмм

Files of type Выберите тип файла калибровочного комплекта

Формат калибровочного комплекта | Тип файла
Калибровочный комплект анализатора текущих версий | *.ckt
Калибровочный комплект старых версий анализатора (Версии 1) | *.ck1
Калибровочный комплект анализатора 8510 | CK_*
Калибровочный комплект анализаторов 8753, 8752, 8719, 8720 или 8722 | *.ck

File name Выберите расположение и файл калибровочного комплекта.

Open Открывает указанный файл. Комплект добавляется в конец списка калибровочных комплектов.

Импортирование комплектов анализаторов, не относящихся к текущей серии

Калибровочные комплекты "устаревших" анализаторов цепей Agilent (перечисленных выше) могут не содержать всю требуемую для анализатора информацию. Поэтому анализатор может изменить имя и описание калибровочного комплекта, калибровочные стандарты и назначения классов, пытаясь достичь "наилучшего приближения". После импорта "устаревшего" калибровочного комплекта может потребоваться редактирование этих параметров.

  • Устаревшие калибровочные комплекты основываются на типе(штекер/гнездо) измерительного порта анализатора; калибровочные комплекты текущих анализаторов основываются на типе (штекер/гнездо) соединителей тестируемого устройства. Поэтому при импорте комплекта ярлык и описание стандарта реверсируются и записыватся как –F- (гнездо) и –M- (штекер).

  • Если в файле комплекта обнаруживается коаксиальный стандарт, обычно создается пара соединителей "штекер/гнездо".

  • Стандарты волноводов, создаваемые, как "соединители", не имеют типа (штекер/гнездо).

Справка по диалоговому окну Edit Kit

Identification (Идентификация)

Kit Number Номер выбранного калибровочного комплекта.

Kit Name Позволяет изменять имя выбранного калибровочного комплекта.

Kit Description Позволяет изменять описание выбранного калибровочного комплекта.

Connectors (Соединители)

Примечание: Соединитель с новым или измененным именем НЕЛЬЗЯ использовать при выполнении назначения пользовательской характеристики ECal.

Щелкните по стрелке вниз, чтобы изменить тип соединителя.

Add or Edit Вызывает диалоговое окно Add or Edit Connector, в котором можно добавить новый тип соединителя в калибровочный набор или изменить свойства соединителя.

Change Family Вызывает диалоговое окно Change Connector Family, в котором можно переименовать все семейство соединителей.

Class Assignments (Назначения классов)

Щелкните по стрелке вниз, чтобы изменить назначения классов.

Edit вызывает диалоговое окно Modify Calibration Class Assignments.

Standards in Kit (Стандарты в комплекте)

Перечисляет текущие стандарты и описания, находящиеся в калибровочном комплекте.

Add... Вызывает диалоговое окно Add Standard, позволяющее добавлять определения для стандарта.

Edit... Вызывает диалоговое окно Edit dialog box, позволяющее изменить определения стандарта выбранного стандарта: КЗ, ХХ, согласованная нагрузка, перемычка (Open, Short, Load, или Thru).

Delete Удаляет выбранный стандарт из калибровочного комплекта.

Справка по диалоговому окну Add or Edit Connector

Identification (Идентификация)

Примечание: Соединитель с новым или измененным именем НЕЛЬЗЯ использовать при выполнении назначения пользовательской характеристики ECal.

Connector Family Позволяет добавить(Add) или изменить(Edit) имя определенного соединителя. Если имя семейства соединителей изменяется на новое, уникальное имя, это имя и выбранный тип(штекер/гнездо) ДОБАВЛЯЕТСЯ в список соединителей этого комплекта.

Примечание: Чтобы изменить имя семейства соединителей для всех соединителей в наборе, щелкните Change Family в предыдущем диалоговом окне.

Description Отображает тип соединителя и вид (штекер/гнездо).

Frequency Range (Диапазон частот)

Min Позволяет определить самую низкую частоту, при которой стандарт используется для калибровки.

Max Позволяет определить самую высокую частоту, при которой стандарт используется для калибровки.

Gender

Позволяет определить тип (штекер/гнездо) соединителя.

Impedance

Позволяет определить сопротивление стандарта.

Media

Позволяет определить носитель (или 'геометрию') соединителя (КОАКСИАЛЬНЫЙ или ВОЛНОВОД).

Cutoff Frequency Если используется тип носителя - волновод, введите нижнюю критическую частоту волновода.

См. также: Создание нового калибровочного комплекта на основе существующего калибровочного комплекта

Справка по диалоговому окну Change Connector Family

Примечание: Соединитель с новым или измененным именем НЕЛЬЗЯ использовать при выполнении назначения пользовательской характеристики ECal.

Выполняет функцию "Поиск и замена" по тексту. По полю описания каждого из стандартов текущего калибровочного набора выполняется поиск исходного имени соединителя(Previous Connector Name) и замена на новое имя соединителя(New Connector Name).

Specify New Connector Name Позволяет заменить исходное имя семейства соединителей из выбранного набора на новое имя семейства соединителей. Анализатор допускает существование нескольких семейств соединителей в одном наборе.

Previous Connector Name Отображает исходное имя семейства соединителей. Все вхождения исходного имени семейства соединителей в диалоговых окнах калибровки будут заменены. Это включает ярлыки калибровочного набора и поля описания.

Примечания:

  • Замена строк требует точного совпадения и чувствительна к размеру символов. Например, "Тип N" не соответствует строке "тип N", а "apc 7" не соответствует строке "APC 7".

  • В некоторых калибровочных комплектах могут быть указаны имена соединителей, не совпадающие со строками в ярлыках или полях описания. Можно использовать диалог Change Connector Name несколько раз подряд, чтобы стандартизировать имена в наборе, а затем заменить стандартное имя на новое.
    Пример    :
    Выберите калибровочный комплект 85056A. По умолчанию имя соединителя "APC 2.4". Однако многие стандартные файлы описания имеют метку "2.4 mm". При необходимости можно заменить имя семейства соединителей на новое, и обновить описания стандартов, чтобы они совпадали с новым именем. Для этого комплекта выполните следующие два шага.

    1. С помощью диалога Change Connector Name замените "APC 2.4" на "2.4 мм".

    2. С помощью диалога Change Connector Name замените "2.4 мм" на новое имя, "PSC 2.4 мм".

См. также Создание нового калибровочного комплекта на основе существующего калибровочного комплекта

Если в поле Class Assignment диалогового окна Edit Kit выбрано TRL, появляются следующие изменения:

Справка по диалоговому окну Modify Calibration Class Assignments

Позволяет назначить одному или нескольким стандартам класс. Чтобы добавить или редактировать стандарты, щелкните Calibration, затем щелкните Advanced Modify Cal Kit.

Чтобы назначить стандарту калибровочный класс:

  1. Выберите Calibration Class

  2. Выберите стандарт из поля Unselected Standards field

  3. Щелкните стрелку вправо, чтобы переместить стандарт в поле Selected Standards .

Примечания:

  • Во время неуправляемой калибровки доступны все стандарты из поля Selected Standards. Можно выбирать, с какими из них будут выполняться измерения.

  • Стандартам MATCH должны назначаться классы FWD MATCH, REV MATCH или LINE. См. Калибровки TRL для дополнительной информации о стандартах TRL.

  • Используйте кнопки MOVE UP и MOVE DOWN, чтобы изменить ПОРЯДОК указания стандартов. Порядок важен при управляемой калибровке, чтобы определить приоритет при перекрытии, когда:

    • Multiple standards are valid for a frequency (Для частоты подходят несколько стандартов) - стандарты выводятся в порядке, в котором они указаны.

    • Using two sets of standards (Используются два набора стандартов) - измените порядок, в котором будут выводиться стандарты, чтобы он соответствовал конфигурации тестируемого устройства. Например, для тестируемого устройства с соединителем типа "штекер" на порту 1 и соединителем типа "гнездо" на порту 2 можно установить такой порядок устройств в классах S11 (A, B и C), что стандарты типа ШТЕКЕР будут первыми в списке. Затем можно упорядочить классы S22 таким образом, что стандарты типа ГНЕЗДО будут первыми в списке.

Calibration Class Label (Метка класса калибровки)

Это метка, выводимая в диалоговом окне Unguided Cal - Measure Mechanical Standards при выполнении неуправляемой калибровки. Например, метка класса калибровки "Modified OPEN" (Измененный ХХ) отобразилась бы следующим образом:

Следующие выборы в этом диалоговом окне зависят от выбора назначения класса (SOLT или TRL), сделанного в диалоговом окне Edit Kit.

SOLT ONLY

Link FWD TRANS, FWD MATCH, REV TRANS, and REV MATCH установите, чтобы автоматически назначать определение стандарта FWD TRANS для FWD MATCH, REV MATCH и REV TRANS. Уберите флажок, чтобы раздельно назначать классы FWD MATCH, REV MATCH и REV TRANS (только для калибровок SOLT).

Expanded Calibration (Расширенная калибровка)

Следующие два флажка действительны ТОЛЬКО для управляемой калибровки. При неуправляемой калибровке эти флажки игнорируются, даже в случае, когда выводится несколько диалоговых окон стандартов.

Примечание: Выбрать значения этих параметров можно как во время процесса калибровки, выполняя просмотр/изменение настроек, вызванных из мастера калибровки, так и изменяя калибровочный комплект при расширенном редактировании калибровочного комплекта.

Measure all mateable standards in class Установите этот флажок, чтобы были измерены все совместимые стандарты в классе. Это обеспечивает наивысшую достижимую точность. Например, если калибровочный комплект содержит несколько стандартов согласованной нагрузки, то во время процесса калибровки вы получите запрос на измерение каждого из стандартов. При этом на калибровку может потребоваться значительное время. Если этот флажок установлен, флажок "Use expanded math when possible" устанавливается автоматически.

Use expanded math when possible Некоторые наборы содержат несколько калибровочных стандартов одного и того же типа, вместе покрывающих очень широкий частотный диапазон. (Например: несколько КЗ, или низкочастотная согласованная нагрузка и скользящая нагрузка.) Если для калибровки требуется более одного стандарта, чтобы покрыть диапазон частот калибровки, тогда в некоторых областях измерения могут перекрываться. Если этот флажок установлен, анализатор автоматически выполняет расчет наиболее точного измерения в регионах перекрытия, с помощью подбора методом взвешенных наименьших квадратов. Эта функция улучшает точность, не замедляя калибровку.

  • Устанавливайте этот флажок вручную лишь тогда, когда калибровочный комплект содержит несколько стандартов одного типа. (Например: несколько КЗ, или низкочастотная согласованная нагрузка и скользящая нагрузка)

  • Этот флажок убирается по умолчанию, когда в меню калибровочного комплекта выбрана полиномиальная модель.

  • Этот флажок устанавливается по умолчанию, когда в меню калибровочного комплекта выбрана основанная на данных модель 85058B или 85058E.

TRL ONLY

Стандартам MATCH должны назначаться классы FWD MATCH, REV MATCH или LINE. См. калибровки TRL для дополнительной информации о стандартах TRL.

LRL line auto characterization (Автоматическое определение характеристик линии LRL)

Примечание: Эта настройка применяется ТОЛЬКО тогда, когда калибровочный набор LRL был изменен И плоскость отсчета измерительного порта установлена в Thru Standard (Стандарт перемычки) И для класса стандарта перемычки TRL и класса стандарта линии/согласования TRL установлены одинаковые значения Offset Z0 (Сдвига Z0) и Loss(Потерь). Иначе эта настройка игнорируется.

  • Установите флажок, чтобы анализатор автоматически выполнил коррекцию потерь в линии и характеристик дисперсии.

  • Уберите флажок, если при калибровочном измерении возникают аномалии, которые могут указывать на различные уровни потерь или значения сопротивления у стандартов линии.

Calibration Reference Z0 (TRL only) Калибровка опорного Z0 (только для TRL)

System Z0 Сопротивление системы используется, как опорное сопротивление. Выберите, если необходимое сопротивление измерительного порта отличается от сопротивления стандарта линии. Также выбирайте в случае, когда для коаксиальной линии требуется коррекция поверхностного эффекта сопротивления.

Line Z0 Сопротивление стандарта линии, используемого как опорное сопротивление, или центр диаграммы Смита. Любое отражение от стандарта линии воспринимается как часть погрешности направления.

Testport Reference Plane (TRL only) Плоскость отсчета измерительного порта (только TRL)

Thru Standard Определение стандарта перемычки, используемого для определения плоскости отсчета измерения. Установите, если стандарт перемычки(THRU) имеет нулевую длину или является очень коротким.

Reflect Standard определение стандарта отражения (REFLECT), используемого для опредения положения плоскости отсчета измерения. Выберите, если стандарт перемычки (THRU) не подходит И задержка для стандарта отражения(REFLECT) четко определена.

Справка по диалоговому окну Add Standard

Позволяет вам добавлять стандарты в файл калибровочного комплекта.

OPEN Добавляет стандарт ХХ в файл калибровочного комплекта.

SHORT Добавляет стандарт КЗ в файл калибровочного комплекта.

LOAD Добавляет стандарт согласованной нагрузки в файл калибровочного комплекта.

THRU Добавляет стандарт перемычки в файл калибровочного комплекта.

DATA BASED STANDARD Добавляет основанный на данных стандарт в файл калибровочного комплекта.

OK Вызывает пустое окно редактирования стандартов (Edit Standards): ХХ, КЗ, согласованная нагрузка или перемычка.

Для дополнительной информации см. Создание пользовательских калибровочных комплектов, использующих новое семейство соединителей.

Редактирование/добавление стандартов (ХХ, КЗ, согласованная нагрузка или перемычка)

Справка по диалоговому окну Edit / Add Standards

Диалоговое окно изменяется в зависимости от типа выбранного стандарта.

Выделенные области предыдущего рисунка применимы ко всем стандартным типам:

Identification (Идентификация)

Standard ID Номер в списке стандартов

Label Тип стандарта.

Description Описание стандарта.

Frequency Range (Диапазон частот)

Min Определяет самую низкую частоту, при которой стандарт будет использоваться для калибровки.

Max Определяет самую высокую частоту, при которй стандарт будет использоваться для калибровки.

Connector (Соединитель)

Указывает тип и вид (штекер, гнездо, нет) стандарта of the standard.

Delay Characteristics (Характеристики задержки)

Delay Определяет время передачи в одном направлении от плоскости калибровки к стандарту, в секундах.

Z0 Определяет полное сопротивление стандарта.

Loss Определяет потерю энергии, связанную с поверхностным эффектом, происходящую по всей длине коаксиального кабеля в одном направлении.

· Уровень потерь вводится в Ом/с при частоте 1 ГГц.

· Чтобы вычислить уровень потерь для стандарта, измерьте задержку в секундах и уровень потерь в дБ при частоте 1 ГГц. Затем выполните расчет по следующей формуле:

Следующее применимо к таким типам стандартов ХХ, КЗ, согласованной нагрузке, перемычке , и основанным на данных

Стандарт ХХ (Open)

C0, C1, C2, C3 Указывает краевые емкости.

Стандарт КЗ (Short)

L0, L1, L2, L3 Указывает остаточную индуктивность.

Стандарт согласованной нагрузки (Load)

Позволяет выбрать тип согласованной нагрузки.

Тип согласованной нагрузки

Fixed Load Указывает на тип нагрузки - постоянная

Sliding Load Указывает тип нагрузки - скользящая

Arbitrary Impedance Указывает, что у типа нагрузки значение сопротивления отличается от значения Z0 системы. Следующие настройки доступны, только если выбран параметр Arbitrary Impedance (Произвольное сопротивление):

  • Real действительная часть значения сопротивления.

  • Imaginary Мнимая часть значения сопротивления.

Стандарт перемычки (Thru)

Connectors

Определяет тип соединителей у обоих портов.

Стандарт, основанный на данных (Data-based)

Примечание: Для информации о редактировании файлов основанных на данных стандартов, посетите http://na.tm.agilent.com/pna/dbcal.html

Измененный файл затем можно загрузить в анализатор.

Upload Data From File (Загрузка данных из файла)

Щелкните Browse (Обзор), чтобы загрузить данные из существующего основанного на данных стандарта

Connectors

One Port Standard В данный момент можно редактировать лишь 1-портовые стандарты.

Port 1 Выберите тип соединителя.

File Information Информация о стандарте читается из загруженного файла.


3-портовые измерения

Сетевые анализаторы типа PNA, N3381A, N3382A и N3383A обеспечивают вектор истинных измерений с корректировкой погрешности для 3-портовых устройств. В данном разделе представлена информация о процессе измерений для 3-портовых устройств.

  • Обзор

  • 3-портовые калибровки

  • Выбор параметров

Другие разделы по калибровке

Обзор

З-портовые сетевые анализаторы типа PNA предлагают более быстрое снятие характеристик по сравнению с 2-портовыми анализаторами. Вы можете без изменения настроек проводить измерения на таких устройствах, как ответвители направления, делители, антенные диплексеры. 3-портовые измерения дают возможность просмотра до девяти различных S-параметров с разными настройками формата и масштабирования.

3-портовые калибровки

Для выполнения полной 3-портовой калибровки пользуйтесь регулируемой калибровкой (Guided calibration) Помощника по калибровке (Calibration Wizard). Вы можете провести регулируемую калибровку с помощью механических мер или модуля Ecal. С механическими мерами регулируемая калибровка автоматически проводит калибровки адаптера для не вставляемых устройств. Смотрите Мастер калибровки.

Векторы ошибок

На следующей блок-схеме показаны векторы ошибок 3-портовой модели:

где:

E = вектор ошибок

DIR = направленность

MAT = согласование прямого источника и согласование обратной нагрузки

TRK = слежение за прямым отражением и слежение за обратной передачей

Просмотр измерений

Поскольку можно просматривать девять параметров, будет полезным узнать, как конфигурировать измерение для просмотра данных. Можно разными способами сконфигурировать несколько измерений с помощью до шестнадцати окон и четырех графиков в окне. После окончания конфигурирования измерения можно менять размер и размещение окон, а также данных для распечатки.

Выбор параметров

Можно выбирать из девяти S-параметров, три отражения и шесть передач. Как показано на следующем графике после параметров отражения стоит число в скобках {}. Это число указывает порт, который надо использовать для реверсивного свипирования в процессе полной 2-портовой калибровки.

Выберите эти и другие необходимые параметры для 2-портового PNA. Смотрите Выбор измеряемого параметра


Калибровка мощности

Калибровки мощности источника и приемника выполняются совместно для обеспечения очень точных уровней мощности источника и измерений мощности приемника.

  • Калибровка источника мощности

  • Уменьшение времени выполнения калибровки источника мощности

  • Калибровка приемника мощности

  • Сохранение калибровки источника и приемника мощности

См. примеры программирования для SCPI и COM

Другие разделы по калибровке

Калибровка источника мощности

Проводите калибровку источника мощности, если вам нужны точные уровни мощности в некоторой точке пути прохождения измерения между тестовыми портами PNA. Например, вы хотите снять характеристики усиления усилителя по частотному диапазону при указанной входной мощности. Вы можете провести калибровку источника мощности на входе усилителя, чтобы убедиться в точности уровня мощности, поступающего на усилитель, по частотному диапазону.

С помощью калибровки источника мощности вы можете обоснованно предполагать, что мощность в точке калибровки будет находиться в пределах погрешности используемых ваттметра и датчика.

Примечание: Возможно, вам не удастся провести калибровку источника мощности без подключения к PNA с учетной записью администратора. Чтобы исправить это, см. http://na.tm.agilent.com/pna.

Калибровка источника мощности:

  • Это независимый тип измерения. Корректирует источник PNA независимо от типа приемников, используемых при измерении. Поэтому ее можно использовать как при абсолютных, так и относительных измерениях.

  • Применяется ко всем измерениям по активному в процессе калибровки каналу.

  • Применяется ТОЛЬКО к тем измерениям, которые используют для калибровки тестовый порт, определенный как источник. Например, вы указали порт 1 как источник, который необходимо калибровать, тогда будут корректироваться только измерения, использующие порт 1 в качестве источника.

  • Можно использовать совместно с калибровками других измерений, например, полной 2-портовой калибровкой. Для большей точности выполняйте калибровку процесса измерения ПОСЛЕ калибровки источника.

  • • Можно использовать с типом Свипирование по мощности. Калибровка источника мощности будет корректировать мощность на всех уровнях по свипированию мощности.

Обзор способа действия:

Переход к подробной процедуре

  1. Укажите настройки измерения (частотный диапазон, полоса ПЧ и т.д.)

  2. Запустите калибровку источника мощности.

  3. Подключите датчик ваттметра к точке, где необходимо измерить уровень мощности. Можно подключать к вводу или выводу устройства, либо к другой точке между тестовыми портами.

  4. Программа пройдет по указанному частотному диапазону источника PNA при указанном уровне мощности и измерит мощность с помощью ваттметра.

  5. Программа рассчитывает и сохраняет разность между необходимой скорректированной мощностью (мощность калибровки) и измеренной ваттметром в каждой точке.

  6. После завершения источник калибровки мощности можно сохранить на диск в качестве инструментального состояния.

  • Ваттметр снимается и повторно подключается путь прохождения измерения.

  • Калибровка автоматически подключается к процессу измерения, так что при последующих свипированиях мощность регулируется по значениям разности для корректировки уровня мощности.

Поддерживаемое испытательное оборудование

Ваттметры

Номер модели Agilent | Основные технические данные
E4416A | Один канал
E4417A | Двойной канал
EPM-441A, E4418A/B | Один канал
EPM442A, E4419A/B | Двойной канал
437B | Один канал
438A | Двойной канал
Смотрите создание пользовательского драйвера ваттметра.

Датчики мощности

Калибровку источника мощности можно проводить, используя ВСЕ датчики мощности, поддерживаемые ваттметрами, указанными в приведенном выше списке ваттметров. Однако с датчиками мощности Agilent E930x и E932x калибровка источника мощности и Scalar Mixer Calibration, проходит медленно, поскольку обе калибровки не оптимизированы для применения с данными датчиками.

Можно использовать до двух датчиков, чтобы охватить частотный интервал измерения.

Подробное описание процедуры: Проведение калибровки источника мощности

  1. Настройте измерение (тип свипирования, диапазон частоты, полоса ПЧ и т.д.).

  2. Подключите коаксиальный кабель, кабель GPIB и датчики мощности к PNA, как показано на рисунке ниже.

Примечание: Для управления ваттметром можно использовать интерфейс 82357A USB/GPIB.

  3. Подайте мощность на ваттметр, перед началом калибровки схема должна прогреться в течение 30 минут.

  4. Выберите Source Power Cal (Калибровка источника мощности) следующим образом:

  5. Заполните позиции диалогового окна Source Power Cal (ниже), включая Loss Compensation и Power Sensor Settings, так как это необходимо.

  6. После завершения нажмите Take a Cal Sweep (Выполнить калибровочное свипирование) в диалоговом окне Source Power Cal.

  7. Выполните предложения по подключению датчиков.

  8. После завершения калибровки нажмите OK.

  9. Снимите датчик.

  • В строке состояния отображается

    Src Pwr Cal и данные корректировки, применяемые к последующим свипированиям.

  • Установите корректировку в положение OFF, в меню Calibration перейдите к Power Calibration, затем установите Source Power Correction (Корректировка источника мощности) на OFF.

Интерполяция

Если изменены первоначальные настройки стимула, применяется интерполяция или ЭКСТРАПОЛЯЦИЯ и в строке состояния отображается Src Pwr Cal*. Это отличается о интерполяции калибровки измерения. Например, если увеличен интервал частоты, PNA будет экстраполировать новые значения корректировки, а не отключать корректировку. Таким образом, ваше испытательное устройство будет защищено от избыточной мощности источника. Если восстановлены первоначальные настройки, калибровка источника мощности возвращается к полной корректировке.

Справка по диалоговому окну Source Power Cal

Примечание: Убедитесь в том, что частотный диапазон датчика мощности охватывает частотный диапазон измерения. Автоматически это НЕ выполняется.

Power (Мощность)

Cal Power (Калибровка мощности) Рассчитанная мощность (в dBm) в точке калибровки. Это значение состоит из указанного источника мощности PNA плюс значение сдвига по мощности (Power Offset).

Power Offset (Сдвиг по мощности) Дает возможность указать усиление или потери (в дБ), чтобы учитывать компоненты, подключенные между источником и опорной плоскостью измерения. Например, укажите 10 дБ для учета усилителя в 10 дБ, который находится на пути к вашему тестируемому устройству. После калибровки показания мощности PNA будут исправлены на это значение.

Channel and Port Selection (Канал и выбор порта)

Channel (Канал) Указывает канал, на котором проводится калибровка. По умолчанию данная настройка указывает активный канал.

Source Port (Порт источника) Выбранный порт источника. По умолчанию данная настройка указывает на порт источника активного канала.

Accuracy (Точность)

В каждой точке мощность измеряется и подстраивается (с помощью указанных настроек) до тех пор, пока показание не попадет в пределы указанного Tolerance (допуска) или будет достигнуто Max Number of Readings (Максимальное количество показаний). Последнее показание мощности отображается на экране (под диалоговым окном) рядом с ограничительными линиями допуска.

Tolerance Устанавливает максимальное желаемое отклонение от заданного уровня Cal Power.

Max Number of Readings Устанавливает отбор максимального количества показаний в каждой точке для итерации источника мощности.

Use Reference Receiver for Fast Iteration (Использовать опорный приемник для быстрой итерации) Если поле отмечено, для калибровки опорного приемника используется первое показание в каждой точке. Следующие показания, если это необходимо для соответствия вашим требованиям по точности, снимаются с помощью опорного приемника. Такая технология действует намного быстрее, чем при использовании ваттметра, почти без ущерба для точности.

Примечание: НЕ пользуйтесь опорным приемником для функции итерации, если перед датчиком мощности находится датчик мощности с нелинейными характеристиками, например, усилитель мощности с нелинейными искажениями.

Power Meter Config (Конфигурирование ваттметра) Вызывает диалоговое окно Power Meter Settings

Take Cal Sweep Начинает процесс измерения калибровки источника мощности.

OK Применяет калибровку. Данная кнопка отключена, если не нажата Take Cal Sweep.

Cancel Отменяет калибровку.

Дополнительная информация о калибровке источника мощности

Справка по диалоговому окну Power Meter Settings (Настройки ваттметра)

GPIB Address Адрес GPIB для ваттметра. По умолчанию 13. При проведении калибровки источника мощности PNA будет просматривать интерфейсы VISA, сконфигурированные в Agilent IO LIbraries в PNA.

Sensors (Датчики) Вызывает диалоговое окноpower sensor settings.

Settling

Каждое показание мощности "установлено", если последовательные показания ваттметра находятся в пределах Tolerance (Допуск) или достигнуто Max Number of Readings (Максимальное количество показаний). Для получения "установленного" показания отобранные показания усредняются. Затем установленное показание сравнивается с требованиями к точности (допуск и максимальное количество показаний), указанными в диалоговом окне Source Power Cal.

Tolerance Если последовательные показания ваттметра находятся в пределах допуска, то показание считается установленным.

Max Number of Readings (Максимальное количество показаний) Устанавливает максимальное количество показаний, отбираемых ваттметром для достижения стабилизации.

Sensor Loss Compensation (Компенсация потерь датчика)

Use Loss Table (Использовать таблицу потерь) Отметьте данное поле, чтобы применить данные потерь для коррекции калибровки источника мощности (например, для адаптера на источнике мощности).

Edit Table (Редактировать таблицу) Вызывает диалоговое окно Power Loss Compensation.

Справка по диалоговому окну Power Loss Compensation (Компенсация потерь мощности)

Дает возможность компенсировать потери, возникающие при использовании адаптера или ответвителя для подключения датчика мощности к измерительному порту.

Delete Table Segment (Удалить сегмент таблицы) Удаляет строку, указанную в поле.

Delete All (Удалить все) Удаляет все данные в таблице.

Примечание: Чтобы добавить строку к таблице, щелкните по строке таблицы и нажмите стрелку вниз на передней панели PNA или на клавиатуре.

  • Если используется один сегмент частоты/потерь, анализатор применит это значение ко всему диапазону частоты.

  • Можно вводить до 100 сегментов, чтобы добиться большей точности.

Справка по диалоговому окну Power Sensor (Датчик мощности)

Примечание: Убедитесь в том, что частотный диапазон вашего датчика мощности охватывает диапазон частоты измерения. Это НЕ выполняется автоматически.

Sensor A (B) (Датчик А (В)) Отображает одно из следующих сообщений в зависимости от типа датчика.

  • Not connected (Не подключен) PNA не может обнаружить датчик мощности.

  • Cal factors are contained within this sensor (Коэффициенты калибровки находятся в датчике) PNA фиксирует датчик мощности типа Agilent E. Опорный коэффициент калибровки (Cal Factor) и данные коэффициента калибровки загружаются автоматически.

  • Sensor Data (Данные датчика) Дает возможность ввода данных датчика мощности:

Reference Cal Factor (Опорный коэффициент калибровки) Задает опорный коэффициент калибровки датчика.

Cal Factor Table (Таблица коэффициентов калибровки) Задает частоту и соответствующий коэффициент калибровки для датчика.

Delete Cal Factor (Удалить коэффициент калибровки) Удаляет в таблице указанную строку.

Delete All (Удалить все) Удаляет все данные в таблице.

Use this sensor only (Использовать только этот датчик) Отметьте данное поле, чтобы использовать этот датчик по всему интервалу частоты измерения, даже если к ваттметру подключены два датчика. Снимите отметку, чтобы дать возможность ввода минимальной и максимальной частот для датчика.

Minimum Frequency (Минимальная частота) Задает минимальный частотный диапазон датчика при использовании двух датчиков.

Maximum Frequency (Максимальная частота) Задает максимальный частотный диапазон датчика при использовании двух датчиков.

Perform Sensor Zeroing and Calibration (Выполнить обнуление датчика и калибровку) Обнуляет и калибрует датчик мощности перед снятием данных.

Примечание: Чтобы добавить строку к таблице, щелкните по строке таблицы и нажмите стрелку вниз на передней панели PNA или на клавиатуре. Строка добавляется в нижнюю часть таблицы. Таблица автоматически сортируется по частоте при нажатии ОК.

Уменьшение времени выполнения калибровки источника мощности

Время, необходимое для выполнения калибровки источника мощности, зависит от источника мощности, количества точек и количества снятых показаний. Следующими методами можно уменьшить время проведения измерений:

  • Уменьшение количества точек перед калибровкой. Перед началом процесса измерения можно уменьшить количество точек, затем, после завершения калибровки и включения режима коррекции, верните первоначальное значение количества точек. Анализатор выполнить линейную интерполяцию, хотя с некоторой потерей в точности.

  • Используйте датчик типа Agilent E. С датчиком такого типа можно получать 200+ показаний в секунду через GPIB.

  • Повысьте мощность, подаваемую к датчику. Для некоторых датчиков пониженная мощность может увеличить время на стабилизацию.

  • Отметьте Use Reference Receiver for Iteration.

Калибровка приемника мощности

Калибровка приемника мощности математическим способом удаляет ошибки частотной характеристики в указанном приемнике PNA и корректирует показания такой же уровень, как у калибровки источника мощности (или на значение сдвига). Это такой же процесс, как в Data / Memory, (Данные/Память), однако данные сдвигаются на значение Cal Power.

Используйте калибровку приемника мощности для выполнения очень точных измерений абсолютной мощности (амплитуды).

Калибровка приемника мощности:

  • Предполагается, что сначала выполнена калибровка источника мощности.

  • Допускается ТОЛЬКО при измерениях абсолютной мощности.

  • Применяется ТОЛЬКО к активному измерению.

Выполнение калибровки приемника мощности

  1. Выполните калибровку источника мощности.

  2. Установите активное измерение, как абсолютное. Подробнее.

  3. Подключите перемычку от порта источника к порту приемника. Если вы проводите калибровку приемника мощности по опорному приемнику, какое-либо подключение не требуется, поскольку приемник внутренне подключен к источнику.

  4. Убедитесь в том, что калибровка источника мощности включена, на что указывают Src Pwr Cal или Src Pwr Cal* в строке состояния.

  5. Выберите Receiver Power Cal следующим образом:

  6. Заполните следующее диалоговое окно Receiver Power Cal

Справка по диалоговому окну Receiver Power Cal (Калибровка приемника мощности)

Cal Power (Калибровка мощности) Задает мощность, которую будет измерять приемник.

Using power level from Source Power Cal. (Используется уровень мощности калибровки источника мощности). Выберите данное поле, чтобы использовать уровень мощности калибровки источника мощности. Снимите отметку, чтобы ввести другое значение калибровки мощности.

Take a Cal Sweep (Провести калибровку свипированием) Нажмите, чтобы переключить на свипирование калибровки приемника мощности.

OK Нажмите по завершению свипирования калибровки приемника мощности.

Примечания:

  • ? После завершения калибровки приемника мощности в строке состояния появляется C Rcvr Pwr, данные корректировки применяются к последующим свипированиям.

  • ? Чтобы перевесит корректировку в состояние OFF, нажмите Calibration, перейдите к Power Calibration, затем установите Receiver Power Correction на OFF.

Интерполяция

Так же как для калибровки измерения, при суженых настройках первоначального стимула применяется интерполяция и в строке состояния появляется C* Rcvr Pwr. Если первоначальные настройки стимула расширены, PNA переключит коррекцию приемника мощности на OFF.

Если первоначальные настройки восстановлены, калибровка приемника мощности вернется к полной коррекции.

Сохранение калибровки источника и приемника мощности

Калибровки источника и приемника сохраняются как часть инструментального состояния; НЕ как данные калибровки. Поэтому их можно сохранить, как файл .sta или файл .cst. Для сохранения данных калибровки измерения с калибровками источника или приемника, необходимо использовать файл .cst. Подробнее о типах сохраняемых PNA файлов.


Калибровочные стандарты (меры)

В данном разделе описаны основные принципы и термины, которые касаются файлов калибровочных комплектов. Способ модификации файлов калибровочных комплектов смотрите в Изменение калибровочных комплектов.

  • Информация о калибровочных комплектах

  • Калибровочные меры

  • Тип меры

  • Определения мер

  • Назначение в класс

Другие разделы по калибровке

Информация о калибровочных комплектах

Калибровочный комплект – это набор физических устройств, которые называются мерами. Для каждой меры точно известны (или предсказуемы) амплитуда и фазочастотная характеристика, как функция от частоты.

Для того чтобы анализатор использовал меры калибровочных комплектов, необходимо математически вычислить отклик каждой меры, затем организовать их в стандартные классы, соответствующие погрешности моделей, используемых анализатором.

Для того чтобы использовать определенный калибровочный комплект необходимо ввести в память анализатора известные характеристики каждой меры из набора или вызвать их из заданного по умолчанию списка калибровочных комплектов, который хранится в анализаторе.

Список калибровочных комплектов – смотрите в Аксессуары анализатора.

Калибровочные меры

Калибровочные меры предоставляют эталон для измерений с корректировкой погрешности сетевого анализатора. Для каждой меры существуют точно известные значения, сюда входят электромагнитная инерция, импеданс и потери. Анализатор сохраняет данные значения и использует их для расчета условий корректировки погрешности.

При калибровке измерения анализатор проводит измерения на мерах и математическим способом сравнивает результаты с "идеальными моделями" этих мер. Расхождения выделяются в вектор ошибок, который позже при корректировке ошибок удаляется из измерений по устройству.

Тип меры

Тип меры – один из четырех базовых типов, который определяет форму или структуру модели, используемой с данной мерой. Ниже указаны четыре типа мер:

Мера

Импеданс схемы

SHORT (КЗ)

нулевое сопротивление

OPEN (ХХ)

бесконечное сопротивление

LOAD (Нагрузка)

импеданс системы, Z0

THRU/LINE (Перемычка/линия задержки)

импеданс схемы отсутствует

ARBITRARY (Произвольный импеданс)

определяется пользователем

Определения мер

Определения мер описывают их электрические характеристики и частоты, которые будут ими использоваться. Обращайтесь к "таблице определений мер", которая входит в комплект калибровки. Определения мер включают в себя:

  • Minimum Frequency (Минимальная частота) Определяет минимальную частоту, которую мера использует для калибровки.

  • Maximum Frequency (Максимальная частота) Определяет максимальную частоту, которую мера использует для калибровки.

  • Z0 Определяет характеристический импеданс меры (не характеристический импеданс системы или схемы стандарта).

  • Delay Определяет длину однородной линии передачи между определяемой мерой и фактической плоскостью калибровки.

  • Type Определяет тип меры (SHORT, OPEN, THRU/LINE, LOAD, ARBITRARY).

  • Loss Определяет потери энергии из-за поверхностного эффекта и односторонней длины коаксиального кабеля.

Уравнение расчета потерь для модели:

  • Значение потерь вводится в единицах ом/сек при 1 ГГц.

  • Для расчета потерь меры измерьте задержку в секундах и потери в дБ при 1 ГГц. Затем используйте следующую формулу:

Уравнение расчета емкости для модели:

C0, C1, C2, C3. Определяет краевую емкость для меры ХХ.

  • C = (C0) + (C1 x F) + (C2 x FІ) + (C3 x Fі)

  • (F - это частота измерения).

  • ? Члены уравнения определены, если ХХ определять следующим образом:

    • C0 – это постоянный член полинома третьей степени, выражается в фарадах.

    • C1 выражается в Ф/Гц (фарады/ Гц).

    • C2 выражается в Ф/Гц.

    • C3 выражается в Ф/Гц.

Уравнение расчета индуктивности для модели:

L0, L1, L2, L3. Определяет остаточную индуктивность для меры КЗ.

  • L = (L0) + (L1 x F) + (L2 x FІ) + (L3 x Fі)

  • (F – это частота измерения).

  • Члены уравнения определены, если КЗ определять следующим образом:

    • L0 – это постоянный член полинома третьей степени, выражается в Генри.

    • выражается в Г/Гц (Генри/ Гц)

    • L2 выражается в Г/Гц.

    • L3 выражается в Г/Гц.

Назначение в класс

После того, как мера характеризована, необходимо отнести ее к "классу" меры. Класс меры – это группа стандартов, организованная в соответствии с калибровкой модели ошибок PNA.

Количество классов, необходимых для отдельного типа калибровки равно количеству исправляемых векторов ошибок.

Часто класс состоит из одной меры, но может быть составлен из нескольких мер, например, линий нагрузки или задержки. Смотрите таблицу "назначение класса" для калибровочного комплекта.

Пример: Для калибровки отклика необходим только один класс, для этого класса могут применяться меры типа OPEN, SHORT или THRU. Для 1-портовой калибровки необходимы три класса. Для полной 2-портовой калибровки необходимо 10 классов, без учета двух для развязки.

Количество мер, назначенных в заданный класс, может меняться от одной до семи для не регулируемых калибровок. Для регулируемых калибровок допускается необходимое количество мер.

Различные классы, используемые в PNA:

S11A, S11B, S11C (S22A, S22B, S22C и так далее)

Существует три класса для калибровок с одним отражением (также три класса для S22 и S33). Их используют в одно-портовых калибровках и полной двух-портовой калибровке. Они необходимы для удаления погрешностей слежения за направленностью, согласования источника и отражения. Как правило, эти классы могут состоять из мер типа ХХ, КЗ, и LOAD для каждого порта.

Передача и согласование (в прямом и обратном направлении)

Эти классы используют для проведения полной двух-портовой калибровки. Класс передачи в основном относится к слежению за передачей, а класс согласования – к согласованию в нагрузке. Для обоих классов стандартная мера – это мера типа перемычка или линия задержки.

Развязка (Isolation)

Классы развязки используют для проведения полной двух-портовой калибровки и двух-портовой калибровки TRL. Классы развязки применяют для элементов прямых и обратных перекрестных искажений в модели ошибок PNA.

TRL, мера типа перемычка (TRL thru)

Используются для выполнения двух-портовой калибровки TRL. В класс thru для TRL должна входить мера типа thru или КЗ. Если в него входит мера типа thru с не нулевой длиной, то тип калибровки называется LRL или LRM.

TRL, отражение (TRL reflect)

Данный класс используют для выполнения двух-портовой калибровки TRL. В класс отражения TRL должна входить мера с высоким коэффициентом отражения, как правило, ХХ или КЗ. Знать фактический коэффициент отражения не обязательно, но необходимо как можно точнее (± 90 град.) указать фазовый угол. В процессе калибровки TRL необходимо использовать совершенно идентичные меры отражения на обоих портах.

TRL, линия (или согласование) (TRL line (or match))

Используются для выполнения двух-портовой калибровки TRL. Линия TRL или класс согласования должны включать в себя меры линии, меры нагрузки или то и другое. Если используется мера линии, ее сдвиг по фазе должен отличаться от меры типа thru для TRL на величину от 20° до 160°. Это ограничивает диапазон применяемой частоты примерно до 8 к 1. Для того чтобы получить более широкий диапазон частоты, можно указать меры типа линия с разной длиной. Кроме того, принято использовать меру типа нагрузка для охвата низких частот, где длина линии оказалась бы неприемлемо большой. Если используется мера типа нагрузка, тип калибровки называется TRM или LRM.

Примечание: За дополнительной информацией обращайтесь к примечанию к приложению 8510-5A, "Определение калибровочных мер для сетевого анализатора Agilent 8510". Несмотря на то, что данное приложение написано для сетевых анализаторов типа Agilent 8510, его можно применять и к PNA. Номер части в публикации - 5956-4352.


Калибровка TRL

TRL (Thru - Reflect - Line – Перемычка-Отражение-Линия) представляет семейство технологий калибровки, где для определения 12-векторных коэффициентов погрешности для 2-портовых устройств проводятся измерения по двум мерах передачи и одной мере отражения. Например, в это семейство включено TRM (Thru - Reflect – Match - Перемычка-Отражение-Согласование) . При традиционной калибровке SOLT для определения таких же коэффициентов погрешности проводится измерение по одной мере передачи (T) и трем мерам отражения (SOL).

  • Назначение калибровки TRL

  • Процесс калибровки TRL

  • Калибровочные комплекты TRL

  • Калибровочные меры, используемые при TRL

  • Опции TRL

Примечание: Калибровку TRL можно выполнять только на 2-портовых моделях PNA со специализированным опорным приемником на каждом тестовом порту. Список номеров моделей представлен в стандартных конфигурациях PNA. 4-портовые модели PNA (N5230A Opts 240/245) НЕ поддерживают калибровки TRL или TRL*, поскольку имеют только один опорный приемник.

Другие разделы по калибровке

Назначение калибровки TRL

Калибровка TRL чрезвычайно точная, в некоторых классах намного точнее калибровки SOLT. Однако немногие из калибровочных комплектов включают в себя меры TRL. Чаще всего калибровка TRL проводится, если вам нужен высокий уровень точности, и у вас нет калибровочных мер с таким же типом разъема, как у вашего тестируемого устройства. Как правило, это происходит при использовании испытательных приспособлении или проведении измерений зондами во включенном состоянии. Поэтому в некоторых случаях вам необходимо создать схему и определить меры с таким же типом носителя, как в конфигурации вашего тестируемого устройства. Проще изготовить три меры TRL и снять их характеристики, чем четыре меры SOLT.

Ограничением для калибровки TRL с широким охватом частоты является необходимость в нескольких мерах типа LINE. Например, для интервала от 2 ГГц до 26 ГГц необходимы две меры типа линия. Кроме того, для пониженных частот меры типа LINE будут не практичными из-за большой длины.

Процесс калибровки TRL

Калибровку TRL можно выполнить, используя помощник по калибровке, нерегулируемую калибровку, но в следующем процессе применяется более простой SmartCal. Для обоих вариантов необходимо иметь определенными калибровочные меры TRL и калибровочный комплект, включенный в PNA.

  1. Предварительная настройка PNA

  2. Подключите тестируемое устройство к PNA

  3. Установите измерение S-параметра и желаемые настройки стимула.

  4. Нажмите Calibration / Calibration Wizard

  5. Нажмите SmartCal Guided Cal / Use Mechanical Stds

  6. Выберите соединители тестируемого устройства и калибровочный набор для каждого порта. В выбранные калибровочные комплекты ДОЛЖНЫ быть включены меры TRL. В качестве метода калибровки (Cal Method) должен появиться TRL.

  7. Отметьте поля Modify Cal, Next, затем View/Modify чтобы при необходимости изменить заданные по умолчанию опции TRL.

  8. Для завершения калибровки выполняйте предлагаемые действия.

  9. Проверьте точность калибровки

Калибровочные комплекты TRL

Agilent Technologies предлагает два калибровочных комплекта, куда входят меры, необходимые для проведения калибровки TRL: 85050C (APC 7 мм) и 85052C (3.5 мм). В оба комплекта входят традиционные меры типа КЗ, ХХ и Нагрузка. (Фактически, мера типа Перемычка не поставляется, предполагается перемычка нулевой длины). Кроме того, в комплекты включена воздушная линия, используемая, как мера типа LINE. Для использования воздушной линии в комплекты входят корпус воздушной линии, центральный провод и инструменты для монтажа / демонтажа. В комплект АРС 7 входит адаптер для подключения воздушной линии к разъему АРС.

Калибровочные меры, используемые при TRL

Эти меры необходимо определить в вашем калибровочном комплекте TRL:

THRU (ПЕРЕМЫЧКА)

  • Мера типа THRU может иметь нулевую или не нулевую длину. Однако мера THRU с нулевой длиной более точная из-за нулевых потерь и отсутствия характеристического импеданса.

  • Мера THRU не может иметь такую же электрическую длину, как мера LINE.

  • При четко определенных вносимом сдвиге фазы и электрической длине меру THRU можно использовать для установки плоскости отсчета.

REFLECT (ОТРАЖЕНИЕ)

  • Мерой типа REFLECT может быть любое приспособление с высоким коэффициентом отражения и с длиной, соответствующей подключению к портам PNA.

  • Нет необходимости знать фактическую величину отражения.

  • Должна быть известна фаза меры отражения в пределах 1/4 длины волны..

  • При четко определенных величине и фазе меры отражения меру можно использовать для установки плоскости отсчета.

LINE (ЛИНИЯ)

Мера типа LINE устанавливает опорный импеданс для измерения после завершения калибровки. Калибровка TRL ограничена только следующими ограничениями для меры типа LINE:

  • Необходим такой же импеданс, как для меры типа THRU

  • Электрическую длину необходимо задавать только в пределах 1/4 длины волны.

  • Длина не должна равняться длине меры THRU.

  • Необходима соответствующая частотному диапазону электрическая длина. При каждой частоте разность фаз между THRU и LINE должна быть больше 20 градусов и меньше 160 градусов. На практике это означает, что одна мера типа LINE применяется только по частотному диапазону 8:1 (Интервал частоты / Стартовая частота). Поэтому для широкого охвата частоты необходимо несколько линий.

  • Для пониженных частот меры типа LINE могут быть не практичными из-за большой длины. Оптимальная длина меры LINE составляет 1/4 длины волны в геометрическом понимании интервала частоты (квадратный корень из f1 x f2).

MATCH (СОГЛАСОВАНИЕ)

При невозможности изготовить меру LINE соответствующей длины или из-за потерь, вместо меры типа LINE можно использовать меру MATCH.

  • Мера MATCH – это оконечное устройство с низким отражением, подключенное к порту 1 и порту 2.

  • При расчетах схемы TRL данная мера учитывается, как линия передачи бесконечной длины с большими потерями.

  • Импеданс меры MATCH становится опорным импедансом для измерения.

Примечание: Меры типа MATCH должны быть назначены в классы FWD MATCH, REV MATCH и TRL LINE. За подробной информацией о создании и модификации определений калибровочных наборов обращайтесь к Изменение калибровочных комплектов.

Дополнительная информация о мерах TRL находится по адресу http://www.tm.agilent.com. Нажмите "Technical Support" (Техническая поддержка). Используйте "Application Notes" (Примечания по приложению) для поиска App Note 8510-5A (номер части 5956-4352). Несмотря на то, что примечание по приложению предназначено для сетевых анализаторов типа Agilent 8510, оно также применяется к PNA.

Установка опций TRL

Пользуйтесь одним из следующих методов:

  • В диалоге Guided Cal (Регулируемая калибровка) выберите соединители тестируемого устройства и калибровочный набор отметьте Modify Cal (Модифицировать калибровку). В части Modify Thru Method (Модифицировать метод Thru) диалогового окна калибровки нажмите View/Modify (Обзор/Модификация), чтобы вызвать диалоговое окно Modify Calibration Class Assignments. Кроме того, вы можете вызвать это диалоговое окно, нажимая Calibration (Калибровка), Advanced Modify Cal Kit (Расширенный калибровочный комплект). Данные настройки определяют поведение заданных по умолчанию опций TRL.

  • Для подавления заданного поведения TRL для Unguided Cal (Не регулируемая калибровка), нажмите Full TRL 2-PORT

Дополнительная информация об использовании интерфейса передней панели

Справка по диалоговому окну Select Calibration Type (Выбор типа калибровки)

Примечание: Калибровку TRL можно выполнять только на 2-портовых моделях PNA со специализированным опорным приемником на каждом тестовом порту. Список номеров моделей представлен в PNA Standard Configurations. 4-портовые модели PNA (N5230A Opts 240/245) НЕ поддерживают калибровки TRL или TRL*, поскольку имеют только один опорный приемник.

TRL Reference Plane (Плоскость отсчета TRL)

Thru Мера THRU, используется для установки позиции плоскости отсчета. Выделите, если мера THRU имеет нулевую длину или очень короткая.

Reflect Мера REFLECT используется для установки позиции плоскости отсчета. Выделите если мера THRU не подходит, И задержка меры REFLECT четко определена.

TRL Impedance (Импеданс TRL)

Line Z0 Указывает, что необходимо использовать характеристический импеданс меры LINE в качестве системного импеданса. Здесь не учитывается разность между Offset Z0, Offset Loss и системным Z0.

System Z0 Преобразует импеданс меры LINE и потери в системный импеданс для использования с векторами ошибок калибровки. При калибровке TRL сначала вычисляются векторы ошибок, предполагая, что импеданс меры LINE – это характеристический импеданс системы (то же, что и в опции LINE), затем векторы ошибок модифицируются, чтобы включить преобразование импеданса. Это необходимо использовать только с коаксиальным кабелем, поскольку используемая модель поверхностного эффекта – это коаксиальная модель.

Дополнительная информация находится в Установка системного сопротивления.


Fixturing Macro (Макрос для приспособлений)

Данный макрос дает возможность компенсировать измерения PNA по воздействию испытательных приспособлений или других внешних компонент. Применяя макрос, вы можете выполнить следующее:

  • Добавить Расширения портов с потерями или без них

  • Модифицировать Опорный импеданс измерительного порта

  • Вставить/отменить вставку 2-портового устройства

Компенсация, полученная в результате этих операций, применяется к отдельным портам и каналам.

Например, вы можете проводить измерения на тестируемом устройстве в среде с 50 ом, 75 ом и 100 ом, создавая три канала измерений, каждый канал для своего опорного импеданса. Не требуются изменения физического подключения.

Запуск Fixturing Macro

+

  1. Несколько раз нажмите кнопку Macro, пока в зоне экрана Active Entry не появится Fixturing.

  2. Нажмите соответствующую кнопку Active Entry.

Дополнительная информация об использовании интерфейса передней панели

Справка по диалоговому окну Agilent Fixturing Macro

Fixture Ordering (Порядок закрепления)

В зависимости от порядка выполнения данных операций можно получить различные результаты. Например, результаты при применении расширения порта и последующей вставке приспособления будут отличаться от результатов при вставке и последующем расширении порта.

Для изменения порядка операций:

  1. Выберите одну из операций закрепления.

  2. Используйте кнопки Up и Down для изменения порядка операций

  3. Remove (Удалить) операцию, которая не будет использоваться.

Reset Восстанавливает заданный по умолчанию порядок операций.

Fixturing Setup

Port Extension (Расширение порта) Вызывает диалоговое окно Port Extensions.

Reference Impedance (Опорный импеданс) Вызывает диалоговое окно Reference Impedance.

Embed/De-Embed (Вставка/Отмена вставки) Вызывает диалоговое окно Embed/De-Embed.

Other Actions (Другие действия)

Save Сохраняет информацию о закреплении для последующего вызова, избавляет от необходимости вводить параметры повторно.

Recall Повторно вызывает ранее сохраненный файл закрепления. Нажмите Apply, чтобы применить вызванную информацию о закреплении.

Apply Модифицирует коэффициенты погрешности PNA, чтобы включить информацию о закреплении.

Примечание: После повторного вызова файла нажмите Apply, чтобы применить компенсацию текущих измерений.

Reset All Восстанавливает заданный по умолчанию порядок операций закрепления. Удаляет данные, введенные в индивидуальных рабочих диалогах. Восстанавливает первоначальную калибровку.

Справка по диалоговому окну Port Extensions

Примечание: Расширения портов применяются к отдельным портам на КАЖДОМ КАНАЛЕ. Используйте полосу прокрутки (справа от диалогового окна) для перехода к соответствующему каналу.

Enable Отметьте, чтобы включить расширение порта на соответствующем порту PNA.

Port Extensions (ps) Величина расширения в пикосекундах. Это значение будет отображаться в корректированном измерении, как соответствующее чередование фазы.

Loss (dB) At Frequency (Потери по частоте) Со значением расширения порта можно сопоставить одно или два значения потерь.

Если указано одно значение потери без значения частоты, потеря учитывается, как константа по всем частотам.
Если указана потеря при одной частоте, то потеря экстраполируется таким образом:

L(f) = Loss (1 GHz) * f ^.5

Где:
L(f) – это потеря в дБ при частоте измерения в ГГц
Loss (1 ГГц) – это потеря в дБ при 1 ГГц.

Если указана потеря при двух частотах, то потеря экстраполируется таким образом:

L(f) = L * f ^n
n = (log (L1/L2)) / (log (f1/f2))
L = L1 / f1^n

Где:
L1 и L2 – это потеря в дБ при f1 и f2 (в ГГц) соответственно.

OK Сохраняет введенные данные

Reset Восстанавливает заданные по умолчанию значения формы

Cancel Выход без сохранения введенных данных.

Подробнее о расширениях портов

Справка по диалоговому окну Reference Impedance (Опорный импеданс)

Алгоритм опорного импеданса корректирует измерение и отображает результаты так будто измерения выполнялись при заданном значении опорного импеданса. Физическая оконечная нагрузка порта – приблизительно 50 ом.

Примечание: Опорный импеданс применяется к отдельным портам на КАЖДОМ КАНАЛЕ. Используйте полосу прокрутки (справа от диалогового окна) для перехода к соответствующему каналу.

R Часть сопротивления желаемого опорного импеданса для указанного порта и канала.

X Реактивная часть желаемого опорного импеданса для указанного порта и канала.

Cancel Выход без сохранения введенных данных.

Reset Восстанавливает заданные по умолчанию значения формы

OK Сохраняет введенные данные

Справка по диалоговому окну Embed/De-Embed

Вставку используют, чтобы добавить к результатам измерения эффект от устройства. Например, можно добавить реактивную нагрузку, которая сейчас не установлена.

Отмена вставки используется, чтобы устранить нежелательные эффекты от устройства из результатов измерения. Например, можно удалить эффекты от испытательного приспособления.

Операция вставки/отмены вставки создает и вызывает файл s2p (формат критерия) для 2-портового устройства. В данный файл входят электрические характеристики дополнительного приспособления или устройства. Файл может иметь любой стандартный формат (действительный-мнимый, величина-угол, дБ-угол) и представлять любое 2-портовое устройство.

Примечание: В любом случае предполагается, что порт 1 вспомогательного устройства должен быть подключен к PNA, а порт 2 устройства – к тестируемому устройству.

Выполните одно из следующих действий для каждого порта на каждом канале:

Введите в соответствующем окне полное составное имя файла, который будет вставлен (или вставка будет отменена).

Browse Поиск уже существующего файла.

Circuit Создает файл, запуская диалоговое окно Circuit Characteristics

Справка по диалоговому окну Circuit Characteristics

Разрешает создание одного из нескольких согласованных контуров. Данный контур симулирует вставляемое или удаляемое устройство.

Примечание: PNA всегда находится в левой части контура, а тестируемое устройство – в правой.

Parameters (Параметры)

Start Frequency Стартовая частота измерения, к которому будет применяться компенсация.

Stop Frequency Конечная частота измерения, к которому будет применяться компенсация.

Number of Points Количество точек измерения, к которым будет применяться компенсация.

Inductance, Inductance Series R, Capacitance, Capacitance Shunt R Значения отдельных компонент контура, который моделирует дополнительное устройство. Capacitance и Capacitance Shunt R не должны равняться нулю.

Type Тип создаваемого контура, соответствующий приспособлению

OK Создает файл данных Touchstone (.s2p) для заданного контура. Предлагает имя файла при вызове. Затем закрывает диалоговое окно характеристик контура.

Cancel Выход без сохранения введенных данных.


A simulated variable length of lossless transmission line, added to or subtracted from a receiver input, to compensate for interconnecting cables. The firmware equivalent of mechanical or analog 'line stretchers' in other network analyzers.

Маркеры

Функция маркера обеспечивает вывод численного значения измеренных данных, возможность поиска определенных величин и может менять настройки стимулов. Существует 9 простых маркеров и один опорный для каждого графика. В данном разделе рассматриваются все аспекты маркеров.

Примечание: Вывод численного значения маркером может быть ВКЛЮЧЕН / ВЫКЛЮЧЕН и меняться с помощью меню View. См. Вывод численного значения маркером

  • Создание и перемещение маркеров

  • Дельта маркеры

  • Поиск с помощью маркеров

  • Функции маркера (изменение параметров настройки)

  • Дополнительные параметры маркеров

  • Таблица маркеров

Другие разделы по анализу данных

Как создавать и перемещать маркеры

Используйте один из следующих методов:

  • Панель Активного ввода (Active Entry)
    +

  • Панель маркеров

  • Диалоговое окно маркеров

Более подробно см. интерфейс передней панели

Создание маркера

  • На панели Активного ввода нажмите номер маркера. Чтобы перейти к маркерам 4 - 9, нажимайте [image] повторно.

  • На панели маркеров или в диалоговом окне Marker выберите номер маркера и нажмите ON

Перемещение маркера

Чтобы переместить маркер, сделайте его активным, выбрав номер маркера (с помощью любого из 3 вышеперечисленных методов). Потом измените величину стимула, используя один из следующих методов:

  • Введите значение

  • Выберите значение стимула, используя стрелки вверх/вниз

  • Щелкните по окну стимула, после чего используйте ручку на передней панели.

Примечание: Чтобы изменить свойства маркера, маркер должен быть активным. Активный маркер появляется на экране анализатора как \/. Все остальные маркеры неактивные и показаны на экране как /\.

Marker справка по диалоговому окну

Marker определяет номер маркера, который вы выбрали.

Stimulus определяет значение выбранного маркера по оси Х. Чтобы изменить значение стимула введите величину, используя стрелки вверх - вниз или щелкните по текстовому окну и используйте ручку на передней панели.

On отметьте, чтобы отобразить маркер и соответствующие данные на экране.

Delta Marker отметьте, чтобы сделать определенный маркер соотносительным с опорным маркером. Если опорный маркер (R) еще не включен, он будет отображен автоматически. Подробнее о Дельта маркерах

Advanced... Вызывает диалоговое окно Advanced Markers.

All Off выключает все маркеры на активном графике.

Дельта маркеры

Дельта маркеры позволяют видеть данные по отношению к опорному маркеру.

Дельта маркер можно установить из диалогового окна Marker dialog box или Marker Toolbar.

Когда дельта маркер создан, опорный маркер будет активирован автоматически.

Поиск с помощью маркеров

Можно использовать маркеры для поиска измеренных данных по определенным критериям.

Если нет достоверного совпадения данных ни для одного из типов поиска, маркер не переместится из своего положения.

Поиск с помощью маркеров

Используйте один из следующих методов:

  • +

Только Max, Min, Left Peak, и Right Peak типы поиска доступны с помощью клавиш активного ввода

Более подробно см. Интерфейс передней панели

Marker Search справка по диалоговому окну

Marker указывает маркер, который Вы определяете.

Search Domain определяет область, где может перемещаться или производить поиск маркер. Для полного диапазона маркер производит поиск значений во всем диапазоне измерений. Для диапазона, определенного пользователем, маркер производит поиск значений в заданном Вами диапазоне. Подробнее об области поиска.

Тип поиска

Maximum Маркер находит положение максимального (самого высокого) значения данных.

Minimum Маркер находит минимальное (самое низкое) значение данных.

Next Peak Маркер находит положение пика со следующим более низким значением амплитуды относительно начальной позиции. См. Что такое пик.

Peak Right Маркер находит следующий пик справа от начальной позиции по оси Х. См. Что такое пик.

Peak Left Маркер находит следующий пик слева от начальной позиции по оси Х. См. Что такое пик.

  • Threshold (Граничное значение) - минимальная амплитуда (дБ). Чтобы считаться достоверным пик должен находиться выше уровня граничного значения. Точка минимума на каждой стороне может находиться ниже уровня граничного значения.

  • Excursion (Размах) - Вертикальное расстояние (дБ) между пиком и минимальной точкой на обеих сторонах. Чтобы данные считались пиком, значения данных должны понижаться от пика в обе стороны на величину размаха.

Target Введите целевое значение. Маркер перемещается к первому местонахождению целевого значения справа от его текущего положения. Последовательные нажатия кнопки Execute (выполнить) вызывают перемещение маркера к следующему значению справа, которое соответствует целевому значению. Когда маркер достигает верхнего края диапазона стимула, он "вернется обратно" и продолжит поиск с нижнего края диапазона стимула (левая сторона окна).

  • Если Discrete Marker находится в выключенном состоянии (OFF), маркер находит точку, полученную путем интерполяции, которая равна целевому значению.

  • Если Discrete Marker находится во включенном состоянии (ON) и есть две точки по обеим сторонам от целевого значения, то маркер находит ближайшую к целевому значению точку

Bandwidth (Полоса) Маркер 1 локализует самый высокий пик, от которого идет спад по обе стороны на определенный уровень. (Когда выбрана полоса, то появляется окно уровня, чтобы определить уровень в дБ вниз от пика, на котором измеряется полоса. Значение по умолчанию – 3 дБ).

Этот тип поиска обычно использует маркеры 1-4.

  • Маркер 1: Пик

  • Маркер 2: Определенный уровень вниз влево от пика

  • Маркер 3: Определенный уровень вниз вправо от пика

  • Маркер 4: Центральная частота полосы

Отображение показаний при поиске полосы:

  • BW: (значение маркера 3 по оси Х) - (значение маркера 2 по оси Х) = ширина фильтра

  • Center Средняя математическая точка между маркерами 2 и 3

  • Q отношение центральной частоты к полосе (Центральная частота/Полоса)

  • Loss значение маркера 4 на оси Y. Это потери фильтра на его центральной частоте. Идеальный фильтр не имеет потерь (0 дБ) в полосе пропускания.

Примечание: Необходимо сначала или нажать Execute или отметить Tracking, чтобы запустить все типы поиска.

Execute Нажать, чтобы маркер начал поиск по указанному критерию.

Tracking отметьте, чтобы маркер начинал поиск по указанному критерию с каждым новым свипированием. Поиск начинается с первым свипированием, после того, как было отмечено Tracking, основываясь на типе поиска и информации об области. Поэтому, убедитесь, что критерии поиска находятся в необходимом состоянии, перед тем как использовать данные. Вы не можете вручную изменить настройки стимула для маркера, если для этого маркера выбрано Tracking.

Что такое "пик"?

Вы определяете, что анализатор будет считать "пиком", выбирая две следующие настройки критериев пика:

  • Threshold (Граничное значение) - минимальная амплитуда (дБ). Чтобы считаться достоверным пик должен находиться выше уровня граничного значения. Точка минимума на каждой стороне может находиться ниже уровня граничного значения.

  • Excursion (Размах) - Вертикальное расстояние (дБ) между пиком и минимальной точкой на обеих сторонах. Чтобы данные считались пиком, значения данных должны понижаться от пика в обе стороны на величину размаха.

Пример:

Настройка граничного значения: -10 дБ
Настройка размаха: 1 дБ
Масштаб = 1 дБ /Деление шкалы
Проведите мышкой над графиком, чтобы найти достоверный пик.

Пик А = Достоверный пик (над настройками Threshold и Excursion)
Пик В = Недостоверный пик (ниже настройки Excursion)
Пик С = Недостоверный пик (ниже настройки Threshold)

Область поиска

Настройки области поиска ограничивают значения стимулов (по оси Х в формате прямоугольных координат) до определенного диапазона. Установите Start и Stop настройки стимулов этих диапазонов Пользователя. Если Start больше чем Stop, маркер не будет перемещаться.

  • Значение области каждого нового маркера по умолчанию - "полный диапазон".

  • Есть 9 областей, определенных пользователем для каждого канала.

  • Области, определенные пользователем, могут перекрываться.

  • Определенную область могут использовать несколько маркеров.

На следующем графике показаны примеры областей поиска.

Функции маркера - изменение настроек прибора

Следующие настройки изменяют настройки анализатора PNA в соответствии с позицией активного маркера.

Как изменить настройку прибора, используя маркеры

Используйте один из следующих методов:

  • +
    Только Center, Ref Level, и Delay доступны

  • На панели Marker Toolbar доступны только Start, Stop Center и Span Frequencies.

Более подробно см. интерфейс передней панели

Marker Function справка по диалоговому окну

Примечание: Функции маркеров не работают с каналами, которые находятся в режиме CW или Сегментированное свипирование.

Marker =>Start Устанавливает начало свипирования на значение активного маркера.

Marker =>Stop Устанавливает окончание свипирования на значение активного маркера.

Marker =>Center Устанавливает средину свипирования на значение активного маркера.

Marker =>Ref Level Устанавливает опорный уровень экрана на значение активного маркера.

Marker =>Delay Наклон фазы в положении стимула, отмеченного активным маркером, используется для настройки длины линии к входу приемника. Это эффективно выравнивает график фазы вокруг активного маркера. (Дополнительные настройки электрической задержки требуются для устройств без постоянной групповой задержки в пределах измеряемого диапазона частот.) Это можно использовать для измерения электрической длины или отклонения от линейной фазы.

Эта функция добавляет задержку фазы к изменению фазы в зависимости от частоты; таким образом, она применима только для относительных измерений. (См. Измеряемые параметры.)

Marker =>Span Устанавливает диапазон свипирования равным диапазону, который определяется дельта маркером и опорным маркером. Недоступно, если нет дельта маркера.

Выбор дополнительных настроек маркера (Advanced Marker settings)

Потом нажмите Advanced в диалоговом окне Marker

Более подробно см. интерфейс передней панели

Advanced Marker справка по диалоговому окну

Marker определяет номер маркера, который вы выбрали.

On отметьте, чтобы отобразить маркер и соответствующие данные на экране.

Format отображает данные маркеров в формате, который Вы выбрали. Формат маркера может отличаться от формата сетки. В настройках по умолчанию форматы маркера и сетки одинаковые.

Discrete Marker отметьте, чтобы значения отображались только в дискретных точках, в которых берутся данные. Снимите отметку, чтобы отображались значения, которые получены интерполяцией точек.

Coupled Markers отметьте, чтобы связать маркеры по номеру маркера, 1 с 1, 2 с 2 и так далее. Маркеры будут оставаться связанными до тех пор, пока не будет снята отметка. Подробнее о связанных маркерах.

Тип маркера

Normal (Нормальный) имеет фиксированное положение стимула (ось Х) и отвечает на изменения в амплитуде данных (ось Y). Его можно перемещать влево и вправо по оси Х, изменяя значение стимула маркера. Используйте этот тип маркера с одним из типов поиска маркера для нахождения положения необходимых данных.

Fixed (Фиксированный) имеет фиксированное положение оси Х и оси Y, которое основывается на его положении на графике в момент, когда он был зафиксирован. Он НЕ перемещается с изменением амплитуды данных на графике. Его можно перемещать влево и вправо по оси Х, изменяя значение стимула маркера.

Используйте этот тип маркера, чтобы быстро проверить изменения измеряемого устройства "до и после". Например, можно использовать фиксированные маркеры для записи разницы результатов измерений до и после настройки фильтра.

Связанные маркеры

Функция связанных маркеров заставляет маркеры на разных графиках выстраиваться в линию с маркерами на выбранном графике. Маркеры связываются номером маркера, 1 с 1, 2 с 2, 3 с 3 и так далее. Если области оси Х одинаковые (такие как частота или время), связывание происходит во всех каналах, окнах и графиках. Маркеры графика в разных областях оси Х не будут связаны. Если маркер графика не имеет маркера для связывания на выбранном графике, то маркер остается независимым.

Модель связанных маркеров

Эта модель моделирует использование связанных маркеров в анализаторе PNA

  1. Нажмите Trace A или Trace B

  2. Нажмите Coupled Markers

  3. Обратите внимание на следующее:
    * Маркеры на невыбранном графике перемещаются к позициям на оси Х выбранного графика.
    * Если номер маркера на невыбранном графике не имеет соответствующего маркера на выбранном графике, то этот маркер не перемещается.

  4. Нажмите Reset для повторного запуска модели. (В анализаторе PNA нет Reset для связанных маркеров)

Устанавливайте связанные маркеры из диалогового окна Advanced Markers.

Таблица маркеров

Можно вывести на экран таблицу, которая показывает данные маркера для активного графика. Данные маркера отображены в установленном для каждого маркера формате.

Вывод таблицы маркеров

Используйте один из следующих методов:

  • +

Более подробно см. интерфейс передней панели

Примечание: Таблицу маркеров и показания маркеров можно также включить с помощью меню View (См. Модификация экрана PNA.)


Математические операции

Использование математических операций

Можно выполнить 4 типа математических операций между на активным графиком и графиком в памяти. Дополнительно можно вычислить и отобразить для активного графика данных три статистические величины (Средняя величина, Среднеквадратичное отклонение и Амплитудное значение).

  • Математическая обработка графика

  • Статистические величины графика

Другие разделы по анализу данных

Математическая обработка графика

Чтобы выполнить любое математическое действие, сначало необходимо сохранить график в памяти. Можно отобразить график из памяти, используя опции View.

Математическая обработка графика выполняется на комплексных данных, перед тем как они форматируются для вывода на экран. См. Схема обработки данных PNA.

Маркеры могут быть использованы при просмотре любого графика, включая график в памяти.

Выбор математической обработки графика

Используйте один из следующих методов:

  • +

Только следующее доступно из панели Активного ввода

  • Data>>Mem (сохраняет данные графика в память)

  • Data/Mem (выполняет математическую операцию: деление данных графика на данные из памяти)

  • Data (отображает график данных, к которому не применялись математические действия)

  • Mem on/OFF (включает и выключает график в памяти)

Более подробно см. Интерфейс передней панели

Math / Memory справка по диалоговому окну

Data=>Memory Отправляет активный график данных в память.

Data Math

Все математические действия выполняются на линейных данных (действительных и мнимых) перед форматированием. См. Поток данных PNA (ниже).

Data Не выполняет математических операций.

Data / Memory - Текущие математические данные делятся на данные из памяти. Используйте для сопоставления двух графиков, таких как измерения усиления или ослабления. Подробнее.

Data – Memory - Данные в памяти вычитаются из текущих измеренных данных. Например, можно использовать эту функцию для сохранения вектора погрешности и затем вычесть эту погрешность из измерений тестируемого устройства. Подробнее.

Data + Memory - Текущие измеренные данные складываются с данными в памяти. Подробнее.

Data * Memory - Текущие измеренные данные умножаются на данные в памяти. Подробнее.

8510 Mode Отметьте, чтобы эмулировать последовательность обработки данных Agilent 8510 в части, относящейся к математической обработке данных и памяти. Эта настройка применяется ко всем каналам. Когда флажок установлен или снят PNA выполняет предварительную настройку прибора и хранит эту настройку при последующих предварительных настройках прибора.

Эта настройка сохраняется как часть состояния прибора. Однако, при повторном вызове, эта настройка принимается только временно. Когда выполняется последующая предварительная настройка PNA, анализатор возвращается к настройке, которая была в действии перед повторным вызовом состояния.

Этот рисунок показывает соответствующую часть потока данных. См. полную последовательность обработки данных PNA.

Trace View Options

Data Trace Отображает ТОЛЬКО график данных (с применением выбранных математических действий).

Memory Trace Отображает ТОЛЬКО график данных в памяти.

Data and Memory Trace Отображает и график данных (с применением выбранных математических действий) и график в памяти.

Подробнее о математической обработке данных (выше)

(Data / Memory) и (Data - Memory)

(Data / Memory) и (Data - Memory) – математические действия, которые выполняются для линейных данных перед форматированием. Поскольку данные часто просматривают в логарифмическом формате, то очень часто неясно, какое из математических действий нужно применять. Запомните: деление линейных данных - то же самое, что вычитание логарифмических данных. Следующий пример показывает, когда обычно используется каждое из математических действий.

Используйте Data / Memory с целью нормализации, например при сравнении графиков S21 "до" и "после" внесения изменения или при измерении шума графика. В следующей таблице значения Data/Mem интуитивно понятно показывают разницу между графиками. Не ясно, что именно отображает Data-Mem.

Значения S21 для сравнения | Data/Mem | Data-Mem
0.5 дБ и 0.6 дБ | 0.1 дБ | -39 дБ
0.5 дБ и 0.7 дБ | 0.2 дБ | -33 дБ

Используйте Data - Memory, чтобы показать разницу между двумя сигналами. Используйте для сравнения очень слабых сигналов, таких как S11 согласование двух коннекторов.

В следующей таблице значение Data/Mem показывает, что обе пары коннекторов имеют одинаковую разницу в 2 дБ. Однако, вторая пара коннекторов имеет намного лучшую характеристику S11 (-50 и -52), а относительная значимость показана в значениях Data-Mem.

Значения S11 для сравнения | Data/Mem | Data-Mem
-10 дБ и -12 дБ | 2 дБ | -24 дБ
-50 дБ и -52 дБ | 2 дБ | -64 дБ

Data * Memory и Data + Memory

Используйте Data * Memory и Data + Memory для выполнения математических действий на активном графике данных, используя данные из собственных формул или алгоритмов, а не данные измерений. Например, если Вы хотите смоделировать усиление теоритического усилителя, размещенного последовательно перед тестируемым устройством, Вы можете:

  1. Создать алгоритм, который бы характеризовал частотную характеристику теоретического усилителя.

  2. Ввести пары комплексных данных, которые соответствуют количеству точек для Вашего графика данных.

  3. Загрузить пары данных в память с помощью команд SCPI или COM. Анализатор преобразовывает пары комплексных данных, чтобы они соответствовали значениям стимулов в действительных точках измерения.

  4. Использовать функцию data + memory или data * memory, чтобы добавить или умножить данные частотной характеристики на измеренные данные из активного графика данных.

Примечание: График данных необходимо сконфигурировать перед тем, как загрузить в память.

Статистические величины графика

Можно вычислить и отобразить статистические величины для активного графика данных. Это следующие величины:

  • Средняя величина

  • Среднеквадратичное отклонение

  • Амплитудные значения

Можно рассчитать статистические величины для полного диапазона стимула или его частей для диапазонов пользователя.

Для одного канала может быть 9 диапазонов пользователя. Эти диапазоны пользователя - то же самое, что и области поиска, определенные для поиска маркером в том же канале; они используют те же регистры памяти и таким образом, имеют одинаковые диапазоны стимула. Если Вы определили области поиска с помощью поиска маркером для канала, Вы можете повторно вызвать эти диапазоны, выбрав соответствующие диапазоны пользователя. Диапазоны пользователя для канала могут перекрывать друг друга.

Удобно пользоваться статистикой графика, чтобы найти амплитудное значение неравномерности в полосе пропускания без поиска отдельно минимального и максимального значений.

Статистические величины графика рассчитываются, основываясь на формате, который используется для отображения данных.

  • Данные в формате прямоугольных координат рассчитываются из скалярных данных, представленных на экране

  • Данные в формате полярной диаграммы или диаграммы Смита рассчитываются из данных, как это было бы отображено в формате Log Mag

Как активировать статистику графика

Более подробно см. Интерфейс передней панели

Trace Statistics справка по диалоговому окну

Statistics отметьте, чтобы отобразить среднюю величину, среднеквадратичное отклонение и амплитудные значения для активного графика.

Span определяет диапазон активного графика, где собираются данные для математической обработки. Можно определить до 9 диапазонов пользователя для одного канала с помощью кнопок Start и Stop. Также можно определить диапазоны пользователя из диалогового окна Marker Search.

Start Определяет начало диапазона пользователя.

Stop Определяет окончание диапазона пользователя.

Подробнее о статистике графика (выше)


Использование граничных линий для тестирования устройств

Граничные линии позволяют сравнивать измеренные данные с ограничениями характеристик, которые Вы устанавливаете.

  • Обзор

  • Создание и редактирование граничных линий

  • Отображение на экране и тестирование с помощью граничных линий

  • Тестирование с достаточным количеством точек

Другие разделы по анализу данных

Обзор

Граничные линии – визуальное представление указанных пределов измерения на экране анализатора. Граничные линии используются:

  • Чтобы дать оператору визуальные указатели при настройке приборов.

  • Чтобы обеспечить стандартный критерий для соответствия спецификации прибора.

  • Чтобы показать сравнение данных со спецификацией.

Граничное тестирование (тестирование по критерию) сравнивает измеренные данные с установленными границами и обеспечивает дополнительную информацию годен/не годен (Pass or Fail) для каждой измеренной точки.

Вы можете устанавливать до 100 отдельных линий для каждго измерения, что позволяет тестировать все аспекты характеристики тестируемого устройства.

Граничные линии и граничное тестирование НЕ доступны для отображения в формате полярной диаграммы или диаграммы Смита. Если граничные линии ВКЛЮЧЕНЫ, и Вы измените формат на формат полярной диаграммы или диаграммы Смита, то анализатор автоматически отключает граничные линии и граничное тестирование.

Примечание: Граничные линии НЕ поддерживаются Приложением Преобразователь частоты. Они МОГУТ быть использованы при базовых измерениях со смещением частоты.

Создание и редактирование граничных линий

Можно создавать граничные линии для всех графиков измерений. Граничные линии того же цвета, что и график измерений.

Граничные линии состоят из дискретных линий с четырьмя координатами:

  • НАЧАЛО и КОНЕЦ стимула - значения по оси X.

  • НАЧАЛО и КОНЕЦ отклика – значения по оси Y.

Создание и редактирование граничных линий

Границы создаются, изменяются и активируются с помощью таблицы границ.

Используйте один из следующих методов, чтобы показать таблицу границ:

  • +

Более подробно см. Интерфейс передней панели

Таблица границ

Примечание: Чтобы ДОБАВИТЬ граничную линию в таблицу, измените последнюю граничную линию на МАКС или МИН (MAX или MIN)

  1. В области Type таблицы границ выберите MIN или MAX для граничной линии 1.
    Значение MIN не позволит признать годным результат измерения НИЖЕ этой границы.
    Значение MAX не позволит признать годным результат измерения ВЫШЕ этой границы.

  2. Нажмите BEGIN STIMULUS для сегмента границы 1. Введите необходимое значение.

  3. Нажмите END STIMULUS для сегмента границы 1. Введите необходимое значение.

  4. Нажмите BEGIN RESPONSE для сегмента границы 1. Введите необходимое значение.

  5. Нажмите END RESPONSE для сегмента границы 1. Введите необходимое значение.

  6. Повторите шаги 1 – 5 для каждой граничной линии.

Отображение на экране и тестирование с помощью граничных линий

После создания граничных линий, можно выбрать отобразить или спрятать для каждого графика. Установленные границы остануться действительными, даже если линии не отображены.

Граничное тестирование не может выполняться для графиков в памяти.

Можно выбрать визуальную и/или звуковую индикацию годен/ не годен (PASS / FAIL).

Когда граничное тестирование включено (ON):

  • Любая часть измеренного графика, которая относится к "не годен" – показывается красным цветом.

  • Любая часть измеренного графика, которая относится к "годен" – остается без изменений.

PASS – режим по умолчанию тестирования Pass / Fail. Точка "не проходит" только, если она попадает за граничные линии.

  • Если граничная линия установлена в OFF (выключена), то весь график "годен".

  • Если нет измеренной точки на граничной линии настройки стимула, то эта точка "годна".

Отображение на экране и тестирование с помощью граничных линий

Следующий метод активизирует диалоговое окно

Следующий метод показывает таблицу границ и обеспечивает включение/выключение тестирования и линий.

  • +
    Выбор Sound ON Fail не доступен на панели активного ввода

Более подробно см. Интерфейс передней панели

Limit Test (Граничное тестирование) справка по диалоговому окну

Limit Test

Limit Test ON отметьте, чтобы сравнить график данных с границами и отобразить PASS или FAIL.

Limit Line ON отметьте, чтобы линии были видны на экране (Тестирование также происходит, если линии невидимые.)

Sound ON Fail отметьте, чтобы PNA издавал звуковой сигнал, когда точка не проходит граничный тест.

Global Pass/Fail

Индикатор Pass/Fail обеспечивает простоту слежения за состоянием всех измерений.

Global pass/fail display ON отметьте, чтобы отобразить статус Global Pass/Fail.

Policy: Выберите, что из нижеперечисленного должно выполняться, чтобы статус Global Pass/Fail отображался как PASS:

  • All Tests Must Pass - Все тесты (при включенном граничном тестировании) должны пройти - эта настройка считывает результаты граничных тестов. Если все тесты (при включенном граничном тестировании) прошли тогда статус Global Pass/Fail будет PASS.

  • All Measurements Must Pass - Все измерения должны пройти – эта более требовательная настройка показывает FAIL, если только все измеренные точки не попадают внутрь установленных тестовых границ и граничное тестирование включено. Примечание: с данной настройкой все граничные тесты могут пройти, хотя статус Global Pass/Fail показывает FAIL. Это случается из-за того, что граничные тесты по умолчанию установлены на PASS и Global Pass/Fail с "Все измерения должны пройти" установлен по умолчанию в FAIL.

Show Table Показывает таблицу, которая позволяет создавать и изменять границы.

Hide Table Убирает таблицу границ с экрана.

Примечание: Чтобы ДОБАВИТЬ граничную линию в таблицу, измените последнюю граничную линию на МАКС или МИН (MAX или MIN)

Более подробно об отображении на экране и тестировании с помощью границ (прокрутить вверх)

Тестирование с достаточным количеством точек

Границы проверяются только в фактически измеренных точках. Таким образом, устройство может несоответствовать спецификации и при этом не будет индикации "не годен", если количество точек недостаточное.

На рисунке ниже изображен график данных фильтра, состоящего из 11 точек (приблизительно одна на каждую вертикальную линию координатной сетки). Фильтр тестируется минимальной граничной линией (любая точка под граничной линией не проходит).

Хотя график данных ниже граничной линии на обеих сторонах амплитудно-частотной характеристики фильтра, появляется индикатор ГОДЕН (PASS), поскольку на этих частотах не измеряется ни одна точка.

На следующем рисунке изображены практически те же условия, кроме количества точек, которое увеличено до 1601. Теперь фильтр не проходит граничный тест, что обозначено красным на графике данных.


Сохранение и вызов файла

Анализатор PNA позволяет сохранять и вызывать файлы с внешнего и внутреннего устройства хранения данных в различных форматах.

  • Как сохранить файл

  • Как вызвать файл

  • Файлы состояния прибора/ калибровки (.cst, .sta, .cal)

  • Файлы с данными измерений (.prn, .SnP, .cti)

  • Определение сохранения данных

  • Управление файлами без мыши

Другие разделы по выводу данных

Как сохранить файл

Используйте один из следующих методов:

    • +

Save Сразу сохраняет состояние анализатора и возможные данные калибровки в файл с именем и расширением, использованными при последнем сохранении. Запоминаются только файлы с расширением .cst и .sta. Файл будет переписан при следующем сохранении. Чтобы этого не случилось, используйте один из следующих методов.

Save As Вызывает диалоговое окно Save As.

Auto Save (доступно только с помощью кнопок панели активного ввода). Сохраняет состояние и данные калибровки на внутренний жесткий диск в C:\Program Files\Agilent\Network Analyzer\Documents. Имя файлу присваивается автоматически, используя синтаксис "atxxx.cst"; где xxx число, увеличенное на 1, когда автоматически сохраняется новый файл.

Примечание: НЕЛЬЗЯ сохранять файлы приложения преобразователя частоты (FCA - Frequency Converter Application) .S2P используя данный метод. См. Использование FCA, сохранение данных.

Более подробно см. Интерфейс передней панели

Справка по диалоговому окну Save As

Save in Позволяет перемещаться к каталогу, в которой Вы хотите сохранить файл.

File name Отображает название файла, которое вы вводите, или выбираете из окна каталогов.

Save as type

(Сохранить с расширением) Следующие типы файлов сохраняют состояние прибора и данные калибровки. Эти типы файлов распознаются только анализаторами Agilent серии PNA. Более подробно о типах файлов.

  • *.cst - сохраняет и состояние прибора, и указатель на данные Cal Set

  • *.sta - сохраняет только состояние прибора (а (не данные калибровки)

  • *.cal - сохраняет только данные калибровки (без Cal Set)

Следующие типы файлов сохраняют данные измерения для использования в электронных таблицах или программах CAE. См. более подробно об этих типах файлов.

  • *.prn

  • *.s1p , *.s2p, *.s3p

  • *cti (citifile)

Прмечание: Чтобы сохранить экран PNA в графических файлах типа .bmp, .jpg, или .png, нажмите File / Print to File. Более подробно.

Save Сохраняет файл в указанный каталог с указанным названием.

Как вызвать (открыть) файл

Используйте один из следующих методов:

  • Нажмите [image] повторно, потом

Более подробно см. Интерфейс передней панели

Справка по диалоговому окну Recall (Вызов)

Look in Позволяет выбрать каталог, который содержит файл, который Вы хотите открыть.

File name Отображает имя файла, которое Вы вводите, или выбираете из каталога в диалоговом окне.

Files of type Позволяет видеть и выбирать файлы, перечисленные в категориях типа файла.

Recall Вызывает файл, отображенный в строке file name.

Примечание: Анализатор PNA не может открыть файлы *s1p, *s2p, *s3p.

Файлы состояния прибора/ калибровки

Можно сохранить, а потом вызвать настройки прибора и данные калибровки. Почти каждая настройка анализатора сохраняется и вызывается с помощью состояния прибора (Instrument State). Следующие настройки PNA НЕ сохраняются и не вызываются с помощью состояния прибора:

  1. Адрес GPIB

  2. РЧ мощность ВКЛ/ВЫКЛ (См. более подробно.)

  3. Настройки ввода/вывода тестовой последовательности (Test set I/O settings)

Есть три типа файлов, которые сохраняют и вызывают эти файлы:

  • *.sta файлы содержат Состояние прибора но не данные калибровки или указатель на Cal Set.

  • *.cal файлы содержат Данные калибровки НЕ как указатель на Cal Set.

  • *.cst файлы содержат и Состояние прибора и указатель на Cal Set. См. более подробно о наборах калибровки (Cal Sets). Вызов файла *.cst file экономит время, поскольку вызывает и состояние прибора, и данные калибровки для каждого измерения.

Файлы с данными измерений

Измерения данных сохраняются как файлы типа ASCII для использования в электронных таблицах и программах CAE. Следующие три типа файлов используются анализатором PNA. Вы можете выбрать содержание и формат файлов *.SnP и *.cti через диалоговое окно Define Data Saves (Определение сохранения данных).

  • *.prn файлы

  • *.SnP (для программы Touchstone)

  • *.cti (Citifile)

*Файлы .prn

  • Считываются прямо в ряды и колонки электронных таблиц, таких как Microsoft® Excel.

  • Содержат отформатированные и скорректированные стимулы и данные.

  • Содержат перечень через запятую ТОЛЬКО для активного в данный момент графика.

  • Только выходные данные – они не читаются анализатором.

Пример:

"S11 Log Mag" |
"Частота (Гц)", | "дБ"
3.000000e+005 , | -3.528682e+001 ,
4.529850e+007 , | -2.817913e+001 ,
9.029700e+007 , | -3.216808e+001 ,
1.352955e+008 , | -3.101017e+001 ,

Формат SnP (*.s1p, *.s2p, *.s3p)

Этот формат используется программами CAE, такими как Microwave Design System (MDS) от Agilent и Advanced Design System (ADS).

Note: файлы приложения преобразователя частоты .S2P сохраняются с помощью другого метода. См. Использование FCA, сохранение данных.

  • SnP данные только для вывода; они не читаются анализатором.

  • SnP данные можно сохранять в различных форматах. См. Определение сохранения данных Define Data Saves

  • Количество сохраненных данных зависит от типа файла, который Вы определите:

Тип файла | Кол-во портов | Кол-во сохраненных S-параметров
*.s1p | 1 | 1 S-параметр
*.s2p | 2 | 4 S-параметра
*.s3p | 3 | 9 S-параметров

SnP данные обычно используются для сбора всех 4-х S-параметров для полностью скорректированных измерений. Анализатор PNA выполняет этот запрос, используя данные, доступные в канале активного измерения.

  • Если применяется полная 2-портовая корректировка, достоверные данные возвращаются для всех 4 исправленных s-параметров.

  • Если корректировка НЕ применяется, анализатор PNA возвращает как можно более применимые исходные данные, используя измерения S-параметров на выбранном канале.

  • Недоступные данные заполняются нулями.

Например, если НЕ применяется корректировка, и активное измерение - S11, и на канале также есть измерение параметра S21, тогда данные возвращаются с измерениям параметров S11 и S21. Данные для S12 и S22 недоступны, поэтому они возвращаются как нули.

Все достоверные данные сохраняются, используя один и тот же формат и настройки, как и активное измерение. Например, если настройки активного измерения включают расширения порта, временную область и сглаживание, тогда все достоверные данные обрабатываются и сохраняются, используя эти настройки.

Вывод данных SnP

SnP файлы содержат информацию заголовка, данные стимулов, пары данных отклика для измерения КАЖДОГО S-параметра. Единственная разница между файлами S1P, S2P и S3P - количество S-параметров, которые сохраняются.

Пример Информации заголовка (Header information):

!Agilent Technologies,E8362B,US42340026,Q.03.54

!Agilent E8362B: Q.03.54

!Date: Friday, April 25, 2003 13:46:41

!Correction: S11(Full 2 Port SOLT,1,2) S21(Full 2 Port SOLT,1,2) S12(Full 2 Port SOLT,1,2) S22(Full 2 Port SOLT,1,2)

!S2P File: Measurements:S11,S21,S12,S22:

# Hz  S RI R 50

Примечание: Хотя пример показывает пары Real / Imag (действительные / мнимые), формат может также быть LogMag / Phase (логарифмическая амплитуда / фаза) или LinMag / Phase (линейная амплитуда / фаза)

Файлы *.s1p

Каждая запись содержит 1 значение стимула и 1 S-параметр (всего 2 значения)

Stim Real (Sxx) Imag(Sxx)

Файлы *.s2p

Каждая запись содержит 1 значение стимула и 4 S-параметров (всего 8 значений)

Stim Real (S11) Imag(S11) Real(S21) Imag(S21) Real(S12) Imag(S12) Real(S22) Imag(S22)

Файлы *.s3p

Каждая запись содержит 1 значение стимула и 9 S-параметров (всего 18 значений)

Stim Real (S11) Imag(S11) Real(S12) Imag(S12) Real(S13) Imag(S13)

Real (S21) Imag(S21) Real(S22) Imag(S22) Real(S23) Imag(S23)

Real (S31) Imag(S31) Real(S32) Imag(S32) Real(S33) Imag(S33)

Примечание: для файлов *.s3p необходимо 3 строки на один стимул.

*cti CitiFiles

Формат Citifile совместим с анализатором Agilent 8510 и системой проектирования Agilent's Microwave Design System (MDS). С помощью citi-файлов можно выполнять следующее:

  • Сохранять активный график, или же все графики (См. Определение сохранения данных (Define Data Saves))

  • Сохранять форматированные и неформатированные данные citifile

Сохранение форматированных данных

  1. Установите формат, используя Define Data Saves.

  2. Нажмите File, а потом Save As

  3. Выберите Citifile Formatted Data (*cti)

  • См. примечание под Вызов файлов Citifile, используя PNA

  • На карте доступа к данным, отформатированные данные берутся из ячеек 2 или 4 карте доступа к данным, форматированные данные берутся из положений 2 или 4.

Сохранение неформатированных данных

  1. Нажмите File Save As

  2. Выберите Citifile Data Data (*cti)

На карте доступа к данным, не отформатированные данные берутся из блока прямо перед Format.

Вызов файлов Citifile, используя PNA

Чтобы читать файлы citifile, используя PNA, нажмите File потом Recall. Установите (*.cti)

Вызванные файлы отображаются на анализаторе в новых окнах и каналах.

  • Номера новых окон начинаются со следующего доступного номера окна.

  • Номера новых каналов начинаются с канала 9.

При вызове файлов citifile отображается ошибка, если Вы превысили ограничения для окон и каналов PNA.

Примечание: Вызванные данные файлов citifile ВСЕГДА отображаются на анализаторе, используя формат LogMag, независимо от того, как сохраняется файл.

Определение сохранения данных (Define Data Saves)

Как выбрать определение сохранения данных (Define Data Saves)

Более подробно см. Интерфейс передней панели

Define Data Saves справка по диалоговому окну

CitiFile Contents Определяет, что сохраняется в .cti файле.

Auto - Сохраняет активный график. Дополнительные графики сохраняются, если ВКЛЮЧЕНА корректировка и выполняется полная 2-портовая или 3-портовая калибровка. Для полной 2-портовой калибровки сохраняется 4 графика. Для полной 3-портовой калибровки сохраняются 9 графиков.

Single Trace - Сохраняет активный график в выбранном окне.

Displayed Traces - Сохраняет все отображенные графики данных

Citifile Formatted Data

Auto - Вывод в выбранном формате графика. Если формат не логарифмической амплитуды LogMag, линейной амплитуды LinMag, или действительные/ мнимые данные Real/Imag, тогда вывод производится в формате действительные/ мнимые данные Real/Imag.

LogMag, LinMag, Real/Imag - Выберите формат. Все выводы в формате LogMag и LinMag - в градусах.

SnP Formatted Data (.s1p, .s2p, .s3p)

Auto - Вывод в выбранном формате графика. Если формат не логарифмической амплитуды LogMag, линейной амплитуды LinMag, или действительные/ мнимые данные Real/Imag, тогда вывод производится в формате действительные/ мнимые данные Real/Imag.

LogMag, LinMag, Real/Imag - Выберите формат. Все выводы в формате LogMag и LinMag - в градусах.

Управление файлами без мыши

Диалоговое окно Manage Files разработано для использования с передней панели. Оно выполняет ту же функцию, что и Windows Explorer, но может использоваться без мыши или клавиатуры.

Более подробно об использовании интерфейса передней панели.

Manage Files справка по диалоговому окну

Recall Открывает состояние анализатора, уже сохраненное в памяти.

Rename Переименовывает файл, выбранный в открытой папке.

Delete Удаляет файл, выбранный в открытой папке.

Delete All Удаляет все файлы выбранного типа, которые появляются в открытой папке.

New folder Создает и называет новую папку

При пользовании мышкой:

Файлы можно перемещать перетаскиванием.

Щелкните правой кнопкой мыши, чтобы вызвать функции управления файлами.


Подключение диска (Drive Mapping)

Подключение диска позволяет совместно использовать дисководы между анализатором PNA и внешним ПК. Вы можете подключаться или от анализатора PNA, или от Вашего ПК.

  • Подключение анализатора PNA к диску на внешнем ПК

  • Подключение внешнего ПК к диску на анализаторе PNA

Подготовка к совместному использованию диска:

  1. И ПК и анализатор должны быть подключены к одной сети

  2. Необходимо знать полное имя ПК (или анализатора), диски которых будут совместно использоваться . Как это сделать

  3. Логин и пароль на анализаторе должны быть такими же, как и на внешнем ПК. Можете добавить логин Вашего ПК в анализатор. Как это сделать

Примечание: Для данных процедур требуется мышь и клавиатура. Также на внешнем ПК должна быть установлена Windows NT 4.0 (или более новая версия).

Подключение анализатора PNA к диску на внешнем ПК

  1. На рабочем столе внешнего ПК выберите Windows Explorer. В списке дисков нажмите правой клавишей мышки на диск, который Вы хотите совместно использовать. Нажмите Sharing.

  2. В диалоговом окне выберите Shared As. В окне Share Name используйте клавиши со стрелками или введите общее имя для диска. Например: C$. Нажмите OK.

  3. На рабочем столе анализатора выберите Windows Explorer. В меню Tools нажмите Map Network Drive. (Чтобы перейти на рабочий стол анализатора нажмите View, затем Title Bars)

  4. Если Вы хотите подключиться к внешнему ПК под другим логином, нажмите Connect using a different Logon. Этот логин должен быть зарегистрирован на анализаторе, и его нужно использовать на внешнем ПК при подключении.

    1. В Connect as введите Ваш логин.
      Логин и пароль должны быть абсолютно одинаковыми как на внешнем ПК, так и на анализаторе.

    2. В Password введите пароль, который Вы используете для внешнего ПК. Нажмите OK. Логин и пароль должны быть абсолютно одинаковыми как на внешнем ПК, так и на анализаторе.

  5. В Folder введите \(полное название компьютера анализатора)\совместное название (см. шаг 2)\(Например: \SLT1234\C$ )

  6. Нажмите Finish.

Подключение внешнего ПК к диску на анализаторе PNA

  1. На рабочем столе анализатора, нажмите Windows Explorer. Нажмите правой клавишей мышки на диск, который Вы хотите совместно использовать. Нажмите Sharing...

  2. В диалоговом окне выберите Shared this folder. В окне Share Name введите название диска для совместного использования. Например: C$. Нажмите OK.

  3. На рабочем столе внешнего ПК нажмите Windows Explorer. Из меню Tools выберите Map Network Drive.

  4. Если текущий логин на Вашем ПК отличается от логина анализатора, нажмите Connect using a different Logon чтобы подключиться к текущему логину анализатора. Этот логин должен быть зарегистрирован на внешнем ПК. Чтобы увидеть текущий логин на ПК или на анализаторе, нажмите и удерживайте клавиши Ctrl - Alt, и нажмите Delete.

    1. В Connect as введите логин, который в данный момент используется анализатором.

    2. В Password введите пароль, который Вы используете для внешнего компьютера. Нажмите OK

  5. В Folder введите \\computername (prep1)\share name (из шага 2). (Например: \\SLT1234\C$ )

  6. Нажмите Finish.


Печать измерений

Печать измерений, отображенных на экране

Анализатор позволяет распечатать отображенные на экране измерения в принтер или в файл. Принтер может быть как подключенный к сети, так и локальный. Нажмите на ссылку, чтобы узнать, как подключить принтер или распечатать отображенные на экране измерения.

  • Подключение принтера

  • Печать

Другие разделы по выводу данных

Подключение принтера

Можно подсоединить принтер к анализатору PNA, используя три типа разъемов:

  • Параллельный разъем

  • Последовательный разъем

  • USB

Примечание: Старые модели PNA имеют разъем Centronics для подсоединения к принтеру. Вместе с анализаторами поставлялись адаптеры (36-контактный штекерный - 1284-C - на 25 контактный гнездовой) для соединения с стандартным кабелем принтера.

ВНИМАНИЕ: НЕ подключайте принтер к 25-контактному гнездовому порту, обозначенному как Ext. Test Set Interface. Уровни напряжения сигнальных шин могут повредить порт ввода/вывода принтера.

Добавление принтера

Примечание: Если Вы печатаете из приложения PNA, и появляется мастер Add Printer Wizard нажмите Cancel и добавьте принтер, выполнив следующие шаги.

  1. В приложении PNA, нажмите View потом нажмите Minimize Application

  2. На панели задач Windows, нажмите Start, укажите на Settings, потом нажмите Printers.

  3. Сделайте двойной щелчок на Add Printer.

  4. Следуйте инструкциям в мастере Add Printer.

За более подробной информацией обращайтесь к справке Microsoft Windows Help или см. документацию к принтеру.

Печать

  • Печатная копия

  • Опции печати

  • Печать в файл

Данные измерения на экране можно распечатать с помощью локального или подсоединенного к сети принтера, который подключен к анализатору. Количество информации для печати определяется в настройках опции принтера.

На рисунке ниже показан пример как выглядит при печати изображение экрана. Настройки Опции принтера позволяют настроить форму печати информации об измерениях.

Как распечатать печатную копию

Используйте один из следующих методов

Более подробно см. Интерфейс передней панели

Примечание: Более подробно об опциях в диалоговом окне Print, см. Справку Windows 2000 Help.

Опции печати

Диалоговое окно Опции печати (Print Options) позволяет настраивать вид, в котором распечатываются данные измерений. После выбора опций нажмите Print... чтобы получить печатную копию.

Как выбрать опции печати

Более подробно см. Интерфейс передней панели

Справка по диалоговому окну Print Options (Опции печати)

Windows (окна)

Print Отметьте, чтобы распечатать данные окон измерений.

Minimum vertical size Настройте, чтобы изменить область страницы, которую заполнит окно измерений. Диапазон настройки - от 0.4 до 1.0 страницы.

Print one window per page Отметьте, чтобы на одной странице распечатывалось одно окно. Уберите флажок, если хотите, чтобы все выбранные окна распечатывались без перехода на следующую страницу.

Only print active window Выберите, чтобы распечатать только активное окно. Уберите флажок, если хотите распечатать все окна.

Channel Settings Table (Таблица настроек канала)

Print Отметьте, чтобы распечатать таблицу настроек канала.

Expand segment data Отметьте, чтобы распечатать данные сегментов. Количество данных зависит от того, на сколько сегментов разбито свипирование.

Trace Attributes Table (Таблица параметров графика)

Print Отметьте, чтобы напечатать таблицу параметров графика. Параметры графика таблицы: тип измерения, поправочные коэффициенты ВКЛ или ВЫКЛ, сглаживание, опции, сведения о маркерах. Параметры графиков перечислены в идентификаторах Trace ID# (1-4) для каждого окна.

Каждый Trace ID# может иметь несколько входных данных, в зависимости от количества маркеров графика. Сведения о маркере - это номер маркера, расположение и отклик. Если на графике есть много маркеров, то показываются параметры графика только для первого маркера. Однако параметры графика для первого маркера применяются ко всем маркерам графика.

В графе опций может быть одна или несколько опций. D для задержки, M для маркера, G для стробирования (временной селекции). Выбранные множественные опции будут выглядеть так: DMG.

Print marker data Отметьте, чтобы распечатать все сведения о маркерах. Количество сведений зависит от того, сколько маркеров создано.

Печать в файл

Анализатор может сохранить изображение на экране в любом из следующих форматов:

  • .bmp формат (побитовое отображение)

  • .jpg формат

  • .png формат

Анализатор автоматически сохраняет файл по текущему пути. Если путь предварительно не определен, то анализатор автоматически выбирает путь по умолчанию C:\Program Files\Agilent\Network Analyzer\Documents\

Файл .bmp, как и файл .prn, можно импортировать в приложения, такие как Microsoft Excel, Word, или Paint , чтобы отобразить изображение на экране.

Как выполнить печать в файл

Более подробно см. Интерфейс передней панели

Более подробно см. Сохранение и вызов файлов.


PNA Object Model

See a list of obsolete commands.


Application Object

Description

The Application object is the highest object in the PNA object model. This object presents methods and properties that affect the entire analyzer, rather than a specific channel or measurement. For example, the application object provides the GetIDString method. There's only one ID string for the instrument, unrelated to the channel or parameter being measured. Likewise, the TriggerSignal Property is global to the instrument. You can elect to use an internally generated (free run) trigger or a manual trigger. Either way, that type of trigger generation will be used on all measurements, on all channels. Therefore, it is under the Application object.

Accessing the Application object

This object is unique in that you must create this object rather than just get a handle to it.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Replace <analyzerName> with the full computer name of your PNA. For example, "My PNA". See Change Computer Name.

See Also:

PNA Automation Interfaces

The PNA Object Model

Getting a Handle to an Object.

(Bold Methods or Properties provide access to a child object)

Methods

Interface

See History

Description

ActivateWindow

IApplication

Makes a window object the Active Window.

AllowAllEvents

IApplication

Monitors all events

AllowEventCategory

IApplication

Monitors an event category

AllowEventMessage

IApplication

Monitors an event

AllowEventSeverity

IApplication

Monitors an event severity level

BuildHybridKit

IApplication

Defines the user kit as port1kit + port2kit.

Channel

IApplication

Stimulus values like frequency, power, IF bandwidth, and number of points.

CreateCustomMeasurementEx

IApplication3

Creates a new custom measurement with initialization.

CreateCustomMeasurement

IApplication

OBSOLETE - CreateCustomMeasurementEx Method

CreateMeasurement

IApplication

Creates a new measurement.

CreateSParameter

IApplication

OBSOLETE - Use Create SParameterEX Method

CreateSParameterEx

IApplication

Creates a new S-Parameter measurement with a 3-port load.

DeleteShortCut

IApplication

Removes a macro (shortcut) from the list of macros

DisallowAllEvents

IApplication

Monitors NO events

DoPrint

IApplication

Prints the screen to the active Printer.

ExecuteShortcut

IApplication

Executes a macro (shortcut) stored in the analyzer.

GetAuxIO

IApplication

Returns a handle to the AuxIO interface

GetCalManager

IApplication

Returns a handle to the CalManager interface

GetExternalTestSetIO

IApplication

Returns a handle to the ExternalTestSet IO interface

GetMaterialHandlerIO

IApplication

Returns a handle to the MaterialHandlerIO interface

GetShortcut

IApplication

Returns the title and path of the specified macro (shortcut).

LaunchCalWizard

IApplication

Launches the Cal Wizard

ManualTrigger

IApplication

Triggers the analyzer when TriggerSignal = naTriggerManual.

Preset

IApplication

Resets the analyzer to factory defined default settings.

PrintToFile

IApplication

Saves the screen data to bitmap (.bmp) file of the screen.

PutShortcut

IApplication

Puts a Macro (shortcut) file into the analyzer.

Quit

IApplication

Ends the Network Analyzer application.

Recall

IApplication

Recalls a measurement state, calibration state, or both from the hard drive into the analyzer.

RecallKits

IApplication

Recalls the calibration kits definitions that were stored with the SaveKits command.

Reset

IApplication

Removes all existing windows and measurements.

RestoreCalKitDefaults

IApplication

Restores the factory defaults for the specified kit.

RestoreCalKitDefaultsAll

IApplication

Restores the factory defaults for all kits.

Save

IApplication

Saves files to disk

SaveCitiDataData

IApplication4

Saves UNFORMATTED trace data to .cti file.

SaveCitiFormattedData

IApplication4

Saves FORMATTED trace data to .cti file.

SaveKits

IApplication

Saves all cal kits to disk.

SetFailOnOverRange

IApplication

Causes over range values to return an error code

ShowStatusBar

IApplication

Shows and Hides the Status Bar.

ShowStimulus

IApplication

Shows and Hides Stimulus information.

ShowTitleBars

IApplication

Shows and Hides the Title Bars.

ShowToolbar

IApplication

Shows and Hides the specified Toolbar.

UserPreset

IApplication7

Performs a User Preset.

UserPresetLoadFile

IApplication7

Loads an existing instrument state file (.sta or .cst) to be used for User Preset.

UserPresetSaveState

IApplication7

Saves the current instrument settings as UserPreset.sta.

Properties

Description

ActiveCalKit

IApplication

Returns a pointer to the kit identified by kitNumber.

ActiveChannel

IApplication

Returns a handle to the Active Channel object.

ActiveMeasurement

IApplication

Returns a handle to the Active Measurement object.

ActiveNAWindow

IApplication

Returns a handle to the Active Window object.

ArrangeWindows

IApplication

Sets or returns the arrangement of all the windows.

CalKitType

IApplication

Sets or returns the calibration kit type for to be used for calibration or for kit modification. Shared with the CalKit object.

Capabilities

IApplication4

Return capabilities of the remote PNA.

Channels

IApplication

Collection for iterating through the channels

CoupledMarkers

IApplication

Sets (or reads) coupled markers ON and OFF

DisplayAutomationErrors

IApplication2

Enables or disables automation error messages from being displayed on the screen. U

DisplayGlobalPassFail

IApplication6

Shows or hides the dialog which displays global pass/fail results.

ExternalALC

IApplication

Sets or returns the source of the analyzer leveling control.

GPIBAddress

IApplication8

Sets and returns the PNA GPIB address.

GPIBMode

IApplication

Makes the analyzer the system controller or a talker/listener.

IDString

IApplication

Returns the model, serial number and software revision of the analyzer

LocalLockoutState

IApplication4

Prevents use of the mouse, keyboard, and front panel while your program is running.

Measurements

IApplication

Collection for iterating through the Application measurements.

MessageText

IApplication

Returns text for the specified eventID

NaWindows

IApplication

Collection for iterating through the Application windows.

NumberOfPorts

IApplication

Returns the number of hardware source ports on the PNA

Options

IApplication

Returns the options on the analyzer

Port Extensions

IApplication

Preferences

IApplication5

Preferences for saving citifiles.

ScpiStringParser

IApplication

Provides the ability to send a SCPI command from within the COM command.

SecurityLevel

IApplication4

Turns ON or OFF the display of frequency information.

SICL

IApplication5

Allows control of the PNA via SICL

SICLAddress

IApplication8

Sets and returns the PNA SICL address

SourcePowerCalibrator

IApplication2

Allows capability for performing source power calibrations.

SourcePowerState

IApplication

Turns Source Power ON and OFF.

SystemImpedanceZ0

IApplication

Sets the analyzer impedance value.

SystemName

IApplication

Returns the full computer name of the PNA.

TriggerDelay

IApplication

Sets or returns the delay time for a trigger.

TriggerSetup

IApplication4

Controls triggering for the entire PNA application.

TriggerSignal

IApplication

Obsolete - use Source Property

TriggerType

IApplication

Obsolete - use Scope Property

UserPresetEnable

IApplication7

'Checks' and 'clears' the enable box on the User Preset dialog box.

VelocityFactor

IApplication

Sets the velocity factor to be used with Electrical Delay, Port Extensions, and Time Domain marker distance calculations.

Visible

IApplication

Makes the Network Analyzer application visible or not visible.

WindowState

IApplication

Sets or returns the window setting of Maximized, Minimized, or Normal.

Shared with the NAWindow Object

Events

Interface

Description

OnCalEvent

IApplication

Triggered by a calibration event.

OnChannelEvent

IApplication

Triggered by a channel event.

OnDisplayEvent

IApplication

Triggered by a display event.

OnHardwareEvent

IApplication

Triggered by a hardware event.

OnMeasurementEvent

IApplication

Triggered by a measurement event.

OnSCPIEvent

IApplication

Triggered by a SCPI event.

OnSystemEvent

IApplication

Triggered by a system event.

OnUserEvent

IApplication

For future use

IApplication History

Interface | Introduced with PNA Rev:
IApplication | 1.0
IApplication2 | 3.0
IApplication3 | 3.2
IApplication4 | 3.5
IApplication5 | 4.0
IApplication6 | 5.0
IApplication7 | 5.0
IApplication8 | 5.2


CalFactorSegments Collection

Description

A collection object that provides a mechanism for iterating through the segments of a power sensor cal factor table.

Accessing the CalFactorSegments collection

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim calFact As CalFactorSegments
Set calFact = app.SourcePowerCalibrator.PowerSensors(1).CalFactorSegments

See Also:

Collections in the Analyzer

The PNA Object Model

Methods

Description

Add

Adds a PowerSensorCalFactorSegment object to the collection

Item

Use to get a handle to a PowerSensorCalFactorSegment object in the collection.

Remove

Removes an object from the collection.

Properties

Description

Count

Returns the number of objects in the collection.

Parent

Returns a handle to the Parent object (PowerSensor) of this collection.


Calibrator Object

See Calibrator Methods and Properties

See ICalData Interface for putting and getting typed Calibration data.

Description

The Calibrator object, a child of the channel, is used to perform an Unguided calibration.

Note: You can NOT perform a full 3 or 4-port using the Calibrator object; you must use the GuidedCalibration object.

There must be a measurement present for the calibrator to use or you will receive a "no measurement found" error. Therefore, to perform a 2-port cal, you must have any S-parameter measurement on the channel. For a 1-port measurement, you must have the measurement (S11 or S22) on the channel. The same is true for a response measurement.

There are a number of approaches to calibration with the calibrator object:

  • You can collect data yourself and download it to the ACQUISITION buffer. The acquisition buffer holds the actual measured data for each standard. See the PNA data map.

  1. Calibrator.SetCalInfo

  2. Connect a standard

  3. Trigger a sweep

  4. Retrieve the data for the standard

  5. Download the data - calibrator.putStandard

  6. Repeat for each standard

  7. Calibrator.CalculateErrorCoefficients

  • You can tell the calibrator to acquire a standard. In this case, the calibrator collects the data and places it in the ACQUISITION buffer.

  1. Calibrator.SetCalInfo

  2. Connect a standard

  3. Calibrator.AcquireCalStandard2

  4. Repeat for each standard

  5. Calibrator.CalcuateErrorCoefficients

  • You can put previously-retrieved error terms in the error correction buffer.

  1. PutErrorTerm

  2. Repeat for each term

  3. Measurement.Caltype = pick one

  • You can also "piece together" a 2-port cal from two 1-port cals (S11 and S22) and four response (thru) cals. The system will detect that all the standards needed for a 2-port cal have been acquired even though they may not have gathered at the same time.

Accessing the Calibrator object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim cal As ICalibrator
Set cal = app.ActiveChannel.Calibrator

See Also:

  • PNA Automation Interfaces

  • The PNA Object Model

  • Learn about reading and writing Calibration data.

Methods

Interface

See History

Description

AcquireCalConfidenceCheckECAL

ICalibrator

Obsolete - use AcquireCalConfidenceCheckECALEx

AcquireCalConfidenceCheckECALEx

ICalibrator4

Transfers ECAL confidence data into analyzer memory

AcquireCalStandard

ICalibrator

Obsolete - use AcquireCalStandard2

AcquireCalStandard2

ICalibrator

Causes the analyzer to measure a calibration standard. Also provides for sliding load.

CalculateErrorCoeffecients

ICalibrator

Generates Error Terms from standard and actual data in the error correction buffer.

DoECAL1Port

ICalibrator

Obsolete - use DoECAL1PortEx

DoECAL1PortEx

ICalibrator4

Completes a 1 port ECAL

DoECAL2Port

ICalibrator

Obsolete - use DoECAL2PortEx

DoECAL2PortEx

ICalibrator4

Completes a 2 port ECAL

DoneCalConfidenceCheckECAL

ICalibrator

Concludes an ECAL confidence check

GetECALModuleInfo

ICalibrator

Obsolete - use Get ECALModuleInfoEx

Get ECALModuleInfoEx

ICalibrator4

Returns information about the attached module

getErrorTerm

ICalibrator

Obsolete- replaced by GetErrorTermByString

getStandard

ICalibrator

Obsolete - replaced by GetStandardByString

putErrorTerm

ICalibrator

Obsolete - replaced by PutErrorTermByString

putStandard

ICalibrator

Obsolete - replaced by PutStandardByString

SaveCalSets

ICalibrator

Writes new or changed Cal Sets to disk.

Shared with the CalManager Object

setCalInfo

ICalibrator

Specifies the type of calibration and prepares the internal state for the rest of the calibration.

Properties

Interface

Description

AcquisitionDirection

ICalibrator

Specifies the direction in a 2-Port cal using one set of standards.

ECALCharacterization

ICalibrator2

Obsolete - use ECALCharacterizationEx

ECALCharacterizationEx

ICalibrator4

Specifies which set of characterization data within an ECal module will be used for ECal operations with that module.

ECALCharacterizationIndexList

ICalibrator6

Returns a list of characterizations stored in the specified ECal module.

ECAL Isolation

ICalibrator

Obsolete - No replacement

ECALModuleNumberList

ICalibrator6

Returns a list of index numbers to be used for referring to the ECal modules that are currently attached to the PNA.

ECALPortMap

ICalibrator3

Obsolete - use ECALPortMapEx

ECALPortMapEx

ICalibrator4

Specifies which ports of the ECal module are connected to which ports of the PNA.

IsECALModuleFound

ICalibrator

Obsolete - use IsECALModuleFoundEx

IsECALModuleFoundEx

ICalibrator4

Obsolete - use ECALModuleNumberList and ECALCharacterizationIndexList

OrientECALModule

ICalibrator3

Specifies if the PNA should perform orientation of the ECal module during calibration.

Simultaneous2PortAcquisition

ICalibrator

Allows the use of 2 sets of standards at the same time.

ICalibrator History

Interface | Introduced with PNA Rev:
ICalibrator | 1.0
ICalibrator2 | 3.1
ICalibrator3 | 3.1
ICalibrator4 | 3.5
ICalibrator6 | 4.87

ICalData Interface

Description

Contains methods for putting Calibration data in and getting Calibration data out of the analyzer using typed data. This interface transfers data more efficiently than variant data.

There is also an ICalData Interface on the CalSet Object

Learn about reading and writing Calibration data.

Methods

Description

getErrorTermComplex

Retrieves error term data

getStandardComplex

Retrieves calibration data from the acquisition data buffer (before error-terms are applied).

putErrorTermComplex

Puts error term data

putStandardComplex

Puts calibration data into the acquisition data buffer (before error-terms are applied).

Properties

Description

None

ICalData History

Interface | Introduced with PNA Rev:
ICalData | 1.0


CalKit Object

Description

The calkit object provides the properties and methods to access and modify a calibration kit. The calkitType property can be set from two objects:

  • Application object - app.calKitType

  • CalKit object - calKit.calKitType

Both of these commands specify or read the calibration kit type. When specified, the cal kit also becomes the Active cal kit.

Accessing a CalKit object

To get a handle to a cal kit, use app.ActiveCalKit.

The calKit object behaves differently from other objects in the system in that you can only have a handle to one cal kit -- the active calkit. Therefore, when you change the calkitType from either the Application object or the CalKit object, you may also be changing the object to which you may have other references.

For example, the following example specifies two calKit type objects and in turn, assigns them to two different variables: ck1 and ck2.

Dim app As AgilentPNA835x.Application
Dim ck1 As calKit
Dim ck2 As calKit

Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)
app.CalKitType = naCalKit_User1
Set ck1 = app.ActiveCalKit
ck1.Name = "My CalKit1"

app.CalKitType = naCalKit_User2
Set ck2 = app.ActiveCalKit
ck2.Name = "My CalKit2"

Print "ck1: " & ck1.Name
Print "ck2: " & ck2.Name

When the pointer to each of these kits is read (printed), they each have a pointer to the last kit to be assigned to the Active cal kit:

ck1: My CalKit2
ck2: My CalKit2

See Also:

PNA Automation Interfaces

The PNA Object Model

(Bold Methods or Properties provide access to a child object)

Methods

Description

getCalStandard

Returns a handle to a calibration standard for modifying its definitions.

GetStandardsForClass

Returns the calibration standard numbers for a specified calibration class.

SetStandardsForClass

Sets the calibration standard numbers for a specified calibration class

Properties

Description

CalKitType

Sets or returns the calibration kit type for to be used for calibration or for kit modification.

Shared with the Application object.

Name

Sets and returns the name of the cal kit

PortLabel

Labels the ports for the kit; only affects the cal wizard annotation.

StandardForClass

Obsolete Use GetStandardForClass and SetStandardForClass.

Maps a standard device to a cal class.

ICalKit History

Interface | Introduced with PNA Rev:
ICalKit | 1.0


CalManager Object

Description

Use this interface to list, save, and delete Cal Sets.

Accessing the CalManager object

Get a handle to a the CalManager with the app.GetCalManager Method.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim mgr as ICalManager
Set mgr = app.GetCalManager

See Also:

PNA Automation Interfaces

The PNA Object Model

(Bold Methods or Properties provide access to a child object)

Methods

Interface

See History

Description

CreateCalSet

ICalManager

Creates a new Cal Set

CreateCustomCal

ICalManager2

Creates a custom cal object.

DeleteCalSet

ICalManager

Deletes a Cal Set

GetCalSetByGUID

ICalManager

Get a handle to a Cal Set

GetCalSetCatalog

ICalManager

Gets a list of Cal Sets

GetCalSetUsageInfo

ICalManager

Returns the Cal Set ID and Error Term ID currently in use

GetCalTypes

ICalManager2

Query for a list of available calibration types.

GetRequiredEtermNames

ICalManager2

Returns an array of strings specifying the error terms

required by the Cal Type correction algorithm.

SaveCalSets

ICalManager

Writes new or changed Cal Sets to disk

Shared with the Calibrator Object

Properties

Cal Sets

ICalManager

Collection for iterating through all the Cal Sets in the analyzer.

GuidedCalibration

ICalManager4

Used to perform a Guided Calibration.

ICalManager History

Interface | Introduced with PNA Rev:
ICalManager | 2.0
CalManager2 | 3.1
CalManager3 | 3.5
CalManager4 | 5.0


CalSet Object

See ICalData Interface for putting and getting typed Cal Set data.

Description

Use this interface to query and or change the contents of a Cal Set.

Accessing the CalSet object

Get a handle to a CalSet object by using the CalSets collection. This is done through the CalManager object with the app.GetCalManager Method.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim calst As ICalSet
Set calst = app.GetCalManager.CalSets.Item(1)

See Also:

PNA Automation Interfaces

The PNA Object Model

Reading and Writing Calibration data.

Methods

Interface

See History

Description

CloseCalSet

ICalSet

Obsolete - No longer necessary.

ComputeErrorTerms

ICalSet

Computes error terms for the CalType specified by a preceding OpenCal Set call.

Copy

ICalSet

Creates a new Cal Set and copies the current Cal Set data into it.

getErrorTerm

ICalSet

Obsolete - Use getErrorTermByString

getErrorTermByString

ICalSet2

Returns variant error term data by specifying the string name of the error term.

getErrorTermList

ICalSet

Obsolete - Use getErrorTermList2

getErrorTermList2

ICalSet2

Returns a list of error term names found in a calset.

GetGUID

ICalSet

Returns the GUID identifying a Cal Set

getStandard

ICalSet

Obsolete - Use getStandardByString

getStandardByString

ICalSet2

Returns variant standard acquisition data by specifying the string name of the standard.

getStandardsList

ICalSet

Obsolete - Use getStandardList2

getStandardList2

ICalSet2

Returns a list of standard names found in a Cal Set.

HasCalType

ICalSet

Verifies that the Cal Set object contains the error terms required to apply the specified CalType to an appropriate measurement.

OpenCalSet

ICalSet

Obsolete - No longer necessary.

putErrorTerm

ICalSet

Obsolete - Use putErrorTermByString

putErrorTermByString

ICalSet2

Writes variant error term data by specifying the string name of the error term.

putStandard

ICalSet

Obsolete - Use putStandardByString

putStandardByString

ICalSet2

Writes variant standard acquisition data by specifying the string name of the standard.

Save

ICalSet

Saves the current Cal Set to disk.

StringToNACalClass

ICalSet

Converts string values from GetStandardsList into enumeration data

StringToNAErrorTerm2

ICalSet

Converts string values from GetErrorTermList into enumeration data

Properties

Description

AlternateSweep

ICalSet3

Reads sweep either alternate or chopped.

Attenuator

ICalSet3

Returns the value of the attenuator control for the specified port number.

AttenuatorMode

ICalSet3

Returns the mode of operation (auto or manual) of the attenuator control for the specified port number.

CouplePorts

ICalSet3

Returns state of couple ports (ON or OFF)

CWFrequency

ICalSet3

Returns CW Frequency

Description

ICalSet

Set or return the descriptive string assigned to the Cal Set

DwellTime

ICalSet3

Returns the dwell time for the channel.

FrequencyOffsetCWOverride

ICalSet3

Reads state of CW Override (ON or OFF)

FrequencyOffsetDivisor

ICalSet3

Reads Frequency Offset Divisor value

FrequencyOffsetFrequency

ICalSet3

Reads Offset Frequency

FrequencyOffsetMultiplier

ICalSet3

Reads Frequency Offset Multiplier value

FrequencyOffsetState

ICalSet3

Reads Frequency Offset state (ON or OFF)

IFBandwidth

ICalSet3

Reads IF Bandwidth of the channel

LastModified

ICalSet3

Reads the time stamp of when the file was last modified

NumberOfPoints

ICalSet3

Returns the Number of Points of the channel.

PowerSlope

ICalSet3

Returns the Power Slope value.

ReceiverAttenuator

ICalSet3

Returns the value of the specified receiver attenuator control.

StartFrequency

ICalSet3

Returns the start frequency of the channel.

StartPower

ICalSet3

Returns the start power of the PNA when sweep type is set to Power Sweep.

StimulusValues

ICalSet3

Returns x-axis values for stimulus or response frequencies

StopFrequency

ICalSet3

Returns the stop frequency of the channel.

StopPower

ICalSet3

Returns the stop power of the PNA when sweep type is set to Power Sweep.

SweepGenerationMode

ICalSet3

Returns the method being used to generate a sweep: analog or stepped.

SweepTime

ICalSet3

Returns the sweep time of the analyzer.

SweepType

ICalSet3

Returns the type of X-axis sweep that is performed on a channel.

TestPortPower

ICalSet3

Returns the RF power level for the channel.

ICalSet History

Interface | Introduced with PNA Rev:
ICalSet | 2.0
ICalSet2 | 3.0
ICalSet3 | 3.2

ICalData Interface

Description

Use this interface as an alternative to the ICalSet Interface to avoid using variants when transmitting data to and from the Cal Set

Learn about reading and writing Calibration data.

Methods

Interface

See History

Description

get ErrorTermComplex

ICalData2

Obsolete - Use getErrorTermComplexByString

getErrorTermComplexByString

ICalData3

Returns typed error term data by specifying the string name of the error term.

getStandardComplex

ICalData2

Obsolete - Use getStandardComplexByString

getStandardComplexByString

ICalData3

Returns typed standard acquisition data by specifying the string name of the standard.

putErrorTermComplex

ICalData2

Obsolete - Use putErrorTermComplexByString

putErrorTermComplexByString

ICalData3

Writes typed error term data by specifying the string name of the error term.

putStandardComplex

ICalData2

Obsolete - Use putStandardComplexByString

putStandardComplexByString

ICalData3

Writes typed standard acquisition data by specifying the string name of the standard.

Properties

Description

None

History

Interface | Introduced with PNA Rev:
The original ICalData Interface was introduced with PNA 1.0 on the Calibrator Object.
ICalData2 | 2.0
ICalData3 | 3.1


Cal Sets Collection

Description

A collection object that provides a mechanism for iterating through all the Cal Sets in the analyzer. There is no ordering to the items in the collection. Therefore make no assumptions about the formatting of the collection.

Accessing the CalSets collection

Get a handle to the CalSets collection through the CalManager object with the app.GetCalManager Method.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim calsts As CalSets
Set calsts = app.GetCalManager.CalSets

See Also:

Collections in the Analyzer

The PNA Object Model

Methods

Description

Item

Returns a handle to a Cal Set object in the collection.

Remove

Deletes the Cal Set residing at position index in the collection.

Properties

Description

Count

Returns the number of Cal Sets in the collection.


CalStandard Object

Description

Contains all of the settings that are required to modify a calibration kit.

Accessing the CalStandard object

Get a handle to a standard with the calkit.GetCalStandard Method.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim std As ICalStandard
Set std = app.ActiveCalKit.GetCalStandard(1)
std.Delay = 0.00000003

See Also:

PNA Automation Interfaces

The PNA Object Model

Reading and Writing Calibration data.

Method

None

Property

Interface

See History

Description

C0

ICalStandard

Sets and Returns the C0 (C-zero) value (the first capacitance value) for the calibration standard, when the Type is set to "naOpen".

C1

ICalStandard

Sets and Returns the C1 value (the second capacitance value) for the calibration standard, when the Type is set to "naOpen".

C2

ICalStandard

Sets and Returns the C2 value (the third capacitance value) for the calibration standard, when the Type is set to "naOpen".

C3

ICalStandard

Sets and Returns the C3 value (the fourth capacitance value) for the calibration standard, when the Type is set to "naOpen".

Delay

ICalStandard

Sets and Returns the electrical delay value for the calibration standard.

L0

ICalStandard

Sets and Returns the L0 (L-zero) value (the first inductance value) for the calibration standard, when the Type is set to "naShort".

L1

ICalStandard

Sets and Returns the L1 value (the second inductance value) for the calibration standard, when the Type is set to "naShort"..

L2

ICalStandard

Sets and Returns the L2 value (the third inductance value) for the calibration standard, when the Type is set to "naShort"..

L3

ICalStandard

Sets and Returns the L3 value (the third inductance value) for the calibration standard, when the Type is set to "naShort"..

Label

ICalStandard

Sets and Returns the label for the calibration standard.

loss

ICalStandard

Sets and Returns the insertion loss for the calibration standard.

Maximum
Frequency

ICalStandard

Sets and Returns the maximum frequency for the calibration standard.

Medium

ICalStandard

Sets and Returns the media type of the calibration standard.

Minimum
Frequency

ICalStandard

Sets and Returns the minumum frequency for the calibration standard.

Type

ICalStandard

Sets and Returns the type of calibration standard. Selections are: naOpen, naShort, naLoad, naThru, naArbitraryImpedance and naSliding.

TZReal

ICalStandard2

Sets and Returns the TZReal value (the Real Terminal Impedance value) for the calibration standard, when the Type is set to "naArbitraryImpedance".

TZImag

ICalStandard2

Sets and Returns the TZImag value (the Imaginary Terminal Impedance value) for the calibration standard, when the Type is set to "naArbitraryImpedance".

Z0

ICalStandard

Sets and Returns the characteristic impedance for the calibration standard.

ICalStandard History

Interface | Introduced with PNA Rev:
CalStandard | 1.0
CalStandard2 | 3.0


Capabilities Object

Description

These properties return capabilities of the remote PNA.

Accessing the Capabilities object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim cap As Capabilities
Set cap = app.Capabilities

See Also:

PNA Automation Interfaces

The PNA Object Model

ICapabilities History

Method

None

Property

Description

FirmwareMajorRevision

Returns integer portion of firmware revision number.

FirmwareMinorRevision

Return decimal portion of firmware revision number.

FirmwareSeries

Returns the Alpha portion of the firmware revision number.

InternalTestsetPortCount

Returns the number of test ports (2 or 3).

IsFrequencyOffsetPresent

Returns the presence of Frequency Offset Option 080 (True or False).

IsReceiverStepAttenuatorPresent

Returns the presence of receiver step attenuators (True or False).

IsReferenceBypassSwitchPresent

Returns the presence of the reference switch (True or False).

MaximumFrequency

Returns the maximum frequency of the PNA.

MaximumNumberOfPoints

Returns the maximum possible number of data points.

MaximumReceiverStepAttenuator

Returns the maximum amount of receiver attenuation.

MaximumSourceALCPower

Returns the maximum amount of source ALC power.

MaximumSourceStepAttenuator

Returns the maximum amount of source attenuation.

MinimumFrequency

Returns the minimum frequency of the PNA.

MinimumNumberOfPoints

Returns the minimum possible number of data points.

MinimumReceiverStepAttenuator

Returns the minimum amount of receiver attenuation.

MinimumSourceALCPower

Returns the minimum amount of source ALC power.

ReceiverCount

Returns the number of receivers in the PNA.

ReceiverStepAttenuatorStepSize

Returns the step size of the attenuator.

SourceCount

Returns the number of sources.

ICapabilities History

I Interface | Introduced with PNA Rev:
ICapabilities | 3.5


Channel Object

See SourcePowerCalData Interface for putting and getting typed source power calibration data.

Description

The channel object is like the engine that produces data. Channel settings consist of stimulus values like frequency, power, IF bandwidth, and number of points.

Accessing the Channel object

You can get a handle to a channel in a number of ways. But first you have to make sure that the channel exists. When you first startup the analyzer, there is one S11 measurement on channel 1. Thus there is only one channel in existence. You can do the following:

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim chan As IChannel
Set chan = app.ActiveChannel

or

Set chan = app.Channels(2)

The first method returns the channel object that is driving the active measurement. If there is no measurement, there may not be a channel. Once a channel is created, it does not go away. So if there once was a measurement (hence a channel), the channel will still be available.

If there is no channel you can create one in a couple ways. You can do the following:

Pna.CreateMeasurement( ch1, "S11", port1, window2)

or

Pna.Channels.Add(2)

The latter will have no visible effect on the analyzer. It will simply create channel 2 if it does not already exist.

See Also:

PNA Automation Interfaces

The PNA Object Model

Reading and Writing Calibration data.

(Bold Methods or Properties provide access to a child object)

Methods

Interface

See History

Description

Abort

IChannel

Aborts the current measurement sweep on the channel.

AveragingRestart

IChannel

Clears and restarts averaging of the measurement data.

Continuous

IChannel

The channel continuously responds to trigger signals.

CopyToChannel

IChannel

Sets up another channel as a copy of this object’s channel.

GetNumberOfGroups

IChannel3

Returns the number of groups a channel has yet to acquire.

getSourcePowerCalData

IChannel

OBSOLETE - use Get SourcePowerCalDataEx Method

getSourcePowerCalDataEx

IChannel4

Returns requested source power calibration data, if it exists.

GetXAxisValues

IChannel

Returns the channel's X-axis values into a dimensioned Variant array.

GetXAxisValues2

IChannel

Returns the channel's X-axis values into a dimensioned NON-Variant array.

Hold

IChannel

Puts the Channel in Hold - not sweeping.

Next_IFBandwidth

IChannel

A function that returns the Next higher IF Bandwidth value.

NumberOfGroups

IChannel

Sets the Number of trigger signals the channel will receive.

Preset

IChannel

Resets the channel to factory defined settings.

PreviousIFBandwidth

IChannel

Returns the previous IF Bandwidth value.

putSourcePowerCalData

IChannel

OBSOLETE - use Put SourcePowerCalDataEx Method

putSourcePowerCalDataEx

IChannel4

Inputs source power calibration data to this channel for a specific source port.

SelectCal Set

IChannel

Specifies the Cal Set to use for the Channel

Single

IChannel

Channel responds to one trigger signal from any source (internal, external, or manual). Then channel switches to Hold.

Properties

Interface

Description

AlternateSweep

IChannel

Sets sweeps to either alternate or chopped.

Attenuator

IChannel

Sets or returns the value of the attenuator control for the specified port number.

AttenuatorMode

IChannel

Sets or returns the mode of operation of the attenuator control for the specified port number.

Averaging

IChannel

Turns trace averaging ON or OFF for all measurements on the channel.

AveragingCount

IChannel

Returns the number of sweeps that have been averaged into the measurements.

AveragingFactor

IChannel

Specifies the number of measurement sweeps to combine for an average.

BalancedTopology

IChannel6

Sets and returns the topology of a balanced DUT.

Calibrator

IChannel4

Used to perform an Unguided calibration.

CalSet

IChannel

centerFrequency

IChannel

Sets or returns the center frequency of the channel.

Shared with the Segment Object

channelNumber

IChannel

Returns the Channel number.

Shared with the Measurement Object

CoupleChannelParams

IChannel5

Turns ON and OFF Time Domain Trace Coupling.

CouplePorts

IChannel

Turns ON and OFF port power coupling.

CWFrequency

IChannel

Set the Continuous Wave (CW) frequency.

DwellTime

IChannel

Sets or returns the dwell time for the channel.

Shared with the Segment Object

ExternalTriggerDelay

IChannel6

Sets or returns the external trigger delay value for the channel.

Fixturing

IChannel6

Port Ext, Embedding, and De-embedding functions.

FrequencyOffsetDivisor

IChannel2

Part of formula used to determine offset frequency of receivers.

FrequencyOffsetFrequency

IChannel2

Part of formula used to determine offset frequency of receivers.

FrequencyOffsetMultiplier

IChannel2

Part of formula used to determine offset frequency of receivers.

FrequencyOffsetCWOverride

IChannel2

Establishes a fixed (CW) stimulus frequency while measuring swept response frequency range.

FrequencyOffsetState

IChannel2

Turns frequency Offset ON and OFF.

FrequencySpan

IChannel

Sets or returns the frequency span of the channel.

Shared with the Segment Object.

IFBandwidth

IChannel

Sets or returns the IF Bandwidth of the channel.

Shared with the Segment Object.

IFConfiguration

IChannel4

Control the IF gain and source path settings for the H11 Option.

IsContinuous

IChannel3

Returns whether or not a channel is in continuous mode.

IsHold

IChannel3

Returns whether or not a channel is in hold mode.

NumberOfPoints

IChannel

Sets or returns the Number of Points of the channel.

Shared with the Segment Object.

Parent

IChannel

Returns a handle to the parent object of the channel.

PowerSlope

IChannel

Sets or returns the Power Slope value.

R1InputPath

IChannel2

Throws internal reference switch (option 081).

ReceiverAttenuator

IChannel

Sets or returns the value of the specified receiver attenuator control.

ReduceIFBandwidth

IChannel

Sets or returns the state of the Reduced IF Bandwidth at Low Frequencies setting.

Segments

IChannel

Collection for iterating through the sweep segments of a channel.

SourcePowerCalPowerOffset

IChannel4

Sets or returns a power level offset from the PNA test port power.

SourcePowerCorrection

IChannel

Turns source power correction ON or OFF for a specific source port.

StartFrequency

IChannel

Sets or returns the start frequency of the channel.

Shared with the Segment Object

StartPower

IChannel

Sets the start power of the analyzer when sweep type is set to Power Sweep.

StopFrequency

IChannel

Sets or returns the stop frequency of the channel.

Shared with the Segment Object

StopPower

IChannel

Sets the Stop Power of the analyzer when sweep type is set to Power Sweep.

SweepGenerationMode

IChannel

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

SweepTime

IChannel

Sets the Sweep time of the analyzer.

SweepType

IChannel

Sets the type of X-axis sweep that is performed on a channel.

TestPortPower

IChannel

Sets or returns the RF power level for the channel.

Shared with the Segment Object

TriggerMode

IChannel

Determines the measurement that occurs when a trigger signal is sent to the channel.

UserRangeMax

IChannel

Sets the stimulus stop value for the specified User Range.

UserRangeMin

IChannel

Sets the stimulus start value for the specified User Range.

XAxisPointSpacing

IChannel

Sets X-Axis point spacing for the active channel.

IChannel History

Interface | Introduced with PNA Rev:
IChannel | 1.0
IChannel2 | 3.0
IChannel3 | 4.0
IChannel4 | 4.0
IChannel5 | 4.2
IChannel6 | 5.0
IChannel7 | 5.2

ISourcePowerCalData Interface

Description

Contains methods for putting source power calibration data in and getting source power calibration data out of the analyzer using typed data. The methods in this interface transfer data more efficiently than methods that use variant data.

Note: Interface ISourcePowerCalData is abbreviated as ISPCD in the following table.

Methods

Interface

See History

Description

getSourcePowerCalDataScalar

ISPCD

OBSOLETE - use PutSourcePowerCalDataScalarEx Method

getSourcePowerCalDataScalarEx

ISPCD2

Returns requested source power calibration data, if it exists.

putSourcePowerCalDataScalar

ISPCD

OBSOLETE - use PutSourcePowerCalDataEx Method

putSourcePowerCalDataScalarEx

ISPCD2

Inputs source power calibration data to a channel, for a specific source port.

Properties

Description

None

ISourcePowerCalData History

Interface | Introduced with PNA Rev:
ISourcePowerCalData | 2.0
ISourcePowerCalData2 | 4.0


Channels Collection

Description

A collection object that provides a mechanism for iterating through the channels

Collections are, by definition, unordered lists of like objects. You cannot assume that Channels.Item(1) is always Channel 1.

Accessing the Channels collection

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim chans As Channels
Set chans = app.Channels

See Also:

Collections in the Analyzer

The PNA Object Model

Methods

Interface

Description

Add

IChannels

An alternate way to create a measurement.

Hold

IChannels

Places all channels in Hold trigger mode.

Item

IChannels2

Use to get a handle on a channel in the collection.

Resume

IChannels2

Resumes the trigger mode of all channels that was in effect before sending the channels.Hold method.

Properties

Description

Count

IChannels

Returns the number of channels in the analyzer.

Parent

IChannels

Returns a handle to the current Application.

UnusedChannelNumbers

IChannels2

Returns an array of channel numbers that are NOT in use.

UsedChannelNumbers

IChannels2

Returns an array of channel numbers that are in use.


Gating Object

Description

Contains the methods and properties that control Time Domain Gating.

Accessing the Gating Object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim gate As Gating
Set gate = app.ActiveMeasurement.Gating

See Also:

PNA Automation Interfaces

The PNA Object Model

Time Domain Topics

Methods

None

Property

Interface

(see History)

Description

Center

IGating

Sets or returns the Center time.

Shared with the Transform Object

CoupledParameters

IGating2

Select Gating parameters to couple

Shape

IGating

Specifies the shape of the gate filter.

Span

IGating

Sets or returns the Span time.

Shared with the Transform Object

Start

IGating

Sets or returns the Start time.

Shared with the Transform Object

State

IGating

Turns an Object ON and OFF.

Stop

IGating

Sets or returns the Stop time.

Shared with the Transform Object

Type

IGating

Specifies the type of gate filter used.

History

Interface | Introduced with PNA Rev:
IGating | 1.0
IGating2 | 4.2


HWAuxIO Object

Description

Contains the methods and properties that control the rear panel Auxiliary Input / Output connector.

Accessing the HWAuxIO object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim AuxIO As HWAuxIO
Set AuxIO = app.GetAuxIO

See Also:

Pinout of the Aux IO Connector

PNA Automation Interfaces

The PNA Object Model

Method

Interface

See History

Description

get_InputVoltage

IHWAuxIO

Reads the ADC input voltage

get_OutputVoltage

IHWAuxIO

Reads voltages on the DAC/Analog Output 1 and Output 2

get_OutputVoltageMode

IHWAuxIO2

Reads mode setting for either DAC output.

get_PortCData

IHWAuxIO

Reads a 4-bit value from Port C

put_OutputVoltage

IHWAuxIO

Writes voltages to the DAC/Analog Output 1 and Output 2

put_OutputVoltageMode

IHWAuxIO2

Writes mode setting for either DAC output.

put_PortCData

IHWAuxIO

Writes a 4-bit value to Port C

Property

Description

FootSwitch

IHWAuxIO

Reads the Footswitch Input

FootswitchMode

IHWAuxIO3

Determines the action that occurs when the footswitch is pressed.

PassFailLogic

IHWAuxIO

Sets and reads the logic of the PassFail line

Shared with the HWMaterialHandler Object

PassFailMode

IHWAuxIO

Sets and reads the mode of the PassFail line

Shared with the HWMaterialHandler Object

PassFailPolicy

IHWAuxIO4

Sets the policy used to determine how global pass/fail is computed.

Shared with the HWMaterialHandler Object

PassFailScope

IHWAuxIO

Sets and reads the scope of the PassFail line

Shared with the HWMaterialHandler Object

PassFailStatus

IHWAuxIO4

Returns the most recent pass/fail status value.

Shared with the HWMaterialHandler Object

PortCLogic

HWAuxIO

Sets and reads the logic mode of Port C

PortCMode

HWAuxIO

Sets and reads the mode of Port C

SweepEndMode

HWAuxIO

Sets and reads the event that causes the Sweep End line to go to a false state.

Shared with the HWMaterialHandler Object

IHWAuxIO History

Interface | Introduced with PNA Rev:
IHWAuxIO | 2.0
IHWAuxIO2 | 3.0
IHWAuxIO3 | 3.0
IHWAuxIO4 | 5.0


HWExternalTestSetIO Object

Description

Contains the methods and properties that control the rear panel External Test Set Input / Output connector

Accessing the HWExternalTestSetIO object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim ExtTS As HWExternalTestSetIO
Set ExtTS = app.GetExternalTestSetIO

See Also:

Pinout of the Aux IO Connector

Pinout for the External Test Set Connector

PNA Automation Interfaces

The PNA Object Model

Method

Description

ReadData

Reads data and generates the appropriate timing signals

ReadRaw

Reads data, but does NOT generate appropriate timing signals

WriteData

Writes data and generates the appropriate timing signals

WriteRaw

Writes data, but does NOT generate the appropriate timing signals

Property

Description

Interrupt

Returns the state of the Interrupt line

SweepHoldOff

Returns the state of the Sweep Holdoff line

IHWExternalTestSetIO History

Interface | Introduced with PNA Rev:
HWExternalTestSetIO | 2.0


HWMaterialHandlerIO Object

Description

Contains the methods and properties that control the rear panel Material Handler Input / Output connector.

Accessing the HWMaterialHandlerIO object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim MatHdlr As HWMaterialHandlerIO
Set MatHdlr = app.GetMaterialHandlerIO

See Also:

Pinout for the Material HandlerIO Connector

PNA Automation Interfaces

The PNA Object Model

Method

Interface

Description

get_Input1

HWMaterialHandlerIO

Reads a hardware latch that captures low to high transition on Input1

get_Output

HWMaterialHandlerIO

Returns the last value written to the selected output pin.

get_Port

HWMaterialHandlerIO

Returns the value from the specified "readable" port.

put_Output

HWMaterialHandlerIO

Writes a TTL HI or TTL Low to output pins 3 or 4.

put_Port

HWMaterialHandlerIO

Writes a value to the specified port.

Property

Description

IndexState

HWMaterialHandlerIO2

Determines the control of Material Handler connector Pin 20

ReadyForTriggerState

HWMaterialHandlerIO2

Determines the control of Material Handler connector Pin 21

PassFailLogic

HWMaterialHandlerIO

Sets and reads the logic of the PassFail line

Shared with the HWAuxIO Object

PassFailMode

HWMaterialHandlerIO

Sets and reads the mode for the PassFail line

Shared with the HWAuxIO Object

PassFailPolicy

HWMaterialHandlerIO2

Sets the policy used to determine how global pass/fail is computed.

Shared with the HWAuxIO Object

PassFailScope

HWMaterialHandlerIO

Sets and reads the scope for the PassFail line

Shared with the HWAuxIO Object

PassFailStatus

HWMaterialHandlerIO2

Returns the most recent pass/fail status value.

Shared with the HWAuxIO Object

PortLogic

HWMaterialHandlerIO

Sets and returns the logic mode of data ports A-H

PortMode

HWMaterialHandlerIO

Sets and returns whether Port C or Port D is used for writing or reading data

SweepEndMode

HWMaterialHandlerIO

Sets and reads the event that cause the Sweep End line to go to a low state.

Shared with the HWAuxIO Object

HWMaterialHandlerIO History

Interface | Introduced with PNA Rev:
HWMaterialHandlerIO | 2.0
HWMaterialHandlerIO2 | 5.0


IIFConfiguration Object

IFConfiguration Object

Description

These properties control the IF gain and source path settings for the H11 Option.

Accessing the IFConfiguration object

Dim app as AgilentPNA835x.Application
Dim chan as Channel
Set chan = app.ActiveChannel
Dim cfg as IIFConfiguration
Set cfg = chan.IFConfiguration

See Also:

PNA Automation Interfaces

The PNA Object Model

About the H11 Option

Pulsed Application

ConfigNarrowBand2 Method

Pulsed Measurement Example

Method

Description

None

Property

Interface

See History

Description

IFFilterSampleCount

IFConfiguration2

Sets or returns the number of taps in the IF filter.

IFFilterSamplePeriod

IFConfiguration2

Sets or returns the IF filter sample period time.

IFFilterSamplePeriodList

IFConfiguration2

Returns the list of available IF filter sample periods for the instrument.

IFFilterSamplePeriodMode

IFConfiguration2

Sets or returns the IF filter sample period mode.(Auto or Manual).

IFFilterSource Property

IFConfiguration2

Sets or retrieves type of IF filter to be used.

IFGainLevel Property

IFConfiguration

Sets the gain level for the specified receiver.

IFGainMode Property

IFConfiguration

Sets the gain state for ALL receivers.

IFGateEnable Property

IFConfiguration2

Sets or retrieves the state of the IF Gate.

IFSourcePath Property

IFConfiguration

Sets the source path of the specified receiver to Internal or External.

MaximumIFFilterSampleCount

IFConfiguration2

Returns the maximum allowed value for the IFFilterSampleCount.

MinimumIFFilterSampleCount

IFConfiguration2

Returns the minimum allowed value for the IFFilterSampleCount.

IFConfiguration History

Interface | Introduced with PNA Rev:
IIFConfiguration | 4.0
IIFConfiguration2 | 4.0


IMixer Interface

IMixer Interface (Option 083)

Description

Contains the methods and properties to setup Mixer measurements. For performing calibrations, use either the SMC Type Object or the VMC Type Object.

Accessing the IMixer Interface

Access the IMixer Interface through the Measurement Object. If the particular type of Measurement that was created supports IMixer, then the program determines this at run time and can access the functionality exposed by IMixer. Because the determination of IMixer support is not made until runtime, the program should handle the case where IMixer is not supported on the object.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", "analyzerName")
app.Preset

' FCA Measurements can't share the channel with standard measurements
' Because preset creates a single measurement in channel 1, we first delete the standard measurement
Dim standardMeas As IMeasurement
Set standardMeas = app.ActiveMeasurement
standardMeas.Delete

' Create a Measurement object, in this case using the IMeasurement interface
Dim meas As IMeasurement
Set meas = app.CreateCustomMeasurementEx(1, "SMC_Forward.SMC_ForwardMeas", "SC21")

' See if this measurement object supports IMixer
Dim mixer As IMixer

See an example program that shows how to create and calibrate a standard SMC or VMC measurement or a fixed output SMC measurement.

See Also:

PNA Automation Interfaces

The PNA Object Model

Methods

Interface

See History

Description

Apply

IMixer3

Applies mixer settings.

Calculate

IMixer

Automatically calculate Input and Output frequencies for mixer setup.

LoadFile

IMixer

Loads a previously-configured mixer attributes file (.mxr)

SaveFile

IMixer

Saves the settings for the mixer/converter test setup to a mixer attributes file.

Properties

Description

ActiveXAxisRange

IMixer3

Sets or returns the swept parameter to display on the X-axis.

AvoidSpurs

IMixer

Sets and returns the state of the avoid spurs feature.

IFDenominator

IMixer

Sets or returns the denominator value of the IF Fractional Multiplier.

IFNumerator

IMixer

Sets or returns the numerator value of the IF Fractional Multiplier.

IFSideband

IMixer

Sets or returns the value of the IF sideband.

IFStartFrequency

IMixer

Returns the start frequency of the mixer IF.

IFStopFrequency

IMixer

Returns the stop frequency of the mixer IF.

InputDenominator

IMixer

Sets or returns the denominator value of the Input Fractional Multiplier.

InputNumerator

IMixer

Sets or returns the numerator value of the Input Fractional Multiplier.

InputPower

IMixer

Sets or returns the value of the Input Power.

InputStartFrequency

IMixer

Sets or returns the start frequency of the mixer input.

InputStopFrequency

IMixer

Sets or returns the stop frequency of the mixer input.

IsInputGreaterThanLO

IMixer2

Specifies whether to use the Input frequency that is greater than the LO or less than the LO.

LODenominator

IMixer

Sets or returns the denominator value of the LO Fractional Multiplier.

LOFixedFrequency

IMixer

Sets or returns the fixed frequency of the specified LO.

LOName

IMixer

Sets or returns the LO name.

LONumerator

IMixer

Sets or returns the numerator value of the LO Fractional Multiplier.

LOPower

IMixer

Sets or returns the value of the LO Power.

LORangeMode

IMixer3

Sets or returns the LO sweep mode to fixed or swept.

LOStage

IMixer

Returns the number of stages.

LOStartFrequency

IMixer3

Sets or returns the start frequency of the specified LO.

LOStopFrequency

IMixer3

Sets or returns the start frequency of the specified LO.

NominalIncidentPowerState

IMixer4

Toggles Nominal Incident Power ON and OFF.

OutputFixedFrequency

IMixer3

Sets or returns the fixed frequency of the mixer output.

OutputSideband

IMixer

Sets or returns the value of the output sideband.

OutputStartFrequency

IMixer

Sets or returns the start frequency of the mixer output.

OutputStopFrequency

IMixer

Sets or returns the stop frequency of the mixer output.

IMixer History

Interface | Introduced with PNA Rev:
IMixer | 1.0
IMixer2 | 3.5
IMixer3 | 4.0
IMixer4 | 4.8


Limit Test Collection

Description

Child of the Measurement Object. A collection that provides a mechanism for iterating through the Measurement's Limit Segment objects (Limit Lines). The collection has 100 limit lines by default.

Accessing the LimitTest collection

Get a handle to an individual limit segment by specifying an item of the LimitTest collection.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim limSegs As LimitTest
Set limSegs = app.ActiveMeasurement.LimitTest
limSegs.Item(1).BeginResponse = 1000000000#

See Also:

Collections in the Analyzer

The PNA Object Model

Limit Line Testing Example

Methods

Description

GetTestResult

Retrieves the Pass/Fail results of the Limit Test (State).

Item

Use to get a handle on a limit line in the collection.

Properties

Description

Count

Returns the number of limit lines used in the measurement.

LineDisplay

Displays the limit lines on the screen.

SoundOnFail

Enables a beep on Limit Test fails.

State

Turns ON and OFF limit testing.

LimitTest History

Interface | Introduced with PNA Rev:
ILimitTest | 1.0


LimitSegment Object

Description

The LimitSegment object is an individual limit line.

Accessing the LimitSegment object

Get a handle to an individual limit line by using the LimitTest collection.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim limSegs As LimitTest
Set limSegs = app.ActiveMeasurement.LimitTest
limSegs(1).BeginResponse = 1000000000#

See Also:

PNA Automation Interfaces

The PNA Object Model

Methods

Description

None

Properties

Description

BeginResponse

Specifies the Y-axis value that corresponds with Begin Stimulus (X-axis) value.

BeginStimulus

Specifies the beginning X-axis value of the Limit Line.

EndResponse

Specifies the Y-axis value that corresponds with End Stimulus (X-axis) value.

EndStimulus

Specifies the End X-axis value of the Limit Line.

Type

Specifies the Limit Line type.

LimitSegment History

Interface | Introduced with PNA Rev:
ILimitSegment | 1.0


Marker Object

Description

Contains the methods and properties that control Markers. There are 10 markers available per measurement:

  • 1 reference marker

  • 9 markers for absolute data or data relative to the reference marker (delta markers).

There are two ways to control markers through COM.

  1. The Measurement object has properties that apply to ALL of the markers for that measurement. For example, meas.MarkerFormat = naLinMag applies formatting to all markers.

  2. Marker object properties override the Measurement object properties. For example, you can then override the format setting for an individual marker by specifying mark.Format = naLogMag on the marker object.

Note: SearchFilterBandwidth is available through the measurement object.

Accessing the Marker object

To turn ON a marker, get a handle to the marker through the measurement object. If not already activated, this command will turn ON marker 1

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

app.ActiveMeasurement.marker(1).Format = naLinMag

You can also set the marker object to an object variable:

Dim m1 As Marker
Set m1 = app.ActiveMeasurement.Marker(1)
m1.Format = naMarkerFormat_LinMag

See Also:

PNA Automation Interfaces

The PNA Object Model

Methods

Interface

Description

Activate

IMarker

Makes an object the Active Object.

Shared with the Marker Object

SearchMax

IMarker

Searches the marker domain for the maximum value.

SearchMin

IMarker

Searches the marker domain for the minimum value.

SearchNextPeak

IMarker

Searches the marker's domain for the next largest peak value.

SearchPeakLeft

IMarker

Searches the marker's domain for the next VALID peak to the left of the marker.

SearchPeakRight

IMarker

Searches the marker's domain for the next VALID peak to the right of the marker.

SearchTarget

IMarker

Searches the marker's domain for the target value.

SearchTargetLeft

IMarker

Moving to the left of the marker position, searches the marker's domain for the target value.

SearchTargetRight

IMarker

Moving to the right of the marker position, searches the marker's domain for the target value.

SetCenter

IMarker

Changes the analyzer's center frequency to the X-axis position of the marker.

SetCW

IMarker

Changes the analyzer to sweep type CW mode and makes the CW frequency the marker's frequency.

SetElectricalDelay

IMarker

Changes the measurement's electrical delay to the marker's delay value.

SetReferenceLevel

IMarker

Changes the measurement's reference level to the marker's Y-axis value.

SetStart

IMarker

Changes the analyzer's start frequency to the X-axis position of the marker.

SetStop

IMarker

Changes the analyzer's stop frequency to the X-axis position of the marker.

Property

Description

Bucket Number

IMarker

Marker data point number

DeltaMarker

IMarker

Makes a marker relative to the reference marker

Distance

IMarker2

Sets or returns distance value for time domain trace.

Format

IMarker

Linear, SWR, and so forth

Interpolated

IMarker

Turn marker interpolation ON and OFF

Number

IMarker

Read the number of the active marker

PeakExcursion

IMarker

Sets and reads the peak excursion value for the specified marker.

PeakThreshold

IMarker

Sets peak threshold for the specified marker.

SearchFunction

IMarker

Emulates the Tracking function in the marker search dialog box.

Stimulus

IMarker

Sets and reads the X-Axis value of the marker.

Target Value

IMarker

Sets the target value for the marker when doing Target Searches.

Tracking

IMarker

The tracking function finds the selected search function every sweep.

Type

IMarker

Sets and reads the marker type.

UserRange

IMarker

Assigns the marker to the specified User Range.

UserRangeMax

IMarker

Sets the stimulus stop value for the specified User Range.

UserRangeMin

IMarker

Sets the stimulus start value for the specified User Range.

Value

IMarker

Reads the Y-Axis value of the marker.

Marker History

Interface | Introduced with PNA Rev:
IMarker | 1.0
IMarker2 | 4.2


Measurement Object

See IArrayTransfer Interface for putting and getting typed data.

See IMixer Interface (used with Option 083)

Description

The Measurement object is probably the most used object in the PNA Object Model. A measurement object represents the chain of data processing algorithms that take raw data from the channel and make it ready for display, which then becomes the scope of the Trace object.

A Measurement object is defined by it's parameter (S11, S22, A/R1, B and so forth). The measurement object is associated with a channel which drives the hardware that produces the data that feeds the measurement. The root of a measurement is the raw data. This buffer of complex paired data then flows through a number of processing blocks: error-correction, trace math, phase correction, time domain, gating, formatting. All of these are controlled through the measurement object.

The ACTIVE measurement is the measurement that will be acted upon if you make a setting from the front panel. It is the measurement whose "button" is pressed in the window with the red "active window" frame. If you create a new measurement, that measurement becomes the active measurement.

Therefore, all automation methods with the word "Active" in them refer to the object associated with the Active measurement, whether that object is a Channel, Window, Trace or Limit line.

Learn about the IMeasurement2 Interface for reading stimulus properties.

Accessing the Measurement object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim meas As IMeasurement
Set meas = app.ActiveMeasurement

or

Set meas = app.Measurements(n)

You can access four other objects through the Measurement object: markers, limit test, transform, and gating. For example, because each measurement has its own set of markers, you can set a marker by doing this:

Dim meas as measurement
Set meas = app.ActiveMeasurement
meas.marker(1).Stimulus = 900e6

IMeasurement2 Interface

Some of the properties and methods for the IMeasurement2 Interface return stimulus values that are set using the channel object. The following is the reason these properties and methods are duplicated.

Every measurement carries with it a snapshot of the stimulus properties of the channel that were in effect when the measurement last acquired data. Therefore, it is the measurement that provides the most accurate stimulus description of its data. Any change made to the channel after the measurement was acquired renders the IChannel interface unreliable in terms of describing the measurement.

See Also:

PNA Automation Interfaces

The PNA Object Model

(Bold Methods or Properties provide access to a child object)

Methods

Interface

Description

Activate

IMeasurement

Makes an object the Active Object.
Shared with the Marker Object

ActivateMarker

IMeasurement

Makes a marker the Active Marker.

ChangeParameter

IMeasurement

Changes the parameter of the measurement.

DataToDivisor

IMeasurement

Stores data for receiver power cal of unratioed measurements.

DataToMemory

IMeasurement

Stores the active measurement into memory.

Delete

IMeasurement

Deletes the measurement object.

DeleteAllMarkers

IMeasurement

Deletes all of the markers from the measurement.

DeleteMarker

IMeasurement

Deletes a marker from the active measurement.

getData

IMeasurement

Retrieves Complex data from analyzer memory

getDataByString

IMeasurement

Retrieves variant data from the specified location in your choice of formats.

GetFilterStatistics

IMeasurement

Returns all four Filter Statistics

GetReferenceMarker

IMeasurement

Returns a handle to the reference marker.

Get SnPData

IMeasurement3

Returns SnP data.

GetTraceStatistics

IMeasurement

Returns the Trace Statistics.

GetXAxisValues

IMeasurement2

Returns the stimulus values for the measurement.

InterpolateMarkers

IMeasurement

Turns All Marker Interpolation ON and OFF for the measurement.

putDataComplex

IMeasurement

Puts complex data into one of five data buffers.

putDataScalar

IMeasurement

Puts formatted variant data into the measurement results buffer.

SearchFilterBandwidth

IMeasurement

Searches the domain with the current BW target.

Properties

Interface

Description

ActiveMarker

IMeasurement

Returns a handle to the Active Marker object.

BalancedMeasurement

IMeasurement

Sets the measurement type that is used with balanced topologies.

BandwidthTarget

IMeasurement

The insertion loss value at which the bandwidth of a filter is measured.

BandwidthTracking

IMeasurement

Turns Bandwidth Tracking function ON and OFF.

CalibrationName

IMeasurement2

Returns the name of the current cal type.

CalibrationType

IMeasurement

Set or get the calibration type for the measurement.

CalibrationTypeID

IMeasurement2

Sets or returns the current cal type to the Cal Set ID (CLSID).

Center

IMeasurement2

Returns the stimulus value of the center point for the measurement.

channelNumber

IIMeasurement

Returns the channel number.
Shared with the Channel Object

Domain

IMeasurement2

Returns the domain (frequency, time, power) for the measurement.

ElectricalDelay

IMeasurement

Sets electrical delay.

ElecDelayMedium

IMeasurement2

Sets or returns the characteristic of the electrical delay medium.

ErrorCorrection

IMeasurement

Set or get the state of error correction for the measurement.

FilterBW

IMeasurement

Returns the results of the SearchBandwidth method.

FilterCF

IMeasurement

Returns the Center Frequency result of the SearchBandwidth method.

FilterLoss

IMeasurement

Returns the Loss value of the SearchBandwidth method.

FilterQ

IMeasurement

Returns the Q (quality factor) result of the SearchBandwidth method.

Format

IMeasurement

Sets display format.

Gating

IMeasurement

Controls Time Domain Gating.

InterpolateCorrection

IMeasurement

Turns ON and OFF the calculation of new error terms when stimulus values change.

InterpolateNormalization

IMeasurement

Turns ON and OFF normalization interpolation when stimulus values change after receiver power cal of unratioed measurements.

IsSparameter

IMeasurement2

Returns true if measurement represents an S-Parameter.

LimitTest

IMeasurement

Collection for iterating through the Limit Segment objects (Limit Lines).

LimitTestFailed

IMeasurement

Returns the results of limit testing

LoadPort

IMeasurement

Returns the load port number associated with an S-parameter reflection measurement.

LogMagnitudeOffset

IMeasurement

Sets or returns the value that normalized, unratioed, receiver power measurement data will be shifted by

MagnitudeOffset

IMeasurment4

Offsets the magnitude of the entire data trace to a specified value.

MagnitudeSlopeOffset

IMeasurment4

Offsets the magnitude of the data trace to a value that changes linearly with frequency.

Marker

IMeasurement

Contains the methods and properties that control Markers.

MarkerFormat

IMeasurement

Sets or returns the format of all the markers in the measurement.

Marker State

IMeasurement3

Sets or returns the ON / OFF state of a marker.

Mean

IMeasurement

Returns the mean value of the measurement.

Name

IMeasurement

Sets or returns the name of the measurement.

NAWindow

IMeasurement

Controls the part of the display that contains the graticule, or what is written on the display.

Normalization

IMeasurement

Turns ON or OFF normalization for receiver power cal of unratioed measurements

Number

IMeasurement

Returns the number of the measurement.

NumberOfPoints

IMeasurement2

Returns the Number of Points of the measurement.

Parameter

IMeasurement

Returns the measurement Parameter.

PeakToPeak

IMeasurement

Returns the Peak to Peak value of the measurement.

PhaseOffset

IMeasurement

Sets the Phase Offset for the active channel.

ReceivePort

IMeasurement2

Returns the receiver port of the measurement.

ReferenceMarkerState

IMeasurement

Turns the reference marker ON or OFF

ShowStatistics

IMeasurement

Displays and hides the measurement statistics (peak-to-peak, mean, standard deviation) on the screen.

Smoothing

IMeasurement

Turns ON and OFF data smoothing.

SmoothingAperture

IMeasurement

Specifies or returns the amount of smoothing as a ratio of the number of data points in the measurement trace.

SourcePort

IMeasurement2

Returns the source port of the measurement.

Span

IMeasurement2

Returns the stimulus span (stop - start) for the measurement.

StandardDeviation

IMeasurement

Returns the standard deviation of the measurement.

Start

IMeasurement2

Returns the stimulus value of the first point for the measurement.

StatisticsRange

IMeasurement

Sets the User Range number for calculating measurement statistics.

Stop

IMeasurement2

Returns the stimulus value of the last point for the measurement.

Trace

IMeasurement

Controls scale, reference position, and reference line.

TraceMath

IMeasurement

Performs math operations on the measurement object and the trace stored in memory.

Transform

IMeasurement

Controls Time Domain transforms.

View

IMeasurement

Sets (or returns) the type of trace displayed on the screen

WGCutoffFreq

IMeasurement2

Sets or returns the value of the waveguide cut off frequency

IMeasurement History

Interface | Introduced with PNA Rev:
IMeasurement | 1.0
IMeasurement2 | 3.0
IMeasurement3 | 4.0
IMeasurement4 | 4.2
IMeasurement5 | 5.0

IArrayTransfer Interface

Description

Contains methods for putting data in and getting data out of the analyzer using typed data. This interface transfers data more efficiently than the IMeasurement Interface.

Methods

Description

getComplex

Retrieves real and imaginary data from the specified buffer.

getNAComplex

Retrieves typed NAComplex data from the specified buffer.

getPairedData

Retrieves magnitude and phase data pairs from the specified buffer.

getScalar

Retrieves scalar data from the specified buffer.

putComplex

Puts real and imaginary data into the specified buffer.

putNAComplex

Puts typed NAComplex data into the specified buffer.

putScalar

Puts scalar data into the measurement result buffer.

Properties

Description

None

IArrayTransfer History

Interface | Introduced with PNA Rev:
IArrayTransfer | 1.0


Measurements Collection

Measurement Collection

Description

A collection object that provides a mechanism for iterating through the Application measurements.

Accessing the Measurements collection

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim measments As Measurements
Set measments = app.Measurements

See Also:

Collections in the Analyzer

The PNA Object Model

Methods

Description

Add

Adds a Measurement to the collection.

Item

Use to get a handle on a measurement in the collection.

Remove

Removes a measurement from the measurements collection.

Properties

Description

Count

Returns the number of measurements in the analyzer.

Parent

Returns a handle to the current Application.


NAWindow Object

Description

The NAWindow object controls the part of the display that contains the graticule, or what is written on the display.

Accessing the NaWindow object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim window As NAWindow
Set window = app.NAWindows(1)
window.AutoScale

or

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", "analyzerName")

app.NAWindows(1).AutoScale

See Also:

PNA Automation Interfaces

The PNA Object Model

(Bold Methods or Properties provide access to a child object)

Methods

Description

Autoscale

Autoscales all measurements in the window.

Shared with the Trace Object

ShowMarkerReadout

Shows and Hides the Marker readout for the active marker in the upper-right corner of the window object.

ShowTable

Shows or Hides the specified table for the active measurement in the lower part of the window object.

Properties

Description

ActiveTrace

Sets a trace to the Active Trace.

MarkerReadout

Sets and reads the state of the Marker readout for the active marker in the upper-right corner of the window object.

MarkerReadoutSize

Specifies the size of font used when displaying Marker readout in the selected window.

OneMarkerReadoutPerTrace

Either show marker readout of only the active trace or all of the traces simultaneously.

Title

Writes or reads a custom title for the window.

TitleState

Turns ON and OFF the window title.

Trace

Collection for getting a handle to a trace or iterating through the traces in a window.

WindowNumber

Reads the number of the active window.

WindowState

Maximizes or minimizes a window.

Shared with the Application Object

INaWindow History

Interface | Introduced with PNA Rev:
INaWindow | 1.0


NAWindows Collection

Description

A collection object that provides a mechanism for iterating through the Application windows.

Accessing the NaWindows collection

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim windows As NAWindows
Set windows = app.NAWindows

See Also:

Collections in the Analyzer

The PNA Object Model

Methods

Description

Add

Adds a window to the NAWindows collection.

Item

Use to get a handle to a window in the collection.

Remove

Removes a window from the NAWindows collection.

Properties

Description

Count

Returns the number of windows on the analyzer.

Parent

Returns a handle to the current Application.


Port Extension Object

Description

Contains the methods and properties that control Port Extensions.

Accessing a Port Extension object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim PortExt As PortExtension
Set PortExt = app.PortExtension

See Also:

PNA Automation Interfaces

The PNA Object Model

Methods

None

Property

Description

Input A

Sets the Input A extension value.

Input B

Sets the Input B extension value.

Input C

Sets the Input C extension value.

Port 1

Sets the Port 1 extension value.

Port 2

Sets the Port 2 extension value.

Port 3

Sets the Port 3 extension value.

State

Turns Port Extensions ON and OFF.

IPort Extension History

Interface | Introduced with PNA Rev:
IPort Extension | 1.0


PowerLossSegment Object

Description

Contains the properties describing a segment of the power loss table used in source power calibration.

You can get a handle to one of these segments through the segments.Item Method of the PowerLossSegments collection.

Accessing the PowerLossSegment object

You can get a handle to one of these segments through PowerLossSegments.Item(n)

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim PwrLossSeg As PowerLossSegment
Set PwrLossSeg = app.SourcePowerCalibrator.PowerLossSegments(1)

See Also:

PNA Automation Interfaces

The PNA Object Model

Methods

None

Properties

Description

Frequency

The frequency (Hz) associated with this segment.

Shared with the PowerSensorCalFactorSegment Object

Loss

The loss value (dB) associated with this segment.

SegmentNumber

Returns the number of this segment

Shared with the PowerSensorCalFactorSegment Object

IPowerLossSegment History

Interface | Introduced with PNA Rev:
IPowerLossSegment | 2.0


PowerLossSegments Collection

Description

A collection object that provides a mechanism for iterating through the segments of the power loss table used in source power calibration.

Accessing the PowerLossSegments collection

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim PwrLossSegs As PowerLossSegments
Set PwrLossSegs = app.SourcePowerCalibrator.PowerLossSegments

See Also:

Collections in the Analyzer

The PNA Object Model

Methods

Description

Add

Adds a PowerLossSegment object to the collection.

Item

Use to get a handle to a PowerLossSegment object in the collection.

Remove

Removes an object from the collection.

Properties

Description

Count

Returns the number of objects in the collection.

Parent

Returns a handle to the Parent object (SourcePowerCalibrator) of this collection.


PowerSensor Object

Description

Each power sensor connected to the power meter associated with Source Power Calibration will have a PowerSensor object created to represent it. These PowerSensor objects reside in the PowerSensors collection within the SourcePowerCalibrator object. You cannot directly create PowerSensor objects, but can only retrieve existing ones from the PowerSensors collection.

The PowerSensorCalFactorSegment object is also accessed through the PowerSensor object. These are accessed through the CalFactorSegments collection in the PowerSensor object.

Accessing a PowerSensor object

Dim pna As AgilentPNA835x.Application
Set pna = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim powerCalibrator as SourcePowerCalibrator
Dim powerSensor as PowerSensor
Dim calFactorSegment as PowerSensorCalFactorSegment

Set powerCalibrator = pna.SourcePowerCalibrator

' Specify GPIB address of the power meter.
powerCalibrator.PowerMeterGPIBAddress = 13

' Each time the PowerSensors collection is accessed, the power meter is queried to determine which channels have sensors attached. The collection is updated accordingly.

If powerCalibrator.PowerSensors.Count > 0 Then
' If channel B of the meter has a sensor attached but channel A does not, then element 1 of the
' collection is sensor B. Whenever channel A has a sensor, sensor A will be element 1.
Set powerSensor = powerCalibrator.PowerSensors(1)
' Insert one new PowerSensorCalFactorSegment at the beginning of the collection (index 1).

powerSensor.CalFactorSegments.Add(1)
' Assign our variable to refer to that object.
Set calFactorSegment = powerSensor.CalFactorSegments(1)

' Set property values for that object.
calFactorSegment.Frequency = 300000
' frequency in Hz
calFactorSegment.CalFactor = 98
' cal factor in percent

End If

See Also:

PNA Automation Interfaces

The PNA Object Model

Methods

None

Properties

Description

CalFactorsSegments (collection)

MinimumFrequency

Minimum usable frequency (Hz) specified for this power sensor.

MaximumFrequency

Maximum usable frequency (Hz) specified for this power sensor.

PowerMeterChannel

Identifies which power sensor this object corresponds to ( or which channel of the power meter the sensor is connected to).

ReferenceCalFactor

Reference cal factor (%) associated with this power sensor.

IPowerSensor History

Interface | Introduced with PNA Rev:
IPowerSensor | 2.0


PowerSensorCalFactorSegment Object

Description

Contains the properties describing a segment of a power sensor cal factor table.

Accessing the PowerSensorCalFactorSegment object

You can get a handle to one of these segments through CalFactorSegments.Item(n)

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim calFactSeg As CalFactorSegments
Set calFactSeg = app.SourcePowerCalibrator.PowerSensors(1).CalFactorSegments(1)

See Also:

PNA Automation Interfaces

The PNA Object Model

Methods

None

Properties

Description

Frequency

The frequency (Hz) associated with this segment.

Shared with the PowerLossSegment Object

CalFactor

The cal factor (%) associated with this segment.

SegmentNumber

Returns the number of this segment

Shared with the PowerLossSegment Object

IPowerSensorCalFactorSegment History

Interface | Introduced with PNA Rev:
IPowerSensorCalFactorSegment | 2.0


PowerSensors Collection

Description

A collection object that provides a mechanism for iterating through the PowerSensor objects which are connected to the power meter. Each time this collection object is accessed, the power meter is queried to determine how many sensors are connected to it. The collection size and order of objects is then adjusted accordingly before the requested method or property operation is performed. The power meter is specified by using the PowerMeterGPIBAddress property of the SourcePowerCalibrator object.

Accessing the PowerSensors Collection

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim PwrSensors As PowerSensors
Set PwrSensors = app.SourcePowerCalibrator.PowerSensors

See Also:

Collections in the Analyzer

The PNA Object Model

Methods

Description

Item

Use to get a handle to a PowerSensor object in the collection.

Properties

Description

Count

Returns the number of objects in the collection.

Parent

Returns a handle to the Parent object (SourcePowerCalibrator) of this collection.


Preferences Object

Description

Sets the preferences for saving citifiles.

Accessing the Preferences object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim pref As Preferences
Set pref = app.Preferences

See Also:

Citifile Define Data Saves

PNA Automation Interfaces

The PNA Object Model

Method

None

Property

Description

CitiContents

Specifies the contents of subsequent citifile saves.

CitiFormat

Specifies the format of subsequent citifile saves.

SnPFormat

Specifies the format of subsequent .S1P, .S2P, .S3P file saves.

IPreferences History

Interface | Introduced with PNA Rev:
IPreferences | 4.0


SCPIStringParser Object

Description

Provides the ability to send a SCPI command from within the COM command.

Accessing the Port Extension object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim SCPI As IScpiStringParser
Set SCPI = app.ScpiStringParser

See Also:

PNA Automation Interfaces

The PNA Object Model

Method

Interface

Description

Parse

ISCPIStringParser

Provides the ability to send a SCPI command from within the COM command.

Execute

ISCPIStringParser2

Does not convert scpi errors. Use :SYST:ERR?

Properties

None

History

Interface | Introduced with PNA Rev:
ISCPIStringParser | 1.0
ISCPIStringParser2 | 3.0


Segment Object

Description

Contains the methods and properties that affect a sweep segment.

Note: All of these properties are shared with at least one of the following objects: Channel, Cal Set, PowerSensorCalFactorSegment, or PowerLossSegment.

Accessing a Segment object

You can get a handle to a sweep segment through the segments collection.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim segs As ISegments
Set segs = app.ActiveChannel.Segments

segs(2).NumberOfPoints = 30

See Also:

PNA Automation Interfaces

The PNA Object Model

Segment Sweep

Method

None

Property

Interface

Description

centerFrequency

ISegment

Sets or returns the center frequency of the segment.

Shared with the Channel Object

DwellTime

ISegment

Dwell time value.

Shared with the Channel Object

FrequencySpan

ISegment

Sets or returns the frequency span of the segment.

Shared with the Channel Object

IFBandwidth

ISegment

Sets or returns the IF Bandwidth of the segment.

Shared with the Channel Object and Cal Set object.

NumberOfPoints

ISegment

Sets or returns the Number of Points of the segment.

Shared with the Channel Object

SegmentNumber

ISegment

Returns the number of the current segment.

StartFrequency

ISegment

Sets or returns the start frequency of the segment.

Shared with the Channel Object

State

ISegment

Turns On or OFF a segment.

StopFrequency

ISegment

Sets or returns the stop frequency of the segment.

Shared with the Channel Object

TestPortPower

ISegment

Sets or returns the RF power level of the segment.

Shared with the Channel Object

ISegment History

Interface | Introduced with PNA Rev:
ISegment | 1.0


Segments Collection

Description

A collection object that provides a mechanism for iterating through the sweep segments of a channel. Sweep segments are a potentially faster method of sweeping the analyzer through only the frequencies of interest. Learn more about Segment Sweep.

Accessing the Segments collection

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim segs As ISegments
Set segs = app.ActiveChannel.Segments

See Also:

Collections in the Analyzer

The PNA Object Model

Methods

Interface

See History

Description

Add

ISegments

Adds an item to either the Segments collection.

Item

ISegments

Use to get a handle to a segment in the collection..

Remove

ISegments

Removes an item from a collection of objects.

SetAllSegments

ISegments2

Uploads a segment table to the PNA.

Properties

Description

AllowArbitrarySegments

ISegments3

Enables the setup of arbitrary segment sweep

Count

ISegments

Returns the number of items in a collection of objects.

IF Bandwidth Option

ISegments

Enables the IFBandwidth to be set on individual sweep segments.

Parent

ISegments

Returns a handle to the current naNetworkAnalyzer application..

Source Power Option

ISegments

Enables setting the Source Power for a segment.

ISegments History

Interface | Introduced with PNA Rev:
ISegments | 1.0
ISegments2 | 3.5
ISegments3 | 4.2


SMCType Object

Description

Contains the methods and properties to perform an Scalar Measurement Calibration for the Frequency Converter Application (option 083).

Accessing the SMCType object

See an example which creates and calibrates an SMC measurement.

See Also:

PNA Automation Interfaces

The PNA Object Model

Methods

AcquireStep

Acquire the measurement data for the specified step in the calibration process.

GenerateErrorTerms

Generates the error terms for the calibration.

GenerateSteps

Returns the number of steps required to complete the calibration.

GetStepDescription

Returns the description of the specified step calibration process.

Initialize

Begins a calibration.

Property

Description

AutoOrient

Sets ECAL module automatic orientation ON or OFF.

CalibrationPort

Sets or returns the calibration source port for the calibration.

CalKitType

Sets and returns a calibration kit type for calibration.

CompatibleCalKits

Returns a list of cal kits that are compatible with the connector type for the specified port.

ConnectorType

Sets or queries the connector type for the specified port.

Do2PortEcal

Specify ECAL or Mechanical calibration.

EcalCharacterization

Specifies the characterization data within an ECal module to be used for the calibration.

EcalOrientation

Specifies which port of the ECal module is connected to which port of the PNA when the AutoOrient property = False.

OmitIsolation

Sets and returns whether Isolation portion of the calibration will be performed or not.

ThruCalMethod

Sets and returns the method for performing the thru portion of the calibration.

ValidConnectorTypes

Returns a list of connector types for which there are calibration kits.

ISMCType History

Interface | Introduced with PNA Rev:
ISMCType | 3.5


SourcePowerCalibrator Object

Description

This object is a child of the Application object and is a vehicle for performing source power calibrations.

Accessing the SourcePowerCalibrator Object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim ispc As ISourcePowerCalibrator
Set ispc = app.SourcePowerCalibrator

See Also:

PNA Automation Interfaces

The PNA Object Model

Note: Interface ISourcePowerCalibrator is abbreviated as ISPC in the following table.

(Bold Methods or Properties provide access to a child object)

Methods

Interface

See History

Description

AbortPowerAcquisition

ISPC

Aborts a source power cal acquisition sweep that is currently in progress.

AcquirePowerReadings

ISPC

Initiates a source power cal acquisition.

ApplyPowerCorrectionValues

ISPC

Applies correction values after completing a source power cal acquisition sweep.

CheckPower

ISPC2

Measures power at a specific frequency. Used to test power level before and/or after applying a source power calibration.

LaunchPowerMeterSettingsDialog

ISPC2

Launches the Power Meter Settings dialog on the PNA.

SetCalInfo

ISPC

OBSOLETE

SetCalInfo2

ISPC3

REPLACEMENT - Specifies the type of source power calibration about to be performed.

SetPowerAcquisitionDevice

ISPC3

Sets the power sensor channel (A or B) to be used. This method is ONLY necessary when performing an SMC calibration.

Properties

Interface

Description

CalPower

ISPC

Specifies the power level that is expected at the desired reference plane.

IterationsTolerance

ISPC3

Sets the maximum desired deviation from the sum of the test port power and the offset value.

MaximumIterationsPerPoint

ISPC3

Specifies maximum number of readings to take at each data point for iterating the source power.

PowerAcquisitionDevice

ISPC2

Specifies the power sensor channel (A or B) that is currently selected for use at a specific frequency.

PowerLossSegments (collection)

ISPC2

Collection for iterating through the segments of the power loss table used in source power calibration.

PowerMeterGPIBAddress

ISPC

Specifies the GPIB address of the power meter.

PowerSensors (collection)

ISPC2

Collection for iterating through the PowerSensor objects which are connected to the power meter for a source power cal.

ReadingsPerPoint

ISPC

Specifies the maximum power readings for power meter settling.

ReadingsTolerance

ISPC3

Power meter settling tolerance value.

UsePowerLossSegments

ISPC

Specifies if subsequent calls to the AcquirePowerReadings method will make use of the loss table (PowerLossSegments).

UsePowerSensorFrequencyLimits

ISPC

Specifies if subsequent calls to the AcquirePowerReadings method will make use of power sensor frequency checking capability.

ISourcePowerCalibrator History

Interface | Introduced with PNA Rev:
ISourcePowerCalibrator | 2.0
ISourcePowerCalibrator2 | 3.5
ISourcePowerCalibrator3 | 4.0


Trace Object

Description

The Trace object controls how the measurement data is displayed. You can control scale, reference position, and value from the Trace Object.

Accessing a Trace object

There are several ways to get a handle to a trace.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim trace As Trace

Then you can do any of the following:

Set trace = app.NAWindows(1).traces(1)

set trace = app.NAWindows.item(1).ActiveTrace

set trace = app.ActiveNAWindow.traces.item(1)

set trace = app.ActiveNAWindow.ActiveTrace

Set trace = app.Measurements(1).trace

Set trace = app.ActiveMeasurement.trace

See Also:

PNA Automation Interfaces

The PNA Object Model

Traces, Channels, and Windows on the PNA

Methods

Description

Autoscale

Autoscales the trace or all of the traces in the selected window.

Shared with the NAWindow Object

Property

Description

Name

Sets or returns the trace name

ReferencePosition

Sets or returns the Reference Position of the active trace.

ReferenceValue

Sets or returns the value of the Y-axis Reference Level of the active trace.

YScale

Sets or returns the Y-axis Per-Division value of the active trace.

ITrace History

Interface | Introduced with PNA Rev:
ITrace | 1.0


Traces Collection

Description

Child of the Application Object. A collection that provides a mechanism for getting a handle to a trace or iterating through the traces in a window.

Accessing the Traces collection

Get a handle to the traces collection through the NaWindows collection. The following example sets the variable trcs to the collection of traces in window 1 of the NaWindows collection.

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim trcs As traces
Set trcs = app.NAWindows(1).traces

See Also:

Collections in the Analyzer

The PNA Object Model

Methods

Description

Item

Use to get a handle to a trace

Properties

Description

Count

Returns the number of traces in the collection.

Parent

Returns a handle to the current Application.


Transform Object

Description

Contains the methods and properties that control Time Domain transforms.

Accessing the Transform Object

Dim app As AgilentPNA835x.Application
Set app = CreateObject("AgilentPNA835x.Application", <analyzerName>)

Dim trans As Transform
Set trans = app.ActiveMeasurement.Transform

See Also:

PNA Automation Interfaces

The PNA Object Model

Time Domain Topics

Methods

Interface

Description

SetFrequencyLowPass

ITransform

Sets low frequencies for low pass.

Property

Description

Center

ITransform

Sets or returns the Center time.

Shared with the Gating Object

CoupledParameters

ITransform2

Select Transform parameters to couple

DistanceMarkerMode

ITransform2

Sets the measurement type in order to determine the correct marker distance.

DistanceMarkerUnit

ITransform2

Sets the unit of measure for the display of marker distance values.

ImpulseWidth

ITransform

Sets or returns the Impulse Width of Time Domain transform windows.

KaiserBeta

ITransform

Sets or returns the Kaiser Beta of Time Domain transform windows.

Mode

ITransform

Sets the type of transform.

Span

ITransform

Sets or returns the Span time.

Shared with the Gating Object

Start

ITransform

Sets or returns the Start time.

Shared with the Gating Object

State

ITransform

Turns an Object ON and OFF.

StepRiseTime

ITransform

Sets or returns the Rise time of the stimulus in Low Pass Step Mode.

Stop

ITransform

Sets or returns the Stop time.

Shared with the Gating Object

ITransform History

Interface | Introduced with PNA Rev:
ITransform | 1.0
ITransform2 | 4.2


TriggerSetup Object

Description

These properties setup Global triggering that effects the entire PNA application.

Accessing the TriggerSetup object

Dim app as AgilentPNA835x.Application
Dim trigSetup as ITriggerSetup
Set trigSetup = app.TriggerSetup

See Also:

PNA Automation Interfaces

The PNA Object Model

Triggering in the PNA

Methods

Interface

See History (below)

Description

None

Properties

Description

AcceptTriggerBeforeArmed

ITriggerSetup2

Allows a trigger signal to be remembered and then used when the PNA becomes armed (ready to be triggered).

ExternalTriggerConnectionBehavior

ITriggerSetup

Configures the external triggering signal for the PNA

Scope

ITriggerSetup

Determines whether a trigger signal affects a single channel or all channels in the PNA.

Source

ITriggerSetup

Sets or returns the source of triggering in the PNA.

TriggerOutputEnabled

ITriggerSetup2

Enables the PNA to send trigger signals out the rear-panel TRIGGER OUT connector.

ITriggerSetup History

Interface | Introduced with PNA Rev:
ITriggerSetup | 4.0
ITriggerSetup2 | 4.2


VMC Type Object

Description

Contains the methods and properties to perform a Vector Measurement Calibration for the Frequency Converter Application (option 083).

Accessing the VMCType object

See an example which creates and calibrates a VMC measurement.

See Also:

PNA Automation Interfaces

The PNA Object Model

Methods

AcquireStep

Acquire the measurement data for the specified step in the calibration process.

GenerateErrorTerms

Generates the error terms for the calibration.

GenerateSteps

Returns the number of steps required to complete the calibration.

GetStepDescription

Returns the description of the specified step in the calibration process.

Initialize

Begins a calibration.

Property

Description

AutoOrient

Sets ECAL module automatic orientation ON or OFF.

CalKitType

Sets and returns a calibration kit type for calibration.

CharacterizeMixerOnly

Sets and returns whether to perform a mixer characterization ONLY or full 2-port calibration.

CharFileName

Specifies the .S2P mixer characterization file name.

CharMixerReverse

Specifies the direction in which to characterize the calibration mixer.

CompatibleCalKits

Returns a list of cal kits that are compatible with the connector type for the specified port.

ConnectorType

Sets or queries the connector type for the specified port.

Do1PortEcal

Specify ECAL or Mechanical calibration for the mixer characterization portion of a VMC calibration.

Do2PortEcal

Specify ECAL or Mechanical calibration for the 2-port calibration portion of a VMC calibration.

EcalCharacterization

Specifies the characterization data within an ECal module to be used for the calibration.

EcalOrientation1Port

For Mixer Characterization ONLY - Specifies which port of the ECal module is connected to which port of the PNA

EcalOrientation2Port

For full 2-port VMC cal - Specifies which port of the ECal module is connected to which port of the PNA

LoadCharFromFile

Specifies and loads a mixer characterization (S2P) file.

OmitIsolation

Sets and returns whether Isolation portion of the calibration will be performed or not.

ThruCalMethod

Sets and returns the method for performing the thru portion of the calibration.

ValidConnectorTypes

Returns a list of connector types for which there are calibration kits.

IVMCType History

Interface | Introduced with PNA Rev:
IVMCType | 3.5


Write/Read.

About Trigger

AcceptTriggerBeforeArmed Property

Description

Determines what happens to an EDGE trigger signal if it occurs before the PNA is ready to be triggered. (LEVEL trigger signals are always ignored.) For more information, see External triggering.

VB Syntax

trigsetup.AcceptTriggerBeforeArmed = boolean

Variable

(Type) - Description

trigsetup

A TriggerSetup2 (object)

boolean

Choose from:
0 - False - A trigger signal is ignored if it occurs before the PNA is ready to be triggered.

1 - True - A trigger signal is remembered and then used when the PNA becomes armed (ready to be triggered). The PNA remembers only one trigger signal.

Return Type

Boolean

Default

False

Examples

trigsetup.AcceptTriggerBeforeArmed = 1 'Write

atba = trigsetup.AcceptTriggerBeforeArmed 'Read

C++ Syntax

HRESULT get_AcceptTriggerBeforeArmed( BOOL *pVal);

HRESULT put_AcceptTriggerBeforeArmed( BOOL newVal);

Interface

ITriggerSetup2


Read / Write
About Performing a Calibration

AcquisitionDirection Property

Description

Specifies the direction of each part of a 2-port calibration.

VB Syntax

cal.AcquisitionDirection = value

Variable

(Type) - Description

cal

A Calibrator (object)

value

(enum NADirection) - Choose from:

0 - naForward - measures the forward direction
1 - naReverse - measures the reverse direction

Return Type

Long Integer

Default

naForward

Examples

cal.AcquisitionDirection = naForward

C++ Syntax

HRESULT AcquisitionDirection(tagNADirection dir);

Interface

ICalibrator


Active Cal Kit Property

Read-only

About Calibration Kits

ActiveCalKit Property

Description

Returns a handle to the Active CalKit object. You can either (1) use the handle directly to access CalKit properties and methods, or (2) set a variable to the CalKit object. The variable retains a handle to the original object if another CalKit becomes active.

VB Syntax

1) app.ActiveCalKit.<setting>
or
2) Set cKit = app.ActiveCalKit

Variable

(Type) - Description

app

An Application (object)

<setting>

A CalKit property (or method) and arguments

cKit

(object) - A CalKit object

Return Type

CalKit object

Default

None

Examples

Public cKit as calKit
Set cKit = app.ActiveCalKit 'read

C++ Syntax

HRESULT get_ActiveCalKit (ICalkit * kit)

Interface

IApplication


Active Channel Property

Read-only
About Channels

ActiveChannel Property

Description

Returns a handle to the Active Channel object. You can either (1) use the handle directly to access channel properties and methods, or (2) set a variable to the channel object. The variable retains a handle to the original channel if another channel becomes active.

VB Syntax

(1) app.ActiveChannel.<setting>
or
(2) Set chan = app.ActiveChannel

Variable

(Type) - Description

chan

A Channel (object)

app

An Application (object)

<setting>

A channel property (or method) and arguments

Return Type

Channel object

Default

Not applicable

Examples

1) app.ActiveChannel.Averaging = 1
2) Public chan as Channel
Set chan = app.ActiveChannel

C++ Syntax

HRESULT get_ActiveChannel( IChannel* *pVal)

Interface

IApplication


Read-only
About Markers

ActiveMarker Property

Description

Returns a handle to the Active Marker object. You can either (1) use the handle directly to access Marker properties and methods, or (2) set a variable to the Marker object. The variable retains a handle to the original object if another Marker becomes active.

VB Syntax

1) meas.ActiveMarker.<setting>
or
2) Set mark = meas.ActiveMarker

Variable

(Type) - Description

meas

(object) - An Measurement object

<setting>

A marker property (or method) and arguments

mark

(object) - A marker object

Return Type

marker object

Default

None

Examples

Public mark as marker
Set mark = meas.ActiveMarker

C++ Syntax

HRESULT get_ActiveMarker(IMarker** marker)

Interface

IMeasurement


Active Measurement Property

Read-only

ActiveMeasurement Property

Description

Returns a handle to the Active Measurement object. You can either (1) use the handle directly to access measurement properties and methods, or (2) set a variable to the measurement object. The variable retains a handle to the original measurement.

VB Syntax

1) app.Active Measurement.<setting>
or
2) Set meas = app.Active Measurement

Variable

(Type) - Description

meas

A Measurement (object)

app

An Application (object)

<setting>

A measurement property (or method) and arguments

Return Type

Measurement object

Default

None

Examples

1) app.ActiveMeasurement.Averaging = 1
2) Public meas as Measurement
Set meas = app.ActiveMeasurement

C++ Syntax

HRESULT get_ActiveMeasurement(IMeasurement **ppMeas)

Interface

IApplication


Read-only
About Windows

ActiveNAWindow Property

Description

Returns a handle to the Active Window object. You can either (1) use the handle directly to access window properties and methods, or (2) set a variable to the window object. The variable retains a handle to the original window if another window becomes active.

VB Syntax

1) app.ActiveNAWindow.<setting>
or
2) Set win = app.ActiveNAWindow

Variable

(Type) - Description

win

A NAWindow (object)

app

An Application (object)

<setting>

A NAWindow property (or method) and arguments

Return Type

A NAWindow object

Default

Not applicable

Examples

Public win as NAWindow
Set win = app.ActiveWindow

C++ Syntax

HRESULT get_ActiveNAWindow(INAWindow **ppWindow)

Interface

IApplication


Write/Read
About X-axis display

ActiveXAxisRange Property

Description

Sets or returns the swept parameter to display on the X-axis for the selected FCA measurement.

VB Syntax

mixer.ActiveXAxisRange = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(Enum as MixerStimulusRange) - Parameter to display on the X-axis. Choose from:

0 - mixINPUT - Input frequency span

1 - mixOUTPUT - Output frequency span

2 - mixLO_1 - First LO frequency span

3 - mixLO_2 - Second LO frequency span

Return Type

Enum

Default

OUTPUT

Examples

mixer.ActiveXAxisRange = 1 'Write

variable = mixer.ActiveXAxisRange 'Read

C++ Syntax

HRESULT get_ActiveXAxisRange(tagMixerStimulusRange *Val)

HRESULT put_ActiveXAxisRange(tagMixerStimulusRange newVal)

Interface

IMixer3


Active Trace Property

Read-only
About Traces

ActiveTrace Property

Description

Returns a handle to the Active Trace object. You can either (1) use the handle directly to access trace properties and methods, or (2) set a variable to the trace object. The variable retains a handle to the original trace if another trace becomes active.

VB Syntax

1) win.ActiveTrace.<setting>
or
2) Set trce = win.ActiveTrace

Variable

(Type) - Description

trce

A Trace (object)

win

An NAWindow (object)

<setting>

A trace property (or method) and arguments

Return Type

An NAWindow object

Default

None

Examples

1) win.ActiveTrace.Autoscale
2) Public trce as Trace
Set trce = Application.ActiveNAWindow.ActiveTrace

C++ Syntax

HRESULT get_ActiveTrace(ITrace* *pVal)

Interface

INAWindow


Write/Read

About Segment Sweep

AllowArbitrarySegments Property

Description

Enables you to setup a segment sweep with arbitrary frequencies. The start and stop frequencies of each segment can overlap other segments. Also, each segment can have a start frequency that is greater than its stop frequency which causes a reverse sweep over that segment. Learn more about Arbitrary Segment Sweep.

VB Syntax

segs.AllowArbitrarySegments = value

Variable

(Type) - Description

segs

A Segments collection (object)

value

(boolean)
True - Allows the setup of arbitrary segment sweep.
False - Prevents the setup of arbitrary segment sweep.

Return Type

Boolean

Default

False

Examples

segs.AllowArbitrarySegments = True 'Write

AllowArbSegs = AllowArbitrarySegments 'Read

C++ Syntax

HRESULT get_AllowArbitrarySegments(VARIANT_BOOL *pVal)

HRESULT put_AllowArbitrarySegments(VARIANT_BOOL newVal)

Interface

ISegments3


Alternate Sweep Property

Write/Read
About Sweeping

AlternateSweep Property

Description

Sets sweeps to either alternate or chopped.

VB Syntax

object.AlternateSweep = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(boolean) - Choose either:

False (0) - Sweep mode set to Chopped - reflection and transmission are measured on the same sweep.
True (1) - Sweep mode set to Alternate - reflection and transmission measured on separate sweeps. Improves Mixer bounce and Isolation measurements. Increases cycle time.

Return Type

boolean

Default

False (0)

Examples

chan.AlternateSweep = True 'Write

altSwp = chan.AlternateSweep 'Read

C++ Syntax

HRESULT AlternateSweep(VARIANT_BOOL *pVal)
HRESULT AlternateSweep(VARIANT_BOOL newVal)

Interface

IChannel

ICalSet3


Read-only

Application Property

Description

Returns the name of the Analyzer making measurements on the channel.

VB Syntax

chan.Application

Variable

(Type) - Description

chan

A Channel (object)

Return Type

object

Default

None

Examples

rfna = chan.Application 'returns the Analyzer name

C++ Syntax

HRESULT get_Application(IApplication** Application)

Interface

IChannel


Arrange Windows Property

Write/Read

About Arrange Windows

ArrangeWindows Property

Description

Sets or returns the arrangement of all the windows. Overlay, Stack2, Split3 and Quad4 will create windows.

To control the state of the one window you have a handle to, use app.WindowState.

VB Syntax

app.ArrangeWindows = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NAWindowModes) - Choose from:

0 - naTile
1 - naCascade
2 - naOverlay
3 - naStack2
4 - naSplit3
5 - naQuad4

Return Type

NAWindowModes

Default

naTile

Examples

app.ArrangeWindow = naTile 'Write

arrWin = app.ArrangeWindows 'Read

C++ Syntax

HRESULT put_ArrangeWindows(tagNAWindowModes newVal)

Interface

IApplication


Attenuator Mode Property

Write/Read
About Attenuation

AttenuatorMode Property

Description

Sets or returns the mode of operation of the attenuator control for the specified port number. This command is automatically set to Manual when an Attenuator value is set.

VB Syntax

object.AttenuatorMode(portNum) = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

portNum

(long) - Port number (1 or 2) of attenuator control to be changed.

value

(enum NAModes) - Choose from:

0 - naAuto - Attenuator control set to automatic. The analyzer will set the attenuator control appropriately to deliver the specified power at the source.

1 - naManual - Specify the attenuator setting using chan.Attenuator (which automatically sets AttenuatorMode = naManual.

Return Type

NAModes

Default

0 - Auto

Examples

chan.AttenuatorMode(1) = naAuto 'Write

attn = chan.AttenuatorMode(1) 'Read

C++ Syntax

HRESULT get_AttenuatorMode(long port, tagNAModes* pVal)
HRESULT put_AttenuatorMode(long port, tagNAModes newVal)

Interface

IChannel

ICalSet3


Write/Read
About Attenuation

Attenuator Property

Description

Sets or returns the value of the attenuator control for the specified port number. Sending this command automatically sets AttenuatorMode to Manual.

VB Syntax

object.Attenuator(portNum) = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

portNum

(long integer) - Port number (1 or 2) of attenuator control to be changed.

value

(double) - Attenuator value in dB in 10dB steps.

Note: To determine the maximum attenuator value, use MaximumSourceStepAttenuator Property

If an invalid value is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered the analyzer will select 10 dB attenuation.

Return Type

Double

Default

20 dB

Examples

chan.Attenuator(1) = 20 'Write

attn = chan.Attenuator(cnum) 'Read

C++ Syntax

HRESULT get_Attenuator(long port, double *pVal)
HRESULT put_Attenuator(long port, double newVal)

Interface

IChannel

ICalSet3


Write/Read
About ECAL orientation

AutoOrient Property

Description

Sets ECAL module automatic orientation ON or OFF.

VB Syntax

obj.AutoOrient = bool

Variable

(Type) - Description

obj

SMCType (object)

or

VMCType (object)

bool

(Boolean)

1 - Set AutoOrientation ON

0 - Set AutoOrientation OFF

Return Type

Boolean

Default

1

Examples

Smc.AutoOrient = 1

C++ Syntax

HRESULT put_AutoOrient(VARIANT_BOOL bAutoOrient);

HRESULT get_AutoOrient(VARIANT_BOOL *bAutoOrient);

Interface

SMCType

VMCType


Read-only

About Averaging

AveragingCount Property

Description

Returns the number of sweeps that have been acquired and averaged into the measurements on this channel. AveragingFactor specifies the number of sweeps to average. AveragingCount indicates the progress toward that goal.

VB Syntax

value = chan.AveragingCount

Variable

(Type) - Description

chan

A Channel (object)

value

(Long Integer) - Variable to store the returned count

Return Type

Long Integer

Default

Not Applicable

Example

avgcount = chan.AveragingCount

C++ Syntax

HRESULT get_AveragingCount(long* count)

Interface

IChannel


Averaging Factor Property

Write/Read

About Averaging

AveragingFactor Property

Description

Specifies the number of measurement sweeps to combine for an average. Must also turn averaging ON by setting chan.Averaging = 1. Averaging is only allowed on ratioed measurements; not on single input measurements.

VB Syntax

chan.AveragingFactor = value

Variable

(Type) - Description

chan

A Channel (object)

value

(Long Integer) - Number of measurement sweeps to average. Choose any number between 1 and 1024.

Return Type

Long Integer

Default

1

Examples

chan.AveragingFactor = 5 'Write

avgfact = chan.AveragingFactor ' doesn't work -Read

C++ Syntax

HRESULT get_AveragingFactor(long *pVal)
HRESULT put_AveragingFactor(long newVal)

Interface

IChannel


Write/Read
About Averaging

Averaging Property

Description

Turns trace averaging ON or OFF for all measurements on the channel. Averaging is only allowed on ratioed measurements; not on single input measurements.

VB Syntax

chan.Averaging = state

Variable

(Type) - Description

chan

A Channel (object)

state

(boolean)
0 - Turns averaging OFF
1 - Turns averaging ON

Return Type

Boolean

Default

0

Examples

chan.Average = 1 'Write

averg = chan.Averaging 'Read

C++ Syntax

HRESULT get_Averaging(BOOL *pVal)
HRESULT put_Averaging(BOOL newVal)

Interface

IChannel


Write/Read
About Avoid Spurs Feature

AvoidSpurs Property

Description

Sets and returns the state of the avoid spurs feature.

VB Syntax

mixer.AvoidSpurs = boolean

Variable

(Type) - Description

mixer

A Mixer (object)

value

(Boolean) - State of avoid spurs feature. Choose from

0 Avoid spurs OFF

1 Avoid spurs ON

Return Type

Boolean

Default

0

Examples

mixer.AvoidSpurs = 1 'Write

variable = mixer.AvoidSpurs 'Read

C++ Syntax

HRESULT get_AvoidSpurs(Bool *bVal)

HRESULT put_AvoidSpurs(Bool newVal)

Interface

IMixer3


Bandwidth Target Property

Write/Read

About Marker Search

BandwidthTarget Property

Description

Sets the insertion loss value at which the bandwidth of a filter is measured (using BandwidthTracking or SearchFilterBandwidth). For example, if you want to determine the filter bandwidth 3 db below the bandpass peak value, set BandwidthTarget to -3.

VB Syntax

meas.BandwidthTarget = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(single) - Target value. Choose any number between -500 and 500

Return Type

Single

Default

-3

Examples

meas.BandwidthTarget = -3 'Write

fbw = meas.BandwidthTarget 'Read

C++ Syntax

HRESULT put_BandwidthTarget(float target)
HRESULT get_BandwidthTarget(float* target)

Interface

IMeasurement


Bandwidth Tracking Property

Write/Read
About Marker Search

BandwidthTracking Property

Descriaption

Searches continually (every sweep) for the current BandwidthTarget (default is -3). To search the filter bandwidth for ONE SWEEP only (not continually), use meas.SearchFilterBandwidth.

This feature uses markers 1-4. To turn off these markers, either turn them off individually or DeleteAllMarkers.

The bandwidth statistics are displayed on the analyzer screen. To get the bandwidth statistics, use either GetFilterStatistics or FilterBW, FilterCF , FilterLoss ,or FilterQ.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To restrict the search to a UserRange with the bandwidth search, first activate marker 1 and set the desired UserRange. Then send the SearchFilterBandwidth command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.

VB Syntax

meas.BandwidthTracking = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
1 - Turns bandwidth tracking ON
0 - Turns bandwidth tracking OFF

Return Type

Boolean

Default

0 - OFF

Examples

meas.BandwidthTracking = 1 'Write

bwtrack = meas.BandwidthTracking 'Read

C++ Syntax

HRESULT put_BandwidthTracking(VARIANT_BOOL state)
HRESULT get_BandwidthTracking(VARIANT_BOOL* state)

Interface

IMeasurement


Begin Response Property

Write/Read
About Limits

BeginResponse Property

Description

When constructing a limit line, specifies the amplitude value of the start of a limit segment.

VB Syntax

limtseg.BeginResponse = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - Amplitude value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.BeginResponse = 10 'Write

BegResp = limtseg.BeginResponse 'Read

C++ Syntax

HRESULT get_BeginResponse(double *pVal)
HRESULT put_BeginResponse(double newVal)

Interface

ILimitSegment


Begin Stimulus Property

Write/Read
About Limits

BeginStimulus Property

Description

When constructing a limit line, specifies the beginning X-axis value.

VB Syntax

limtseg.BeginStimulus = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - Stimulus value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.Type = naLimitSegmentType_Maximum
limtseg.BeginStimulus = 3e9
limtseg.EndStimulus = 4e9
limtseg.BeginResponse = 10
limtseg.EndResponse = 10

BegStim = limtseg.BeginStimulus 'Read

C++ Syntax

HRESULT get_BeginStimulus(double *pVal)
HRESULT put_BeginStimulus(double newVal)

Interface

ILimitSegment


Bucket Number Property

Write/Read

About Markers

BucketNumber Property

Description

Sets or returns the bucket number (data point) for the active marker.

VB Syntax

mark.BucketNumber = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - Data point. Choose any number between 0 and the measurement's number of data points - 1.

For example, with Number of points = 201, choose between 0 and 200

Return Type

Long Integer

Default

The first marker is set to the middle of the span. Subsequent markers are set to the bucket number of the previously active marker.

Examples

mark.BucketNumber = 100 'moves the active marker to data point 100 -Write

pointNumber = mark.BucketNumber 'returns the data point number the active marker is currently on. -Read

C++ Syntax

HRESULT get_BucketNumber(long *pVal)
HRESULT put_BucketNumber(long newVal)

Interface

IMarker


Write/Read

About Modifying Cal Kits

C0 Property

Description

Sets and Returns the C0 (C-zero) value (the first capacitance value) for the calibration standard.

To set the other capacitance values, use C1, C2, C3

VB Syntax

calstd.C0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C0 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C0 = 15 'Write the value of C0 to 15picofarads

cap0 = calstd.C0 'Read the value of C0

C++ Syntax

HRESULT get_C0(float *pVal)
HRESULT put_C0(float newVal)

Interface

ICalStandard


Write/Read
About Modifying Cal Kits

C1 Property

Description

Sets and Returns the C1 value (the second capacitance value) for the calibration standard.

To set the other capacitance values, use C0, C2, C3

VB Syntax

calstd.C1 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C1 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C1 = 15 'Write the value of C1 to 15picofarads

cap1 = calstd.C1 'Read the value of C1

C++ Syntax

HRESULT get_C1(float *pVal)
HRESULT put_C1(float newVal)

Interface

ICalStandard


Write/Read

About Modifying Cal Kits

C2 Property

Description

Sets and Returns the C2 value (the third capacitance value) for the calibration standard.

To set the other capacitance values, use C0, C1, C3

VB Syntax

calstd.C2 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C2 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C2 = 15 'Write the value of C2 to 15picofarads

cap2 = calstd.C2 'Read the value of C2

C++ Syntax

HRESULT get_C2(float *pVal)
HRESULT put_C2(float newVal)

Interface

ICalStandard


Write/Read

About Modifying Cal Kits

C3 Property

Description

Sets and Returns the C3 value (the fourth capacitance value) for the calibration standard.

To set the other capacitance values, use C0, C1, C2

VB Syntax

calstd.C3 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C3 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C3 = 15 'Write the value of C3 to 15picofarads

cap3 = calstd.C3 'Read the value of C3

C++ Syntax

HRESULT get_C3(float *pVal)
HRESULT put_C3(float newVal)

Interface

ICalStandard


Write / Read
About Source Power Cal

CalFactor Property

Description

Sets or returns the cal factor value associated with a power sensor cal factor segment.

VB Syntax

calFactSeg.CalFactor = value

Variable

(Type) - Description

powerCalibrator

(object) - A PowerSensorCalFactorSegment (object)

value

(double) – Cal factor in percent. Choose any value between 1 and 150

Return Type

Double

Default

0

Examples

calFactSeg.CalFactor = 98 'Write
factor = calFactSeg.CalFactor 'Read

C++ Syntax

HRESULT put_CalFactor(Double newVal);

HRESULT get_CalFactor(Double *pVal);

Interface

IPowerSensorCalFactorSegment


Calibration Type Property

Write/Read
About Performing a Calibration

CalibrationType Property

Description

Specifies the type of calibration to perform or apply to the measurement.

VB Syntax

meas.CalibrationType = type

Variable

(Type) - Description

meas

A Measurement (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None
8 - naCalType_ThreePort_SOLT

Return Type

NACalType

Default

naCalType_None

Examples

meas.CalibrationType = naCalType_Response_Open 'Write

meascal = meas.CalibrationType 'Read

C++ Syntax

HRESULT put_CalibrationType (tagNACalType CalType)
HRESULT get_CalibrationType (tagNACalType* pCalType)

Interface

IMeasurement


CalibrationName_Property

Read only

CalibrationName Property

Description

Get the name of the current cal type.

VB Syntax

value = meas.CalibrationName

Variable

(Type) - Description

value

(string) - Variable to store the returned value.

meas

A Measurement (object)

Return Type

String

Default

Not Applicable

Examples

ct = meas.CalibrationName

C++ Syntax

HRESULT get_CalibrationName( [out,retval] BSTR* CalibrationName);

Interface

IMeasurement2


Read / Write

CalibrationPort Property

Description

Specifies which SMC port to calibrate.

VB Syntax

SMC.CalibrationPort = value

Variable

(Type) - Description

SMC

SMCType (object)

value

(String) Port number to be calibrated. Choose from:

  • 1 - SMC forward

  • 2 - SMC reverse

  • Both

Return Type

String

Default

1

Examples

value = SMC.CalibrationPort = "Both"

C++ Syntax

HRESULT put_CalibrationPort(BSTR port);

HRESULT get_CalibrationPort(BSTR *port);

Interface

SMCType

VMCType


CalibrationTypeID_property

Write/Read

Learn about SMC cal types

CalibrationTypeID Property

Description

Sets or returns the current cal type for custom measurements (FCA) using a Cal Type Name.

You can also use the CLSID or GUID associated with the cal type.

To select cal types for standard measurements, see Calibration Type Property.

VB Syntax

meas.CalibrationTypeID = id

Variable

(Type) - Description

meas

A Measurement (object)

id

(String) Cal type identifier Name. Use one of the following:

Name - Choose one of the following:

  • "VMC"

  • “SMC_2P” or “SMC”

  • “SMCRsp+IN”

  • “SMCRsp+OUT”

  • “SMCRsp”

You can also use a ClassID or GUID. The following are examples:

CLSID - "VectorMixerCal.VCMCType"

GUID - "{2061767B-0FE2-4F6F-86D0-9AB332B18DA5}"

Return Type

String

Default

Not Applicable

Examples

Dim pna

Dim m

Set pna = CreateObject("AgilentPNA835x.Application")

Set m = pna.ActiveMeasurement

m.CalibrationTypeID = "VMC"

m.ErrorCorrection = True

MsgBox m.CalibrationName

C++ Syntax

HRESULT get_CalibrationTypeID( [out, retval] BSTR* CalibrationTypeID );

HRESULT put_CalibrationTypeID( [in] BSTR CalibrationTypeID );

Interface

IMeasurement2


Write/Read
About Modifying Cal Kits

CalKitType Property

Description

Sets and returns a calibration kit type for calibration or to be used for kit modification. To get a handle to this kit, use app.ActiveCalKit.

There is also a CalKitType property on the GuidedCalibration object.

VB Syntax

object.CalKitType = value

Variable

(Type) - Description

object

calkit (object) or

Application (object)

Note: app.CalKitType and calkit.calKitType perform exactly the same function.

value

(enum naCalKit) - Calibration Kit type. Choose from:

1 - naCalKit_User1
2 - naCalKit_User2
3 - naCalKit_User3
4 - naCalKit_User4
..
..
..
49 - naCalKit_User49
50 - naCalKit_User50

These enumerated values correspond with the calibration kit ID on the Advanced Cal Kit Modify dialog box.

To change the cal kit name, use Name property.

Return Type

NACalKit

Default

Not Applicable

Examples

calkit.CalKitType = naCalKit_User27

kitype = app.CalKitType

C++ Syntax

HRESULT get_CalKitType(tagNACalKit *pVal);
HRESULT put_CalKitType(tagNACalKit newVal);

Interface

IApplication
ICalKit


CalKitType fca Property

Write/Read

CalKitType Property

Description

Sets and returns a calibration kit type for the specified port number.

VB Syntax

object.CalKitType (port) = value

Variable

(Type) - Description

object

GuidedCalibration (object) or

SMCType (object) or

VMCType (object)

port

(Long) Port number the cal kit will be assigned to.

value

(string) - Calibration Kit type.

Use CompatibleCalKits property for a list of valid Cal Kits.

Return Type

String

Default

Not Applicable

Examples

SMC.CalKitType(1) = naCalKit_User27

value = smc.CalKitType(1)

C++ Syntax

Interface

SMCType

VMCType


Read-only

About Source Power Cal

CalPower Property

Description

Specifies the power level that is expected at the desired reference plane (DUT input or output). This is not used for segment sweep with independent power levels or power sweeps.

Note: Although this command still works, it is recommended that you specify cal power by setting the test port power and offset value.

VB Syntax

value = powerCalibrator.CalPower (chan, sourcePort)

Variable

(Type) - Description

value

(double) - Variable to store the returned Cal power value in dBm.

powerCalibrator

(object) - A SourcePowerCalibrator object

chan

(long integer) - Channel number of the PNA.

sourcePort

(long integer) - Source port number

Return Type

None

Default

0

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.CalPower = -10 'Write

power = powerCalibrator.CalPower 'Read

C++ Syntax

HRESULT get_CalPower(long channel, long sourcePort, double *pVal);

Interface

ISourcePowerCalibrator


Write/Read

About Gating

Center Property

Description

Sets or returns the Center time of either Gating or Time Domain transform windows

VB Syntax

object.Center = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Center time in seconds. Choose any number between:
± (points-1) / frequency span

Return Type

Double

Default

0

Examples

trans.Center = 4.5e-9 'sets the Center time of a transform window -Write
gate.Center = 4.5e-9 'sets the Center time of a gating window -Write

cnt = trans.Center 'Read

C++ Syntax

HRESULT get_Center(double *pVal)
HRESULT put_Center(double newVal)

Interface

ITransform
IGating


Center_Property

Read-only

Center Property

Description

Returns the stimulus value of the center data point for the measurement. This function does NOT work for segment sweep measurements. To understand how this property is useful, see IMeasurement2 Interface.

VB Syntax

value = meas.Center

Variable

(Type) - Description

value

(Double) - Variable to store the returned value.

meas

A Measurement (object)

Return Type

Double

Default

Not Applicable

Examples

Print meas.Center 'prints the center data point

C++ Syntax

HRESULT get_Center(double * Val);

Interface

IMeasurement2


Write/Read

About Frequency

CenterFrequency Property

Description

Sets or returns the center frequency of the channel
or
Sets or returns the center frequency of the segment.

see also Measurement2 interface

VB Syntax

object.centerFrequency = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Center frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Center of the frequency range

Examples

chan.centerFrequency = 4.5e9 'sets the center frequency of a linear sweep for the channel object -Write

centfreq = chan.centerFrequency 'Read

C++ Syntax

HRESULT get_CenterFrequency(double *pVal)
HRESULT put_CenterFrequency(double newVal)

Interface

IChannel
ISegment


Channel Number Property

Read-only

About Channels

ChannelNumber Property

Description

Returns the Channel number of the Channel or Measurement object.

VB Syntax

object.ChannelNumber

Variable

(Type) - Description

object

A Channel (object)
or
A Measurement (object)

Return Type

Long Integer

Default

Not applicable

Examples

chanNum = chan.ChannelNumber 'returns the channel number
chanNum = meas.ChannelNumber 'returns the channel number of the measurement

C++ Syntax

HRESULT get_ChannelNumber(long *pVal)

Interface

IChannel
IMeasurement


Read/Write

CharacterizeMixerOnly Property

Description

Sets and returns whether to perform ONLY a mixer characterization.

VB Syntax

VMC.CharacterizeMixerOnly = bool

Variable

(Type) - Description

VMC

VMCType (object)

bool

(Boolean)

1 - Perform ONLY mixer characterization.

0 - Perform both mixer characterization and calibration.

Return Type

Boolean

Default

0

Examples

value = VMC.CharacterizeMixerOnly

C++ Syntax

HRESULT put_CharacterizeMixerOnly(VARIANT_BOOL bCharMixerOnly);

HRESULT get_CharacterizeMixerOnly(VARIANT_BOOL *bCharMixerOnly);

Interface

VMCType


Write/Read

CharFileName Property

Description

Specifies the mixer characterization (.S2P) file and immediately loads the file. Also specify the use of a characterization file with LoadCharFromFile Property

VB Syntax

VMC.CharFileName = value

Variable

(Type) - Description

VMC

VMCType (object)

value

(String) Full path and file name of the mixer characterization file.

Return Type

Not Applicable

Default

"C:\Program Files\Agilent\Network Analyzer\Documents\default.S2P"

Examples

VMC.CharFileName = "C:\Program Files\Agilent\Network Analyzer\Documents\default.S2P"

C++ Syntax

HRESULT put_CharFileName(BSTR filename);

HRESULT get_CharFileName(BSTR *filename);

Interface

VMCType


Read-Write

CharMixerReverse Property

Description

Specifies the direction in which to characterize the calibration mixer. Learn more about the calibration mixer.

VB Syntax

VMC.CharMixerReverse = bool

Variable

(Type) - Description

VMC

VMCType (object)

bool

(Boolean)

0 - Characterize the calibration mixer in the SAME direction as that specified in the mixer setup.

1 - Characterize the calibration mixer in the REVERSE direction as that specified in the mixer setup.

Return Type

Boolean

Default

0

Examples

VMC.CharMixerReverse = 0

C++ Syntax

HRESULT put_CharMixerReverse(VARIANT_BOOL bcharReverse);

HRESULT get_CharMixerReverse(VARIANT_BOOL *bcharReverse);

Interface

VMCType2


Write/Read

About Citifiles

CitiContents Property

Description

Specifies the contents of subsequent citifile saves using app.SaveCitiDataData or app.SaveCitiFormattedData

VB Syntax

pref.CitiContents = value

Variable

(Type) - Description

pref

A Preferences (object)

value

(string) - Contents that will be saved with subsequent save commands. Choose from:

"Single" - Single trace

"Displayed" - All displayed traces

"Auto" - All displayed traces

Return Type

String

Default

"Auto"

Examples

pref.CitiContents = "Single" 'Write

content = pref.CitiContents 'Read

C++ Syntax

HRESULT get_CitiContents(BSTR *Contents)
HRESULT put_CitiContents(BSTR Contents)

Interface

IPreferences


Write/Read

About Citifiles

CitiFormat Property

Description

Specifies the format of subsequent citifile saves using app.SaveCitiFormattedData

VB Syntax

pref.CitiFormat = value

Variable

(Type) - Description

pref

A Preferences (object)

value

(string) - Format in which the citifile will be saved with subsequent save commands. Choose from:

"MA" - Linear Magnitude / degrees

"DB" - Log Mag / degrees

"RI" - Real / Imaginary

"Auto" - Format in which the trace is already displayed. If other than Log Mag, Linear Magnitude, or Real/Imag, then the format will be in Real/Imag.

Return Type

String

Default

"Auto"

Examples

pref.CitiFormat = "MA" 'Write

format = pref.CitiFormat 'Read

C++ Syntax

HRESULT get_CitiFormat(BSTR *Format)
HRESULT put_CitiFormat(BSTR Format)

Interface

IPreferences


Read-only

CompatibleCalKits Property

Description

Returns a list of cal kits that are compatible with the connector type for the specified port.

VB Syntax

value = obj.CompatibleCalKits (port)

Variable

(Type) - Description

value

(Variant) Variable to store the returned list of CalKits.

obj

Any of the following:

GuidedCalibration (object)

SMCType (object)

VMCType (object)

port

(Long) Port number for which you want compatible kits.

Return Type

Variant

Default

Not Applicable

Examples

Dim kits As Variant
kits = MySMC.CompatibleCalKits(1)

C++ Syntax

HRESULT get_CompatibleCalKits(long port, VARIANT* Kits);

Interface

IGuidedCalibration

SMCType

VMCType


Read / Write

ConnectorType Property

Description

Sets or queries the connector type for the specified port.

VB Syntax

obj.ConnectorType (port) = value

Variable

(Type) - Description

obj

Any of the following:

GuidedCalibration (object)

SMCType (object)

VMCType (object)

port

(Long) Port number of the connector type

value

(String) - Connector type.

Use ValidConnectorType Property to list connector types.

Return Type

String

Default

None

Examples

Dim value As String
Value = MySMC.ConnectorType

C++ Syntax

HRESULT get_ConnectorType( long port, BSTR *connector)

HRESULT put_ConnectorType( long port, BSTR connector)

Interface

IGuidedCalibration

SMCType

VMCType


Read-only

Count Property

Description

Returns the number of items in a collection of objects.

VB Syntax

object.Count

Variable

(Type) - Description

object

Any of the following (objects):

Cal Sets collection
CalFactorSegments collection
Channels collection
LimitTest collection
Measurements collection
NAWindows collection
PowerLossSegments collection
PowerSensors collection
Segments collection
Traces collection

Return Type

Long Integer

Default

Not applicable

Examples

numofchans = chans.Count 'return the number of channels -Read

C++ Syntax

HRESULT get_Count(long *p<interface>)

Interface

ICal Sets
ICalFactorSegments
IChannels
ILimitTest
IMeasurements
INAWindows
IPowerLossSegments
IPowerSensors
ISegments
ITraces


Couple Ports Property

Write/Read
About Power Coupling

CouplePorts Property

Description

Turns ON and OFF port power coupling. ON means the power level is the same for both ports. OFF means the power level may be set independently for each port.

VB Syntax

object.CouplePorts = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(enum NAStates) Choose from:
0 - NaOff - Turns coupling OFF
1 - NaOn - Turns coupling ON

Retaurn Type

Long Integer
1 - ON
0 - OFF

Default

NaON (1)

Examples

chan.CouplePorts = NaOff 'Write

couplport = chan.CouplePorts 'Read

C++ Syntax

HRESULT get_CouplePorts(tagNAStates *pState)
HRESULT put_CouplePorts(tagNAStates newState)

Interface

IChannel

|CalSet3


Write/Read
About Time Domain Trace Coupling

CoupleChannelParams Property

Description

Turns ON and OFF Time Domain Trace Coupling. All of the measurements in the specified channel are coupled.

  • To select Transform parameters to couple, use Trans.CoupledParameters Property

  • To select Gating parameters to couple, use Gate.CoupledParameters Property

VB Syntax

chan.CoupleChannelParams = state

Variable

(Type) - Description

chan

A Channel (object)

state

(boolean)
0 - Turns Trace Coupling OFF
1 - Turns Trace Coupling ON

Return Type

Boolean

Default

1 - ON

Examples

chan.CoupleChannelParams = 1 'Write

couple = chan.CoupleChannelParams 'Read

C++ Syntax

HRESULT get_CoupleChannelParams(VARIANT_BOOL *isCoupled);

HRESULT put_CoupleChannelParams(VARIANT_BOOL isCoupled);

Interface

IChannel5


Write/Read

About Coupled Markers

CoupledMarkers Property

Description

Sets and Reads the state of Coupled Markers (ON and OFF)

VB Syntax

app.CoupledMarkers = state

Variable

(Type) - Description

app

(object) - An Application object

state

(boolean)
False (0) - Turns Coupled Markers OFF
True (1) - Turns Coupled Markers ON

Return Type

Boolean
0 - OFF
1 - ON

Default

OFF (0)

Examples

app.CoupledMarkers = True 'Write

coupl = app.CoupledMarkers 'Read

C++ Syntax

HRESULT put_CoupledMarkers(VARIANT_BOOL bState)
HRESULT get_CoupledMarkers(VARIANT_BOOL *bState)

Interface

IApplication


CoupledParameters Gate Property

Write/Read

About Time Domain Trace Coupling

CoupledParameters Property (Gating)

Description

Specifies the time domain gating parameters to be coupled. The settings for those parameters will be copied from the active measurement to all other measurements on the channel.

To turn coupling ON and OFF, use CoupleChannelParams Property

To specify Transform parameters to couple, use Transform.CoupledParameters Property

VB Syntax

gate.CoupledParameters = value

Variable

(Type) - Description

trans

A Gating (object)

value

(Enum As NAGatingCoupledParams) - Parameters to couple. To specify more than one parameter, add the numbers. Choose from:

1 - naGatingStimulusCoupled (Start, Stop, Center, and Span TIME settings.)

2 - naGateStateCoupled (ON / OFF)

4 - naGatingShapeCoupled (Minimum, Normal, Wide, and Maximum)

8 - naGatingTypeCoupled (Bandpass and Notch)

Return Type

Enum

Default

29

Examples

gate.CoupledParameters = 15 'Couple all parameters

CP = gate.CoupledParameters 'Read

C++ Syntax

HRESULT get_CoupledParameters(long *lParams);

HRESULT put_CoupledParameters(long lParams);

Interface

IGating2


CoupledParameters Transform Property

Write/Read

About Time Domain Trace Coupling

CoupledParameters Property (Transform)

Description

Specifies the time domain transform parameters to be coupled. The settings for those parameters will be copied from the active measurement to all other measurements on the channel.

To turn coupling ON and OFF, use CoupleChannelParams Property

To specify Gating parameters to couple, use Gate.CoupledParameters Property

VB Syntax

trans.CoupledParameters = value

Variable

(Type) - Description

trans

A Transform (object)

value

(Enum As NATransformCoupledParams) - Parameters to couple. To specify more than one parameter, add the numbers. Choose from:

1 - naTransformStimulusCoupled (Start, Stop, Center, and Span TIME settings.)

2 - naTransformStateCoupled (ON / OFF)

4 - naTransformWindowCoupled (Kaiser Beta / Impulse Width)

8 - naTransformModeCoupled (Low Pass Impulse, Low Pass Step, Band Pass)

16 - naTransformDistMkrUnitCoupled (Distance maker Units)

Return Type

Enum

Default

29

Examples

trans.CoupledParameters = 31 'Couple all parameters

CP = trans.CoupledParameters 'Read

C++ Syntax

HRESULT get_CoupledParameters(long *lParams);

HRESULT put_CoupledParameters(long lParams);

Interface

ITransform2


Write/Read

About CW Frequency

CW Frequency Property

Description

Set the Continuous Wave (CW) frequency. Must first send chan.SweepType = naCWTimeSweep

VB Syntax

object.CWFrequency = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(double) CW frequency. Choose any number between:
the minimum and maximum frequency limits of the anal yzer
Units are Hz

Return Type

Double

Default

1e9

Examples

chan.CWFrequency = 5e9 'Write

cwfreq = chan.CWFrequency 'Read

C++ Syntax

HRESULT put_CWFrequency(double newVal)
HRESULT get_CWFrequency(double *pVal)

Interface

IChannel

|CalSet3


Write/Read

About Modifying Cal Kits

Delay Property

Description

Sets and Returns the electrical delay value for the calibration standard.

VB Syntax

calstd.Delay = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Electrical delay in seconds

Return Type

Single

Default

Not Applicable

Exaamples

calstd.Delay = .00015 'Write the Delay .00015 seconds

stdDelay = calstd.Delay 'Read the value of Delay

C++ Syntax

HRESULT get_Delay(float *pVal)
HRESULT put_Delay(float newVal)

Interface

ICalStandard


Write/Read
About Reference Markers

DeltaMarker Property

Description

Sets a marker as a delta marker. The reference marker must already be turned ON. See meas.ReferenceMarkerState

VB Syntax

mark.DeltaMarker = state

Variable

(Type) - Description

app

A Marker (object)

state

(boolean) -
ON (1) marker is a delta marker
OFF (0) marker is NOT a delta marker

Return Type

Boolean

Default

OFF (0)

Examples

mark.DeltaMarker = True 'Write

delta = mark.DeltaMarker 'Read

C++ Syntax

HRESULT get_DeltaMarker(VARIANT_BOOL bState)
HRESULT put_DeltaMarker(VARIANT_BOOL *bState)

Interface

IMarker


Write / Read
About Cal Sets

Description Property

Description

Sets or returns the descriptive string assigned to the Cal Set. Change this string so that you can easily identify each Cal Set constructed.

VB Syntax

CalSet.Description = value

Variable

(Type) - Description

CalSet

(object) - A Cal Set object

value

(string) – Description of the Cal Set

Return Type

String

Default

“CalSet_n” where n is an integer number.

Examples

CalSet.Description = "My Cal Set" 'Write
desc = CalSet.Description 'Read

C++ Syntax

HRESULT get_Description(BSTR *pVal)

HRESULT put_Description(BSTR newVal);

Interface

ICalSet


Write/Read

About Data Format

Format Property

Description

Sets or returns the display format of the measurement.

VB Syntax

meas.Format = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(enum NADataFormat) - Choose from:

0 - naDataFormat_LinMag

1 - naDataFormat_LogMag

2 - naDataFormat_Phase

3 - naDataFormat_Polar

4 - naDataFormat_Smith

5 - naDataFormat_Delay

6 - naDataFormat_Real

7 - naDataFormat_Imaginary

8 - naDataFormat_SWR

Return Type

Long Integer

Default

1 - naDataFormat_LogMag

Examples

meas.Format = naDataFormat_Real 'Write

fmt = meas.Format 'Read

C++ Syntax

HRESULT get_Format(tagDataFormat *pVal)

HRESULT put_Format(tagDataFormat newVal)

Interface

IMeasurement


DisplayAutomationErrors

Write-Read

DisplayAutomationErrors Property

Description

Enables or disables automation error messages from being displayed on the screen.

VB Syntax

app.DisplayAutomationErrors = value

Variable

(Type) - Description

app

An application(object)

value

(Boolean)

True allows error to show on display,

False turns error off from display.

Return Type

Boolean

Default

True

Examples

Dim app As Application

Set app = New Application

app.DisplayAutomationErrors = False 'Turns off display

print app.DisplayAutomationErrors 'prints False

C++ Syntax

HRESULT get_DisplayAutomationErrors(VARIANT_BOOL * Val);

HRESULT put_DisplayAutomationErrors(VARIANT_BOOL Val);

Interface

IApplication2


Write-Read

DisplayGlobalPassFail Property

Description

Shows or hides the dialog which displays global pass/fail results. Learn more about Global Pass/Fail.

VB Syntax

app.DisplayGlobalPassFail = value

Variable

(Type) - Description

app

An Application (object)

value

(Boolean)

True (1) - displays the pass/fail dialog.

False(0) - hides the pass/fail dialog.

Return Type

Boolean

Default

False

Examples

Dim app As Application

Set app = New Application

app.DisplayGlobalPassFail = true 'shows dialog

C++ Syntax

HRESULT get_DisplayGlobalPassFail(VARIANT_BOOL * Val);

HRESULT put_DisplayGlobalPassFail(VARIANT_BOOL Val);

Interface

IApplication6


Write/Read
About Distance Markers

Distance Property

Description

Set or query marker distance on a time domain trace.

The Write command moves the marker to the specified distance value. Once moved, you can read the Y axis value or read the X-axis time value. (Distance is calculated from the X-axis time value.)

The Read command reads the distance of the marker.

If the marker is set as delta, the WRITE and READ data is relative to the reference marker.

VB Syntax

mark.Distance = value

Variable

(Type) - Description

mark

A Marker (object)

value

(double) - Marker distance in the unit of measure specified with DistanceMarkerUnit Property

Return Type

Double

Default

Not Applicable

Examples

mark.Distance = 3e9 'Write

XVal = mark.Distance 'Read

C++ Syntax

HRESULT get_Distance(double *pVal);

HRESULT put_Distance(double newVal);

Interface

IMarker2


Write/Read

About Distance MarkerSettings

DistanceMarkerMode Property

Description

Specifies the measurement type in order to determine the correct marker distance.

  • Select Auto for S-Parameter measurements.

  • Select Reflection or Transmission for arbitrary ratio or unratioed measurements.

This settings affects the display of ALL markers for only the ACTIVE measurement.

VB Syntax

trans.DistanceMarkerMode = value

Variable

(Type) - Description

trans

A Transform (object)

value

(enum As NADistanceMarkerMode) - Choose from:

0 - naDistanceMarkerModeAuto

1 - naDistanceMarkerModeReflection

2 - naDistanceMarkerModeTransmission

Return Type

Enum

Default

0 - naDistanceMarkerModeAuto

Examples

trans.DistanceMarkerMode = naDistanceMarkerModeReflection 'Write

DMM = trans.DistanceMarkerMode 'Read

C++ Syntax

HRESULT get_DistanceMarkerMode(tagNADistanceMarkerMode *pVal);

HRESULT put_DistanceMarkerMode(tagNADistanceMarkerMode newVal);

Interface

ITransform2


Write/Read

About Distance MarkerSettings

DistanceMarkerUnit Property

Description

Specifies the unit of measure for the display of marker distance values. This settings affects the display of ALL markers for only the ACTIVE measurement (unless Distance Maker Units are coupled using CoupledParameters Property.

VB Syntax

trans.DistanceMarkerUnit = value

Variable

(Type) - Description

trans

A Transform (object)

value

(Enum As NADistanceMarkerUnit) - Distance Marker Units. Choose from

0 - naDistanceMarkerUnitMeter

1 - naDistanceMarkerUnitFeet

2 - naDistanceMarkerUnitInch

Return Type

Enum

Default

0 - naDistanceMarkerUnitMeter

Examples

trans.DistanceMarkerUnit = naDistanceMarkerUnitFeet 'sets the

U = trans.DistanceMarkerUnit 'Read

C++ Syntax

HRESULT get_DistanceMarkerUnit(tagNADistanceMarkerUnit *pVal);

HRESULT put_DistanceMarkerUnit(tagNADistanceMarkerUnit newVal);

Interface

ITransform2


Read-Write

Do1PortEcal Property

Description

Specify ECAL or Mechanical calibration for the mixer characterization portion of a VMC calibration.

VB Syntax

VMC.Do1PortEcal = bool

Variable

(Type) - Description

VMC

VMCType (object)

bool

(Boolean)

1 - ECAL

0 - Mechanical

Return Type

Boolean

Default

0

Examples

value = VMC.Do1PortECal

C++ Syntax

HRESULT put_Do1PortEcal(VARIANT_BOOL bDoEcal);

HRESULT get_Do1PortEcal(VARIANT_BOOL *bDoEcal);

Interface

VMCType


Read-Write

Do2PortEcal Property

Description

Specify ECAL or Mechanical calibration. For VMC, this selection only applies to the 2-port calibration portion. For mixer characterization (VMC), use Do1PortEcal Property

VB Syntax

object.Do2PortEcal = bool

Variable

(Type) - Description

object

SMCType (object) or

VMCType (object)

bool

(Boolean)

1 - ECAL

0 - Mechanical

Return Type

Boolean

Default

0

Examples

value = VMC.Do2PortECal

C++ Syntax

HRESULT put_Do2PortEcal(VARIANT_BOOL bDoEcal);

HRESULT get_Do2PortEcal(VARIANT_BOOL *bDoEcal);

Interface

SMCType

VMCType


Domain_Property

Read-only

Domain Property

Description

Returns the domain (frequency,time, power) of the measurement. To understand how this property is useful, see IMeasurement2 Interface.

VB Syntax

value = meas.Domain

Variable

(Type) - Description

value

(Enum as NADomainType) - variable to store the returned value

0 - Frequency

1 - Time

2 - Power

meas

A Measurement (object)

Return Type

Enum as NADomainType

Default

Not Applicable

Examples

Print meas.Domain 'prints the value of the domain enum

C++ Syntax

HRESULT get_Domain(tagNADomainType * Val);

Interface

IMeasurement2


Dwell Time Property

Write/Read

About Dwell Time

DwellTime Property

Description

Sets or returns the dwell time at the start of each sweep point for all measurements in a channel. Dwell time is only available with Chan.SweepGenerationMode = naSteppedSweep (not naAnalogSweep).

Sets or returns the dwell time of a specified sweep segment.

VB Syntax

object.DwellTime = value

Variable

(Type) - Description

object

A Channel (object)

or CalSet (object) - Read-only property

or Segment (object)

value

(double) - Dwell Time in seconds. Choose any number between 0 and 86400

Return Type

Double

Default

0

Examples

chan.DwellTime = 3e-3 'sets the dwell time for the channel -Write

segs(3).DwellTime = 1e9 'sets the dwell time of segment 3 -Write

dwell = chan.DwellTime 'Read

C++ Syntax

HRESULT get_DwellTime(double *pVal)
HRESULT put_DwellTime(double newVal)

Interface

IChannel
ISegment

|CalSet3


ECALCharacterization Property

Write/Read

ECALCharacterization Property - Obsolete

Description

Note: This property is replaced by ECALCharacterizationEx Property.

Specifies the characterization data within an ECal module to be used for the calibration.

Learn more about ECal User Characterization.

VB Syntax

cal.ECALCharacterization(mod) = value

Variable

(Type) - Description

cal

Calibrator (object)

module

1- ECal module

value

(Long) – Characterization data within the ECal module to be used for ECal operations. Choose from:

0 – Factory Characterization

1 – UserCharacterization1

2 – UserCharacterization2

3 – UserCharacterization3

4 – UserCharacterization4

5 – UserCharacterization5

Return Type

Long

Default

0 - Factory Characterization

Interface

ICalibrator2


ECALCharacterization smc Property

Write/Read

ECALCharacterization Property

Description

Specifies the characterization data within an ECal module to be used for the SMC calibration.

Learn more about ECal User Characterization.

VB Syntax

SMC.ECALCharacterization(mod) = value

Variable

(Type) - Description

SMC

SMCType (object)

module

1- ECal module

value

(Long) – Characterization data within the ECal module to be used for ECal operations. Choose from:

0 – Factory Characterization

1 – UserCharacterization1

2 – UserCharacterization2

3 – UserCharacterization3

4 – UserCharacterization4

5 – UserCharacterization5

Return Type

Long

Default

0 - Factory Characterization

Examples

SMC.ECALCharacterization(1)= 2

C++ Syntax

HRESULT put_ECALCharacterization( long moduleNumber, long characterization);

HRESULT get_ECALCharacterization( long moduleNumber, long* characterization);

Interface

ICalibrator2


ECALCharacterization vmc Property

Write/Read

ECALCharacterization Property

Description

Specifies the characterization data within an ECal module to be used, and the portion of the VMC calibration.

Learn more about ECal User Characterization.

VB Syntax

VMC.ECALCharacterization (module,port) = value

Variable

(Type) - Description

VMC

VMCType (object)

module

(long integer)

1 - ECAL module

port

(boolean)

True - 2-port calibration portion of the VMC

False - 1-port (mixer characterization portion of the VMC cal

value

(Long) – Characterization data within the ECal module to be used for ECal operations. Choose from:

0 – Factory Characterization

1 – UserCharacterization1

2 – UserCharacterization2

3 – UserCharacterization3

4 – UserCharacterization4

5 – UserCharacterization5

Return Type

Long

Default

0 - Factory Characterization

Examples

VMC.ECALCharacterization (1,True) = 4

C++ Syntax

HRESULT put_ECALCharacterization( long moduleNumber, long characterization);

HRESULT get_ECALCharacterization( long moduleNumber, long* characterization);

Interface

ICalibrator2


Write/Read

ECALCharacterizationEx Property

Description

This property replaces ECALCharacterization Property.

Specifies the characterization data within an ECal module to be used for the calibration.

Learn more about ECal User Characterization.

VB Syntax

cal.ECALCharacterizationEx (module) = value

Variable

(Type) - Description

cal

Calibrator (object)

module

(long integer) Optional argument. ECal module.

Choose from modules 1 through 8

Use IsECALModuleFoundEx to determine the number of modules connected to the PNA

Use GetECALModuleInfoEx to returns the model and serial number of each module.

value

(Long) – Characterization data within the ECal module to be used for ECal operations. Choose from:

0 – Factory Characterization

1 – UserCharacterization1

2 – UserCharacterization2

3 – UserCharacterization3

4 – UserCharacterization4

5 – UserCharacterization5

Return Type

Long

Default

0 - Factory Characterization

Examples

cal.ECALCharacterizationEx (4) = 2

C++ Syntax

HRESULT put_ECALCharacterizationEx( long moduleNumber, long characterization);

HRESULT get_ECALCharacterizationEx( long moduleNumber, long* characterization);

Interface

ICalibrator4


Read-only

ECALCharacterizationIndexList Property

Description

Returns a list of characterizations stored in the specified ECal module. Learn more about ECal User characterization.

VB Syntax

clist = cal.ECALCharacterizationIndexList (moduleNum)

Variable

(Type) - Description

clist

Variable to store the returned list of characterization index numbers.

cal

Calibrator (object)

module

ECal module from which to read user characterization numbers.

Return Type

Variant

Default

Not Applicable

Examples

'Module 1 contains User Characterizations 1 and 3.
clist = cal.ECALCharacterizationIndexList(1)
'Returns the following (0 always indicates the factory characterization):
0,1,3

C++ Syntax

HRESULT get_ECALCharacterizationIndexList( long moduleNumber, VARIANT *characterizations);

Interface

ICalibrator6


Read/Write
About ECAL

ECALIsolation Property

Description

Specifies whether the acquisition of the ECal calibration should include isolation or not.

Note: This command is ignored on PNA release 4.26 and greater. Isolation is never performed with ECal as the inherent isolation of the PNA is better than that achieved with ECal.

VB Syntax

cal.ECALIsolation = value

Variable

(Type) - Description

cal

A Calibrator (object)

value

(boolean)

False (0) - Exclude Isolation

True (1) - Include Isolation

Return Type

Boolean

Default

False (0)

Examples

Dim oPNA as AgilentPNA835x.Application

Dim oCal as Calibrator

Set oPNA = CreateObject("AgilentPNA835x.Application", "MachineName")

Set oCal = oPNA.ActiveChannel.Calibrator

' Uncomment the following line to have the cal include isolation

' oCal.ECALIsolation = True

' Uncomment the following line to have the cal omit isolation

'oCal.ECALIsolation = False

oCal.DoECAL2Port ' Do the cal

C++ Syntax

HRESULT put_ECALIsolation ( VARIANT_BOOL bIsolationState );

HRESULT get_ECALIsolation ( VARIANT_BOOL *bIsolationState );

Interface

Calibrator


Read-only

ECALModuleNumberList Property

Description

Returns a list of index numbers to be used for referring to the ECal modules that are currently attached to the PNA.

VB Syntax

clist = cal.ECALModuleNumberList

Variable

(Type) - Description

clist

Variable to store the returned list of index numbers.

cal

Calibrator (object)

Return Type

Variant

Default

Not Applicable

Examples

clist = cal.ECALModuleNumberList
'If 2 modules are attached to the PNA
'then the returned list will be:
1,2

C++ Syntax

HRESULT get_ECALModuleNumberList( VARIANT *modules);

Interface

ICalibrator6


Read/Write

EcalOrientation Property

Description

Specifies which port of the ECal module is connected to which port of the PNA when the AutoOrient property = False.

VB Syntax

SMC.EcalOrientation (mod) = value

Variable

(Type) - Description

SMC

SMCType (object)

mod

(Long)

1 - Use ECAL Module for the calibration.

value

(string) -Format this parameter in the following manner:

Aw,Bx,Cy,Dz

where

  • A, B, C, and D are literal ports on the ECAL module

  • w,x,y, and z are substituted for PNA port numbers to which the ECAL module port is connected.

Ports of the module which are not used are omitted from the string.

For example, on a 4-port ECal module with

  • port A connected to PNA port 2

  • port B connected to PNA port 3

  • port C not connected

  • port D connected to PNA port 1

the string would be: A2,B3,D1

Return Type

String

Default

"A1,B2"

Examples

SMC.EcalOrientation (1) = "A2,B1"

C++ Syntax

HRESULT put_EcalOrientation(long lModuleNum, BSTR orientation);

HRESULT get_EcalOrientation(long lModuleNum, BSTR *orientation);

Interface

SMCType


Read/Write

EcalOrientation1Port Property

Description

For Mixer Characterization ONLY Specifies which port of the ECal module is connected to which port of the PNA for the Do1PortECAL property when the AutoOrient property = False.

VB Syntax

VMC.EcalOrientation1Port (mod) = value

Variable

(Type) - Description

VMC

VMCType (object)

mod

(Long)

1 - Use ECAL Module for the calibration.

value

(string) - Choose from:

"A1" - ECAL module port A is connected to PNA port 1

"B1" - ECAL module port A is connected to PNA port 1

Return Type

String

Default

"A1"

If anything other than port 1 is specified, "B1" will be used. For example, if "A2" is specified, "B1" is used.

Examples

VMC.EcalOrientation1Port(1) = "B1"

C++ Syntax

HRESULT put_EcalOrientation1Port(long lModuleNum, BSTR orientation);

HRESULT get_EcalOrientation1Port(long lModuleNum, BSTR

Interface

VMCType


Read/Write

EcalOrientation2Port Property

Description

Specifies which port of the ECal module is connected to which port of the PNA for the Do2PortECAL property when the AutoOrient property = False.

VB Syntax

VMC.EcalOrientation2Port (mod) = value

Variable

(Type) - Description

VMC

VMCType (object)

mod

(Long) Module being used for the calibration.

Choose from 1 or 2.

value

(string) -Format this parameter in the following manner:

Aw,Bx,Cy,Dz

where

  • A, B, C, and D are literal ports on the ECAL module

  • w,x,y, and z are substituted for PNA port numbers to which the ECAL module port is connected.

Ports of the module which are not used are omitted from the string.

For example, on a 4-port ECal module with

  • port A connected to PNA port 2

  • port B connected to PNA port 3

  • port C not connected

  • port D connected to PNA port 1

the string would be: A2,B3,D1

Return Type

String

Default

"A1,B2"

Examples

VMC.EcalOrientation1Port(1) = "A2,B1"

C++ Syntax

HRESULT put_EcalOrientation2Port(long lModuleNum, BSTR orientation);

HRESULT get_EcalOrientation2Port(long lModuleNum, BSTR *orientation);

Interface

VMCType


ECALPortMapEx_Property

Write/Read

ECALPortMapEx Property

Description

This property replaces ECALPortMap Property

Specifies which ports of the ECal module are connected to which ports of the PNA for the DoECAL1PortEx and DoECAL2PortEx methods when the OrientECALModule property = False.

VB Syntax

cal.ECALPortMapEx (module) = value

Variable

(Type) - Description

cal

A Calibrator (object)

module

(long integer) Optional argument. ECal module.

Choose from modules 1 through 8

Use IsECALModuleFoundEx to determine the number of modules connected to the PNA

Use GetECALModuleInfoEx to return the model and serial number of each module.

value

(string) -Format this parameter in the following manner:

Aw,Bx,Cy,Dz

where

  • A, B, C, and D are literal ports on the ECAL module

  • w,x,y, and z are substituted for PNA port numbers to which the ECAL module port is connected.

Ports of the module which are not used are omitted from the string.

For example, on a 4-port ECal module with

  • port A connected to PNA port 2

  • port B connected to PNA port 3

  • port C not connected

  • port D connected to PNA port 1

the string would be: A2,B3,D1

DoECAL1PortEx or DoECAL2PortEx methods will fail if the port numbers passed to those methods are not in the string of this property and OrientECALModule property = False.

Return Type

String

Default

Not Applicable

Examples

Dim cal As Calibrator
Dim sPortMap As String
Set cal = PNAapp.ActiveChannel.Calibrator
cal.ECALPortMapEx = “a2,b1” 'Write
sPortMap = cal.ECALPortMap 'Read

C++ Syntax

HRESULT put_ECALPortMapEx( long moduleNumber, BSTR strPortMap);

HRESULT get_ECALPortMapEx( long moduleNumber, BSTR *strPortMap);

Interface

ICalibrator4


ElecDelayMedium_Property

Write/Read

ElecDelayMedium Property

Description

Sets or returns the electrical delay medium.

VB Syntax

meas.ElecDelayMedium = value

Variable

(Type) - Description

meas

A Measurement (object)

value

( enum NACalStandardMedium ) choose from

0 - naCoax

1 - naWaveGuide

Return Type

NACalStandardMedium

Default

Not Applicable

Examples

Print meas.ElecDelayMedium 'prints the value of the electrical delay medium

C++ Syntax

HRESULT get_ElecDelayMedium(tagNACalStandardMedium *pVal);

HRESULT put_ElecDelayMedium(tagNACalStandardMedium newVal);

Interface

IMeasurement2


Electrical Delay Property

Write/Read
About Electrical Delay

ElectricalDelay Property

Description

Sets the Electrical Delay for the active channel.

VB Syntax

meas.ElectricalDelay = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - Electrical Delay in seconds. Choose any number between -9.99 and 9.99

Return Type

Double

Default

0

Examples

meas.ElectricalDelay = 1e-3 'Write

edelay = meas.ElectricalDelay 'Read

C++ Syntax

HRESULT get_ElectricalDelay(double *pVal)
HRESULT put_ElectricalDelay(double newVal)

Interface

IMeasurement


Error Correction Property

Write/Read
About Performing a Calibration

ErrorCorrection Property

Description

Sets (or returns) error correction ON or OFF for the measurement.

VB Syntax

meas.ErrorCorrection = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
0 - Turns error correction OFF
1 - Turns error correction ON

Return Type

Boolean

Default

Not Applicable

Examples

meas.ErrorCorrection = 1 'Write

errcorr = meas.ErrorCorrection 'Read

C++ Syntax

HRESULT put_ErrorCorrection (VARIANT_BOOL bState)
HRESULT get_ErrorCorrection (VARIANT_BOOL *bState)

Interface

IMeasurement


External ALC Property

Write/Read

ExternalALC Property

Description

Sets or returns the source of the analyzer leveling control.

VB Syntax

app.ExternalALC = value

Variable

(Type) - Description

app

An Application (object)

value

(boolean) - Choose from:
True (or 1) - Leveling control supplied through the rear panel.
False (or 0) - Leveling control supplied inside the analyzer

Return Type

Boolean

Default

0

Examples

app.ExternalALC = True 'Write

extALC = app.ExternalALC 'Read

C++ Syntax

HRESULT get_ExternalALC(VARIANT_BOOL *pVal)
HRESULT put_ExternalALC(VARIANT_BOOL newVal)

Interface

IApplication


Write/Read.

About Trigger

ExternalTriggerConnectionBehavior Property

Description

Configures the external triggering signal for the PNA. To receive trigger signals from an external source, TriggerSouce Property must be set to External.

Edge triggering is only available on some PNA models. For more information, see External Triggering.

VB Syntax

trigsetup.ExternalTriggerConnectionBehavior (conn) = value

Variable

(Type) - Description

trigsetup

A TriggerSetup (object)

conn

(enum NATriggerConnection) Rear Panel connector to send or receive trigger signals. Choose from:

Only one of the input connectors is active at a time. When a command is sent to one, the PNA automatically makes the other INACTIVE.

0 - naTriggerConnectionAUXT Trigger IN from external source (AUX IO connector Pin 19)

1 - naTriggerConnectionBNC1 Trigger IN from external source (Trigger IN BNC connector)

2 - naTriggerConnectionBNC2 Trigger OUT (Trigger OUT BNC connector). Only useful in point sweep mode.

value

(enum NAExternalTriggerBehavior) -

0 - naTriggerInactive - Disables the specified connector.

Choose from ONLY 1 through 4 when <conn> is set to either naTriggerConnectionBNC1 or naTriggerConnectionAUXT

1 - naTriggerInEdgeNegative - Triggers the PNA when receiving a negative going signal

2 - naTriggerInEdgePositive - Triggers the PNA when receiving a positive going signal

3 - naTriggerInLevelLow - Triggers the PNA when receiving a low level signal

4 - naTriggerInLevelHigh - Triggers the PNA when receiving a High-level signal

Choose from ONLY 5 through 8 when <conn> is set to naTriggerConnectionBNC2.

In addition to sending this command, you must also use TriggerOutputEnabled Property to enable the BNC2 output.

5 - naTriggerOutPulsePositiveAfter - Sends a POSITIVE going TTL pulse at the END of each point during the sweep.

6 - naTriggerOutPulsePositiveBefore - Sends a POSITIVE going TTL pulse at the START of each point during the sweep.

7 - naTriggerOutPulseNegativeAfter - Sends a NEGATIVE going TTL pulse at the END of each point during the sweep.

8 - naTriggerOutPulseNegativeBefore - Sends a NEGATIVE going TTL pulse at the START of each point during the sweep.

Return Type

Enum as NAExternalTriggerBehavior

Default

BNC1 = naTriggerInactive

BNC2 = naTriggerInactive

AUXT = naTriggerInLevelHigh

When Output is enabled

BNC1 = naTriggerInactive

BNC2 = naTriggerOutPulsePositiveAfter

AUXT = naTriggerInLevelHigh

Examples

trigsetup.ExternalTriggerConnectionBehavior (naTriggerConnectionAUXT) = naTriggerInLevelLow 'Write

trigBehav = trigsetup.ExternalTriggerConnectionBehavior (naTriggerConnectionAUXT) 'Read

C++ Syntax

HRESULT get_ExternalTriggerConnectionBehavior(tagNATriggerConnection connection,tagNAExternalTriggerBehavior *trigger);

HRESULT put_ExternalTriggerConnectionBehavior(tagNATriggerConnection connection,tagNAExternalTriggerBehavior trigger);

Interface

ITriggerSetup


Write/Read

About Trigger

ExternalTriggerDelay Property

Description

Sets and reads the trigger delay for all measurements in the CHANNEL. This delay is only applied while in app.Source = naTriggerSourceExternal and trigsetup.Scope = naChannelTrigger . After an external trigger is applied, the start of the sweep is delayed for the specified delay value plus any inherent latency.

To apply a trigger delay for all channels (Global), use TriggerDelay Property.

VB Syntax

chan.ExternalTriggerDelay = value

Variable

(Type) - Description

chan

A Channel (object)

value

Double- Trigger delay value in seconds. Range is from 0 to 107 seconds

Return Type

Double

Default

0

Examples

chan.ExternalTriggerDelay = .003 'Write

delay = chan.ExternalTriggerDelay 'Read

C++ Syntax

HRESULT get_ExternalTriggerDelay(double *delay);

HRESULT put_ExternalTriggerDelay(double delay)

Interface

IChannel6


Filter BW Property

Read-only

About Marker Search

FilterBW Property

Description

Returns the results of the SearchBandwidth method.

VB Syntax

filtBW = meas.FilterBW

Variable

(Type) - Description

filtBW

(single) - Variable to store bandwidth data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filterBW = meas.FilterBW 'Read

C++ Syntax

HRESULT get_FilterBW(float* bw)

Interface

IMeasurement


Filter CF Property

Read-only

About Marker Search

FilterCF Property

Description

Returns the Center Frequency result of the SearchBandwidth method.

VB Syntax

filtCF = meas.FilterCF

Variable

(Type) - Description

filtCF

(double) - Variable to store bandwidth CF data

meas

A Measurement (object)

Return Type

Double

Default

Not applicable

Examples

filtCF = meas.FilterCF 'Read

C++ Syntax

HRESULT get_FilterCF(double* centerFrequency)

Interface

IMeasurement


Filter Loss Property

Read-only

About Marker Search

FilterLoss Property

Description

Returns the Loss value of the SearchBandwidth method.

VB Syntax

filtLoss = meas.FilterLoss

Variable

(Type) - Description

filtLoss

(single) - Variable to store bandwidth Loss data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filterLoss = meas.FilterLoss 'Read

C++ Syntax

HRESULT get_FilterLoss(float* loss)

Interface

IMeasurement


Filter Q Property

Read-only

About Marker Search

FilterQ Property

Description

Returns the Q (quality factor) result of the SearchBandwidth method.

VB Syntax

filtQ = meas.FilterQ

Variable

(Type) - Description

filtQ

(single) - Variable to store bandwidth Q data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filtQ = meas.FilterQ 'Read

C++ Syntax

HRESULT get_FilterQ(float* quality)

Interface

IMeasurement


Read only
About PNA Options

FirmwareMajorRevision Property

Description

Returns the major firmware revision number as an integer. For example, given a firmware revision number A.03.30, this command returns 3.

VB Syntax

value = cap.FirmwareMajorRevision

Variable

(Type) - Description

value

(Long) - Variable to store the returned integer value of the firmware revision number.

cap

A Capabilities (object)

Return Type

Long

Default

Not Applicable

Examples

value = cap.FirmwareMajorRevision 'Read

C++ Syntax

HRESULT get_FirmwareMajorRevision(long * majorRev );

Interface

ICapabilities


FirmwareMinorRevision

Read only
About PNA Options

FirmwareMinorRevision Property

Description

Returns the minor firmware revision number as an integer. For example, given a firmware revision number A.03.30, this command returns 30.

VB Syntax

value = cap.FirmwareMinorRevision

Variable

(Type) - Description

value

(Long) - Variable to store the returned decimal value of the firmware revision number.

cap

A Capabilities (object)

Return Type

Long

Default

Not Applicable

Examples

value = cap.FirmwareMinorRevision 'Read

C++ Syntax

HRESULT get_FirmwareMinorRevision(long * minorRev );

Interface

ICapabilities


Read only
About PNA Options

FirmwareSeries Property

Description

Returns the alpha portion of the firmware revision number. For example, given a firmware revision number A.03.30, this command returns A.

VB Syntax

value = cap.FirmwareSeries

Variable

(Type) - Description

value

(String) - Variable to store the returned alpha value of the firmware revision number.

cap

A Capabilities (object)

Return Type

String

Default

Not Applicable

Examples

value = cap.FirmwareSeries 'Read

C++ Syntax

HRESULT get_FirmwareSeries(BSTR * series);

Interface

ICapabilities


Read-only

FootSwitch Property

Description

Reads the Footswitch Input (pin 20 of the AUX IO connector).

VB Syntax

value = AuxIO.Footswitch

Variable

(Type) - Description

value

(boolean) - Variable to store the returned value

False (0) -foot switch is released

True (1) - footswitch is depressed

AuxIO

(object) - A Hardware Aux I/O object

Return Type

Boolean

Default

True (1)

Examples

fs = aux.Footswitch

C++ Syntax

HRESULT get_FootSwitch ( VARIANT_BOOL* State );

Interface

IHWAuxIO


FootswitchMode Property

Description

Determines what occurs when the footswitch is pressed. For more information see the FootSwitch In pin description in the Auxiliary IO connector.

VB Syntax

AuxIo.FootSwitchMode = value

Variable

(Type) - Description

value

(enum NAFootSwitchMode )

0 - naIgnoreFootswitch - Footswitch presses are ignored.

1 - naSweepTrigger - Footswitch presses trigger a sweep. The PNA must be in Manual Trigger Mode.

2 - naRecallNextState - Footswitch presses recall an instrument state. When more than one state is available, then each footswitch press recalls the next state, then starts over from the beginning. It is possible for a recalled state to override the current mode. If the recalled state is IGNore, then mode changes and additional footswitch presses are ignored.

3 - naRunMacro - Footswitch presses load and run a macro. When more than one macro is available, then each footswitch press loads and runs the next macro, then starts over from the beginning. It is possible for a Macro to override the current mode. If the macro contains a Preset, then the mode changes to the default setting IGNore and additional footswitch presses are ignored.

AuxIO

(object) - A Hardware Aux I/O object

Return Type

NAFootSwitchMode

Default

0 - naIgnoreFootswitch

Examples

auxIo.FootSwitchMode = naIgnoreFootSwitch 'Write

C++ Syntax

HRESULT get_FootSwitchMode(NAFootSwitchMode *pFootSwitchMode )

HRESULT put_FootSwitchMode(NAFootSwitchMode newFootSwitchMode)

Interface

IHWAuxIO3


Format (Marker) Property

Write/Read
About Marker Format

Format Property (marker)

Description

Sets (or returns) the format of the marker.

VB Syntax

mark.Format = value

Variable

(Type) - Description

mark

A Marker (object)

value

(enum NAMarkerFormat) - Choose from:

0 - naMarkerFormat_LinMag
1 - naMarkerFormat_LogMag
2 - naMarkerFormat_Phase
3 - naMarkerFormat_Delay
4 - naMarkerFormat_Real
5 - naMarkerFormat_Imaginary
6 - naMarkerFormat_SWR
7 - naMarkerFormat_LinMagPhase
8 - naMarkerFormat_LogMagPhase
9 - naMarkerFormat_RealImaginary
10 - naMarkerFormat_ComplexImpedance
11 - naMarkerFormat_ComplexAdmittance

Return Type

NAMarkerFormat

Default

1 - naMarkerFormat_LogMag

Examples

mark.Format = naMarkerFormat_SWR 'Write

fmt = mark.Format 'Read

C++ Syntax

HRESULT get_Format(tagNAMarkerFormat *pVal)
HRESULT put_Format(tagNAMarkerFormat newVal)

Interface

IMarker


Write / Read
About Source Power Cal

Frequency Property

Description

Sets or returns the frequency associated with a PowerSensorCalFactorSegment

or

Sets or returns the frequency associated with a PowerLossSegment.

VB Syntax

object.Frequency = value

Variable

(Type) - Description

object

(object) - PowerSensorCalFactorSegment or PowerLossSegment

value

(double) – Frequency in units of Hz. This can be any non-negative value (limited by the maximum value of double).

Return Type

Double

Default

0

Examples

seg.Frequency = 6e9 'Write
freq = seg.Frequency 'Read

C++ Syntax

HRESULT put_Frequency(double newVal);

HRESULT get_Frequency(double *pVal);

Interface

IPowerSensorCalFactorSegment

IPowerLossSegment


Frequency Span Property

Write/Read

About Frequency Range

FrequencySpan Property

Description

Sets or returns the frequency span of the channel.

Sets or returns the frequency span of the segment.

VB Syntax

object.FrequencySpan = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Frequency span in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Full frequency span of the analyzer

Examples

chan.FrequencySpan = 4.5e9 'sets the frequency span of a linear sweep for the channel object -Write

freqspan = chan.FrequencySpan 'Read

C++ Syntax

HRESULT get_FrequencySpan(double *pVal)
HRESULT put_FrequencySpan(double newVal)

Interface

IChannel
ISegment


Write/Read
About Frequency Offset

FrequencyOffsetDivisor Property

Description

Specifies (along with FrequencyOffsetMultiplier) the value to multiply by the stimulus.

See other Frequency Offset properties

VB Syntax

object.FrequencyOffsetDivisor = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(Double) - Divisor value. Range is 1 to 1000

Return Type

Double

Default

1

Examples

chan.FrequencyOffsetDivisor = 2 'Write

fOffsetDiv = chan.FrequencyOffsetDivisor 'Read

C++ Syntax

HRESULT get_FrequencyOffsetDivisor(double*pval)

HRESULT put_FrequencyOffsetDivisor(double newVal)

Interface

IChannel2

|CalSet3


Write/Read
About Frequency Offset

FrequencyOffsetFrequency Property

Description

Specifies an absolute offset frequency in Hz. For mixer measurements, this would be the LO frequency. See other Frequency Offset properties.

VB Syntax

object.FrequencyOffsetFrequency = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(Double) - Offset value. Range is +/- 1000 GHz. (Offsets can be positive or negative.)

Return Type

Double

Default

0 Hz

Examples

chan.FrequencyOffsetFrequency = 2 'Write

fOffsetFreq = chan.FrequencyOffsetFrequency 'Read

C++ Syntax

HRESULT get_FrequencyOffsetFrequency(double*pval)
HRESULT put_FrequencyOffsetFrequency(double newVal)

Interface

IChannel2

|CalSet3


Write/Read
About Frequency Offset

FrequencyOffsetMultiplier Property

Description

Specifies (along with FrequencyOffsetDivisor) the value to multiply by the stimulus. See other Frequency Offset properties.

VB Syntax

object.FrequencyOffsetMultiplier = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(Double) - Multiplier value. Range is 1 to 1000

Return Type

Double

Default

1

Examples

chan.FrequencyOffsetMultiplier = 2 'Write

fOffsetMult = chan.FrequencyOffsetMultiplier 'Read

C++ Syntax

HRESULT get_FrequencyOffsetMultiplier (double*pval);
HRESULT put_FrequencyOffsetMultiplier (double newVal);

Interface

IChannel2

|CalSet3


Write/Read
About Frequency Offset

FrequencyOffsetCWOverride Property

Description

Establishes a fixed (CW) stimulus frequency while measuring the Response over a swept frequency range. For example, a fixed-frequency PNA stimulus may be applied to the RF input of a mixer whose local oscillator (LO) is being swept. Because the IF output of the mixer will be swept, the PNA receivers must also be swept.

See other Frequency Offset properties.

VB Syntax

object.FrequencyOffsetCWOverride = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(Enum as NaStates) - Choose from:

naOFF (0) - Turns CW override OFF

naON (1) - Turns CW override ON

Return Type

Enum

Default

0 Hz

Examples

chan.FrequencyOffsetCWOverride = 1 'Write

fOffsetOV = chan.FrequencyOffsetCWOverride 'Read

C++ Syntax

HRESULT get_FrequencyOffsetCWOverride (tagNAStates *pstate)
HRESULT put_FrequencyOffsetCWOverride (tag NAStates newState)

Interface

IChannel2

|CalSet3


Write/Read
About Frequency Offset

FrequencyOffsetState Property

Description

Enables Frequency Offset on ALL measurements that are present on the active channel. This immediately causes the source and receiver to tune to separate frequencies. The receiver frequencies are specified with other channel and offset settings. To make the stimulus settings, use Channel Start, Stop Frequency properties. See other Frequency Offset properties.

Tip: To avoid unnecessary errors, first make other frequency offset settings. Then turn Frequency Offset ON.

VB Syntax

object.FrequencyOffsetState = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(Enum as NaStates) - Choose from:

naOFF (0) - Turns Frequency Offset OFF

naON (1) - Turns Frequency Offset ON

Return Type

Enum

Default

naOFF (0)

Examples

chan.FrequencyOffsetState = True 'Write

Foffset = chan.FrequencyOffsetState 'Read

C++ Syntax

HRESULT FrequencyOffsetState (tag NAStates *pState);
HRESULT FrequencyOffsetState (tag NAStates newState)

Interface

IChannel2

|CalSet3


Write/Read
About Gating

Shape Property

Description

Specifies the shape of the gate filter.

VB Syntax

gat.Shape = value

Variable

(Type) - Description

gat

A Gating (object)

value

(enum NAGateShape) - Choose from:

0 - naGateShapeMaximum
1 - naGateShapeWide
2 - naGateShapeNormal
3 - naGateShapeMinimum

Return Type

NAGateShape

Default

2 - Normal

Examples

gat.Shape = naGateShapeMaximum 'Write

filterShape = gat.Shape 'Read

C++ Syntax

HRESULT get_Shape(tagNAGateShape *pVal)
HRESULT put_Shape(tagNAGateShape newVal)

Interface

IGating


Type (Gate) Property

Write/Read

About Time Domain

Type Property

Description

Specifies the type of gate filter used.

VB Syntax

gat.Type = value

Variable

(Type) - Description

gat

A Gating (object)

value

(enum NAGateType) - Choose from:
0 - naGateTypeBandpass - Includes (passes) the range between the start and stop times.
1 - naGateTypeNotch - Excludes (attenuates) the range between the start and stop times.

Return Type

NAGateType

Default

Bandpass

Examples

gate.Type = naGateTypeNotch 'Write

filterType = gate.Type 'Read

C++ Syntax

HRESULT get_Type(tagNAGateType *pVal)
HRESULT put_Type(tagNAGateType newVal)

Interface

IGating


Write-Read
About GPIB Fundamentals

GPIBAddress Property

Description

Sets and returns the PNA GPIB address bus.

VB Syntax

app.GPIBAddress (bus) = value

Variable

(Type) - Description

app

An Application (object)

bus

(Short Integer) GPIB bus. MUST be set to 0.

value

(Short Integer) GPIB Address on the PNA. Choose a value between 0 and 30.

Return Type

Short Integer

Default

16

Examples

address=app.GPIBAddress(0) 'Read

app.GPIBAddress(0)=16 'Write

C++ Syntax

HRESULT get_GPIBAddress(short busIndex, short* address);

HRESULT put_GPIBAddress(short busIndex,short address);

Interface

IApplication8


Write/Read

About GPIB Fundamentals

GPIBMode Property

Description

Changes the analyzer to a GPIB system controller or a talker/listener on the bus. The analyzer must be the controller if you want to use it to send commands to other instruments. The analyzer must be a talker/listener if you want to send it commands from another PC.

VB Syntax

app.GPIBMode value

Variable

(Type) - Description

app

An Application (object)

value

(enum NAGPIBMode) -Choose either:
0 - naTalkerListener - the analyzer is a talker / listener
1 - naSystemController - the analyzer is the system controller

Return Type

Long Integer

Default

0 - naTalkerListener

Examples

app.GPIBMode = naTalkerListener 'Write

mode = app.GPIBMode 'Read

C++ Syntax

HRESULT get_GPIBMode(tagGPIBModeEnum* eGpibMode)
HRESULT put_GPIBMode(tagGPIBModeEnum eGpibMode)

Interface

IApplication


Read-only

IDString Property

Description

Returns the ID of the analyzer, including the Model number, Serial Number, and the Software revision number.

VB Syntax

value = app.IDString

Variable

(Type) - Description

app

An Application (object)

value

(string) - variable to contain the returned ID string

Return Type

String

Default

Not Applicable

Examples

id = app.IDString

C++ Syntax

HRESULT IDString(BSTR* IDString)

Interface

IApplication


IF Bandwidth Option Property

Write/Read

About Segment Sweep

IFBandwidthOption Property

Description

Enables the IFBandwidth to be set on individual sweep segments. This property must be set True before seg.IFBandwidth = value is sent. Otherwise, this command will be ignored.

VB Syntax

segs.IFBandwidthOption = value

Variable

(Type) - Description

segs

A Segments collection (object)

value

(boolean)
True - Enables variable IFBandwidth setting for segment sweep
False - Disables variable IFBandwidth setting for segment sweep

Return Type

Boolean

Default

False

Examples

segs.IFBandwidthOption = True 'Write

IFOption = IFBandwidthOption 'Read

C++ Syntax

HRESULT get_IFBandwidthOption(VARIANT_BOOL *pVal)
HRESULT put_IFBandwidthOption(VARIANT_BOOL newVal)

Interface

ISegments


IF Bandwidth Property

Write/Read

About IF Bandwidth

IFBandwidth Property

Description

Sets or returns the IF Bandwidth of the channel.

Sets or returns the IF Bandwidth of the segment.

Returns the IF Bandwidth used in the Cal Set

VB Syntax

object.IFBandwidth = value

Variable

(Type) - Description

object

Channel (object)

or

Segment (object)

or

CalSet (object) - Read-only property

value

(double) - IF Bandwidth in Hz. The list of valid IF Bandwidths is different depending on the PNA model. (Click to see the lists.) If an invalid number is specified, the analyzer will round up to the closest valid number.

Return Type

Double

Default

See Preset IFBW for your PNA model.

Examples

chan.IFBandwidth = 3e3 'sets the IF Bandwidth of for the channel object to 3 kHz. -Write
seg.IFBandwidth = 5 'sets the IF Bandwidth of the segment to 5 Hz. -Write

ifbw = chan.IFBandwidth -Read

C++ Syntax

HRESULT get_IFBandwidth(double *pVal);
HRESULT put_IFBandwidth(double newVal);

Interface

IChannel
ISegment

|CalSet3


IFDenominator_Property

Write/Read
About Mixer Configuration

IFDenominator Property

Description

Sets or returns the denominator value of the IF Fractional Multiplier.

Only applies to 2 stage mixers!

VB Syntax

mixer.IFDenominator = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(long) IF Denominator value.

Return Type

Long

Default

1

Examples

Print mixer.IFDenominator 'prints the value of the IFDenominator

C++ Syntax

HRESULT get_IFDenominator(long *pVal)

HRESULT put_IFDenominator(long newVal)

Interface

IMixer


Write/Read
About Pulsed Application

IFFilterSampleCount Property

Description

Sets or retrieves the number of taps in the IF filter when the IFFilterSource property is set to naIFFilterSourceManual.

Note: An error will occur if this command is used on a PNA without option H08 installed.

VB Syntax

IfConfig.IFFilterSampleCount = value

Variable

(Type) - Description

IfConfig

IFConfiguration (object)

value

(long) – The IF filter sample count. The minimum and maximum allowed values for this property can vary by model number, but can be queried using the MinimumIFFilterSampleCount and MaximumIFFilterSampleCount properties.

Return Type

Long Integer

Default

PNA Model number dependent

Examples

App.ActiveChannel.IFConfiguration.IFFilterSampleCount = 200 'Write

variable = App.ActiveChannel.IFConfiguration.IFFilterSampleCount 'Read

See an example program

C++ Syntax

HRESULT get_IFFilterSampleCount( long * pSampleCount );

HRESULT put_IFFilterSampleCount ( long sampleCount );

Interface

IIFConfiguration2


Write/Read
About Pulsed Application

IFFilterSamplePeriod Property

Description

Sets or returns the IF filter sample period time. This time is only used if the IFFilterSamplePeriodMode is set to naManual.

Note: An error will occur if this command is used on a PNA without option H08 installed.

VB Syntax

IfConfig.IFFilterSamplePeriod = value

Variable

(Type) - Description

IfConfig

IFConfiguration (object)

value

(double) – The sample period time in seconds. Valid sample period times can be queried using the IFFilterSamplePeriodList property.

Return Type

Double

Default

PNA Model number dependent.

Examples

App.ActiveChannel.IFConfiguration.IFFilterSamplePeriod = .000006 'Write

variable = App.ActiveChannel.IFConfiguration.IFFilterSamplePeriod 'Read

See an example program

C++ Syntax

HRESULT get_IFFilterSamplePeriod( double * pSamplePeriod );

HRESULT put_IFFilterSamplePeriod ( double samplePeriod );

Interface

IIFConfiguration2


Read-only
About Pulsed Application

IFFilterSamplePeriodList Property

Description

Retrieves the list of available IF filter sample periods for the instrument.

Note: An error will occur if this command is used on a PNA without option H08 installed.

VB Syntax

variable = IfConfig.IFFilterSamplePeriodList

Variable

(Type) - Description

variable

(Array) An array of permissible values that can be passed to the IFFilterSamplePeriod property.

IfConfig

IFConfiguration (object)

Return Type

Array

Default

Not applicable

Examples

Dim Variable
Variable = App.ActiveChannel.IFConfiguration.IFFilterSamplePeriodList 'Read
MsgBox “First IF Sample Period Value: “ & Variable(0)

See an example program

C++ Syntax

HRESULT get_IFFilterSamplePeriodList( SAFEARRAY ** ppSamplePeriodList );

Interface

IIFConfiguration2


Write/Read
About Pulsed Application

IFFilterSamplePeriodMode Property

Description

Sets or returns the IF filter sample period mode.

Note: An error will occur if this command is used on a PNA without option H08 installed.

VB Syntax

IfConfig.IFFilterSamplePeriodMode = value

Variable

(Type) - Description

IfConfig

IFConfiguration (object)

value

(enum NAModes) -

0 - naAuto - IF filter sample period is chosen automatically.

1 - naManual - the IF filter sample period is the value specified by the IFSamplePeriod property.

Return Type

NAModes

Default

0 - naAuto

Examples

App.ActiveChannel.IFConfiguration.IFFilterSamplePeriodMode = naAuto 'Write

variable = App.ActiveChannel.IFConfiguration.IFFilterSamplePeriodMode 'Read

See an example program

C++ Syntax

HRESULT get_IFFilterSamplePeriodMode( tagNAModes * pMode);

HRESULT put_IFFilterSamplePeriodMode ( tagNAModes mode );

Interface

IIFConfiguration2


Write/Read
About Pulsed Application

IFFilterSource Property

Description

Sets or retrieves type of IF filter to be used.

Note: An error will occur if this command is used on a PNA without option H08 installed.

VB Syntax

IfConfig.IFFilterSource = value

Variable

(Type) - Description

object

IFConfiguration (object)

value

(NAIFFilterSource) – The type of filter to use. Choose from:

naIFFilterSourceAuto – The IF filter type is automatically chosen.

naIFFilterSourceManual – The IF filter is a predetermined shape where the IFFilterSampleCount determines the number of taps in the filter.

Return Type

NAIFFilterSource

Default

naIFFilterSourceAuto

Examples

App.ActiveChannel.IFConfiguration.IFFilterSource = naIFFilterSourceManual 'Write

Variable = App.ActiveChannel.IFConfiguration.IFFilterSource 'Read

See an example program

C++ Syntax

HRESULT get_IFFilterSource( tagNAIFFilterSource * pFilterSource );

HRESULT put_IFFilterSource(tagNAIFFilterSource filterSource );

Interface

IIFConfiguration2


Write/Read
About IF Access

IFGainLevel Property

Description

Manually sets the gain level for the specified receiver.

VB Syntax

IfConfig.IFGainLevel (id) = value

Variable

(Type) - Description

IfConfig

An IFConfiguration (object)

id

Receiver for which to set the gain level. Choose from: 'A', 'B', 'R1', 'R2'.

Note: The A and R1 receivers are always switched together. B and R2 are also always switched together. For example, if you specify 'A', R1 will also be switched.

value

(long Integer) Gain Level. Choose from:

0 - Lowest gain setting
1
2 - Highest gain setting

Return Type

Long Integer

Default

0 (Lowest setting)

Examples

IfConfig.IFGainLevel('A') = 1

C++ Syntax

HRESULT get_IFGainLevel (BSTR IDString, *GainLevel)

HRESULT put_IFGainLevel (BSTR IDString, GainLevel)

Interface

IFConfiguration


Write/Read
About IF Access

IFGainMode Property

Description

Sets the gain state for ALL receivers to Auto or Manual.

VB Syntax

IfConfig.IFGainMode (id) = value

Variable

(Type) - Description

IfConfig

An IFConfiguration (object)

id

Receivers for which to set the state. Choose 'ALL'.

value

(enum as NAModes)

Choose from:

0 - naAUTO

1 - naMANUAL (use IFGainLevel Property to manually set gain level)

Return Type

NAModes

Default

0 - naAUTO

Examples

IfConfig.IFGainMode("ALL") = naAUTO

C++ Syntax

HRESULT get_IFGainMode (BSTR IDString, NAModes *gainMode)

HRESULT put_IFGainMode (BSTR IDString, NAModes gainMode)

Interface

IIFConfiguration


Write/Read
About Pulsed Application

IFGateEnable Property

Description

Sets or retrieves the state of the IF Gate.

Note: An error will occur if this command is used on a PNA without option H08 installed.

VB Syntax

IfConfig.IFGateEnable = value

Variable

(Type) - Description

IfConfig

IFConfiguration (object)

value

(Boolean) – The state of the IF Gate.

True – The IF Gate is in use.

False – The IF Gate is not in use.

Return Type

Boolean

Default

False

Examples

App.ActiveChannel.IFConfiguration.IFGateEnable = True 'Write

variable = App.ActiveChannel.IFConfiguration.IFGateEnable 'Read

See an example program

C++ Syntax

HRESULT get_IFGateEnable( VARIANT_BOOL * pGateEnabled );

HRESULT put_IFGateEnable( VARIANT_BOOL gateEnabled );

Interface

IIFConfiguration


IFNumerator_Property

Write/Read
About Mixer Configuration

IFNumerator Property

Description

Sets or returns the numerator value of the IF Fractional Multiplier.

Only applies to 2 stage mixers!

VB Syntax

mixer.IFNumerator = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(Long)

Return Type

long

Default

Not Applicable

Examples

Print mixer.IFNumerator 'prints the value of the IFNumerator

C++ Syntax

HRESULT get_IFNumerator(long *pVal)

HRESULT put_IFNumerator(long newVal)

Interface

IMixer


IFSideband_Property

Write/Read
About Mixer Configuration

IFSideband Property

Description

Sets or returns the value of the IF sideband, high or low.

Only applies to 2 stage mixers!

VB Syntax

mixer.IFSideband =value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(enum as FCASideBand) - Choose from:

0 - LOW

1 - HIGH

Return Type

FCASideBand

Default

0 - LOW

Examples

Print mixer.IFSideband 'prints the value of the IFSideband

C++ Syntax

HRESULT get_IFSideband(FCASideBand *pVal)

HRESULT put_IFSideband(FCASideBand newVal)

Interface

IMixer


Write/Read
About IF Access

IFSourcePath Property

Description

Sets the source path of the specified receiver. An error is returned if <id> is not valid, or if <value> is not valid for the specified <id>.

VB Syntax

IfConfig.IFSourcePath (id) = value

Variable

(Type) - Description

IfConfig

An IFConfiguration (object)

id

Receiver for which to set the gain level. Choose from: 'A', 'B', 'R1', 'R2'..

Note: The A and R1 receivers are always switched together. B and R2 are also always switched together. For example, if you specify "A", R1 will also be switched.

value

(Enum as NAIFSourcePath) Source path. Choose from:

0 - naNormalIFPath - the PNA decides the appropriate IF input paths.

1 - naExternalIFPath - always use the rear panel IF inputs.

Return Type

NAIFSourcePath

Default

0 - naNormalIFPath

Examples

IfConfig.IFSourcePath('A') = naNormalIFPath

C++ Syntax

HRESULT get_IFSourcePath (BSTR IDString, naIFSourcePath *IFSourcePath)

HRESULT put_IFSourcePath (BSTR IDString, naIFSourcePath IFSourcePath)

Interface

IIFConfiguration


IFStartFrequency_Property

Write/Read
About Mixer Configuration

IFStartFrequency Property

Description

Sets or returns the start frequency value of the mixer IF frequency.

Only applies to 2 stage mixers!

VB Syntax

mixer.IFStartFrequency = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - Frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

Print mixer.IFStartFrequency 'prints the value of the IFStartFrequency

C++ Syntax

HRESULT get_IFStartFrequency(double *pVal)

HRESULT put_IFStartFrequency(double newVal)

Interface

IMixer


IFStopFrequency_Property

Write/Read
About Mixer Configuration

IFStopFrequency Property

Description

Sets or returns the stop frequency value of the mixer IF frequency.

Only applies to 2 stage mixers!

VB Syntax

mixer.IFStopFrequency = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - IF stop frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

Print mixer.IFStopFrequency 'prints the value of the IFStopFrequency

C++ Syntax

HRESULT get_IFStopFrequency(double *pVal)

HRESULT put_IFStopFrequency(double newVal)

Interface

IMixer


Impulse Width Property

Write/Read

About Time Domain

ImpulseWidth Property

Description

Sets or returns the Impulse Width of Time Domain transform windows

VB Syntax

trans.ImpulseWidth = value

Variable

(Type) - Description

trans

A Transform (object)

value

(double) - Impulse Width in seconds. Range of settings depends on the frequency range of your analyzer.

Return Type

Double

Default

.98 / Default Span

Examples

trans.ImpulseWidth = 200e-12 'sets the Impulse width of a transform window -Write

IW = trans.ImpulseWidth 'Read

C++ Syntax

HRESULT get_ImpulseWidth(double *pVal)
HRESULT put_ImpulseWidth(double newVal)

Interface

ITransform


Read/Write
About the Handler I/O Connector

IndexState Property

Description

Determines the control of Material Handler connector Pin 20.

VB Syntax

handler.IndexState = value

Variable

(Type) - Description

handler

(object) - A Handler I/O object

value

(boolean)

0 (False) - Pin 20 is controlled by Output Port B6

1(True) - Pin 20 is controlled by the Index signal

Return Type

Boolean

Default

Examples

handler.IndexState = False 'Write

bState = handler.IndexState 'Read

C++ Syntax

HRESULT put_IndexState (BOOL *pVal);

HRESULT get_IndexState (BOOL newVal);

Interface

IHWMaterialHandlerIO2


Input A Property

Write/Read
About Port Extensions

InputA Property

Description

Sets a Port Extension value for Receiver A

VB Syntax

portExt.InputA = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.InputA = 10e-6 'Write

inA = portExt.InputA 'Read

C++ Syntax

HRESULT get_InputA(double *pVal)
HRESULT put_InputA(double newVal)

Interface

IPortExtension


Input B Property

Write/Read

About Port Extensions

InputB Property

Description

Sets the Port Extension value for Receiver B

VB Syntax

portExt.InputB = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.InputB = 10e-6 'Write

inB = portExt.InputB 'Read

C++ Syntax

HRESULT get_InputB(double *pVal)
HRESULT put_InputB(double newVal)

Interface

IPortExtension


Input_C_Property

Write/Read

About Port Extensions

InputC Property

Description

Sets the Port Extension value for Receiver C

VB Syntax

portExt.InputC = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.InputC = 10e-6 'Write

inC = portExt.InputC 'Read

C++ Syntax

HRESULT get_InputC(double *pVal)
HRESULT put_InputC(double newVal)

Interface

IPortExtension


InputDenominator_Property

Write/Read
About Mixer Configuration

InputDenominator Property

Description

Sets or returns the denominator value of the Input Fractional Multiplier.

VB Syntax

mixer.InputDenominator = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(Long) - Input denominator value.

Return Type

Long

Default

1

Examples

Print mixer.InputDenominator 'prints the value of the InputDenominator

C++ Syntax

HRESULT get_InputDenominator(long *pVal)

HRESULT put_InputDenominator(long newVal)

Interface

IMixer


Write/Read
About Mixer Configuration

IsInputGreaterThanLO Property

Description

Specifies whether to use the Input frequency that is greater than the LO or less than the LO. To learn more, see the mixer setup dialog box help.

VB Syntax

mixer.IsInputGreaterThanLO (LO) = bool

Variable

(Type) - Description

mixer

A Mixer (object)

LO

(Integer) - LO stage number

Choose from 1 (default) or 2

bool

(Boolean) -

True (1) - Use the Input that is Greater than the specified LO.

False (0) - Use the Input that is Less than the specified LO.

Return Type

Boolean

Default

True

Examples

mixer.IsInputGreaterThanLO(1) = True

C++ Syntax

HRESULT get_IsInputGreaterThanLO(VARIANT_BOOL * val);

HRESULT put_IsInputGreaterThanLO(VARIANT_BOOL val);

Interface

IMixer2


InputNumerator_Property

Write/Read
About Mixer Configuration

InputNumerator Property

Description

Sets or returns the numerator value of the Input Fractional Multiplier.

VB Syntax

mixer.InputNumerator = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(Long) - Input numerator value.

Return Type

Long

Default

1

Examples

Print mixer.InputNumerator 'prints the value of the InputNumerator

C++ Syntax

HRESULT get_InputNumerator(long *pVal)

HRESULT put_InputNumerator(long newVal)

Interface

IMixer


InputPower_Property

Write/Read
About Mixer Configuration

InputPower Property

Description

Sets or returns the value of the Input Power.

VB Syntax

mixer.InputPower = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - Input power in dBm.

Return Type

Double

Default

-17dBm

Examples

Print mixer.InputPower 'prints the value of the InputPower

C++ Syntax

HRESULT get_InputPower(double *pVal)

HRESULT put_InputPower(double newVal)

Interface

IMixer


InputStartFrequency_Property

Write/Read
About Mixer Configuration

InputStartFrequency Property

Description

Sets and returns the start frequency value of the mixer Input frequency.

VB Syntax

mixer.InputStartFrequency = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - Input start frequency in Hertz.

Return Type

Double

Default

Start frequency of the PNA

Examples

mixer.InputStartFrequency = Start_Freq

C++ Syntax

HRESULT get_InputStartFrequency(double *pVal)

HRESULT put_InputStartFrequency(double newVal)

Interface

IMixer


InputStopFrequency_Property

Write/Read
About Mixer Configuration

InputStopFrequency Property

Description

Sets and returns the stop frequency value of the mixer Input frequency.

VB Syntax

mixer.InputStopFrequency = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - Input stop frequency in Hertz.

Return Type

Double

Default

Stop frequency of the PNA

Examples

mixer.InputStopFrequency = Stop_Freq

C++ Syntax

HRESULT get_InputStopFrequency(double *pVal)

HRESULT put_InputStopFrequency(double newVal)

Interface

IMixer


Read only
About PNA Options

InternalTestsetPortCount Property

Description

Returns the number of PNA test ports on the internal testset.

VB Syntax

value = cap.InternalTestsetPortCount

Variable

(Type) - Description

value

(Long) - Variable to store the returned number of PNA test ports.

cap

A Capabilities (object)

Return Type

Long

Default

Not Applicable

Examples

value = cap.InternalTestsetPortCount 'Read

C++ Syntax

HRESULT get_InternalTestsetPortCount(long * numPorts );

Interface

ICapabilities


Write/Read

About Interpolation

Interpolate Correction Property

Description

Turns ON and OFF correction interpolation which calculates new error terms when stimulus values change after calibration.

When this property is ON and error correction is being applied, the calibration subsystem attempts to interpolate the error terms whenever the stimulus parameters are changed.

When this property is OFF under the same circumstances, error correction is turned OFF.

VB Syntax

meas.InterpolateCorrection = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean) - Choose from:

True - Turns correction interpolation ON
False - Turns correction interpolation OFF

Return Type

Boolean

Default

True

Examples

meas.InterpolateCorrection = False

calInterpolate = InterpolateCorrection 'Read

C++ Syntax

HRESULT get_InterpolateCorrection(boolean *pVal)
HRESULT put_InterpolateCorrection(boolean newVal)

Interface

IMeasurement


Write/Read

About Receiver Cal

InterpolateNormalization Property

Description

Turns ON and OFF normalization interpolation which calculates new divisor data when stimulus values change after normalization.

When this property is ON and normalization is being applied, the Normalization algorithm attempts to interpolate the divisor data whenever the stimulus parameters are changed.

When this property is OFF under the same circumstances, normalization is turned OFF.

Normalization is currently supported only on measurements of unratioed power for the purpose of performing a receiver power calibration.

VB Syntax

meas.InterpolateNormalization = value

Variable

(Type) - Description

meas

(object) - A Measurement object

value

(boolean)

0 – Turns normalization interpolation OFF

1 – Turns normalization interpolation ON

Return Type

Boolean

Default

0 -OFF

Examples

meas.InterpolateNormalization = 1 'Write

normalized = meas.InterpolateNormalization 'Read

C++ Syntax

HRESULT put_InterpolateNormalization(VARIANT_BOOL bState);

HRESULT get_InterpolateNormalization(VARIANT_BOOL *bState);

Interface

IMeasurement


Read-only

About the ExtTestSetIO connector

Interrupt Property

Description

Reads the boolean that represents the state of the Interrupt In line (pin 13) on the external test set connector.

VB Syntax

value = ExtIO.Interrupt

Variable

(Type) - Description

value

(boolean) - Variable to store the returned data

ExtIO

(object) - An ExternalTestSetIO object

Return Type

Boolean

False (0) - indicates the line is being held at a TTL High

True (1) - indicates the line is being held at a TTL Low

Default

Not Applicable

Examples

value = ExtIO.Interrupt

C++ Syntax

HRESULT get_Interrupt( VARIANT_BOOL* bValue);

Interface

IHWExternalTestSetIO


Read-only
About Trigger

IsContinuous Property

Description

Returns whether or not a channel is in continuous mode. To set the channel to continuous mode, use Continuous Method.

VB Syntax

value = chan.IsContinuous

Variable

(Type) - Description

value

(boolean) - Choose either:

False (0) - Channel trigger is NOT set to continuous.

True (1) - Channel trigger IS set to continuous.

chan

Channel (object)

Return Type

boolean

Default

Not Applicable

Examples

trig = chan.IsContinuous 'Read

C++ Syntax

HRESULT get_IsContinuous ( VARIANT_BOOL *bContinuous);

Interface

IChannel3


IsECALModuleFoundEx Property

Read only
About ECAL

IsECALModuleFoundEx Property - OBSOLETE

Description

Note: This command is replaced by ECALModuleNumberList and ECALCharacterizationIndexList

Returns true or false depending on whether communication was established between the PNA and the specified ECal module.

VB Syntax

modFound = cal.IsECALModuleFoundEx (module)

Variable

(Type) - Description

modFound

(boolean) - Variable to store the returned test result.

True - The PNA identified the presence of the specified ECal module.

False - The PNA did NOT identify the presence of the specified ECal module.

cal

(object) - A Calibrator object

module

(long integer) ECal module.

Choose from modules 1 through 8

Use GetECALModuleInfoEx to return the model and serial number of each module.

Return Type

Boolean

Default

Not applicable

Examples

Set cal = pna.ActiveChannel.Calibrator

moduleFound = cal.IsECALModuleFoundEx(1)

C++ Syntax

HRESULT get_IsECALModuleFoundEx( long moduleNumber, VARIANT_BOOL *bModuleFound);

Interface

ICalibrator4


Read only
About PNA Options

IsFrequencyOffsetPresent Property

Description

Returns a value indicating the presence of Frequency Offset Option 080 in the remote PNA.

VB Syntax

value = cap.IsFrequencyOffsetPresent

Variable

(Type) - Description

value

(Boolean) - Variable to store the returned value (True or False).

cap

A Capabilities (object)

Return Type

Boolean

Default

Not Applicable

Examples

value = cap.isFrequencyOffsetPresent(1) 'Read

C++ Syntax

HRESULT get_IsFrequencyOffsetPresent(VARIANT_BOOL * present );

Interface

ICapabilities


Read-only
About Trigger

IsHold Property

Description

Returns whether or not a channel is in hold mode. To set the channel to hold mode, use Hold Method.

VB Syntax

value = chan.IsHold

Variable

(Type) - Description

value

(boolean) - Choose either:

False (0) - Channel trigger is NOT set to hold.

True (1) - Channel trigger IS set to hold.

chan

Channel (object)

Return Type

boolean

Default

Not Applicable

Examples

trig = chan.IsHold 'Read

C++ Syntax

HRESULT get_IsHold ( VARIANT_BOOL *bHold);

Interface

IChannel3


Read only
About PNA Options

IsReceiverStepAttenuatorPresent Property

Description

Returns a value indicating the presence of Receiver step attenuators in the remote PNA.

VB Syntax

value = cap.IsReceiverStepAttenuatorPresent (n)

Variable

(Type) - Description

value

(Boolean) - Variable to store the returned value.

cap

A Capabilities (object)

n

(Long) - port number to query for step attenuators

Return Type

Boolean

Default

Not Applicable

Examples

value = cap.IsReceiverStepAttenuatorPresent(1)'Read

C++ Syntax

HRESULT get_IsReceiverStepAttenuatorPresent(long portNumber, VARIANT_BOOL * present );

Interface

ICapabilities


Read only
About PNA Options

IsReferenceBypassSwitchPresent Property

Description

Returns a value indicating the presence of a Reference Bypass Switch in the remote PNA.

VB Syntax

value = cap.IsReferenceBypassSwitchPresent (n)

Variable

(Type) - Description

value

(Boolean) - Variable to store the returned value (True or False).

cap

n

A Capabilities (object)

(Long) - port number to query for reference bypass switch

Return Type

Boolean

Default

Not Applicable

Examples

value = cap.IsReferenceBypassSwitchPresent(1) 'Read

C++ Syntax

HRESULT get_IsReferenceBypassSwitchPresent(long portNumber, VARIANT_BOOL * present );

Interface

ICapabilities


IsSParameter_Property

Read-only

IsSParameter Property

Description

Returns true if measurement represents an S-Parameter

VB Syntax

value = meas.IsSparameter

Variable

(Type) - Description

meas

A Measurement (object)

value

(Boolean)

1 True - measurement is an S-Parameter

0 False - measurement is NOT an S-Parameter

Return Type

Boolean

Default

True

Examples

print app.IsSparameter

C++ Syntax

HRESULT IsSparameter( [out, retval] VARIANT_BOOL * bVal);

Interface

IMeasurement2


Write / Read

About Source Power Cal

IterationsTolerance Property

Description

Sets the maximum desired deviation from the sum of the test port power and the offset value. Power readings will continue to be made, and source power adjusted, until a reading is within this tolerance value or the max number of readings has been met. The last value to be read is the valid reading for that data point.

VB Syntax

pwrCal.IterationsTolerance = value

Variable

(Type) - Description

pwrCal

(object) - A SourcePowerCalibrator (object)

value

(Double) – Tolerance value in dBm. Choose any number between 0 and 5

Return Type

Double

Default

.05 dB

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.IterationsTolerance = .1 'Write
ReadTol = powerCalibrator.IterationsTolerance 'Read

C++ Syntax

HRESULT get_IterationsTolerance( double *pVal);

HRESULT put_IterationsTolerance( double newVal);

Interface

ISourcePowerCalibrator3


Kaiser Beta Property

Write/Read

About Time Domain

KaiserBeta Property

Description

Sets or returns the Kaiser Beta of Time Domain transform windows

VB Syntax

trans.KaiserBeta = value

Variable

(Type) - Description

trans

A Transform (object)

value

(single) - Kaiser Beta. Choose any number between 0 and 13.

Return Type

Single

Default

0

Examples

trans.KaiserBeta = 6 'sets the Kaiser Beta of a transform window -Write

KB = trans.KaiserBeta 'Read

C++ Syntax

HRESULT get_KaiserBeta(float *pVal)
HRESULT put_KaiserBeta(float newVal)

Interface

ITransform


Write/Read
About Modifying Cal Kits

L0 Property

Description

Sets and Returns the L0 (L-zero) value (the first inductance value) for the calibration standard.

To set the other inductance values, use L1, L2, L3

VB Syntax

calstd.L0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L0 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L0 = 15 'Write the value of L0 = 15picohenries

Induct0 = calstd.L0 'Read the value of L0

C++ Syntax

HRESULT get_L0(float *pVal)
HRESULT put_L0(float newVal)

Interface

ICalStandard


Write/Read

About Modifying Cal Kits

L1 Property

Description

Sets and Returns the L1 value (the second inductance value) for the calibration standard.

To set the other inductance values, use L0, L2, L3

VB Syntax

calstd.L1 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L1 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L1 = 15 'Write the value of L1 = 15picohenries

Induct1 = calstd.L1 'Read the value of L1

C++ Syntax

HRESULT get_L1(float *pVal)
HRESULT put_L1(float newVal)

Interface

ICalStandard


Write/Read

About Modifying Cal Kits

L2 Property

Description

Sets and Returns the L2 value (the third inductance value) for the calibration standard.

To set the other inductance values, use L0, L1, L3

VB Syntax

calstd.L2 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L2 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L2 = 15 'Write the value of L2 to 15picohenries

Induct2 = calstd.L2 'Read the value of L2

C++ Syntax

HRESULT get_L2(float *pVal)
HRESULT put_L2(float newVal)

Interface

ICalStandard


Write/Read

About Modifying Cal Kits

L3 Property

Description

Sets and Returns the L3 value (the third inductance value) for the calibration standard.

To set the other inductance values, use L0, L1, L2

VB Syntax

calstd.L3 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L3 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L3 = 15 'Write the value of L3 to 15picohenries

Induct3 = calstd.L3 'Read the value of L3

C++ Syntax

HRESULT get_L3(float *pVal)
HRESULT put_L3(float newVal)

Interface

ICalStandard


Write/Read

About Modifying Cal Kits

Label Property

Description

Sets and Returns the label for the calibration standard. The label is used to prompt the user to connect the specified standard.

VB Syntax

calstd.Label = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(string) - between 1 and 12 characters long. Cannot begin with a numeric.

Return Type

String

Default

Not Applicable

Examples

calstd.Label = "Short" 'Write

stdLabel = calstd.Label 'Read

C++ Syntax

HRESULT get_Label(BSTR *pVal)
HRESULT put_Label(BSTR newVal)

Interface

ICalStandard


Read-only
About Cal Sets

LastModified Property

Description

Returns the time stamp of the last modification to this CalSet

VB Syntax

value = Object.LastModified

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(Variant) – Variable to store the time stamp.

Return Type

Variant

Default

Not Applicable

Examples

date = CalSet.LastModified 'Read

C++ Syntax

HRESULT get_LastModified(VARIANT* datetime)

Interface

ICalSet3


Read-only

About Limit Testing

LimitTestFailed Property

Description

Returns the results of limit testing for the measurement.

VB Syntax

testFailed = meas.LimitTestFailed

Variable

(Type) - Description

testFailed

(boolean) Variable to store the returned value

False (0) - Limit Test Passed
True (1) - Limit Test Failed

meas

A Measurement (object)

Return Type

Boolean

Default

False returned if there is no testing in progress

Examples

Dim testRes As Boolean
testRes = meas.LimitTestFailed
MsgBox (testRes)

C++ Syntax

HRESULT get_LimitTestFailed(VARIANT_BOOL* trueIfFailed)

Interface

IMeasurement


End Stimulus Value

Write/Read

About Limits

EndStimulus Property

Description

When constructing a limit line, specifies the stimulus value for the end of the segment.

VB Syntax

limtseg.EndStimulus = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - End Stimulus X-axis value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.EndStimulus = 8e9 'Write

EndStim = limtseg.EndStimulus 'Read

C++ Syntax

HRESULT get_EndStimulus(double *pVal)
HRESULT put_EndStimulus(double newVal)

Interface

ILimitSegment


End Response Property

Write/Read

About Limits

EndResponse Property

Description

When constructing a limit line, specifies the amplitude value at the end of the limit segment.

VB Syntax

limtseg.EndResponse = value

Variable

(Type) - Description

limts

A LimitSegment (object)

value

(double) - Y-axis value of the End Response limit. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.EndResponse = 10 'Write

EndResp = limtseg.EndResponse 'Read

C++ Syntax

HRESULT get_EndResponse(double *pVal)
HRESULT put_EndResponse(double newVal)

Interface

ILimitSegment


Write/Read

About Limits

Type (limit) Property

Description

Specifies the Limit Line type.

VB Syntax

limt(index).Type = value

Variable

(Type) - Description

limt

A LimitSegment (object)

index

(variant) - Limit line number in the LimitTest collection

value

(enum NALimitSegmentType) - Limit Line type. Choose from:
0 - naLimitSegmentType_OFF - turns limit line OFF
1 - naLimitSegmentType_Maximum - limit line fails with a data point ABOVE the line
2 - naLimitSegmentType_Minimum - limit line fails with a data point BELOW the line

Return Type

Long Integer

Default

0 - OFF

Examples

Set limts = meas.LimitTest
limts.Type = naLimitSegmentType_Maximum 'Write

limitType = limts.Type 'Read

C++ Syntax

HRESULT put_Type(tagNALimitSegmentType *pVal)
HRESULT get_Type(tagNALimitSegmentType newVal)

Interface

ILimitSegment


Write/Read
About Limits

LineDisplay Property

Description

Turns the display of limit lines ON or OFF. To turn limit TESTING On and OFF, use State Property.

Note: Trace data must be ON to view limit lines

VB Syntax

limitst.LineDisplay = state

Variable

(Type) - Description

limitst

A LimitTest (object)

state

(boolean)
0 - Turns the display of limit lines OFF
1 - Turns the display of limit lines ON

Return Type

Long Integer

Default

1 - ON

Examples

Limttest.LineDisplay = 1 'Write

lineDsp = Limttest.LineDisplay 'Read

C++ Syntax

HRESULT get_LineDisplay(VARIANT_BOOL *pVal)
HRESULT put_LineDisplay(VARIANT_BOOL newVal)

Interface

ILimitTest


Read/Write

LoadCharFromFile Property

Description

Sets and returns whether a Mixer characterization file is to be loaded. Specify and load the filename with CharFileName Property

VB Syntax

VMC.LoadCharFromFile = bool

Variable

(Type) - Description

VMC

VMCType (object)

bool

(Boolean)

1 - Load from file

0 - Perform mixer characterization

Return Type

Boolean

Default

0

Examples

value = VMC.LoadCharFromFile

C++ Syntax

HRESULT put_LoadCharFromFile(VARIANT_BOOL bLoadCharFromFile);

HRESULT get_LoadCharFromFile(VARIANT_BOOL *bLoadCharFromFile);

Interface

VMCType


Read-only

About Limit Testing

LoadPort Property

Description

Returns the load port number associated with an S-parameter reflection measurement. If the measurement is not a reflection S-parameter, the number returned by this property will have no meaning.

VB Syntax

loadPort = meas.LoadPort

Variable

(Type) - Description

loadPort

(long integer) - The reflection measurement’s load port number.

meas

A Measurement (object)

Return Type

Long Integer

Default

Not Applicable

Examples

Set meas = pna.ActiveMeasurement
loadPort = meas.LoadPort

C++ Syntax

HRESULT get_LoadPort(long *pPortNumber);

Interface

IMeasurement


Write/Read

LocalLockoutState Property

Description

Prevents use of the mouse, keyboard, and front panel while your program is running. Use of these controls while this property is set TRUE causes an error message on the PNA display. To prevent these messages, see About Error Messages.

VB Syntax

app.LocalLockoutState = bool

Variable

(Type) - Description

app

An Application (object)

bool

(boolean) -Choose either:

0 (False) - User Interface is NOT locked out.

1 (True) - User Interface IS locked out.

Return Type

Boolean

Default

0 - False

Examples

app.LocalLockoutState = True 'Write

block = app.LocalLockoutState 'Read

C++ Syntax

HRESULT get_LocalLockoutState(VARIANT_BOOL *State);
HRESULT put_LocalLockoutState(VARIANT_BOOL *State);

Interface

IApplication4


LODenominator_Property

Write/Read
About Mixer Configuration

LODenominator Property

Description

Sets or returns the denominator value of the LO Fractional Multiplier.

VB Syntax

mixer.LODenominator (n) = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(Long) - LO denominator value

n

(Long) - LO stage number

Choose from 1 or 2

Return Type

Long

Default

1

Examples

Print mixer.LODenominator(1) 'prints the value of the

first LODenominator

C++ Syntax

HRESULT get_LODenominator(long *pVal)

HRESULT put_LODenominator(long newVal)

Interface

IMixer


LOFixedFrequency_Property

Write/Read
About Mixer Configuration

LOFixedFrequency Property

Description

Sets or returns the LO frequency value

VB Syntax

mixer.LOFixedFrequency (n) = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - LO Frequency in Hertz.

n

(Long) - LO stage number

Choose from 1 or 2

Return Type

Double

Default

0 Hz

Examples

Print mixer.LOFixedFrequency(1) 'prints the value of the first LO fixed frequency

C++ Syntax

HRESULT get_LOFixedFrequency(double *pVal)

HRESULT put_LOFixedFrequency(double newVal)

Interface

IMixer


Write/Read
About Receiver Cal

LogMagnitudeOffset Property

Description

Sets or returns the power offset value in dBm that the normalized unratioed power measurement data will be shifted by. The unratioed power measurement is effectively calibrated to the power level specified by the value of LogMagnitudeOffset as soon as the Normalization property is set to ON after the DataToDivisor method has been called.

VB Syntax

meas.LogMagnitudeOffset = value

Variable

(Type) - Description

meas

(object) - A Measurement object

value

(double) - Power offset in dBm. No limits are enforced on this value, but the PNA receivers themselves have maximum and minimum power specifications. This value must comply with those limits for a valid receiver power calibration

Return Type

Double

Default

0

Examples

meas.LogMagOffset = -10 'Write (-10 dBm)

calpower = meas.LogMagOffset 'Read
meas.DataToDivisor 'Store meas data as measurement divisor
meas.Normalize = 1 'Measurement is now calibrated to –10 dBm

C++ Syntax

HRESULT put_LogMagOffset(double newVal);

HRESULT get_LogMagOffset(double *pVal);

Interface

IMeasurement


LOName_Property

Write/Read
About Configure an External LO Source

LOName Property

Description

Sets or returns the name of the external LO source.

VB Syntax

mixer.LOName (n) =value

Variable

(Type) - Description

mixer

A Mixer (object)

n

(Long) - LO stage number

Choose from 1 or 2

value

(string) - External LO Source name. Must be a valid source name already configured on the PNA. The source must also be connected properly..

Return Type

String

Default

"Not controlled"

Examples

mixer.LOName(1) = "MySource"

C++ Syntax

HRESULT get_LOName(string *pVal)

HRESULT put_LOName(string newVal)

Interface

MIXer


LONumerator_Property

Write/Read
About Mixer Configuration

LONumerator Property

Description

Sets or returns the numerator value of the LO Fractional Multiplier.

VB Syntax

mixer.LONumerator (n) = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(Long) - LO denominator value

n

(Long) - LO stage number

Choose from 1 or 2

Return Type

Long

Default

1

Examples

Print mixer.LONumerator(1) 'prints the value of the

first LO Numerator

C++ Syntax

HRESULT get_LONumerator(long *pVal)

HRESULT put_LONumerator(long newVal)

Interface

IMixer


LOPower_Property

Write/Read
About Mixer Configuration

LOPower Property

Description

Sets or returns the value of LO Power.

VB Syntax

mixer.LOPower (n) = value

Variable

(Type) - Description

mixer

A Mixer (object)

n

(Long) - LO stage number

Choose from 1 or 2

value

(double) - LO Power in dBm.

Return Type

Double

Default

-10dBm

Examples

Print mixer.LOPower(1) 'prints the value of the LO Power

C++ Syntax

HRESULT get_LOPower(double *pVal)

HRESULT put_LOPower(double newVal)

Interface

IMixer


Write/Read
About Mixer Configuration

LORangeMode Property

Description

Sets or returns the LO sweep mode.

VB Syntax

mixer.LORangeMode (n) = value

Variable

(Type) - Description

mixer

A Mixer (object)

n

(Long) - LO stage number.

Choose from 1 or 2

value

(Enum as MixerRangeMode) - LO sweep mode. Choose from:

0 - mixSwept

1 - mixFixed

Return Type

Enum

Default

0 - mixSwept

Examples

mixer.LORangeMode(1)=mixSwept

C++ Syntax

HRESULT get_LORangeMode(long *pVal)

HRESULT put_LORangeMode(long newVal)

Interface

IMixer3


Write/Read
About Modifying Cal Kits

Loss Property

Description

Sets and Returns the insertion loss for the calibration standard.

VB Syntax

calstd.loss = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Insertion loss in Mohms / sec. (MegaOhms per second of electrical delay)

Return Type

Single

Default

Not Applicable

Examples

calstd.loss = 3.5e9 'Write

stdLoss = calstd.loss 'Read the value of Loss

C++ Syntax

HRESULT get_Loss(float *pVal)
HRESULT put_Loss(float newVal)

Interface

ICalStandard


Loss (sourceCal) Property

Write / Read
About Source Power Cal

Loss (Source Power Cal) Property

Description

Sets or returns the loss value associated with a PowerLossSegment.

VB Syntax

lossSeg.Loss = value

Variable

(Type) - Description

lossSeg

(object) - PowerLossSegment

value

(double) – Loss value in dB. This can be any value between 0 and 200.

Return Type

Double

Default

0

Examples

lossSeg.Loss = 0.5 'Write
lossVal = lossSeg.Loss 'Read

C++ Syntax

HRESULT put_Loss(Double newVal);

HRESULT get_Loss(Double *pVal);

Interface

IPowerLossSegment


LOStage_Property

Write/Read
About Mixer Configuration

LOStage Property

Description

Sets or returns the number of LO stages present in the mixer.

VB Syntax

mixer.LOStage = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(Long) - Number of LO stages. Choose from 1 or 2

Return Type

Long

Default

1

Examples

mixer.LOStage = 1 'sets the LO Stage value to 1

C++ Syntax

HRESULT get_LOStage(long *pVal)

HRESULT put_LOStage(long newVal)

Interface

IMixer


Write/Read
About Mixer Configuration

LOStartFrequency Property

Description

Sets or returns the LO start frequency value. This command can only be used with SMC (not VMC) measurements.

VB Syntax

mixer.LOStartFrequency (n) = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - LO Start Frequency in Hertz.

n

(Long) - LO stage number

Choose from 1 or 2

Return Type

Double

Default

Examples

Print mixer.LOStartFrequency(1) 'prints the value of the first LO start frequency

C++ Syntax

HRESULT get_LOStartFrequency(long id, double *pVal)

HRESULT put_LOStartFrequency(long id,double newVal)

Interface

IMixer3


Write/Read
About Mixer Configuration

LOStopFrequency Property

Description

Sets or returns the LO stop frequency value. This command can only be used with SMC (not VMC) measurements.

VB Syntax

mixer.LOStopFrequency (n) = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - LO Stop Frequency in Hertz.

n

(Long) - LO stage number

Choose from 1 or 2

Return Type

Double

Default

Examples

Print mixer.LOStopFrequency(1) 'prints the value of the first LO stop frequency

C++ Syntax

HRESULT get_LOStopFrequency(long id, double *pVal)

HRESULT put_LOStopFrequency(long id,double newVal)

Interface

IMixer3


Write/Read
About Magnitude Offset

MagnitudeOffset Property

Description

Offsets the data trace magnitude by the specified value.

To offset the data trace magnitude to a slope value that changes with frequency, use MagnitudeSlopeOffset Property.

To implement a Receiver Cal offset, use LogMagnitudeOffset property.

VB Syntax

meas.MagnitudeOffset = value

Variable

(Type) - Description

meas

(object) - A Measurement object

value

(double) - Offset value in dB.

Return Type

Double

Default

0

Examples

meas.MagnitudeOffset = 4 'Write

offs = meas.MagnitudeOffset 'Read

C++ Syntax

HRESULT put_MagnitudeOffset(double newVal);

HRESULT get_MagnitudeOffset(double *pVal);

Interface

IMeasurement4


Write/Read
About Magnitude Offset

MagnitudeSlopeOffset Property

Description

Offsets the data trace magnitude to a value that changes linearly with frequency. The offset slope begins at 0 Hz.

To offset the entire data trace magnitude by a specified value, use MagnitudeOffset Property.

VB Syntax

meas.MagnitudeSlopeOffset = value

Variable

(Type) - Description

meas

(object) - A Measurement object

value

(double) - Offset slope value in dB / 1GHz.

Return Type

Double

Default

0

Examples

meas.MagnitudeSlopeOffset = 4 'Writes a slope offset of 4dB/1GHz.

offs = meas.MagnitudeSlopeOffset 'Read

C++ Syntax

HRESULT put_MagnitudeSlopeOffset(double newVal);

HRESULT get_MagnitudeSlopeOffset(double *pVal);

Interface

IMeasurement4


Marker Format Property

Write/Read

About Marker Format

MarkerFormat Property

Description

Sets (or returns) the format of all the markers in the measurement. To override this setting for an individual marker, use mark.Format

VB Syntax

meas.MarkerFormat = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(enum NAMarkerFormat) - Choose from:

0 - naMarkerFormat_LinMag
1 - naMarkerFormat_LogMag
2 - naMarkerFormat_Phase
3 - naMarkerFormat_Delay
4 - naMarkerFormat_Real
5 - naMarkerFormat_Imaginary
6 - naMarkerFormat_SWR
7 - naMarkerFormat_LinMagPhase
8 - naMarkerFormat_LogMagPhase
9 - naMarkerFormat_RealImaginary
10 - naMarkerFormat_ComplexImpedance
11 - naMarkerFormat_ComplexAdmittance

Return Type

Long Integer

Default

1 - naMarkerFormat_LogMag

Examples

meas.MarkerFormat = naMarkerFormat_SWR 'Write

fmt = mark.Format 'Read

C++ Syntax

HRESULT put_MarkerFormat(tagNAMarkerFormat NewFormat)

Interface

IMeasurement


Interpolate Markers Method

Write-only

About Markers

InterpolateMarkers Method

Description

Turns All Marker Interpolation ON and OFF for the measurement. Marker interpolation enables X-axis resolution between the discrete data values. The analyzer will calculate the x and y-axis data values between discrete data points. To override this property for individual markers, use the Interpolated property.

VB Syntax

meas.Interpolate = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
False - Turns interpolation OFF for all markers in the measurement
True - Turns interpolation ON for all markers in the measurement

Return Type

Boolean

Default

True (ON)

Examples

meas.Interpolate = 1

C++ Syntax

HRESULT InterpolateMarkers(VARIANT_BOOL bNewVal)

Interface

IMeasurement


Write/Read
About Markers

Interpolated Property

Description

Turns marker Interpolation ON and OFF. Marker interpolation enables X-axis resolution beyond the discrete data values. The analyzer will calculate the x and y-axis data values between discrete data points. Use meas.Interpolate to change interpolation of all markers in a measurement. This command will override the measurement setting.

VB Syntax

mark.Interpolated = value

Variable

(Type) - Description

mark

A Marker (object)

value

(boolean)
False - Turns interpolation OFF
True - Turns interpolation ON

Return Type

Boolean

Default

True (ON)

Examples

mark.Interpolated = 1 'Write

interpolate = mark.Interpolated 'Read

C++ Syntax

HRESULT get_Interpolated(VARIANT_BOOL *pVal)
HRESULT put_Interpolated(VARIANT_BOOL newVal)

Interface

IMarker


Number (marker) Property

Read-only
About Markers

Number Property

Description

Returns the number of the marker.

VB Syntax

marknum = mark.Number

Variable

(Type) - Description

marknum

(long) - Variable to store marker number

mark

A Marker (object)

Return Type

Long Integer

Default

Not applicable

Examples

marknum = mark.Number 'Read

C++ Syntax

HRESULT get_Number(long *pVal)

Interface

IMarker


Write/Read

About Marker Readout

MarkerReadout Property

Description

Enables or disables the readout of markers in the window. To show the marker on the screen use ShowMarkerReadout Method.

VB Syntax

win.MarkerReadout = state

Variable

(Type) - Description

win

A NAWindow (object)

state

(boolean)

True (1) - enables marker readout
False (0) - disables marker readout

Return Type

Boolean

Default

True

Examples

win.MarkerReadout = True 'Write

State = app.ActiveNAWindow.MarkerReadout 'Read

C++ Syntax

HRESULT get_MarkerReadout(VARIANT_BOOL *pVal)
HRESULT put_MarkerReadout(VARIANT_BOOL newVal)

Interface

INAWindow


Write/Read

About Marker Readout

MarkerReadoutSize Property

Description

Specifies the size of font used when displaying Marker Readout in the selected window.

VB Syntax

win.MarkerReadoutSize = value

Variable

(Type) - Description

win

A NAWindow (object)

value

(enum NAFontSize)

0 - naDefault - marker readout appears in default font size

1 - naLarge - marker readout appears in large font size

Return Type

Long Integer

Default

naDefault

Examples

win.MarkerReadoutSize = naDefault 'write default size for marker readout

Dim Size As NAFontSize
Size = app.ActiveNAWindow.MarkerReadoutSize 'Read

C++ Syntax

HRESULT get_MarkerReadoutSize(tagNAFontSize *pVal)

HRESULT put_MarkerReadoutSize(tagNAFontSize newVal)

Interface

INAWindow


Write/Read
About Markers

MarkerState Property

Description

Sets or returns the ON / OFF state of the specified marker.

VB Syntax

meas.MarkerState (n) = state

Variable

(Type) - Description

meas

A Measurement (object)

n

(Long Integer) Marker number to turn on or off.

state

(boolean) -
ON (1) turns the specified marker ON
OFF (0) turns the specified marker OFF

Return Type

Boolean

Default

0 - OFF

Examples

meas.MarkerState(1) = True

reference = meas.MarkerState(2)

C++ Syntax

HRESULT get_MarkerState(long markerNum, VARIANT_BOOL bState)
HRESULT put_MarkerState(long markerNum, VARIANT_BOOL* bState)

Interface

IMeasurement3


Write/Read

About Marker Types

Type (Marker) Property

Description

Sets and reads the marker type.

VB Syntax

mark.Type = value

Variable

(Type) - Description

chan

A Marker (object)

value

(enum NAMarkerType) - Marker Type. Choose from:
0 - naMarkerType_Normal - the X-axis value for a normal marker will always be determined by the measurement data of the marker.

1 - naMarkerType_Fixed - retains and keeps its x-axis value at the time the marker type is set.

Return Type

Long Integer

Default

naMarkerType_Normal

Examples

mark.Type = naMarkerType_Normal 'Write

MrkType = mark.Type 'Read

C++ Syntax

HRESULT get_Type(tagNAMarkerType *pVal)
HRESULT put_Type(tagNAMarkerType newVal)

Interface

IMarker


Write/Read
About Markers

Stimulus Property

Description

Sets and reads the X-Axis value of the marker. If the marker is a delta marker, the value will be relative to the reference marker.

VB Syntax

mark.Stimulus = value

Variable

(Type) - Description

mark

A Marker (object)

value

(double) - X-Axis value. Choose any number within the full span of the channel or User Range (if set).

Return Type

Double

Default

First activated Marker turns ON in the middle of the X-axis range. Subsequent markers turn ON at the position of the most recently active marker.

Examples

mark.Stimulus = 3e9 'Write

XVal = mark.Stimulus 'Read

C++ Syntax

HRESULT get_Stimulus(double *pVal)
HRESULT put_Stimulus(double newVal)

Interface

IMarker


Read-only

About Markers

Value Property

Description

Reads the Y-Axis value of the marker. If the marker is a delta marker, the value will be relative to the reference marker.

You cannot set the Y-axis value of a marker. The marker remains at the position at the time you set marker.Type.

VB Syntax

YValue = mark.Value (format)

Variable

(Type) - Description

YValue

A variable to store the Y-axis value

mark

A Marker (object)

format

(enum NAMarkerFormat) - The format you would like the marker's Y-axis value. The number in parenthesis following the format is the number of values that are returned in a variant array. Choose from:

0 - naMarkerFormat_LinMag (1)
1 - naMarkerFormat_LogMag (1)
2 - naMarkerFormat_Phase (1)
3 - naMarkerFormat_Delay (1)
4 - naMarkerFormat_Real (1)
5 - naMarkerFormat_Imaginary (1)
6 - naMarkerFormat_SWR (1)
7 - naMarkerFormat_LinMagPhase (2)
8 - naMarkerFormat_LogMagPhase (2)
9 - naMarkerFormat_RealImaginary (2)
10 - naMarkerFormat_ComplexImpedance (3)
11 - naMarkerFormat_ComplexAdmittance (3)

Return Type

Variant - The previous list of formats indicates the number of values that are returned in a variant array

Default

Not applicable

Examples

YVal = mark.Value 'Read

C++ Syntax

HRESULT get_Value(tagNAMarkerFormat format, VARIANT *pVal)

Interface

IMarker


Write/Read
About Modifying Cal Kits

MaximumFrequency Property

Description

Sets and Returns the maximum frequency for the calibration standard.

VB Syntax

calstd.MaximumFrequency = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(double) - Maximum frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

calstd.MaximumFrequency = 9e9 'Write

maxFrequency = calstd.MaximumFrequency 'Read

C++ Syntax

HRESULT get_MaximumFrequency(double *pVal)
HRESULT put_MaximumFrequency(double newVal)

Interface

ICalStandard


Read only
About PNA Options

MaximumFrequency Property

Description

Returns the maximum frequency of the remote PNA.

VB Syntax

value = cap.MaximumFrequency

Variable

(Type) - Description

value

(Double) - Variable to store the returned maximum frequency of the PNA.

cap

A Capabilities (object)

Return Type

Double

Default

Not Applicable

Examples

value = cap.MaximumFrequency 'Read

C++ Syntax

HRESULT get_MaximumFrequency(&frequencyMax);

Interface

ICapabilities


MaximiumFrequency (sourceCal) Property

Write/Read
About Source Power Cal

MaximumFrequency (Source Power Cal) Property

Description

Maximum usable frequency specified for the power sensor.

VB Syntax

pwrSensor.MaximumFrequency = value

Variable

(Type) - Description

pwrSensor

(object) - A PowerSensor (object)

value

(double) -Frequency in Hertz.

Return Type

Double

Default

0

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.PowerSensors(1).MaximumFrequency = 6e9 'Write

MaxFreq = powerCalibrator.PowerSensors(1).MaximumFrequency 'Read

C++ Syntax

HRESULT put_MaximumFrequency(double newVal);

HRESULT get_MaximumFrequency(double *pVal);

Interface

IPowerSensor


Read-only
About Pulsed Application

MaximumIFFilterSampleCount Property

Description

Returns the maximum allowed value for the IFFilterSampleCount property for the queried PNA.

Note: An error will occur if this command is used on a PNA without option H08 installed.

VB Syntax

IfConfig.MaximumIFFilterSampleCount = value

Variable

(Type) - Description

IfConfig

IFConfiguration (object)

value

(long) The maximum allowed value that can be applied to the IFFilterSampleCount property.

Return Type

Long Integer

Default

PNA Model number dependent

Examples

variable = App.ActiveChannel.IFConfiguration.MaximumIFFilterSampleCount 'Read

See an example program

C++ Syntax

HRESULT get_MaximumIFFilterSampleCount( long * pMaxSampleCount );

Interface

IIFConfiguration2


Write / Read

About Source Power Cal

MaximumIterationsPerPoint Property

Description

Sets the maximum number of readings to take at each data point for iterating the source power. Power readings will continue to made, and source power adjusted, until a reading is within the IterationsTolerance value or this max number of readings has been met. The last value to be read is the valid reading for that data point.

VB Syntax

pwrCal.MaximumIterationsPerPoint = value

Variable

(Type) - Description

pwrCal

(object) - A SourcePowerCalibrator (object)

value

(Long) – Maximum number of readings. Choose any number between 1 and 100.

Return Type

Long Integer

Default

5

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.MaximumIterationsPerPoint = 5 'Write
MaxReads = powerCalibrator.MaximumIterationsPerPoint 'Read

C++ Syntax

HRESULT get_MaximumIterationsPerPoint( long *pVal);

HRESULT put_MaximumIterationsPerPoint( long newVal);

Interface

ISourcePowerCalibrator3


MaximumNumberOfPoints

Read only
About PNA Options

MaximumNumberOfPoints Property

Description

Returns the maximum possible number of data points.

VB Syntax

value = cap.MaximumNumberOfPoints

Variable

(Type) - Description

value

(Long) - Variable to store the returned maximum value for number of points.

cap

A Capabilities (object)

Return Type

Long

Default

Not Applicable

Examples

value = cap.MaximumNumberOfPoints 'Read

C++ Syntax

HRESULT get_MaximumNumberOfPoints(double * maximumNumberOfPoints );

Interface

ICapabilities


Read only
About PNA Options

MaximumReceiverStepAttenuator Property

Description

Returns the maximum amount of receiver attenuation.

VB Syntax

value = cap.MaximumReceiverStepAttenuator (n)

Variable

(Type) - Description

value

(Double) - Variable to store the returned value of maximum receiver attenuation.

cap

A Capabilities (object)

n

(Long) - port number to query for step attenuators

Return Type

Double

Default

Not Applicable

Examples

value = cap.MaximumReceiverStepAttenuator'Read

C++ Syntax

HRESULT get_MaximumReceiverStepAttenuator(long portNumber, double * attenuation );

Interface

ICapabilities


Read only
About PNA Options

MaximumSourceALCPower Property

Description

Returns a value indicating the maximum amount of source ALC power.

VB Syntax

value = cap.MaximumSourceALCPower (n)

Variable

(Type) - Description

value

(Double) - Variable to store the returned value for the maximum amount of source ALC power.

cap

A Capabilities (object)

n

(Long) - source number to query for maximum ALC power

Return Type

Double

Default

Not Applicable

Examples

value = cap.MaximumSourceALCPower'Read

C++ Syntax

HRESULT get_MaximumSourceALCPower(long sourceNum, double * power );

Interface

ICapabilities


Read only
About PNA Options

MaximumSourceStepAttenuator Property

Description

Returns a value for the maximum amount of source attenuation.

VB Syntax

value = cap.MaximumSourceStepAttenuator (n)

Variable

(Type) - Description

value

(Double) - Variable to store the returned value for the maximum amount of source attenuation.

cap

A Capabilities (object)

n

(Long) - port number to query for the maximum amount of source attenuation

Return Type

Double

Default

Not Applicable

Examples

value = cap.MaximumSourceStepAttenuator'Read

C++ Syntax

HRESULT get_MaximumSourceStepAttenuator(long portNumber, double * attenuation );

Interface

ICapabilities


Read-only

About Trace Statistics

Mean Property

Description

Returns the mean value of the measurement . To retrieve all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

average = meas.Mean

Variable

(Type) - Description

average

(single) - Variable to store mean value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

Dim average as Single
average = meas.Mean 'Read

C++ Syntax

HRESULT get_Mean(float* mean)

Interface

IMeasurement


Write/Read
About Modifying Cal Kits

Medium Property

Description

Sets and Returns the media type of the calibration standard.

VB Syntax

calstd.Medium = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(enum NACalStandardMedium) - Medium of the transmission line of the standard. Choose from:
0 - naCoax - Coaxial Cable
1 - naWaveGuide

Return Type

Long Integer

Default

Not Applicable

Examples

calstd.Medium = naCoax 'Write

stdMedium = calstd.Medium 'Read

C++ Syntax

HRESULT get_Medium(tagNACalStandardMedium *pVal)
HRESULT put_Medium(tagNACalStandardMedium newVal)

Interface

ICalStandard


Write/Read

About Modifying Cal Kits

MinimumFrequency Property

Description

Sets and Returns the minimum frequency for the calibration standard.

VB Syntax

calstd.MinimumFrequency = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(double) -Minimum frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

calstd.MinimumFrequency = 300e3 'Write

minFrequency = calstd.MinimumFrequency 'Read

C++ Syntax

HRESULT get_MinimumFrequency(double *pVal)
HRESULT put_MinimumFrequency(double newVal)

Interface

ICalStandard


Read only
About PNA Options

MinimumFrequency Property

Description

Returns the minimum frequency of the remote PNA.

VB Syntax

value = cap.MinimumFrequency

Variable

(Type) - Description

value

(Double) - Variable to store the returned minimum frequency of the PNA.

cap

A Capabilities (object)

Return Type

Double

Default

Not Applicable

Examples

value = cap.MinimumFrequency 'Read

C++ Syntax

HRESULT get_MinimumFrequency(double *pVal)

Interface

ICapabilities


MinimumFrequency (sourceCal) Property

Write/Read
About Source Power Cal

MinimumFrequency (Source Power Cal) Property

Description

Minimum usable frequency specified for the power sensor.

VB Syntax

pwrSensor.MinimumFrequency = value

Variable

(Type) - Description

pwrSensor

(object) - A PowerSensor (object)

value

(double) -Frequency in Hertz.

Return Type

Double

Default

0

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.PowerSensors(1).MinimumFrequency = 300e3 'Write

MinFreq = powerCalibrator.PowerSensors(1).MinimumFrequency 'Read

C++ Syntax

HRESULT put_MinimumFrequency(double newVal);

HRESULT get_MinimumFrequency(double *pVal);

Interface

IPowerSensor


Read-only
About Pulsed Application

MinimumIFFilterSampleCount Property

Description

Returns the Minimum allowed value for the IFFilterSampleCount property for the queried PNA.

Note: An error will occur if this command is used on a PNA without option H08 installed.

VB Syntax

IfConfig.MinimumIFFilterSampleCount = value

Variable

(Type) - Description

IfConfig

IFConfiguration (object)

value

(long) The minimum allowed value that can be applied to the IFFilterSampleCount property.

Return Type

Long Integer

Default

PNA Model number dependent

Examples

variable = App.ActiveChannel.IFConfiguration.MinimumIFFilterSampleCount 'Read

See an example program

C++ Syntax

HRESULT get_MinimumIFFilterSampleCount( long * pMinSampleCount );

Interface

IIFConfiguration2


MinimumNumberOfPoints

Read only
About PNA Options

MinimumNumberOfPoints Property

Description

Returns the minimum possible number of data points for a data trace.

VB Syntax

value = cap.MinimumNumberOfPoints

Variable

(Type) - Description

value

(Long) - Variable to store the returned minimum value for number of points.

cap

A Capabilities (object)

Return Type

Long

Default

Not Applicable

Examples

value = cap.MinimumNumberOfPoints 'Read

C++ Syntax

HRESULT get_MinimumNumberOfPoints(double * minimumNumberOfPoints );

Interface

ICapabilities


Read only
About PNA Options

MinimumReceiverStepAttenuator Property

Description

Returns a value indicating the minimum amount of receiver attenuation.

VB Syntax

value = cap.MinimumReceiverStepAttenuator (n)

Variable

(Type) - Description

value

(Double) - Variable to store the returned minimum value of receiver attenuation.

cap

A Capabilities (object)

n

(Long) - port number to query for minimum value of receiver attenuation

Return Type

Double

Default

Not Applicable

Examples

value = cap.MinimumReceiverStepAttenuator'Read

C++ Syntax

HRESULTget_ MinimumReceiverStepAttenuator(long portNumber, double * attenuation );

Interface

ICapabilities


Read only
About PNA Options

MinimumSourceALCPower Property

Description

Returns a value indicating the minimum amount of source ALC power.

VB Syntax

value = cap.MinimumSourceALCPower (n)

Variable

(Type) - Description

value

(Double) - Variable to store the returned minimum value of source ALC power.

cap

A Capabilities (object)

n

(Long) - source number to query for the minimum value of source ALC power

Return Type

Double

Default

Not Applicable

Examples

value = cap.MinimumSourceALCPower'Read

C++ Syntax

HRESULT get_MinimumSourceALCPower(long sourceNum, double * power );

Interface

ICapabilities


Name (Meas) Property

Write/Read

About Traces

Name (Measurement) Property

Description

Sets (or returns) the Name of the measurement. Measurement names must be unique among the set of measurements. Measurement names cannot be an empty string.

Note: This is the same name as trace.Name; when one changes, the other changes.

VB Syntax

meas.Name = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(string) - A user defined name of the measurement

Return Type

String

Default

"CH1_S11_1" - name of the default measurement

Examples

meas.Name = "Filter BPass" 'Write

MName = meas.Name 'Read

C++ Syntax

HRESULT get_Name(BSTR *pVal)
HRESULT put_Name(BSTR newVal)

Interface

IMeasurement


Write/Read

About Traces

Name (trace) Property

Description

Sets or returns the name of the Trace. Use the trace name to identify the trace and refer to the trace in the collection.

Note: This is the same name as meas.Name; when one changes, the other changes.

VB Syntax

trac.Name = value

Variable

(Type) - Description

trac

A Trace (object)

value

(String) Trace name

Return Type

String

Default

"CH1_S11_1" - name of the default measurement

Examples

trace.Name = "myTrace" 'Write

traceName = Name.Trace 'Read

C++ Syntax

HRESULT put_Name(BSTR name)
HRESULT get_Name(BSTR *name)

Interface

ITrace


Write/Read

About Modifying Cal Kits

Name (CalKit) Property

Description

Sets and Returns a name for the selected calibration kit.

VB Syntax

calKit.Name = value

Variable

(Type) - Description

calKit

A CalKit (object).

value

(string) -Calibration Kit name. Any string name, can include numerics, period, and spaces; any length (although the dialog box display is limited to about 30 characters).

Return Type

String

Default

Not Applicable

Examples

calKit.Name = "MyCalKit" 'Write

KitName = calKit.Name 'Read

C++ Syntax

HRESULT get_Name(BSTR *pVal)
HRESULT put_Name(BSTR newVal)

Interface

ICalKit


Write/Read
About Mixer Configuration

NominalIncidentPowerState Property

Description

Toggles the Nominal Incident Power setting ON and OFF. This setting is ONLY to be used with SMC measurements, not VMC. Learn more about Nominal Incident Power.

VB Syntax

mixer.NominalIncidentPowerState = bool

Variable

(Type) - Description

mixer

A Mixer (object)

bool

(boolean) - Nominal Incident Power State. Choose from:

1 -(True) Turn nominal incident power ON

0 -(False) Turn nominal incident power OFF

Return Type

Boolean

Default

0 -(False)

Examples

mixer.NominalIncidentPowerState = True 'sets NominalIncidentPowerState to ON

C++ Syntax

HRESULT get_NominalIncidentPowerState(VARIANT_BOOL *pVal)

HRESULT put_NominalIncidentPowerState(VARIANT_BOOL val );

Interface

IMixer4


Write/Read
About Receiver Cal

Normalization Property

Description

Sets or returns normalization ON or OFF for the measurement. Normalization is currently supported only on measurements of unratioed power for the purpose of performing a receiver power calibration. If this property is set to ON for a ratioed measurement (such as S-parameter), it will return an error. This property will also return an error when set to ON if the divisor buffer doesn’t yet exist.

VB Syntax

meas.Normalization = value

Variable

(Type) - Description

meas

(object) - A Measurement object

value

(boolean)

0 – Turns normalization OFF

1 – Turns normalization ON

Return Type

Boolean

Default

0 -OFF

Examples

meas.Normalization = 1 'Write

normalized = meas.Normalization 'Read

C++ Syntax

HRESULT put_Normalization(VARIANT_BOOL bState);

HRESULT get_Normalization(VARIANT_BOOL *bState);

Interface

IMeasurement


Number (meas) Property

Read-only

About Measurements

Number (Measurement) Property

Description

Returns the Number of the measurement. Measurement numbers are assigned internally.

Note: Measurement numbers are NOT the same as their number in the Measurements collection. Measurement number is used to identify the measurement associated with an event.

This property is used to identify measurements when events occur through the OnMeasurementEvent callback. For example:

OnMeasurementEvent (naEventId_MSG_LIMIT_FAILED, 3)

VB Syntax

measNum = meas.Number

Variable

(Type) - Description

measNum

(long) - variable to store the measurement number

meas

A Measurement (object)

Return Type

Long Integer

Default

"1" - number of the default measurement

Examples

measNum = meas.Number

C++ Syntax

HRESULT get_Number(long *MeasurementNumber)

Interface

IMeasurement


Number of Points Property

Write/Read

About Number of Points

NumberOfPoints Property

Description

Sets or returns the Number of Points of the channel.
Sets or returns the Number of Points of the segment.

see also Measurement2 interface

VB Syntax

object.NumberOfPoints = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(long) - Number of Points.

For channel, choose any number from 1 to 16001.

For segment, the total number of points in all segments cannot exceed 16001. A segment can have as few as 1 point.

Return Type

Long Integer

Default

201 for channel

21 for segment

Examples

chan.NumberOfPoints = 201 'sets the number of points for all measurements in the channel. -Write

numofpts = chan.NumberOfPoints 'Read

C++ Syntax

HRESULT get_NumberOfPoints(long *pVal)
HRESULT put_NumberOfPoints(long newVal)

Interface

IChannel
ISegment

|CalSet3


NumberofPoints_meas Property

Read-only

NumberOfPoints Property

Description

Returns the number of data points of the measurement. To understand how this property is useful, see IMeasurement2 Interface.

VB Syntax

value = meas.NumberOfPoints

Variable

(Type) - Description

value

(Long) - variable to store the returned value

meas

A Measurement (object)

Return Type

Long Integer

Default

Not Applicable

Examples

Print meas.NumberOfPoints 'prints the number of data points

C++ Syntax

HRESULT get_NumberOfPoints(long *pVal);

Interface

IMeasurement2


Read-only

NumberOfPorts Property

Description

Returns the number of hardware source ports on the PNA.

VB Syntax

value = app.NumberOfPorts

Variable

(Type) - Description

app

An Application (object)

value

(long integer) - variable to contain the returned value

Return Type

(long integer)

Default

Not Applicable

Examples

iNumPorts = app.NumberOfPorts

C++ Syntax

HRESULT NumberOfPorts( long* NumPorts)

Interface

IApplication


Read/Write

OmitIsolation Property

Description

Sets and returns whether Isolation portion of the calibration will be performed or not.

VB Syntax

obj.OmitIsolation = bool

Variable

(Type) - Description

obj

SMCType (object)

or

VMCType (object)

bool

(Boolean)

1 - Isolation is NOT performed

0 - Isolation is performed

Return Type

Boolean

Default

1

Examples

value = SMC.OmitIsolation

C++ Syntax

HRESULT put_OmitIsolation (VARIANT_BOOL bState)
HRESULT get_OmitIsolation (VARIANT_BOOL *bState)

Interface

SMCType

VMCType


Write/Read

About Marker Readout

OneReadoutPerTrace Property

Description

Either show marker readout of only the active trace or all of the traces simultaneously.

VB Syntax

win.OneReadoutPerTrace = state

Variable

(Type) - Description

win

A NAWindow (object)

value

(boolean)

True (1) - show a single marker per trace
False (0) - show up to 4 markers per active trace

Return Type

Boolean

Default

False (0)

Examples

win.OneReadoutPerTrace = True 'Write

State = app.ActiveNAWindow.OneReadoutPerTraceBegResp 'Read

C++ Syntax

HRESULT get_OneReadoutPerTrace(VARIANT_BOOL *pVal)
HRESULT put_OneReadoutPerTrace(VARIANT_BOOL newVal)

Interface

INAWindow


Read-only
About Options

Options Property

Description

Returns a string identifying the analyzer option configuration.

VB Syntax

value = app.Options

Variable

(Type) - Description

app

An Application (object)

value

(string) - variable to contain the returned string

Return Type

String

Default

Not Applicable

Examples

availOptions = app.Options

C++ Syntax

HRESULT Options(BSTR* OptionString)

Interface

IApplication


OrientECALModule_Property

Write/Read

OrientECALModule Property

Description

Specifies if the PNA should perform orientation of the ECal module during calibration. Orientation is a technique by which the PNA automatically determines which ports of the module are connected to which ports of the PNA. Orientation begins to fail at very low power levels or if there is much attenuation in the path between the PNA and the ECal module.

VB Syntax

cal.OrientECALModule = value

Variable

(Type) - Description

cal

A Calibrator (object)

value

(boolean)

False (0) – DoECAL1Port and DoECAL2Port methods will use the value of the ECALPortMap property to determine the port connections.

True (1) - DoECAL1Port and DoECAL2Port methods will use Orientation technique to determine port connections.

Return Type

Boolean

Default

True (1)

Examples

Dim cal As Calibrator

Dim bOrient As Boolean

Set cal = PNAapp.ActiveChannel.Calibrator

cal.OrientECALModule = False 'Write

bOrient = cal.OrientECALModule 'Read

C++ Syntax

HRESULT put_OrientECALModule(VARIANT_BOOL bOrient);

HRESULT get_OrientECALModule(VARIANT_BOOL *bOrient);

Interface

ICalibrator3


Write/Read
About Mixer Configuration

OutputFixedFrequency Property

Description

Sets or returns the mixer output fixed frequency value. This command can only be used with SMC (not VMC) measurements.

VB Syntax

mixer.OutputFixedFrequency = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - Output Fixed Frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

Print mixer.OutputFixedFrequency 'prints the output fixed frequency value of the mixer.

C++ Syntax

HRESULT get_OutputFixedFrequency(double *pVal)

HRESULT put_OutputFixedFrequency(double newVal)

Interface

IMixer3


OutputSideband_Property

Write/Read
About Mixer Configuration

OutputSideband Property

Description

Sets or returns the value of the output sideband, high or low.

VB Syntax

mixer.OutputSideband = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(FCASideBand) -

Choose from:

0 - LOW

1 - HIGH

Return Type

FCASideBand

Default

LOW

Examples

Print mixer.OutputSideband 'prints the value of the OutputSideband

C++ Syntax

HRESULT get_OutputSideband(FCASideBand *pVal)

HRESULT put_OutputSideband(FCASideBand newVal)

Interface

IMixer


OutputStartFrequency_Property

Write/Read
About Mixer Configuration

OutputStartFrequency Property

Description

Sets or returns the mixer output start frequency.

VB Syntax

mixer.OutputStartFrequency = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - Output Start Frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

Print mixer.OutputStartFrequency 'prints the value of the OutputStartFrequency

C++ Syntax

HRESULT get_OutputStartFrequency(double *pVal)

HRESULT put_OutputStartFrequency(double newVal)

Interface

IMixer


OutputStopFrequency_Property

Write/Read
About Mixer Configuration

OutputStopFrequency Property

Description

Sets or returns the mixer Output Stop frequency.

VB Syntax

mixer.OutputStopFrequency = value

Variable

(Type) - Description

mixer

A Mixer (object)

value

(double) - Output stop frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

Print mixer.OutputStopFrequency 'prints the value of the OutputStopFrequency

C++ Syntax

HRESULT get_OutputStopFrequency(double *pVal)

HRESULT put_OutputStopFrequency(double newVal)

Interface

IMixer


Read-only

Parameter Property

Description

Returns the measurement Parameter. To change the parameter, use meas.ChangeParameter

VB Syntax

measPar = meas.Parameter

Variable

(Type) - Description

measPar

(string) - Variable to store Parameter string

meas

A Measurement (object)

Return Type

String

Default

Not applicable

Examples

measPar = meas.Parameter 'Read

C++ Syntax

HRESULT get_Parameter(BSTR *pVal)

Interface

IMeasurement


Read-only

Parent Property

Description

Returns a handle to the parent object of the collection object being refered to in the statement. The parent property allows the user to traverse from an object back up the object hierarchy.

VB Syntax

object.Parent

Variable

(Type) - Description

object

Channels collection
Channel object
Measurements collection
NAWindows collection
Traces collection
Segments collection
PowerSensors collection
CalFactorSegments collection
PowerLossSegments collection

Return Type

Object

Default

Not Applicable

Examples

parentobj = chans.Parent 'returns a handle to the parent object (Application) of the chans collection. -Read

C++ Syntax

HRESULT get_Parent(IApplication* *pApplication); //IChannels, IChannel, IMeasurements and INAWindows

HRESULT get_Parent(IChannel* *pChannel); //ITraces

HRESULT get_Parent(INAWindow* *pWindow); //ISegments

HRESULT get_Parent(IPowerSensor* *pSensor); //ICalFactorSegments

HRESULT get_Parent(ISourcePowerCalibrator* *pCalibrator); //IPowerSensors and IPowerLossSegments

Interface

IChannels

IChannel

IMeasurements

INAWindows

ITraces

ISegments

IPowerSensors

ICalFactorSegments

IPowerLossSegments


Read/Write

PassFailLogic Property

Description

Sets and reads the logic of the PassFail line on the HANDLER IO connector (pin 33) and AUX IO connector (pin 12). Learn more about Global Pass/Fail.

Note: This line is connected to both the Handler IO and Aux IO in the PNA. Therefore, this command will affect both of these connectors in the same way.

VB Syntax

object.PassFailLogic = value

Variable

(Type) - Description

object

(object) - An Aux I/O or Handler I/O object

value

(enum as NARearPanelIOLogic) Choose from:

0 - naPositiveLogic - Causes the PassFail line to have positive logic (high = pass, low = fail).

1 - naNegativeLogic - Causes the PassFail line to have negative logic (high = fail, low = pass).

Return Type

Long Integer

Default

naPositiveLogic

Examples

aux.PassFailLogic = naNegativeLogic 'Write

Text1.Text = aux.PassFailLogic 'Read

C++ Syntax

HRESULT put_PassFailLogic ( tagNARearPanelIOLogic Mode );

HRESULT get_PassFailLogic ( tagNARearPanelIOLogic* Mode );

Interface

IHWAuxIO

IHWMaterialHandlerIO


Read/Write

PassFailMode Property

Description

Sets and reads the mode of the PassFail line on the HANDLER IO connector (pin 33) and AUX IO connector (pin 12). Learn more about Global Pass/Fail.

Note: This line is connected to both the Handler IO and Aux IO in the PNA. Therefore, this command will affect both of these connectors in the same way.

VB Syntax

object.PassFailMode = value

Variable

(Type) - Description

object

(object) - An Aux I/O or Handler I/O object

value

(enum as NAPassFailMode).Choose from:
0 - naDefaultPassNoWaitMode- the line stays in PASS state. When a device fails, then the line goes to fail IMMEDIATELY.

1 - naDefaultPassWaitMode - the line stays in PASS state. When a device fails, then the line goes to fail after the Sweep End line is asserted.

2 - naDefaultFailWaitMode- the line stays in FAIL state. When a device passes, then the line goes to PASS state after the Sweep End line is asserted.

Return Type

Long Integer

Default

0 - naDefaultPassNoWaitMode

Examples

HWAuxIO.PassFailMode = naDefaultPassNoWaitMode 'Write

mode = HWAuxIO.PassFailMode 'Read

C++ Syntax

HRESULT put_PassFailMode ( tagNAPassFailMode Mode );

HRESULT get_PassFailMode ( tagNAPassFailMode* Mode );

Interface

IHWAuxIO

IHWMaterialHandlerIO


Read/Write

PassFailPolicy Property

Description

Sets the policy used to determine how global pass/fail is computed. Learn more about Global Pass/Fail.

VB Syntax

object.PassFailPolicy = value

Variable

(Type) - Description

object

(object) - An Aux I/O or Handler I/O object

value

(enum as NAPassFailPolicy) Choose from:

0 - naPolicyAllTests - - Pass/Fail Status returns PASS if all tests on all measurements pass.

1 - naPolicyAllMeas - Pass/Fail Status returns PASS if all measurements have associated tests, and all tests pass. FAIL is returned if even one measurement has no associated limit test.

Only those measurements which are not in HOLD mode contribute to the pass/fail result.

Return Type

Long Integer

Default

naPolicyAllTests

Examples

matHndler.PassFailPolicy = naPolicyAllTests 'Write

policy = aux.PassFailPolicy 'Read

C++ Syntax

HRESULT put_PassFailPolicy ( tagNAPassFailPolicy Policy);

HRESULT get_PassFailPolicy ( tagNARearPanelIOLogic* Policy);

Interface

IHWAuxIO4

IHWMaterialHandlerIO2


Read/Write

PassFailScope Property

Description

Sets and reads the Scope of the PassFail line on the HANDLER IO connector (pin 33) and AUX IO connector (pin 12). Learn more about Global Pass/Fail.

Note: The PassFail line is connected to both the Handler IO and Aux IO in the PNA. Therefore, this command will affect both of these connectors in the same way.

VB Syntax

object.PassFailScope = value

Variable

(Type) - Description

object

(object) - An Aux I/O or Handler IO object

value

(enum NAPassFailScope ) Choose from:

0 - naChannelScope - The PassFail line returns to its default state before sweeps on the next channel start. (A channel measurement may require several sweeps.)

1 - naGlobalScope - The PassFail line returns to its default state before the sweeps for the next triggerable channel start.

The default state of the PassFail line before a measurement occurs and after a failure occurs is set by the PassFailMode property.

Return Type

enum NAPassFailScope

Default

1 - naGlobalScope

Examples

HWAuxIO.PassFailScope = naGlobalScope 'Write

scope = HWAuxIO.PassFailScope 'Read

C++ Syntax

HRESULT put_PassFailScope ( tagNAPassFailScope Scope );

HRESULT get_PassFailScope ( tagNAPassFailScope* Scope );

Interface

IHWAuxIO

IHWMaterialHandlerIO


Read-Only

PassFailStatus Property

Description

Returns the most recent pass/fail status value. Use this command as follows:

  1. Set the PNA trigger scope to GLOBAL

  2. Set the PNA trigger source to MANUAL or EXTERNAL.

  3. Configure and enable Limit Testing

  4. Trigger the PNA.

  5. Use the *OPC? (with SCPIStringParser object) to determine when the sweep is complete.

  6. Use the PassFailStatus property to obtain the global pass/fail result.

Learn more about Global Pass/Fail.

VB Syntax

var = object.PassFailStatus

Variable

(Type) - Description

var

(enum as NAPassFailStatus) Variable to store returned status. One of the following will be returned:

0 - naStatusFail - all measurements not in HOLD mode have been swept, and one or more limit tests failed according to the specified Pass/Fail policy.

1 - naStatusPass - all measurements not in HOLD mode have been swept, and all associated limit tests have passed.

2 - naStatusNone - status cannot be determined because measurements are in progress.

object

(object) - An Aux I/O or Handler I/O object

Return Type

Long Integer

Default

Not Applicable

Examples

status = aux.PassFailStatus 'Read

C++ Syntax

HRESULT get_PassFailPolicy ( tagNAPassFailStatus* status);

Interface

IHWAuxIO4

IHWMaterialHandlerIO2


Peak Excursion Property

Write/Read

About Marker Search

PeakExcursion Property

Description

Sets and reads the peak excursion value for the specified marker. The Excursion value determines what is considered a "peak".

VB Syntax

mark.PeakExcursion = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Peak Excursion. Choose any number between -500 and 500

Return Type

Single

Default

3

Examples

mark.PeakExcursion = 1 'Write

PkExcur = mark.PeakExcursion 'Read

C++ Syntax

HRESULT get_PeakExcursion(float *pVal)
HRESULT put_PeakExcursion(float newVal)

Interface

IMarker


Peak Threshold Property

Write/Read

About Marker Search

PeakThreshold Property

Description

Sets peak threshold for the specified marker. If a peak (using the criteria set with PeakExcursion) is below this reference value, it will not be considered when searching for peaks.

VB Syntax

mark.PeakThreshold = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Peak Threshold. Choose any number between:
-500 and 500

Return Type

Single

Default

-100db

Examples

mark.PeakThreshold = 1 'Write

PkThresh = mark.PeakThreshold 'Read

C++ Syntax

HRESULT get_PeakThreshold(float *pVal)
HRESULT put_PeakThreshold(float newVal)

Interface

IMarker


Read-only
About Trace Statistics

PeakToPeak Property

Description

Returns the Peak to Peak value of the measurement.To retreive all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

pp = meas.PeakToPeak

Variable

(Type) - Description

pp

(single) - Variable to store peak-to-peak value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

pp = meas.PeakToPeak 'Read

C++ Syntax

HRESULT get_PeakToPeak(float* pp)

Interface

IMeasurement


Phase Offset Property

Write/Read

About Phase Offset

PhaseOffset Property

Description

Sets the Phase Offset for the active channel.

VB Syntax

meas.PhaseOffset = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - PhaseOffset in degrees. Choose any number between:
-360 and +360

Return Type

Double

Default

0

Examples

meas.PhaseOffset = 25 'Write

poffset = meas.PhaseOffset 'Read

C++ Syntax

HRESULT get_PhaseOffset(double *pVal)
HRESULT put_PhaseOffset(double newVal)

Interface

IMeasurement


Port 1 Property

Write/Read

About Port Extensions

Port1 Property

Description

Sets a Port Extension value for Port 1

VB Syntax

portExt.Port1 = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.Port1 = 10e-6 'Write

prt1 = portExt.Port1 'Read

C++ Syntax

HRESULT get_Port1(double *pVal)
HRESULT put_Port1(double newVal)

Interface

IPortExtension


Port 2 Property

Write/Read
About Port Extensions

Port2 Property

Description

Sets a Port Extension value for Port 2

VB Syntax

portExt.Port2 = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.Port2 = 10e-6 'Write

prt2 = portExt.Port2 'Read

C++ Syntax

HRESULT get_Port2(double *pVal)
HRESULT put_Port2(double newVal)

Interface

IPortExtension


Port_3_Property

Write/Read

About Port Extensions

Port3 Property

Description

Sets a Port Extension value for Port 3

VB Syntax

portExt.Port3 = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.Port3 = 10e-6 'Write

prt3 = portExt.Port3 'Read

C++ Syntax

HRESULT get_Port3(double *pVal)
HRESULT put_Port3(double newVal)

Interface

IPortExtension


Read/Write

About the Aux I/O Connector

PortCLogic Property

Description

Sets and reads the logic mode of Port C on the AUX IO connector and the Handler IO connector.

Note: Port C lines are connected to both the Handler IO and Aux IO in the PNA. Therefore, this command will affect both of these connectors in the same way.

VB Syntax

AuxIO.PortCLogic = value

Variable

(Type) - Description

AuxIO

(object) - A Hardware Aux I/O object

value

(Enum as NaRearPanelIOLogic) - Choose from:

0 - naPositiveLogic - The associated data line goes HIGH when writing a 1 to a PortC bit.

1 - naNegativeLogic - The associated data line goes LOW when writing a 1 to a PortC bit.

When Port C is in Output/Write mode, a change in logic causes the output lines to change state immediately. For example, Low levels change to High levels.

When Port C is in Input/Read mode, a change in logic will not cause the lines to change, but data read from Port C will reflect the change in logic.

Return Type

Enum

Default

1 - naNegativeLogic

Examples

auxIO.PortCLogic = value 'Write

value = auxIo.PortCLogic 'Read

C++ Syntax

HRESULT put_PortCLogic ( tagNARearPanelIOLogic Mode );

HRESULT get_PortCLogic ( tagNARearPanelIOLogic* Mode );

Interface

IHWAuxIO


Read/Write

About the Aux I/O Connector

PortCMode Property

Description

Sets and reads whether Port C is setup for writing or reading data on the AUX IO connector and the Handler IO connector.

Note: Port C lines are connected to both the Handler IO and Aux IO in the PNA. Therefore, this command will affect both of these connectors in the same way.

VB Syntax

AuxIO.PortCMode = value

Variable

(Type) - Description

AuxIO

(object) - A Hardware Aux I/O object

value

(enum as NaPortMode) - Choose from:

0 - naInput - set the port for reading

1 - naOutput - set the port for writing

Return Type

Enum as NaPortMode

Default

1 - naInput

Examples

auxIo.get_PortCMode = naInput 'Write

value = auxIo.get_PortCMode 'Read

C++ Syntax

HRESULT get_PortCMode( tagNAPortMode* pMode );

HRESULT put_PortCMode( tagNAPortMode pMode );

Interface

IHWAuxIO


Write/Read
About Modifying Cal Kits

PortLabel Property

Description

Sets and returns the label on the calibration kit Port for the calibration wizard.

VB Syntax

calKit.Portlabel (portNum) = value

Variable

(Type) - Description

calKit

A CalKit (object)

portNum

(long integer) - number of the port to be labeled. Choose either 1 or 2

value

(string) - Label that is visible in the calibration wizard.

Return Type

String

Default

Depends on the Cal Kit.

Examples

calKit.PortLabel = "MyCalKit" 'Write

kitLabel = calKit.PortLabel 'Read

C++ Syntax

HRESULT get_PortLabel(long port, BSTR *pVal)
HRESULT put_PortLabel(long port, BSTR newVal)

Interface

ICalKit


Read/Write

About the Handler I/O Connector

PortLogic Property

Description

Sets and returns the logic mode of data ports A-H on the HandlerIO connector. Port C of the Handler IO is connected internally to the Port C of the Aux IO connector. Therefore, it will have the same logic mode.

VB Syntax

handler.PortLogic = value

Variable

(Type) - Description

handler

(object) - A HandlerI/O object

value

(enum as NaRearPanelIOLogic) - Choose from:

0 - naPositiveLogic - When a value of one is written, the associated line goes High

1 - naNegativeLogic - When a value of one is written, the associated line goes Low

For ports that are in output (write) mode, a change in logic causes the output lines to change state immediately. For example, Low levels change immediately to High levels.

For ports that are in input (read) mode (C,D,E only), a change in logic will be reflected when data is read from that port. For example, if a line read 0, the next read after a logic change will read 1.

Return Type

Long Integer

Default

1 - naNegativeLogic

Examples

handler.PortLogic = value 'Write

value = handler.PortLogic 'Read

C++ Syntax

HRESULT put_PortLogic( tagNARearPanelIOLogic Mode );

HRESULT get_PortLogic( tagNARearPanelIOLogic* Mode );

Interface

IHWMaterialHandlerIO


Read/Write
About the Handler I/O Connector

PortMode Property

Description

Sets and returns whether Port C or Port D is used for writing or reading data on the Handler IO connector. The Handler IO Port C is connected internally to the Port C of the Aux IO connector. Therefore, the Aux IO connector will have the same input/output mode.

VB Syntax

handler.PortMode (port) = value

Variable

(Type) - Description

handler

(object) - A Handler I/O object

port

(enum as NAMatHandlerPort) Port to be changed. Choose from:

2 -naPortC

3- naPortD

value

(enum as NaPortMode) - Choose from:

0 - naInput - set the port for reading

1 - naOutput - set the port for writing

Return Type

Long Integer

Default

1 - naInput

Examples

handler.PortMode(naPortC) = naInput 'Write

value = handler.PortMode(naPortD) 'Read

C++ Syntax

HRESULT put_PortMode ( tagNAMatHandlerPort Port, tagNAPortMode Mode );

HRESULT get_PortMode ( tagNAMatHandlerPort Port, tagNAPortMode* Mode );

Interface

IHWMaterialHandlerIO


Power Slope Property

Write/Read
About Power Slope

PowerSlope Property

Description

Sets or returns the Power Slope value. Power Slope function increases or decreases the output power over frequency. Units are db/GHz. For example: PowerSlope = 2 will increase the power 2db/1GHZ.

VB Syntax

object.PowerSlope = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(double) - Power Slope. Choose any number between -2 and 2.
No slope = 0

Return Type

Double

Default

0

Examples

chan.PowerSlope = 2 'Write

pwrslp = chan.PowerSlope 'Read

C++ Syntax

HRESULT get_PowerSlope(double *pVal)
HRESULT put_PowerSlope(double newVal)

Interface

IChannel

|CalSet3


Read only
About Power Calibration

PowerAcquisitionDevice Property

Description

Returns the power sensor channel (A or B) that is currently selected for use at a specific frequency.

If UsePowerSensorFrequencyLimits is set to False, this property will return the sensor channel last used for a source power calibration. This setting corresponds to the Use this sensor only checkbox in the Power Sensor Settings dialog.

When performing an SMC calibration, use SetPowerAcquisitionDevice Method to set the power sensor channel.

VB Syntax

sensor = pwrCal.PowerAcquisitionDevice(dFreq)

Variable

(Type) - Description

sensor

(enum NAPowerAcquisitionDevice) The currently selected sensor channel for the specified frequency. Choose from:

0 – naPowerSensor_A

1 – naPowerSensor_B

pwrCal

A SourcePowerCalibrator (object)

dFreq

(double) Frequency (Hz) for the power reading of interest.

Return Type

enum NAPowerAcquisitionDevice

Default

Not Applicable

Examples

selectedSensor = pwrCal.PowerAcquisitionDevice(1.E9) 'Write

C++ Syntax

HRESULT get_PowerAcquisitionDevice(double dFreq, tagNAPowerAcquisitionDevice* enumAcqDevice);

Interface

ISourcePowerCalibrator2


Read-only

About Source Power Cal

PowerMeterChannel Property

Description

Identifies which channel of the power meter the power sensor is connected to.

VB Syntax

chan = powerSensor.PowerMeterChannel

Variable

(Type) - Description

chan

(enum NAPowerAcquisitionDevice) – Power meter channel identifier for sensor. Choose from:

0 – naPowerSensor_A

1 – naPowerSensor_B

pwrSensor

(object) - A PowerSensor (object)

Return Type

NAPowerAcquisitionDevice

Default

Not Applicable

Examples

Set pwrCal = pna.SourcePowerCalibrator
meterChannel = pwrCal.PowerSensors(1).PowerMeterChannel

C++ Syntax

HRESULT PowerMeterChannel(tagNAPowerAcquisitionDevice *pSensor);

Interface

IPowerSensor


Write / Read

About Source Power Cal

PowerMeterGPIBAddress Property

Description

Specifies the GPIB address of the power meter that will be referenced by the SourcePowerCalibrator object.

When performing a source power cal, the PNA will search VISA interfaces that are configured in the Agilent IO LIbraries on the PNA.

VB Syntax

powerCalibrator.PowerMeterGPIBAddress = value

Variable

(Type) - Description

powerCalibrator

(object) - A SourcePowerCalibrator (object)

value

(long integer) – Power meter GPIB address. Choose any number between 0 and 30.

Return Type

Long integer

Default

13

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.PowerMeterGPIBAddress = 13 'Write

pwrMtrAddress = powerCalibrator.PowerMeterGPIBAddress 'Read

C++ Syntax

HRESULT put_PowerMeterGPIBAddress(long newVal);

HRESULT get_PowerMeterGPIBAddress(long *pVal);

Interface

ISourcePowerCalibrator


R1inputPath_Property

Write/Read
About Frequency Offset

R1inputPath Property

Description

PNA models with option 081 have a switch in the test set that allows access to the port 1 reference receiver through the front panel Reference 1 connectors. This command throws that switch between the internal path to the receiver, or through the external connectors. You could use this feature to make converter measurements relative to a reference ("golden") mixer.

See other Frequency Offset properties.

VB Syntax

chan.R1InputPath = value

Variable

(Type) - Description

chan

A Channel (object)

value

(Enum as naInputPath) - Choose from:naPathInternal -

(0) - internal path to the reference receiver naPathExternal

(1) - path through external connectors

Return Type

Enum

Default

naPathInternal - (0)

Examples

chan.R1InputPath = naPathInternal 'Write

Inpath = chan.R1InputPath 'Read

C++ Syntax

HRESULT get_R1InputPath (tag NAInputPath *pPath);

HRESULT put_R1InputPath (tag NAInputPath newPath);

Interface

IChannel2


Write / Read

About Source Power Cal

ReadingsPerPoint Property

Description

Specifies the maximum number of power readings that are taken at each stimulus point to allow for power meter settling. Each reading is averaged with the previous readings at that stimulus point. When this average meets the ReadingsTolerance value or this number of readings has been made, the average is returned as the valid reading.

VB Syntax

pwrCal.ReadingsPerPoint = value

Variable

(Type) - Description

pwrCal

(object) - A SourcePowerCalibrator (object)

value

(long integer) – Number of power readings. Choose any number between 3 and 100.

Return Type

Long Integer

Default

3

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.ReadingsPerPoint = 3 'Write

numReadings = powerCalibrator.ReadingsPerPoint 'Read

C++ Syntax

HRESULT put_ReadingsPerPoint(long newVal);

HRESULT get_ReadingsPerPoint(long *pVal);

Interface

ISourcePowerCalibrator


Write / Read

About Source Power Cal

ReadingsTolerance Property

Description

Each power reading is averaged with the previous readings at each stimulus point. When the average meets this tolerance value or the maximum ReadingsPerPoint has been made, the average is returned as the valid reading.

VB Syntax

pwrCal.ReadingsTolerance = value

Variable

(Type) - Description

pwrCal

(object) - A SourcePowerCalibrator (object)

value

(Double) – Power meter settling tolerance value in dB. Choose any number between 0 and 5.

Return Type

Double

Default

.05 dB

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.ReadingsTolerance = .1 'Write
ReadTol = powerCalibrator.ReadingsTolerance 'Read

C++ Syntax

HRESULT get_ReadingsTolerance( double *pVal);

HRESULT put_ReadingsTolerance( double newVal);

Interface

ISourcePowerCalibrator3


Read/Write
About the Handler I/O Connector

ReadyForTriggerState Property

Description

Determines the control of Material Handler connector Pin 21.

VB Syntax

handler.ReadyForTriggerState = value

Variable

(Type) - Description

handler

(object) - A Handler I/O object

value

(boolean)

0 (False) - Pin 21 is controlled by Output Port B7

1(True) - Pin 21 is controlled by the Ready for Trigger signal

Return Type

Boolean

Default

Examples

handler.ReadyForTriggerState = False 'Write

bState = handler.ReadyForTriggerState 'Read

C++ Syntax

HRESULT put_ReadyForTriggerState (BOOL *pVal);

HRESULT get_ReadyForTriggerState (BOOL newVal);

Interface

IHWMaterialHandlerIO2


Receiver Attenuator Property

Write/Read
About Receiver Attenuation

ReceiverAttenuator Property

Description

Sets or returns the value of the specified receiver attenuator control.

VB Syntax

object.ReceiverAttenuator(rec) = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only propertyA Channel (object)

rec

(long integer) - Receiver with attenuator control to be changed. Choose from:
1 - Receiver A
2 - Receiver B

value

(double) - Attenuator value in dB. Choose any Long Integer between 0 and 35 in 5dB steps:

If an invalid value is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered the analyzer will select 15 dB attenuation.

Return Type

Double

Default

0 db

Examples

chan.ReceiverAttenuator(1) = 5 'Write

attn = chan.ReceiverAttenuator(2) 'Read

C++ Syntax

HRESULT get_ReceiverAttenuator(long lport, double *pVal)
HRESULT put_ReceiverAttenuator(long lport, double newVal)

Interface

IChannel

|CalSet3


Read only
About PNA Options

ReceiverCount Property

Description

Returns the number of receivers in the remote PNA.

VB Syntax

value = cap.ReceiverCount

Variable

(Type) - Description

value

(Long) - Variable to store the returned number of receivers.

cap

A Capabilities (object)

Return Type

Long

Default

Not Applicable

Examples

value = cap.ReceiverCount 'Read

C++ Syntax

HRESULT get_ReceiverCount(long * receiverCount );

Interface

ICapabilities


Read only
About PNA Options

ReceiverStepAttenuatorStepSize Property

Description

Returns a value indicating the step size of the attenuator.

VB Syntax

value = cap.ReceiverStepAttenuatorStepSize (n)

Variable

(Type) - Description

value

(Double) - Variable to store the returned value of the attenuator step size.

cap

A Capabilities (object)

n

(Long) - port number to query for the value of the attenuator step size.

Return Type

Double

Default

Not Applicable

Examples

value = cap.ReceiverStepAttenuatorStepSize'Read

C++ Syntax

HRESULT get_ReceiverStepAttenuatorStepSize(long portNumber, double * stepSize );

Interface

ICapabilities


ReceivePort_Property

Read-only

ReceivePort Property

Description

Returns the receiver (response) port number of measurement. To understand how this property is useful, see IMeasurement2 Interface.

VB Syntax

value = meas.ReceivePort

Variable

(Type) - Description

meas

A Measurement (object)

value

(Long) - Variable to store the returned value

Return Type

Long Integer

Default

Not Applicable

Examples

rp = meas.ReceivePort

C++ Syntax

HRESULT ReceivePort( [out, retval] Long* rcvPort);

Interface

IMeasurement2


Write/Read
About IF BW

ReduceIFBW Property

Description

Sets or returns the state of the Reduced IF Bandwidth at Low Frequencies setting.

VB Syntax

chan.ReduceIFBW = state

Variable

(Type) - Description

chan

A Channel (object)

state

(boolean)
0 - Turns Reduce IFBW OFF
1 - Turns Reduce IFBW ON

Return Type

Boolean

Default

1

Examples

chan.ReduceIFBW = 1 'Write

reduce = chan.ReduceIFBW 'Read

C++ Syntax

HRESULT get_ReduceIFBW(BOOL *pVal)
HRESULT put_ReduceIFBW(BOOL newVal)

Interface

IChannel


Read-only

About Source Power Cal

ReferenceCalFactor Property

Description

Reference cal factor (%) associated with this power sensor. This property and the CalFactorSegments collection are used to perform source power calibration only if the power sensor does not contain cal factors in EPROM (for example, HP/Agilent 848x sensors).

VB Syntax

powerSensor.ReferenceCalFactor = value

Variable

(Type) - Description

pwrSensor

(object) - A PowerSensor (object)

value

(double) – Cal factor in units of percent. This can be any value between 1 and 150.

Return Type

Double

Default

100

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.PowerSensors(1).ReferenceCalFactor = 99 'Write

RefFact = powerCalibrator.PowerSensors(1).ReferenceCalFactor 'Read

C++ Syntax

HRESULT put_ReferenceCalFactor(double newVal);
HRESULT get_ReferenceCalFactor(double *pVal);

Interface

IPowerSensor


Write/Read
About Reference Markers

ReferenceMarkerState Property

Description

Turn ON or OFF the reference marker.

VB Syntax

meas.ReferenceMarkerState = state

Variable

(Type) - Description

app

A Measurement (object)

state

(boolean) -
ON (1) turns the reference marker ON
OFF (0) turns the reference marker OFF

Return Type

Boolean

Default

0 - OFF

Examples

meas.ReferenceMarkerState = True

reference = meas.ReferenceMarkerState

C++ Syntax

HRESULT get_ReferenceMarkerState(VARIANT_BOOL bState)
HRESULT put_ReferenceMarkerState(VARIANT_BOOL* bState)

Interface

IMeasurement


Reference Value Property

Write/Read

About Reference Level

ReferenceValue Property

Description

Sets or returns the value of the Y-axis Reference Level of the active trace.

VB Syntax

trce.ReferenceValue = value

Variable

(Type) - Description

trce

A Trace (object)

value

(double) - Reference Value. Units and range depend on the current data format.

Return Type

Double

Default

Not applicable

Examples

meas.ReferenceValue = 0 'Write

rlev = meas.ReferenceValue 'Read

C++ Syntax

HRESULT get_ReferenceValue(double *pVal)
HRESULT put_ReferenceValue(double newVal)

Interface

ITrace


Reference Position Property

Write/Read

About Reference Position

ReferencePosition Property

Description

Sets or returns the Reference Position of the active trace.

VB Syntax

trce.ReferencePosition = value

Variable

(Type) - Description

trce

A Trace (object)

value

(double) - Reference position on the screen measured in horizontal graticules from the bottom of the screen. Choose from any number between: 0 and 10.

Return Type

Double

Default

0

Examples

meas.ReferencePosition = 5 'Middle of the screen -Write

rpos = meas.ReferencePosition -Read

C++ Syntax

HRESULT get_ReferencePosition(double *pVal)
HRESULT put_ReferencePosition(double newVal)

Interface

ITrace


Write/Read.

About Trigger

Scope Property

Description

Sets or returns the scope of a trigger signal. This determines whether a trigger signal affects a single channel or all channels in the PNA.

Note: naGlobalTrigger is not compatible with TriggerMode = naTriggerModePoint. If you set Scope = naGlobalTrigger, any channel in naTriggerModePoint will be set to naTriggerModeMeasurement .

VB Syntax

trigsetup.Scope = value

Variable

(Type) - Description

trigsetup

A TriggerSetup (object)

value

(enum NATriggerType) - Trigger type. Choose from:
0 - naGlobalTrigger - a trigger signal is applied to all triggerable channels

1 - naChannelTrigger - a trigger signal is applied to the current channel. The next trigger signal will be applied to the next channel;not necessarily the next channel in numeric sequence (1-2-3-4 and so forth).

Return Type

Long Integer

Default

naGlobalTrigger

Examples

trigsetup.Scope = naGlobalTrigger 'Write

trigtyp = trigsetup.Scope 'Read

C++ Syntax

HRESULT get_Scope(tagNATriggerType *pTrigger)
HRESULT put_Scope(tagNATriggerType trigger)

Interface

ITriggerSetup


Search Function Property

Write/Read
About Marker Search

SearchFunction Property

Description

Emulates the Tracking function in the marker search dialog box. The value you choose for SearchFunction will determine the type of search that takes place when the Tracking property is set true.

The tracking function finds the selected search function every sweep. In effect, turning Tracking ON is the same as executing one of the "Search..." methods (such as SearchMin, SearchMax) for every sweep.

VB Syntax

mark.SearchFunction = value

Variable

(Type) - Description

mark

A Marker (object)

value

(enum NAMarkerFunction) - search function. Choose from:

0 - naMarkerFunction_None
1 - naMarkerFunction_Min
2 - naMarkerFunction_Max
3 - naMarkerFunction_Target
4 - naMarkerFunction_NextPeak
5 - naMarkerFunction_PeakRight
6 - naMarkerFunction_PeakLeft

Return Type

Long Integer

Default

0 - naMarkerFunction_None

Examples

mark.SearchFunction = naMarkerFunction_Target 'When this marker is set to track, it will track the Target value.

searchfunction = mark.SearchFunction 'Read

C++ Syntax

HRESULT get_SearchFunction(tagNAMarkerFunction *pVal)
HRESULT put_SearchFunction(tagNAMarkerFunction newVal)

Interface

IMarker


Write/Read

About Security Level

SecurityLevel Property

Description

Controls the display of frequency information on the PNA screen and printouts.

VB Syntax

app.SecurityLevel value

Variable

(Type) - Description

app

An Application (object)

value

(enum NASecurityLevel) -Choose either:
0 - None - ALL frequency information is displayed

1 - Low - NO frequency information is displayed. Frequency information can be redisplayed using the Security Setting dialog box or this command..

2- High - NO frequency information is displayed. Frequency information can be redisplayed ONLY by performing a Preset or recalling an instrument state with None or Low security settings, or using this command.

Return Type

Long Integer

Default

0 - None

Examples

app.SecurityLevel = None 'Write

level = app.SecurityLevel 'Read

C++ Syntax

HRESULT get_NASecurityLevel(tagNASecurityLevel *level);
HRESULT put_NASecurityLevel(tagNASecurityLevel level);

Interface

IApplication4


Segment Number Property

Read-only

About Segment Sweep

SegmentNumber Property

Description

Returns the number of the current segment, PowerSensorCalFactorSegment or PowerLossSegment object.

VB Syntax

seg.SegmentNumber

Variable

(Type) - Description

seg

(object) - A Segment, PowerSensorCalFactorSegment or PowerLossSegment. Get a handle to the object by referring to the item in the appropriate collection (Segments, CalFactorSegments or PowerLossSegments).

Return Type

Long Integer

Default

Not Applicable

Examples

segNum = seg.SegmentNumber 'returns the segment number -Read

C++ Syntax

HRESULT get_SegmentNumber(long *pVal)

Interface

ISegment
IPowerSensorCalFactorSegment
IPowerLossSegment


Show Statistics Property

Write/Read
About Trace Statistics

ShowStatistics Property

Description

Displays and hides the measurement (Trace) statistics (peak-to-peak, mean, standard deviation) on the screen. To display measurement statistics for a narrower band of the X-axis, use StatisticsRange.

The analyzer will display either measurement statistics or Filter Bandwidth statistics; not both.

VB Syntax

meas.ShowStatistics = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean) - Boolean value:

1 - Show statistics
0 - Hide statistics

Return Type

Boolean

Default

0 - Hide

Examples

meas.ShowStatistics = True 'Write

showstats = meas.ShowStatistics 'Read

C++ Syntax

HRESULT put_ShowStatistics(VARIANT_BOOL bState)

Interface

IMeasurement


Write/Read

Configuring the analyzer for SICL/VISA

SICL Property

Description

Allows you to control the PNA via SICL (standard instrument control library). In this mode, the analyzer can receive SCPI commands from the LAN interface or from a program residing on the PNA itself. This command performs the same function as the SICL / GPIB dialog box - SICL Enabled checkbox. See Configuring the analyzer for SICL/VISA.

With this method you can augment a test program written using SICL that resides on the PNA so that it will run unattended. An automation script can be written to start the PNA, enable SICL (using the SICL property), and then start the SICL based program.

VB Syntax

app.SICL value

Variable

(Type) - Description

app

An Application (object)

value

(Boolean) Choose from:

True - enable SICL

False - disable SICL

Return Type

Boolean

Default

False

Examples

Dim Pna as AgilentPNA835x.Application
Dim siclState as Boolean
Set Pna = CreateObject(“AgilentPNA835x.Application”)
Pna.SICL = true ‘write

siclState = Pna.SICL 'Read

C++ Syntax

HRESULT get_SICL(VARIANT_BOOL *pVal)

HRESULT put_SICL(VARIANT_BOOL newVal)

Interface

IApplication5


Write-Read
Configuring the analyzer for SICL/VISA

SICLAddress Property

Description

Sets and returns the PNA SICL address. This is the address used for SICL over LAN.

VB Syntax

app.SICLAddress = value

Variable

(Type) - Description

app

An Application (object)

value

(Integer) SICL Address of the PNA. Choose a value between 0 and 30.

Return Type

Short Integer

Default

16

Examples

address=app.SICLAddress 'Read

app.SICLAddress=16 'Write

C++ Syntax

HRESULT get_SICLAddress(short busIndex, short* address);

HRESULT put_SICLAddress(short busIndex,short address);

Interface

IApplication8


Read / Write

About Performing a Calibration

Simultaneous2PortAcquisition Property

Description

Specifies whether a 2-port calibration will be done with a single set of standards (one port at a time) or with two sets of standards (simultaneously).

The AcquireCalStandard2 command uses the same standard index for each calibration class. To specify the calibration standard gender for each port, you must first ensure that the order of calibration class accurately reflects the configuration of your DUT. For example, for a DUT with a male connector on port 1 and a female connector on port 2, order the devices within the S11 classes (A, B, and C) such that the MALE standards are first in the list. Then order the S22 classes specifying the FEMALE standards as the first in the list.

VB Syntax

cal.Simultaneous2PortAcquisition = state

Variable

(Type) - Description

cal

A Calibrator (object)

state

(boolean) - Choose from:

True - measures 2 ports simultaneously
False - measures 1 port at a time

Return Type

Boolean

Default

False

Examples

cal.Simultaneous2PortAcquisition = True

C++ Syntax

HRESULT put_Simultaneous2PortAcquisition( VARIANT_BOOL bTwoSetsOfStandards)

HRESULT Simultaneous2PortAcquisition( VARIANT_BOOL *bTwoSetsOfStandards)

Interface

ICalibrator


Smoothing Aperture Property

Write/Read

About Smoothing

SmoothingAperture Property

Description

Specifies or returns the amount of smoothing as a ratio of the number of data points in the measurement trace.

VB Syntax

meas.SmoothingAperture = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - Smoothing Aperture. A ratio of (aperture points / trace points)/100 Choose any number between .01 and .25.

Return Type

Double

Default

.25

Examples

meas.SmoothingAperture = .10 'Write

saperture = meas.SmoothingAperture 'Read

C++ Syntax

HRESULT get_SmoothingAperture(double *pVal)
HRESULT put_SmoothingAperture(double newVal)

Interface

IMeasurement


Write/Read
About Smoothing

Smoothing Property

Description

Turns ON and OFF data smoothing.

VB Syntax

meas.Smoothing = state

Variable

(Type) - Description

meas

A Measurement (object)

state

(boolean)
1 - Turns smoothing ON
0 - Turns smoothing OFF

Return Type

Boolean

Default

0

Examples

meas.Smoothing = 1 'Write

smooth = meas.Smoothing 'Read

C++ Syntax

HRESULT get_Smoothing(VARIANT_BOOL *pVal)
HRESULT put_Smoothing(VARIANT_BOOL newVal)

Interface

IMeasurement


Write/Read

About SnP files

SnPFormat Property

Description

Specifies the format of .S1P, .S2P, .S3P data.

Use either app.Save (saves data to file) or meas.GetSnPData (reads data into variant array).

VB Syntax

pref.SnPFormat = value

Variable

(Type) - Description

pref

A Preferences (object)

value

(string) - Format of the .S1P, .S2P, .S3P data. Choose from:

"MA" - Linear Magnitude / degrees

"DB" - Log Mag / degrees

"RI" - Real / Imaginary

"Auto" - Format in which the trace is already displayed. If other than Log Mag, Linear Magnitude, or Real/Imag, then the format will be in Real/Imag.

Return Type

String

Default

"Auto"

Examples

pref.SnPFormat = "MA" 'Write

format = pref.SnPFormat 'Read

C++ Syntax

HRESULT get_SnPFormat(BSTR *Format)
HRESULT put_SnPFormat(BSTR Format)

Interface

IPreferences


Write/Read

About Limits

SoundOnFail Property

Description

Turns ON or OFF the audio indicator for limit failures.

VB Syntax

limitst.SoundOnFail = state

Variable

(Type) - Description

limitst

A LimitTest (object)

state

(boolean)
0 - Turns the sound OFF
1 - Turns the sound ON

Return Type

Long Integer

Default

1 - ON

Examples

Limttest.SoundOnFail = 1 'Write

sound = Limttest.SoundOnFail 'Read

C++ Syntax

HRESULT get_SoundOnFail(VARIANT_BOOL *pVal)
HRESULT put_SoundOnFail(VARIANT_BOOL newVal)

Interface

ILimitTest


Read only
About PNA Options

SourceCount Property

Description

Returns the number of sources in the remote PNA.

VB Syntax

value = cap.SourceCount

Variable

(Type) - Description

value

(Long) - Variable to store the returned number of sources.

cap

A Capabilities (object)

Return Type

Long

Default

Not Applicable

Examples

value = cap.SourceCount 'Read

C++ Syntax

HRESULT get_SourceCount(long * sourceCount );

Interface

ICapabilities


SourcePort_Property

Read-only

SourcePort Property

Description

Returns the source port of measurement. To understand how this property is useful, see IMeasurement2 Interface.

VB Syntax

value = meas.SourcePort

Variable

(Type) - Description

meas

A Measurement (object)

value

(Long) - Variable to store the returned value

Return Type

Long Integer

Default

Not Applicable

Examples

sp = meas.SourcePort

C++ Syntax

HRESULT SourcePort( [out, retval] Long* srcPort);

Interface

IMeasurement2


TriggerSouce Property

Write/Read

About Trigger Source

Source Property

Description

Sets or returns the source of triggering in the PNA.

VB Syntax

app.Source = value

Variable

(Type) - Description

app

A TriggerSetup (object)

value

(enum NATriggerSource) - Choose from:

0 - naTriggerSourceInternal - free run

1 - naTriggerSourceManual - manual trigger source; use app.ManualTrigger to send a trigger signal.

2 - naTriggerSouceExternal - a trigger signal is generated when a trigger signal is sensed on the external trigger pin of the Aux IO connector. Use ExternalTriggerConnectionBehavior to configure the characteristics of the external trigger signal.

Return Type

Long Integer

Default

naTriggerSourceInternal

Examples

app.Source = naTriggerSourceInternal 'Write

trigsource = app.Source 'Read

C++ Syntax

HRESULT get_Source(tagNATriggerSource *pTrigger);

HRESULT put_Source(tagNATriggerSource trigger);

Interface

ITriggerSetup


Write / Read

About Source Power Cal

SourcePowerCalPowerOffset Property

Description

Sets or returns a power level offset from the PNA test port power. This can be a gain or loss value (in dB) to account for components you connect between the source and the reference plane of your measurement. For example, specify 10 dB to account for a 10 dB amplifier at the input of your DUT.

Cal power is the sum of the test port power setting and this offset value. Following the calibration, the PNA power readouts are adjusted to the cal power.

This property performs the same function as the power offset argument on the SetCalInfo2 Method

VB Syntax

chan.SourcePowerCalPowerOffset (sourcePort) = value

Variable

(Type) - Description

chan

(object) - A Channel object

sourcePort

(long integer) - The source port for which to set this power offset value.

value

(double) - Gain or loss value in dB. Choose a value between -200 and 200

Return Type

Double

Default

0 dB

Examples

chan.SourcePowerCalPowerOffset(1) = 10 'Write
offset = chan.SourcePowerCalPowerOffset(2) 'Read

C++ Syntax

HRESULT get_SourcePowerCalPowerOffset(long sourcePort, double *pVal);

HRESULT put_SourcePowerCalPowerOffset(long sourcePort, double newVal);

Interface

IChannel4


Write / Read
About Source Power Cal

SourcePowerCorrection Property

Description

Sets source power correction ON or OFF for a specific source port on this channel, or returns the current ON or OFF state of correction for that source port.

VB Syntax

chan.SourcePowerCorrection(sourcePort) = value

Variable

(Type) - Description

chan

(object) – A Channel object

sourcePort

(long integer) – Source port for which to set or return the ON or OFF state of source power correction.

value

(boolean)

False (0) – Turns source power correction OFF for the source port.

True (1) – Turns source power correction ON for the source port.

Return Type

Boolean

Default

False (0) - Source power correction will turn correction ON

Examples

chan.SourcePowerCorrection(1) = 1 'Write
calOnPort2 = chan.SourcePowerCorrection(2) 'Read

C++ Syntax

HRESULT put_SourcePowerCorrection(VARIANT_BOOL bState);

HRESULT get_SourcePowerCorrection(VARIANT_BOOL *bState);

Interface

IChannel


Source Power Option Property

Write/Read

About Source Power

SourcePowerOption Property

Description

Enables the source power to be set on individual sweep segments. This property must be set True before seg.TestPortPower = value is sent. Otherwise, the test port power command will be ignored.

VB Syntax

segs.SourcePowerOption = state

Variable

(Type) - Description

segs

A Segments collection (object)

state

(boolean)
True (1) - Enables variable TestPortPower to be set segment sweep
False (0) - Disables variable TestPortPower to be set segment sweep

Return Type

Boolean
True - Enabled
False - Disabled

Default

False

Examples

segs.SourcePowerOption = True 'Write

powerOption = SourcePowerOption 'Read

C++ Syntax

HRESULT get_SourcePowerOption(VARIANT_BOOL *pVal)
HRESULT put_SourcePowerOption(VARIANT_BOOL newVal)

Interface

ISegments


Source Power State Property

Write/Read
About Source Power

SourcePowerState Property

Description

Turns Source Power ON and OFF.

See note about source power state with instrument state save and recall.

VB Syntax

app.SourcePowerState = state

Variable

(Type) - Description

app

An Application (object)

state

(boolean)
False (0) - Turns Source Power OFF
True (1) - Turns Source Power ON

Return Type

Boolean
0 - Power OFF
1 - Power ON

Default

ON (1)

Examples

app.SourcePowerState = True 'Write

pwr = app.SourcePowerState 'Read

C++ Syntax

HRESULT get_SourcePowerState(VARIANT_BOOL *pVal)
HRESULT put_SourcePowerState(VARIANT_BOOL newVal)

Interface

IApplication


Write/Read

About Time Domain

Span Property

Description

Sets or returns the Span time of either Gating or Time Domain transform windows

VB Syntax

object.Span = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Span time in seconds. Choose any number between: 2*[(number of points-1) / frequency span] and 0

Return Type

Double

Default

20ns

Examples

Trans.Span = 4.5e-9 'sets the time span of a transform window -Write
Gate.Span = 4.5e-9 'sets the Span time of a gating window -Write

span = Trans.Span 'Read

C++ Syntax

HRESULT get_Span(double *pVal)
HRESULT put_Span(double newVal)

Interface

ITransform
IGating


Span_Meas_Property

Read-only

Span Property

Description

Returns the stimulus span of the measurement (stop-start data points). To understand how this property is useful, see IMeasurement2 Interface.

VB Syntax

value = meas.Span

Variable

(Type) - Description

value

(Double) - Variable to store the returned value.

meas

A Measurement (object)

Return Type

Double

Default

Not Applicable

Examples

Print meas.Span 'prints the span of the measurement

C++ Syntax

HRESULT get_Span(double * Val);

Interface

IMeasurement2


Standard Deviation Property

Read-only
About Trace Statistics

StandardDeviation Property

Description

Returns the standard deviation of the measurement.
To retreive all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

stdev = meas.StandardDeviation

Variable

(Type) - Description

stdev

(single) - Variable to store standard deviation value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

stdev = meas.StandardDeviation 'Read

C++ Syntax

HRESULT get_StandardDeviation(float* stdDeviation)

Interface

IMeasurement


Write/Read

About Modifying Cal Kits

StandardForClass Property

Description

Sets a standard to a calibration class. Does NOT set or dictate the order for measuring the standards.

VB Syntax

calKit.StandardForClass(class, portNum) = value

Variable

(Type) - Description

calKit

A CalKit (object). Use calKit.GetCalStandard to get a handle to the standard.

class

(enum NACalClass) Standard. Choose from:

1 - naClassA

2 - naClassB

3 - naClassC

4 - naClassD

5 - naClassE

6 - naReferenceRatioLine

7 - naReferenceRatioThru

SOLT Standards

1 - naSOLT_Open

2 - naSOLT_Short

3 - naSOLT_Load

4 - naSOLT_Thru

5 - naSOLT_Isolation

TRL Standards

1 - naTRL_Reflection

2 - naTRL_Line_Reflection

3 - naTRL_Line_Tracking

4 - naTRL_Thru

5 - naTRL_Isolation

portNum

(long) - The port number the standard will be connected to. For example, you may have a 3.5mm connector designated for port 1, and Type N designated for port 2.

value

(long) - Calibration class number. Choose a number between 1 and 8. The <value> numbers are associated with the following calibration classes:

<value> | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S21T | Thru standard

Return Type

Long Integer

Default

Not Applicable

Examples

calKit.StandardForClass(naSOLT_Short, 1) = 1

Kclass = calKit.StandardForClass(naSOLT_Short, 1)

C++ Syntax

HRESULT put_StandardForClass (NACalClass item, long pNum);

HRESULT get_StandardForClass (NACalClass* item, long *pNum);

Interface

ICalKit


Start Frequency Property

Write/Read

About Linear Frequency Sweep

StartFrequency Property

Description

Sets or returns the start frequency of the channel
or
Sets or returns the start frequency of the segment.

see also Measurement2 interface

VB Syntax

object.StartFrequency = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(double) - Start frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Channel - Minimum frequency of the analyzer
Segment - 0

Examples

chan.StartFrequency = 4.5e9 'sets the start frequency of a linear sweep for the channel object -Write

startfreq = Chan.StartFrequency 'Read

C++ Syntax

HRESULT get_StartFrequency(double *pVal)
HRESULT put_StartFrequency(double newVal)

Interface

IChannel
ISegment

|CalSet3


Start Power Property

Write/Read
About Power Sweep

StartPower Property

Description

Sets the start power of the analyzer when sweep type is set to Power Sweep. Frequency of the measurement is set with chan.CWFrequency.

VB Syntax

object.StartPower = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(double) - Start Power in dBm.

Note: The range of settable power values depends on the PNA model and if source attenuators are installed. To determine the range of values, use cap.MaximumSourceALCPower and cap.MinimumSourceALCPower

Auto attenuation is not allowed in Power Sweep.

Return Type

Double

Default

0

Examples

Chan.StartPower = -10 'Write

strtpwr = Chan.StartPower 'Read

C++ Syntax

HRESULT get_StartPower(double *pVal)
HRESULT put_StartPower(double newVal)

Interface

IChannel

|CalSet3


Write/Read

About Time Domain

Start Property

Description

Sets or returns the start time of either Gating or Time Domain transform windows

VB Syntax

object.Start = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Start time in seconds. Choose any number between:
± (number of points-1) / frequency span

Return Type

Double

Default

-10ns

Examples

Trans.Start = 4.5e-9 'sets the start time of a transform window -Write
Gate.Start = 4.5e-9 'sets the start time of a gating window -Write

strt = Trans.Start 'Read

C++ Syntax

HRESULT get_Start(double *pVal)
HRESULT put_Start(double newVal)

Interface

ITransform
IGating


Start_Meas_Property

Read-only

Start Property

Description

Returns the stimulus value of the first data point for the measurement. To understand how this property is useful, see IMeasurement2 Interface.

VB Syntax

value = meas.Start

Variable

(Type) - Description

value

(Double) - Variable to store the returned value

meas

A Measurement (object)

Return Type

Double

Default

Not Applicable

Examples

Print meas.Start 'prints the stimulus value of the first data point

C++ Syntax

HRESULT get_Start (double * Val);

Interface

IMeasurement2


Write/Read

State Property

Description

Turns an Object ON and OFF.

VB Syntax

object.State = value

Variable

(Type) - Description

object

Applies to any of the following:
Gating (object)
LimitTest (object)
Port Extension (object)
Segment (object)
Transform (object)

Note: For LimitTest.State - If using Global Pass/Fail status, trigger the PNA AFTER turning Limit testing ON.

value

(boolean) -

0 - Turns obj OFF
1 - Turns obj ON

Return Type

Long Integer

Default

Depends on the object:
0 - Gating
0 - LimitTest
0 - Port Extension
1 - Segment
0 - Transform

Examples

Seg.State = 1 'Turns the segment object ON -Write

tran = Trans.State 'returns the state of Transform -Read

C++ Syntax

HRESULT get_State(VARIANT_BOOL *pVal)
HRESULT put_State(VARIANT_BOOL newVal)

Interface

ISegment
ITransform
IGating
ILimitTest
IPortExtension


Write/Read

About User Ranges

Statistics Range Property

Description

Sets the User Range number for calculating measurement statistics. Set the start and stop values for a User Range with chan.UserRangeMin and chan.UserRangeMax.

There are 9 User Ranges per channel. User ranges are applied independently to any measurement.

VB Syntax

meas.StatisticsRange = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(long integer) - Range Number. Choose any number between 0 and 9.
1 - 9 are user-defined ranges
0 is Full Span

Return Type

Long Integer

Default

0

Examples

meas.StatisticsRange = 2 'Write

statrange = meas.StatisticsRange 'Read

C++ Syntax

HRESULT get_StatisticsRange(long* rangeNumber)
HRESULT put_StatisticsRange(long rangeNumber)

Interface

IMeasurement


Step Rise Time Property

Write/Read

About Time Domain

StepRiseTime Property

Description

Sets or returns the Rise time of the stimulus in Low Pass Step Mode.

VB Syntax

trans.StepRiseTime = value

Variable

(Type) - Description

trans

A Transform (object)

value

(double) - Rise time in seconds. Choose any number between 5.0e-13 and 1.63e-14.

Return Type

Double

Default

0

Examples

trans.StepRiseTime = 1.0e-14 'sets the step rise time to 100 psec. -Write

rt = trans.StepRiseTime 'Read

C++ Syntax

HRESULT get_StepRiseTime(double *pVal)
HRESULT put_StepRiseTime(double newVal)

Interface

ITransform


Read-only
About Cal Sets

StimulusValues Property

Description

Returns multiple X-axis frequency arrays (source and response) needed by frequency offset measurements. The arrays contain one frequency value for each data point.

VB Syntax

value = object.StimulusValues (range)

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

range

(Long) –

Specify 0 to return source frequencies.

Specify 1 to return response frequencies.

Return Type

1-dimensional variant array

Default

Not Applicable

Examples

array = CalSet.StimulusValues 'Read

C++ Syntax

HRESULT get_StimulusValues (long range, VARIANT* vals)

Interface

ICalSet3


Stop Frequency Property

Write/Read

About Linear Frequency Sweep

StopFrequency Property

Description

Sets or returns the stop frequency of the channel
or
Sets or returns the stop frequency of the segment.

see also Measurement2 interface

VB Syntax

object.StopFrequency = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(double) - Stop frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Channel - Maximum frequency of the analyzer
Segment - 0

Examples

chan.StopFrequency = 4.5e9 'sets the stop frequency of a linear sweep for the channel object -Write

stopfreq = Chan.StopFrequency 'Read

C++ Syntax

HRESULT get_StopFrequency(double *pVal)
HRESULT put_StopFrequency(double newVal)

Interface

IChannel
ISegment

|CalSet3


Stop Power Property

Write/Read
About Power Sweep

StopPower Property

Description

Sets the Stop Power of the analyzer when sweep type is set to Power Sweep. Frequency of the measurement is set with chan.CWFrequency

VB Syntax

object.StopPower = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(double) - Stop Power in dB. Start Power in dB.

Note: The range of settable power values depends on the PNA model and if source attenuators are installed. To determine the range of values, use cap.MaximumSourceALCPower and cap.MinimumSourceALCPower

Auto attenuation is not allowed in Power Sweep.

Return Type

Double

Default

0

Examples

Chan.StopPower = -10 'Write

stppwr = Chan.StopPower 'Read

C++ Syntax

HRESULT get_StopPower(double *pVal)
HRESULT put_StopPower(double newVal)

Interface

IChannel

|CalSet3


Write/Read

About Time Domain

Stop Property

Description

Sets or returns the Stop time of either Gating or Time Domain transform windows

VB Syntax

object.Stop = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Start time in seconds. Choose any number between:
± (number of points-1) / frequency span

Return Type

Double

Default

10 ns

Examples

Trans.Stop = 4.5e-9 'sets the stop time of a transform window -Write
Gate.Stop = 4.5e-9 'sets the stop time of a gating window -Write

stp = Trans.Stop 'Read

C++ Syntax

HRESULT get_Stop(double *pVal)
HRESULT put_Stop(double newVal)

Interface

ITransform
IGating


Stop_Meas_Property

Read- only

Stop Property

Description

Returns the stimulus value of the last data point for the measurement. To understand how this property is useful, see IMeasurement2 Interface.

VB Syntax

value = meas.Stop

Variable

(Type) - Description

value

(Double) Variable to store the returned value

meas

A Measurement (object)

Return Type

Double

Default

Not Applicable

Examples

Print meas.Stop 'prints the stimulus value of the last data point

C++ Syntax

HRESULT get_Stop(double * Val);

Interface

IMeasurement2


Read/Write

SweepEndMode Property

Description

Sets and reads the event that will cause the Sweep End line to go to a low state. The line will return to a high state after the appropriate calculations are complete.

Note: This line is connected to the following pins on the HANDLER IO connector and AUX IO connector in the PNA. Therefore, this command will affect both of these connectors in the same way.

VB Syntax

object.SweepEndMode = value

Variable

(Type) - Description

object

(object) - A HandlerIO or AuxIO object

value

(enum as NASweepEndMode ) Choose from:

0 - naSweep - the line goes low when each sweep is complete

1 - naChannelSweep - the line goes low when all the sweeps for each channel is complete.

2 - naGlobalSweep - the line goes low when all sweeps for all triggerable channels are complete.

Return Type

Long Integer

Default

0 - naSweep

Examples

HWAuxIO.PassFailMode = naSweep 'Write

value = HWAuxIO.PassFailMode 'Read

C++ Syntax

HRESULT put_SweepEndMode ( tagNASweepEndMode Mode );

HRESULT get_SweepEndMode ( tagNASweepEndMode* Mode );

Interface

IHWAuxIO

IHWMaterialHandlerIO


Read-only

About the ExtTestSetIO connector

SweepHoldOff Property

Description

Returns a boolean that represents the state of SweepHoldoff line (pin2) of the External Test Set connector.

VB Syntax

value = ExtIO.SweepHoldOff

Variable

(Type) - Description

value

(boolean) - Variable to store the returned data

ExtIO

(object) - An External IO object

Return Type

Boolean

False (0) - indicates the line is being held at a TTL Low

True (1) - indicates the line is being held at a TTL High

Default

Not Applicable

Examples

value = ExtIO.SweepHoldOff

C++ Syntax

HRESULT get_SweepHoldOff( VARIANT_BOOL* bValue);

Interface

IHWExternaTestSetIO


Sweep Generation Mode Property

Write/Read
About Stepped Sweep

SweepGenerationMode Property

Description

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

VB Syntax

object.SweepGenerationMode = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(enum NASweepGenerationModes) - Choose either:

0 - naSteppedSweep - source frequency is CONSTANT during measurement of eah displayed point. More accurate than Analog. Dwell time can be set in this mode.

1 - naAnalogSweep - source frequency is continuously RAMPING during measurement of each displayed point. Faster than Stepped. Sweep time (not dwell time) can be set in this mode.

Return Type

Long Integer

Default

Analog

Examples

Chan.SweepGenerationMode = naAnalogSweep 'Write

swpgen = Chan.SweepGenerationMode 'Read

C++ Syntax

HRESULT get_SweepGenerationMode(tagNASweepGenerationModes* pVal)
HRESULT put_SweepGenerationMode(tagNASweepGenerationModes newVal)

Interface

IChannel

|CalSet3


Sweep Time Property

Write/Read
About Sweep Time

SweepTime Property

Description

Sets the Sweep time of the analyzer. If sweep time accuracy is critical, use ONLY the values that are attained using the up and down arrows next to the sweep time entry box. See Sweep Time.

VB Syntax

object.SweepTime = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(double) - Sweep time in seconds. The maximum sweep time of the PNA is 86400 seconds (1 day).

To set the fastest sweep speed possible, set this value to 0.

Return Type

Double

Default

0

Examples

chan.SweepTime = 3e-3 'Write

swptme = chan.SweepTime 'Read

C++ Syntax

HRESULT get_SweepTime(double *pVal)
HRESULT put_SweepTime(double newVal)

Interface

IChannel

CalSet3


Sweep Type Property

Write/Read

About Sweep Types

SweepType Property

Description

Sets the type of X-axis sweep that is performed on a channel.

VB Syntax

object.SweepType = value

Variable

(Type) - Description

object

Channel (object)

or

CalSet (object) - Read-only property

value

(enum NASweepTypes) - Choose from:

0 - naLinearSweep
1 - naLogSweep
2 - naPowerSweep
3 - naCWTimeSweep
4 - naSegmentSweep

Note: Sweep type cannot be set to Segment sweep if there are no segments turned ON. A segment is automatically turned ON when a application is created.

Return Type

Long Integer

Default

naLinearSweep

Examples

chan.SweepType = naPowerSweep 'Write

swptyp = chan.SweepType 'Read

C++ Syntax

HRESULT get_SweepType(tagNASweepTypes* pVal)
HRESULT put_SweepType(tagNASweepTypes newVal)

Interface

IChannel

|CalSet3


Write/Read

About System Impedance

SystemImpedanceZ0 Property

Description

Sets and returns the impedance for the analyzer.

VB Syntax

app.SystemImpedanceZ0 = value

Variable

(Type) - Description

app

An Application (object)

value

(double) Analyzer Impedance. Choose any number between 0 and 1000 ohms.

Return Type

Double

Default

50

Examples

app.SystemImpedanceZ0 = 75 'Write

z0 = app.SystemImpedanceZ0 'Read

C++ Syntax

HRESULT get_SystemImpedanceZ0(double dSystemZ0)
HRESULT put_SystemImpedanceZ0(double *pdSystemZ0)

Interface

IApplication


Read-only
About Computer Properties

SystemName Property

Description

Returns the computer name of the PNA.

VB Syntax

name = app.SystemName

Variable

(Type) - Description

name

(String) Variable to store the returned computer name.

app

An Application (object)

Return Type

String

Default

Not Applicable

Examples

name = app.SystemName

C++ Syntax

HRESULT SystemName(BSTR* computerName)

Interface

IApplication


Write/Read
About Marker Search

TargetValue Property

Description

Sets the target value for the marker when doing Target Searches ( SearchTargetLeft, SearchTarget, SearchTargetRight).

VB Syntax

mark.TargetValue = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Target value. Choose any number between: -500 and 500

Return Type

Single

Default

0

Examples

mark.TargetValue = 10.5 'Write

target = mark.TargetValue 'Read

C++ Syntax

HRESULT get_TargetValue(float *pVal)
HRESULT put_TargetValue(float newVal)

Interface

IMarker


Test Port Power Property

Write/Read
About Power Level

TestPortPower Property

Description

Sets or returns the RF power level for the channel
or
Sets or returns the RF power level of the segment.

VB Syntax

object.TestPortPower(portNum) = value

Variable

(Type) - Description

object

A Channel (object)

or

A CalSet (object)

or

A Segment (object) - See also Segs.SetAllSegments

portNum

(long integer) - Port number for which to set source power.

If chan.CouplePorts = True, then chan.TestPortPower (1) = 0 sets power level at ALL ports to 0 dBm.

value

(double) - RF Power in dBm.

Note: The range of settable power values depends on the PNA model and if source attenuators are installed. To determine the range of values, use cap.MaximumSourceALCPower and cap.MinimumSourceALCPower

Actual achievable leveled power depends on frequency.

Return Type

Double

Default

0

Examples

chan.TestPortPower(1) = 5 'sets the port 1 RF power level for the channel object -Write

powerlev = Chan.TestPortPower(1) 'Read

C++ Syntax

HRESULT get_TestPortPower(long port, double *pVal)
HRESULT put_TestPortPower(long port, double newVal)

Interface

IChannel
ICalSet3
ISegment


Read/Write

ThruCalMethod Property

Description

Sets and returns the method for performing the thru portion of the calibration.

Note: There is also a ThruCalMethod Property on the GuidedCalibration object.

VB Syntax

obj.ThruCalMethod = value

Variable

(Type) - Description

obj

SMCType (object)

or

VMCType (object)

value

(String) Specifies the Thru method. Case insensitive - include spaces. Choose from:

"Default"

"Flush Thru" or "FLUSH"

"Unknown Thru" or "UNKN"

"Adapter Removal" or "ADAP"

Return Type

String

Default

Default

Examples

SMC.ThruCalMethod = "UNKN"

C++ Syntax

HRESULT put_ThruCalMethod(enum NAThruCalMethod thruMethod);

HRESULT get_ThruCalMethod(enum NAThruCalMethod *thruMethod);

Interface

SMCType

VMCType


Read/Write

ThruCalMethod Property

Description

Sets and returns the method for performing the THRU portion of the calibration.

VB Syntax

guidedCal.ThruCalMethod = value

Variable

(Type) - Description

guidedCal

GuidedCalibration (object)

value

(Enum as NAThruCalMethod) Specifies the THRU method. Choose from:

0 - naDefaultCalMethod - allow the PNA to choose the best possible method (from the following) depending on whether the device or ECal module is insertable or non-insertable and given the model number of the PNA. (default selection if omitted.)

1 - naAdapterRemoval - Perform Adapter removal calibration.

2 - naFlushThru - Perform Flush Thru calibration.

3 - naDefinedThru - Perform Defined Thru calibration. If performing an ECal, this is the Thru standard in the ECal module.

4 - naUnknownThru - Perform Unknown Thru calibration.

Return Type

Enum

Default

0 - naDefaultCalMethod

Examples

guided.ThruCalMethod = naDefinedThru

C++ Syntax

HRESULT get_ThruCalMethod(enum NAThruCalMethod *thruMethod);

HRESULT put_ThruCalMethod(enum NAThruCalMethod thruMethod);

Interface

IGuidedCalibration


Read/Write

ThruPortList Property

Description

Note: Available only on PNA releases 5.0 and greater.

Sets and returns the thru connection port pairs for the calibration.

  • For 3-port cals, specify at least two pairs.

  • For 4-port cals, specify at least three pairs.

  • For highest accuracy, specify more than the minimum pairs.

  • You can query (not set) the thru port pairs for one and two port calibrations.

Learn more about Thru method and port pairings.

See an example of a 4-port guided calibration using COM.

VB Syntax

guidedCal.ThruPortList = t1a, t1b, t2a, t2b, t3a, t3b

Variable

(Type) - Description

guidedCal

GuidedCalibration (object)

t1a, t1b...

(Variant) Port numbers in pairs:

t1a, t1b (Thru1 - port A and port B)

,t2a, t2b (Thru2 - port A and port B)

,t3a, t3b (Thru3 - port A and port B)

Return Type

Variant - Returns comma-separated pairs.

Default

Not Applicable

Example

guided.ThruPortList = 1,2,1,3,1,4

'Sets the following three thru connections for a 4-port calibration:
Thru 1 - ports 1 and 2
Thru 2 - ports 1 and 3
Thru 3 - ports 1 and 4

C++ Syntax

HRESULT get_ThruPortList(VARIANT* portList);

HRESULT put_ThruPortList(VARIANT portList);

Interface

IGuidedCalibration


Write/Read

About Title

Title Property

Description

Writes or reads a custom title for the window. Newer entries replace (not append) older entries.Turn the title ON and OFF with TitleState

VB Syntax

win.Title = string

Variable

(Type) - Description

win

A NaWindow (object)

string

(long) - Title limited to 50 characters.

Return Type

String

Default

Null

Examples

win.Title = "Hello World" 'Write

titl = win.Title 'Read

C++ Syntax

HRESULT get_Title(BSTR *title)
HRESULT put_Title(BSTR title)

Interface

INAWindow


Title State Property

Write/Read
About Titles

TitleState Property

Description

Turns ON and OFF the window title. Write a window title with Title

VB Syntax

win.TitleState = state

Variable

(Type) - Description

win

A NaWindow (object)

state

(boolean)
True (1) - Title ON
False (0) - Title OFF

Return Type

Long Integer
0 - Title OFF
1 - Title ON

Default

0 - OFF

Examples

win.TitleState = True 'Write

titlestate = win.TitleState 'Read

C++ Syntax

HRESULT get_TitleState(VARIANT_BOOL* bState)
HRESULT put_TitleState(VARIANT_BOOL bState)

Interface

INAWindow


Trace Math Property

Write/Read

About Math Operations

TraceMath Property

Description

Performs math operations on the measurement object and the trace stored in memory. (There MUST be a trace stored in Memory to perform math. See Meas.DataToMemory method.)

VB Syntax

meas.TraceMath = value

Variable

(Type) - Description

meas

A measurement (object)

value

(enum NAMathOperation) - Choose from:

0 - naDataNormal
1 - naDataMinusMemory
2 - naDataPlusMemory
3 - naDataDivMemory
4 - naDataTimesMemory

Return Type

NAMathOperation

Default

Normal (0)

Examples

meas.TraceMath = naDataMinusMemory 'Write

mathOperation = meas.TraceMath 'Read

C++ Syntax

HRESULT get_TraceMath(tagNAMathOperation* pMathOp)
HRESULT put_TraceMath(tagNAMathOperation mathOp)

Interface

IMeasurement


Write/Read
About Marker Search

Tracking Property

Description

This property, when on, executes the search function (marker.SearchFunction) every sweep.

In effect, turning Tracking ON is the same as executing one of the immediate, one-time, "Search..." methods (such as SearchMin, SearchMax) for every sweep.

VB Syntax

mark.Tracking = state

Variable

(Type) - Description

mark

A Marker (object)

state

(boolean) - Tracking state. Choose from:
ON (1)
OFF (0)

Return Type

Boolean
0 - Tracking OFF
1 - Tracking ON

Default

0 - OFF

Examples

mark.Tracking = 1 'Write

markTracking = mark.Type 'Read

C++ Syntax

HRESULT put_Tracking(VARIANT_BOOL bOn)
HRESULT get_Tracking(VARIANT_BOOL * pbOn)

Interface

IMarker


Write/Read

About Time Domain

Mode Property

Description

Sets the type of transform.

VB Syntax

trans.Mode = value

Variable

(Type) - Description

trans

A Transform (object)

value

(enum NATransformMode) - Choose from:

0 - naTransformBandpassImpulse
1 - naTransformLowpassImpulse
2 - naTransformLowpassStep

Return Type

NATransformMode

Default

0 - naTransformBandpassImpulse

Examples

trans.Mode = naTransformLowpassStep 'Write

transmode = trans.Mode 'Read

C++ Syntax

HRESULT get_Mode(tagNATransformMode *pVal)
HRESULT put_Mode(tagNATransformMode newVal)

Interface

ITransform


Write/Read

About Trigger

TriggerDelay Property

Description

Sets and reads the trigger delay. This delay is only applied while in External Trigger mode. After an external trigger is applied, the start of the sweep is delayed for the specified delay value plus any inherent latency.

VB Syntax

app.TriggerDelay = value

Variable

(Type) - Description

app

An Application (object)

value

Double- Trigger delay value. Range is from 0 to 1 second

Return Type

Double

Default

0

Examples

app.TriggerDelay = .003 'Write

delay = app.TriggerDelay 'Read

C++ Syntax

HRESULT get_TriggerDelay(double *delay);

HRESULT put_TriggerDelay(double delay)

Interface

IApplication


Write/Read.

About Trigger

TriggerOutputEnabled Property

Description

Enables the PNA to send trigger signals out the rear-panel TRIGGER OUT connector. For more information, see External triggering.

VB Syntax

trigsetup.TriggerOutputEnabled = boolean

Variable

(Type) - Description

trigsetup

A TriggerSetup2 (object)

boolean

Choose from:
0 - False - PNA does NOT send output trigger signals.

1 - True - PNA sends output trigger signals.

Return Type

Boolean

Default

False

Examples

trigsetup.TriggerOutputEnabled = 1 'Write

atba = trigsetup.TriggerOutputEnabled 'Read

C++ Syntax

HRESULT get_TriggerOutputEnabled( BOOL *pVal);

HRESULT put_TriggerOutputEnabled( BOOL newVal);

Interface

ITriggerSetup2


Trigger Mode Property

Write/Read
About Triggering

TriggerMode Property

Description

Each trigger signal will cause either:
all measurements in the channel to be made or
only a single data point in the channel at a time.

VB Syntax

chan.TriggerMode = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NATriggerMode) - Choose from:

0 - naTriggerModePoint - a single data point is measured with each trigger signal the channel receives. Subsequent trigger signals continue to go to the channel in Point mode until the channel measurements are complete.

1 - naTriggerModeMeasurement - all measurements in the channel are made with each trigger signal the channel receives.

Note: Point Mode is not compatible when TriggerType is set to naGlobalTrigger. If you change any channel to TriggerModePoint, TriggerType will be set to naChannelTrigger.

Return Type

Long Integer

Default

0 - naTriggerModeMeasurement

Examples

chan.TriggerMode = naTriggerModePoint 'Write

trigtyp = chan.TriggerMode 'Read

C++ Syntax

HRESULT get_TriggerMode (tagNATriggerMode *pMode)
HRESULT put_TriggerMode (tagNATriggerMode newMode)

Interface

IChannel


Trigger Signal Property

Write/Read

About Trigger Source

TriggerSignal Property - Obsolete

Description

Note: This command has been replaced by Source Property

Sets or returns the trigger source.

VB Syntax

app.TriggerSignal = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NATriggerSignal) - Choose from:

0 - naTriggerInternal - free run

1 - naTriggerExternalPositive - a trigger signal is generated when a TTL high is sensed on the external trigger pin of the Aux IO connector

2 - naTriggerExternalNegative - a trigger signal is generated when a TTL low is sensed on the external trigger pin of the Aux IO connector.

3 - naTriggerManual - manual trigger source; use app.ManualTrigger to send a trigger signal.

4 - naTriggerExternalHigh - a trigger signal is generated when a TTL high is sensed on the external trigger pin of the Aux IO connector

5 - naTriggerExternalLow - a trigger signal is generated when a TTL low is sensed on the external trigger pin of the Aux IO connector

Return Type

Long Integer

Default

naTriggerInternal

Examples

app.TriggerSignal = naTriggerExternalPositive 'Write

trigsign = app.TriggerSignal 'Read

C++ Syntax

HRESULT get_TriggerSignal(tagNATriggerSignal *pSignal)
HRESULT put_TriggerSignal(tagNATriggerSignal signal)

Interface

IApplication


Trigger Type Property

Write/Read.

About Trigger

TriggerType Property - Obsolete

Description

Note: This property has been replaced with Scope Property.

Sets or returns the trigger type which determines the scope of a trigger signal.

VB Syntax

app.TriggerType = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NATriggerType) - Trigger type. Choose from:
0 - naGlobalTrigger - a trigger signal is applied to all triggerable channels

1 - naChannelTrigger - a trigger signal is applied to the current channel. The next trigger signal will be applied to the next channel; not necessarily channel 1-2-3-4.

Return Type

Long Integer

Default

naGlobalTrigger

Examples

app.TriggerType = naGlobalTrigger 'Write

trigtyp = app.TriggerType 'Read

C++ Syntax

HRESULT get_TriggerType(tagNATriggerType *pTrigger)
HRESULT put_TriggerType(tagNATriggerType trigger)

Interface

IApplication


Write/Read.
About Modifying Cal Kits

Type (calstd) Property

Description

Sets and Returns the type of calibration standard.

VB Syntax

calstd.Type = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(enum NACalStandardType) -Choose from:
0 - naOpen
1 - naShort
2 - naLoad
3 - naThru

Return Type

Long Integer

Default

Not Applicable

Examples

calstd.Type = naOpen 'Write

standardtype = calstd.Type 'Read

C++ Syntax

HRESULT get_Type(tagNACalStandardType *pVal)
HRESULT put_Type(tagNACalStandardType newVal)

Interface

ICalStandard


Write/Read

About Modifying Cal Kits

TZImag Property

Description

Sets and Returns the TZImag value (the Imaginary Terminal Impedance value) for the calibration standard. Only applicable when "Type" is set to naArbitraryImpedance.

To set the other resistance values, use TZReal

VB Syntax

calstd.TZImag = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for TZImag in Ohms

Return Type

Single

Default

Not Applicable

Examples

calstd.TZImag = 15 'Write the value of TZImag to 15 Ohms

imp0 = calstd.TZImag 'Read the value of TZImag

C++ Syntax

HRESULT get_TZImag(float *pVal);
HRESULT put_TZImag(float newVal);

Interface

ICalStandard2


Write/Read

About Modifying Cal Kits

TZReal Property

Description

Sets and Returns the TZReal value (the real Terminal Impedance value) for the calibration standard. Only applicable when "Type" is set to naArbitraryImpedance.

To set the other resistance values, use TZImag

VB Syntax

calstd.TZReal = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for TZReal in Ohms

Return Type

Single

Default

Not Applicable

Examples

calstd.TZReal = 15 'Write the value of TZReal to 15 Ohms

imp0 = calstd.TZReal 'Read the value of TZReal

C++ Syntax

HRESULT get_TZReal(float *pVal);
HRESULT put_TZReal(float newVal);

Interface

ICalStandard2


Read-only

UnusedChannelNumbers Property

Description

Returns an array of channel numbers that are NOT in use. An unused channel has NO measurements subscribed to it.

VB Syntax

chanNumbers = chans.UnusedChannelNumbers (NumberOfChannels)

Variable

(Type) - Description

chanNumbers

Variable array to store the returned channel numbers

chans

A Channel collection (object)

NumberOfChannels

(Long Integer) Number of channels that you are requesting.

Return Type

One-dimensional array of long integers. The size of the array is specified by the NumberOfChannels parameter.

Default

Not Applicable

Examples

chanNumbers = chans.UnusedChannelNumbers(5)

C++ Syntax

HRESULT get_UnusedChannelNumbers(long numberRequested,VARIANT* channelNumbers);

Interface

IChannels2


Read-only

UsedChannelNumbers Property

Description

Returns an array of channel numbers that are in use. A used channel has at least one measurement subscribed to it

VB Syntax

chanNumbers = chans.UsedChannelNumbers

Variable

(Type) - Description

chanNumbers

Variable array to store the returned channel numbers

chans

A Channel collection (object)

Return Type

One-dimensional array of long integers

Default

Not Applicable

Examples

chanNumbers = chans.UsedChannelNumbers

C++ Syntax

HRESULT get_UsedChannelNumbers(VARIANT* channelNumbers);

Interface

IChannels2


Write / Read

About Source Power Cal

UsePowerLossSegments Property

Description

Specifies if subsequent calls to the AcquirePowerReadings method will make use of the loss table (PowerLossSegments).

VB Syntax

pwrCal.UsePowerLossSegments = value

Variable

(Type) - Description

pwrCal

(object) – A SourcePowerCalibrator (object)

value

(boolean) -

False (0) – Do not use loss table

True (1) – Use loss table

Return Type

Boolean

Default

False

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.UsePowerLossSegments = 1 'Write
lossTableState = powerCalibrator.UsePowerLossSegments 'Read

C++ Syntax

HRESULT put_UsePowerLossSegments(VARIANT_BOOL bState);

HRESULT get_UsePowerLossSegments(VARIANT_BOOL *bState);

Interface

ISourcePowerCalibrator


Write / Read

About Source Power Cal

UsePowerSensorFrequencyLimits Property

Description

Specifies if subsequent calls to the AcquirePowerReadings method will observe frequency values of the MinimumFrequency and MaximumFrequency properties.

VB Syntax

pwrCal.UsePowerSensorFrequencyLimits = value

Variable

(Type) - Description

pwrCal

(object) – A SourcePowerCalibrator (object)

value

(boolean) -

False (0) – Do not use power sensor frequency limits. An acquisition will use just one power sensor for the entire sweep, regardless of frequency.

True (1) – Use power sensor frequency limits. A requested acquisition will only succeed for those frequency points which fall between the MinimumFrequency and MaximumFrequency values of that PowerSensor. An acquisition will pause in mid-sweep if the frequency is about to exceed the MaximumFrequency value. When the sweep is paused in this manner, a sensor connected to the other channel input of the power meter can be connected to the measurement port in place of the previous sensor, and then the sweep completed by another call to AcquirePowerReadings. However, the MaximumFrequency specified for the second sensor would need to be sufficient for the sweep to complete.

Return Type

Boolean

Default

False (0)

Examples

Set powerCalibrator = pna.SourcePowerCalibrator
powerCalibrator.UsePowerSensorFrequencyLimits = 1 'Write
FreqCheck = powerCalibrator.UsePowerSensorFrequencyLimits 'Read

C++ Syntax

HRESULT put_UsePowerSensorFrequencyLimits(VARIANT_BOOL bState);

HRESULT get_UsePowerSensorFrequencyLimits(VARIANT_BOOL *bState);

Interface

ISourcePowerCalibrator


User Range Property

Write/Read
About User Ranges

UserRange Property

Description

Assigns the marker to the specified User Range. This restricts the marker's x-axis travel to the User Range span, specified with Start and Stop values.

  • Each channel has 10 user ranges.

  • Markers and trace statistics can be restricted to any user range.

  • More than one marker can occupy a user range.

  • User ranges can overlap. For example:

    • User range 1 - 3GHz to 5GHz

    • User range 2 - 4GHz to 6GHz

Note: User ranges are especially useful in restricting marker searches to specific areas of the measurement.

VB Syntax

mark.UserRange = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - User Range. Choose any number between 0 and 9 (0=Full Span)

Return Type

Long Integer

Default

0 - Full Span

Examples

mark.UserRange = 1 'Write

UseRnge = mark.UserRange 'Read

C++ Syntax

HRESULT get_UserRange(long *pRangeNumber)
HRESULT put_UserRange(long lRangeNumber)

Interface

IMarker


User Range Max Property

Write/Read
About User Ranges

UserRangeMax Property

Description

Sets the stimulus stop value for the specified User Range.

This property uses different arguments for the channel and marker objects.

VB Syntax

chan.UserRangeMax(domainType,Mnum) = value
or
mark.UserRangeMax(rnum) = value

Variable

(Type) - Description

chan

A Channel (object)

mark

A Marker (object)
To assign a marker to a User Range, use the UserRange Property.

Note: The Marker object does not require the "DomainType" argument.

domainType

(enum NADomainType) - Choose from:

0 - naDomainFrequency
1 - naDomainTime
2 - naDomainPower

Mnum

(long integer) - User Range number. Choose any number between 1 and 9 (0=Full Span)

value

(double) - Stop value. Choose any number within the full span of the channel

Return Type

Double

Default

The current stimulus setting for the channel

Examples

mark.UserRangeMax(1) = 3e9 'Write
chan.UserRangeMax(naDomainFrequency,1) = 3e9 'Write

UseRngeMax = mark.UserRangeMax 'Read
UseRngeMax = chan.UserRangeMax 'Read

C++ Syntax

HRESULT put_UserRangeMax(tagNADomainType domain, long rangeNumber, double maxValue)
HRESULT get_UserRangeMax(tagNADomainType domain, long rangeNumber, double *maxValue)

Interface

IChannel


User Range Min Property

Write/Read
About User Ranges

UserRangeMin Property

Description

Sets the stimulus start value for the specified User Range.

This property uses different arguments for the channel and marker objects.

VB Syntax

chan.UserRangeMin(domainType,range) = value
or
mark.UserRangeMin(range) = value

Variable

(Type) - Description

chan

A Channel (object)

mark

A Marker (object)
To assign a marker to a User Range, use the UserRange Property.

Note: The Marker object does not require the DomainType argument

domainType

(enum NADomainType) Type of sweep currently implemented on the channel - Choose from:
0 - naDomainFrequency
1 - naDomainTime
2 - naDomainPower

range

(long) - User Range number. Choose any number between 1 and 9 (0=Full Span)

value

(double) - Start value. Choose any number within the full span of the analyzer

Return Type

Double

Default

The current stimulus setting for the channel

Examples

mark.UserRangeMin(1) = 3e9 'Write
chan.UserRangeMin(naDomainFrequency,1) = 3e9 'Write

UseRngeMin = mark.UserRangeMin 'Read
UseRngeMin = chan.UserRangeMin 'Read

C++ Syntax

HRESULT put_UserRangeMin(tagNADomainType domain, long rangeNumber, double minValue)
HRESULT get_UserRangeMin(tagNADomainType domain, long rangeNumber, double *minValue)

Interface

IChannel


Write/Read
About User Preset

UserPresetEnable Property

Description

'Checks' and 'clears' the enable box on the User Preset dialog box. This only affects subsequent Presets from the front panel user interface.

Regardless of the state of the User Preset Enable checkbox, the app.Preset command will always preset the PNA to the factory preset settings, and app.UserPreset will always perform a User Preset.

VB Syntax

app.UserPresetEnable = state

Variable

(Type) - Description

app

An Application (object)

state

(boolean) Front Panel User Preset State. Choose from:

0 (False) – User Preset OFF

1 (True) – User Preset ON

Return Type

Boolean

Default

OFF (0)

Examples

app.UserPresetEnable = True 'Write

upreset = app.UserPresetEnable 'Read

C++ Syntax

HRESULT get_UserPresetEnable(VARIANT_BOOL *pVal)
HRESULT put_UserPresetEnable(VARIANT_BOOL newVal)

Interface

IApplication6


ValidConnectorType Property

Read only

ValidConnectorTypes Property

Description

Returns a list of connector types for which there are calibration kits.

VB Syntax

value = obj.ValidConnectorTypes

Variable

(Type) - Description

value

(Variant) List of connector types

obj

Any of the following:

GuidedCalibration (object)

SMCType (object)

VMCType (object)

Return Type

Variant

Default

Not Applicable

Examples

value = SMC.ValidConnectorTypes

C++ Syntax

HRESULT get_ValidConnectorTypes(VARIANT* connectorTypes);

Interface

IGuidedCalibration

SMCType

VMCType


Velocity Factor Property

Write/Read

About Port Extensions

VelocityFactor Property

Description

Sets the velocity factor to be used with Electrical Delay, Port Extensions, and Time Domain marker distance calculations.

VB Syntax

app.VelocityFactor = value

Variable

(Type) - Description

app

An Application (object)

value

(double) - Velocity factor. Choose a number between: 0 and 10
(.66 polyethylene dielectric; .7 teflon dielectric)

Return Type

Double

Default

1

Examples

app.VelocityFactor = .66 'Write

RelVel = app.VelocityFactor 'Read

C++ Syntax

HRESULT get_VelocityFactor(double *pVal)
HRESULT put_VelocityFactor(double newVal)

Interface

IApplication


Write/Read

About Math Operations

View Property

Description

Sets (or returns) the type of trace displayed on the screen.

VB Syntax

meas.View = value

Variable

(Type) - Description

meas

A measurement (object)

value

(enum NAView) - Type of trace. Choose from:

0 - naData
1 - naDataAndMemory
2 - naMemory
3 - naNoTrace

Note: The naData trace may reflect the result of a TraceMath operation.

Return Type

NAView

Default

naData

Examples

meas.View = naData 'Write

trceview = meas.View 'Read

C++ Syntax

HRESULT get_View(tagNAView* pView)
HRESULT put_View(tagNAView newView)

Interface

IMeasurement


Write/Read

Visible Property

Description

Makes the Network Analyzer application visible or not visible. In the Not Visible state, the analyzer cycle time for making measurements can be significantly faster because the display does not process data.

VB Syntax

app.Visible = state

Variable

(Type) - Description

app

An Application (object)

state

(boolean)
0 - Network Analyzer application NOT visible
1 - Network Analyzer application IS visible

Return Type

Boolean
0 - Not visible
1 - Visible

Default

1

Examples

app.Visible = 0 'Write

vis = app.Visible 'Read

C++ Syntax

HRESULT get_Visible(VARIANT_BOOL * bVisible)
HRESULT put_Visible(VARIANT_BOOL bVisible)

Interface

IApplication


WGCutoffFreq_Property

Write-Read

WGCutoffFreq Property

Description

Sets or returns the value of the waveguide cut off frequency.

VB Syntax

meas.WGCutoffFreq = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - Frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

Print meas.WGCutoffFreq 'prints the value of the waveguide cut off frequency

C++ Syntax

HRESULT get_WGCutoffFreq(double *pVal);

HRESULT put_WGCutoffFreq(double newVal);

Interface

IMeasurement2


Read-only

WindowNumber Property

Description

Returns the window number. You might use this property to identify a particular window so that you can create a new Measurement in that window.

VB Syntax

value = win.WindowNumber

Variable

(Type) - Description

win

A NAWindow (object)

value

(long integer) - Variable to store the returned window number

Return Type

Long Integer

Default

Not Applicable

Examples

value = app.ActiveNAWindow.WindowNumber

C++ Syntax

HRESULT (long* windowNumber);

Interface

INAWindow


Window State Property

Write/Read

About Arranging Windows

WindowState Property

Description

Sets or returns the window setting of Maximized, Minimized, or Normal. To arrange all of the windows, use app.ArrangeWindows.

VB Syntax

object.WindowState = value

Variable

(Type) - Description

object

An Application (object) - main window
or
A NaWindow (object) - data windows

value

(enum NAWindowStates) - The window state. Choose from:
0 - naMinimized - Minimizes the window to an Icon on the lower toolbar
1 - naMaximized - Maximizes the window
2 - naNormal - changes the window size to the user defined setting (between Max and Min).

Return Type

Long Integer

Default

naMaximized

Examples

app.WindowState = naMinimized 'changes the Network Analyzer application window to an icon. -Write
win.WindowState = naNormal 'changes the window defined by the win object variable to user defined settings. -Write

winstate = app.WindowState 'Read

C++ Syntax

HRESULT get_WindowState(tagNAWindowStates *pVal)
HRESULT put_WindowState(tagNAWindowStates newVal)

Interface

INAWindow
IApplication


Write/Read

About X-Axis Spacing

XAxisPointSpacing Property

Description

Sets X-axis Point Spacing for the displaytraces measured with segment sweeps on the active channel.

VB Syntax

chan.XAxisPointSpacing = value

Variable

(Type) - Description

chan

A Channel (object)

value

(Enum as naStates) - Choose from:

0 - naOFF - Turns X-axis Point Spacing OFF

1 - naON - Turns X-axis Point Spacing ON

Return Type

Enum

Default

0 - naOFF

Examples

chan.XAxisPointSpacing = naOFF 'Write

xspac = chan.XAxisPointSpacing 'Read

C++ Syntax

HRESULT get_XAxisPointSpacing (tagNAStates *pState);
HRESULT put_XAxisPointSpacing (tagNAStates newState);

Interface

IChannel2


Write/Read

About Scale

YScale Property

Description

Sets or returns the Y-axis Per-Division value of the active trace.

VB Syntax

trace.YScale = value

Variable

(Type) - Description

trace

A Trace (object)

value

(double) - Scale /division number. Units and range depend on the current data format.

Return Type

Double

Default

10 (db)

Examples

trac.YScale = 5 'Write

yscl = trac.YScale 'Read

C++ Syntax

HRESULT get_YScale(double *pVal)
HRESULT put_YScale(double newVal)

Interface

ITrace


Write/Read

About Modifying Cal Kits

Z0 Property

Description

Sets and Returns the characteristic impedance for the calibration standard.

VB Syntax

calstd.Z0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) -Impedance in Ohms

Return Type

Single

Default

Not Applicable

Examples

calstd.Z0 = 50 'Write

impedance = calstd.Z0 'Read

C++ Syntax

HRESULT get_Z0(float *pVal)
HRESULT put_Z0(float newVal)

Interface

ICalStandard


Write-only

About Triggering

Abort Method

Description

Ends the current measurement sweep on the channel.

VB Syntax

chan.Abort [sync]

Variable

(Type) - Description

chan

(object) - A Channel object

sync

(boolean) - wait (or not) for the analyzer to stop before processing subsequent commands. Optional argument; if unspecified, value is set to False. Choose from:
True - synchronize - the analyzer will not process subsequent commands until the current measurement is aborted.
False - continue processing commands immediately

Return Type

None

Default

None

Examples

chan.abort True
chan.abort

C++ Syntax

HRESULT Abort(VARIANT_BOOL bSynchronize);

Interface

IChannel


Write-only

About Source Power Cal

AbortPowerAcquisition Method

Description

Aborts a source power cal acquisition sweep that is currently in progress.

VB Syntax

powerCalibrator.AbortPowerAcquisition

Variable

(Type) - Description

powerCalibrator

(object) - A SourcePowerCalibrator object

Return Type

None

Default

Not Applicable

Examples

powerCalibrator.AbortPowerAcquisition

C++ Syntax

HRESULT AbortPowerAcquisition();

Interface

ISourcePowerCalibrator


Acquire Cal Standard Method

Write-only

About Calibration Standards

AcquireCalStandard Method - Obsolete

Description

Note: This command has been replaced by AcquireCalStandard2 Method, which provides for acquisition of sliding load standards. All other functionality is identical.

VB Syntax

cal.AcquireCalStandard std[,index]

Variable

(Type) - Description

cal

A Calibrator (object)

std

(enum NACalClass) Standard to be measured. Choose from:

1 - naClassA

2 - naClassB

3 - naClassC

4 - naClassD

5 - naClassE

6 - naReferenceRatioLine

7 - naReferenceRatioThru

SOLT Standards

1 - naSOLT_Open

2 - naSOLT_Short

3 - naSOLT_Load

4 - naSOLT_Thru

5 - naSOLT_Isolation

TRL Standards

1 - naTRL_Reflection

2 - naTRL_Line_Reflection

3 - naTRL_Line_Tracking

4 - naTRL_Thru

5 - naTRL_Isolation

index

(long integer) number of the standard. Optional argument - Used if there is more than one standard required to cover the necessary frequency range. If unspecified, value is set to 0.

Return Type

None

Default

Not Applicable

Examples

Cal.AcquireCalStandard naSOLT_Thru 'Write

C++ Syntax

HRESULT AcquireCalStandard(tagNACalClass enumClass, short standardNumber)

Interface

ICalibrator


Acquire Cal Standard2 Method

Write-only
About Calibration Standards

AcquireCalStandard2 Method

Description

Measures the specified standard from the selected calibration kit. The calibration kit is selected using app.CalKitType.

For 2-port calibration, it is also necessary to specify direction with AcquisitionDirection.

To omit Isolation from a 2-port calibration, do not Acquire a cal standard for naSOLT_Isolation.

For using two sets of standards, see Simultaneous2PortAcquisition Property.

Note: This command replaces AcquireCalStandard. This command provides for the acquisition of a sliding load cal. All other functionality is identical.

VB Syntax

cal.AcquireCalStandard2 std[,index][,slide]

Variable

(Type) - Description

cal

A Calibrator (object)

std

(enum NACalClass) Standard to be measured. Choose from:

1 - naClassA

2 - naClassB

3 - naClassC

4 - naClassD

5 - naClassE

6 - naReferenceRatioLine

7 - naReferenceRatioThru

SOLT Standards

1 - naSOLT_Open

2 - naSOLT_Short

3 - naSOLT_Load

4 - naSOLT_Thru

5 - naSOLT_Isolation

TRL Standards

1 - naTRL_Reflection

2 - naTRL_Line_Reflection

3 - naTRL_Line_Tracking

4 - naTRL_Thru

5 - naTRL_Isolation

[index]

(long integer) Number of the standard. Optional argument - Used if there is more than one standard required to cover the necessary frequency range. If unspecified, value is set to 1.

[slide]

(enum as NACalStandardSlidingState) Optional argument. State of the sliding load. The slide should be set a minimum of five times. Seven is the maximum that can be stored. Choose from:

0 - naNotSlidingStd - not using a sliding load - Default if not specified.

1 - naSlideIsSet - slide is set for acquisition

2 - naSlideIsDone - this next acquisition will be the last. Calculations will then be performed.

Return Type

None

Default

Not Applicable

Examples

Cal.AcquireCalStandard2 naSOLT_Thru
Cal.AcquireCalStandard2 naSOLT_Thru,2,naNotSlidingStd
'measures the second standard listed in the class of naSOLT_Thru

C++ Syntax

HRESULT AcquireCalStandard2(NACalClass enumClass, long standardPosition, NACalStandardSlidingState slidingStandardState)

Interface

ICalibrator


Write-only
About ECAL Confidence Check

AcquireCalConfidenceCheckECALEx Method

Description

This method replaces AcquireCalConfidenceCheckECAL

Transfers confidence data from the specified ECal module into the measurement's memory trace. The data is transferred to the specified S-parameter on the same channel as this Calibrator object.

The characterization within the ECal module that the confidence data will be read from is specified by ECALCharacterizationEx. The default value is 0.

VB Syntax

cal.AcquireCalConfidenceCheckECALEx Sparam [,ecalModule]

Variable

(Type) - Description

cal

A Calibrator (object)

Sparam

(String) S-parameter to transfer confidence data to. This parameter must be present on the same channel as the calibrator object.

ecalModule

(Integer) – Optional argument. ECal module.

Choose from modules 1 through 8

Use IsECALModuleFoundEx to determine the number of modules connected to the PNA

Use GetECALModuleInfoEx to return the model and serial number of each module.

Return Type

None

Default

Not applicable

Examples

Cal.AcquireCalConfidenceCheckECALEx "S11", 2

C++ Syntax

HRESULT AcquireCalConfidenceCheckECALEx(BSTR strParameter, long moduleNumber = 1);

Interface

ICalibrator4


Write-only
About Source Power Cal

AcquirePowerReadings Method

Description

Initiates a source power cal acquisition.

VB Syntax

powerCalibrator.AcquirePowerReadings device [,sync]

Variable

(Type) - Description

powerCalibrator

(object) - A SourcePowerCalibrator object

device

(enum NAPowerAcquisitionDevice) The specific device (sensor on the power meter) to be used for the acquisition. Choose from:

0 – naPowerSensor_A

1 – naPowerSensor_B

To use the sensor that currently corresponds to the frequency of interest, use the value from the PowerAcquisitionDevice property.

sync

(boolean) Optional argument. If not specified, value is set to False. Choose from:

True (1) – The method does not return until this acquisition has completed (the program calling this method is halted while waiting for the method to return).

False (0) – The method initiates an acquisition then returns immediately (while the acquisition still proceeds). The program calling this method can then perform other operations during the acquisition.

Return Type

None

Default

Not Applicable

Examples

powerCalibrator.AcquirePowerReadings naPowerSensor_A, True

C++ Syntax

HRESULT AcquirePowerReadings(tagNAPowerAcquisitionDevice enumAcqDevice, VARIANT_BOOL bSync);

Interface

ISourcePowerCalibrator


Write-only

AcquireStep Method

Description

Acquire the measurement data for the specified step in the calibration process.

VB Syntax

obj.AcquireStep (n)

Variable

(Type) - Description

obj

Any of the following:

GuidedCalibration (object)

SMCType (object)

VMCType (object)

n

Step number in the calibration process.

Use GenerateSteps to determine the total number of steps.

Use GetStepDescription to read the description of each step.

Return Type

Not Applicable

Default

Not Applicable

Examples

VMC.AcquireStep (3)

C++ Syntax

HRESULT put_AcquireStep([in] long step);

Interface

SMCType

VMCType

IGuidedCalibration


Write-only

Activate Method

Description

Makes an object the Active Object. When making a measurement active, the channel and window the measurement is contained in becomes the active channel and active window.

In order to change properties on any of the active objects, you must first have a "handle" to the active object using the Set command. For more information, See Getting a Handle to an Object.

You do not have to make an object "Active" to set or read its properties remotely. But an object must be "Active" to change its values from the front panel.

VB Syntax

object.Activate

Variable

(Type) - Description

object

Measurement (object)
or
Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.Activate
mark.Activate

C++ Syntax

HRESULT Activate()

Interface

IMeasurement
IMarker


Activate Marker Method

Write-only
About Markers

ActivateMarker Method

Description

Makes a marker the Active Marker. Use meas.ActiveMarker to read the number of the active marker.

VB Syntax

meas.ActivateMarker(Mnum)

Variable

(Type) - Description

meas

A Measurement (object)

Mnum

(long integer) - the number of the marker to make active. Choose any marker number from 1 to 9.

Return Type

None

Default

Not Applicable

Examples

meas.ActivateMarker(1)'Write

C++ Syntax

HRESULT ActivateMarker(long lMarkerNumber)

Interface

IMeasurement

Remarks

Use ReferenceMarkerState to control the Reference marker.


Write-only
About Windows

ActivateWindow Method

Description

Makes a window object the Active Window.

In order to change properties on any of the active objects, you must first have a "handle" to the active object using the Set command. For more information, See Programming the Analyzer Object Model.

You do not have to make an object "Active" to set or read its properties remotely. But an object must be "Active" to change its values from the front panel.

VB Syntax

app.ActivateWindow n

Variable

(Type) - Description

app

An Application (object)

n

(long) Number of the window to make active

Return Type

Window Object

Default

Not Applicable

Examples

app.ActivateWindow 4

C++ Syntax

HRESULT ActivateWindow(long WindowNumber)

Interface

IApplication


Write-only
About Channels

Add (channels) Method

Description

Creates a channel and returns a handle to it. If the channel already exists, it returns the handle to the existing channel.

VB Syntax

chans.Add (item)

Variable

(Type) - Description

chans

A Channel collection (object)

item

(variant) - Channel number.

Return Type

Channel

Default

Not Applicable

Examples

chans.Add 3 'Creates channel 3

C++ Syntax

HRESULT Add(VARIANT numVal, IChannel** pChannel)

Interface

IChannels


Write-only

Add (measurement) Method

Description

Adds a Measurement to the collection.

VB Syntax

meas.Add channel,param,source[,window]

meas

A Measurements collection (object)

channel

(long) - Channel number of the new measurement.

param

(string) - Parameter of the new measurement. Choose from:

  • "S11"

  • "S22"

  • "S21"

  • "S12"

  • "A"

  • "B"

  • "R1"

  • "R2"

or

  • combine 2 of (A,B,R1,R2) in this format: "A/R1"

source

(long integer) - Source port number; if unspecified, value is set to 1. Only used for non-s-parameter measurements; ignored if s-parameter.

window

(long integer) - Optional argument. Window number of the new measurement. Choose 1 to 16. If unspecified, the S-Parameter will be created in the Active Window.

Return Type

None

Default

None

Examples

meass.Add 3,"A/R1",1,1 'Adds A/R1 measurement to channel 3 in window 1

C++ Syntax

HRESULT Add(long ChannelNum, BSTR strParameter, long srcPort, VARIANT_BOOL bNewWindow)

Interface

IMeasurements


Write-only

About Windows

Add (NAWindows) Method

Description

Add a window to the display. Does not add a measurement. The window number must not already exist.

VB Syntax

wins.Add [item]

Variable

(Type) - Description

wins

A NAWindow collection (object)

item

(variant) - optional argument; Window number. Range between 1 - 4

Return Type

Object

Default

Not Applicable

Examples

wins.Add 3 'Creates a window number 3

C++ Syntax

HRESULT Add(long windowNumber )

Interface

INAWindows


Write-only

About Source Power Cal

Add (PowerLossSegment) Method

Description

Adds a PowerLossSegment to the PowerLossSegments collection.

To ensure predictable results, it is best to remove all segments before defining a new list of segments. For each segment in the collection, do a seg.Remove.

VB Syntax

segs.Add (item [ size])

Variable

(Type) - Description

segs

(object) - A PowerLossSegments collection (object)

item

(variant) - Number of the new segment. If it already exists, a new segment is inserted at the requested position.

size

(long integer) - Optional argument. The number of segments to add, starting with item. If unspecified, value is set to 1.

Return Type

None

Default

Not Applicable

Examples

segs.Add 1, 4 'Adds segments 1,2,3 and 4

C++ Syntax

HRESULT Add(VARIANT index, long size);

Interface

IPowerLossSegments


Write-only

About Source Power Cal

Add (PowerSensorCalFactorSegment) Method

Description

Adds a PowerSensorCalFactorSegment to the CalFactorSegments collection.

To ensure predictable results, it is best to remove all segments before defining a new list of segments. For each segment in the collection, do a seg.Remove.

VB Syntax

segs.Add (item [ size])

Variable

(Type) - Description

segs

(object) - A CalFactorSegments collection (object)

item

(variant) - Number of the new segment. If it already exists, a new segment is inserted at the requested position.

size

(long integer) - Optional argument. The number of segments to add, starting with item. If unspecified, value is set to 1.

Return Type

None

Default

Not Applicable

Examples

segs.Add 1, 4 'Adds segments 1,2,3 and 4

C++ Syntax

HRESULT Add(VARIANT index, long size);

Interface

ICalFactorSegments


Add (segments) Method

Write-only

About Segment Sweep

Add (segment) Method

Description

Adds segments to the Segments collection, but does not turn the segments ON.

VB Syntax

segs.Add (item, [size])

segs

A segments collection (object)

item

(variant) Number of the new segment. If it already exists, a new segment is inserted at the requested position.

size

(long integer) Optional argument. The number of segments to add, starting with item. If unspecified, value is set to 1.

Return Type

None

Default

None

Examples

Segs.Add 1, 4 'Adds segments 1,2,3,and 4. (does NOT automatically turn segments ON)

C++ Syntax

HRESULT Add(VARIANT index, long size);

Interface

ISegments

Remarks

To ensure predictable results, it is best to remove all segments before defining a segment list. For each segment in the collection, do a seg.Remove.


Write/Read

About Analyzer Events

AllowAllEvents Method

Description

Sets event filtering to monitor all events in the analyzer. This is the default setting when subscribing to events. This could slow the measurement speed of the analyzer significantly.

VB Syntax

app.AllowAllEvents

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowAllEvents

C++ Syntax

HRESULT AllowAllEvents()

Interface

IApplication


Write/Read
About Analyzer Events

AllowEventCategory Method

Description

Sets event filtering to monitor a category of event.

VB Syntax

app.AllowEventCategory, category, state

Variable

(Type) - Description

app

An Application (object)

category

Category to monitor. Choose from list in Working with the Analyzer's Events

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventCategory

C++ Syntax

HRESULT AllowEventCategory(tagNAEventCategory category, VARIANT_BOOL bAllow )

Interface

IApplication


Write/Read

About Analyzer Events

AllowEventMessage Method

Description

Sets event filtering to monitor specific events.

VB Syntax

app.AllowEventMessage event

Variable

(Type) - Description

app

An Application (object)

event

Event to monitor. Refer to list in Working with the Analyzer's Events

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventMessage

C++ Syntax

HRESULT AllowEventMessage( tagNAEventID eventID, VARIANT_BOOL bAllow)

Interface

IApplication


Write/Read

About Analyzer Events

AllowEventSeverity Method

Description

Sets event filtering to monitor levels of severity.

VB Syntax

app.AllowEventSeverity severity,state

Variable

(Type) - Description

app

An Application (object)

severity

(enum naEventSeverity) Choose from:naEventSeverityERROR
naEventSeverityINFORMATIONAL
naEventSeveritySUCCESS
naEventSeverityWARNING

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventSeverity

C++ Syntax

HRESULT AllowEventSeverity( tagNAEventSeverity severity, VARIANT_BOOL bAllow)

Interface

IApplication


Write only

Apply Method

Description

Applies the mixer setup to the mixer object and turns the channel ON. (Performs the same function as the Apply button on the mixer setup dialog box.)

VB Syntax

mxr.Apply

Variable

(Type) - Description

mxr

Mixer Interface pointer to the Measurement (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mxr.Apply

C++ Syntax

HRESULT Apply()

Interface

IMixer3


Write-only
About Source Power Cal

ApplyPowerCorrectionValues Method

Description

Applies the array of power correction values to the channel memory and turns correction ON. Perform after completing a source power cal acquisition sweep.

This command does NOT save the correction values. To save correction values, save an instrument / calibration state (*.cst file) after performing a source power cal.

VB Syntax

powerCalibrator.ApplyPowerCorrectionValues

Variable

(Type) - Description

powerCalibrator

(object) - A SourcePowerCalibrator object

Return Type

None

Default

Not Applicable

Examples

powerCalibrator.ApplyPowerCorrectionValues

C++ Syntax

HRESULT ApplyPowerCorrectionValues();

Interface

ISourcePowerCalibrator


Write-only
About Display Formatting

Autoscale Method

Description

Trace Object - Autoscales only the ONE trace on which Autoscale is being called.

NAWindow Object - Autoscales ALL of the traces in the Window on which Autoscale is being called.

VB Syntax

object.Autoscale

Variable

(Type) - Description

object

Trace (object)
or
NAWindow (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

Trac.Autoscale 'Autoscales the trace
Win.Autoscale 'Autoscales all the traces in the window -Write

C++ Syntax

HRESULT AutoScale()

Interface

INAWindow
ITrace


Averaging Restart Method

Write-only
About Averaging

AveragingRestart Method

Description

Clears and restarts averaging of the measurement data.

VB Syntax

chan.AveragingRestart

Variable

(Type) - Description

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.AveragingRestart

C++ Syntax

HRESULT AveragingRestart()

Interface

IChannel


Build Hybrid Kit Method

Write-only

About Modifying Cal Kits

BuildHybridKit Method

Description

Use this method when you have different port connectors. This is a convenient way to combine two kits that match the connectors on your DUT.

VB Syntax

app.BuildHybridKit port1Kit,p1sex,port2Kit,p2sex,adapter,user kit

Variable

(Type) - Description

app

An Application (object)

port1Kit
port2Kit

(enum NACalKit) - Specifies the two kits to be used to build the hybrid kit. Choose from:

naCalKit_85032F_N50
naCalKit_85033E_3_5
naCalKit_85032B_N50
naCalKit_85033D_3_5
naCalKit_85038A_7_16
naCalKit_85052C_3_5_TRL
naCalKit_User7
naCalKit_User8
naCalKit_User9
naCalKit_User10

p1sex
p2sex

(enum NAPortSex) - Specifies the sex of the connector at that port. Choose from:
naMale
naFemale
naDon'tCare

adapter

(enum NAAdapter) -Choose from:
naUserkit - the electrical length of the adapter in the userKit specifications
naZeroLength - no adapter

userKit

(enum NACalKit) - The Hybrid kit - Choose from the previous list of kits

Return Type

Not Applicable

Default

Not Applicable

Examples

app.BuildHybridKit naCalKit_85033E_3_5,naMale,naCalKit_85038A_7_16
,naFemale,naUserkit,naCalKit_User8

C++ Syntax

HRESULT BuildHybridKit\(tagNACalKit port1Kit, tagNAPortSex port1Sex, tagNACalKit port2Kit, tagNAPortSex port2Sex, tagNAAdapter adapter, tagNACalKit userKit)

Interface

IApplication


Calculate Error Coefficients Method

Write-only

About Performing a Calibration

CalculateErrorCoefficients Method

Description

This method is the final call in a calibration process. It calculates error-correction terms and turns error-correction ON.

Do NOT use this command during an ECAL.

VB Syntax

cal.CalculateErrorCoeffecients

Variable

(Type) - Description

cal

Calibrator (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

Cal.CalculateErrorCoeffecients

C++ Syntax

HRESULT CalculateErrorCoefficients()

Interface

ICalibrator


Write only

Calculate Method

Description

Calculates the Input or Output frequencies of the mixer setup, applies the mixer setup to the mixer object, and turns the channel ON.

VB Syntax

mxr.Calculate (port)

Variable

(Type) - Description

mxr

Mixer Interface pointer to the Measurement (object)

port

(enum as MixerCalculation) Port of the mixer for which to calculate start and stop frequencies. Choose from:

enum

1st or only stage requires:

In addition, 2nd stage requires:

0

mixCalculateINPUT

  • Output Start and Stop frequencies

  • LO frequency

  • Output sideband (High or Low)

  • IF Start and Stop frequencies

  • 2nd LO frequency

  • IF sideband (High or Low)

1

mixCalculateINPUT AndOUTPUT

(2 stage mixers ONLY)

NA

  • IF Start and Stop frequencies

  • Both LO frequencies

2

mixCalculateOUTPUT

  • Input Start and Stop frequencies

  • LO frequency

  • Output sideband (High or Low)

  • IF Start and Stop frequencies

  • 2nd LO frequency

  • IF sideband (High or Low)

3

mixCalculateLO1

  • Input Start and Stop frequencies

  • Output frequency

  • Output sideband (High or Low)

  • IF Start and Stop frequencies

  • 2nd LO frequency

  • IF sideband (High or Low)

4

mixCalculateLO2

NA

  • Input Start and stop frequencies

  • 1st LO start and stop frequencies

  • Output frequency

  • IF sideband(High or Low

  • Output sideband(High or Low)

Return Type

Not Applicable

Default

Not Applicable

Examples

mxr.Calculate (mixCalculateOUTPUT)

C++ Syntax

HRESULT Calculate()

Interface

IMixer


Change Parameter Method

Write-only

About Measurement Parameters

ChangeParameter Method

Description

Changes the parameter of the measurement.

VB Syntax

meas.ChangeParameter(param,lPort)

Variable

(Type) - Description

meas

A Measurement (object)

param

(string) - New parameter. Choose from:

S11 | S22 | S21 | S12

Additionally, for 3-port analyzers only:

S33 | S13 | S31 | S23 | S32

For non-ratioed measurements:
A | B | R1 | R2
C - 3-port analyzers only

For ratioed measurements:

A/B

A/C - 3 port analyzers only

B/A

B/C - 3 port analyzers only

C/A - 3 port analyzers only

C/B - 3 port analyzers only

A/R1

B/R1

C/R1 - 3 port analyzers only

A/R2

B/R2

R1/A

R2/A

R1/B

R2/B

R1/C - 3 port analyzers only

R2/R1

R1/R2

lPort

(long integer)
Load port if param is a reflection S-Parameter

Ignored if param is a transmission S-Parameter

Source port if param is anything other than an S-parameter

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.ChangeParameter "S11",1

C++ Syntax

HRESULT ChangeParameter(BSTR parameter, long lPort)

Interface

IMeasurement


Write-only
About Source Power Cal

CheckPower Method

Description

Measures power at a specified frequency. Use this method to test power level before and/or after applying a source power calibration.

VB Syntax

pow = pwrCal.CheckPower (device, freq [,unit])

Variable

(Type) - Description

pow

(double) Variable to store power value returned by this method.

pwrCal

A SourcePowerCalibrator (object)

device

(enum NAPowerAcquisitionDevice) The specific sensor on the power meter to be used for the acquisition. Choose from:

0 – naPowerSensor_A

1 – naPowerSensor_B

To use the sensor that currently corresponds to the frequency of interest, use the value from the PowerAcquisitionDevice property.

freq

(double) Frequency (Hz) at which the sensor is to read the power.

unit

(enum NAPowerUnit)

Optional argument. Choose from:

naDBM – Returns the power in dBm.(default)

naWATT – Returns the power in Watts.

Return Type

Double

Default

Not Applicable

Examples

watt = powerCalibrator.CheckPower(naPowerSensor_A, 1E9, naWATT)

C++ Syntax

HRESULT put_CheckPower(tagNAPowerAcquisitionDevice enumAcqDevice, double dFreq, tagNAPowerUnit enumPowerUnit, double *pdPower);

Interface

ISourcePowerCalibrator2


Write-only
About Cal Sets

Close CalSet Method

Description

Closes read/write access to the Cal Set.

See OpenCalSet for an explanation of gaining access to the Cal Set.

When you are finished reading and writing data from or to the Cal Set, close the Cal Set. Subsequent read/writes will require a new OpenCal Set call.

Reading and writing Cal Set data is performed with the PutStandard, GetStandard, PutErrorTerm, GetErrorTerm method calls. These methods are provided by the ICal Set and ICalData2 interfaces.

VB Syntax

CalSet.CloseCalSet

Variable

(Type) - Description

CalSet

(object) - A Cal Set object

Return Type

Not Applicable

Default

Not Applicable

Examples

Cal Set.CloseCalSet

C++ Syntax

HRESULT CloseCalSet

Interface

ICalSet


Write-only

About Cal Sets

ComputeErrorTerms Method

Description

Computes error terms for the caltype specified by a preceding OpenCal Set call.

The Cal Set must first be opened using OpenCalSet. If this call has not been made, the following error is issued:

E_NA_Cal Set_ACCESS_DENIED

The standards data required for the CalType must be available in the Cal Set or this error will be returned: E_NA_STANDARD_NOT_FOUND.

Note: Error term computation requires data for the actual calibration kit standards from the current kit definition. ComputeErrorTerms assumes that the standards were acquired using only one standard per class.

VB Syntax

CalSet.ComputeErrorTerms

Variable

(Type) - Description

CalSet

(object) - A Cal Set object

Return Type

Not Applicable

Default

Not Applicable

Examples

CalSet.ComputeErrorTerms

C++ Syntax

HRESULT ComputeErrorTerms( )

Interface

ICalSet


Write-Read
Learn about the Pulsed Application

ConfigNarrowBand3 Method

Description

Note: This method replaces ConfigNarrowBand2 Method. The BW argument now returns 0 if no solution is found for the specified PRF and BW. In addition, adjustments were made to the filter finder algorithm

This subroutine determines, then returns, the proper configuration for pulsed measurements on the PNA using the spectral nulling technique. The configuration returned needs to be sent to the PNA and any other related external equipment such as pulse generators. The routine will take a desired Pulse Repetition Frequency (PRF) and measurement IFBW and return a possibly modified PRF and IFBW for proper pulsed operation on the PNA. The routine will also return the Sample Rate, Number of Taps, and Offset that must be sent to the PNA to configure it in pulsed mode using the spectral nulling technique.

Although the example below uses COM programming to communicate with the PNA, these commands can be replaced with SCPI equivalents.

Note: The pulsed application may set the offset frequency (option 080) of the PNA to some value other than zero (the default value). If the stop frequency is set to the maximum of the PNA model, then an error message may appear on the PNA stating that the response frequency has exceeded the maximum allowed frequency. To fix this, set the stop frequency to a value that is at least 2 KHz less than the maximum allowed.
For example, if you have a 20 GHz PNA, and the stop frequency is set to 20 GHz, and the error message appears, then set the stop frequency to 19.999998 GHz

VB Syntax

Pulsed.ConfigNarrowBand (PRF, NumTaps, BW, OffSet, SampleRate, Precision, FixedPRF, PG81110)

Variable

(Type) - Description

Pulsed

(interface) An interface to the agilentpnapulsed.dll application interface.

PRF

(Double) The Pulse Repetition Frequency.

[out] The pulse repetition frequency that has been optimized for use with the PNA. NOTE: This value may be different from the value requested.

[in] The desired pulse repetition frequency.

NumTaps

(Long) The number of taps to send to the PNA for pulsed operation.

BW

(Long) The PNA IF Bandwidth.

[out] The PNA IF bandwidth that has been optimized for use with the PNA. NOTE: This value may be different from the value requested. Zero (0) is returned if no solution is found for the specified PRF and BW.

[in] The desired PNA IF bandwidth.

Offset

(Double) The offset value to send to the PNA for pulsed operation. The offset value is used to adjust the PNA for the two different possible sample rates that may be returned.

SampleRate

(Double) The sample rate to send to the PNA for pulsed operation.

Precision

(Double) The precision variables sets the precision that will be used to decrement the PRF when running the configuration routines. This variable can be set to the precision required by the external pulse generators so that the configuration routine will not return a PRF that is not within the precision limits of the pulse generators.

FixedPRF

(Boolean)

1 (True) Signals the .DLL routine to NOT adjust the PRF value; rather adjust ONLY the IF Bandwidth. This is the default setting.

0 (False) Adjust both the PRF and IF Bandwidth values as necessary.

PG81110

(Boolean)

1 (True) You are using an Agilent 81110 as the pulse generator. This allows increased accuracy in adjustments for offset and PRF.

0 (False) Not using an Agilent 81110.

Return Type

Not Applicable

Default

Not Applicable

Example

See an example using this command.

C++ Syntax

HRESULT ConfigNarrowBand(double *pPRF, long *pNumTaps, long *pBW, double *pOffset, double *pSampleRate, int Precision)

Interface

AgilentPNAPulsed.Application


Write-only

About Triggering

Continuous Method

Description

The channel continuously responds to trigger signals.

Note: This command does NOT change TriggerSignal to Continuous.

VB Syntax

chan.Continuous

Variable

(Type) - Description

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.Continuous

C++ Syntax

HRESULT Continuous()

Interface

IChannel


Write-only

About Cal Sets

Copy Method

Description

Creates a new Cal Set and copies the current Cal Set data into it. Therefore, you now have a clone Cal Set with a different ID. Use this command to manipulate data on a Cal Set without corrupting the original cal data.

VB Syntax

CalSet.Copy

Variable

(Type) - Description

CalSet

(object) - A Cal Set object

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim mgr As CalManager
Dim ocalset As CalSet
Dim newcalset As CalSet
Set mgr = pna.GetCalManager
'Create a new (empty) Cal Set.
Set ocalset = mgr.CreateCalSet(1)
ocalset.Description = "original calset"
pna.Channel(1).SelectCalSet ocalset.GetGUID, True

'Launch the cal wizard and allow the user to perform the calibration.
If pna.LaunchCalWizard(False) Then
'If the Launch returns true then the calibration finished.
ocalset.Save

'Copy the Cal Set to the new one.
Set newcalset = ocalset.Copy
newcalset.Description = "copy of original calset"

Else
'If the cal doesn't finish, delete the old Cal Set
'so it isn't taking up unnecessary memory.
mgr.DeleteCalSet ocalset.GetGUID
End If

As a result, the programmer can manipulate the data in the new Cal Set and always revert back to the old Cal Set as needed.

C++ Syntax

HRESULT Copy( ICalSet** pCalSet);

Interface

ICalSet


CopyToChannel_Method

Write-only

About Copy Channels

CopyToChannel Method

Description

Sets up another channel as a copy of this object’s channel.

VB Syntax

chan.CopyToChannel(lChanNum)

Variable

(Type) - Description

chan

A Channel (object)

IChanNum

(long integer) – Number of the channel to become a copy of this channel.

Return Type

None

Default

Not Applicable

Examples

Dim chan As Channel

Set chan = PNAapp.ActiveChannel

Const lNEW_CHAN_NUM As Long = 2

chan.CopyToChannel(lNEW_CHAN_NUM)

C++ Syntax

HRESULT CopyToChannel(long lChanNum);

Interface

IChannel2


Create SParameterEX Method

Write-only
About Measurement Parameters

CreateSParameterEx Method

Description

Creates a new S-Parameter measurement in an existing or new window and specifies the load port for 3-port devices.

VB Syntax

app.CreateSParameter chan,recvr,source[,loadPort][,window]

Variable

(Type) - Description

app

Application (object)

chan

(long integer) - Channel number of the new measurement

recvr

(long integer) - Port number of the receiver

source

(long integer) - Port number of the source

loadPort

(long integer) - Port number of the load. Required for reflection measurements of 3-port devices on 3-port PNAs.

window

(long integer) - Optional argument. Window number of the new measurement. Choose 1 to 4. If unspecified, the S-Parameter will be created in the Active Window.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.CreateSParameter 1,2,1,1 'Creates a new S21 measurement in channel 1 and New window(1)
app.CreateSParameter 2,1,1,3,1 'Creates a new S11 measurement on channel 2 with port 3 as the load. Create in the active window

C++ Syntax

HRESULT CreateSParameter(long ChannelNum, long RcvPort, long SrcPort, long LoadPort, long windowNumber)

Interface

IApplication


CreateCal Set Method

Write-only

About Cal Sets

CreateCalSet Method

Description

Creates a new Cal Set.

The new cal set is initialized with the stimulus settings from the channel whose number is passed as the argument to this method. Stimulus settings include frequency, bandwidth, number of points, and so forth.

Use this method when you want to manually upload data to the Cal Set using the returned ICal Set interface handle..

The channel number does not restrict the usage of this Cal Set on any other channel. It simply provides a link to the originating channel so that the stimulus values can be stored in the Cal Set.

Note: Be sure to SAVE the CalSet you are creating. Use ICalSet::Save.

VB Syntax

calMgr.CreateCalSet (chan)

Variable

(Type) - Description

calMgr

(object) - A CalManager object

chan

(long) - channel number of the new Cal Set.

Return Type

ICal Set Interface

Default

Not Applicable

Example

calMgr.CreateCalSet 1

C++ Syntax

HRESULT CreateCalSet( long ChannelNumber, ICal Set** pCal Set);

Interface

ICalManager


Write-only

CreateCustomMeasurementEx Method

Description

Creates a new custom measurement.

VB Syntax

app.CreateCustomMeasurementEx chanNum,ID,initData [,window]

Variable

(Type) - Description

app

(object) - An Application object

chanNum

(long) -Channel number used by the new measurement; can exist or be a new channel.

ID

(string) - Identifier of the new custom measurement object. The new custom measurement must be installed and registered on the PNA.

Choose from the following Program IDs:

  • FCA.VMCMeas

  • SMC_Forward.SMC_ForwardMeas

  • SMC_Reverse.SMC_ReverseMeas

InitData

(variant) Measurement specific data for passing initialization data to the new measurement. The variant type and content of the initialization value is defined by the type of measurement being created.

Program ID | Choose from:
FCA.VMCMeas | "S11" "VC21" "S22"
SMC_Forward.SMC_ForwardMeas | "S11" "SC21" "S22" "IPwr" "OPwr"
SMC_Reverse.SMC_ReverseMeas | "S11" "SC12" "S22" "IPwr" "OPwr"

window

(long) Optional argument. Number of the window the new custom measurement will be placed in. Choose 1 to 16. If unspecified, the measurement is placed in the active window.

Return Type

IMeasurement

Default

Not Applicable

Examples

'To create a forward scalar mixer measurement in channel 2:
Dim MyMeas as Agilent835x.Measurement
Set MyMeas = app.CreateCustomMeasurementEx ( 2, "SMC_Forward.SMC_ForwardMeas", "SC21" )

'To create a reverse scalar mixer measurement in channel 2:
Dim MyMeas as Agilent835x.Measurement
Set MyMeas = app.CreateCustomMeasurementEx ( 2, "SMC_Reverse.SMC_ReverseMeas", "SC12" )

'To create a vector mixer measurement in channel 2:
Dim MyMeas as Agilent835x.Measurement
Set MyMeas = app.CreateCustomMeasurementEx ( 2, "FCA.VMCMeas", "VC21" )

C++ Syntax

HRESULT put_CreateCustomMeasurementEx (long ChannelNum, BSTR guid, VARIANT initData, long windowNumber, IMeasurement** ppMeasurement );

Interface

IApplication3


CreateCustomCal_Method

Write-only

CreateCustomCal Method

Description

Creates a custom cal object.

VB Syntax

calmgr.CreateCustomCal(CalType)

Variable

(Type) - Description

calMgr

Cal Manager (Object)

CalType

(String) Name of the calibration. Choose from:

"VMC" or "VectorMixerCal.VMCType"

"SMC" or "ScalarMixerCal.SMCType"

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim CalMgr As ICalManager2
Dim SMC As ISMCType
Set SMC = CreateCustomCal("SMC")

See SMC and VMC examples using this command.

C++ Syntax

HRESULT CreateCustomCal( BSTR CustomCal)

Interface

ICalManager2


Write-only

About Measurement Parameters

CreateMeasurement Method

Description

Creates a new measurement

VB Syntax

app.CreateMeasurement chanNum,param,lPort[,window]

Variable

(Type) - Description

app

Application (object)

chanNum

(long) - Channel number of the new measurement; can exist or be a new channel

param

((string) - New parameter. Choose from:

S11 | S22 | S21 | S12

Additionally, for 3-port analyzers only:

S33 | S13 | S31 | S23 | S32

For non-ratioed measurements:
A | B | R1 | R2
C -3-port analyzers only

For ratioed measurements:

A/B

A/C - 3 port analyzers only

B/A

B/C - 3 port analyzers only

C/A - 3 port analyzers only

C/B - 3 port analyzers only

A/R1

B/R1

C/R1 - 3 port analyzers only

A/R2

B/R2

R1/A

R2/A

R1/B

R2/B

R1/C - 3 port analyzers only

R2/R1

R1/R2

lPort

(long) -
Load port if param is a reflection S-Parameter

Ignored if param is a transmission S-Parameter

Source port if param is anything other than an S-parameter

window

(long) Optional argument. Window number of the new measurement. Choose 1 to 16. If unspecified, the measurement will be created in the Active Window.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.CreateMeasurement(1,"A/R1",1,0)

C++ Syntax

HRESULT CreateMeasurement(long ChannelNum, BSTR strParameter, long lPort, long windowNumber)

Interface

IApplication


Write-only

About Receiver Cal

DataToDivisor Method

Description

Stores the measurement’s data to the measurement’s “divisor” buffer for use by the Normalization data processing algorithm. Normalization is currently supported only on measurements of unratioed power, for purpose of receiver power calibration. If DataToDivisor is called on a ratioed measurement (such as an S-parameter), it will return an error.

VB Syntax

meas.DataToDivisor

Variable

(Type) - Description

meas

(object) - A Measurement object

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DataToDivisor

C++ Syntax

HRESULT DataToDivisor();

Interface

IMeasurement


Write-only
About Math Operations

DataToMemory Method

Description

Stores the active measurement data into memory creating a memory trace. The memory can then be displayed or used in calculations with the measurement data.

VB Syntax

meas.DataToMemory

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DataToMemory

C++ Syntax

HRESULT DataToMemory()

Interface

IMeasurement


Write-only

About Measurement Parameters

Delete Method

Description

Deletes the measurement.

VB Syntax

meas.Delete

Variable

(Type) - Description

meas

The Measurement object to delete (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.Delete

C++ Syntax

HRESULT Delete()

Interface

IMeasurement


Delete Marker Method

Write-only

About Markers

DeleteMarker Method

Description

Deletes a marker from the measurement.

VB Syntax

meas.DeleteMarker(Mnum)

Variable

(Type) - Description

meas

A Measurement (object)

Mnum

(long) - Any existing marker number in the measurement

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DeleteMarker(1)

C++ Syntax

HRESULT DeleteMarker(long lMarkerNumber)

Interface

IMeasurement


Write-only
About Markers

DeleteAllMarkers Method

Description

Deletes all of the markers from the measurement.

VB Syntax

meas.DeleteAllMarkers

Variable

(Type) - Description

meas

(object) - The Measurement object from which markers will be deleted.

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DeleteAllMarkers

C++ Syntax

HRESULT DeleteAllMarkers()

Interface

IMeasurement


DeleteCal Set Method

Write-only
About Cal Sets

DeleteCalSet Method

Description

Deletes a Cal Set from the set of available Cal Sets. This method immediately updates the Cal Set file on the hard drive. If the Cal Set is currently being used by a channel, this request will be denied and an error is returned.

Errors returned by this method:

E_NA_CAL_SET_IN_USE

E_NA_Cal Set_NOT_FOUND

E_NA_Cal Set_SAVE_FAILED

Using the Cal Sets collection is a convenient way to manage Cal Sets.

VB Syntax

calMgr.DeleteCalSet (GUID)

Variable

(Type) - Description

calMgr

(object) - A CalManager object

GUID

(string) - GUID number of the Cal Set to be deleted

Return Type

Not Applicable

Default

Not Applicable

Example

dim cs As CalSet ' the collection

dim strGUID as string

strGUID = cs.GetGUID

calMgr.DeleteCalSet  strGUID

C++ Syntax

HRESULT DeleteCalSet( BSTR strGUID);

Interface

ICalManager


Write-only

About Macros

DeleteShortCut Method

Description

Removes a macro from the list of macros in the analyzer. Does not remove the file.

Note: There are always 12 macro positions. They do not have to be sequential. For example, you can have number 7 but no numbers 1 to 6.

VB Syntax

app.DeleteShortCut item

Variable

(Type) - Description

app

An Application (object)

item

(long integer) number of the macro to be deleted.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DeleteShortCut 2

C++ Syntax

HRESULT DeleteShortcut(long Number )

Interface

IApplication


Write/Read
About Analyzer Events

DisallowAllEvents Method

Description

Sets event filtering to monitor NO eventst.

VB Syntax

app.DisallowAllEvents

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DisallowAllEvents

C++ Syntax

HRESULT DisallowAllEvents()

Interface

IApplication


Do Print Method

Write-only

About Printing

DoPrint Method

Description

Prints the screen to the default Printer.

VB Syntax

app.DoPrint

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DoPrint

C++ Syntax

HRESULT DoPrint()

Interface

IApplication


Write-only
About Calibration

DoECAL1PortEx Method

Description

This method replaces DoECAL1Port Method.

Does a 1-Port calibration using an ECAL module. You must first have a 1-port measurement active to perform the calibration.

The characterization within the ECal module that will be used for the calibration is specified by ECALCharacterizationEx. The default value is 0.

VB Syntax

cal.DoECAL1PortEx [port][,module]

Variable

(Type) - Description

cal

A Calibrator (object)

port

(long integer) Optional argument - Port number to calibrate. Choose from:
1 - Calibrate port 1 (default if unspecified)
2 - Calibrate port 2

module

(long integer) Optional argument. ECal module.

Choose from modules 1 through 8

Use IsECALModuleFoundEx to determine the number of modules connected to the PNA

Use GetECALModuleInfoEx to returns the model and serial number of each module.

Return Type

None

Default

Not Applicable

Examples

cal.DoECAL1PortEx,2,2

C++ Syntax

HRESULT DoECAL1PortEx(long port, long moduleNumber = 1);

Interface

ICalibrator4


Write-only
About Calibration

DoECAL2PortEx Method

Description

This method replaces DoECAL2Port Method.

Does a 2-Port calibration using an ECAL module. You must first have a 2-port measurement active to perform the calibration.

The characterization within the ECal module that will be used for the calibration is specified by ECALCharacterizationEx. The default value is 0.

VB Syntax

cal.DoECAL2PortEx [portA][,portB][,module]

Variable

(Type) - Description

cal

A Calibrator (object)

portA

(long integer) Optional argument - Number of the receive port to calibrate. Choose from:
1 - Calibrate port 1 (default, if unspecified)
2 - Calibrate port 2
3 - Calibrate port 3 (if the PNA has 3 ports)

portB

(long integer) Optional argument - Number of the source port to calibrate. Choose from:
1 - Calibrate port 1 (default, if unspecified)
2 - Calibrate port 2
3 - Calibrate port 3 (if the PNA has 3 ports)

module

(long integer) Optional argument. ECal module.

Choose from modules 1 through 8

Use IsECALModuleFoundEx to determine the number of modules connected to the PNA

Use GetECALModuleInfoEx to returns the model and serial number of each module.

Return Type

None

Default

Not Applicable

Examples

cal.DoECAL2PortEx,1,2,3

C++ Syntax

HRESULT DoECAL2PortEx( long portA = 1, long portB =2, long moduleNumber = 1);

Interface

ICalibrator4


DoneCalConfidenceCheckECAL

Write-only
About ECAL Confidence Check

DoneCalConfidenceCheckECAL Method

Description

Concludes the Confidence Check and sets the ECal module back into the idle state.

VB Syntax

cal.DoneCalConfidenceCheckECAL

Variable

(Type) - Description

cal

A Calibrator (object)

Return Type

None

Default

None

Examples

cal.DoneCalConfidenceCheckECAL

C++ Syntax

HRESULT DoneCalConfidenceCheckECAL( );

Interface

ICalibrator


Read-only

Execute Method

Description

This method can be used with SCPI command :SYST:ERR? to convert scpi errors into text.

VB Syntax

Scpi.Execute(SCPI_Command As String)

Variable

(Type) - Description

scpi

A ScpiStringParser (Object)

SCPI_Command

(String) - Any valid SCPI command

Return Type

String

Default

Not Applicable

Examples

Dim scpi As ScpiStringParser

Set scpi = app.ScpiStringParser
scpi.Execute("SYST:PRES");

ErrorString = scpi.Execute("SYST:ERROr?");

C++ Syntax

Execute([in] BSTR SCPI_Command,[out,retval] BSTR * pQueryResponse);

Interface

IScpiStringParser2


Execute Shortcut Method

Write-only
About Macros

ExecuteShortcut Method

Description

Executes a Macro (shortcut) stored in the analyzer. Use app.getShortcut to list existing macros. Use app.putShortcut to associate the macro number with the file.

VB Syntax

app.ExecuteShortcut index

Variable

(Type) - Description

app

An Application (object)

index

(long integer) - Number of the macro stored in the analyzer.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ExecuteShortcut 1

C++ Syntax

HRESULT ExecuteShortcut(long index)

Interface

IApplication


Write-only

GenerateErrorTerms Method

Description

Generates the error terms for the specified calibration type, stores the error terms in a Cal Set, saves the Cal Set, and returns the Cal Set GUID.

If ALL the data for the cal type has NOT been acquired an error message is returned.

VB Syntax

value = obj.GenerateErrorTerms

Variable

(Type) - Description

value

(String) - Variable to store the returned GUID or error message.

obj

Any of the following:

GuidedCalibration (object)

SMCType (object)

VMCType (object)

Return Type

String

Default

Not Applicable

Examples

string = SMC.GenerateErrorTerms

C++ Syntax

HRESULT put_GenerateErrorTerms(BSTR* calsetGUID);

Interface

IGuidedCalibration

SMCType

VMCType


Write-only

About FCA Calibrations

GenerateSteps Method

Description

Returns the number of steps required to complete the calibration type.

VB Syntax

value = obj.GenerateSteps

Variable

(Type) - Description

value

(long) - Variable to store the returned number of steps

obj

Any of the following:

GuidedCalibration (object)

SMCType (object)

VMCType (object)

Return Type

Long

Default

Not Applicable

Examples

value = SMC.GenerateSteps

C++ Syntax

HRESULT put_GenerateSteps(long* steps);

Interface

IGuidedCalibration

SMCType

VMCType


Get AuxIO Method

Read-only

About the AuxIO connector

GetAuxIO Method

Description

This method returns the IAuxIO interface.

VB Syntax

app.GetAuxIO

Variable

(Type) - Description

app

An Application (object)

Return Type

IHWAuxIO

Default

Not Applicable

Example

Dim app As AgilentPNA835x.Application
Dim aux As HWAuxIO
Set aux = app.GetAuxIO

C++ Syntax

HRESULT GetAuxIO (IHWAuxIO **pAux);

Interface

IApplication


Get Cal Standard Method

Write-only

About Modifying Cal Kits

GetCalStandard Method

Description

Returns a handle to a calibration standard for modifying its definitions. To select a standard for performing a calibration (use Calibrator.AquireCalStandard).

VB Syntax

calkit.GetCalStandard(index)

Variable

(Type) - Description

calkit

A calKit (object)

index

(long) - Number of calibration standard. Choose 1 to 30; (there are 30 cal standards in every kit).

Return Type

calStandard

Default

Not Applicable

Examples

Dim short As CalStandard
Set short = calKit.getCalStandard(1)
short.label = "myShort"

C++ Syntax

HRESULT GetCalStandard(long standardNumber, ICalStandard **pCalStd)

Interface

ICalKit


Get CalManager Method

Read-only
About Cal Sets

GetCalManager Method

Description

This method returns the ICalManager interface.

VB Syntax

app.GetCalManager

Variable

(Type) - Description

app

An Application (object)

Return Type

ICalManager*

Default

Not Applicable

Example

dim app as AgilentPNA835x.Application
dim mgr as CalManager
set mgr = app.GetCalManager

C++ Syntax

HRESULT GetCalManager( ICalManager **mgr);

Interface

IApplication


Read-only
About Cal Sets

Get CalSetByGUID Method

Description

Requests a Cal Set by GUID. Returns an ICal Set interface.

VB Syntax

calMgr.GetCalSetByGUID (GUID)

Variable

(Type) - Description

calMgr

(object) - A CalManager object

GUID

(string) - GUID of the Cal Set being requested.

Return Type

Interface object

Default

Not Applicable

Example

calMgr.GetCalSetByGUID (2B893E7A-971A-11d5-8D6C-00108334AE96)

C++ Syntax

HRESULT GetCalSetByGUID( BSTR* strGUID, ICal Set* pCalSet);

Interface

ICalManager


Get CalSetCatalog Method

Read-only

About Cal Sets

GetCalSetCatalog Method

Description

Returns a string containing a list of comma-separated GUIDs in the following format:

{FD6F863E-9719-11d5-8D6C-00108334AE96},

{1B03B2CE-971A-11d5-8D6C-00108334AE96},

{2B893E7A-971A-11d5-8D6C-00108334AE96}

VB Syntax

value = calMgr.GetCalSetCatalog

Variable

(Type) - Description

value

(string) - Variable to store the returned GUID list

calMgr

(object) - A CalManager object

Return Type

String

Default

Not Applicable

Example

value = calMgr.GetCalSetCatalog

C++ Syntax

HRESULT GetCalSetCatalog( BSTR);

Interface

ICalManager


Get CalSetUsageInfo Method

Read-only
About Cal Sets

GetCalSetUsageInfo Method

Description

Returns a string identifying the Cal Set currently in use by the specified channel.

This method identifies the Cal Set being used by returning its GUID.

This method also identifies the "Error Term set" within the Cal Set.

Error term sets are identified by integers, with set 0 belonging to the original (non-interpolated) terms. As stimulus values for a channel are changed causing interpolation to be required, a new Error Term set is constructed within the Cal Set to hold the interpolated Error Terms. The sets are sequentially numbered 1, 2, 3, and so forth. These Error Term sets are destroyed when they are no longer being used.

If there is no Cal Set in use for the given channel, the <GUID> argument is set to the empty string.

VB Syntax

calMgr.GetCalSetUsageInfo (chan, GUID, EtermID)

Variable

(Type) - Description

calMgr

(object) - A CalManager object

chan

(long [in]) - channel of the Cal Set being requested

GUID

(string [out]) - variable to store the GUID of the Cal Set being requested. If there is no Cal Set in use for the given channel, the <GUID> argument is set to the empty string.

EtermID

(long [out]) - variable to store the error term ID being requested. If the returned argument is greater than 0, the set is being interpolated.

Return Type

String , Long Integer

Default

Not Applicable

Example

calMgr.GetCalSetUsageInfo (1, GUID, EtermID)

C++ Syntax

HRESULT GetCalSetUsageInfo (long lChannel, BSTR* CalSetGUID, long* etermSetID);

Interface

ICalManager


Get CalTypes_Method

Read only

GetCalTypes

Description

Returns a list of available calibration types, both Standard and Custom. The Standard CalTypes are the same on all PNA's, but the Custom CalTypes are not necessarily the same. They are dependent on the custom components that have been installed in the instrument.

VB Syntax

v = CalManager.GetCalTypes

Variable

(Type) - Description

v

NameGuidPair: contains the calibration type name and associated GUID for each cal type known to the PNA

Return Type

(variant) of type VT_ARRAY. The array is two dimensional containing elements of type variant.

Default

Not Applicable

Examples

v =CalManager.GetCalTypes

C++ Syntax

HRESULT GetCalTypes( VARIANT * NameGuidPair )

Interface

ICalManager2


Get Complex Method

Read-only

Data Access Map

GetComplex Method

Description

Retrieves complex data from the specified location.
See also getNAComplex , getData , and getPairedData Methods

VB Syntax

measData.getComplex location, numPts, real(), imag()

Variable

(Type) - Description

measData

An IArrayTransfer interface which supports the Measurement object

location

(enum NADataStore - IArrayTransfer) - Where the data you want is residing. Choose from:

0 - naRawData

1 - naCorrectedData

2 - naMeasResult

3 - naRawMemory

4 - naMemoryResult

5 - naDivisor - When reading data from, or writing data to, the normalization divisor, you must first create a divisor trace using DataToDivisor Method.

See the Data Access Map

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the arrays

real

(single) - Array to store the real values

imag

(single) - Array to store the imaginary values

Return Type

Single

Default

Not Applicable

Examples

Dim real(201) AS Single
Dim imag(201) AS Single
Dim pts as Integer
Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement
measData.getComplex naCorrectedData, pts, real(0), imag(0)

C++ Syntax

IArrayTransfer - HRESULT getComplex(tagNADataStore DataStore, long* pNumValues, float* pReal, float* pImag)

Interface

IArrayTransfer


Get DataByString Method

Read-only

About Accessing Data

getDataByString Method

Description

Retrieves variant data from the specified location in your choice of formats.

VB Syntax

data = meas.getDataByString location, format

Variable

(Type) - Description

data

(variant) - Array to store the data.

meas

(object) - A Measurement object

location

(string) – Name of the buffer to be read. Choose from:

"naRawData"

"naCorrectedData"

"naMeasResult"

"naRawMemory"

"naMemoryResult"

"naDivisor" - When reading data from, or writing data to, the normalization divisor, you must first create a divisor trace using DataToDivisor Method.

See the Data Access Map

format

(enum NADataFormat) - Format in which you would like the data. It does not have to be the displayed format. Choose from:

0 - naDataFormat_LinMag

1 - naDataFormat_LogMag

2 - naDataFormat_Phase

3 - naDataFormat_Polar *

4 - naDataFormat_Smith *

5 - naDataFormat_Delay

6 - naDataFormat_Real

7 - naDataFormat_Imaginary

8 - naDataFormat_SWR

* Specfiy Smith or Polar formats to obtain complex data pairs, which require a two-dimensional array varData (numpts, 2) to accomodate both real and imaginary data.

All scalar formats return a single dimension varData(numpts).

Return Type

Variant array

Default

Not Applicable

Examples

meas.getDataByString “VectorResult0”, naDataFormat_Phase

C++ Syntax

HRESULT getDataByString( BSTR location, tagDataFormat dataFormat, VARIANT * pData );

Interface

IMeasurement


Get Data Method

Read-only
About Accessing Data

GetData Method

Description

Retrieves variant data from the specified location in your choice of formats. To get smoothed data from any of the specified locations, the format must be the same as the displayed format.

Note: This method returns a variant which is less efficient than methods available on the IArrayTransfer interface.

Note: If you plan to Put this data back into analyzer, putDataComplex (variant data) method requires complex, two-dimensional data. Therefore, request the data in Polar format.

VB Syntax

data = meas.GetData location, format

Variable

(Type) - Description

data

Variant array to store the data.

meas

A Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData

1 - naCorrectedData

2 - naMeasResult

3 - naRawMemory

4 - naMemoryResult

5 - naDivisor When reading data from, or writing data to, the normalization divisor, you must first create a divisor trace using DataToDivisor Method.

See the Data Access Map

format

(enum NADataFormat) - Format in which you would like the data. It does not have to be the displayed format. Choose from:

0 - naDataFormat_LinMag

1 - naDataFormat_LogMag

2 - naDataFormat_Phase

3 - naDataFormat_Polar *

4 - naDataFormat_Smith *

5 - naDataFormat_Delay

6 - naDataFormat_Real

7 - naDataFormat_Imaginary

8 - naDataFormat_SWR

* Specfiy Smith or Polar formats to obtain complex data pairs, which require a two-dimensional array varData (numpts, 2) to accommodate both real and imaginary data.

All scalar formats return a single dimension varData(numpts).

naDataFormat_Phase returns degrees. However, putDataScalar method accepts data in radians (not degrees) and displays in degrees.

Return Type

Variant array - automatically dimensioned to the size of the data

Default

Not Applicable

Examples

Dim varData As Variant
varData = meas.GetData(naMeasResult,naDataFormat_Phase)
'Print Data
For i = 0 to chan.NumberOfPoints-1
Print varData(i)
Next i

C++ Syntax

HRESULT getData(tagNADataStore DataStore, tagDataFormat DataFormat, VARIANT *pData)

Interface

IMeasurement


Get ECALModuleInfoEx Method

Read-only

GetECALModuleInfoEx Method

Description

This property replaces Get ECALModuleInfo Method.

Returns the following information about the connected ECAL module: model number, serial number, connector type, calibration date, min and max frequency.

The characterization within the ECal module that this information will be read from is specified by ECALCharacterizationEx. The default value is 0.

VB Syntax

moduleInfo = cal.GetECALModuleInfoEx (module)

Variable

(Type) - Description

moduleInfo

(string) - variable to store the module information

cal

A Calibrator (object)

module

(long integer) ECal module.

Choose from modules 1 through 8

Use IsECALModuleFoundEx to determine the number of modules connected to the PNA

Return Type

String

Default

Not Applicable

Examples

info = cal.GetECALModuleInfoEx(2)

Example return string:

ModelNumber: 85092-60007, SerialNumber: 01386, ConnectorType: N5FN5F, PortAConnector: Type N (50) female, PortBConnector: Type N (50) female, MinFreq: 30000, MaxFreq: 9100000000, NumberOfPoints: 250, Calibrated: July 4 2002

C++ Syntax

HRESULT GetECALModuleInfoEx(long moduleNumber, BSTR* info);

Interface

ICalibrator4


Get Error Term Method

Read-only

About Measurement Calibration

GetErrorTerm Method - Obsolete

Description

Note: This command is replaced by CalSet.getErrorTerm.

Retrieves error term data that is used for error correction. The data is complex pairs. Memory for the returned Variant is allocated by the server. The server returns a variant containing a two-dimensional safe Array.

This method returns a variant which is less efficient than getErrorTermComplex on the ICalData interface.

Learn about reading and writing Calibration data.

VB Syntax

data = cal.getErrorTerm term, rcv. src

Variable

(Type) - Description

data

Variant array to store the data.

cal

A Calibrator (object)

term

(enum As NaErrorTerm). Choose from:

naErrorTerm_Directivity_Isolation
naErrorTerm_Match
naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

To get this | Specify these parameters:
Error Term | term | rcv | src
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 2 | 1
Rev Isolation | naET_Directivity Isolation | 1 | 2
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 2 | 1
Rev Load Match | naErrorTerm_Match | 1 | 2
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 2 | 1
Rev Trans Tracking | naErrorTerm_Tracking | 1 | 2

Return Type

Variant

Default

Not Applicable

Examples

Dim varError As Variant
varError = cal.getErrorTerm(naErrorTerm_Tracking,2,1)

C++ Syntax

HRESULT getErrorTerm(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, VARIANT* pData)

Interface

ICalibrator


Get ErrorTerm2 Method

Read-only
About Cal Sets

GetErrorTerm Method

Description

Queries data from the Cal Set that was acquired for a specific standard.

Learn more about reading and writing Cal Data using COM.

Before calling this method you must open the Cal Set with OpenCalSet.. If the Cal Set is not open, this method returns E_NA_Cal Set_ACCESS_DENIED.

The data is complex pairs. The server returns a variant containing a two-dimensional safe array. Memory for the returned Variant is allocated by the server and must be released by client.

Note: See also getErrorTermComplex on the ICalData2 interface to avoid using the variant data type.

VB Syntax

data = CalSet.getErrorTerm setID, term, rcv, src

Variable

(Type) - Description

data

Variant array to store the data.

CalSet

A Cal Set (object)

setID

(long integer) – specifies which error term set to read data from. (0 is the master set of eterms.)

To get data from interpolated error terms, you must first determine if an interpolated set exists by calling the GetCalSetUsageInfo method. If it returns a number greater than 0 for the error term set ID, then the channel is currently using interpolated arrays. In this case, you can read from either the interpolated array (setID > 0) or the master array (setID = 0).

Note::Interpolated error terms are destroyed when no longer being used.

term

(enum As NaErrorTerm2). Choose from:

0 - naET_Directivity (rcv = src)

1 - naET_SourceMatch ( rcv = src)

2 - naET_ReflectionTracking ( rcv = src )

3 - naET_TransmissionTracking (rcv != src)

4 - naET_LoadMatch ( rcv != src)

5 - naET_Isolation (rcv != src)

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

Return Type

Variant

Default

Not Applicable

Examples

Dim varError As Variant
varError = CalSet.getErrorTerm(0,naET_TransmissionTracking,2,1)

C++ Syntax

HRESULT getErrorTerm(long setID, tagNAErrorTerm2 ETerm, long ReceivePort, long SourcePort, VARIANT* pData)

Interface

ICalSet


Get ErrorTermByString_Method

Read-only

GetErrorTermByString

Description

Returns the data array for a specific error term from the calset

VB Syntax

pdata = Calset.GetErrorTermByString(SetNumber, bufferName)

Variable

(Type) - Description

calset

A Calset (object)

SetNumber

(long integer) SetNumber = 0 is the master set of error terms for this calset. Interpolated error terms reside in sets > 0. To determine what set number is being used by a channel, see ICalManager::GetCalSetUsage .

bufferName

(String) The string used to identify a particular buffer in the calset. An example string for port 3 directivity in a full 2 port cal might be "Full 2 Port Cal (2,3)::Directivity(3,3)".

pdata

(Variant) The pdata array is a variant. This data is usually two dimensional. Each element of the variant array is a 2 array of type single. The two elements represent the real and imaginary parts of a complex datum.

Note: This structure is compatible with scripting clients who can only use variants. For alternative methods that use typed arrays, see ICalData3.

Return Type

Variant

Default

Not Applicable

Examples

See an example

C++ Syntax

HRESULT GetErrorTermByString (long SetNumber, BSTR bufferName, VARIANT* pdata);

Interface

ICalSet2


Get Error Term Complex Method

Read-only

About Accessing Data

GetErrorTermComplex Method

Description

Retrieves error term data from the error correction buffer. The data is in complex pairs. Learn more about reading and writing Cal Data using COM.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetErrorTerm Method on ICalibrator.

VB Syntax

eData.GetErrorTermComplex term, rcv, src, numPts, real(), imag()

Variable

(Type) - Description

eData

An ICalData pointer to the Calibrator object

term

(enum NAErrorTerm) - The error term to be retrieved. Choose from:

  • naErrorTerm_Directivity_Isolation

  • naErrorTerm_Match

  • naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - on input, max number of data points to return;
on output: indicates the actual number of data points returned.

real()

(single) - array to accept the real part of the error-term. One-dimensional for the number of data points.

imag()

(single) - array to accept the imaginary part of the error-term. One-dimensional for the number of data points.

To get this | Specify these parameters:
Error Term | term | rcv | src
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 2 | 1
Rev Isolation | naET_Directivity Isolation | 1 | 2
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 2 | 1
Rev Load Match | naErrorTerm_Match | 1 | 2
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 2 | 1
Rev Trans Tracking | naErrorTerm_Tracking | 1 | 2

Return Type

Single

Default

Not Applicable

Examples

ReDim rel(numpts)
ReDim img(numpts)
Dim eData As ICalData
Set eData = chan.Calibrator
eData.getErrorTermComplex naErrorTerm_Directivity_Isolation, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT raw_getErrorTermComplex(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Get ErrorTermComplex2 Method

Read-only
About Cal Sets

GetErrorTermComplex Method

Description

Queries error term data from the Cal Set. The data is in complex pairs. Learn more about reading and writing Cal Data using COM.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetErrorTerm Method on ICal Set.

VB Syntax

eData.GetErrorTermComplex setID, term, rcv, src, numPts, real(), imag()

Variable

(Type) - Description

eData

An ICalData2 pointer to the Cal Set object

setID

(long integer) – specifies which error term set to read data from. (0 is the master set of eterms.)

To get data from interpolated error terms, you must first determine if an interpolated set exists by calling the GetCalSetUsageInfo method. If it returns a number greater than 0 for the error term set ID, then the channel is currently using interpolated arrays. In this case, you can read from either the interpolated array (setID > 0) or the master array (setID = 0).

Note::Interpolated error terms are destroyed when no longer being used.

term

(enum NAErrorTerm2) - The error term to be retrieved. Choose from:

0 - naET_Directivity

1 - naET_SourceMatch

2 - naET_ReflectionTracking

3 - naET_TransmissionTracking

4 - naET_LoadMatch

5 - naET_Isolation

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - on input, max number of data points to return;
on output: indicates the actual number of data points returned.

real()

(single) - array to accept the real part of the error-term. One-dimensional for the number of data points.

imag()

(single) - array to accept the imaginary part of the error-term. One-dimensional for the number of data points.

Return Type

Single

Default

Not Applicable

Examples

dim numpts as long
numpts = ActiveChannel.NumberOfPoints
ReDim r(numpts) ' real part
ReDim i(numpts) ' imaginary part
Dim CalSet as CalSet
set CalSet = pna.GetCalManager.GetCal SetByGUID( txtGUID )
Dim eData As ICalData2
Set eData = CalSet
eData.getErrorTermComplex 0, naET_LoadMatch, 1, 2, numpts, r(0),i (0)

C++ Syntax

HRESULT getErrorTermComplex(long setID, tagNAErrorTerm2 ETerm, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData2


Get ErrorTermComplexByString_Method

Read-only

GetErrorTermComplexByString

Description

Returns data for a specific error term.

VB Syntax

ICalData3.GetErrorTermComplexByString(etermSetID, bufferName, lnumPoints, rea(0)l, imag(0) )

Variable

(Type) - Description

ICalData3

An ICalData3 pointer to a CalSet (Object)

etermSetID

(Long) SetNumber = 0 is the master set of error terms for this Cal Set. Interpolated error terms reside in sets > 0. To determine what set number is being used by a channel, see ICalManager.GetCalSetUsage.

bufferName

(String) The string used to identify a particular buffer in the Cal Set. An example string for port 3 directivity in a full 2 port cal might be "Full 2 Port Cal (2,3)::Directivity(3,3)".

lnumpoints

[In] (long) The size of the float arrays in arguments"real" & "imag".

[Out] (long) The number of actual data buckets returned in the real and imag arrays.

see note

real

(Single) The real component of the complex data.

imag

(Single) The imaginary component of the complex data.

Return Type

Single

Default

Not Applicable

Examples

See example

C++ Syntax

HRESULT PutErrorTermComplexByString( BSTR bufferName, long lnumPoints, float* real, float* imag);

Interface

ICalData3

Note: lnumpoints is an In/Out parameter.

On the way in, it indicates the max number of values the user is requesting. This is critical because the capacity of the "read" & "imag" arrays must be allocated by the user to hold at least this number of elements. On the way out, it indicates the values actually returned.


Get ErrorTermList Method

Write-only
About Cal Sets

GetErrorTermList Method

Description

Returns the list of Error Terms contained in this Cal Set for the CalType specified in the OpenCal Set method. Learn more about reading and writing Cal Data using COM.

The list is a comma separated, textual representation of the error terms with the term name followed by the port path in parentheses:

Term (n, n),

Term (m,n)

Before calling this method you must open the Cal Set with OpenCal Set.. If the Cal set is not open, this method returns E_NA_Cal Set_ACCESS_DENIED.

Use StringToNAErrorTerm2 to convert the list entrees to values that can be used with GetErrorTerm and PutErrorTerm.

Note: The port path designation (m n) indicates the ports that contribute to the error being compensated. Directivity, source match and reflection tracking are single port characteristics, designated in this list by (n n) where n equals the port being characterized.
Other terms characterize the interaction between ports. For example, the load match term is describing the match at port (m) while looking into port (n). Thus the notation (m n) indicates the two ports that contribute to the loadmatch error.

VB Syntax

CalSet.GetErrorTermList (SetID, count, strList)

Variable

(Type) - Description

CalSet

(object) - A Cal Set object

SetID

(long) - specifies the error term set to query. Use 0 for the master set.

count

(long) - the number of error terms in the returned list

strList

(string) - comma separated list of error terms found in Cal Set

Return Type

Not Applicable

Default

Not Applicable

Examples

dim count as Integer
dim list as string
OpenCalSet (naCalType_TwoPortSOLT 1, 2)
GetErrorTermList( 0, count, list)
CloseCalSet( )

Assuming the cal set contained the full set of error terms for this two-port Cal, the returned list would be:

"Directivity(1 1),SourceMatch(1 1),ReflectionTracking(1 1),TransmissionTracking(2 1),LoadMatch(2 1),Isolation(2 1),Directivity(2 2),SourceMatch(2 2),ReflectionTracking(2 2),TransmissionTracking(1 2),LoadMatch(1 2),Isolation(1 2)"

C++ Syntax

HRESULT GetErrorTermList (long etermSetID, long* count, BSTR* strList);

Interface

ICalSet


Get ErrorTermList2_Method

Read-only

GetErrorTermList2

Description

Returns a list of error terms names found in the calset, containing the specified prefix.

VB Syntax

GetErrorTermList2(SetNumber, calTypePrefix )

Variable

(Type) - Description

SetNumber

(Long) SetNumber = 0 is the master set of error terms for this caltype, in this calset. Interpolated error terms reside in sets > 0. To determine what set number is being used, see ICalManager::GetCalSetUsage.

caltypePrefix

(String) The string used to identify calset data as belonging to a specific caltype. (By convention, calset buffers are named "CalType:Item".) An example prefix for a two port cal on ports 2 and 3 might be: "Full 2 Port Cal (2,3)". If the prefix is empty, all terms are returned. This string is used as a filter so that only the buffer names of interest are returned.

list

(Variant) Variant containing a string array of error term names

Return Type

Variant

Default

Not Applicable

Examples

See example

C++ Syntax

HRESULT GetErrorTermList2 (long SetNumber, BSTR caltypePrefix, VARIANT* list)

Interface

ICalSet2


Read-only
About the External TestSet connector

Get ExternalTestSetIO Method

Description

This method returns the IExternalTestSetIO interface.

VB Syntax

app.GetExternalTestSetIO

Variable

(Type) - Description

app

An Application (object)

Return Type

IHWExternalTestSetIO

Default

Not Applicable

Example

Dim app As AgilentPNA835x.Application
Dim ets As HWExternalTestSetIO
Set ets = app.GetExternalTestSetIO

C++ Syntax

HRESULT GetExternalTestSetIO (IHWExternalTestSetIO **ptestset);

Interface

IApplication


Get Filter Statistics Method

Read-only

About Marker Search

GetFilterStatistics Method

Description

Returns all four Filter Statistics resulting from a SearchFilterBandwidth.
To retrieve individual filter statistics, use meas.FilterCF, meas.FilterBW, meas.FilterLoss, meas.FilterQ properties.

VB Syntax

meas.GetFilterStatistics cf,bw,loss,q

Variable

(Type) - Description

meas

A Measurement (object)

cf,bw,loss,q

Dimensioned variables to store the returned values

Return Type

(double) cf
(single) bw,loss,q

Default

Not Applicable

Examples

'Dimension variables
Dim cf as Double
Dim bw as Single
Dim loss as Single
Dim q as Single

meas.GetFilterStatistics cf,bw,loss,q

C++ Syntax

HRESULT GetFilterStatistics(double* centerFreq, float* bw, float* loss, float* quality)

Interface

IMeasurement


Get Guid Method

Read-only

About Cal Sets

GetGuid Method

Description

Returns a string containing the GUID identifying this Cal Set. Each Cal Set is assigned a GUID (global unique ID). GUIDs are used to retrieve and select Cal Sets on the PNA. Learn more about reading and writing Cal Data using COM.

VB Syntax

value = CalSet.GetGuid

Variable

(Type) - Description

value

(string) - Variable to store the returned GUID

CalSet

(object) - A Cal Set object

Return Type

String

Default

Not Applicable

Examples

guid = CalSet.GetGuid 'Read

C++ Syntax

HRESULT GetGUID( BSTR* pGUIDString);

Interface

ICalSet


get InputVoltage Method

Read-only
About the Aux I/O Connector

get_InputVoltage Method

Description

Reads the ADC input voltage from Analog IN (pin 14) of the AUX IO connector

VB Syntax

volts = AuxIO.get_InputVoltage

Variable

(Type) - Description

volts

(double) - variable to store the return value

AuxIO

(object) - A Hardware Auxiliary Input / Output object

Return Type

Double

Default

0

Examples

Dim aux as HWAuxIO

Set aux = PNA.getAuxIO
volts = aux.get_InputVoltage 'read voltage on Analog In (pin 14)

C++ Syntax

HRESULT get_InputVoltage ( double* Voltage );

Interface

HWAuxIO


get Input1 Method

Read-only
About the Handler IO Connector

get_Input1 Method

Description

Reads a hardware latch that captures high to low transitions on Input1 of the Material Handler IO. Reading the latch causes it to reset and is ready for the next transition. The hardware latch is only capable of capturing one transition per query. Additional transitions are ignored until after the next query.

Momentarily driving Input1 high, then low, causes a transition to be detected and latched.

VB Syntax

inp1 = handlerIo.get_Input1

Variable

(Type) - Description

inp1

(variant) - A variable to store the return value

handlerIo

(object) - A HandlerIO object

Return Type

Variant -

0 - a high to low transition occurred at Input1 since the last time it was queried.

1 - no high to low transition occurred.

Default

Not Applicable

Examples

input1 = handlerIo.get_Input1 'Read

C++ Syntax

HRESULT get_Input1 (VARIANT* Data );

Interface

IHWMaterialHandlerIO


Read-only

About the MaterialHandler connector

Get MaterialHandlerIO Method

Description

This method returns the MaterialHandlerIO interface.

VB Syntax

app.GetMaterialHandlerIO

Variable

(Type) - Description

app

An Application (object)

Return Type

IHWMaterialHandlerIO

Default

Not Applicable

Example

Dim app As AgilentPNA835x.Application
Dim hand As HWMaterialHandlerIO
Set hand = app.GetMaterialHandlerIO

C++ Syntax

HRESULT GetMaterialHandlerIO (IHWMaterialHandlerIO **phand);

Interface

IApplication


Get NAComplex Method

Read-only
Data Access Map

GetNAComplex Method

Description

Retrieves complex data from the specified location.
See also getComplex and getData Method.

VB Syntax

measData.getNAComplex location, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer interface which supports the Measurement object

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData

1 - naCorrectedData

2 - naMeasResult

3 - naRawMemory

4 - naMemoryResult

5 - naDivisor - When reading data from, or writing data to, the normalization divisor, you must first create a divisor trace using DataToDivisor Method.

See the Data Access Map

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dComplex array

data

(NAComplex) - A one-dimensional array of NaComplex to store the data.

Return Type

NAComplex

Default

Not Applicable

Examples

Dim dComplex(201) AS NaComplex
Dim measData As IArrayTransfer
Dim pts as Long
Set measData = app.ActiveMeasurement
measData.getNAComplex naCorrectedData, pts, dComplex(0)

Notes

The data is stored as Real and Imaginary (Re and Im) members of the NaComplex user defined type. You can access each number individually by iterating through the array.

For i = 0 to NumPts-1
dReal (i) = dcomplex (i).Re
dImag (i) = dcomplex (i).Im
Next i

C++ Syntax

HRESULT getNAComplex(tagNADataStore DataStore, long* pNumValues, TsComplex* pComplex)

Interface

IArrayTransfer


Read-only
About Trigger

GetNumberOfGroups Method

Description

Returns the number of groups a channel has yet to acquire. To set the number of groups for a channel, use Number Of Groups Method

VB Syntax

value = chan.GetNumberOfGroups

Variable

(Type) - Description

value

(Long Integer) - Number of groups

chan

Channel (object)

Return Type

(Long Integer)

Default

Not Applicable

Examples

groups = chan.GetNumberOfGroups 'Read

C++ Syntax

HRESULT GetNumberOfGroups(long* numberOfGroups);

Interface

IChannel3


get Output Method

Read-only
About the Handler IO Connector

get_Output Method

Description

Type 1 and Type2 configurations: Returns the last value written to the selected output pin.

Type3 configuration: Returns the current state of the selected output pin. If an Input1 trigger occurs, the state may not be the same value as was written.

All configurations: Data is written using put_Output Method.

VB Syntax

data = handlerIo.get_Output (pin)

Variable

(Type) - Description

data

(variant) - A variable to store the return value. The returned value will be one of the following:

0 - TTL Low

1 - TTL High

handlerIo

(object) - A HandlerIO object

pin

(enum as NAMatHandlerOutput) - output to read. Choose from:

naOutput1 (0)
naOutput1User (1)
naOutput2 (2)
naOutput2User (3)

Learn about User Output

Return Type

Variant

Default

Not Applicable

Examples

data = handlerIo.get_Output(naOutput1)

C++ Syntax

HRESULT get_Output ( tagNAMatHandlerOutput Output, VARIANT* Data );

Interface

IHWMaterialHandlerIO


get OutputVoltage Method

Read-only

About the Aux I/O Connector

get_OutputVoltage Method

Description

Reads voltages on the DAC/Analog Output 1 and Output 2 (pins 2 and 3 of the Aux I/O connector)

VB Syntax

volts = AuxIO.get_OutputVoltage (output)

Variable

(Type) - Description

volts

(double) - variable to store the return value

AuxIO

(object) - A Hardware Auxiliary Input / Output object

output

(variant) Number of the output DAC to read voltage from. Choose from:

1 - Output DAC 1 -(pin 3)

2 - Output DAC 2 -(pin 2)

Return Type

Double

Default

Not Applicable

Examples

Dim aux as HWAuxIO

Set aux = PNA.getAuxIO

volts = aux.get_OutputVoltage(1) 'read voltage from Analog Out 1 (pin3)

C++ Syntax

HRESULT get_OutputVoltage( VARIANT Output, double* Voltage );

Interface

IHWAuxIO


get_OutputVoltageMode Method

Read-only

get OutputVoltageMode Method

Description

This command returns the mode of the selected "Analog Out" line on the Auxiliary IO connector. The modes give the user the option to have the requested voltage applied immediately or not until the sweep is done. To set the mode, use put_OutputVoltageMode Method.

VB Syntax

mode = auxIo.get_OutputVoltageMode (output)

Variable

(Type) - Description

mode

(enum NAOutputVoltageMode ) - variable to store the returned mode.

naWaitEOS - While in this mode any voltage changes sent to the selected analog out will only get applied to the output between sweeps.

naNoWait - While in this mode any voltage changes sent to the selected analog out will occur right away without waiting until the end of a sweep, the voltage gets applied immediately.

auxIo

(object) - A Hardware Auxiliary Input / Output object

output

(double) Analog Output. Choose from 1 or 2

Return Type

enum as NAOutputVoltageMode

Default

naWaitEOS

Examples

vOutMode = auxIo.get_OutputVoltageMode (1)

C++ Syntax

HRESULT get_OutputVoltageMode(VARIANT Output, tagNAOutputVoltageMode* pMode);

Interface

IHWAuxIO


Get Paired Data Method

Read-only
Data Access Map

GetPairedData Method

Description

Retrieves pairs of data from the specified location.

Note: This method exists on a non-default interface. If you cannot access this method, use the Get Data Method on IMeasurement.

VB Syntax

measData.getPairedData location, format, numPts, d1, d2

Variable

(Type) - Description

measData

An IArrayTransfer interface which supports the Measurement object

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData

1 - naCorrectedData

2 - naMeasResult

3 - naRawMemory

4 - naMemoryResult

5 - naDivisor - When reading data from, or writing data to, the normalization divisor, you must first create a divisor trace using DataToDivisor Method.

See the Data Access Map

format

(enum NAPairedDataFormat) - Format in which you would like the Paired data. Choose from:

  • naLinMagPhase - Linear magnitude and phase

  • naLogMagPhase - Log magnitude and phase

  • naRealImaginary - Real and Imaginary

Note: Selecting naRealImaginary format is the same as using the getComplex method

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dPaired array

d1

(single) - Array to store the magnitude / real values

d2

(single) - Array to store the phase / imaginary values

Return Type

Two Single arrays

Default

Not Applicable

Examples

Dim logm() As Single
Dim phase() As Single
Public measData As IArrayTransfer
Set measData = app.ActiveMeasurement
Dim numpts As Long
numPoints = app.ActiveChannel.NumberOfPoints
ReDim logm(numPoints)
ReDim phase(numPoints)

measData.getPairedData naCorrectedData, naLogMagPhase, numPoints, logm(0), phase(0)

Print values(0), values(1)

C++ Syntax

HRESULT getPairedData(tagNADataStore DataStore, tagNAPairedDataFormat PairFormat, long* pNumValues, float* pReal, float* pImag)

Interface

IArrayTransfer


get Port Method

Read-only

About the Handler IO Connector

get_Port Method

Description

Returns the value from the specified "readable" port.

VB Syntax

data = handlerIo.get_Port (port)

Variable

(Type) - Description

data

(variant) - A variable to store the return value. The following table shows what the returned data represents:

Port | MSB...........................................LSB 8...................................................0
C | C3...C0
D | D3...D0
E | D3...D0 + C3...C0

handlerIo

(object) - A HandlerIO object

port

(enum as NAMatHandlerPort) - port to get data from. Choose from:

naPortC - (2)

naPortD - (3)

naPortE - (4)

Note: Reading data from the Write-only ports (A,B,F,G,H) will return an error.
Ports C and D must be put in Read mode before reading from C, D, or E using PortMode Property.

Return Type

Variant

Default

0

Examples

data = handlerIo.get_Port(naPortC)

C++ Syntax

HRESULT get_Port ( tagNAMatHandlerPort Port, VARIANT* Data );

Interface

IHWMaterialHandlerIO


Get PortCData Method

Read-only
About the Aux I/O Connector

get_PortCData Method

Description

Reads a 4-bit value from Port C of the Aux I/O connector (pins 22-25) and the Material Handler IO (pins 21-24 Anritsu) - (pins 22-25 Avantest).

Note: These lines are connected to both the Handler IO and Aux IO in the PNA.

VB Syntax

value = AuxIO.get_PortCData

Variable

(Type) - Description

value

(variant) - Variable to store the returned data

AuxIO

(object) - A Hardware Auxiliary Input / Output object

Return Type

Integer

Default

None

Examples

value = auxIo.get_PortCData 'Reading a value of 15 when in Positive Logic indicates Port C lines C0, C1, C2, C3 are High. If in Negative Logic they are Low.

C++ Syntax

HRESULT get_PortCData( VARIANT* Data );

Interface

IHWAuxIO


Get Reference Marker Method

Write/Read
About Reference Markers

GetReferenceMarker Method

Description

Returns a handle to the reference marker.

VB Syntax

meas.GetReferenceMarker

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Object

Default

Not Applicable

Examples

meas.GetReferenceMarker

C++ Syntax

HRESULT GetReferenceMarker(IMarker** refMarker)

Interface

IMeasurement


Get RequiredEtermNames_Method

Write-only

GetRequiredEtermNames

Description

Returns an array of strings specifying the error terms required by the caltype's correction algorithm in order to correct the specified parameter.

This function interrogates a specific caltype ( caltypeGUID) for the list of error terms it would need in order to correct the specified parameter. All the standard S Parameter calibration types embed port specifiers in the error term name. The specific port information is gleaned from the passed parameter. For example, to query the error term requirements specific to a two port cal on ports 1 and 3, issue this with a parameter of S13 or S31. The buffer names returned will be formatted in this way:

Full 1 Port SOLT(1,3):TransmissionTracking(3,1)

VB Syntax

EtermNames = GetRequiredEtermNames(CalTypeGUID As String, Parameter As String)

Variable

(Type) - Description

caltypeGUID:

[in] the GUID of the desired calibration type

parameter

[in] string specifying the parameter to be corrected

EtermNames

[out] array of strings containing the error term names.

Note: In C++ Allocated by server. Must be freed by caller using SysFreeString.

Return Type

Not Applicable

Default

Not Applicable

Examples

enames = GetRequiredEtermNames(ctGUID, Parm)

C++ Syntax

HRESULT GetRequiredEtermNames( BSTR caltypeGUID, BSTR parameter, VARIANT* EtermNames )

Interface

ICalManager2


Get Scalar Method

Read-only
Data Access Map

GetScalar Method

Description

Retrieves scalar data from the specified locations.

Note: This method exists on a non-default interface. If you cannot access this method, use the Get Data Method on IMeasurement.

Note: You can NOT use this command to get complex data.

VB Syntax

measData.getScalar location, format, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer interface which supports the Measurement object

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData

1 - naCorrectedData

2 - naMeasResult

3 - naRawMemory

4 - naMemoryResult

5 - naDivisor - When reading data from, or writing data to, the normalization divisor, you must first create a divisor trace using DataToDivisor Method.

See the Data Access Map

format

(enum DataFormat) - Scalar format in which you would like the data. Choose from:

  • naDataFormat_Delay

  • naDataFormat_Imaginary

  • naDataFormat_LinMag

  • naDataFormat_LogMag

  • naDataFormat_Phase

  • naDataFormat_Real

  • naDataFormat_SWR

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dScalar array

data

(single) - Array to store the scalar data.

Return Type

Single

Default

Not Applicable

Examples

Dim dScalar() As Single
Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement
Dim numpts as Long
numpts = app.ActiveChannel.NumberOfPoints
ReDim dScalar(numPoints)

measData.getScalar naCorrectedData, naDataFormat_LogMag, numpts, dScalar(0)
Print dScalar(0), dScalar(1)

C++ Syntax

HRESULT getScalar(tagNADataStore DataStore, tagDataFormat DataFormat, long* pNumValues, float* pVals)

Interface

IArrayTransfer


Get Shortcut Method

Read-only

GetShortcut Method

Description

Returns the Title, Path, and optional argument strings, of the specified Macro (shortcut). Use this method to list the titles and paths of macros in the analyzer.

VB Syntax

app.GetShortcut index, title, path, arguments

Variable

(Type) - Description

app

An Application (object)

index

(long) - Number of the macro. Use a number between 1 and 12.

title

(string) - Title of the specified macro. (Appears in the softkey label)

path

(string) - Pathname of the specified macro.

arguments

(string) - Arguments for the specified macro

Return Type

String

Default

Not Applicable

Example

Dim t As String
Dim p As String
Dim arg As String
Dim i As Integer
For i = 1 to 12
app.GetShortcut i,t,p,arg
Print t,p
Next

C++ Syntax

HRESULT GetShortcut(long Number, BSTR* title, BSTR* pathname, BSTR* arguments)

Interface

IApplication

Remarks

Shortcuts can also be defined and accessed using the macro key on the front panel. However, the benefit of this feature is primarily for the interactive user


Get SnPData Method

Read-only
About SnP Data

GetSnPData Method

Description

Reads SnP data from the selected measurement. Learn more about SnP that is returned from the PNA.

VB Syntax

data = meas.GetSnPData type

Variable

(Type) - Description

data

Variant array to store the data.

meas

A Measurement (object)

type

(string) - Type of SnP data to return. If unspecified, <n> is set to 2. Choose from:

"S1P" returns data for the active measurement.

"S2P" returns data for the current 2-port measurement (4 S-parameters).

"S3P" returns data for the current 3 port measurement (9 S-parameters). Valid only on instruments with more than 2 ports.

SnP data can be output using several data formatting options. See SnPFormat Property

Return Type

Variant array - automatically dimensioned to the size of the data

Default

Not Applicable

Examples

Dim pna As AgilentPNA835x.Application
Dim meas As AgilentPNA835x.IMeasurement3
Dim snp
Set pna = CreateObject("AgilentPnA835x.application")
Set meas = pna.ActiveMeasurement
snp = meas.GetSnPData("s2p")

Dim param
Dim point

' snp returns a 3 dimensional array
' dimension 1 is the parameter, s11, s21, s12, s22
' snp(param,point,pair)
'-------------------------------------
For param = LBound(snp, 1) To UBound(snp, 1)
Debug.Print "Parameter: " & (param + 1)
For point = LBound(snp, 2) To UBound(snp, 2)
Debug.Print " Point: " & (point + 1)
Debug.Print " Real", snp(param, point, 0) ' real element
Debug.Print " Imag", snp(param, point, 1) 'imaginary element
Next
Next

C++ Syntax

HRESULT GetSnPData( BSTR snptype, VARIANT * response)

Interface

IMeasurement3


Get SourcePowerCalDataEx Method

Read-only

About Source Power Cal

getSourcePowerCalDataEx Method

Description

Note: This method replaces getSourcePowerCalData Method

Retrieves (as variant data type) source power calibration data, if it exists, from the channel.

If the channel is sweeping the source backwards, then the first data point is the highest frequency value; the last data point is the lowest. Use the Get X-Axis Values command to return the X-axis values in the displayed order.

Note: This method returns a variant which is less efficient than methods available on the ISourcePowerCalData interface

VB Syntax

data = chan.getSourcePowerCalData (buffer, sourcePort)

Variable

(Type) - Description

data

(variant) – Array to store the data.

chan

(object) – A Channel object

buffer

(enum NASourcePowerCalBuffer) - The requested source power cal data buffer.

0 - naCorrectionValues This is the only buffer currently available

sourcePort

(long integer) – The source port for which calibration data is being requested.

Return Type

Variant array – automatically dimensioned to the size of the data.

Default

Not Applicable

Examples

Dim varData As Variant
Const port1 As Long = 1
varData = chan.getSourcePowerCalDataEx (naCorrectionValues, port1)
'Print the data
For i = 0 to chan.NumberOfPoints - 1
Print varData(i)
Next i

C++ Syntax

HRESULT getSourcePowerCalDataEx(tagNASourcePowerCalBuffer bufSelect, long sourcePort, VARIANT *pData);

Interface

IChannel4


Get SourcePowerCalDataScalarEx Method

Read-only

About Source Power Cal

getSourcePowerCalDataScalarEx Method

Description

Note: This method replaces getSourcePowerCalDataScalar Method

Retrieves (as scalar values) source power calibration data, if it exists, from this channel.

If the channel is sweeping the source backwards, then the first data point is the highest frequency value; the last data point is the lowest. Use the Get X-Axis Values2 command to return the X-axis values in the displayed order.

Note: This method exists on a non-default interface. If you cannot access this method, use the getSourcePowerCalDataEx Method on IChannel4.

VB Syntax

chanData.getSourcePowerCalDataScalar buffer, sourcePort, numValues, data

Variable

(Type) - Description

chanData

(interface) – An ISourcePowerCalData2 interface on the Channel object.

buffer

(enum NASourcePowerCalBuffer) - The requested source power cal data buffer.

0 - naCorrectionValues Currently this is the only buffer available.

sourcePort

(long integer) – The source port for which calibration data is being requested.

numValues

(long integer) – Number of data values.

[out] – specifies number of data values returned.

[in] – specifies number of values being requested (this must not be larger than the capacity of the data array).

data

(single) – Array to store the data.

Return Type

Single

Default

Not Applicable

Examples

Dim numValues As Long
Dim scalarCalValues() As Single
Dim chanData As ISourcePowerCalData2
Const port1 As Long = 1
numValues = app.ActiveChannel.NumberOfPoints
ReDim scalarCalValues(numValues)
Set chanData = app.ActiveChannel

chanData.getSourcePowerCalDataScalarEx naCorrectionValues, port1, numValues, scalarCalValues(0)

'Print the data
For i = 0 to numValues - 1
Print scalarCalValues(i)
Next I

C++ Syntax

HRESULT getSourcePowerCalDataScalarEx(tagNASourcePowerCalBuffer bufSelect, long sourcePort, long *pNumValues, float *pData);

Interface

ISourcePowerCalData2


Get Standard2 Method

Read-only

About Cal Sets

GetStandard Method

Description

Queries data from the Cal Set that was acquired for a specific standard. Learn more about reading and writing Cal Data using COM.

Before calling this method you must open the Cal Set with OpenCal Set.. If the Cal Set is not open, this method returns E_NA_Cal Set_ACCESS_DENIED.

The data is complex pairs. The server returns a variant containing a two-dimensional safe array. Memory for the returned Variant is allocated by the server and must be released by client.

Note: See also getStandardComplex on the ICalData2 interface to avoid using the variant data type.

VB Syntax

data = CalSet.getStandard standard, rcv , src

Variable

(Type) - Description

data

Variant array to store the data.

CalSet

A Cal Set (object)

standard

(enum NACalClass) Standard to be measured. Choose from:

1 - naClassA

2 - naClassB

3 - naClassC

4 - naClassD

5 - naClassE

6 - naReferenceRatioLine

7 - naReferenceRatioThru

SOLT Standards

1 - naSOLT_Open

2 - naSOLT_Short

3 - naSOLT_Load

4 - naSOLT_Thru

5 - naSOLT_Isolation

TRL Standards

1 - naTRL_Reflection

2 - naTRL_Line_Reflection

3 - naTRL_Line_Tracking

4 - naTRL_Thru

5 - naTRL_Isolation

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

Return Type

(variant) - two-dimensional array (0:1, 0:NumberOfPoints-1)

Default

Not Applicable

Examples

Dim varStd As Variant

Dim varStd2 As Variant

Cal Set.OpenCalSet( naCalType_TwoPortSOLT, 1, 2)
varStd = CalSet.getStandard(naSOLT_Thru,2,1)

varStd2 = Cal Set.getStandard(naSOLT_Thru,1,2)

Cal Set.CloseCalSet( )

C++ Syntax

HRESULT getStandard(tagNACalClass stdclass, long ReceivePort, long SourcePort, VARIANT* pData)

Interface

ICalSet


Get StandardByString_Method

Read-only

GetStandardByString

Description

Returns the data for a specific standard.

VB Syntax

GetStandardByString(bufferName, pdata )

Variable

(Type) - Description

bufferName

(String) The string used to identify a particular buffer in the calset. An example string requesting the data for the Load standard in a full 2 port cal might be "Full 2 Port Cal (2,3)::S11C(3,3)".

pdata

(Variant) The pdata array is a variant. This data is usually two dimensional. Each element of the variant array is a 2 array of type single. The two elements represent the real and imaginary parts of a complex datum.

Note: This structure is compatible with scripting clients who can only use variants. For alternative methods that use typed arrays, see ICalData3.

Return Type

Variant

Default

Not Applicable

Examples

See the following example

C++ Syntax

HRESULT GetStandardByString( BSTR bufferName, VARIANT* pdata)

Interface

ICalSet2


Get Standard Complex Method

Write-only

About Cal Sets

GetStandardComplex Method

Description

Queries standards acquisition data from the Cal Set. The data is in complex pairs. Learn more about reading and writing Cal Data using COM.

Before calling this method from the ICalData2 interface you must open the Cal Set with OpenCal Set. If the Cal Set is not open, this method returns E_NA_Cal Set_ACCESS_DENIED.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetStandard Method on ICal Set

VB Syntax

interface.getStandardComplex class, rcv, src, numPts, real(), imag()

Variable

(Type) - Description

interface

An ICalData pointer to the Calibrator object or
An ICalData2 pointer to the Cal Set object(preferrred)

class

(enum NACalClass) Standard to be measured. Choose from:

1 - naClassA

2 - naClassB

3 - naClassC

4 - naClassD

5 - naClassE

6 - naReferenceRatioLine

7 - naReferenceRatioThru

SOLT Standards

1 - naSOLT_Open

2 - naSOLT_Short

3 - naSOLT_Load

4 - naSOLT_Thru

5 - naSOLT_Isolation

TRL Standards

1 - naTRL_Reflection

2 - naTRL_Line_Reflection

3 - naTRL_Line_Tracking

4 - naTRL_Thru

5 - naTRL_Isolation

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - on input, max number of data points to return;
on output: indicates the actual number of data points returned.

real()

(single) - array to accept the real part of the calibration data. One-dimensional for the number of data points.

imag()

(single) - array to accept the imaginary part of the calibration data. One-dimensional for the number of data points.

Return Type

(single)

Default

Not Applicable

Examples

Dim numpts as long
numpts = ActiveChannel.NumberOfPoints
ReDim r(numpts) ' real part
ReDim i(numpts) ' imaginary part
Dim Cal Set as Cal Set
set Cal Set = pna.GetCalManager.GetCal SetByGUID( txtGUID )
Dim sData As ICalData2
Set sData = Cal Set
sdata.getStandardComplex naSOLT_Open, 1, 1, numpts, r(0), i(0)

C++ Syntax

HRESULT getStandardComplex(tagNACalClass stdclass, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData2


Get StandardComplexByString_Method

Read-only

GetStandardComplexByString

Description

Queries the Cal Set for specific standard data.

VB Syntax

ICalData3.GetStandardComplexByString(bufferName, lnumPoints, real(0), imag(0))

Variable

(Type) - Description

ICalData3

An ICalData3 pointer to a CalSet (Object)

bufferName

(String) The string used to identify a particular buffer in the Cal Set. An example string requesting the data for the Load standard in a full 2 port cal might be "Full 2 Port Cal (2,3)::S11C(3,3)".

lnumpoints

in (Long) The maximum number of values in the real and imaginary arrays being requested.

out (Long) The actual number of values returned in the real and imaginary arrays.

real

(Single) The real component of the complex data.

imag

(Single) The imaginary component of the complex data.

Return Value

Single

Default

Not Applicable

Examples

See example

C++ Syntax

HRESULT GetStandardComplexByString( BSTR bufferName, long* lnumPoints, float* real, float* imag);

Interface

ICalData3


Get StandardsList Method

Read-only

About Cal Sets

GetStandardsList Method

Description

Returns the list of Standards contained in this Cal Set for the CalType specified in the OpenCal Set method. Learn more about reading and writing Cal Data using COM.

The list is a comma separated, textual representation of the error terms with the term name followed by the port path in parentheses.

Standard (n, n),

Standard (m, n)

Before calling this method you must open the Cal Set with OpenCal Set. If the Cal Set is not open, this method returns E_NA_Cal Set_ACCESS_DENIED.

Use StringToNACalClass to convert the list entrees to values that can be used with GetStandard and PutStandard.

Note: The port path designation (m n) indicates the receive and source ports for the measurement. Shorts, opens and loads are single port devices, designated in this list by (n n) where n equals the port to which the device is connected. These devices are all characterized by reflection measurements.
The dual port thru device is characterized by both transmission and reflection measurements in order to compensate for load match and tracking terms.
The notation (n n) indicates the reflection measurement for this device.
The notation (m n) indicates the transmission measurement, where the source and receive ports are different.

VB Syntax

CalSet.GetStandardsList (count, list)

Variable

(Type) - Description

CalSet

(object) - A Cal Set object

count

(long [out]) - indicates the number of items returned in the list

list

(string) - Variable to store the returned Comma separated list of items.

Return Type

String

Default

Not Applicable

Examples

dim count as Integer
dim list as string
OpenCalSet (naCalType_TwoPortSOLT, 1, 2)
GetStandardsList( count, list)
CloseCalSet( )

Assuming the Cal Set contained the full set of standards for this two port cal, the returned list would be:

"Open(1 1),

Short(1 1),

Load(1 1),

Thru(1 1),

Isolation(2 1),

Open(2 2),

Short(2 2),

Load(2 2),

Thru(2 2),

Isolation(1 2)

Thru(2 1),

Thru(1 2)"

C++ Syntax

HRESULT GetStandardsList( long* count, BSTR* list);

Interface

ICalSet


Get StandardList2_Method

Read-only

GetStandardList2

Description

Returns a list of standards contained by this calset for the specified caltype.

VB Syntax

GetStandardList2(calType, list )

Variable

(Type) - Description

caltype

(String) The string used to identify calset data as belonging to a specific caltype. (By convention, calset buffers are named "CalType:Item"). An example string for a two port cal on ports 2 and 3 might be: "Full 2 Port Cal (2,3)". If the string is empty, all standards are returned. This string is used as a filter so that only the buffer names of interest are returned.

list

(Variant) Variant containing a string array of standards for the specified caltype.

Return Type

Variant

Default

Not Applicable

Examples

See the following example

C++ Syntax

HRESULT GetErrorTermList2( BSTR caltype, VARIANT* list)

Interface

ICalSet2


GetStandardForClass_Method

Read-only

GetStandardsForClass Method

Description

Get the calibration standard numbers for a specified calibration class. To set the calibration number use SetStandardsForClass Method

VB Syntax

calkit.GetStandardsForClass (calclassorder, std1, std2, std3, std4, std5, std6, std7)

Variable

(Type) - Description

calKit

A CalKit (object)

calclassorder

(enum NACalClassOrder) Choose from:

0 - naRefl_1_S11

1 - naRefl_2_S11

2 - naRefl_3_S11

3 - naTran_1_S21

4 - naRefl_1_S22

5 - naRefl_2_S22

6 - naRefl_3_S22

7 - naTran_1_S12

8 - naRefl_1_S33

9 - naRefl_2_S33

10 - naRefl_3_S33

11 - naTran_1_S32

12 - naTran_1_S23

13 - naTran_1_S31

14 - naTran_1_S13

15 - naTRL_T

16 - naTRL_R

17 - naTRL_L

std1…std7

(long) Calibration Standard Number. Nominal values from 1 through 30. 0 indicates that a standard number has not been selected.

Return Type

Not applicable

Default

Not applicable

Examples

calkit.GetStandardsForClass naRefl_3_S11, std1, std2, std3, std4, std5, std6, std7

C++ Syntax

HRESULT GetStandardsForClass(NACalClassOrder calclassorder, long std1, long std2, long std3, long std4, long std5, long std6, long std7)

Interface

ICalKit


Get StepDescription Method

Read-only

GetStepDescription Method

Description

Returns the description of the specified step in the calibration process.

VB Syntax

value = obj.GetStepDescription (n)

Variable

(Type) - Description

value

(string) - Variable to store the returned number of steps.

obj

Any of the following:

GuidedCalibration (object)

SMCType (object)

VMCType (object)

n

(Long) Step in the calibration process.

Use GenerateSteps to determine the total number of steps.

Return Type

String

Default

Not Applicable

Examples

value = SMC.GetStepDescription(5)

C++ Syntax

HRESULT get_GetStepDescription(long step, BSTR* str);

Interface

IGuidedCalibration

SMCType

VMCType


Get Test Result Method

Read-only

About Limit Testing

GetTestResult Method

Description

Returns the result of limit line testing. There are three ways to use this command:

  • If neither optional parameter is specified, limit results for ALL data is returned.

  • If one parameter is specified (start), the limit result for that data point is returned.

  • If both parameters are specified, limit results are returned beginning with start, and ending with (start+size)-1

VB Syntax

testRes = limts.GetTestResult [start,size]

Variable

(Type) - Description

testRes

(enum NALimitTestResult) - A dimensioned variable to store test results. If a limit line is not tested, a PASS is returned.

0 - naLimitTestResult_None
1 - naLimitTestResult_Fail
2 - naLimitTestResult_Pass

limts

A LimitTest (object)

start

(long) - Optional argument. A start data point number to return limit test results.

size

(long) - Optional argument. Number of data points from start to return limit test results.

Return Type

Long Integer

Default

Not Applicable

Examples

Dim testRes As NALimitTestResult
testRes = limts.GetTestResult
Select Case testRes

Case 1
Print "Fails"

Case 2
Print "Pass"

End Select

C++ Syntax

HRESULT GetTestResult(long lStart, long lSize, tagNALimitTestResult *pVal)

Interface

ILimitTest


Get Trace Statistics Method

Read-only

About Trace Statistics

GetTraceStatistics Method

Description

Returns all four Trace Statistics. To retreive individual Trace statistics, use Mean, PeakToPeak, StandardDeviation properties. Use ShowStatistics to display the statistics of the screen.

VB Syntax

meas.GetTraceStatistics pp,mean,stdev

Variable

(Type) - Description

meas

A Measurement (object)

pp,mean,stdev

(double) - Dimensioned variables to store the returned values

Return Type

Double

Default

Not Applicable

Examples

'Dimension variables
Dim pp As Double
Dim mean As Double
Dim stdv As Double
meas.GetTraceStatistics pp, mean, stdv

C++ Syntax

HRESULT GetTraceStatistics(double* pp, double* mean, double* stdDeviation)

Interface

IMeasurement


Get X-Axis Values 2

Read-only
About Segment Sweep

GetXAxisValues2 Method

Description

Returns the channel's X-axis values into a dimensioned Typed array. GetXAxisValues2 is a convenient method for determining the frequency of each point when the points are not linearly spaced - as in segment sweep.

Note: This method will fail if called using a scripting client such as VBScript or Agilent Vee, (see remarks)

Note: In Segment Sweep, chan.NumberofPoints will return the total number of data points for the combined segments.

VB Syntax

chan.GetXAxisValues2 numPts,data

Variable

(Type) - Description

chan

(object) - A Channel object

numPts

(long integer) - Number of data points in the channel

data

(double) Single dimensioned array of data matching the number of points in the channel.

Return Type

double

Default

Not applicable

Examples

Dim App As Application
Set App = New Application
Dim numPoints As Long
Dim values() As Double
numPoints = App.ActiveChannel.NumberOfPoints
ReDim values(numPoints)
App.ActiveChannel.GetXAxisValues2 numPoints, values(0)
Print values(0), values(1)

C++ Syntax

HRESULT GetXAxisValues2(long* pNumValues, double* stimulus)

Interface

IChannel

Remarks:

This method will fail if called using a scripting client such as VBScript or Agilent Vee. Use the GetXAxisValues method as a replacement for these COM environments.

This method also cannot be called using late-bound typing in Visual Basic. For instance, if, in the example above, the first line were replaced with "Dim App as Object", then this method would fail.


Get XAxisValues_Method

Read-only

GetXAxisValues Method

Description

Returns the stimulus values for the measurement. To understand how this property is useful, see IMeasurement2 Interface.

VB Syntax

data = meas.GetXAxisValues

Variable

(Type) - Description

data

(Variant) Array to store the data.

meas

A Measurement (object)

Return Type

Variant

Default

Not Applicable

Examples

Dim varData As Variant
Dim i As Integer
varData = meas.GetXAxisValues
'Print Data
For i = 0 To meas.NumberOfPoints - 1
Print varData(i)
Next i

C++ Syntax

HRESULT GetXAxisValues(VARIANT* xData);

Interface

IMeasurement2


Get X-axis Values Method

Read-only
About Segment Sweep

GetXAxisValues Method

Description

Returns the channel's X-axis values. GetXAxisValues is a convenient method for determining the frequency of each point when the points are not linearly spaced - as in segment sweep.

Note: This method returns a variant which is less efficient than GetXAxisValues2.

Note: In Segment Sweep, chan.NumberofPoints will return the total number of data points for the combined segments.

VB Syntax

data = chan.GetXAxisValues

Variable

(Type) - Description

data

Variant array to store the data.

chan

A Channel (object)

Return Type

Variant

Default

Not Applicable

Examples

Dim varData As Variant
Dim i As Integer
varData = chan.GetXAxisValues
'Print Data
For i = 0 To chan.NumberOfPoints - 1
Print varData(i)
Next i

C++ Syntax

HRESULT GetXAxisValues (VARIANT* xData)

Interface

IChannel


Has CalType Method

Read-only
About Cal Sets

HasCalType Method

Description

Verifies that the Cal Set object contains the error terms required to perform the specified correction (CalType) to an appropriate measurement.

The argument list includes specifiers for up to 3 ports. The number of arguments required depends on the CalType specified. The value for each port is set to 0 if not specified.

* order of port arguments is significant for these caltypes

Caltype | Port arguments required
naCalType_Response_Open | Port1
naCalType_Response_Short | Port1
*naCalType_Response_Thru | Port1 (rcv), Port2 (src)
*naCalType_Response_Thru_And_Isol | Port1 (rcv), Port2 (src)
naCalType_OnePort | Port1
naCalType_TwoPort_SOLT | Port1, Port2
naCalType_TwoPort_TRL | Port1, Port2
naCalType_ThreePort_SOLT | Port1, Port2, Port3

VB Syntax

check = CalSet.HasCalType calType, port1, port2, port3

Variable

(Type) - Description

check

(boolean) - variable to store the returned value

TRUE (nonzero) - Cal Set has all of the error terms necessary to apply the specified correction (CalType)

FALSE(0) - Cal Set DOES NOT have all of the error terms necessary to apply the specified CalType

CalSet

(object) - A Cal Set object

calType

(enum as naCalType) - type of correction to be applied. Choose from

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None
8 - naCalType_ThreePort_SOLT

port1

(long) - required. This argument must be specified.

This specifies either:

- the one significant port for an open/short response cal or a 1 port cal.

- or one of the ports involved in a 2 or 3 port cal

- or the receive port for a thru response / thru-isolation cal.

port2

(long) - required for any caltype involving more than one port

This specifies either:

- one of the ports involved in a 2 or 3 port cal (order independent)

- or the source port for a thru response / thru-isolation cal

port3

(long) - required only for 3 port cal

This specifies either:

- one of the ports involved in a 3 port cal (order independent)

Return Type

VARIANT_BOOL

Default

Not Applicable

Examples

value = CalSet.HasCalType(naCalType_TwoPort_TRL, 1, 2)

C++ Syntax

HRESULT HasCalType( tagNACalType, long port1, long port2, long port3, BOOL *pVal);

Interface

ICalSet


Write-only

About Triggering

Hold Method

Description

Puts the Channel in Hold - not sweeping.

VB Syntax

chan.Hold [sync]

Variable

(Type) - Description

chan

A Channel (object)

[sync]

(boolean) - Optional argument. A variable set to either True or False.

True - program control waits until the channel is in the Hold state.
False - program control continues immediately. You are not guaranteed the channel is in Hold yet.

Return Type

Not Applicable

Default

Not Applicable

Examples

wate = True
chan.Hold wate

C++ Syntax

HRESULT Hold(VARIANT_BOOL bWait)

Interface

IChannel


HoldChan Method

Write-only
About Triggering

Hold (channels) Method

Description

Places all channels in hold mode. To place a single channel in hold mode, use channel.Hold Method.

VB Syntax

chans.Hold

Variable

(Type) - Description

chans

A Channel collection (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

chans.Hold

C++ Syntax

HRESULT Hold();

Interface

IChannels2


Write only

Initialize Method

Description

Begins a calibration.

Note: chan must be the active channel.

VB Syntax

obj.Initialize (chan, useCalReg)

Variable

(Type) - Description

obj

Any of the following:

GuidedCalibration (object)

SMCType (object)

VMCType (object)

chan

(Long) Channel number to calibrate.

useCalReg

(boolean)

True or 1 - Cal will be stored in Cal Register ONLY

False or 0 - Cal will be stored in Cal Register AND User Cal Set. The active channel must be pointing to a User Cal Set.

Return Type

Not Applicable

Default

Not Applicable

Examples

smc.Initialize(2,1)

C++ Syntax

HRESULT put_Initialize(long channelnumber, VARIANT_BOOL bNewCalSet);

Interface

IGuidedCalibration

SMCType

VMCType


Write-only

Item Method

Description

Returns an object from the collection of objects.

Note: The order of objects within a collection cannot be assumed.

VB Syntax

Object[.Item](n)

Variable

(Type) - Description

Object

Any of the following (objects):
CalFactorSegments collection
Cal Sets collection
Channels collection
LimitTest collection
Measurements collection
NaWindows collection
PowerLossSegments collection
PowerSensors collection
Segments collection
Traces collection

.Item

Optional - Item is the default property of a collections object and therefore can be called implicitly. For example, the following two commands are equivalent:

Channels.Item(3).Averaging = 1
Channels(3).Averaging = 1

n

(variant) - number of the item in the collection.

Note: the Measurements and Traces collections allow you to specify the name of the measurement as a string. For example: measCollection("CH_S11_1").InterpolateMarkers

Return Type

(Object)

Default

Not Applicable

Examples

For i = 1 to Traces.Count -1
Traces.Item(i).YScale = .5dB
Next i

C++ Syntax

HRESULT Item(VARIANT index, <interface>** pItem)

Interfaces

ICalFactorSegments
ICal Sets
IChannels
ILimitTest
IMeasurements
INaWindows
IPowerLossSegments
IPowerSensors
ISegments
ITraces


Read-Write

About the Cal Wizard

LaunchCalWizard Method

Description

Launches the Cal Wizard on the PNA and does not return until the Cal Wizard is dismissed.

Note: The Cal Wizard operates on the active measurement. Therefore, activate the measurement to be calibrated before launching the Cal Wizard.

VB Syntax

success = app.LaunchCalWizard (newCS)

Variable

(Type) - Description

success

(boolean) - variable to store the returned value
True - The Cal was completed
False - The Cal was canceled without completing the calibration.

app

An Application (object)

newCS

(boolean)

True - Cal will be performed on a new Cal Set.
False - Cal will be performed using the existing Cal Set assigned to the channel. If no Cal Set is found, a new Cal Set will be created.

Return Type

Boolean

Default

Not Applicable

Example

dim bSuccess as boolean
dim bNewCalset as boolean
bNewCalSet = false
bSuccess = app.LaunchCalWizard( bNewCalSet)

C++ Syntax

HRESULT LaunchCalWizard(VARIANT_BOOL bCalsuccess)

Interface

IApplication


Write-only
About Source Power Cal

LaunchPowerMeterSettingsDialog Method

Description

Launches the Power Meter Settings dialog on the PNA. Changing certain values from that dialog will change values of the corresponding properties on this COM object.

VB Syntax

pwrCal.LaunchPowerMeterSettingsDialog

Variable

(Type) - Description

pwrCal

A SourcePowerCalibrator (object)

Return Type

None

Default

Not Applicable

Examples

powerCalibrator.LaunchPowerMeterSettingsDialog

C++ Syntax

HRESULT put_LaunchPowerMeterSettingsDialog();

Interface

ISourcePowerCalibrator2


LoadFile_Method

Write only

LoadFile Method

Description

Loads a previously-configured mixer attributes file (.mxr)

VB Syntax

mixer.LoadFile (filename)

Variable

(Type) - Description

mixer

A IMixer Interface pointer to the Meas (object)

filename

(String) Path and file name of the .mxr file

Return Type

String

Default

Not Applicable

Examples

mixer.LoadFile (File_Name)

C++ Syntax

HRESULT put_LoadFile(BSTR newVal)

Interface

IMixer


Manual Trigger Method

Write-only

About Triggering

ManualTrigger Method

Description

Triggers the analyzer when TriggerSignal = naTriggerManual.

Note: An SMC Fixed Output measurement cannot be triggered using this command. For more information, see the example program.

VB Syntax

app.ManualTrigger [sync],[timeout]

Variable

(Type) - Description

app

An Application (object)

sync

(boolean) - Optional argument.
A variable set to either True or False.

True - The analyzer waits until the trigger is completed to process subsequent commands.
False - Subsequent commands are processed immediately (the default setting)

timeout

(long) - Optional argument.
If sync is true, timeout sets the amount of time the PNA will wait until continuing program execution. Units are milliseconds. A value of -1 (the default setting) causes the PNA to wait indefinitely.

If sync is False, the timeout setting is ignored.

Return Type

Not Applicable

Default

Not Applicable

Examples

' After Manual trigger is executed, the PNA will wait 1 second to continue program execution
Dim wait as Boolean
wait = True
app.ManualTrigger wait, 1000

C++ Syntax

HRESULT ManualTrigger(VARIANT_BOOL bSynchronize, long timeout)

Interface

IApplication


Message Text Property

Write/Read
About Analyzer Events

MessageText Property

Description

Returns text for the specified eventID

VB Syntax

app.MessageText,eventID,message

Variable

(Type) - Description

app

An Application (object)

enentID

(enum naEventID) Choose from the list in Working with the Analyzer's Events

message

(string) - variable to store the returned message

Return Type

String

Default

Not Applicable

Examples

RFNA.MessageText naEventID_ARRANGE_WINDOW_EXCEED_CAPACITY, message

C++ Syntax

HRESULT MessageText( tagNAEventID msgID, BSTR* message)

Interface

IApplication


Next IF Bandwidth Method

Write-only

About Dynamic Range

NextIFBandwidth Method

Description

A function that returns the Next higher IF Bandwidth value. Use to retrieve the list of available IFBandwidth settings.

VB Syntax

chan.Next_IFBandwidth bw

Variable

(Type) - Description

chan

A Channel (object)

bw

(double) - The argument that you use to send an IFBandwidth. The function uses this argument to return the Next higher IFbandwidth.

Return Type

Double

Default

Not Applicable

Examples

Public pnbw As Double 'declare variable outside of procedure

pnBW = chan.IFBandwidth 'put the current IFBW in pnBW
chan.Next_IFBandwidth pnBW 'function returns the Next higher IFBandwidth.
chan.IFBandwidth = pnBW 'set IFBW to the Next value

C++ Syntax

HRESULT Next_IFBandwidth (double *pVal)

Interface

IChannel


Number Of Groups Method

Write-only

About Triggering

NumberOfGroups Method

Description

Sets the Number of trigger signals the channel will receive. After the channels has received that number of trigger signals, the channel switches to Hold mode.

To begin sweeping the number of groups, send app.Continuous

VB Syntax

chan.NumberOfGroups num, sync

Variable

(Type) - Description

chan

A Channel (object)

num

(long integer) Number of trigger signals the channel will receive. Choose any number between 1 and 2 million

sync

(boolean)
Variable set to either:
True - subsequent commands are not processed until the groups are complete. Do not use with manual trigger.
False - subsequent commands are processed immediately

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.NumberOfGroups

C++ Syntax

HRESULT NumberOfGroups(long count, VARIANT_BOOL bWait)

Interface

IChannel


Open CalSet Method

Read-only
About Cal Sets

OpenCalSet Method

Description

Open the Cal Set to read/write a particular CalType. Learn more about reading and writing Cal Data using COM.

This method is a prerequisite to several other Cal Set methods.

A Cal Set can contain more than one caltype. This method opens the Cal Set and restrict access to a particular set of terms. Subsequent commands like PutErrorTerm and GetErrorTerm use this information to access the correct error terms in the Cal Set. For example:

OpenCal Set( naCalType_TwoPortSOLT, 3, 2, 0)

PutErrorTerm( naDirectivity, 1, 1, Buffer)

The directivity error term for port 1 could belong to any number of caltypes: Full1Port (S11), Full2Port (12), Full2Port (13) or Full3Port (123). The CalType and port specifiers in the OpenCalSet call direct the uploaded directivity term to the correct set of error terms.

To close the CalType, see CloseCalSet.

The argument list includes three port specifiers. The following table shows which of these arguments are significant, given the CalType specified.

Caltype | Port arguments required
naCalType_Response_Open | Port1
naCalType_Response_Short | Port1
*naCalType_Response_Thru | Port1 (rcv), Port2(src)
*naCalType_Response_Thru_And_Isol | Port1 (rcv), Port2(src)
naCalType_OnePort | Port1
naCalType_TwoPort_SOLT | Port1, Port2
naCalType_TwoPort_TRL | Port1, Port2
naCalType_ThreePort_SOLT | Port1, Port2, Port3

* order of port arguments is significant for these caltypes

VB Syntax

CalSet.OpenCalSet (CalType, port1, port2, port3)

Variable

(Type) - Description

CalSet

(object) - A Cal Set object

CalType

(enum as naCalType) - type of correction to be applied. Choose from

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL

7 - naCalType_None
8 - naCalType_ThreePort_SOLT

port1

(long) - required. This argument must be specified.

This specifies either:

- the one significant port for an open/short response cal or a 1 port cal.

- or one of the ports involved in a 2 or 3 port cal

- or the receive port for a thru response / thru-isolation cal.

port2

(long) - required for any caltype involving more than one port

This specifies either:

- one of the ports involved in a 2 or 3 port cal (order independent)

- or the source port for a thru response / thru-isolation cal

port3

(long) - required only for 3 port cal

This specifies either:

- one of the ports involved in a 3 port cal (order independent)

Return Type

None

Default

Not Applicable

Examples

CalSet.OpenCalSet naCalType_ThreePort_SOLT, 3,2,1

C++ Syntax

HRESULT OpenCalSet ( naCalType, port1, [optional] port2, [optional] port3);

Interface

ICalSet


Write-Read

SCPI Command Tree

Parse Method

Description

Executes a SCPI command.

VB Syntax

scpi.Parse ("SCPI command")

Variable

(Type) - Description

scpi

A ScpiStringParser (object)

SCPI command

(string) - Any valid SCPI command

Return Type

String

Default

Not Applicable

Examples

Dim scpi As ScpiStringParser
Set scpi = app.ScpiStringParser
Dim startfreq As Double
startfreq = 100e6
'
scpi.Parse ("Sens:Freq:Start " & startfreq)'Write

Dim str As String
str = scpi.Parse ("Sens:Freq:Start?")'Read

C++ Syntax

HRESULT Parse(BSTR SCPI_Command, BSTR *pQueryResponse)

Interface

IScpiStringParser


Write-only
Factory Preset Settings

Preset Method

Description

Application Object: Deletes all traces and windows. In addition, resets the analyzer to factory defined default settings and creates an S11 measurement named "CH1_S11_1" in window 1.

Channel Object: Resets the channel (object) to factory defined default settings. Does NOT delete the current measurements or add a new measurement.

Regardless of the state of the User Preset Enable checkbox, the app.Preset command will always preset the PNA to the factory preset settings, and app.UserPreset will always perform a User Preset.

VB Syntax

app.Preset
chan.Preset

Variable

(Type) - Description

app

An Application (object)

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Preset

C++ Syntax

HRESULT Preset()

Interface

IApplication
IChannel


Previous IF Bandwidth Method

Write-only
About Dynamic Range

PreviousIFBandwidth Method

Description

A function that returns the previous IF Bandwidth value. Use to retrieve the list of available IFBandwidth settings.

VB Syntax

chan.Previous_IFBandwidth bw

Variable

(Type) - Description

chan

A Channel (object)

bw

(double) - The argument that you use to send an IFBandwidth. The function uses this argument to return the previous IFbandwidth.

Return Type

Double

Default

Not Applicable

Examples

Public pnbw As Double 'declare variable outside of procedure

PreBW = chan.IFBandwidth 'put the current IFBW in PreBW
chan.Previous_IFBandwidth PreBW 'function returns the Previous IFBandwidth of the current one.
chan.IFBandwidth = PreBW 'set IFBW to the previous value

C++ Syntax

HRESULT Previous_IFBandwidth (double *pVal)

Interface

IChannel


Write-only

About Saving to File

PrintToFile Method

Description

Saves the screen image to a bitmap (.bmp) file.

VB Syntax

app.PrintToFile filename

Variable

(Type) - Description

app

An Application (object)

filename

(string) Name of the file to save the screen to. The file is saved to the current working directory unless a valid full path name is specified.

Use one of the following suffixes:

  • .bmp - not recommended due to large file size

  • .jpg - not recommended due to poor quality

  • .png - recommended

Return Type

Not Applicable

Default

Not Applicable

Examples

app.PrintToFile "myfile.png"
app.PrintToFile "c:\data\myfile.png"

C++ Syntax

HRESULT PrintToFile(BSTR bstrFile)

Interface

IApplication


Put Complex Method

Write-only
Data Access Map

PutComplex Method

Description

Puts real and imaginary data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten. Learn more about reading and writing Cal Data using COM.

Data put in the raw data store will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in the measurement results store will be overwritten by any measurement attribute changes.

See also putNAComplex

VB Syntax

measData.putComplex location, numPts, real(), imag(), [format]

Variable

(Type) - Description

measData

An IArrayTransfer interface which supports the Measurement object

location

(enum NADataStore) Where the Data will be put. Choose from:

0 - naRawData

1 - naCorrectedData

2 - naMeasResult

3 - naRawMemory

4 - naMemoryResult

5 - naDivisor - When reading data from, or writing data to, the normalization divisor, you must first create a divisor trace using DataToDivisor Method.

See the Data Access Map

numPts

(long integer) - Number of data points in the channel

real()

(single) - Array containing real data values

imag()

(single) -Array containing imaginary data values

format

(enum NADataFormat) optional argument - display format of the real and imaginary data. Only used if destination is naMeasResult or naMemoryResult buffer. If unspecified, data is assumed to be in naDataFormat_Polar

0 - naDataFormat_LinMag

1 - naDataFormat_LogMag

2 - naDataFormat_Phase

3 - naDataFormat_Polar

4 - naDataFormat_Smith

5 - naDataFormat_Delay

6 - naDataFormat_Real

7 - naDataFormat_Imaginary

8 - naDataFormat_SWR

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putComplex naMemoryResult, 201, real(0),imag(0),naDataFormat_SWR

C++ Syntax

HRESULT putComplex( tagNADataStore DataStore, long lNumValues, float* pReal, float* pImag, tagDataFormat displayFormat)

Interface

IArrayTransfer


Put Data Complex Method

Write-only
About Accessing Data

PutDataComplex Method

Description

Puts complex data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten.

VB Syntax

meas.putDataComplex location, data

Variable

(Type) - Description

meas

A measurement (object)

location

(enum NADataStore) Where the Data will be put. Choose from:

0 - naRawData

1 - naCorrectedData

2 - naMeasResult

3 - naRawMemory

4 - naMemoryResult

5 - naDivisor - When reading data from, or writing data to, the normalization divisor, you must first create a divisor trace using DataToDivisor Method.

  • Data put in 0 - naRawData will be re-processed whenever a change is made to the measurement attributes such as format or correction.

  • Data put in 2 - naMeasResult will be overwritten by any measurement attribute changes.

  • When putting data into 3 - naRawMemory:

1. Put the analyzer in hold mode

2. Call DataToMemory to initialize a memory buffer

3. Call putDataComplex(naRawMemory, data)

This ensures that the memory buffer is appropriately initialized before receiving new data.

See the Data Access Map

data

(variant) - A two-dimensional variant array.

Note: All buffers except naMeasResult and naMemoryResult require Complex data

Return Type

Not Applicable

Default

Not Applicable

Examples

' Put 201 points worth of raw (complex) data into the measurement
' Note that an array of complex numbers is represented by a 2-D array where the first rank is the number of points, and the 2nd rank is always size 2 (max index 1) representing the Real and Imag parts of the complex number.

' complex array of data (2nd dimension of size 2 represents Re/Im
Dim data(200,1) )
For i = 0 to 200
' Set Real part of data point i
data(i,0) = i/200;
' Set Imag part of data point i
data(i,1) = i/200;
Next
app.ActiveMeasurement.putDataComplex naRawData, data

C++ Syntax

HRESULT putDataComplex(tagNADataStore DataStore, VARIANT complexData)

Interface

IMeasurement


Put Error Term Method

Write-only

About Measurement Calibration

PutErrorTerm Method - Obsolete

Description

Note: This command is replaced by CalSet.putErrorTerm.

Puts variant error term data into the error-correction buffer. See Accessing data.

Learn about reading and writing Calibration data.

VB Syntax

cal.putErrorTerm(term,rcv, src, data)

Variable

(Type) - Description

cal

A Calibrator (object)

term

(enum As NaErrorTerm)

naErrorTerm_Directivity_Isolation
naErrorTerm_Match
naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

data

(variant) Error term data in a two-dimensional array (0:1, 0:numpts-1).

To get this | Specify these parameters:
Error Term | term | rcv | src
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 2 | 1
Rev Isolation | naET_Directivity Isolation | 1 | 2
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 2 | 1
Rev Load Match | naErrorTerm_Match | 1 | 2
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 2 | 1
Rev Trans Tracking | naErrorTerm_Tracking | 1 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim varError As Variant
varError = cal.putErrorTerm (naErrorTerm_Tracking,2,1,VarData)

C++ Syntax

HRESULT putErrorTerm(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, VARIANT varData)

Interface

ICalibrator


Put ErrorTerm2 Method

Write-only

About Cal Sets

PutErrorTerm Method

Description

Puts error term data into the Cal Set. Learn more about reading and writing Cal data using COM

Before calling this method you must open the Cal Set with OpenCal Set.. If the Cal Set is not open, this method returns E_NA_Cal Set_ACCESS_DENIED.

The data must be complex pairs, contained in a two-dimensional VARIANT array.

Note: See also PutErrorTermComplex on the ICalData2 interface to avoid using the variant data type.

VB Syntax

CalSet.putErrorTerm (term, rcv, src, data)

Variable

(Type) - Description

CalSet

(object) - A Cal Set object

term

(enum As NaErrorTerm2) Error Term. Choose from:

0 - naET_Directivity (src = rcv)

1 - naET_SourceMatch ( src = rcv)

2 - naET_ReflectionTracking (src = rcv)

3 - naET_TransmissionTracking (src != rcv)

4 - naET_LoadMatch (src != rcv)

5 - naET_Isolation (src != rcv)

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

data

(variant) Error term data in a two-dimensional array (0:1, 0:numpts-1).

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub Form_Load()
Set pna=CreateObject("AgilentPNA835x.Application")
InitPhonyData
PutPhonyData
End Sub

Private Sub InitPhonyData()
Dim i
Dim numpts
numpts = ActiveChannel.NumberOfPoints
ReDim v(numpts - 1, 1)

For i = 0 To numpts - 1
v(i, 0) = i
v(i, 1) = 0
Next

End Sub

Private Sub PutPhonyData()
Dim cset As CalSet
Set cmgr = pna.GetCalManager
Set cset = cmgr.CreateCalSet(1)
cset.OpenCalSet naCalType_OnePort, 1
cset.putErrorTerm naET_Directivity, 1, 1, v
cset.putErrorTerm naET_ReflectionTracking, 1, 1, v
cset.putErrorTerm naET_SourceMatch, 1, 1, v
cset.CloseCalSet
cset.Description = "Phony One Port"
guid = cset.GetGUID

End Sub

C++ Syntax

HRESULT putErrorTerm(tagNAErrorTerm2 ETerm, long ReceivePort, long SourcePort, VARIANT varData)

Interface

ICalSet


Put ErrorTermByString_Method

Write-only

PutErrorTermByString

Description

Writes a name/array pair to the calset

VB Syntax

PutErrorTermByString(bufferName, vdata)

Variable

(Type) - Description

bufferName

(String) The string used to specify a particular buffer in the calset. An example string for port 3 directivity in a full 2 port cal might be "Full 2 Port Cal (2,3)::Directivity(3,3)".

vdata

(Variant) The vdata array is a variant. This data is usually two dimensional. Each element of the variant array is a 2 array of type single. The two elements represent the real and imaginary parts of a complex datum.

Note: This structure is compatible with scripting clients who can only use variants. For alternative methods that use typed arrays, see ICalData3.

Return Type

Not Applicable

Default

Not Applicable

Examples

See example

C++ Syntax

HRESULT PutStandardByString( BSTR bufferName, VARIANT vardata)

Interface

ICalSet2


Put Error Term Complex Method

Write-only

About Accessing Data

PutErrorTermComplex Method

Description

Puts error term data into the error-correction data buffer. Learn more about reading and writing Cal data using COM

VB Syntax

data.putErrorTermComplex term, rcv, src, numPts, real(), imag()

Variable

(Type) - Description

data

An ICalData pointer to the Calibrator object

term

(enum NAErrorTerm) - The error term to be retrieved. Choose from:

  • naErrorTerm_Directivity_Isolation

  • naErrorTerm_Match

  • naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - number of data points in the array

real()

(single) - array containing the real part of the calibration data. One-dimensional: the number of data points.

imag()

(single) - array containing the imaginary part of the calibration data. One-dimensional: the number of data points.

To get this | Specify these parameters:
Error Term | term | rcv | src
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 2 | 1
Rev Isolation | naET_Directivity Isolation | 1 | 2
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 2 | 1
Rev Load Match | naErrorTerm_Match | 1 | 2
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 2 | 1
Rev Trans Tracking | naErrorTerm_Tracking | 1 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim eData As ICalData
Set eData = chan.Calibrator
eData.putErrorTermComplex naErrorTerm_Directivity_Isolation, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT putErrorTermComplex(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Put ErrorTermComplex2 Method

Write-only
About Cal Sets

PutErrorTermComplex Method

Description

Puts error term data into the Cal Set. Learn more about reading and writing Cal data using COM

Before calling this method you must open the Cal Set with OpenCal Set. If the Cal Set is not open, this method returns E_NA_Cal Set_ACCESS_DENIED.

VB Syntax

data.putErrorTermComplex term, rcv, src, numPts, real(), imag()

Variable

(Type) - Description

data

An ICalData2 pointer to the Cal Set object

term

(enum NAErrorTerm2) - The error term to be written. Choose from:

0 - naET_Directivity

1 - naET_SourceMatch

2 - naET_ReflectionTracking

3 - naET_TransmissionTracking

4 - naET_LoadMatch

5 - naET_Isolation

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - number of data points in the array

real()

(single) - array containing the real part of the calibration data. One-dimensional: the number of data points.

imag()

(single) - array containing the imaginary part of the calibration data. One-dimensional: the number of data points.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim eData As ICalData2
Set eData = app.GetCalManager.Cal Sets.Item(1)
eData.putErrorTermComplex naET_LoadMatch, 1, 2, numpts, rel(0), img(0)

C++ Syntax

HRESULT putErrorTermComplex(tagNAErrorTerm2 ETerm, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData2


Put ErrorTermComplexByString_Method

Write-only

PutErrorTermComplexByString

Description

Writes a name/array pair to the calset

VB Syntax

PutErrorTermComplexByString(bufferName, lnumPoints, real(0), imag(0))

Variable

(Type) - Description

bufferName

(String) The string used to identify a particular buffer in the calset. An example string for port 3 directivity in a full 2 port cal might be "Full 2 Port Cal (2,3)::Directivity(3,3)".

lnumpoints

(Long) The capacity of the float arrays in arguments "real" & "imag".

real

(Single) The real component of the complex data.

imag

(Single) The imaginary component of the complex data.

Note: The size of the real and imaginary arrays should be the same.

Return Value

Single

Default

Not Applicable

Examples

See example

C++ Syntax

HRESULT PutErrorTermComplexByString( BSTR bufferName, long lnumPoints, float* real, float* imag);

Interface

ICalData3


Put Scalar Method

Write-only
Data Access Map

PutScalar Method

Description

Puts Scalar data in the Measurement Result buffer. The putScalar array is not processed by the analyzer; it is just displayed. Any change to the measurement state (changing the format, for example) will cause the putScalar data to be overwritten with the data processed from the raw data buffer.

VB Syntax

measData.putScalar, format, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer interface which supports the Measurement object.

format

(enum NADataFormat) Format of the data. Choose from:

0 - naDataFormat_LinMag

1 - naDataFormat_LogMag

2 - naDataFormat_Phase

5 - naDataFormat_Delay

6 - naDataFormat_Real

7 - naDataFormat_Imaginary

8 - naDataFormat_SWR

Note: Smith and Polar formats are not allowed.

See the Data Access Map

numPts

(integer) - Number of values. Usually the number of points in the trace (chan.NumberOfPoints).

data

(single) - A one-dimensional array of Scalar data matching the number of points in the current measurement.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putScalar naDataFormat_LogMag, 201, dScalar(0)

C++ Syntax

HRESULT putScalar\(tagDataFormat eFormat, long lNumValues, float* pArrayOfScalar)

Interface

IArrayTransfer


Put NAComplex Method

Write-only
Data Accessing Map

PutNAComplex Method

Description

Puts complex data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten. The data is processed and displayed.

Data put in the naRawData store will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in the naMeasResult store will be overwritten by any measurement attribute changes (such as moving a marker).

Note: This method uses NAComplex which is a user-defined data type. If you cannot or prefer not to use this data type, use the putComplex method.

VB Syntax

measData.putNAComplex location, numPts, data, [format]

Variable

(Type) - Description

measData

An IArrayTransfer interface which supports the Measurement object

location

(enum NADataStore) Where the Data will be put. Choose from:

0 - naRawData

1 - naCorrectedData

2 - naMeasResult

3 - naRawMemory

4 - naMemoryResult

5 - naDivisor - When reading data from, or writing data to, the normalization divisor, you must first create a divisor trace using DataToDivisor Method.

See the Data Access Map

numPts

(long integer) - Number of data points in the channel

data

(NAComplex) - A one-dimensional array of Complex data matching the number of points in the current measurement.

format

(enum NADisplayFormat) - Optional argument. Format of the data. If unspecified, naDataFormat_Polar is assumed. Only used when the destination store is naMeasResult or naMemoryResult.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putNAComplex naMemoryResult, 201, dRawComplex(0)

C++ Syntax

HRESULT putNAComplex(tagNADataStore DataStore, long lNumValues, TsComplex* pArrayOfComplex, tagDataFormat displayFormat)

Interface

IArrayTransfer


put Output Method

Write-only

About the Handler IO Connector

put_Output Method

Description

Writes a TTL HI or TTL Low to output pins 3 or 4 of the Material Handler IO connector.

Each pin also has a latched output which is written to with USER. With the latched (USER) outputs, the value is not applied to the associated pin until a positive edge is detected at INPUT1 (pin 2).

VB Syntax

handlerIo.put_Output (pin) = value

Variable

(Type) - Description

handlerIo

(object) - A HandlerIO object

pin

(enum as NAMatHandlerOutput) - pin to write data to. Choose from:

naOutput1 - (0) - pin3
naOutput1User (1) - pin3 latched (applied to pin 3 on positive edge of Input1-pin2)
naOutput2 (2) - pin4
naOutput2User (3) - pin4 latched (applied to pin 4 on positive edge of Input1-pin2)

value

(Variant) Value to write to the selected pin. Choose from

0 - TTL LOW

1 - TTL HIGH

Return Type

Not Applicable

Default

0

Examples

handlerIo.put Output(naOutput1)= 1

C++ Syntax

HRESULT put_Output ( tagNAMatHandlerOutput Output, VARIANT Data );

Interface

IHWMaterialHandlerIO


put OutputVoltage Method

Write-only
About the Aux I/O Connector

put_OutputVoltage Method

Description

Writes voltages on the DAC/Analog Output 1 and Output 2 (pins 2 and 3 of the Aux I/O connector)

VB Syntax

AuxIO.put_OutputVoltage output, voltage

Variable

(Type) - Description

AuxIO

(object) - A Hardware Auxiliary Input / Output object

output

(variant) Number of the output DAC to write voltage to. Choose from:

1 Output DAC 1 - (pin 2)

2 Output DAC 2 - (pin 3)

voltage

(double) Voltage to write to the output DAC. Choose a voltage from -10 to 10

Return Type

None

Default

None

Examples

HWAuxIO.put_OutputVoltage 1,9 'set Analog Out1 to +9v

C++ Syntax

HRESULT put_OutputVoltage (VARIANT Output, double Voltage );

Interface

IHWAuxIO


Write-only

put_OutputVoltageMode Method

Description

This command sets the mode of the selected "Analog Out" line on the Auxiliary IO connector. The modes give the user the option to have the requested voltage applied immediately or not until the sweep is done. To read the mode on each output use get_OutputVoltageMode Method.

VB Syntax

auxIo.put_OutputVoltageMode (output, mode)

Variable

(Type) - Description

auxIo

(Object) An AuxIO object

output

Analog Output to receive mode setting. Choose from 1 or 2

mode

(enum NAOutputVoltageMode )

naWaitEOS - While in this mode any voltage changes sent to the selected analog out will only get applied to the output between sweeps.

naNoWait - While in this mode any voltage changes sent to the selected analog out will occur right away without waiting until the end of a sweep, the voltage gets applied immediately.

Return Type

NAOutputVoltageMode

Default

naWaitEOS

Examples

auxIo.put_OutputVoltageMode 1, naWaitEOS 'Write

C++ Syntax

HRESULT put_OutputVoltageMode(VARIANT Output, tagNAOutputVoltageMode dNewMode);

Interface

IHWAuxIO


Write-only
About the Handler IO Connector

put Port Method

Description

Writes a value to the specified port. Use the get_Port Method to read the settings from the "readable" ports (C, D, E).

VB Syntax

handlerIo.put_Port (port) = value

Variable

(Type) - Description

handlerIo

(object) - A HandlerIO object

port

(enum as NAMatHandlerPort) - port to put data into. Choose from:

naPortA - (0)

naPortB - (1)

naPortC - (2)

naPortD - (3)

naPortE - (4)

naPortF - (5)

naPortG - (6)

naPortH - (7)

value

The number of the data bits to set. The following table shows what the value represents:

Note: When writing to port G, port C must be set to output mode
When writing to port H, both port C and port D must be set to output mode. Use Port Mode Property

Port | Max allowable <num> | MSB...........................................LSB 23...................................................0 |
A | 255 | A7...A0 | Write-only
B | 255 | B7...B0 | Write-only
C | 15 | C3...C0 | Read-Write
D | 15 | D3...D0 | Read-Write
E | 255 | D3...D0 + C3...C0 | Read-Write
F | 65535 | B7...B0 + A7...A0 | Write-only
G | 1048575 | C3...C0 + B7...B0 + A7...A0 | Write-only
H | 16777215 | D3...D0 + C3...C0 + B7...B0 + A7...A0 | Write-only

Return Type

Not Applicable

Default

Not Applicable

Examples

handlerIo.put Port(naPortB)= 15

C++ Syntax

HRESULT put_Port ( tagNAMatHandlerPort Port, VARIANT Data );

Interface

IHWMaterialHandlerIO


Put PortCData Method

Write-only
About the Aux I/O Connector

put_PortCData Method

Description

Writes a 4-bit value to Port C on the Aux I/O connector (pins 22-25) and the Material Handler IO (pins 21-24 Anritsu) - (pins 22-25 Avantest).

Note: These lines are connected to both the Handler IO and Aux IO in the PNA. Therefore, this command will affect both of these connectors in the same way.

VB Syntax

AuxIO.put_PortCData num

Variable

(Type) - Description

AuxIO

(object) - A Hardware Auxiliary Input / Output object

num

(variant) - 4 bit binary value. Choose from 0-15

Return Type

None

Default

None

Examples

HWAuxIO.put_PortCData 15 'If Positive Logic, Port C lines C0, C1, C2, C3 go High. If Negative Logic, they go Low.

C++ Syntax

HRESULT put_PortCData( VARIANT Data );

Interface

IHWAuxIO


Put Data Scalar Method

Write-only
About Accessing Data

PutDataScalar Method

Description

Puts formatted variant scalar data into the measurement result buffer. The data will be immediately processed and displayed. Subsequent changes to the measurement state will be reflected on the display.

Always precede this command by setting the format on the measurement to be consistent with the format of the data being sent to the analyzer. In this way, the display annotation will be correct.

Execution of this command does not change the display format.

VB Syntax

meas.putDataScalar format, data

Variable

(Type) - Description

meas

A measurement (object)

format

(enum NADataFormat) Format of the data. This value is presently ignored by the PNA. Data is always presented in the current format.

Choose from:

0 - naDataFormat_LinMag

1 - naDataFormat_LogMag

2 - naDataFormat_Phase

3 - naDataFormat_Polar

4 - naDataFormat_Smith

5 - naDataFormat_Delay

6 - naDataFormat_Real

7 - naDataFormat_Imaginary

8 - naDataFormat_SWR

Notes:

  • The getData (variant) method includes a "format" argument, which allows scalar (one-dimensional) data. To put data back into the "raw" data buffer using this (putDataComplex) method, specify Polar format when using the getData method.

  • Phase format accepts data in radians (not degrees) and displays in degrees. To convert to degrees: radians * (57.29577951308233) = degrees. The getData method returns degrees if the request is for phase data.

data

(variant) - A 1-dimension array of single precision floating point numbers.

Return Type

Not Applicable

Default

Not Applicable

Examples

' Put 201 points worth of scalar data into the measurement
' 200 is max index, so 0 to 200 is 201 points
Dim data(200) ' array of 201 (scalar) data points
' Fill the array
For i = 0 to 200
data(i) = i/200;
Next
app.ActiveMeasurement.putDataScalar 0, data

C++ Syntax

HRESULT putDataScalar(tagNADataStore DataStore, VARIANT scalarArray)

Interface

IMeasurement


Put Shortcut Method

Write-only

About Macros

PutShortcut Method

Description

Defines a Macro (shortcut) file in the analyzer. This command links a file name and path to the Macro file. You still need to put the macro file in the analyzer at the location indicated by this command.

VB Syntax

app.PutShortcut index,title,path

Variable

(Type) - Description

app

An Application (object)

index

(long) - Number of the macro to be stored in the analyzer. If the index number already exists, the existing macro is replaced with the new macro.

title

(string) - The name to be assigned to the macro

path

(string) - Full pathname to the existing macro "executable" file.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.PutShortcut 1,"Test","C:\Automation\MyTest.vbs"

C++ Syntax

HRESULT PutShortcut(long Number, BSTR title, BSTR pathname)

Interface

IApplication


Put SourcePowerCalDataEx Method

Write-only
About Source Power Cal

putSourcePowerCalDataEx Method

Description

Note: This method replaces putSourcePowerCalData Method

Inputs source power calibration data (as variant data type) to this channel for a specific source port.

If the channel is sweeping the source backwards, then the first data point is the highest frequency value; the last data point is the lowest. Use the Get X-Axis Values command to return the X-axis values in the displayed order.

The calibration is not valid if the current number of points on the channel is not equal to the number of values that were input.

Note: This method sends variant data which is less efficient than methods available on the ISourcePowerCalData interface.

VB Syntax

chan.putSourcePowerCalData buffer, sourcePort, data

Variable

(Type) - Description

chan

(object) – A Channel object

buffer

(enum NASourcePowerCalBuffer) - The source power cal data buffer to write to.

0 - naCorrectionValues This is the only data buffer currently available.

sourcePort

(long integer) – The source port for which calibration data is being requested.

data

(variant) – Array of source power cal data being input.

Return Type

None

Default

Not Applicable

Examples

chan.putSourcePowerCalDataEx naCorrectionValues, 1, varData

C++ Syntax

HRESULT putSourcePowerCalDataEx(tagNASourcePowerCalBuffer bufSelect, long sourcePort, VARIANT varData);

Interface

IChannel4


Put SourcePowerCalDataScalarEx Method

Write-only.
About Source Power Cal

putSourcePowerCalDataScalarEx Method

Description

Note: This method replaces putSourcePowerCalDataScalar Method

Inputs source power calibration data (as scalar values) to this channel for a specific source port.

If the channel is sweeping the source backwards, then the first data point is the highest frequency value; the last data point is the lowest. Use the Get X-Axis Values2 command to return the X-axis values in the displayed order.

VB Syntax

chanData.putSourcePowerCalDataScalarEx buffer, sourcePort, numValues, data

Variable

(Type) - Description

chanData

(interface) – An ISourcePowerCalData2 interface on the Channel (object)

buffer

(enum NASourcePowerCalBuffer) - The source power cal data buffer to write to.

0 - naCorrectionValues This is the only buffer currently available.

sourcePort

(long integer) – The source port for which calibration data is being input.

numValues

(long integer) – Number of data values being input.

Note: If this does not equal the current number of points on the channel, the calibration will not be valid.

data

(single) – Array of source power cal data being input.

Return Type

None

Default

Not Applicable

Examples

Dim chanData As ISourcePowerCalData2
Set chanData = app.ActiveChannel
chanData.putSourcePowerCalDataScalarEx naCorrectionValues, 1, 201, scalarCalValues(0)

C++ Syntax

HRESULT putSourcePowerCalDataScalarEx(tagNASourcePowerCalBuffer bufSelect, long sourcePort, long numValues, float *pData);

Interface

ISourcePowerCalData2


Put Standard2 Method

Write-only

About Cal Sets

PutStandard Method

Description

Puts data into the CalSet. Learn more about reading and writing Cal data using COM

Before calling this method you must open the Cal Set with OpenCal Set. If the Cal Set is not open, this method returns E_NA_Cal Set_ACCESS_DENIED.

The data is complex pairs. The server returns a variant containing a two-dimensional safe array. Memory for the returned Variant is allocated by the server and must be released by client.

Note: See also PutStandardComplex on the ICalData2 interface to avoid using the variant data type.

VB Syntax

obj.putStandard class, rcv, src, data

Variable

(Type) - Description

obj

(object) - A Calibrator or Cal Set object

class

(enum NACalClass) Standard. Choose from:

1 - naClassA

2 - naClassB

3 - naClassC

4 - naClassD

5 - naClassE

6 - naReferenceRatioLine

7 - naReferenceRatioThru

SOLT Standards

1 - naSOLT_Open

2 - naSOLT_Short

3 - naSOLT_Load

4 - naSOLT_Thru

5 - naSOLT_Isolation

TRL Standards

1 - naTRL_Reflection

2 - naTRL_Line_Reflection

3 - naTRL_Line_Tracking

4 - naTRL_Thru

5 - naTRL_Isolation

rcv

(long) - Receiver Port

src

(long) - Source Port

data

(variant) Two dimensional array ( NUMPTS, 2)

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim cmgr as CalManager
Dim cset As CalSet
Set cmgr = pna.GetCalManager
Set cset = cmgr.CreateCalSet(1)
cset.OpenCalSet naCalType_OnePort, 1
cset.putStandard naSOLT_Open, 1, 1, varOpen
cset.putStandard naSOLT_Short, 1, 1, varShort
cset.putStandard naSOLT_Load, 1, 1, varLoad
cset.ComputeErrorTerms
cset.CloseCalSet
cset.Description = "Uploaded one port cal"
guid = cset.GetGUID

End Sub

C++ Syntax

HRESULT putStandard(tagNACalClass stdclass, long ReceivePort, long SourcePort, VARIANT varData)

Interface

ICalibrator
ICalSet


Put StandardByString_Method

Write-only

PutStandardByString

Description

Writes a name array/pair to the calset.

VB Syntax

PutStandardByString(bufferName, vdata)

Variable

(Type) - Description

bufferName

(String) The string used to specify a particular buffer in the calset. An example string requesting the data for the Load standard in a full 2 port cal might be "Full 2 Port Cal (2,3)::S11C(3,3)".

vdata

(Variant) The variant containing a safearray of variants. This data is usually two dimensional.

Note: The vardata array is a safearray of variants wrapped in a variant. This structure is compatible with scripting clients who can only use variants. For alternative methods that used typed arrays, see ICalData3.

Return Type

Not Applicable

Default

Not Applicable

Examples

See an example

C++ Syntax

HRESULT PutStandardByString( BSTR bufferName, VARIANT vardata);

Interface

ICalSet2


Put Standard Complex Method

Write-only
About Cal Sets

PutStandardComplex Method

Description

Puts standards acquisition data into the Cal Set. Learn more about reading and writing Cal data using COM

Before calling this method you must open the Cal Set with OpenCal Set. If the Cal Set is not open, this method returns E_NA_Cal Set_ACCESS_DENIED.

VB Syntax

interface.putStandardComplex class, rcv, src, numPts,real(),imag()

Variable

(Type) - Description

interface

A ICalData pointer to the Calibrator object or
A ICalData2 pointer to the Cal Set object

class

(enum NACalClass) Standard. Choose from:

1 - naClassA

2 - naClassB

3 - naClassC

4 - naClassD

5 - naClassE

6 - naReferenceRatioLine

7 - naReferenceRatioThru

SOLT Standards

1 - naSOLT_Open

2 - naSOLT_Short

3 - naSOLT_Load

4 - naSOLT_Thru

5 - naSOLT_Isolation

TRL Standards

1 - naTRL_Reflection

2 - naTRL_Line_Reflection

3 - naTRL_Line_Tracking

4 - naTRL_Thru

5 - naTRL_Isolation

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - number of data points in the arrays being sent.

real()

(single) - one-dimensional array containing the real part of the acquisition data. (0:points-1)

imag()

(single) - one-dimensional array containing the imaginary part of the acquisition data. (0:points-1)

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim sdata As ICalData2
Set sdata = calmanager.CreateCal Set( 1 )
sdata.putStandardComplex naSOLT_Open, 1, 1, numpts, rel(0), img(0)

C++ Syntax

HRESULT putStandardComplex(tagNACalClass stdclass, long ReceivePort, long SourcePort, long lNumValues, float* pReal, float* pImag)

Interface

ICalData
ICal Set


Put StandardComplexByString_Method

Write-only

PutStandardComplexByString

Description

Writes a name/array pair to the calset.

VB Syntax

PutStandardComplexByString(bufferName, lnumPoints , real(o) , imag(0))

Variable

(Type) - Description

bufferName

(String) The string used to identify a particular buffer in the calset. An example string for port 3 directivity in a full 2 port cal might be "Full 2 Port Cal (2,3)::Directivity(3,3)".

lnumpoints

(Long) The size of the arrays in arguments 4 and 5.

real

(Single) The real component of the complex data.

imag

(Single) The imaginary component of the complex data.

Note: The size of the real and imaginary arrays should be the same.

Return Value

Single

Default

Not Applicable

Examples

See example

C++ Syntax

HRESULT PutStandardComplexByString( BSTR bufferName, long lnumPoints, float* real, float* imag);

Interface

ICalData3


Write-only

Quit Method

Description

Terminates the Network Analyzer application.

VB Syntax

app.Quit

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Quit

C++ Syntax

HRESULT Quit()

Interface

IApplication

Remarks

Under the rules of COM, the server should not exit until all references to it have been released. This method is a brute force way of terminating the application. Be sure to release all references (or terminate the client program) before attempting to restart the Network Analyzer application.

An alternate approach to terminating the application is to make the application invisible (app.Visible = False) and release all references. The server will shutdown.


Read-only
About the ExtTestSetIO connector

ReadData Method

Description

Reads a 13-bit data word from the specified address. Data is read using the AD0 through AD12 lines of the external test set connector. The instrument generates the appropriate timing signals. It automatically controls timing signals LDS, LAS and RLW to strobe the address, and then read the data, from the external test set. See the timing diagram for Address and Data I/O read.

VB Syntax

value = ExtIO.ReadData (address)

Variable

(Type) - Description

value

(variant) - Variable to store the returned data

ExtIO

(object) - An ExternalTestSetIO object

address

(variant) - address to read data from.

Return Type

Variant

Default

Not Applicable

Examples

value = ExtIO.ReadData (15)

C++ Syntax

HRESULT ReadData (VARIANT Address, VARIANT* Data);

Interface

IHWExternaTestSetIO


Read-only
About the ExtTestSetIO connector

ReadRaw Method

Description

Reads a 16-bit value from the external test set. The 16-bit value is comprised of lines AD0 - AD12, Sweep Holdoff In and Interrupt In (inverted).

When this command is used the analyzer does NOT generate the appropriate timing signals; it simply reads the lines. The user needs to first use the WriteRaw method to do the initial setup. The RLW line (pin25) must be set to the appropriate level in order to read the test set connected.

Below is the format of data that is read with ReadRaw:

Pin | Bit | Signal name
22 | 0 | AD0*
23 | 1 | AD1*
11 | 2 | AD2*
10 | 3 | AD3*
9 | 4 | AD4*
21 | 5 | AD5*
20 | 6 | AD6*
19 | 7 | AD7*
6 | 8 | AD8*
5 | 9 | AD9*
4 | 10 | AD10*
17 | 11 | AD11*
3 | 12 | AD12*
2 | 13 | Sweep Holdoff In
13 | 14 | Interrupt In (inverted internally)
na | 15 | Always Zero, grounded internally

*These lines are dependent on the state of RLW (pin25).
Writing a 0(low) to RLW will set lines AD0-AD12 to write mode.
Writing a 1(high) to RLW will set lines AD0-AD12 to read mode.

VB Syntax

value = ExtIO.ReadRaw (address)

Variable

(Type) - Description

value

(variant) - Variable to store the returned data

ExtIO

(object) - An External IO object

address

(variant) - Address to read data from

Return Type

Real

Default

Not Applicable

Examples

value = ExtIO.ReadRaw (address)

C++ Syntax

HRESULT ReadRaw( VARIANT* Input );

Interface

IHWExternalTestSetIO


Write-only
About Save/Recall

Recall Method

Description

Recalls a measurement state, calibration state, or both from the hard drive into the analyzer.

Use app.Save to save the measurement and calibration state.

VB Syntax

app.Recall (filename.ext)

Variable

(Type) - Description

app

An Application (object)

filename.ext

(string) - Filename and extension of the file to be recalled.

Valid extensions:

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

  • .cti - Citifile (data will always be formatted. See Recalling Citifiles Using the PNA)

Files are stored in the default folder "C:\Program Files\Agilent\Network Analyzer\Documents

To recall from a different folder, specify the pathname in the filename.ext. argument.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Recall (mystate.sta) 'Recalls "mystate.sta" from the default folder
app.Recall ("C:\Program Files\Agilent\Network Analyzer\Documents\Newfolder\MyState.cst) 'Recalls "mystate.cst" from the specified folder

C++ Syntax

HRESULT Recall(BSTR bstrFile)

Interface

IApplication


Write-only

About Modifying Cal Kits

Recall Kits Method

Description

Recalls the calibration kits definitions that were stored with the SaveKits command.

VB Syntax

app.RecallKits

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RecallKits

C++ Syntax

HRESULT RecallKits()

Interface

IApplication


Write-only

Remove Method

Description

Removes an item from a collection of objects.

VB Syntax

Object.Remove item

Variable

(Type) - Description

Object

Any of the following (objects)

CalFactorSegments collection
Cal Sets collection
Measurements collection
NAWindows collection
PowerLossSegments collection
Segments collection

Note: Segments, CalFactorSegments, and PowerLossSegments have an OPTIONAL argument [size] referring to the number of segments to remove, starting with the item parameter.

item

(variant) - Item number to be removed

Return Type

Not Applicable

Default

Not Applicable

Examples

Measurements.Remove 3 'Removes measurement 3
segments.Remove 2,20 'Removes 20 segments (2 - 21)

C++ Syntax

HRESULT Remove(VARIANT index); //Measurements

HRESULT Remove(VARIANT index); //Cal Sets

HRESULT Remove(long windowNumber); //NAWindows

HRESULT Remove(VARIANT index, long size); //Segments

HRESULT Remove(VARIANT index, long size); //CalFactorSegments

HRESULT Remove(VARIANT index, long size); //PowerLossSegments

Interface

IMeasurements

INAWindows

ISegments

ICalFactorSegments
ICal Sets

IPowerLossSegments


Write-only

About Presetting the Analyzer

Reset Method

Description

Removes all existing windows and measurements from the application. (Unlike Preset, does not create a new measurement.)

VB Syntax

app.Reset

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Reset

C++ Syntax

HRESULT Reset()

Interface

IApplication


Restore Cal Kit Defaults Method

Write-only

About Modifying Cal Kits

RestoreCalKitDefaults Method

Description

Restores the original properties of the specified Cal Kit, overwritting the last definition with the factory defaults.

VB Syntax

app.RestoreCalKitDefaults (calKit)

Variable

(Type) - Description

app

An Application (object)

calKit

(enum NACalKit) - Calibration Kit to restore. Choose from:

1 - naCalKit_85032F_N50
2 - naCalKit_85033E_3_5
3 - naCalKit_85032B_N50
4 - naCalKit_85033D_3_5
5 - naCalKit_85038A_7_16
6 - naCalKit_85052C_3_5_TRL
7 - naCalKit_User7
8 - naCalKit_User8
9 - naCalKit_User9
10 - naCalKit_User10

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RestoreCalKitDefaults naCalKit_MechKit10

C++ Syntax

HRESULT RestoreCalKitDefaults\(tagNACalKit kit)

Interface

IApplication


Restore Cal Kit Defaults All Method

Write-only
About Modifying Cal Kits

RestoreCalKitDefaultsAll Method

Description

Restores the original properties of ALL of the Cal Kits, overwritting the last definitions with the factory defaults.

VB Syntax

app.RestoreCalKitDefaultsAll

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RestoreCalKitDefaultsAll

C++ Syntax

HRESULT RestoreCalKitDefaultsAll()

Interface

IApplication


Write-only
About Triggering

Resume Method

Description

Resumes the trigger mode of all channels that was in effect before sending the channels.Hold method. Channels.Hold must be sent before channels.Resume, using the same instance of the Channels object.

VB Syntax

chans.Resume

Variable

(Type) - Description

chans

A Channel collection (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

chans.Resume

C++ Syntax

HRESULT Resume();

Interface

IChannels2


Write-only

About Save/Recall

Save Method

Description

Saves the appropriate content to the hard drive depending on the file suffix provided. See the table below. Some saved files can be recalled using app.Recall. depending on the content.

VB Syntax

app.Save(filename.ext)

Variable

(Type) - Description

app

An Application (object)

filename.ext

(string) - Filename and extension of the file to be saved.

Extensions:

  • .cst - Saves both Instrument State and Cal Set reference - Recalls a calibrated measurement. (Recallable)

  • .sta - Saves Instrument State only - recalls the instrument state without calibration. (Recallable)

  • .cal - Calibration file – saves the active Cal Sets currently in use by any channel. Use this mode for archival purposes only. All Cal Sets are saved to a Cal Set data file. This mode provides a method of safeguarding calibration data. This data can be restored to the list of Cal Sets available in the instrument. (Recallable)

  • .prn - Saves active trace in comma-separated format (not recallable)

  • .bmp - Saves a Bitmap of the screen (not recallable)

  • .s1p - Saves 1-port measurement data (not recallable)

  • .s2p - Saves 2-port measurement data (not recallable)

Files are saved to the default folder "C:\Program Files\Agilent\Network Analyzer\Documents. To save to a different folder, specify the pathname in the filename.ext. argument.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Save(mystate.sta) 'Saves "mystate.sta" to the default folder
app.Save("C:\Program Files\Agilent\Network Analyzer\Documents\Newfolder\MyState.cst) 'Saves "mystate.cst" to the specified folder

C++ Syntax

HRESULT Save(BSTR bstrFile)

Interface

IApplication


Save (CalSet) Method

Write-only

About Cal Sets

Save Method

Description

Saves the current Cal Set to disk (recommended method for saving a Cal Set).

Note: There is also a Save method on the ICalManager and Calibrator interface which saves every Cal Set that currently exists in the instrument to the disk.

Learn more about reading and writing Cal data using COM

VB Syntax

CalSet.Save

Variable

(Type) - Description

CalSet

(object) - A Cal Set object

Return Type

Not Applicable

Default

Not Applicable

Examples

myCalSet.Save

See Copy Method for an example application of this command.

C++ Syntax

HRESULT Save();

Interface

ICalSet


Save Cal Sets Method

Write-only

About Cal Sets

SaveCalSets Method

Description

Writes new or changed Cal Sets out to disk. All Cal Sets are saved in a single file. This file is updated at the following times:

  • When a Cal Set has been deleted.

  • When a calibration has been performed through the front panel interface.

  • When this method is called.

  • When ICalSet::Save is called.

Note: The recommended method to save a Cal Set is ICalSet::Save which saves the data for only the current Cal Set to the disk.
This method (ICalManager/Calibrator::SaveCalSets) saves every Cal Set that currently exists in the instrument to the disk.

Learn more about reading and writing Cal data using COM

VB Syntax

object.SaveCalSets

Variable

(Type) - Description

object

(object) - A CalManager object or a Calibrator object

Return Type

None

Default

Not Applicable

Example

calMgr.SaveCalSets

C++ Syntax

HRESULT SaveCalSets( );

Interface

ICalManager
ICalibrator


Write-only

About Save/Recall

SaveCitiDataData Method

Description

Saves UNFORMATTED trace data to .cti file. Learn more about citifiles.

VB Syntax

app.SaveCitiDataData(filename.cti)

Variable

(Type) - Description

app

An Application (object)

filename.cti

(string) - Filename and .cti extension of the file to be saved.

Files are saved to the default folder "C:\Program Files\Agilent\Network Analyzer\Documents. To save to a different folder, specify the pathname in the filename.cti. argument.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.SaveCitiDataData ("myDDCitifile.cti") 'Saves "myDDCitifile.cti" to the default folder

app.SaveCitiDataData ("C:\Program Files\Agilent\Network Analyzer\Documents\Newfolder\myDDCitifile.cti") 'Saves "myDDCitifile.cti" to the specified folder

C++ Syntax

HRESULT SaveCitiDataData (BSTR bstrFile)

Interface

IApplication5


Write-only

About Save/Recall

SaveCitiFormattedData Method

Description

Saves FORMATTED trace data to .cti file. Learn more about citifiles.

VB Syntax

app.SaveCitiFormattedData(filename.cti)

Variable

(Type) - Description

app

An Application (object)

filename.cti

(string) - Filename and .cti extension of the file to be saved.

Files are saved to the default folder "C:\Program Files\Agilent\Network Analyzer\Documents. To save to a different folder, specify the pathname in the filename.cti. argument.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.SaveCitiFormattedData ("myFDCitifile.cti") 'Saves "myFDCitifile.cti" to the default folder

app.SaveCitiFormattedData ("C:\Program Files\Agilent\Network Analyzer\Documents\Newfolder\myFDCitifile.cti") 'Saves "myFDCitifile.cti" to the specified folder

C++ Syntax

HRESULT SaveCitiFormattedData (BSTR bstrFile)

Interface

IApplication5


SaveFile_Method

Write only

SaveFile Method

Description

Saves the mixer/converter test setup to a mixer attributes (.mxr) file.

VB Syntax

mixer.SaveFile (filename)

Variable

(Type) - Description

mixer

An IMixer Interface pointer to a measurement (object)

filename

(String) Path and file name of the .mxr file

Return Type

String

Default

Not Applicable

Examples

mixer.SaveFile (File_Name)

C++ Syntax

HRESULT put_SaveFile(BSTR newVal)

Interface

IMixer


Save Kits Method

Write-only

About Modifying Cal Kits

SaveKits Method

Description

Saves the cal kits, typically after modifying a calibration kit. To load a cal kit into the analyzer from the hard drive, use app.RecallKits.

VB Syntax

app.SaveKits

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.SaveKits

C++ Syntax

HRESULT SaveKits()

Interface

IApplication


Search Filter Bandwidth Method

Write-only

About Marker Search

SearchFilterBandwidth Method

Description

Searches the measurement data with the current BandwidthTarget (default is -3). To continually track the filter bandwidth, use BandwidthTracking.

This feature uses markers 1-4. If not already, they are activated. To turn off these markers, either turn them off individually or DeleteAllMarkers.

The bandwidth statistics are displayed on the analyzer screen. To get the bandwidth statistics, use either GetFilterStatistics or FilterBW, FilterCF , FilterLoss ,or FilterQ.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To search a UserRange with the bandwidth search, first activate marker 1 and set the desired UserRange. Then send the SearchFilterBandwidth command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.

VB Syntax

meas.SearchFilterBandwidth

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.SearchFilterBandwidth

C++ Syntax

HRESULT SearchFilterBandwidth()

Interface

IMeasurement


Search Max Method

Write-only

About Marker Search

SearchMax Method

Description

Searches the marker domain for the maximum value.

VB Syntax

mark.SearchMax

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchMax

C++ Syntax

HRESULT SearchMax()

Interface

IMarker


Search Min Method

Write-only
About Marker Search

SearchMin Method

Description

Searches the marker domain for the minimum value.

VB Syntax

mark.SearchMin

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchMin

C++ Syntax

HRESULT SearchMin()

Interface

IMarker


Search Next Peak Method

Write-only

About Marker Search

SearchNextPeak Method

Description

Searches the marker's domain for the next peak value.

VB Syntax

mark.SearchNextPeak

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchNextPeak

C++ Syntax

HRESULT SearchNextPeak()

Interface

IMarker


Search Peak Left Method

Write-only

About Marker Search

SearchPeakLeft Method

Description

Searches the marker's domain for the next VALID peak to the left of the marker.

VB Syntax

mark.SearchPeakLeft

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchPeakLeft

C++ Syntax

HRESULT SearchPeakLeft()

Interface

IMarker


Search Peak Right Method

Write-only

About Marker Search

SearchPeakRight Method

Description

Searches the marker's domain for the next VALID peak
to the right of the marker.

VB Syntax

mark.SearchPeakRight

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchPeakRight

C++ Syntax

HRESULT SearchPeakRight()

Interface

IMarker


Search Target Method

Write-only

About Marker Search

SearchTarget Method

Description

Searches the marker's domain for the target value (specified with mark.TargetValue). Searches to the right; then at the end of the search domain, begins again at the start of the search domain.

VB Syntax

mark.SearchTarget

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTarget

C++ Syntax

HRESULT SearchTarget()

Interface

IMarker


Search Target Left Method

Write-only
About Marker Search

SearchTargetLeft Method

Description

Moving to the left of the marker position, searches the marker's domain for the target value (specified with mark.TargetValue).

VB Syntax

mark.SearchTargetLeft

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTargetLeft

C++ Syntax

HRESULT SearchTargetLeft()

Interface

IMarker


Search Target Right Method

Write-only
About Marker Search

SearchTargetRight Method

Description

Moving to the right of the marker position, searches the marker's domain for the target value (specified with mark.TargetValue).

VB Syntax

mark.SearchTargetRight

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTargetRight

C++ Syntax

HRESULT SearchTargetRight()

Interface

IMarker


SelectCal Set Method

Write-only

SelectCalSet Method

Description

Selects a Cal Set to apply to the measurements on the calling channel.

If the cal set's GUID is not found, this method returns E_NA_Cal Set_NOT_FOUND.

Note: Error Correction is not automatically applied as a result of this command being issued. If there is more than one Cal Type in the Cal Set, you must explicitly choose the Cal Type you want to apply. (See meas.Caltype)I

VB Syntax

channel.SelectCalSet GUID, restore

Variable

(Type) - Description

channel

(object) - A Channel object

GUID

(string) - GUID number of the Cal Set to select

restore

(boolean) -

True (1) - The stimulus stored with the cal set will be applied to the channel.

False (0) - If a conflict is detected between the existing channel settings and the Cal Set stimulus settings, then the following will occur:

If interpolation is ON, then interpolation will be attempted. This may fail if the channel frequency is outside the range of the Cal Set.

If interpolation is OFF, the selection will be abandoned and an error is returned: E_NA_CAL_STIMULUS_VALUES_EXCEEDED

Return Type

Not Applicable

Default

Not Applicable

Example

channel.SelectCalSet GUID, 1

C++ Syntax

HRESULT SelectCalSet (BSTR strGUID, bool bRestore);

Interface

IChannel


SetAllSegments_Method

Write-only
About Segment Sweep

SetAllSegments Method

Description

Uploads a segment table to the PNA replacing any existing segment table.

  • Segments must be ascending in frequency and non-overlapping. If they are not, the segments are 'adjusted' as they are from the front panel control.

  • The total number of points for all segments cannot exceed the PNA maximum for a sweep.

  • Can set independent IFBW and port power.

Note: For a 4-port PNA, send either 1 port power value or 4 port power values. Sending 2 or 3 values will result in an error.

See an example that uses this command.

VB Syntax

Segs.SetAllSegments (segdata)

Variable

(Type) - Description

segs

A Segments (Collections)

segdata

Variant or Double Array - Segment data

For VARIANT, the underlying type must be appropriate for the element:

  • Boolean - segment on/off

  • Integer - number of points

  • Double - all other elements.

Return Type

Not Applicable

Default

Not Applicable

Examples

See an example using this command

C++ Syntax

SetAllSegments (VARIANT Segments );

Interface

ISegments2


Write-only

About Performing a Calibration

SetCalInfo Method

Description

Specifies the type of calibration. This method should be the first method called on the calibrator object. It prepares the internal state for the rest of the calibration. Learn more about reading and writing Cal data using COM

VB Syntax

cal.SetCalInfo(type,rcvPort,srcPort)

Variable

(Type) - Description

cal

A Calibrator (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None
8 - naCalType_ThreePort_SOLT

Note: The analyzer can measure both ports simultaneously, assuming you have two of each standard type. For a 2-port cal, See cal.Simultaneous2PortAcquisition

Note: For 1-port cals, the source port = receiver port. For 2-port SOLT and TRL, it doesn't matter which port is specified as source and receiver

rcvPort

(long integer) - Receiver Port

srcPort

(long integer) - Source Port

Return Type

NACalType

Default

7- naCalType_None

Examples

cal.setCalInfo(naCalType_Response_Open,1,1)

C++ Syntax

HRESULT SetCalInfo(tagNACalType calType,long portA, long portB)

Interface

ICalibrator


SetCalInfo2 Method

Write-only

About Source Power Cal

SetCalInfo2 Method (for source power cals)

Description

Specifies the technique, the channel, and the source port to be used for the source power calibration about to be performed.

Note: This method replaces SetCalInfo Method.

VB Syntax

powerCalibrator.SetCalInfo2 calMethod, channel, sourcePort, [powerOffset,] [display]

Variable

(Type) - Description

powerCalibrator

(object) - A SourcePowerCalibrator3 object

calMethod

(enum NASourcePowerCalMethod) Selects the calibration method to be used for the source power cal acquisition.

0 – naPowerMeter Power Meter is used for all readings. (same as "fast iteration" box not checked on dialog box)

1 - naPowerMeterAndReceiver Power meter for the first iteration; then use the reference receiver for remaining readings if necessary (same as "fast iteration" box checked on dialog box)

channel

(long integer) - Number of the PNA channel (not power meter channel) on which the source power cal will be performed. If the channel does not already exist, it will be created.

sourcePort

(long integer) - Port number on which the source power cal will be performed.

[powerOffset]

(double) - Optional argument. Sets or returns a power level offset from the PNA test port power. This can be a gain or loss value (in dB) to account for components you connect between the source and the reference plane of your measurement. For example, specify 10 dB to account for a 10 dB amplifier at the input of your DUT. Following the calibration, the PNA power readouts are adjusted by this value. This argument performs the same function as chan.SourcePowerCalPowerOffset Property

[display]

(boolean) Optional argument. Enables and disables the display of power readings on the PNA screen. After the source power cal data is acquired, this setting is reset to ON. If unspecified, value is set to ON.

True - Display of power readings is ON

False - Display of power readings is OFF

Return Type

None

Default

Not Applicable

Examples

powerCalibrator.SetCalInfo2 naPowerMeter, 1, 1, -10, True

C++ Syntax

HRESULT SetCalInfo2( tagNASourcePowerCalMethod enumCalMethod, long Channel, long SourcePort, double PowerOffset = 0., VARIANT_BOOL bDisplay = VARIANT_TRUE);

Interface

ISourcePowerCalibrator3


Set Center Method

Write-only
About Marker Functions

SetCenter Method

Description

Changes the center stimulus to the stimulus value of the marker. The start stimulus stays the same and the stop is adjusted.

Note: This command does not work with channels that are in CW or Segment Sweep mode.

VB Syntax

mark.SetCenter

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetCenter

C++ Syntax

HRESULT SetCenter()

Interface

IMarker


Set CW Method

Write-only
About Marker Functions

SetCW Method

Description

Changes the analyzer to sweep type CW mode and sets the CW frequency to the marker's frequency. Does not change anything if current sweep type is other than a frequency sweep.

VB Syntax

mark.SetCW

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetCW

C++ Syntax

HRESULT SetCW()

Interface

IMarker


Write-only
About Marker Functions

SetElectricalDelay Method

Description

Changes the measurement's electrical delay to the marker's delay value.

VB Syntax

mark.SetElectricalDelay

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetElectricalDelay

C++ Syntax

HRESULT SetElectricalDelay()

Interface

IMarker


Write/Read

About Analyzer Events

SetFailOnOverRange Method

Description

When set TRUE, configures the analyzer to report outOfRange conditions with an error code. Any overrange error will return E_NA_LIMIT_OUTOFRANGE_ERROR.

Note: This method is for the benefit of VB clients. The analyzer automatically adjusts overrange conditions to the closest acceptable setting. The VB user will not See that an overrange occurred because the HRESULT is not returned if it has a success code. For more information, See Events/OverRange.

VB Syntax

app.SetFailOnOverRange state

Variable

(Type) - Description

app

An Application (object)

state

(boolean) -
True (1) - Overrange conditions report an error code
False (0) - Overrange conditions report a success code

Return Type

Not Applicable

Default

False (0)

VB Example

app.SetFailOnOverRange TRUE
On Error Goto ERRHANDLER

'the following overrange will cause ERRHANDLER to be invoked

channel.StartFrequency = 9.9 GHZ
exit

ERRHANDLER:
print "something failed"

C++ Syntax

HRESULT put_SetFailOnOverRange(VARIANT_BOOL mode)

Interface

IApplication


Write only
About Power Calibration

SetPowerAcquisitionDevice Method

Description

Sets the power sensor channel (A or B) to be used. This performs the same function as the Use this sensor only checkbox in the Power Sensor Settings dialog.

Note: This method is only necessary when performing an SMC calibration.

VB Syntax

pwrCal.SetPowerAcquisitionDevice sensor

Variable

(Type) - Description

pwrCal

(Object) A SourcePowerCalibrator object

sensor

(enum NAPowerAcquisitionDevice) The power sensor channel. Choose from:

0 – naPowerSensor_A

1 – naPowerSensor_B

Default

Not Applicable

Examples

pwrCal.PowerAcquisitionDevice naPowerSensor_A

C++ Syntax

HRESULT SetPowerAcquisitionDevice( tagNAPowerAcquisitionDevice enumAcqDevice);

Interface

ISourcePowerCalibrator3


Set Frequency LowPass Method

Write-only

About Time Domain

SetFrequencyLowPass Method

Description

Set the start frequencies when trans.Mode = LowPass.

VB Syntax

trans.SetFrequencyLowPass

Variable

(Type) - Description

trans

A Transform (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

trans.SetFrequencyLowPass

C++ Syntax

HRESULT SetFrequencyLowPass(void)

Interface

ITransform


Write-only
About Marker Functions

SetReferenceLevel Method

Description

Changes the measurement's reference level to the marker's Y-axis value.

VB Syntax

mark.SetReferenceLevel

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetReferenceLevel

C++ Syntax

HRESULT SetReferenceLevel()

Interface

IMarker


SetStandardForClass_Method

Write-only

SetStandardsForClass Method

Description

Set the calibration standard numbers for a specified calibration class. To read the cal standard numbers use GetStandardsForClass Method

VB Syntax

calKit.SetStandardsForClass (calclassorder, std1, std2, std3, std4, std5, std6, std7)

Variable

(Type) - Description

calKit

A CalKit (object)

calclassorder

(enum NACalClassOrder) Cal Class. Choose from:

0 - naRefl_1_S11

1 - naRefl_2_S11

2 - naRefl_3_S11

3 - naTran_1_S21

4 - naRefl_1_S22

5 - naRefl_2_S22

6 - naRefl_3_S22

7 - naTran_1_S12

8 - naRefl_1_S33

9 - naRefl_2_S33

10 - naRefl_3_S33

11 - naTran_1_S32

12 - naTran_1_S23

13 - naTran_1_S31

14 - naTran_1_S13

15 - naTRL_T

16 - naTRL_R

17 - naTRL_L

std1…std7

(long) Calibration Standard Number. Choose from 1 through 30. Std2 through Std7 are optional

Return Type

Not applicable

Default

Not applicable

Examples

calkit.SetStandardsForClass naRefl_3_S11, 3, 5, 6

calkit.SetStandardsForClass naTran_1_S21, 4

C++ Syntax

HRESULT SetStandardsForClass(NACalClassOrder calclassorder, long std1, long std2, long std3, long std4, long std5, long std6, long std7)

Interface

ICalKit


Set Start Method

Write-only

About Marker Functions

SetStart Method

Description

Changes the start stimulus to the stimulus value of the marker. The stop stimulus stays the same and the span is adjusted.

Note: This command does not work with channels that are in CW or Segment Sweep mode.

VB Syntax

mark.SetStart

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetStart

C++ Syntax

HRESULT SetStart()

Interface

IMarker


Set Stop Method

Write-only
About Marker Functions

SetStop Method

Description

Changes the stop stimulus to the stimulus value of the marker. The start stimulus stays the same and the span is adjusted.

Note: This command does not work with channels that are in CW or Segment Sweep mode.

VB Syntax

mark.SetStop

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetStop

C++ Syntax

HRESULT SetStop()

Interface

IMarker


Show Marker Readout Method

Write-only
About Display Formatting

ShowMarkerReadout Method

Description

Shows and Hides the Marker readout for the active marker in the upper-right corner of the window.

VB Syntax

win.ShowMarkerReadout state

Variable

(Type) - Description

win

A NAWindow (object)

state

(boolean) -
True (1) - Show the Marker readout
False (0) - Hide the Marker readout

Return Type

Not Applicable

Default

Not Applicable

Examples

win.ShowMarkerReadout True

C++ Syntax

HRESULT ShowMarkerReadout(VARIANT_BOOL bState)

Interface

INAWindow


Show Status Bar Method

Write-only

About Display Formatting

ShowStatusBar Method

Description

Shows and Hides the Status Bar. The Status Bar is located across the bottom of the display. The following information is shown for the active measurement:

  • Channel number

  • Parameter

  • Correction On or Off

  • Remote or Local operation

VB Syntax

app.ShowStatusBar state

Variable

(Type) - Description

app

An Application (object)

state

(boolean) -
True (1) - Show the Status Bar
False (0) - Hide the Status Bar

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowStatusBar True

C++ Syntax

HRESULT ShowStatusBar (VARIANT_BOOL bState)

Interface

IApplication


Show Stimulus Method

Write-only
About Display Formatting

ShowStimulus Method

Description

Shows and Hides the Stimulus (X-axis) information located at the bottom of the display. The start and stop stimulus values are shown for the active measurement.

VB Syntax

app.ShowStimulus state

Variable

(Type) - Description

app

An Application (object)

state

(boolean) -
True (1) - Show the Stimulus information
False (0) - Hide the Stimulus information

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowStimulus True

C++ Syntax

HRESULT ShowStimulus(VARIANT_BOOL bState)

Interface

IApplication


Show Table Method

Write-only

About Display Formatting

ShowTable Method

Description

Shows or Hides the specified table for the window's active measurement in the lower part of the window.

VB Syntax

win.ShowTable value

Variable

(Type) - Description

win

A NAWindow (object)

value

(enum naTable) - The table to show or hide. Choose from:

0 - naTable_None
1 - naTable_Marker
2 - naTable_Segment
3 - naTable_Limit

Return Type

Not Applicable

Default

Not Applicable

Examples

win.ShowTable naTable_limit

C++ Syntax

HRESULT ShowTable (tagNATableType table)

Interface

INAWindow


Show Title Bars Method

Write-only

About Display Formatting

ShowTitleBars Method

Description

Shows and Hides the Title Bars. The Title Bars are across the top of the Network Analyzer Window and each of the measurement windows. The Window name is shown in the Title Bar.

VB Syntax

app.ShowTitleBars state

Variable

(Type) - Description

app

An Application (object)

state

(boolean)
True (1) - Show the Title Bars
False (0) - Hide the Title Bars

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowTitleBars True

C++ Syntax

HRESULT ShowTitleBars\(VARIANT_BOOL bState)

Interface

IApplication


Show Toolbar Method

Write-only
About Display Formatting

ShowToolbar Method

Description

Shows and Hides the specified Toolbar.

VB Syntax

app.ShowToolbar toolbar,state

Variable

(Type) - Description

app

An Application (object)

toolbar

(enum NAToolbarType) - The toolbar to show or hide. Choose from:

0 - naToolbar_None
1 - naToolbar_ActiveEntry
2 - naToolbar_Markers
3 - naToolbar_Measurement
4 - naToolbar_Stimulus
5 - naToolbar_SweepControl

state

(boolean) -
True (1) - Show the specified toolbar
False (0) - Hide the specified toolbar

Return Type

Not Applicable

Default

1 - naToolbar_ActiveEntry showing; all others hiding.

Examples

app.ShowToolbar 1,1 'shows the active entry toolbar

C++ Syntax

HRESULT ShowToolbar(tagNAToolbarType toolbar, VARIANT_BOOL bState)

Interface

IApplication


Write-only

About Triggering

Single Method

Description

Sets the trigger count to 1, which will cause the channel to respond to exactly one trigger signal from any source (internal, external, or manual).

VB Syntax

chan.Single [sync]

Variable

(Type) - Description

chan

A Channel (object)

[sync]

(boolean) -Optional argument. A variable set to either True or False.

True - The analyzer waits until the trigger is completed to process subsequent commands.
False - Subsequent commands are processed immediately.

Return Type

Not Applicable

Default

Not Applicable

Examples

sync = True
chan.Single sync

C++ Syntax

HRESULT Single(VARIANT_BOOL bWait)

Interface

IChannel


Read-only
About Cal Sets

StringToNACalClass Method

Description

Converts the returned strings from GetStandardsList into the enumeration (NACalClass) and the port numbers required for PutStandard and GetStandard methods that transmit data in and out of the Cal Set.

Learn more about reading and writing Cal data using COM

VB Syntax

CalSet.StringToNACalClass (list, std, rcv, src)

Variable

(Type) - Description

CalSet

(object) - A Cal Set object

list

(string) - a string containing the textual description of the standard.

std

(enum NACalClass) Choose from:

1 - naClassA

2 - naClassB

3 - naClassC

4 - naClassD

5 - naClassE

6 - naReferenceRatioLine

7 - naReferenceRatioThru

SOLT Standards

1 - naSOLT_Open

2 - naSOLT_Short

3 - naSOLT_Load

4 - naSOLT_Thru

5 - naSOLT_Isolation

TRL Standards

1 - naTRL_Reflection

2 - naTRL_Line_Reflection

3 - naTRL_Line_Tracking

4 - naTRL_Thru

5 - naTRL_Isolation

rcv

(long) - port number of the receiver

src

(long) - port number of the source

Return Type

Not Applicable

Default

Not Applicable

Examples

guid = CalSet.StringToNACalClass(list, std, rcv, src)

C++ Syntax

HRESULT StringtoNACalClass ( BSTR* str, NACalClass* item, long *rcv, long *src);

Interface

ICalSet


Read-only

About Cal Sets

StringtoNAErrorTerm2 Method

Description

Converts the returned strings from GetErrorTermList into the enumeration (NAErrorTerm2) and the port numbers required for PutErrorTerm and GetErrorTerm methods that transmit data in and out of the Cal Set.

Learn more about reading and writing Cal data using COM

VB Syntax

Cal Set.StringToNAErrorTerm2 (list, eterm, rcv, src)

Variable

(Type) - Description

Cal Set

(object) - A Cal Set object

list

(string) - a string containing the textual description of the error term.

eterm

(enum As NaErrorTerm2). Choose from:

0 - naET_Directivity (rcv = src)
1 - naET_SourceMatch ( rcv = src)
2 - naET_ReflectionTracking ( rcv = src )
3 - naET_TransmissionTracking (rcv != src)
4 - naET_LoadMatch ( rcv != src)
5 - naET_Isolation (rcv != src)

rcv

(long) - port number of the receiver

src

(long) - port number of the source

Return Type

Not Applicable

Default

Not Applicable

Examples

CalSet.StringToNAErrorTerm2 str, term, rcv, src

C++ Syntax

HRESULT StringToNAErrorTerm2 (BSTR* str, NAErrorTerm2* item, long *rcv, long *src);

Interface

ICalSet


Write-only
About User Preset

UserPreset Method

Description

Performs a User Preset. There must be an active User Preset state file (see UserPresetLoadFile and UserPresetSaveState) or an error will be returned.

Regardless of the state of the User Preset Enable checkbox, the app.Preset command will always preset the PNA to the factory preset settings, and app.UserPreset will always perform a User Preset.

VB Syntax

app.UserPreset

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.UserPreset

C++ Syntax

HRESULT UserPreset()

Interface

IApplication6


Write-only
About User Preset

UserPresetLoadFile Method

Description

Loads an existing instrument state file (.sta or .cst) to be used for User Preset. Subsequent execution of app.UserPreset will cause the PNA to assume this instrument state.

Regardless of the state of the User Preset Enable checkbox, the app.Preset command will always preset the PNA to the factory preset settings, and app.UserPreset will always perform a User Preset.

VB Syntax

app.UserPresetLoadFile (file)

Variable

(Type) - Description

app

An Application (object)

file

(String) Full path, name, and extension of the file to be loaded.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.UserPresetLoadFile ("C:\Program Files\Agilent\Network Analyzer\Documents\10MHzto20GHz.sta")

C++ Syntax

HRESULT UserPresetLoadFile (BSTR bstrFile)

Interface

IApplication6


Write-only
About User Preset

UserPresetSaveState Method

Description

Saves the current instrument settings as UserPreset.sta. Subsequent execution of app.UserPreset will cause the PNA to assume this instrument state.

Regardless of the state of the User Preset Enable checkbox, the app.Preset command will always preset the PNA to the factory preset settings, and app.UserPreset will always perform a User Preset.

VB Syntax

app.UserPresetSaveState

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.UserPresetSaveState

C++ Syntax

HRESULT UserPresetSaveState()

Interface

IApplication6


Write-only
About the ExtTestSetIO connector

WriteData Method

Description

Writes a 13-bit value to the specified address using the AD0 through AD12 lines of the external test set connector. The PNA generates the appropriate timing signals. It automatically controls timing signals LDS, LAS and RLW to strobe the address, then the data, to the external test set. See the timing diagram for Address and Data I/O read.

VB Syntax

ExtIO.WriteData (address) = value

Variable

(Type) - Description

ExtIO

(object) - An External IO object

address

(variant) - Address to be written to.

value

(variant) - 13-bit word to write

Return Type

Not Applicable

Default

Not Applicable

Examples

ExtIO.WriteData (15) = 12

C++ Syntax

HRESULT WriteData(VARIANT Address, VARIANT Data);

Interface

IHWExternaTestSetIO


Write-only

About the ExtTestSetIO connector

WriteRaw Method

Description

Writes a 16-bit value to the external test set connector lines AD0 - AD12, RLW, LAS and LDS. The analyzer does NOT generate the appropriate timing signals. The user has control of all 16 lines using this write method.

Note: When RLW (pin25) is set to 1 (high) it causes lines AD0 - AD12 to float. It disables their output latches and sets the hardware for reading. LDS and LAS are not affected by this behavior.

Below is the format of data that is written with WriteRaw:

* This Output will float if RLW (bit-13) is set high

Pin | Bit | Signal name
22 | 0 | AD0*
23 | 1 | AD1*
11 | 2 | AD2*
10 | 3 | AD3*
9 | 4 | AD4*
21 | 5 | AD5*
20 | 6 | AD6*
19 | 7 | AD7*
6 | 8 | AD8*
5 | 9 | AD9*
4 | 10 | AD10*
17 | 11 | AD11*
3 | 12 | AD12*
25 | 13 | RLW
24 | 14 | LDS
8 | 15 | LAS

VB Syntax

ExtIO.WriteRaw value

Variable

(Type) - Description

ExtIO

(object) - An External IO object

value

(variant) - Data to be written

Return Type

Not Applicable

Default

Not Applicable

Examples

ExtIO.WriteRaw 12

C++ Syntax

HRESULT WriteRaw( VARIANT Output );

Interface

IHWExternalTestSetIO


OnCal Event

About Analyzer Events

OnCalEvent

Description

Triggered by a calibration event. See a list of CAL Events.

Note: Some Severe Events are also used as Error Messages

VB Syntax

Sub app_OnCalEvent(ByVal eventID As Variant, ByVal chanNum As Variant, ByVal measNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

measNum

Measurement Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnCalEvent(ByVal eventID As Variant, ByVal channelNumber As Variant, ByVal measurementNumber As Variant)
'
MsgBox ("A Calibration event has occured")
End Sub

C++ Syntax

HRESULT OnCalEvent(VARIANT eventID, VARIANT channelNumber, VARIANT measurementNumber)

Interface

IApplication


OnChannel Event

About Analyzer Events

OnChannelEvent

Description

Triggered by a channel event. See a list of Channel Events

Note: Some Severe Events are also used as Error Messages

VB Syntax

Sub app_OnChannelEvent(ByVal eventID As Variant, ByVal chanNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnChannelEvent(ByVal eventID As Variant, ByVal channelNumber As Variant)
MsgBox "A channel event occured"
End Sub

C++ Syntax

HRESULT OnChannelEvent(VARIANT eventID, VARIANT channelNumber)

Interface

IApplication


OnDisplay Event

About Analyzer Events

OnDisplayEvent

Description

Triggered by a display event. See a list of Display Events

Note: Some Severe Events are also used as Error Messages

VB Syntax

Sub app_OnDisplayEvent(ByVal eventID As Variant, ByVal winNum As Variant, ByVal traceNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

winNum

Window Number of the event

traceNum

Trace Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnDisplayEvent(ByVal eventID As Variant, ByVal windowNumber As Variant, ByVal traceNumber As Variant)
MsgBox ("A Display event has occured")
End Sub

C++ Syntax

HRESULT OnDisplayEvent(VARIANT eventID, VARIANT windowNumber, VARIANT traceNumber)

Interface

IApplication


OnHardware Event

About Analyzer Events

OnHardwareEvent

Description

Triggered by a hardware event. See a list of Hardware Events

Note: Some Severe Events are also used as Error Messages

VB Syntax

Sub app_OnHardwareEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnHardwareEvent(ByVal eventID As Variant)
MsgBox ("A Hardware event has occured")
End Sub

C++ Syntax

HRESULT OnHardwareEvent(VARIANT eventID)

Interface

IApplication


OnMeasurement Event

About Analyzer Events

OnMeasurementEvent

Description

Triggered by a measurement event. See a list of Measurement Events.

Note: Some Severe Events are also used as Error Messages

VB Syntax

Sub app_OnMeasurementEvent(ByVal eventID As Variant, ByVal measNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

measNum

Measurement Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnMeasurementEvent(ByVal eventID As Variant, ByVal measurementNumber As Variant)

MsgBox ("A Measurement event has occured")

End Sub

C++ Syntax

HRESULT OnMeasurementEvent(VARIANT eventID, VARIANT measurementNumber)

Interface

IApplication


OnSCPI Event

About Analyzer Events

OnSCPIEvent

Description

Triggered by a SCPI event. See a list of SCPI Events

Note: Some Severe Events are also used as Error Messages

VB Syntax

Sub app_OnSCPIEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnSCPIEvent(ByVal eventID As Variant)
MsgBox ("A SCPI event has occured")
End Sub

C++ Syntax

HRESULT OnSCPIEvent(VARIANT eventID )

Interface

IApplication


OnSystem Event

About Analyzer Events

OnSystemEvent

Description

Triggered by a system event. See a list of System Events, also known as general events.

Note: Some Severe Events are also used as Error Messages

VB Syntax

Sub app_OnSystemEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnSystemEvent(ByVal eventID As Variant)
MsgBox ("A System event has occured")
End Sub

C++ Syntax

HRESULT OnSystemEvent(VARIANT eventID)

Interface

IApplication


OnUser Event

About Analyzer Events

OnUserEvent

Description

Reserved for future use.

VB Syntax

Sub app_OnUserEvent


COM_CalSet_Examples

Intro to Examples

COM CalSet program examples using C++

  • Get example, cycles through the calsets collection, printing values from each error term buffer.

  • Put example, creates a calset and a buffer using SafeArrayCreate.

  • Put and Get example, creates a calset, writes a buffer to it and reads it back.

Get example

This example cycles through the calsets collection, printing values from each error term buffer.

The example uses the methods GetErrorTermList2 and GetErrorTermByString. The methods GetStandardsList2 and GetStandardByString are used similarly.

#include "stdafx.h"
#include "atlbase.h"
using namespace std;
#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb" raw_interfaces_only, named_guids, no_namespace
inline void HR( HRESULT hr)
{
    if (FAILED(hr))
        throw hr;
}
int main()
{
    CoInitialize(NULL);
    CComPtr spPNA;
    if (FAILED(CoCreateInstance(CLSID_Application, NULL, CLSCTX_SERVER, IID_IApplication, (void**)&spPNA)))
    {
        MessageBox(NULL, "could not create PNA","",0);
        return 1;
    }
    try {

        long setCount;
        CComBSTR unfiltered("");
        // ** initialize interface handles
        CComPtr spMgr;
        HR(spPNA->GetCalManager(&spMgr ));
        CComPtr spSets;
        HR(spMgr->get_CalSets( &spSets) );   // Get the calset collection
        HR(spSets->get_Count( &setCount));
        // ** loop through the collection
        for (int i = 1; i <= setCount;i++)
        {CComVariant itemNum(i);
         CComPtr spSet;
            CComQIPtr spSet2;
            HR(spSets->Item( itemNum, &spSet  ));
            HR(spSet->QueryInterface( &spSet2 ));

            VARIANT buflist;
            HR(spSet2->GetErrorTermList2(0, unfiltered, &buflist));

            // ** loop through all the error term buffers in the calset
            VARIANT* pvStrings;
            HR(SafeArrayAccessData( buflist.parray, (void**)&pvStrings));
            for ( int bufNum = 0; bufNum <buflist.parray->rgsabound[0].cElements; bufNum++ )
            {
                VARIANT vOut;
                BSTR bufName = pvStrings[bufNum].bstrVal;
                HR(spSet2->GetErrorTermByString( 0, bufName, &vOut));
                cout	<<(LPCTSTR) CString(bufName)
                "\n";
                if
                 (vOut.parray->cDims != 2) throw 1;
                long indices[2];
                char formatted[100];
                int maxpts = vOut.parray->rgsabound[1].cElements;
                int maxparts = vOut.parray->rgsabound[0].cElements;
                for (int pt = 0; pt <maxpts; pt++)
                    {
                    indices[0]="pt;"
                    indices[1]="0;"
                    VARIANT valReal,valImag;										SafeArrayGetElement(
                    vOut.parray,indices,&valReal);
                    indices[1]++;
                    &valImag);
                    sprintf(formatted,"[%d]:%f\t%f\n",pt,valReal.fltVal,valImag.fltVal);
                    cout<<formatted;
                    }
                    HR(SafeArrayUnaccessData(buflist.parray));
                    catch(HRESULT hr)CComBSTR bstrMsg;
                    spPNA->get_MessageText((enum NAEventID) hr, &bstrMsg );
    }
    spPNA.Release();
    CoUninitialize();
    return 0;
}

Put example

This example creates a calset and a buffer using SafeArrayCreate.

The example uses the methods PutErrorTermByString method to put the buffer in the calset. The PutStandardByString is a similarly used method.

// PutErrorTermByString.cpp : Defines the entry point for the console application.
//
#include "stdafx.h"
#include "atlbase.h"

#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb" raw_interfaces_only, named_guids, no_namespace
inline void HR( HRESULT hr)
{
    if (FAILED(hr))
        throw hr;
}
using namespace std;
int main()
{
    CoInitialize(NULL);
    CComPtr spPNA;
    if (FAILED(CoCreateInstance(CLSID_Application, NULL, CLSCTX_SERVER, IID_IApplication, (void**)&spPNA)))
    {
        MessageBox(NULL, "could not create PNA","",0);
        return 1;
    }
    try {
        HR(spPNA->Preset());

        // generate a safearray of floats

        SAFEARRAYBOUND bounds[2];
         bounds[0].cElements = 201;
        bounds[0].lLbound = 0;
        bounds[1].cElements = 2;
        bounds[1].lLbound = 0;
        float realPart = 1.0;
        float imagPart = 0.0;
        long indices[2];
        long maxPts = 201;
        SAFEARRAY* psa = SafeArrayCreate( VT_R4, 2, bounds );
        for (int pt = 0 ; pt <maxpts; pt++
        )
        {
        indices[0]="pt;"
        indices[1]="1;"
        realPart +="pt;"
        HR(SafeArrayPutElement(psa,indices,(void*)&realPart));
        (void*)&imagPart));
        }
        //wrap the array in Variant
        for IDispatch complexData;
        complexData.vt="VT_ARRAY;"
        complexData.parray="psa;"
        Create a calset and put	buffer.
        CComPtr spMgr;
        spSet;
        CComQIPtr spSet2;
        HR(spPNA->GetCalManager(&spMgr ));
        HR(spMgr->CreateCalSet(1, &spSet));
        spSet2 = spSet;
        CComBSTR bufName("MyPhonyCalSet:MyPhonyBuffer");
        HR(spSet2->PutErrorTermByString( bufName, complexData));
        HR(spSet2->Save());
    }
    catch (HRESULT hr)
    {
        CComBSTR bstrMsg;
        spPNA->get_MessageText((enum NAEventID) hr, &bstrMsg );
        MessageBox( NULL, (LPCTSTR)CString(bstrMsg), "Error",MB_OK);
    }
    spPNA.Release();
    CoUninitialize();
    return 0;

Put and Get example for ICalData3

This example creates a calset, writes a buffer to it and reads it back. The example uses the methods PutErrorTermComlexByString and GetErrorTermComlexByString methods. The PutStandardComplexByString and GetStandardComplexByString methods are used similarly.

#include "stdafx.h"
#include "atlbase.h"
#include <iostream>
#include <vector>

#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb" raw_interfaces_only, named_guids, no_namespace
inline void HR( HRESULT hr)
{
    if (FAILED(hr))
        throw hr;
}
using namespace std;
int main()
{
    CoInitialize(NULL);
    CComPtr spPNA;
    if (FAILED(CoCreateInstance(CLSID_Application, NULL, CLSCTX_SERVER, IID_IApplication, (void**)&spPNA)))
    {
        MessageBox(NULL, "could not create PNA","",0);
        return 1;
    }
    try {
        HR(spPNA->Preset());

        // generate some data for our calset buffer
        std::vector<float> real(201,0);
        std::vector<float> imag(201,0);
        for (int i = 0; i <real.size(); i++)
            {
            real[i]="(float)i;"
            }
            //needed interface pointers CComPtr	<spMgr>;
        CComPtr <spset>;
        CComQIPtr <spcaldata3>;
        // Create a calset
        HR(spPNA->GetCalManager(&spMgr ));
        HR(spMgr->CreateCalSet(1, &spSet));
        spCalData3 = spSet;
        // insert a buffer
        CComBSTR bufName("Example Cal Set:Bogus Data Buffer");
        HR(spCalData3->PutErrorTermComplexByString( bufName, real.size(), &real[0], &imag[0]));
        HR(spSet->Save());
        // read the buffer back out
        long pts = real.size();
        real.assign(pts,0);
        imag.assign(pts,0);
        HR(spCalData3->GetErrorTermComplexByString( 0, bufName, &pts, &real[0], &imag[0]));
    }
    catch (HRESULT hr)
    {

        CComBSTR bstrMsg;
        spPNA->get_MessageText((enum NAEventID) hr, &bstrMsg );
        MessageBox( NULL, (char*)_bstr_t(bstrMsg.m_str), "Error",MB_OK);
    }
    spPNA.Release();
    CoUninitialize();
    return 0;
}


Intro to Examples

Getting Trace Data from the Analyzer

This Visual Basic program:

  • Retrieves Scalar Data from the Analyzer and plots it.

  • Retrieves Paired Data from the Analyzer and plots it.

  • Retrieves Complex Data from the Analyzer and plots it.

To use this code, prepare a form with the following:

  • Two MSCharts named MSChart1 and MSChart2

  • Three buttons named GetScalar, GetPaired, GetComplex

Note: You can get MSChart in Visual Basic by clicking Project / Components / Microsoft Chart Control

'Put this in a module
Public dlocation As NADataStore
Public numpts As Long
Public fmt As NADataFormat
Public app As Application
Public measData As IArrayTransfer
Public chan As Channel

Sub Form_Load()
'Change analyzerName to your analyzer's full computer name
Set app = CreateObject("AgilentPNA835x.Application", "analyzerName")

Set measData = app.ActiveMeasurement
Set chan = app.ActiveChannel

'To pick a location to get the data from remove the comment from one of these
dlocation = naRawData
'dlocation = naCorrectedData
'dlocation = naMeasResult
'dlocation = naRawMemory
'dlocation = naMemoryResult

'setup MSChart1 and MSChart2
'right click on the chart and select:
' - line chart
' - series in rows
End Sub

Sub GetComplex_Click()
ReDim Data(numpts) As NAComplex
Dim Real(201) AS Single
Dim Imag(201) AS Single
numpts = chan.NumberOfPoints

'You cannot change the format of Complex Data
Call trigger
'get data
measData.GetNAComplex dlocation, numpts, Data(0)
'plot data
Dim i As Integer

For i = 0 To numpts - 1
 Real(i) = Data(i).Re
 Imag(i) = Data(i).Im
Next i
MSChart1 = Real()
MSChart2.Visible = True
MSChart2 = Imag()
Call Sweep
End Sub

Sub GetPaired_Click()
ReDim Real(numpts) As Single
ReDim Imag(numpts) As Single
numpts = chan.NumberOfPoints

' To pick a format, remove the comment from one of these
fmt = naLogMagPhase
'fmt = naLinMagPhase
Call trigger
'Get data
measData.getPairedData dlocation, fmt, numpts, Real(0), Imag(0)
'Plot Scalar
MSChart1 = Real()
MSChart2.Visible = True
MSChart2 = Imag()
Call Sweep
End Sub

Sub GetScalar_Click()
ReDim Data(numpts) As Single

numpts = chan.NumberOfPoints
'To pick a format remove the comment from one of these
fmt = naDataFormat_LogMag
'fmt = naDataFormat_LinMag
'fmt = naDataFormat_Phase
'fmt = naDataFormat_Delay
'fmt = naDataFormat_Real
'fmt = naDataFormat_Imaginary
Call trigger
'Get data
measData.GetScalar dlocation, fmt, numpts, Data(0)
'Plot Data
MSChart1 = Data()
MSChart2.Visible = False
Call Sweep
End Sub

Sub trigger()

'The analyzer sends continuous trigger signals
app.TriggerSignal = naTriggerInternal
'The channel will only accept one, then go into hold
'Sync true will wait for the sweep to complete

sync=True

chan.Single sync
End Sub

Sub Sweep()
'The channel goes back to accepting all triggers
chan.Continuous
End Sub


Perform a Source Power Cal using COM

This program can be run in either Visual Basic 6 or as a VBScript program. The PNA can run *.vbs programs as macros.

This program demonstrates:

  • Performing a source power calibration of Port 2 for Channel 1.

  • Reading the calibration data.

Learn more about Power Calibrations

See an example that Uploads a Source Power Cal

See Other COM Example Programs

To run this program, you need:

  • One of the following power meters connected to the PNA through GPIB: E4416A, E4417A, E4418A/B, E4419A/B, 437B, 438A, EPM-441A, EPM-442A

Note: If your power meter is other than these, you can create your own Power Meter Driver using our template.

  • Your PC and PNA both connected to a LAN (for communicating with each other).

To make this program work in VBS, save the following code in a text editor file such as Notepad and save as *.vbs.

To make this program work in Visual Basic 6:

  1. Create a new project

  2. Click Project, Add New Module, click Open.

  3. Paste the following code into the code window.

  4. Delete the first two lines (comment and Main)

  5. Click Project, Properties. Under Startup Object, select Sub Main

  6. Click Project, References, and select the Agilent PNA Series Type Library.

' Run the Main subroutine
Main
Public Sub Main()
Dim PNA, chan, pwrcal ' PNA COM objects
Const naPowerMeter = 0, naPowerMeterAndReceiver = 1 ' enum NASourcePowerCalMethod
Const naPowerSensor_A = 0 ' enum NAPowerAcquisitionDevice
Const naCorrectionValues = 0 ' enum NASourcePowerCalBuffer
Const port = 2 ' PNA port #2 as source port
Const offset = 0 ' cal power offset value
Const bDisplay = True ' whether to display data during acquire
Dim stimulus, calvalues, strResult

' Instantiate our PNA COM objects
Set PNA = CreateObject("AgilentPNA835x.Application")
Set chan = PNA.Channels(1)
Set pwrcal = PNA.SourcePowerCalibrator

' Set the number of sweep points to 21 on Channel 1.
chan.NumberOfPoints = 21

' Specify the GPIB address of the power meter
' that will be used in performing the calibration.
pwrcal.PowerMeterGPIBAddress = 13

' Turn use of the loss table OFF (this assumes there is
' virtually no loss in the RF path to the power sensor
' due to a splitter, coupler or adapter).
pwrcal.UsePowerLossSegments = False

' Turn frequency checking OFF (so one power sensor is used for the entire cal
' acquisition sweep regardless of frequency span).
pwrcal.UsePowerSensorFrequencyLimits = False

' Specify a nominal power accuracy tolerance (IterationsTolerance) in dB for the
' calibration, and the maximum number of iterations to adjust power at each point,
' attempting to achieve within tolerance of the desired power. If at any stimulus
' point the power fails to reach within the set tolerance of the desired power
' after the maximum number of iterations, the power at that point will be set to the
' value determined by the last iteration (the Source Power Cal dialog box will
' indicate the FAIL, but we can still apply the cal if desired when it's complete).
' Each iteration is based upon a SETTLED power reading (see comments preceding the
' next two properties below).
pwrcal.IterationsTolerance = 0.1
pwrcal.MaximumIterationsPerPoint = 3

' The worst-case window of power uncertainty (for a calibration which meets
' tolerance) is the sum of the iteration tolerance and the power meter settling
' tolerance (which is described below).
' At each stimulus point, the PNA takes power meter readings and determines when
' they have settled by comparing the magnitude difference between consecutive
' readings versus a nominal dB tolerance limit (ReadingsTolerance) on that magnitude
' difference. When consecutive readings are within tolerance of each other, or
' if they are not within tolerance but we've taken a maximum number of readings
' (ReadingsPerPoint), the PNA does a weighted average of the readings taken at that
' stimulus point and that is considered our settled power reading.
pwrcal.ReadingsTolerance = 0.1
pwrcal.ReadingsPerPoint = 5

' Setup of information pertaining to this specific cal acquisition. Includes the
' method (type of devices) that will be used to perform the cal -- choose either
' naPowerMeter or naPowerMeterAndReceiver. naPowerMeterAndReceiver uses the power
' meter for the first iteration of each point and the PNA's reference receiver for
' subsequent iterations, so is much faster than using power meter only naPowerMeter).
' But the power meter accounts for compression when calibrating at the output of an
' active device, whereas the reference receiver cannot unless it is coupled to the
' cal reference plane (on a PNA which allows direct access to the receivers).
' 'offset' specifies if the cal power level is offset (positive value for a gain,
' negative value for a loss) from the PNA port power setting on the channel when
' no source power cal is active. This is to account for components between the PNA
' test port and cal reference plane. In this example, we will calibrate at the PNA
' test port, so there is no offset (it is zero).
' 'bDisplay' indicates whether to display the source power cal dialog during the
' source power cal acquisition (the dialog will chart the corrected power readings).
pwrcal.SetCalInfo2 naPowerMeter, chan.channelNumber, port, offset, bDisplay

' Perform synchronous source power cal acquisition sweep using the sensor attached
' to Channel A of the power meter. This assumes that the power sensor is already
' connected to Port 2 of the PNA.
pwrcal.AcquirePowerReadings naPowerSensor_A, True

' Conclude the calibration. This applies the cal data to PNA channel memory,
' and turns the correction ON for Port 2 on Channel 1, but does NOT save the
' calibration.
pwrcal.ApplyPowerCorrectionValues

' At this point, if you choose to save the instrument state as a ".CST" file,
' the calibration will be saved with the instrument state in that file.
' Read the stimulus values from Channel 1.
stimulus = chan.GetXAxisValues

' Read the source power correction data.
calvalues = chan.getSourcePowerCalDataEx(naCorrectionValues, port)

' Print the data using a message box (here, Chr returns the ASCII characters
' for Tab (9) and Linefeed (10)).
strResult = "Stimulus" & Chr(9) & Chr(9) & "Cal Value" & Chr(10)
For i = 0 To UBound(stimulus)
strResult = strResult & stimulus(i) & Chr(9) & calvalues(i) & Chr(10)
Next
MsgBox strResult
End Sub


Upload a Source Power Cal using COM

This program can be run in either Visual Basic 6 or as a VBScript program. The PNA can run *.vbs programs as macros.

This program demonstrates:

  • Uploading a source power calibration of Port 2 for Channel 1.

  • Reading the calibration data.

Learn more about Power Calibrations

See Other COM Example Programs

To run this program you need:

  • Your PC and PNA both connected to a LAN (for communicating with each other).

To make this program work in VBS, save the following code in a text editor file such as Notepad and save as *.vbs.

To make this program work in Visual Basic 6:

  1. Create a new project

  2. Click Project, Add New Module, click Open.

  3. Paste the following code into the code window.

  4. Delete the first two lines (comment and Main)

  5. Click Project, Properties. Under Startup Object, select Sub Main

  6. Click Project, References, and select the Agilent PNA Series Type Library.

' Run the Main subroutine
Main
Public Sub Main()
Dim PNA, chan ' PNA COM objects
Const naCorrectionValues = 0 ' enum NASourcePowerCalBuffer
Const port = 2 ' PNA port #2 as source port
Dim stimulus, calvalues
Dim power, calpower, strResult
' Instantiate our PNA COM objects
Set PNA = CreateObject("AgilentPNA835x.Application")
Set chan = PNA.Channels(1)

' Set the number of sweep points to 2 on Channel 1.
chan.NumberOfPoints = 2

' Ensure there's currently no source power cal on for this channel and port.
chan.SourcePowerCorrection(port) = False

' Specify if the cal power level is offset (positive value for a gain, negative
' value for a loss) from the PNA port power setting on the channel when
' no source power cal is active. This is to account for components
' between the PNA test port and cal reference plane.
' In this example, let's set up our calibration
' at the output of an amplifier with 15 dB gain.
chan.SourcePowerCalPowerOffset(port) = 15

' Send our source power correction data to the PNA. For purpose of simplicity
' in this example, we'll set up for no correction (0) at our start stimulus and
' 0.5 dB at our stop stimulus (recall that our sweep currently has just 2 points).
calvalues = Array(0, 0.5)
chan.putSourcePowerCalDataEx naCorrectionValues, port, calvalues

' Set the number of sweep points to 21 on Channel 1.
chan.NumberOfPoints = 21

' Read the fixed power level for this port on Channel 1.
power = chan.TestPortPower(port)

' Turn the source power cal on.
chan.SourcePowerCorrection(port) = True

' Again read the fixed power level for this port on Channel 1
' (with our calibration turned on, this should now include the 15 dB offset
' we indicated our power amplifier provides).
calpower = chan.TestPortPower(port)

' Read the stimulus values from Channel 1.
stimulus = chan.GetXAxisValues

' Read back the source power correction data, now interpolated for 21 points
calvalues = chan.getSourcePowerCalDataEx(naCorrectionValues, port)

' Print the data using a message box (here, Chr returns the ASCII characters
' for Tab (9) and Linefeed (10)).
strResult = "PNA port power = " & power & Chr(10)
strResult = strResult & "Power at reference plane = " & calpower & Chr(10) & hr(10)
strResult = strResult & "Stimulus" & Chr(9) & Chr(9) & "Cal Value" & Chr(10)
For i = 0 To UBound(stimulus)
strResult = strResult & stimulus(i) & Chr(9) & calvalues(i) & Chr(10)
Next
MsgBox strResult
End Sub


Upload Segment Table Example

Upload Segment Table

This VBScript program does the following:

  • Creates an array of segment data

  • Fills the array with start and stop frequencies, number of points, IFBW, and port power for each segment.

  • Uploads the array to the PNA

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save the file on the PNA hard drive as segTable.vbs. Learn how to setup and run the macro.

See Other COM Example Programs

' Create the application
 instance, and preset the application
Set app = CreateObject("AgilentPNA835x.Application")
app.Preset
Dim chan
Set chan = app.ActiveChannel
chan.sweeptype = 4

'To specify uncoupled (separate) port power, set the following to 0
chan.CouplePorts = 1

Dim segs
Set segs = chan.Segments
Dim win
Set win = app.NAWindows(1)
win.ShowTable 2

' Multipliers
kHz = 1000
MHz = kHz*1000
GHz = MHz*1000

' Create segments from 10MHz to 3GHz
StartFreq = 10 * MHz
StopFreq  =
  3 * GHz
'
' Number of segments to create
numSegs = 20

'Create a 2-D array of segments.
'  1st dimension
 is number of settings; 9
'  2nd dimension
 is number of segments.
'  Each dimension
 is set to 1 less than desired size to allow for index 0
Dim segdata
ReDim segData(9, numSegs-1)
' Width of frequency segment, used below
SegmentWidth = (StopFreq-StartFreq)/10

' Fill all segments with data
For i = 0 To numSegs-1
' element 0=segment state (True-on | False-off)
segdata(0, i) = True

' element 1=Num Points in this segment
segdata(1, i) = 100

' element 2=Start Freq in Hz
segdata(2, i) = StartFreq + i * SegmentWidth

' element 3=Stop Freq in Hz
segdata(3, i) = segdata(2, i) + SegmentWidth

' element 4=IFBW in Hz
segdata(4, i) = 35000

' element 5=Dwell Time in sec
segdata(5, i) = 0

' element 6=Port 1 Power to -1 dBm
segdata(6, i) = -1

'The following 3 values are ignored if port power is coupled.
' element 7=Port 2 Power to -2 dBm
segdata(7, i) = -2

'The following 2 values are ignored on a 2-port PNA
' element 8=Port 3 Power to -3 dBm
segdata(8, i) = -3

' element 9=Port 4 Power to -4 dBm
segdata(9, i) = -4

Next

'Configure Independent segment settings
'Independent Dwell time setting is not currently available
segs.IFBandwidthOption = True
segs.SourcePowerOption = True

' Push the segment data into the PNA's Active Channel
segs.SetAllSegments segdata


Create and Cal an SMC Measurement

This example uses the creates and calibrates an SMC measurement. To run this example without modification you need the following:

  • A Mixer setup file saved on the PNA: C:\Program Files\Agilent\Network Analyzer\Documents\Mixer\MyMixer.mxr.

  • If the mixer file uses an external LO source, it must also be attached and configured.

  • An ECAL module that covers the frequency range of the measurement.

  • A power meter must be connected to the PNA using GPIB.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save on the PNA hard drive as SMC.vbs. Learn how to setup and run the macro.

See Other COM Example Programs

Dim App
Set App = CreateObject("AgilentPNA835x.Application")
Dim Meas
Set Meas = App.ActiveMeasurement
Meas.Delete

App.CreateCustomMeasurementEx 1, "SMC_Forward.SMC_ForwardMeas","SC21"
'Other valid strings that can be specified to create a measurement with a parameter 'other than'"SC21" are: "S11", "S22", "IPwr", and "OPwr"

Set Meas = App.ActiveMeasurement
'You can perform mixer setup here or
'recall a previous mixer setup from the PNA Hard drive
'Here are some basic mixer setup commands
Dim mix
Set mix = Meas

'Load your own SMC measurement from the PNA Hard drive.
Meas.LoadFile "C:\Program Files\Agilent\Network Analyzer\Documents\Mixer\MyMixer.mxr"

Dim CalMgr
Set CalMgr = App.GetCalManager
Dim SMC
Set SMC = CalMgr.CreateCustomCal("SMC")
SMC.Initialize 1, 1
SMC.Do2PortEcal = 1 'specify 0 for mechanical cal, 1 for ecal
'use Factory Characterization
SMC.ECALCharacterization(1) = 0
'only specify the ThruCalMethod if you have a non-insertable DUT
'SMC.ThruCalMethod = "Adapter Removal"
'If you specify Adapter Removal or Unknown Thru calibration
'then you need to specify the connector types of your DUT.
'Specify a connector that is the same type as your selected
'ECAL characterization. The characterization selected in
'this case is APC 2.4 female APC 2.4 male so the connectors
'specified for my DUT have to be APC 2.4 but can be any sex.
'SMC.ConnectorType(1) = "APC 2.4 female"
'SMC.ConnectorType(2) = "APC 2.4 female"
SMC.OmitIsolation = 1
SMC.AutoOrient = 1
' 1- forward, 2-reverse, or Both
SMC.CalibrationPort = "1"

Dim steps
steps = SMC.GenerateSteps
For i = 1 To steps
MsgBox SMC.GetStepDescription(i)
SMC.AcquireStep i
Next

Dim calset
calset = SMC.GenerateErrorTerms
Msgbox("SMC Cal Complete!")


Create and Cal a VMC Measurement

The following VMC calibration options are presented in VB Script examples:

  • Full 2-port ECAL

  • For Mixer Characterization ONLY

  • Mechanical Calibration

Note: Each of the following programs load a mixer setup file.
Substitute "Mixer009.mxr" with your own .mxr file.

Full 2-port ECAL

Dim App
Set App = CreateObject("AgilentPNA835x.Application")
Dim Meas
Set Meas = App.ActiveMeasurement
Meas.Delete

App.CreateCustomMeasurementEx ( 2, "FCA.VMCMeas", "VC21"
 )
'Other valid strings that can be specified to create a measurement with
 a parameter other than"VC21" are: "S11", and "S22"
Set Meas = App.ActiveMeasurement

Meas.LoadFile "C:\\Program Files\\Agilent\\Network Analyzer\\Documents\\mixer\\Mixer009.mxr"

Dim CalMgr
Set CalMgr = App.GetCalManager
Dim VMC
Set VMC = CalMgr.CreateCustomCal("VMC")
VMC.Initialize 1, 1
VMC.Do2PortEcal = 1
VMC.Do1PortEcal = 1
VMC.ECALCharacterization(1, 1) = 0 'APC 2.4 male APC 2.4 female
VMC.ECALCharacterization(1, 0) = 0
' could be Default, Flush Thru, Unknown Thru, or Adapter Removal
VMC.ThruCalMethod = "Adapter Removal"
VMC.OmitIsolation = 1
VMC.AutoOrient = 1
VMC.EcalOrientation1Port(1) = "A1"
VMC.CharacterizeMixerOnly = 0
VMC.LoadCharFromFile = 0
' to load mixer characterization from file, specify LoadCharFromFile =
 1,
' then VMC.CharFileName = "C:\\Program Files\\Agilent\\Network
' Analyzer\\Documents\\YourFile.s2p" (specify your own .s2P filename)

VMC.ConnectorType(1) = "APC 2.4 female"
VMC.ConnectorType(2) = "APC 2.4 female"

Dim steps
steps = VMC.GenerateSteps
For i = 1 To steps
MsgBox VMC.GetStepDescription(i)
VMC.AcquireStep i
Next

Dim calset
calset = VMC.GenerateErrorTerms

Mixer Characterization ONLY

Dim App
Set App = CreateObject("AgilentPNA835x.Application")
Dim Meas
Set Meas = App.ActiveMeasurement
Meas.Delete
app.CreateCustomMeasurementEx ( 2, "FCA.VMCMeas", "VC21"
 )
'Other valid strings that can be specified to create a measurement with
 a parameter other than "VC21" are: "S11", and "S22"

Set Meas = App.ActiveMeasurement
Meas.LoadFile "C:\\Program Files\\Agilent\\Network Analyzer\\Documents\\mixer\\Mixer009.mxr"

Dim CalMgr
Set CalMgr = App.GetCalManager
Dim VMC
Set VMC = CalMgr.CreateCustomCal("VectorMixerCal.VMCType")
VMC.Initialize 1, 1
VMC.Do2PortEcal = 1
VMC.Do1PortEcal = 1
VMC.ECALCharacterization(1, 1) = 0
VMC.ECALCharacterization(1, 0) = 0
VMC.ThruCalMethod = "Default"
VMC.OmitIsolation = 1
VMC.AutoOrient = 1
VMC.EcalOrientation1Port(1) = "A1"
VMC.CharacterizeMixerOnly = 1
VMC.LoadCharFromFile = 0
VMC.CharFileName = "C:\\Program Files\\Agilent\\Network Analyzer\\Documents\\MyMixerChar.s2p"

Dim steps
steps = VMC.GenerateSteps
For i = 1 To steps
MsgBox VMC.GetStepDescription(i)
VMC.AcquireStep i
Next

Dim calset
calset = VMC.GenerateErrorTerms
MsgBox VMC.CharFileName

Mechanical Calibration

Dim App
Set App = CreateObject("AgilentPNA835x.Application")
Dim Meas
Set Meas = App.ActiveMeasurement
Meas.Delete
app.CreateCustomMeasurementEx ( 2, "FCA.VMCMeas", "VC21"
 )
'Other valid strings that can be specified to create a measurement with
 a parameter other than "VC21" are: "S11", and "S22"

Set Meas = App.ActiveMeasurement
Meas.LoadFile "C:\\Program Files\\Agilent\\Network Analyzer\\Documents\\mixer\\Mixer009.mxr"
Dim CalMgr
Set CalMgr = App.GetCalManager
Dim VMC
Set VMC = CalMgr.CreateCustomCal("VectorMixerCal.VMCType")
VMC.Initialize 1, 1
VMC.Do2PortEcal = 1
VMC.Do1PortEcal = 0
VMC.ECALCharacterization(1, 1) = 0
VMC.ThruCalMethod = "Default"
VMC.OmitIsolation = 1
VMC.AutoOrient = 1
VMC.CharacterizeMixerOnly = 0
VMC.LoadCharFromFile = 0
VMC.ConnectorType(1) = "APC 3.5 female"
VMC.ConnectorType(2) = "APC 3.5 male"
VMC.CalKitType(1) = "85033D/E"
VMC.CalKitType(2) = "85033D/E"

Dim steps
steps = VMC.GenerateSteps
For i = 1 To steps
MsgBox VMC.GetStepDescription(i)
VMC.AcquireStep i
Next

Dim calset
calset = VMC.GenerateErrorTerms


Create an SMC Fixed Output Meas

Create an SMC Fixed Output Measurement

This Visual Basic example creates a calibrated SMC fixed output measurement using a controlled LO. Then a single sweep is taken and data is retrieved.

Fixed output measurements are only supported on SMC (not VMC) measurements. Fixed output measurements require that an external LO source be sweeping and synchronized with the PNA source. FCA can perform this synchronization using the external source configuration settings. The fastest, and recommended, method of controlling the LO source is Hardware List (BNC) triggering mode. However, in this mode, FCA channels will not respond to manual triggers. Therefore, the following example uses the "Single" IChannel::Single mechanism to trigger a sweep.

Both VMC and SMC measurements require that mixer parameters be setup before making the measurement. The mixer parameters are not applied until calling IMixer::Calculate.

You can also setup the mixer parameters using IMixer::LoadFile. With this interface, the specified mixer file is loaded and immediately applied.

option explicit
dim app
set app = createobject("agilentpna835x.application")
app.preset

' Put the channel in hold (highly recommended)
app.ActiveChannel.Hold 1

' Select calibration. Apply stimulus settings to the channel
app.ActiveChannel.SelectCalSet "{C9080B34-EF1F-4ED5-B07D-250B45962B99}",1

' Delete the standard measurement
app.ActiveMeasurement.Delete

' Create an SC21 measurement
app.CreateCustomMeasurementEx 1, "SMC_Forward.SMC_ForwardMeas","SC21"

' Set the number of points to 11
app.ActiveChannel.NumberOfPoints = 11

' Setup the mixer parameters for a swept LO, fixed output measurement

dim mixer
set mixer = app.ActiveMeasurement
mixer.InputStartFrequency = 200e6
mixer.InputStopFrequency = 700e6
mixer.LORangeMode(1) = 0 ' 0 = Swept mode
mixer.OutputFixedFrequency = 3.4e9
mixer.InputPower = -17
mixer.LOPower(1) = 10

' Specify the LO name, for controlled LO. This name can be setup in the External Source Config Dialog
mixer.LOName(1) = "8360"

' The CALC method calculates the LO frequency from the other parameters,
' It also applies ALL mixer parameters to the channel.
mixer.Calculate 3 ' Calculate the LO range

' Create an S11 in the same channel
app.CreateCustomMeasurementEx 1, "SMC_Forward.SMC_ForwardMeas","S11"
dim S11Meas
set S11Meas = app.ActiveMeasurement

' Create an IPwr in the same channel
app.CreateCustomMeasurementEx 1, "SMC_Forward.SMC_ForwardMeas","IPwr"

' Create an OPwr in the same channel
app.CreateCustomMeasurementEx 1, "SMC_Forward.SMC_ForwardMeas","OPwr"

' Perform a single sweep synchronously.
app.ActiveChannel.Single 1
function ToString(complexDataArray)
dim dataAsString
dim point
for point = 0 to UBound(data)
dataAsString = dataAsString & "(" & data(point,0) & "," & data(point,1) & ") "
next
ToString = dataAsString
end function

' Retrieve the SC21 data
dim data
'Get the calibrated real/imaginary values
data = mixer.GetData(1,3)
wscript.echo ToString(data)

' Retrieve the S11 data
'Get the calibrated real/imaginary values
data = S11Meas.GetData(1,3)
wscript.echo ToString(data)


Create a Pulsed Measurement

The following example demonstrates how to create a pulsed measurement using the Pulsed Application DLL. It first gets valid configuration settings and then uses those settings to configure the PNA and external pulsed generators.

To run this program, you need:

  • Pulsed Application (Option H08)

  • IF Access (Option H11)

  • External Pulse Generators

  • External Pulse Modulator / Pulse Bias

Learn how to install and register the pulsed .dll on your PC

See the ConfigureNarrowBand3 Method for sending and returning parameters to the .dll.

See the documentation for the following COM IF Configuration commands.

See the SCPI IF Configuration commands.

Learn about the Pulsed Application.

'Interfaces
Dim OApp As AgilentPNA835x.Application
Dim OIF As AgilentPNA835x.IFConfiguration

'Pulsed parameters
Dim DPRF As Double
Dim DOffset As Double
Dim DSampleRate As Double
Dim LNumTaps As Long
Dim LBW As Long
Dim IPrecision as Integer
Dim BPG81110 As Boolean
Dim BFixedPRF As Boolean

'pulsed DLL interface
Dim OPulsed As New AgilentPNAPulsed.Application
DPRF=5123 'Hz
LBW=100 'Hz
BPG81110=True 'Using the Agilent 81110A Pulse Generator
BFixedPRF=True 'Do not change the PRF during filter alignment. Only adjust the IFBW.

'Calculate precision of pulse generators so that the config function returns the correct precision with the right filter. For example, DPRF=5000 Hz with a pulse generator that will only take a total of four numeric values
' (5.123 kHz)
'->log10(DPRF)=3.709
'->int(3.709)=3
'->3-3=0

'The algorithm will use a 10^x value for decrementing the PRF for null computation. This means that the first numeric digit from the right should be the one that is decremented by the pulsed algorithm (i.e. 5.122 kHz) to compute the filter nulls. This ensures that the pulse generators receive a PRF that is within their precision with the associated nulling IFBW.
IPrecision = Int(Flog10(CSng(DPRF))) - 3

'Send desired pulsed parameters to the pulsed configuration DLL. The DLL will return a new set of pulse parameters that provide the proper filter nulling.
OPulsed.ConfigNarrowBand3 DPRF, LNumTaps, LBW, DOffset, DSampleRate, IPrecision, BFixedPRF,BPG81110

'Send configuration to PNA

'Connect to the PNA application
Set OApp = CreateObject("AgilentPNA835x.Application")
Set OIF = OApp.ActiveChannel.IFConfiguration

'Set PNA IFBW close to that returned by pulsed algorithm. This ensures that the proper settling time is set on the PNA.

OApp.ActiveChannel.IFBandwidth = LBW
OIF.IFFilterSamplePeriodMode = naMANUAL
OIF.IFFilterSamplePeriod = DSampleRate
OIF.IFFilterSource = naIFFilterSourceManual
OIF.IFFilterSampleCount = LNumTaps
OIF.IFGateEnable = True
OApp.ActiveChannel.FrequencyOffsetState = naON
OApp.ActiveChannel.FrequencyOffsetFrequency = DOffset

'Set receivers to medium gain setting

OIF.IFGainMode("ALL") = naMANUAL
OIF.IFGainLevel("A") = 1
OIF.IFGainLevel("B") = 1
OIF.IFGainLevel("R1") = 1
OIF.IFGainLevel("R2") = 1

Public Function Flog10(SGNum As Single) As Single
Flog10 = Log(SGNum) / Log(10)
End Function

'Enter Code here to send configuration to external pulse generators


ECAL Confidence Check Example with COM

ECAL Confidence Check

This Visual Basic program:

  • Initializes the PNA objects.

  • Performs a complete ECAL confidence check

Before using this code:

  • The active channel must contain an S11 measurement with a 1-port or N-port calibration

  • Prepare a form with two buttons named cmdRun and cmdQuit

Private oPNA As AgilentPNA835x.Application

Private oChan As Channel

Private oCal As Calibrator

Private oMeas As Measurement

Private Sub cmdRun_Click()

Dim iMeasIndex As Integer

Set oPNA = CreateObject("AgilentPNA835x.Application", "MachineName")

Set oChan = oPNA.ActiveChannel

Set oCal = oChan.Calibrator

iMeasIndex = 1

' Loop through measurements until an S11 on the active channel

' is found, or the end of the measurement collection is reached.

Do

Set oMeas = oPNA.Measurements(iMeasIndex)

If oMeas.Parameter = "S11" And _

oMeas.channelNumber = oChan.channelNumber Then Exit Do

iMeasIndex = iMeasIndex + 1

If iMeasIndex > oPNA.Measurements.Count Then

MsgBox "No S11 measurement found on the active channel." _

& " Create an S11 measurement, then try again."

Exit Sub

End If

Loop

' Set up trace view so we are viewing only the data trace.

oMeas.View = naData

' Acquire the S11 confidence check data from ECal Module A

' into the memory buffer.

oCal.AcquireCalConfidenceCheckECALEx "S11", 1

' Turn on trace math so the trace shows data divided by memory.

' You can be confident the S11 calibration is reasonably good if

' the displayed trace varies no more than a few tenths of a dB

' from 0 dB across the entire span.

oMeas.TraceMath = naDataDivMemory

End Sub

Sub cmdQuit_Click()

' Turn off trace math

' in case someone clicks Quit without having clicked Run

If oMeas <> Nothing Then oMeas.TraceMath = naDataNormal

' Conclude the confidence check to set the ECal module

' back to it's idle state.

If oCal <> Nothing Then oCal.DoneCalConfidenceCheckECAL

' End the program

End

End Sub


Limit Line Testing Example with COM

Intro to Examples

Limit Line Testing with COM

This Visual Basic program:

  • Turns off existing Limit Lines

  • Establishes Limit Lines with the following settings:

    • Frequency range - 4 GHz to 8 GHz

    • Maximum value - (10dB)

    • Minimum value - (-30dB)

  • Turns on Lines, Testing, and Sound

If using Global Pass/Fail to report limit results, trigger the PNA after configuring and enabling Limit lines.

Public limts As LimitTest
Set limts = meas.LimitTest
'All Off
For i = 1 To 20
limts(i).Type = naLimitSegmentType_OFF
Next i

'Set up Limit Lines
limts(1).Type = naLimitSegmentType_Maximum
limts(1).BeginResponse = 10
limts(1).EndResponse = 10
limts(1).BeginStimulus = 4000000000#
limts(1).EndStimulus = 8000000000#
limts(2).Type = naLimitSegmentType_Minimum
limts(2).BeginResponse = -30
limts(2).EndResponse = -30
limts(2).BeginStimulus = 4000000000#
limts(2).EndStimulus = 8000000000#

'Turn on Lines, Testing, and Sound
limts.LineDisplay = 1
limts.State = 1
limts.SoundOnFail = 1


COM Events Example

This Visual Basic program shows how to monitor the end of sweep.

The program will set sweep time to various amounts and BEEPs when sweep is completed. This method allows other processes to continue while waiting for end-of-sweep. This program stops after 10 loops.

Note: To avoid Permission Denied problems, this should be run on the PNA and not a PC. To run it from a PC both units must be "trusted" and on the same domain/workgroup.

Option Explicit
Dim na As AgilentPNA835x.Application
Dim WithEvents naEvnt As AgilentPNA835x.Application
Dim ch As AgilentPNA835x.Channel
Dim sweepComplete As Boolean

Private Sub Form_Load()

Dim N As Integer
Set na = CreateObject("AgilentPNA835x.application")
na.preset
Set ch = na.ActiveChannel
na.DisallowAllEvents ' Turn off all events
Set naEvnt = na ' Enable event interrupts
Do
N = N + 1 ' Loop counter
ch.sweepTime = 1 + (Rnd * 9) ' Set random sweep-time from 1-10 sec
sweepComplete = False
ch.Single False ' Trigger sweep
naEvnt.AllowEventCategory naEventCategory_CHANNEL, True ' Enable Channel event
Do
DoEvents ' Allows other processes to continue
Loop Until sweepComplete = True
naEvnt.AllowEventCategory naEventCategory_CHANNEL, False ' Disable event until ready for next one
Beep ' Do end-of-sweep processing here;

Loop Until N > 10
End

End Sub

Private Sub naEvnt_OnChannelEvent(ByVal eventID As Variant, ByVal chNumber As Variant)
' In this example we don't care about the channel info
If eventID = naEventID_CHANNEL_TRIGGER_COMPLETE Then sweepComplete = True
End Sub


Конфигурирование COM-DCOM

Перед разработкой или запуском COM-программы необходимо установить соединение между ПК и анализатором. Этот процесс необходим для получения доступа к анализатору. На ПК необходимо зарегистрировать библиотеку типов PNA.

DCOM (объектная модель распределённых компонент) отвечает за доступ к PNA с удаленного ПК.

COM (объектная модель компонент) отвечает за доступ к PNA с ПК анализатора.

  • Организация доступа

  • Процедуры доступа

  • Регистрация библиотеки типов PNA на ПК

  • Проблемы?

Примечание: Для доступа к новым функциям COM после обновления прошивки необходимо скопировать новую библиотеку типов на ПК разработки. См. Регистрация анализатора на ПК (Register the analyzer on your PC).

Другие разделы по технологии COM

Для получения более подробной информации см. http://na.tm.agilent.com/pna/DCOMSecurity.html

Организация доступа

Анализаторы PNA поставляются с предустановленными правами доступа и запуска приложения PNA для группы пользователей Everyone. Понятие Everyone означает различные диапазоны пользователей, в зависимости от того, куда входит PNA, в домен или рабочую группу (должно быть одно или другое; не оба). По умолчанию PNA конфигурируется как член рабочей группы. Следовательно, Everyone включает только тех пользователей, которым была выдана учетная запись на PNA.

Рабочая группа

Рабочая группа устанавливается администратором PNA. При этом задается имя рабочей группы, а PNA конфигурируется как член этой рабочей группы. Рабочая группа не требует создания и управления сетевым администратором.

Everyone включает только тех пользователей, которым была выдана учетная запись на PNA.

По умолчанию PNA конфигурируется как член рабочей группы WORKGROUP.

Примечание: Для создания учетной записи нового пользователя см. Дополнительные пользователи (Additional Users).
Самый простой способ организации доступа по DCOM – задать на PNA имя пользователя и пароль, совпадающие с учетной записью на удаленном ПК.

Домен

Домен обычно представляет собой большую организованную группу компьютеров. Поддержкой домена и добавлением в него новых компьютеров занимаются сетевые администраторы.

Everyone в данном случае ссылается на пользователей, зарегистрированных в домене. Кроме того, к анализатору также имеют доступ пользователи с учетными записями.

Общие сведения

  • Рабочая группа не требует обслуживания, однако позволяет DCOM-доступ только пользователям, имеющим учетную запись на PNA.

  • Домен требует административного обслуживания, однако все пользователи домена со своими учетными записями имеют DCOM-доступ к PNA.

В разделе "Процедуры доступа" описана более безопасная конфигурация, разрешающая DCOM доступ (Access Procedures) и запуск (Launch) только выбранным (не Everyone) пользователям домена и рабочей группы.

Процедуры доступа

Выполните эту процедуру для следующих действий:

  • Разрешить удаленный доступ и запуск PNA выбранным (не всем) пользователям. Разрешение запуска позволяет запускать приложение PNA, если оно еще не открыто.

  • Для проверки DCOM-доступа к анализатору.

Примечание: Перед выполнением этой процедуры необходимо иметь учетную запись на PNA. См. Учетные записи PNA ( PNA User Accounts).

Приведенная ниже процедура назначает выбранным пользователям права запуска и доступа DCOM к приложению PNA:

Перед выполнением этой процедуры приложение PNA необходимо свернуть.

Как определить имеющуюся операционную систему?

Windows 2000

Windows XP

Нажмите кнопку Windows Start на PNA button

Нажмите кнопку Windows Start на PNA

Нажмите Run

Нажмите Run

В диалоге Open: введите dcomcnfg

В диалоге Open: введите dcomcnfg

Нажмите OK

Нажмите OK

В окне Distributed COM Configuration Properties выберите из списка приложений Agilent PNA Series. Нажмите Properties...

Откройте следующую последовательность папок:

Окно Component Services

Component Services

Computers

My Computer

DCOM Config

Щелкните правой кнопкой мыши на Agilent PNA Series

Нажмите Properties

Нажмите закладку Security

Нажмите закладку Security

Выберите Use custom access permissions и нажмите Edit

В разделе Access Permissions, выберите Customize, и нажмите Edit

В разделе Registry Value Permissions, выберите Everyone, и нажмите Remove

Выберите Everyone, и нажмите Remove

Нажмите Add

Нажмите Add

Выберите одну или несколько групп или конкретных пользователей, которым будет назначен доступ к PNA. Для назначения указанному пользователю доступа нажмите Show users или Members и выберите имя из списка.

Введите имя группы или имя учетной записи пользователя

Нажмите Add, после этого нажмите OK

Нажмите OK

Разрешение запуска

Выберите Use custom launch permissions, и нажмите Edit

В разделе Launch Permissions, выберите Customize, и нажмите Edit

В разделе Registry Value Permissions, выберите Everyone и нажмите Remove

Выберите Everyone, и нажмите Remove

Нажмите Add

Нажмите Add

Выберите одну или несколько групп или конкретных пользователей, которым будет назначено право запуска PNA.

  • Для назначения группе прав запуска, выберите группу из списка.

  • Для назначения прав запуска указанному пользователю нажмите Show users или Members, и выберите имя из списка.

Введите имя группы или имя учетной записи пользователя

Нажмите Add, после этого нажмите OK

Нажмите OK

Регистрация библиотеки типов PNA на ПК

Библиотека типов содержит объектную модель PNA. На ПК находится файл реестра, в котором хранится информация об объектных моделях. Поэтому перед разработкой и выполнением программы на ПК необходимо зарегистрировать библиотеку типов. Наиболее эффективно регистрировать библиотеку типов на этапе разработки (перед запуском COM-программы).

Перед началом работы необходимо:

  1. Подключить ПК и PNA к локальной сети.

  2. Подсоедините сетевой диск к анализатору или скопируйте файлы библиотеки типов на гибкий диск или другой носитель. См. Подсоединение дисков (Drive Mapping.)

Примечание: Для регистрации библиотеки типов на ПК необходимо войти в систему с правами администратора. См. Учетные записи пользователей (User Accounts.)

Процедура выполняет следующие действия:

  • Регистрирует приложение Network Analyzer на ПК.

  • Копирует и регистрирует proxystub (835xps.DLL) на ПК.

  • Копирует и регистрирует библиотеку типов PNA (835x.tlb) на ПК.

  • Копирует и регистрирует библиотеку типов FCA (fca.tlb) на ПК.

  1. При помощи проводника Windows найдите диск C: анализатора. Этот диск не будет называться "C:" на Вашем ПК ему будет присвоена буква, назначенная при подключении.

  2. Перейдите в папку Program Files \ Agilent \ Network Analyzer \ Automation

  3. Дважды щелкните на pnaproxy.exe и следуйте инструкциям для установки PNA Proxy. Если при установке будет запрошено Modify (модифицировать), Repair (восстановить), или Remove (удалить), выберите Remove. После этого снова дважды щелкните на pnaproxy.exe.

  4. В процессе установки введите имя компьютера PNA (как узнать имя).

  5. После завершения программы установки библиотеки типов PNA и FCA должны быть зарегистрированы на Вашем ПК.

  6. Ваша среда разработки может требовать задания ссылки на библиотеку типов PNA, размещенную на Вашем ПК. В Visual Basic нажмите Project, References. Перейдите в папку C:\Program Files\Common Files\Agilent\PNA и выберите 835x.tlb

Проблемы?

  • Процедура завершится неудачно в случае, если библиотека типов PNA используется другими программами (например: Visual basic, VEE, Visual Studio, или любое другое приложение, взаимодействующее с PNA).

  • Если предыдущая процедура завершилась успешно, но соединение с PNA отсутствует – выполните следующую процедуру.

  • Если при установке произошла ошибка, проверьте совпадение имен учетных записей и паролей, используемых на PNA и ПК.

  • Если ошибка повторяется, см. http://na.tm.agilent.com/pna/DCOMSecurity.html.

  1. Map a drive Подсоедините сетевой диск PNA на Ваш удаленный ПК. Запомните букву сетевого диска на ПК.
    При выполнении приведенной ниже процедуры заменяйте PNA на эту букву.

  2. Вызовите режим командной строки c:> на ПК

  3. Наберите PNA: (например o:)

  4. Введите cd program files\agilent\network analyzer\automation

  5. Введите copy 835xps.dll c:\program files\common files\agilent\pna

  6. Введите copy 835x.tlb c:\program files\common files\agilent\pna

Пропустите шаги 6,7,8, если не требуется использовать команды FCA.

  6. Введите cd..

  7. Введите cd applications\fca

  8. Введите copy fca.tlb c:\program files\common files\agilent\pna

  9. Скопируйте файл regtlib.exe из папки PNA:\WINNT в папку C:\<windows>\system32 (папка <windows> зависит от ОС, может быть windows или WINNT)

  10. Введите regtlib C:\program files\common files\agilent\pna\835x.tlb

  11. Введите regsvr32 C:\program files\common files\agilent\pna\835xps.dll

  12. Введите regtlib C:\program files\common files\agilent\pna\fca.tlb

После выполнения этих шагов выполните процедуру доступа (Access Procedure).


Основы технологии COM

В данном разделе рассматриваются следующие понятия:

  • Объекты

  • Интерфейсы

  • Коллекции

  • Методы

  • Свойства

  • События

  • Синтаксис Visual Basic

Примечание: Информация, содержащаяся в данном разделе, представляет собой справочное пособие для программистов SCPI, переходящих на технологию COM. Это не полное руководство по программированию с использованием технологии COM.

Другие разделы по технологии COM

Объекты

Объекты анализатора (приложения) упорядочены иерархически. Объектная модель сетевого анализатора представляет собой список объектов и их связи между собой.

При использовании SCPI перед установками необходимо выбрать измерение. При использовании COM выбирается дескриптор объекта (коллекции), к которому производятся обращения для получения или изменения свойств этого объекта.

Для подробной информации см. раздел "Получение дескриптора объекта" ( Getting a Handle to an Object.)

Интерфейсы

Интерфейс COM обеспечивает связь с объектом. При получении дескриптора объекта используется интерфейс к этому объекту. Это важно при разработке кода PNA, который должен выполняться на различных версиях. Для подробной информации см. раздел "Интерфейсы PNA" (PNA Interfaces).

Коллекции

Коллекция представляет собой объект, содержащий несколько других однотипных объектов. Например, коллекция Channels содержит все объекты каналов.

Примечание: В приведенных ниже примерах доступ к коллекциям осуществляется в виде переменной. Перед использованием объекта коллекции необходимо создать его экземпляр. Для подробной информации см. раздел "Получение дескриптора объекта" (Getting a Handle to an Object)

Доступ к элементам коллекции осуществляется по индексу или по имени. Порядок объектов в коллекции не задается. Они всегда не отсортированы и начинаются с 1. Например, в приведенной ниже процедцуре, chans(1) устанавливает усреднение для первого канала коллекции Channels (не обязательно канал 1).

Sub SetAveraging()
chans(1).AveragingFactor = 10
End Sub

Приведенная ниже процедура использует строковое имя для задания формата измерения в коллекции измерений.

meass("CH1_S11_1").Format = 1

Приведенная ниже процедура использует строковое имя для задания формата измерения в коллекции измерений.

Sub setDwell()
For Each seg In segs
segs.DwellTime = 0.03
Next
End Sub

Методы

Методом называется действие, выполняемое над объектом. Например, CreateSParameter метод объекта Application object. Приведенная ниже процедура использует этот метод для создания нового измерения S21 в канале 1 в новом окне.

Sub CreatMeas
app.CreateSParameter 1,2,1,1
End Sub

Свойства

Свойство – это атрибут объекта, определяющий одну из его характеристик, например цвет, размер, или расположение на экране. Свойство также может изменять поведение объекта, например его видимость. В любом случае, для изменения характеристик объекта необходимо изменять значения его свойств.

Например, следующий оператор устанавливает значение полосы ПЧ (IF Bandwidth) в 1 КГц.

Chan.IFBandwidth = 1e3

Имеется также возможность считать текущее значение свойства. Следующий оператор считывает текущее значение полосы ПЧ (IF Bandwidth) в переменную Ifbw.

Ifbw = Chan.IFBandwidth

Некоторые свойства предназначены только для чтения, а некоторые – только для записи. В разделе справки для каждого свойства описано, можете ли Вы:

  • Устанавливать и считывать значение свойства (Запись/Чтение)

  • Только считывать значение свойства (Только чтение)

  • Только устанавливать значение свойства (Только запись)

События

Событие – это действие, распознаваемое объектом, например, нажатие клавиши или кнопки мыши. При помощи событий программа может отвечать на действия пользователя, программного кода, или действия, вызванные анализатором. Например:

OnChannelEvent

Для подробной информации см. раздел "Работа с событиями анализатора" (Working with the Analyzer's Events.)

Синтаксис Visual Basic

Примеры в справочном руководстве PNA используют синтаксис Visual Basic с "точечной" записью.

Для установки свойства указывается имя объекта:

  • точка (.)

  • свойство или метод

  • знак равенства (=)

  • новое значение

Например:

object.property = value ' Зеленый текст после апострофа (') – комментарий.

Для считывания свойства указывается имя переменной для хранения возвращенного значения:

  • знак равенства (=)

  • объект или ссылка на объект

  • точка (.)

  • свойство

Например:

variable = object.property

Для вызова метода указывается имя объекта или ссылки на объект:

  • точка (.)

  • метод

  • пробел

  • параметры

Например:

object.method parameters

Некоторые методы возвращают значения. Для получения данных, возвращаемых методом, указывается имя переменной для хранения возвращенного значения:

  • знак равенства (=)

  • объект или ссылка на объект

  • точка (.)

  • метод

  • требуемые параметры, заключенные в круглые скобки

variable = object.method (parameters)


Получение дескриптора объекта

В данном разделе рассматриваются следующие понятия:

  • Что такое дескриптор

  • Объявление переменной

  • Присвоение объекта переменной

  • Навигация по иерархии объектов

  • Получение дескриптора коллекции

Другие разделы по технологии COM

Что такое дескриптор

При использовании SCPI перед установкой или считыванием настроек необходимо выбрать измерение. При использовании COM выбирается дескриптор объекта (коллекции), к которому производятся обращения для получения или изменения свойств этого объекта. Можно провести следующую аналогию:

Машину можно назвать объектом. Точнее, машина – класс объектов. Например, одно из свойств машины – "цвет". Его можно считать (посмотреть) или установить (покрасить) для объекта А. Другими словами, можно считывать или устанавливать свойства конкретного объекта, а не класса объектов. Поэтому для установки или чтения свойства необходимо получить "дескриптор", или экземпляр объекта.

Этот процесс также называется "получение доступа к объекту", "получение экземпляра объекта", "возвращение объекта" или "получение ссылки на объект". Одновременно можно открывать несколько дескрипторов объектов

Доступ к объектам PNA

Объект PNA Application является базовым объектом иерархии PNA. Поэтому это единственный объект, который должен быть "создан" перед использованием всех остальных объектов. В процессе создания объект присваивается переменной или дескриптору. В пользовательской программе использование объекта сводится к обращению к этой переменной. Все объекты PNA могут быть присвоены переменным.

Приведенный ниже пример иллюстрирует создание объекта PNA Application и общие принципы получения дескриптора объекта.

Получение дескриптора объектов анализатора производиться в два этапа:

  1. Объявление переменной

  2. Присвоение этой переменной объекта

1. Объявление переменной

Примечание: В примерах, приведенных в данном разделе, используется язык Visual Basic. См. сокращенный раздел "Синтаксис Visual Basic" (Visual Basic syntax.)

Для объявления переменной используйте оператор Dim или любой другой декларатор (Public, Private, или Static). Тип переменной может быть Variant, Object или конкретный тип объекта. Некоторые языки программирования, такие как VBScript и Agilent VEE, не позволяют задавать тип переменных.

TПриведенные ниже примеры объявляют переменную pna. Каждое последующее объявление более точное:

  • Dim pna 'Тип данных Variant.

  • Dim pna As Object 'Тип данных Object.

  • Dim pna As AgilentPNA835x.Application 'Конкретный тип Application

  • Dim pna As AgilentPNA835x.IApplication 'Интерфейсный тип

  1. Этот метод наиболее безопасный во всех средах программирования, однако, такой код выполняется менее эффективно. Этот метод наиболее безопасный во всех средах программирования, однако, такой код выполняется менее эффективно.

  2. Если тип объекта заранее известен и среда программирования позволяет явно задавать тип, то можно объявить переменную как объект.

  3. Явное задание типа объекта позволяет использовать автоматическую проверку типов (Intellisense), такой код выполняется быстрее и более удобочитаемый.

  4. Наиболее специфичный способ, используемый при разработке кода для нескольких версий прошивки – объявление интерфейса. См. Интерфейсы.

2. Присвоение объекта переменной

Для присвоения экземпляра объекта переменной после ее объявления используется ключевое слово Set. Приведенный ниже пример присваивает переменной "pna" значение объекта AgilentPNA835x Application.

Set pna = AgilentPNA835x.Application

Как было сказано ранее, объект AgilentPNA835x уникален, поскольку он является наивысшим звеном иерархии объектов PNA. Поэтому необходимо использовать ключевое слово CreateObject с параметрами (classname,server name).

  • Имя класса classname анализатора всегда "AgilentPNA835x.Application".

  • Получение имени сервера server name, описано в разделе "Просмотр и изменение полного имени компьютера"

Приведенный ниже оператор создает экземпляр объекта Analyzer.

Dim pna AS AgilentPNA835x.Application
Set pna = CreateObject("AgilentPNA835x.Application", "Analyzer46")

Примечание: Если приложение PNA не выполняется, то при выполнении этого оператора оно автоматически запустится.

Навигация по иерархии объектов

После создания экземпляра приложения PNA доступ к объектам PNA осуществляется навигацией по иерархии объектов. Навигация по иерархии объектной модели может быть очень сложной. Кроме того, необходимо знать, как обращаться к указанному экземпляру данного объекта. Например, если на PNA существуют три измерения, как обратиться к измерению канала 1 ? Каждый объект на изображении объектной модели PNA привязан к странице объектов. В верхней части каждой страницы объектов расположены разделы Description и "Accessing the ... Object". В этих разделах описана навигация по иерархии PNA для получения доступа к указанному экземпляру данного объекта.

Исходя из вышесказанного, можно подумать, что перед установкой или считыванием свойств необходимо объявить переменные и назначить им объекты. Несмотря на то, что этот метод лучше использовать для повторно используемых объектов, таких как измерения, это не всегда оправдано. Можно также обращаться к объекту напрямую.

Объект TriggerSetup является наследником объекта Application. Поскольку для установки нескольких свойств достаточно одного обращения к объекту, достаточно просто сделать это напрямую. В предыдущем примере мы получили дескриптор объекта Application в переменную pna. Приведенный ниже пример обращается к свойству Scope объекта TriggerSetup используя "точечную запись" Visual basic.

pna.TriggerSetup.Scope = naChannelTrigger

При прямом обращении к объекту TriggerSetup необходимо указать тот же путь, что и при обращении к свойствам объекта TriggerSetup. Ниже приведено присвоение объекта pna.TriggerSetup переменной для многократного использования.

Dim trig As Object
Set trig = pna.TriggerSetup

После создания переменной к ней можно обращаться как к объекту, на который она ссылается. Например:

trig.Scope = naChannelTrigger
trig.Source = naTriggerSourceInternal

Получение дескриптора коллекции

Анализатор имеет несколько коллекций объектов для облегчения процедуры установки или считывания свойств сразу всех объектов, входящих в коллекцию. Кроме того, существуют объекты (например, предельные линии), доступ к которым осуществляется исключительно через коллекции.

Для получения дескриптора элемента коллекции необходимо обратиться к нему по индексу или, в некоторых случаях, по имени. Перед этим необходимо получить дескриптор коллекции. Для присвоения коллекции переменной выполните следующие шаги (1. объявите переменную, 2. присвойте значение при помощи оператора 'Set').

Dim meass As Measurements

Dim meas As Measurement

После этого можно проходить в цикле по всем элементам коллекции и считывать или устанавливать их свойства

Sub setFormat()
For Each meas In meass
meas.Format = naDataFormat_LinMag
Next
End Sub

Кроме того, имеется возможность работы с конкретным объектом коллекции:

meass(1).Format = naLinMag

Примечание: Для каждого объекта и коллекции существует своя уникальная нумерация и именование элементов. Для подробной информации см. раздел "Объектная модель анализатора" (Analyzer Object Model).


Коллекции анализатора

Коллекции представляют собой группы однотипных объектов. Они обеспечивают удобный доступ к свойствам этих объектов. Коллекции обычно имеют следующие базовые методы и свойства:

Item(n)
Count
Add(n)
Remove(n)

где (n) - порядковый номер объекта в коллекции. Некоторые коллекции имеют уникальные возможности, характерные для содержащихся в них объектов.

Другие разделы по технологии COM

Коллекции динамические

Коллекция не существует до тех пор, пока не будет запрошена. При запросе объекта Channels (см. "Получение дескриптора объекта/коллекции) получаются дескрипторы всех объектов каналов и помещаются в массив.

Например, если существуют только каналы 2 и 4, массив будет содержать только 2 элемента. Команда 'channels.Count' возвратит значение 2,:

  • Channels(1) будет содержать объект канала 2.

  • Channels(2) будет содержать объект канала 4.

Объекты в коллекции не упорядочены. Если к предыдущему примеру добавить:

Pna.Channels.Add(3)

то команда 'channels.Count' возвратит значение 3:

  • Channels(1) будет содержать объект канала 2.

  • Channels(2) будет содержать объект канала 3.

  • Channels(3) будет содержать объект канала 4.

Коллекции обычно используются для проведения итераций следующего типа:

Dim ch as Channel
For each ch in pna.Channels
Print ch.Number
Print ch.StartFrequency
Print ch.StopFrequency
Next ch

После выполнения блока for-each объект Channels выходит из области видимости.


Типы данных COM

Для связи с главным компьютером PNA использует несколько типов данных. Перед использованием переменной ее желательно объявить в соответствии с хранимым типом данных. Это позволяет экономить память и убыстряет доступ. Ниже приведены наиболее часто используемые типы данных:

  • Long Integer

  • Single Precision (Real)

  • Double Precision (Real)

  • Boolean

  • String

  • Object

  • Enumeration

  • Variant

Другие разделы по технологии COM

Long (длинное целое) – переменные хранятся в виде знакового 32-битного (4-байтового) числа в диапазоне -2,147,483,648 … 2,147,483,647.

Double ((плавающая точка двойной точности) - переменная хранится в виде 64-битного (8-байового) числа с плавающей точкой в формате IEEE в диапазоне -1.79769313486232E308 … -4.94065645841247E-324 для отрицательных чисел и 4.94065645841247E-324 … 1.79769313486232E308 для положительных.

Single (плавающая точка одинарной точности) - переменная хранится в виде 32-битного (4-байового) числа с плавающей точкой в формате IEEE в диапазоне -3.402823E38 … -1.401298E-45 для отрицательных чисел и 1.401298E-45 … 3.402823E38 для положительных

Boolean – булевский тип. Переменные хранятся в виде 16-битых (2-байтовых) чисел, но могут принимать только два значения – истина или ложь (True или False). Для присвоения значений булевским переменным используются ключевые слова True и False.

При преобразовании числовых типов в булевский 0 соответствует False, а все остальные числа – True. При преобразовании булевского типа в числовые False соответствует 0, а True – -1.

String – значения символьного типа. Переменные строкового типа могут хранить строки до 65,535 байт (64К) фиксированной или переменной длины. Один символ соответствует одному байту. Строки фиксированной длины объявляются с явным указанием длины. Строки переменной длины могут быть любой длины до 64К с учетом небольшого количества служебной информации.

Object Переменные типа Object хранятся в виде 32-битных (4-байтовых) адресов, указывающих на объекты анализатора или какого-либо другого приложения. Одной переменной типа Object могут быть последовательно присвоено несколько любых объектов анализатора (при помощи оператора Set).

Перечисления (Enum) – набор поименованных постоянных значений. Они позволяют обращаться к числовым константам по именам. Например:

Enum DaysOfWeek
Sunday = 0
Monday = 1
Tuesday = 2
Wednesday = 3
Thursday = 4
Friday = 5
Saturday = 6
End Enum

После объявления такого перечисления можно передавать константы следующим образом:
SetTheDay(Monday)
вместо
SetTheDay(1)
для улучшения удобочитаемости кода.

Однако анализатор возвращает длинное целое, а не текст.
Day = DaysofWeek(today) 'Day = 1

Variant – если при объявлении переменной тип данных не указан, ей назначается тип Variant. Тип Variant может представлять различные типы данных в разных ситуациях.

PNA передает и принимает данные типа Variant, поскольку существуют языки программирования, не поддерживающие типизированные данные. Данные типа Variant передаются дольше, чем "типизированные".


Интерфейсы PNA

Интерфейс COM обеспечивает связь с объектом. При получении дескриптора объекта на самом деле используется интерфейс к этому объекту. Это тонкое различие касается COM-программиста по следующим двум причинам:

  • Наследование интерфейсов (Программирование под разные версии PNA))

  • Пользовательские интерфейсы .

Другие разделы по технологии COM

Наследование интерфейсов (Программирование под разные версии PNA)

TPNA продолжает развиваться, выходят новые версии прошивки / программного обеспечения, предоставляющие больше возможностей и функциональности. К существующим объектам добавляются новые команды, для поддержки которых добавляются новые интерфейсы. Например, в PNA версии 3.0 были добавлены новые команды к объекту Measurement. Эти команды доступны через новый интерфейс IMeasurement2. Это может быть важно, если код разрабатывается с использованием библиотеки типов 3.0, но выполняться должен на PNA более старой версии, например 2.0

При использовании на PNA версии 2.0 команд, появившихся в версии 3.0 произойдет ошибка, поскольку старая версия PNA не распознает новых команд. Кроме того, ошибка может возникнуть даже в том случае, если новые команды НЕ используются. Ниже приведен пример подобной проблемы и ее решения.

Приведенный ниже оператор Visual Basic присваивает переменной meas объект.

Dim meas As Measurement

При компиляции программы Visual Basic определяет, какой интерфейс использовать для доступа к объекту. При объявлении переменной типа object, VB использует интерфейс по умолчанию. После того, как к объекту добавляются новые интерфейсы, они становятся интерфейсами по умолчанию. Если программа была разработана и скомпилирована с использованием библиотеки типов PNA 3.0, то интерфейс по умолчанию для объекта Measurement будет IMeasurement2. Однако, если программа будет запускаться на приборе с прошивкой PNA 2.0, где интерфейс IMeasurement2 отсутствует, возникнет ошибка E_NOINTERFACE.

Исходя из этого, наиболее эффективный способ – при объявлении переменной указать не объект, а интерфейс.

Dim meas As IMeasurement

Этот код будет использовать только интерфейс IMeasurement, несмотря на интерфейс по умолчанию.

Однако, при использовании новых команд на старой версии, ошибки будут возникать независимо от того, как объявлена переменная.

Пользовательские интерфейсы

Объектная модель PNA содержит три "пользовательских" интерфейса. Эти интерфейсы позволяют программисту на Visual Basic и C++ передавать данные при помощи "типизированных" переменных, что более эффективно, чем использовать переменные вариантного типа. Интерфейсы:

  • IArrayTransfer - Объект Measurement

  • ICalData - Объект Calibrator

  • ISourcePowerCalData - Объект Channel


Работа с событиями PNA

Работа с событиями

  • Что такое события?

  • Использование событий анализатора

  • Идентификаторы событий

  • Фильтрация событий

  • Список событий

  • Ошибки выхода за пределы значений

  • Решение проблем с обратными вызовами

См. Примеры событий.

Другие разделы по технологии COM

Что такое события?

Приложения Windows обрабатывают пользовательские события, такие как перемещение курсора мыши и нажатия ее кнопок. Нажатие кнопки мыши генерирует событие, которое можно проигнорировать или обработать в специальной процедуре, например:

Sub DoThis_onClick
Perform something
End Sub

Если в программе присутствует подобная процедура, то при нажатии кнопки мыши происходит "обратный вызов" клиента и прерывание текущего действия для обработки события.

Более наглядный пример события анализатора - контроль по диапазону значений. Если при контроле по диапазону значений при измерении обнаруживается ошибка, анализатор генерирует событие "Выход за допустимый предел". Если же значение в пределах лимитов, анализатор генерирует событие "Значение в пределах лимитов".

Анализатор имеет сложную структуру обработки событий. При возникновении одного или нескольких событий программа может быть о них уведомлена. Однако, это не всегда необходимо.

Например, у анализатора есть событие, уведомляющее программу об окончании свипирования. Существует более простой способ – использовать синхронную команду, ожидающую завершения свипирования.

sync = True
app.ManualTrigger sync
chan.StartFrequency = 4.5E6

Это НЕ будет работать, если контроллер должен производить во время ожидания другие операции, например установку измерителя мощности или сортировку данных. В этом случае необходимо произвести "обратный вызов" с анализатора для сообщения программе о завершении свипирования. См. "Пример обработки событий" like setup a power meter or sort some data. In this case you would like a "callback" from the analyzer to let your program know that the sweep has completed. For an example of this see Events Example.

Другая причина использовать события - уведомления о состояниях, например об ошибках или исходных разблокировках. Постоянно опрашивать эти состояния при выполнении программы – не лучший вариант.

Использование событий

При использовании событий COM для осуществления обратного вызова программа должна выполнить следующие действия:

1. Подписаться на события:

Все события анализатора унаследованы от объекта Application через интерфейс INetworkAnalyzerEvents. Объекту Application необходимо сообщить, какие события необходимо получать. Этот процесс называется подпиской.

В Visual Basic это осуществляется при помощи директывы "WithEvents" в операторе объявления. Приведенная ниже строка объявляет объект класса Application (myPNA), и подписывает его на события, генерируемые объектом Application.

Dim WithEvents myPNA as AgilentPNA835x.Application

В C++ все несколько сложнее. Необходимо запросить интерфейс IconnectionPointContainer, получить интерфейс InetworkAnalyzerEvents при помощи вызова FindConnectionPoint, а после этого вызвать метод Advise().

2. Реализовать обработчик событий

При возникновении события объект Application производит "обратный вызов" через интерфейс InetworkAnalyzerEvents.

В среде разработки VB, щелкните по окну объектов (левая верхняя панель). Найдите объект Application и щелкните по нему. На верхней левой панели появятся интерфейсы событий. При нажатии на нужный интерфейс VB автоматически генерирует первую строку кода. Далее необходимо написать текст обработчика события. Ниже приведен пример процедуры-обработчика события.

Примечание: В C++ необходимо написать обратный вызов.

Private Sub OnChannelEvent( eventID as Variant, channelNumber as Variant)
Select Case (eventID)
Case naEventID_CHANNEL_TRIGGER_COMPLETE:
GetData( channelNumber )
Case naEventID_CHANNEL_TRIGGER_ABORTED:
MsgBox( "Hey don't touch the front panel!")
End Select
End Sub

При выполнении условий возникновения события приложение производит обратный вызов процедуры обработчика события Sub OnChannelEvent().

Идентификаторы событий

3 | 3 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Sev |  | C | R | Устройство |  |  |  |  |  |  |  |  |  |  | Код

Фильтрация событий

При объявлении "Dim WithEvents..." происходит автоматическая подписка более чем на 140 различных событий. (или эквивалентной конструкцией используемого языка программирования). Мониторинг всех состояний существенно замедляет работу анализатора. Приведенные ниже методы позволяют фильтровать события и отслеживать только указанные условия.

  • AllowEventMessage - отслеживать указанное событие

  • AllowAllEvents - отслеживать ВСЕ события

  • DisallowAllEvents - НЕ отслеживать события

  • AllowEventCategory - отслеживать события заданных категорий (см. ниже)

  • AllowEventSeverity - отслеживать события с одним или несколькими уровнями важности.

Code | Важность
00 | naEventSeveritySUCCESS - операция завершилась успешно
01 | naEventSeverityINFORMATIONAL - события, не влияющие на целостность измерений
10 | naEventSeverityWARNING - события, при которых возможно нарушение целостности измерений
11 | naEventSeverityERROR - события, при которых возможно серьезное нарушение целостности измерений

Список событий

Ниже приведен список категорий и типов входящих в них событий. Щелкните по ссылке для просмотра подробной информации о событии.

Категория | Процедура обратного вызова
naEventCategory_PARSER | OnSCPIEvent
naEventCategory_MEASURE | OnMeasurementEvent
naEventCategory_CHANNEL | OnChannelEvent
naEventCategory_HW | OnHardwareEvent
naEventCategory_CAL | OnCalEvent
naEventCategory_USER | OnUserEvent
naEventCategory_DISPLAY | OnDisplayEvent
naEventCategory_GENERAL | OnSystemEvent

Примечание: Для получения текстового сообщения с описанием события используйте метод MessageText.

Ошибки выхода за пределы значений

При попытке установить в активной функции значение, выходящее за допустимые пределы (минимальный или максимальный), анализатор ограничивает это значение до предельного значения (минимального или максимального). На передней панели это выглядит как ограничение вводимого значения в элементе редактирования или сообщение на дисплее. Например, можно попытаться установить начальное значение частоты меньше 300 КГц. Элемент редактирования не позволит ввести значение меньше 300 КГц.

При попытке задать значение программно (например, стартовую частоту ниже допустимого предела) имеет место аналогичное поведение. Анализатор принимает ограниченное значение. Однако, для того, чтобы узнать, какое значение было установлено, необходимо проанализировать HRESULT.

Все вызовы автоматизации возвращают значения типа HRESULT. По умолчанию при выходе за допустимые пределы возвращается HRESULT S_NA_LIMIT_OUTOFRANGE. Это значение является кодом успешного завершения, поскольку бит 31 установлен в 0. Для определения успешности вызова необходимо всегда проверять код возврата.

Некоторые макросы С++ (например SUCCEEDED(hr) и FAILED(hr) ) проверяют только бит 31. Поэтому для определения ошибки outOfRange необходимо явно проверять S_NA_LIMIT_OUTOFRANGE.

В качестве альтернативы можно настроить анализатор на оповещение условия outOfRange в виде кода ошибки. Используйте метод: App.SetFailOnOverRange (true). При установке этого метода в TRUE, все ошибки выхода за допустимые пределы будут возвращать E_NA_LIMIT_OUTOFRANGE_ERROR.

Этот метод облегчает работу клиентам VB. Пользователи VB не могут определять специфические коды возврата, поскольку VB игнорирует HRESULT, и возбуждает ошибку времени выполнения, только если установлен бит 31 (код неудачного завершения).

Решение проблем с обратными вызовами

При выполнении обратных вызовов клиентский ПК становится сервером, а анализатор (сервер) – клиентом. Обратные вызовы могут осуществляться только в том случае, если клиент и сервер находятся в одной и той же рабочей группе или домене. См. Конфигурирование COM (Configure for COM).


Считывание и запись калибровочных данных при помощи COM

Имеется возможность считывать и записывать следующие типы калибровочных данных PNA:

  • Стандартные данные измерений -необработанные данные измерений калибровочного стандарта.

  • Векторы ошибок - данные результатов подсчетов стандартных данных измерений по специальным алгоритмам калибровки.

Все эти данные доступны PNA в виде типизированных или нетипизированных данных. См. типизированные и нетипизированные (variant) данные.

Другие разделы по технологии COM

Развитие архитектуры калибровки

В PNA 2.0 функциональность Cal Set (хранилище калибровочных данных) несколько расширена. В PNA 1.0 Cal Set был ограничен данными одной калибровки, и мог использоваться только создавшим его каналом. В PNA 2.0 размер Cal Set выбирается динамически, может хранить несколько типов калибровок и использоваться несколькими каналами. (См. Cal Sets)

В PNA присутствуют два набора интерфейсов автоматизации, содержащих методы считывания и записи калибровочных данных в Cal Set:

Набор 1 - ICalibrator (нетипизированный), ICalData (типизированный)

Интерфейсы ICalibrator и ICalData были введены в PNA 1.0. Они содержат несколько методов считывания и записи кодов ошибок и данных измерений.

Набор 2 - ICalSet (нетипизированный), ICalData2(типизированный)

Интерфейс ICalSet был введен в PNA2.0 для поддержки новой функциональности Cal Set. Методы этого интерфейса кроме всего прочего также включают методы обмена данными с Cal Set. Кроме того, интерфейс ICalData2 может работать с типизированными данными. В приведенном ниже примере ICalSet используется для считывания кодов ошибок. Дескриптор Cal Set получается при помощи метода GetCalSetByGUID.

dim CMGR as CalManager
dim CSet as CalSet
dim strCalSetGUID as string
dim iEtermSetID as integer
dim caltype as NACalType
dim eTerm as NAErrorTerm2
dim rcvPort as long
dim srcPort as long
CMGR.GetCalSetUsageInfo( channel, strCalsetGUID, iEtermSetID)
set CSet = CMGR.GetCalSetByGUID( strCalSetGUID)
caltype = naResponseOpen
rcvPort = 1
srcPort = 1
eTerm = naET_ReflectionTracking
CSet.Open( caltype, rcvPort, srcPort)
VarData = CSet.GetErrorTerm( ETerm, rcvPort, srcPort)
CSet.Close()

Рекомендации

Для чтения и записи калибровочных данных настоятельно рекомендуется использовать интерфейсы ICalSet и ICalData2.

Примечание: Интерфейс ICalibrator все еще требуется для других функций калибровки, например для сбора калибровочных данных.

Использование ICalibrator совместно с PNA2.0 Cal Sets

Для обмена калибровочными данными с 2.0 Cal Sets можно использовать интерфейс ICalibrator.

Получение данных с Cal Set:

  1. Получить дескриптор Cal Set при помощи методов "get" интерфейса ICalManager

  2. Получить дескриптор объекта Calibrator на том же канале что и Cal Set.

  3. Укажите Cal Type и порты для метода SetCalInfo:

Следующий пример считывает данные об ошибках с Cal Set

WICalibrator.SetCalInfo( caltype, rcvPort, srcPort)
VarData = ICalibrator.GetErrorTerm( ETerm, rcvPort, srcPort)

Запись данных на Cal Set:

Имеется возможность заполнения данными "пустого" cal set и перезаписи существующего. Метод SetCalInfo создает пустой Cal Set при отсутствии активного Cal Set на том же канале, что и объект Calibrator. Следующий пример записывает данные об ошибках в пустой Cal Set.

ICalibrator.SetCalInfo( caltype, rcvPort, srcPort)
VarData = ICalibrator.putErrorTerm( ETerm, rcvPort, srcPort)


C++ и интерфейс COM

Программирование PNA на C++

Информация, содержащаяся в справочном руководстве, предназначена для программистов на Visual Basic. VB значительно облегчает разработку, и автоматизирует доступ и управление компонентами. При использовании языков более низкого уровня (таких как С++) требуется более глубокое понимание принципов СОМ. Этот раздел не предназначен для обучения COM-программированию. Здесь приведены основные понятия, которые необходимо знать для программирования с использованием COM.

  • Инициализация COM

  • Импортирование библиотеки типов

  • Создание объекта Application

  • Ошибки

  • События

  • Дополнительная литература

  • Пример

Примечание: Информация в этом разделе подразумевает разработку под ОС Windows с использованием средств Microsoft.

Другие разделы по технологии COM

Инициализация COM

Перед выполнением любых транзакций COM необходимо проинициализировать библиотеку COM. Это может быть выполнено двумя способами. Самый простой способ – вызвать CoInitialize( ) или CoIntializeEx( ). В качестве альтернативы можно использовать функцию AfxOleInit( ) MFC (библиотека базовых классов).

Соответственно, перед выходом из программы необходимо деактивировать COM. Для этого используется процедура CoUninitialize( ) или функция MFC AfxOleTerm( ).

Importing the Type Library

Библиотека типов экспортируется сервером для того, чтобы компонент стал доступным клиенту. Для PNA этот файл имеет имя 835x.tlb. Он находится на жестком диске PNA в папке C:\Program Files\ Agilent\ Network Analyzer\ Automation. См. Конфигурирование COM-DCOM для разработки (Configure for COM-DCOM Programming).

Библиотека типов может быть считана и дешифрована при помощи другого интерфейса COM – ItypeLib. Этот интерфейс использует VB для заполнения обозревателя объектов. Visual C++ также может загружать библиотеки типов. Для этого необходимо импортировать библиотеку типов в проект при помощи следующей директивы компилятора:

#import "C:\Program Files\Common Files\Agilent\Pna\835x.tlb", named_guids

При обработке этой директивы компилятор создает два файла: 835x.tlh и 835x.tli. Первый файл – заголовочный файл, в котором находятся объявления типов COM-интерфейсов PNA и их методов. Второй файл содержит интерфейсные функции для методов интерфейсов PNA. Интерфейсные функции содержат обработку ошибок для вызовов всех методов.

TВ файле .tlh определен "интеллектуальный указатель", при помощи которого осуществляется доступ к объектам PNA. Определение "интеллектуального указателя" выглядит следующим образом:

_com_smartptr_typedef(Iapplication, _uuidof(Iapplication))

"Интеллектуальный указатель" - это объект C++, инкапсулирующий указатель для обращения к COM-объекту. Все COM-объекты унаследованы от интерфейса IUnknown. Этот интерфейс содержит три метода: QueryInterface( ), AddRef( ), и Release( ). Методы AddRef и Release управляют счетчиками ссылок на объект и его временем жизни. При каждом создании COM-объекта необходимо увеличить счетчик ссылок. После завершения использования объекта, необходимо уменьшить счетчик ссылок . Этим и занимаются "интеллектуальные указатели", как показано в примере. Кроме того, "интеллектуальные указатели" выполняют, в случае необходимости, вызов QueryInterface. Метод QueryInterface получает указанный интерфейс объекта. В демонстрационной программе осуществляется доступ к интерфейсу IArrayTransfer объекта Measurement. В процедуре ReadMethod присутствует строка:

PTransferData = pMeas;

Оператор присваивания перегружен "интеллектуальным указателем", на самом деле этот оператор выполняет следующее действие:

HRESULT hr = pMeas->QueryInterface( IID_IArrayTransfer,(void**)&pTransferData);

Этот вызов использует существующий указатель на объект (pMeas) для проверки поддержки интерфейса IArrayTransfer и получения указателя на него в pTransferData. Интеллектуальные указатели облегчают разработку приложений на C++. Подробная инфорамция об интеллектуальных указателях доступна в сети для разработчиков, использующих платформу Microsoft (MSDN).

Создание объекта Application

Объект Application – единственный создаваемый объект, экспортируемый PNA. Обычно он создается вызовом CoCreateInstance:

STDAPI CoCreateInstance(
CLSID__IApplication, //Class identifier (CLSID) of the object
NULL, //Pointer to controlling IUnknown
CLS_CTX_SERVER, //Context for running executable code
IID_IApplication, //Reference to the IID of the interface
(void**)&pNA //Address of output variable that receives
// the interface pointer requested in riid
);

При использовании интеллектуальных указателей это осуществляется следующим вызовом:

IApplicationPtr pNA; // declare the smart pointer
pNA = IApplicationPtr("AgilentPNA835x.Application.1");

Ошибки

Все методы COM возвращают значение HRESULT. Это значения представляет собой 32-битное целое число специального формата.

  • Самый старший бит означает успешное завершение (0) или сбой (1).

  • Младшие 16 бит содержат специфичный код ошибки.

Visual Basic игнорирует возвращенное значение HRESULT, и возбуждает исключительную ситуацию только в случае неудачного завершения. При программировании на С++ обработка ошибок производится вручную. Необходимо проверять возвращаемое значение каждой вызываемой COM-функции.

События

Объект Application поддерживает интерфейс INetworkAnalyzerEvents. Этот объект является источником всех событий. Для использования событий в С++ необходимо выполнить следующие действия:

  1. Реализовать интерфейс INetworkAnalyzerEvents – унаследовать объект от INetworkAnalyzerEvents и реализовать описанные там методы.

  2. Подписаться на интерфейс IconnectionPoint объекта Application. Получить указатель на интерфейс IConnectionPointContainer объекта Application и сделать следующий вызов:

FindConnectionPoint( IID_InetworkAnalyzerEvents, &pConnection );

При успешном завершении этого вызова в pConnection будет возвращен указатель. Используйте этот указатель для подписки на объект Application:

pConnect->Advise( IUnknown* punk, DWORD dwCookie);

Этот вызов предоставляет серверу объект с адресом обратного вызова. Указатель на Iunkown в данном вызове – это указатель на объект, реализующий интерфейс INetworkAnalyzerEvents. Это называется event sink. Объект application требует указатель на этот объект для вызова клиентского интерфейса при наступлении события. dwCookie – ключ подписки. Он используется для отмены подписки (см. Unadvise( )).

Дополнительная литература

"MSDN" - Microsoft Developer's Network Library

"Learning DCOM", by Thuan L. Thai, published by O'Reilly(1999)

"Inside COM", by Dale Rogerson, published by Microsoft Press (1997)

"Understanding ActiveX and OLE", by David Chappell, also published by Microsoft Press (1996)

"Beginning ATL COM Programming", published by Wrox Press (1998)

Пример

В примере используется интеллектуальный указатель, созданный Microsoft Visual Studio. Библиотеки COM загружаются и освобождаются при помощи вызовов CoInitialize и CoUninitialize. В данном примере явно освобождаются также локальные указатели главной функции. Интеллектуальные указатели освобождаются автоматически при выходе из области видимости. Однако, учитывая то, что мы вызываем CoUninitialize до освобождения указателей, освобождение производится вручную.

См. демонстрационную программу.


Использование .NET

Использование COM в среде .NET

Для связи с PNA с использованием языков платформы Microsoft .NET, таких как C# и Visual Basic.NET, выполните следующие шаги:

  1. Сконфигурируйте ПК и PNA для программирования COM-DCOM.

  2. Установите библиотеку типов в среде разработки (см. исключения для проектов на managed C++.) В процессе установки библиотеки типов создается сборка .NET, являющаяся "обложкой" библиотеки типов в среде .NET. Такая .NET-сборка называется сборка взаимодействия (Interop Assembly).

Для запуска программ .NET на PNA необходимо установить на PNA .NET framework. Для этого нужно загрузить и выполнить файл dotnetfx.exe, находящийся по адресу: http://www.microsoft.com/downloads/details.aspx?FamilyID=262d25e3-f589-4842-8157-034d1e7cf3a3&DisplayLang=en

Если программы .NET будут выполняться только на удаленном компьютере, то устанавливать .NET framework на PNA нет необходимости.

Исключение для проектов на managed C++: Для того, чтобы сгенерировать Interop Assembly для проектов на managed C++ необходимо использовать утилиту tlbimp.exe. Эта утилита описана в документации MSDN. На клиентском ПК нажмите Start потом Run и введите: tlbimp.exe 835x.tlb и нажмите OK. После этого можно использовать директиву #using для включения Interop Assembly в проекты на managed C++.

Регистрация PNA Primary Interop Assembly (PIA) (ОПЦИОНАЛЬНО)

Для связи с PNA использовать PIA НЕ обязательно. Следующая процедура используется в том случае, когда две программы .NET разделяют одни и те же определения интерфейса PNA. Без PIA каждое приложение .NET будет использовать свою Interop Assembly.

Для регистрации PIA на компьютере должно быть установлено common language runtime (CLR). Этот пакет входит в состав Visual Studio.NET. После этого выполните следующие шаги:

Примечание: В приведенных ниже шагах необходимо заменить <локальный каталог> на полный к путь к указанному файлу на вашем ПК.

  1. Запустите программу PNAProxy.exe, как описано в "Конфигурирование COM-DCOM для разработки".

  2. На PNA скопиркйте файл C:\Program Files\Agilent\Network Analyzer\Automation\AgilentPNA835x.dll в локальный каталог ПК. Запомните этот каталог.

  3. На клиентском ПК нажмите Start, потом Run, и введите: regasm <локальный каталог> \AgilentPNA835x.dll и нажмите OK для регистрации библиотеки.

  4. Снова нажмите Start, потом Run, и введите: gacutil /i <локальный каталог> \AgilentPNA835x.dll и нажмите OK для добавления сборки в глобальный кэш сборок (GAC).

Для деинсталляции PIA, выполните следующие действия:

  1. На клиентском ПК нажмите Start, потом Run, и введите: gacutil /u <локальный каталог> \AgilentPNA835x.exe и нажмите OK для удаления сборки из глобального кэша сборок (GAC).

  2. На клиентском ПК нажмите Start, потом Run, и введите: regasm /unregsiter <локальный каталог> \ agilentpna835x.dll и нажмите OK для отмены регистрации сборки.

  3. Для удаления PNA Proxy.exe используйте утилиту Add/Remove Programs на панели управления.


SCPI List

List of PNA SCPI Commands

Click on a command for details

Local Lockout - GPIB Message

COMMON COMMANDS

*CLS - Clear Status

*ESE - Event Status Enable

*ESE? - Event Status Enable Query

*ESR - Event Status Enable Register

*IDN? - Identify

*OPC - Operation complete command

*OPC? - Operation complete query

*OPT? - Identify Options Query

*RST - Reset

*SRE - Service Request Enable

*SRE? - Service Request Enable Query

*STB? - Status Byte Query

*TST? - Result of Self-test Query

*WAI - Wait

ABORT Command

ABORt

CALC:CORRECTION Commands

CALCulate<cnum>:CORRection:EDELay:MEDium <num>

CALCulate<cnum>:CORRection:EDELay:TIME <num>

CALCulate<cnum>:CORRection:EDELay:WGCotoff <num>

CALCulate<cnum>:CORRection:[STATe] <on|off>

CALCulate<cnum>:CORRection:TYPE <char>

CALCulate<cnum>:CORRection:OFFSet[:MAGNitude] <num>

CALCulate<cnum>:CORRection:OFFSet:PHASe <num>[<char>] OBSOLETE

CALC:CUSTOM Commands

CALCulate<cnum>:CUST:DEFine <Mname>, <ProgID> [,param]

CALCulate<cnum>:CUSTom:MODify <param>

CALC:DATA Commands

CALCulate<cnum>:DATA <char>

CALCulate<cnum>:DATA:CUSTom <name>,<data>

CALCulate<cnum>:DATA:CUSTom:CATalog?

CALCulate<cnum>:DATA:SnP?

CALC:FILTER Commands

CALCulate<cnum>:FILTer[:GATE]:COUPle:PARameter <char>

CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer <num>

CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe <char>

CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN <num>

CALCulate<cnum>:FILTer[:GATE]:TIME:STATe <boolean>

CALCulate<cnum>:FILTer[:GATE]:TIME:STARt <num>

CALCulate<cnum>:FILTer[:GATE]:TIME:STOP <num>

CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE] <char>

CALC:FORMAT Command

CALCulate<cnum>:FORMat <char>

CALC:FUNCTION Commands

CALCulate<cnum>:FUNCtion:DATA?

CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe] <range>

CALCulate<cnum>:FUNCtion:DOMain:USER:STARt <range>, <start>

CALCulate<cnum>:FUNCtion:DOMain:USER:STOP <range>, <stop>

CALCulate<cnum>:FUNCtion:STATistics[:STATe] <ON|OFF>

CALCulate<cnum>:FUNCtion:TYPE <char>

CALC:LIMIT Commands

CALCulate<cnum>:LIMit:DATA <block>

CALCulate<cnum>:LIMit:DISPlay[:STATe] <ON | OFF>

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt <num>

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP <num>

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt <num>

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP <num>

CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE <char>

CALCulate<cnum>:LIMit:SOUNd[:STATe] <ON | OFF>

CALCulate<cnum>:LIMit:STATe <ON | OFF>

CALC:MARKER Commands

CALCulate<cnum>:MARKer:AOFF

CALCulate<cnum>:MARKer:BWIDth <num>

CALCulate<cnum>:MARKer<mkr>:COUPling[:STATe]<ON|OFF>

CALCulate<cnum>:MARKer<mkr>:DELTa <ON|OFF>

CALCulate<cnum>:MARKer<mkr>:DISCrete <ON|OFF>

CALCulate<cnum>:MARKer<mkr>:DISTance <num>

CALCulate<cnum>:MARKer<mkr>:FORMat <char>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion <num>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold <num>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER <range>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt <start>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP <stop>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:EXECute [<func>]

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect] <char>

CALCulate<cnum>:MARKer<mkr>:TARGet <num>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking <ON | OFF>

CALCulate<cnum>:MARKer:REFerence[:STATe] <ON | OFF>

CALCulate<cnum>:MARKer:REFerence:X <num>

CALCulate<cnum>:MARKer:REFerence:Y?

CALCulate<cnum>:MARKer<mkr>:TYPE <char>

CALCulate<cnum>:MARKer<mkr>:SET <char>

CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

CALCulate<cnum>:MARKer<mkr>:X <num>

CALCulate<cnum>:MARKer<mkr>:Y?

CALC:MATH Commands

CALCulate<cnum>:MATH:FUNCtion <char>

CALCulate<cnum>:MATH:MEMorize

CALC:MIXER Command

CALC ulate<ch>:MIXer:INPut:POWer:USENominal

CALCulate<ch>:MIXer:XAXis <char>

CALC:NORMALIZE Commands

CALCulate<cnum>:NORMalize[:IMMediate]

CALCulate<cnum>:NORMalize:STATe <ON | OFF>

CALCulate<cnum>:NORMalize:INTerpolation[:STATe] <ON | OFF>

CALC:OFFSet Commands

CALCulate<cnum>:OFFSet:MAGNitude <num>

CALCulate<cnum>:OFFSet:MAGNitude:SLOPe <num>

CALCulate<cnum>:OFFSet:PHASe <num>[<char>]

CALC:PARAMETER Commands

CALCulate<cnum>:PARameter:CATalog?

CALCulate<cnum>:PARameter:DEFine <Mname>,<param>[,load]

CALCulate<cnum>:PARameter:DELete <Mname>

CALCulate:PARameter:DELete:ALL

CALCulate<cnum>:PARameter:MNUMber?

CALCulate<cnum>:PARameter::MODify <param>

CALCulate<cnum>:PARameter:SELect <Mname>

CALC:RDATA Commands

CALCulate<cnum>:RDATA? <char>

CALC:SMOOTHING Commands

CALCulate<cnum>:SMOothing:APERture <num>

CALCulate<cnum>:SMOothing:POINts <num>

CALCulate<cnum>:SMOothing[:STATe] <ON | OFF>

CALC:TRANSFORM Commands

CALCulate<cnum>:TRANsform:COUPle:PARameters <num>

CALCulate<cnum>:TRANsform:TIME:CENTer <num>

CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDTh <num>

CALCulate<cnum>:TRANsform:TIME:KBESsel <num>

CALCulate<cnum>:TRANsform:TIME:LPFREQuency

CALCulate<cnum>:TRANsform:TIME:MARKer:MODE <char>

CALCulate<cnum>:TRANsform:TIME:MARKer:UNIT <char>

CALCulate<cnum>:TRANsform:TIME:SPAN <num>

CALCulate<cnum>:TRANsform:TIME:STARt <num>

CALCulate<cnum>:TRANsform:TIME:STATe <ON | OFF>

CALCulate<cnum>:TRANsform:TIME:STOP <num>

CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe <num>

CALCulate<cnum>:TRANsform:TIME:STIMulus <char>

CALCulate<cnum>:TRANsform:TIME[:TYPE] <char>

CONTROL Commands

CONTrol:ECAL:MODule[num]:STATe <value>

CONTrol:AUXiliary:C[:DATA] <num>

CONTrol:AUXiliary:C:LOGic <char>

CONTrol:AUXiliary:C:MODE <char>

CONTrol:AUXiliary:FOOTswitch?

CONTrol:AUXiliary:FOOTswitch:MODE <char>

CONTrol:AUXiliary:INPut:VOLTage?

CONTrol:AUXiliary:OUTPut<out>:MODE <char>

CONTrol:AUXiliary:OUTPut<out>:VOLTage <num>

CONTrol:AUXiliary:PASSfail:LOGic <char>

CONTrol:AUXiliary:PASSfail:MODe <char>

CONTrol:AUXiliary:PASSfail:SCOPe <char>

CONTrol:AUXiliary:PASSfail:POLicy <char>

CONTrol:AUXiliary:PASSfail:STATus?

CONTrol:AUXiliary:SWEepend <char>

Control External Test Set Commands

CONTrol:EXTernal:TESTset:DATa <addr>,<data>

CONTrol:EXTernal:TESTset:INTerrupt?

CONTrol:EXTernal:TESTset:RAWData <data>

CONTrol:EXTernal:TESTset:SWEepholdoff?

Control Handler Commands

CONTrol:HANDler:C:MODE <char>

CONTrol:HANDler:D:MODE <char>

CONTrol:HANDler:<port>[:DATa] <num>

CONTrol:HANDler:INPut?

CONTrol:HANDler:LOGic <char>

CONTrol:HANDler:OUTPut<num>[:DATa] <num2>

CONTrol:HANDler:OUTPut<num>:USER[:DATa] <num2>

CONTrol:HANDler:PASSfail:LOGic <char>

CONTrol:HANDler:PASSfail:MODe <char>

CONTrol:HANDler:PASSfail:SCOPe <char>

CONTrol:HANDler:PASSfail:POLicy

CONTrol:HANDler:PASSfail:STATus?

CONTrol:HANDler:SWEepend <char>

Control Signal Commands

CONTrol:SIGNal <conn>,<char>

CONTrol:SIGNal:TRIGger:ATBA <bool>

CONTrol:SIGNal:TRIGger:OUTP <bool>

DISPLAY Commands

DISPlay:ANNotation:FREQuency[:STATe] <ON | OFF>

DISPlay:ANNotation:MESSage:STATe <ON | OFF>

DISPlay:ANNotation:STATus <ON|OFF>

DISPlay:ARRange <char>

DISPlay:CATalog?

DISPlay:ENABLE <ON | OFF>

DISPlay:FSIGn <ON | OFF>

DISPlay[:TILE] OBSOLETE

DISPlay:WINDow<wnum>:ANNotation:MARKer:SINGle[:STATe] <bool>

DISPlay:WINDow<wnum>:ANNotation:MARKer:SIZE <char>

DISPlay:WINDow<wnum>:ANNotation:MARKer:STATe <ON|OFF>

DISPlay:WINDow<wnum>:ANNotation:TRACe:STATe <ON|OFF>

DISPlay:WINDow<wnum>:CATalog?

DISPlay:WINDow<wnum>:ENABle <ON | OFF>

DISPlay:WINDow<wnum>:SIZE MIN | MAX | NORM

DISPlay:WINDow<wnum>[:STATe] <ON | OFF>

DISPlay:WINDow<wnum>:TABLe <char>

DISPlay:WINDow<wnum>:TITLe:DATA <string>

DISPlay:WINDow<wnum>:TITLe[:STATe] <ON | OFF>

DISPlay:WINDow<wnum>:TRACe<tnum>:DELete

DISPlay:WINDow<wnum>:TRACe<tnum>:FEED <name>

DISPlay:WINDow<wnum>:TRACe<tnum>MEMory[:STATe] <ON | OFF>

DISPlay:WINDow<wnum>:TRACe<tnum>:SELect

DISPlay:WINDow<wnum>:TRACe<tnum>[:STATe] <ON | OFF>

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:AUTO

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision <num>

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel <num>

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition <num>

FORMAT Commands

FORMat:BORDer <char>

FORMat[:DATA] <char>

HARDCOPY Command

HCOPy:FILE

HCOPy[:IMMediate]

INITIATE Commands

INITiate:CONTinuous <boolean>

INITiate<cnum>[:IMMediate]

MMEMORY Commands

MMEMory:CATalog[:<char>]? [<folder>]

MMEMory:CDIRectory <folder>

MMEMory:COPY <file1>,<file2>

MMEMory:DELete <file>

MMEMory:LOAD[:<char>] <file>

MMEMory:MDIRectory <folder>

MMEMory:MOVE <file1>,<file2>

MMEMory:RDIRectory <folder>

MMEMory:STORe[:<char>] <file>

MMEMory:STORe:CITI:DATA <filename>

MMEMory:STORe:CITI:FORMat <filename>

MMEMory:STORe:TRACe:CONTents:CITifile <char>

MMEMory:STORe:TRACe:FORMat:CITifile <char>

MMEMory:STORe:TRACe:FORMat:SNP <char>

MMEMory:TRANsfer <fileName>,<dataBlock>

OUTPUT Command

OUTPut[:STATe] <ON | OFF>

SENS:AVERAGE Commands

SENSe<cnum>:AVERage:CLEar

SENSe<cnum>:AVERage:COUNt <num>

SENSe<cnum>:AVERage[:STATe] <ON | OFF>

SENSE:BANDWIDTH Command

SENSe<cnum>:BANDwidth | BWIDth[:RESolution] <num>

SENSe<cnum>:BANDwidth | BWIDth:TRACk <bool>

SENSE:CORRECTION Commands

SENSe<cnum>:CORRection:CCHeck[:ACQuire] <char>

SENSe<cnum>:CORRection:CCHeck:DONE

SENSe<cnum>:CORRection:CCHeck:PARameter <Mname>

SENSE:CORRECTION:CKIT Commands

SENSe:CORRection:CKIT:CLEar[:IMMediate]

SENSe:CORRection:CKIT:COUNt?

SENSe:CORRection:CKIT:ECAL<mod>:CLISt?

SENSe:CORRection:CKIT:ECAL<mod>:INFormation? [<char>]

SENSe:CORRection:CKIT:ECAL:LIST?

SENSe:CORRection:CKIT:IMPort <string>

SENSe:CORRection:CKIT:INITialize[:IMMediate]

SENSe:CORRection:CKIT:LOAD <string>

SENSE:CORRECTION:COLLECT

S ENSe:CORRection:COLLect[:ACQuire] <class>[,sub]

SENSe:CORRection:COLLect:APPLy

SENSe<cnum>:CORRection:COLLect:METHod <char>

SENSe<cnum>:CORRection:COLLect:SAVE

SENSE:CORRECTION:COLLECT:CKIT Commands

SENSe:CORRection:COLLect:CKIT:CONNector:ADD <family>,<start>,<stop>,<z0>,<gender>,<media>,<cutoff>

SENSe:CORRection:COLLect:CKIT:CONNector:CATalog?

SENSe:CORRection:COLLect:CKIT:CONNector:DELete

SENSe:CORRection:COLLect:CKIT:CONNector:FNAME <name>

SENSe:CORRection:COLLect:CKIT:CONNector:SNAMe <family>,<gender>,<port>

SENSe:CORRection:COLLect:CKIT:DESCription <string>

SENSe:CORRection:COLLect:CKIT:INFormation? <module>[,char]

SENSe:CORRection:COLLect:CKIT:NAME <name>

SENSe:CORRection:COLLect:CKIT:OLABel<class> <name>

SENSe:CORRection:COLLect:CKIT:OLIST[class]?

SENSe:CORRection:COLLect:CKIT:ORDer<class> <std> [,<std>] [,<std>] [,<std>] [,<std>] [,<std>] [,<std>]

SENSe:CORRection:COLLect:CKIT:RESet <num>

SENSe:CORRection:COLLect:CKIT[:SELect] <num>

SENSe:CORRection:COLLect:CKIT:STANdard:C0 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:C1 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:C2 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:C3 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter <char>

SENSe:CORRection:COLLect:CKIT:STANdard:DELay <num>

SENSe:CORRection:COLLect:CKIT:STANdard:FMAX <num>

SENSe:CORRection:COLLect:CKIT:STANdard:FMIN <num>

SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance <num>

SENSe:CORRection:COLLect:CKIT:STANdard:L0 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:L1 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:L2 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:L3 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:LABel <name>

SENSe:CORRection:COLLect:CKIT:STANdard:LOSS <num>

SENSe:CORRection:COLLect:CKIT:STANdard:REMove

SENSe:CORRection:COLLect:CKIT:STANdard:SDEScription <string>

SENSe:CORRection:COLLect:CKIT:STANdard[:SELECT] <num>

SENSe:CORRection:COLLect:CKIT:STANdard:TYPE <char>

SENSe:CORRection:COLLect:CKIT:STANdard:TZImag <num>

SENSe:CORRection:COLLect:CKIT:STANdard:TZReal <num>

SENSe:CORRection:COLLect:CKIT:TRLoption:IMPedance <char>

SENSe:CORRection:COLLect:CKIT:TRLoption:RPLane <char>

SENSE:CORRECTION:COLLECT:GUIDED Commands

SENSe<cnum>:CORRection:COLLect:GUIDed:ACQuire <std>

SENSe<cnum>:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>:CATalog?

SENSe<cnum>:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>[:SELect] <kit>

SENSe<cnum>:CORRection:COLLect:GUIDed:CONNector:CATalog?

SENSe<cnum>:CORRection:COLLect:GUIDed:CONNector:PORT<pnum>[:SELect] <conn>

SENSe<cnum>:CORRection:COLLect:GUIDed:DESCription? <step>

SENSe<cnum>:CORRection:COLLect:GUIDed:INITiate

SENSe<cnum>:CORRection:COLLect:GUIDed:METHod

SENSe<cnum>:CORRection:COLLect:GUIDed:SAVE

SENSe<cnum>:CORRection:COLLect:GUIDed:STEPs?

SENSE:CORRECTION:COLLECT:SESSION Commands

SENSe<ch>:CORRection:COLLect:SESSion<n>:ACQuire <step>

SENSe<ch>:CORRection:COLLect:SESSion<n>:CKIT:PORT<pnum>:CATalog?

SENSe< ch>:CORRection:COLLect:SESSion<n>:CKIT:PORT<pnum>[:SELect] <kit>

SENSe<ch>:CORRection:COLLect:SESSio n<n>:CONNector:PORT<pnum>[:SELect] <conn>

SENSe<ch>:CORRection:COLLect:SESSio n<n>:DESCription? <step>

SENSe<ch>:CORRection:COLLect:SESSio n<n>:INITiate<string>

SENSe<ch>:CORRection:COLLect:SESSi on<n>:DONE

SENSe<ch>:CORRection:COLLect:SESSio n<n>:SAVE?

SENSe<ch>:CORRection:COLLect:SESSion<n>:STEPs?

SENSE:CORRECTION:COLLECT:SESSION:SMC Commands

SENSe<ch>:CORRection:COLLect:SESSion<n >:SMC:ECAL:CHARacteriza <mod> ,<char>

SENSe<ch>:CORRection:COLLect:SESSion<n>:SMC:PWRCal:SRCPort <char>

S ENSe<ch>:CORRection:COLLect:SESSion<n>:SMC:TWOPort:ECAL:ORIentation[:STATe] <bool>

SENSe<ch>:CORRection:COLLect:SESSion<n>:SMC:TWOPort:ECAL:PORTmap <mod>, <string>

SENSe<ch>:CORRection:COLLect:SESSion<n >:SMC:TWOPort:METHod <char>

SENSe<ch>:CORRection:COLLect:SESSion<n >:SMC:TWOPort:OMITisolat <bool>

SENSe<ch>:CORRection:COLLect:SESSion<n >:SMC:TWOPort:OPTion <char>

SENSE:CORRECTION:COLLECT:SESSION:VMC Commands

SENSe<ch>:CORRection:COLLect:SESSion<n>:VMC:CHARacterize:CAL:FILename <string>

SENSe<ch>:CORRection:COLLect:SESSion<n>:VMC:MIXer:CHARacterize:CAL: OPTion <char>

SENSe<ch>:CORRection:COLLect:SESSion<n>:VMC:MIXer:CHARacterize:CAL: REVerse <bool>

SENSe<ch>:CORRection:COLLect:SESSion<n>:VMC: MIXer:ECAL:CHARacteriza <mod> ,<char>

SENSe<ch>:CORRection:COLLect:SESSion<n>:VMC:MIXer:ECAL:PORTmap <mod>, <string>

SENSe<ch>:CORRection:COLLect:SESSion<n>:VMC:OPERation <char>

SENSe<ch>:CORRection:COLLect:SESSion<n >:VMC:TWOPort:ECAL:CHARacteriza <mod> ,<char>

SENSe<ch>:CORRection:COLLect:SESSion<n >:VMC:TWOPort:ECAL:ORIentation[:STATe] <bool>

SENSe<ch>:CORRection:COLLect:SESSion<n >:VMC:TWOPort:ECAL:PORTmap <mod>, <string>

SENSe<ch>:CORRection:COLLect:SESSion<n >:VMC:TWOPort:METHod <char>

SENSe<ch>:CORRection:COLLect:SESSion<n >:VMC:TWOPort:OMITisolat <bool>

SENSe<ch>:CORRection:COLLect:SESSion<n >:VMC:TWOPort:OPTion <char>

SENSE:CORRECTION:CSET Commands

SENSe:CORRection:CSET:CATalog?

SENSe<cnum>:CORRection:CSET:DELete <string>

SENSe<cnum>:CORRection:CSET:DESCription <string>

SENSe<cnum>:CORRection:CSET:GUID <string>

SENSe<cnum>:CORRection:CSET[:SELect] <char>

SENSe<cnum>:CORRection:CSET:SAVE <char>

SENSe<cnum>:CORRection:CSET:TYPE:CATalog?

SENSE:CORRECTION:

SENSe<cnum>:CORRection:EXTension:PORT<pnum>[:TIME] <num>

SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum>[:TIME] <num>

SENSe<cnum>:CORRection:EXTension[:STATe] <ON | OFF>

SENSe:CORRection:IMPedance:INPut:MAGNitude <num>

SENSe<cnum>:CORRection:INTerpolation[:STATe] <ON | OFF>

SENSe<cnum>:CORRection:ISOLation[:STATe] <ON | OFF>

SENSe:CORRection:PREFerences:ECAL:ORIentation[:STATe] <ON|OFF>

SENSe:CORRection:PREFerences:ECAL:PMAP <module>,<string>

SENSe<cnum>:CORRection:RVELocity:COAX <num>

SENSe:CORRection:SFORward[:STATe] <boolean>

SENSe<cnum>:CORRection[:STATe] <ON | OFF>

SENSe:CORRection:TSTandards[:STATe] <boolean>

SENSe:CORRection:TYPE:CATalog? <char>

SENSE:COUPLE Command

SENSe<cnum>:COUPle <ALL | NONE>

SENSe<cnum>:COUPle:PARameter

SENSE:FREQUENCY Commands

SENSe<cnum>:FREQuency:CENTer <num>

SENSe<cnum>:FREQuency[:CW |:FIXed] <num>

SENSe<cnum>:FREQuency:SPAN <num>

SENSe<cnum>:FREQuency:STARt <num>

SENSe<cnum>:FREQuency:STOP <num>

SENSe:IF Commands

SENSe<cnum>:IF:FILTer:SAMPle:COUNt <num>

SENSe<cnum>:IF:FILTer:SAMPle:COUNt:MODE <char>

SENSe<cnum>:IF:FILTer:SAMPle:PERiod <num>

SENSe<cnum>:IF:FILTer:SAMPle:PERiod:CATalog?

SENSe<cnum>:IF:FILTer:SAMPle:PERiod:MODE <char>

SENSe<cnum>:IF:GAIN:ALL[:STATe] <char>

SENSe<cnum>:IF:GAIN:LEVel <id>, <level>

SENSe<cnum>:IF:GAIN[:STATe]?, <id>

SENSe<cnum>:IF:GATE:STATe <boolean>

SENSe<cnum>:IF:SOURce:PATH <id>, <char>

SENSe:MIXer Commands

SENSe<ch>:MIXer:APPLy

SENSe<ch>:MIXer:AVOidspurs <bool>

SENSe<ch>:MIXer:CALCulate <char>

SENSe<ch>:MIXer:IF:FREQuency:DENominator <value>

SENSe<ch>:MIXer:IF:FREQuency:FIXed <value>

SENSe<ch>:MIXer:IF:FREQuency:NUMerator <value>

SENSe<ch>:MIXer:IF:FREQuency:SIDeband <value>

SENSe<ch>:MIXer:IF:FREQuency:STARt <value>

SENSe<ch>:MIXer:IF:FREQuency:STOP <value>

SENSe<ch>:MIXer:INPut:FREQuency:DENominator <value>

SENSe<ch>:MIXer:INPut:FREQuency:FIXed<value>

SENSe<ch>:MIXer:INPut:FREQuency:NUMerator <value>

SENSe<ch>:MIXer:INPut:FREQuency:STARt <value>

SENSe<ch>:MIXer:INPut:FREQuency:STOP <value>

SENSe<ch>:MIXer:INPut:POWer <value>

SENSe<ch>:MIXer:LO<n>:FREQuency:DENominator <value>

SENSe<ch>:MIXer:LO<n>:FREQuency:FIXed <value>

SENSe<ch>:MIXer:LO<n>:FREQuency:ILTI <value>

SENSe<ch>:MIXer:LO<n>:FREQuency:MODE <char>

SENSe<ch>:MIXer:LO<n>:FREQuency:NUMerator <value>

SENSe<ch>:MIXer:LO<n>:NAME <value>

SENSe<ch>:MIXer:LO<n>:POWer <value>

SENSe<ch>:MIXer:LOAD <name>

SENSe<ch>:MIXer:OUTput:FREQuency:SIDeband <value>

SENSe<ch>:MIXer:OUTput:FREQuency:STARt <value>

SENSe<ch>:MIXer:OUTput:FREQuency:STOP <value>

S ENSe<ch>:MIXer:SAVE <name>

SENSe<ch>:MIXer:STAGe <n>

SENSe:OFFSet Commands

SENSe<cnum>:OFFSet:CW <bool>

SENSe<cnum>:OFFSet:DIVisor <num>

SENSe<cnum>:OFFSet:MULTiplier <num>

SENSe<cnum>:OFFSet:OFFSet <num>

SENSe<cnum>:OFFSet:STARt?

SENSe<cnum>:OFFSet:[STATe] <bool>

SENSe<cnum>:OFFSet:STOP?

SENSE:POWER Command

SENSe<cnum>:POWer:ATTenuation <recvr>,<num>

SENSE:ROSCILLATOR Command

SENSe:ROSCillator:SOURce?

SENSE:SEGMENT Commands

SENSe<cnum>:SEGMent<snum>:ADD

SENSe<cnum>:SEGMent:ARBitrary

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution] <num>

SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol <ON | OFF>

SENSe<cnum>:SEGMent:COUNt?

SENSe<cnum>:SEGMent<snum>:DELete

SENSe<cnum>:SEGMent:DELete:ALL

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer <num>

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN <num>

SENSe<cnum>:SEGMent<snum>:FREQuency:START <num>

SENSe<cnum>:SEGMent<snum>:FREQuency:STOP <num>

SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel] <num>

SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol <ON | OFF>

SENSe<cnum>:SEGMent<snum>[:STATe] <ON | OFF>

SENSe<cnum>:SEGMent<snum>:SWEep:POINts <num>

SENSe<cnum>:SEGMent<snum>:SWEep:TIME <num>

SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol <ON | OFF>

SENSe<cnum>:SEGMent<snum>:X:SPACing <char>

SENSE:SWEEP Commands

SENSe<cnum>:SWEep:DWELl <num>

SENSe<cnum>:SWEep:DWELl:AUTO <ON | OFF>

SENSe<cnum>:SWEep:GENeration <char>

SENSe<cnum>:SWEep:GROups:COUNt <num>

SENSe<cnum>:SWEep:MODE <char>

SENSe<cnum>:SWEep:POINts <num>

SENSe<cnum>:SWEep:SRCPort <1 | 2>

SENSe<cnum>:SWEep:TIME <num>

SENSe<cnum>:SWEep:TIME:AUTO <ON | OFF>

SENSe<cnum>:SWEep:TRIGger:DELay <num>

SENSe<cnum>:SWEep:TRIGger:POINt <ON | OFF>

SENSe<cnum>:SWEep:TYPE <char>

SENSE:X: Command

SENSe<cnum>:X:VALues?

SOURCE Commands

SOURce<cnum>:POWer<port>:ATTenuation <num>

SOURce<cnum>:POWer<port>:ATTenuation:AUTO <ON | OFF>

SOURce<cnum>:POWer:CENTer <num>

SOURce<cnum>:POWer:COUPle <ON | OFF>

SOURce<cnum>:POWer:DETector <INTernal | EXTernal>

SOURce<cnum>:POWer<port>[:LEVel][:IMMediate] [:AMPLitude] <num>

SOURce<cnum>:POWer[:LEVel]:SLOPe <int>

SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe <ON|OFF>

SOURce<cnum>:POWer:SPAN <num>

SOURce<cnum>:POWer:STARt <num>

SOURce<cnum>:POWer:STOP <num>

SOURCE:POWER:CORRECTION Commands

SOURce<cnum>:POWer<port>:CORRection:COLLect:ABORt

SOURce<cnum>:POWer<port>:CORRection:COLLect[:ACQuire] <char>

SOURce<cnum>:POWer<port>:CORRection:COLLect:AVERage[:COUNt] <num>

SOURce<cnum>:POWer<port>:CORRection:COLLect:AVERage:NTOLerance <num>

SOURce<cnum>:POWer:CORRection:COLLect:DISPlay[:STATe] <ON | OFF>

SOURce<cnum>:POWer:CORRection:COLLect:FCHeck[:STATe] <ON | OFF>

SOURce<cnum>:POWer<port>:CORRection:COLLect:ITERation[:COUNt] <num>

SOURce<cnum>:POWer<port>:CORRection:COLLect:ITERation:TOLerance <num>

SOURce<cnum>:POWer<port>:CORRection:COLLect:METHod <char>

SOURce<cnum>:POWer<port>:CORRection:COLLect:SAVE

SOURce<cnum>:POWer:CORRection:COLLect:<pmChan>SENsor[:FRANge] <num1>,<num2>

SOURce<cnum>:POWer:CORRection:COLLect:<pmChan>SENsor:RCFactor <num>

SOURce<cnum>:POWer:CORRection:COLLect:<pmChan>SENsor:SELect

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:DATA <data>

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:FREQuency <data>

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:LOSS[:STATe] <ON | OFF>

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:POINts?

SOURce<cnum>:POWer:CORRection:COLLect:TABLe[:SELect] <char>

SOURce<cnum>:POWer<port>:CORRection:DATA <data>

SOURce<cnum>:POWer<port>:CORRection:LEVel <num>

SOURce<cnum>:POWer<port>:CORRection:OFFSet[:MAGNitude] <num>

SOURce<cnum>:POWer<port>:CORRection[:STATe] <ON|OFF>

STATUS REGISTER Commands

Status Byte Register Commandsr

STATus:QUEStionable:<keyword>

STATus:QUEStionable:INTegrity <keyword>

STATus:QUEStionable:INTegrity:HARDware<keyword>

STATus:QUEStionable:INTegrity:MEASurement<n> <keyword>

STATus:QUEStionable:LIMit<n> <keyword>

STATus:QUEStionable:DEFine<keyword>

STATus:QUEStionable:DEFine:USER<1|2|3><keyword>

Standard Event Status Register Commands

STATus:OPERation<keyword>

STATus:OPERation:AVERaging<n> <keyword>

STATus:OPERation:DEFine<keyword>

STATus:OPERation:DEFine:USER<1|2|3><keyword>

SYSTEM Commands

SYSTem:CHANnels:HOLD

SYSTem:CHANnels:RESume

S YSTem:COMMunicate:GPIB:PMETer:ADDRess <num>

SYSTem:COMMunicate:GPIB:RDEVice:CLOSe <ID>

SYSTem:COMMunicate:GPIB:RDEVice:OPEN <bus>, <addr>, <timeout>

SYSTem:COMMunicate:GPIB:RDEVice:READ? <ID>

SYSTem:COMMunicate:GPIB:RDEVice:RESet

SYSTem:COMMunicate:GPIB:RDEVice:WBINary

SYSTem:COMMunicate:GPIB:RDEVice:WBLock

SYSTem:COMMunicate:GPIB:RDEVice:WRITe <ID>,<string>

SYSTem:CORRection:WIZard <char>

SYSTem:ERRor?

SYSTem:ERRor:COUNt?

SYSTem:FPReset

SYSTem:MACRo:COPY:CHANnel

SYSTem:PRESet

SYSTem:SECurity[:LEVel]

SYSTem:UPReset

SYSTem:UPReset:FPANel[:STATe] <bool>

SYSTem:UPReset:LOAD <file>

SYSTem:UPReset:SAVE[:STATe]

TRIGGER Commands

TRIGger:DELay<num>

TRIGger[:SEQuence]:LEVel <char> OBSOLETE

TRIGger[:SEQuence]:SCOPe <char>

TRIGger[:SEQuence]:SOURce <char>


SCPI Command Tree

See a List of ALL SCPI commands

IEEE- 488.2 Common Commands

Local Lockout

ABORt

Stops all sweeps

CALCulate Click to hide and show CALC commands

:CORRection | Sets Electrical Delay and Phase Offset
:CUSTom | Creates custom measurements
:DATA | Sends and queries data.
:FILTer | Sets time domain gating
:FORMat | Sets the display format
:FSIM:BALun | Configures Balanced measurements.
:FSIM:SEND | Controls Fixture Embed/De-embedding.
:FUNCtion | Controls Trace Statistics.
:LIMit | Controls limit lines for pass / fail testing.
:MARKer | Controls the marker settings.
:MATH | Performs math on the memory trace.
:MIXer | Sets the X-axis display for FCA measurements.
:NORMalize | Performs normalization for a receiver power cal.
:OFFSet | Sets Phase and Mag offset.
:PARameter | Creates and deletes measurements.
:RDATa? | Queries receiver data.
:SMOothing | Controls point-to-point smoothing.
:TRANsform | Controls time domain transform settings.
CONTrol | Controls the rear-panel connectors
DISPlay | Controls the display settings
FORMat | Sets the format for data transfer
HCOPy | Controls hardcopy printing
INITiate | Sets continuous or manual triggering
MMEMory | Saves and recalls instrument states
OUTPut | Turns RF power ON and OFF

SENSe Click to hide and show SENSe commands

:AVErage | Sets sweep averaging parameters
:BANDwidth | Specifies the IF filter bandwidth
:CORRection | Provides non-guided calibration capability
:CORR:CKIT | Manage Cal Kits
:CORR:COLL:CKIT | Defines calibration standards
:CORR:CSET | Manages Cal Sets
:CORR:COLL:GUID | Provides Guided calibration capability
:CORR:COLL:SESS | Provides VMC and SMC calibration capability.
:COUPle | Sets sweep as Chopped or Alternate
:FREQuency | Controls frequency sweep functions
:IF | Controls IF Access capability
:MIXer | Sets mixer measurement configuration
:OFFSet | Sets frequency offset functions
:POWer | Sets receiver attenuation and overpower protection
:ROSCillator | Returns the source of the reference oscillator.
:SEGMent | Defines the segment sweep settings.
:SWEep | Specifies the sweep modes of the analyzer.
:X:VALues | Returns X-axis values
SOURce | Controls the power to the DUT
SOURce:POWer | Provides for Source Power Correction
STATus | Reads the analyzer status registers
SYSTem | Controls the analyzer defaults
TRIGger | Starts or ends a measurement


Abort SCPI

About Triggering

Abort Command

ABORt

(Write-only) Stops all sweeps - then resume per current trigger settings. This command is the same as INITtiate:IMMediate (restart) except if a channel is performing a single sweep, ABORt will stop the sweep, but not initiate another sweep.
Examples | ABOR abort
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable


Correction SCPI

Calc:Correction Commands

Controls error correction functions.

  • Click on a blue keyword to view the command details.

  • New See Calibrating the PNA Using SCPI

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. To select the measurement use CALC<cnum>:PAR:SEL <MeasName>.

CALCulate<cnum>:CORRection:EDELay:MEDium <char>

(Read-Write) Sets the media used when calculating the electrical delay.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<num> | Choose from: COAX for coaxial medium, WAVEguide for waveguide medium.
Examples | CALC:CORR:EDEL:MED COAX calc3:corr:edelay:medium waveguide
Query Syntax | CALCulate<cnum>:CORRection:EDELay:MEDium?
Return Type | Character
Overlapped? | No
Default | COAX

CALCulate<cnum>:CORRection:EDELay:TIME <num>

(Read-Write) Sets the electrical delay for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Electrical delay in seconds. Choose any number between: -10.00 and 10.00 Use SENS:CORR:RVEL:COAX <num> to set Velocity factor.
Examples | CALC1:CORR:EDEL:TIME 1NS calculate2:correction:time 0.5e-12
Query Syntax | CALCulate:CORRection:EDELay:TIME?
Return Type | Numeric
Overlapped? | No
Default | 0 seconds

CALCulate<cnum>:CORRection:EDELay:WGCutoff <num>

(Read-Write) Sets the waveguide cutoff frequency used when the electrical delay media is set to WAVEguide. (See CALCulate:CORRection:EDELay:MEDium <char>.)
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<num> | Waveguide cutoff frequency used with the electrical delay calculation.
Examples | CALC:CORR:EDEL:WGC 18.067 GHz calculate3:correction:edelay:wgcutoff 14.047 ghz
Query Syntax | CALCulate<cnum>:CORRection:EDELay:WGCutoff?
Return Type | Numeric
Overlapped? | No
Default | 45 MHz

CALCulate<cnum>: CORRection:[STATe] <bool>

(Read-Write) Turns error correction ON or OFF for the selected measurement on the specified channel. Critical Note: Note: You must set the error correction type (CALC:CORR:TYPE) before turning error correction ON.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | Correction state. Choose from: 0 - Correction OFF 1 - Correction ON
Examples | CALC:CORR ON calculate:correction:state off
Query Syntax | CALCulate<cnum>: CORRection: STATe?
Return Type | Boolean
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:CORRection:TYPE <string>

(Read-Write) Sets the Cal Type for the selected measurement on the specified channel. This is used when a Cal Set is applied.

  • Use SENS:CORR:TYPE:CAT? to list the Cal Types in the PNA.

  • Use SENS:CORR:CSET:TYPE:CAT? to list the Cal Types contained in the active Cal Set for the channel.

  • Use SENS:CORR:COLL:METH to set the Cal type to perform a new calibration,

Critical Note:

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<string>

Cal Type. Choose from:

  • "Full 1 Port"

  • "Full 2 Port SOLT"

  • "Full 2 Port TRL"

  • "Full 3 Port SOLT"

  • "Open Response"

  • “SMC_2P” or “SMC”

  • “SMCRsp+IN”

  • “SMCRsp+OUT”

  • “SMCRsp”

  • "Short Response"

  • "Thru Response"

  • "Thru Response and Isolation"

  • "VMC"

Learn more applying SMC cal sets

Examples

CALC:CORR:TYPE "VMC"

Query Syntax

CALCulate<cnum>:CORRection:TYPE?

Return Type

String

Overlapped?

No

Default

Not Applicable

CALCulate<cnum>:CORRection:OFFSet[:MAGNitude] <num>

(Read-Write) For Receiver Power Calibration, specifies the power level to which the selected (unratioed) measurements data is to be adjusted. This command applies only when the selected measurement is of unratioed power. :Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Cal power level in dBm. No limits are enforced on this value, but the PNA receivers themselves have maximum and minimum power specifications (that may differ between PNA models) which this value must comply with for a valid receiver power cal.
Examples | CALC:CORR:OFFS 10DBM calculate1:correction:offset:magnitude maximum
Query Syntax | CALCulate<cnum>:CORRection:OFFSet[:MAGNitude]?
Return Type | Numeric
Overlapped? | No
Default | 0dBm

CALCulate<cnum>:CORRection:OFFSet:PHASe <num>[<char>] - OBSOLETE

(Read-Write) Replaced with CALC:OFFSet:PHASe Sets the phase offset for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Offset phase value. Choose any number between: -360 and 360
<char> | Units for phase. OPTIONAL. Choose either: DEG - Degrees (default) RAD - Radians
Examples | CALC:CORR:OFFS:PHAS 10 calculate:correction:offset:phase 20rad
Query Syntax | CALCulate:CORRection:OFFSet:PHASe?
Return Type | Numeric, returned value always in degrees
Overlapped? | No
Default | 0 degrees


Custom SCPI

Calculate:Custom Commands

Provides capability to create and modify Frequency Converter Application (opt 083) measurements.

CALCulate<cnum>:CUSTom:DEFine <Mname>, <ProgID> [,param]

(Write-only) Creates a custom measurement. The custom measurement is not automatically displayed. You must also do the following:

  • Use DISP:WIND:STATe to create a window if it doesn't already exist.·

  • Use DISP:WIND:TRAC:FEED to display the measurement

  • Select the measurement (CALC:PAR:SEL) before making additional settings.

See an example using this command to create a VMC and SMC measurement

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<Mname>

Name of the measurement. Any non-empty, unique string, enclosed in quotes.

<ProgID>

The type of custom measurement. Choose from:

  • FCA.VMCMeas

  • SMC_Forward.SMC_ForwardMeas

  • SMC_Reverse.SMC_ReverseMeas

[param]

Optional parameter specifies the measurement parameter to create.

Program ID | Valid Parameters:
FCA.VMCMeas | "S11" "VC21" "S22"
SMC_Forward.SMC_ForwardMeas | "S11" "SC21" "S22" "IPwr" "OPwr"
SMC_Reverse.SMC_ReverseMeas | "S11" "SC12" "S22" "IPwr" "OPwr"

Examples

CALC2:CUST:DEF 'My VC21', 'FCA.VMCMeas','S22'

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:CUSTom:MODify <param>

(Write-only) Changes the selected custom measurement to a different parameter.

See an example using this command for a VMC and SMC measurement

Parameters

<cnum>

Channel of the custom measurement to be changed. First, select the measurement using CALC:PAR:SEL.

<param>

Parameter to change the custom measurement to. Select a parameter that is valid for the type of measurement.

Type | Valid Parameters
VMC Measurement | "S11" "VC21" "S22"
SMC Forward Measurement | "S11" "SC21" "S22" "IPwr" "OPwr"
SMC Reverse Measurement | "S11" "SC12" "S22" "IPwr" "OPwr"

Examples

SYST:PRES

CALC2:CUST:DEF 'My VC21', 'FCA.VMCMeas'

CALC:PAR:SEL 'My VC21'

CALC2:CUST:MOD 'S22'

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable


Data SCPI

Calc:Data Commands

Controls sending and receiving data with the PNA

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See Data Access Map

CALCulate<cnum>:DATA <char>,<data>

Write Writes Measurement data, Memory data, Normalization Divisor data, or Error terms.

Data type depends on FORM:DATA command.

CALCulate<cnum>:DATA? <char>

Read Returns Measurement data, Memory data, Normalization Divisor data, or Error terms.

Data type depends on FORM:DATA command.

To write or read

  • Measurement (DATA)

  • Memory (MEM)

  • Normalization Divisor (DIV) (Receiver Power Cal error term)

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

FDATA

Formatted trace data from measResult location

Returns TWO numbers per data point for Polar and Smith Chart format
Returns one number per data point for all other formats

SDATA

Corrected complex trace data from rawMeas location

Returns TWO numbers per data point

FMEM

Formatted memory data from memResult location

Returns TWO numbers per data point for Polar and Smith Chart format
Returns one number per data point for all other formats

SMEM

Corrected complex data from rawMemory location

Returns TWO numbers per data point

SDIV

Receiver Power Cal error term.

Complex data from Normalization Divisor location

Returns TWO numbers per data point

Notes:

When reading data from, or writing data to, the normalization divisor, you must first create a divisor trace using CALC:NORMalize[:IMMediate].

If normalization interpolation is ON and the number of points changes after the initial normalization, the divisor data will then be interpolated.

To write or read Error Terms:

Note: All Error Terms return two numbers per trace point

For Response Open and Short calibrations:

SCORR3

Reflection Tracking Error Term

For Response Thru calibrations:

SCORR6

Transmission Tracking Error Term

For Response Thru and Isolation calibrations:

Specify this <char> | to get this Term...
SCORR4 | Isolation
SCORR6 | Transmission Tracking

For 1-Port calibrations:

Specify this <char> | to get this Term...
SCORR1 | Directivity
SCORR2 | Source Match
SCORR3 | Reflection Tracking

For 2-Port SOLT and TRL calibrations

Specify this <char> | to get this Term...
SCORR1 | Forward Directivity
SCORR2 | Forward Source Match
SCORR3 | Forward Reflection Tracking
SCORR4 | Forward Isolation
SCORR5 | Forward Load Match
SCORR6 | Forward Transmission Tracking
SCORR7 | Reverse Directivity
SCORR8 | Reverse Source Match
SCORR9 | Reverse Reflection Tracking
SCORR10 | Reverse Isolation
SCORR11 | Reverse Load Match
SCORR12 | Reverse Transmission Tracking

For FULL 3-Port SOLT calibrations

Specify this <char> | to get this Term... | for this Receiver Port .
SCORR13 | Directivity | 3 (S33)
SCORR14 | Source Match | 3 (S33)
SCORR15 | Reflection Tracking | 3 (S33)
SCORR16 | Isolation | 3 (S31)
SCORR17 | Load Match | 3 (S31)
SCORR18 | Trans Tracking | 3 (S31)
SCORR19 | Isolation | 1 (S13)
SCORR20 | Load Match | 1 (S13)
SCORR21 | Trans Tracking | 1 (S13)
SCORR22 | Isolation | 3 (S32)
SCORR23 | Load Match | 3 (S32)
SCORR24 | Trans Tracking | 3 (S32)
SCORR25 | Isolation | 2 (S23)
SCORR26 | Load Match | 2 (S23)
SCORR27 | Trans Tracking | 2 (S23)

EXAMPLE

CALC:DATA FDATA,Data(x)
calculate2:data sdata,data(r,i)

See another example using this command.

Return Type: Block data

Overlapped? - No

Default - Not Applicable

Notes:

  • When querying memory, you must first store a trace into memory using CALC:MATH:MEMorize.

  • When querying error terms, there must be error terms in the analyzer.

  • If interpolation is ON and the number of points changes after the initial calibration, the error terms will then be the interpolated results.

  • To get and put receiver data, see CALC:RDATA?

  • To get uncorrected ratioed data, turn correction OFF and use Calc:Data SDATA.

  • CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

Learn more about Error Terms

CALCulate<cnum>:DATA:CUSTom <name>,<data>

(Read-Write) Reads or writes data from a custom-named measurement buffer. Specify the measurement using CALCulate:PARameter:SELect. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<name> | Name of the buffer to be read or written
<data> | Data to be read or written to the custom buffer. Format as one number per data point.
Examples | CALC:DATA:CUST 'VectorResult0',0,1,2,3,4,5 'Write CALC:DATA:CUST? 'VectorResult0' 'Read
Query Syntax | CALCulate:DATA:CUSTom? <name>
Return Type | Depends on Form:Data
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:DATA:CUSTom:CATalog?

(Read-only) Reads the list of buffer names (comma separated list of string values) available from the selected parameter. Specify the measurement using CALCulate:PARameter:SELect. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:DATA:CUST:CAT? calculate:data:custom:catalog?
Return Type | String
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:DATA:SNP? <n>

(Read-only) Reads SnP data from the selected measurement. Learn more about SnP data. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<n>

Amount of data to return. If unspecified, <n> is set to 2. Choose from:

1 (S1P) returns data for the active measurement.

2 (S2P) returns data for the 2 port parameters associated with the current measurement. Default.

3 (S3P) returns data for the 3 port parameters associated with the current measurement. Valid only on instruments with more than 2 ports.

SnP data can be output using several data formatting options. See the command MMEM:STORe:TRACe:FORMat:SNP.

See also MMEM:STOR <file>.<snp>

Examples

CALC:PAR:DEF “MyMeasurement”, S11

CALC:PAR:SEL “MyMeasurement”

CALC:DATA:SNP? 1

Return Type

Depends on FORMat:DATA

Overlapped?

No

Default

Not Applicable


Filter SCPI

Calc:Filter Commands

Controls the gating function used in time domain measurements. The gated range is specified with either (start / stop) or (center / span) commands.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Gating

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:FILTer[:GATE]:COUPle:PARameters <num>

(Read-Write) Specifies the time domain gating parameters to be coupled. The settings for those parameters will be copied from the selected measurement to all other measurements on the channel.

  • To enable Trace Coupling, use SENS:COUP:PAR

  • To specify Transform parameters to couple, use CALC:TRAN:COUP:PAR

Learn more about Time Domain Trace Coupling

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

(Numeric) Parameters to couple. To specify more than one parameter, add the numbers.

1 - Gating Stimulus (Start, Stop, Center, and Span TIME settings.)

2 - Gating State (ON / OFF)

4 - Gating Shape (Minimum, Normal, Wide, and Maximum)

8 - Gating Type (Bandpass and Notch)

Examples

'To couple all parameters:

CALC:FILT:COUP:PAR 15

'To couple Stimulus and Type:
calculate2:filter:gate:couple:parameters 9

Query Syntax

CALCulate<cnum>:FILTer:GATE:COUPle:PARameters?

Return Type

Numeric

Overlapped?

No

Default

13 (All parameters except 2 - Gating State)

CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer <num>

(R ead-Write) Sets the gate filter center time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Center time in seconds; Choose any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:GATE:TIME:CENT -5 ns calculate2:filter:time:center maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer?
Return Type | Numeric
Overlapped? | No
Default | 0

CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe <char>

(R ead-Write) Sets the gating filter shape when in time domain. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from MAXimum - the widest gate filter available WIDE - NORMal - MINimum - the narrowest gate filter available
Examples | CALC:FILT:GATE:TIME:SHAP MAX calculate2:filter:time:shape normal
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe?
Return Type | Character
Overlapped? | No
Default | NORMal

CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN <num>

(R ead-Write) Sets the gate filter span time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Time span in seconds; Choose any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:GATE:TIME:SPAN 5 ns calculate2:filter:time:span maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN?
Return Type | Numeric
Overlapped? | No
Default | 20 ns

CALCulate<cnum>:FILTer[:GATE]:TIME:STATe <boolean>

(R ead-Write) Turns gating state ON or OFF. Critical Note: Note: Sweep type must be set to LInear Frequency in order to use Transform Gating.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<boolean> | ON (or 1) - turns gating ON. OFF (or 0) - turns gating OFF.
Examples | CALC:FILT:TIME:STAT ON calculate2:filter:gate:time:state off
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:FILTer[:GATE]:TIME:STARt <num>

(R ead-Write) Sets the gate filter start time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:TIME:STAR 1e-8 calculate2:filter:gate:time:start minimum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STARt?
Return Type | Numeric
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:FILTer[:GATE]:TIME:STOP <num>

(R ead-Write) Sets the gate filter stop time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:TIME:STOP -1 ns calculate2:filter:gate:time:stop maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STOP?
Return Type | Numeric
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE] <char>

(R ead-Write) Sets the type of gate filter used. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: BPASs - Includes (passes) the range between the start and stop times. NOTCh - Excludes (attenuates) the range between the start and stop times.
Examples | CALC:FILT:TIME BPAS calculate2:filter:gate:time:type notch
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE]?
Return Type | Character
Overlapped? | No
Default | BPAS


Format SCPI

Calc:Format Command

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

  • See an example using this command.

  • See a List of all commands in this block.

  • Learn About Data Format

CALCulate<cnum>:FORMat <char>

(Read-Write) Sets the display format for the measurement. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Choose from:

  • MLINear

  • MLOGarithmic

  • PHASe

  • IMAGinary

  • REAL

  • POLar

  • SMITh

  • SWR

  • GDELay

Examples

CALC:FORM MLIN
calculate2:format polar

Query Syntax

CALCulate<cnum>:FORMat?

Return Type

Character

Overlapped?

No

Default

MLINear


Function SCPI

Calc:Function Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn a bout Trace Statistics

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:FUNCtion:DATA?

(Read-only) Returns the trace statistic data for the selected statistic type for the specified channel. Select the type of statistic with CALC:FUNC:TYPE. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Return Type

Depends on FORM:DATA

Example

CALCulate2:FUNCtion:DATA?

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe] <range>

(Read-Write) Sets the range used to calculate trace statistics. Each channel shares 10 domain ranges. The x-axis range is specified with the CALC:FUNC:DOM:USER:START and STOP commands. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number. Choose from: 0 to 9 0 is Full Span of the current x-axis range 1 to 9 are user-specified ranges
Examples | CALC:FUNC:DOM:USER 4 calculate2:function:domain:user:range 0
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe]?
Return Type | Numeric
Overlapped? | No
Default | 0 - Full Span

CALCulate<cnum>:FUNCtion:DOMain:USER:STARt <range>, <start>

(Read-Write) Sets the start of the specified user-domain range. To apply this range, use CALC:FUNC:DOM:USER To set the stop of the range, use CALC:FUNC:DOM:USER:STOP. Critical Note: Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STAR
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number that will receive the start value. Choose an integer between 1 and 9
<start> | Start value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:FUNC:DOM:USER:STAR 1,1e9 calculate2:function:domain:user:start 2,2e9
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER:STARt? <range>
Return Type | Numeric
Overlapped? | No
Default | The analyzer's Minimum x-axis value

CALCulate<cnum>:FUNCtion:DOMain:USER:STOP <range>, <stop>

(Read-Write) Sets the stop of the specified user-domain range. To apply this range, use CALC:FUNC:DOM:USER To set the start of the range, use CALC:FUNC:DOM:USER:START Critical Note: Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STOP
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number that will receive the stop value. Choose an integer between 1 and 9
<stop> | Stop value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:FUNC:DOM:USER:STOP 4,5e9 calculate2:function:domain:user:stop 3,8e9
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER:STOP? <range>
Return Type | Numeric
Overlapped? | No
Default | The analyzer's Maximum x-axis value

CALCulate<cnum>:FUNCtion:STATistics[:STATe] <ON|OFF>

(Read-Write) Displays and hides the measurement (Trace) statistics (peak-to-peak, mean, standard deviation) on the screen.

The analyzer will display either measurement statistics or Filter Bandwidth statistics; not both. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<ON|OFF>

ON - Displays trace statistics

OFF - Hides trace statistics

Examples

CALC:FUNC:STAT ON
calculate2:function:statistics:state off

Query Syntax

CALCulate<cnum>:FUNCtion:STATistics[:STATe]?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF (0)

CALCulate<cnum>:FUNCtion:TYPE <char>

(Read-Write) Sets statistic TYPE that you can then query using CALC:FUNCtion:DATA?. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: PTPeak - the difference between the max and min data points on the trace. STDEV - standard deviation of all data points on the trace MEAN - mean (average) of all data points on the trace
Examples | CALC:FUNC:TYPE PTP calculate2:function:type stdev
Query Syntax | CALCulate<cnum>:FUNCtion:TYPE?
Return Type | Character
Overlapped? | No
Default | PTPeak


Limit SCPI

Calc:Limit Commands

Controls the limit segments used for pass / fail testing.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Limit Lines

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:LIMit:DATA <block>

(Read-Write) Sets data for limit segments. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<block>

Data for all limit segments in REAL,64 format. The following is the data format for 1 segment:
Type,BegStim, EndStim, BegResp,EndResp

Type | Type of limit segment. Choose from 0 - Off 1 - Max 2 - Min
BegStim | Start of X-axis value (freq, power, time)
EndStim | End of X-axis value
BegResp | Y-axis value that corresponds with Start of X-axis value
EndResp | Y-axis value that corresponds with End of X-axis value

Examples

The following writes three max limit segments for a bandpass filter.

"CALC:LIM:DATA 1,3e5,4e9,-60,0,1,4e9,7.5e9,0,0,1,7.5e9,9e9,0,-30"

Query Syntax

CALCulate<cnum>:LIMit:DATA?

Return Type

Depends on FORM:DATA - All 100 predefined limit segments are returned.

Overlapped?

No

Default

100 limit segments - all values set to 0

CALCulate<cnum>:LIMit:DISPlay[:STATe] <ON | OFF>

(Read-Write) Turns the display of limit segments ON or OFF (if the data trace is turned ON). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns the display of limit segments ON. OFF (or 0) - turns the display of limit segments OFF.
Examples | CALC:LIM:DISP:STAT ON calculate2:limit:display:state off
Query Syntax | CALCulate<cnum>:LIMit:DISPlay[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt <num>

(Read-Write) Sets the start (beginning) of the Y-axis amplitude (response) value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500 Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:LIM:SEGM1:AMPL:STAR 10 calculate2:limit:segment2:amplitude:start 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt?
Return Type | Numeric
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP <num>

(Read-Write) Sets the stop (end) of the Y-axis amplitude (response) value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500 Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:LIM:SEGM1:AMPL:STOP 10 calculate2:limit:segment2:amplitude:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP?
Return Type | Numeric
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt <num>

(Read-Write) Sets the start (beginning) of the X-axis stimulus value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:LIM:SEGM1:STIM:STAR 10 calculate2:limit:segment2:stimulus:start 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt?
Return Type | Numeric
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP <num>

(Read-Write) Sets the stop (end) of the X-axis stimulus value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:LIM:SEGM1:AMPL:STOP 10 calculate2:limit:segment2:stimulus:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP?
Return Type | Numeric
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE <char>

(Read-Write) Sets the type of limit segment. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number. Choose any number between: 1 and 100 If unspecified, value is set to 1.
<char> | Choose from: LMAX - a MAX limit segment. Any response data exceeding the MAX value will fail. LMIN - a MIN limit segment. Any response data below the MIN value will fail. OFF - the limit segment (display and testing) is turned OFF.
Examples | CALC:LIM:SEGM:TYPE LMIN calculate2:limit:segment3:type lmax
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE?
Return Type | Character
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:SOUNd[:STATe] <ON | OFF>

(Read-Write) Turns limit testing fail sound ON or OFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns sound ON. OFF (or 0) - turns sound OFF.
Examples | CALC:LIM:SOUN ON calculate2:limit:sound:state off
Query Syntax | CALCulate<cnum>:LIMit:SOUNd[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:STATe <ON | OFF>

(Read-Write) Turns limit segment testing ON or OFF.

  • Use CALC:LIM:DISP to turn ON and OFF the display of limit segments.

  • If using Global Pass/Fail status, trigger the PNA AFTER turning Limit testing ON.

  • Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<ON | OFF>

ON (or 1) - turns limit testing ON.
OFF (or 0) - turns limit testing OFF.

Examples

CALC:LIM:STAT ON
calculate2:limit:state off

Query Syntax

CALCulate<cnum>:LIMit:STATe?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF


Marker SCPI

Calc:Marker Commands

Controls the marker settings used to remotely output specific data to the computer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See commands for controlling the marker readout number and size

  • Learn about Markers

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

Note: The Reference Marker is Marker Number 10

CALCulate<cnum>:MARKer:AOFF

(Write-only) Turns all markers off for selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:MARK:AOFF calculate2:marker:aoff
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

CALCulate<cnum>:MARKer:BWIDth <num>

(Read-Write) Turns on and sets markers 1 through 4 to calculate filter bandwidth. The <num> parameter sets the value below the maximum bandwidth peak that establishes the bandwidth of a filter. For example, if you want to determine the filter bandwidth 3 db below the bandpass peak value, set <num> to -3.

This feature activates markers 1 through 4. To turn off these markers, either turn them off individually or turn them All Off.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To search a User Range with the bandwidth search, first activate marker 1 and set the desired User Range. Then send the CALC:MARK:BWID command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.
Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

Target value below filter peak. Choose any number between:
-500 and 500

Examples

CALC:MARK:BWID -3
calculate2:marker:bwidth -2.513

Query Syntax

CALCulate<cnum>:MARKer:BWIDth?
Returns the results of bandwith search:

Return Type

Numeric - Four Character values separated by commas: bandwidth, center Frequency, Q, loss.

Overlapped?

No

Default

-3

CALCulate<cnum>:MARKer<mkr>:COUPling[:STATe]<ON|OFF>

(Read-Write) Sets and Reads the state of Coupled Markers (ON and OFF) Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | False (0) - Turns Coupled Markers OFF True (1) - Turns Coupled Markers ON
Examples | CALC:MARK:COUP ON calculate2:marker8:coupling off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:COUPling:[STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:DELTa <ON|OFF>

(Read-Write) Specifies whether marker is relative to the Reference marker or absolute. Note: The reference marker must already be turned ON with CALC:MARK:REF:STATE. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - Specified marker is a Delta marker OFF (or 0) - Specified marker is an ABSOLUTE marker
Examples | CALC:MARK:DELT ON calculate2:marker8:delta off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DELTa?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:DISCrete <ON|OFF>

(Read-Write) Makes the specified marker display either a calculated value between data points (interpolated data) or the actual data points (discrete data). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - Specified marker displays the actual data points OFF (or 0) - Specified marker displays calculated data between the actual data points.
Examples | CALC:MARK:DISC ON calculate2:marker8:discrete off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DISCrete?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:DISTance <num>

(Read-Write) Set or query marker distance on a time domain trace. The Write command moves the marker to the specified distance value. Once moved, you can read the Y axis value or read the X-axis time value. (Distance is calculated from the X-axis time value.) The Read command reads the distance of the marker. If the marker is set as delta, the WRITE and READ data is relative to the reference marker. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Marker distance in the unit of measure specified with CALC:TRAN:TIME:MARK:UNIT
Examples | CALC:MARK:DIST .1 calculate2:marker8:distance 5
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DISTance?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:MARKer<mkr>:FORMat <char>

(Read-Write) Sets the format of the data that will be returned in a marker data query CALC:MARK:Y? and the displayed value of the marker readout. The selection does not have to be the same as the measurement's display format. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1
<char> | Choose from: DEFault - The format of the selected measurement MLINear - Linear magnitude MLOGarithmic - Logarithmic magnitude IMPedance - (R+jX) ADMittance - (G+jB) PHASe - Phase IMAGinary - Imaginary part (Im) REAL - Real part (Re)l POLar - (Re, Im) GDELay - Group Delay LINPhase - Linear Magnitude and Phase LOGPhase - Log Magnitude and Phase
Examples | CALC:MARK:FORMat MLIN calculate2:marker8:format Character
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FORMat?
Return Type | Character
Overlapped? | No
Default | DEFault

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion <num>

(Read-Write) Sets amplitude peak excursion for the specified marker. The Excursion value determines what is considered a "peak". This command applies to marker peak searches (Next peak, Peak Right, Peak Left). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Excursion value. Choose any number between -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:EXC 10 calculate2:marker8:function:apeak:excursion maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion?
Return Type | Numeric
Overlapped? | No
Default | 3

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold <num>

(Read-Write) Sets peak threshold for the specified marker. If a peak (using the criteria set with :EXCursion) is below this reference value, it will not be considered when searching for peaks. This command applies to marker peak searches (Next peak, Peak Right, Peak Left). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1
<num> | Threshold value.Choose any number betwe en -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:THR -40 calculate2:marker8:function:apeak:threshold -55
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold?
Return Type | Numeric
Overlapped? | No
Default | -100

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER <range>

(Read-Write) Assigns the specified marker to a range number. The x-axis travel of the marker is constrained to the range's span. The span is specified with the CALC:MARK:FUNC:DOM:USER:START and STOP commands, unless range 0 is specified which is the full span of the analyzer.

Each channel shares 10 domain ranges. (Trace statistics use the same ranges.) More than one marker can use a domain range. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<span>

User span. Choose any Integer from 0 to 9.

0 is Full Span of the analyzer
1 to 9 are available for user-defined x-axis span

Examples

CALC:MARK:FUNC:DOM:USER 1
calculate2:marker8:function:domain:user 1

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER?
Returns the user span number that the specified marker is assigned to.

Return Type

Numeric

Overlapped?

No

Default

0 - Full Span

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt <start>

(Read-Write) Sets the start of the span that the specified marker's x-axis span will be constrained to.
Use CALC:MARK:FUNC:DOM:USER<range> to set range number
Use CALC:MARK:FUNC:DOM:USER:STOP to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STAR

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<start>

The analyzer's Minimum x-axis value

Examples

CALC:MARK:FUNC:DOM:USER:START 500E6
calculate2:marker8:function:domain:user:start 1e12

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt?

Return Type

Numeric

Overlapped?

No

Default

The analyzer's Minimum x-axis value

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP <stop>

(Read-Write) Sets the stop of the span that the marker's x-axis travel will be constrained to. Use CALC:MARK:FUNC:DOM:USER<range> to set range number
Use CALC:MARK:FUNC:DOM:USER:STARt to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STOP

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<stop>

Stop value of x-axis span; Choose any number between the analyzer's MINimum and MAXimum x-axis value.

Examples

CALC:MARK:FUNC:DOM:USER:STOP 500e6
calculate2:marker8:function:domain1:user:stop 1e12

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP?

Return Type

Numeric

Overlapped?

No

Default

The analyzer's MAXimum x-axis value.

CALCulate<cnum>:MARKer<mkr>:FUNCtion:EXECute [<func>]

(Write-only) Immediately executes (performs) the specified search function. If no function is specified, executes the selected function. Select the function with CALC:MARK:FUNCtion:SEL. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<func>

Optional argument. The function that is to be performed. Choose from:

MAXimum - finds the highest value
MINimum - finds the lowest value
RPEak - finds the next valid peak to the right
LPEak - finds the next valid peak to the left
NPEak - finds the next highest value among the valid peaks
TARGet - finds the target value to the right, wraps around to the left
LTARget - finds the next target value to the left of the marker
RTARget - finds the next target value to the right of the marker

Examples

CALC:MARK:FUNC:EXEC
calculate2:marker2:function:execute maximum

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect] <char>

(Read-Write) Sets the search function that the specified marker will perform when executed. To execute (or perform) the function, use:
CALC:MARK:FUNC:EXEC or
CALC:MARK:FUNC:TRAC ON to automatically execute the search every sweep. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<char>

Marker function. Choose from:

MAXimum - finds the highest value
MINimum - finds the lowest value
RPEak - finds the next valid peak to the right
LPEak - finds the next valid peak to the left
NPEak - finds the next highest value among the valid peaks
TARGet - finds the target value to the right; wraps around to the left
LTARget - finds the next target value to the left of the marker
RTARget - finds the next target value to the right of the marker

Examples

CALC:MARK:FUNC MAX
calculate2:marker8:function:select ltarget

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect]?

Return Type

Character

Overlapped?

No

Default

MAX

CALCulate<cnum>:MARKer<mkr>:TARGet <num>

(Read-Write) Sets the target value for the specified marker when doing Target Searches (CALC:MARK:FUNC:SEL <TARGet | RTARget | LTARget> Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Target value to search for; Units are NOT allowed.
Examples | CALC:MARK:TARG 2.5 calculate2:marker8:target -10.3
Query Syntax | CALCulate<cnum>:MARKer<mkr>:TARGet?
Return Type | Numeric
Overlapped? | No
Default | 0

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking <ON | OFF>

(Read-Write) Sets the tracking capability for the specified marker. The tracking function finds the selected search function every sweep. In effect, turning Tracking ON is the same as doing a CALC:MARK:FUNC:EXECute command every sweep. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<ON | OFF>

ON (or 1) - The specified marker will "Track" (find) the selected function every sweep.

OFF (or 0) - The specified marker will find the selected function only when the CALC:MARK:FUNC:EXECute command is sent.

Examples

CALC:MARK:FUNC:TRAC ON
calculate2:marker8:function:tracking off

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF

CALCulate<cnum>:MARKer:REFerence[:STATe] <ON | OFF>

(Read-Write) Turns the reference marker (marker 10) ON or OFF. When turned OFF, existing Delta markers revert to absolute markers. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns reference marker ON OFF (or 0) - turns reference marker ON
Examples | CALC:MARK:REF ON calculate2:marker:reference:state OFF
Query Syntax | CALCulate<cnum>:MARKer:REFerence[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer:REFerence:X <num>

(Read-Write) Sets and returns the absolute x-axis value of the reference marker (marker 10). Critical Note:

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

X-axis value. Choose any number within the operating domain of the reference marker.

Examples

CALC:MARK:REF:X 1e9

calculate2:marker:reference:x 1e6

Query Syntax

CALCulate<cnum>:MARKer:REFerence:X?

Return Type

Numeric

Overlapped?

No

Default

If the first Marker, turns ON in the middle of the X-axis span. If not, turns ON at the position of the active marker.

CALCulate<cnum>:MARKer:REFerence:Y?

(Read-only) Returns the absolute Y-axis value of the reference marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Examples

CALC:MARK:REF:Y?

calculate2:marker:reference:y?

Return Type

Character

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>:TYPE <char>

(Read-Write) Sets the type of the specified marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<char>

Choose from:
NORMal - a marker that stays on the assigned X-axis position unless moved or searching.
FIXed - a marker that will not leave the assigned X or current Y-axis position.

Examples

CALC:MARK:TYPE NORM
calculate2:marker2:type fixed

Query Syntax

CALCulate<cnum>:MARKer<mkr>:TYPE?

Return Type

Character

Overlapped?

No

Default

NORMal

CALCulate<cnum>:MARKer<mkr>:SET <char>

(Read-Write) Sets the selected instrument setting to assume the value of the specified marker.

Marker Functions CENT, SPAN, STARt, and STOP do not work with channels that are in CW or Segment Sweep mode.

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<char>

Choose from:
CENTer - changes center frequency to the value of the marker
SPAN - changes the sweep span to the span that is defined by the delta marker and the marker that it references. Unavailable if there is no delta marker.
STARt - changes the start frequency to the value of the marker
STOP - changes the stop frequency to the value of the marker
RLEVel - changes the reference level to the value of the marker
DELay - changes the line length at the receiver input to the phase slope at the active marker stimulus position.

Examples

CALC:MARK:SET CENT
calculate2:marker8:set span

Query Syntax

CALCulate<cnum>:MARKer<mkr>:SET?

Return Type

Character

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

(Read-Write) Turns the specified marker ON or OFF. Marker 10 is the Reference Marker. To turn all markers off, use CALC:MARK:AOFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - turns marker ON. OFF (or 0) - turns marker OFF.
Examples | CALC:MARK ON calculate2:marker8 on
Query Syntax | CALCulate<cnum>:MARKer<mkr>:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Off

CALCulate<cnum>:MARKer<mkr>:X <num>

(Read-Write) Sets the marker's X-axis value (frequency, power, or time). If the marker is set as delta, the SET and QUERY data is relative to the reference marker. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Any X-axis position within the measurement span of the marker. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:X 100Mhz calculate2:marker8:x maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:X?
Return Type | Numeric
Overlapped? | No
Default | First Marker turns ON in the middle of the X-axis span. Subsequent markers turn ON at the position of the active marker.

CALCulate<cnum>:MARKer<mkr>:Y?

(Read-only) Reads the marker's Y-axis value. The format of the value depends on the current CALC:MARKER:FORMAT setting. If the marker is set as delta, the data is relative to the reference marker. The query always returns two numbers:

  • Smith and Polar formats - (Real, Imaginary)

  • LINPhase and LOGPhase - (Real, Imaginary)

  • All other formats - (Value,0)

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

Examples

CALC:MARK:Y?
calculate2:marker3:y?

Query Syntax | CALCulate<cnum>:MARKer<mkr>:Y?
Return Type | Numeric
Overlapped? | No
Default | Not applicable


Math SCPI

Calc:Math Command

Controls math operations on the currently selected measurement and memory.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Math Operations

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:MATH:FUNCtion <char>

(Read-Write) Sets math operations on the currently selected measurement and the trace stored in memory. (There MUST be a trace stored in Memory. See CALC:MATH MEM) Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | The math operation to be applied. Choose from the following:
NORMal | Trace data only
ADD | Data + Memory
SUBTract | Data - Memory
MULTiply | Data * Memory
DIVide | Data / Memory
Examples | CALC:MATH:FUNC NORM calculate2:math:function subtract
Query Syntax | CALCulate<cnum>:MATH:FUNCtion?
Return Type | Character
Overlapped? | No
Default | NORMal

CALCulate<cnum>:MATH:MEMorize

(Write-only) Puts the currently selected measurement trace into memory. (Data-> Memory) Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:MATH:MEM calculate2:math:memorize
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable


Mixer

Calc:Mixer Commands

CALCulate<ch>:MIXer:INPut:POWer:USENominal <bool>

(Read-Write) Toggles the Nominal Incident Power setting ON and OFF. This setting is ONLY to be used with SMC measurements, not VMC. Learn more about Nominal Incident Power.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<bool> | Nominal Incident Power State. Choose from: 1 -(ON) Turn nominal incident power ON 0 -(OFF) Turn nominal incident power OFF
Examples | CALC:MIX:INP:POW:USEN 1 CALCulate2:MIXer:INPut:POWer:USENominal 0
Query Syntax | CALCulate<ch>:MIXer:INPut:POWer:USENominal?
Return Type | Boolean
Overlapped? | No
Default | 0 - OFF

CALCulate<ch>:MIXer:XAXis <char>

(Read-Write) Sets or returns the swept parameter to display on the X-axis for the selected FCA measurement. Learn more about X-axis display.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1.

<char>

Parameter to display on the X-axis. Choose from:

INPUT - Input frequency span

OUTPUT - Output frequency span

LO_1 - First LO frequency span

LO_2 - Second LO frequency span

Examples

CALC:MIX:XAX INPUT
calc2:mixer:xaxis output

See an example that creates, selects, and calibrates an SMC and VMC measurement using SCPI.

Query Syntax

CALCulate<ch>:MIXer:XAXis?

Return Type

Character

Overlapped?

No

Default

OUTPUT


Normalize SCPI

Calc:Normalize Commands

Specifies the normalization features used for a receiver power calibration.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Receiver Cal

Save and recall your receiver power calibration (which use .CST file commands):

  • SENS:CORR:CSET:SAVE

  • SENS:CORR:CSET[:SEL]

Or use these two commands and specify either .STA or .CST file extensions:

  • MMEM:LOAD

  • MMEM:STOR

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:NORMalize[:IMMediate]

(Write only) Stores the selected measurement’s data to that measurement’s “divisor” buffer for use by the Normalization data processing algorithm. This command is not compatible with ratioed measurements such as S-parameters. It is intended for receiver power calibration when the selected measurement is of an unratioed power type. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:NORM calculate1:normalize:immediate
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:NORMalize:STATe <ON | OFF>

(Read-Write) Specifies whether or not normalization is applied to the measurement. Normalization is enabled only for measurements of unratioed power where it serves as a receiver power calibration. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - normalization is applied to the measurement. OFF (or 0) – normalization is NOT applied to the measurement.
Examples | CALC:NORM:STAT ON calculate2:normalize:state off
Query Syntax | CALCulate<cnum>:NORMalize:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:NORMalize:INTerpolate[:STATe] <ON | OFF>

(Read-Write) Turns normalization interpolation ON or OFF. Normalization is enabled only for measurements of unratioed power, where it serves as a receiver power calibration. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) – turns interpolation ON. OFF (or 0) – turns interpolation OFF.
Examples | CALC:NORM:INT ON calculate2:normalize:interpolate:state off
Query Syntax | CALCulate<cnum>:NORMalize:INTerpolate[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON


Parameter SCPI

Calc:Parameter Commands

Lists, creates, selects and deletes measurements.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Measurement Parameters

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:PARameter:CATalog?

(Read-only) Returns the names and parameters of existing measurements for the specified channel. Critical Note:
Parameters |
<cnum> | Channel number of the measurements to be listed. If unspecified, <cnum> is set to 1.
Examples | CALC:PAR:CAT? calculate2:parameter:catalog?
Return Type | String - "<measurement name>,<parameter>,[<measurement name>,<parameter>...]"
Overlapped? | No
Default | "CH1_S11_1,S11"

CALCulate<cnum>:PARameter:DEFine <Mname>,<param>[,port]

(Write-only) Creates a measurement but does NOT display it.

There is no limit to the number of measurements that can be created. However, there is a limit to the number of measurements that can be displayed. See Traces, Channels, and Windows on the PNA.

  • Use DISP:WIND:STATe to create a window if it doesn't already exist.

  • Use DISP:WIND<wnum>:TRAC<tnum>:FEED <Mname> to display the measurement.

You must select the measurement (CALC<cnum>:PAR:SEL <mname>) before making additional settings. Critical Note:

Parameters

<cnum>

Channel number of the new measurement. Choose any number between:
1 and 4
If unspecified, value is set to 1.

<Mname>

Name of the measurement. Any non-empty, unique string, enclosed in quotes.

<param>

Parameter

Choose from the following for S-Parameter measurements

S11 | S22 | S12 | S21

For 3-port analyzers only:

S33 | S13 | S31 | S23 | S32

Note: For all non S-Parameter measurements, specify the source port with the optional <port> argument:

Choose from the following for non-ratioed measurements:
A | B | C | R1 | R2

Choose from the following for ratioed measurements:

<param> | Description
AB | A/B
AC | A/C - 3 port analyzers only
BA | B/A
BC | B/C - 3 port analyzers only
CA | C/A - 3 port analyzers only
CB | C/B - 3 port analyzers only
AR1 | A/R1
BR1 | B/R1
CR1 | C/R1 - 3 port analyzers only
AR2 | A/R2
BR2 | B/R2
R1A | R1/A
R2A | R2/A
R1B | R1/B
R2B | R2/B
R1C | R1/C - 3 port analyzers only
R2R1 | R2/R1
R1R2 | R1/R2
[port] | Optional argument; For multi-port reflection S-parameter measurements: specifies the PNA port which will provide the load for the calibration. This argument is ignored if a transmission S-parameter is specified. For all non S-parameter measurements: specifies the source port for the measurement.
Examples | CALC4:PAR:DEF 'ch4_S33',S33,2 'Defines an S33 measurement with a load on port2 of the analyzer. calculate2:parameter:define 'ch1_a', a, 1
Query Syntax | Not Applicable; see Calc:Par:Cat?
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:PARameter:DELete [:NAME]<Mname>

(Write-only) Deletes the specified measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<Mname> | String - Name of the measurement
Examples | CALC:PAR:DEL 'TEST' calculate2:parameter:delete 'test'
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

CALCulate:PARameter:DELete:ALL

(Write-only) Deletes all measurements on the PNA. Critical Note:
Parameters |
Examples | CALC:PAR:DEL:ALL
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:PARameter:MNUMber?

(Read-only) Returns the measurement number of the selected measurement. This is useful when needing to identify a measurement by number, such as with Status:Ques:Lim or Status:Oper:Aver commands. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. If unspecified, <cnum> is set to 1.
Examples | CALC:PAR:MNUM? calculate2:parameter:mnumber?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:PARameter:MODify <param>

(Write-only) Modifies a standard measurement using the same arguments as CALC:PAR:DEF. To modify an FCA measurement, use CALC:CUST:MOD. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. The selected measurement on that channel will be changed. If unspecified, <cnum> is set to 1.
<param> | Measurement parameter to change to. Use the same <param> arguments as CALC:PAR:DEF.
Examples | SYST:PRESET CALC:PAR:DEF "MyMeas", S11 CALC:PAR:SEL "MyMeas" CALC:PAR:MOD AR1 'changes the selected S11 measurement to an A/R1 measurement
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:PARameter:SELect <Mname>

(Read-Write) Sets the selected measurement. Most CALC: commands require that this command be sent before a setting change is made. One measurement on each channel can be selected at the same time. To obtain a list of currently named measurements, use CALC:PAR:CAT? Critical Note:
Parameters |
<cnum> | Channel number of the measurement to be selected. If unspecified, <cnum> is set to 1.
<Mname> | String - Name of the measurement. (Do NOT include the parameter name.)
Examples | CALC:PAR:SEL 'TEST' calculate2:parameter:select 'test'
Query Syntax | CALCulate:PARameter:SELect?
Return Type | String
Overlapped? | No
Default | No Selection


RData SCPI

Calc:RData? Command

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:RDATA? <char>

(Read-only) Returns receiver data for the selected measurement. To query measurement data, see CALC:DATA?
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from receivers: A B R1 R2 REF - returns either R1 or R2 data depending on the source port of the CALC-selected measurement.
Example | GPIB.Write "INITiate:CONTinuous OFF" GPIB.Write "INITiate:IMMediate;*wai" GPIB.Write "CALCulate:RDATA? A"
Return Type | Depends on FORM:DATA - Two numbers per data point
Overlapped? | No
Default | Not Applicable

Notes:

Generally when you query the analyzer for data, you expect that the number of data values returned will be consistent with the number of points in the sweep.

However, if you query receiver data while the instrument is sweeping, the returned values may contain zeros. For example, if your request for receiver data is handled on the 45th point of a 201 point sweep, the first 45 values will be valid data, and the remainder will contain complex zero.

This can be avoided by synchronizing this request with the end of a sweep or putting the channel in hold mode.

Learn about Unratioed Measurements


Smoothing SCPI

Calc:Smoothing Commands

Controls point-to-point smoothing. Smoothing is a noise reduction technique that averages adjacent data points in a measurement trace. Choose the amount of smoothing by specifying either the number of points or the aperture. Smoothing is not the same as CALC:AVERage which averages each data point over a number of sweeps.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

  • Learn about Smoothing

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:SMOothing:APERture <num>

(Read-Write) Sets the amount of smoothing as a percentage of the number of data points in the channel. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Percentage value. Choose any number between: 1 and 25
Examples | CALC:SMO:APER 2 calculate2:smoothing:aperture 20.7
Query Syntax | CALCulate<cnum>:SMOothing:APERture?
Return Type | Numeric
Overlapped? | No
Default | 1.5

CALCulate<cnum>:SMOothing:POINts <num>

(Read-Write) Sets the number of adjacent data points to average. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Number of points from 1 point to maximum of 25% of data points in the channel. For example: if number of points in a data trace = 401, the maximum value for points = 100. The points value is always rounded to the closest odd number.
Examples | CALC:SMO:POIN 50 calculate2:smoothing:points 21
Query Syntax | CALCulate<cnum>:SMOothing:POINts?
Return Type | Numeric
Overlapped? | No
Default | 3

CALCulate<cnum>:SMOothing[:STATe] <ON | OFF>

(Read-Write) Turns data smoothing ON or OFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns smoothing ON. OFF (or 0) - turns smoothing OFF.
Examples | CALC:SMO ON calculate2:smoothing:state off
Query Syntax | CALCulate<cnum>:SMOothing[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF


Transform SCPI

Calc:Transform Commands

Specifies the settings for time domain transform.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Time Domain

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:TRANsform:COUPle:PARameters <num>

(Read-Write) Specifies the time domain transform parameters to be coupled. The settings for those parameters will be copied from the selected measurement to all other measurements on the channel.

  • To turn coupling ON and OFF, use SENS:COUP:PAR

  • To specify Gating parameters to couple, use CALC:FILT:COUP:PAR

Learn more about Time Domain Trace Coupling

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

(Numeric) Parameters to couple. To specify more than one parameter, add the numbers.

1 - Transform Stimulus (Start, Stop, Center, and Span TIME settings.)

2 - Transform State (ON / OFF)

4 - Transform Window (Kaiser Beta / Impulse Width)

8 - Transform Mode (Low Pass Impulse, Low Pass Step, Band Pass)

16 - Transform Distance Marker Units

Examples

'To couple all parameters:

CALC:TRAN:COUP:PAR 31

'To couple Stimulus and Mode:
calculate2:transform:couple:parameters 9

Query Syntax

CALCulate<cnum>:TRANsform:COUPle:PARameters?

Return Type

Numeric

Overlapped?

No

Default

29 (All parameters except 2 - Transform State)

CALCulate<cnum>:TRANsform:TIME:CENTer <num>

(Read-Write) Sets the center time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Center time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:CENT 1e-8 calculate2:transform:time:center 15 ps
Query Syntax | CALCulate<cnum>:TRANsform:TIME:CENTer?
Return Type | Numeric
Overlapped? | No
Default | 0

CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDTh <num>

(Read-Write) Sets the impulse width for the transform window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Impulse width in seconds; Choose any number between: .6 / frequency span and 1.39 / frequency span
Examples | CALC:TRAN:TIME:IMP:WIDTh 10 calculate2:transform:time:impulse:width 13
Query Syntax | CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDTh?
Return Type | Numeric
Overlapped? | No
Default | .98 / Default Span

CALCulate<cnum>:TRANsform:TIME:KBESsel <num>

(Read-Write) Sets the parametric window for the Kaiser Bessel window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Window width for Kaiser Bessel in seconds; Choose any number between: 0.0 and 13.0
Examples | CALC:TRAN:TIME:KBES 10 calculate2:transform:time:kbessel 13
Query Syntax | CALCulate<cnum>:TRANsform:TIME:KBESsel?
Return Type | Numeric
Overlapped? | No
Default | 6

CALCulate<cnum>:TRANsform:TIME:LPFREQuency

(Write-only) Sets the start frequencies in LowPass Mode. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:TRAN:TIME:LPFR calculate2:transform:time:lpfrequency
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

CALCulate<cnum>:TRANsform:TIME:MARKer:MODE <char>

(Read-Write) Specifies the measurement type in order to determine the correct marker distance.

  • Select Auto for S-Parameter measurements.

  • Select Reflection or Transmission for arbitrary ratio or unratioed measurements.

This setting affects the display of ALL markers for only the ACTIVE measurement.

Learn more about Distance Markers.

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Choose from:

AUTO If the active measurement is an S-Parameter, automatically chooses reflection or transmission. If non S-Parameter measurements, reflection is chosen.

REFLection Displays the distance from the source to the receiver divided by two (to compensate for the return trip.)

TRANsmission Displays the distance from the source to the receiver.

Examples

CALC:TRAN:TIME:MARK:MODE REFL
calculate2:transform:time:marker:mode auto

Query Syntax

CALCulate<cnum>:TRANsform:TIME:MARKer:MODE?

Return Type

Character

Overlapped?

No

Default

Auto

CALCulate<cnum>:TRANsform:TIME:MARKer:UNIT <char>

(Read-Write) Specifies the unit of measure for the display of marker distance values. This settings affects the display of ALL markers for only the ACTIVE measurement (unless Distance Maker Units are coupled using CALC:TRAN:COUP:PAR. Learn more about Distance Markers. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: METRs FEET INCHes
Examples | CALC:TRAN:TIME:MARK:UNIT INCH calculate2:transform:time:marker:unit feet
Query Syntax | CALCulate<cnum>:TRANsform:TIME:MARKer:UNIT?
Return Type | Character
Overlapped? | No
Default | METRs

CALCulate<cnum>:TRANsform:TIME:SPAN <num>

(Read-Write) Sets the span time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Span time in seconds; any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:SPAN 1e-8 calculate2:transform:time:span maximum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:SPAN?
Return Type | Numeric
Overlapped? | No
Default | 20 ns

CALCulate<cnum>:TRANsform:TIME:STARt <num>

(Read-Write) Sets the start time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:STAR 1e-8 calculate2:transform:time:start minimum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STARt?
Return Type | Numeric
Overlapped? | No
Default | -10 ns

CALCulate<cnum>:TRANsform:TIME:STATe <ON | OFF>

(Read-Write) Turns the time domain transform capability ON or OFF. Critical Note: Note: Sweep type must be set to Linear Frequency in order to use Time Domain Transform.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON|OFF> | ON (or 1) - turns time domain ON. OFF (or 0) - turns time domain OFF.
Examples | CALC:TRAN:TIME:STAT ON calculate2:transform:time:state off
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:TRANsform:TIME:STOP <num>

(Read-Write) Sets the stop time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:STOP 1e-8 calculate2:transform:time:stop maximum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STOP?
Return Type | Numeric
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe <num>

(Read-Write) Sets the step rise time for the transform window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Rise time in seconds; Choose any number between: .45 / frequency span and 1.48 / frequency span
Examples | CALC:TRAN:TIME:STEP:RTIM 1e-8 calculate2:transform:time:step:rtime 15 ps
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe?
Return Type | Numeric
Overlapped? | No
Default | .99 / Default Span

CALCulate<cnum>:TRANsform:TIME:STIMulus <char>

(Read-Write) Sets the type of simulated stimulus that will be incident on the DUT. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: STEP - simulates a step DUT stimulus IMPulse - simulates a pulse DUT stimulus STEP can ONLY be used when CALC:TRAN:TIME:TYPE is set to LPASs (Lowpass). (STEP cannot be used with TYPE = BPASs.) :STIM STEP will set :TYPE to LPASs :TYPE BPASs will set :STIM to IMPulse
Examples | CALC:TRAN:TIME:STIM STEP calculate2:transform:time:stimulus impulse
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STIMulus?
Return Type | Character
Overlapped? | No
Default | IMPulse

CALCulate<cnum>:TRANsform:TIME[:TYPE] <char>

(Read-Write) Sets the type of time domain measurement. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Type of measurement. Choose from:
LPASs - Lowpass; Must also send CALC:TRAN:TIME:LPFRequency before calibrating.
BPASs - Bandpass;

BPASs can only be used when CALC:TRAN:TIME:STIM is set to IMPulse. (BPASs cannot be used with :STIM = STEP)

:STIM STEP will set :TYPE to LPASs

:TYPE BPASs will set :STIM to IMPulse

Examples

CALC:TRAN:TIME LPAS
calculate2:transform:time:type bpas

Query Syntax

CALCulate<cnum>:TRANsform:TIME[:TYPE]?

Return Type

Character

Overlapped?

No

Default

BPAS


Common Commands SCPI

IEEE 488.2 Common Commands

*CLS - Clear Status

*ESE - Event Status Enable

*ESE? - Event Status Enable Query

*ESR? - Event Status Enable Register

*IDN? - Identify

*OPC - Operation complete command

*OPC? - Operation complete query

*OPT? - Identify Options Query

*RST - Reset

*SRE - Service Request Enable

*SRE? - Service Request Enable Query

*STB? - Status Byte Query

*TST? - Result of Self-test Query

*WAI - Wait

*CLS - Clear Status

Clears the instrument status byte by emptying the error queue and clearing all event registers. Also cancels any preceding *OPC command or query. See Status Commands and Reading the Analyzer's Status Registers.

*ESE - Event Status Enable

Sets bits in the standard event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*ESE? - Event Status Enable Query

Returns the results of the standard event enable register. The register is cleared after reading it. See Status Commands and Reading the Analyzer's Status Registers.

*ESR - Event Status Enable Register

Reads and clears event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*IDN? - Identify

Returns a string that uniquely identifies the analyzer. The string is of the form "Agilent Technologies",<model number>,<serial "number>,<software revision>" .

*OPC - Operation complete command

Generates the OPC message in the standard event status register when all pending overlapped operations have been completed (for example, a sweep, or a Default). See Understanding Command Synchronization.

*OPC? - Operation complete query

Returns an ASCII "+1" when all pending overlapped operations have been completed. See Understanding Command Synchronization

*OPT? - Identify Options Query

Returns a string identifying the analyzer option configuration.

*RST - Reset

Executes a device reset and cancels any pending *OPC command or query, exactly the same as a SYSTem:PRESet. The contents of the analyzer's non-volatile memory are not affected by this command.

*SRE - Service Request Enable

Before reading a status register, bits must be enabled. This command enables bits in the service request register. The current setting is saved in non-volatile memory. See Status Commands and Reading the Analyzer's Status Registers.

*SRE? - Service Request Enable Query

Reads the current state of the service request enable register. The register is cleared after reading it. The return value can be decoded using the table in Status Commands. See also Reading the Analyzer's Status Registers.

*STB? - Status Byte Query

Reads the value of the instrument status byte. The register is cleared only when the registers feeding it are cleared. See Status Commands and Reading the Analyzer's Status Registers.

*TST? - Result of Self-test Query

Returns the result of a query of the analyzer hardward status. An 0 indicates no failures found. Any other value indicates one or more of the following conditions exist. The value returned is the Weight (or sum of the Weights) of the existing conditions. For example:

  • If 4 is returned from *TST?, an Overpower condition exists.

  • If 6 is returned, both Unleveled and Overpower conditions exists.
Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Phase Unlock | The source has lost phaselock. This could be caused by a reference channel open or a hardware failure.
1 | 2 | Unleveled | The source power is unleveled. This could be a source is set for more power than it can deliver at the tuned frequency. Or it could be caused by a hardware failure.
2 | 4 | Not used
3 | 8 | EE Write Failed | An attempted write to the EEPROM has failed. This is possibly caused by a hardware failure.
4 | 16 | YIG Cal Failed | The analyzer was unable to calibrate the YIG. Either the phaselock has been lost or there has been a hardware failure.
5 | 32 | Ramp Cal Failed | The analyzer was unable to calibrate the analog ramp generator due to a possible hardware failure.
6 | 64 | Not used

*WAI - Wait

Prohibits the instrument from executing any new commands until all pending overlapped commands have been completed. See Understanding Command Synchronization


Control SCPI

Control Commands

Specifies the settings to remotely control the rear panel connectors and ECAL Module state.

  • Click on a blue keyword to view the command details.

  • See a List of all SCPI commands.

  • See a pinout and detailed description of the rear panel connectors:

    • Auxilliary IO connector

    • External Test Set IO connector

    • Material Handler IO connector

CONTrol:ECAL:MODule[num]:STATe <value>

(Write-only) Sets the internal state of the selected ECAL module.

Parameters

[num]

Optional argument. USB number of the ECal module. If unspecified (only one ECal module is connected to the USB), <num> is set to 1. If two or more modules are connected, use SENS:CORR:COLL:CKIT:INF? to verify their identity.

<value>

Integer code for switching the module. The following are codes for Agilent ECal modules.

Agilent 8509x Modules
State | Port A | Port B
Open | 0 | 0
Short | 43 | 43
Load | 33 | 33
Mismatch | 4 | 16
Thru | 84
Confidence | 20

Agilent N469x Modules
State | Port A | Port B
Open | 36 | 33
Short | 39 | 45
Load | 37 | 37
Mismatch (Offset short) | 53 | 53
Impedance 5 (Offset open) | 5 | 5
Impedance 6 (Offset short) | 21 | 21
Impedance 7 (Offset short) | 38 | 41
Thru | 42
Confidence | 40

Agilent N4431 Modules
State | Port A | Port B | Port C | Port D
Open | -1398 | -1384 | -2774 | -2654
Short | -1350 | -1381 | -2582 | -2642
Load | 26985 | -26986 | -26986 | 26985
Mismatch | -26986 | 26985 | 26985 | -26986
Path | Thru | Confidence
AB Path | -2590 | -598
AC Path | -4011 | 85
AD Path | -2517 | 16042
BC Path | -1650 | -598
BD Path | -4011 | 85
CD Path | -1352 | 16042

Examples

CONT:ECAL:MOD:STAT 36
control:ecal:module2:state 38

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

CONTrol:SIGNal <conn>,<char>

(Read-Write) Configures external triggering in the PNA.

Trigger:Sequence:Source is automatically set to External when CONTrol:SIGNal is sent.

Edge triggering is only available on some Microwave PNA models.

For more information, see External Triggering in the PNA.

Parameters

<conn>

Rear Panel connector to send or receive trigger signals. Choose from:

BNC1 Trigger IN from rear-panel Trigger IN BNC connector

AUXT Trigger IN from AUX IO connector Pin 19

Note: Only one of the input connectors is active at a time. When a command is sent to one, the PNA automatically makes the other INACTIVE.

BNC2 Trigger OUT to rear-panel Trigger OUT BNC connector.

MATHtrigger - Trigger IN from rear-panel Material Handler connector Pin 18

<char>

INACTIVE - Disables the specified connector <conn>.

Choose from ONLY the following when <conn> is set to either BNC1 or AUXT:

TIENEGATIVE - (Trigger In Edge Negative) - Triggers the PNA when receiving a negative going signal

TIEPOSITIVE - (Trigger In Edge Positive) - Triggers the PNA when receiving a positive going signal

TILLOW - (Trigger In Level Low) - Triggers the PNA when receiving a low level signal

TILHIGH - (Trigger In Level High) - Triggers the PNA when receiving a High-level signal

Choose from ONLY the following when <conn> is set to BNC2:

Use CONTrol:SIGNal:TRIGger:OUTP to enable the BNC2 output.

TOPPAFTER - (Trigger Out Pulse Positive After) - Sends a POSITIVE going TTL pulse at the END of each point during the sweep.

TOPPBEFORE - (Trigger Out Pulse Positive Before) - Sends a POSITIVE going TTL pulse at the START of each point during the sweep.

TOPNAFTER - (Trigger Out Pulse Negative After) - Sends a NEGATIVE going TTL pulse at the END of each point during the sweep.

TOPNBEFORE - (Trigger Out Pulse Negative Before) - Sends a NEGATIVE going TTL pulse at the START of each point during the sweep.

Examples

CONT:SIGN BNC1,TIENEGATIVE
control:signal bnc2,toppbefore

Query Syntax

CONTrol:SIGNal? <conn>

In addition to the arguments listed above, the following is also a possible returned value:

NAVAILABLE - This feature is not available on this PNA

Return Type

Character

Overlapped?

No

Default

At Preset:

BNC1 = INACTIVE
BNC2 = INACTIVE
AUXT = TILHIGH

When Output is enabled:

BNC1 = INACTIVE
BNC2 = TOPPAFTER
AUXT = TILHIGH

CONTrol:SIGNal:TRIGger:ATBA <bool>

(Read-Write) Accept Trigger Before Armed Determines what happens to an EDGE trigger signal if it occurs before the PNA is ready to be triggered. (LEVEL trigger signals are always ignored.) For more information, see External triggering.
Parameters |
<bool> | Boolean False (0) - A trigger signal is ignored if it occurs before the PNA is ready to be triggered. True (1) - A trigger signal is remembered and then used when the PNA becomes armed (ready to be triggered). The PNA remembers only one trigger signal.
Examples | CONT:SIGN:TRIG:ATBA 0 control:signal:trigger:atba true
Query Syntax | CONTrol:SIGNal:TRIGger:ATBA?
Return Type | Boolean
Overlapped? | No
Default | False

CONTrol:SIGNal:TRIGger:OUTP <bool>

(Read-Write) Output Enabled The PNA can be enabled to send trigger signals out the rear-panel TRIGGER OUT BNC connector. Use CONTrol:SIGNal to configure for output triggers. For more information, see External triggering.
Parameters |
<bool> | Boolean False (0) - PNA does NOT output trigger signals. True (1) - PNA DOES output trigger signals.
Examples | CONT:SIGN:TRIG:OUTP 1 control:signal:trigger:outp false
Query Syntax | CONTrol:SIGNal:TRIGger:OUTP?
Return Type | Boolean
Overlapped? | No
Default | False


Display SCPI

Display Commands

Controls the settings of the front panel screen.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands

  • Learn a bout Screen Setup

DISPlay:ANNotation:FREQuency[:STATe] <ON | OFF>

(Read-Write) Turns frequency information on the display title bar ON or OFF for all windows.
Parameters |
<ON | OFF> | ON (or 1) - turns frequency annotation ON. OFF (or 0) - turns frequency annotation OFF.
Examples | DISP:ANN:FREQ ON display:annotation:frequency:state off
Query Syntax | DISPlay:ANNotation:FREQuency[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

DISPlay:ANNotation:MESSage:STATe <ON | OFF>

(Read-Write) Enables and disables error pop-up messages on the display.
Parameters |
<ON | OFF> | ON (or 1) - enables error pop-up messages OFF (or 0) - disables error pop-up messages
Examples | DISP:ANN:MESS:STAT ON display:annotation:message:state off
Query Syntax | DISPlay:ANNotation:MESSage:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

DISPlay:ANNotation:STATus <ON | OFF>

(Read-Write) Turns the status bar at the bottom of the screen ON or OFF. The status bar displays information for the active window.
Parameters |
<ON | OFF> | ON (or 1) - turns status bar ON. OFF (or 0) - turns status bar OFF.
Examples | DISP:ANN:STAT ON display:annotation:status off
Query Syntax | DISPlay:ANNotation:STATus?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Last state that was set

DISPlay:ARRange <char>

(Read-Write) Places EXISTING measurements into pre-configured window arrangements. Overlay, Stack(2), Split(3), and Quad(4) creates new windows. To learn more, see Arrange Existing Measurements.

Parameters

<char>

Window arrangement. Choose from:

  • TILE - tiles existing windows

  • CASCade - overlaps existing windows

  • OVERlay - all traces placed in 1 window

  • STACk - 2 windows

  • SPLit - 3 windows

  • QUAD - 4 windows

Examples

DISP:ARR CASC
display:arrange cascade

Query Syntax

DISPlay:ARRange?

Return Type

Character

Overlapped?

No

Default

TILE

DISPlay:CATalog?

(Read-only) Returns the existing Window numbers.
Return Type | String of Character values, separated by commas
Example | Two windows with numbers 1 and 2 returns: "1,2"
Overlapped? | No
Default | Not applicable

DISPlay:ENABLE <ON | OFF>

(Read-Write) Specifies whether to disable or enable all analyzer display information in all windows in the analyzer application. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<ON | OFF> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:ENAB ON display:enable off
Query Syntax | DISPlay:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:FSIGn <ON | OFF>

(Read-Write) Shows or hides the window which displays global pass/fail results.
Parameters |
<ON | OFF> | ON (or 1) - displays the pass/fail dialog OFF (or 0) - hides the pass/fail dialog
Examples | DISP:FSIG ON display:fsign off
Query Syntax | DISPlay:FSIGn?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay[:TILE] - OBSOLETE - Use DISP:ARRange

(Write-only) Tiles the windows on the screen.
Examples | DISP display:tile
Overlapped? | No
Default | Not Applicable

DISPlay:WINDow<wnum>:ANNotation:MARKer:SINGle[:STATe] <bool>

(Read-Write) Either shows marker readout of only the active trace or all of the traces simultaneously. See other SCPI Marker commands
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<bool> | ON (or 1) - show a single marker per trace OFF (or 0) - show up to 4 markers per active trace
Examples | DISP:WIND:ANN:MARK:SING ON display:window:annotation:marker:single off
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:SINGle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:ANNotation:MARKer:SIZE <char>

(Read-Write) Specifies the size of the marker readout text. See other SCPI Marker commands
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<char> | Readout text size. Choose from:NORMal | LARGe
Examples | DISP:WIND:ANN:MARK:SIZE LARG display:window:annotation:marker:size normal
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:SIZE?
Return Type | Character
Overlapped? | No
Default | NORMal

DISPlay:WINDow<wnum>:ANNotation:MARKer:STATe <ON | OFF>

(Read-Write) Specifies whether to show or hide the Marker data (when markers are ON) on the selected window. See other SCPI Marker commands
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns marker data ON. OFF (or 0) - turns marker data OFF.
Examples | DISP:WIND:ANN:MARK:STAT ON display:window:annotation:marker:state off
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:ANNotation:TRACe:STATe <ON | OFF>

(Read-Write) Specifies whether to show or hide the Trace Status buttons on the left of the display.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns the buttons ON. OFF (or 0) - turns the buttons OFF.
Examples | DISP:WIND:ANN:TRAC:STAT ON display:window:annotation:trace:state off
Query Syntax | DISPlay:WINDow:ANNotation:TRACe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:CATalog?

(Read-only) Returns the trace numbers for the specified window.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
Example | Window 1 with four traces: DISPlay:WINDow1:CATalog? Returns: "1,2,3,4"
Return Type | String of Character values separated by commas
Overlapped? | No
Default | Not applicable

DISPlay:WINDow<wnum>:ENABle <ON | OFF>

(Read-Write) Specifies whether to disable or enable all analyzer display information in the specified window. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:WIND:ENABle ON display:window1:enable off
Query Syntax | DISPlay:WINDow<wnum>:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:SIZE <char>

(Read-Write) Sets or returns the window setting of Maximized, Minimized, or Normal. To arrange all of the windows, use DISP:ARR.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1
<char> | Window size. Choose from: MIN | MAX | NORM
Examples | DISP:WIND:SIZE MAX display:window:size norm
Query Syntax | DISPlay:WINDow:SIZE?
Overlapped? | No
Default | Not Applicable

DISPlay:WINDow<wnum>[:STATe] <ON | OFF>

(Read-Write) Write to create or delete a window on the screen or Read whether a window is present.
Parameters |
<wnum> | Window number to create; choose any integer between: 1 and 16
<ON | OFF> | ON (or 1) - The window <wnum> is created. OFF (or 0) - The window <wnum> is deleted.
Examples | DISP:WIND ON display:window2:state off
Query Syntax | DISPlay:WINDow<wnum>[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Window number "1" ON

DISPlay:WINDow<wnum>:TABLe <char>

(Read-Write) Write to show the specified table at the bottom of the analyzer screen or Read to determine what table is visible.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1
<char> | Table to show. Choose from: OFF | MARKer | LIMit | SEGMent
Examples | DISP:WIND:TABLe SEGM display:window:table off
Query Syntax | DISPlay:WINDow:TABLe?
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:TITLe:DATA <string>

(Read-Write) Sets data in the window title area. The title is turned ON and OFF with DISP:WIND:TITL:STAT OFF.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<string> | Title to be displayed. Any characters, enclosed with quotes. If the title string exceeds 50 characters, an error will be generated and the title not accepted. Newer entries replace (not append) older entries.
Examples | DISP:WIND:TITL:DATA 'hello' display:window2:title:data 'hello'
Query Syntax | DISPlay:WINDow<wnum>:TITLe:DATA?
Return Type | String
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TITLe[:STATe] <ON | OFF>

(Read-Write) Turns display of the title string ON or OFF. When OFF, the string remains, ready to be redisplayed when turned back ON.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the title string ON. OFF (or 0) - turns the title string OFF.
Examples | DISP:WIND:TITL ON Display:window1:title:state off
Query Syntax | DISPlay:WINDow<wnum>:TITLe[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:DELete

(Write-only) Deletes the specified trace from the specified window. The measurement parameter associated with the trace is not deleted.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<tnum> | The number of the trace to be deleted; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:DEL display:window2:trace2:delete
Query Syntax | Not applicable
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>:FEED <name>

(Write-only) Creates a new trace <tnum> and associates (feeds) a measurement <name> to the specified window<wnum>. This command should be executed immediately after creating a new measurement with CALC:PAR:DEF<name>,<parameter>.

To feed the same measurement to multiple traces, create another measurement with the same <name>,<parameter> using the CALC:PAR:DEF command. The analyzer will collect the data only once.

Parameters

<wnum>

Any existing window number (1 to 16); if unspecified, value is set to 1.

<tnum>

Trace number to be created. Choose any Integer between:
1 and 4

<name>

Name of the measurement that was defined with CALC:PAR:DEF<name>,<parameter>

Examples

DISP:WIND:TRAC:FEED 'test'
display:window2:trace2:feed 'test'

Query Syntax

Not applicable

Overlapped?

No

Default

"CH1_S11"

DISPlay:WINDow<wnum>:TRACe<tnum>MEMory[:STATe] <ON | OFF>

(Read-Write) Turns the memory trace ON or OFF.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the memory trace ON. OFF (or 0) - turns the memory trace OFF.
Examples | DISP:WIND:TRAC:MEM ON display:window2:trace2:memory:state off
Query Syntax | DISPlay:WIND<wnum>:TRACe<tnum>:MEMory[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:TRACe<tnum>:SELect

(Write-only) Activates the specified trace in the specified window for front panel use.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:SEL display:window2:trace2:select
Query Syntax | Not applicable
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>[:STATe] <ON | OFF>

(Read-Write) Turns the display of the specified trace in the specified window ON or OFF. When OFF, the measurement behind the trace is still active.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the trace ON. OFF (or 0) - turns the trace OFF.
Examples | DISP:WIND:TRAC ON display:window2:trace2:state off
Query Syntax | DISPlay:WIND<wnum>:TRACe<tnum>[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:AUTO

(Write-only) Performs an Autoscale on the specified trace in the specified window, providing the best fit display. Autoscale is performed only when the command is sent; it does NOT keep the trace autoscaled indefinitely.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:Y:AUTO display:window2:trace2:y:scale:auto
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision <num>

(Read-Write) Sets the Y axis Per Division value of the specified trace in the specified window.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<num> | Units / division value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:TRAC:Y:PDIV 1 display:window2:trace2:y:scale:pdivision maximum
Query Syntax | DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision?
Return Type | Numeric
Overlapped? | No
Default | 10

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel <num>

(Read-Write) Sets the Y axis Reference Level of the specified trace in the specified window.
Parameters |
<wnum> | Any existing window number (1 to 16); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<num> | Reference level value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:TRAC:Y:RLEV 0 display:window2:trace2:y:scale:rlevel minimum
Query Syntax | DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel?
Return Type | Numeric
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition <num>

(Read-Write) Sets the Reference Position of the specified trace in the specified window

Parameters

<wnum>

Any existing window number (1 to 16); if unspecified, value is set to 1.

<tnum>

Any existing trace number; if unspecified, value is set to 1

<num>

Reference position on the screen measured in horizontal graticules from the bottom. The range of acceptable values is dependent on format and domain.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

DISP:WIND:TRAC:Y:RPOS 0
display:window2:trace2:y:rposition maximum

Query Syntax

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition?

Return Type

Numeric

Overlapped?

No

Default

5


Format SCPI

Format Commands

Specifies the way that data will be transferred when moving large amounts of data. These commands will affect data that is transferred with the CALC:DATA and CALC:RDATA commands.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

FORMat:BORDer <char>

(Read-Write) Set the byte order used for GPIB data transfer. Some computers read data from the analyzer in the reverse order. This command is only implemented if FORMAT:DATA is set to :REAL. If FORMAT:DATA is set to :ASCII, the swapped command is ignored.

Parameters

<char>

Choose from:

NORMal - Use when your controller is anything other than an IBM compatible computers

SWAPped - for IBM compatible computers

Note: Use NORMal if you are using drivers like VISA or development environments like VEE, LabView, or T&M Tool kit.

Examples

FORM:BORD SWAP
format:border normal

Query Syntax

FORMat:BORDer?

Return Type

Character

Overlapped?

No

Default

Normal

FORMat[:DATA] <char>

(Read-Write) Sets the data format for data transfers. To transfer measurement data, use the CALC:DATA command.

To transfer Source Power correction data, use SOURce:POWer:CORRection:COLLect:TABLe:DATA SOURce:POWer:CORRection:COLLect:TABLe:FREQuency

SOURce:POWer:CORRection:DATA

Parameters

<char>

Choose from:
REAL,32 - (default value for REAL) Best for transferring large amounts of measurement data.

REAL,64 - Slower but has more significant digits than REAL,32. Use REAL,64 if you have a computer that doesn't support REAL,32.

ASCii,0 - The easiest to implement, but very slow. Use if small amounts of data to transfer.

Note: The REAL,32 and REAL,64 arguments transfer data in block format as explained in Transferring Measurement Data.

Examples

FORM REAL,64
format:data ascii

Query Syntax

FORMat:DATA?

Return Type

Character,Character

Overlapped?

No

Default

ASCii,0


Hardcopy SCPI

Hardcopy Command

Learn about Printing

HCOPy:FILE <filename>

(Write-only) Saves the screen image to a file.
Parameters |
<filename> | Name of the file to save the screen to. The file is saved to the current working directory unless a valid full path name is specified. Use one of the following suffixes: .bmp - not recommended due to large file size .jpg - not recommended due to poor quality .png - recommended
Examples | HCOPY:FILE "myFile.png" hcopy:file "c:\data\myfile.png"
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

HCOPy[:IMMediate]

(Write-only) Prints the screen to the default printer.
Examples | HCOP hcopy:immediate
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable


Initiate SCPI

Initiate Commands

Controls triggering signals

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn a bout Triggering

INITiate:CONTinuous <boolean>

(Read-Write) Specifies whether the analyzer sends Continuous sweep triggers to triggerable channels or enables Manual triggering.
Parameters |
<boolean> | ON (or 1) - Continuous sweep mode. OFF (or 0) - Manual sweep mode.
Examples | INIT:CONT ON initiate:continuous off
Query Syntax | INITiate:CONTinuous?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

INITiate<cnum>[:IMMediate]

(Write-only) Stops the current sweeps and immediately sends a trigger to the specified channel. ( Same as Sweep \ Trigger \ Trigger! )

  • If the specified channel is in HOLD, it will sweep one time and return to HOLD when complete.

  • If Trigger:Scope = Global, all channels will receive a trigger.

  • If Trigger:Scope = Channel (only the active channel receives a trigger) and the specified channel is not the active channel, the specified channel will NOT receive a trigger signal.

  • If the specified channel is NOT in Manual trigger (INIT:CONT OFF), the analyzer will return an error.

  • If channel <cnum> does not exist, the analyzer will return an error.

Note: An SMC Fixed Output measurement cannot be triggered using this command. For more information, see the example program.

Parameters

<c num>

Any existing channel number. If unspecified, value is set to 1

Examples

INIT
initiate2:immediate

Query Syntax

Not applicable

Overlapped?

Yes

Default

Not applicable


Memory SCPI

Memory Commands

The memory commands control saving and loading instrument states and measurement trace data to the hard drive. To read and write trace data in GPIB format, see CALC:DATA.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Save / Recall and File Types

Specifying Path Names

The MMEM commands use the following rules to specify path names:

  • The default folder is "C:\Program Files\Agilent\Network Analyzer\Documents"

  • You can change the active directory using MMEMory:CDIRectory.

  • Specify only the file name if using the active directory.

  • You can also use an absolute path name to specify the folder and file.

MMEMory:CATalog[:<char>]? [<folder>]

(Read-only) Returns a comma-separated string of file names that are in the specified folder. If there are no files of the specified type, "NO CATALOG" is returned.
Parameters |
<char> | The type of files to list. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If unspecified then ALL file types (even unknown types) are listed.
<folder> | String - Any existing folder name. See Specifying Path Names
Examples | MMEM:CAT? 'lists all files from the current folder mmemory:catalog:correction? 'C:\Program Files\Agilent\Network Analyzer\Documents' 'lists .cal files from the specified folder
Overlapped? | No
Default | Not applicable

MMEMory:CDIRectory <folder>

(Read-Write) Changes the folder name.

Parameters

<folder>

Any drive and folder name that already exists.
If the same level as "C:\Program Files\Agilent\Network Analyzer\Documents", then no punctuation is required

MMEM:CDIR Service

If the new folder is at a different level than "C:\Program Files\Agilent\Network Analyzer\Documents", use a slash (\) before the folder name and enclose in quotes.

mmemory:cdirectory '\automation' 'changes default directory up one level.

You can use an absolute path to specify the new folder.

mmemory:cdirectory 'c:\automation\service'

Query Syntax

MMEMory:CDIRectory? 'Returns the current folder name

Return Type

String

Overlapped?

No

Default

'C:\Program Files\Agilent\Network Analyzer\Documents'

MMEMory:COPY <file1>,<file2>

(Write-only) Copies file1 to file2. Extensions must be specified.
Parameters |
<file1> | String - Name of the file to be copied. See Specifying Path Names
<file2> | String - Name of the file to be created from file1.
Examples | MMEM:COPY 'MyFile.cst','YourFile.cst'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:DELete <file>

(Write-only) Deletes file. Extensions must be specified.
Parameters |
<file> | String - Name of the file to be deleted. See Specifying Path Names
Examples | MMEM:DEL 'MyFile.cst'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:LOAD[:<char>] <file>

(Write-only) Loads the specified file.
Parameters |
<char> | The type of file to load. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If <char> is unspecified, the extension must be included in the filename. If an extension is specified in <file> that does not agree with <char> then no action is taken.
<file> | String - Name of the file to be loaded. See Specifying Path Names
Examples | MMEM:LOAD 'MyFile.cst' mmemory:load:state 'MyInstState'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:MDIRectory <folder>

(Write-only) Makes a folder.
Parameters |
<folder> | String - Name of the folder to make. See Specifying Path Names
Examples | MMEM:MDIR 'MyFolder' mmemory:mdirectory 'c:\NewFolder'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:MOVE <file1>,<file2>

(Write-only) Renames <file1> to <file2>. File extensions must be specified.
Parameters |
<file1> | String - Name of the file to be renamed. See Specifying Path Names
<file2> | String - Name of the new file.
Examples | MMEM:MOVE 'MyFile.cst','YourFile.cst'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:RDIRectory <folder>

(Write-only) Removes the specified folder.
Parameters |
<folder> | String - Name of the folder to remove. See Specifying Path Names
Examples | MMEM:RDIR 'MyFolder'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:STORe[:<char>] <file>

(Write-only) Stores the specified file (.sta, .cal, .cst, .s1p, .s2p, and .s3p.). Learn about saving SnP files on the PNA. To save *.cti files, use MMEM:STOR:CITI:DATA or MMEM:STOR:CITI:FORM.
Parameters |
<char> | The type of file to store. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) No <char> is specified for s1p, s2p and s3p If unspecified, then the extension must be included in the filename. If an extension is specified in <file> that does not agree with <char> then no action is taken.
<file> | String - Name of any valid file that is not already in existence. See Specifying Path Names
Examples | MMEM:STOR:STAT 'myState' mmemory:store 'c:\bin\myState.sta' MMEM:STOR 'MyData.S2P'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:STORe:CITI:DATA <filename>

(Write only) Saves UNFORMATTED trace data to .cti file. Learn more.

Parameters

<filename>

Any drive and folder name that already exists.
If the same level as "C:\Program Files\Agilent\Network Analyzer\Documents", then no punctuation is required

MMEM:STOR:CITI:DATA MYCITIFile

If the new folder is at a different level than "C:\Program Files\Agilent\Network Analyzer\Documents", use a slash (\) before the folder name and enclose in quotes.

mmemory:cdirectory '\automation' 'changes default directory up one level.

You can use an absolute path to specify the new folder.

mmemory:cdirectory 'c:\automation\service'

Query Syntax

Not Applicable

Overlapped?

No

Default

C:\Program Files\Agilent\Network Analyzer\Documents'

MMEMory:STORe:CITI:FORMat <filename>

(Write only) Saves FORMATTED trace data to .cti file. Learn more.

Parameters

<filename>

Any drive and folder name that already exists.
If the same level as "C:\Program Files\Agilent\Network Analyzer\Documents", then no punctuation is required

MMEM:STOR:CITI:DATA MYFile

If the new folder is at a different level than "C:\Program Files\Agilent\Network Analyzer\Documents", use a slash (\) before the folder name and enclose in quotes.

mmemory:cdirectory '\automation' 'changes default directory up one level.

You can use an absolute path to specify the new folder.

mmemory:cdirectory 'c:\automation\service'

Query Syntax

Not Applicable

Overlapped?

No

Default

C:\Program Files\Agilent\Network Analyzer\Documents'

MMEMory:STORe:TRACe:CONTents:CITifile <char>

(Read-Write) Specifies the contents of subsequent citifile save statements. (See Data Define Saves)
Parameters |
<char> | Choose from: SING - Single trace DISP - All displayed traces AUTO - All displayed traces
Examples | MMEM:STOR:TRAC:CONT:CIT SING
Query Syntax | MMEMory:STORe:TRACe:CONTents?
Return Type | Character
Overlapped? | No
Default | Auto

MMEMory:STORe:TRACe:FORMat:CITifile <char>

(Read-Write) Specifies the format of subsequent citifile save statements. (See Data Define Saves)

Parameters

<char>

Format in which the citifile will be saved with subsequent MMEMory:STORe:CITI:FORMat statements. Choose from:

MA - Linear Magnitude / degrees

DB - Log Magnitude / degrees

RI - Real / Imaginary

AUTO - Format in which the trace is already displayed. If other than Log Mag, Linear Magnitude, or Real/Imag, then the format will be in Real/Imag.

Examples

MMEM:STOR:TRAC:FORM:CIT MA

Query Syntax

MMEMory:STORe:TRACe:FORMat:CITifile?

Return Type

Character

Overlapped?

No

Default

Auto'

MMEMory:STORe:TRACe:FORMat:SNP <char>

(Read-Write) Specifies the format of subsequent .s1p, .s2p, .s3p save statements. (See Data Define Saves).
Parameters |
<char> | Choose from: MA - Linear Magnitude / degrees DB - Log Magnitude / degrees RI - Real / Imaginary AUTO - data is output in currently selected trace format. If other than LogMag, LinMag, or Real/Imag, then output is in Real/Imag.
Examples | MMEM:STOR:TRAC:FORM:SNP MA
Query Syntax | MMEMory:STORe:TRACe:FORMat:SNP?
Return Type | Character
Overlapped? | No
Default | Auto'

MMEMory:TRANsfer <fileName>,<dataBlock>

(Read-Write) Transfers data between the PNA and an external controller. Other MMEM commands transfer data between the PNA application and the PNA hard drive. If <fileName> already exists, it will be overwritten. The file must be no larger than 20MB. To read trace data from the PNA in block format, use CALC:DATA.
Parameters |
<fileName> | String - File name. See Specifying Path Names
<dataBlock> | Block Data - The contents of the file. The data block is a block of binary data. Use the following syntax: #<num digits><byte count><data bytes><NL><END> where: <num_digits> specifies how many digits are contained in <byte_count> <byte_count> specifies how many data bytes will follow in <data bytes>
Example | !Write the data 10 OUTPUT 717;":MMEM:TRAN ""Trace01.csv"",#6012345";Dat$ !# - always sent before definite block data !6 - specifies that the byte count is six digits (012345) !12345 - specifies the number of data bytes that will follow, not counting <NL><END> !Dat$ - Data !Read the data back 10 OUTPUT 717;":MMEM:TRAN? ""Trace01.csv""" 20 ENTER 717 USING "#,A";A$ 30 ENTER 717 USING "#,A";Digit$ 40 Img$="#,"&Digit$&"A" 50 ENTER 717 USING Img$;Byte$ 60 Img$=Byte$&"A" 70 ALLOCATE Dat$[VAL(Byte$)] 80 ENTER 717 USING Img$;Dat$
Query Syntax | MMEMory:TRANsfer? <fileName> Reads block data from the specified file location.
Overlapped? | No
Default | Not applicable


Output SCPI

Output Command

Learn about Power

OUTPut[:STATe] <ON | OFF>

(Read-Write) Turns RF power from the source ON or OFF. See note about source power state with instrument state save and recall.
Parameters |
<ON | OFF> | ON (or 1) - turns RF power ON OFF (or 0) - turns RF power OFF
Examples | OUTP ON output:state off
Query Syntax | OUTPut[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON


Route_SCPI

Route Command

Learn about Frequency Offset

ROUTe:PATH:LOOP:R1 <char>

(Read-Write) Throws internal switch to reference receiver. This feature is only available on PNA models with Option 081 - external reference switch. See block diagram of the reference switch.
Parameters |
<char> | Position of the switch. Choose from: INTernal - bypass R1 Loop. Connects the port 1 source directly to the R1 receiver. EXTernal - flow through R1 Loop. Allows direct access to the R1 receiver through the Reference 1 front-panel connectors.
Examples | ROUT:PATH:LOOP:R1 INT route:path:loop:r1 external
Query Syntax | ROUTe:PATH:LOOP:R1?
Return Type | Character
Overlapped? | No
Default | INTernal


Average SCPI

Sens:Average Commands

Sets sweep-to-sweep averaging parameters. Averaging is a noise reduction technique that averages each data point over a user-specified number of sweeps. Averaging affects all of the measurements in the channel.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands.

  • Learn about Averaging

SENSe<cnum>:AVERage:CLEar

(Write-only) Clears and restarts averaging of the measurement data. Must also set SENS:AVER[:STATe] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
Examples | SENS:AVER:CLE sense2:average:clear
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:AVERage:COUNt <num>

(Read-Write) Sets the number of measurement sweeps to combine for an average. Must also set SENS:AVER[:STATe] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<num> | Number of measurement sweeps to average. Choose any number between: 1 and 1024
Examples | SENS:AVER:COUN 999 sense2:average:count 73
Query Syntax | SENSe<cnum>:AVERage:COUNt?
Return Type | Numeric
Overlapped? | No
Default | 1

SENSe<cnum>:AVERage[:STATe] <ON | OFF>

(Read-Write) Turns trace averaging ON or OFF.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns averaging ON. OFF (or 0) - turns averaging OFF.
Examples | SENS:AVER ON sense2:average:state off
Query Syntax | SENSe<cnum>:AVERage[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Off


Sense Bandwidth SCPI

Sense:Bandwidth Commands

Learn about IF Bandwidth

See a list of SCPI commands

SENSe<cnum>:BANDwidth | BWIDth[:RESolution] <num>

(Read-Write) Sets the bandwidth of the digital IF filter to be used in the measurement. (Use either Sense:Bandwidth or Sense:Bwidth)
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | IF Bandwidth in Hz. The list of valid IF Bandwidths is different depending on the PNA model. (Click to see the lists.) If an invalid number is specified, the analyzer will round up to the closest valid number.
Examples | SENS:BWID 1KHZ sense2:bandwidth:resolution 1000
Query Syntax | SENSe<cnum>:BANDwidth | BWIDth[:RESolution]?
Return Type | Numeric
Overlapped? | No
Default | See Preset IFBW for your PNA model.

SENSe<cnum>:BANDwidth | BWIDth:TRACk <bool>

(Read-Write) Sets and returns the state of the Reduce IF BW at Low Frequencies feature. (Use either Sense:Bandwidth:Track or Sense:Bwidth:Track).
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | Choose from: ON or 1 - Reduce IF BW at Low Frequencies is set ON OFF or 0 - Reduce IF BW at Low Frequencies is set OFF
Examples | SENS:BWID:TRAC OFF sense2:bandwidth:track 1
Query Syntax | SENSe<cnum>:BANDwidth | BWIDth:TRACk?
Return Type | Boolean
Overlapped? | No
Default | ON


Sense Correction SCPI

Sense:Correction Commands

Performs and applies measurement calibration and other error correction features.

  • Click on a blue keyword to view the command details.

  • New See Calibrating the PNA Using SCPI

  • See a List of all commands in this block.

  • See a examples using some of these commands.

  • Learn about Measurement Calibration

SENSe<cnum>:CORRection:CCHeck[:ACQuire] <mod>[,char]

(Write-only) Reads the 'confidence data' associated with the specified ECal module and puts it into memory. The measurement is selected using SENS:CORR:CCH:PAR. This command is compatible with *OPC.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<mod>

ECAL Module that contains the confidence data. Choose from:

ECAL1

..through..

ECAL8

[char]

Optional argument. Specifies which characterization within the ECal module that the confidence data will be read from.

CHAR0 Factory characterization (data that was stored in the ECal module by Agilent). Default if not specified.

CHAR1 User characterization #1

CHAR2 User characterization #2

CHAR3 User characterization #3

CHAR4 User characterization #4

CHAR5 User characterization #5

Examples

SENS:CORR:CCHeck ECAL2

sense2:correction:ccheck:acquire ecal1,char1

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:CCHeck:DONE

(Write-only) Concludes the Confidence Check and sets the ECal module back into the idle state.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:CCH:DONE sense2:correction:ccheck:done
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:CCHeck:PARameter <Mname>

(Read-Write) Specifies an existing measurement to be used for the Confidence Check.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<Mname> | Name of the measurement you are selecting for the confidence check. The measurement must already exist.
Examples | SENS:CORR:CCH:PAR 'TEST' 'selects the measurement "test" on channel 1 for the confidence check sense2:correction:ccheck:parameter 'test' 'selects the measurement "test" on channel 2 for the confidence check
Query Syntax | SENSe<cnum>:CORRection:CCHeck:PARameter? Returns the name of the selected measurement on channel <cnum>.
Return Type | String
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:COLLect[:ACQuire] <class>[,subclass]

(Write-only) Measures the specified standards from the selected calibration kit. The calibration kit is selected using the Sense:Correction:Collect:CKIT command.

For using two sets of standards, see SENS:CORR:TST.

Note: Before using this command you must select two items:
1. Select a calibration method using SENS:CORR:COLL:METH
2. Select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<class>

Measures the standards associated with these class labels:
Choose from:

 | STAN1 | S11A and S22A
 | STAN2 | S11B and S22B
 | STAN3 | S11C and S22C
 | STAN4 | S21T and S12T - usually the THRU standard
 | STAN5 | Generic Isolation; not associated with calibration kit definition
 | ECAL1 through ECAL8 | ECAL modules
 | SLSET | Sets 'sliding load type', and increments the "number of slides" count. The total number of slides is critical to the correct calculation of the sliding load algorithm. See a sliding load cal example.
 | SLDONE | Computes the sliding load using a circle fit algorithm.
[subclass] | Optional argument. For mechanical calibration kits, choose from the following to specifying the standard identified in the SENS:CORR:COLL:CKIT:ORDer list to be acquired. If this argument is not used, the default is SST1.
SST1 | First standard in the order list
SST2 | Second standard in the order list
SST3 | Third standard in the order list
SST4 | Fourth standard in the order list
SST5 | Fifth standard in the order list
SST6 | Sixth standard in the order list
SST7 | Seventh standard in the order list
If an ECAL module (1 through 8) is specified for <class>, choose one of the following for specifying which characterization within the ECal module will be used for the acquire. If not specified, the default is CHAR0.
CHAR0 | Factory characterization (data that was stored in the ECal module by Agilent)
CHAR1 | User characterization #1
CHAR2 | User characterization #2
CHAR3 | User characterization #3
CHAR4 | User characterization #4
CHAR5 | User characterization #5
Examples | SENS:CORR:COLL STAN1 'If SENS:CORR:COLL:CKIT:ORDer2 5,3,7 was specified, the following command measures standard 3 (the second in the order list) sense1:correction:collect:acquire stan3,sst2 SENS:CORR:COLL ECAL4 sense2:correction:collect:acquire ecal2,char1
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:COLLect:APPLy

(Write-only) Applies error terms to the measurement that is selected using Calc:Par:Select.

Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Note: This command is only necessary if you need to modify error terms. If you do not need to modify error terms, SENSe<cnum>:CORRection:COLLect:SAVE calculates and then automatically applies error terms after you use SENS:CORR:COLL:ACQuire to measure cal standards.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Example

  1. CALCulate2:PARameter:SELect S21_2 'select the measurement to apply terms to

  2. SENSe2:CORRection:COLLect:METHod SPARSOLT 'set type of cal method.

  3. CALCulate2:DATA? SCORR1 'download the error term of interest

  4. 'Modify the error term here

  5. CALCulate2:DATA SCORR1 'upload the error term of interest

  6. SENSe2:CORRection:COLLect:APPLy 'applies the error terms to the measurement

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect:METHod <char>

(Read-Write) Sets the calibration method (also known as 'Calibration Type' on calibration dialog box.) To set the Cal Type for a Cal Set, use CALC:CORR:TYPE.

Note: Before using this command you must select the measurement to be calibrated using CALC:PAR:SEL. You can select one measurement for each channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

Method | Description
NONE | No Cal method
REFL1OPEN | Response Open
REFL1SHORT or REFL1 | Response Short
REFL3 | Full 1 port
TRAN1 | Response Thru
TRAN2 | Response Thru and Isolation
SPARSOLT | Full SOLT 2 port
SPARTRL | TRL Cal (not supported on all PNAs.)
Examples | SENS:CORR:COLL:METH REFL1 sense2:correction:collect:method sparsolt
Query Syntax | SENSe<cnum>:CORRection:COLLect:METHod?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:SAVE

(Write-only) Calculates the error terms using the selected :METHod and applies the error terms to the selected measurement (turns error correction ON.) Does NOT save the calibration error-terms.

Do NOT use this command during an ECAL.

Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Examples

SENS:CORR:COLL:SAVE
sense2:correction:collect:save

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:EXTension:PORT<pnum>[:TIME] <num>

(Read-Write) Sets the extension value at the specified port. Must also set SENS:CORR:EXT ON. Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Number of the port that will receive the extension. If unspecified, value is set to 1. Choose from: 1 for Port 1 2 for Port 2
<num> | The port extension in seconds; may include suffix. Choose a number between: -10 and 10
Examples | SENS:CORR:EXT:PORT 2MS sense2:correction:extension:port2 .00025
Query Syntax | SENSe<cnum>:CORRection:EXTension:PORT<pnum> [:TIME]?
Return Type | Numeric
Overlapped? | No
Default | 0

SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum>[:TIME] <num>

(Read-Write) Sets the extension value at the specified receiver. Must also set SENS:CORR:EXT ON . Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<Rnum> | Number of the receiver that will receive the extension. If unspecified, value is set to 1 Choose from: 1 for Receiver A 2 for Receiver B
<num> | The electrical length in seconds; may include suffix. Choose a number between: -10 and 10
Examples | SENS:CORR:EXT:REC 2MS sense2:correction:extension:receiver2:time .00025
Query Syntax | SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum> [:TIME]?
Return Type | Numeric
Overlapped? | No
Default | 0

SENSe<cnum>:CORRection:EXTension[:STATe] <ON | OFF>

(Read-Write) Turns port extensions ON or OFF. Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns port entensions ON. OFF (or 0) - turns port extensions is OFF.
Examples | SENS:CORR:EXT ON sense2:correction:extension:state off
Query Syntax | SENSe<cnum>:CORRection:EXTension[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe:CORRection:IMPedance:INPut:MAGNitude <num>

(Read-Write) Sets and returns the system impedance value for the analyzer.
Parameters |
<num> | System Impedance value in ohms. Choose any number between 0 and 1000 ohms.
Examples | SENS:CORR:IMP:INP:MAGN 75 sense:correction:impedance:input:magnitude 50.5
Query Syntax | SENSe:CORRection:IMPedance: INPut:MAGNitude?
Return Type | Numeric
Overlapped? | No
Default | 50

SENSe<cnum>:CORRection:INTerpolate[:STATe] <ON | OFF>

(Read-Write) Turns correction interpolation ON or OFF. Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns interpolation ON. OFF (or 0) - turns interpolation OFF.
Examples | SENS:CORR:INT ON sense2:correction:interpolate:state off
Query Syntax | SENSe<cnum>:CORRection:INTerpolate[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:CORRection:ISOLation[:STATe] <ON | OFF>

(Read-Write) Turns isolation cal ON or OFF during Full 2-port calibration. If this command is not sent, the default state is to disable Isolation.

Note: This command is ignored for ECal on PNA release 4.26 and greater. Isolation is never performed with ECal as the inherent isolation of the PNA is better than that achieved with ECal.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<ON | OFF>

ON (or 1) - turns isolation ON.
OFF (or 0) - turns isolation OFF.

Examples

SENS:CORR:ISOL ON
sense2:correction:isolation:state off

Query Syntax

SENSe<cnum>:CORRection:ISOLation[:STATe]?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF - (Isolation disabled)

SENSe:CORRection:PREFerence:ECAL:ORIentation[:STATe] <ON|OFF>

(Read-Write) Specifies whether or not the PNA should perform orientation of the ECal module during calibration. Orientation is a technique by which the PNA automatically determines which ports of the module are connected to which ports of the PNA. Orientation begins to fail at very low power levels or if there is much attenuation in the path between the PNA and the ECal module. If orientation is turned OFF, the SENS:CORR:PREF:ECAL:PMAP command must be used to specify the port connections before performing a cal.

Note: 3-port calibration with a 2-port ECal module does not fully support the mode of orientation = OFF.

Examples

SENS:CORR:PREF:ECAL:ORI OFF

sense:correction:preference:ecal:orientation:state on

Query Syntax

SENSe:CORRection:PREFerence:ECAL:ORIentation[:STATe]?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

ON (1)

SENSe:CORRection:PREFerence:ECAL:PMAP <module>,<string>

(Read-Write) When ECal module orientation is turned OFF (SENS:CORR:PREF:ECAL:ORI OFF), this command specifies the port mapping (which ports of the module are connected to which ports of the PNA) prior to performing ECal calibrations.

Parameters

<module>

Specifies which ECal module this port map is being applied to. Choose from:

ECAL1

.through.

ECAL8

<string>

Format this parameter in the following manner:

Aw,Bx,Cy,Dz

where

  • A, B, C, and D are literal ports on the ECAL module

  • w,x,y, and z are substituted for PNA port numbers to which the ECAL module port is connected.

Ports of the module which are not used are omitted from the string.

For example, on a 4-port ECal module with

port A connected to PNA port 2

port B connected to PNA port 3

port C not connected

port D connected to PNA port 1

the string would be: A2,B3,D1

If either the receive port or source port (or load port for 2-port cal) of the CALC:PAR:SELected measurement is not in this string and orientation is OFF, an attempt to perform an ECal calibration will fail.

Examples

SENS:CORR:PREF:ECAL:PMAP ECAL2, 'A1,B2' sense:correction:preference:ecal:pmap ecal3, 'a2,b1,c3'

Query Syntax

SENSe:CORRection:PREFerence:ECAL:PMAP? <module>

Return Type

String

Overlapped?

No

Default

Null string ()

SENSe<cnum>:CORRection:RVELocity:COAX <num>

(Read-Write) Sets the velocity factor to be used with Electrical Delay and Port Extensions.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Velocity factor. Choose a number between 0 and 10 (.66 polyethylene dielectric; .7 teflon dielectric)
Examples | SENS:CORR:RVEL:COAX .66 sense2:correction:rvelocity:coax .70
Query Syntax | SENSe<cnum>:CORRection:RVELocity:COAX?
Return Type | Numeric
Overlapped? | No
Default | 1

SENSe:CORRection:SFORward[:STATe] <boolean>

(Read-Write) Sets the direction a calibration will be performed when only one set of standards is used. Use SENSe:CORRection:TSTandards[:STATe] OFF to specify that only one set of standards will be used.
Parameters |
<boolean> | ON (1) - FORWARD direction of a 2-port calibration will be performed. OFF (0) - REVERSE direction of a 2-port calibration will be performed.
Examples | SENS:CORR:SFOR 1 sense:correction:sforward:state 0 See an example using this command
Query Syntax | SENSe:CORRection:SFORward[:STATe]?
Return Type | Boolean
Overlapped? | No
Default | ON

SENSe<cnum>:CORRection[:STATe] <ON | OFF>

(Read-Write) Specifies whether or not correction data is applied to the measurement. Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - correction is applied to the measurement. OFF (or 0) - correction is NOT applied to the measurement.
Examples | SENS:CORR ON sense2:correction:state off
Query Syntax | SENSe<cnum>:CORRection[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe:CORRection:TSTandards[:STATe] <boolean>

(Read-Write) Specifies the acquisition of calibration data using TWO set of standards or ONE.

Parameters

<boolean>

ON (1) - TWO sets of standards will be used for full 2-port calibration for both Forward and Reverse parameters.

OFF (2) - ONE set of standards will be used for full 2-port calibration.

Set SENSe:CORRection:COLLect:SFORward[:STATe] to ON for the forward acquisitions and OFF for the reverse acquisitions.

When specifying ON (two sets), the SENS:CORR:COLL:ACQuire command uses the same standard index for each calibration class. To specify the calibration standard gender for each port, you must first ensure that the order of calibration class accurately reflects the configuration of your DUT. For example, for a DUT with a male connector on port 1 and a female connector on port 2, order the devices within the S11 classes (A, B, and C) such that the MALE standards are first in the list. Then order the S22 classes specifying the FEMALE standards as the first in the list.

Examples

SENS:CORR:TST 1
sense:correction:tstandard:state 0

See an example using this command

Query Syntax

SENSe:CORRection:TSTandards[:STATe]?

Return Type

Boolean

Overlapped?

No

Default

ON

SENSe:CORRection:TYPE:CATalog? <char>

(Read-Write) Lists the Cal Types in the PNA by either GUID or registered name. Critical Note:
Parameters |
<char> | Specifies the type of list. Choose from: GUID - the registered GUID of the Cal Type NAME - the registered name of the Cal Type
Examples | SENS:CORR:TYPE:CAT? GUID
Query Syntax | SENSe<cnum>:CORRection:TYPE:CATalog? <char>
Return Type | Comma-separated string
Overlapped? | No
Default | Not Applicable


CorrCKIT SCPI

Sense:Correction:CKIT Commands

Manages the list of cal kits that are installed in the PNA.

  • Click on a blue keyword to view the command details.

  • New See Calibrating the PNA Using SCPI

  • See a List of all commands in this block.

  • Learn about Modifying Cal Kits

SENSe:CORRection:CKIT:CLEar[:IMMediate]

(Write-only) Deletes ALL installed cal kits.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:CKIT:CLE
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:CKIT:COUNt?

(Read-only) Returns the number of installed cal kits.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:CKIT:COUNt?
Query Syntax | SENS:CORR:CKIT:COUNt?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:CKIT:ECAL<mod>:CLISt?

(Read-only) Returns a list of characterizations stored in the specified ECal module.
Parameters |
<mod> | ECal module from which to read user characterization numbers. If unspecified, value is set to 1.
Examples | Module 1 contains User Characterizations 1 and 3. SENSe:CORRection:CKIT:ECAL:CLIST? 'Returns the following (0 always indicates the factory characterization): 0,1,3
Return Type | Numeric list, separated by commas.
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:CKIT:ECAL<mod>:INFormation? [<char>]

(Read-only) Reads the user-characterization information from the specified ECal module. This command returns the same values as SENS:CORR:COLL:CKIT:INF?

Parameters

<mod>

ECal module to read characterizations from. Choose from:

1 through 8. If unspecified, value is set to 1.

<char>

Optional argument. Specifies which characterization within the ECal module to read information from. If not specified, value is set to CHAR0.

Choose from:

  • CHAR0 Factory characterization (data that was stored in the ECal module by Agilent)

  • CHAR1 User characterization #1

  • CHAR2 User characterization #2

  • CHAR3 User characterization #3

  • CHAR4 User characterization #4

  • CHAR5 User characterization #5

Examples

SENS:CORR:CKIT:ECAL2:INFormation? char5

'Example return string:

ModelNumber: 85092-60007, SerialNumber: 01386, ConnectorType: N5FN5F, PortAConnector: Type N (50) female, PortBConnector: Type N (50) female, MinFreq: 30000, MaxFreq: 9100000000, NumberOfPoints: 250, Calibrated: July 4 2002

Return Type

Character

Overlapped?

No

Default

Not Applicable

SENSe:CORRection:CKIT:ECAL:LIST?

(Read-only) Returns a list of index numbers to be used for referring to the ECal modules that are currently attached to the PNA.
Examples | SENS:CORR:CKIT:ECAL:LIST? 'If 2 modules are attached to the PNA 'then the returned list will be: 1,2
Return Type | Numeric list, separated by commas.
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:CKIT:IMPort <string>

(Write-only) Imports the specified cal kit (.ckt file) and appends the imported kit to the end of the list of kits whenever the file import succeeds.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<string> | Path and cal kit name.
Examples | SENSe2:CORRection:CKIT:IMPort "C:\Program Files\Agilent\Network Analyzer\Documents\85033D.ckt"
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:CKIT:INITialize[:IMMediate]

(Write-only) Restores all default factory installed cal kits.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:CKIT:INITialize sense2:correction:ckit:initialize
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:CKIT:LOAD <string>

(Write-only) Loads the specified collection of cal kits from a .wks file. You can make your own collection of cal kits from the Advanced Modify Cal Kit menu.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<string> | Path and file name of the cal kit collection.
Examples | sense2:correction:ckit:load "C:\Program Files\Agilent\Network Analyzer\PnaCalKits\factory\MyCalKits.wks
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable


CorrCollCKIT SCPI

Sense:Correction:Collect:CKit Commands

Use to change the definitions of calibration kit standards.

Click on a blue keyword to view the command details.

Most of these commands act on the currently selected standard from the currently selected calibration kit.

  • New See Calibrating the PNA Using SCPI

  • To select a Calibration kit, use SENS:CORR:COLL:CKIT:SEL.

  • To select a Calibration standard, use SENS:CORR:COLL:CKIT:STAN:SEL

  • See a List of all commands in this block.

  • See an example program that CREATES a New Cal Kit

  • See an example program that MODIFIES an Existing Cal Kit

  • Learn about Modifying Cal Kits

Note: You should provide data for every definition field - for every standard in your calibration kit. If a field is not set, the default value may not be what you expect.

SENSe:CORRection:COLLect:CKIT:CONNector:ADD <family>,<start>,<stop>,<z0>,<gender>,<media>,<cutoff>

(Write only) Creates a new connector. The connector is automatically added to the list of available connectors for the currently selected cal kit. If a connector includes both male and female connectors, each connector must be added separately.
Parameters |
<family> | (String) Name of connector family. Limited to 50 characters.
<start> | Start frequency
<stop> | Stop frequency
<z0> | Characteristic Impedance of the connector in ohms.
<gender> | Connector gender. Choose from: MALE FEMALE NONE
<media> | Media of the connector. Choose from: COAX - coaxial WAVE - waveguide
<cutoff> | Cutoff frequency of the connector (waveguide only).
Examples | SENS:CORR:COLL:CKIT:CONN:ADD "PSC 1.8 mm",0 HZ,999.9 GHZ,50,FEMALE,COAX,0.0 SENS:CORR:COLL:CKIT:CONN:ADD "PSC 1.8 mm",0 HZ,999.9 GHZ,50,MALE,COAX,0.0
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:CONNector:CATalog?

(Read-only) Returns a comma-separated list of all connectors defined within the currently selected cal kit. The returned string includes the connector family name followed by the connector gender, if any. Kits may include a primary connector family name and additional connector family names.

Connector family names are case sensitive. A connector family named "PSC 2.4" is different from a connector family named "psc 2.4".

Learn more about Connector Family Name

Parameters

None

Examples

SENS:CORR:COLL:CKIT:CONN:CAT?

'Returned string

"Type-N (50) male, Type-N (50) female"

Overlapped?

No

Default

Not Applicable

SENSe:CORRection:COLLect:CKIT:CONNector:DELete

(Write-only) Deletes the primary connector family name from the selected kit. The PNA allows multiple connector families for each kit. If a kit includes multiple connector families, only the first listed (primary) connector family name is deleted.

Once the connector family is deleted, the connector may not be assigned to any new or existing standard within the kit.

The previously defined standards retain their association to the deleted connector name. To reassign standards to a new connector family name, use SENS:CORR:COLL:CKIT:CONN:SNAMe.

Parameters

None

Examples

SENS:CORR:COLL:CKIT:CONN:DEL

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SENSe:CORRection:COLLect:CKIT:CONNector:FNAME <name>

(Read-Write) Replaces the primary connector family name from the selected kit with a new connector family name. The connector family name is replaced in all standards in the kit that share that name. The PNA allows multiple connector families for each kit. If a kit includes multiple connector families, only the first listed (primary) connector family name is replaced. Use the query form of this command to return the name of the primary connector family.
Parameters |
<name> | New connector family name. Limited to 50 characters.
Examples | SENS:CORR:COLL:CKIT:CONN:FNAM 'MYPSC35' Sense:correction:collect:ckit:connector:name 'My Type N'
Query Syntax | SENSe:CORRection:COLLect:CKIT:CONNector:FNAMe?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:CONNector:SNAMe <family>,<gender>,<port>

(Read-Write) Assigns a family name to the currently selected standard from the currently selected kit. Specify each port of a 2-port standard individually. Use the query form of this command to read the connector family name assigned to the current standard. The name is not assigned unless the connector family name is previously defined within the selected kit.
Parameters |
<family> | String. Connector family name.
<gender> | Connector gender. Choose from: MALE FEMALE NONE
<port> | Number of the connector port to be assigned the connector family name. 2-port standards such as a thru line must be assigned separately. It is not relevant which connector is port 1 or port 2. 1 Specifies a 1-port standard or the first port of a 2-port standard. 2 Specifies the second port of a 2-port standard.
Examples | SENS:CORR:COLL:CKIT:CONN:SNAMe "Type-N (50)",MALE,1
Query Syntax | SENSe:CORRection:COLLect:CKIT:CONNector:SNAMe?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:DESCription <string>

(Read-Write) Modifies the cal kit description field of the selected kit. This description appears in the Edit PNA Cal Kit dialog box.
Parameters |
<string> | Description of the cal kit. Limited to 50 characters.
Examples | SENS:CORR:COLL:CKIT:DESC "My New CalKit"
Query Syntax | SENSe:CORRection:COLLect:CKIT:DESCription?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:INFormation? <module>[,char]

(Read Only) Reads characterization information from an ECal module.
Parameters |
<module> | Specifies which ECal module to read from. Choose from: ECAL1 .through. ECAL8
[char] | Optional argument. Specifies which characterization within the ECal module to read information from. If this argument is not used, the default is CHAR0. CHAR1 through CHAR5 are for user characterizations that may have been written to the module by the User Characterization feature on the PNA. Choose from: CHAR0 Factory characterization (data that was stored in the ECal module by Agilent) CHAR1 User characterization #1 CHAR2 User characterization #2 CHAR3 User characterization #3 CHAR4 User characterization #4 CHAR5 User characterization #5
Examples | SENS:CORR:COLL:CKIT:INF? ECAL4 sense:correction:collect:ckit:information? ecal2,char1
 | Example return string:
 | ModelNumber: 85092-60007, SerialNumber: 01386, ConnectorType: N5FN5F, PortAConnector: Type N (50) female, PortBConnector: Type N (50) female, MinFreq: 30000, MaxFreq: 9100000000, NumberOfPoints: 250, Calibrated: July 4 2002
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:NAME <name>

(Read-Write) Sets a name for the selected calibration kit.
Parameters |
<name> | Calibration Kit name. Any string name, can include numerics, period, and spaces; any length (although the dialog box display is limited to about 30 characters).
Examples | SENS:CORR:COLL:CKIT:NAME 'MYAPC35' sense:correction:collect:ckit:name 'mytypen'
Query Syntax | SENSe:CORRection:COLLect:CKIT:NAME?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:OLABel<class> <name>

(Read-Write) Sets the label for the calibration class designed by <class>. The label is used in the prompts for connecting the calibration standards associated with that <class>.
Parameters |
<class> | Number of the calibration class. Choose a number between: 1 and 18. The <class> numbers are associated with the following calibration Classes:
 | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru/Delay standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru/Delay standard
3-port analyzers only
9 | S33A | Reflection standard
10 | S33B | Reflection standard
11 | S33C | Reflection standard
12 | S32T | Thru/Delay standard
13 | S23T | Thru/Delay standard
14 | S31T | Thru/Delay standard
15 | S13T | Thru/Delay standard
TRL Calibrations
16 | TRL "T" | Thru standard
17 | TRL "R" | Reflect standard
18 | TRL "L" | Line standard
<name> | Label for the calibration class. Must be enclosed in quotes. Any string between 1 and 12 characters long. Cannot begin with a numeric.
Examples | SENS:CORR:COLL:CKIT:OLAB3 'LOADS' sense:correction:collect:ckit:olabel4 'Thru'
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:OLIST[class]?

(Read-only) Returns seven values of standards that are assigned to the specified class.
Parameters |
<class> | Number of the calibration class to be queried. The <class> numbers are associated with the following calibration Classes:
 | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru/Delay standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru/Delay standard
3-port analyzers only
9 | S33A | Reflection standard
10 | S33B | Reflection standard
11 | S33C | Reflection standard
12 | S32T | Thru/Delay standard
13 | S23T | Thru/Delay standard
14 | S31T | Thru/Delay standard
15 | S13T | Thru/Delay standard
TRL Calibrations
16 | TRL "T" | Thru standard
17 | TRL "R" | Reflect standard
18 | TRL "L" | Thru standard
Examples | SENS:CORR:COLL:CKIT:OLIST8? Always returns 7 standard numbers. Unassigned standards return 0
Return Type | Numeric; returns the <class> number of the selected standard.
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:ORDer<class> <std> [,<std>] [,<std>] [,<std>] [,<std>] [,<std>] [,<std>]

(Read-Write) Sets a standard number to a calibration class. Does NOT set or dictate the order for measuring the standards. For more information, see Assigning Standards to a Calibration Class
Parameters |
<class> | Number of the calibration class that is assigned to <standard>. Choose a number between: 1 and 18. The <class> numbers are associated with the following calibration Classes:
 | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru/Delay standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru/Delay standard
3-port analyzers only
9 | S33A | Reflection standard
10 | S33B | Reflection standard
11 | S33C | Reflection standard
12 | S32T | Thru/Delay standard
13 | S23T | Thru/Delay standard
14 | S31T | Thru/Delay standard
15 | S13T | Thru/Delay standard
TRL Calibration
16 | TRL "T" | Thru standard
17 | TRL "R" | Reflect standard
18 | TRL "L" | Line standard
<std> | Standard number to be assigned to the class; Choose a standard between 1 and 8. One standard is mandatory; up to six additional standards are optional.
Examples | Assigns standard 3 to S11A class: SENS:CORR:COLL:CKIT:ORD1 3 Assigns standard 2 and 5 to S21T class class: sense:correction:collect:ckit:order4 2,5
Query Syntax | SENSe:CORRection:COLLect:CKIT:ORDer<class>? 'Returns only the first standard assigned to the specified class. To query the remaining standards, use SENSe:CORRection:COLLect:CKIT:OLIST[1-15]?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:RESet <num>

(Write-only) Obsolete in Rev 3.2. Instead use Sens:Corr:Ckit:Init. Resets the selected calibration kit to factory default definition values.
Parameters |
<num> | The number of the calibration kit to be reset. Choose any integer between: 1 and 8
Examples | SENS:CORR:COLL:CKIT:RESet 1 sense:correction:collect:ckit:reset 4
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT[:SELect] <num>

(Read-Write) Selects (makes active) a calibration kit for performing a calibration or for modifying standards. All subsequent "CKIT" commands that are sent apply to this selected calibration kit. Select a calibration standard using SENS:CORR:COLL:CKIT:STAN <num>
Parameters |
<num> | The number of the calibration kit. Choose from: Use SENSe:CORRection:COLLect:CKIT:RESet to restore Cal Kits to default values.
 | Name
1 | User Defined 1
2 | User Defined 2
3 | User Defined 3
48 | User Defined 48
49 | User Defined 49
50 | User Defined 50
99 | ECAL module OBSOLETE - This argument is no longer required. Specify the use of ECal using only Sens:Corr:Coll:Acquire. See example.
Examples | SENS:CORR:COLL:CKIT 2 sense2:correction:collect:ckit:select 7
Query Syntax | SENSe:CORRection:COLLect:CKIT?
Return Type | Numeric
Overlapped? | No
Default | Last kit selected

SENSe:CORRection:COLLect:CKIT:STANdard:C0 <num>

(Read-Write) Sets the C0 value (the first capacitance value) for the selected standard.
Parameters |
<num> | Value for C0 in picofarads
Examples | The following commands set C0=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C0 15 sense:correction:collect:ckit:standard:c0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C0?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C1 <num>

(Read-Write) Sets the C1 value (the second capacitance value) for the selected standard.
Parameters |
<num> | Value for C1 in picofarads
Examples | The following two commands set C1=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C1 15 sense:correction:collect:ckit:standard:c1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C1?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C2 <num>

(Read-Write) Sets the C2 value (the third capacitance value) for the selected standard.
Parameters |
<num> | Value for C2 in picofarads
Examples | The following two commands set C2=(-15) picofarads: SENS:CORR:COLL:CKIT:STAN:C2 -15 sense:correction:collect:ckit:standard:c2 -15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C2?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C3 <num>

(Read-Write) Sets the C3 value (the fourth capacitance value) for the selected standard.
Parameters |
<num> | Value for C3 in picofarads
Examples | The following two commands set C3=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C3 15 sense:correction:collect:ckit:standard:c3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C3?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter <char>

(Read-Write) Sets the media type of the selected calibration standard.
Parameters |
<char> | Media type of the standard. Choose from: Coax - Coaxial Cable Wave - Waveguide
Examples | SENS:CORR:COLL:CKIT:STAN:CHAR COAX sense:correction:collect:ckit:standard:character wave
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter?
Return Type | Numeric
Overlapped? | No
Default | Coax

SENSe:CORRection:COLLect:CKIT:STANdard:DELay <num>

(Read-Write) Sets the electrical delay value for the selected standard.
Parameters |
<num> | Electrical delay in seconds
Examples | SENS:CORR:COLL:CKIT:STAN:DEL 50e-12 sense2:correction:collect:ckit:standard:delay 50ps
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:DELay?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMAX <num>

(Read-Write) Sets the maximum frequency for the selected standard.
Parameters |
<num> | Maximum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMAX 9e9 sense:correction:collect:ckit:standard:fmax 9Ghz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMAX?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMIN <num>

(Read-Write) Sets the minimum frequency for the selected standard.
Parameters |
<num> | Minimum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMIN 1e3 sense:correction:collect:ckit:standard:fmin 1khz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMIN?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance <num>

(Read-Write) Sets the characteristic impedance for the selected standard.
Parameters |
<num> | Impedance in Ohms
Examples | SENS:CORR:COLL:CKIT:STAN:IMP 75 sense:correction:collect:ckit:standard:impedance 50.3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance?
Return Type | Numeric
Overlapped? | No
Default | 50

SENSe:CORRection:COLLect:CKIT:STANdard:L0 <num>

(Read-Write) Sets the L0 value (the first inductance value) for the selected standard.
Parameters |
<num> | Value for L0 in picohenries
Examples | The following two commands set L0=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L0 15 sense:correction:collect:ckit:standard:l0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L0?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L1 <num>

(Read-Write) Sets the L1 value (the second inductance value) for the selected standard.
Parameters |
<num> | Value for L1 in picohenries
Examples | The following two commands set L1=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L1 15 sense:correction:collect:ckit:standard:l1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L1?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L2 <num>

(Read-Write) Sets the L2 value (the third inductance value) for the selected standard.
Parameters |
<num> | Value for L2 in picohenries
Examples | The following two commands set L2=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L2 15 sense:correction:collect:ckit:standard:l2 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L2?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L3 <num>

(Read-Write) Sets the L3 value (the fourth inductance value) for the selected standard.
Parameters |
<num> | Value for L3 in picohenries
Examples | The following two commands set L3=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L3 15 sense:correction:collect:ckit:standard:l3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L3?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LABel <name>

(Read-Write) Sets the label for the selected standard. The label is used to prompt the user to connect the specified standard.
Parameters |
<name> | Label for the standard; Must be enclosed in quotes. Any string between 1 and 12 characters long. Cannot begin with a numeric.
Examples | SENS:CORR:COLL:CKIT:STAN:LAB 'OPEN' sense:correction:collect:ckit:standard:label 'Short2'
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LABel?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LOSS <num>

(Read-Write) Sets the insertion loss for the selected standard.
Parameters |
<num> | Insertion loss in Mohms / sec. (MegaOhms per second of electrical delay)
Examples | SENS:CORR:COLL:CKIT:STAN:LOSS 3.5e9 sense:correction:collect:ckit:standard:loss 3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LOSS?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:REMove

(Write only) Deletes the selected standard from the selected cal kit.
Examples | SENS:CORR:COLL:CKIT:STAN:REMove
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:SDEScription <string>

(Read-Write) Modifies the description of the selected standard of the selected kit. This description appears in the edit kit dialog box.
Parameters |
<string> | Description of the standard. How long can this be?
Examples | SENS:CORR:COLL:CKIT:STAN:SDES "My New Standard"
Query Syntax | SENSe:CORRection:COLLect:STANdard:SDEScription?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard[:SELECT] <num>

(Read-Write) Selects the calibration standard. All subsequent "CKIT" commands to modify a standard will apply to the selected standard. Select a calibration kit using SENS:CORR:COLL:CKIT:SEL
Parameters |
<num> | Number of the standard. Choose any number between: 1 and 30
Examples | SENS:CORR:COLL:CKIT:STAN 3 sense:correction:collect:ckit:standard:select 8
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard[:SELect]?
Return Type | Numeric
Overlapped? | No
Default | 1

SENSe:CORRection:COLLect:CKIT:STANdard:TYPE <char>

(Read-Write) Sets the type for the selected standard.
Parameters |
<char> | Choose from: OPEN SHORT LOAD SLOAD (sliding load) THRU (through) ARBI(arbitrary)
Examples | SENS:CORR:COLL:CKIT:STAN:TYPE LOAD sense:correction:collect:ckit:standard:type short
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TYPE?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:TZReal <num>

(Read-Write) Sets the TZReal component value of the Terminal Impedance for the selected standard. Note: Only applicable when the Standard Type is set to ARBI
Parameters |
<num> | Value for TZReal in Ohms
Examples | The following commands set TZReal=15 Ohms: SENS:CORR:COLL:CKIT:STAN:TZReal 15 sense:correction:collect:ckit:standard:TZReal 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TZReal?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:TZImag <num>

(Read-Write) Sets the TZImag component value of the Terminal Impedance for the selected standard. Note: Only applicable when the Standard Type is set to ARBI
Parameters |
<num> | Value for TZImag in Ohms
Examples | The following two commands set TZImag=15 Ohms: SENS:CORR:COLL:CKIT:STAN:TZImag 15 sense:correction:collect:ckit:standard:TZImag 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TZImag?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:TRLoption:IMPedance <char>

(Read-Write) Determines how the reference impedance is set for the TRL calibration.

Parameters

<char>

LINE Specifies that the characteristic impedance of the LINE standard should be used as the system impedance. This ignores any difference between Offset Z0, Offset Loss and system Z0.

SYSTEM Transforms the LINE standard impedance and loss to that of the system impedance for use with the calibration error terms. The TRL calibration will first compute the error terms assuming the "Line" standard impedance is the system's characteristic impedance (same as LINE option), then modify the error terms to include the impedance transformation. This should only be used with coax since the skin effect model used is a coaxial model.

The System Impedance may be changed if necessary using SENS:CORR:IMP:INP:MAGN.

Examples

SENS:CORR:COLL:CKIT:TRL:IMP LINE

sense:correction:collect:ckit:trloption:impedance system

Query Syntax

SENSe:CORRection:COLLect:CKIT:TRLoption:IMPedance?

Return Type

Character

Overlapped?

No

Default

SYST

SENSe:CORRection:COLLect:CKIT:TRLoption:RPLane <char>

(Read-Write) Specifies the standard to be used to establish the position of the measurement reference plane.
Parameters |
<char> | Standard used to establish the position of the measurement reference plane. Choose from: THRU Select if the THRU standard is zero-length or very short. REFLect Select if the THRU standard is not appropriate AND the delay of the REFLECT standard is well defined.
Examples | SENS:CORR:COLL:CKIT:TRL:RPL REFL sense:correction:collect:ckit:trloption:rplane thru
Query Syntax | SENSe:CORRection:COLLect:CKIT:TRLoption:RPLane?
Return Type | Character
Overlapped? | No
Default | THRU


CorrCollSess

SENSe:CORRection:COLLect:SESSion Commands

The commands in this topic are common to perform both SMC and VMC calibrations. A calibration session is a term used to describe an instance of an SMC or VMC calibration. For more commands, see SESS:SMC and SESS:VMC.

Commands to read (STEP?) and describe (DESC?) each step are provided to facilitate a remote user interface.

  • Click on a blue keyword to view the command details.

  • New See Calibrating the PNA Using SCPI

  • See a List of all commands in this block.

  • See a SCPI SMC and VMC calibration.

  • Learn about SMC and VMC calibrations

SENSe<ch>:CORRection:COLLect:SESSion<n>:ACQuire <step>

(Write only) Acquire a calibration measurement.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | Session number. Choose from 1 to 16.
<step> | Step number to acquire. Use SENS:CORR:COLL:SESS:STEPS? to find the number of steps required for the calibration.
Examples | SENSe2:CORR:COLL:SESS6:ACQ 5
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:SESSion<n>:CKIT:PORT<p>:CATalog?

(Read only) Returns a list of cal kits that are compatible with the connector on port <p>. The port connector type is set with SENS:CORR:COLL:SESS:CONN:PORT
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | Session number. Choose from 1 to 16.
<p> | Port number of connector to query for compatible cal kits.
Examples | SENS2:CORR:COLL:SESS6:CKIT:PORT2:CAT?
Return Type | Comma separated string values
Overlapped? | No
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:SESSion<n>:CKIT:PORT<p>[:SELect] <calkit>

(Read-Write) Set or return the Cal Kit for the specified port. Use SENS:CORR:COLL:SESS:CKIT:PORT:CAT? to list compatible Cal Kits.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
<p> | Port number for which to set cal kit.
<calkit> | Cal Kit Name
Examples | SENS:CORR:COLL:SESS:CKIT:PORT:SEL 85091A SENS2:CORR:COLL:SESS6:CKIT:PORT2:SEL?
Query Syntax | SENS<ch>:CORR:COLL:SESS<n>:CKIT:PORT<p>[:SEL] ?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:SESSion<n>:CONN:PORT<p>[:SEL] <conn>

(Read-Write) Set the connector type and sex for the specified port number. Catalog valid connector types using SENS:CORR:COLL:GUID:CONN:CAT?
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
<p> | Port number for which to select a connector type.
<conn> | Name of the connector type
Examples | SENS2:CORR:COLL:SESS6:CONN:PORT1:SEL "N Type"
Query Syntax | SENS<ch>:CORR:COLL:SESS<n>:CONN:PORT<p>[:SEL] ?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:SESSion<n>:DESC? <step>

(Read-only) Returns the connection prompt for the step. List the number of steps in the calibration using SENS:CORR:COLL:SESS:STEPS?.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
<step> | Step number
Examples | SENS1:CORR:COLL:SESS6:DESC?3
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:SESSion<n>:DONE

(Write only) Ends the calibration sessions. Use SAVE? to calculate error terms and save the CalSet.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
Examples | SENS1:CORR:COLL:SESS6:DONE
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:SESSion<n>:INITiate <string>

(Write only) Initiates an SMC or VMC calibration session. Use the session number for subsequent SMC or VMC commands.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16. If the session number already exists it will be terminated and a new session initiated.
<string> | Name of the calibration. Choose from: "VMC" or "VectorMixerCal.VMCType" "SMC" or "ScalarMixerCal.SMCType"
Examples | SENS1:CORR:COLL:SESS6:INITiate "VectorMixerCal.VMCType"
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:SESSion<n>:SAVE?

(Read only) Finish the SMC or VMC calibration, compute error terms, populate and save the CalSet, and return the GUID of the CalSet.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
Examples | SENS1:CORR:COLL:SESS6:SAVE?
Return Type | String specifying the GUID of the CalSet produced by this session.
Overlapped? | No
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:SESSion<n>:STEPs?

(Read-only) Returns the number of steps required by the Calibration. To ensure this query always completes successfully, first send the write command: SENS:CORR:COLL:SESS:STEP, then send the query.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
Examples | SENS1:CORR:COLL:SESS6:STEPs?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable


CorrCollSessSMC

SENSe:CORRection:COLLect:SESSion:SMC Commands

Performs scalar (SMC) calibration on a frequency converting device.

  • Click on a blue keyword to view the command details.

  • New See Calibrating the PNA Using SCPI

  • See a List of all commands in this block.

  • Learn about FCA Calibrations

NOTE: To configure a power meter and sensor see SOURce:POWer: commands.

SENSe<ch>:CORRection:COLLect:SESSion<n >:SMC:ECAL:CHARacteriza <mod> ,<char>

(Read-Write) Specifies the ECal module and characterization to be used for the SMC calibration.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
<mod> | 1 - Electronic Calibration Module
<char> | Specifies which characterization within the ECal module from which to read the confidence data. 0 Factory characterization (data that was stored in the ECal module by Agilent). Default if not specified. 1 User characterization #1 2 User characterization #2 3 User characterization #3 4 User characterization #4 5 User characterization #5
Examples | SENS:CORR:COLL:SESS:SMC:ECAL:CHAR 1,2
Query Syntax | SENS:CORR:COLL:SESS:SMC:ECAL:CHAR?
Return Type | Numeric
Overlapped? | No
Default | 1,0

SENSe<ch>:CORRection:COLLect:SESSion<n>:SMC:PWRCal:SRCPort <string>

(Read-Write) Specifies which port to calibrate.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
<char> | '1' Source port 1 (SMC forward direction) '2' Source port 2 (SMC reverse direction 'BOTH' (both forward and reverse directions)
Examples | SENS:CORR:COLL:SESS:SMC:PWRC:SRCP 'both' SENSe2:CORRection:COLLection:SESSion6:SMC:PWRCal:SRCPort '2'
Query Syntax | SENS:CORR:COLL:SESS:SMC:PWRC:SRCP?
Return Type | String
Overlapped? | No
Default | 1

SENSe<ch>:CORRection:COLLect:SESSion<n>:SMC:TWOPort:ECAL:ORIentation[:STATe] <bool>

(Read-Write) Sets ECAL Auto-Orientation ON or OFF. If setting auto-orientation OFF, you must manually specify the orientation of the ECAL module with SENS:CORR:COLL:SESS:SMC:TWOP:ECAL:PORTmap.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
<bool> | 0 = Orientation OFF 1 = Orientation ON
Examples | SENS:CORR:COLL:SESS:SMC:TWOP:ECAL:ORI 1
Query Syntax | SENS:CORR:COLL:SESS:SMC:TWOP:ECAL:ORI?
Return Type | Boolean
Overlapped? | No
Default | 1

SENSe<ch>:CORRection:COLLect:SESSion<n>:SMC:TWOPort:ECAL:PORTmap <mod>, <string>

(Read-Write) Specifies the manual orientation (which ports of the module are connected to which ports of the PNA) when auto-orientation is OFF.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<n>

Session number. Choose from 1 to 16.

<mod>

1 - Electronic Calibration Module

<string>

Format in the following manner:

Aw,Bx,Cy,Dz

where

  • A, B, C, and D are literal ports on the ECAL module

  • w,x,y, and z are substituted for PNA port numbers to which the ECAL module port is connected.

Ports of the module which are not used are omitted from the string.

For example, on a 4-port ECal module with

  • port A connected to PNA port 2

  • port B connected to PNA port 3

  • port C not connected

  • port D connected to PNA port 1

the string would be: A2,B3,D1

If either the receive port or source port (or load port for 2-port cal) of the CALC:PAR:SELected measurement is not in this string and orientation is OFF, an attempt to perform an ECal calibration will fail.

Examples

SENS:CORR:COLL:SESS:SMC:TWOP:ECAL:PORTmap 1,'A1,B2'

Query Syntax

SENS:CORR:COLL:SESS:SMC:TWOP:ECAL:PORTmap?

Return Type

String

Overlapped?

No

Default

"A1,B2"

SENSe<ch>:CORRection:COLLect:SESSion<n >:SMC:TWOPort:METHod <string>

(Read-Write) Specifies the guided ECal method for performing the thru portion of the calibration.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
<char> | ECAL Method: Choose from: 'DEFAULT' - Default 'ADAP' - Adapter removal 'FLUSH' - Flush Through 'UNKN' - Unknown Thru
Examples | SENS:CORR:COLL:SESS:SMC:TWOPort:METH 'default'
Query Syntax | SENS:CORR:COLL:SESS:SMC:TWOPort:METH?
Return Type | String
Overlapped? | No
Default | DEFAULT

SENSe<ch>:CORRection:COLLect:SESSion<n >:SMC:TWOPort:OMITisolat <bool>

(Read-Write) Select to omit or perform the isolation portion of the ECAL.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
<bool> | 1 - Omit isolation 0 - Perform isolation
Examples | SENS:CORR:COLL:SESS:SMC:TWOPort:OMIT 1
Query Syntax | SENS:CORR:COLL:SMC:TWOPort:OMIT?
Return Type | Boolean
Overlapped? | No
Default | 1

SENSe<ch>:CORRection:COLLect:SESSion<n >:SMC:TWOPort:OPTion <string>

(Read-Write) Sets the SMC calibration to ECAL or MECHanical
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16.
<char> | Choose from: 'ECAL' Electronic Calibration Module 'MECH' Mechanical Calibration Kit
Examples | SENS:CORR:COLL:SESS:SMC:TWOPort:OPTion 'ECAL'
Query Syntax | SENS:CORR:COLL:SESS:SMC:TWOPort:OPTion?
Return Type | String
Overlapped? | No
Default | ECAL


CorrCollSessVMC

SENSe:CORRection:COLLect:SESSion:VMC Commands

Performs a vector (VMC) calibration on a frequency converting device.

  • Click on a blue keyword to view the command details.

  • New See Calibrating the PNA Using SCPI

  • See a List of all commands in this block.

  • Learn about VMC Calibration

SENS<ch>:CORRection:COLLect:SESSion<n> :VMC:CHARacterize:CAL:FILename <string>

(Read-Write) Specifies the .S2P filename used for mixer characterization. Use the VMC:MIXer:CHARacterize:CAL: OPTion command to recall the file for mixer characterization. Once recalled, use this command to query the current filename or set a new filename.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16
<string> | Filename of the S2P used for mixer characterization. Use the full path name, file name, and .S2P suffix
Examples | SENS2:CORR:COLL:SESS4:VMC:CHAR:CAL:FILE "C:\Program Files\Agilent\Network Analyzer\Documents\MyMixer.S2P"
Query Syntax | SENS:CORR:COLL:SESS:VMC:CHAR:CAL:FIL?
Return Type | String
Overlapped? | No
Default | C:\Program Files\Agilent\Network Analyzer\Documents\default.s2p

SENS<ch>:CORRection:COLLect:SESSion<n> :VMC:MIXer:CHARacterize:CAL: OPTion <char>

(Read-Write) Sets the mixer characterization method to ECal, Mechanical, or read from a file.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16
<char> | ECAL - Electronic Calibration Module MECH - Mechanical Calibration Kit FILE, <filename> - Retrieve a mixer characterization file. Also specify the filename of the S2P used for mixer characterization. Use the full path name, file name, and .S2P suffix. Use the VMC:CHARacterize:CAL:FILename command to query the filename..
Examples | SENS:CORR:COLL:SESS:VMC:MIX:CHAR:CAL:OPT ECAL SENS2:CORR:COLL:SESS6:VMC:MIXer:CHAR:CAL:OPTion FILE, MyMixerFile.mxr
Query Syntax | SENS:CORR:COLL:SESS:VMC:MIX:CHAR:CAL:OPT?
Return Type | String
Overlapped? | No
Default | MECH

SENS<ch>:CORRection:COLLect:SESSion<n> :VMC:MIXer:CHARacterize:CAL: REVerse <bool>

(Read-Write) Specifies the direction in which to characterize the calibration mixer. Learn more about the calibration mixer.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<n>

Session number. Choose from 1 to 16

<bool>

False (0) - Characterize the calibration mixer in the SAME direction as that specified in the mixer setup.

True (1) - Characterize the calibration mixer in the REVERSE direction as that specified in the mixer setup.

Examples

SENS:CORR:COLL:SESS:VMC:MIX:CHAR:CAL:REV 1

Query Syntax

SENS:CORR:COLL:SESS:VMC:MIX:CHAR:CAL:REV?

Return Type

Boolean

Overlapped?

No

Default

False

SENS<ch>:CORRection:COLLect:SESSion<n > :VMC:MIXer:ECAL:CHARacteriza <mod> ,<char>

(Read-Write) Specifies the ECal module and characterization to be used for the mixer characterization portion of the calibration.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16
<mod> | 1 - Electronic Calibration Module
<char> | Characterization number in the specified ECAL module. Choose from: 0 Factory characterization (data that was stored in the ECal module by Agilent). Default if not specified. 1 User characterization #1 2 User characterization #2 3 User characterization #3 4 User characterization #4 5 User characterization #5
Examples | SENS:CORR:COLL:SESS:VMC:MIX:ECAL:CHAR 1,0
Query Syntax | SENS:CORR:COLL:SESS:VMC:MIX:ECAL:CHAR?
Return Type | Numeric
Overlapped? | No
Default | 1,0

SENS<ch>:CORRection:COLLect:SESSion<n> :VMC:MIXer:ECAL:PORTmap <mod>, <string>

(Read-Write) Sets the port mapping for the mixer characterization with ECal. This command is required if SENS:CORR:COLL:SESS:VMC:MIX:CHAR:CAL:OPT ECAL is specified.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16
<mod> | 1 - Electronic Calibration Module
<string> | Choose from: "A1" - ECAL module port A is connected to PNA port 1 "B1" - ECAL module port B is connected to PNA port 1
Examples | SENS:CORR:COLL:SESS:VMC:MIX:ECAL:PORT? SENS2:CORR:COLL:SESS:VMC:MIXer:ECAL:PORTmap 1,"A1"
Query Syntax | SENS:CORR:COLL:SESS:VMC:MIX:ECAL:PORTmap?
Return Type | String
Overlapped? | No
Default | "A1"

SENSe<ch>:CORRection:COLLect:SESSion<n>:VMC:OPERation <string>

(Read-Write) Perform either full VMC calibration or mixer characterization only.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16
<char> | 'CAL' - full calibration and mixer characterization 'CHAR' - mixer characterization only (no reference mixer required) - Saves an .S2P file with the filename specified in SENS<ch>:CORR:COLL:SESSion<n >:VMC:CHARacterize:CAL:FILename <filename> . If none is specified, a filename is automatically generated and can be queried using the filename command.
Examples | SENS:CORR:COLL:SESS:VMC:OPER 'CAL'
Query Syntax | SENS:CORR:COLL:SESS:VMC:OPER?
Return Type | String
Overlapped? | No
Default | CAL

SENS<ch>:CORRection:COLLect:SESSion<n> :VMC:TWOPort:ECAL:CHARacteriza <mod> ,<char>

(Read-Write) Specifies the ECal module and characterization to be used for the VMC calibration.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16
<mod> | 1 - Electronic Calibration Module
<char> | Characterization number in the specified ECAL module. Choose from: 0 Factory characterization (data that was stored in the ECal module by Agilent). Default if not specified. 1 User characterization #1 2 User characterization #2 3 User characterization #3 4 User characterization #4 5 User characterization #5
Examples | SENS:CORR:COLL:SESS:VMC:TWOP:ECAL:CHAR 1,1
Query Syntax | SENS:CORR:COLL:SESS:VMC:TWOP:ECAL:CHAR?
Return Type | Integer
Overlapped? | No
Default | 1,0

SENS<ch>:CORRection:COLLect:SESSion<n> :VMC:TWOPort:ECAL:ORIentation[:STATe] <bool>

(Read-Write) Sets ECAL orientation for the VMC ECal.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16
<bool> | 1 = ON 0 = OFF
Examples | SENS:CORR:COLL:SESS:VMC:TWOP:ECAL:ORI 1
Query Syntax | SENS:CORR:COLL:SESSion:VMC:TWOPort:ECAL:ORIentation[:STATe]?
Return Type | Integer
Overlapped? | No
Default | ON

SENS<ch>:CORRection:COLLect:SESSion<n> :VMC:TWOPort:ECAL:PORTmap <mod>, <string>

(Read-Write) Specifies the manual orientation (which ports of the module are connected to which ports of the PNA) when orientation is turned off.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<n>

Session number. Choose from 1 to 16

<mod>

1 - Electronic Calibration Module

<string>

Port Map, formatted in the following manner:

Aw,Bx,Cy,Dz

where:

  • A, B, C, and D are literal ports on the ECAL module.

  • w,x,y, z are substituted for PNA port numbers to which the ECAL module port is connected.

  • Ports of the module which are not used are omitted from the string.

For example, on a 4-port ECal module with:

  • port A connected to PNA port 2

  • port B connected to PNA port 3

  • port C not connected

  • port D connected to PNA port 1

the string would be: A2,B3,D1

If either the receive port or source port (or load port for 2-port cal) of the measurement is not in this string and orientation is OFF, an attempt to perform an ECal will fail.

Examples

SENS:CORR:COLL:SESS:VMC:TWOP:ECAL:PORTmap 1,"A2,B1"

Query Syntax

SENS:CORR:COLL:SESS:VMC:TWOP:ECAL:PORTmap?

Return Type

string

Overlapped?

No

Default

"A1,B2"

SENS<ch>:CORRection:COLLect:SESSion<n> :VMC:TWOPort:METHod <string>

(Read-Write) Specifies the guided ECal method for performing the thru portion of the calibration.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16
<char> | 'DEFAULT' - Default 'ADAP' - Adapter removal 'FLUSH' - Flush Through 'UNKN' - Unknown Thru
Examples | SENS:CORR:COLL:SESS:VMC:TWOP:METH 'ADAP' SENSe2:CORR:COLL:SESSion6:VMC:TWOPort:METHod 'FLUSH'
Query Syntax | SENS:CORR:COLL:SESS:VMC:TWOP:METH?
Return Type | String
Overlapped? | No
Default | DEFAULT

SENS<ch>:CORRection:COLLect:SESSion<n> :VMC:TWOPort:OMITisolat <bool>

(Read-Write) Select to omit or perform the isolation portion of the ECAL.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16
<bool> | 1 - omit isolation 0 - perform isolation
Examples | SENS:CORR:COLL:SESS:VMC:TWOP:OMIT 1
Query Syntax | SENS:CORR:COLL:SESS:VMC:TWOP:OMIT?
Return Type | Numeric
Overlapped? | No
Default | 1

SENS<ch>:CORRection:COLLect:SESSion<n> :VMC:TWOPort:OPTion <string>

(Read-Write) Sets the 2-port calibration option to ECAL or MECHanical
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<n> | Session number. Choose from 1 to 16
<char> | Choose from: 'ECAL' Electronic Calibration Module 'MECH' Mechanical Calibration Kit
Examples | SENS:CORR:COLL:SESS:VMC:TWOP:OPT 'MECH' SENSe2:CORR:COLL:SESSion6:VMC:TWOPort:OPTion 'ECAL'
Query Syntax | SENS:CORR:COLL:SESS:VMC:TWOP:OPT?
Return Type | String
Overlapped? | No
Default | "MECH"


CorrCset SCPI

Sense:Correction:CSET Commands

Performs actions on calibration sets.

  • Click on a blue keyword to view the command details.

  • New See Calibrating the PNA Using SCPI

  • See a List of all commands in this block.

  • Learn about Cal Sets

SENSe:CORRection:CSET:CATalog?

(Read-only) Returns a string containing a list of comma-separated GUIDs for Cal Sets in the following format: {FD6F863E-9719-11d5-8D6C-00108334AE96}, {1B03B2CE-971A-11d5-8D6C-00108334AE96}
Parameters |
Examples | SENS:CORR:CSET:CAT? sense2:correction:cset:catalog?
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:CSET:DELete <string>

(Write-only) Deletes a Cal Set from the set of available Cal Sets. This command immediately updates the Cal Set file on the hard drive. Using the Cal Sets collection is a convenient way to manage Cal Sets.

If the Cal Set identified by the GUID is currently in use, the Cal Set will not be deleted. If you still want to delete a Cal Set that is in use, either turn off correction on the subscribing measurement, turn off subscribed channels, or select a different Cal Set for the subscribed channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<string>

The GUID of the Cal Set to be deleted. The curly brackets and hyphens must be included. Not case sensitive.

Examples

SENS:CORR:CSET:DEL '{2B893E7A-971A-11d5-8D6C-00108334AE96}'
sense2:correction:cset:delete '{2B893E7A-971A-11d5-8D6C-00108334AE96}'

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:CSET:DESCription <string>

(Read-Write) Sets or returns the descriptive string assigned to the selected Cal Set. Change this string so that you can easily identify each Cal Set. Select the Cal Set using SENSe:CORRection:CSET:GUID
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<string> | The descriptive string associated with the currently-selected Cal Set
Examples | SENS:CORR:CSET:DESC 'MyCalSet' sense2:correction:cset:description 'thisCalSet'
Query Syntax | SENSe<cnum>:CORRection:CSET:DESCription?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:CSET:GUID <string>

(Read-Write) Selects the Cal Set identified by the string parameter (GUID) and applies it to the specified channel.

A Cal Set cannot be selected for a channel which is not On.

If the stimulus settings of the selected Cal Set differ from those of the selected channel, the instrument will automatically change the channel's settings to match the Cal Set.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<string>

GUID of the desired Cal Set. The curly brackets and hyphens must be included.

Examples

SENS:CORR:CSET:GUID '{2B893E7A-971A-11d5-8D6C-00108334AE96}'
sense2:correction:cset:guid '{2B893E7A-971A-11d5-8D6C-00108334AE96}'

Query Syntax

SENSe<cnum>:CORRection:CSET:GUID?

Returns the GUID of the currently-selected Cal Set for the specified channel.

Return Type

String

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:CSET[:SELect] <char>

(Read-Write) Restores a correction data set from memory. The file name is "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a cal set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00x.cst". For more information on the file naming syntax, see the MMEMory subsystem.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: DEF - Presets the analyzer USER01 - Restores User01 calibration data USER02 - Restores User02 calibration data through... USER10 - Restores User10 calibration data
Examples | SENS:CORR:CSET DEF sense2:correction:cset:select user02
Query Syntax | SENSe<cnum>:CORRection:CSET[:SELect]?
Return Type | Charact er
Overlapped? | No
Default | DEF

SENSe<cnum>:CORRection:CSET:SAVE <char>

(Read Write) Write a correction data set to memory or read the last correction set saved. The file name is saved as "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a cal set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00x.cst". For more information on the filenaming syntax, see the MMEMory subsystem.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: USER01 USER02... USER10
Examples | SENS:CORR:CSET:SAVE USER03 sense2:correction:cset:save user09
Query Syntax | SENSe<cnum>:CORRection:CSET:SAVE? Queries the last correction set saved.
Return Type | Charact er
Overlapped? | No
Default | Not applicable

SENSe<ch>:CORRection:CSET:TYPE:CATalog? [format]

(Read-only) Query the Cal Types available in the selected Cal Set. You can specify the output format: a comma separated list of Guids or a list of names.

Note: CalTypes in earlier versions of PNA (pre 3.0) were indicated by a pre defined enumeration. In 3.0 the identity of the CalType has been expanded to support runtime detectable contribution calibration types. CalTypes are now identified by GUID's (128 bit number) and a name (string).

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

[format]

(Optional) Format of the output of cal types. choose from:

NAME - (default) returns a list of cal type string names.

GUID - returns a list of cal type GUIDs

Examples

SENS:CORR:CSET:TYPE:CAT? NAME
SENS2:CORRection:CSET:TYPE:CAT?

Return Type

string

Overlapped?

No

Default

Not Applicable


CorrGuided SCPI

Sense:Correction:Collect:Guided Commands

Performs and applies a GUIDED measurement calibration and other error correction features.

  • Click on a blue keyword to view the command details.

  • New See Calibrating the PNA Using SCPI

  • See a List of all commands in this block.

  • See an example using some of these commands.

  • Learn about Measurement Calibration

Note: With PNA release 4.8, the following changes occurred to ECal THRU methods. These changes affect the number of calibration steps that are performed, which could cause an error or inaccurate calibration when performed using a SCPI program.

  • Adapter Removal Thru method now performs 2-port measurements on both sides of the adapter. It previously performed 2-port measurements on one side and 1-port measurements on the other.

  • Unknown Thru and Flush Thru now use two, instead of three, connection steps.

To prevent these problems, use the sequence of commands outlined in the Guided Cal example to query, then perform, the correct number of calibration steps each time the program is run.

SENSe<cnum>:CORRection:COLLect:GUIDed:ACQuire <std>

(Write-only) Initiates the measurement of the specified calibration standard. Executing this command with an unnecessary standard has no affect.

The measured data is stored and used for subsequent calculations of error correction coefficients. All standards must be measured before a calibration can be completed. Any measurement can be repeated until the SENS:CORR:COLL:GUID:SAVE command is executed.

Query the user prompt description using SENS:CORR:COLL:GUID:DESC?

Query the required calibration steps using SENS:CORR:COLL:GUID:STEP?

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<std>

Choose from:STAN1, STAN2, STAN3, through STAN40

Examples

SENS:CORR:COLL:GUID:ACQ STAN1
sense2:correction:collect:guided:acquire stan1

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:CKIT:
PORT<pnum>:CATalog?

(Read-only) Returns a comma-separated list of valid kits for each port. In addition to mechanical calibration kits, this will include applicable characterizations found within ECal modules currently connected to the PNA. Use items in the list to select the kit to be used with the SENS:CORR:COLL:GUID:CKIT:PORT command.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Any existing port number. If unspecified, value is set to 1
Examples | SENS:CORR:COLL:GUID:CKIT:PORT1:CAT? 'When "Type N (50) male" is specified for connector type, returns: "85054D, 85032F"
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:CKIT:
PORT<pnum>[:SELect] <kit>

(Read-Write) Specifies the calibration kit for each port to be used during a guided calibration. An unused port does NOT need to have a specified Cal Kit.

Note: Sliding loads are not fully supported from Sens:Corr:Coll:Guided... The Measure button must be manually pressed.

1. Specify the connector type for the port with SENS:CORR:COLL:GUID:CONN:PORT.

2. Query the valid available kits for the connector on each port with SENS:CORR:COLL:GUID:CKIT:PORT:CAT?

3. Specify the kit using this command.

4. Perform a query of this command. If the <kit> parameter was incorrectly entered, an error will be returned.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pnum>

Any existing port number. If unspecified, value is set to 1

<kit>

Calibration kit to be used for the specified port.

Examples

SENS:CORR:COLL:GUID:CKIT:PORT1 '85055A'

sense2:correction:collect:ckit:port2:select '85092-60010 User 1 ECal'

Query Syntax

SENSe:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>[:SELect]?

Return Type

String - If the <kit> parameter was incorrectly entered while writing, an error will be returned.

Overlapped?

No

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:CONNector:CATalog?

(Read only) Returns a list of valid connectors based on the connector descriptions of the available cal kits. Use an item from the returned list to specify a connector for SENS:CORR:COLL:GUID:CONN:PORT
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:COLL:GUID:CONN:CAT? Returns: Type N (50) female, Type N (50) male, APC 7 (50), 3.5 mm (50) male, 3.5 mm (50) female, User Connector A
Return Type | Comma separated string values
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:CONNector:
PORT<pnum>[:SELect] <conn>

(Read-Write) Specifies a connector type for every port during the Guided Calibration procedure. Valid connector names are stored within calibration kits. Some cal kits may include both male and female connectors. Therefore, specifying connector gender may be required.

Unused ports must be defined as or Not used. If all ports are defined as "Not used", a guided calibration cannot be performed.

  • A single port with a valid <conn> name indicates a 1-Port calibration will be performed.

  • Two ports with valid <conn> names indicate either a 2-Port or TRL calibration will be performed depending on the standards definition found within the cal kit and the capability of the analyzer. (The analyzer must have 4 receivers for TRL calibrations.).

  • Three ports with valid <conn> names indicate a 3-Port calibration will be performed.

  • Four ports with valid <conn> names indicate a 4-Port calibration will be performed.

Note:
1. Use SENS:CORR:COLL:GUID:CONN:CAT? to query available connectors before specifying the port connector.
2. Select a connector type using this command.
3. Perform a query of this command. If the <conn> parameter was incorrectly entered, an error will be returned.
4. Specify the cal kit to use for each port with SENS:CORR:COLL:GUID:CKIT:PORT

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pnum>

Any existing port number. If unspecified, value is set to 1

<conn>

DUT connector type to connect with analyzer port <pnum>

Some kits may include both male and female connectors so specifying gender may be required.

Valid connector names are stored within calibration kits. Query available connectors using SENSe:CORRection:COLLect:GUIDed:CONNector:CATalog?

Examples

SENS:CORR:COLL:GUID:CONN:PORT1 'Type N (50) female'

'Indicates the DUT port that connects with the analyzer's Port1 is a TypeN 50 ohm Female connector.

Query Syntax

SENSe<cnum>:CORRection:COLLect:GUIDed:CONNector:PORT<pnum>[:SELect]?

Return Type

String

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:DESCription? <step>

(Read-only) Returns the connection description for the specified calibration step.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<step> | A number from 1 to the number of steps required to complete the calibration (Use SENS:CORR:COLL:GUID:STEP? to query the number of steps )
Examples | SENS:CORR:COLL:GUID:DESC? 10 'Returns: Connect APC 7 Open to port3
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:INITiate [GUID [,bool]]

(Write-only) Initiates a guided calibration. Either create a new cal set or optionally add to / overwrite a specified cal set.

The PNA determines the measurements needed to perform the calibration using the settings specified from the SENS:CORR:COLL:GUID:CONN:PORT and SENS:CORR:COLL:GUID:CKIT:PORT commands.

After this command is executed, subsequent commands can be used to query the number of measurement steps, issue the acquisition commands, query the connection description strings, and subsequently complete a guided calibration.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<GUID>

Optional argument. If not specified a new calset is created.

Calset GUID in the form: "{GUID}"; including quotes and curly brackets.

The guided cal that is being initiated either supplements the existing cal set, or overwrites the cal set depending on the method, connectors, and ports selected. Learn more about Cal Sets.

Must be a valid GUID; an error is reported if the GUID is not found.

Query all Cal Set GUIDs with SENS:CORR:CSET:CAT?

<bool>

Optional argument.

False (0) If cal set stimulus settings differ from the existing channel, do not change channel stimulus settings. Return an error. This is the default setting if not specified.

True (1) If cal set stimulus settings differ from the existing channel, change the channel stimulus settings to match the cal set settings..

Examples

SENS:CORR:COLL:GUID:INIT "{2B893E7A-971A-11d5-8D6C-00108334AE96}",1
sense2:correction:collect:guided:initiate

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:METHod <char>

(Read-Write) Specifies the method for performing the THRU portion of a guided calibration.

See Note regarding changes to this command.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

DEFAULT - allow the PNA to choose the best possible method (from the following) depending on whether the device or ECal module is insertable or non-insertable and given the model number of the PNA. (default selection if omitted.)

ADAP - Perform Adapter removal calibration

FLUSH - Perform Flush Thru calibration.

UNKN - Perform Unknown Thru calibration.

DEFined - Perform Defined Thru calibration. If performing an ECal, this is the Thru standard in the ECal module.

TRL - Select TRL Cal Type for 2-Port guided cals. Valid for "TRL ready" Cal Kits with properly assigned TRL cal classes.

SOLT - Select SOLT Cal Type for 2-Port guided cals. Valid for any kit with properly assigned SOLT cal classes.

Examples

SENS:CORR:COLL:GUID:METH ADAP
sense2:correction:collect:guided:method unkn

Query Syntax

SENSe<cnum>:CORRection:COLLect:GUIDed:METHod

Return Type

Character

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:SAVE

(Write-only) Completes the guided cal by computing the error correction terms, turning Correction ON, and saving the calibration to a Cal Set.

If all of the required standards have not been measured, the calibration will not complete properly.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Examples

SENS:CORR:COLL:GUID:SAVE
sense2:correction:collect:guided:save

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:STEPs?

(Read-only) Returns the number of measurement steps required to complete the current guided calibration. This command is sent after the SENS:CORR:COLL:GUID:INIT, SENS:CORR:COLL:GUID:CONN:PORT and SENS:CORR:COLL:GUID:CKIT:PORT commands.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:COLL:GUID:STEP? sense2:correction:collect:guided:steps?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:THRU:PORTs <t1a, t1b, t2a, t2b, t3a, t3b>

(Read-Write) Specifies the port pairs for the thru connections of the calibration.

Note: Only for PNA release 5.0 and greater.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<t1a,...>

Specify Port numbers in pairs:

  • For 3-port cals, specify two pairs.

  • For 4-port cals, specify three pairs.

t1a, t1b (Thru1 - port A and port B)

t2a, t2b (Thru2 - port A and port B)

t3a, t3b (Thru3 - port A and port B)

Examples

SENS:CORR:COLL:GUID:THRU:PORT 1,2,1,3,1,4 '4-port measurement
sense2:correction:collect:guided:thru:ports 1,2,2,3 '3-port measurement

Query Syntax

SENSe<cnum>:CORRection:COLLect:GUIDed:THRU:PORTs?

Return Type

Numeric

Overlapped?

No

Default

Port pairings that were used in the previous cal.


Couple SCPI

Sense:Couple Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SENSe<cnum>:COUPle <ALL | NONE>

(Read-Write) Sets the sweep mode as Chopped or Alternate. Learn about Alternate Sweep
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<ALL | NONE> | ALL - Sweep mode set to Chopped - reflection and transmission measured on the same sweep. NONE - Sweep mode set to Alternate - reflection and transmission measured on separate sweeps. Improves Mixer bounce and Isolation measurements. Increases sweep time
Examples | SENS:COUP ALL sense2:couple none
Query Syntax | SENSe<cnum>:COUPle?
Return Type | Character
Overlapped? | No
Default | ALL

SENSe<cnum>:COUPle:PARameter[:STATe] <bool>

(Read-Write) Turns ON and OFF Time Domain Trace Coupling. All of the measurements in the specified channel are coupled.

  • To select Transform parameters to couple, use CALC:TRAN:COUP:PAR

  • To select Gating parameters to couple, use CALC:FILT:COUP:PAR

Learn more about Time Domain Trace Coupling.

Parameters

<cnum>

Any existing channel number; if unspecified, value is set to 1.

<bool>

ON (or 1) - Turns ON Time Domain Trace Coupling.

OFF (or 0) - Turns OFF Time Domain Trace Coupling.

Examples

SENS:COUP:PAR 0
sense2:couple:parameter:state on

Query Syntax

SENSe<cnum>:COUPle:PARameter[:STATe]?

Return Type

Boolean

Overlapped?

No

Default

ON (or 1)


Frequency SCPI

Sense:Frequency Commands

Sets the frequency sweep functions of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands.

  • Learn about Frequency Sweep

SENSe<cnum>:FREQuency:CENTer <num>

(Read-Write) Sets the center frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Center frequency. Choose any number between the minimum and maximum frequency limits of the anal yzer. Units are Hz

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:CENT 1000000
sense2:frequency:center 1mhz

Query Syntax

SENSe<cnum>:FREQuency:CENTer?

Return Type

Numeric

Overlapped?

No

Default

Center of the analyzer's frequency span

SENSe<cnum>:FREQuency[:CW |:FIXed] <num>

(Read-Write) Sets the Continuous Wave (or Fixed) frequency. Must also send SENS:SWEEP:TYPE CW to put the analyzer into CW sweep mode.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

CW frequency. Choose any number between the minimum and maximum frequency limits of the anal yzer. Units are Hz.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ 1000000
SENS:FREQ:CW MIN
sense2:frequency:fixed 1mhz

Query Syntax

SENSe<cnum>:FREQuency[:CW | :FIXed]?

Return Type

Numeric

Overlapped?

No

Default

1 GHz

SENSe<cnum>:FREQuency:SPAN <num>

(Read-Write) Sets the frequency span of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Frequency span. Choose any number between:
0 (minimum) and the maximum frequency span of the anal yzer.
Units are Hz

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:SPAN 1000000
sense2:frequency:span max

Query Syntax

SENSe<cnum>:FREQuency:SPAN?

Return Type

Numeric

Overlapped?

No

Default

Maximum frequency span of the analyzer

SENSe<cnum>:FREQuency:STARt <num>

(Read-Write) Sets the start frequency of the analyzer.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start frequency. Choose any number between the MIN and MAX frequency limits of the anal yzer. Units are Hz If FREQ:START is set greater than FREQ:STOP, then STOP is set equal to START. Note: This command will accept MIN or M AX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:FREQ:STAR 1000000 sense2:frequency:start MIN
Query Syntax | SENSe<cnum>:FREQuency:STARt? If Sweep type is segment, this query returns the start frequency of the first segment.
Return Type | Numeric
Overlapped? | No
Default | Minimum frequency of the analyzer

SENSe<cnum>:FREQuency:STOP <num>

(Read-Write) Sets the stop frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Stop frequency. Choose any number between:
the minimum and maximum frequency limits of the anal yzer. Units are Hz

If FREQ:STOP is set less than FREQ:START, then START will be set equal to STOP.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:STOP 1000000
sense2:frequency:stop max

Query Syntax

SENSe<cnum>:FREQuency:STOP?

If Sweep type is segment, this query returns the stop frequency of the last segment.

Return Type

Numeric

Overlapped?

No

Default

Maximum frequency of the analyzer


SenseIF

Sense:IF Commands

Controls the IF source and gain settings for use with the PNA H11 Option.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about the IF Access (H11 option)

SENSe<cnum>:IF:FILTer:SAMPle:COUNt <num>

(Read-Write) Sets and returns the number of taps in the IF filter. The IF filter sample count setting is only used when SENSe:IF:FILTer:SAMPle:COUNt:MODE is set to MANUAL. Critical Note:
Parameters |
<cnum> | Existing channel number to manipulate. If unspecified, <cnum> is set to 1.
<num> | An integer value. (MIN and MAX return the minimum and maximum allowed values, respectively.)
Examples | SENS:IF:FILT:SAMP:COUN 40 sense2:if:filter:sample:count maximum
Query Syntax | SENS:IF:FILTer:SAMPle:COUNt?
Return Type | Numeric
Overlapped? | No
Default | Instrument dependent.

SENSe<cnum>:IF:FILTer:SAMPle:COUNt:MODE <char>

(Read-Write) Sets and returns the IF filter sample count mode to the specified value. When in MANUAL mode, the value specified for the IF Filter sample count is used as the number of taps in the IF filter. Critical Note:
Parameters |
<cnum> | Existing channel number to manipulate. If unspecified, <cnum> is set to 1.
<char> | Choose either AUTO or MANUAL.
Examples | SENS:IF:FILT:SAMP:COUN:MODE MANUAL sense2:if:filter:sample:count:mode AUTO
Query Syntax | SENS:IF:FILTer:SAMPle:COUNt:MODE?
Return Type | Character
Overlapped? | No
Default | AUTO

SENSe<cnum>:IF:FILTer:SAMPle:PERiod <num>

(Read-Write) Sets and returns the IF filter sample period. The IF filter sample period setting is only used by the instrument when the SENS:IF:FILT:SAMP:PER:MODE is set to MANUAL. Critical Note:
Parameters |
<cnum> | Existing channel number to manipulate. If unspecified, <cnum> is set to 1.
<num> | Sample period. Choose from values returned from the SENS:IF:FILTer:SAMPle:PERiod:CAT? command.
Examples | SENS:IF:FILT:SAMP:PER 6 us sense2:if:filter:sample:period maximum
Query Syntax | SENS:IF:FILTer:SAMPle:PERiod?
Return Type | Numeric
Overlapped? | No
Default | Instrument dependent.

SENSe<cnum>:IF:FILTer:SAMPle:PERiod:CATalog?

(Read-Only) Returns the list of allowed IF filter sample periods for this instrument. Critical Note:
Parameters |
<cnum> | Existing channel number to manipulate. If unspecified, <cnum> is set to 1.
Examples | SENS:IF:FILT:SAMP:PER:CAT? sense2:if:filter:sample:period:catalog?
Query Syntax | SENS:IF:FILTer:SAMPle:PERiod:CATalog?
Return Type | String
Overlapped? | No
Default | AUTO

SENSe<cnum>:IF:FILTer:SAMPle:PERiod:MODE <char>

(Read-Write) Sets and returns the IF filter sample period mode to the specified value. Critical Note:
Parameters |
<cnum> | Existing channel number to manipulate. If unspecified, <cnum> is set to 1.
<char> | Sample period mode. Choose from AUTO or MANUAL.
Examples | SENS:IF:FILT:SAMP:PER:MODE MANUAL sense2:if:filter:sample:period:mode AUTO
Query Syntax | SENS:IF:FILTer:SAMPle:PERiod:MODE?
Return Type | Character
Overlapped? | No
Default | AUTO

SENSe<cnum>:IF:GAIN:ALL[:STATe] <char>

(Write only) Sets the gain state for ALL receivers to Auto or Manual.
Parameters |
<cnum> | Existing channel number to manipulate. If unspecified, <cnum> is set to 1.
<char> | Choose from AUTO or MANUAL
Examples | SENS:IF:GAIN:ALL AUTO sense:if:gain:all:state manual
Query Syntax | Not Applicable
Return Type | Character
Overlapped? | No
Default | AUTO

SENSe<cnum>:IF:GAIN:LEVel <id>, <level>

(Read Write) Manually sets the gain level for the specified receiver.
Parameters |
<cnum> | Existing channel number to manipulate. If unspecified, <cnum> is set to 1.
<id> | Choose from: 'A', 'B', 'R1', 'R2'. Note: The A and R1 receivers are always switched together. B and R2 are also always switched together. For example, if you specify 'A', R1 will also be switched.
<level> | Gain level. Choose from: 0 - Lowest gain setting 1 2 - Highest gain setting
Examples | SENS:IF:GAIN:LEVel 'A', 1
Query Syntax | SENSe<cnum>:IF:GAIN:LEVel? <id>
Return Type | Numeric
Overlapped? | No
Default | 0

SENSe<cnum>:IF:GAIN[:STATe]?, <id>

(Read only) Returns the gain state for the specified receiver. Use SENS:IF:GAIN:ALL. to set the gain state for all channels.
Parameters |
<cnum> | Existing channel number to manipulate. If unspecified, <cnum> is set to 1.
<id> | Choose from: 'A', 'B', 'R1', 'R2'. Note: The A and R1 receivers are always switched together. B and R2 are also always switched together. For example, if you specify 'A', R1 will also be switched.
Examples | SENS:IF:GAIN? 'A'
Return Type | Boolean
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:IF:GATE:STATe <boolean>

(Read-Write) Sets or returns the IF filter gate state.
Parameters |
<cnum> | Existing channel number to manipulate. If unspecified, <cnum> is set to 1.
<boolean> | Choose from ON or OFF
Examples | SENS:IF:FILT:GATE:STAT ON sense2:if:filter:gate:state 0
Query Syntax | SENS:IF:FILTer:SAMPle:COUNt:MODE?
Return Type | Boolean
Overlapped? | No
Default | AUTO

SENSe<cnum>:IF:SOURce:PATH <id>, <char>

(Read Write) Sets the source path for the specified receiver. An error is returned if <id> is not valid, or if <char> is not valid for the specified <id>.

Parameters

<cnum>

Existing channel number to manipulate. If unspecified, <cnum> is set to 1.

<id>

Choose from: 'A', 'B', 'R1', 'R2'

Note: The A and R1 receivers are always switched together. B and R2 are also always switched together. For example, if you specify "A", R1 will also be switched.

<char>

Choose from:

  • NORMal - the PNA decides the appropriate IF input paths.

  • EXTernal - always use the rear panel IF inputs.

Examples

SENS:IF:SOUR:PATH 'A', Ext

Query Syntax

SENSe<cnum>:IF:SOURce:PATH? <id>

Return Type

Character

Overlapped?

No

Default

Normal


MIXer SCPI

Sense:Mixer Commands

Performs Mixer setup and configuration.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about the Frequency Converter Application

SENSe<ch>:MIXer:APPLy

(Write only) Applies the mixer setup settings and turns the channel ON. (Performs the same function as the Apply button on the mixer setup dialog box).
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:MIX:APPL
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:AVOidspurs <bool>

(Read Write) Sets and returns the state of the avoid spurs feature. Learn more about avoid spurs.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<bool> | Avoid spurs state. Choose from 0 - Avoid spurs OFF 1 - Avoid spurs ON
Examples | SENS:MIX:AVO sense2:mixer:avoidspurs 1
Query Syntax | SENSe<ch>:MIXer:AVOidspurs?
Return Type | Boolean
Overlapped? | No
Default | 0 (OFF)

SENSe<ch>:MIXer:CALCulate <char>

(Write only) Calculates the Input, IF, or Output frequencies of the mixer setup and updates the channel settings.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<char>

Mixer port to be calculated. Choose from:

<char>

1st or only stage requires:

In addition, 2nd stage requires:

INPUT

  • Output Start and Stop frequencies

  • LO frequency

  • Output sideband (High or Low)

  • IF Start and Stop frequencies

  • 2nd LO frequency

  • IF sideband (High or Low)

Both

NA

  • IF Start and Stop frequencies

  • Both LO frequencies

OUTPUT

  • Input Start and Stop frequencies

  • LO frequency

  • Output sideband (High or Low)

  • IF Start and Stop frequencies

  • 2nd LO frequency

  • IF sideband (High or Low)

LO_1

  • Input Start and Stop frequencies

  • Output frequency

  • Output sideband (High or Low)

  • IF Start and Stop frequencies

  • 2nd LO frequency

  • IF sideband (High or Low)

LO_2

NA

  • Input Start and stop frequencies
  • 1st LO start and stop frequencies
  • Output frequency
  • IF sideband(High or Low
  • Output sideband(High or Low)

Examples

SENS:MIX:CALC Output

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SENSe<ch>:MIXer:LOAD <name>

(Write-only) Loads a previously-configured mixer attributes file (.mxr)
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<name> | Path and file name (including .mxr extension) to load.
Examples | SENSe:MIXer:LOAD "C:\Program Files\Agilent\Network Analyzer\Documents\Mixer\MyMixer.mxr"
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:SAVE <name>

(Write-only) Saves the settings for the mixer/converter test setup to a mixer attributes file.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<name> | Path and file name (including .mxr extension) to save.
Examples | SENSe:MIXer:SAVE "C:\Program Files\Agilent\Network Analyzer\Documents\Mixer\MyMixer.mxr"
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:STAGe <n>

(Read-Write) Number of IF stages of the mixer.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | Number of stages. Choose either 1 or 2
Examples | SENSe:MIX:STAG 2 SENSe:MIXer:STAGE 1
Query Syntax | SENSe<ch>:MIXer:STAGe?
Return Type | Numeric
Overlapped? | No
Default | 1

SENSe<ch>:MIXer:IF:FREQuency:DENominator <num>

(Read-Write) Sets or returns the denominator value of the IF Fractional Multiplier.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<num> | Denominator value.
Examples | SENSe:MIX:IF:FREQ:DEN 5 SENSe2:MIXer:IF:FREQ:DENominator 4
Query Syntax | SENSe<ch>:MIXer:IF:FREQuency:DENominator?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:IF:FREQuency:FIXed <num>

(Read-Write) Sets or returns the fixed frequency of the IF..
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<num> | Frequency.
Examples | SENSe:MIXer:IF:FREQ:FIXed 1e9 SENSe2:MIXer:IF:FREQ:FIXed 1000000000
Query Syntax | SENSe<ch>:MIXer:IF:FREQuency:FIXed?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:IF:FREQuency:NUMerator <num>

(Read-Write) Sets or returns the numerator value of the IF Fractional Multiplier.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<num> | Numerator value of the IF fractional multiplier
Examples | SENSe:MIX:IF:FREQ:NUM 4 SENSe2:MIXer:IF2:FREQ:NUMerator 3
Query Syntax | SENSe<ch>:MIXer:IF:FREQuency:NUMerator?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:IF:FREQuency:SIDeband <char>

(Read-Write) Sets or returns the value of the IF sideband.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<char> | Sideband value. Choose from LOW - Low or Difference (-) HIGH - High or Sum (+)
Examples | SENS:MIX:IF:FREQ:SIDE LOW SENSe2:MIXer:IF:FREQ:SIDEband HIGH
Query Syntax | SENSe<ch>:MIXer:IF:FREQuency:SIDeband?
Return Type | Character
Overlapped? | No
Default | LOW

SENSe<ch>:MIXer:IF:FREQuency:STARt <num>

(Read-Write) Sets or returns the IF start frequency value of the mixer.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<num> | IF Start Frequency value
Examples | SENS:MIX:IF:FREQ:STAR 1e9 SENSe2:MIXer:IF:FREQ:STARt 1000000000
Query Syntax | SENSe<ch>:MIXer:IF:FREQuency:STARt?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:IF:FREQuency:STOP <num>

(Read-Write) Sets or returns the stop frequency value of the mixer IF frequency.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<num> | IF Stop Frequency value
Examples | SENS:MIX:IF:FREQ:STOP 2e9 SENSe2:MIXer:IF:FREQ:STOP 2000000000
Query Syntax | SENSe<ch>:MIXer:IF:FREQuency:STOP?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:INPut:FREQuency:DENominator <value>

(Read-Write) Sets or returns the denominator value of the Input Fractional Multiplier.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input denominator value.
Examples | SENS:MIX:INP:FREQ:DEN 5 SENS2:MIXer:INPut:FREQ:DENominator 4
Query Syntax | SENSe<ch>:MIXer:INPut:FREQuency:DENominator?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:INPut:FREQuency:FIXed<value>

(Read-Write) Sets or returns the fixed frequency of the input.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input frequency.
Examples | SENSe:MIXer:INPut:FREQ:FIXed 1e9 SENSe2:MIXer:INPut:FREQ:FIXed 1000000000
Query Syntax | SENSe<ch>:MIXer:INPut:FREQuency:FIXed?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:INPut:FREQuency:NUMerator <value>

(Read-Write) Sets or returns the numerator value of the Input Fractional Multiplier.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input numerator value.
Examples | SENS:MIX:INP:FREQ:NUM 3 SENSe2:MIXer:INPut:FREQ:NUMerator 1
Query Syntax | SENSe<ch>:MIXer:INPut:FREQ:NUMerator?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:INPut:FREQuency:STARt <value>

(Read-Write) Sets or returns the Input start frequency value of the mixer.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input Start frequency
Examples | SENS:MIX:INP:FREQ:STAR 1e9 SENSe2:MIXer:INPut:FREQ:STARt 1000000000
Query Syntax | SENSe<ch>:MIXer:INPut:FREQuency:STARt?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:INPut:FREQuency:STOP <value>

(Read-Write) Sets or returns the Input stop frequency value of the mixer.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input stop frequency
Examples | SENS:MIX:INP:FREQ:STOP 2e9 SENSe2:MIXer:INPut:FREQ:STOP 2000000000
Query Syntax | SENSe<ch>:MIXer:INPut:FREQuency:STOP?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:INPut:POWer <value>

(Read-Write) Sets or returns the value of the Input Power.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input power in dBm.
Examples | SENS:MIX:INP:POW 9 SENSe2:MIXer:INPut:POWer 5
Query Syntax | SENSe<ch>:MIXer:INPut:POWer?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:FREQuency:DENominator <value>

(Read-Write) Sets or returns the denominator value of the LO Fractional Multiplier.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2.
<value> | LO denominator.
Examples | SENS:MIX:LO:FREQ:DEN 5 SENSe2:MIXer:LO2:FREQ:DENominator 4
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:DENominator?
Return Type | Numeric
Overlapped? | No
Default | 1

SENSe<ch>:MIXer:LO<n>:FREQuency:FIXed <value>

(Read-Write) Sets or returns the fixed frequency of the specified mixer LO.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<value> | LO frequency.
Examples | SENS:MIX:LO:FREQ:FIX 1e9 SENSe2:MIXer:LO2:FREQ:FIXed 1000000000
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:FIXed?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:FREQuency:ILTI <bool>

(Read-Write) Specifies whether to use the Input frequency that is greater than the LO or less than the LO. To learn more, see the mixer setup dialog box help.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<bool> | True (1) - Use the Input that is Greater than the specified LO. False (0) - Use the Input that is Less than the specified LO.
Examples | SENS:MIX:LO1:FREQ:ILTI 1 sense2:mixer:lo2:frequency:ilti true
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:ILTI?
Return Type | Boolean
Overlapped? | No
Default | False

SENSe<ch>:MIXer:LO<n>:FREQuency:MODE <char>

(Read-Write) Sets or returns the LO sweep mode.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<char> | LO sweep mode. Choose either FIXED or SWEPT
Examples | SENS:MIX:LO:FREQ:MODE FIXED SENSe2:MIXer:LO2:FREQ:MODE swept
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:MODE?
Return Type | Character
Overlapped? | No
Default | Fixed

SENSe<ch>:MIXer:LO<n>:FREQuency:NUMerator <value>

(Read-Write) Sets or returns the numerator value of the LO Fractional Multiplier.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<value> | LO Numerator.
Examples | SENS:MIX:LO:FREQ:NUM 5 SENSe2:MIXer:LO2:FREQ:NUMerator 4
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:NUMerator?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:FREQuency:STARt <value>

(Read-Write) Sets or returns the LO start frequency value. This command can only be used with SMC (not VMC) measurements.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<value> | LO Start Frequency in Hertz.
Examples | SENS:MIX:LO:FREQ:STAR 5E9
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:STARt?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:FREQuency:STOP <value>

(Read-Write) Sets or returns the LO stop frequency value. This command can only be used with SMC (not VMC) measurements.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<value> | LO Stop Frequency in Hertz.
Examples | SENS:MIX:LO:FREQ:STOP 5E9
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:STOP?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:NAME <value>

(Read-Write) Sets or returns the name of the external LO source.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2.
<value> | External LO source name
Examples | SENS:MIX:LO:NAME "MySource"
Query Syntax | SENSe<ch>:MIXer:LO<n>:NAME?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:POWer <value>

(Read-Write) Sets or returns the value of the LO Power.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage. Choose 1 or 2
<value> | LO Power in dBm
Examples | SENS:MIX:LO:POW 9
Query Syntax | SENSe<ch>:MIXer:LO<n>:POWer?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:OUTPut:FREQuency:FIXed <value>

(Read-Write) Sets or returns the output fixed frequency of the mixer. This command can only be used with SMC (not VMC) measurements.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Output fixed frequency in Hertz.
Examples | SENS:MIX:OUTP:FREQ:FIX 5e9
Query Syntax | SENSe<ch>:MIXer:OUTPut:FREQuency:FIXed?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:OUTPut:FREQuency:SIDeband <value>

(Read-Write) Sets or returns the value of the output sideband.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Boolean Sideband value. Choose from LOW - Low or Difference (-) HIGH - High or Sum (+)
Examples | SENS:MIX:OUTP:FREQ:SIDe LOW SENSe2:MIXer:OUTPut:FREQ:SIDeband HIGH
Query Syntax | SENSe<ch>:MIXer:OUTPut:FREQuency:SIDeband?
Return Type | Character
Overlapped? | No
Default | LOW

SENSe<ch>:MIXer:OUTPut:FREQuency:STARt <value>

(Read-Write) Sets or returns the Output start frequency of the mixer.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Output start frequency
Examples | SENS:MIX:OUTP:FREQ:STAR 1e9 SENSe2:MIXer:OUTPut:FREQ:STARt 1000000000
Query Syntax | SENSe<ch>:MIXer:OUTPut:FREQuency:STARt?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<ch>:MIXer:OUTPut:FREQuency:STOP <value>

(Read-Write) Sets or returns the Output stop frequency of the mixer.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Output stop frequency
Examples | SENS:MIX:OUTP:FREQ:STOP 1e9 SENSe2:MIXer:OUTPut:FREQ:STOP 1000000000
Query Syntax | SENSe<ch>:MIXer:OUTPut:FREQuency:STOP?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable


Offset SCPI

Sense:Offset Commands

Sets the offset frequency functions, causing the stimulus and response frequencies to be different.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Frequency Offset

SENSe<cnum>:OFFSet:CW <bool>

(Read-Write) Turns stimulus CW Override mode ON or OFF. Use this setting to establish a fixed (CW) stimulus frequency while measuring the Response over a swept frequency range. Learn more about Frequency Offset.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | ON (or 1) - turns CW override ON. OFF (or 0) - turns CW overide OFF.
Examples | SENS:OFFS:CW ON sense2:offset:cw off
Query Syntax | SENSe<cnum>:OFFSet:CW?
Return Type | Boolean
Overlapped? | No
Default | OFF

SENSe<cnum>:OFFSet:DIVisor <num>

(Read-Write) Specifies (along with the multiplier) the value to multiply by the stimulus. Learn more about Frequency Offset.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Divisor value. Range is 1 to 1000
Examples | SENS:OFFS:DIV 3 sense2:offset:divisor 2
Query Syntax | SENSe<cnum>:OFFSet:DIVisor?
Return Type | Numeric
Overlapped? | No
Default | 1

SENSe<cnum>:OFFSet:MULTiplier <num>

(Read-Write) Specifies (along with the divisor) the value to multiply by the stimulus. Learn more about Frequency Offset.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Multiplier value. Range is +/- 1000. Negative multipliers cause the stimulus to sweep in decreasing direction. For mixer measurements, this would be for setups requiring the RF frequency to be less than LO frequency
Examples | SENS:OFFS:MULT 2 sense2:offset:multiplier 4
Query Syntax | SENSe<cnum>:OFFSet:MULTplier?
Return Type | Numeric
Overlapped? | No
Default | 1

SENSe<cnum>:OFFSet:OFFSet <num>

(Read-Write) Specifies an absolute offset frequency in Hz. For mixer measurements, this would be the LO frequency. Learn more about Frequency Offset.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Offset frequency. Range is +/- 1000 GHz. Offsets can be positive or negative
Examples | SENS:OFFS:OFFS 1GHz sense2:offset:offset 1e9
Query Syntax | SENSe<cnum>:OFFSet:OFFSet?
Return Type | Numeric
Overlapped? | No
Default | 0 Hz

SENSe<cnum>:OFFSet:STARt?

(Read-Only) Returns the response start frequency Learn more about Frequency Offset.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:OFFS:STAR? sense2:offset:start?
Return Type | Numeric
Overlapped? | No
Default | Not applicable

SENSe<cnum>:OFFSet:[STATe] <bool>

(Read-Write) Enables Frequency Offset Mode on ALL measurements that are present on the active channel. This immediately causes the source and receiver to tune to separate frequencies. The receiver frequencies are specified with the other SENS:OFFSet commands. To make the stimulus settings use the SENS:FREQ commands.

Tip: To avoid unnecessary errors, first make other offset frequency settings, then set Frequency Offset ON. Learn more about Frequency Offset.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<bool>

ON (or 1) - turns Frequency Offset ON.

OFF (or 0) - turns Frequency Offset OFF.

Examples

SENS:OFFS ON
sense2:offset:state off

Query Syntax

SENSe<cnum>:OFFSet:[STATe]?

Return Type

Boolean

Overlapped?

No

Default

OFF (0)

SENSe<cnum>:OFFSet:STOP?

(Read-Only) Returns the response stop frequency. Learn more about Frequency Offset.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:OFFS:STOP sense2:offset:stop
Return Type | Numeric
Overlapped? | No
Default | Not applicable


Power SCPI

Sense:Power Command

Learn a bout Receiver Attenuation

SENSe<cnum>:POWer:ATTenuation <recvr>,<num>

(Read-Write) Sets the attenuation level for the specified receiver. Note: Attenuation cannot be set with Sweep Type set to Power
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<recvr> | Receiver to get attenuation. Choose from: ARECeiver - receiver A BRECeiver - receiver B
<num> | Choose from: 0 to 35 dB - in 5 dB steps If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered for <num> the analyzer will switch in 15 dB attenuation.
Examples | SENS:POW:ATT AREC,10 sense2:power: attentuation breceiver,30
Query Syntax | SENSe<cnum>:POWer:ATTenuation? <rec>
Return Type | Numeric
Overlapped? | No
Default | 0


Roscillator SCPI

Sense:Roscillator Command

Learn about the Reference Osc.

SENSe:ROSCillator:SOURce?

(Read-only) Applying a signal to the Reference Oscillator connector automatically sets the Reference Oscillator to EXTernal. This command allows you to check that it worked. EXT is returned when a signal is present at the Reference Oscillator connector. INT is returned when NO signal is present at the Reference Oscillator connector.
Examples | SENS:ROSC:SOUR? sense:roscillator:source?
Return Type | Character
Overlapped? | No
Default | Not applicable


Segment SCPI

Sense:Segment Commands

Defines the segment sweep settings. Enable segment sweep with SENS:SWE:TYPE SEGMent.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn a bout Segment Sweep

SENSe<cnum>:SEGMent<snum>:ADD

(Write-only) Adds a segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to add. If unspecified, value is set to 1. Segment numbers must be sequential. If a new number is added where one currently exists, the existing segment and those following are incremented by one.
Examples | Two Segments exist (1 and 2). The following command will add a new segment (1). The existing (1 and 2) will become (2 and 3) respectively. SENS:SEGM1:ADD sense2:segment1:add
Query Syntax | Not applicable. Use Sense:Segment:Count to determine the number of segments in a trace.
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:ARBitrary <ON | OFF>

(Read-Write) Enables you to setup a segment sweep with arbitrary frequencies. The start and stop frequencies of each segment can overlap other segments. Also, each segment can have a start frequency that is greater than its stop frequency which causes a reverse sweep over that segment. Learn more about Arbitrary Segment Sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - Allows the setup of arbitrary segment sweep. OFF (or 0) - Prevents the setup of arbitrary segment sweep.
Examples | SENS:SEGM:ARB ON sense2:segment:arbitrary off
Query Syntax | SENSe<cnum>:SEGMent:ARBitrary?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution] <num>

(Read-Write) Sets the IF Bandwidth for the specified segment. First set SENS:SEGM:BWIDth:CONTrol ON. All subsequent segments that are added assume the new IF Bandwidth value.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

IF Bandwidth in Hz. The list of valid IF Bandwidths is different depending on the PNA model. (Click to see the lists.) If an invalid number is specified, the analyzer will round up to the closest valid number.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:BWID 1KHZ
sense2:segment2:bwidth:resolution max

Query Syntax

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution]?

Return Type

Numeric

Overlapped?

No

Default

See Preset IFBW for your PNA model.

SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol <ON | OFF>

(Read-Write) Specifies whether the IF Bandwidth resolution can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Bandwidth control ON. Bandwidth can be set for each segment OFF (or 0) - turns Bandwidth control OFF. Use channel bandwidth setting
Examples | SENS:SEGM:BWID:CONT ON sense2:segment:bwidth:control off
Query Syntax | SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent:COUNt?

(Read-only) Queries the number of segments that exist in the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:COUNt? sense2:segment:count?
Return Type | Numeric
Overlapped? | No
Default | 1 segment

SENSe<cnum>:SEGMent<snum>:DELete

(Write-only) Deletes the specified sweep segment.
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Number of the segment to delete. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL sense2:segment2:delete
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:DELete:ALL

(Write-only) Deletes all sweep segments.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL:ALL sense2:segment:delete:all
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer <num>

(Read-Write) Sets the Center Frequency for the specified segment. The Frequency Span of the segment remains the same. The Start and Stop Frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Center Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:CENT 1MHZ
sense2:segment2:frequency:center 1e9

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer?

Return Type

Numeric

Overlapped?

No

Default

Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN <num>

(Read-Write) Sets the Frequency Span for the specified segment. The center frequency of the segment remains the same. The start and stop frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Frequency Span in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:SPAN 1MHZ
sense2:segment2:frequency:span max

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN?

Return Type

Numeric

Overlapped?

No

Default

If first segment, frequency span of the analyzer. Otherwise 0.

SENSe<cnum>:SEGMent<snum>:FREQuency:START <num>

(Read-Write) Sets the Start Frequency for the specified sweep segment.

Notes

All other segment Start and Stop Frequency values that are larger than this frequency are changed to this frequency.

To return the start and stop frequency of the entire sweep (all segments), Use SENS:FREQ:STARt? and SENS:FREQ:STOP?

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Start Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:STAR 1MHZ
sense2:segment2:frequency:start minimum

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:STARt?

Return Type

Numeric

Overlapped?

No

Default

Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:STOP <num>

(Read-Write) Sets the Stop Frequency for the specified sweep segment.

Notes

All other segment Start and Stop Frequency values that are larger than this frequency are changed to this frequency.

To return the start and stop frequency of the entire sweep (all segments), Use SENS:FREQ:STARt? and SENS:FREQ:STOP?

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Stop Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:STOP 1MHZ
sense2:segment2:frequency:stop maximum

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:STOP?

Return Type

Numeric

Overlapped?

No

Default

If first segment, stop frequency of the analyzer. Otherwise, start frequency of the segment.

SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel] <num>

(Read-Write) Sets the Port Power level for the specified sweep segment. First set SENS:SEGM:POW:CONTrol ON. All subsequent segments that are added assume the new Power Level value.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<port> | Port number of the source. Choose from 1 or 2. If unspecified, value is set to 1.
<num> | Power level. Note: The range of settable power values depends on the PNA model and if source attenuators are installed. To determine the range of values, send SOUR:POW? MAX and SOUR:POW? MIN. (SOUR:POW:ATT:AUTO must be set to ON). Actual achievable leveled power depends on frequency.
Examples | SENS:SEGM:POW 0 sense2:segment2:power1:level -10
Query Syntax | SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel]?
Return Type | Numeric
Overlapped? | No
Default | 0

SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol <ON | OFF>

(Read-Write) Specifies whether Power Level can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Power Level control ON. Power level can be set for each segment. OFF (or 0) - turns Power Level control OFF. Use the channel power level setting.
Examples | SENS:SEGM:POW:CONT ON sense2:segment:power:level:control off
Query Syntax | SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>[:STATe] <ON | OFF>

(Read-Write) Turns the specified sweep segment ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to be turned ON or OFF
<ON | OFF> | ON (or 1) - turns segment ON. OFF (or 0) - turns segment OFF.
Examples | SENS:SEGM ON sense2:segment2:state off
Query Syntax | SENSe<cnum>:SEGMent[:STATe]? <snum>
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>:SWEep:POINts <num>

(Read-Write) Sets the number of data points for the specified sweep segment.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Any existing segment number. If unspecified, value is set to 1

<num>

Number of points in the segment. The total number of points in all segments cannot exceed 16001. A segment can have as few as 1 point.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:SWE:POIN 51
sense2:segment2:sweep:points maximum

Query Syntax

SENSe<cnum>:SEGMent<snum>:S WEep:POINts?

Return Type

Numeric

Overlapped?

No

Default

201

SENSe<cnum>:SEGMent<snum>:SWEep:TIME <num>

(Read-Write) Sets the time the analyzer takes to sweep the specified sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<num> | Sweep time in seconds. Choose a number between 0 and 100 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:SWE:TIME 1ms sense2:segment2:sweep:time .001
Query Syntax | SENSe<cnum>:SEGMent<snum>:S WEep:TIME?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol <ON | OFF>

(Read-Write) Specifies whether Sweep Time can be set independently for each sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Sweep Time control ON. Sweep Time can be set for each segment. OFF (or 0) - turns Sweep Time control OFF. Uses the channel Sweep Time setting.
Examples | SENS:SEGM:SWE:TIM:CONT ON sense2:segment:sweep:time:control off
Query Syntax | SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>:X:SPACing <char>

(Read-Write) Sets X-axis spacing ON or OFF
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number. (This parameter is ignored)
<char> | LINear - turns X-axis point spacing OFF OBASe - turns X-axis point spacing ON
Examples | SENS:SEGM:X:SPACing LIN sense2:segment1:spacing obase
Query Syntax | SENSe<cnum>:SEGMent<snum>:X:SPACing?
Return Type | Character
Overlapped? | No
Default | LINear


Sweep SCPI

Sense:Sweep Commands

Specifies the sweep functions of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn a bout Sweeping

SENSe<cnum>:SWEep:DWELl <num>

(Read-Write) Sets the dwell time between each sweep point.

  • Dwell time is ONLY available with SENSe:SWEep:GENeration set to STEPped; It is Not available in ANALOG.

  • Sending dwell = 0 is the same as setting SENS:SWE:DWEL:AUTO ON. Sending a dwell time > 0 sets SENS:SWE:DWEL:AUTO OFF.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Dwell time in seconds.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SWE:DWEL .1
sense2:sweep:dwell min

Query Syntax

SENSe<cnum>:SWEep:DWELl?

Return Type

Numeric

Overlapped?

No

Default

0 - (Note: dwell time set to 0 is the same as dwell:auto ON)

SENSe<cnum>:SWEep:DWELl:AUTO <ON | OFF>

(Read-Write) Specifies whether or not to automatically calculate and set the minimum possible dwell time. Setting Auto ON has the same effect as setting dwell time to 0.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns dwell ON. OFF (or 0) - turns dwell OFF.
Examples | SENS:SWE:DWEL:AUTO ON sense2:sweep:dwell:auto off
Query Syntax | SENSe<cnum>:S WEep:DWELl:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:SWEep:GENeration <char>

(Read-Write) Sets sweep as Stepped or Analog.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

STEPped - source frequency is CONSTANT during measurement of eah displayed point. More accurate than ANALog. Dwell time can be set in this mode.

ANALog - source frequency is continuously RAMPING during measurement of each displayed point. Faster than STEPped. Sweep time (not dwell time) can be set in this mode.

Examples

SENS:SWE:GEN STEP
sense2:sweep:generation analog

Query Syntax

SENSe<cnum>:S WEep:GENeration?

Return Type

Character

Overlapped?

No

Default

Analog

SENSe<cnum>:SWEep:GROups:COUNt <num>

(Read-Write) Sets the trigger count (groups) for the specified channel. Set trigger mode to group after setting this count.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Count (groups) number. Choose any number between: 1 and 2e6 (1 is the same as single trigger)
Examples | SENS:SWE:GRO:COUN 10 sense2:sweep:groups:count 50
Query Syntax | SENSe<cnum>:SWEep:GROups:COUNt?
Return Type | Numeric
Overlapped? | No
Default | 1

SENSe<cnum>:SWEep:MODE <char>

(Read-Write) Sets the trigger mode for the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Trigger mode. Choose from: HOLD - channel will not trigger CONTinuous - channel triggers indefinitely GROups - channel accepts the number of triggers specified with the last SENS:SWE:GRO:COUN <num>
Examples | SENS:SWE:MODE CONT sense2:sweep:mode hold
Query Syntax | SENSe<cnum>:SWEep:MODE?
Return Type | Character
Overlapped? | YES - SENS:SWE:MODE GROUPS (when INIT:CONT is ON) NO - HOLD and CONTinuous
Default | CONTinuous

SENSe<cnum>:SWEep:POINts <num>

(Read-Write) Sets the number of data points for the measurement.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Choose any number between 1 and 16001 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SWE:POIN 51 sense2:sweep:points max
Query Syntax | SENSe<cnum>:S WEep:POINts?
Return Type | Numeric
Overlapped? | No
Default | 201

SENSe<cnum>:SWEep:SRCPort <1 | 2>

(Read-Write) Sets the source port when making non S-parameter measurements. Has no effect on S-parameter measurements.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<1 | 2> | 1 - Source power comes out Port 1 2 - Source power comes out Port 2
Examples | SENS:SWE:SRCP 1 sense2:sweep:srcport 2
Query Syntax | SENSe<cnum>:S WEep:SRCPort?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:SWEep:TIME <num>

(Read-Write) Sets the Sweep time of the analyzer. If sweep time accuracy is critical, use ONLY the values that are attained using the up and down arrows next to the sweep time entry box. See Sweep Time.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Sweep time in seconds. To select the fastest sweep speed, either send MIN as an argument to this command, or send SENS:SWE:TIME:AUTO 1

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SWE:TIME 1ms
sense2:sweep:time .001

Query Syntax

SENSe<cnum>:S WEep:TIME?

Return Type

Numeric

Overlapped?

No

Default

NA

SENSe<cnum>:SWEep:TIME:AUTO <ON | OFF>

(Read-Write) Turns the automatic sweep time function ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the automatic sweep time ON. OFF (or 0) - turns the automatic sweep time OFF.
Examples | SENS:SWE:TIME:AUTO 1 sense2:sweep:time:auto off
Query Syntax | SENSe<cnum>:S WEep:TIME:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:SWEep:TRIGger:DELay <num>

(Read-Write) Sets and reads the trigger delay for all measurements in the specified CHANNEL. This delay is only applied while TRIG:SOURce EXTernal and TRIG:SCOP CURRent . After an external trigger is applied, the start of the sweep is delayed for the specified delay value plus any inherent latency. To apply a trigger delay for all channels (Global), use TRIG:DEL.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Trigger delay value in seconds. Range is from 0 to 107 seconds
Examples | SENS:SWE:TRIG:DELay .003 sense2:sweep:trigger:delay 1
Query Syntax | SENSe<cnum>:SWEep:TRIGger:DELay?
Return Type | Numeric
Overlapped? | No
Default | 0

SENSe<cnum>:SWEep:TRIGger:POINt <ON | OFF>

(Read-Write) Specifies whether the specified channel will measure one point for each trigger or all of the measurements in the channel. Setting any channel to POINt mode will automatically set the TRIGger:SCOPe = CURRent.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - Channel measures one data point per trigger. OFF (or 0) - All measurements in the channel made per trigger.
Examples | SENS:SWE:TRIG:POIN ON sense2:sweep:trigger:point off
Query Syntax | SENSe<cnum>:SWEep:TRIGger:POINt?
Return Type | Boolean (1 = Point, 0 = Measurement)
Overlapped? | No
Default | 0 - Measurement

SENSe<cnum>:SWEep:TYPE <char>

(Read-Write) Sets the type of analyzer sweep mode.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: LINear | LOGarithmic | POWer | CW | SEGMent Note: SWEep TYPE cannot be set to SEGMent if there are no segments turned ON. A segment is automatically turned ON when the analyzer is started.
Examples | SENS:SWE:TYPE LIN sense2:sweep:type segment
Query Syntax | SENSe<cnum>:S WEep:TYPE?
Return Type | Character
Overlapped? | No
Default | LINear


X-Axis

X Values Command

SENSe<cnum>:X[:VALues]?

(Read-only) Returns the stimulus values for the specified channel. If the channel is sweeping the source backwards, the values will be in descending order.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
Examples | SENS:X? sense2:x:values?
Return Type | Depends on FORM:DATA command
Overlapped? | No
Default | Not applicable


Source SCPI

Source Commands

Controls the power delivered to the DUT.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Power Settings

SOURce<cnum>:POWer<port>:ATTenuation <num>

(Read-Write) Sets the attenuation level for the selected channel. Sending this command turns automatic attenuation control (SOUR:POW:ATT:AUTO) to OFF. If the ports are coupled, changing the attenuation on one port will also change the attenuation on the other port. To turn port coupling OFF use SOURce:POWer:COUPle OFF.

Note: Attenuation cannot be set with Sweep Type set to Power

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.

<num>

Attenuation value. The range of settable values depends on the PNA model. To determine the range of values, perform a query using MAX, then MIN, as an argument. Example: SOURce:POWer:ATT? Max

Enter a value between MAX and MIN in 10 dB steps.

If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered for <num> the analyzer will switch in 10 dB attenuation.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SOUR:POW:ATT 10
source2:power:attentuation maximum

Query Syntax

SOURce<cnum>:POWer<port>:ATTenuation?

Return Type

Numeric

Overlapped?

No

Default

0

SOURce<cnum>:POWer<port>:ATTenuation:AUTO <ON | OFF>

(Read-Write) Turns automatic attenuation control ON or OFF. Setting an attenuation value (using SOURce:POWer:ATTenuation <num>) sets AUTO OFF.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<port>

Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.

<ON | OFF>

ON (or 1) - turns coupling ON. The analyzer automatically selects the appropriate attenuation level to meet the specified power level.

OFF (or 0) - turns coupling OFF. Attenuation level must be set using SOURce:POWer:ATTenuation <num>.

Examples

SOUR:POW2:ATT:Auto On
source2:power:
attentuation:auto off

Query Syntax

SOURce<cnum>:POWer:ATTenuation:Auto?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

ON

SOURce<cnum>:POWer:CENTer <num>

(Read-Write) Sets the power sweep center power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:SPAN <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Center power. Actual achievable leveled power depends on frequency.
Examples | SOUR:POW:CENT -15 source2:power:center -7
Query Syntax | SOURce<cnum>:POWer:CENTer?
Return Type | Numeric
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer:COUPle <ON | OFF>

(Read-Write) Turns Port Power Coupling ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns coupling ON. Power level can be set individually for each source port. OFF (or 0) - turns coupling OFF. The same power level is used for both source ports.
Examples | SOUR:POW:COUP ON source2:power:couple off
Query Syntax | SOURce<cnum>:POWer:COUPle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SOURce<cnum>:POWer:DETector <char>

(Read-Write) Sets the source leveling loop as Internal or External.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | INTernal - Internal leveling is applied to the source EXTernal - External leveling is applied to the source through a rear-panel connector. ONLY provided on 3 GHz, 6 GHz, and 9 GHz PNA models.
Examples | SOUR:POW:DET INT source2:power:detector external
Query Syntax | SOURce<cnum>:POWer:DETector?
Return Type | Character
Overlapped? | No
Default | INTernal

SOURce<cnum>:POWer<port>[:LEVel][:IMMediate]
[:AMPLitude] <num>

(Read-Write) Sets the RF power output level.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.
<num> | Source power in dBm. Note: The range of settable power values depends on the PNA model and if source attenuators are installed. To determine the range of values, perform a query using MAX, then MIN, as an argument. (SOUR:POW:ATT:AUTO must be set to ON) Example: SOURce:POWer? Max Actual achievable leveled power depends on frequency.
Examples | SOUR:POW1 5DB source2:power:level :immediate:amplitude maximum
Query Syntax | SOURce<cnum>:POWer[:LEVel][:IMMediate][:AMPLitude]?
Return Type | Numeric
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer[:LEVel]:SLOPe <num>

(Read-Write) Sets the RF power slope value.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Slope value in db/GHz. Choose any integer between -2 and 2 (0 is no slope).
Examples | SOUR:POW:SLOP 2 source2:power:slope -2
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe?
Return Type | Numeric
Overlapped? | No
Default | 0

SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe <ON | OFF>

(Read-Write) Turns Power Slope ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON|OFF> | ON (or 1) - turns slope ON. OFF (or 0) - turns slope OFF.
Examples | SOUR:POW:SLOP:STAT ON source2:power:slope:state off
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SOURce<cnum>:POWer:SPAN <num>

(Read-Write) Sets the power sweep span power. Must also set:

SENS:SWE:TYPE POWer and SOURce:POWer:CENTer <num> .

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Span power. Actual achievable leveled power depends on frequency.

Examples

SOUR:POW:SPAN -15
source2:power:span -7

Query Syntax

SOURce<cnum>:POWer:SPAN?

Return Type

Numeric

Overlapped?

No

Default

0 dBm

SOURce<cnum>:POWer:STARt <num>

(Read-Write) Sets the power sweep start power. Must also set SENS:SWE:TYPE POWer and SOURce:POWer:STOP <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start power. Note: The range of settable power values depends on the PNA model and if source attenuators are installed. To determine the range of values, perform a query using MAX, then MIN, as an argument. (SOUR:POW:ATT:AUTO must be set to ON) Example: SOURce:POWer:STARt? MIN Actual achievable leveled power depends on frequency.
Examples | SOUR:POW:STAR -15 source2:power:start -7
Query Syntax | SOURce<cnum>:POWer:STARt?
Return Type | Numeric
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer:STOP <num>

(Read-Write) Sets the power sweep stop power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:START <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Stop power. Note: The range of settable power values depends on the PNA model and if source attenuators are installed. To determine the range of values, perform a query using MAX, then MIN, as an argument. (SOUR:POW:ATT:AUTO must be set to ON) Example: SOURce:POWer:STOP? MAX Actual achievable leveled power depends on frequency.
Examples | SOUR:POW:STOP -15 source2:power:stop -7
Query Syntax | SOURce<cnum>:POWer:STOP?
Return Type | Numeric
Overlapped? | No
Default | 0 dBm


SourceCorrection SCPI

Source:Power:Correction Commands

Controls the source power correction features of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example program using these commands.

  • See a template for creating your own Power Meter Driver

  • Learn about Source Cal

Note: The SOURce:POWer:CORRection:COLLect:ACQuire command, used to step the PNA and read a power meter, cannot be sent over the GPIB unless the power meter is connected to a different GPIB interface. See the alternative methods described in the command details.

SOURce<cnum>:POWer<port>:CORRection:COLLect:ABORt

(Write-only) Aborts a source power calibration sweep that is in progress.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
Examples | SOUR:POW:CORR:COLL:ABOR source1:power2:correction:collect:abort
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SOURce<cnum>:POWer<port>:CORRection:COLLect[:ACQuire] <char>

(Write-only) Initiates a source power cal acquisition sweep using the power sensor attached to the specified channel (A or B) on the power meter.

Note: This command, used to step the PNA and read a power meter, cannot be sent over the GPIB unless the power meter is connected to a different GPIB interface. Use one of the following methods to perform this command or its equivalent:

  • Connect the power meter to the PNA using a USB / GPIB interface (Agilent 82357A).

  • SCPI programming of the PNA using a LAN Client interface (see example)

  • Send SCPI commands through the COM interface using the SCPI String Parser object.

  • Directly control the Power Meter and PNA to step frequency; then acquire and store the Power reading. (see example)

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<char>

Choose from:

ASENsor - Sensor on power meter channel A

BSENsor - Sensor on power meter channel B

Examples

SOUR:POW:CORR:COLL ASEN
source1:power2:correction:collect:acquire bsensor

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SOURce<cnum>:POWer<port>:CORRection:COLLect:AVERage[:COUNt] <num>

(Read-Write) Specifies the maximum number of power readings that are taken at each stimulus point to allow for power meter settling. Each reading is averaged with the previous readings at that stimulus point. When this average meets the Average:NTOLerance value or this number of readings has been made, the average is returned as the valid reading.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
<num> | Maximum number of readings to make to allow for settling. Choose any number between 3 and 25.
Examples | SOUR:POW:CORR:COLL:AVER 2 source1:power2:correction:collect:average:count 3
Query Syntax | SOURce:POWer:CORRection:COLLect:AVERage[:COUNt]?
Return Type | Numeric
Overlapped? | No
Default | 3

SOURce<cnum>:POWer<port>:CORRection:COLLect:AVERage:NTOLerance <num>

(Read-Write) Each power reading is averaged with the previous readings at each stimulus point. When the average meets this nominal tolerance value or the max number of readings has been made, the average is returned as the valid reading.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
<num> | Power meter settling tolerance value in dB. Choose any number between 0 and 5.
Examples | SOUR:POW:CORR:COLL:AVER:NTOL .05 source1:power2:correction:collect:average:ntolerance .003
Query Syntax | SOURce:POWer:CORRection:COLLect:AVERage:NTOLerance?
Return Type | Numeric
Overlapped? | No
Default | .050 dBm

SOURce<cnum>:POWer:CORRection:COLLect:DISPlay[:STATe] <ON | OFF>

(Read-Write) Enables and disables the display of power readings on the PNA screen. Send this command BEFORE you begin a source power cal acquisition. After the source power cal data is acquired, this setting is reset to ON.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON|OFF> | ON (1) Source power calibration dialog box is shown on the PNA screen. Power meter readings are plotted against the Tolerance value as limit lines. OFF (0) - Source power calibration dialog box is NOT shown on the PNA screen.
Examples | SOUR:POW:CORR:COLL:DISP ON source1:power2:correction:collect:display:state off
Query Syntax | SOURce:POWer:CORRection:COLLect:DISPlay[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

SOURce<cnum>:POWer:CORRection:COLLect:FCHeck[:STATe] <ON | OFF>

(Read-Write) Enables and disables frequency checking of source power cal acquisition sweeps. ONLY use when you have more than one power sensor.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<ON|OFF>

ON (1) turns source power cal frequency checking ON. A requested acquisition will only succeed for those frequency points which fall within a frequency range specified for the power sensor being used. An acquisition will pause in mid-sweep if the frequency is about to exceed the maximum frequency limit specified for that sensor. When the sweep is paused in this manner, a sensor connected to the other channel input of the power meter can be connected to the measurement port in place of the previous sensor, and used to complete the sweep. However, the maximum frequency specified for the second sensor would need to be sufficient for the sweep to complete. Frequency limits are specified using the SOUR:POW:CORR:COLL:SEN command.

OFF (0) - turns source power cal frequency checking OFF. An acquisition will use just one power sensor for the entire sweep, regardless of frequency.

Examples

SOUR:POW:CORR:COLL:FCH ON
source1:power2:correction:collect:fcheck:state off

Query Syntax

SOURce:POWer:CORRection:COLLect:FCHeck[:STATe]?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF (0)

SOURce<cnum>:POWer<port>:CORRection:COLLect:ITERation[:COUNt] <num>

(Read-Write) Sets the maximum number of readings to take at each data point for iterating the source power. Power readings will continue to be made, and source power adjusted, until a reading is within the iteration tolerance value or this max number of readings has been met. The last value to be read is the valid reading for that data point.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
<num> | Maximum number of readings. Choose any number between 1 and 100.
Examples | SOUR:POW:CORR:COLL:ITER 2 source1:power2:correction:collect:iteration 3
Query Syntax | SOURce:POWer:CORRection:COLLect:ITERation[:COUNt]?
Return Type | Numeric
Overlapped? | No
Default | 1

SOURce<cnum>:POWer<port>:CORRection:COLLect:ITERation:NTOLerance <num>

(Read-Write) Sets the maximum desired deviation from the sum of the test port power and the offset value. Power readings will continue to be made, and source power adjusted, until a reading is within this tolerance value or the max number of readings has been met. The last value to be read is the valid reading for that data point.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
<num> | Tolerance value in dBm. Choose any number between 0 and 5
Examples | SOUR:POW:CORR:COLL:ITER:NTOL .005 source1:power2:correction:collect:iteration:ntolerance .1
Query Syntax | SOURce:POWer:CORRection:COLLect:ITERation:NTOLerance?
Return Type | Numeric
Overlapped? | No
Default | .05

SOURce<cnum>:POWer<port>:CORRection:COLLect:METHod <char>

(Read-Write) Selects the calibration method to be used for the source power cal acquisition.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<char>

Choose from:

NONE - No Cal method

PMETer - Power Meter is used for all readings. (same as "fast iteration" box not checked on dialog box)

PMReceiver - Power meter for the first iteration; then use the reference receiver for remaining readings if necessary (same as "fast iteration" box checked on dialog box)

Examples

SOUR:POW:CORR:COLL:METH PMET
source1:power2:correction:collect:method pmreceiver

Query Syntax

SOURce:POWer:CORRection:COLLect:METHod?

Return Type

Character

Overlapped?

No

Default

NONE

SOURce<cnum>:POWer<port>:CORRection:COLLect:SAVE

(Write-only) Applies the array of correction values after a source power calibration sweep has completed. The source power correction will then be active on the specified source port for channel <cnum>. This command does NOT save the correction values. To save correction values, save an instrument / calibration state (*.cst file) after performing a source power cal.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
Examples | SOUR:POW:CORR:COLL:SAVE source1:power2:correction:collect:save
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SOURce<cnum>:POWer:CORRection:COLLect:<pmChan>SENsor[:FRANge] <num1>,<num2>

(Read-Write) Specifies the frequency range over which the power sensors connected to the specified channels (A and B) of the power meter can be used (minimum frequency, maximum frequency). If the power meter has only a single channel, that channel is considered channel A.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pmChan> | Power Meter channel. Choose from: A - Channel A B - Channel B
<num1> | Minimum frequency for the sensor. If a frequency unit is not specified, Hz is assumed. No limits are placed on this value.
<num2> | Maximum frequency for the sensor. If a frequency unit is not specified, Hz is assumed. No limits are placed on this value.
Examples | SOUR:POW:CORR:COLL:ASEN 100E3, 3E9 source1:power2:correction:collect:bsensor:frange 10 MHz, 18 GHz
Query Syntax | SOURce:POWer:CORRection:COLLect:ASENsor[:FRANge]? SOURce:POWer:CORRection:COLLect:BSENsor[:FRANge]?
Return Type | Numeric
Overlapped? | No
Default | 0,0

SOURce<cnum>:POWer:CORRection:COLLect:<pmChan>SENsor:RCFactor <num>

(Read-Write) ) Specifies the reference cal factor for the power sensor connected to channel A or B of the power meter. If the power meter has only a single channel, that channel is considered channel A.

Note: If the sensor connected to the specified channel of the power meter contains cal factors in EPROM (such as the Agilent E-series power sensors), those will be the cal factors used during the calibration sweep. The reference cal factor value associated with this command, and any cal factors entered into the PNA for that sensor channel, will not be used.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pmChan>

Power Meter channel. Choose from:

A - Channel A

B - Channel B

<num>

Reference cal factor in percent. Choose any number between 1 and 150.

Examples

SOUR:POW:CORR:COLL:ASEN:RCF 98.7
source1:power2:correction:collect:bsensor:rcfactor 105

Query Syntax

SOURce:POWer:CORRection:COLLect:ASENsor:RCFactor?

SOURce:POWer:CORRection:COLLect:BSENsor:RCFactor?

Return Type

Numeric

Overlapped?

No

Default

100

SOURce<cnum>:POWer:CORRection:COLLect:<pmChan>SENsor:SELect

(Read-Write) Sets and returns the power sensor channel (A or B) to be used. This performs the same function as the Use this sensor only checkbox in the Power Sensor Settings dialog.

Note: This write portion of this command is only necessary when performing an SMC calibration.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pmChan>

Power Meter channel. Choose from:

A - Channel A

B - Channel B

Examples

SOUR:POW:CORR:COLL:<pmChan>SEN:SEL 'Write

source1:power2:correction:collect:bsensor:select? 1e9 'Read

Query Syntax

SOURce:POWer:CORRection:COLLect:ASENsor:SELect? <Frequency>

SOURce:POWer:CORRection:COLLect:BSENsor:SELect? <Frequency>

Returns a boolean 1 or 0 (true or false) indicating whether the sensor is to be used at the specified frequency.

If frequency checking is OFF, then the <Frequency> parameter is ignored. The query returns if the sensor is selected for ALL frequencies.

Return Type

Numeric

Overlapped?

No

Default

Not Applicable

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:DATA <data>

(Read-Write) Read or write data into the selected table. If the selected table is a power sensor table, the data is interpreted as cal factors in units of percent. If the loss table is selected, the data is interpreted as loss in units of dB.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<data> | Data to write into the selected table.
Examples | SOURce:POWer:CORRection:COLLect:TABLe:DATA 0.12, 0.34, 0.56
Query Syntax | SOURce<cnum>:POWer:CORRection:COLLect:TABLe:DATA? If the selected table is currently empty, no data is returned.
Return Type | Numeric - one number per table segment
Overlapped? | No
Default | Not Applicable

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:FREQuency <data>

(Read-Write) Read or write frequency values for the selected table (cal factor table for a power sensor, or the loss compensation table).
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<data> | Frequency data to write into the selected table.
Examples | SOURce:POWer:CORRection:COLLect:TABLe:FREQuency 10E6, 1.5E9, 9E9
Query Syntax | SOURce<cnum>:POWer:CORRection:COLLect:TABLe:FREQuency? If the selected table is currently empty, no data is returned.
Return Type | Numeric - one number per table segment
Overlapped? | No
Default | Not Applicable

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:LOSS[:STATe] <ON | OFF>

(Read-Write) Indicates whether or not to adjust the power readings using the values in the loss table during a source power cal sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON|OFF> | ON (or 1) - turns use of the loss table ON. OFF (or 0) - turns use of the loss table OFF.
Examples | SOUR:POW:CORR:COLL:TABL:LOSS ON source1:power2:correction:collect:table:loss:state off
Query Syntax | SOURce:POWer:CORRection:COLLect:TABLe:LOSS[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF (0)

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:POINts?

(Read-only) Returns the number of segments that are currently in the selected table.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SOUR:POW:CORR:COLL:TABL:POIN? source1:power2:correction:collect:table:points?
Return Type | Numeric
Overlapped? | No
Default | 0

SOURce<cnum>:POWer:CORRection:COLLect:TABLe[:SELect] <char>

(Read-Write) Selects which table (cal factor table for a power sensor, or the loss compensation table) you want to write to or read from. Read or write using SOURce:POWer:CORRection:COLLect:TABLe:FREQuency and SOURce:POWer:CORRection:COLLect:TABLe:DATA
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: NONE - No table selected ASENsor - Cal Factor table for Power Sensor A BSENsor - Cal Factor table for Power Sensor B LOSS - Loss compensation table
Examples | SOUR:POW:CORR:COLL:TABL ASEN source1:power2:correction:collect:table:select bsensor
Query Syntax | SOURce:POWer:CORRection:COLLect:TABLe[:SELect]?
Return Type | Character
Overlapped? | No
Default | NONE

SOURce<cnum>:POWer<port>:CORRection:DATA <data>

(Read-Write) Writes and reads source power calibration data.

When querying source power calibration data, if no source power cal data exists for the specified channel and source port, no data is returned.

If a change in the instrument state causes interpolation and/or extrapolation of the source power cal, the correction data associated with this command correspond to the new instrument state (interpolated and/or extrapolated data).

If the channel is sweeping the source backwards, then the first data point is the highest frequency value; the last data point is the lowest. Use the SENS:X:VALues? command to return the X-axis values in the displayed order.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<data>

Correction Data

Examples

SOURce1:POWer2:CORRection:DATA 0.12, -0.34, 0.56

Query Syntax

SOURce<cnum>:POWer<port>:CORRection:DATA?

Return Type

Depends on FORMat:DATA command

Overlapped?

No

Default

Not Applicable

SOURce<cnum>:POWer<port>:CORRection:LEVel <num>

(Read-Write) Specifies the power level that is expected at the desired reference plane (DUT input or output). This is not used for segment sweep with independent power levels or power sweeps.

Note: Although this command still works, it is recommended that you specify cal power by setting the test port power and offset value.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<num>

Cal power level in dBm. Because this could potentially be at the output of a device-under-test, no limits are placed on this value here. It is realistically limited by the specifications of the device (power sensor) that will be used for measuring the power. The power delivered to the PNA receiver must never exceed PNA specifications for the receiver!

Examples

SOUR:POW:CORR:LEV 10
source1:power2:correction:level 0 dbm

Query Syntax

SOURce:POWer:CORRection:LEVel?

Return Type

Numeric

Overlapped?

No

Default

0 dBm

SOURce<cnum>:POWer<port>:CORRection:OFFSet[:MAGNitude] <num>

(Read-Write) Sets or returns a power level offset from the PNA test port power. This can be a gain or loss value (in dB) to account for components you connect between the source and the reference plane of your measurement. For example, specify 10 dB to account for a 10 dB amplifier at the input of your DUT.

Cal power is the sum of the test port power setting and this offset value. Following the calibration, the PNA power readouts are adjusted to the cal power.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<num>

Gain or loss value in dB. Choose a value between -200 and 200

Examples

SOUR:POW:CORR:OFFS 10
source1:power2:correction:offset:magnitude -3

Query Syntax

SOURce:POWer:CORRection:OFFSet[:MAGNitude]?

Return Type

Numeric

Overlapped?

No

Default

0 dB

SOURce<cnum>:POWer<port>:CORRection[:STATe] <ON|OFF>

(Read-Write) Enables and disables source power correction for the specified port on the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
<ON|OFF> | ON (or 1) turns source power correction ON. OFF (or 0) - turns source power correction OFF.
Examples | SOUR:POW:CORR ON source1:power2:correction:state off
Query Syntax | SOURce:POWer:CORRection[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF (0)


Status SCPI

Status Register Commands

The status registers enable you to query the state of selected events that occur in the analyzer.

Note: This documentation requires familiarity with the "Standard Status Data Structure - Register Model" as defined in IEEE Std 488.2-1992.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Status Registers

Note: Any bit not shown in the registers is not used but may be reserved for future use.

Status Byte Register

Summarizes the states of the other registers and monitors the analyzer's output queue. It also generates service requests. The Enable register is called the Service Request Enable Register.

Commands

Description

*CLS

Clears ALL "event" registers and the SCPI Error / Event queue. The corresponding ENABLE registers are unaffected.

*STB?

Reads the value of the analyzer's status byte. The byte remains after being read.

*SRE?

Reads the current state of the Service Request Enable Register.

*SRE <num>

Sets bits in the Service Request Enable register. The current setting of the SRE register is stored in non-volatile memory. Use *SRE 0 to clear the enable.

<num> Combined value of the weights for bits to be set.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
2 | 4 | Error / Event queue Summary (EAV) | the Error / Event queue is not empty. To read the the error message, use SYST:ERR?
3 | 8 | Questionable Register Summary | any enabled bit in the questionable event status register is set to 1
4 | 16 | Message Available | the output queue is not empty
5 | 32 | Standard Event Register Summary | any enabled bit in the standard event status register is set to 1
6 | 64 | Request Service | any of the other bits in the status byte register is set to 1 (used to alert the controller of a service request within the analyzer). This bit cannot be disabled.
7 | 128 | Operation Register Summary | any enabled bit in the standard operation event status register is set to 1

STATus:QUEStionable:<keyword>

Summarizes conditions that monitor the quality of measurement data.

< keyword >

Example

:CONDition?

STAT:QUES:COND?

:ENABle <bits>

STAT:QUES:ENAB 1024

[:EVENt]?

STAT:QUES?

:NTRansition <bits>

STAT:QUES:NTR 1024

:PTRansition <bits>

STAT:QUES:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
9 | 512 | Integrity Reg summary | any enabled bit in the Integrity event register is set to 1
10 | 1024 | Limit Registers summary | any enabled bit in the Limit event registers is set to 1
11 | 2048 | Define Registers summary | any enabled bit in the Define event registers is set to 1

STATus:QUEStionable:INTegrity <keyword>

Summarizes conditions in the Measurement Integrity register.

<keyword>

Example

:CONDition?

STAT:QUES:INT:COND?

:ENABle <bits>

STAT:QUES:INT:ENAB 1024

[:EVENt]?

STAT:QUES:INT?

:NTRansition <bits>

STAT:QUES:INT:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Measurement Summary | any bit in the Measurement Integrity event register is set to 1
2 | 2 | Hardware Summary | any bit in the Hardware event register is set to 1

STATus:QUEStionable:INTegrity:HARDware<keyword>

Monitors the status of hardware failures.

<keyword>

Example

:CONDition?

STAT:QUES:INT:HARD:COND?

:ENABle <bits>

STAT:QUES:INT:HARD:ENAB 1024

[:EVENt]?

STAT:QUES:INT:HARD?

:NTRansition <bits>

STAT:QUES:INT:HARD:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:HARD:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Phase Unlock | the source has lost phaselock, possibly caused by a reference channel open or a hardware failure.
2 | 4 | Unleveled | the source power is unleveled. This could be caused by a source set for more power than it can deliver at the tuned frequency. Or it could be caused by a hardware failure.
3 | 8 | Not used | N/A
4 | 16 | EE Write Failed | an attempted write to the EEPROM has failed, possibly caused by a hardware failure.
5 | 32 | Not used | N/A
6 | 64 | Ramp Cal Failed | the analyzer was unable to calibrate the analog ramp generator due to a possible hardware failure.
7 | 128 | Not used | N/A

STATus:QUEStionable:INTegrity:MEASurement<n> <keyword>

Monitors the lag between changing a channel settings and when the data is ready to query out.

When you change the channel state (start/stop freq, bandwidth, and so on), then the questionable bit for that channel gets set. This indicates that your desired channel state does not yet match the data you would get if querying a data trace. When the next complete sweep has been taken (without aborting in the middle), and the data trace matches the channel state that produced it, the bit is cleared for that channel.

<n>

Measurement register number. Choose from 1 to 3

<keyword>

Example

:CONDition?

STAT:QUES:INT:MEAS1:COND?

:ENABle <bits>

STAT:QUES:INT:MEAS2:ENAB 1024

[:EVENt]?

STAT:QUES:INT:MEAS3?

:NTRansition <bits>

STAT:QUES:INT:MEAS2:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:MEAS1:PTR 0

 |  | Measurement Register <n> |  |  |
Bit | Weight | 1 | 2 | 3 | Bit is set to 1 when the following conditions exist:
0 | 1 | 1 | Summary from Meas Reg 3 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
1 | 2 | 2 | 15 | 29 | a setting change on this channel has occurred and the data does not yet reflect that change.
2 | 4 | 3 | 16 | 30 | a setting change on this channel has occurred and the data does not yet reflect that change.
3 | 8 | 4 | 17 | 31 | a setting change on this channel has occurred and the data does not yet reflect that change.
4 | 16 | 5 | 18 | 32 | a setting change on this channel has occurred and the data does not yet reflect that change.
5 | 32 | 6 | 19 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
6 | 64 | 7 | 20 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
7 | 128 | 8 | 21 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
8 | 256 | 9 | 22 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
9 | 512 | 10 | 23 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
10 | 1024 | 11 | 24 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
11 | 2048 | 12 | 25 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
12 | 4096 | 13 | 26 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
13 | 8192 | 14 | 27 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
14 | 16384 | Summary from Meas Reg 2 | 28 |  | a setting change on this channel has occurred and the data does not yet reflect that change.

STATus:QUEStionable:LIMit<n> <keyword>

Monitors and summarizes the status of limit line failures. When a trace fails, the representative bit is set to 1. Bit 0 is used to summarize failures in the registers that follow. For example, Limit 3 register, bit 0, summarizes the failures from registers 4 and 5.
All enable bits are set to 1 by default. To find the measurement number, use Calc:Par:Mnum

<n>

Limit register: Choose from 1 to 5.

<keyword>

Example

:CONDition?

STAT:QUES:LIM4:COND?

:ENABle <bits>

STAT:QUES:LIM1:ENAB 1024

[:EVENt]?

STAT:QUES:LIM3?

:NTRansition <bits>

STAT:QUES:LIM2:NTR 1024

:NTRansition?

STAT:QUES:LIM1:NTR?

:PTRansition <bits>

STAT:QUES:LIM5:PTR 0

:PTRansition?

STAT:QUES:LIM1:PTR?

 |  | Limit Register <n> |  |  |  |  |
Bit | Weight | 1 | 2 | 3 | 4 | 5 | Bit is set to 1 when the following conditions exist:
0 | 1 | 2, 3, 4, 5 | 3, 4, 5 | 4, 5 | 5 |  | Summary - Any point from these registers fails
 |  | Trace Numbers |  |  |  |  |
1 | 2 | 1 | 15 | 29 | 43 | 57 | any point on trace fails the limit test
2 | 4 | 2 | 16 | 30 | 44 | 58 | any point on trace fails the limit test
3 | 8 | 3 | 17 | 31 | 45 | 59 | any point on trace fails the limit test
4 | 16 | 4 | 18 | 32 | 46 | 60 | any point on trace fails the limit test
5 | 32 | 5 | 19 | 33 | 47 | 61 | any point on trace fails the limit test
6 | 64 | 6 | 20 | 34 | 48 | 62 | any point on trace fails the limit test
7 | 128 | 7 | 21 | 35 | 49 | 63 | any point on trace fails the limit test
8 | 256 | 8 | 22 | 36 | 50 | 64 | any point on trace fails the limit test
9 | 512 | 9 | 23 | 37 | 51 |  | any point on trace fails the limit test
10 | 1024 | 10 | 24 | 38 | 52 |  | any point on trace fails the limit test
11 | 2048 | 11 | 25 | 39 | 53 |  | any point on trace fails the limit test
12 | 4096 | 12 | 26 | 40 | 54 |  | any point on trace fails the limit test
13 | 8192 | 13 | 27 | 41 | 55 |  | any point on trace fails the limit test
14 | 16384 | 14 | 28 | 42 | 56 |  | any point on trace fails the limit test

STATus:QUEStionable:DEFine<keyword>

Summarizes conditions in the Questionable:Define:User<1|2|3> event registers.

<keyword>

Example

:CONDition?

STAT:QUES:DEF:COND?

:ENABle <bits>

STAT:QUES:DEF:ENAB 1024

[:EVENt]?

STAT:QUES:DEF?

:NTRansition <bits>

STAT:QUES:DEF:NTR 1024

:PTRansition <bits>

STAT:QUES:DEF:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | USER1 | any bit in the USER1 event register is set to 1
2 | 4 | USER2 | any bit in the USER2 event register is set to 1
3 | 8 | USER3 | any bit in the USER3 event register is set to 1

STATus:QUEStionable:DEFine:USER<1|2|3><keyword>

Monitors conditions that you define and map in any of the three QUES:DEF:USER event registers.

<keyword>

Example

:ENABle <bits>

STAT:QUES:DEF:USER1:ENABle 1024

[:EVENt]?

STAT:QUES:DEF:USER1?

:MAP <bit>,<error>

STAT:QUES:DEF:USER1:MAP 0,-113 'when error -113 occurs, bit 0 in USER1 will set to 1.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | for user | user defined
1 | 2 | for user | user defined
2 | 4 | for user | user defined
3 | 8 | for user | user defined
4 | 16 | for user | user defined
5 | 32 | for user | user defined
6 | 64 | for user | user defined
7 | 128 | for user | user defined
8 | 256 | for user | user defined
9 | 512 | for user | user defined
10 | 1024 | for user | user defined
11 | 2048 | for user | user defined
12 | 4096 | for user | user defined
13 | 8192 | for user | user defined
14 | 16384 | for user | user defined

Standard Event Status Register

Monitors "standard" events that occur in the analyzer. This register can only be cleared by:

  • a Clear Command (*CLS).

  • reading the Standard Enable Status Register (*ESE?).

  • a power-on transition. The analyzer clears the register and then records any transitions that occur, including setting the Power On bit (7).

Commands

Description

*ESE?

Reads the settings of the standard event ENABLE register.

*ESE <bits>

Sets bits in the standard event ENABLE register. The current setting is saved in non-volatile memory.

<bits> The sum of weighted bits in the register. Use *ESE 0 to clear the enable register.

*ESR?

Reads and clears the EVENT settings in the Standard Event Status register.

*OPC

Sets bit 0 when the overlapped command is complete. (see Understanding Command Synchronization / OPC).

*OPC?

Operation complete query - read the Operation Complete bit (0).

Bit

Weight

Description

Bit is set to 1 when the following conditions exist:

0

1

Operation Complete

the two following events occur in order:

  1. the *OPC command is sent to the analyzer

  2. the analyzer completes all pending overlapped commands

1

NA

Request Control

Not Supported - the analyzer application is not configured to control GPIB operation

2

4

Query Error

a query error is detected indicating:
- an attempt to read data from the output queue when no data was present OR
- data in the output queue was lost, as in an overflow

4

16

Execution Error

an execution error is detected indicating:
- a <PROGRAM DATA> element was outside the legal range or inconsistent with the operation of the analyzer OR
- the analyzer could not execute a valid command due to some internal condition

5

32

Command Error

a command error is detected indicating that the analyzer received a command that:

  • did not follow proper syntax

  • was misspelled

  • was an optional command it does not implement

7

128

Power ON

Power to the analyzer has been turned OFF and then ON since the last time this register was read.

STATus:OPERation<keyword>

Summarizes conditions in the Averaging and Operation:Define:User<1|2|3> event registers.

<keyword>

Example

:CONDition?

STAT:OPER:COND?

:ENABle <bits>

STAT:OPER:ENAB 1024

[:EVENt]?

STAT:OPER?

:NTRansition <bits>

STAT:OPER:NTR 1024

:PTRansition <bits>

STAT:OPER:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
8 | 256 | Averaging summary | either enabled bit in the Averaging summary event register is set to 1
9 | 512 | User Defined summary |
10 | 1024 | Device summary | either enabled bit in the Device summary event register is set to 1

STATus:OPERation:AVERaging<n> <keyword>

Monitors and summarizes the status of Averaging on traces 1 to 64. When averaging for a trace is complete, the representative bit is set to 1. Bit 0 is used to summarize the status in the registers that follow. For example, Average 3 register, bit 0, summarizes the status from registers 4 and 5. All enable bits are set to 1 by default. To find the measurement number, use Calc:Par:Mnum.

<n>

Averaging Register. Choose from 1 to 5

<keyword>

Example

:CONDition?

STAT:OPER:AVER1:COND?

:ENABle <bits>

STAT:OPER:AVER1:ENAB 1024

[:EVENt]?

STAT:OPER:AVER1?

:NTRansition <bits>

STAT:OPER:AVER1:NTR 1024

:PTRansition <bits>

STAT:OPER:AVER1:PTR 0

 |  | Averaging Register <n> |  |  |  |  |
Bit | Weight | 1 | 2 | 3 | 4 | 5 | Bit is set to 1 when the following conditions exist:
0 | 1 | 2, 3, 4, 5 | 3, 4, 5 | 4, 5 | 5 |  | any enabled bit in these registers is set to 1(Summary Bit)
 |  | Trace Numbers |  |  |  |  |
1 | 2 | 1 | 15 | 29 | 43 | 57 | Averaging on this trace is complete
2 | 4 | 2 | 16 | 30 | 44 | 58 | Averaging on this trace is complete
3 | 8 | 3 | 17 | 31 | 45 | 59 | Averaging on this trace is complete
4 | 16 | 4 | 18 | 32 | 46 | 60 | Averaging on this trace is complete
5 | 32 | 5 | 19 | 33 | 47 | 61 | Averaging on this trace is complete
6 | 64 | 6 | 20 | 34 | 48 | 62 | Averaging on this trace is complete
7 | 128 | 7 | 21 | 35 | 49 | 63 | Averaging on this trace is complete
8 | 256 | 8 | 22 | 36 | 50 | 64 | Averaging on this trace is complete
9 | 512 | 9 | 23 | 37 | 51 |  | Averaging on this trace is complete
10 | 1024 | 10 | 24 | 38 | 52 |  | Averaging on this trace is complete
11 | 2048 | 11 | 25 | 39 | 53 |  | Averaging on this trace is complete
12 | 4096 | 12 | 26 | 40 | 54 |  | Averaging on this trace is complete
13 | 8192 | 13 | 27 | 41 | 55 |  | Averaging on this trace is complete
14 | 16384 | 14 | 28 | 42 | 56 |  | Averaging on this trace is complete

STATus:OPERation:DEFine<keyword>

Summarizes conditions in the OPERation:Define:User<1|2|3> event registers.

<keyword>

Example

:CONDition?

STAT:OPER:DEF:COND?

:ENABle <bits>

STAT:OPER:DEF:ENAB 12

[:EVENt]?

STAT:OPER:DEF?

:NTRansition <bits>

STAT:OPER:DEF:NTR 12

:PTRansition <bits>

STAT:OPER:DEF:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | USER1 | any bit in the USER1 event register is set to 1
2 | 4 | USER2 | any bit in the USER2 event register is set to 1
3 | 8 | USER3 | any bit in the USER3 event register is set to 1

STATus:OPERation:DEFine:USER<1|2|3><keyword>

Monitors conditions that you define and map in any of the three OPER:DEF:USER event registers.

<keyword>

Example

:ENABle <bits>

STAT:OPER:DEF:USER1:ENAB 1024

[:EVENt]?

STAT:OPER:DEF:USER1?

:MAP <bit>,<error>

STAT:OPER:DEF:USER1:MAP 0,-113 'when error -113 occurs, bit 0 in USER1 will set to 1.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | for user | user defined
1 | 2 | for user | user defined
2 | 4 | for user | user defined
3 | 8 | for user | user defined
4 | 16 | for user | user defined
5 | 32 | for user | user defined
6 | 64 | for user | user defined
7 | 128 | for user | user defined
8 | 256 | for user | user defined
9 | 512 | for user | user defined
10 | 1024 | for user | user defined
11 | 2048 | for user | user defined
12 | 4096 | for user | user defined
13 | 8192 | for user | user defined
14 | 16384 | for user | user defined

STATus:OPERation:DEVice<keyword>

Summarizes conditions in the OPERation:DEVice event registers.

<keyword>

Example

:CONDition?

STAT:OPER:DEV:COND?

:ENABle <bits>

STAT:OPER:DEV:ENAB 16

[:EVENt]?

STAT:OPER:DEV?

:NTRansition <bits>

STAT:OPER:DEV:NTR 16

:PTRansition <bits>

STAT:OPER:DEV:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Unused |
1 | 2 | Unused |
2 | 4 | Unused |
3 | 8 | Unused |
4 | 16 | Sweep Completed | When sweep is complete
5 | 32 | Unused |
6 | 64 | Unused |
7 | 128 | Unused |
8 | 256 | Unused |
9 | 512 | Unused |
10 | 1024 | Unused |
11 | 2048 | Unused |
12 | 4096 | Unused |
13 | 8192 | Unused |
14 | 16384 | Unused |


System SCPI

System Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Preset

SYSTem:CHANnels:HOLD

(Write-only) Places all channels in hold mode. To place a single channel in hold mode, use SENS:SWE:MODE.
Examples | SYST:CHAN:HOLD
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SYSTem:CHANnels:RESume

(Write-only) Resumes the trigger mode of all channels that was in effect before sending SYSTem:CHANnels:HOLD (must be sent before SYST:CHAN:RESume).
Examples | SYST:CHAN:RES
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SYSTem:COMMunicate:GPIB:PMETer:ADDRess <num>

(Read-Write) Specifies the GPIB address of the power meter to be used in a source power calibration. When performing a source power cal, the PNA will search VISA interfaces that are configured in the Agilent IO LIbraries on the PNA.
Parameters |
<num> | GPIB address of the power meter. Choose any integer between 0 and 30.
Examples | SYST:COMM:GPIB:PMET:ADDR 13 system:communicate:gpib:pmeter:address 14
Query Syntax | SYSTem:COMMunicate:GPIB:PMETer:ADDRess?
Return Type | Numeric
Overlapped? | No
Default | 13

SYSTem:COMMunicate:GPIB:RDEVice:CLOSe <ID>

(Write only) Closes the remote GPIB session. This command should be sent when ending every successful OPEN session.
Parameters |
<ID> | Session identification number that was returned with the OPEN? command.
Examples | See an example program
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SYSTem:COMMunicate:GPIB:RDEVice:OPEN <bus>, <addr>, <timeout>

(Read-Write) Initiates a GPIB pass-through session. First send this OPEN command, then send the OPEN query to read the session ID number. An existing GPIB pass-through session remains open after an instrument preset. To learn more about GPIB pass-through capability, see the example program.
Parameters |
<bus> | Bus ID number. You can find the USB-GPIB adapter bus number by looking at the dialog that appears when the USB-GPIB device is connected.
<addr> | GPIB Address of the device to be controlled
<timeout> | The amount of time (in milliseconds) to wait for a response from the remote device after sending a command. A "timeout" error is displayed after this time has passed without a response.
Examples | See an example program
Query Syntax | SYSTem:COMMunicate:GPIB:RDEVice:OPEN? Returns the session identification number that is used when communicating with this device.
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

SYSTem:COMMunicate:GPIB:RDEVice:READ? <ID>

(Read-only) Returns data from the GPIB pass-through device.
Parameters |
<ID> | Session identification number that was returned with the OPEN? command.
Examples | See an example program
Return Type | String
Overlapped? | No
Default | Not Applicable

SYSTem:COMMunicate:GPIB:RDEVice:RESet

(Write-only) Performs the same function as SYST:COMM:GPIB:RDEV:CLOS except that ALL pass-through sessions are closed.
Examples | SYST:COMM:GPIB:RDEV:RES
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SYSTem:COMMunicate:GPIB:RDEVice:WBINary <ID>,<data>

(Write-only) Sends data to a GPIB pass-through device. This command requires a header that specifies the size of the data to be written. The header (described below) is not passed along to the device. Use this command if too many embedded quotes prevent you from using SYST:COMM:GPIB:RDEV:WRIT. Use SYST:COMM:GPIB:RDEV:OPEN to open the pass through session.
Parameters |
<ID> | Session identification number that was returned with the OPEN? command.
<data> | Data to be sent to the GPIB pass-through device. Use the following syntax: #<num digits><byte count><data bytes><NL><END> <num_digits> specifies how many digits are contained in <byte_count> <byte_count> specifies how many data bytes will follow in <data bytes>
Examples | SYSTem:COMMunicate:GPIB:RDEVice:WBINary 101,#17ABC+XYZ<nl><end> # - always sent before data. 1 - specifies that the byte count is one digit (7). 7 - specifies the number of data bytes that will follow, not counting <NL><END>. ABC+XYZ - Data block <nl><end> - always sent at the end of block data.
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SYSTem:COMMunicate:GPIB:RDEVice:WBLock <ID>,<data>

(Write-only) Same as SYSTem:COMM:GPIB:RDEV:WBIN (above) but the header IS passed along to the device. Use this command if too many embedded quotes prevent you from using SYST:COMM:GPIB:RDEV:WRIT.
Parameters |
<ID> | Session identification number that was returned with the OPEN? command.
<data> | Data to be sent to the GPIB pass-through device. See previous command.
Examples | See previous example.
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SYSTem:COMMunicate:GPIB:RDEVice:WRITe <ID>,<string>

(Write-only) Sends ASCII string data to the GPIB pass-through device.
Parameters |
<ID> | Session identification number that was returned with the OPEN? command.
<string> | Commands to be sent to the GPIB pass-through device.
Examples | See an example program
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SYSTem:CORRection:WIZard <char>

(Write-only) Launches either the Calibration Wizard or the Version 2 Calibration Kit File Manager dialog box.
Parameters |
<char> | Choose from: MAIN - Launches the Calibration Wizard CKIT - Launches the Version 2 Calibration Kit File Manager dialog box. Both display on the PNA screen.
Examples | SYST:CORR:WIZ MAIN system:correction:wizard ckit
Query Syntax | Not Applicable?
Overlapped? | No
Default | Not Applicable

SYSTem:ERRor?

(Read-only) Returns the next error in the error queue. Each time the analyzer detects an error, it places a message in the error queue. When the SYSTEM:ERROR? query is sent, one message is moved from the error queue to the output queue so it can be read by the controller. Error messages are delivered to the output queue in the order they were received. The error queue is cleared when any of the following conditions occur:

  • When the analyzer is switched ON.

  • When the *CLS command is sent to the analyzer.

  • When all of the errors are read.

If the error queue overflows, the last error is replaced with a "Queue Overflow" error. The oldest errors remain in the queue and the most recent error is discarded.

Examples

SYST:ERR?
system:error?

Overlapped?

No

Default

Not applicable

SYSTem:ERRor:COUNt?

(Read-only) Returns the number of errors in the error queue. Use SYST:ERR? to read an error.
Examples | SYST:ERR:COUN? system:error:count?
Overlapped? | No
Default | Not applicable

SYSTem:FPReset

(Write-only) Performs a standard Preset, then deletes the default trace, measurement, and window. The PNA screen becomes blank.
Examples | SYST:FPR system:fpreset
Overlapped? | No
Default | Not applicable

SYSTem:MACRo:COPY:CHANnel<cnum>[:TO] <num>

(Write-only) Sets up channel <num> as a copy of channel <cnum>. Learn more about copy channels.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<num> | Number of the channel which is to become a copy of channel <cnum>.
Examples | SYST:MACR:COPY:CHAN1 2 system:macro:copy:channel2:to 3
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SYSTem:PRESet

(Write-only) Deletes all traces, measurements, and windows. In addition, resets the analyzer to factory defined default settings and creates a S11 measurement named "CH1_S11_1". For a list of default settings, see Preset.

Regardless of the state of the User Preset Enable checkbox, the SYST:PRESet command will always preset the PNA to the factory preset settings, and SYST:UPReset will always perform a User Preset.

If the PNA display is disabled with DISP:ENAB OFF then SYST:PRES will NOT enable the display.

This command performs the same function as *RST.

Examples

SYST:PRES
system:preset

Overlapped?

No

Default

Not applicable

SYSTem:SECurity[:LEVel] <char>

(Read-Write) Sets and returns the display of frequency information on the PNA screen and printouts. Learn more about security level.

Parameters

<char>

Choose from:

None - ALL frequency information is displayed

Low - NO frequency information is displayed. Frequency information can be redisplayed using the Security Setting dialog box or this command..

High - NO frequency information is displayed. Frequency information can be redisplayed ONLY by performing a Preset or recalling an instrument state with None or Low security settings, or using this command.

Examples

SYST:SEC LOW
system:security:level high

Query Syntax

SYSTem:SECurity[:LEVel]?

Return Type

Character

Overlapped?

No

Default

None

SYSTem:UPReset

(Write-only) Performs a User Preset. There must be an active User Preset state file (see Load and Save) or an error will be returned. Learn more about User Preset.

Regardless of the state of the User Preset Enable checkbox, the SYST:PRESet command will always preset the PNA to the factory preset settings, and SYST:UPReset will always perform a User Preset.

Examples

SYST:UPReset

system:upreset

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SYSTem:UPReset:FPANel[:STATe] <bool>

(Read-Write) 'Checks' and 'clears' the enable box on the User Preset dialog box. This only affects subsequent Presets from the front panel user interface.

Regardless of the state of the User Preset Enable checkbox, the SYST:PRESet command will always preset the PNA to the factory preset settings, and SYST:UPReset will always perform a User Preset.

Parameters

<bool>

Front Panel User Preset State. Choose from:

0 – User Preset OFF

1 – User Preset ON

Examples

SYST:UPR:FPAN 1

system:upreset:fpanel:state 0

Query Syntax

SYSTem:UPREset:FPANel[:STATe]?

Return Type

Boolean

Overlapped?

No

Default

0

SYSTem:UPReset:LOAD <file>

(Read-Write) Loads an existing instrument state file (.sta or .cst) to be used for User Preset. Subsequent execution of SYSTem:UPReset will cause the PNA to assume this instrument state.

Regardless of the state of the User Preset Enable checkbox, the SYST:PRESet command will always preset the PNA to the factory preset settings, and SYST:UPReset will always perform a User Preset.

Learn more about User Preset.

Parameters

<file>

String - Name of the file to be loaded. The default folder "C:\Program Files\Agilent\Network Analyzer\Documents" is used if unspecified. Change the default folder name using MMEMory:CDIRectory.

Examples

SYST:UPR:LOAD '1MHzto20GHzUserPreset.cst'

system:upreset:load 'C:\Documents and Settings\Administrator\My Documents\NewUserPreset.cst'

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SYSTem:UPReset:SAVE[:STATe]

(Write-only) Saves the current instrument settings as UserPreset.sta. Subsequent execution of SYSTem:UPReset will cause the PNA to assume this instrument state.

Regardless of the state of the User Preset Enable checkbox, the SYST:PRESet command will always preset the PNA to the factory preset settings, and SYST:UPReset will always perform a User Preset.

Learn more about User Preset.

Examples

SYST:UPR:SAVE

system:upreset:save:state

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable


Trigger SCPI

Trigger Commands

Starts or ends a measurement sequence.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Triggering

TRIGger:DELay <num>

(Read-Write) Sets and reads the trigger delay for all channels. This delay is only applied while in External Trigger mode. After an external trigger is applied, the start of the sweep is held off for an amount of time equal to the delay setting plus any inherent latency. To apply delay to a single channel, use SENS:SWE:TRIG:DELay
Parameters |
<num> | Delay value in seconds. Choose from 0 to 1.
Examples | TRIG:DEL .0003 Sets the trigger delay to 300 microseconds. The sweep will not start until approximately 300 microseconds after an external trigger is applied.
Query Syntax | TRIGger:DELay?
Return Type | Numeric
Overlapped? | No
Default | 0

TRIGger[:SEQuence]:LEVel <char>

OBSOLETE COMMAND - Replaced with CONTrol:SIGNal.command. (Read-Write) Triggers either on a High or Low level trigger signal. This setting only has an effect when TRIG:SOURce EXTernal is selected.
Parameters |
<char> | Choose from: HIGH - analyzer triggers on TTL High LOW - analyzer triggers on TTL Low
Examples | TRIG:LEV HIGH trigger:sequence:level low
Query Syntax | TRIGger[:SEQuence]:LEVel?
Return Type | Character
Overlapped? | No
Default | LOW

TRIGger[:SEQuence]:SCOPe <char>

(Read-Write) Specifies whether triggers are applied to all channels or the current channel.
Parameters |
<char> | Choose from: ALL - triggers all channels. Also sets SENS:SWEep:TRIG:POINt OFF on ALL channels. CURRent - trigger only one channel at a time. With each trigger signal, the channel is incremented to the next triggerable channel.
Examples | TRIG:SCOP ALL trigger:sequence:scope current
Query Syntax | TRIGger[:SEQuence]:SCOPe?
Return Type | Character
Overlapped? | No
Default | ALL

TRIGger[:SEQuence]:SOURce <char>

(Read-Write) Sets the source of the sweep trigger signal. This command is a super-set of INITiate:CONTinuous, which can NOT set the source to External. To configure external triggering, see CONTrol:SIGNal.
Parameters |
<char> | Choose from: EXTernal - external (rear panel) source. IMMediate - internal source sends continuous trigger signals MANual - sends one trigger signal when manually triggered from the front panel or INIT:IMM is sent.
Examples | TRIG:SOUR EXT trigger:sequence:source immediate
Query Syntax | TRIGger[:SEQuence]:SOURce?
Return Type | Character
Overlapped? | No
Default | IMMediate


Catalog Measurements using SCPI

This Visual Basic Program does the following:

  • Catalogs the currently defined measurements, windows, and traces

  • Selects a measurement for further definition

  • Adds a Title to the window

To run this program, you need:

  • An established GPIB interface connection

See Other SCPI Example Programs

Dim Meas as String
Dim Win as String
Dim Trace as String

'Read the current measurements in Channel 1
GPIB.Write "CALCulate1:PARameter:CATalog?"
Meas = GPIB.Read
MsgBox ("Ch1 Measurments: " & Meas)

'Read the current windows
GPIB.Write "DISPlay:CATalog?"
Win = GPIB.Read
MsgBox ("Windows: " & Win)

'Read current traces in window 1
GPIB.Write "DISPlay:WINDow1:CATalog?"
Trace = GPIB.Read
MsgBox ("Traces in Window1: " & Win)


Create a Measurement using SCPI

This VBScript program creates a new S21 measurement and displays it on the PNA screen.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as NewMeas.vbs. Learn how to setup and run the macro.

See Other SCPI Example Programs

Dim app
Dim scpi
' Create / Get the PNA application.
Set app = CreateObject("AgilentPNA835x.Application")
Set scpi = app.ScpiStringParser

' A comment
'Preset the analyzer
scpi.Execute ("SYST:FPReset")
' Create and turn on window 1
scpi.Execute ("DISPlay:WINDow1:STATE ON")
'Define a measurement name, parameter
scpi.Execute ("CALCulate:PARameter:DEFine 'MyMeas',S21")
'Associate ("FEED") the measurement name ('MyMeas') to WINDow (1), and give the new TRACe a number (1).
scpi.Execute ("DISPlay:WINDow1:TRACe1:FEED 'MyMeas'")


Setup Sweep Parameters using SCPI

This Visual Basic program sets up sweep parameters on the Channel 1 measurement.

To run this program, you need:

  • An established GPIB interface connection

See Other SCPI Example Programs

GPIB.Write "SYSTem:PRESet"
'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"
'Set sweep type to linear
GPIB.Write "SENSe1:SWEep:TYPE LIN"

'Set IF Bandwidth to 700 Hz
GPIB.Write "SENSe1:BANDwidth 700"

'Set Center and Span Freq's to 4 GHz
GPIB.Write "SENSe1:FREQuency:CENTer 4ghz"
GPIB.Write "SENSe1:FREQuency:SPAN 4ghz"

'Set number of points to 801
GPIB.Write "SENSe1:SWEep:POINts 801"

'Set sweep generation mode to Analog
GPIB.Write "SENSe1:SWEep:GENeration ANAL"

'Set sweep time to Automatic
GPIB.Write "SENSe1:SWEep:TIME:AUTO ON"

'Query the sweep time
GPIB.Write "SENSe1:SWEep:TIME?
SweepTime = GPIB.Read


Setup the Display using SCPI

This Visual Basic program:

  • Sets data formatting

  • Turns ON the Trace, Title, and Frequency Annotation

  • Autoscales the Trace

  • Queries Per Division, Reference Level, and Reference Position

  • Turn ON and set averaging

  • Turn ON and set smoothing

To run this program, you need:

  • An established GPIB interface connection

See Other SCPI Example Programs

GPIB.Write "SYSTem:PRESet"

'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"

'Set the Data Format to Log Mag
GPIB.Write ":CALCulate1:FORMat MLOG"

'Turn ON the Trace, Title, and Frequency Annotation
GPIB.Write "Display:WINDow1:TRACe1:STATe ON"
GPIB.Write "DISPlay:WINDow1:TITLe:STATe ON"
GPIB.Write "DISPlay:ANNotation:FREQuency ON"

'Autoscale the Trace
GPIB.Write "Display:WINDow1:TRACe1:Y:Scale:AUTO"

'Query back the Per Division, Reference Level, and Reference Position
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:PDIVision?"
Pdiv = GPIB.Read
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:RLEVel?"
Rlev = GPIB.Read
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:RPOSition?"
Ppos = GPIB.Read

'Turn ON, and average five sweeps
GPIB.Write "SENSe1:AVERage:STATe ON"
GPIB.Write "SENSe1:AVERage:Count 5"

'Turn ON, and set 20% smoothing aperture
GPIB.Write "CALCulate1:SMOothing:STATe ON"
GPIB.Write "CALCulate1:SMOothing:APERture 20"


See Other SCPI Example Programs

Channels, Windows, and Measurements using SCPI

SOURce and most SENSe commands act on the channel that is specified in the command. Channel 1 is default if not specified. There can be up to four channels present (numbers 1 to 4) in the analyzer at the same time.

Most DISPlay commands act on the window and trace specified in the command. Window1 and Trace1 are default if not specified. There can be up to four windows present (numbers 1 to 4) and up to four traces present in each window (numbers 1 to 4) at the same time.

CALCulate commands act on the selected measurement in the specified channel. Select the measurement for each channel using CALCulate<channel number>:PARameter:SELect <meas name>. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time.

The following Visual Basic program does the following:

  • Presets the analyzer

  • Create 2 windows

  • Create 2 Measurements

  • Feed the measurements to windows / traces

  • Change frequency ranges for channels

  • Select both measurements

  • Turn marker 1 ON for each measurement

To run this program, you need:

  • An established GPIB interface connection

GPIB.Write "SYSTem:PREset"

'Create Measurements
GPIB.Write "CALCulate1:PARameter:DEFine 'Meas1',S11"
GPIB.Write "CALCulate2:PARameter:DEFine 'Meas2',S21"

' Turn on windows - creates if new
GPIB.Write "DISPlay:WINDow1:STATE ON"
GPIB.Write "DISPlay:WINDow2:STATE ON"

'Associate ("FEED") the measurement name('Meas1') to WINDow(1), and give the new TRACe a number(1).
GPIB.Write "DISPlay:WINDow1:TRACe1:FEED 'Meas1'"
GPIB.Write "DISPlay:WINDow2:TRACe2:FEED 'Meas2'"

'Change each channel's frequency range
GPIB.Write "SENSe1:FREQuency:SPAN 1e9"
GPIB.Write "SENSe2:FREQuency:SPAN 2e9"

'Select both measurements
GPIB.Write "CALCulate1:PARameter:SELect 'Meas1'"
GPIB.Write "CALCulate2:PARameter:SELect 'Meas2'"

'Turn marker 1 ON for each measurement
GPIB.Write "CALCulate1:MARKer:STATe ON"
GPIB.Write "CALCulate2:MARKer:STATE ON"


Perform Guided Cal

Perform a Guided Calibration using SCPI

This VBScript program performs a Guided Calibration using ECal or Mechanical standards. This example includes optional ECal orientation features.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as Guided.vbs. Learn how to setup and run the macro.

' Performing a Guided 2-port cal (Ports 1 and 2)
TwoPortGuidedCal
Sub TwoPortGuidedCal
Dim app
Dim scpi
Dim connList
Dim selectedConn
Dim kitList
Dim selectedKit
Dim message

' Create / Get the PNA application.
Set app = CreateObject("AgilentPNA835x.Application")
Set scpi = app.ScpiStringParser

' Query the list of connectors that the PNA system recognizes
connList = scpi.Execute("sens:corr:coll:guid:conn:cat?")

' Format the list with linefeed characters in place of the commas
connList = FormatList(connList)

message = "Enter your DUT connector for Port 1. Choose from this list:"
message = message & Chr(10) & Chr(10) & connList

' Select the connector for Port 1
selectedConn = InputBox(message)
If selectedConn = "" Then Exit Sub
scpi.Execute "sens:corr:coll:guid:conn:port1 '" & selectedConn & "'"

message = "Enter your DUT connector for Port 2. Again, choose from this list:"
message = message & Chr(10) & Chr(10) & connList

' Select the connector for Port 2
selectedConn = InputBox(message)
If selectedConn = "" Then Exit Sub
scpi.Execute "sens:corr:coll:guid:conn:port2 '" & selectedConn & "'"

' Note: If your PNA has more than 2 ports, then uncomment
' one or both of these next two lines.
'scpi.Execute "sens:corr:coll:guid:conn:port3 ""Not used"" "
'scpi.Execute "sens:corr:coll:guid:conn:port4 ""Not used"" "

' Query the list of acceptable cal kits and
' ECal module characterizations for Port 1.
kitList = scpi.Execute("sens:corr:coll:guid:ckit:port1:cat?")
' Format the list with linefeed
' characters in place of the commas
kitList = FormatList(kitList)

message = "Enter your cal kit or ECal module characterization for Port 1. "
message = message & "Choose from this list:"
message = message & Chr(10) & Chr(10) & kitList

' Select the Cal Kit or ECal module
' characterization to use for Port 1.
selectedKit = InputBox(message)
If selectedKit = "" Then Exit Sub
scpi.Execute "sens:corr:coll:guid:ckit:port1 '" & selectedKit & "'"

' Query the list of acceptable cal kits
' and ECal module characterizations for Port 2.
kitList = scpi.Execute("sens:corr:coll:guid:ckit:port2:cat?")
' Format the list with linefeed characters in place of the commas
kitList = FormatList(kitList)

message = "Enter your cal kit or ECal module characterization for Port 2. "
message = message & "Choose from this list:"
message = message & Chr(10) & Chr(10) & kitList

' Select the Cal Kit or ECal module
' characterization to use for Port 2.
selectedKit = InputBox(message)
If selectedKit = "" Then Exit Sub
scpi.Execute "sens:corr:coll:guid:ckit:port2 '" & selectedKit & "'"

' This next block of commented code
' shows optional functions when using ECal.
' Send these "sens:corr:pref" commands prior to the
' "sens:corr:coll:guid:init" command.

' Read ECAL information from ECal module #1 on the USB bus
' about the Agilent factory characterization data

'module1Info = scpi.Execute("sens:corr:coll:ckit:inf? ECAL1,CHAR0")
'MsgBox "Description of ECal Module #1:" & Chr(10) & Chr(10) & module1Info

' The following command enables auto orientation of
' the ECal module (The PNA senses which port of the
' module is connected to which port of the PNA).

'scpi.Execute "sens:corr:pref:ecal:ori ON"

' However, if you are measuring at very low power levels where
' the PNA may fail to sense the module's orientation, then turn auto
' orientation OFF and specify how the module is connected.
' "A1,B2" indicates Port A of the module is connected
' to PNA Port 1 and Port B is connected to PNA Port 2).
'scpi.Execute "sens:corr:pref:ecal:ori OFF"
'scpi.Execute "sens:corr:pref:ecal:pmap ECAL1,'A1,B2'"
' End of optional ECal setup

' Select the thru method of "Default". This instructs the PNA to
' determine which thru standard measurement technique to use
' based upon the selected connectors and
' calibration kit(s) and the PNA model number.
scpi.Execute "sens:corr:coll:guid:meth default"

' Initiate the calibration and query the number of steps
scpi.Execute "sens:corr:coll:guid:init"
numSteps = scpi.Execute("sens:corr:coll:guid:steps?")
MsgBox "Number of steps is " + CStr(numSteps)

' Measure the standards
For i = 1 To numSteps
step = "Step " + CStr(i) + " of " + CStr(numSteps)
strPrompt = scpi.Execute("sens:corr:coll:guid:desc? " + CStr(i))
MsgBox strPrompt, vbOKOnly, step
scpi.Execute "sens:corr:coll:guid:acq STAN" + CStr(i)
Next

' Conclude the calibration
scpi.Execute "sens:corr:coll:guid:save"
MsgBox "Cal is done!"

End Sub

Function FormatList(list)
Dim tokens
' Strip the leading and trailing quotation
' marks from the list string
list = Mid(list, 2, Len(list) - 3)
' Tokenize the comma-delimited list string
' into an array of the individual substrings
tokens = Split(list, ",")
' Rebuild the list string, placing linefeed
' characters where the commas were,
' using Trim to remove leading and trailing spaces.
list = ""
For i = 0 To UBound(tokens)
tokens(i) = Trim(tokens(i))
list = list & tokens(i) & Chr(9)
If i < UBound(tokens) Then
i = i + 1
tokens(i) = Trim(tokens(i))
list = list & tokens(i) & Chr(10)
End If
Next
FormatList = list
End Function


Perform Guided 1Port

Perform a Guided 1-Port Cal on Port 2

This VBScript program does the following:

  1. Clear measurements from the PNA

  2. Create a new S22 measurement

  3. Set an instrument state

  4. Select the connector types

  5. Select a cal kit

  6. Initiate a Guided calibration

  7. Display a prompt to connect each standard

  8. Save the calibration to a newly created cal set

Note: This example illustrates an important step when calibrating a reflection measurement in the reverse direction. You MUST create a reverse (S22) measurement and have it be the active (selected) measurement on the channel that is being calibrated. This is not necessary for any calibrating any other measurement parameter.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as Guided.vbs. Learn how to setup and run the macro.

Dim App
Set App = CreateObject("AgilentPNA835x.Application")
App.Preset

Dim step
Dim Parser
Dim prompt
Dim txtDat
Dim Chan

Rem Clear old measurements
App.Reset

Rem Create a new Measurement
Set Parser = App.SCPIStringParser
Parser.Parse "DISPlay:WINDow1:STATE ON"
Parser.Parse "CALCulate:PARameter:DEFine 'MyMeas',S22"
Parser.Parse "DISPlay:WINDow1:TRACe1:FEED 'MyMeas'"

Rem Initialize state
Set Chan = App.ActiveChannel
Chan.StartFrequency = 200e6
Chan.StopFrequency = 1.5e9
Chan.IFBandwidth = 1000
step = 3

Rem Begin a guided calibration
Parser.Parse "SENS:CORR:COLL:GUID:CONN:PORT1 'Not used'"
Parser.Parse "SENS:CORR:COLL:GUID:CONN:PORT2 'Type N (50) male'"
Parser.Parse "SENS:CORR:COLL:GUID:CKIT:PORT1 ''"
Parser.Parse "SENS:CORR:COLL:GUID:CKIT:PORT2 '85054D'"
Parser.Parse "SENS:CORR:COLL:GUID:INIT"

Rem Query the number of steps
txtDat = Parser.Parse("SENS:CORR:COLL:GUID:STEP?")

Rem Display the number of steps
MsgBox("Number of steps is " + txtDat)

Rem Set the loop counter limit
step = txtDat

Rem  Measure
 the standards
For i = 1 To step
If i= 1 Then
prompt = Parser.Parse("sens:corr:coll:guid:desc? 1")
MsgBox(prompt)
Parser.Parse ("sens:corr:coll:guid:acq STAN1")
ElseIf i = 2 then
prompt = Parser.Parse("sens:corr:coll:guid:desc? 2")
MsgBox(prompt)
Parser.Parse ("sens:corr:coll:guid:acq STAN2")
ElseIf i = 3 then
prompt = Parser.Parse("sens:corr:coll:guid:desc? 3")
MsgBox(prompt)
Parser.Parse ("sens:corr:coll:guid:acq STAN3")
End If
Next

Rem All standards have been measured.  Save
 the result
Parser.Parse "SENS:CORR:COLL:GUID:SAVE"
MsgBox("The calibration has been completed")


Perform Unguided ECAL

Perform an Unguided ECal

This VBScript program performs an Unguided Full 2-Port ECal.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as Unguided.vbs. Learn how to setup and run the macro.

Set pna = CreateObject("AgilentPNA835x.Application")
Set scpi = pna.ScpiStringParser
' Preset the analyzer
scpi.Execute "SYSTem:PRESet"

' Start frequency of 10 MHz
scpi.Execute "SENSe:FREQuency:STARt 10E6"

' Stop frequency of 9 GHz
scpi.Execute "SENSe:FREQuency:STOP 9E9"

' Select the preset S11 measurement
scpi.Execute "CALCulate:PARameter:SELect 'CH1_S11_1'"
' Read the information about the Agilent factory
' characterization data of ECal module #1 on the USB bus
module1Info = scpi.Execute("SENSe:CORRection:COLLect:CKIT:INFormation? ECAL1,CHAR0")

' Prompt for the ECal module
MsgBox "Description of ECal Module #1:" & Chr(10) & Chr(10) & module1Info & _Chr(10) & Chr(10) & "Make port connections to the ECal module, then press enter"
' ECal full 1 port and 2 port
' Choose a Calibration Type (comment out one of these)
scpi.Execute "SENSe:CORRection:COLLect:METHod refl3"
scpi.Execute "SENSe:CORRection:COLLect:METHod SPARSOLT"
' Specify to have the PNA automatically determine which port of the
' ECal module is connected to which port of the PNA.
scpi.Execute "SENSe:CORRection:PREFerence:ECAL:ORIentation ON"
' Alternatively, if you are measuring at very low power levels where
' the PNA fails to sense the module's orientation, you may need to turn
' off the auto orientation and specify how the module is connected (as in
' these next two commented lines of code -- "A1,B2" would indicate Port A
' of the module is connected to Port 1 and Port B is connected to Port 2).
'scpi.Execute "SENSe:CORRection:PREFerence:ECAL:ORIentation OFF"
'scpi.Execute "SENSe:CORRection:PREFerence:ECAL:PMAP ECAL1,'A1,B2'"
' Acquire and store the calibration terms. *OPC? causes a "+1" to be
' returned when finished. CHAR0 indicates to use the Agilent factory
' characterized data within the ECal module (as opposed to a user characterization).
x = scpi.Execute("SENSe:CORRection:COLLect:ACQuire ECAL1,CHAR0;*OPC?")
MsgBox "Done with calibration."


Perform Unguided 2-Port Mech Cal

Perform an Unguided 2-Port Mechanical Cal

This VBScript program performs an Unguided, Full 2-Port, calibration using ONE set of mechanical calibration standards.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as Unguided.vbs. Learn how to setup and run the macro.

Set App = CreateObject("AgilentPNA835x.Application")
Set Scpi = App.SCPIStringParser

'Initialize state
Scpi.Execute ("SYSTem:PRESet")

'Select the Preset measurement
Scpi.Execute ("CALCulate:PARameter:SELect 'CH1_S11_1'")

'Set the calibration method
Scpi.Execute ("SENSe:CORRection:COLLect:METHod SPARSOLT")

'Select a cal kit
Scpi.Execute ("SENSe:CORRection:COLLect:CKIT:SELect 1")

'Set acquisition to FORWARD
Scpi.Execute ("SENSe:CORRection:SFORward ON")

'Measure the standards in forward direction
MsgBox "Connect OPEN to Port 1; then press OK"
Scpi.Execute ("SENSe:CORRection:COLLect:ACQuire stan1")

MsgBox "Connect SHORT to Port 1; then press OK"
Scpi.Execute ("SENSe:CORRection:COLLect:ACQuire stan2")

MsgBox "Connect LOAD to Port 1; then press OK"
Scpi.Execute ("SENSe:CORRection:COLLect:ACQuire stan3")

'Set acquisition to REVERSE
Scpi.Execute ("SENSe:CORRection:SFORward OFF")

'Measure the standards in reverse direction
MsgBox "Connect OPEN to Port 2; then press OK"
Scpi.Execute ("SENSe:CORRection:COLLect:ACQuire stan1")

MsgBox "Connect SHORT to Port 2; then press OK"
Scpi.Execute ("SENSe:CORRection:COLLect:ACQuire stan2")

MsgBox "Connect LOAD to Port 2; then press OK"
Scpi.Execute ("SENSe:CORRection:COLLect:ACQuire stan3")

'Measure the thru standard
MsgBox "Connect THRU between Ports 1 and 2; then press OK"
Scpi.Execute ("SENSe:CORRection:COLLect:ACQuire stan4")

'All standards have been measured. Save the result
Scpi.Execute ("SENS:CORR:COLL:SAVE")
MsgBox "The calibration has been completed"


Perform an Unguided 1-Port Cal on Port 2

This VBScript program does the following:

  1. Clear measurements from the PNA

  2. Create a new S22 measurement

  3. Set an instrument state

  4. Select a cal kit

  5. Initiate an Unguided calibration

  6. Display a prompt to connect each standard

  7. Save the calibration to a newly created cal set

Note: This example illustrates an important step when calibrating a reflection measurement in the reverse direction. You MUST create a reverse (S22) measurement and have it be the active (selected) measurement on the channel that is being calibrated. This is not necessary for any calibrating any other measurement parameter.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as Unguided.vbs. Learn how to setup and run the macro.

Dim App
Set App = CreateObject("AgilentPNA835x.Application")
App.Preset

Dim Parser
Dim Chan

Rem Clear old measurements
App.Reset

Rem Create a new Measurement
Set Parser = App.SCPIStringParser
Parser.Parse "DISPlay:WINDow1:STATE ON"
Parser.Parse "CALCulate:PARameter:DEFine 'MyMeas',S22"
Parser.Parse "DISPlay:WINDow1:TRACe1:FEED 'MyMeas'"

Rem Initialize state
Set Chan = App.ActiveChannel
Chan.StartFrequency = 200e6
Chan.StopFrequency = 1.5e9
Chan.IFBandwidth = 1000

Rem Begin an unguided calibration
Rem Set the calibration method
Parser.Parse "SENSe:CORRection:COLLect:METHod REFL3"

Rem Turn off continuous sweep
Parser.Parse "INITiate:CONTinuous OFF"

Rem Select a cal kit
Parser.Parse "SENSe:CORRection:COLLect:CKIT:SELect 1"

Rem Measure the standards
MsgBox("Connect OPEN to port 2. Then press OK")
Parser.Parse ("sens:corr:coll:acq STAN1")

MsgBox("Connect SHORT to port 2. Then press OK")
Parser.Parse ("sens:corr:coll:acq STAN2")

MsgBox("Connect LOAD to port 2. Then press OK")
Parser.Parse ("sens:corr:coll:acq STAN3")

Rem All standards have been measured. Save the result
Parser.Parse "SENS:CORR:COLL:SAVE"

Rem Turn ON continuous sweep
Parser.Parse "INITiate:CONTinuous ON"
MsgBox("The calibration has been completed")


Perform a Source Power Cal using SCPI

Programming the PNA using COM or using SICL/VISA over LAN (as in this example) leaves the PNA free to control GPIB devices as needed. This Visual Basic program demonstrates:

  • Performing a source power calibration of Port 2 for Channel 1.

  • Reading the calibration data.

Learn more about Power Calibrations.

See an example that Uploads a Source Power Cal.

Other SCPI Example Programs

To run this program, you need:

  • One of the following power meters connected to the PNA through GPIB: E4416A, E4417A, E4418A/B, E4419A/B, 437B, 438A, EPM-441A, EPM-442A

Note: If your power meter is other than these, you can create your own Power Meter Driver using our template.

  • Your PC and PNA both connected to a LAN (for communicating with each other).

  • The SICL and VISA components of Agilent’s I/O Libraries software installed on your PC (both are included when you install the software, unless you already have another vendor's VISA installed. Then specify Full SICL and VISA installation to overwrite the other vendor's VISA.

  • The module visa32.bas added to your VB project.

  • A form with two buttons: cmdRun and cmdQuit.

  • A VISA interface configured on your remote PC to control the PNA. This could be GPIB interface or a VISA LAN Client.

Note: The SOURce:POWer:CORRection:COLLect:ACQuire command, used to step the PNA and read a power meter, cannot be sent over the GPIB unless the power meter is connected to a different GPIB interface. See the alternative methods described in the command details.

'Session to VISA Default Resource Manager
Private defRM As Long
'Session to PNA
Private viPNA As Long
'VISA function status return code
Private status As Long

Private Sub Form_Load()
defRM = 0
End Sub

Private Sub cmdRun_Click()
' String to receive data from the PNA.
' Dimensioned large enough to receive scalar comma-delimited values
' for 21 frequency points (20 ASCII characters per point)
Dim strReply As String * 420

Dim strStimulus, strCalValue
Dim strResult As String

' Open the VISA default resource manager
status = viOpenDefaultRM(defRM)
If (status < VI_SUCCESS) Then HandleVISAError

' ' Open a session (viPNA) to the PNA at "address 16" on the VISA
' interface configured as "GPIB1" on this PC. This could be a
' VISA LAN Client pointing to the SICL LAN Server on the PNA, or
' an actual GPIB interface on this PC connected to the PNA GPIB
' (in which case the power meter would need to be connected to a
' different GPIB interface on the PNA, such as the Agilent 82357A
' USB-to-GPIB).
status = viOpen(defRM, "GPIB0::16::INSTR", 0, 0, viPNA)
If (status < VI_SUCCESS) Then HandleVISAError

' Set the number of sweep points to 21 on Channel 1.
status = myGPIBWrite(viPNA, "SENS1:SWE:POIN 21")
If (status < VI_SUCCESS) Then HandleVISAError

' Specify the GPIB address of the power meter
' that will be used in performing the calibration.
status = myGPIBWrite(viPNA, "SYST:COMM:GPIB:PMET:ADDR 13")
If (status < VI_SUCCESS) Then HandleVISAError

' Turn use of the loss table OFF (this assumes there is
' virtually no loss in the RF path to the power sensor
' due to a splitter, coupler or adapter).
status = myGPIBWrite(viPNA, "SOUR:POW:CORR:COLL:TABL:LOSS OFF")
If (status < VI_SUCCESS) Then HandleVISAError

' Turn frequency checking OFF (so one power sensor is used for the entire cal
' acquisition sweep regardless of frequency span).
status = myGPIBWrite(viPNA, "SOUR:POW:CORR:COLL:FCH OFF")
If (status < VI_SUCCESS) Then HandleVISAError

' Specify a nominal power accuracy tolerance (NTOLerance) in dB for the calibration,
' and the maximum number (COUNt) of iterations to adjust power at each point,
' attempting to achieve within tolerance of the desired power. If at any stimulus
' point the power fails to reach within the set tolerance of the desired power
' after the maximum number of iterations, the power at that point will be set to the
' value determined by the last iteration (the Source Power Cal dialog box will
' indicate the FAIL, but we can still apply the cal if desired when it's complete).
' Each iteration is based upon a SETTLED power reading (see comments preceding the
' next two commands below).
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:COLL:ITER:NTOL 0.1")
If (status < VI_SUCCESS) Then HandleVISAError
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:COLL:ITER:COUN 3")
If (status < VI_SUCCESS) Then HandleVISAError

' The worst-case window of power uncertainty (for a calibration which meets
' tolerance) is the sum of the iteration tolerance and the power meter settling
' tolerance (which is described below).

' At each stimulus point, the PNA takes power meter readings and determine when
' they have settled by comparing the magnitude difference between consecutive
' readings versus a nominal dB tolerance limit (NTOLerance) on that magnitude
' difference. When consecutive readings are within tolerance of each other, or
' if they are not within tolerance but we've taken a maximum number of readings
' (COUNt), the PNA does a weighted average of the readings taken at that stimulus
' point and that is considered our settled power reading.
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:COLL:AVER:NTOL 0.1")
If (status < VI_SUCCESS) Then HandleVISAError
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:COLL:AVER:COUN 5")
If (status < VI_SUCCESS) Then HandleVISAError

' Specify if the cal power level is offset (positive value for a gain, negative
' value for a loss) from the PNA port power setting on the channel when no source
' power cal is active. This is to account for components between the PNA test
' port and cal reference plane. In this example, we will calibrate at the PNA
' test port, so there is no offset (it is zero).

status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:OFFS 0 DB")
If (status < VI_SUCCESS) Then HandleVISAError

' Specify the method (type of devices) that will be used to perform the cal.
' Choose either power meter (PMETer), or power meter and receiver (PMReceiver).
' PMReceiver uses the power meter for the first iteration of each point and
' the PNA's reference receiver for subsequent iterations, so is much faster
' than using power meter only. But the power meter accounts for compression
' when calibrating at the output of an active device, whereas the reference
' receiver cannot unless it is coupled to the cal reference plane (on a PNA
' which allows direct access to the receivers).
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:COLL:METH PMET")
'status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:COLL:METH PMR")
If (status < VI_SUCCESS) Then HandleVISAError

' Show the source power cal dialog during the source power cal acquisition.
' (this is the default, so this command is only necessary if this setting
' may have been changed beforehand, perhaps by another program).
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:COLL:DISP ON")
If (status < VI_SUCCESS) Then HandleVISAError

' Perform the source power cal acquisition sweep using the sensor attached to
' Channel A of the power meter (asking for an OPC reply when it’s done). This
' assumes that the power sensor is already connected to Port 2 of the PNA.
' We'll put up an hourglass cursor while waiting for the acquire to complete.
Screen.MousePointer = vbHourglass
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:COLL:ACQ ASEN;*OPC?")
If (status < VI_SUCCESS) Then HandleVISAError

' In the process of beginning a source power cal acquisition, the PNA searches
' for the power meter on VISA interfaces configured in the Agilent I/O Libraries
' on the PNA. One of those interfaces is the SICL/VISA LAN server, so if this
' program is using that interface, we need to ensure our program is not pending
' an operation on that interface when the PNA wants to search it. So this
' Wait subroutine suspends execution of our program (for 6000 milliseconds =
' 6 seconds), giving the PNA time to search that interface and discover that the
' power meter is not there (the 6 seconds is just to be safe, the search actually
' takes only a few seconds).
' Note: If instead of using the VISA LAN server interface, you are having this
' program communicate with the PNA via it's GPIB interface (which requires the
' power meter be connected to a different GPIB interface on the PNA, such as the
' Agilent 82357A USB-to-GPIB), then this Wait is not needed.
Wait 6000

' The PNA sends an OPC reply ("+1") when the cal acquisition is complete, so
' our Read operation will wait on the reply until it is received. We need to
' set the VISA timeout value long enough to give our Read sufficient time to
' complete before a timeout error occurs. For this example, let's try setting
' the limit to 60000 milliseconds (60 seconds).
status = viSetAttribute(viPNA, VI_ATTR_TMO_VALUE, 60000)
If (status < VI_SUCCESS) Then HandleVISAError
status = myGPIBRead(viPNA, strReply)
If (status < VI_SUCCESS) Then HandleVISAError

' Change mouse cursor from hourglass back to normal
Screen.MousePointer = vbDefault

' Conclude the calibration. This applies the cal data to PNA channel memory,
' and turns the correction ON for Port 2 on Channel 1,
' but does NOT save the calibration.
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:COLL:SAVE")
If (status < VI_SUCCESS) Then HandleVISAError

' At this point, if you choose to save the instrument state as a ".CST" file,
' the calibration will be saved with the instrument state in that file.

' Prepare for doing data transfer in ASCII format.
status = myGPIBWrite(viPNA, "FORM:DATA ASCII")
If (status < VI_SUCCESS) Then HandleVISAError

' Read the stimulus values from Channel 1.
status = myGPIBWrite(viPNA, "SENS1:X?")
If (status < VI_SUCCESS) Then HandleVISAError
status = myGPIBRead(viPNA, strReply)
If (status < VI_SUCCESS) Then HandleVISAError

' Tokenize the reply string into an array containing the values
strStimulus = Split(strReply, ",")

' Read the source power correction data.
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:DATA?")
If (status < VI_SUCCESS) Then HandleVISAError
status = myGPIBRead(viPNA, strReply)
If (status < VI_SUCCESS) Then HandleVISAError

' Tokenize the reply string into an array containing the values
strCalValue = Split(strReply, ",")

' Print the data using a message box (here, Chr returns the ASCII characters
' for Tab (9) and Linefeed (10)).
strResult = "Stimulus" & Chr(9) & Chr(9) & "Cal Value" & Chr(10)
For i = 0 To UBound(strStimulus)
strResult = strResult & Val(strStimulus(i)) & Chr(9) & Val(strCalValue(i)) & Chr(10)
Next
MsgBox strResult
End Sub

Private Function myGPIBWrite(ByVal viHandle As Long, ByVal strOut As String) As Long

' The "+ Chr$(10)" appends an ASCII linefeed character to the
' output, for terminating the write transaction.
myGPIBWrite = viVPrintf(viHandle, strOut + Chr$(10), 0)
End Function

Private Function myGPIBRead(ByVal viHandle As Long, strIn As String) As Long
myGPIBRead = viVScanf(viHandle, "%t", strIn)
End Function

Sub HandleVISAError()
Dim strVisaErr As String * 200
Call viStatusDesc(defRM, status, strVisaErr)
MsgBox "*** Error : " + strVisaErr, vbExclamation

' Close the resource manager session (which also closes
' the session to the PNA).

If defRM <> 0 Then Call viClose(defRM)
End
End Sub

Public Sub Wait(ByVal mS_delay As Long)

Dim t0 As Single
t0 = Timer
Do While Timer - t0 < mS_delay / 1000
Dim dummy As Integer
dummy = DoEvents() ' if we cross midnight, back up one day
If Timer < t0 Then t0 = t0 - 86400
Loop
End Sub


Uploading a Source Power Cal using SCPI

Programming the PNA using COM or using SICL/VISA over LAN (as in this example) leaves the PNA free to control GPIB devices as needed. This Visual Basic program demonstrates:

  • Uploading a source power calibration of Port 2 for Channel 1.

  • Reading the calibration data.

Learn more about Power Calibrations

Other SCPI Example Programs

To run this program, you need:

  • Your PC and PNA both connected to a LAN (if using VISA LAN server / client).

  • The SICL and VISA components of Agilent’s I/O Libraries software installed on your PC (both are included when you install the software, unless you already have another vendor's VISA installed. Then specify Full SICL and VISA installation to overwrite the other vendor's VISA.

  • The module visa32.bas added to your VB project.

  • A form with two buttons: cmdRun and cmdQuit.

  • A VISA interface configured on your remote PC to control the PNA. This could be GPIB interface or a VISA LAN Client.

'Session to VISA Default Resource Manager
Private defRM As Long
'Session to PNA
Private viPNA As Long
'VISA function status return code
Private status As Long
Private Sub Form_Load()
defRM = 0
End Sub
Private Sub cmdRun_Click()

' String to receive data from the PNA.
' Dimensioned large enough to receive scalar comma-delimited values
' for 21 frequency points (20 ASCII characters per point)
Dim strReply As String * 420
Dim strPower As String, strCalPower As String
Dim strStimulus, strCalValue
Dim strResult As String

' Open the VISA default resource manager
status = viOpenDefaultRM(defRM)
If (status < VI_SUCCESS) Then HandleVISAError

' Open a session (viPNA) to the PNA at "address 16" on the VISA
' interface configured as "GPIB0" on this PC.
status = viOpen(defRM, "GPIB0::16::INSTR", 0, 0, viPNA)
If (status < VI_SUCCESS) Then HandleVISAError

' Set the number of sweep points to 2 on Channel 1.
status = myGPIBWrite(viPNA, "SENS1:SWE:POIN 2")
If (status < VI_SUCCESS) Then HandleVISAError

' Ensure there's currently no source power cal on for this channel and port.
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR OFF")
If (status < VI_SUCCESS) Then HandleVISAError

' Specify if the cal power level is offset (positive value for a gain, negative
' value for a loss) from the PNA port power setting on the channel when no source
' power cal is active. This is to account for components between the PNA test
' port and cal reference plane. In this example, let's set up our calibration
' at the output of an amplifier with 15 dB gain.
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:OFFS 15 DB")
If (status < VI_SUCCESS) Then HandleVISAError

' Prepare for doing data transfer in ASCII format.
status = myGPIBWrite(viPNA, "FORM:DATA ASCII")
If (status < VI_SUCCESS) Then HandleVISAError

' Send our source power correction data to the PNA. For purpose of simplicity
' in this example, we'll set up for no correction (0) at our start stimulus and
' 0.5 dB at our stop stimulus (recall that our sweep currently has just 2 points).
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:DATA 0,0.5")
If (status < VI_SUCCESS) Then HandleVISAError

' Set the number of sweep points to 21 on Channel 1.
status = myGPIBWrite(viPNA, "SENS1:SWE:POIN 21")
If (status < VI_SUCCESS) Then HandleVISAError

' Read the fixed power level for this port on Channel 1.
status = myGPIBWrite(viPNA, "SOUR1:POW2:LEV?")
If (status < VI_SUCCESS) Then HandleVISAError
status = myGPIBRead(viPNA, strReply)
If (status < VI_SUCCESS) Then HandleVISAError
strPower = strReply

' Turn the source power cal on.
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR ON")
If (status < VI_SUCCESS) Then HandleVISAError

' Again read the fixed power level for this port on Channel 1
' (with our calibration turned on, this should now include the 15 dB offset
' we indicated our power amplifier provides).
status = myGPIBWrite(viPNA, "SOUR1:POW2:LEV?")
If (status < VI_SUCCESS) Then HandleVISAError
status = myGPIBRead(viPNA, strReply)
If (status < VI_SUCCESS) Then HandleVISAError
strCalPower = strReply

' Read the stimulus values from Channel 1.
status = myGPIBWrite(viPNA, "SENS1:X?")
If (status < VI_SUCCESS) Then HandleVISAError
status = myGPIBRead(viPNA, strReply)
If (status < VI_SUCCESS) Then HandleVISAError

' Tokenize the reply string into an array containing the values
strStimulus = Split(strReply, ",")

' Read back the source power correction data, now interpolated for 21 points
status = myGPIBWrite(viPNA, "SOUR1:POW2:CORR:DATA?")
If (status < VI_SUCCESS) Then HandleVISAError
status = myGPIBRead(viPNA, strReply)
If (status < VI_SUCCESS) Then HandleVISAError

' Tokenize the reply string into an array containing the values
strCalValue = Split(strReply, ",")

' Print the data using a message box (here, Chr returns the ASCII characters
' for Tab (9) and Linefeed (10)).
strResult = "PNA port power = " & Val(strPower) & Chr(10)
strResult = strResult & "Power at reference plane = " & Val(strCalPower) & Chr(10) Chr(10)
strResult = strResult & "Stimulus" & Chr(9) & Chr(9) & "Cal Value" & Chr(10)
For i = 0 To UBound(strStimulus)
strResult = strResult & Val(strStimulus(i)) & Chr(9) & Val(strCalValue(i)) & Chr(10)
Next
MsgBox strResult
End Sub
Private Sub cmdQuit_Click()

' Close the resource manager session (which also closes
' the session to the PNA).
If defRM <> 0 Then Call viClose(defRM)

' End the program
End
End Sub
Private Function myGPIBWrite(ByVal viHandle As Long, ByVal strOut As String) As Long

' The "+ Chr$(10)" appends an ASCII linefeed character to the
' output, for terminating the write transaction.
myGPIBWrite = viVPrintf(viHandle, strOut + Chr$(10), 0)
End Function
Private Function myGPIBRead(ByVal viHandle As Long, strIn As String) As Long
myGPIBRead = viVScanf(viHandle, "%t", strIn)

' Remove trailing linefeed character
If Right(strIn, 1) = Chr(10) Then strIn = Left(strIn, Len(strIn) - 1)
End Function
Sub HandleVISAError()
Dim strVisaErr As String * 200
Call viStatusDesc(defRM, status, strVisaErr)
MsgBox "*** Error : " + strVisaErr, vbExclamation

' Close the resource manager session (which also closes
' the session to the PNA).
If defRM <> 0 Then Call viClose(defRM)
End
End Sub


Sliding Load Cal using SCPI

Perform a Sliding Load Calibration using GPIB

This Visual Basic program does a only the sliding load portion of a Calibration.

To run this program, you need:

  • An established GPIB interface connection

  • A measurement and calibration routine to call this sub-program

  • STAN3 set up as a sliding load standard
See Other SCPI Example Programs

Sub slide()
'Measure the sliding load for at least 5 and no more than 7 slides
'Note that "SLSET" and "SLDONE" must be executed before the actual acquisition of a slide
MsgBox "Connect Sliding Load; set to Position 1; then press OK"
GPIB.Write "SENS:CORR:COLL SLSET"
GPIB.Write "SENS:CORR:COLL STAN3;"

MsgBox "Set Sliding Load to position 2; then press OK"
GPIB.Write "SENS:CORR:COLL SLSET"
GPIB.Write "SENS:CORR:COLL STAN3;"

MsgBox "Set Sliding Load to position 3; then press OK"
GPIB.Write "SENS:CORR:COLL SLDONE"
GPIB.Write "SENS:CORR:COLL STAN3;"
End Sub


ECALConfidence Check using SCPI

This Visual Basic program performs a complete ECAL confidence check.

To run this program, you need:

  • An established GPIB interface connection

  • Agilent's VISA or National Instrument's VISA installed on your PC

  • The module visa32.bas added to your VB project.

  • A form with two buttons: cmdRun and cmdQuit

  • A calibrated S11 1-port or N-port measurement active on Channel 1

  • Window 1 is visible

See Other SCPI Example Programs

'Session to VISA Default Resource Manager

Private defRM As Long

'Session to PNA

Private viPNA As Long

'VISA function status return code

Private status As Long

Private Sub Form_Load()

defRM = 0

End Sub

Private Sub cmdRun_Click()

'String to receive data from the PNA

Dim strReply As String * 200

' Open the VISA default resource manager

status = viOpenDefaultRM(defRM)

If (status < VI_SUCCESS) Then HandleVISAError

' Open a VISA session (viPNA) to the PNA at GPIB address 16.

status = viOpen(defRM, "GPIB0::16::INSTR", 0, 0, viPNA)

If (status < VI_SUCCESS) Then HandleVISAError

' Need to set the VISA timeout value to give all our GPIB Reads

' sufficient time to complete before a timeout error occurs.

' For this example, let's try setting the limit to

' 10000 milliseconds (10 seconds).

status = viSetAttribute(viPNA, VI_ATTR_TMO_VALUE, 10000)

If (status < VI_SUCCESS) Then HandleVISAError

' Get the catalog of all the measurements currently on Channel 1.

status = myGPIBWrite(viPNA, "CALC1:PAR:CAT?")

If (status < VI_SUCCESS) Then HandleVISAError

status = myGPIBRead(viPNA, strReply)

If (status < VI_SUCCESS) Then HandleVISAError

' If an S11 measurement named "MY_S11" doesn't already exist,

' then create it.

If InStr(strReply, "MY_S11") = 0 Then

status = myGPIBWrite(viPNA, "CALC1:PAR:DEF MY_S11,S11")

If (status < VI_SUCCESS) Then HandleVISAError

End If

strReply = ""

' Get the catalog of all the trace numbers currently active

' in Window 1.

status = myGPIBWrite(viPNA, "DISP:WIND1:CAT?")

If (status < VI_SUCCESS) Then HandleVISAError

status = myGPIBRead(viPNA, strReply)

If (status < VI_SUCCESS) Then HandleVISAError

' If a trace number 4 already exists in Window 1, then this

' will remove it.

If InStr(strReply, "4") > 0 Then

status = myGPIBWrite(viPNA, "DISP:WIND1:TRAC4:DEL")

If (status < VI_SUCCESS) Then HandleVISAError

End If

' Set trace number 4 to MY_S11.

status = myGPIBWrite(viPNA, "DISP:WIND1:TRAC4:FEED MY_S11")

If (status < VI_SUCCESS) Then HandleVISAError

' Set up trace view so we are viewing only the data trace.

status = myGPIBWrite(viPNA, "DISP:WIND1:TRAC4 ON")

If (status < VI_SUCCESS) Then HandleVISAError

status = myGPIBWrite(viPNA, "DISP:WIND1:TRAC4:MEM OFF")

If (status < VI_SUCCESS) Then HandleVISAError

' Select MY_S11 as the measurement to be used for the

' Confidence Check.

status = myGPIBWrite(viPNA, "SENS1:CORR:CCH:PAR MY_S11")

If (status < VI_SUCCESS) Then HandleVISAError

' Acquire the S11 confidence check data from ECal Module A

' into the memory buffer (asking for an OPC reply when it's done).

status = myGPIBWrite(viPNA, "SENS1:CORR:CCH:ACQ ECAL1;*OPC?")

If (status < VI_SUCCESS) Then HandleVISAError

' The PNA sends an OPC reply ("+1") when the confidence data

' acquisition into memory is complete, so this Read is waiting on

' the reply until it is received.

status = myGPIBRead(viPNA, strReply)

If (status < VI_SUCCESS) Then HandleVISAError

' Turn on trace math so the trace shows data divided by memory.

' You can be confident the S11 calibration is reasonably good if

' the displayed trace varies no more than a few tenths of a dB

' from 0 dB across the entire span.

status = myGPIBWrite(viPNA, "CALC1:MATH:FUNC DIV")

If (status < VI_SUCCESS) Then HandleVISAError

End Sub

Private Sub cmdQuit_Click()

' Turn off trace math

status = myGPIBWrite(viPNA, "CALC1:MATH:FUNC NORM")

If (status < VI_SUCCESS) Then HandleVISAError

' Conclude the confidence check to set the ECal module

' back to it's idle state.

status = myGPIBWrite(viPNA, "SENS1:CORR:CCH:DONE")

If (status < VI_SUCCESS) Then HandleVISAError

' Close the resource manager session (which also closes

' the session to the PNA).

If defRM <> 0 Then Call viClose(defRM)

' End the program

End

End Sub

Private Function myGPIBWrite(ByVal viHandle As Long, ByVal strOut As String) As Long

' The "+ Chr$(10)" appends an ASCII linefeed character to the output, for

' terminating the write transaction.

myGPIBWrite = viVPrintf(viHandle, strOut + Chr$(10), 0)

End Function

Private Function myGPIBRead(ByVal viHandle As Long, strIn As String) As Long

myGPIBRead = viVScanf(viHandle, "%t", strIn)

End Function

Sub HandleVISAError()

Dim strVisaErr As String * 200

Call viStatusDesc(defRM, status, strVisaErr)

MsgBox "*** Error : " + strVisaErr, vbExclamation

End

End Sub


Create and Cal a VMC Measurement

Create and Calibrate a VMC Measurement

This VB Script example creates and calibrates a Vector mixer measurement. To run this example without modification you need the following:

  • A Mixer setup file saved on the PNA: C:\Program Files\Agilent\Network Analyzer\Documents\Mixer\MyMixer.mxr.

  • If the mixer file uses an external LO source, it must also be attached and configured.

  • An ECAL module that covers the frequency range of the measurement.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example. However, some modification may be necessary to make the program run on a traditional GPIB Interface.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as VMC.vbs. Learn how to setup and run the macro.

Dim app
Dim scpi
' Create / Get the PNA application.
Set app = CreateObject("AgilentPNA835x.Application")
Set scpi = app.ScpiStringParser
'---Create a Vector Mixer Measurement
'First, delete all measurements on the channel
scpi.Execute "CALC:PAR:DEL:ALL"
'Create a forward scalar mixer measurement and configure
'it in channel 1.
'The first parameter is a unique identifying string
'(specified by the user) to allow subsequent
'commands to be directed at this specific measurement.
SCPI.Execute "CALC:CUST:DEF ""My VC21"", ""FCA.VMCMeas"""
'Setup the new measurement as the 2nd trace in the active window
SCPI.Execute "DISP:WIND:TRAC2:FEED ""My VC21"""
'Make the new trace the active measurement
SCPI.Execute "CALC:PAR:SEL ""My VC21"""
'The parameters of the mixer measurement can now be configured.
'This can be done by either using the SENS:MIX commands
'for each of the parameters or by loading a mixer setup file.
'This example loads a mixer setup file. The path name
'for the mixer file may be loaded from other mapped drives.
SCPI.Execute "SENS:MIXer:Load ""C:\Program Files\Agilent\Network Analyzer\Documents\Mixer\MyMixer.mxr"""

'--------------Perform A Vector Mixer Calibration-------------
'Initialize an VMC guided calibration for session number 6
SCPI.Execute "SENS:CORR:COLL:SESS6:INIT ""VMC"""
'This sets the VMC operation to full system cal as opposed to
'performing a mixer characterization only.
SCPI.Execute "SENS:CORR:COLL:SESS6:VMC:OPER ""CAL"""
'This example uses ECal for the 2-port cal portion of the procedure
'To use a mechanical kit you will have to use the following command:
'SCPI.Execute "SENS:CORR:COLL:SESS6:SMC:TWOPort:OPTion""MECH"""
SCPI.Execute "SENS:CORR:COLL:SESS6:VMC:TWOPort:OPTion ""ECAL"""
'If you select the mechanical method then you also have to
'specify the connector types and the cal kits for each of the ports.
'The comments below show an example of how that is done:
'SCPI.Execute "SENS:CORR:COLL:SESS6:CONN:PORT1:SEL ""APC 3.5 male"""
'SCPI.Execute "SENS:CORR:COLL:SESS6:CONN:PORT2:SEL ""APC 3.5 female"""
'SCPI.Execute "SENS:CORR:COLL:SESS6:CKIT:PORT1:SEL ""85052D"""
'SCPI.Execute "SENS:CORR:COLL:SESS6:CKIT:PORT2:SEL ""85052D"""
'Choose the between ECal or Mechanical calibration for the
'Mixer Characterization portion of the VMC cal.
SCPI.Execute "SENS:CORR:COLL:SESS6:VMC:MIX:CHAR:CAL:OPT ""ECAL"""
'This command sets the port mapping for the ECal to be used
'during the Mixer Characterization portion of the VMC cal.
'It is a required command if in the previous command the option
'was set to 'ECAL'. The only valid port maps are either 'A1'
'or 'B1'.
SCPI.Execute "SENS:CORR:COLL:SESS6:VMC:MIX:ECAL:PORT 1, ""A1"""
'Specify the ECal module and the ECal characterization for the
'two port calibration portion of this session. FCA calibrations
'currently only support ECal module number 1. In this example
'the factory characterization is used by specifying 0 for the
'characterization number.
SCPI.Execute "SENS:CORR:COLL:SESS6:VMC:TWOP:ECAL:CHAR 1,0"
'Specify the ECal module and the ECal characterization for the
'Mixer Characterization portion of this session. FCA calibrations
'currently only support ECal module number 1. In this example
'the factory characterization is used by specifying 0 for the
'characterization number.
SCPI.Execute "SENS:CORR:COLL:SESS6:VMC:MIX:ECAL:CHAR 1,0"
'Specify the thru measurement method. This applies to both ECal
'and mechanical calibrations. For ECal 'DEFAULT' will use the ECal
'thru. Other choices may be used depending on the genders and types
'of the connectors on the test interface.
SCPI.Execute "SENS:CORR:COLL:SESS6:VMC:TWOP:METH ""DEFAULT"""
'Omit the isolation part of the 2-port cal
SCPI.Execute "SENS:CORR:COLL:SESS6:VMC:TWOP:OMIT 1"
'Turn on auto orientation for the ECal
SCPI.Execute "SENS:CORR:COLL:SESS6:VMC:TWOP:ECAL:ORI:STATE 1"

'Tell the wizard to generate and report the number of steps in this
'cal session
Dim steps
Dim desc
'Determine the number of steps required to complete the calibration.
'First send the write command, then the query.
SCPI.Execute "SENS:CORR:COLL:SESS6:STEP"
steps = SCPI.Execute ("SENS:CORR:COLL:SESS6:STEP?")
For i = 1 To steps
'Display the prompt for each step
desc = SCPI.Execute ("SENS:CORR:COLL:SESS6:DESC? " & CStr(i))
MsgBox (desc)
'Perform the measurement for each step
SCPI.Execute "SENS:CORR:COLL:SESS6:ACQ " & CStr(i)
Next
Dim calset
'Finish the cal and save the calset
calset = SCPI.Execute ("SENS:CORR:COLL:SESS6:SAVE?")
Msgbox ("VMC Cal Complete!")


Create and Cal an SMC Measurement

This Visual Basic example creates and calibrates a scalar mixer measurement.

To run this example without modification you need the following:

  • A Mixer setup file saved on the PNA: C:\Program Files\Agilent\Network Analyzer\Documents\Mixer\MyMixer.mxr.

  • If the mixer file uses an external LO source, it must also be attached and configured.

  • An ECAL module that covers the frequency range of the measurement.

  • A power meter must be attached to the PNA. If this example is run in the PNA, the power meter does not need to be attached using a GPIB/USB interface.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example. However, some modification is necessary to make the program run on a traditional GPIB Interface. For example, during the power meter portion of this calibration, scpi.Execute will not process a command until the power meter routine has completed. Traditional GPIB would require a serial polling technique to ensure the routine has completed before proceeding.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as SMC.vbs. Learn how to setup and run the macro.

Dim app
Dim scpi
' Create / Get the PNA application.
Set app = CreateObject("AgilentPNA835x.Application")
Set scpi = app.ScpiStringParser
'---Create a Scalar Mixer Forward Measurement
'First, delete all measurements on the channel
scpi.Execute "CALC:PAR:DEL:ALL"
'Create a forward scalar mixer measurement and configure it in
'channel 1. The first parameter is a unique
'identifying string (specified by the user) to allow subsequent
'commands to be directed at this specific measurement.
scpi.Execute "CALC:CUST:DEF ""My SC21"", ""SMC_Forward.SMC_ForwardMeas"""
'For reverse measurements, use the following:
'scpi.Execute "CALC:CUST:DEF ""My SC12"", ""SMC_Reverse.SMC_ReverseMeas"""
'Setup the new measurement as the 2nd trace in the active window
scpi.Execute "DISP:WIND:TRAC2:FEED ""My SC21"""
'Make the new trace the active measurement
scpi.Execute "CALC:PAR:SEL ""My SC21"""
'The parameters of the mixer measurement can now be configured.
'This can be done by either using the individual SENS:MIX commands
'for each of the parameters or by loading a mixer setup file. This
'example loads a mixer setup file. The path name
'for the mixer file may be loaded from other mapped drives
scpi.Execute "SENS:MIXer:Load ""C:\Program Files\Agilent\Network Analyzer\Documents\Mixer\MyMixer.mxr"""
'--------------Perform A Scalar Mixer Calibration----------------------
'Initialize an SMC guided calibration for session number 6
scpi.Execute "SENS:CORR:COLL:SESS6:INIT ""SMC"""
'Select to use an ECal for the 2-port cal portion of the procedure
'To use a mechanical kit you will have to use the following command:
'scpi.Execute "SENS:CORR:COLL:SESS6:SMC:TWOPort:OPTion ""MECH"""
scpi.Execute "SENS:CORR:COLL:SESS6:SMC:TWOPort:OPTion ""ECAL"""
'If you select the mechanical method then you also have to
'specify the connector types and the cal kits for each of the ports.
'The comments below show an example of how that is done:
'scpi.Execute "SENS:CORR:COLL:SESS6:CONN:PORT1:SEL ""APC 3.5 male"""
'scpi.Execute "SENS:CORR:COLL:SESS6:CONN:PORT2:SEL ""APC 3.5 female"""
'scpi.Execute "SENS:CORR:COLL:SESS6:CKIT:PORT1:SEL ""85052D"""
'scpi.Execute "SENS:CORR:COLL:SESS6:CKIT:PORT2:SEL ""85052D"""
'Specify the ECal module and the ECal characterization for this
'session. FCA calibrations currently only support ECal module
'number 1. In this example the factory characterization is used
'by specifying 0 for the characterization number.
scpi.Execute "SENS:CORR:COLL:SESS6:SMC:ECAL:CHAR 1,0"
'Specify the thru measurement method. This applies to both ECal
'and mechanical calibrations. For ECal 'DEFAULT' will use the ECal
'thru. Other choices may be used depending on the genders and types
'of the connectors on the test interface.
scpi.Execute "SENS:CORR:COLL:SESS6:SMC:TWOP:METH ""DEFAULT"""
'Omit the isolation part of the 2-port cal
scpi.Execute "SENS:CORR:COLL:SESS6:SMC:TWOP:OMIT 1"
'Turn on auto orientation for the ECal
scpi.Execute "SENS:CORR:COLL:SESS6:SMC:TWOP:ECAL:ORI:STATE 1"
'Set the Source port for the power cal to 1. If the
'measurement is an SMC Forward the valid port settings are '1' and
''BOTH' and if the measurement is an SMC Reverse, the valid port settings
'are '2' and 'BOTH'.
scpi.Execute "SENS:CORR:COLL:SESS6:SMC:PWRC:SRCP ""1"""
'Tell the wizard to generate and report the number of steps in this
'cal session
Dim steps
Dim desc
'Determine the number of steps required to complete the calibration.
'First send the write command, then the query.
scpi.Execute "SENS:CORR:COLL:SESS6:STEP"
steps = scpi.Execute ("SENS:CORR:COLL:SESS6:STEP?")
For i = 1 To steps
'Display the prompt for each step
desc = scpi.Execute ("SENS:CORR:COLL:SESS6:DESC? " & CStr(i))
MsgBox (desc)
'Perform the measurement for each step
scpi.Execute "SENS:CORR:COLL:SESS6:ACQ " & CStr(i)
Next
Dim calset
'Finish the cal and save the calset
calset = scpi.Execute ("SENS:CORR:COLL:SESS6:SAVE?")
Msgbox ("SMC Cal Complete!")


Create an SMC Fixed Output Meas

Create an SMC Fixed Output Measurement

This VB Script example creates a calibrated SMC fixed output measurement using a controlled LO. Then a single sweep is taken and data is retrieved. You can run a VBScript (*.vbs) program from the PNA using Macros.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object.

Fixed output measurements are only supported on SMC (not VMC) measurements. Fixed output measurements require that an external LO source be sweeping and synchronized with the PNA source. FCA can perform this synchronization using the external source configuration settings.

The fastest, and recommended, method of controlling the LO source is Hardware List (BNC) triggering mode. However, in this mode, FCA channels will not respond to manual triggers. Therefore, the example uses the following mechanism to trigger a sweep:

Write "SENS:SWE:MODE HOLD" 'place channel 1 in HOLD mode
Write "INIT:CONT ON" 'place PNA in internal trigger mode
Write "SENS:SWE:GRO:COUNT 1" 'specify that the group count is 1 sweep
Write "SENS:SWE:MODE GROUPS" 'execute group count (1 sweep)
Write "*OPC?" 'wait until the sweep is complete
Read

Both VMC and SMC measurements require that mixer parameters be setup before making the measurement. The mixer parameters are not applied until calling SENS:MIX:CALC

You can also setup the mixer parameters using SENS:MIX:LOAD. With this interface, the specified mixer file is loaded and immediately applied.

To run this program, copy the following code into a text editor and save it as a *.vbs file.

option explicit

' Setup infrastructure to use the SCPI over COM
dim app
set app = createobject("Agilentpna835x.application")
dim p
set p = app.scpistringparser
dim returnStr

sub Write (command)
if len(returnStr) <> 0 then
err.Raise 55,"Write","Query Unterminated"
end if
returnStr = p.parse(command)
end sub

sub WriteIgnoreError(command)
returnStr = p.Execute(command)
p.Parse("SYST:ERR?") ' clear error queue
end sub

function Read
if len(returnStr) = 0 then
err.Raise 55,"Read","Bad read"
end if
Read = returnStr
returnStr = ""
end function

Write "SYST:PRES"

' When programming in remote mode, hold mode is recommended
Write "SENS:SWE:MODE HOLD"

' Select calibration. Use execute so that errors get ignored
WriteIgnoreError "SENS:CORR:CSET:GUID '{C9080B34-EF1F-4ED5-B07D-250B45962B99}'"

' Delete the standard measurement
Write "CALC:PAR:DEL:ALL"

' Create an SC21 measurement
Write "CALC:CUST:DEF 'MySMC', 'SMC_Forward.SMC_ForwardMeas'"
Write "DISP:WIND:TRACE:FEED 'MySMC'"
Write "CALC:PAR:SEL 'MySMC'"
Write "CALC:CUST:MOD 'SC21'"

' Set number of points to 11
Write "SENS:SWE:POIN 11 "

' Setup the mixer parameters for a swept LO, fixed output measurement
Write "SENS:MIX:INP:FREQ:START 200e6"
Write "SENS:MIX:INP:FREQ:STOP 700e6"
Write "SENS:MIX:LO:FREQ:MODE Swept"
Write "SENS:MIX:OUTPUT:FREQ:FIX 3.4e9"
Write "SENS:MIX:OUTP:FREQ:SID HIGH"
Write "SENS:MIX:INP:POW -17"
Write "SENS:MIX:LO:POW 10"
' Specify the LO name, for controlled LO.
' This name is setup in the External Source Config Dialog
Write "SENS:MIX:LO:NAME '8360'"
' The CALC method calculates the LO frequency from the other parameters,
' It also applies the mixer parameters to the channel.
Write "SENS:MIX:CALC LO_1"

' Create an S11 in the same channel
Write "CALC:CUST:DEF 'MyS11', 'SMC_Forward.SMC_ForwardMeas'"
Write "DISP:WIND:TRACE2:FEED 'MyS11'"
Write "CALC:PAR:SEL 'MyS11'"
Write "CALC:CUST:MOD 'S11'"

' Create an IPwr in the same channel
Write "CALC:CUST:DEF 'MyIPwr', 'SMC_Forward.SMC_ForwardMeas'"
Write "DISP:WIND:TRACE3:FEED 'MyIPwr'"
Write "CALC:PAR:SEL 'MyIPwr'"
Write "CALC:CUST:MOD 'IPwr'"

' Create an OPwr in the same channel
Write "CALC:CUST:DEF 'MyOPwr', 'SMC_Forward.SMC_ForwardMeas'"
Write "CALC:PAR:SEL 'MyOPwr'"
Write "DISP:WIND:TRACE4:FEED 'MyOPwr'"
Write "CALC:CUST:MOD 'OPwr'"

' Perform a single sweep, synchronously. When *OPC returns, the sweep is done
Write "SENS:SWE:GRO:COUN 1"
Write "SENS:SWE:MODE GROUPS"
Write "*OPC?"
Read

' Retrieve the SC21 data
Write "CALC:PAR:SEL 'MySMC'"
Write "CALC:DATA? SDATA"
dim data
data = Read()
wscript.echo(data)

'Retrieve the S11 data
Write "CALC:PAR:SEL 'MyS11'"
Write "CALC:DATA? SDATA"
data = Read()
wscript.echo(data)


Getting and Putting Data using SCPI

This Visual Basic Program does the following:

  • Reads data from the analyzer

  • Puts the data back into memory

  • To see the data on the analyzer after running the program, from the front panel click:
    Trace - Math/Memory - Memory Trace

To run this program, you need:

  • An established GPIB interface connection

See Other SCPI Example Programs

Note: To change the read and write location of data, removing the comment from the beginning of ONE of the lines, and replace the comment in the beginning of the SDATA and SMEM lines.

Private Sub ReadWrite_Click()
Dim i As Integer
Dim t As Integer
Dim q As Integer
Dim dat As String
Dim cmd As String
Dim datum() As Double

GPIB.Configure
GPIB.Write "SYSTem:PRESet;*wai"

'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"

'Read the number of data points
GPIB.Write "SENSe1:SWEep:POIN?"
numpts = GPIB.Read

'Turn continuous sweep off
GPIB.Write "INITiate:CONTinuous OFF"

'Take a sweep
GPIB.Write "INITiate:IMMediate;*wai"

'Ask for the Data

'PICK ONE OF THESE LOCATIONS TO READ
'GPIB.Write "CALCulate:DATA? FDATA" 'Formatted Meas
'GPIB.Write "CALCulate:DATA? FMEM" 'Formatted Memory
GPIB.Write "CALCulate:DATA? SDATA" 'Corrected, Complex Meas
'GPIB.Write "CALCulate:DATA? SMEM" 'Corrected, Complex Memory
'GPIB.Write "CALCulate:DATA? SCORR1" 'Error-Term Directivity

'Number of values returned per data point
'q = 1 ' Pick this if reading FDATA or FMEM
q = 2 ' Otherwise pick this

'Parse the data
ReDim datum(q, numpts)
For i = 0 To numpts - 1
  For t = 0 To q - 1
  'Read the Data
  dat = GPIB.Read(20)
  'Parse it into an array
  datum(t, i) = Val(dat)
  Next t
Next i

'PUT THE DATA BACK IN
GPIB.Write "format ascii"

'PICK ONE OF THESE LOCATIONS TO PUT THE DATA
'cmd = "CALCulate:DATA FDATA," 'Formatted Meas
'cmd = "CALCulate:DATA FMEM," 'Formatted Memory
'cmd = "CALCulate:DATA SDATA," 'Corrected, Complex Meas
cmd = "CALCulate:DATA SMEM," 'Corrected, Complex Memory
'cmd = "CALCulate:DATA SCORR1," 'Error-Term Directivity

For i = 0 To numpts - 1
  For t = 0 To q - 1
  If i = numpts - 1 And t = q - 1 Then
  cmd = cmd & Format(datum(t, i))
  Else
  cmd = cmd & Format(datum(t, i)) & ","
  End If
  Next t
Next i

GPIB.Write cmd
End Sub


Establish a VISA Session

This Visual Basic program demonstrates how to send a SCPI command using VISA and the Agilent IO libraries. To run this program, you need:

  • Your PC and PNA both connected to a LAN (for communicating with each other).

  • The SICL and VISA components of Agilent’s I/O Libraries software installed on your PC. Both are included when you install the software, unless you already have another vendor's VISA installed. Then specify Full SICL and VISA installation to overwrite the other vendor's VISA.

  • The module visa32.bas added to your VB project. After you install VISA, the module will be located at C:\VXIPNP\WINNT (or equivalent)\INCLUDE\Visa32.bas

  • A form with two buttons: cmdRun and cmdQuit.

  • Your PC configured to be a VISA LAN Client, and the SICL Server capability enabled on the PNA. See Configure for VISA and SICL

See Other SCPI Example Programs

Note: This example is a piece of a larger VISA program that performs a source power calibration.

'Session to VISA Default Resource Manager
Private defRM As Long
'Session to PNA
Private viPNA As Long
'VISA function status return code
Private status As Long

Private Sub Form_Load()
defRM = 0
End Sub

Private Sub cmdRun_Click()
' String to receive data from the PNA.
' Dimensioned large enough to receive scalar comma-delimited values
' for 21 frequency points (20 ASCII characters per point)
Dim strReply As String * 420

' Open the VISA default resource manager
status = viOpenDefaultRM(defRM)
If (status < VI_SUCCESS) Then HandleVISAError

' Open a VISA session (viPNA) to the SICL LAN server
' at “address 16” on the PNA pointed to by the “GPIB0”
' VISA LAN Client on this PC.
' CHANGE GPIB0 TO WHATEVER YOU PNA IS SET TO
status = viOpen(defRM, "GPIB0::16::INSTR", 0, 0, viPNA)
If (status < VI_SUCCESS) Then HandleVISAError

' Need to set the VISA timeout value to give all our calls to
' myGPIBRead sufficient time to complete before a timeout
' error occurs.
' For this example, let's try setting the limit to
' 30000 milliseconds (30 seconds).
status = viSetAttribute(viPNA, VI_ATTR_TMO_VALUE, 30000)
If (status < VI_SUCCESS) Then HandleVISAError

' Preset the PNA
status = myGPIBWrite(viPNA, "SYST:PRES")
If (status < VI_SUCCESS) Then HandleVISAError

' Print the data using a message box
MsgBox strReply
End Sub

Private Sub cmdQuit_Click()
' Close the resource manager session (which also closes
' the session to the PNA).
If defRM <> 0 Then Call viClose(defRM)

' End the program
End
End Sub

Private Function myGPIBWrite(ByVal viHandle As Long, ByVal strOut As String) As Long
' The "+ Chr$(10)" appends an ASCII linefeed character to the
' output, for terminating the write transaction.
myGPIBWrite = viVPrintf(viHandle, strOut + Chr$(10), 0)
End Function

Private Function myGPIBRead(ByVal viHandle As Long, strIn As String) As Long
myGPIBRead = viVScanf(viHandle, "%t", strIn)
End Function

Sub HandleVISAError()
Dim strVisaErr As String * 200
Call viStatusDesc(defRM, status, strVisaErr)
MsgBox "*** Error : " + strVisaErr, vbExclamation
End
End Sub


See Other SCPI Example Programs

Status Reporting using SCPI

This Visual Basic program demonstrates two methods of reading the analyzer's status registers:

  • Polled Bit Method - reads the Limit1 register continuously.

  • SRQ Method - enables an interrupt of the program when bit 6 of the status byte is set to 1. The program then queries registers to determine if the limit line failed.

To run this program, you need:

  • An established GPIB interface connection

  • A form with two buttons: Poll and SRQ Method

  • A means of causing the limit line to fail, assuming it passes initially.

Private Sub Poll_Click()
' POLL THE BIT METHOD
' Clear status registers
GPIB.Write "*CLS"

'Loop FOREVER
Do
DoEvents
GPIB.Write "STATus:QUEStionable:LIMit1:EVENt?"
onn = GPIB.Read
Loop Until onn = 2

MsgBox "Limit 1 Failed "
End Sub

Private Sub SRQMethod_Click()
'SRQ METHOD
GPIB.Write "SYSTem:PRESet"
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"
'slow down the trace
GPIB.Write "SENS:BWID 150"

'Setup limit line
GPIB.Write "CALC:LIM:DATA 2,3e9,6e9,-2,-2"
GPIB.Write "CALC:LIMit:DISP ON"
GPIB.Write "CALC:LIMit:STATe ON"

' Clear status registers.
GPIB.Write "*CLS;*wai"
' Clear the Service Request Enable register.
GPIB.Write "*SRE 0"
' Clear the Standard Event Status Enable register.
GPIB.Write "*ESE 0"

' Enable questionable register, bit(10) to report to the status byte.
GPIB.Write "STATus:QUEStionable:ENABle 1024"

' Enable the status byte register bit3 (weight 8) to notify controller
GPIB.Write "*SRE 8"

' Enable the onGPIBNotify event
GPIB.NotifyMask = cwGPIBRQS
GPIB.Notify
End Sub

----------------------------------------------------
Private Sub GPIB_OnGPIBNotify(ByVal mask As Integer)
' check to see what failed
' was it the analyzer?
GPIB.Write "*STB?"
onn = GPIB.Read
If onn <> 0 Then
' If yes, then was it the questionable register?
GPIB.Write "STATus:QUEStionable:EVENt?"
onn = GPIB.Read
' Determine if the limit1 register, bit 8 is set.
If onn = 1024 Then
'if yes, then was it trace 1?
GPIB.Write "STAT:QUES:LIMIT1:EVEN?"
onn = GPIB.Read
If onn = 2 Then MsgBox ("Limit Line1 Failed")
End If
End If
End Sub


Create New Cal Kit using SCPI

When creating new cal kits programmatically, the order in which cal kit commands are sent can be important.

For example to create a kit with opens, shorts, loads, and thrus. Be sure to use the following sequence for each newly defined standard.

  1. Programmatically select the standard number

  2. Programmatically select the standard type.

  3. Program the cal standard's values.

  4. Repeat steps 1, 2, 3 for additional new standards being defined.

10   !

20   !

30   ! This example program demonstrates how to create

40   ! new PNA calibration kits.

50   !

60   ! 1) Select a kit not previously defined

70   ! 2) Define open, short, load, and thru cal standards

80   !    Note:  Each of the newly defined standards is assigned

90   !    a default connector name.  These default connector names

100  !    will be replaced in subsequent steps.

110  ! 3) Use the delete connector command to remove default

120  !    connector names.

130  ! 4) Add connectors.  Specify:

140  !      Start and Stop Freq

150  !      Z - Impedance

160  !      sex - MALE, FEMALE, NONE

170  !      media - COAX, WAVE

180  !      cutoff - Frequency for waveguide

190  ! 5) Assign the appropriate connector to each standard

200  ! 6) Modify the class assignments for the standards defined

210  ! 7) Verify the kit values

220  !

230  ! Additional Note:  After setting each new cal kit value, it is

240  ! recommended that the program periodically perform queries to

250  ! verify the new values.

260  !

270  ! This will prevent program synchronization issues that can affect

280  ! final values stored within new cal kits.

290  !

300  !------------------------------------------------------------

310  !

320  ! Set up I/O path

330   ASSIGN @Na TO 716

340   DIM Calkname$[80],Conn$[80]

350   INTEGER Calkitnum

360  !

370   CLEAR SCREEN

380  !

390  !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

400  ! Designate the kit selection to be used for performing cal's

410   OUTPUT @Na;":sens:corr:ckit:count?"

420   ENTER @Na;Calkitnum

430   Calkitnum=Calkitnum+1

440   OUTPUT @Na;":sens:corr:coll:ckit "&VAL$(Calkitnum)

450  !

460  ! Name this kit with your own name

470   OUTPUT @Na;":sens:corr:coll:ckit:name ""Special 2.4 mm Model 85056"""

480  !

490  !

500   DISP "Defining kit std 1..."

510  ! Now set up standard #1

520   OUTPUT @Na;":sens:corr:coll:ckit:stan 1"

530   OUTPUT @Na;":sens:corr:coll:ckit:stan:type SHORT"

540   Get_std

550   OUTPUT @Na;":sens:corr:coll:ckit:stan:char coax"

560   OUTPUT @Na;":sens:corr:coll:ckit:stan:label ""My Short"""

570   Get_label

580  !

590   DISP "Defining kit std 2..."

600  ! Now set up standard #2

610   OUTPUT @Na;":sens:corr:coll:ckit:stan 2"

620   OUTPUT @Na;":sens:corr:coll:ckit:stan:type OPEN"

630   Get_std

640   OUTPUT @Na;":sens:corr:coll:ckit:stan:char coax"

650   OUTPUT @Na;":sens:corr:coll:ckit:stan:label ""My Open"""

660   Get_label

670  !

680   DISP "Defining kit std 3..."

690  ! Now set up standard #3

700   OUTPUT @Na;":sens:corr:coll:ckit:stan 3"

710   OUTPUT @Na;":sens:corr:coll:ckit:stan:type LOAD"

720   Get_std

730   OUTPUT @Na;":sens:corr:coll:ckit:stan:char coax"

740   OUTPUT @Na;":sens:corr:coll:ckit:stan:label ""My Fixed Load"""

750   Get_label

760  !

770   DISP "Defining kit std 4..."

780  ! Now set up standard #4

790   OUTPUT @Na;":sens:corr:coll:ckit:stan 4"

800   OUTPUT @Na;":sens:corr:coll:ckit:stan:type THRU"

810   Get_std

820   OUTPUT @Na;":sens:corr:coll:ckit:stan:char coax"

830   OUTPUT @Na;":sens:corr:coll:ckit:stan:label ""My Thru"""

840   Get_label

850  !

860   DISP "Defining kit std 5..."

870  ! Now set up standard #5

880   OUTPUT @Na;":sens:corr:coll:ckit:stan 5"

890   OUTPUT @Na;":sens:corr:coll:ckit:stan:type SLOAD"

900   Get_std

910   OUTPUT @Na;":sens:corr:coll:ckit:stan:char coax"

920   OUTPUT @Na;":sens:corr:coll:ckit:stan:label ""Sliding Load"""

930   Get_label

940  !

950   DISP "Defining kit std 6..."

960  ! Now set up standard #6

970  !

980   OUTPUT @Na;":sens:corr:coll:ckit:stan 6"

990   OUTPUT @Na;":sens:corr:coll:ckit:stan:type SHORT"

1000  Get_std

1010  OUTPUT @Na;":sens:corr:coll:ckit:stan:char coax"

1020  OUTPUT @Na;":sens:corr:coll:ckit:stan:label ""Short"""

1030  Get_label

1040 !

1050  DISP "Defining kit std 7..."

1060 ! Now set up standard #7

1070  OUTPUT @Na;":sens:corr:coll:ckit:stan 7"

1080  OUTPUT @Na;":sens:corr:coll:ckit:stan:type SHORT"

1090  Get_std

1100  OUTPUT @Na;":sens:corr:coll:ckit:stan:char coax"

1110  OUTPUT @Na;":sens:corr:coll:ckit:stan:label ""Short"""

1120  Get_label

1130 !

1140  DISP "Defining kit std 8..."

1150 ! Now set up standard #8

1160 !

1170  OUTPUT @Na;":sens:corr:coll:ckit:stan 8"

1190  OUTPUT @Na;":sens:corr:coll:ckit:stan:type ARBI"

1200  Get_std

1210  OUTPUT @Na;":sens:corr:coll:ckit:stan:char coax"

1220  OUTPUT @Na;":sens:corr:coll:ckit:stan:TZR 15;"

1230  OUTPUT @Na;":sens:corr:coll:ckit:stan:TZI -9;"

1240  OUTPUT @Na;":sens:corr:coll:ckit:stan:label ""Z Load"""

1250  Get_label

1260 !

1270 !

1280 !

1290 ! First remove any old connector names

1300  OUTPUT @Na;":sens:corr:coll:ckit:conn:del"

1310 ! Verify that no connectors are currently installed

1320  OUTPUT @Na;":sens:corr:coll:ckit:conn:cat?"

1330  ENTER @Na;Conn$

1340  PRINT "Verify empty list: ";Conn$

1350 !

1360 ! Define your new connectors

1370  OUTPUT @Na;":sens:corr:coll:ckit:conn:add ""PSC 2.4"",0HZ,999GHZ,50.0,MALE,COAX,0.0"

1380  OUTPUT @Na;":sens:corr:coll:ckit:conn:add ""PSC 2.4"",0HZ,999GHZ,50.0,FEMALE,COAX,0.0"

1390 !

1400 ! Verify that the new connectors are installed

1410  OUTPUT @Na;":sens:corr:coll:ckit:conn:cat?"

1420  ENTER @Na;Conn$

1430  PRINT "Verify new connectors: ";Conn$

1440  DISP ""

1450 !

1460  DISP "Defining conn std 1..."

1470 ! Now set up standard #1

1480  OUTPUT @Na;":sens:corr:coll:ckit:stan 1"

1490  Verify_std

1500  OUTPUT @Na;":sens:corr:coll:ckit:conn:snam ""PSC 2.4"",FEMALE,1"

1510  Print_connector

1520 !

1530  DISP "Defining conn std 2..."

1540 ! Now set up standard #2

1550  OUTPUT @Na;":sens:corr:coll:ckit:stan 2"

1560  Verify_std

1570  OUTPUT @Na;":sens:corr:coll:ckit:conn:snam ""PSC 2.4"",FEMALE,1"

1580  Print_connector

1590 !

1600  DISP "Defining conn std 3..."

1610 ! Now set up standard #3

1620  OUTPUT @Na;":sens:corr:coll:ckit:stan 3"

1630  Verify_std

1640  OUTPUT @Na;":sens:corr:coll:ckit:conn:snam ""PSC 2.4"",FEMALE,1"

1650  Print_connector

1660 !

1670  DISP "Defining conn std 4..."

1680 ! Now set up standard #4

1690  OUTPUT @Na;":sens:corr:coll:ckit:stan 4"

1700  Verify_std

1710  OUTPUT @Na;":sens:corr:coll:ckit:conn:snam ""PSC 2.4"",FEMALE,1"

1720  OUTPUT @Na;":sens:corr:coll:ckit:conn:snam ""PSC 2.4"",MALE,2"

1730  Print_connector

1740 !

1750  DISP "Defining conn std 5..."

1760 ! Now set up standard #5

1770  OUTPUT @Na;":sens:corr:coll:ckit:stan 5"

1780  OUTPUT @Na;":sens:corr:coll:ckit:stan:label ""Sliding Load"""

1790  Verify_std

1800  OUTPUT @Na;":sens:corr:coll:ckit:conn:snam ""PSC 2.4"",MALE,1"

1810  Print_connector

1820 !

1830  DISP "Defining conn std 6..."

1840 ! Now set up standard #6

1850 !

1860  OUTPUT @Na;":sens:corr:coll:ckit:stan 6"

1870  Verify_std

1880  OUTPUT @Na;":sens:corr:coll:ckit:conn:snam ""PSC 2.4"",MALE,1"

1890  Print_connector

1900 !

1910  DISP "Defining conn std 7..."

1920 ! Now set up standard #7

1930  OUTPUT @Na;":sens:corr:coll:ckit:stan 7"

1940  Verify_std

1950  OUTPUT @Na;":sens:corr:coll:ckit:conn:snam ""PSC 2.4"",MALE,1"

1960  Print_connector

1970 !

1980  DISP "Defining conn std 8..."

1990 ! Now set up standard #8

2000  OUTPUT @Na;":sens:corr:coll:ckit:stan 8"

2010  Verify_std

2020  OUTPUT @Na;":sens:corr:coll:ckit:conn:snam ""PSC 2.4"",MALE,1"

2030  Print_connector

2040 !

2050  DISP "Class assignments..."

2060 !

2070 ! Designate the "order" associated with measuring the standards

2080 !

2090 !    Set Port 1, 1st standard measured to be standard #2

2100  OUTPUT @Na;":sens:corr:coll:ckit:order1 2"

2110 !    Set Port 1, 2nd standard measured to be standard #1

2120  OUTPUT @Na;":sens:corr:coll:ckit:order2 1,6,7"

2130 !    Set Port 1, 3nd standard measured to be standard #3 and #5

2140  OUTPUT @Na;":sens:corr:coll:ckit:order3 3,5"

2150 !    Set Port 1, 4th standard measured to be standard #4

2160  OUTPUT @Na;":sens:corr:coll:ckit:order4 4"

2170 !

2180 !    Set Port 2, 1st standard measured to be standard #2

2190  OUTPUT @Na;":sens:corr:coll:ckit:order5 2"

2200 !    Set Port 2, 2nd standard measured to be standard #1

2210  OUTPUT @Na;":sens:corr:coll:ckit:order6 1,6,7"

2220 !    Set Port 2, 3nd standard measured to be standard #3 and #6

2230  OUTPUT @Na;":sens:corr:coll:ckit:order7 3,5"

2240 !    Set Port 2, 4th standard measured to be standard #4

2250  OUTPUT @Na;":sens:corr:coll:ckit:order8 4"

2260 !

2270 !    Set Port 1, 1st standard

2280  OUTPUT @Na;":sens:corr:coll:ckit:olabel1 ""MyOpen1"""

2290 !    Set Port 1, 2nd standard

2300  OUTPUT @Na;":sens:corr:coll:ckit:olabel2 ""MyShorts1"""

2310 !    Set Port 1, 3nd standard

2320  OUTPUT @Na;":sens:corr:coll:ckit:olabel3 ""MyLoads1"""

2330 !    Set Port 1, 4th standard measured to be standard #4

2340  OUTPUT @Na;":sens:corr:coll:ckit:olabel4 ""MyThru1"""

2350 !

2360 !    Set Port 2, 1st standard

2370  OUTPUT @Na;":sens:corr:coll:ckit:olabel5 ""MyOpen2"""

2380 !    Set Port 2, 2nd standard

2390  OUTPUT @Na;":sens:corr:coll:ckit:olabel6 ""MyShorts2"""

2400 !    Set Port 2, 3nd standard

2410  OUTPUT @Na;":sens:corr:coll:ckit:olabel7 ""MyLoads2"""

2420 !    Set Port 2, 4th standard

2430  OUTPUT @Na;":sens:corr:coll:ckit:olabel8 ""MyThrus2"""

2440 !

2450  BEEP

2460  DISP "Done!"

2470  END

2480  SUB Get_label

2490    OUTPUT 716;":sens:corr:coll:ckit:stan:label?"

2500    ENTER 716;Label$

2510    PRINT Label$

2520  SUBEND

2530 !

2540  SUB Get_std

2550    OUTPUT 716;":sens:corr:coll:ckit:stan:type?"

2560    ENTER 716;Type$

2570    PRINT Type$

2580  SUBEND

2590 !

2600  SUB Print_connector

2610    DIM Nam$[40]

2620    OUTPUT 716;":sens:corr:coll:ckit:conn:sname?"

2630    ENTER 716;Nam$

2640    PRINT Nam$

2650  SUBEND

2660 !

2670  SUB Verify_std

2680    OUTPUT 716;":sens:corr:coll:ckit:stan:label?"

2690    ENTER 716;Label$

2700  SUBEND

2710 !


Modify a Calibration Kit using SCPI

This Visual Basic program:

  • Modifies Calibration kit number 3

  • Completely defines standard #4 (thru)

To run this program, you need:

  • An established GPIB interface connection

See Other SCPI Example Programs

'Modifying cal kit number 3
Calkitnum = 3

'Designate the kit selection to be used for performing cal's
GPIB.Write "SENSe:CORRection:COLLect:CKIT:SELect " & Val(Calkitnum)

'Reset to factory default values.
GPIB.Write "SENSe:CORRection:COLLect:CKIT:RESet " & Val(Calkitnum)

'Name this kit with your own name
GPIB.Write "SENSe:CORRection:COLLect:CKIT:NAME 'My Cal Kit'"

'Assign standard numbers to calibration classes
'Set Port 1, class 1 (S11A) to be standard #8
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer1 8"
'Set Port 1, class 2 (S11B) to be standard #7
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer2 7"
'Set Port 1, class 3 (S11C) to be standard #3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer3 3"
'Set Port 1, class 4 (S21T) to be standard #4
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer4 4"
'Set Port 2, class 1 (S22A) to be standard #8
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer5 8"
'Set Port 2, class 2 (S22B) to be standard #7
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer6 7"
'Set Port 2, class 3 (S22C) to be standard #3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer7 3"
'Set Port 2, class 4 (S12T) to be standard #4
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer8 4"

'Set up Standard #4 completely
'Select Standard #4; the rest of the commands act on it
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard 4"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:FMIN 300KHz"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:FMAX 9GHz"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance 50"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:DELay 1.234 ns"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:LOSS 23e6"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C0 0"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C1 1"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C2 2"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C3 3"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L0 10"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L1 11"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L2 12"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L3 13"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:LABel 'My Special Thru'"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:TYPE THRU"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:CHARacteristic Coax"


GPIB using Visual C++

See Other SCPI Example Programs

/*
* This example assumes the user's PC has a National Instruments GPIB
 board. The example is comprised of three basic parts:
*
* 1. Initialization
* 2. Main Body
* 3. Cleanup
*
* The Initialization portion consists of getting a handle to the
 PNA and then doing a GPIB clear of the PNA.
*
* The Main Body consists of the PNA SCPI example.
*
* The last step, Cleanup, releases the PNA for front panel control.
*/

#include <stdio.h>
#include <stdlib.h>

/*
* Include the WINDOWS.H and DECL-32.H files. The standard Windows
* header file, WINDOWS.H, contains definitions used by DECL-32.H
 and
* DECL-32.H contains prototypes for the NI GPIB routines and constants.
*/
#include <windows.h>
#include "decl-32.h"

#define ERRMSGSIZE 1024 // Maximum size of SCPI command string
#define ARRAYSIZE 1024 // Size of read buffer

#define BDINDEX 0 // Board Index of GPIB board
#define PRIMARY_ADDR_OF_PNA 16 // GPIB address of PNA
#define NO_SECONDARY_ADDR 0 // PNA has no Secondary address
#define TIMEOUT T10s // Timeout value = 10 seconds
#define EOTMODE 1 // Enable the END message
#define EOSMODE 0 // Disable the EOS mode

int pna;
char ValueStr[ARRAYSIZE + 1];
char ErrorMnemonic[21][5] = {"EDVR", "ECIC", "ENOL",
 "EADR", "EARG",
"ESAC", "EABO", "ENEB", "EDMA",
 "",
"EOIP", "ECAP", "EFSO", "",
 "EBUS",
"ESTB", "ESRQ", "", "",
 "", "ETAB"};

void GPIBWrite(char* SCPIcmd);
char *GPIBRead(void);
void GPIBCleanup(int Dev, char* ErrorMsg);

int main()
{

char *opc;
char *result;
char *value;

/*
* =========================================
* INITIALIZATION SECTION
* =========================================
*/

/*
* The application brings the PNA online using ibdev. A device handle,pna,
 is returned and is used in all subsequent calls to the PNA.
*/
pna = ibdev(BDINDEX, PRIMARY_ADDR_OF_PNA, NO_SECONDARY_ADDR,
TIMEOUT, EOTMODE, EOSMODE);
if (ibsta & ERR)
{
printf("Unable to open handle to PNA\nibsta = 0x%x iberr =
 %d\n",
ibsta, iberr);
return 1;
}

/*
* Do a GPIB Clear of the PNA. If the error bit ERR is set in ibsta,
 call GPIBCleanup with an error message.
*/
ibclr (pna);
if (ibsta & ERR)
{
GPIBCleanup(pna, "Unable to perform GPIB clear of the PNA");
return 1;
}

/*
* =========================================
* MAIN BODY SECTION
* =========================================
*/

// Reset the analyzer to instrument preset
GPIBWrite("SYSTem:FPRESET");

// Create S11 measurement
GPIBWrite("CALCulate1:PARameter:DEFine 'My_S11',S11");

// Turn on Window #1
GPIBWrite("DISPlay:WINDow1:STATe ON");

// Put a trace (Trace #1) into Window #1 and 'feed' it from the
 measurement
GPIBWrite("DISPlay:WINDow1:TRACe1:FEED 'My_S11'");

// Setup the channel for single sweep trigger
GPIBWrite("INITiate1:CONTinuous OFF;*OPC?");
opc = GPIBRead();
GPIBWrite("SENSe1:SWEep:TRIGger:POINt OFF");

// Set channel parameters
GPIBWrite("SENSe1:SWEep:POINts 11");
GPIBWrite("SENSe1:FREQuency:STARt 1000000000");
GPIBWrite("SENSe1:FREQuency:STOP 2000000000");

// Send a trigger to initiate a single sweep
GPIBWrite("INITiate1;*OPC?");
opc = GPIBRead();

// Must select the measurement before we can read the data
GPIBWrite("CALCulate1:PARameter:SELect 'My_S11'");

// Read the measurement data into the "result" string
 variable
GPIBWrite("FORMat ASCII");
GPIBWrite("CALCulate1:DATA? FDATA");
result = GPIBRead();

// Print the data to the display console window
printf("S11(dB) - Visual C++ SCPI Example for PNA\n\n");
value = strtok(result, ",");
while (value != NULL)
{
printf("%s\n", value);
value = strtok(NULL, ",");
}

/*
* =========================================
* CLEANUP SECTION
* =========================================
*/

/* The PNA is returned to front panel control. */
ibonl(pna, 0);

return 0;
}

/*
* Write to the PNA
*/
void GPIBWrite(char* SCPIcmd)
{
int length;
char ErrorMsg[ERRMSGSIZE + 1];
length = strlen(SCPIcmd) ;

ibwrt (pna, SCPIcmd, length);
if (ibsta & ERR)
{
strcpy(ErrorMsg, "Unable to write this command to PNA:\n");
strcat(ErrorMsg, SCPIcmd);

GPIBCleanup(pna, ErrorMsg);
exit(1);
}
}

/*
* Read from the PNA
*/
char* GPIBRead(void)
{
ibrd (pna, ValueStr, ARRAYSIZE);
if (ibsta & ERR)
{
GPIBCleanup(pna, "Unable to read from the PNA");
exit(1);
}
else
return ValueStr;
}

/*
* After each GPIB call, the application checks whether the call succeeded.
 If an NI-488.2 call fails, the GPIB driver sets the corresponding bit
 in the global status variable. If the call failed, this procedure prints
 an error message, takes the PNA offline and exits.
*/
void GPIBCleanup(int Dev, char* ErrorMsg)
{
printf("Error : %s\nibsta = 0x%x iberr = %d (%s)\n",
ErrorMsg, ibsta, iberr, ErrorMnemonic[iberr]);
if (Dev != -1)
{
printf("Cleanup: Returning PNA to front panel control\n");
ibonl (Dev, 0);
}
}


Custom Power Meter Driver

Create a Custom Power Meter Driver

Note: This topic requires that you have a working knowledge of Visual Basic.

This topic will help you create your own power meter driver for use with Source Power Calibration on the PNA. If you are using one of the following Power Meters to perform a Source Power Calibration, you do NOT need to create your own driver:

E4416A, E4417A, E4418A/B, E4419A/B, 437B, 438A, EPM-441A, EPM-442A

Your Power Meter driver will be created from a template written in Visual Basic using VISA over the GPIB bus.

Note: This procedure applies to Visual Basic 6.0. Applicability to Visual Basic .NET has not yet been investigated.

  • Prepare Template Files

  • Modify Template Files

  • Compile, Copy, and Register, Your New Driver

  • Test Your new Driver

Other SCPI Example Programs

Prepare Template Files

  1. Copy all the files from the PNA hard drive C:\Program Files\Agilent\Network Analyzer\Automation\Power Meter Driver Template folder, to a folder on your development PC.

  2. In Visual Basic click File, then Open Project…, find MyPowerMeter.vbp (a file you copied from the PNA). Click Open. This is a VB ActiveX EXE template, which you will fill in to become your driver.

  3. Click Project, then MyPowerMeter Properties. Click the General tab.

  4. Overwrite the Project Name with a name of your own choosing. This will be the name of your driver’s type library (also the default name of your exe).

Note If the name of your exe does not match the VB Project Name with which it was compiled, registration of the exe on the PNA will not succeed.

  5. Set the Project Description. After building your driver if you wish to test it using VB, this is the string that will show up in the VB References list of your test project, and also in the lower pane of the VB Object Browser.

  6. Set the Thread Pool size to 1 thread.

  7. Click OK to close the project properties dialog.

  8. From the VB Project menu, click References… Ensure that Agilent PNA Power Meter 1.0 Type Library and VISA Library are checked. Click OK.

Note: Agilent's implementation of VISA is installed as part of the Agilent I/O Libraries on the PNA. For help on VISA, go to the Windows Start button on your PNA, select Programs, Agilent IO Libraries, VISA Help.

Modify Template Files

From Visual Basic View menu click Project Explorer. Expand the Modules and Class Modules folders. Ensure there is one module (WinAPI) and one class module (PowerMeter).

Let's look at the WinAPI module first.

  1. In the Project Explorer window, click WinAPI.

  2. From the View menu click Code.

There is only one line of code you should need to modify in this module: the value of the string constant named sIDSEARCH. The comments preceding the declaration of that string describe how to change it. The rest of this module contains functions which will use the Microsoft Windows API to insure proper registration of your driver on the PNA. If you know of other Windows API functions you feel might be helpful to call from within your PowerMeter class module (to help in formatting data, for example), this module would be the place to declare them.

Now let's look at the class module.

  1. In the Project Explorer window, click PowerMeter.

  2. From the View menu click Properties Window. The Instancing property must be set to MultiUse. This allows other applications to create objects from this class, such that one instance of your driver EXE can supply more than one such object at a time.

  3. From the View menu click Code.

Do NOT modify the Interfaces to IPowerMeter subroutines and functions. PNA source power cal expects to find these interfaces as they are currently defined.

The only members that you need to supply code to are those containing “Your code here” comments.

In addition, comments have been provided at the beginning of each member to describe the information that member needs to be read from or written to the power meter.

To get an idea of how communicate with the power meter using the VISA functions viWrite and viRead, examine the code which has been implemented for you in IPowerMeter_Connect, IPowerMeter_QueryMeter, and IPowerMeter_WriteMeter.

Compile, Copy, and Register Your New Driver

When your driver is ready to run, you will first need to compile it into an EXE.

From the File menu select Make exe.

After compiling, the following will instruct VB to use the same ID (GUID) every time you re-compile your project.

  1. From the Project menu, click PowerMeter Properties.

  2. On the Component tab, select Binary Compatibility and click ...

  3. Browse to and select your project EXE. Click Open.

  4. Click OK to close Project Properties.

  5. Save your project.

  6. Copy your driver EXE file to a folder on your PNA (do NOT use C:\Program Files\Agilent\Network Analyzer\Automation\Power Meter Driver Template folder).

  7. Run the EXE file. A message box will pop up reporting whether or not registration was successful. If not successful, it will make a suggestion on what to fix.

When your driver is properly registered, PNA Source Power Cal should be able to associate it with the ID string of your power meter.

Test Your Power Meter Driver

We have also provided a Visual Basic project to test your new Power Meter driver. This project individually calls every IPowerMeter method and property in your driver to verify that it performs correctly. Before running the test your PC and PNA must be configured to communicate using DCOM.

  1. Connect your PC and the PNA to LAN.

  2. Add your PC logon to the PNA. Both logons and password must match to communicate using DCOM. See Additional PNA users.

  3. Configure your driver using DCOM Config on the PNA. This will give you permission to launch and access the driver. See Configure for COM-DCOM Programming.

Modify the Test Project

  1. In Visual Basic click File, then Open Project…, find MyPowerMeterTest.vbp (a file you copied from the PNA). Click Open.

  2. From the Project menu, click References… From the list, find and check your new Power Meter Driver. (It should have been registered on your PC when you successfully made your driver EXE.) Click OK.

  3. From the View menu click Code.

  4. Modify the CreateObject line as follows:
    Replace MyPowerMeter with the Project Name that you chose for your driver
    Replace MyPNA with the Computer Name of your PNA.
    For example:

Set PowerMeterObj = CreateObject("AcmeBrand.PowerMeter", "AGILENT-PNA123")

(This assumes that you kept PowerMeter as class module name in your driver.)

Run the Test Project

Ensure your power meter is connected to the PNA with a GPIB cable.

Put the PNA in system controller mode:

  1. From the PNA System menu point to Configure then click SICL/GPIB.

  2. In the GPIB box click System Controller.

Run the test project. If there are no errors, the driver is created successfully. If there are errors, try to figure out what went wrong and fix it. Then re-compile, re-copy the .exe to the PNA, and re-run the test. You should not need to re-register the driver or re-modify the test program.


GPIB Pass Through

GPIB Pass-Through Example

The SCPI SYSTem commands used in this example allow you to send GPIB commands to another GPIB device through the PNA. The other GPIB device cannot be connected to the GPIB bus through the PNA rear panel if the PNA is being controlled by a remote PC using that connector. The other device would typically be connected to the PNA using a USB/GPIB interface.

This VB Script example uses the COM SCPIStringParser object. However, this is not critical to the use of these commands; they can be sent using the normal syntax of your programming environment. Using the SCPIStringParser over LAN allows you to communicate with GPIB devices without requiring your remote PC to have a GPIB interface card installed.

Although this method of pass-through works for most applications, there are a couple of limitations:

  • All data is transferred using ASCII format. Therefore, transferring large blocks of data is very slow.

  • Only read and write functions are possible. Service Interrupts are not supported.

See Other SCPI Example Programs

option explicit
dim app
set app = CreateObject("AgilentPNA835x.Application")

dim p
set p = app.ScpiStringParser

' Open a new GPIB session on Bus:2 Device:14 Timeout: 100ms
p.Parse "SYST:COMM:GPIB:RDEV:OPEN 2,14,100"
dim handleAsStr

' Retrieve the handle (ID number)
handleAsStr = p.Parse ("SYST:COMM:GPIB:RDEV:OPEN?")

' Convert the handle to an integer
dim handleAsInt
handleAsInt = CInt(handleAsStr)

' Send the "*IDN?" query
p.Parse "SYST:COMM:GPIB:RDEV:WRITE " & handleAsInt &
 ",'*IDN?'"

' Read its results
dim idn
idn = p.Parse("SYST:COMM:GPIB:RDEV:READ? " & handleAsInt)
msgbox idn

' Close the GPIB session
p.Parse "SYST:COMM:GPIB:RDEV:CLOSE " & handleAsInt


Controll,Talk,Listen using SCPI

PNA as Controller and Talker / Listener

This Visual Basic Program uses VISA to do the following:

  • This Visual Basic Program uses VISA to do the following:

  • Control the PNA using a VISA LAN Client interface on the PNA.

  • Control another instrument using the PNA as GPIB controller.

  • Queries both the analyzer and other instrument to identify themselves with *IDN?

Note: This program can be modified to work from a remote PC to control both instruments. In that case, set up the PNA to be a talker/listener.

To run this program, you need to do the following:

  • Add module visa32.bas to the VB project. It is located on the analyzer at C:\Program Files\HP\VXIPNP\WINNT\Include\VISA32.bas

  • Configure the PNA for VISA / SICL

  • Set up the PNA to be GPIB system controller.

    1. On the System menu, point to Configure. Click SICL / GPIB

    2. Click System Controller

  • Connect another instrument to the analyzer through a GPIB cable with Primary address of 13 on GPIB0 interface

See Other SCPI Example Programs

Sub main()

'This application run from onboard the PNA

'can control both the PNA and another GPIB instrument.

'

'To run this program the module visa32.bas must be added

'to the project.

'VISA function status return code

Dim status As Long

'Session to Default Resource Manager

Dim defRM As Long

'Session to instrument

Dim viPNA As Long

'Session to other GPIB instrument

Dim viInstrument As Long

'String to hold results

Dim strRes As String * 200

On Error GoTo ErrorHandler

status = viOpenDefaultRM(defRM)

If (status < VI_SUCCESS) Then GoTo VisaErrorHandler

'Open the session to the PNA

status = viOpen(defRM, "GPIB1::16::INSTR", 0, 0, viPNA)

If (status < VI_SUCCESS) Then GoTo VisaErrorHandler

'Ask for the PNA's ID.

status = viVPrintf(viPNA, "*IDN?" + Chr$(10), 0)

If (status < VI_SUCCESS) Then GoTo VisaErrorHandler

'Read the ID as a string.

status = viVScanf(viPNA, "%t", strRes)

If (status < VI_SUCCESS) Then GoTo VisaErrorHandler

'Display the results

MsgBox "PNA is: " + strRes

'Open the session to the other instrument

status = viOpen(defRM, "GPIB0::13::INSTR", 0, 0, viInstrument)

If (status < VI_SUCCESS) Then GoTo VisaErrorHandler

'Ask for the instrument's ID.

status = viVPrintf(viInstrument, "*IDN?" + Chr$(10), 0)

If (status < VI_SUCCESS) Then GoTo VisaErrorHandler

'Read the ID as a string.

status = viVScanf(viPNA, "%t", strRes)

If (status < VI_SUCCESS) Then GoTo VisaErrorHandler

'Display the results

MsgBox "Other instrument is: " + strRes

' Close the resource manager session (which closes everything)

Call viClose(defRM)

End

ErrorHandler:

'Display the error message

MsgBox "*** Error : " + Error$, MB_ICONEXCLAMATION

End

VisaErrorHandler:

Dim strVisaErr As String * 200

Call viStatusDesc(defRM, status, strVisaErr)

MsgBox "*** Error : " + strVisaErr

End

End Sub


Основы GPIB

Универсальная интерфейсная шина (General Purpose Interface Bus, GPIB) – это система аппаратного и программного обеспечения, которая дает вам возможность управлять измерительной аппаратурой для быстрого и точного выполнения измерений. В данном разделе содержится следующая информация:

  • Компоненты аппаратного обеспечения GPIB

  • Программные элементы GPIB / SCPI

  • Конфигурация для операции GPIB / SICL

  • Операция LCL и RMT

  • Характеристики GPIB

  • Коды характеристик интерфейса GPIB

Примечание: Во всех имеющих отношение к программированию разделах предполагается, что вы уже знакомы с программированием, желательно на языке для управления приборами.

Другие разделы по GPIB

Компоненты аппаратного обеспечения GPIB

Системная шина и соответствующие операции интерфейса определяются стандартом IEEE 488. В следующих разделах перечислены и описаны основные элементы аппаратного обеспечения системы GPIB:

Приборы

По умолчанию анализатор сконфигурирован как Источник / Приемник.

  • Источники это приборы, которые можно назначить для передачи данных контроллеру.

  • Приемники это приборы, которые можно назначить для получения команды и последующего ответа на нее. Все устройства шины должны иметь возможность быть приемниками.

Адреса GPIB

Каждому прибору GPIB необходимо назначить собственный уникальный адрес в шине. Адрес анализатора (716) состоит из двух частей:

  1. Код выборки интерфейса (как правило, 7) указывает, какой из портов GPIB системного контроллера используется для связи с устройством.

  2. Первичный адрес (16) устанавливают на производстве. Вы можете изменить первичный адрес любого устройства шины на любой номер от 0 до 30. Для изменения адреса анализатора щелкните по System \ Configure \ SICL-GPIB

Вторичный адрес иногда используют для разрешения доступа к отдельным модулям модульной системы контрольно-измерительных приборов, например, базовому компьютеру VXI. Анализатору не назначают вторичный адрес.

Контроллеры

Контроллеры назначают приборы, которые будут выполнять функции источника и приемника при обмене данными. Контроллер шины должен быть оснащен интерфейсной картой GPIB для связи с GPIB.

  • Активный контроллер – это компьютер или устройство, фактически контролирующее обмен данными.

  • Системный контроллер – это компьютер или устройство, которое берет на себя управление и передает управление GPIB другому компьютеру или устройству, которое затем называют активным контроллером.

Управление GPIB НЕЛЬЗЯ переключать на PNA. Однако через PNA вы можете поддерживать связь с другими устройствами GPIB с помощью одного из следующих методов или их комбинации:

  • Используйте команды SCPI SYST:COMM:GPIB:RDEV.

  • Пользуйтесь VISA или SICL по локальной сети. Смотрите пример.

  • Используйте интерфейс USB / GPIB

Кабели

Кабели GPIB – это физический канал, соединяющий все устройства шины. Кабели GPIB содержат восемь линий для передачи данных от одного устройства к другому. Кроме того, восемь линий управления контролируют трафик по линиям передачи данных и другие операции интерфейса.

К контроллеру можно подключать приборы в любой компоновке с учетом следующих ограничений:

  • Не подключайте к системе GPIB более 15 устройств. Это количество можно увеличить с помощью расширения шины.

  • Общая длина кабеля не должна превышать 20 метров или 2 метра на устройство.

  • Не устанавливайте более трех разъемов на задней панели прибора. Это может стать причиной нежелательной нагрузки на разъем задней панели.

Программные элементы GPIB / SCPI

В программе GPIB скомбинированы следующие программные элементы программного обеспечения:

  • Команды GPIB

  • Программные операторы

  • Драйверы приборов

Команды GPIB

Команда GPIB – это основная единица связи в системе GPIB. Анализатор реагирует на три типа команд GPIB:

1. IEEE 488.1 – команды управления шиной

В основном данные команды используют для того, чтобы сообщить всем устройствам шины, либо одному из них, о необходимости выполнить определенные операции интерфейса.

Все действия, которые можно выполнить с помощью данных команд, также выполняются командами IEEE 488.2 или SCPI. Поэтому данные команды не описаны в справочном руководстве. Полный перечень команд IEEE 488.1 представлен в стандарте IEEE 488. Примеры команд IEEE 488.1

  • CLEAR - очистка шины от всех подвешенных операций

  • LOCAL - возврат приборов к локальному действию

2. Общие команды IEEE 488.2

Данные команды передаются приборам для выполнения операций интерфейса. Общая команда IEEE 488.2 состоит мнемонических символов со звездочкой ( * ) перед ними. Некоторые команды имеют вопросительную форму – после команды ставится знак "?". Такие команды опрашивают прибор о текущих настройках. Полный перечень команд, распознаваемых анализатором, приведен в Общие команды. Примеры команд IEEE 488.2

  • *OPC - операция завершена

  • *RST - сброс

  • *OPT? - вопрос о конфигурации опции

3. Команды SCPI

Стандартные команды для программируемых измерительных приборов (Standard Commands for Programmable Instruments, SCPI) – это набор команд, разработанных в 1990 году. Полезность стандартизации команд SCPI состоит в том, что программы, написанные для отдельного прибора SCPI, можно с легкостью адаптировать для подобного прибора SCPI. Команды SCPI сообщают приборам о необходимости выполнить заданные функции. Например, команды SCPI могут сообщить прибору о необходимости выполнить измерение и передать данные контроллеру. Примерыкоманд SCPI:

CALCULATE:AVERAGE:STATE ON

SENSE:FREQUENCY:START?

Дополнительная информация о SCPI:

  • Правила и синтаксис команд SCPI - предоставляет более подробную информацию о структуре команды SCPI.

  • Дерево команд SCPI - это полный перечень команд SCPI для анализатора

Программные операторы

Для составления программных операторов в команды SCPI включены операторы ввода-вывода, соответствующие языку. Синтаксис программных операторов определяется языком программирования. Программы SCPI могут быть написаны на разных языках программирования, например, VEE, HP BASIC или C++. Пример оператора Visual Basic:

  • GPIB.Write "SOURCE:FREQUENCY:FIXED 1000 MHz"

Замечание по примерам

Драйверы приборов

Драйверы приборов – это обеспечивающие выполнение функций подпрограммы, которые можно использовать в разных программах. Лидеры сферы GPIB представили стандарты для программистов – разработчиков драйверов. Если программисты разрабатывают драйверы, соответствующие стандартам, их можно использовать с прогнозируемыми результатами. Для соответствия стандарту к каждому драйверу должна прилагаться документация с описанием выполняемых функций и способа применения.

Конфигурация для операции SICL / GPIB

Более подробно см. интерфейс передней панели

SICL / GPIB – справка по диалоговому окну

GPIB

Talker/Listener (Источник/Приемник) - устанавливает PNA на получение и отправку сообщений GPIB/SCPI системному контроллеру (внешний компьютер).

Talker/Listener Address (Адрес Источника/Приемника) – устанавливает GPIB адрес источника/приемника PNA.

System Controller (Системный контроллер) – назначает PNA системным контроллером, который управляет связью GPIB с внешними устройствами. Дополнительная информация находится в PNA в качестве контроллера.

System Controller Address (Адрес системного контроллера) – назначает GPIB адрес системного контроллера PNA.

SICL

SICL Enabled (SICL включен) – если отмечено – анализатор может запускать программы GPIB для управления функциями анализатора на своем компьютере. Программы необходимо запускать в программной среде, где может работать GPIB (VEE, Visual Basic). Данный режим не дает возможности управлять внешними приборами GPIB. Для того, чтобы снять отметку в этом окне, выйдите из приложения PNA - (Нажмите File, затем Exit). PNA перезапускается без отметки в поле SICL, если не отмечено поле Automatically Enable on Startup (Автоматическое включение при запуске).

Дополнительная информация находится в Конфигурирование для VISA и SICL.

Address (Адрес) – устанавливает адрес PNA.

Automatically Enable on Startup (Автоматическое включение при запуске) – при отмеченном поле при запуске приложения PNA автоматически выбирается команда SICL Enabled (SICL включен).

Монитор SCPI / Ввод

GPIB Command Processor Console (Консоль командного процессора GPIB) – запускает окно для отправки отдельных команд SCPI/GPIB.

Примечание: Нажмите Control+Z , затем ввод, чтобы закрыть окно консоли.

  • Наберите правильно составленную команду с соответствующими аргументами и нажмите ввод.

  • Для повторного вызова предыдущих команд пользуйтесь кнопками со стрелками.

  • Окно консоли может работать за пределами приложения PNA. Нажмите Control+Tab чтобы переместить окно консоли вверх.

Monitor GPIB Bus (Монитор шины GPIB) ) – включает мониторинг GPIB.

Show GPIB Bus Monitor Window (Показать окно монитора шины GPIB) - открывает и скрывает окно мониторинга работы GPIB.

Операция LCL и RMT

Метки операции анализатор LCL и RMT (локальный и дистанционный) появляются в нижнем правом углу строки текущего состояния.

Примечание: Строка текущего состояния НЕ видна, если анализатор установлен заранее. Чтобы сделать строку видимой, нажмите View (Просмотр), затем Status Bar (Строка состояния).

  • LCL появляется, если не установлено управление SCPI

  • RMT появляется, если установлено управление SCPI . Метка RMT НЕ появляется, если под управлением COM RMT отключает кнопки передней панели, кроме кнопки Macro/Local.

Нажатие кнопки Macro / Local возвращает анализатор к операции Local (локальная – передняя панель).

Команда IEEE488.1 "GTL" (перейти к локальному) также возвращает анализатор к операции Local (локальная – передняя панель).

Команда IEEE488.1 "LLO" (блокировка локального) отключает кнопку передней панели Local.

Характеристики GPIB

Interconnected devices (Взаимосвязанные устройства) - до 15 устройств (максимум) на одной сопряженной шине.

Interconnection path (Межсоединение) - звездообразная или линейная (или смешанная) схема разводки шины, до 20 метров общего пути передачи или по 2 метра на устройство, возможно меньше.

Message transfer scheme (Схема передачи сообщений) - побайтная, параллельная по битам, асинхронная передача данных с помощью 3-проводного устройства установления связи.

Maximum data rate (Максимальная скорость передачи данных) - 1 мегабайт в секунду на ограниченные расстояния, стандартный максимум в 250 - 500 килобайт в секунду по всему каналу передачи. Фактическую скорость передачи данных определяют устройства шины.

Address capability (Характеристика адресации) - первичные адреса, 31 источник и 31 приемник; вторичные адреса, 961 источник и 961 приемник. На одной шине одновременно могут находиться максимум 1 источник и до 14 приемников. Кроме того, смотрите предыдущий раздел - адреса GPIB.

Коды характеристик интерфейса GPIB

По стандарту IEEE 488.1 требуется, чтобы на задних панелях всех приборов, совместимых с GPIB, были указаны характеристики интерфейса. Ниже приведены коды анализатора и их описания:

SH1 | полная производительность источника установления связи
AH1 | полная производительность приемника установления связи
T6 | базовый источник, последовательный опрос, без – только передача, без адреса, если установлен MLA (My Listen Address – мой адрес приемника)
TEO | без расширенных возможностей источника
L4 | базовый приемник, без – только прием, без адреса, если установлен MTA (My Talk Address – мой адрес источника)
LEO | без расширенных возможностей приемника
SR1 | полные возможности запросов на обслуживание
RL1 | полные возможности дистанционно / локально
PPO | без возможностей параллельного опроса
DC1 | возможность полной очистки устройства
DT1 | возможность полного запуска устройств
C1 | производительность системного контроллера
C2 | отправить IFC (Очистка интерфейса) и принять управление контроллером
C3 | отправить REN (Включить дистанционный режим) контроллера
C4 | ответить на SRQ (Запрос на обслуживание)


Правила и синтаксис SCPI

Большинство команд, используемых для управления приборами GPIB, - это команды SCPI. Следующие разделы помогут вам научиться использовать команды SCPI в программах.

  • Ветви дерева команд

  • Команда и вопрос

  • Множественные команды

  • Командные аббревиатуры

  • Вспомогательные [в скобках] ключевые слова

  • Вертикальная черта

  • Параметры MIN и MAX

Другие разделы по GPIB

Ветви дерева команд

Всем основным функциям анализатора назначены зарезервированные слова, они называются командами ROOT. (За перечнем корневых команд SCPI обращайтесь к Определителю команд GPIB). У корневых команд есть ветви, содержащие одно или более зарезервированных слов. Ветвление продолжается до тех пор, пока каждой ветви назначена функция анализатора. Иногда корневую команду и ветви называют подсистемой.

Например, на следующем графике показана подсистема SOURce. Под ключевыми словами SOURce и POWer находятся несколько команд-ответвлений.

Иногда в нескольких ветвях командного дерева используется одно и то же ключевое слово, например, STATE. Чтобы пройти по текущей ветви программа синтаксического анализа анализатора применяет следующие правила:

  • Power On and Reset (Включить питание и сброс) - после цикла выключение-включение питания, либо после *RST, устанавливается текущий путь к командам корневого уровня.

  • Message Terminators (Указатели конца сообщения) - A message terminator, such as a <NL> character, sets the current path to the root command level. Many programming language output statements send message terminators automatically. Message terminators are described in Sending Messages to the Analyzer.

  • Colon (:) - Если между двумя ключевыми словами команды стоит двоеточие, это перемещает текущий путь на один уровень вниз по командному дереву. Например, двоеточие в :SOURCE:POWER указывает на то, что POWER на один уровень ниже SOURCE. Если двоеточие – это первый символ команды, то это означает, что следующее ключевое слово – команда корневого уровня. Например, двоеточие в :SOURCE указывает на то, что SOURCE – это команда корневого уровня.

Примечание: В первой строке программы начальное двоеточие можно пропустить. Например, следующие две команды эквивалентны:
SOUR:POW:ATT:AUTO
:SOUR:POW:ATT:AUTO

  • <WSP> - символы табуляции, например <tab> и <space>, как правило, игнорируются. Есть два важных исключения:

    • o Пробелы в пределах ключевого слова, например :CALC ULATE, не допускаются.

    • o Большая часть команд заканчиваются параметром. Необходимо использовать пробелы, чтобы отделить параметры от команды. Обращайтесь к документации по командам. В следующем примере пробел находится между STATE и ON.

CALCULATE1:SMOOTHING:STATE ON

  • Запятая (,) - если в команде более одного параметра, их необходимо разделить запятыми. Например, в команде SYSTEM:TIME для установки часов анализатора необходимы три значения: часы, минуты и секунды. Сообщение для установки часов на 8:45 будет следующим SYSTEM:TIME 8,45,0. Запятые не влияют на текущий путь.

  • Точка с запятой(;) - точка с запятой отделяет две команды в одном сообщении, не изменяя текущий путь. Смотрите дальше в данном разделе Множественные команды later in this topic.

  • Общие команды IEEE 488.2 - общие команды, например, *RST, не являются частью какой-либо подсистемы. Прибор интерпретирует их одинаково, независимо от настройки текущего пути.

Команда и вопрос

Команда SCPI может быть командой Событие, командой Вопрос (команда, запрашивающая информацию у анализатора) или и тем, и другим. Далее следуют описания и примеры каждой формы команды. В Определителе команд GPIB перечислены все команды SCPI, распознаваемые анализатором, и их формы.

Форма | Примеры
Команды Событие - инициируют действие анализатора. | :INITIATE:IMMEDIATE
Команды Вопрос - только вопрос; не требуют соответствующей установки анализатора. | :SYSTem:ERRor?
Команда и вопрос - устанавливают настройку анализатора или запрашивают о ней. В вопросе к форме команды добавляется вопросительный знак (?) | :FORMat:DATA ! Command :FORMat:DATA? ! Query

Множественные команды

Несколько команд можно передать в одном программном сообщении. При разделении команд точкой с запятой текущий путь не меняется. Следующие примеры иллюстрируют три метода отправки двух команд:

  1. Два программных сообщения:

SOURCE:POWER:START 0DBM
SOURCE:POWER:STOP 10DBM

  2. Одно длинное сообщение. За точкой с запятой стоит двоеточие, разделяющее две команды, поэтому синтаксический анализатор команд возвращается к корню командного дерева. В результате следующая команда действительна только тогда, когда в нее включено полное ключевое слово пути от корня дерева:

SOURCE:POWER:START 0DBM;:SOURCE:POWER:STOP 10DBM

  3. Одно короткое сообщение. Синтаксический анализатор команд отслеживают позицию на командном дереве. Следовательно, вы можете упростить программные сообщения, включая только ключевое слово на том же уровне командного дерева.

SOURCE:POWER:START 0DBM;STOP 10DBM

Общие команды и команды SCPI

Вы можете одновременно, в одном сообщении, отправлять общие команды и команды SCPI. (За дополнительной информацией по этим типам команд обращайтесь к Основы GPIB.) Так же, как и при отправке команд SCPI, их необходимо разделить точкой с запятой.

Пример одновременной отправки общей команды и команды SCPI

*RST;SENSE:FREQUENCY:CENTER 5MHZ;SPAN 100KHZ

Командные аббревиатуры

Каждая команда может быть представлена в длинной форме и краткой форме аббревиатуры. В синтаксисе данной справочной системы прописные символы используют для идентификации краткой формы определенного ключевого слова. Для завершения длинной формы остальную часть ключевого слова пишут строчными буквами.

SOUR - краткая форма
SOURce - длинная форма

Для каждого ключевого слова необходимо использовать полную краткую форму или полную длинную форму. Однако ключевые слова в составе полной команды SCPI могут представлять собой комбинацию краткой и длинной форм.

Приведенные далее примеры недопустимы - первые три ключевых слова не являются ни краткой, ни длинной формой.

SOURc:Powe:Atten:Auto on

Приведенное ниже допустимо - все ключевые слова в краткой или длинной форме.

SOUR:POWer:ATT:AUTO on

Кроме того, анализатор воспринимает строчные и прописные символы, как эквивалент, как показано в следующих эквивалентных примерах:

source:POW:att:auto ON
Source:Pow:Att:Auto on

Вспомогательные [в скобках] ключевые слова

Нельзя пропускать некоторые ключевые слова, не изменяя действие команды. Данные дополнительные, или заданные по умолчанию, ключевые слова используют во многих подсистемах и в синтаксических диаграммах выделяют их скобками

Пример вспомогательных ключевых слов

В подсистеме HCOPy содержится вспомогательное ключевое слово IMMediate в первой точке ветвления. Следующие команды эквивалентны:

"HCOPY:IMMEDIATE"

"HCOPY"

В данной справочной системе синтаксическая структура выглядит подобным образом:

HCOPy[:IMMediate]

Вертикальная черта |

Вертикальную черту можно читать как "или". Их используют в синтаксических диаграммах для разделения альтернативных вариантов параметров.

Пример вертикальных черт:

SOURce:POWer:ATTenuation:AUTO <on|off>

Действующим вариантом параметра может быть ON или OFF.

Параметры MIN и MAX

Параметры особой формы "MINimum" и "MAXimum" можно использовать в некоторых командах анализатора, как указано в документации по командам. Краткая форма (min) и длинная форма (minimum) этих ключевых слов эквивалентны.

  • MAXimum обращается к наибольшему текущему значению, которое может быть установлено для данной функции.

  • MINimum обращается к наименьшему текущему значению, которое может быть установлено для данной функции.

Например, следующая команда устанавливает стартовую частоту на наименьшее значение, возможное в данный момент:

SENS:FREQ:START MIN

Кроме того, данные команды могут запросить минимальное и максимальное значения.

Например, следующая команда возвращает наименьшее значение стартовой частоты, которую можно установить в данный момент:

SENS:FREQ:START? MIN

Если отправлен числовой параметр, превышающий значения MAX и MIN, будет возвращено сообщение об ошибке.

Например, следующая команда возвратит сообщение "Out of range" (за пределами диапазона).

SENS:FREQ:START 1khz


Калибровка PNA с помощью SCPI

Существует несколько способов калибровки PNA с помощью SCPI, это зависит от необходимых измерений. Начиная с Cal Wizard, вы можете выполнить Guided Cal (управляемая калибровка), Unguided Cal (калибровка без управления), или ECal. В данном разделе поясняется различие между указанными типами калибровки с использованием команд SCPI.

Управляемые калибровки (Guided Calibrations)

  • Используйте команды Sens:Corr:Coll:Guided.

  • Полные 1,2,3,4-портовые калибровки SOLT и TRL – без калибровок частотной неравномерности.

  • Все расширенные функции калибровки (Метод THRU, укажите разъемы тестируемого устройства (DUT) и калибровочные комплекты (Cal kits) для каждого порта, пары портов).

Не управляемые калибровки (Unguided Calibrations)

  • Команды Sens:Correction.

  • 1-портовая, 2-портовая, характеристика частотной неравномерности.

  • Можно выбрать два набора стандартов (калибровочных мер).

  • TRL НЕ рекомендуется.

ECal

Из программы Cal Wizard (Помощник по калибровке) или программы SCPI, ECal выполняется быстро, точно и повторяемо. В отличие от Cal Wizard можно использовать SCPI для выполнения ECal с помощью команд Guided (управляемая) или Unguided (неуправляемая). Проще всего применять команды Unguided. Однако в следующих ситуациях необходимо применять команды Guided.

  • Для повышения точности все калибровки ECal для PNA выполняют измерение Unknown Thru модуля Ecal, состояние Thru, ЕСЛИ используемая модель PNA имеет 1 опорный приемник на порт. Если ваш PNA не имеет 1 опорного приемника на порт, используйте команды Guided Ecal и укажите метод Thru.

  • Если разъемы вашего модуля ECal НЕ соответствуют разъемам тестируемого устройства, и вы решили не выполнять User Characterization, используйте команды Guided ECal и задайте метод Thru.

ECAL, примечания:

  • При использовании команд Guided или Unguided для ECal в ситуациях недостаточного питания используйте настройки Orientation (Ориентация). На примере показано использование команд Guided. При использовании Unguided их необходимо применять перед командой Acquire (получить).

  • Диапазон частоты измерений должен находиться в пределах диапазона модуля Ecal. Иначе калибровка не будет выполнена.

  • Несмотря на то, что недавно эта команда была представлена, вы НЕ должны отправлять команду состояния модуля Ecal. Алгоритм Ecal автоматически переключает состояния Ecal.

  • Все эти варианты для Ecal перечислены в функции Поиск команд программирования данного справочного файла.

Информация обо всех функциях Ecal находится в Применение ECal.

Смотрите примеры SCPI калибровки


Получение данных из анализатора с помощью SCPI

Получение данных из анализатора

В ответ на программные запросы анализатор отправляет данные. Данные могут иметь вид кратких сообщений-ответов, например, настройки анализатора, или больших блоков с данными измерений. В данном разделе описан наиболее эффективный способ чтения ответов на запросы и данных измерений анализатора.

  • Синтаксис ответного сообщения

  • Очистка очереди вывода

  • Типы ответных данных

  • Передача данных измерений

Примечание: В некоторых компьютерах используется модификация форматов с плавающей точкой IEEE с обратным порядком байтов. Для изменения порядка байтов при передаче данных в компьютер используйте команду FORMat:BORDer.

Другие разделы по GPIB

Синтаксис ответного сообщения

В ответах, отправленных анализатором, содержатся данные, соответствующая пунктуация и признаки конца сообщения.

В качестве конца ответного сообщения всегда отправляется <NL><^END> В большинстве языков программирования данные знаки обрабатываются понятным для программиста способом.

В следующих ситуациях запятые и точка с запятой применяются в ответных сообщениях, как разделители:

  • запятая разделяет ответные данные, если отдельная команда запроса возвращает несколько значений

FORM:DATA? 'Запрос
ASC, +0 'Ответ анализатора

  • точка с запятой разделяет ответные данные, если в одном сообщении отправлены несколько запросов

SENS:FREQ:STAR?;STOP? --Пример запроса

+1.23000000E+008; +7.89000000E+008<NL><^END> 'Ответ анализатора

Очистка очереди вывода

Получив запрос, анализатор помещает ответное сообщение в свою очередь вывода. Ваша программа должна читать ответ сразу же после отправки запроса. Таким образом, гарантировано, что ответ не будет удален до прочтения. Ответ удаляется при одном из следующих условий:

  • Если запрос не завершен должным образом символом возврата ASCII или сообщением GPIB <^END>.

  • Если отправлен второй программный запрос .

  • Если отправленное программное сообщение превышает длину входной очереди

  • Если ответное сообщение генерирует больше ответных данных, чем может поместить очередь вывода.

  • Если анализатор в состоянии ВКЛ.

Типы ответных данных

Анализатор отправляет ответные данные различного типа в зависимости от параметра запроса. Вы должны знать тип данных, которые будут возвращаться, чтобы назначить соответствующий тип переменной для приема данных. За дополнительной информацией о назначении переменных обращайтесь к руководству по языку программирования. В Определителе команд GPIB перечислены все команды GPIB и формат возвращения данных в ответ на запрос. Анализатор возвращает данные следующего типа:

  • Цифровые данные

  • Символьные данные

  • Данные типа строки

  • Блок данных

Цифровые данные

Все цифровые данные, отправленные с помощью GPIB, - это символы ASCII. Ваша программная среда преобразует символы в цифровые данные. Булевы данные (1 | 0 ) – это тип цифровых данных.

Символьные данные

Символьные данные состоят из символов ASCII, объединенных в мнемонические группы, которые представляют собой конкретные настройки анализатора. Анализатор всегда возвращает краткую форму мнемонических данных в виде прописных текстовых символов. Символьные данные выглядят как данные типа строки. Таким образом, для определения формата возврата для каждой команды-запроса обращайтесь к Определителю команд GPIB.

Пример символьных данных

MLOG

Данные типа строки

Строковые данные состоят из символов ASCII. Фактически строковые параметры могут содержать любые наборы символов ASCII. При отправке строковых данных анализатору строка должна начинаться с одинарной ( ' ) или двойной кавычки ( ") и заканчиваться таким же символом (ограничитель).

Примечание: Анализатор правильно реагирует на все специальные символы, если строка заключена в одинарные кавычки. Если кавычки не используются, анализатор переведет текст в верхний регистр. Анализатор может не отреагировать ожидаемым образом.

При возвращении строковых данных анализатор всегда заключает данные в двойные кавычки.

Пример строковых данных

GPIB.Write "DISP:WINDow:TITLe:DATA?"

“Это строка ответных данных.”

Блок данных

Блок данных применяется для передачи данных измерений. Несмотря на то, что анализатор принимает блоки с заданной или неопределенной длиной, он всегда возвращает блок данных заданной длины в ответ на запросы, если не задан формат ASCII. На следующем графике показана синтаксическая структура для определения блока данных:

<num_digits> указывает количество цифр в <byte_count>
<byte_count> указывает количество байтов данных, которые будут находиться в <data bytes>

Пример определенного блока данных

#17ABC+XYZ<nl><end>

# - всегда отправляется перед определенным блоком данных

1 - указывает, что контрольная сумма байтов – одна цифра (7)

7 - указывает количество последующих байтов данных, не учитывая <NL><END>

<NL><END> - всегда отправляется в конце блока данных

Передача данных измерений

Данные измерений – это блоки цифр, полученные в результате измерений анализатора. Данные измерений поступают от различных массивов обработки анализатора. За дополнительной информацией о процессе обработки данных обращайтесь к Accessing Data Map. Независимо от того, какой из массивов измерений читается, передача данных измерений выполняется одинаково.

Команда FORMat:DATA дает вам возможность выбрать для передачи данных измерений один из следующих типов данных:

  • REAL (Вещественное число)

  • ASCII

На следующем рисунке показаны различия во времени передачи двух типов данных:

Вещественные (REAL) данные

Вещественные данные (также называются данные с плавающей точкой) передаются быстрее. Это происходит потому, что данные типа REAL двоичные и занимают вдвое меньше места, чем данные ASCII. Недостаток использования вещественных данных – для них требуется заголовок, который необходимо читать. Смотрите блок данных заданной длины. Двоичные форматы с плавающей точкой определены в стандарте IEEE 754-1985. Для данных формата REAL возможны следующие варианты:

  • REAL,32 - IEEE 32-битовый формат – одинарная точность (не поддерживается HP BASIC)

  • REAL,64 - IEEE 64-битовый формат – удвоенная точность

Данные ASCII

Самый простой и медленный способ передачи данных измерений – использование данных ASCII. Данные ASCII передаются, если данные содержат цифры и символы (настройка FORMat:DATA игнорируется). Данные ASCII отделяются запятыми.


Понятие синхронизации команд

Thi s program determines which frequency contains the maximum amplitude.

GPIB.Write "ABORT; :INITIATE:IMMEDIATE"! Restart the measurement
GPIB.Write "*OPC?" 'Wait until complete
Meas_done = GPIB.Read 'Read output queue, throw away result
GPIB.Write "CALCULATE:MARKER:MAX" 'Search for max amplitude
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency?
Marker_x = GPIB.Read
PRINT "MARKER at " & Marker_x & " Hz"

Понятие синхронизации команд

На обработку некоторых команд у анализатора уходит больше времени, чем на обработку других:

  • Последовательные команды обрабатываются быстро, в порядке их поступления.

  • Перекрывающиеся команды требуют больше времени на обработку. Поэтому они дают программе возможность выполнять другие задачи во время ожидания. Однако программист может решить не допускать того, чтобы анализатор обрабатывал новые команды до выполнения перекрывающихся команд. Это называется "синхронизацией" анализатора и контроллера.

Примечание: В анализаторе существуют две перекрывающиеся команды:
INITitate:IMMediate

SENSe:SWEep:MODE GROUPS (если INIT:CONT в состоянии ВКЛ)

Очереди анализатора хранят команды и ответы в ожидании обработки. Использование очередей анализатора и управление последовательностью обработки перекрывающихся команд называется синхронизацией анализатора и контроллера. В данном разделе рассказано, как и когда необходимо выполнять синхронизацию.

  • Очереди анализатора

  • Синхронизация перекрывающихся команд

Другие разделы по GPIB

Очереди анализатора

Очереди – это буферы памяти, где до обработки хранятся сообщения. Существуют следующие очереди анализатора:

  • Входная очередь

  • Выходная очередь

  • Очередь ошибок

Входная очередь

Контроллер отправляет операторы анализатору без учета количества времени на выполнение операторов. Входная очередь очень большая (31кбайт). В ней временно хранятся команды и запросы контроллера до тех пор, пока программа синтаксического анализа анализатора не прочитает их. Входная очередь очищается, когда анализатор переключается на ВКЛ.

Выходная очередь

Когда анализатор проводит разбор запроса, ответ помещается в выходную очередь до тех пор, пока контроллер не прочитает его. Ваша программа должна немедленно прочесть ответ, иначе он может быть удален из выходной очереди. Ответы на запрос будут удалены при следующих условиях:

  • Если до чтения ответа будет направлен следующий запрос. Это не выполняется, если в одном операторе отправляют несколько запросов.

  • Если отправленное программное сообщение превышает длину входной очереди.

  • Если ответное сообщение генерирует больше данных, чем может поместить очередь вывода.

  • Если анализатор в состоянии ВКЛ.

Очередь ошибок

При каждом обнаружении ошибки анализатор помещает сообщение в очередь ошибок. После отправки запроса SYSTEM:ERROR? , одно сообщение перемещается из очереди ошибок в очередь вывода, так что контроллер может прочитать его. Сообщения об ошибках попадают в выходную очередь в порядке их поступления. Очередь ошибок очищается при выполнении любого из следующих условий:

  • Если анализатор в состоянии ВКЛ.

  • Если анализатору направлена команда *CLS.

  • После прочтения всех ошибок.

При переполнении очереди ошибок последняя ошибка заменяется на ошибку "Queue Overflow" (переполнение очереди). В очереди остаются более давние ошибки, самая последняя ошибка удаляется.

Синхронизация перекрывающихся команд

Анализатор выполняет и обрабатывает команды GPIB в порядке их поступления. Команды можно разделить на два широких класса:

  • Перекрывающиеся команды - как правило, требуют большего времени обработки анализатором. Примерами функций с перекрывающимися командами являются печать и выполнение измерений. Поскольку они требуют большего времени на обработку, то дают возможность выполнять следующие команды во время обработки перекрывающихся. Однако программист может решить не допускать того, чтобы анализатор обрабатывал новые команды до выполнения перекрывающихся команд. Это называется "синхронизацией" анализатора и контроллера

  • Последовательные команды, как правило быстро обрабатываются анализатором. Поэтому они не допускают выполнения следующих команд до полного завершения обработки последовательных. Для этих команд НЕ требуется синхронизация.

  • Методы синхронизации

  • Когда синхронизировать

Методы синхронизации

Для синхронизации анализатора и контроллера используют следующие команды. Примеры иллюстрируют использование каждой команды в программе. Для того, чтобы определить, является ли команда перекрывающейся, смотрите информацию о командах SCPI.

  • *WAI

  • *OPC?

  • *OPC

*WAI

Команда *WAI:

  • Не позволяет анализатору обрабатывать следующие команды до полного завершения обработки перекрывающихся команд.

  • Не мешает контроллеру отправлять команды к этому и другим устройствам шины. Это самый простой метод синхронизации.

Пример команды *WAI

GPIB.Write "ABORT;:INITIATE:IMMEDIATE" 'Повторный запуск измерений.
GPIB.Write "CALCULATE:MARKER:SEARCH:MAXIMUM" 'Поиск максимальной амплитуды.
GPIB.Write "CALCULATE:MARKER:X?" 'Какая частота?

На следующей временной шкале показано соотношение времени обработки трех команд:

INITIATE:IMMEDIATE это перекрывающаяся команда, она разрешает немедленную обработку последовательной команды, CALCULATE:MARKER:SEARCH:MAXIMUM. Однако INITIATE:IMMEDIATE не считается выполненной до завершения измерения. Поэтому маркер ищет максимальную амплитуду до завершения измерения. Запрос CALCULATE:MARKER:X? может вернуть неточное значение.

Для решения проблемы вставьте команду *WAI command.

GPIB.Write "ABORT;:INITIATE:IMMEDIATE" 'Повторный запуск измерения.
GPIB.Write "*WAI" 'Ждать до завершения.
GPIB.Write "CALCULATE:MARKER:MAXIMUM" 'Поиск максимальной амплитуды.
GPIB.Write "CALCULATE:MARKER:X?" 'Какая частота

Теперь временная шкала выглядит следующим образом:

Команда *WAI не позволяет выполнение MARKER:SEARCH:MAXIMUM до завершения измерения. Запрос CALCULATE:MARKER:X? возвращает корректное значение.

Примечание: Несмотря на то, что *WAI не позволяет анализатору обрабатывать следующие команды, эта команда не останавливает контроллер. Контроллер может отправлять команды другим устройствам шины.

*OPC?

Запрос *OPC? останавливает контроллер до завершения выполнения всех невыполненных перекрывающихся команд.

В следующем примере оператор Read после запроса *OPC? не будет выполняться до тех пор, пока анализатор не ответит, а это не произойдет до завершения выполнения перекрывающихся команд. Следовательно, анализатор и другие устройства не получают следующих команд. После того, как анализатор закончит обрабатывать перекрывающиеся команды, в выходную очередь анализатора помещается "1". "1" в выходной очереди удовлетворяет команду Read, и программа продолжается.

Пример запроса *OPC? Click

*OPC

Команда *OPC позволяет анализатору и контроллеру обрабатывать команды во время обработки перекрывающихся команд.

После того, как анализатор закончит обрабатывать перекрывающиеся команды, команда *OPC устанавливает бит 0 регистра стандартных событий на 1. Для этого необходим опрос байтов состояния или возможности запроса на обслуживание (SRQ) вашего контроллера. За дополнительной информацией о регистре состояния стандартных событий, генерировании SRQ и обработке прерываний обращайтесь к Чтение регистра состояния анализатора.

Примечание: Будьте осторожны при отправке анализатору команд между моментом отправки *OPC и получением прерывания. Некоторые команды могут нарушить целостность измерения. Кроме того, это может повлиять на реакцию прибора на ранее отправленную *OPC.

Пример опрашиваемого бита и процессов SRQ .

Когда синхронизировать анализатор и контроллер

Синхронизация может не потребоваться, несмотря на то, что команда может быть определена, как прерывающаяся. Необходимость в синхронизации зависит от ситуации, в которой выполняется перекрывающаяся команда. В следующем разделе описаны ситуации, где для успешного функционирования необходима синхронизация.

  • Завершение измерения

  • Измерения с внешним запуском

  • Усредненные измерения

Завершение измерения

Чтобы синхронизировать завершение измерения для анализатора и контроллера, используйте последовательность команд ABORT;INITIATE:IMMEDIATE для начала измерения.

Данная последовательность команд начинает (или перезапускает) сбор данных при текущей конфигурации измерения. Последовательность перезапуска, например, ABORT;INITIATE:IMMEDIATE – это перекрывающаяся команда. Она завершается после выполнения всех операций, инициированных последовательностью команды перезапуска, включая измерение. Команды *WAI,*OPC? и *OPC дают вам возможность определить, когда завершено выполнение измерения. Это гарантирует то, что на дальнейшую обработку поступит правильное значение измерения.

Измерения с внешним запуском

Для использования внешнего запуска, перед тем как подать запуск для измерения, синхронизируйте анализатор и контроллер. Установите анализатор на получение запуска от внешнего источника (подключен к разъему EXTERNAL TRIGGER на задней панели). Система запуска усилена GPIB с INITIATE:IMMEDIATE. (Поскольку источник запуска задан, как внешний, данная команда "готовит" анализатор к запуску, но фактически не генерирует его.).

Усредненные измерения

Усредненные измерения завершаются по достижении числа подсчетов среднего. Число подсчетов среднего достигается, когда заданное количество отдельных измерений объединяется в один усредненный результат измерения. Чтобы определить достижение числа подсчетов среднего, используйте синхронизацию.

Если анализатор продолжает измерять и усреднять результаты после достижения числа подсчетов среднего, используйте синхронизацию, чтобы определить момент завершения каждого следующего измерения.


Чтение регистра состояния анализатора

Анализатор имеет несколько регистров состояния, ваша программа может читать их, чтобы узнать о конкретных событиях. Существует два метода чтения регистров состояния анализатора: метод Polled Bit (бит с опросом) и метод Service Request (запрос на обслуживание).

  • Метод битов с опросом

  • Метод запроса на обслуживание

  • Установка и чтение битов в регистрах состояния

  • Переходы в сторону повышения и понижения

  • Команды состояния

Другие разделы по GPIB

Большая часть регистров состояния анализатора – 16-битовые. Для простоты в данном разделе будет показано как использовать 8-битовые регистры. Биты регистра представляют состояние различных режимов анализатора. На следующем рисунке регистр изображен рядом окошек, каждое из которых представляет бит. Бит 3 - ВКЛ.

Метод битов с опросом

Если используется метод битов с опросом, ваша программа постоянно следит за битом регистра состояния, представляющим интересующий вас режим. Если анализатор устанавливает бит на 1, программа это немедленно заметит и соответствующим образом ответит.

Преимущество: При данном методе требуется небольшой объем программирования.

Недостаток: При данном методе ваша программа может только опрашивать необходимый бит до тех пор, пока не будет выполнено условие.

Процедура:

1. Выберите условие, которое будет отслеживаться. В разделе Команды состояния перечислены все возможные режимы анализатора, которые можно отслеживать.

2. Определите команду и бит, который будет отслеживать команду.

3. Создайте цикл для опроса бита до тех пор, пока он будет установлен.

4. Составьте программу для реагирования после установки бита.

Метод запроса на обслуживание (Service Request, SRQ)

Ваша программа включает биты регистров состояния , представляющие контролируемое условие. При выполнении условия анализатор активно прерывает вашу программу на любом действии, а обработчик событий программы реагирует соответственным образом. Пользуйтесь этим методом, если хотите отслеживать несколько условий, либо условия таковы, что нет необходимости специально ждать их выполнения.

Преимущество: Данный метод освобождает вашу программу для других действий до выполнения условия. Программа прерывается, чтобы отреагировать на условие.

Недостаток: Для данного метода может потребоваться большой объем программирования в зависимости от типа и количества контролируемых условий.

Процедура:

1. Выберите условие, которое будет отслеживаться. В разделе Команды состояния перечислены все возможные режимы анализатора, которые можно отслеживать.

2. Установите биты enable в итоговых регистрах и регистре байта состояния.

Enabling (Включение) похоже на подключение энергии к источнику света – без энергии переключатель можно включить, но свет не зажжется. В анализаторе без включения условие может быть выполнено, но контроллер не отреагирует на это, если не будет включен.

TНеобходимо включить условие и бит в итоговых регистрах по пути отчетов. Вывод: это похоже на ручьи (условия), втекающие в реки (итоговые регистры), а реки впадают в океан (контроллер). Смотрите изображение регистров состояния в Команды состояния.

Бит 6 регистра байта состояния это единственный бит, который может прервать работу контроллера. Если любой репрезентативный бит в регистре байта состояния переходит в ВКЛ, бит 6 автоматически переключается на ВКЛ.

4. Включите вашу программу на прерывание контроллера. Это можно сделать несколькими способами, зависящими от языка программирования и используемой карты интерфейса GPIB. В приведенном примере программы показано, как это выполняется на языке Visual Basic с картой GPIB National Instruments.

5. Составьте подпрограмму для обработки события прерывания. Если вы контролируете более одного условия своей системы, обработчик событий должен определить, какое из условий вызывает прерывание. Для определения прибора, вызывающего прерывание, используйте команду *SPE, затем опрашивайте итоговые регистры и регистры условия, чтобы определить причину прерывания.

Установка и чтение битов в регистрах состояния

В обоих методах чтения регистров состояния необходимо читать биты регистров. В большинстве регистров состояния анализаторов содержится 16 битов, пронумерованных от 0 до 15. Каждый бит имеет взвешенное значение. В следующем примере показано, как устанавливать биты в 8-битовом регистре состояния.

8-битовый регистр

Бит | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
Вес | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128

Мы хотим установить биты 4 и 5 включения состояния регистра стандартных событий.

Шаг | Пример
1. Прочитайте значение взвешенного бита для данных битов | вес 16 и 32 (соответственно)
2. Сложите эти значения | 16 + 32 = 48
3. Передайте данное число, как аргумент в соответствующей команде. (Смотрите Команды состояния) | STAT:QUES:LIMIT1:ENAB 1026

Переходы в сторону повышения и понижения

Регистры перехода контролируют тип из регистра условий, который будет устанавливать соответствующий бит в регистре событий.

  • Переходы в сторону повышения (0 на 1)) появляются в регистре событий только в случае, если соответствующий бит перехода в сторону повышения установлен на 1.

  • Переходы в сторону понижения (1 на 0)) появляются в регистре событий только в случае, если соответствующий бит перехода в сторону понижения установлен на 1.

  • При установке на 1 обоих битов перехода появятся сообщения о переходах и в сторону повышения, и в сторону понижения.

Регистры перехода считываемые-записываемые, на них не действуют команда *CLS (очистить состояние) или запросы. Они возвращаются к заданным настройкам при включении питания и после команд *RST и SYSTem:PRESet. Далее представлены заданные по умолчанию настройки регистров перехода:

  • Для всех регистров перехода в сторону повышения = 1

  • Для всех регистров перехода в сторону понижения = 0

Это значит, что по умолчанию анализатор будет фиксировать все регистры событий на переходе от понижения к повышению (0 на 1).

Далее представлен пример установки регистров перехода:

При критическом измерении необходимо находить среднее значение из 10 измерений, затем повторить вычисление среднего. Вы решили опросить бит усреднения. После завершения вычисления среднего значения бит выполняет переход в сторону повышения. После перезапуска вы опрашиваете бит, чтобы убедиться что он снова установлен на переход от 1 к 0 – в сторону понижения. Вы установили переход в сторону понижения для регистра усреднения.


Конфигурирование SCPI LAN с помощью SICL / VISA

  • Интерфейсы, поддерживаемые PNA

  • Библиотеки Agilent I/O

  • Запуск программ SICL / VISA на PNA

  • Конфигурирование PNA для SICL / VISA

  • Конфигурирование внешнего контроллера

Другие разделы по GPIB

Интерфейсы, поддерживаемые PNA

PNA поддерживает следующие интерфейсы для связи с SICL / VISA:

  • LAN - как дистанционный интерфейс GPIB. PNA LAN представлен, как виртуальный интерфейс GPIB. Он НЕ поддерживает простое управление на основе TCPIP. Поэтому при конфигурировании на вашем компьютере библиотек Agilent IO добавьте интерфейс REMOTE GPIB использующий клиентский интерфейс LAN.

  • GPIB - необходимо иметь карту GPIB на вашем внешнем контроллере.

Примечание: Для оптимального функционирования интерфейса LAN используйте COM, чтобы управлять PNA. Команды SCPI можно передавать к PNA с помощью объекта COM SCPIStringParser.

НЕ поддерживаются следующие интерфейсы:

  • USB - несмотря на то, что PNA использует USB для управления периферийными устройствами, с его помощью нельзя управлять PNA.

  • Serial

Важное примечание:

Чтобы подключить VISA или SICL через LAN, необходимо выполнить следующее:

  1. В PNA щелкните по System, (Система), перейдите к Configure, (Конфигурировать), затем нажмите SICL/GPIB.

  2. Отметьте поле SICL Enabled. (SICL включено). Для автоматического включения SICL при загрузке PNA отметьте поле Automatically enable on Startup (Автоматически включать при загрузке).

  3. Нажмите OK.

Теперь PNA готов к управлению через LAN.

Подробнее об этом диалоговом окне.

Библиотеки Agilent I/O

В библиотеки Agilent I/O входят драйверы, которые дают вам возможность связи с контрольно-измерительными приборами Agilent. Каждый PNA оснащен версией "М" установленных библиотек Agilent I/O. Мы НЕ рекомендуем обновлять библиотеки Agilent I/O для PNA, поскольку результаты могут быть непредсказуемыми. Если вы решили обновить библиотеки Agilent I/O для PNA, НЕ выбирайте заданный по умолчанию путь к папке в Помощнике InstallShield.

Кроме того, для связи с PNA библиотеки Agilent I/O должны быть установлены на вашем внешнем контроллере. Чтобы приобрести библиотеки Agilent I/O или загрузить бесплатное обновление, перейдите к www.agilent.com и найдите IO Libraries. Найдите Software (программное обеспечение), Firmware (встроенные программы) & Drivers (драйверы).

Запуск программ SICL / VISA на PNA

Для управления PNA на нем можно запустить программу SICL / VISA. Несмотря на то, что библиотеке Agilent I/O уже установлены на PNA, он сконфигурирован, как Host. Вам также необходимо сконфигурировать на PNA клиентский интерфейс SICL или VISA LAN, указав имя главного узла LAN того же PNA.

Если в вашей программе для связи с VISA используется интерфейс COM, и он компилирован на компьютере с Agilent IO Libraries Suite (версия 14 или более поздняя), и полученный выполняемый файл скопирован и запущен на PNA, появиться сообщение “type mismatch error” (ошибка несовместимости типа). Это происходит потому, что в PNA установлена версия 'М' библиотек Agilent I/O. Следующий код Visual Basic – это пример того, как избежать такой ошибки при связи с PNA из самого PNA:

Dim rm As IResourceManager
Dim fmio As IFormattedIO488
Set rm = CreateObject("AgilentRM.SRMCls")
Set fmio = CreateObject("VISA.BasicFormattedIO")
Set fmio.IO = rm.Open("GPIB0::22")
fmio.WriteString "*IDN?" & Chr(10)
MsgBox fmio.ReadString()

Управление PNA по LAN при том, что управление другими приборами выполняется через GPIB

PNA не может одновременно выполнять функции контроллера и источника/приемника на одной и той же шине GPIB. С помощью SICL / VISA вы можете использовать LAN для управления PNA, таким образом PNA сможет использовать интерфейс GPIB задней панели для управления устройствами GPIB.

Конфигурирование PNA для SICL / VISA

  1. В PNA щелкните по System (Система), затем отметьте поле Windows Taskbar

  2. Нажмите Start затем перейдите к Program Files, Agilent IO Libraries, и нажмите IO Config

  3. Выбирайте каждый интерфейс GPIB и нажимайте Edit (редактировать), чтобы проверить (или установить) заданные по умолчанию настройки в следующей таблице. Данные настройки НЕОБХОДИМЫ при использовании интерфейса 82357A USB / GPIB с PNA.

  4. По завершении нажмите OK, чтобы закрыть диалог редактирования.

  5. 5. Нажмите OK чтобы закрыть диалог конфигурирования.

Имя интерфейса VISA | Имя интерфейса SICL | Название диалогового окна | Описание
GPIB0 | gpib0 | GPIB с использованием NI-488.2 | Разъем GPIB задней панели PNA. Интерфейс GPIB можно использовать для управления PNA ИЛИ для управления внешним оборудованием. ОН НЕ МОЖЕТ ВЫПОЛНЯТЬ ОБЕ ФУНКЦИИ В ПРЕДЕЛАХ ОДНОЙ ПРОГРАММЫ. Подробнее об опциях pass-through.
GPIB1 | hpib7 | Конфигурирование внутреннего инструмента | Внутренний интерфейс для самоуправления запущенных на PNA программ.

Конфигурирование внешнего контроллера

За информацией по конфигурированию контроллера для связи с PNA обращайтесь к документации по библиотекам Agilent I/O. По данным ссылкам вы увидите, как найти следующую информацию о PNA:

  • Полное имя компьютера PNA

  • Адрес GPIB

  • Адрес IP

Этот пример программы поможет вам протестировать конфигурацию VISA.


RPAuxIO Connector

Auxiliary I/O Connector

General Description

This DB-25 male connector provides a variety of analog I/O, digital I/O, timing I/O, and supply lines. You can change the settings on the Auxiliary IO connector through SCPI and COM programming commands. The settings are NOT accessible through the front-panel keys or display menu.

Note: AUX IO settings remain Instrument Preset will clear the

Note: The AUX IO configuration settings REMAIN after an Instrument Preset and Hibernation. However, Preset will clear the DAC values. The settings will revert to their default settings ONLY after the PNA is restarted, or until they are changed by you. AUX IO settings are saved and recalled with Instrument State.

Pin | Name | Description
1 | ACOM | Ground reference for analog signals
2 | Analog Out 2 | -10 to +10Vdc output, 10mA max
3 | Analog Out 1 | -10 to +10Vdc output, 10mA max
4 | no connect | for future enhancements
5 | DCOM | Ground reference for digital signals
6 | reserved | for future enhancements
7 | reserved | for future enhancements
8 | reserved | for future enhancements
9 | +5V | +5Vdc output, 100mA max.
10 | Pass/Fail Write Strobe | Indicates pass/fail line is valid (active low)
11 | Sweep End | Indicates sweep is done (programmable modes)
12 | Pass/Fail | Indicates pass/fail (programmable logic, modes and scope)
13 | Output Port Write Strobe | Writes I/O port data (active low)
14 | Analog In | -10 to +10VDC analog input
15 | ACOM | Ground reference for analog signals
16 | Power Button In | Grounding replicates front panel power button press
17 | DCOM | Ground reference for digital signals
18 | Ready for Trigger | Indicates ready for external trigger (active low)
19 | External Trigger In | Measurement trigger input (programmable to be active high or low)
20 | Footswitch In | Active low input latches a user-readable status bit.
21 | +22V | +22Vdc output, 100mA max.
22 | In/Out port C0 | General purpose input / output
23 | In/Out port C1 | General purpose input / output
24 | In/Out port C2 | General purpose input / output
25 | In/Out port C3 | General purpose input / output

ACOM (pins 1, 15)

Description

Analog common (ground) - To be used with the Analog Out and Analog In lines.

ACOM and DCOM are connected to system ground at a star ground point inside the analyzer.

Analog Out 1, 2 (pins 2, 3)

Description

Two analog outputs programmable to +/-10V; Iout<10mA; Rout=100 ohms

12-bit DACs with voltage resolution of approximately 5mV/count.

The DACs are set to constant values using SCPI or COM, and can be read using SCPI or COM commands.

Preset state for both pins is 0 volts.

HW Details

Looking into this output pin is a 100-ohm series resistor followed by two diodes tied to +/-15V for static protection, then the output or an op-amp.

The voltage output is provided by a 12-bit DAC with an op amp buffer.

Specifics:

  • Maximum output current = 10mA

  • Settling time = 3us

Timing

The DACs are set after the last data point is measured, during retrace. If the analyzer is in single sweep mode, the DACs are set as part of the presweep process, before the sweep is triggered.

DCOM (pins 5, 17)

Description

Digital common (ground).

Used with the digital input and output lines.

ACOM and DCOM are connected to system ground at a star ground point inside the analyzer.

Pins 6, 7, 8

Description

Reserved

+5V (pin 9)

Description

+5V nominal output (100mA max).

Protected by self-healing fuse:

Pass/Fail Write Strobe (pin 10)

Description

See Handler IO connector.

Sweep End (pin 11)

Description

See Handler IO connector.

Pass/Fail (pin 12)

Description

See Handler IO connector.

Output Port Write Strobe (pin 13)

Description

See Handler IO connector.

Analog In (pin 14)

Description

Analog input, +/-10V range, Rin=100k ohm

Bandwidth = 40kHz (2-pole lowpass filter).

This analog input may be read using the SCPI or COM commands.

HW Details

Looking into this pin there is 1k-ohm series resistor followed by 100k-ohm resistor to ground, static protection diodes after the 1k resistor limit the signal to +/-15V, then a high impedance buffer and active filter limiting the bandwidth to 40kHz with a lowpass filter.

Power Button In (pin 16)

Description

Short this pin to ground to replicate a front panel power button key press.

HW Details

Looking into the pin there is a 215-ohm series resistor followed by a 10k pull-up to the 3V standby supply, static protection diodes to the 0V/5V and then connects to the front panel power key circuit.

CAUTION: Because this line is internally pulled up to 3V, it should not be driven by a TTL driver.

Timing

Grounding this line for 1us to 2 seconds will simulate pressing the front panel power button.

Grounding this line for >4 seconds will perform a hard reset (similar to a personal computer) and is not recommended.

Ready for Trigger (pin 18)

Description

TTL output.

Active Low signal indicates that system is ready for an external trigger.

Remains High if system is not in External Trigger mode.

Goes High after an External Trigger is acknowledged.

Goes Low after the system has finished with its measurements, the source has been set up, and the next data point is ready to be measured.

HW Details

Looking into this pin there is a 215-ohm series resistor followed by a 10k pullup, diodes to 0V/5V for static protection, then the output of an "ABT" TTL buffer.

This line is enabled only when the analyzer is in External Trigger mode.

Refer to External Trigger In (following pin) for more information.

Timing

Refer to External Trigger In (following pin)

External Trigger In (pin 19)

Description

This input accepts level trigger signals (High / Low) on all PNA models, or edge trigger signals on some PNA models.

The external trigger configuration is set from the front panel, SCPI or COM.

For more information, see External triggering.

A single trigger is achieved by asserting the external trigger for a period from 1us to 50us. Continuous triggering is achieved by holding the external trigger in the "asserted" mode (either Low or High).

HW Details

Looking into this pin is a 215-ohm series resistor followed by a 4.64k pullup, 1000pF to ground and then a "FAST" TTL buffer input.

Timing

A level trigger width should be between 1us and 50us.

Footswitch In (pin 20)

Description

TTL input.

A Low level input such as shorting this line to ground using a footswitch (where the input stays low for >1us) will be latched.

The latched status may be read using the SCPI or COM commands.

Only one footswitch press can be latched (remembered) by the system.

Reading the latch status will reset it if Footswitch In has returned to a high level.

HW Details

Looking into this pin is a 215-ohm series resistor followed by a 4.64k pullup to 5V and 1000pF to ground. This line is an input to a "FAST" TTL buffer.

Timing

Footswitch In must be Low for at least 1us.

+22V (pin 21)

Description

+22V nominal output (100mA max).
Protected by self-healing fuse.

In/Out Port C0-C3 (pins 22-25)

Description

See Handler IO connector


RPTestSetIO Connector

External Test Set I/O Connector

General Description

This DB-25 female connector is used to control external test sets. The external test set bus consists of 13 multiplexed address and data lines, three control lines, and an open-collector interrupt line. The Test Set IO is not compatible with the 8753 test sets.

You can change the settings on the External Test Set IO connector through SCPI and COM programming commands. The settings are NOT accessible through the front-panel keys or display menu.

Notes:

  • The External Test Set pin settings are NOT affected by Instrument State Save/Recall or Instrument Preset.

  • At PNA Power Up and return from Hibernation, the External Test Set bus data lines, address lines, and control lines are set HIGH, and no strobe lines are pulsed.

Caution: Do not mistake this connector with a Parallel Printer port. A printer may be damaged if connected to this port.

Pin | Name | Description
1 | SEL0 | Test set select bit 0; tied to GND
2 | Sweep Holdoff In | TTL input - state may be read with SCPI or COM command
3 | AD12 | Address and latched data
4 | AD10 | Address and latched data
5 | AD9 | Address and latched data
6 | AD8 | Address and latched data
7 | GND | 0V
8 | LAS | TTL output Low = Address Strobe
9 | AD4 | Address and latched data
10 | AD3 | Address and latched data
11 | AD2 | Address and latched data
12 | GND | 0V
13 | Interrupt In | TTL input - state may be read with a SCPI or COM command
14 | No connect | CAUTION: Older PNAs have +22v on this line; this will damage a printer.
15 | SEL1 | Test set select bit 1; tied to GND
16 | SEL2 | Test set select bit 2; tied to GND
17 | AD11 | Address and latched data
18 | SEL3 | Test set select bit 3; tied to GND
19 | AD7 | Address and latched data
20 | AD6 | Address and latched data
21 | AD5 | Address and latched data
22 | AD0 | Address and latched data
23 | AD1 | Address and latched data
24 | LDS | TTL output - active low data strobe
25 | RLW | TTL output - high-read, low write

SEL0-SEL3 (pins 1,15,16,18)

Description

Selects addresses of test sets that are "daisy chained" to this port. The select code is set to zero at the PNA connector and is incremented by one as it goes through each successive external test set. Therefore, the first test set in the chain has address zero and so on, for up to 16 test sets.

HW Details

Connected to ground inside the PNA.

Timing

None

Sweep Holdoff In (pin 2)

Description

Input line used by the test set for holding off a sweep. Holding off a sweep is one way of introducing a delay that allows an external device to settle before the PNA starts taking data. You must write a program that will query the line and perform the delay. The program needs to query the line and keep PNA from sweeping while the line remains low. When a subsequent query detects that the line went high the program would then trigger the PNA to start the sweep.

Use either Single or External trigger mode to control the PNA sweep.

HW Details

This pin has a series 215-ohms resistor followed by 4.7k-ohm pull-up and then an "ABT" TTL buffered register.

Timing

This input is not latched by the PNA hardware. Therefore the input level must be held at the desired state by the test set until it's read by your program.

AD0-AD12 (pins 3-6, 9-11, 17, 19-23)

Description

Thirteen lines are used to output data addresses or input / output data. Several SCPI and COM commands are available for reading and writing to these lines. You can choose to use commands where the PNA provides the appropriate timing signals needed for strobing the addresses and data. Or you can choose to control the timing signal directly. The timing signals are RLW, LAS and LDS. If you decide to do direct control refer to the corresponding SCPI and COM command details. Close attention to detail is needed to insure the desired results.

After a write command, lines AD0-AD12 are left in the state they were programmed. Default setting for Mode is Read / Input).

After a read command, lines AD0-AD12 are left in input mode. While in this mode an external test set attached to the IO is free to set the level on each line.

HW Details

Each of these I/O pins has a series 215-ohm resistor followed by 4.7k-ohm pull-up resistor.

Write/Read is implemented by an output tri-state TTL buffer / latch for latching and enabling write data in parallel with a TTL input buffer for reading.

Timing

Output Address and data setup and hold times are 1us minimum.

Address & Data I/O Write

Address & Data I/O Read - Data must be valid for 1us before and after strobe

GND (pins 7, 12)

Description

Two ground pins used as ground references by the test set.

HW Details

Connected to digital ground.

Timing

None.

LAS (Low Address Strobe) (pin 8)

Description

This line has two behaviors that are command dependent. Refer to the SCPI and COM commands for further details.

In one behavior LAS is one of the lines used by the PNA to provide appropriate timing for writing Address and Data to the Test Set. In this case LAS is controlled automatically by the PNA and is intended to be used as the strobe for the Address. When LAS is low, lines AD0 - AD12 represent the Address. LAS will return to its normally high state when the transaction is finished.

In the second behavior the PNA will NOT provide appropriate timing. In this case LAS is controlled directly by the user through a SCPI or COM command. When the transaction is finished LAS is left set to the state it was programmed to until another command changes it. (Default for LAS is TTL High).

HW Details

This output pin is driven by a TTL latched buffer with a series 215-ohm resistor followed by 2.15k-ohm pull-up.

Timing

Strobe length, setup and hold times are all 1us minimum.

See the description for AD0-AD12 for more timing information.

Interrupt In (pin 13)

Description

Query this line with a SCPI or COM command.

HW Details

This line is a non-latched TTL input, has series 215-ohms followed by 4.64k-ohm pullup.

Timing

The Test Set must maintain at the desired TTL level until its read.

(pin 14) No Connect (previously +22V )

WARNING: Early versions of the PNA had +22v on this pin. Connecting a printer to this port will usually damage the printer.

Description

+22V, 100mA max. The 25-pin D connector is the same as a computer parallel printer port connector. Pin (14) corresponds to a printer's "autofeed" line. Connecting a printer to this port will damage the printer if +22v is present since printers requires less than 5V on all control lines.

HW Details

No connect

Timing

None

LDS (Low Data Strobe) (pin 24)

Description

This line has two behaviors that are command dependent. Refer to the External Test Set IO SCPI and COM commands for further details. (Default setting for LDS is TTL High)

In one behavior LDS is one of lines used by the PNA to provide appropriate timing for writing Address and Data to the Test Set. In this case LDS is controlled automatically by the PNA and is intended to be used as the strobe for the Data. When LDS is low, lines AD0 - AD12 represents Data. LDS will return to its normally high state when the transaction is finished.

In the second behavior the PNA will NOT provide appropriate timing. In this case LDS is controlled directly by the user through a SCPI or COM command. When the transaction is finished the LDS is left set to the state it was programmed to.

HW Details

This output pin is driven by a TTL latched buffer with a series 215-ohm resistor followed by 2.15k-ohm pull-up.

Timing

Strobe length, setup and hold times are all 1us minimum.

See the description for AD0-AD12 for more timing information.

RLW (pin 25)

Description

This line is the output for the Read Write signal. It has two behaviors that are command dependent. Refer to the External Test Set IO SCPI and COM commands for further details. (Default setting for RLW is TTL High)

In one behavior RWL is controlled automatically by the PNA during a Read Write operation. When RLW is low, lines AD0 - AD12 represent output Data. When RLW is high, the lines represent input Data.

In the second behavior the PNA does NOT provide the timing. The user must control it directly through the SCPI or COM command. In this case the line is left set to the state it was programmed to.

HW Details

This pin is a TTL latched output with a series 215-ohm resistor followed by 2.15k-ohm pull-up resistor.

Timing

Strobe length, setup and hold times are all 1us minimum.

See the description for AD0-AD12 for more timing information.


RPHandler IO Connector

Material Handler I/O Connector

This rectangular 36-pin female connector provides communication signals between the PNA and a material parts handler. You can change the settings on the Material Handler IO connector using SCPI and COM commands. The settings are NOT accessible through the front-panel keys or display menu.

  • Overview - Controlling a Material Handler

  • Pin Assignments

  • Pin Descriptions

  • Timing Diagrams

  • Input Output Electrical Characteristics

Note: On early PNAs this connector is labeled "GPIO". It is covered to indicate that the connector is not functional.

Overview - Controlling a Material Handler

The PNA is capable of interacting with an external material handler or part handler. This allows the PNA to be used in an automated test environment, where devices to be tested are inserted into a test fixture by a part handler, and sorted into pass/fail bins by the handler after testing is complete. By connecting the part handler to the PNAs Auxiliary or Material Handler I/O ports, the PNA and part handler can synchronize their activities in a way that makes automated testing possible.

PNA and Part Handler Preparation

  1. Define the measurements you want to make.

  2. Define limits for each of the measurements.

  3. Configure the PNAs Material Handler port so that it is compatible with your part handler. This usually involves setting the handler logic, pass/fail logic, pass/fail scope, and pass/fail mode. These settings are made remotely using SCPI or COM commands.

  4. Use a cable to connect the PNA to your part handler.

  5. Put the PNA in External Trigger mode.

  6. Load parts in handler per manufacturer instructions.

Note: The Material Handler configuration settings REMAIN after an Instrument Preset and Hibernation. The settings will revert to their default settings ONLY after the PNA is restarted, or until they are changed by you. Material Handler settings are saved and recalled with Instrument State.

Flow Diagram

The following diagram and descriptions summarizes the events that occur during automated testing. 'DUT' refers to Device Under Test.

Text Descriptions

  1. (Optional). The PNA sends values out the Material Handler and/or Auxiliary I/O connectors to configure external instruments. The A,B,C, and D ports of the Material Handler can be used to control devices used in testing, such as step attenuators, part handlers, or even the DUT itself. Also, the DAC1 and DAC2 lines on the Aux I/O connector can be used to provide bias voltages for devices and instruments. If you wish to use the Material Handler or Aux connectors for testing, you will need to write a program to send values out the various lines and ports, as there is no activity on these lines by default.

  2. The part handler receives a Ready for Trigger signal from the PNA. This indicates that the PNA is properly configured and ready to take a measurement.

  3. The part handler sends an External Trigger signal to the PNA. This signals that the part handler has settled, and allows the PNA to begin taking measurements.

  4. The PNA takes measurements on all triggerable channels.

  5. The Index line on the material handler goes to a Low state, which means that all required data has been collected by the PNA.

  6. The part handler removes the DUT from the test fixture, and inserts a new DUT into the fixture. This operation is often referred to as part handler indexing. The device just tested is staged (removed from the fixture and prepared for binning), and the next part to be tested is put into the fixture. The removed DUT cannot be assigned to a Pass/Fail bin yet, as the Pass/Fail status is not available.

  7. The PNA sends the Pass/Fail Status.

  8. The PNA sends the Pass/Fail Strobe meaning that the Pass/Fail status has been determined.

  9. The part handler reads the Pass/Fail Status line.

  10. The part handler bins the staged part based on the Pass/Fail Status.

  11. The test process repeats at step 1, waiting for Ready for Trigger from the PNA.

Material Handler IO Pin Assignments

There are three different Handler IO pin assignment configurations depending on the PNA model:

  • Type 1 - All 3 GHz, 6 GHz, and 9 GHz PNA models. You can change the pinout configuration to Type 2 on these models. This requires opening the instrument and changing a connector internally. Refer to the procedure in the Service Guide, Chapter 7. You can download a copy of the Service Guide from our Web site at http://www.agilent.com/find/pna. Caution: Changing this connection should be done by qualified service personnel.

  • Type 2 - All PNA models EXCEPT 3 GHz, 6 GHz, and 9 GHz and N5230 Opt 240, 245.

  • Type 3 - N5230 Options: 020,025,120,125, 240, 245

See PNA models and options.

Shaded/bold indicates changes from Type 1

Note: A slash (/) preceding the signal names indicates that the signal uses negative (active low) logic. A low pulse is a logical 1.

Pin | Type 1 | Type 2 | Type 3
1 | Ground | Ground | Ground
2 | / INPUT1 | / INPUT1 | / INPUT1
3 | / OUTPUT1 | / OUTPUT1 | / OUTPUT1
4 | / OUTPUT2 | / OUTPUT2 | / OUTPUT2
5 | / Output port A0 | / Output port A0 | / Output port A0
6 | / Output port A1 | / Output port A1 | / Output port A1
7 | / Output port A2 | / Output port A2 | / Output port A2
8 | / Output port A3 | / Output port A3 | / Output port A3
9 | / Output port A4 | / Output port A4 | / Output port A4
10 | / Output port A5 | / Output port A5 | / Output port A5
11 | / Output port A6 | / Output port A6 | / Output port A6
12 | / Output port A7 | / Output port A7 | / Output port A7
13 | / Output port B0 | / Output port B0 | / Output port B0
14 | / Output port B1 | / Output port B1 | / Output port B1
15 | / Output port B2 | / Output port B2 | / Output port B2
16 | / Output port B3 | / Output port B3 | / Output port B3
17 | / Output port B4 | / Output port B4 | / Output port B4
18 | no connect | / Output port B5 | / Ext. Trigger
19 | / Output port B5 | / Output port B6 | / Output port B5
20 | / Output port B6 | / Output port B7 | / Output port B6 - / Index Signal
21 | / Output port B7 | / In/Out port C0 | / Output port B7 / Ready for Trigger
22 | / In/Out port C0 | / In/Out port C1 | / In/Out port C0
23 | / In/Out port C1 | / In/Out port C2 | / In/Out port C1
24 | / In/Out port C2 | / In/Out port C3 | / In/Out port C2
25 | / In/Out port C3 | / In/Out port D0 | / In/Out port C3
26 | / In/Out port D0 | / In/Out port D1 | / In/Out port D0
27 | / In/Out port D1 | / In/Out port D2 | / In/Out port D1
28 | / In/Out port D2 | / In/Out port D3 | / In/Out port D2
29 | / In/Out port D3 | Port C Status | / In/Out port D3
30 | Port C Status | Port D Status | Port C Status
31 | Port D Status | / Output Port Write Strobe | Port D Status
32 | / Output Port Write Strobe | no connect | / Output Port Write Strobe
33 | / Pass/Fail | / Pass/Fail | / Pass/Fail
34 | / Sweep End | +5V | / Sweep End
35 | +5V | / Sweep End | +5V
36 | / Pass/Fail Write Strobe | / Pass/Fail Write Strobe | / Pass/Fail Write Strobe

Pin Descriptions

Input1

When this Input line receives a Low pulse from the material handler, data is latched on the OUTPUT1 and OUTPUT2 lines. See OUTPUT1|2 Data Output Write Timing

Note: Type 1 and Type 2 Behavior: The Input line responds to a High (rising edge) pulse.

The Input Line activity can be read:

SCPI

COM

CONTrol:HANDler:INPut?

get_Input1 Method

Output1, Output2

See OUTPUT1|2 Data Output Write Timing

The current state of these latched TTL outputs may be set High or Low (Default setting) using the (non-user) SCPI put_Output (COM) commands.

The next state (following a negative edge on the INPUT1 line) may be pre-loaded to High or Low (Default setting) using the user commands.

For example, on the next negative pulse on the INPUT1 line, you want the OUTPUT1 line to go from 0 to 1. To do this:

CONT:HAND:OUTP1:DATA 0 'Force the OUTPUT1 line to 0
CONT:HAND:OUTP1:USER 1 'Set the OUTPUT1:USER buffer to 1, indicating the next state

SCPI

COM

Write User Data

CONT:HAND:OUTP<pin>:USER

put_Output Method

Read last value written

CONT:HAND:OUTP<pin>:USER

get_Output Method.

Write non-user data

CONT:HAND:OUTP<pin>:DATA

put_Output Method

Read last value written

CONT:HAND:OUTP<pin>:DATA

get_Output Method

Output Ports A and B

These two general purpose, 8-bit output ports are used to write data to the material handler. When any line changes state, all output lines are latched to the I/O connector as the Output Write Strobe goes Low.

The default state for data is Low.

See Data Output Write Timing Diagram

Set Port Logic:

The logic for the data lines can be set to either: Positive (1 = High) or Negative (1 = Low). This setting affects all data ports. They cannot be set independently.

SCPI

COM

CONTrol:HANDler:LOGic

PortLogic Property

Combine to read or write data to Port F:

Ports A and B can be virtually combined to write data to one 16-bit I/O port F.

SCPI

COM

CONTrol:HANDler:F <num>

put Port (F)

Input/Output Ports C and D

These two general purpose 4-bit Input/Output ports are used to write data (Output) or read data (Input). These lines could be used to write to an external device such as a step attenuator.

When any line changes state, all output lines are latched to the I/O connector as the Output Write Strobe goes Low. See Data Output Write Timing

The four lines of Port C are connected internally to the Auxiliary IO connector.

Set Input | Output Mode:

Each port may be independently defined as Output or Input.

SCPI

COM

CONTrol:HANDler:C:MODE

PortMode Property

CONTrol:HANDler:D:MODE

Set Port Logic:

The logic for the data lines can be set to either: Positive (1 = High) or Negative (1 = Low). This setting affects all data ports. They cannot be set independently.

SCPI

COM

CONTrol:HANDler:LOGic

PortLogic Property

Read or write data:

Ports C and D can be virtually combined to read or write data to one 8-bit I/O port E. When combined, both C and D ports must be set to either INPUT or OUTPUT mode.

SCPI

COM

CONTrol:HANDler:<port>[:DATa]>

get_Port(x)

put Port (x)

Port C Status, Port D Status

These two output lines indicate the Read / Write mode of the C and D ports.

  • A Low level indicates that the associated port is in INPUT mode (read only).

  • A High level indicates that the associated port is in OUTPUT mode (write only).

These logic of these status outputs cannot be changed.

See Input/Output Ports C and D to learn how to set I/O Mode

See Data Output Write Timing

Output Port Write Strobe

This Output line goes Low to write data from Ports A and B and Ports C and D when a change is detected on any of the data lines.

These logic of this strobe output cannot be changed.

This line is shared with Auxiliary IO connector.

See Data Output Write Timing

External Trigger

When trigger source is set to external, this Input line accepts a trigger signal from the material handler. This usually means that a part is in place and ready to be tested.

See Trigger Timing Diagram

Index

A Low signal on this Output line indicates to the material handler that the measurement is complete. This usually means that the handler can connect the next device. However, measurement data is not available until data is calculated. S ee Trigger Timing Diagram.

Set Function:

This line also serves as a data line. Set the function using the following commands:

SCPI

COM

CONTrol:HANDler:INDex:STATe

IndexState

Ready for Trigger

When this output line goes low, it indicates to the material handler that the PNA is ready for a trigger signal.

See Trigger Timing Diagram

See Pass/Fail Timing Diagram

Set Function:

This line also serves as a data line. Set the function using the following commands:

SCPI

COM

CONTrol:HANDler:RTRigger:STATe

ReadyForTriggerState

Pass/Fail State

This Output line indicates to the handler whether the limit test has passed or failed.

Pass/Fail state is valid only when the limit test function is ON and while Pass/Fail strobe line is Low. See Pass/Fail Timing Diagram

This line is shared with the Auxiliary IO connector.

Set Pass / Fail Logic:

  • Positive Logic: High=Pass, Low=Fail. (Default setting)

  • Negative Logic: High=Fail, Low=Pass.

SCPI

COM

CONTrol:HANDler:PASSfail:LOGic

PassFailLogic Property

Set Default Conditions:

  • PASS- the line stays in PASS state. When a device fails, then the line goes to fail after the Sweep End line is asserted.

  • FAIL- the line stays in FAIL state. When a device passes, then the line goes to PASS state after the Sweep End line is asserted.

  • No Wait- the line stays in PASS state. When a device fails, then the line goes to fail IMMEDIATELY. (Default setting)

SCPI

COM

CONTrol:HANDler:PASSfail:MODE

PassFailMode Property

Set Pass / Fail Scope:

  • Channel scope: The line resets to the default state after the measurements on a channel have completed.

  • Global scope: The line resets to the default state after the measurements on all triggerable channels have completed. (Default setting)

SCPI

COM

CONTrol:HANDler:PASSfail:SCOPe

PassFailScope Property

Pass/Fail Write Strobe

A Low pulse indicates that Pass/Fail line is valid and the Pass / Fail State is output to the material handler.

This line is shared with the Auxiliary IO connector.

The Pass/Fail Strobe is fixed in duration and timing. However, when the strobe occurs depends on the Pass/Fail Mode and Pass/Fail Scope (Channel or Global) settings. See Pass/Fail State

See Pass/Fail Timing Diagram

+5V

+5V nominal output (100mA max).

Protected by self-healing fuse.

Sweep End

This output line indicates the status of the PNA sweep. The sweep includes sweeping the source and taking data.

  • Low (falling edge) indicates that the specified sweep event has finished. This does NOT indicate that all calculations have finished.

  • High indicates that the specified sweep event is active.

See Trigger Timing Diagram

This line is shared with the Auxiliary IO connector.

Set Sweep Event Mode:

  • Sweep: indicates that a single source sweep has finished. (Default setting)

  • Channel: indicates that a single channel has finished.

  • Global: indicates that all enabled channels have finished.

SCPI

COM

CONTrol:HANDler:SWEepend

SweepEndMode Property

Timing Diagrams

Trigger Timing

All signals are active low.

T1 = 1 ms External Trigger pulse width

T2 > 10ms Sweep End pulse width (both High and Low)

Pass / Fail Timing

T1 = 1 ms Pulse width and response time of Pass / Fail Strobe

T2 > 10 ms Ready for Trigger lag

Ports A-F Data Output Write Timing

T1 = 1 ms Write Strobe response time

T2 = 1 ms Write Strobe pulse width

OUTPUT1|2 Data Output Write Timing

The old state to new state transition can be either low to high (as shown) or high to low.

T1 = .6 ms Output1|2 response time

T2 = 1 ms Input1 Strobe pulse width

Input / Output Electrical Characteristics

All Material Handler I/O Input and Output lines are TTL compatible.

Input and Input/Output lines

Lines carrying information IN (or bidirectional) to the PNA from the material handler.

Maximum Input Voltages: | -0.5 V to 5.5 V
TTL High level: | 2.0 V to 5.0 V
TTL Low level: | 0 V to 0.5 V

PNA Input and Input/Output Circuit Diagram

To Handler I/O Port

Note: The INPUT1 line does NOT have the 10K pullup resistor.

Output Lines

Lines carrying information OUT of the PNA to the material handler.

Maximum Output Current: |  | -10 mA to 10 mA
Output Current | TTL High level: | -5 mA
 | TTL Low level: | 3 mA
Output Voltage | TTL High level: | 2.0 V to 3.3 V
 | TTL Low level: | 0 V to 0.8 V

PNA Output Circuit Diagram

To Handler I/O Port


Использование COM и SCPI

Существует два способа удаленного управления PNA: COM и SCPI. В следующих разделах описаны критерии выбора метода под конкретные потребности:

  • Программное подключение (Software Connection)

  • Физическое соединение (The Physical Connection)

  • Выбор метода

  • Языки программирования

Другие разделы по технологии COM

Программное подключение (Software Connection)

Технология COM использует двоичный протокол, позволяющий напрямую вызывать функции PNA. Этот способ более эффективный чем SCPI. Например, приведенный ниже оператор напрямую вызывает функцию PNA GetIDString.

PNA.GetIDString()

SCPI представляет собой текстовый инструментальный язык. Для получения строки идентификатора необходимо отправить на PNA следующую строку:

IbWrite( "*IDN?")

Разборщик PNA SCPI декодирует текстовую строку, для определения того, что пользователь послал на PNA команду идентификации. После этого он вызовет функцию GetIDString().

Физическое соединение (The Physical Connection)

Внутреннее управление

При использовании как COM так и SCPI, наивысшая пропускная способность достигается при работе с встроенным в PNA PC. Однако, если Ваш тестовый код использует слишком много системных ресурсов (процессорного времени и/или памяти), производительность PNA ухудшится.

При помощи библиотек ввода/вывода SICL можно подключиться к PNA из выполняющейся на нем программы.

Внешнее управление

Имеется возможность управления PNA с удаленного ПК при помощи COM или SCPI.

COM – (модель составных объектов) может быть использована для доступа к любой программе, например PNA (835x.exe) или библиотеке (.dll), экспортирующей ее функции в СОМ-совместимую модель. Эти программы или библиотеки называются "серверами". Программы (например, программа на Вашем удаленном ПК), подключаемые к этим серверам и вызывающие их функции, называются "клиентами".

При использовании технологии COM клиент и сервер могут находиться на разных машинах. Технология DCOM (распределенная COM) делает местоположение сервера прозрачным для клиента. Технология DCOM используется при доступе к PNA с удаленного компьютера. В этом случае данные передаются по локальной сети (LAN).

SCPI - подключение к прибору осуществляется при помощи карты интерфейса GPIB и кабеля GPIB. Длина кабеля и количество одновременно подключаемых приборов ограничены.

При помощи библиотек ввода/вывода Agilent SICL можно подключить прибор через соединение по локальной сети.

(LAN или INTERNAL) Команды SCPI отправляются при помощи COM-объекта ScpiStringParser.

Выбор метода

Практически всегда рекомендуется выбирать технологию COM по следующим причинам:

  • В большинстве случаев COM работает быстрее.

  • Технология COM более проста в использовании. Технологию COM поддерживают современные средства разработки, значительно облегчающие процесс написания программ.

  • В будущем основной упор будет сделан на развитии COM-технологии как основного способа программирования.

Однако выбор метода соединения зависит от ситуации. Ниже рассмотрены критерии выбора:

  1. Если PNA используется для управления другими приборами GPIB, то для взаимодействия с PNA предпочтительней использовать COM. В режиме GPIB PNA не может быть сконфигурировано одновременно в системный контроллер (System Controller) и talker/listener. Поскольку PNA не поддерживает управление прохождением данных, возможно одновременное использование только одного режима.

  2. Если у Вас есть старый, написанный на SCPI код для другого сетевого анализатора, его можно будет использовать для управления PNA. Однако PNA использует платформу, отличную от предыдущих анализаторов Agilent. Поэтому не для всех команд существуют прямые замены. См. Транслятор кода PNA (PNA Code Translator Application.)

Языки программирования

Имеется возможность программирования PNA при помощи COM или SCPI, используя несколько языков программирования. Наиболее часто используемые языки:

Agilent VEE - этот язык используется для отправки текстовых команд SCPI и автоматизации. Рекомендуется использовать VEE 6.0 или более позднюю версию.

Visual Basic - Отличная поддержка объектов автоматизации, также можно использовать команды SCPI. Использование драйверов VISA для аппаратного интерфейса GPIB позволяет упростить задачу отправки команд SCPI.

C++ - Позволяет использовать все возможности. Этот язык не такой простой в использовании, как предыдущие, но более гибкий.


Code Translator

Приложение Преобразователь кода

Приложение Преобразователь кода (Code Translator, CXL) дает возможность контролировать то, как PNA использует 8753, тестовые программы 872x или 8510 (Legacy) GPIB. Приложение CXL работает с PNA и обрабатывает каждую традиционную команду в реальном времени, сначала распознает допустимость традиционных команд, затем выполняет эквивалент команды PNA, если он существует.

Кроме того, приложение CXL преобразует программы Legacy в команды SCPI и COM для PNA.

Приложение CXL работает с программами HP-VEE, Visual Basic и RMB. Приложение CXL необходимо использовать с прошивкой PNA, версия A.04.00 или более поздняя.

Установка приложения CXL

Загрузите приложение CXL с http://na.tm.agilent.com/pna/programming/. Для установки приложения CXL дважды щелкните по пиктограмме InstallShield.

Для приложения CXL имеется собственный файл справки, куда включены перекрестные ссылки на команды для моделей 8510/8753/872x и команд PNA.


Анализатор цепей. Основы.

Эта мультимедийная презентация предназначена для работы на PNA.

Нажмите здесь, чтобы продолжить читать Анализатор цепей. Основы.

Чтобы просмотреть презентацию на внешнем ПК, скопируйте все файлы с PNA C:\WINNT\Help\NABasics в таком же порядке на жесткий диск Вашего ПК. Размер файла составляет приблизительно 100 МБ.


Уход за коннекторами

Правильный уход за коннекторами важен для точных и повторяемых измерений. Следующая информация поможет сохранить точность и продлить срок службы коннекторов, сохранив при этом время и деньги.

  • Уход за коннекторами. Краткое справочное руководство

  • Материалы для чистки коннекторов

  • Напоминание о безопасности

  • О коннекторах

  • Основные принципы калибровки

  • Инструкции по уходу за коннекторами

Уход за коннекторами. Краткое справочное руководство

Использование и хранение коннекторов
Надо | Нельзя
Содержать коннекторы в чистоте Защищать коннекторы пластмассовыми наконечниками Температура коннекторов должна быть такой же, как температура анализатора | Прикасаться к сопрягающимся поверхностям коннекторов Бросать контактные концы коннекторов Хранить коннекторы свободно в коробке или ящике
Визуальный контроль
Надо | Нельзя
Осматривать коннекторы с помощью увеличительного стекла. Осматривать на наличие металлических частиц, царапин или вмятин | Использовать коннектор с погнутым или сломанным центральным проводником Использовать коннектор с деформированной резьбой
Очистка коннекторов
Надо | Нельзя
Очищать поверхность сначала сухим сжатым воздухом Использовать тампоны без ворса Использовать минимум спирта Чистить внешние сопрягающиеся поверхности и резьбу | Использовать высокое давление (>60 фунтов на квадратный дюйм) Использовать абразивные материалы Допускать попадание спирта на поддерживающие изоляционные втулки коннектора Применять поперечную силу к центральному проводнику
Калибровка коннекторов
Надо | Нельзя
Проверять и чистить калибр, контркалибр и тестируемое устройство Использовать правильный ключ с ограничением по крутящему моменту Обнулять калибр перед использованием Использовать многократные измерения и записывать показания | Использовать коннектор не соответствующий спецификации Держать калибр соединителя около круговой шкалы
Соединения
Надо | Нельзя
Сначала выравнивать коннекторы Поворачивать только гайку коннектора Использовать правильный ключ с ограничением по крутящему моменту | Завинчивать с перекосом соединения Поворачивать корпус коннектора для соединения Совмещать разные типы коннекторов

Материалы для чистки и ухода за коннекторами

Ниже перечислены материалы, которые используются для чистки коннекторов. Чтобы заказать эту и другую продукцию для ухода за коннекторами, см. Аксессуары анализатора.

Описание | Agilent P/N
Тампоны без ворса, маленькие 100 шт. | 9301-1243
Изопропиловый спирт (IPA) 99.5%, бутылка 30 мл | 8500-5344
Сжатый воздух, баллончик 235 мл | 8500-6659

Напоминание о безопасности

При очистке коннекторов:

  • Всегда используйте защитные очки при использовании сжатого воздуха или азота.
  • Держите изопропиловый спирт подальше от тепла и огня. Используйте его с соответствующей вентиляцией. Избегайте контакта с глазами, кожей и одеждой.
  • Избегайте электростатического разряда (ESD). Надевайте антистатический браслет (с последовательным сопротивлением 1 MОм) при чистке устройства, коннекторов кабеля или тестовых портов.

О коннекторах

  • Срок службы коннекторов

  • Категории и эффективность функционирования коннекторов

  • Адаптеры как средство сохранения коннекторов

  • Сопрягающиеся поверхности коннекторов

Срок службы коннекторов

Хотя калибровочные меры, кабели и коннекторы разработаны и изготовлены по высоким стандартам, все коннекторы имеют ограниченный срок службы. Это означает, что коннекторы могут испортиться из-за износа при нормальном использовании. Для получения лучших результатов все коннекторы должны проверяться и ремонтироваться, чтобы продлить их срок службы.

Визуальный контроль должен производиться каждый раз, когда выполняется соединение. Металлические частички из резьбы коннектора часто попадают на соседние поверхности при соединении или рассоединении. См. Процедура осмотра.

Очистка от грязи и загрязнений сопрягающихся поверхностей и резьбы может продлить срок службы коннектора и улучшить качество калибровки и измерений. См.Процедура очистки.

Калибровка коннекторов не только обеспечивает правильные технологические допуски, а также качество функционирования коннектора, но и определяет ситуации, когда может существовать потенциальная угроза повреждения другого коннектора. См. Процедура калибровки.

Правильный уход за коннекторами и техника соединения способствуют:

·

Более долгому сроку службы

·

Лучшему функционированию

·

Лучшей повторяемости

Категории и функционирование коннекторов

Ниже перечислены три категории коннекторов (уровни качества) для распространенных серий коннекторов. Некоторые специальные серии могут не иметь всех трех категорий.

  • Коннекторы категории Production – самые простые и дешевые. Эти коннекторы обычно используются на типичных тестируемых устройствах. Они имеют самое низкое качество функционирования из всех коннекторов из-за больших допусков. Это означает, что коннекторы категории production необходимо всегда тщательно осматривать перед соединением с анализатором. Некоторые коннекторы категории Production не рассчитаны на использование вместе с коннекторами категории metrology.

  • Коннекторы категории Instrument - средний уровень коннекторов. Такие коннекторы в основном используются в и с измерительными приборами, большинством кабелей, адаптеров и некоторыми калибровочными мерами. Они обеспечивают более длительный срок службы и лучшее функционирование, а также допуск в более узких пределах. Такие коннекторы могут иметь интерфейс с диэлектриком, и поэтому могут не показывать отличное согласование, как коннекторы категории Metrology.

  • Коннекторы категории Metrology имеют самые высокие характеристики и являются самыми дорогими. Эта категория используется для калибровочных стандартов (мер) и проверочных стандартов, точных адаптеров. Поскольку это коннекторы высокой точности, они выдерживают много соединений и рассоединений и поэтому имеют самый долгий срок службы из всех категорий коннекторов. Эти коннекторы имеют самые точные геометрические спецификации и технические требования к материалам. Глубина и диаметр вывода определяются очень точно. Коннекторы категории Metrology используют воздушный диэлектрик и бесщелевой гнездовой контакт, что обеспечивает самое эффективное функционирование и единство измерений.

Примечание: Обычно, коннекторы категории Metrology не должны сопрягаться с коннекторами категории Production.

Адаптеры как средство сохранения коннекторов

Убедитесь, что используете высококачественный (категории Instrument или лучше) адаптер, подбирая различные типы коннекторов к измерительным портам анализатора. Неплохо использовать адаптер даже, если тестируемое устройство того же типа соединения, что и тестовые порты анализатора. В любом случае, он поможет продлить срок службы и защитит измерительные порты от повреждений и дорогого ремонта.

Адаптер нужно тщательно осмотреть перед присоединением к измерительному порту анализатора, а потом периодически чистить. Поскольку эталоны калибровки (меры) подсоединены к адаптеру, адаптер должен быть хорошего качества, чтобы обеспечить подходящие характеристики на РЧ и уменьшить влияние рассогласования.

Сопрягающиеся поверхности коннекторов

Важным моментом в микроволновых и РЧ измерениях является плоскость отсчета. Для анализатора цепей это поверхность, к которой обращены все измерения. При калибровке плоскость отсчета определяется, как плоскость, на которой соединяются сопрягающиеся ровные поверхности порта измерения и эталоны калибровки. Хорошие соединения (и калибровки) зависят от идеально ровного контакта между коннекторами во всех точках на сопряженной ровной поверхности (как показано на следующем рисунке).

Основные принципы калибровки

Калибры коннекторов - важные инструменты для измерения глубины центрального вывода в коннекторах. Глубина вывода коннектора, которая измеряется в единицах понижения и повышения (Recession и Protrusion), - это расстояние между сопряженной поверхностью и концом центрального провода, или плечо центрального проводника для ступенчатого штыревого контакта.

Типичная калибровка коннекторов

ПОНИЖЕНИЕ

ПОВЫШЕНИЕ

Понижение и повышение

Глубина вывода отрицательная (понижение) если центральный провод понижается ниже сопряженной поверхности внешнего провода, которую обычно называют "плоскость отсчета". Глубина вывода положительная (повышение) если центральный провод идет вперед от плоскости отсчета.

Глубина вывода

1. Понижение гнездового контакта

2. Понижение плеча штыревого контакта

Разница для коннекторов N-типа

В коннекторах N-типа сопряженные к центральным проводам поверхности смещены от плоскости отсчета. В данном случае установка на нуль "контркалибров" обычно смещает номинальное расстояние между сопряженной поверхностью центрального провода и плоскостью отсчета соединителя.

Когда калибровать коннекторы

  • Перед использованием соединителя или адаптера в первый раз.
  • Если визуальный контроль или электрические характеристики говорят о том, что интерфейс коннектора мог выйти из допустимого диапазона.
  • Через каждые 100 соединений, в зависимости от использования.

Точность калибровки коннекторов

Калибры коннекторов (которые включены с калибровочными наборами и инструментами проверки) могут выполнять только приблизительные измерения. Это происходит из-за неопределенностей повторяемости, связанных с измерением. Важно понять, что коннекторы измерительного порта и эталоны калибровки имеют очень точные механические спецификации. Только специальные процессы калибровки и электрическое тестирование (выполненное в лаборатории калибровки) могут точно определить механические характеристики устройств. Спецификации глубины вывода в руководстве Agilent предусматривают компромисс между требуемой точностью глубины вывода и точностью калибров. Калибры из набора калибровки и проверки позволяют измерить глубину вывода коннектора и избежать повреждений от коннекторов, которые не соответствуют спецификациям.

Примечание: Перед калибровкой любого коннектора необходимо проверить механические спецификации, предоставленные вместе с этим коннектором или устройством.

Для калибровки коннекторов

  1. Наденьте антистатический браслет (с подключенным последовательно сопротивлением 1 МОм).

  2. Выберите правильный калибр для тестируемого устройства.

  3. Проверить и очистить калибр, контркалибр и тестируемое устройство.

  4. Обнулите калибр коннектора.

    1. Удерживая калибр над корпусом, осторожно подсоедините контркалибр к калибру. Ввинчивать гайку коннектора только вручную.

    2. Используйте правильный ключ с ограничением по крутящему моменту, чтобы закончить соединение. Если необходимо, используйте дополнительный ключ, чтобы не допустить поворачивания контркалибра (корпус). Слегка подтолкните корпус, чтобы установить калибр.

    3. Стрелка калибра должна стоять ровно на нуле. Если не стоит, установите с помощью кнопки "установка на ноль", пока стрелка не будет показывать ноль. На калибрах, которые имеют винт на шкале и имеют подвижную круговую шкалу, отвинтите винт и двигайте шкалу, пока стрелка не покажет ноль. Калибры нужно обнулять перед каждым измерением, чтобы убедиться, что настройка на ноль не изменилась.

    4. Уберите контркалибр.

  5. Прокалибруйте тестируемое устройство.

    1. Когда держите калибр над корпусом, аккуратно подсоедините тестируемое устройство к калибру. Завинчивайте гайку коннектора только вручную.

    2. Используйте правильный ключ с ограничением по крутящему моменту, чтобы закончить соединение. Если необходимо, используйте дополнительный ключ, чтобы не допустить поворачивания корпуса тестируемого устройства. Слегка подтолкните корпус, чтобы установить калибр.

    3. Посмотрите показания стрелки на понижение или повышение на шкале и сравните показания со спецификациями устройства.

Внимание: Если калибр показывает слишком большое понижение или повышение, коннектор необходимо выбросить или отдать в ремонт.

  6. Для максимальной точности, выполните измерения как минимум три раза и возьмите среднее значение. После каждого измерения поверните калибр на четверть, чтобы уменьшить отклонения измерений.

  7. Если сомневаетесь в точности измерения, удостоверьтесь, что температура частей стабилизировалась. После этого выполните очистку, обнуление и повторите процедуру измерения сначала.

Уход за коннекторами

  • Осмотр коннекторов

  • Очистка коннекторов

  • Выполнение соединений

  • Использование ключа с ограничением по крутящему моменту

  • Использование и хранение коннекторов

Чтобы осмотреть коннекторы

Наденьте антистатический браслет (с подключенным последовательно сопротивлением 1 МОм).

Используйте увеличительное стекло (>10X) и осмотрите коннекторы на наличие:

  • Сильно изношенное покрытие или глубокие царапины

  • Деформированная резьба

  • Металлических частиц на резьбе или сопряженных ровных поверхностях

  • Изогнутые, сломанные или не выровненные центральные проводники

  • Гайки соединителя, которая плохо поворачивается

Внимание: Поврежденное или не соответствующее техническим условиям устройство может повредить хороший коннектор, присоединенный к нему даже в первый раз. Любой коннектор с явным дефектом нужно выбросить или отдать в ремонт.

Чтобы очистить коннекторы

  1. Наденьте антистатический браслет (с подключенным последовательно сопротивлением 1 МОм).

  2. Используйте чистый воздух низкого давления для удаления частиц с резьбы и сопряженных ровных поверхностей. Тщательно осмотрите коннекторы. Если необходима дополнительная чистка, выполните следующие действия.

  3. 3. Слегка смочите тампон изопропиловым спиртом. См. Материалы для чистки рекомендуемого типа.

  4. Очистите резьбу и сопряженные поверхности от загрязнений. При очистке внутренних поверхностей не давите на центральный провод и смотрите, чтобы ворсинки тампона не попали на внутренний проводник.

  5. Подождите пока испарится спирт, а потом окончательно очистите с помощью сжатого воздуха.

  6. Осмотрите коннектор. Удостоверьтесь, что не осталось ни грязи, ни частичек.

  7. Если после очистки все еще видны дефекты, значит коннектор может быть поврежден, и его нельзя использовать. Определите причину повреждения, перед тем как выполнять следующие соединения.

Выполнение соединений

  1. Наденьте антистатический браслет (с подключенным последовательно сопротивлением 1 МОм).

  2. Проверьте, очистите и выверите коннекторы. Все коннекторы должны быть исправными, чистыми и в пределах механических параметров.

  3. Осторожно выровняйте центральные оси обоих устройств. Контакт центрального проводника коннектора должен войти концентрически в контактный палец гнезда разъема.

  4. Осторожно прижмите коннекторы друг к другу, чтобы они мягко зацепились. Закрутите гайку соединителя (не само устройство) вручную, осторожно, чтобы не сорвать резьбу.

  5. Используйте ключ с ограничением по крутящему моменту, чтобы завершить соединение. Завинчивайте до точки "перехода" ключа. Не прилагайте усилий после первоначальной точки "перехода". Если необходимо, используйте дополнительный ключ, чтобы не допустить поворачивания корпуса.

Чтобы разделить соединение

  1. Поддерживайте устройство, чтобы избежать влияния поворачивающих, изгибающих сил и колебаний на коннектор.

  2. Используйте открытый ключ, чтобы не допустить поворачивания корпуса.

  3. Используйте другой открытый ключ, чтобы ослабить гайку коннектора.

  4. Выполните рассоединение вручную, поворачивая только гайку коннектора.

  5. Рассоедините коннекторы.

Использование ключа с ограничением по крутящему моменту

  1. Удостоверьтесь, что ключ имеет правильную настройку момента.

  2. Расположите ключ с ограничением по крутящему моменту и другой ключ (чтобы держать устройство или кабель) на 90 ° друг к другу, перед тем, как применить силу. Поддерживайте устройства, чтобы избежать давления на коннекторы.

 | УДЕРЖИВАЕТСЯ |
ПРАВИЛЬНЫЙ МЕТОД | НЕПРАВИЛЬНЫЙ МЕТОД | (СЛИШКОМ БОЛЬШОЙ ПОДЪЕМ)

  3. Возьмите ключ легко за край ручки, затем примените силу перпендикулярно к ручке ключа. Завинчивайте до точки "перехода" ключа. Не прилагайте усилий после первоначальной точки "перехода".

НАПРАВЛЕНИЕ ВРАЩЕНИЯ

ОСТАНОВИТЕСЬ, КОГДА РУЧКА НАЧНЕТ ПОДДАВАТЬСЯ

Использование и хранение коннекторов

  • Наденьте защитные наконечники, когда коннекторы не используются.

  • Никогда не храните коннекторы, воздушные линии или эталоны калибровки свободно в коробке. Это одна из самых распространенных причин повреждения коннекторов.

  • Поддерживайте температуру коннекторов такую же, как и температура анализатора. Нахождение коннектора в руках или очистка с помощью сжатого воздуха может значительно изменить температуру. Подождите, пока температура соединителя стабилизируется перед калибровкой или измерением.

  • Не прикасайтесь к сопрягающимся поверхностям. Кожный жир и частички грязи тяжело удалить с этих поверхностей.

  • Не бросайте контактные концы коннекторов на жесткую поверхность. Поверхности можно повредить, когда интерфейс вступает в контакт с жесткой поверхностью.

  • Наденьте антистатический браслет и работайте на заземленном проводящем антистатическом коврике. Это поможет защитить анализатор и устройства от электростатического разряда (ESD).


Защита от электростатического разряда

Защита от электростатического разряда важна, когда отсоединяются или подключаются кабели к анализатору. Статическое электричество может накапливаться на теле и при разряде может легко повредить элементы внутренней цепи. Статические разряды, которые даже не чувствуются, могут вызвать серьезное повреждение. Чтобы предотвратить повреждение инструмента:

  • Всегда пользуйтесь антистатическим ковриком, который нужно стелить перед измерительным оборудованием.

  • Всегда надевайте антистатическую манжету, присоединенную последовательно к заземленному антистатическому коврику через сопротивление 1 MΩ при выполнении соединений с измерительным оборудованием.

  • Всегда надевайте заземленную антистатическую ленту на обувь. Если Вы не уверены в проводимости пола, надевайте антистатическую ленту на обувь.

  • Всегда заземляйте себя перед чисткой, осмотром или выполнением соединений с устройством или измерительным портом, чувствительным к статическому электричеству. Например, можно прикоснуться на короткое время к внешней оболочке измерительного порта или кабельного коннектора.

  • Всегда заземляйте центральный провод измерительного кабеля перед подключением к измерительному порту анализатора или другому устройству, чувствительному к статическому электричеству. Это можно сделать следующим образом:

    1. Подсоедините перемычку (из набора калибровки) к одному концу кабеля, чтобы шунтировать центральный провод с внешним.

    2. Если на Вас надет антистатический браслет, прикоснитесь на короткое время к внешней оболочке кабельного коннектора.

    3. Подключите другой конец кабеля к измерительному порту и удалите перемычку с кабеля.

На следующем рисунке показана типичная установка защиты от электростатического разряда с антистатическим ковриком и браслетом. См. Аксессуары анализатора.


Модель согласования импедансов

This applet is a tutorial. It contains NO PNA-specific information.

To view on a PNA (or PC) with Windows XP, download JRE from www.java.com

This applet is intended to be viewed on the analyzer display. To view the applet on your PC, copy the following files from the analyzer's C:\WINNT\Help directory to your PC's C:\WINNT\Help directory.

DemoTimer.class

DisplaySim.class

DisplayXLine.class

imatch.class

MessageSim.class

ParamXLine.class

Postit.class

RunSim.class

SpecAnimation.class

SymbolButton.class

XLine.class

imatch.java

bigimage.gif

Модель согласования импедансов

Согласование импедансов - это процедура, используемая при проектировании схем, для согласования несовпадающих импедансов источника и нагрузки, что оптимизирует передачу мощности на нагрузку от источника. Согласование импедансов достигается включением согласующих схем в цепь между источником и нагрузкой.

  • Введение в модель

  • Модель согласования импедансов

  • Описание упражнений

  • Траектории элементов схемы на диаграммах Смита

  • Запретные области диаграммы Смита

Другие разделы учебного руководства

Введение

В данной модели оптимизации передачи мощности в простой цепи для визуализации интерактивных процессов согласования импеданса используются диаграммы Смита. Используются простые последовательно/параллельные, индуктивно/емкостные согласующие схемы, причем можно в интерактивном режиме регулировать значения соответствующих L и C компонент. Регулировка компонент согласующих схем изменяет характеристики всей цепи. Отраженный сигнал каждой части цепи отображается на диаграмме Смита красными [image] или синими [image] шарами.

При передвижении ползунка и модификации величин компонент модель рассчитывает новые значения для отраженных сигналов цепи и передвигает красные [image] и синие [image] шары на диаграмме Смита. Цель каждого такого действия передвинуть отображаемую точку из центра диаграммы Смита представляющего нагрузку или источник в соответствующее [image] красное и [image] синее кольцо представляющее желаемые условия согласования. Вы можете выбрать три разные задачи согласования импеданса, увеличивающейся сложности, щелкая по одной из трех закладок.

Модель согласования импедансов

Для оптимального обзора разверните это окно до максимального размера. Нажмите если модели импеданса не видны.

Описание упражнений

Первое упражнение позволяет использовать диаграммы Смита для выполнения базового согласования импеданса между активным источником и активной нагрузкой. Для согласования 50-омного источника с 300-омной нагрузкой используются простые схемы с последовательной индуктивностью и параллельной емкостью. Отражение источника в цепи отображающее нагрузку на источнике представлено красным шариком [image], в то время как 300омная нагрузка показана неподвижным [image] красным кольцом.

Целью упражнения является интерактивное выравнивание этих двух импедансов, регулируя бегунки L и C. Модель будет обеспечивать графическую обратную связь, передвигая красный шарик отображая на диаграмме Смита реакцию цепи. Установите бегунки последовательной L и параллельной C так чтобы передвинуть отображаемую точку [image] из центра диаграммы Смита в положение согласованного импеданса внутри красного кольца. Ниже Вы можете изучить Траектории элементов схемы на диаграммах Смита для того чтобы понять каким образом различные элементы цепи изменяют отражение цепи на диаграмме Смита.

Второе упражнение обеспечивает опыт по согласованию импеданса за счет оптимизации усиления мощности преобразователя транзисторного усилителя. Согласование 50-омного источника с входной отражательной способностью транзистора, s*11, и согласование 50-омной нагрузки с выходной отражательной способностью транзистора, s*22, оптимизирует мощность, поступающую с источника через транзистор на нагрузку. Вам требуется независимо подогнать вход – красный шарик [image] и выход – синий шарик [image] транзистора. Установите значения компонент так чтобы передвинуть обе отображаемые точки в соответствующие им правильные положения внутри красного [image] и синего [image] кольца.

Третья часть интерактивной модели согласования импеданса представляет собой наборы упражнений включающих в себя модульные схемы. Вы начинаете с создания схемы с одной или двумя модульными (перетаскиваемыми) компонентами согласующих схем. Как только согласующая схема будет присоединена к цепи активируются бегунки и вы сможете подогнать значения компонент. Далее вы будете вынуждены согласовать импеданс для цепи которою вы только что создали! Существует 8 различных цепей, которые вы можете сконструировать, а на диаграмме Смита существует 5 различных пар значений для s*11 и s*22, в целом 40 способов согласования импеданса. Вы обнаружите что будут работать не все согласующие схемы! Для некоторых цепей, из тех которые вы можете создать, у вас не будет возможности расположить красный шарик [image] внутри красного кольца или синий шарик [image] внутри синего кольца. Для того чтобы заблаговременно определить которые из согласующих схем будут работать внимательно ознакомьтесь с нижеприведенными Запретными областями диаграмм Смита. Существуют 5 различных соответствующих различным частотам определяющих местоположение пар для s*11 и s*22, которые могут быть согласованы. Для того чтобы выбрать рабочую частоту используйте индикатор частот, затем перетащите и установите в цепи подходящую согласующую схему и установите значения компонент так чтобы передвинуть обе отображаемые точки в соответствующие им правильные положения внутри красного [image] и синего кольца.

Траектории элементов схемы на диаграммах Смита

На рисунках ниже показано как различные параллельные и последовательные L и C компоненты изменяют отображение цепи на диаграмме Смита. Предполагая что данные компоненты являются последним компонентами в согласующих схемах, отображение цепи будет двигаться как показано вдоль окружности постоянного сопротивления или постоянной проводимости.

Вы можете представить себе согласование импеданса с использованием диаграмм Смита как поездку на автомобиле в определенную точку города Смита – города в котором нет прямых улиц. Подгоняя определенным образом компоненты цепи можно заставить отображение цепи двигаться вдоль окружностей с постоянным сопротивлением или постоянной проводимостью. Точно как дорожные знаки могут направить машину вдоль окружной дороги города Смита, таким образом чтобы мы могли достичь условий согласования импеданса по прямому и четко определенному пути.

Запретные области диаграммы Смита

Для заданного отображения нагрузки только определенные согласующие L-C схемы будут способны преобразовывать импеданс источника в импеданс нагрузки. Фактически, для любого отображения нагрузки именно две из четырех возможных согласующих L-C схем приведенной выше модели Транзисторного усилителя – II будут иметь возможность выполнить задачу согласования. Но какие две?

Приведенные ниже диаграммы можно использовать для того чтобы определить какие согласующие схемы будут работать в данном состоянии нагрузок. Если для указанной согласующей схемы отображение цепи лежит внутри запретной области диаграммы Смита то это означает что схема не может выполнить требуемые операции согласования. Вы не можете заехать машиной в запретный район города Смита! Там нет дороги!

Используйте эти диаграммы чтобы определить какую согласующую схему нужно использовать. Во первых, визуально определите положение отображения нагрузки приведенной выше модели Транзисторного усилителя – II на каждой из четырех приведенных ниже цветных диаграмм Смита. Затем уберите две схемы чьи запретные области перекрывают точку отображения и используйте одну из оставшихся двух схем для выполнения процедуры согласования импеданса


Отраженная волна вдоль линии передачи

This applet is a tutorial. It contains NO PNA-specific information.

To view on a PNA (or PC) with Windows XP, download JRE from www.java.com.

This applet is intended to be viewed on the analyzer display. To view the applet on your PC, copy the following files from the analyzer's C:\WINNT\Help directory to your PC's C:\WINNT\Help directory.

DemoTimer.class

DisplaySim.class

DisplayXLine.class

imatch.class

MessageSim.class

ParamXLine.class

Postit.class

RunSim.class

SpecAnimation.class

SymbolButton.class

XLine.class

imatch.java

bigimage.gif

Отраженная волна вдоль линии передачи

Когда синусообразная волна генератора радиочастотных сигналов попадает в передающую линию сигнал распространяется в направлении нагрузки. Этот сигнал, показанный здесь желтым, проявляется как набор вращающихся векторов, по одному в каждой точке передающей линии.

Для оптимального обзора разверните это окно до максимального размера. Нажмите здесь если прикладная программа не видна.

В нашем примере линия передачи имеет характеристический импеданс 50 Ом. Если мы выберем нагрузку 50 Ом, тогда амплитуда сигнала не будет изменяться в зависимости от положения вдоль линии. Вдоль линии будет изменяться только фаза, что и показано желтыми вращающимися векторами.

Если импеданс нагрузки не совпадает идеально с характеристическим импедансом линии, то появится отраженный сигнал, распространяющийся по направлению к источнику. В любой точке вдоль линии передачи также возникнет сигнал с постоянным напряжением чья фаза зависит от физического положения на линии.

Напряжение, наблюдаемое в одной конкретной точке линии будет векторной суммой переданной и отраженной синусоиды. Мы можем продемонстрировать это просмотрев два примера.

Идеальное согласование: 50 Ом

Установите согласующий резистор на 50 Ом, используя для этого диалоговое окно с "опускающейся стрелкой". Отметим что нет отражения. Мы имеем идеальное согласование. Каждый из вращающихся векторов имеет нормированную на 1 амплитуду. Если бы мы с помощью идеального измерительного инструмента наблюдали в любой точке форму волны, то мы бы увидели синусоидальную волну одинаковой амплитуды по всей длине линии передачи. Амплитуда сигнала обозначена зеленой линией.

Несогласованная нагрузка: 200 Ом

Теперь давайте специально создадим несогласованную нагрузку. Установите согласующий резистор на 200 Ом, используя для этого подвижную стрелку. Нажмите кнопку PLAY и отметьте изменение формы отраженной волны. Если бы было возможно измерить только отраженную волну, мы бы увидели что ее амплитуда не изменяется от положения на линии. Единственная разница между отраженным (синий) сигналом, показанным в точке z6 и точке z4 это фаза.

Но амплитуда результирующей волны, показанная стоячей волной (зеленая), не постоянна по всей длине линии, потому что переданный и отраженный сигналы (желтый и синий) смешались. Поскольку фаза между переданным и отраженным сигналом изменяется с положением вдоль линии, то их векторная сумма также будет отличаться, создавая то что называется "стоячей волной".

При импедансе нагрузки 200 Ом измерительное устройство, расположенное в точке z6 будет показывать синусоидальную волну постоянной амплитуды. Синусоидальная волна в точке z4 также будет с постоянной амплитудой, но ее амплитуда будет отличаться от амплитуды сигнала в точке z6. И их фазы не будут совпадать друг с другом. Эта разница показана зеленой линией, которая отображает амплитуду в данной точке линии передачи.

Как видно по точкам, пронумерованным от z1 до z7, также вдоль линии изменяется и импеданс.


Измерения отражения

Измерения отражения это важная часть анализа цепей.

  • Что такое измерения отражения?

  • Зачем производить измерения отражения?

  • Отображение отраженных волн

    • Обратные потери

    • КСВН

    • Коэффициент отражения

    • Импеданс

    • Обзор отображений

См. другие разделы учебного руководства

Что такое измерения отражения?

Для того чтобы понять, что такое измерения отражений полезно мыслить о проходящих вдоль линии передачи волнах в терминах аналогичных оптическим. Можно представить падающий свет проходящим через некоторый оптический компонент, такой как чистая линза. Часть света отражается поверхностью линзы, но основная часть света проходит через линзу. Если линза имеет зеркальные поверхности, тогда большинство света будет отражаться и небольшая или нулевая его часть пройдет дальше.

1. Падающий 2. Отраженный 3. Прошедший

При радиочастотных энергиях отражение возникает когда импеданс у двух соединенных устройств будет разным. Измерение отражения - это определение отношения отраженного сигнала к падающему сигналу. Анализаторы цепей измеряют падающую волну на R (опорном) канале и отраженную волну на A канале. Поэтому отражение обычно показывается как отношение A к R (A/R). Отражательные свойства тестируемого устройства (DUT) можно полностью количественно определить из информации о амплитуде и фазе, доступной на обеих каналах A и R. В терминах S-параметров, S11 - это измерение отражения порта 1 устройства (входящий порт); S22 измерение отражения порта 2 (исходящий порт).

Зачем производить измерения отражения?

Мы производим измерения отражения для того чтобы гарантировать эффективную передачу мощности радиочастот. Мы делаем это потому что:

  1. Если энергия отражается, то это значит что меньше энергии передается туда куда ей нужно попасть.

  2. Если отраженная энергия достаточно большая, она может повредить такие компоненты как усилители.

Например, на приведенном ниже рисунке левая радиостанция не работает на пике своей эффективности. Импеданс усилителя не совпадает с импедансом передающей линии, а импеданс передающей линии отличается от импеданса антенны. Оба этих условия приводят к большой отраженной мощности. Эти же условия являются причиной низкой переданной мощности, а высокая отраженная мощность может повредить усилитель.

На правой радиостанции правильно установлено "согласование" передающей линии и антенны. Только очень небольшая часть переданного сигнала отражается, в результате чего возрастает мощность радиовещания, больше слушателей, больше доходы от рекламы и больше прибыль. Усилитель, передающая система и антенна - для них всех необходимо произвести измерения, чтобы убедится в том что отраженная мощность минимальна.

Отображение отраженных волн

После произведения измерения отражения полученные данные могут быть отображены несколькими способами, в зависимости от того что вы пытаетесь исследовать. Все различные способы отображения рассчитываются анализатором из одних и тех же данных измерения отражения. Каждый из методов выражения данных отражения может быть графически выведен на дисплей в одном или нескольких форматах. Для более детальной информации смотрите форматы дисплея.

Обратные потери

Самый простой способ выразить данные об отражении это обратные потери. Обратные потери выражаются в дБ и являются скалярной (только амплитуда) величиной. Обратные потери можно представить себе как абсолютную величину или дБ на которые отраженный сигнал ниже входного сигнала. Обратные потери изменяются от бесконечности для идеального согласования импеданса до 0 дБ для разомкнутых или закороченных цепей или реактивного сопротивления на котором нет потерь. Например, используя формат логарифмической амплитуды анализатора величина измеренного отражения на экране может быть -18дБ. При выражении обратных потерь знак минус игнорируется, таким образом, вышеуказанный компонент имеет обратные потери 18дБ.

КСВН

Две волны, двигающиеся по одной передающей линии, но в противоположных направлениях производят "стоячую волну". Измерения для этого состояния могут быть выполнены в терминах коэффициента стоячей волны по напряжению (КСВН или короче КСВ). КСВН определяется на заданной частоте как максимальное отраженное напряжение, деленное на минимальное отраженное напряжение. КСВН это скалярная (только амплитуда) величина. КСВН изменяется от единицы при идеальном согласовании до бесконечности для разомкнутых или закороченных цепей или реактивного сопротивления без потерь.

Коэффициент отражения

Другой способ отображения результатов измерения отражения это коэффициент отражения гамма (Г). Гамма включает в себя и амплитуду и фазу.

Амплитудная часть гаммы называется ро (р). Коэффициент отражения это отношение напряжения отраженного сигнала к напряжению падающего сигнала. Диапазон возможных значений р от нуля до единицы. Линия передачи, завершающаяся своим характеристическим импедансом будет передавать на нагрузку всю энергию; будет отражаться нулевая энергия и р = 0. Если линия передачи заканчивается разомкнутой или замкнутой накоротко цепью, то отражается вся энергия и р = 1. Величина р безразмерна.

Теперь перейдем к информации о фазе. На высоких частотах, когда длина волны сигнала меньше длины проводника, отражение лучше всего представить себе как волну, двигающуюся в направлении противоположном направлению падающей волны. Падающая и отраженная волны комбинируются, производя единственную "стоячую" волну напряжение которой меняется в зависимости от точки на линии передачи.

Когда линия передачи заканчивается своим характеристическим импедансом (Zo) тогда нет никакого отраженного сигнала. Все входящие сигналы передаются на нагрузку так, как это показано ниже на рисунке. Вдоль линии передачи существует поток энергии в одном направлении.

 | Zo
Падающее напряжение | Отраженное напряжение =0
 | (Вся входящая мощность поглощается на нагрузке)

Когда линия передачи заканчивается коротким замыканием, вся энергия отражается обратно на источник. Отраженная волна по амплитуде равна падающей волне (р = 1). Падение напряжения на концах любого короткого замыкания равно нулю вольт. Поэтому напряжение отраженной волны будет по фазе на 180 градусов отличаться от падающей волны, сводя на нет падение напряжения на нагрузке.

Когда линия передачи заканчивается разрывом, вся энергия отражается обратно на источник. Отраженная волна по амплитуде равна падающей волне (р = 1). Однако в разомкнутой цепи не может течь ток. Поэтому напряжение отраженной волны будет в фазе с напряжением падающей волны.

Когда линия передачи заканчивается 25 омным сопротивлением, некоторая часть, но не вся, падающей энергии, будет поглощена а другая часть будет отражаться обратно на источник. Отраженная волна будет иметь амплитуду равную 1/3 от амплитуды падающей волны, а напряжения на нагрузке для этих двух волн будут отличаться по фазе на 180 градусов. Отношение фаз будет изменяться как функция расстояния по передающей линии от нагрузки. Точки минимума стоячей волны больше не будут доходить до нуля, а пики будут меньше чем в случаях разомкнутых / закороченных цепей.

За более детальной информацией обращайтесь к Измерениям фазы.

Импеданс

Импеданс это другой способ выражения данных отражения. Более детальную информацию об импедансе смотрите в Диаграммах Смита.

Резюме выражений измерений отражения:


Измерение фазы

Знание как амплитудных так и фазовых характеристик необходимо для успешного интегрирования высокоуровневых компонент.

  • Что такое измерение фазы?

  • Зачем измеряется фаза?

  • Использование формата фазы в анализаторе

  • Типы измерений фазы

См. другие разделы учебного руководства

Что такое измерение фазы?

Измерения фазы выполняются с использованием S-параметров, так же как и измерения амплитуды. Измерение фазы - это относительное (соотношение) а не абсолютное измерение. Фазовые измерения сравнивают фазу сигнала входящего в устройство с фазой ответного сигнала устройства. Ответный сигнал может быть либо отраженным либо переданным. Если предположить что уже выполнена точная калибровка, то разница фаз двух сигналов (называемая фазовым сдвигом) является результатом электрических характеристик тестируемого устройства.

На приведенном ниже графике показан фазовый сдвиг (в единицах времени или градусах) между падающим и прошедшим сигналом (таким каким его можно увидеть на дисплее осциллографа).

Зачем измеряется фаза?

Измерение фазы это важный элемент анализа схем. На приведенном ниже рисунке перечислены пять причин для измерения абсолютных величин и фазы.

При использовании в коммуникационных системах для прохождения сигнала, компоненты и цепи не должны приводить к чрезмерному искажению сигнала. Это искажение может быть:

  • Линейным, когда равномерный сдвиг амплитуды и фазы от частоты не поддерживается за пределами интересующей полосы пропускания.

  • Нелинейным, таким как преобразование AM-в-ФM.

Для того чтобы быть уверенным в эффективной передаче или поглощении энергии компонентом или цепью важно измерить ее отражение. Измерение комплексного импеданса антенны является хорошим примером этого.

Использование формата фазы в анализаторе

Анализатор в формате фазы отображает измерения фазы в зависимости от частоты и фазы от мощности. Анализатор не показывает разницу фаз между опорным и измерительным сигналом большую чем ±180 градусов. Когда значение фазы изменяется в пределах между +180 градусов и -180 градусов дисплей анализатора создает пилообразный образец как это показано на следующем рисунке.

Пилообразный образец не всегда достигает +180 градусов и -180 градусов. Это потому что измерения производятся на дискретных частотах и точки с данными для +180 градусов и -180 градусов могут не быть измерены при выбранном свипировании.

Типы измерений фазы

Данные комплексного импеданса это информация, такая как сопротивление, реактивное сопротивление, фаза и амплитуда, которые могут быть определены из измерений S11 или S22. Данные комплексного импеданса можно просмотреть воспользовавшись форматом диаграмм Смита, либо полярным форматом.

Преобразование AM-в-ФM это мера величины ненужного отклонения фазы (PM) причиной которой является изменение амплитуды (AM) системы. Обычно преобразование AM-в-PM определяется как изменение фазы исходящего сигнала при приращении на 1 дБ входной мощности усилителя (т.е. в точке сжатия усиления на 1 дБ). Она выражается в градусах на дБ (°/дБ).

Отклонение от линейной фазы это мера искажения фазы, вызванной устройством. В идеальном случае фазовый сдвиг при прохождении через устройство - это линейная функция от частоты. Среднее отклонение от этого теоретического фазового сдвига называется отклонением от линейной фазы (а также линейностью фазы).

Групповая задержка - это другой способ увидеть искажение фазы устройством. Групповая задержка это мера для времени прохождения через устройств на определенной частоте. Анализатор рассчитывает групповую задержку из производной от измеренной фазовой характеристики.

Сравнение отклонения от линейной фазы с групповой задержкой

Не смотря на то, что отклонение от линейной фазы и групповая задержка это похожие измерения каждое из них имеет собственное применение.

Ниже приведены преимущества измерений отклонения от линейной фазы:

  • Менее шумные чем групповая задержка.

  • Пригодны для описания устройств, которые пропускают фазово-модулированные сигналы и предпочтительнее для отображения в единицах фазы чем времени.

Ниже приведены преимущества измерений групповой задержки:

  • Интерпретация показаний искажения фазы проще чем отклонения от линейной фазы.

  • Пригодны для более точного описания тестируемого устройства. Это потому что при определении групповой задержки анализатор рассчитывает наклон колебаний фазы, который зависит от числа колебаний имеющихся на единицу частоты. Сравнивая две фазовые характеристики с равными отклонениями фазы на полной амплитуде, характеристики с большим наклоном фазы дадут:

    • Большее отклонение групповой задержки.

    • Большее искажение сигнала.


Справочная информация о параметрах усилителя

  • Усиление

  • АЧХ усиления

  • Обратная развязка

  • Изменение коэффициента усиления со временем

  • Отклонение от линейной фазы

  • Групповая задержка

  • Обратные потери (КСВ, ро)

  • Комплексный импеданс

  • Нелинейность амплитудной характеристики

  • Преобразование AM-в-PM

Усиление

Отношение мощности на выходе усилителя (поступившей на нагрузку Z0 к входящей мощности (поступившей от источника Z0 source). Z0 это характеристический импеданс, в данном случае 50 Ом

Для уровней слабых сигналов мощность на выходе усилителя пропорциональна входящей мощности. Коэффициент усиления в режиме малого сигнала - это усиление в этой линейной области.

При возрастании входной мощности и наступлении насыщения усилителя мощность на выходе достигает предела и усиление падает. Усиление больших сигналов это усиление в этой нелинейной области. Смотрите нелинейность амплитудной характеристики.

АЧХ усиления

Изменение усиления в некотором диапазоне частот усилителя. Смотрите коэффициент усиления в режиме малого сигнала и АЧХ.

Обратная развязка

Мера передачи сигнала от выхода на вход. Похоже на измерение усиления за исключением того что входной сигнал прикладывается к выходу усилителя. Смотрите Обратная развязка.

Отклонение коэффициента усиления со временем (изменением температуры, приложенного напряжения)

Максимальное изменение усиления как функция времени при постоянных всех остальных параметрах. Отклонение коэффициента усиления также наблюдается и по отношению к изменению других параметров, таких как температура, влажность или приложенное напряжение.

Отклонение от линейной фазы

Среднее значение отклонения от линейного фазового сдвига. В идеальном случае фазовый сдвиг при прохождении через усилитель это линейная функция от частоты. Смотрите Отклонение от линейной фазы.

Групповая задержка

Время прохождения сигнала через усилитель как функция частоты. Идеально линейный фазовый сдвиг будет иметь постоянную степень изменения относительно частоты, производя постоянную групповую задержку. Смотрите Групповая задержка.

Обратные потери (Коэффициент стоячей волны, р)

Величина несовпадения отражения на входе или выходе усилителя в зависимости от характеристического импеданса системы Z0.

Комплексный импеданс

Комплексный импеданс (1+G). Среднее значение отраженной от усилителя энергии напрямую связанное с его импедансом. Комплексный импеданс состоит из компоненты сопротивления и компоненты реактивного сопротивления. Он рассчитывается из характеристического импеданса системы и коэффициента отражения. Смотрите Комплексный импеданс.

Нелинейность амплитудной характеристики

Усилитель имеет область линейного усиления, в которой коэффициент усиления не зависит от уровня мощности на входе (усиление слабых сигналов). Когда мощность возрастает до уровня, который приводит к насыщению усилителя, коэффициент усиления уменьшается.

Нелинейность амплитудной характеристики определяется измерением точки сжатия коэффициента усиления усилителя на 1 дБ (P 1дБ ), которая соответствует мощности на выходе при которой усиление падает на 1 дБ по отношению к усилению слабых сигналов. Это обычное измерение устойчивости выходной мощности усилителя. Смотрите нелинейность амплитудной характеристики.

Коэффициент преобразования AM-в-PM

Среднее изменение фазы появившееся в исходящем сигнале усилителя в результате изменения амплитуды входящего сигнала.

Коэффициент преобразования AM-в-PM выражается в единицах градус/ дБ при заданном уровне мощности (обычно P1дБ, которая является точкой сжатия коэффициента усиления усилителя на 1 дБ). Смотрите Амплитудно-фазовые искажения.


Амплитудно-фазовые искажения

Амплитудно-фазовые искажения усилителя - это значение присущего системе нежелательного отклонения фазы (PM - фазовая модуляция), причиной которого является изменение амплитуды (AM - амплитудная модуляция).

  • Что такое амплитудно-фазовые искажения?

  • Зачем измеряются амплитудно-фазовые искажения

  • Вопросы точности

  • Как измерить амплитудно-фазовые искажения

Другие разделы учебного руководства

Что такое амплитудно-фазовые искажения?

Преобразование AM-в-PM определяет величину нежелательного отклонения фазы (PM - фазовая модуляция) причиной которой является изменение амплитуды (AM - амплитудная модуляция) системы. Например, причиной нежелательного отклонения фазы (PM) в коммуникационной системе могут быть:

Ненамеренные изменения амплитуды (AM)

  • Пульсация электропитания

  • Температурный сдвиг

  • Многоканальное замирание

Намеренная модуляция амплитуды сигнала

  • QAM (квадратурная амплитудная модуляция)

  • Пакетная модуляция

Обычно величина преобразования AM-в-PM определяется как изменение фазы сигнала на выходе при приращении на 1 дБ в свипировании мощности приложенной ко входу усилителя (т.е. в точке сжатия 1 дБ). Оно выражается в градусах на дБ (°/дБ). У идеального усилителя не должно быть никакой взаимосвязи между его фазовой характеристикой и уровнем мощности входящего сигнала.

Зачем измеряются амплитудно-фазовые искажения

Степень преобразования AM-в-PM является важным параметром для систем, в которых используется фазовая (угловая) модуляция, таких как:

  • FM

  • QPSK

  • 16QAM

Она является важным параметром, потому что не желаемое отклонение фазы (PM) приводит к ухудшению аналогового сигнала или увеличению частоты ошибок по битам (BER) в цифровых коммуникационных системах. Не смотря на то, что в цифровых коммуникационных системах легко измерить BER, эти измерения сами по себе не помогут вам понять причины, лежащие в основе появления ошибочных битов. Преобразование AM-в-PM является одной из основных причин BER и поэтому в коммуникационных системах важно количественно определить этот параметр.

Для дальнейшего обсуждения того, как преобразование AM-в-PM может привести к появлению ошибочных бит, рассмотрим схему I/Q, представленную ниже.

  • Необходим переход из состояния, указанного маленьким сплошным вектором, к состоянию, указанному большим сплошным вектором.

  • При преобразовании AM-в-PM в действительности большой вектор может попасть в точку, указанную пунктирной линией. Это обусловлено сдвигом фазы в результате изменения уровня мощности на входе.

  • Для приведенного сигнала 64QAM (показан только один квадрант) видно, что кольца шумов, окружающие каждое состояние, в действительности могут частично перекрываться, а это означает, что статистически будут возникать ошибочные биты.

Вопросы точности

В данном методе измерения преобразования AM-в-PM, частота модуляции приблизительно обратно пропорциональна времени развертки. Даже для самого быстрого свипирования мощности, доступной большинству анализаторов цепей, конечная частота модуляции остается довольно низкой (обычно меньше 10 Гц). Благодаря этому можно пренебречь изменением температуры при прохождении свипирования, особенно если у усилителя низкая термическая масса, что характерно для безкорпусных устройств. Результаты использования этого метода будут слабо отличатся, если нелинейное поведение усилителя будет чрезвычайно чувствительным к изменению температуры. (Анализаторы серии PNA могут производить свипирование по мощности <1 мс.)

  • Реакция усилителя может сильно отличаться при различных температурах. Измерения должны производиться, когда усилитель находится при требуемых рабочих температурах.

  • В случае необходимости, мощность на выходе усилителя должна быть в достаточной степени ослаблена. Слишком большая мощность на выходе может:

    • повредить приемник анализатора

    • превысить входной уровень сжатия приемника анализатора, приведя к неточности измерений

  • Ослабление мощности на выходе усилителя можно произвести за счет использования:

    • Аттенюаторов

    • Ответвителей

  • При калибровке должно быть учтено влияние частотных характеристик аттенюаторов и ответвителей, поскольку они являются частью измерительной системы. Правильная техника исправления ошибок может уменьшить влияние данных эффектов.

  • Частотные характеристики являются основным источником ошибок при настройке измерения преобразования AM-в-PM. Выполнение калибровки частотной неравномерности по перемычке значительно снижает эти ошибки. Для большей точности выполните 2-портовую калибровку измерений.

Как измерить амплитудно-фазовые искажения

  1. Установите предварительные настройки анализатора.

  2. Выберите измерение S21 в режиме свипирования мощности.

  3. Введите начальный и конечный уровень мощности для свипирования мощности анализатора. Начальный уровень мощности должен находиться в линейной области амплитудной характеристики усилителя (обычно 10 дБ ниже точки соответствующей сжатию 1 дБ). Конечный уровень мощности должен находиться в области сжатия амплитудной характеристики усилителя.

  4. Выберите внешний аттенюатор (если это необходимо) таким образом, чтобы снизить мощность усилителя на выходе настолько, чтобы избежать сжатия на приемнике или повреждения порта 2 анализатора.

  5. Подсоедините усилитель, как это показано на следующем рисунке, и обеспечьте подачу смещения (постоянный ток).

  6. Выберите настройки анализатора для тестируемого усилителя таким образом, чтобы выполнить измерение нелинейности амплитудной характеристики усилителя на данной частоте. См. Нелинейность амплитудной характеристики.

  7. Уберите усилитель и выполните калибровку измерений. Если аттенюатор и кабели будут использоваться при измерениях с усилителем, то убедитесь в том, что они задействованы при установке калибровки.

  8. Сохраните состояние прибора в памяти.

  9. Повторно подсоедините усилитель.

  10. Используйте опорный маркер, для того чтобы указать мощность на входе усилителя в точке сжатия 1 дБ. Выберите второй маркер и подбирайте значение стимула пока его отклик не будет находится на 1 дБ ниже опорного маркера.

  11. Измените измерение S21 с логарифмического формата значений амплитуды на формат фазы (не требуется новой калибровки).

  12. Найдите изменение фазы между маркерами. Значение является коэффициентом преобразования AM-в-PM в точке сжатия 1 дБ.

  13. Распечатайте данные или сохраните их на диске.


Измерения антенн

В этом разделе описано как настроить PNA для того чтобы провести измерения S21 антенной решетки. Измерения можно провести для 100 элементов антенны (Портов) и на 15 дискретных частотах

Последовательность измерений

  1. PNA устанавливается на стартовую частоту.

  2. Когда антенна двигается, PNA реагирует на каждый внешний пусковой сигнал, проводя измерения на порту антенны.

  3. Когда произведены измерения всех портов PNA переключается на следующую частоту

  4. PNA снова замеряет все порты и так далее пока не будут проведены измерения для всех портов на всех частотах в прямом направлении.

  5. Когда антенна начинает двигаться в обратном направлении, выполняется та же последовательность за исключением того, что PNA уменьшает частоту, пока не будут измерены все порты на всех частотах и на PNA обратно не установится первоначальная стартовая частота.

Настройка выполняется один раз, на PNA посылаются только внешние пусковые сигналы. После каждого пускового сигнала измеренные данные сохраняются в памяти PNA.

Как настроить PNA

Для того чтобы узнать как произвести настройку автоматически смотрите Макрос антенны.

  1. В меню System щелкните по Preset

  2. В меню Sweep укажите Trigger а затем нажмите Trigger

  3. В Trigger Source нажмите External

  4. В Trigger Scope нажмите Channel

  5. Нажмите OK

Прямое свипирование

  1. В меню Trace щелкните New Trace

  2. Нажмите S21 затем Channel Number 1

  3. В меню Sweep укажите Trigger затем нажмите Trigger

  4. В Channel Trigger State отметьте Point Sweep

  5. Нажмите OK

  6. В меню Sweep menu нажмите Sweep Type:затем Segment Sweep

  7. Нажмите OK

  8. В меню View укажите Tables затем нажмите Segment Table

  9. Повторите это 15 раз – в меню Sweep укажите на Segment Table затем Insert Segment

  10. Для каждого сегмента в таблице сегментов:

    1. Нажмите State:и выберите ON

    2. Дважды щелкните START и STOP Frequency: (каждый новый сегмент с большей частотой)

    3. Дважды щелкните Points: введите Number of Ports (элементов)

Обратное свипирование

Повторите приведенные ниже шаги для каждой частоты: (до 15)

  • Увеличивайте номер канала (X) начиная с Канала 2

  • Уменьшайте частоту (F)

  1. В меню Trace нажмите New Trace...

  2. Нажмите S21 затем Channel Number X

  3. Если окно содержит четыре графика выберите Create in New Window.

  4. Нажмите OK

  5. В меню Sweep укажите Trigger затем нажмите Trigger

  6. В Channel Trigger State отметьте Point Sweep

  7. Нажмите OK

  8. В меню Sweep menu нажмите Sweep Type:затем Segment Sweep

  9. Нажмите OK

  10. В меню View укажите Tables затем нажмите Segment Table

  11. В таблице Segment table

    1. Нажмите State:и выберите ON

    2. Дважды щелкните START и STOP Frequency F

    3. Дважды щелкните Points: введите Number of Ports (елементов)


Макрос тестирования антенны

Этот выполненный на языке Visual Basic макрос автоматизирует настройку PNA по схемам приведенным в разделе Измерения антенн. В этом разделе показано как скопировать этот макрос в PNA, а затем запустить его.

За более детальной информацией обращайтесь к разделу Использование макросов.

Примечание: Напечатайте эту инструкцию если Вы смотрите ее на PNA. Диалоговое окно Установки макроса (Macro Setup) будет закрывать данный раздел.

  1. Скопируйте следующий код в файл приложения Блокнот (Notepad).

Notepad is a text editor that is installed on all PCs that use a Microsoft Operating system. To launch Notepad on the analyzer:

  1. Click View, then click Title Bars

  2. Click the Start button on the windows taskbar

  3. Point to Programs, Accessories.

  4. Click Notepad

'Start copying here
Set rfna = CreateObject("AgilentPNA835x.Application")
Set chans = rfna.Channels
numfreqs = 15
portz = 3
rfna.Preset
rfna.Reset
rfna.TriggerSignal=3 ' Manual trigger
rfna.TriggerType=1   ' ChannelTrigger
'setup forward sweep
win = 1
trce = 1
rfna.CreateMeasurement 1, "S21", 2, win
Set chan = rfna.ActiveChannel
chan.TriggerMode = 0 'TriggerModePoint
chan.SweepType = 4   'SegmentSweep

For i = 1 To 15
chan.Segments.Add (i)
chan.Segments(i).State = True
chan.Segments(i).NumberOfPoints = portz
Next

chan.Segments(1).StartFrequency = 30000
chan.Segments(1).StopFrequency = 30000
chan.Segments(2).StartFrequency = 1000000
chan.Segments(2).StopFrequency = 1000000
chan.Segments(3).StartFrequency = 500000
chan.Segments(3).StopFrequency = 500000
chan.Segments(4).StartFrequency = 10000000
chan.Segments(4).StopFrequency = 10000000
chan.Segments(5).StartFrequency = 100000000
chan.Segments(5).StopFrequency = 100000000
chan.Segments(6).StartFrequency = 500000000
chan.Segments(6).StopFrequency = 500000000
chan.Segments(7).StartFrequency = 1000000000
chan.Segments(7).StopFrequency = 1000000000
chan.Segments(8).StartFrequency = 2000000000
chan.Segments(8).StopFrequency = 2000000000
chan.Segments(9).StartFrequency = 3000000000
chan.Segments(9).StopFrequency = 3000000000
chan.Segments(10).StartFrequency = 4000000000
chan.Segments(10).StopFrequency = 4000000000
chan.Segments(11).StartFrequency = 5000000000
chan.Segments(11).StopFrequency = 5000000000
chan.Segments(12).StartFrequency = 6000000000
chan.Segments(12).StopFrequency = 6000000000
chan.Segments(13).StartFrequency = 7000000000
chan.Segments(13).StopFrequency = 7000000000
chan.Segments(14).StartFrequency = 8000000000
chan.Segments(14).StopFrequency = 8000000000
chan.Segments(15).StartFrequency = 9000000000
chan.Segments(15).StopFrequency = 9000000000

'setup reverse sweep
'setup the channel
'start with ch 2
For ch = 2 To numfreqs + 1

'put four traces per window
trce = trce + 1
If trce = 5 Then
win = win + 1
trce = 1
End If

rfna.CreateMeasurement ch, "S21", 2, win

Set chan = rfna.ActiveChannel
chan.TriggerMode = 0 'TriggerModePoint
chan.SweepType = 4   'SegmentSweep
Set segs = chan.Segments

Select Case ch
Case 2
segs(1).StartFrequency = 9000000000
segs(1).StopFrequency = 9000000000
Case 3
segs(1).StartFrequency = 8000000000
segs(1).StopFrequency = 8000000000
Case 4
segs(1).StartFrequency = 7000000000
segs(1).StopFrequency = 7000000000
Case 5
segs(1).StartFrequency = 6000000000
segs(1).StopFrequency = 6000000000
Case 6
segs(1).StartFrequency = 5000000000
segs(1).StopFrequency = 5000000000
Case 7
segs(1).StartFrequency = 4000000000
segs(1).StopFrequency = 4000000000
Case 8
segs(1).StartFrequency = 3000000000
segs(1).StopFrequency = 3000000000
Case 9
segs(1).StartFrequency = 2000000000
segs(1).StopFrequency = 2000000000
Case 10
segs(1).StartFrequency = 1000000000
segs(1).StopFrequency = 1000000000
Case 11
segs(1).StartFrequency = 500000000
segs(1).StopFrequency = 500000000
Case 12
segs(1).StartFrequency = 100000000
segs(1).StopFrequency = 100000000
Case 13
segs(1).StartFrequency = 10000000
segs(1).StopFrequency = 10000000
Case 14
segs(1).StartFrequency = 500000
segs(1).StopFrequency = 500000
Case 15
segs(1).StartFrequency = 100000
segs(1).StopFrequency = 100000
Case 16
segs(1).StartFrequency = 30000
segs(1).StopFrequency = 30000
End Select

segs(1).NumberOfPoints = portz
Next

'End copying here

  2. Сохраните файл на жестком диске анализатора в директории C:\Documents. Назовите файл AntennaTest.vbs . Если Вы просматриваете это на внешнем ПК, то файл можно переместить на PNA с помощью дискеты или с помощью подключения диска.

  3. Закройте блокнот

Загрузка макроса в анализатор

  1. В приложении анализатора нажмите System, укажите Macro, затем нажмите Macro Setup

  2. Нажмите на пустой линии под последним вводом. (Там может не быть вводов вообще)

  3. Нажмите Edit

  4. В окне Macro Title box, введите Antenna Test

  5. Нажмите Browse.

  6. Измените Files of Type to VBScript Перейдите в каталог C:\Documents .

  7. Нажмите AntennaTest.vbs

  8. Нажмите OK

  9. Нажмите OK в диалоговом окне Macro Setup.

Для запуска макроса:

  1. Нажмите [image] на клавишах передней панели UTILITY.

  2. Нажмите клавишу активного ввода Antenna Test


Комплексный импеданс

Когда при тестировании устройства производятся измерения S11 или S22, Вы можете видеть данные комплексного импеданса, такие как последовательное и реактивное сопротивление, так же как информацию о фазе и амплитуде. Данные комплексного импеданса могут быть отображены в формате диаграммы Смита, либо в полярном формате.

  • Что такое комплексный импеданс?

  • Вопросы точности

  • Как измерить комплексный импеданс

Что такое комплексный импеданс?

Данные комплексного импеданса - это информация, которая может быть определена при тестировании устройства из измерений S11 или S22, такая как:

  • Сопротивление

  • Реактивное сопротивление

  • Фаза

  • Амплитуда (абсолютное значение)

Величина мощности отраженной от устройства напрямую связана с импедансом, как устройства, так и системы производящей измерения. Например, значение коэффициента комплексного отражения (Г) будет равно 0, только если будут абсолютно одинаковы импеданс устройства и импеданс системы (т.е. от источника на нагрузку передается максимальная мощность). Каждое значение Г однозначно соответствует комплексному импедансу устройства (как функция частоты), в соответсвии с уравнением:

ZL= [(1 + Г) / (1 - Г)] x Z0

где ZL импеданс тестируемого устройства, а Z0 характеристический импеданс измерительной системы.

Комплексный импеданс наилучшим образом отображается при использовании формата диаграммы Смита или полярного формата.

Вопросы точности

  • Диаграмма Смита наиболее проста для понимания, когда используется при полном значении масштаба равном 1.0.

  • Для повышения точности при использовании маркеров в формате диаграммы Смита, или полярном формате активируйте режим дискретных маркеров.

  • На погрешность измерения отражения влияют:

    • Направленность

    • Собственный ноль отражения

    • Согласование с источником

    • Согласование с нагрузкой (2-портовые устройства)

При 2-портовой калибровке влияние этих факторов уменьшается. 1-портовая калибровка предоставляет ту же точность, если выход прибора хорошо согласован (терминирован). Для дальнейшего обсуждения смотрите рисунок внизу.

  • Если вы подсоединили устройство между обоими портами анализатора, то для улучшения точности измерений на выходе устройства рекомендуется использовать фиксированный аттенюатор на 10 дБ. В этом нет необходимости, если вы используете 2-портовую калибровку, поскольку она корректирует согласование с нагрузкой.

  • Если вы подсоединяете устройство с двумя портами только к одному порту анализатора, то на выходе устройства рекомендуется использовать высококачественную нагрузку (такую как стандарт калибровки).

Как измерить комплексный импеданс

  1. Подсоедините устройство, как это показано на предыдущем рисунке.

  2. Установите предварительные настройки анализатора.

  3. Произведите настройку, калибровку и выполните измерения S11 или S22.

  4. Просмотр значений импеданса:

    1. Выберите формат диаграммы Смита.

    2. Установите масштаб отображаемых измерений для оптимального просмотра.

    3. Установите маркер в любой точке графика, чтобы прочесть значения резистивной и реактивной компоненты комплексного импеданса.

    4. Распечатайте данные или сохраните их на диске.

  5. Просмотр амплитуды и фазы коэффициента отражения:

    1. Выберите формат диаграммы Смита или полярный формат.

    2. Выберите линейный (Lin Marker) или логарифмический (Log Marker) формат маркера.

    3. Установите масштаб отображаемых измерений для оптимального просмотра.

    4. Установите маркер в любой точке графика, для того чтобы прочесть значения частоты, амплитуды и фазы коэффициента отражения (Г).

    5. Распечатайте данные или сохраните их на диске.


Отклонение от линейной фазы

Отклонение от линейной фазы это мера искажения фазы. Функция электрической задержки анализатора используется, для того чтобы убрать линейную часть фазового сдвига из измерений. Это дает возможность отобразить с высоким разрешением нелинейную часть фазового сдвига (отклонение от линейной фазы).

  • Что такое линейный фазовый сдвиг?

  • Что такое отклонение от линейной фазы?

  • Зачем измерять отклонение от линейной фазы?

  • Использование электрической задержки

  • Вопросы точности

См. другие разделы учебного руководства

Что такое линейный фазовый сдвиг?

Фазовый сдвиг возникает из-за того, что длины волн, заполняющих электрическую длину устройства, становятся короче при возрастании частоты входящего сигнала. Линейный фазовый сдвиг возникает когда фазовая характеристика прибора линейно зависит от частоты. При отображении на анализаторе, график измерения зависимости фазы от частоты такого идеального линейного фазового сдвига будет прямой линией. Наклон прямо пропорционален электрической длине устройства. Линейный фазовый сдвиг необходим (вместе с плоской АЧХ) для передачи сигналов без искажений.

Что такое отклонение от линейной фазы?

На практике, многие электрические или электронные приборы будут задерживать некоторые частоты больше чем другие, создавая нелинейный фазовый сдвиг (искажение сигналов, состоящих из многочастотных составляющих). Измерение отклонения от линейной фазы - это способ количественной оценки этого нелинейного фазового сдвига.

Поскольку причиной искажения фазы является только отклонение от линейной фазы то из измерений желательно удалить линейную часть фазовой характеристики. Этого можно достичь используя функцию электрической задержки анализатора, для того чтобы математически отнять электрическую длину тестируемого устройства. То, что останется, является отклонением линейной фазы или фазовыми искажениями.

Зачем измерять отклонение от линейной фазы?

Измерение отклонения от линейной фазы выполняет следующее:

  • Представление данных в единицах измерения фазы точнее, а не в секундах (групповая задержка). Для устройств, которые пропускают модулированные сигналы, единицы измерения фазы будут наиболее удобными.

  • Обеспечивает измерения с меньшим уровнем шумов, чем измерение групповой задержки.

Использование электрической задержки

Функция электрической задержки - это электронная версия механического "удлинителя линии" в более ранних моделях анализаторов. Эта функция выполняет следующее:

  • Имитация не имеющей потерь линии передачи изменяемой длины, которая фактически присоединяется или удаляется из пути опорного сигнала.

  • Компенсация электрической длины тестируемого устройства.

  • Плоский график измерений на дисплее анализатора. Это позволяет отображать график с высокой степенью разрешения, что позволяет увидеть детали фазовой нелинейности.

  • Предоставляет удобный метод оценки отклонения от линейной фазы тестируемого устройства. Смотрите приведенные ниже рисунки.

Вопросы точности

Частотная характеристика измерительной установки вносит основную ошибку в измерения отклонения от линейной фазы. Выполнение калибровки собственного нуля передачи значительно снижает эти ошибки. Для большей точности выполните 2-портовую калибровку измерений.

Как измерить отклонение от линейной фазы:

  1. Установите предварительные настройки анализатора.

  2. Если тестируемое устройство - это усилитель, то может появиться необходимость в настройке мощности источника анализатора:

    • Установите уровень мощности источника анализатора так, чтобы он находился в линейной области амплитудной характеристики усилителя (обычно на 10 дБ ниже точки, соответствующей сжатию 1 дБ).

    • Выберите внешний аттенюатор (если это необходимо) таким образом, чтобы снизить мощность усилителя на выходе настолько, чтобы избежать сжатия на приемнике или повреждения порта 2 анализатора.

  3. Подсоедините тестируемое устройство так, как это показано на рисунке ниже.

  3. Выберите измерение S21.

  4. Выберите настройки тестируемого устройства, включая следующее:

    • Формат: фаза (Format: phase)

    • Масштаб: автоматический подбор масштаба (Scale: autoscale)

  5. Уберите устройство и выполните калибровку измерений.

  6. Повторно подсоедините устройство.

  7. Установите масштаб отображаемых измерений для оптимального просмотра.

  8. Активируйте функцию электрической задержки для автоматического выравнивания графика фазы. Если хотите, то вручную окончательно настройте электрическую задержку для корректировки пологости графика фазы.

  9. Для измерения максимальной амплитуды отклонения от линейной фазы используйте маркеры.

  10. Распечатайте данные или сохраните их на диске.


Групповая задержка

Групповая задержка это мера фазового искажения. Групповая задержка - это фактическое время прохождения сигнала через тестируемое устройство в зависимости от частоты. При определении групповой задержки важно указывать апертуру, используемую для измерений.

  • Что такое групповая задержка?

  • Групповая задержка и отклонение от линейной фазы

  • Что такое апертура?

  • Вопросы точности

  • Как измерить групповую задержку?

Смотрите другие разделы по параметрам усилителя

Что такое групповая задержка?

Групповая задержка это:

• Мера искажения фазы устройством.
• Время прохождения сигнала через устройство в зависимости от частоты.
• Производная фазовой характеристики устройства по частоте.

Для дальнейшего обсуждения смотрите рисунок внизу:

Фазовая характеристика устройства обычно содержит как линейную компоненту фазового сдвига, так и компоненты более высокого порядка (отклонение от линейной).

Линейная компонента фазового сдвига: | Компонента фазового сдвига более высокого порядка:
Отражает среднее время прохождения сигнала. | Отражает разброс времени прохождения сигнала для различных частот.
Определяется электрической длиной устройства. | Причина искажения сигнала.

Для дальнейшего обсуждения смотрите рисунок внизу:

При измерении групповой задержки:

  • Линейная часть фазового сдвига обращается в постоянную величину (отражая среднюю задержку)

  • Часть фазового сдвига более высокого порядка преобразуется в отклонение от постоянной групповой задержки (неравномерность групповой задержки).

  • Отклонения групповой задержки приводят к искажению сигнала, так же как отклонения от линейной фазы приводят к искажению.

  • График измерений отображает то количество времени, которое заняло прохождение через тестируемое устройство на каждой частоте.

Для обсуждения того, как анализатор рассчитывает групповую задержку, рассмотрим следующее уравнение:

  • Данные о фазе используются для определения изменения фазы (-dф)

  • Заданная частотная апертура используется для определения изменения частоты (dw)

  • Используя значения двух вышеуказанных величин, в некотором приближении рассчитывается степень изменения фазы с частотой.

  • Это приближение выражает групповую задержку в секундах (предполагается линейное изменение фазы в пределах указанной апертуры частот).

Групповая задержка и отклонение от линейной фазы

Часто групповая задержка является более точным индикатором искажения фазы, чем отклонение от линейной фазы.

Результаты для отклонения от линейной фазы (Deviation from linear phase) приведены в верхней части следующих графиков: Устройство 1 и устройство 2 имеют одинаковые его значения, не смотря на разный внешний вид.

Результаты для групповой задержки приведены в нижней части:
Устройство 1 и устройство 2 имеют разные значения групповой задержки. Это потому что при определении групповой задержки анализатор рассчитывает наклон колебаний фазы, который зависит от числа колебаний приходящихся на единицу частоты.

Что такое апертура?

При измерении групповой задержки анализатор измеряет фазу на двух близко расположенных частотах, а затем рассчитывает наклон фазы. Частотный интервал (дельта частоты) между двумя точками измерения фазы называется апертурой. Изменение апертуры может влиять на значение групповой задержки. Рассчитанный наклон (дельта фазы) изменяется при увеличении апертуры. Поэтому при сравнении данных групповой задержки необходимо знать апертуру, которая использовалась при проведении измерений

Для дальнейшего обсуждения смотрите рисунок внизу:

Узкая апертура (Narrow aperture): | Широкая апертура (Wide aperture):
Обеспечивает более тонкую детализацию линейности фазы | Обеспечивает менее тонкую детализацию линейности фазы, потому что некоторые характеристики фазы усредняются или не измеряются.
Делает измерения более чувствительными к шуму (меньшее соотношение сигнал-шум) и разрешающей способности фазового детектора анализатора. | Делает измерения менее чувствительными к шуму (большее соотношение сигнал-шум).

Устанавливаемые по умолчанию на анализаторе настройки для апертуры групповой задержки - это диапазон частот, разделенный на количество на дисплее. Существует два способа установить другое значение апертуры.

  1. Скорректировать количество точек измерений или диапазон частот.

  • Увеличение количества точек или уменьшение диапазона частот сузит апертуру.

  • Уменьшение количества точек и/или увеличение диапазона частот расширит апертуру.

Примечание:если апертура будет слишком широкой (более чем 180° фазового сдвига между соседними точками для значений частоты), то в данных для групповой задержки будут появляться ошибки.

  2. Используйте функцию сглаживания анализатора.

  • Выполняется усреднение на соседних точках в пределах определенного участка диапазона частот.

  • Результатом будет действие близкое к изменению интервала частот между точками.

  • Допускает более широкую апертуру, потому что на сглаженной апертуре может возникнуть фазовый сдвиг более чем 180°.

Измерения групповой задержки могут быть выполнены для следующих типов свипирования:

  • Линейная частота

  • Перечень сегментов свипирования по частоте

Апертура групповой задержки изменяется в зависимости от интервала между частотами и плотности точек, поэтому при сегментированном свипировании апертура не постоянна. При сегментированном свипировании, для гарантирования желаемой апертуры могут быть определены дополнительные точки значений частоты.

Вопросы точности

Очень важно сохранять разницу фаз между двумя соседними точками измерений меньшей чем 180° (см. следующий рисунок). Иначе, в итоге могут получиться неправильные данные о фазе и задержке. Недостаточная дискретизация может встретиться при измерениях устройств с большой электрической длиной. Вы можете убедиться в том, что разница фаз между двумя соседними измеренными точками меньшей чем 180°, если график измерений перестанет изменяться при следующей регулировке настроек:

  • Увеличьте количество точек

  • Сузьте диапазон частот

Для компенсации этого эффекта может также использоваться электрическая задержка

Частотная характеристика измерительной установки вносит основную ошибку в измерения групповой задержки. Выполнение калибровки собственного нуля передачи значительно снижает эти ошибки.

В частности для усилителя, его характеристики могут изменятся при различных температурах. Измерения должны производиться, когда усилитель находится при требуемых рабочих температурах.

Как измерить групповую задержку?

  1. Установите предварительные настройки анализатора.

  2. Если тестируемое устройство - это усилитель, то может появиться необходимость в настройке мощности источника анализатора:

    • Установите уровень мощности источника анализатора так, чтобы он находился в линейной области амплитудной характеристики усилителя (обычно на 10 дБ ниже точки, соответствующей сжатию 1 дБ).

    • Выберите внешний аттенюатор (если это необходимо) таким образом, чтобы снизить мощность усилителя на выходе настолько, чтобы избежать сжатия на приемнике или повреждения порта 2 анализатора.

  3. Подсоедините тестируемое устройство так, как это показано на рисунке ниже.

  4. Выберите измерение параметра S21.

  5. Выберите настройки для тестируемого устройства, включая следующее:

    • количество измеряемых точек: максимум (number of measurement points: maximum)

    • формат: задержка (format: delay)

    • масштаб: автоматический подбор масштаба (scale: autoscale)

  6. Уберите тестируемое устройство и выполните калибровку измерений.

  7. Подсоедините обратно тестируемое устройство.

  8. становите масштаб отображаемых данных для оптимального просмотра.

  9. Используйте функцию сглаживания анализатора для увеличения апертуры, снижая шум графика и сохраняя значимые детали. Для увеличения апертуры:

    • Включите на анализаторе функцию сглаживания.

    • Изменяйте апертуру сглаживания (до 25% от диапазона свипирования).

  10. Используйте маркеры для измерения интересующей групповой задержки (выраженной в секундах) на определенной частоте.

  11. Распечатайте данные или сохраните их на диске.


Коэффициент усиления в режиме малого сигнала и АЧХ

Коэффициент усиления в режиме малого сигнала - это усиление в линейной области функционирования усилителя. Обычно измеряется при постоянном напряжении на входе и изменяющейся частоте. АЧХ коэффициента усиления это мера изменения усиления в определенном диапазоне частот.

  • Что такое усиление?

  • Что такое АЧХ?

  • Зачем измерять усиление и АЧХ?

  • Вопросы точности

  • Как измерить усиление и АЧХ

Смотрите другие разделы по параметрам усилителя

Что такое усиление?

Усиление радиочастотного усилителя определяется как разница между мощностью сигналов на входе и на выходе усилителя. Предполагается что волновое сопротивление (импеданс) на входе и на выходе усилителя такое же, как характеристический импеданс системы.

  • В терминологии S-параметров, усиление называется S21

  • Усиление выражается в дБ – логарифмическое отношение мощности на выходе к мощности на входе.

  • Усиление может быть получено вычитанием уровня входного сигнала из уровня на выходе, если они оба выражены в dBm, что означает уровень мощности относительно одного милливатта.

  • Коэффициентом усиления усилителя в большинстве случаев считается минимальное его значение в определенном диапазоне частот. Для некоторых усилителей указывается и минимальное и максимальное усиление, для того чтобы быть уверенным в том, что последующие каскады не будут недо- или перегружены.

Что такое АЧХ?

<АЧХ определяет насколько сильно может изменяться коэффициент усиления усилителя в указанном диапазоне частот. Отклонение усилителя от равномерного усиления может привести к искажению сигнала, проходящего через усилитель.

Зачем измерять коэффициент усиления в режиме малого сигнала и АЧХ?

Отклонение коэффициента усиления в интересующей полосе пропускания будет приводить к искажению передаваемого сигнала, потому что частотные компоненты будут усиливаться не одинаково. Коэффициент усиления в режиме малого сигнала позволяет определить усиление на отдельной частоте в 50-омной системе. АЧХ позволяет определить отклонение коэффициента усиления усилителя в указанном диапазоне частот в 50-омной системе.

Вопросы точности

  • Реакция усилителя может сильно отличаться при различных температурах. Измерения должны производиться, когда усилитель находится при требуемых рабочих температурах.

  • В случае необходимости, мощность на выходе усилителя должна быть в достаточной степени ослаблена. Слишком большая мощность на выходе может:

    • повредить приемник анализатора

    • превысить входной уровень сжатия приемника анализатора, приведя к неточности измерений.

Снижение мощности на выходе усилителя можно произвести за счет использования:

    • аттенюаторов

    • ответвителей

При калибровке должно быть учтено влияние частотных характеристик и несогласованности аттенюаторов и ответвителей, поскольку они являются частью измерительной системы. Правильная техника коррекции ошибок может уменьшить влияние данных эффектов.

  • Выполнение калибровки собственного нуля отражения значительно снижает эти ошибки. Для большей точности выполните 2-портовую калибровку измерений.

  • Сужение полосы пропускания промежуточных частот или использование усреднения улучшает динамический диапазон и точность измерений за счет скорости измерений.

Как измерить усиление и АЧХ

  1. Установите предварительные настройки анализатора.

  2. Выберите измерение параметра S21.

  3. Установите уровень мощности источника анализатора так, чтобы он находился в линейной области амплитудной характеристики усилителя (обычно на 10 дБ ниже точки, соответствующей сжатию 1 дБ).

  4. Выберите внешний аттенюатор (если это необходимо) таким образом, чтобы снизить мощность усилителя на выходе настолько, чтобы избежать сжатия на приемнике или повреждения порта 2 анализатора.

  5. Подсоедините усилитель, как это показано на следующем рисунке, и обеспечьте подачу смещения (постоянный ток).

  6. Выберите настройки анализатора для тестируемого усилителя.

  7. Уберите усилитель и выполните калибровку измерений. Если аттенюатор и кабели будут использоваться при измерениях с усилителем, то убедитесь в том, что они задействованы при проведении калибровки.

  8. Сохраните состояние прибора в памяти.

  9. Повторно подсоедините усилитель.

  10. Установите масштаб отображаемых данных для оптимального просмотра и используйте маркер для измерения коэффициента усиления слабого сигнала на выбранной частоте.

  11. Измерьте АЧХ коэффициента усиления в определенном диапазоне частот, используя маркеры для оценки амплитуды неравномерности.

  12. Распечатайте данные или сохраните их на диске.

  13. Этот тип измерений может быть автоматизирован.


Нелинейность амплитудной характеристики

Нелинейность амплитудной характеристики (Gain compression) измеряет уровень приложенной к усилителю мощности на входе, который приводит к искажениям на выходе.

  • Что такое нелинейность амплитудной характеристики?

  • Зачем измерять нелинейность амплитудной характеристики?

  • Вопросы точности

  • Как измерить нелинейность амплитудной характеристики

Смотрите другие разделы по параметрам усилителя

Что такое нелинейность амплитудной характеристики?

Нелинейность амплитудной характеристики возникает, когда входная мощность усилителя возрастает до уровня, при котором у усилителя снижается коэффициент усиления и появляется нелинейность возрастания мощности на выходе.

У анализатора есть возможность производить свипирование по мощности так же как и по частоте. Свипирование по мощности помогает характеризовать нелинейность усилителя. Для дальнейшего обсуждения смотрите рисунок внизу (график мощности на выходе анализатора в зависимости от мощности на входе, для отдельной частоты).

  • У усилителя есть линейный рабочий диапазон, где коэффициент усиления постоянен и независим от уровня мощности. Обычно усиление в этом диапазоне называется "коэффициент усиления в режиме малого сигнала"

  • При возрастании мощности на входе коэффициент усиления усилителя начинает снижаться и усиление начинает ослабевать.

  • Наиболее распространенное измерение нелинейности амплитудной характеристики это точка сжатия на 1 дБ. Это определяется как мощность на входе (или иногда мощность на выходе) которая приводит к уменьшению коэффициента усиления усилителя на 1 дБ (относительно усиления слабых сигналов).

Зачем измерять нелинейность амплитудной характеристики?

При усилении синусоидального сигнала сигнал на выходе усилителя в области сжатия уже не будет синусоидальным. Некоторые выходные сигналы усилителя возникают на гармониках охотнее, чем только на собственной частоте входного сигнала.

При дальнейшем возрастании мощности на входе усилитель входит в насыщение и мощность на выходе остается постоянной. В этой точке дальнейшее увеличение входной мощности усилителя не приводит к изменению мощности на выходе.

В некоторых случаях (таких как с усилителями на ЛБВ) после насыщения в действительности мощность на выходе уменьшается при дальнейшем увеличении входной мощности, а это означает что у усилителя отрицательный коэффициент усиления.

Поскольку усиление необходимо при работе усилителя, то важно знать граничные значения входных сигналов, которые приводят к нелинейности амплитудной характеристики.

Вопросы точности

Для того чтобы вывести усилитель на уровень насыщения, анализатор цепей должен обеспечить достаточную мощность. Если вам необходим уровень входной мощности, больший чем может предоставить источник анализатора, то используйте предусилитель, для того чтобы повысить уровень мощности перед тестируемым усилителем. (Смотрите Измерения усилителей мощности с использованием PNA.) Используя предусилитель можно увеличить точность измерений следующими способами:

  • Используйте ответвитель на выходе предусилителя так, чтобы часть усиленного входного сигнала можно было использовать в опорном канале анализатора. При такой конфигурации из измерений (устанавливая отношение) убираются ошибки, связанные с частотными характеристиками и ошибки из-за ухода параметров.

  • Выполните в измерительной установке калибровку собственного нуля передачи, включая предусилитель, ответвители и аттенюаторы.

В случае необходимости, мощность на выходе усилителя должна быть в достаточной степени ослаблена. Слишком большая мощность на выходе может:

  • Повредить приемник анализатора

  • Превысить входной уровень сжатия приемника анализатора

Ослабление мощности на выходе усилителя можно произвести за счет использования:

  • Аттенюаторов

  • Ответвителей

При калибровке должно быть учтено влияние частотных характеристик аттенюаторов и ответвителей, поскольку они являются частью измерительной системы. Правильная техника коррекции ошибок может уменьшить данные эффекты.

  • Частотная характеристика измерительной установки вносит основную ошибку в измерения нелинейности амплитудной характеристики. Выполнение калибровки собственного нуля передачи значительно снижает эти ошибки.

  • Реакция усилителя может сильно отличаться при различных температурах. Измерения должны производиться, когда усилитель находится при требуемых рабочих температурах.

  • Сужение полосы пропускания промежуточных частот или использование усреднения улучшает динамический диапазон и точность измерений за счет скорости измерений.

Как измерить нелинейность амплитудной характеристики

Ниже приведены три процедуры выполнения измерений, используемых для определения нелинейности амплитудной характеристики усилителя:

  1. Измерение нелинейности амплитудной характеристики при свипировании по частоте определяет наименьшее значение частоты, при котором впервые возникает сжатие усиления на 1 дБ.

  2. Измерение нелинейности амплитудной характеристики при свипировании по мощности указывает значение мощности на входе, при котором для определенного значения частоты (найденного в измерении 1) возникает падение усиления на 1 дБ.

  3. Измерение абсолютной мощности показывает абсолютную мощность на выходе (в dBm) при сжатии.

Измерение нелинейности амплитудной характеристики при свипировании по частоте

Измерение нелинейности амплитудной характеристики при свипировании по частоте определяет значение частоты, при которой впервые возникает сжатие усиления на 1 дБ.

  1. Установите предварительные настройки анализатора.

  2. Выберите измерение параметра S21.

  3. Установите уровень мощности источника анализатора так, чтобы он находился в линейной области амплитудной характеристики усилителя (обычно на 10 дБ ниже точки, соответствующей сжатию 1 дБ).

  4. Выберите внешний аттенюатор (если это необходимо) таким образом, чтобы снизить мощность усилителя на выходе настолько, чтобы избежать сжатия на приемнике или повреждения порта 2 анализатора.

  5. Подсоедините усилитель, как это показано на следующем рисунке, и обеспечьте подачу смещения (постоянный ток).

  6. Выберите настройки анализатора для тестируемого усилителя. Для того чтобы снизить влияние шума можно задать более узкую полосу ПЧ.

  7. Уберите усилитель и выполните калибровку собстенного нуля передачи. Если аттенюатор и кабели будут использоваться при измерениях с усилителем, то убедитесь в том, что они задействованы при проведении калибровки.

  8. Сохраните состояние прибора в памяти.

  9. Повторно подсоедините усилитель.

  10. Расположите маркер приблизительно в середине диапазона.

  11. Установите масштаб анализатора 1 дБ на деление.

  12. Сохраните график в памяти и выведите на экран отношение Data/Mem.

  13. Постепенно увеличивайте мощность источника пока на определенном участке графика, на первой частоте не обнаружится уменьшение усиления на 1 дБ.

  14. Используйте маркер для того чтобы определить первую частоту, на которой возникло уменьшение усиления на 1 дБ.

  15. Распечатайте данные или сохраните их на диске.

Измерение нелинейности амплитудной характеристики при свипировании по мощности

Измерение нелинейности амплитудной характеристики при свипировании по мощности определяет мощность на входе, при которой, для определенного значения частоты (найденого на шаге 13 предыдущих измерений), возникает падение усиления на 1 дБ.

  1. Если это еще не сделано, выполните предыдущее измерение нелинейности амплитудной характеристики при свипировании по частоте.

  2. Установите измерение S21 в режиме развертки по мощности. Включите следующие настройки:

    • Установите значение частоты непрерывных колебаний (CW), отмеченное в шаге 14 предыдущего измерения нелинейности амплитудной характеристики при свипировании по частоте.

    • Введите начальный и конечный уровень мощности для свипирования. Начальная мощность должна находиться в линейной области амплитудной характеристики усилителя (обычно 10 дБ ниже точки, соответствующей сжатию 1 дБ). Конечная мощность должна находиться в области сжатия амплитудной характеристики усилителя.

  3. Установите масштаб анализатора 1 дБ на деление.

  4. Используйте маркеры (включая опорный маркер) для обнаружения значения мощности на входе, при котором возникает уменьшение усиления на 1 дБ.

  5. Распечатайте данные или сохраните их на диске.

Измерение абсолютной мощности на выходе

Измерение абсолютной мощности дает абсолютную мощность на выходе усилителя (в dBm) при сжатии.

  1. Выберите измерение абсолютной (абсолютного значения) мощности. Выберите вход B, если используется измерительная установка с предыдущего рисунка.

  2. Воспользуйтесь значением частоты CW из предыдущего измерения нелинейности амплитудной характеристики при свипировании по мощности.

  3. Установите маркер на уровень входящей мощности, при котором происходит уменьшение усиления на 1 дБ (смотрите шаг 4 предыдущих измерений).

  4. Установите масштаб отображаемых данных для оптимального просмотра.

  5. Считайте значение маркера, для того чтобы определить абсолютную мощность на выходе усилителя (в dBm) при которой происходит уменьшение усиления на 1 дБ.

  6. Распечатайте данные или сохраните их на диске.

Примечание: Для абсолютной мощности не применяется калибровка измерений. Поэтому, если вне анализатора есть какое либо ослабление мощности, Вам необходимо внести поправку на него вручную.


Обратная развязка

Развязка в обратном направлении

Обратная развязка это мера характеристики обратной передачи усилителя – от выхода на вход.

  • Что такое обратная развязка?

  • Зачем измеряется обратная развязка?

  • Вопросы точности

  • Как измерить обратную развязку

См. другие разделы учебного руководства

Что такое обратная развязка?

Обратная развязка это мера того насколько хорошо сигнал приложенный к выходу устройства "изолирован" от его сигнала на его входе.

Измерение обратной развязки похоже на измерение прямого усиления за исключением того что:

  • Сигнал стимула прикладывается к выходному порту усилителя.

  • Отклик измеряется на входном порту усилителя.

Эквивалентным S-параметром является S12.

Зачем измеряется обратная развязка?

У идеального усилителя бесконечная обратная развязка – сигнал не передается с выхода обратно на вход. Однако, отраженный сигнал может пройти через усилитель в обратном направлении. Эта нежелательная обратная передача может привести к интерференции отраженного сигнала с основным сигналом следующим в прямом направлении. Поэтому важно определить величину обратной развязки.

Вопросы точности

Поскольку усилители обычно демонстрируют высокие потери в обратном направлении, то обычно нет необходимости в понижении мощности, которой возможно пользовались для защиты порта 2 приемника при измерении прямой передачи. Устранение ослабления:

  • Увеличит динамический диапазон, тем самым улучшая точность измерений.

  • Потребует новой калибровки для максимальной точности.

Для обеспечения большего динамического диапазона и точности можно увеличить мощность источника РЧ.

Примечание: При отсутствующем ослаблении и усиленной мощности источника РЧ прямое свипирование может повредить порт 2 приемника анализатора. Не выполняйте прямое свипирование или используйте 2-портовую калибровку пока поступающая в прямом направлении мощность не будет установлена достаточно низкой чтобы избежать сжатия или повреждения порта 2 приемника.

Если у тестируемого усилителя развязка очень большая, то уровень переданного сигнала может быть близок к уровню шумов или уровню перекрестных помех приемника. Для понижения уровня шумов:

  • Используйте или увеличьте усреднения измерений.

  • Сузьте полосу ПЧ анализатора.

Примечание: Сужение полосы ПЧ или использование усреднения улучшает динамический диапазон и точность измерений за счет снижения скорости измерений.

  • Если уровень перекрестных помех влияет на точность измерений, уменьшите вектор погрешности перекрестных помех, выполнив калибровку ответного сигнала и развязки. Выполняя связанную с развязкой часть калибровок важно использовать один и тот же коэффициент усреднения и полосу пропускания промежуточных частот как при калибровке так и при измерениях.

  • Частотная характеристика измерительной установки вносит основную ошибку в измерения обратной развязки. Выполнение калибровки собственного нуля передачи значительно снижает эти ошибки. Эта калибровка может быть выполнена как составная часть калибровки ответного сигнала и развязки.

  • Реакция усилителя может сильно отличаться при различных температурах. Измерения должны производиться, когда усилитель находится при требуемых рабочих температурах.

Как измерить обратную развязку

  1. Подсоедините усилитель так как это показано ниже на рисунке.

  2. Установите предварительные настройки анализатора.

  3. Выберите измерение S12.

  4. Выберите настройки тестируемого усилителя.

  5. Уберите усилитель и выполните калибровку собственного нуля передачи, или калибровки ответного сигнала и развязки.

  6. Установите масштаб отображаемых данных измерений для оптимального обзора и используйте маркер для измерения обратной развязки для нужной частоты.

  7. Распечатайте данные или сохраните их на диске.


Мощность на выходе

Абсолютная мощность на выходе

Измерение абсолютной мощности на выходе, дает значение абсолютной мощности в зависимости от частоты.

  • Что такое абсолютная мощность на выходе?

  • Зачем измеряется абсолютная мощность на выходе?

  • Вопросы точности

  • Как измерить абсолютную мощность на выходе

Смотрите другие разделы по параметрам усилителя

Что такое абсолютная мощность на выходе?

Измерение абсолютной мощности на выходе отображает мощность, имеющуюся на входном порту анализатора. Эта мощность является абсолютной величиной – она не связана (безотносительна) с входящей мощностью или мощностью источника. В логарифмическом (log) формате, величины на вертикальной оси сетки указываются в единицах dBm, которые являются мощностью, измеренной по отношению к 1 мВт.

  • 0 dBm = 1 мВт

  • -10 dBm = 100 мкВт

  • +10 dBm = 10 мВт

В линейном формате, величины на вертикальной оси сетки указываются в ваттах (W).

Зачем измеряется абсолютная мощность на выходе?

Абсолютная мощность на выходе измеряется, когда на выходе усилителя должна быть определена абсолютная мощность, а не определено соотношение для относительной мощности. Например, при измерении сжатия (нелинейных искажений), обычно также измеряют абсолютную мощность на выходе. Это дает абсолютную мощность на выходе усилителя при сжатии на 1 дБ.

Вопросы точности

В случае необходимости, мощность на выходе усилителя должна быть в достаточной степени ослаблена. Слишком большая мощность на выходе может:

    • Повредить приемник анализатора

    • Превысить входной уровень сжатия приемника анализатора, приведя к неточности измерений.

Ослабление мощности на выходе усилителя можно произвести за счет использования либо аттенюаторов, либо ответвителей.

Реакция усилителя может сильно отличаться при различных температурах. Измерения должны производиться, когда усилитель находится при требуемых рабочих температурах.

Как измерить абсолютную мощность

Для измерения абсолютной мощности на выходе выполните следующее:

  1. Установите предварительные настройки анализатора.

  2. Выберите абсолютное (unratioed) измерение мощности (приемник B).

  3. Установите мощность источника анализатора на 0 dBm.

  4. Выберите внешний аттенюатор (если это необходимо) таким образом, чтобы мощность усилителя на выходе была бы снижена достаточно, для того чтобы избежать сжатия на приемнике или повреждения порта-2 анализатора.

  5. Подсоедините усилитель, как это показано на следующем рисунке, и обеспечьте подачу смещения (постоянный ток).

  6. Выберите настройки анализатора для тестируемого усилителя.

  7. Уберите усилитель и соедините вместе измерительные порты. Сохраните данные в памяти. Убедитесь в том, что аттенюатор и кабели включены в измерительную схему, если они будут использоваться при измерениях усилителя.

  8. Сохраните состояние прибора в памяти.

  9. Повторно подсоедините усилитель.

  10. Выберите математическую операцию Data/Memory.

  11. Установите масштаб отображаемых данных для оптимального просмотра и используйте маркеры для измерения абсолютного значения мощности на выходе при желаемой частоте.

  12. Распечатайте данные или сохраните их на диске.


Временная область

Временная область позволяет просматривать характеристики устройства как функцию времени. В данном разделе рассмотрено следующее:

  • Обзор

  • Как PNA производит измерения во временной области

  • Калибровка для временной области

  • Измерения передачи

  • Разрешающая способность измерения характеристик

  • Диапазон измерений и повторные отклики

  • Как произвести настройки временной области

  • Временная селекция (Gating)

  • Настройки окна

Примечание: Измерения во временной области доступны только для PNA с Опцией 010. См. Опции PNA

Обзор

В обычном режиме работы PNA измеряет характеристики тестируемого устройства как функцию частоты. При использовании Временной области (опция 010) информация области частот используется для расчета обратного преобразования Фурье и отображения результата измерений на горизонтальной оси дисплея как функции времени. Значения отклика появляются разделенными во времени, что позволяет посмотреть с другой стороны на характеристики и ограничения тестируемого устройства.

На рисунке внизу сравниваются данные измерений характеристик одного и того же кабеля в частотной и временной области. Кабель имеет два изгиба. Каждый изгиб приводит к рассогласованию или изменению импеданса линии.

  • Измерения S11 в частотной области показывают отражения причиной которых являются рассогласования в кабеле. Невозможно определить, где физически в кабеле возникло рассогласование.

  • Отклик во временной области показывает как положение, так и величину каждого рассогласования. Из отклика видно что второй изгиб кабеля является местом значительного рассогласования. Это рассогласование может быть скрыто с помощью временной селекции, позволяя увидеть зависимость в частотной области так, как если бы этого несоответствия не существовало. Для того чтобы точно определить расстояние от рассогласования до плоскости измерения можно использовать маркеры расстояния.

Как PNA производит измерения во временной области

Режим преобразования временной области напоминает обычное измерение отражения во временной области (Time-Domain Reflectometry -TDR), при котором подается импульсный сигнал в тестируемое устройство и на экране рефлектометра выводится отраженная энергия. Анализируя амплитуду, продолжительность и форму отраженного сигнала можно определить природу изменения импеданса в тестируемом устройстве.

PNA не запускает обычный импульс или ступенчатый сигнал. Вместо этого, для того чтобы получить временную информацию из частотных измерений, используется алгоритм преобразования Фурье. Ниже показано как это происходит.

Отдельная частота во временной области отображается в виде синусоидальной волны. На приведенном ниже графике, после того как мы добавили частоту основной гармоники (F0), первую гармонику (2F0) и вторую гармонику (3F0) мы можем увидеть импульс, принимающий свою форму в виде суммарной волны. Если мы добавляли бы больше частотных компонент, то импульс становился бы резче и уже. Когда PNA посылает дискретные частоты на тестируемое устройство, то на самом деле, в качестве стимула для тестируемого устройства посылаются отдельные спектральные компоненты импульса.

При измерениях отражения S11 эти входящие сигналы отражаются от тестируемого устройства и измеряются на приемнике А. После этого для сложения вместе отдельных компонент спектра используются расчеты преобразования временной области.

Например, рассмотрим разомкнутый на конце короткий кабель. Вся мощность входящего сигнала отражается и отражение находится в фазе с входным сигналом. Все частотные компоненты складываются вместе и мы видим структуру, которая будет выглядеть, так же как и смоделированный входной сигнал (см. выше). Амплитуда отражения связана с уровнем рассогласования импеданса, а задержка пропорциональна расстоянию до места рассогласования. Для того чтобы лучше показать задержку у приведенного выше рисунка был изменен масштаб оси x (время).

С другой стороны, тот же кабель закороченный на конце также отражает всю мощность входного сигнала, но со сдвигом фазы на 180 градусов. Когда частотные компоненты отраженного сигнала суммируются вместе, результат получается в виде отрицательной задержки импульса во времени.

Калибровка для временной области

Для простоты мы рассматривали входной сигнал, отраженный на разрыве в тестируемом устройстве. Наиболее общим применением преобразования результатов измерения анализатора цепей является относительное измерение S11. Измерение отражения S11 не просто отображает отражение, измеренное на приемнике A – оно отображает отношение (или разницу) сигналов на приемнике A и опорном приемнике. Кроме того, измерение S11 также может быть откалибровано так, чтобы убрать систематические ошибки из относительных измерений. Это важно для измерений во временной области, поскольку плоскость измерения (на которой находится точка калибровки) становится нулем на оси X шкалы времени. Все данные о времени и расстоянии приводятся по отношению к этой точке. В результате данные об амплитуде и времени будут откалиброванными и очень точными.

Ниже показано, где в потоке данных PNA происходит преобразование во временную область: (см. рисунок)

  1. Запрос необработанных данных приемника (A и R1)

  2. Выполнение расчета соотношения (A/R1)

  3. Применение калибровки

  4. Преобразование данных во временную область

  5. Отображение результатов

Поэтому, не смотря на то, что график во временной области может быть выведен на дисплей, калибровка всегда выполняется и применяется к измерениям в области частот, которые не отображаются.

Измерения передачи

Наиболее распространенный тип измерений для преобразования это измерения отражения S11. Однако полезную информацию о тестируемом устройстве можно получить и из преобразованных измерений передачи S21. Компоненты спектра проходят через тестируемое устройство и измеряются на приемнике B. Если есть более одного пути их прохождения через устройство, то они будут появляться в виде различных импульсов разделенных по времени.

Например, на следующих результатах измерения передачи видны несколько путей прохождения через фильтр на поверхностных акустических волнах (SAW). Самый большой импульс (со временем близким к нулю) показывает время распространения по самому кроткому пути через устройство . Желаемому пути может соответствовать не самый большой импульс. Каждый последующий импульс представляет другой возможный путь от входа к выходу.

Тройное прохождение - это термин, используемый для описания сигнала отраженного от выхода, снова отраженного от входа, и, в конце концов, снова появившегося на выходе. Это лучше всего видно из измерений S21 во временной области.

Разрешающая способность измерения характеристик

Из предыдущего параграфа видно, что использование большего количества частотных компонент приводит к тому, что скомпонованная результирующая форма сигнала отображается более детально. Это называется разрешающей способностью измерения характеристик, которая определяется как возможность различить два близко расположенных ответных сигнала. Следующие настройки также улучшают разрешающую способность измерения характеристик.

Примечание: Регулировка настроек времени преобразования улучшает разрешающую способность отображения, а не разрешающую способность измерения.

  • Настройки окна

  • Режим временной области

  • Полоса частот

На приведенном ниже рисунке показано влияние узкой и широкой полосы частот на разрешающую способность измерения отклика. Более широкая полоса частот позволяет анализатору разделить два коннектора на отдельные четкие ответные сигналы.

Хотя более широкая полоса частот приводит к лучшей разрешающей способности измерения, диапазон измерений становится ограниченным.

Увеличение диапазона частот может привести к тому, что калибровка измерений станет недействительной. ПРЕЖДЕ чем выполнять калибровку убедитесь в том, что полоса частот настроена.

Формула для разрешающей способности

Возможность PNA различать два близко расположенных отклика (в метрах) можно рассчитать, воспользовавшись следующей формулой:

Разрешающая способность = (Vf * c * (points-1)) / (2 * Fspan * Ns)

Где:

Vf = Коэффициент укорочения
c = скорость света в вакууме (2.99796x108 м/сек)
points = количество точек измерения
Fspan = полоса частот измерения
Ns = Коэффициент дискретизации (128 для 101 точки; 256 для 201 точки; 512 для 401 точки)

Диапазон измерений и повторные отклики

Диапазон измерений это интервал времени, в котором могут быть получены реальные характеристики во временной области. Диапазон измерений должен быть достаточно большим, для того чтобы увидеть полные характеристики тестируемого устройства, но так чтобы не столкнуться с повторением отклика (alias). Повторные отклики могут скрывать реальные характеристики во временной области.

Для того чтобы увеличить диапазон измерений в обоих режимах измените одну из следующих настроек:

  • Увеличьте количество точек

  • Уменьшите полосу частот

Примечания:

  • После выполнения этих настроек вам, для того чтобы увидеть новый диапазон измерений, может понадобиться отрегулировать настройки времени преобразования.

  • Уменьшение полосы частот ухудшает разрешающую способность измерений.

  • Выполните установку полосы частот и количества точек ДО калибровки.

  • Максимальный диапазон также зависит от потерь в тестируемом устройстве. Если возвращающийся сигнал слишком слабый, для того чтобы его измерить, диапазон ограничивается вне зависимости от полосы частот.

Повторные ответные сигналы

Повторные ответные сигналы не являются реальными откликами устройства. Повторные ответные сигналы повторяются из-за того что каждый сигнал во временной области имеет много периодов и повторяется со временем (см. Как PNA измеряет во временной области). Повторные ответные сигналы возникают на временных интервалах с размером шага равным 1/частота.

PNA подстраивает настройки времени преобразования так, чтоб вы видели только один свободный от повторных сигналов интервал с каждой стороны (положительный и отрицательный) от нулевого времени. Однако эти настройки обновляются только когда изменяется одна из настроек панели.

Для того чтобы определить является ли отклик реальным, установите маркер на его отображении и измените полосу частот. Реальный отклик устройства не будет двигаться по времени. Повторные сигналы будут передвигаться.

Например, на приведенном выше рисунке отклик с маркером 1 появляется на расстоянии 14.07 дюйма. После изменения полосы частот этот сигнал остается на расстоянии 14.07 дюйма. Сигнал маркера 2 передвинулся.

Формула для диапазона

Диапазон (в метрах) измерений PNA в котором будут отсутствовать повторные сигналы можно рассчитать, воспользовавшись следующей формулой:

Диапазон = Vf * c * (points-1) / (2 * Fspan)

Где:

Vf = Коэффициент укорочения
c = скорость света в вакууме (2.99796x108 м/сек)
points = количество точек измерения
Fspan = полоса частот измерения

Как произвести настройки временной области

Это запустит панель инструментов Временной области

Для того чтобы запустить диалоговое окно Временной области нажмите на панели инструментов More...

Узнайте больше об использовании интерфейса передней панели

Справка по диалоговому окну Transform

Category Выберите Преобразование (Transform), Окно (Window) или Временную селекцию (Gating)

Transform включает или выключает преобразование во временной области.

Coupling Settings Запускает диалоговое окно Настройки связывания графиков .

Настройки времени

Приведенные ниже настройки регулируют разрешающую способность отображения, позволяя увеличить или уменьшить масштаб отображаемых характеристик. Они НЕ изменяют диапазон измерений или разрешающую способность измерений.

Эти настройки обновляются автоматически (когда обновляется одно из соответствующих значений) так чтобы ограничить отображение по обе стороны от нуля времени одним не содержащим повторные сигналы откликом.

Start Устанавливает начальное время преобразования, отображаемое на экране PNA.

Примечание: Нулевая (0) секунда всегда является измерительной плоскостью отсчета. При перемещении измерительной плоскости отсчета полезно использовать отрицательные значения.

Stop Устанавливает время остановки преобразования, которое отображается на экране PNA.

Center Устанавливает время середины преобразования, которое отображается в центре экрана PNA.

Span Устанавливает интервал времени преобразования, который разделен на две части по обе стороны от центрального значения.

Режим преобразования

Режимы преобразования - это три варианта того, как применяется алгоритм преобразования во временной области к измерениям в области частот. Каждый метод имеет отдельную область применения.

Режим

Преимущества использования

Ограничение

Low pass Impulse (Импульс через ФНЧ)

Самая высокая разрешающая способность.

Наиболее полезен для наблюдения малых откликов в устройствах пропускающих низкие частоты, таких как кабели.

Для обоих способов частота вблизи постоянного тока и отрицательные частоты экстраполируются. Поэтому начальная частота корректируется при нажатии Set Freq.Low Pass

Поскольку это будет влиять на точность калибровки, обязательно проведите калибровку ПОСЛЕ полной настройки измерений во временной области.

Low pass Step (Ступенчатый сигнал через ФНЧ)

Наиболее простой способ определения индуктивной или емкостной неоднородности в устройствах пропускающих низкие частоты, таких как кабели.

Band pass Impulse (Импульс через полосовой фильтр)

Самый простой способ – применим для любого свипирования по частоте.

Наиболее полезен при измерении устройств с ограниченной полосой пропускания, таких как фильтры и кабели с развязкой по постоянному току.

Не показывает емкостное и индуктивное реактивное сопротивление

Для одной и той же полосы частот и количества точек, режим полосового фильтра имеет двойную ширину импульса, которая скрывает близко расположенные отклики, уменьшая разрешение откликов.

На следующей схеме показано как интерпретировать результаты различных неоднородностей импеданса используя режим Low pass Step и также режимы Low pass или Band pass Impulse.

Влияние на диапазон измерений

Band pass mode - диапазон измерений обратно пропорционален размеру шага частоты.

Low pass mode - диапазон измерений обратно пропорционален частоте основной (начальной) гармоники ПОСЛЕ нажатия Set Freq. Low Pass.

Set Freq. Low Pass ИСПОЛЬЗУЙТЕ ТОЛЬКО В РЕЖИМАХ LOW PASS (ФНЧ)

Пересчитывает начальную частоту и шаг приращения частот так чтоб они были гармониками начальной частоты (основной гармоники). Начальная частота рассчитывается по следующей формуле: Low Pass Start Frequency = Stop Frequency / Number of points. (Начальная частота для режима ФНЧ = Частота останова/ Количество точек)

Рассчитанное значение должно всегда быть больше или равно минимальной частоте анализатора.

Примечание: Для того чтобы получить такое значение можно изменить количество точек или конечную частоту.

Distance Marker Settings Запускает диалоговое окно Настройки маркеров расстояния.

Временная селекция (Gating)

Функция временной селекции является, возможно, самой полезной функцией преобразования во временной области. При просмотре отклика устройства во временной области для " виртуального " удаления ненужных откликов можно использовать функцию временной селекции. После этого можно одновременно видеть график в частотной области таким, как будто ненужных откликов не существует. Это позволяет получить характеристики устройства без влияния на них внешних устройств, таких как разъемы или адаптеры.

Примечание: Когда неоднородность в тестируемом устройстве отражает энергию, эта энергия уже не достигнет последующих неоднородностей. Это может "МАСКИРОВАТЬ", или спрятать реальные отклики, которые возникли бы, если бы не существовало предыдущей неоднородности. Функция временной селекции НЕ компенсирует это.

На приведенных ниже изображениях измерений показаны реальные примеры того, как использовать и выполнять временную селекцию. Тестируемое устройство представляет собой 10-дюймовый кабель, с последующем аттенюатором на 6 дБ и заканчивающийся коротким замыканием. В окне 2 слева направо явно видны следующие четыре неоднородности:

  1. Неоднородность в кабеле тестируемой системы, которая возникла после калибровки. Она обозначена маркером 2 на расстоянии -10.74 дюймах (за плоскостью измерения).

  2. Неоднородность в 10-дюймовом кабеле устройства сразу после плоскости измерения.

  3. Самая большая неоднородность - это аттенюатор и короткое замыкание показанное маркером 1 на уровне -12.67 дБ (6 дБ потерь в обоих направлениях: прямом и обратном).

  4. Последняя неоднородность это повторное отражение от кабеля устройства.

Мы оставим отклик аттенюатора. Все остальные отклики будут исключены.

Окно 1. Создается исходный график частотной области S11. Показана неравномерность от всех отражений.

Окно 2. Создается новый график S11 – тот же канал; новое окно. Преобразование включено.

Окно 3. Для преобразованного графика включите временную селекцию. Установите центр временного селектора на большой неоднородности (2.500 нсек.). Отрегулируйте ширину селектора так чтобы полностью накрыть неоднородность. Выберите полоснопропускающий тип временной селекции (Bandpass gating).

Окно 4. На исходных частотных измерениях включите временную селекцию (Gating ON), преобразование остается выключенным. Просмотрите результаты измерения без влияния двух нежелательных неоднородностей. Синий график - это измерение для 6 дБ аттенюатора с ФИЗИЧЕСКИ удаленными нежелательными неоднородностями. Разница между двумя графиками в окне 4 - это эффект "маскирования".

См. как запустить диалоговое окно Преобразования

Справка по диалоговому окну Transform Gating

Gating включает и выключает временную селекцию.

Coupling Settings Запускает диалоговое окно Настройки связывания графиков.

Start Устанавливает время начала селекции.

Stop Устанавливает время остановки селекции.

Center Определяет значение в центре области на которой будет действовать функция временной селекции. Это значение может быть в любым в пределах диапазона анализатора.

Span Определяет интервал с обеих сторон от значения центра области на которой будет действовать функция временной селекции.

Gate Type Задает способ фильтрации который будет выполнятся для функции временной селекции. Флажки начала и останова селекции на экране указывают в направлении той части графика, которую Вы хотите сохранить.

  • Bandpass (Пропускание) – сохраняет отклики в пределах интервала селекции.

  • Notch (Режекция) – удаляет отклики в пределах интервала селекции.

Gate Shape определяет характеристики фильтра функции селекции. Можно выбрать Минимальный, Нормальный, Широкий, Максимальный (Minimum, Normal, Wide, Maximum)

Форма фильтра функции селекции (Gate Shape) | Неравномерность в полосе пропускания (Passband Ripple) | Уровни боковых лепестков (Sidelobe Levels) | Время среза (Cutoff Time) | Минимальная ширина селекции (Minimum Gate Span)
Minimum | ±0.1 дБ | -48 дБ | 1.4/Диапазон частот | 2.8/Диапазон частот
Normal | ±0.1 дБ | -68 дБ | 2.8/Диапазон частот | 5.6/Диапазон частот
Wide | ±0.1 дБ | -57 дБ | 4.4/Диапазон частот | 8.8/Диапазон частот
Maximum | ±0.01 дБ | -70 дБ | 12.7/Диапазон частот | 25.4/Диапазон частот

Cutoff time (Время среза) – это время между временем останова (-6 дБ по краю фильтра) и пиком первого бокового лепестка. На диаграмме показана суммарная форма фильтра функции селекции и перечислены характеристики для каждой формы.

  • T1 это интервал временной селекции, который равен времени останова минус время старта.

  • T2 это время между краем полосы пропускания и точкой 6 дБ, представляющее крутизну склона фильтра.

  • T3 это время между точкой 6 дБ и краем полосы задерживания временной селекции.

  • Для фильтров любой формы T2 равен T3, и фильтр одинаков по обе стороны от центрального времени.

Minimum gate span (Минимальная ширина временной селекции) – это умноженное на два время среза. Для каждой из форм фильтра временной селекции для надлежащей работы имеется минимальная рекомендованная ширина временной селекции. Это является следствием конечности крутизны склона фильтра временной селекции. Если Вы укажете полосу временной селекции меньше минимальной полосы, то это следующим образом отобразится на характеристиках:

  • искаженная форма фильтра временной селекции, который не имеет полосы пропускания

  • искаженная форма

  • неправильное отображение времени старта и останова

  • может иметь повышенный уровень боковых лепестков

Настройки окна

При измерениях в области частот существует резкий переход на частоте пуска и останова, приводящий к выбросам и звону отклика во временной области. Функция окна полезна для уменьшения резкости переходов в области частот. Это приводит к необходимости принятия компромиссного решения для отклика во временной области. Выбирать приходится между следующим:

  • Минимальное окно = Лучшее разрешение отклика - возможность различить два близко расположенных отклика.

  • Максимальное окно = Динамический диапазон - возможность измерить отклики с низким уровнем (слабые сигналы).

См. как запустить диалоговое окно Transform

Справка по диалоговому окну Transform - Window

Coupling Settings (Настройки связывания) Запускает диалоговое окно Setup Trace Coupling.

Настройки окна устанавливают баланс между разрешающей способностью и динамическим диапазоном.

  • Минимальное окно = Лучшее разрешение отклика

  • Максимальное окно = Самый лучший динамический диапазон

Ниже приведены три метода установки размера окна. Для получения лучшего результата, при выполнении этих настроек смотрите на отклик во временной области

  • Minimum - Maximum Для того чтобы изменить размер окна двигайте мышкой бегунок

  • Kaiser Beta Изменяет размер окна используя значения Беты окна Кайзера

  • Impulse Width Изменяет размер окна используя значения ширины импульса

Подробнее об Управлении окнами (top)

Как произвести настройки связывания графиков

Диалоговое окно Trace Coupling Settings можно запустить из любого приведенного ниже диалогового окна:

  • Transform

  • Gating

  • Window

Подробнее об использовании интерфейса передней панели

Справка по диалоговому окну Trace Coupling Settings

Связывание графиков позволяет при изменении параметров измерений во временной области получать такие же изменения для всех остальных измерений в этом канале.

Например:

Если вы одновременно просматриваете результаты измерений в области частот и результаты измерений во временной области,

и в данном диалоговом окне включено связывание Coupling,

и в данном диалоговом окне отмечены ВСЕ параметры селекции Gating Parameters,

и для измерений во временной области вы изменили параметр Gate Span,

То результаты измерения в области частот автоматически изменятся так, чтобы отобразить интервал селекции во временной области.

Coupling ON/OFF Отметьте чтобы разрешить связывание. Все измерения в активном канале будут связаны.

Для связывания доступны следующие параметры:

Параметры преобразования

Stimulus Настройки времени Старта (Start), Останова (Stop), Центра (Center) и Интервала времени (Span TIME).

State (On/Off) Преобразование ВКЛ/ ВЫКЛ

Window Бета Кайзера / Ширина импульса

Mode Low pass Impulse (Импульс через ФНЧ), Low pass Step (Ступенчатый сигнал через ФНЧ), Band pass (Импульс через полосовой фильтр)

Параметры временной селекции

Stimulus Настройки времени Старта (Start), Останова (Stop), Центра (Center) и Интервала времени (Span TIME).

State (On/Off) Временная селекция ВКЛ/ ВЫКЛ

Shape Минимальный, Нормальный, Широкий, Максимальный (Minimum, Normal, Wide, Maximum)

Type Пропускание (Bandpass) и Режекция (Notch)

Справка по диалоговому окну Distance Marker Settings (Настройки маркера расстояния)

Для запуска этого диалогового окна нажмите Dist. Marker Settings в диалоговом окне Transform.

Если маркеры установлены при измерениях во временной области, то расстояние автоматически отображается в показаниях маркера, таблице маркеров, и печатной копии. Для того чтобы узнать, как создать для ваших измерений маркеры смотрите настройки маркеров.

Данное диалоговое окно позволяет настроить показания маркеров расстояния во временной области.

Эти настройки влияют на отображение ВСЕХ маркеров только для АКТИВНОГО измерения (если только Distance Marker Unit не связан в диалоговом окне Trace Coupling.

Marker Mode Указывает тип измерений для того, чтобы определить правильное расстояние до маркеров.

  • Выберите Auto для измерения S-параметров.

  • Выберите Reflection или Transmission измерений с произвольным соотношением или абсолютных измерений.

Auto Если текущее измерение - это измерение S-параметров, то автоматически выбирается отражение или передача. Если текущее измерение - это измерение не S-параметров то выбирается отражение.

Reflection Отображает расстояние от источника до приемника и обратно деленное на два (для того чтобы компенсировать путь обратно)

Transmission Отображает расстояние от источника до приемника.

Units Указывает единицы измерения для отображения значения расстояния до маркера.

Velocity Factor (Коэффициент укорочения) Указывает численное значение, отображающее скорость передачи энергии по передающим линиям с разными диэлектриками. Это используется во временной области для точного отображения времени и маркеров расстояния. Некоторые из наиболее распространенных значений :

  • 0.66 - Кабель с полиэтиленовым диэлектриком

  • 0.7 - Фторопластовый диэлектрик

  • 1.0 - Скорость света в вакууме

Эти настройки можно также произвести из диалоговых окон Электрическая задержка и Расширения порта.


Сдвиг частоты

Опция 080 для PNA предоставляет возможность измерений со сдвигом частоты с помощью соответствующего оборудования и базового ПО. В данном разделе рассматриваются настройки PNA, относящиеся к проведению этих типов измерений. См. Измерения устройств преобразования частот для получения дополнительных сведений об измерениях с помощью конкретного устройства.

Примечание: Опция 083 — приложение преобразователя частот — упрощает задачу выполнения предельно точных измерений со сдвигом частоты для БОЛЬШИНСТВА устройств преобразования частот.

  • Диалоговое окно Frequency Offset

  • Примеры установки

  • Диалоговое окно Test Set (Reference Switch)

Другие разделы по сдвигу частоты

Доступ к диалоговому окну Frequency Offset

Узнайте больше об интерфейсе передней панели

Справка по диалоговому окну Frequency Offset

Примечание: Для базовых измерений со сдвигом частоты порты 1 и 2 можно настроить как в качестве источника (стимула), так и в качестве приемника (отклик). В случае с опцией 083 такой возможности НЕТ.

Frequency Offset on/off (Включение/отключение сдвига частоты) Включает режим сдвига частоты для ВСЕХ измерений, проводимых на активном канале. При этом источник и приемник немедленно настраиваются на отдельные частоты. Частоты приемника указаны в остальных настройках данного диалогового окна. Для настройки параметров стимула в меню Channel щелкните Start / Stop, а затем OK.

Совет: Во избежание лишних ошибок следует сначала настроить другие параметры данного диалогового окна, а затем включать параметр Frequency Offset.

Offset Settings (Настройки сдвига)

Приемники настраиваются на частоту, определенную следующей формулой:

Response = Offset +(Multiplier / Divisor) x Stimulus (or source)

Отклик = Сдвиг +(Множитель / Делитель) x Стимул (или источник)

Где:

Offset (Сдвиг) задает абсолютную частоту сдвига в Гц. Для измерений со смесителем это должна быть частота гетеродина (LO). Диапазон +/- 1000 ГГц. Сдвиг может быть как положительным, так и отрицательным. См. пример.

Multiplier (Множитель) задает (наряду с делителем) значение, на которое умножается стимул. Диапазон +/- 1000. При отрицательных множителях стимул свипирует в порядке убывания. Для измерений со смесителем это может применяться в случаях, когда требуется меньшее значение входной (Input) частоты, чем частоты гетеродина (LO). См. пример.

Divisor (Делитель) задает (наряду с множителем) значение, на которое умножается стимул. Диапазон от 1 до 1000.

Stimulus CW Override (Переопределение фиксированной частоты для стимула)

Данный параметр используется для установки фиксированной (CW) частоты стимула при измерении отклика в свипированном диапазоне частот. Например, стимул PNA может подаваться на РЧ вход (RF input) смесителя, гетеродин которого (LO) подвергается свипированию. Так как выход ПЧ (IF output) смесителя будет подвергнут свипированию, приемники PNA также должны быть свипированы. См. пример.

Для установки такого состояния прибора:

  1. Установите тип свипирования стимула (Linear, Log или Segment Sweep) и параметры частоты, а также сдвиг (Offset), множитель (Multiplier) и делитель (Divisor) для установки желаемых частот начала и окончания отклика

  2. Включите сдвиг частоты (Frequency Offset) — после чего приемники будут свипировать между желаемыми частотами

  3. Включите параметр CW Override и установите желаемую фиксированную (CW) частоту для источника.

Примечания:

При включенном сдвиге частоты ВСЕ приемники на канале настраиваются на частоту сдвига, включая и опорный приемник. Поэтому измерения S21 (потери при преобразовании) не будут показывать частоту отклика относительно входной частоты.

Если необходимо выполнять измерения и показывать их результаты по частотам, как стимула, так и отклика, необходимо использовать два канала. Такие виды относительных измерений должны вычисляться вне устройства PNA.

Сведения о калибровке измерений со сдвигом частоты см. в разделе Калибровка сдвига частоты.

Использование свипирования мощности при тестировании смесителей

Для измерения нелинейных искажений смесителя нужно свипировать его входную мощность. Входная и выходная частоты фиксированы, но сдвинуты относительно друг друга. Для установки входной и выходной частоты тестируемого смесителя:

  1. В меню PNA щелкните Sweep, затем Sweep Type. Выберите Power Sweep. Кроме того, установите частоту CW (входную частоту тестируемого смесителя).

  2. Щелкните Channel, а затем Frequency Offset. Установите сдвиг частоты Offset соответственно частоте гетеродина (LO) и отклика тестируемого смесителя.

Примеры настройки

1.

Swept Stimulus Свипированный стимул (1000 МГц ... 1100 МГц)

Swept Response Свипированный отклик (2500 МГц ... 2700 МГц)

Настройте параметры следующим образом:

В меню Channel щелкните Start / Stop

Start Frequency (Начальная частота) = 1000 МГц

Stop Frequency (Конечная частота) = 1100 МГц

В диалоговом окне Frequency Offset:

Offset (Сдвиг) = 500 МГц

Multiplier (Множитель) = 2

Divisor (Делитель) = 1

Frequency Offset (Сдвиг частоты) = ON

Приведенные выше настройки соответствуют следующим частотам отклика:

Отклик = Сдвиг + (Множитель / Делитель) x Стимул

Начальная частота отклика = 500 + [(2 /1) * 1000]

= 2500 МГц

Конечная частота отклика = 500 + [(2 /1) * 1100]

= 2700 МГц

2.

Fixed Stimulus Фиксированный стимул (1000 МГц)

Swept Response Свипированный отклик (2500 МГц ... 2700 МГц)

Настройте параметры следующим образом:

В меню Channel щелкните Start / Stop

Start Frequency (Начальная частота) = 2500 МГц

Stop Frequency (Конечная частота) = 2700 МГц

В диалоговом окне Frequency Offset:

Stimulus CW Override (Переопределение частоты CW стимула): ON (ВКЛ)

CW Frequency (Частота CW): 1000 МГц

Offset (Сдвиг) = 0 МГц

Multiplier (Множитель) = 1

Divisor (Делитель) = 1

Frequency Offset (Сдвиг частоты) = ON (ВКЛ)

3.

Swept Stimulus Свипированный стимул (1000 МГц ... 1100 МГц)

Fixed Response Фиксированный отклик (2500 МГц)

Настройте параметры следующим образом:

В меню Channel щелкните Start / Stop

Start Frequency (Начальная частота) = 1000 МГц

Stop Frequency (Конечная частота) = 1100 МГц

В диалоговом окне Frequency Offset:

Offset (Сдвиг) = 2500 МГц

Multiplier (Множитель) = 0

Divisor (Делитель) = 1

Frequency Offset (Сдвиг частоты) = ON (ВКЛ)

Приведенные выше настройки соответствуют следующим частотам отклика:

Отклик = Сдвиг + (Множитель / Делитель) x Стимул

Начальная частота отклика = 2500 + [(0 /1) * 1000]

= 2500 МГц

Конечная частота отклика = 2500 + [(0 /1) * 1100]

= 2500 МГц

4.

Swept Stimulus Свипированный стимул (2500 МГц ... 2600 МГц)

Swept Response Свипированный отклик (1000 МГц ... 1100 МГц)

External LO Внешний гетеродин (не входит в комплект): 1500 МГц

Start Frequency (Начальная частота) = 2500 МГц

Stop Frequency (Конечная частота) = 2600 МГц

В диалоговом окне Frequency Offset:

Offset (Сдвиг) = -1500 МГц

Multiplier (Множитель) = 1

Divisor (Делитель) = 1

Frequency Offset (Сдвиг частоты) = ON (ВКЛ)

Приведенные выше настройки соответствуют следующим частотам отклика:

Отклик = Сдвиг + (Множитель / Делитель) x Стимул

Начальная частота отклика = -1500 + [(1 /1) * 2500]

= 1000 МГц

Конечная частота отклика = -1500 + [(1 /1) * 2600]

= 1100 МГц

5.

Swept DECREASING Stimulus Свипированный УБЫВАЮЩИЙ стимул (1100 МГц ... 1000 МГц)

Swept INCREASING Response Свипированный ВОЗРАСТАЮЩИЙ отклик (1400 МГц ... 1500 МГц)

External LO Внешний гетеродин (не входит в комплект): 2500 МГц

Для некоторых устройств преобразования частоты по мере возрастания входной частоты выходная частота снижается. Анализатор может отображать частоту отклика (выходную частоту) только как возрастающую. Поэтому при свипировании стимула от более высокой к более низкой частоте достигается тот же эффект. Это позволяет измерить и отобразить возрастающий отклик.

Для этого следует установить отрицательное значение множителя. Это приведет к автоматическому свипированию источника PNA в обратную сторону, от более высокой к более низкой частоте.

Настройте параметры следующим образом:

В меню Channel щелкните Start / Stop

Start Frequency (Начальная частота) = 1000 МГц

Stop Frequency (Конечная частота) = 1100 МГц

В диалоговом окне Frequency Offset:

Offset (Сдвиг) = 2500 МГц

Multiplier (Множитель) = -1

Divisor (Делитель) = 1

Frequency Offset (Сдвиг частоты) = ON (ВКЛ)

Приведенные выше настройки соответствуют следующим частотам отклика:

Отклик = Сдвиг + (Множитель / Делитель) x Стимул

Начальная частота отклика = 2500 + [(-1 /1) * 1000]

= 1500 МГц

Конечная частота отклика = 2500 + [(-1 /1) * 1100]

= 1400 МГц

Свипирование отклика в обратную сторону невозможно, поэтому PNA реверсирует частоты стимула.

Stimulus Start Frequency = 1100 МГц

Stimulus Stop Frequency = 1000 МГц

Начальная частота отклика = 1400 МГц

Конечная частота отклика = 1500 МГц

Опорный переключатель конфигурируемого измерительного пульта

В моделях PNA с опцией 081 В моделях PNA с опцией 081 в конфигурируемом измерительном пульте (test set) имеется переключатель, позволяющий обходить опорный приемник порта 1 через коннекторы передней панели Reference 1. Этот переключатель позволяет легко переключаться между стандартными измерениями S-параметров и измерениями с помощью опорного смесителя. Эту функцию можно использовать для выполнения стандартных измерений S11 и измерений передачи преобразователя относительно опорного ("золотого") смесителя.

Примечание: Приложение Преобразователь частоты (Frequency Converter Application - FCA) Опция 083 упрощает задачу выполнения предельно точных фазовых измерений для БОЛЬШИНСТВА устройств преобразования частоты.

Доступ к диалоговому окну Test Set

Узнайте больше об использовании интерфейса передней панели

Справка по диалоговому окну Test Set

Примечание: Данная функция доступна только в моделях PNA с опцией 081опцией 081 - внешним опорным переключателем.

R1 Input Path

Internal: bypass R1 Loop Подключает источник порта 1 непосредственно к приемнику R1.

External: flow through R1 Loop Делает возможным непосредственный доступ к приемнику R1 через коннекторы передней панели Reference 1.

См. блок-схему опорного переключателя.


Обзор измерений устройств с преобразователями частоты

Измерения устройств с преобразователями частоты

Многие измерения со смещением частоты могут быть сделаны с использованием опции 080. Ниже приведен перечень некоторых из этих измерений и способы их проведения.

  • Потери преобразования

  • Нелинейность характеристики преобразования

  • Обратные потери и КСВН (VSWR)

  • Развязка

  • Гармонические искажения

See Also: Точность измерений со смещением частоты


Точность измерений со сдвигом частоты

В этом разделе обсуждаются методы, которые можно использовать для выполнения точных измерений со сдвигом частоты.

  • Калибровки

  • Ошибки рассогласования

  • Точный и стабильный гетеродин (LO)

См. другие разделы по измерениям смесителя

Калибровки

При измерениях сдвига частоты, частоты стимула и отклика различаются. Стандартные векторы погрешности калибровки вычисляются посредством опорных измерений. Поэтому традиционные методы калибровки, например, полный двухпортовый SOLT, для сдвигов частоты использоваться не могут.

Приложение преобразователя частот (опция 083) поддерживает полноценно калиброванные скалярные и фазовые измерения сдвига частоты.

В случае отсутствия опции 083 калибровку измерений со сдвигом частоты можно выполнять посредством калибровки мощности источника и приемника.

Калибровка мощности источника:

  • Устанавливает точный уровень мощности на частотах стимула независимо от используемого в измерении приемника.

  • Может копироваться на другие каналы с помощью функции копирования каналов.

  • Может быть интерполирована.

Калибровка мощности приемника:

  • Требует предварительного выполнения и применения калибровки источника.

  • Не может копироваться на другие каналы.

Поэтому:

  • Начните с выполнения калибровки мощности источника над комбинированными частотами источника и приемника.

  • Скопируйте канал на другие необходимые каналы, посредством чего будет скопирована калибровка мощности источника.

  • Измените диапазон частот скопированного канала на частоту отклика

  • Выполните калибровку приемника на частотах отклика по отдельным каналам.

  • • Измените диапазон частот на частоту стимула и включите сдвиг частоты.

  • Удостоверьтесь, что в строке состояния включены калибровки источника и приемника (калибровка источника будет интерполирована).

См. Измерения потерь при преобразовании в качестве примера.

Подробнее о калибровках мощности источника и приемника.

Ошибки рассогласования

Ошибки рассогласования имеют место в случае, когда существует соединение между двумя портами с различным импедансом. При измерениях S-параметров эти несоответствия измеряются и математически устраняются в процессе полной двухпортовой калибровки. При измерениях сдвига частоты это превращается в намного более сложную проблему. Более простым решением является использование высококачественных аттенюаторов на входе и выходе смесителя.

При добавлении к порту высококачественного аттенюатора эффективное согласование портов может быть улучшено вплоть до двухкратного значения ослабления. Например, аттенюатор на 10 дБ с согласованием порта 32 дБ может превратить исходное согласованиепорта 10 дБ в эффективное согласование 25 дБ. Однако по мере достижения согласованием аттенюатора согласования источника значение улучшения уменьшается.

Примечание: Приложение преобразователя частот (опция 083) использует технику калибровки, исправляющую ошибки рассогласования.

Чем больше величина ослабления, тем ближе итоговое согласование к согласованию аттенюатора, что показано на следующем рисунке. Однако чрезмерное ослабление нежелательно, так как оно снижает динамический диапазон системы измерений.

Точный и стабильный гетеродин (LO)

При использовании режима сдвига частоты, если сигнал гетеродина (LO) является неточным и нестабильным, то частота выходного сигнала не будет совпадать с ожидаемой частотой отклика. В результате этого выходной сигнал может попасть на скаты фильтра ПЧ приемника PNA или вообще за пределы полосы пропускания фильтра приемника.

Кроме того, уровень мощности гетеродина критичен при измерениях со смесителем. Следует удостовериться, что мониторинг этих уровней мощности осуществляется надлежащим образом.


Потери преобразования

Потери преобразования (коэффициент передачи)

  • Что такое потери преобразования?

  • Зачем измерять потери преобразования?

  • Измерение потерь преобразования

См. другие разделы по измерениям устройств с преобразованием частоты

Что такое потери преобразования?

Потери преобразования определяются как отношение мощности на выходной частоте к мощности на входной частоте при заданной мощности гетеродина. Это иллюстрирует нижеприведенный график. Указание мощности гетеродина необходимо, так как потери преобразования варьируются в зависимости от уровня мощности гетеродина, поскольку изменяется импеданс диода смесителя.

Зачем измерять потери преобразования?

Потери (или коэффициент передачи, в случае множества преобразователей и тюнеров) преобразования являются показателем эффективности преобразования смесителем энергии от входной к выходной частоте. Если характеристика потерь преобразования для смесителя или преобразователя не является линейной в диапазоне рабочих частот, то в результирующем выходном сигнале может быть потеряна ценная информация.

Измерение потерь преобразования

Измерение потерь преобразования представляет собой измерение передачи. Оно выполняется путем применения входного сигнала (стимула) и сигнала гетеродина на конкретных известных уровнях мощности, и измерения уровня результирующего выходного сигнала. Так как выходная частота отличается от входной, для данного измерения необходимо применять режим сдвига частоты (опция 080).

Примечание: Данное измерение выполняется намного проще, если PNA оснащен приложением Преобразователь частоты (FCA)

Настройка оборудования

Пример: Калиброванное измерение потерь преобразования (для понижающего преобразователя)

Свипированный вход с фиксированным LO = свипированному выходу

  • Вход RF: 3,1 - 3,3 ГГц

  • Гетеродин (LO): 2,2 ГГц

  • Выход IF: 900 - 1100 МГц

Настройка устройства PNA и калибровка на канале 1

  • Создайте на канале 1 относительное R-измерение по ВСЕМУ диапазону входных и выходных частот (0,9 - 3,3 ГГц). Это будет базовая калибровка мощности источника, которая будет копироваться на измерения каналов R и B.

  • Выполните калибровку источника с помощью измерителя мощности. Это сделает уровень мощности на входе смесителя довольно точным.

Настройка опорного измерения на канале 2

  • Скопируйте канал 1 на канал 2, на котором будет отображаться опорный вход на смеситель. Калибровка мощности источника с канала 1 будет скопирована вместе с другими настройками канала.

  • Измените измерение на R1 относительное.

  • Измените входную частоту RF на 3,1 — 3,3 ГГц. Калибровка мощности источника станет интерполированной.

  • Выполните калибровку мощности приемника. Для этого не требуется каких-либо физических соединений. Источник PNA изначально подключен к приемнику R1. Такая калибровка заставит приемник R считывать уровень мощности источника.

Настройка B-измерения на канале 3

  • Скопируйте канал 1 на канал 3. На этом канале будет отображаться выход смесителя. Калибровка мощности источника с канала 1 будет скопирована вместе с другими настройками канала.

  • Измените измерение на B относительное.

  • Измените выходную частоту IF (ПЧ) на 0,9 - 1,1 ГГц. При этом калибровка мощности источника станет интерполированной.

  • Подключите линию thru от порта 1 к порту 2.

  • Выполните калибровку мощности приемника. Это заставит приемник B считывать мощность источника на частотах выхода IF.

  • Выключите калибровку мощности приемника. Это позволит предотвратить ошибку, возникающую при переключении на входные частоты (следующий этап).

  • Измените входную частоту RF (РЧ) на 3,1 - 3,3 ГГц. При этом канал переключится обратно на входные частоты RF смесителя.

  • Включите сдвиг частоты.

  • Измените сдвиг на (-2.2 GHz). При этом приемник B будет настроен на выходные частоты IF от 0,9 до 1,1 ГГц. Примечание: Знак минуса указывает на измерение понижающего преобразователя.

  • Включите калибровку мощности приемника.

Измерение смесителя

  • Подключите смеситель.

  • Настройте масштабирование согласно потребностям.

  • Включите маркеры для считывания уровней мощности для каждого графика.

На экране ниже будут показаны:

  • Абсолютная выходная мощность приемника B канала 3 (нижний график).

  • Абсолютная входная мощность на смеситель приемника R1 канала 2 (верхний график).

При использовании данного метода вычисление потерь преобразования (B/R1) нужно выполнить вручную. Маркеры устанавливаются отдельно для каждого канала, но операции с графиками между каналами не поддерживаются. Кроме того, измерение соотношения B/R1 не поддерживается при включенной калибровке мощности приемника. Однако, измерения потерь преобразования (C21) можно выполнять непосредственно и намного проще с помощью приложения Преобразователь частоты, FCA (опция 083).


Нелинейность характеристики преобразования

Нелинейность характеристики преобразования (сжатие при преобразовании)

  • Что такое сжатие при преобразовании?

  • Зачем измерять сжатие при преобразовании?

  • Измерение сжатия при преобразовании

  • Вопросы точности измерений

См. другие разделы по измерениям устройств с преобразованием частоты

Что такое сжатие при преобразовании?

При измерении сжатия при преобразовании измеряется максимальный уровень входного сигнала, на котором смеситель будет работать линейно. Это похоже на нелинейность амплитудной характеристики, наблюдаемую в усилителях.

Для понимания сжатия при преобразовании необходимо сначала понять, что такое потери преобразования. Это отношение выходного уровня смесителя ко входному уровню смесителя. Данное значение остается постоянным в пределах указанного диапазона входных мощностей. Когда уровень входной мощности превышает определенную максимальную величину, постоянное соотношение между входным и выходным уровнями мощности начинает меняться. Точка, в которой соотношение снижается на 1 дБ, называется 1-дБ точкой сжатия. Это иллюстрирует нижеприведенный график.

Зачем измерять сжатие при преобразовании?

Сжатие при преобразовании является показателем динамического диапазона устройства. Динамический диапазон обычно определяется как разность между минимальным уровнем шума и 1-дБ точкой сжатия.

Измерение сжатия при преобразовании

Оборудование и настройка, необходимые для измерения сжатия при преобразовании, по существу те же, что и для измерения потерь при преобразовании, что иллюстрирует следующий рисунок.

PNA выполняет свипирование мощности в режиме сдвига частоты, и в результате отображается выходная мощность смесителя в виде функции его входной мощности. 1-дБ точку сжатия (а также другие, например 3-дБ) можно определить с помощью маркеров.

Вопросы точности измерений

Вопросы настройки оборудования

  • Ответвители PNA обладают довольно хорошей направленностью. В случае значительных обратных потерь тестируемого устройства отраженный сигнал сэмплируется анализатором PNA, что может вызвать ошибки. Это касается ошибки в коэффициенте передачи тестируемого устройства. Для увеличения точности можно добавить аттенюатор между портом источника PNA и входным портом тестируемого устройства. Обычно достаточно аттенюатора на 6 — 10 дБ. Добавление такого аттенюатора, однако, снижает доступную выходную мощность, подаваемую на тестируемое устройство.

  • При высоких уровнях выходной мощности PNA может сам выполнять сжатие, результатом которого будет ошибка измерений. Слишком высокие уровни выходной мощности могут привести к повреждению анализатора. Во избежание подобных проблем следует добавить аттенюатор между выходом тестируемого устройства и входом приемника PNA.

Вопросы калибровки

  • Калибровка мощности источника может использоваться для достижения высокого уровня точности данного измерения.

  • Если PNA оснащен приложением Преобразователь частоты (FCA) (опция 083), можно выполнить скалярную калибровку смесителя для достижения большей точности измерений.


Развязка

Измерения развязки в устройствах преобразования частоты

  • Что такое развязка?

  • Зачем измерять развязку?

  • Измерение развязки

См. другие разделы по измерениям устройств с преобразованием частоты

Что такое развязка?

Развязка представляет собой показатель утечки (проникания) сигнала от одного порта к другому. Чем больший уровень развязки обеспечивает смеситель, тем ниже величина утечки. Развязка измеряется на той же частоте, что и стимул, без сдвига или преобразования частоты. Поэтому возможность сдвига частоты для таких измерений не является необходимой.

Для измерений смесителей важны три основных показателя развязки:

  • Развязка между гетеродином и выходом (LO-to-OUT) (VLO)

  • Развязка между гетеродином и входом (LO-to-IN) (VLO)

  • Проникание между входом и выходом (IN-to-OUT) (VIN)

Зачем измерять развязку?

Утечка любого нежелательного сигнала в устройстве может вызвать его смешивание с желаемым выходным сигналом, создающим интермодуляционные составляющие, что увеличивает интермодуляционные искажения. Фильтрация таких нежелательных сигналов может быть сложной.

Измерение развязки

Для измерения развязки смесителя используются следующие настройки:

Заметьте следующее:

  • Уровень развязки между входом и выходом сильно зависит от уровня мощности гетеродина. Развязку следует измерять при нормальном рабочем уровне мощности гетеродина.

  • Каждый из портов, не подлежащих тестированию, должен подключаться к устройству с импедансом, стандартным для фактической операции. Это не обязательно должен быть характеристический импеданс, Z0 (обычно 50 или 75 Ом). Например, если выходной (OUT) порт смесителя планируется подключить непосредственно к фильтру, этот фильтр должен использоваться при измерении проникания между гетеродином и входом (LO-to-IN).

РАЗВЯЗКА МЕЖДУ ГЕТЕРОДИНОМ И ВХОДОМ (LO-TO-IN)

РАЗВЯЗКА МЕЖДУ ГЕТЕРОДИНОМ И ВЫХОДОМ (LO-TO-OUT)

РАЗВЯЗКА МЕЖДУ ВХОДОМ И ВЫХОДОМ (IN-TO-OUT)

Измерения преобразователей и смесителей

Измерение проникания между входом и выходом (IN-to-OUT) преобразователя идентично такому же измерению для смесителя. Проникание IN-to-OUT для преобразователя является обычно низким из-за включения в устройство фильтра IF. Поэтому для измерения может потребоваться увеличение динамического диапазона PNA.

Для измерения утечки для гетеродина (LO-to-OUT и LO-to-IN) преобразователя требуются иные действия, так как порт гетеродина (LO) обычно недоступен:

  • PNA можно настроить на частоту сигнала гетеродина, а выходной (OUT) или входной (IN) порт подключить к порту приемника PNA. Порт источника PNA не подключается.

  • Анализатор спектра можно подключить либо к выходному, либо ко входному порту и настроить на частоту сигнала гетеродина.


Гармоническое искажение

  • Что такое гармоническое искажение?

  • Зачем измерять гармоническое искажение?

  • Измерение гармонического искажения

  • Вопросы измерений и точности

См. другие разделы по измерениям устройств с преобразованием частоты

Что такое гармоническое искажение?

Гармоники представляют собой многократные повторения какого-либо сигнала, возникающего на входе смесителя, а также многократные повторения сигнала на входе гетеродина. Искажение характеристик на выходе смесителя, вызванное такими гармониками, называется гармоническим искажением. Гармоническое искажение вызывается нелинейностями в устройстве.

Гармоники НЕ являются сигналами, возникающими в результате взаимодействия (смешивания) двух или более сигналов; такие сигналы называются интермодуляционными составляющими, возникающими в результате интермодуляционного искажения.

Зачем измерять гармонические искажения?

  • Они могут ухудшить характеристики устройств, подключенных к выходу смесителя.

  • Гармоники могут также смешиваться с другими сигналами в смесителе, увеличивая интермодуляционные искажения смесителя.

Измерение гармонических искажений

Гармоники можно измерить с помощью PNA с опцией 80 «Frequency Offset». Частота гетеродина для смесителя устанавливается в нуль, а множитель входа RF используется для настройки промежуточной частоты IF (гармоники). Настройка оборудования показана ниже.

Так как гармоники указываются в dBc (децибелах ниже несущей), измеряются основная RF-гармоника, а также вторая и третья гармоники, а затем вычисляются различия. Для этого можно использовать несколько каналов.

  1. Подключите оборудование.

  2. Настройте измерение для калибровки. См. также Вопросы измерений и точности.

Используйте три канала и режим сдвига частоты:

Канал 1 = с F1 до F2

Канал 2 = с F1 до 2F2 (режим сдвига частоты, множитель = 1)

Канал 3 = с F1 до 3F2 (режим сдвига частоты, множитель = 1)

  • Выполните калибровку мощностей источника и приемника по всему диапазону частот. См. Вопросы измерений и точности.

  • Уменьшите интервал частот и увеличьте множитель сдвига частоты на каналах 2 и 3:

Канал 2 = с F1 до F2 (режим сдвига частоты, множитель = 2)

Канал 3 = с F1 до F2 (режим сдвига частоты, множитель = 3)

Примечание: Так как интервал частот изменился по сравнению с использованным при калибровке, калибровки источника и приемника будут интерполированы.

  • Подключите тестируемое устройство, выполните измерение и вычислите отклик гармоник:

Настройте маркеры для каналов 1, 2 и 3, а затем определите разность между значениями маркеров для получения значений каждой гармоники в dBc.

Канал 1 – канал 2 = 2-я гармоника (dBc)

Канал 1 – канал 3 = 3-я гармоника (dBc)

Примечание: Удостоверьтесь, что маркеры настроены на соответствующий стимул. Маркеры канала 2 должны быть установлены на двойную частоту от маркеров канала 1. Маркеры канала 3 должны быть установлены на тройную частоту от маркеров канала 1.

Вопросы измерений и точности

Вопросы настройки оборудования

  • На входе смесителя должен использоваться фильтр для удаления гармоник источника PNA.

Калибровка

  • Если PNA оснащен приложением Преобразователь частоты (FCA), можно выполнить скалярную калибровку смесителя для более точных измерений.


Обратные потери и КСВН

  • Что такое обратные потери и КСВН?

  • Зачем измерять обратные потери и КСВН?

  • Измерение обратных потерь и КСВН

См. другие разделы по измерениям устройств с преобразованием частоты

Что такое обратные потери и КСВН?

Измерения как обратных потерь, так и КСВН представляют собой измерения линейных отражений, даже при тестировании устройств преобразования частоты, так как отражаемая частота не преобразуется. Такие измерения по существу являются одинаковыми для фильтров и усилителей. Узнайте больше об измерениях отражений.

Зачем измерять обратные потери и КСВН?

Использование устройств с неудовлетворительными показателями обратных потерь и КСВН приводит к потере мощности сигнала или искажению содержащейся в сигнале информации.

Измерение обратных потерь и КСВН

При измерении обратных потерь и КСВН PNA настраивается так же, как и любое двухпортовое устройство. Подключите устройство преобразования частоты, как показано на следующих рисунках:

ОБРАТНЫЕ ПОТЕРИ И КСВН ДЛЯ ВХОДНОГО ПОРТА СМЕСИТЕЛЯ

ОБРАТНЫЕ ПОТЕРИ И КСВН ДЛЯ ВЫХОДНОГО ПОРТА СМЕСИТЕЛЯ

ОБРАТНЫЕ ПОТЕРИ И КСВН ДЛЯ ПОРТА ГЕТЕРОДИНА СМЕСИТЕЛЯ


Известные применения приложения Преобразователь частоты

Чтобы увидеть текущий список известных применений приложения Преобразователь частоты, зайдите на сайт http://na.tm.agilent.com/fca/ и нажмите ссылку View currently known FCA issues.


Обзор FCA

Приложение Преобразователь частоты (Frequency Converter Application - FCA)

Приложение преобразователь частоты (опция 083) упрощает тестирование устройств преобразования частот:

  • Улучшенные технологии калибровки, поддерживающие исключительную точность амплитуды и фазы.

  • Управление внешними источниками сигналов для использования их в качестве гетеродинов.

  • Графическое диалоговое окно настройки, позволяющее:

    • быстро настраивать PNA на работу с устройствами одиночного или двойного преобразования.

    • вычислять и выбирать место, в которое будут попадать продукты преобразования.

Дополнительные сведения см. в следующих разделах:

  • Использование приложения Преобразователь частоты (FCA)

  • Конфигурирование смесителя

  • Калибровки приложения FCA

  • Конфигурирование внешнего источника гетеродина (LO)

Для получения более подробных сведений о приложении FCA посетите сайт www.Agilent.com и выполните поиск AN 1408-1, AN1408-2, и 1408-3.

Примечание: О найденных применениях приложения FCA, а также с запросами об улучшении, обращайтесь по адресу fca_support@agilent.com
См. Известные применения приложения Преобразователь частоты


  1. В меню PNA нажмите Help.

    • Или, на передней панели, нажмите Menu/Dialog. Затем, в NAVIGATION BLOCK, нажмите несколько раз левую закладку, чтобы перейти к Help. Нажмите Click.

  2. Нажмите About Network Analyzer.

    • Или в NAVIGATION BLOCK на передней панели нажмите несколько раз стрелку вниз, чтобы перейти к About Network Analyzer. Нажмите Click.

Использование приложения Преобразователь частоты (опция 083)

  • Обзор

  • Создание измерения

  • Предлагаемые измерения

  • Настройка скалярного измерения

  • Настройка векторного измерения

  • Параметры настройки измерения в приложении FCA

    • Изменение измерения

    • Ускорение измерений фиксированного выхода SMC

    • Использование номинальной входной мощности

    • Выбор отображения оси X

    • Сохранение данных графика

    • Предотвращение появления паразитных сигналов

Примечание: О найденных применениях приложения FCA, а также с запросами об улучшении, обращайтесь по адресу fca_support@agilent.com (См. Известные применения приложения Преобразователь частоты.)

Если Вы не уверены, оснащен ли Ваш анализатор опцией 083, проверьте это.

Другие разделы по приложению Преобразователь частоты (FCA)

Обзор

Ниже приведена общая инструкция по проведению измерения с помощью приложения FCA:

  1. ВЫБЕРИТЕ тип измерения — скалярный или векторный. Методы калибровки для каждого из них различаются. См. сравнение двух типов измерений.

  2. СОЗДАЙТЕ установленное по умолчанию измерение потерь при преобразовании: Подробнее.

  3. ИЗМЕНИТЕ измерение, если необходимо измерить что-либо отличное от S21. Узнайте о предлагаемых приложением FCA измерениях, а также как ИЗМЕНИТЬ измерение с помощью приложения FCA.

  4. Выполните КАЛИБРОВКУ скалярного или векторного измерения.

Примечание: Нельзя выполнять на одном и том же канале измерение с помощью приложения FCA и измерение, в котором это приложение не используется.

СОЗДАНИЕ измерения с помощью приложения Преобразователь частоты (FCA)

Диалоговое окно выбора приложения измерения (Choose Application Measurement) можно открыть одним из следующих способов:

  • , а затем

ИЛИ

  • +

Затем выберите одно из предлагаемых по умолчанию измерений потерь при преобразовании:

Примечание: Каждое из этих трех измерений должно быть создано на отдельном канале. НЕЛЬЗЯ разделять один и тот же канал между данными измерениями.

Узнайте, как выбрать это посредством интерфейса передней панели

Измерения, предлагаемые приложением FCA

Узнайте, как изменить установленное по умолчанию измерение.

Примечание: Для PNA версии 4.0 доступны измерения ФИКСИРОВАННОГО ВЫХОДА (FIXED OUTPUT) .

Узнайте, как ускорить измерения фиксированного выхода.

Скалярный смеситель /преобразователь (Прямое направление)

  • SC21 Conversion Loss/Gain (default). Потери/ коэффициент передачи при преобразовании SC21 (по умолчанию)

  • S11 на частоте входа

  • S22 на частоте выхода

  • Incident Power Входная мощность. Откалиброванная входная мощность на тестируемом устройстве. Если не калибрована, то абсолютная мощность R1 при входной частоте — стимул на порту 1

  • Output Power Выходная мощность. Откалиброванная выходная мощность от тестируемого устройства. Если не калибрована, то абсолютная мощность приемника B при выходной частоте — стимул на порту 1

Scalar Reverse Direction

  • SC12 Conversion Loss/Gain (default). Потери/ коэффициент передачи при преобразовании SC21 (по умолчанию).

  • S11 на частоте выхода

  • S22 на частоте входа

  • Incident Power Входная мощность. Откалиброванная входная мощность на тестируемом устройстве. Если не калибрована, то абсолютная мощность R2 при входной частоте — стимул на порту 2

  • Output Power Выходная мощность. Откалиброванная выходная мощность от тестируемого устройства. Если не калибрована, то абсолютная мощность приемника А при выходной частоте — стимул на порту 2

Вектор (Только прямое направление, из-за использования опорного смесителя)

  • VC21 Conversion Loss/Gain (default). Потери/ коэффициент передачи при преобразовании VC21 (по умолчанию).

  • S11

  • S22

  • R1 Power Мощность R1. Абсолютная мощность R1 при выходной частоте, идущая через опорный смеситель — стимул на порту 1. Некалибрована.

  • B Power Мощность В. абсолютная мощность приемника B при выходной частоте — стимул на порту 1. Некалибрована.

Понятие о скалярных измерениях смесителя в прямом (FORWARD) и обратном (REVERSE) направлениях

Смесители обычно являются двусторонними устройствами (S21 = S12), поэтому их использование и измерение доступны в обоих направлениях. Во избежание путаницы на следующих диаграммах не используются традиционные обозначения на смесителях РЧ и ПЧ. Они помечены как порты 1 и 2. Порт гетеродина (LO) не имеет отношения к обсуждаемой теме.

В процессе калибровки задаются направления входное (Input), выходное (Output) или двустороннее (Both). Подробнее.

Входное (Input) и выходное (Output) направления соответствуют настройкам частоты в диалоговом окне настройки смесителя.

ПРЯМОЕ | ОБРАТНОЕ

Примечание:

A и R1 — приемники на порту 1
B и R2 — приемники на порту 2

Настройка векторного измерения

1: Внешний источник (фиксированный сигнал гетеродина)

2: Опорный смеситель

Подробнее о калибровке векторного измерения смесителя.

Подключите оборудование GPIB к устройству PNA одним из следующих способов:

  • через интерфейс Agilent 82357A USB/GPIB

  • через интерфейс GPIB. Для этого сначала переведите PNA в режим системного контроллера. Не находясь в данном режиме, PNA не может функционировать как источник или приемник по интерфейсу GPIB.

Настройка скалярного измерения

1: Внешний источник (фиксированный сигнал гетеродина)

Подробнее о калибровке скалярного измерения смесителя

Подключите оборудование GPIB к устройству PNA одним из следующих способов:

  • через интерфейс Agilent 82357A USB/GPIB

  • через интерфейс GPIB. Для этого сначала переведите PNA в режим системного контроллера. Не находясь в данном режиме, PNA не может функционировать как источник или приемник по интерфейсу GPIB.

Параметры настройки измерения в приложении FCA

Большинство параметров настройки измерений в приложении FCA, описанных в оставшейся части данного раздела, устанавливаются посредством нижеописанного выбора в меню. Выбор может незначительно отличаться в зависимости от активного измерения в приложении FCA.

Выбор нескольких параметров настройки измерения в приложении FCA

Сначала следует создать измерение в приложении FCA. Затем:

(Щелкните ссылки, чтобы узнать больше)

Узнайте, как сделать такой выбор с помощью интерфейса передней панели

ИЗМЕНЕНИЕ измерения в приложении Преобразователь частоты

Выберите измерение в приложении FCA. Затем:

  • +

  • или же используйте предыдущий выбор меню Trace

Узнайте о предлагаемых измерениях в приложении FCA.

Ускорение измерений фиксированного выхода

Для измерений фиксированного выхода требуется пошаговое изменение частоты внешнего источника гетеродина. Это может занять значительное время в зависимости от настроек измерения. Следующие функции помогают существенно ускорить измерение фиксированного выхода:

  • Метод запуска внешнего гетеродина через разъем BNC

  • Выбор приложения Cal Set - выберите SMC Rsp (только для SMC)

  • Использование номинальной входной мощности - (только для SMC)

Подробнее о конфигурировании измерений фиксированного выхода.

Использование номинальной входной мощности

Для каждого свипирования данных в ходе полностью скорректированного измерения SC21 фактически требуется ТРИ свипирования данных. Два из трех свипирований не отображаются. При выборе использования номинальной входной мощности (Use Nominal Incident Power) опорный приемник (R1 или R2) не выполняет измерения входной мощности. Вместо этого предполагается, что входная мощность находится на уровне, установленном при калибровке мощности источника, выполненной как часть любого измерения SMC. Уровень снижения точности весьма незначителен.

При таком выборе свипирование устраняется ТОЛЬКО если:

  • выполняется измерение выходной мощности либо

  • применяется калибровка отклика SMC.

Этот выбор применяется ко всем измерениям SMC.

Узнайте, как выбрать использование номинальной входной мощности.

Выбор отображения оси X для измерений FCA

При измерениях FCA обычно имеется более одного свипируемого параметра. Можно выбрать просмотр отклика (выхода) измерения на оси Y при одновременном отображении какого-либо из свипируемых параметров (Input, LO1, LO2, Output) на оси X дисплея PNA.

Например, на следующем рисунке показан отклик при прямом SMC-измерении фиксированного выхода при свипировании на входе (Input).

Выход (Output): 100 МГц (график)

Вход (Input): 2 ГГц — 23 ГГц (ось X)

Гетеродин (LO): 1,9 ГГц — 22,9 ГГц (не показан)

Показания возле маркеров показывают уровень выходной мощности при входной частоте.

Узнайте, как выбрать отображение оси X

Сохранение данных графика

Данные измерений преобразователя частот можно сохранить на диск в формате S2P.

Примечание: Это единственный метод сохранения файлов преобразователя частот .S2P.
НЕ пытайтесь сохранять эти файлы данных S2P с помощью меню File, Save As...

Узнайте, как сохранять данные графика

Справка по диалоговому окну Save Data to File

Позволяет сохранить данные измерений преобразователя частот в файл S2P. Данные сохраняются в формате S2P подобно стандартным данным PNA. Подробнее о файлах .S2P.

Примечание: Это единственный метод сохранения файлов преобразователя частот .S2P.
НЕ пытайтесь сохранять эти файлы данных S2P с помощью меню File, Save As...

S2P Data Format выберите формат данных. Этот выбор не зависит от дисплея PNA.

Save As щелкните, чтобы указать имя и размещение файла, в котором будут сохранены данные.

Exit закрывает диалоговое окно без сохранения данных. Для сохранения данных необходимо щелкнуть кнопку Save As до закрытия окна с помощью кнопки Exit.

Примечания:

Каждая запись содержит 1 значение стимула и 4 параметра (всего 9 значений) в следующем формате:

Stim Real(p1) Imag(p1) Real(p2) Imag(p2) Real(p3) Imag(p3) Real(p4) Imag(p4)

где pX параметр, в зависимости от типа измерения:

Тип измерения | p1 | p2 | p3 | p4
Скалярный | S11 | SC21 (FWD) | SC12 (REV) | S22
Векторный | S11 | VC21 | VC12 | S22
Характеристика смесителя | Направленность (Directivity) | Согласование с источником (Source Match) | Отражение (Reflection Tracking) | M21

  • Если коррекция ОТКЛЮЧЕНА, данные сохраняются только для активного параметра. Для всех других параметров сохраняются нулевые значения.

  • Если коррекция ВКЛЮЧЕНА, данные сохраняются для всех параметров.

Все файлы содержат следующую информацию заголовка; в скобках [ ] содержатся параметры.

!Agilent [Instrument Model Number]: [version]
!Mixer S2P File: [Mixer Measurement Type]
!Parameters: [Parameter List]
!Calibration State: [On/Off]

!# Begin Mixer Setup
![Mixer Setup parameters listed here]
![Mixer Parameter 1]
.
.
![Mixer Parameter n]
!# End Mixer Setup

# [S2P data here]

Предотвращение появления паразитных сигналов

Функция предотвращения паразитных сигналов (Avoid Spurs) приложения Преобразователь частоты предотвращает появление на экране PNA нежелательных сигналов – продуктов работы смесителя. Данная функция не оказывает значительного влияния на скорость измерений.

Примечание: Функция предотвращения паразитных сигналов для калибровок в приложении FCA по умолчанию ОТКЛЮЧЕНА. Для достижения наивысшей точности измерения следует выполнять при том же состоянии функции предотвращения паразитных сигналов (ВКЛ или ВЫКЛ), которое использовалось при калибровке.

См. подробнее о предотвращении паразитных сигналов ИЛИ проверьте предотвращение паразитных сигналов (Avoid Spurs) в диалоговом окне настройки смесителя (Mixer Setup).

Описание

Термин паразитный сигнал (spurious signal) используется для описания нежелательного результата взаимодействия двух сигналов в смесителе. При настройке в диалоговом окне смесителя на желаемый выход (Output) PNA вычисляет частоты потенциальных нежелательных сигналов. С помощью обработки внутренним оборудованием PNA эти сигналы подавляются и не отображаются на дисплее PNA. Таким образом, устраняется необходимость использования внешних фильтров для предотвращения отображения паразитных сигналов на дисплее PNA.

Время, требуемое PNA для вычисления частот нежелательных паразитных сигналов, МОЖЕТ быть заметным в зависимости от числа точек данных в измерении. Однако, после однократного вычисления, время, требуемое PNA для предотвращения паразитных сигналов, обычно незначительно.

Ограничения

Функция предотвращения паразитных сигналов не может предотвратить все из имеющихся паразитных сигналов. Однако при выборе паразитных сигналов для предотвращения будет выбран самый большой паразитный сигнал.

Вычисление предотращаемых паразитных сигналов

Функция может предотвращать следующие паразитные сигналы:

  • Гетеродин (LO) и его взаимодействие с внутренними компонентами PNA, а также 16 его гармоник.

  • Входные частоты и 16 их гармоник.

  • Нежелательные частоты зеркального канала (сумма или разность) и 16 их гармоник.


Варианты выбора калибровки приложения Преобразователь частоты (опция 083)

  1. В меню анализатора PNA щелкните Help.

    • Или же на передней панели нажмите Menu/Dialog. Затем, находясь в блоке NAVIGATION BLOCK, нажмите левую клавишу Tab несколько раз для перемещения к секции Help. Нажмите Click.

  2. Щелкните About Network Analyzer.

    • Или же на передней панели, в блоке NAVIGATION BLOCK, нажмите несколько раз клавишу со стрелкой вниз для перемещения к секции About Network Analyzer. Нажмите Click.

Калибровка приложения Преобразователь частоты (опция 083)

Приложение Преобразователь частоты (Frequency Converter Application, FCA) (опция 083) поддерживает два варианта расширенной калибровки для измерений смесителя или преобразователя, обеспечивающих исключительную точность амплитуды и фазы.

  • Сравнение скалярной и векторной калибровки смесителя

  • Настройка и обзор скалярной калибровки смесителя (SMC)

  • Настройка и обзор векторной калибровки смесителя (VMC)

  • Диаграмма процесса калибровки в приложении FCA

  • Выполнение калибровки с помощью приложения FCA

  • Применение калибровочного набора FCA

Если Вы не уверены, оснащен ли Ваш анализатор опцией 083, узнайте, как его идентифицировать.

Чтобы узнать больше, найдите на узле www.Agilent.com раздел «Измерения передачи смесителя с помощью приложения Преобразователь частоты» ("Mixer Transmission Measurements Using The Frequency Converter Application (AN 1408-1)").

О найденных применениях приложения FCA, а также с запросами об улучшении, обращайтесь по адресу fca_support@agilent.com (См. Известные применения приложения Преобразователь частоты.)

Другие разделы, связанные с приложением Преобразователь частоты (FCA)

Сравнение скалярной и векторной калибровки смесителя

 | Скалярная калибровка смесителя | Векторная калибровка смесителя
Обзор | Обеспечивает наивысшую скалярную (только для амплитуды) точность измерений потерь и коэффициента преобразования. Комбинирует SOLT и калибровку измерителя мощности. Настраивается проще, чем векторная калибровка смесителя. | Обеспечивает непараллельную точность измерений относительной фазы и абсолютной групповой задержки. Использует комбинацию стандартов SOLT и пару «двусторонний смеситель/фильтр» в процессе калибровки. Более сложная процедура настройки и калибровки, чем при скалярной калибровке смесителя. После калибровки упрощается возможность измерений как одно-, так и двусторонних смесителей и преобразователей.
Типы измерений передачи | Тестирование может выполняться как в прямом (SC21), так и в обратном (SC12) направлении. | Амплитудный отклик VC21 Фазовый отклик Групповая задержка
Требуемые опции и оборудование | Опция 014 Опция 080 Опция 083 Набор для механической калибровки или модуль ECal Измеритель мощности и датчик Интерфейс Agilent 82357A USB/GPIB (включен в поставку приложения Преобразователь частоты, опция 083) | Опция 014 Опция 080 Опция 081 Опция 083 Набор для механической калибровки или модуль ECal Комбинация «калибруемый смеситель/фильтр» (должны быть двусторонними S21 = S12.) Комбинация «опорный смеситель/фильтр» Внешний источник Интерфейс Agilent 82357A USB/GPIB (включен в поставку приложения Преобразователь частоты, опция 083)

Примечание: Дополнительные сведения о сравнении двух типов калибровки смесителя можно найти по адресу http://www.tm.agilent.com. Щелкните "Library" и используйте функцию поиска статьи «Сравнение характеризации смесителя с помощью новых технологий векторной характеризации» ("Comparison of Mixer Characterization Using New Vector Characterization Techniques").

Настройка калибровки SMC

Подключите внешний источник и измеритель мощности ко входу PNA GPIB одним из следующих способов:

  • С помощью интерфейса Agilent 82357A USB/GPIB - настоятельно рекомендуется - предоставляет возможность использования удаленного ПК для контроля за PNA.

  • С помощью стандартного интерфейса GPIB — со следующими ограничениями:

    • Удаленное управление анализатором PNA в качестве источника / приемника по интерфейсу GPIB невозможно. Сначала нужно включить PNA в режим системного контроллера. Узнайте, как это сделать.

    • Это доступно только в версиях PNA 4.2 и более поздних.

Узнайте, как конфигурировать внешний источник гетеродина

Обзор скалярной калибровки смесителя.

Мастер калибровки проводит пользователя по всем этапам данного процесса.

  1. Выполните две двухпортовые калибровки: одну по входным частотам (INPUT) и одну по выходным частотам (OUTPUT) тестируемого устройства. (Если тестируется линейное устройство, при калибровке используется только диапазон входных частот.) Используйте либо набор для механической калибровки, либо модуль ECal.

  2. Подключите датчик измерителя мощности к порту 1 анализатора PNA. На каждом шаге входной и выходной частоты PNA измеряет:

    • согласование входа датчика мощности

    • мощность источника PNA

Настройка калибровки VMC

1. Опорный смеситель, сигнал которого преобразуется синхронно с тестируемым устройством. Это значит, что опорный смеситель и смеситель либо преобразователь, подвергаемый тестированию, используют сигналы гетеродина с постоянным соотношением частоты и фазы.

  • Подключите вход (INPUT) опорного смесителя к выходу PNA Ref 1 Source out

  • Подключите выход (OUTPUT) опорного смесителя ко входу PNA Rcvr R1 In

2. Комбинация «калибруемый смеситель/фильтр», соответствующая следующим требованиям:

  • смеситель должен быть двусторонним. Это означает, что у него должен быть один и тот же магнитудный и фазовый отклик как в восходящем, так и в нисходящем направлении преобразования (C21 = C12).

  • Если диапазоны входных и выходных частот перекрываются, уровень развязки между входом и выходом для смесителя должен на более чем 10 дБ превышать уровень потерь преобразования в перекрываемом диапазоне.

  • Фильтр должен подавлять нежелательные продукты смешения на выходе калибруемого смесителя. Например, если при настройке калибруемого смесителя выбран продукт смешения Input + LO, необходимо использовать высокочастотный фильтр для подавления продукта смешения Input - LO при характеризации калибруемого смесителя. Если это практически нереализуемо, дальнейшие подробные указания см. на сайте www.Agilent.com, выполнив поиск раздела "Mixer Transmission Measurements Using The Frequency Converter Application (AN 1408-1)".

3. Делитель мощности

4. Источник(и) гетеродина (LO) Подключите внешние источники ко входу PNA GPIB одним из следующих способов:

  • С помощью интерфейса Agilent 82357A USB/GPIB - настоятельно рекомендуется - предоставляет возможность использования удаленного ПК для управления анализатором PNA.

  • С помощью стандартного интерфейса GPIB — со следующими ограничениями:

    • Удаленное управление анализатором PNA в качестве источника / приемника по интерфейсу GPIB невозможно. Сначала нужно включить PNA в режим системного контроллера. Узнайте, как это сделать.

    • Это доступно только в версиях PNA 4.2 и более поздних.

Узнайте, как конфигурировать внешний источник гетеродина

Обзор векторной калибровки смесителя

Мастер калибровки проводит пользователя по всем этапам данного процесса. На первых трех этапах выполняется характеризация калибруемого смесителя, используемого в качестве стандарта THRU в процессе калибровки.

  1. Выполните две двухпортовые калибровки по входному (INPUT) и выходному (OUTPUT) диапазонам частот тестируемого устройства. Используйте либо набор для механической калибровки, либо модуль ECal.

  2. Выполните характеризацию входного и выходного согласования для комбинации «калибруемый смеситель/фильтр» с подключенным внешним гетеродином и выходом, оканчивающимся на open, short и load.

  3. Подключите комбинацию «опорный смеситель/фильтр» между коннекторами передней панели Source Out и Rcvr R1. Подключите выходной порт комбинации «калибруемый смеситель/фильтр» к порту 2 анализатора PNA (или окончанию кабеля, присоединенного к порту).

  4. Включив PNA в режиме сдвига частоты, выполните измерение комбинации «калибруемый смеситель/фильтр» в качестве стандарта калибровки THRU.

  5. PNA вычислит векторы ошибок, необходимые для выполнения скорректированных фазовых измерений тестируемого смесителя/преобразователя.

Процесс калибровки в приложении FCA

Щелкните соответствующий блок, чтобы узнать о том или ином этапе.

Примечание: В вышеприведенной диаграмме и следующей процедуре кодирование цветом указывает, что данный этап выполняется только для калибровки SMC или VMC. Блоки желтого цвета указывают на этапы, общие для обоих методов калибровки.

Выполнение калибровки с помощью приложения FCA

Калибровка с помощью приложения FCA начинается так же, как и любая калибровка PNA:

  1. Щелкните Calibration, а затем Calibration Wizard.

  2. Затем выберите Mixer Calibrations.

Справка по диалоговому окну Mixer Calibrations

См данный этап в процессе калибровки с помощью приложения FCA

Позволяет выбрать метод калибровки смесителя/преобразователя:

VMC Vector Mixer Cal Выбор векторной калибровки смесителя.

SMC_2P Scalar Mixer Cal Выбор скалярной калибровки смесителя.

Справка по диалоговому окну Calibration Setup

Позволяет просматривать и изменять параметры настройки калибровки в приложении FCA.

  • Для изменения настроек частоты (Frequency) и мощности (Power) щелкните Edit Mixer

  • Для изменения прочих настроек (Other) (полоса ПЧ, точки, аттенюатор) пролистайте или введите новое значение.

Edit Mixer Отображает диалоговое окно Configure Mixer.

ТОЛЬКО ДЛЯ SMC

Калибровка измерений смесителя на текущем канале (результат — скорректированное скалярное измерение смесителя) — Calibrate mixer measurements on current channel (results in a corrected scalar mixer measurement).
Позволяет выполнять скорректированные скалярные измерения тестируемого устройства на текущем канале. После выполнения калибровки набор калибровок сохраняется, а PNA автоматически создает измерение SC21.

Создать набор калибровок с расширенным списком частот для дальнейшего применения (результат — набор калибровок, который можно в дальнейшем применять к измерениям) — Create an expanded frequency list calset to be applied later (results in a calset that can later be applied to measurements).
Позволяет выбрать диапазон частот калибровки шире, чем диапазон частот тестируемого устройства. После выполнения калибровки набор калибровок сохраняется, но PNA НЕ создает измерения автоматически. Для создания измерения необходимо применить набор калибровок к желаемому каналу и выбрать измерение.

Редактирование частот — Edit Frequencies Включается при выборе Create an expanded.... Отображает диалоговое окно Frequencies, в котором можно расширить диапазон частот калибровки за пределы диапазона тестируемого устройства. Узнайте больше об этом.

ТОЛЬКО ДЛЯ VMC

Справка по диалоговому окну Select Calibration Procedure

Позволяет выполнить только характеризацию калибруемого смесителя или полную калибровку системы.

Что такое характеризация калибруемого смесителя?
Краткое описание см. в разделе Калибруемый смеситель (этап 2).
Подробное описание см. на сайте www.Agilent.com — выполните поиск раздела "Mixer Transmission Measurements Using The Frequency Converter Application (AN 1408-1)"

Процедура (Procedure)

Только характеризация калибруемого смесителя (Calibration Mixer Characterization Only) — Выполняет двухпортовую калибровку и характеризацию калибруемого смесителя. Опорный смеситель не требуется. Выберите этот вариант, если Вы хотите сохранить данные о характеризации смесителя в файл для последующей загрузки в качестве части полной системной калибровки.

Полная системная калибровка (Full System Calibration) — Выполняет полную системную калибровку. Требуется опорный смеситель.

Характеризация (Characterization) — Доступна только при выполнении полной системной калибровки

Выполнить характеризацию калибруемого смесителя (Perform calibration mixer characterization) — Выполняет характеризацию калибруемого смесителя. Выберите этот вариант при отсутствии файла с данными о характеризации смесителя.

Загрузить характеризацию из файла (Load characterization from file) — Загружает данные о характеризации калибруемого смесителя из файла. Для поиска файла используется функция Browse.

ТОЛЬКО ДЛЯ VMC

Справка по диалоговому окну Measurement Direction

Данное диалоговое окно отображается ТОЛЬКО в том случае, если настройки в диалоговом окне Mixer Setup указывают, что тестируемое устройство тестируется в качестве повышающего преобразователя (вход < выход). Оно позволяет выполнить характеризацию калибруемого смесителя (Calibration Mixer) в качестве понижающего (вход > выход) или повышающего преобразователя.

Характеризация в качестве повышающего преобразователя (обычное поведение) — Characterize as upconverter (usual behavior) Недостаток характеризации в качестве повышающего преобразователя заключается в том, что на выходе калибруемого смесителя необходимо использовать дорогой высокочастотный фильтр.

Характеризация в качестве понижающего преобразователя — Characterize as downconverter Выполняет характеризацию калибруемого смесителя в качестве понижающего преобразователя, что позволяет использовать более экономичный низкочастотный фильтр.

Расширенная калибровка SMC

Для калибровки SMC не требуется согласование входной и выходной частоты калибровки с текущими вычислениями промежуточной частоты (IF) смесителя.

Например, можно выполнить калибровку SMC при следующих частотах:

  • Входной диапазон частот: 10 МГц — 20 ГГц

  • Выходной диапазон частот: 10 МГц — 20 ГГц.

После выполнения данной калибровки ее можно сохранить и применить к любому измерению SMC со входной и выходной частотой в диапазоне между 10 МГц и 20 ГГц, совместно использующему одну и ту же физическую настройку измерения. Узнайте, как применить калибровку SMC.

Для выполнения расширенной калибровки SMC в диалоговом окне Calibration Setup выберите Create an expanded frequency list calset to be applied later (Создать набор калибровок с расширенным списком частот для последующего применения).

Для достижения высокой точности измерения следует использовать большое число точек данных. Узнайте больше о точности интерполяции.

Справка по диалоговому окну Frequencies

Позволяет редактировать диапазон частот калибровки и расширять его за пределы диапазона частот тестируемого устройства. Узнайте больше...

Режим (Mode) Позволяет выбрать формат для указания информации о частотах в настройке измерения. Информация о частотах может задаваться в форматах начало/остановка (start/stop) или центр/интервал (center/span).

Начало/Центр (Start/Center) Позволяет вводить начальную частоту (для режима начало/остановка) или центральную частоту (для режима центр/интервал).

Остановка/интервал (Stop/Span) Позволяет вводить частоту остановки (для режима начало/остановка) или интервал частот (для режима центр/интервал).

Выход равен входу (Same As Input) Установите этот флажок, чтобы задать выходную частоту отклика, равную входной частоте стимула.

Справка по диалоговому окну Calibration Type

Позволяет задать либо калибровку с помощью модуля Ecal, либо механическую калибровку.

Двухпортовая калибровка (2-port Cal)

Механическая (Mechanical) Задает механическую калибровку.

ECal Задает калибровку с помощью модуля ECal.

Просмотреть выбранную характеризацию (View Selected Characterization) Установите флажок, чтобы вызвать диалоговое окно просмотра выбранной характеризации (View the Selected Characterization) (пользовательской или заводской) для выполнения калибровки с помощью модуля ECAL. Узнайте больше о пользовательской характеризации.

Если диапазон частот активного канала превышает диапазон частот выбранной характеризации, отображается сообщение с предупреждением о требуемых дополнительных стандартах (Caution: Additional Standards Required). Для данной проблемы существуют следующие альтернативные решения:

  • Уменьшить диапазон частот активного канала.

  • Выбрать другую характеризацию, которая покрывает требуемый диапазон частот.

  • Выполнить повторную характеризацию модуля с увеличенным диапазоном частот.

ТОЛЬКО ДЛЯ VMC:

Характеризация смесителя (Mixer Characterization)

Механическая (Mechanical) Задает механическую калибровку.

ECal Задает калибровку с помощью модуля ECal.

Узнайте больше о характеризации смесителя

В случае использования модуля ECal:

В диалоговом окне Advanced Settings выберите настройки, соответствующие калибровке с помощью модуля ECal.

Если выбрана калибровка с удалением адаптера (Adapter Removal), отображается диалоговое окно Select DUT Connectors. Выберите коннекторы для портов 1 и 2.

В диалоговом окне Electronic Calibration Steps следуйте указаниям по использованию модуля ECal.

В случае использования набора для механической калибровки

Справка по диалоговому окну Select DUT Connectors

Позволяет указать тип коннектора для каждого порта тестируемого устройства.

DUT Port 1 Задает тип коннектора для порта 1 тестируемого устройства.

DUT Port 2 Задает тип коннектора для порта 2 тестируемого устройства.

Примечание: Если коннекторы тестируемого устройства являются:

  • Волноводами (Waveguide) Измените импеданс системы, установив его на 1 Ом перед выполнением калибровки. См. Установка импеданса системы.

  • Неперечисленными в списке (Not listed) (штекер или гнездо) Выберите в качестве типа коннектора Type A . Для типа Type A требуется файл набора для калибровки, содержащий электрические свойства стандартов, используемых при калибровке (см. Наборы для калибровки).

  • Неопределенными (Unspecified) (например, при запакованном устройстве) Выберите в качестве типа коннектора Type B . Для типа Type B требуется файл набора для калибровки, содержащий электрические свойства стандартов, используемых при калибровке (см. Наборы для калибровки).

  • Невставляемыми (Non-insertable) При управляемой калибровке автоматически выполняется калибровка с удалением адаптера. Для этого требуется адаптер с такими же коннекторами, что и у тестируемого устройства.

ТОЛЬКО ДЛЯ SMC:

PNA Port 1 Выберите этот порт для калибровки ТОЛЬКО измерений в прямом направлении. Входные частоты связываются с портом тестируемого устройства, подключенным к порту 1 анализатора PNA.

PNA Port 2 Выберите этот порт для калибровки ТОЛЬКО измерений в обратном направлении. Входные частоты связываются с портом тестируемого устройства, подключенным к порту 2 анализатора PNA.

Оба порта (Both) Позволяет выполнить скалярную калибровку как для прямого, так и для обратного направления измерений SMC. Сохраняются два набора для калибровки. При измерении применяется соответствующая калибровка Узнайте больше о прямых и обратных измерениях SMC.

Справка по диалоговому окну Select Cal Kits

Позволяет выбрать набор для калибровки, используемый для каждого из измерительных портов. В списке для каждого порта отображаются наборы, тип коннектора в которых соответствует тестируемому устройству.

PORT 1 Здесь отображаются наборы для калибровки, доступные для порта 1

PORT 2 Здесь отображаются наборы для калибровки, доступные для порта 2

Вставляемый (Insertable) Выберите, если тестируемое устройство является вставляемым.

Удаление адаптера (Adapter Removal) Выберите, если тестируемое устройство является невставляемым и необходимо выполнить калибровку с удалением адаптера.

Unknown Thru Выберите, если тестируемое устройство является невставляемым и необходимо выполнить калибровку Unknown Thru.

Справка по диалоговому окну Measure Calibration Standards

Иллюстрирует подключение стандарта калибровки, указанного в запросе. Иллюстрация различается в зависимости от измеряемого стандарта калибровки. Иллюстрация также различается, если:

  • используется модуль ECal

  • выполняется характеризация калибруемого смесителя или полная системная калибровка

  • настройка измерения включает одиночный или двойной гетеродин (LO)

  • в диалоговом окне Measurement Direction выбрана характеризация в качестве понижающего преобразователя ("Characterize as downconverter"). В этом случае иллюстрация показывает смеситель, настроенный в обратном направлении для измерений отражений. Выход смесителя подключен к измерительному порту 2 анализатора PNA, а стандарт калибровки (или модуль Ecal) подключен ко входу смесителя.

Измерить и далее (Measure & Next) Позволяет измерить механический стандарт и перейти на следующий этап калибровки.

Назад (Back) Позволяет вернуться к предыдущему диалоговому окну.

Далее (Next) Отображается только после нажатия кнопки Back. Позволяет перейти к следующему необходимому этапу БЕЗ выполнения измерения.

Измерить повторно (ReMeasure) Отображается только после нажатия кнопки Back. Позволяет измерить стандарт повторно.

ТОЛЬКО ДЛЯ SMC

Как для механической калибровки, так и в случае использования модуля ECal:

Справка по диалоговому окну Scalar Mixer Calibration Power Cal.

Предлагает выполнить этап калибровки измерителя мощности.

Примечание: При калибровке SMC выполняется 10 усреднений в начале и в конце этапа калибровки мощности для вычисления разности между нормальными измерениями и измерениями сдвига R1 в калибруемой полосе частот. Усреднение выполняется с целью устранения значительного объема шума в процессе измерения коэффициента.

  • Подключите датчик мощности к порту, показанному на диаграмме. Диаграмма различается в зависимости от того, назначен ли порт 1 в качестве выхода ("output"), входа ("input") или обоих направлений ("both") в диалоговом окне Select DUT Connectors.

  • Начнется калибровка измерителя мощности на порту 1, 2 или на обоих портах.

Настройки измерителя мощности (Power Meter Settings) Вызывает диалоговое окно Power Meter Settings. См. список поддерживаемых измерителей мощности.

Примечание: Из диалогового окна Power Meter Settings можно вызвать таблицу компенсации потерь мощности для компенсации, соответствующей используемому адаптеру при подключении датчика измерителя мощности.

Измерить (Measure) Позволяет начать измерения измерителя мощности, а затем перейти к следующему этапу.

Назад (Back) Позволяет вернуться к предыдущему диалоговому окну.

Далее (Next) Позволяет перейти к следующему этапу калибровки БЕЗ выполнения измерения.

ТОЛЬКО ДЛЯ VMC

Справка по диалоговому окну Save Mixer Characterization

Позволяет сохранить данные характеризации калибруемого смесителя.

Обзор (Browse) Позволяет перейти к месту сохранения данных характеризации калибруемого смесителя. Можно использовать либо предлагаемое по умолчанию имя файла, либо ввести другое.

Далее (Next) Позволяет сохранить файл характеризации смесителя и перейти к следующему этапу процедуры полной системной калибровки.

Готово (Finish) Заменяет кнопку Next в случае выполнения только характеризации калибруемого смесителя вместо полной системной калибровки. Позволяет сохранить файл характеризации смесителя и выйти из процедуры характеризации смесителя.

Сохранение калибровки

В случае выполнения полной системной калибровки:

В диалоговом окне Calibration Completed щелкните Нет. Завершить сейчас (No. Finish now), чтобы выйти из мастера калибровки.

Создание и применение набора для калибровки в приложении FCA

В приложении FCA можно создать измерение и применить к нему существующий набор для калибровки, также как и для любого другого измерения с помощью анализатора PNA. Узнайте больше о наборах дли калибровки.

При применении набора для калибровки в приложении FCA удостоверьтесь, что Вы применяете соответствующий тип калибровки (см. таблицу ниже) к измерению в приложении FCA. Следующие два примечания содержат незначительные различия при применении наборов для калибровки SMC. Калибровки VMC выполняются только в прямом направлении.

  • При калибровках SMC сохраняются отдельные наборы для калибровки для прямого и обратного направлений. Набор для калибровки SMC прямого направления нельзя применить к обратному измерению SMC, равно как и наоборот. Узнайте больше о прямых и обратных скалярных измерениях.

  • Отдельный набор для калибровки SMC может содержать следующие типы калибровки SMC, что позволяет оптимизировать измерения фиксированного выхода по скорости против точности. Узнайте о других способах ускорения измерений фиксированного выхода.

Тип калибровки FCA

Измерение FCA

SMC_2P: (Отклик + Вход + Выход) Наиболее точное

SMC Rsp: без согласования входа или выхода — Наиболее быстрое для фиксированного выхода, но не самое точное.

SMC Rsp + In: без согласования выхода — Наилучшая комбинация точности и скорости для фиксированного выхода.

SMC Rsp + Out: без согласования входа

SC21

SC12

S11

S22

Входная мощность (Incident Power)

Выходная мощность (Output Power)

VMC (источник — порт 1)

VC21

S11

S22


Конфигурирование смесителя

  • Как открыть диалоговое окно настройки смесителя (Mixer Setup)

  • Изучение диалогового окна настройки смесителя

  • Правила конфигурирования смесителя

  • Использование свипирования мощности для тестирования смесителей

  • Пример Input > LO

  • Конфигурирование измерений фиксированного выхода

  • Примеры дробного множителя

Примечание: О найденных применениях приложения FCA, а также с запросами об улучшении, обращайтесь по адресу fca_support@agilent.com (Известные применения приложения Преобразователь частоты.)

Другие разделы, связанные с приложением Преобразователь частоты (FCA)

Как открыть диалоговое окно настройки смесителя (Mixer Setup)

Выберите любой из следующих методов:

Создайте измерение в приложении FCA. Затем

ИЛИ

Создайте измерение в приложении FCA. Затем нажмите одну из кнопок:

или [image] или

ИЛИ

Создайте измерение в приложении FCA. Затем

Щелкните Calibration, а затем Calibration Wizard
Щелкните Mixer Calibration
Щелкните Edit Mixer

Узнайте больше об использовании интерфейса передней панели

Диалоговое окно настройки смесителя (Mixer Setup)

Щелкните тот или иной участок изображения, чтобы узнать больше о соответствующем параметре настройки.

Примечание: На данном рисунке показаны два гетеродина (LO).

См. Примеры дробного множителя (ниже)

Справка по диалоговому окну Mixer Setup

Правила использования диалогового окна Mixer Setup

Красный цвет кнопок Apply и OK указывает на недопустимую настройку одного или более параметров.

  1. Входная (INPUT) начальная частота НЕ может превышать частоту остановки. (Выходная (OUTPUT) начальная частота МОЖЕТ превышать частоту остановки.)

  2. Входная (INPUT) и выходная (OUTPUT) не могут выходить за пределы диапазона PNA

  3. Любая комбинация входной частоты (Input) и частоты гетеродина (LO), результатом которой является свипирование выходной частоты (Output) через 0 Гц, недопустима.

  4. Диапазон числителя и знаменателя дробного множителя лежит в пределах от +1 до +10. Отрицательные значения недопустимы.

Примечание: Во всем диалоговом окне порты смесителя / преобразователя кодируются тем или иным цветом (Input, LO1, IF1, LO2, Output)

Мощность (Power) Устанавливает уровень мощности входного сигнала и обоих сигналов гетеродинов.

Формат частоты (Frequency Format) Позволяет выбрать формат указания частоты для каждого сигнала в настройке измерения. Информация о частотах Input, LO1, LO2, IF и Output может задаваться в форматах начало/остановка или центр/интервал.

Только для частот LO1, LO2, IF и Output можно установить фиксированный (Fixed) формат.

При выборе свипирования частоты гетеродина можно также выбрать информацию, отображаемую по оси X.

Вернуться к изображению Mixer Setup

Кнопки конфигурации источника Выполняют ту же функцию, что и кнопки конфигурации на нижней диаграмме. Текущий источник отображается на обозначении кнопки.

Результирующие частоты Устанавливают либо вычисляют значения частот для каждого из сигналов в настройке измерения. Например, если вводится диапазон входных частот (Input) и нажимается кнопка Calculate, расположенная рядом с Input, устройство PNA вычислит и отобразит выходные частоты (Output).

Вернуться к изображению Mixer Setup

Input > LO

Эти флажки используются для устранения неопределенности при использовании кнопки Calculate для определения входной частоты (INPUT).

Установите, если INPUT БОЛЬШЕ LO

Снимите, если INPUT МЕНЬШЕ LO

Установите, если IF1 БОЛЬШЕ LO2

Снимите, если IF1 МЕНЬШЕ LO2

Эти флажки используются только в случаях, когда истинны все три следующих условия:
(Если ВСЕ 3 НЕ истинны, устройство PNA не считывает эти флажки).

  1. Для соответствующей кнопки Calculate выбран нижний переключатель (разностная нижняя боковая полоса) [image] И

  2. Выходная частота (Output) меньше частоты гетеродина (LO) И

  3. Для вычисления входной частоты (Input) используется зеленая или синяя кнопка Calculate.

Чтобы узнать больше, см. пример.

Дробный множитель

Комбинация (числитель / знаменатель) формирует дробное значение, на которое умножаются диапазоны входных частот и частот гетеродина (а также диапазоны частот IF (ПЧ) и LO2 в настройках измерения с двумя гетеродинами). Эти значения используются при вычислении частоты отклика приемника PNA. Дробные множители используются для:

  • моделирования действия смесителей на гармониках

  • моделирования действия множителей и делителей, которые могут присутствовать в настройке измерения

  • настройки частоты приемника PNA на гармонику смесителя/преобразователя

См. Примеры дробного множителя.

Вернуться к изображению Mixer Setup

Выбор продукта смесителя Определяет, будут ли приемники настраиваться на сумму (+) или разность ( - ) входной частоты и частоты гетеродина. Щелкните смежную кнопку Calculate после того, как выбор сделан.

Кнопки Calculate Служат для вычисления информации о частотах на основе настроек смесителя. Настройки порта смесителя рядом с нажимаемой кнопкой Calculate остаются фиксированными. Например, в сценарии с одним гетеродином укажите входную частоту (Input) и частоту гетеродина (LO), выберите знак + (сумма), затем щелкните кнопку Calculate рядом с Input. Значение входной частоты будет зафиксировано, а диапазон выходных частот — вычислен.
Вернуться к изображению Mixer Setup

Показать / Скрыть диаграммы (Hide / Show Diagrams) Позволяет скрыть или отобразить диаграмму настройки измерения. Измеряемый график отображается, когда диаграмма скрыта.

Гетеродины (LOs) Щелкните 1 или 2, чтобы выбрать число внешних источников гетеродинов в настройке измерения. При выборе двух гетеродинов приложение настраивает промежуточные частоты IF1.

Измерения тестируемого устройства с встроенным гетеродином на данный момент не поддерживаются.

Вернуться к изображению Mixer Setup

Предотвращение паразитных сигналов (Avoid Spurs) Отметьте, чтобы задействовать функцию предотвращения паразитных сигналов.

Загрузить (Load) Позволяет загрузить файл предварительно настроенных атрибутов смесителя (.mxr).

Примечание: Примечание: Файл .mxr включает имя источника гетеродина. Однако он НЕ включает конфигурацию источника гетеродина. Поэтому при использовании файла .mxr, созданного на другом PNA, анализатор PNA отобразит ошибку, если не будет найдена конфигурация источника гетеродина (LO) с ТОЧНО таким же именем.

Сохранить (Save) Позволяет сохранить параметры настройки измерения смесителя/преобразователя в файл атрибутов смесителя (.mxr).

Применить (Apply) Применяет параметры для настройки измерения смесителя/преобразователя к измерениям. Диалоговое окно настройки смесителя остается ОТКРЫТЫМ. Если кнопка затенена красным цветом, см. правила.
Вернуться к изображению Mixer Setup

OK Применяет параметры для настройки измерения смесителя/преобразователя к измерению. Диалоговое окно настройки смесителя ЗАКРЫВАЕТСЯ. Если кнопка затенена красным цветом, см. правила.

Отмена (Cancel) Закрывает диалоговое окно настройки смесителя БЕЗ применения параметров настройки.

Диаграмма частот (Frequency Diagram): Позволяет отобразить информацию о частотах сигналов в настройке измерения.

Конфигурирование источника (Configure Source) Отображает диалоговое окно конфигурации внешнего источника (External Source Configuration). Для конфигурирования внешнего источника с помощью данного диалогового окна источник должен быть подключен к PNA с помощью интерфейса Agilent 82357 USB/GPIB, поставляемого с приложением Преобразователь частоты (Frequency Converter Application, FCA) (опция 083).
Вернуться к изображению Mixer Setup

Использование свипирования мощности для тестирования смесителей

Для измерения нелинейности амплитудной характеристики смесителя необходимо свипировать входную мощность на смесителе. Входная и выходная частоты фиксируются, но сдвигаются относительно друг друга. Для установки свипирования мощности (Power Sweep), а также входной и выходной частоты тестируемого смесителя:

  1. В диалоговом окне смесителя установите частоту гетеродина (LO), идентичные входные начальную частоту и частоту остановки, а также идентичные выходные начальную частоту и частоту остановки. Такой выбор создает фиксированные входные и выходные частоты.

  2. В меню PNA щелкните Sweep, затем Sweep Type. Выберите Power Sweep. НЕ изменяйте несущую частоту (CW) в диалоговом окне Power Sweep. Параметры настройки в диалоговом окне смесителя автоматически не обновятся.

Дополнительные сведения см. в разделе Нелинейность характеристики преобразования.

Пример Input > LO

Для следующего однокаскадного смесителя:

  • Выход (Output) = 2 ГГц

  • Гетеродин (LO) = 3 ГГц

  • Выбрана разность (-)

при нажатии Calculate Input будут переданы два значения входной частоты (Input):

Формула для разности:

Вход - Гетеродин = Выход

Подставим значения из данного примера в формулу:

Вход – 3 ГГц = 2 ГГц

При решении уравнения получаем следующее:

Вход = 5 ГГц

ИЛИ

Вход = 1 ГГц

(Хотя 1-3 = - 2 ГГц, анализатор отображает абсолютное значение частоты.)

Флажок установлен — использовать входную частоту (5 ГГц), превышающую частоту гетеродина (3 ГГц)

Флажок снят — использовать входную частоту (1 ГГц), меньшую, чем частота гетеродина (3 ГГц)

Конфигурирование измерений фиксированного выхода

Приложение Преобразователь частоты позволяет выполнять калиброванные измерения фиксированного выхода (Fixed Output) SMC и VMC. Для этого требуется свипирование одного или обоих гетеродинов (внешних источников) синхронно с входом (Input).

Для выполнения измерения фиксированного выхода с одним гетеродином:

  1. Установите для Input значение Start/Stop.

  2. Установите входную начальную частоту и входную частоту остановки.

  3. Установите для Output значение Fixed — при этом для гетеродина будет автоматически установлено значение Start/Stop.

  4. Установите выходную частоту (Output).

  5. Щелкните кнопку Calculate LO

  6. Щелкните кнопку Not controlled для гетеродина (LO), чтобы настроить внешний источник гетеродина. Хотя PNA позволяет оставить гетеродин без управления (Not Controlled), такая конфигурация обычно приводит к потере значимости измерений фиксированного выхода.

Примечания:

  • В VMC-измерениях фиксированного выхода фазовый ответ представляет собой сдвиг в виде функции смесителя калибровки (Calibration Mixer). При использовании другого смесителя калибровки будет получен другой фазовый сдвиг, хотя относительные фазовые ответы (неравномерность, отклонение от линейной фазы) останутся калиброванными.

  • НЕ используйте формат групповой задержки (Group Delay) в VMC-измерениях фиксированного выхода, так как фазовый ответ содержит только одну точку для каждой частоты гетеродина. Поэтому результат вычисления групповой задержки будет недопустимым.

  • Так как измерение фиксированного выхода управляет внешним источником, оно может показаться довольно медленным. Узнайте, как ускорить измерение фиксированного выхода.

Примеры дробного множителя

Пример 1

Дробный множитель LO используется для моделирования действия смесителя на третьей гармонике, что позволяет PNA точно вычислить частоту приемника. Входная частота и частота гетеродина (LO) известны.

Введите следующие параметры в диалоговом окне Mixer Setup:

  • Входная начальная частота (Input Start Freq): 30 ГГц

  • Входная частота остановки (Input Stop Freq): 40 ГГц

  • Фиксированная частота гетеродина (LO Fixed Freq): 16 ГГц

  • Выбор результата смесителя (Mixer-Product Selector): - (разность)

  • Гетеродины (LOs): 1

  • Дробный множитель гетеродина (LO fractional multiplier): 3/1

  • Дробный множитель входа (INPUT fractional multiplier): 1/1

Щелкните Calculate Output

Результаты:

  • Выходная начальная частота (Output Start Freq): 18 ГГц

  • Выходная частота остановки (Output Stop Freq): 8 ГГц

Пример 2

Дробные множители используются для настройки частоты приемника PNA на вторую гармонику основного сигнала 14 ГГц на выходе смесителя. Входная частота, частота гетеродина (LO) и выходная частота известны.

Введите следующие параметры в диалоговом окне Mixer Setup:

  • Входная начальная частота (Input Start Freq): 4 ГГц

  • Входная частота остановки (Input Stop Freq): 4 ГГц

  • Фиксированная частота гетеродина (LO Fixed Freq): 10 ГГц

  • Выбор результата смесителя (Mixer-Product Selector): + (сумма) входного сигнала и сигнала гетеродина

  • Гетеродины (LOs): 1

  • Дробный множитель входа (INPUT fractional multiplier) = 2/1

  • Дробный множитель гетеродина (LO fractional multiplier) = 2/1

Щелкните Calculate Output

Результаты:

  • Выходная начальная частота (Output Start Freq): 28 ГГц

  • Выходная частота остановки (Output Stop Freq): 28 ГГц

Пример 3

Дробный множитель гетеродина используется для моделирования действия механизма деления на два внутри смесителя. После этого PNA может точно вычислить частоту приемника. Входная частота и частота гетеродина (LO) известны.

Введите следующие параметры в диалоговом окне Mixer Setup:

  • Входная начальная частота (Input Start Freq): 45 МГц

  • Входная частота остановки (Input Stop Freq): 50 МГц

  • Фиксированная частота гетеродина (LO Fixed Freq): 670 МГц

  • Выбор результата смесителя (Mixer-Product Selector): + (сумма) входного сигнала и сигнала гетеродина

  • Гетеродины (LOs): 1

  • Дробный множитель входа (INPUT fractional multiplier) = 1/1

  • Дробный множитель гетеродина (LO fractional multiplier) = 1/2

Щелкните Calculate Output

Результаты:

  • Выходная начальная частота (Output Start Freq): 380 МГц

  • Выходная частота остановки (Output Stop Freq): 385 МГц


Конфигурирование внешнего источника гетеродина

Источник гетеродина (LO) можно настроить на выполнение либо СКАЛЯРНЫХ, либо ВЕКТОРНЫХ измерений с помощью приложения Преобразователь частоты (опция 083).

Как настроить внешний источник гетеродина

  1. Создайте измерение в приложении FCA.

  2. Затем выполните одно из следующих действий:

  • +

  • либо щелкните LO Control в диалоговом окне Configure Mixer.

Узнайте больше об использовании интерфейса передней панели

Примечание: В случае появления ошибки External Source Not Found (Внешний источник не обнаружен) работа библиотеки ввода-вывода Agilent может быть остановлена. Проверить это можно путем поиска значка I0 на панели задач Wndows в PNA. Если он отсутствует, перезапустите библиотеку ввода-вывода. Щелкните Пуск (Start), Программы (Programs), Agilent I/O Libraries, IO Control.

Справка по диалоговому окну External Source Configuration

Данное диалоговое окно используется ТАКЖЕ для конфигурирования внешних источников для измерительных головок миллиметровых волн (Millimeter Wave Test Heads). Узнайте больше об этом.

В настоящий момент не существует программных команд PNA для конфигурирования внешнего источника.

Внешние источники подключаются к интерфейсу PNA GPIB одним из следующих способов:

  • С помощью интерфейса Agilent 82357A USB/GPIB - настоятельно рекомендуется - предоставляет возможность использования удаленного ПК для управления PNA.

  • С помощью стандартного интерфейса GPIB — со следующими ограничениями:

    • Удаленное управление анализатором PNA в качестве источника / приемника по интерфейсу GPIB невозможен. Сначала нужно включить PNA в режиме системного контроллера. Узнайте, как это сделать.

    • Это доступно только в версиях PNA 4.2 и более поздних.

Конфигурация внешнего источника

Без управления (вручную) — Not Controlled (manual) PNA НЕ управляет внешним источником. При выборе данного варианта все другие настройки диалогового окна НЕ применяются.

Управляемый (Controlled) PNA управляет внешними источниками с помощью интерфейса GPIB.

Источник запуска (Trigger Source) Используется ТОЛЬКО при пошаговых изменениях на внешнем источнике (измерения фиксированного выхода с помощью приложения FCA).

Примечание: Параметр настройки PNA Trigger Source НЕ должен быть установлен в значение EXTERNAL для любого из следующих вариантов выбора.

См. примеры измерения фиксированного выхода SMC — SCPI и COM.

Software CW (GPIB) Наиболее медленный метод. Внешний источник принимает несущую частоту (CW) от PNA по интерфейсу GPIB. Это единственный доступный вариант выбора для сторонних (не перечисленных в списке) источников, а также источников Agilent 837X.

Software List (GPIB) Внешний источник принимает список несущих частот (CW) от PNA, затем принимает только необходимые сигналы запуска по интерфейсу GPIB. Используется ТОЛЬКО для источников Agilent 836X.

Hardware List (BNC) Наиболее быстрый метод. Внешний источник принимает список несущих частот (CW) от PNA, затем принимает необходимые сигналы запуска с BNC-коннекторов Trigger на задней панели PNA.

Примечание: Метод Hardware List ВСЕГДА используется для двух внешних источников, управляя измерительными головками миллиметровых волн.

PNA НЕ отвечает на ручные запуски в режиме Hardware List (BNC). Источник запуска PNA должен быть включен как внутренний (INTERNAL). Затем используйте параметры запуска канала "Group" (группа) или "Single" (одиночный), чтобы указать, как измерение FCA должно реагировать на внутренние запуски.

Источники должны быть подключены следующим образом:

1 внешний источник | 2 внешних источника

Примечание: PNA проверяет связь с источниками во время первого измерительного свипирования. В случае ошибки анализатор включает канал в режим удержания запуска (Hold trigger). Необходимо устранить проблему, а затем включить канал на непрерывное либо одиночное свипирование запуска для перезапуска измерения.

Дополнительные сведения см.:

  • Ускорение измерений фиксированного выхода SMC

  • Модель запуска PNA

Управляемый источник (Controlled Source)

Добавить (Add) Отображает диалоговое окно Add New Source.

Удалить (Remove) Удаляет внешний источник из настройки.

Тип источника (Source Type) Отображает номер модели внешнего источника, выбранного в отображаемом списке.

Редактирование команд (Edit Commands) Доступно только для сторонних (не-Agilent) источников. Вызывает диалоговое окно Edit Commands.

Адрес GPIB (GPIB Address) Позволяет установить адрес GPIB для выбранного внешнего источника.

Время ожидания (с) — Timeout (sec) Позволяет установить временное ограничение на установление связи источника с PNA. При превышении этого временного ограничения PNA прекращает процедуру измерения и отображает сообщение об ошибке диагностического типа. В таком случае следует проверить соединения PNA и источника.

Файл калибровки (Cal File): Отображает файл калибровки, используемый для выбранного внешнего источника. После настройки источника необходимо выполнить калибровку, чтобы увидеть файл. Включение параметра Slope Offset вводит калибровку в действие.

Калибровка мощности гетеродина (LO Power Calibration) Отображает диалоговое окно LO Power Calibration. Выводится сообщение-предупреждение о том, что проведенные изменения будут сохранены.

Отмена (Cancel) Позволяет закрыть диалоговое окно без сохранения изменений (если не была нажата кнопка LO Power Calibration).

Справка по диалоговому окну Add New Source

Позволяет добавить внешний источник. Новый источник отображается в списке источников диалогового окна External Source Configuration.

Имя источника (Source Name) Позволяет ввести имя для источника.

Тип источника (Source Type) Позволяет выбрать тип источника из выпадающего списка.

Для использования стандартного (Generic) внешнего источника, не включенного в список, выберите AGGeneric. При этом будет вызвано следующее диалоговое окно Generic Source Commands.

Справка по диалоговому окну Generic Source Commands

Позволяет загрузить следующие команды SCPI, позволяющие управлять функциями стандартного не включенного в список источника.

Operation Complete (*OPC) — Операция завершена.

Preset Предварительная настройка источника

Set CW Frequency Установка значения для несущей частоты (CW) в диалоговом окне Mixer Setup

Set CW Sweep Mode Установка режима свипирования источника

Set Power Установка значения для мощности источника в диалоговом окне Mixer Setup

Set Power State Включение/выключение мощности (ON или OFF)

Справка по диалоговому окну LO Calibration

Позволяет выбрать, загрузить и сохранить настройки калибровки для внешнего источника. Также можно выполнить калибровку гетеродина, настроить наклон/сдвиг (slope/offset), а также настроить измеритель мощности.

Примечание: Свипирование при калибровке гетеродина (LO) вместе с ограничительными линиями «допуска», показаны ниже диалогового окна. Щелкните правой кнопкой на экране для доступа к настройкам экрана.

Настройки калибровки (Calibration Settings)

Начальная частота (Start Frequency) Позволяет установить начальную частоту для калибровки гетеродина.

Частота остановки (Stop Frequency) Позволяет установить частоту остановки для калибровки гетеродина.

Число точек (Number of Points) Позволяет установить число точек данных, измеряемых измерителем мощности в диапазоне частот калибровки гетеродина.

Уровень мощности (Power Level) Позволяет установить уровень мощности для калибровки гетеродина.

Допуск (Tolerance) Позволяет установить максимально разрешаемое отклонение от указанного уровня мощности.

Максимальное число считываний (Max Number of Readings) Позволяет установить максимальное число итеративных процедур, которые PNA выполнит для применения настройки мощности.

Наклон/Сдвиг (Slope/Offset)

Сдвиг (Offset) Позволяет установить величину сдвига мощности, применяемую к каждой точке измерения диапазона частот калибровки гетеродина. Этот сдвиг берется из установок функции компенсация мощности по частоте (Slope feature).

Сдвиг при постоянном токе (Offset at DC) Позволяет установить величину сдвига мощности, прилагаемую к постоянному току.

Наклон (Slope) Позволяет установить наклон мощности (дБ)/ГГц. Предназначен для компенсации потерь от кабеля и тестового оборудования с помощью увеличения выходной мощности внешнего гетеродина с ростом частоты.

Использовать данные калибровки (Use Calibration Data) Установите флажок для использования данных калибровки с целью коррекции внешнего источника. Данные калибровки могут находиться в загруженном файле калибровки источника (.lcf), или могут быть получены в результате новой калибровки гетеродина.

Использовать наклон/сдвиг (Use Slope/Offset) Установите флажок для применения настроек наклона/сдвига к внешнему источнику. Использование настроек наклона/сдвига является более быстрым, но менее эффективным способом улучшения точности гетеродина, чем выполнение его калибровки. Данные настройки могут применяться в дополнение к калибровке гетеродина. Например, если в цепь гетеродина добавляется адаптер, можно использовать настройки наклона/сдвига для компенсации эффектов от адаптера, вместо того чтобы повторять калибровку гетеродина.

Конфигурация измерителя мощности (Power Meter Config) Отображает диалоговое окно Power Meter Settings.

Прервать свипирование (Abort Sweep) Позволяет немедленно остановить измерение калибровки.

Свипирование калибровки (Take Cal Sweep) Запускает измерение калибровки после запроса на подключение измерителя мощности к внешнему источнику непосредственно к порту гетеродина тестируемого устройства.

Загрузить (Load) Позволяет загрузить файл калибровки источника (.lcf) по выбору пользователя.

Сохранить (Save) Позволяет сохранить данные калибровки гетеродина в файле калибровки источника (.lcf).

Настройки измерителя мощности См. Калибровка мощности источника

Датчики См. Калибровка мощности источника


Цепь внешней регулировки уровня

Цепь внешней регулировки уровня, использующая предусилитель постоянного тока

Примечание: Эта цепь не будет работать с моделями E836x; у них на задней панели нет входа внешней регулировки уровня (External Leveling).

Приведенный ниже рисунок - это схема цепи внешней регулировки уровня (предоставляемой пользователем), использующей предусилитель постоянного тока. Использование предусилителя рекомендуется, если входной уровень мощности на диоде детектора ниже -20 dBm.

  • Цепь внешней регулировки уровня в основном состоит из:

    • Детекторного диода

    • Операционного усилителя

  • Измеренное диодом изменение мощности обнаруживается цепью операционного усилителя. Эта цепь регулирует напряжение на входе внешнего детектора (External Detector Input) анализатора, устанавливая мощность источника усилителя так чтобы в реальном времени достичь линейности характеристик тестируемого устройства.

  • Для того чтобы внешняя регулировка работало правильно, напряжение на входе внешнего детектора анализатора должно быть в диапазоне между -0.002 мВ пост. тока и -6 В пост. тока, в зависимости от частоты и уровня мощности.

  • Слишком большие изменения мощности опорного сигнала могут привести к тому, что функция внешней регулировки уровня станет неэффективной в связи с ограниченным диапзоном управления мощностью источника анализатора.


  1. В меню PNA нажмите Help.

    • Или, на передней панели, нажмите Menu/Dialog. Затем в NAVIGATION BLOCK, нажмите несколько раз левую закладку, чтобы перейти к Help. Нажмите Click.

  2. Нажмите About Network Analyzer.

    • Или в группе кнопок на передней панели NAVIGATION BLOCK, нажмите стрелку вниз несколько раз чтобы перейти к About Network Analyzer. Нажмите Click.

Измерения усилителей мощности с использованием PNA

Усилители мощности имеют одну или обе приведенные ниже отличительные черты:

  • Им требуется большая входная мощность, чем может обеспечить стандартный анализатор.

  • Они выдают большую выходную мощность, чем может измерить стандартный анализатор.

Для того чтобы изучить, как произвести измерения для усилителей мощности выберите нужное решение:

Задача | Решение
Какие конфигурации измерительного пульта (Configurable test set) есть у моего PNA? | Конфигурации измерительного пульта PNA
Мощность на входе тестируемого устройства слишком низкая | Выходные усилители в настройке измерения
Только для E835xA, E880xA, и N338xA: Частотная характеристика выходного усилителя не плоская | Внешнее выравнивание для выходных усилителей
При использовании выходного усилителя теряется фазовая автоподстройка | Отключение автоматической калибровки по частоте
Какая калибровка измерений используется? | Выбор калибровки измерений
Какие калибровочные уровни мощности используются? | Рекомендации по уровню мощности для калибровки
Мощность на выходе тестируемого устройства слишком большая | Компоненты, уменьшающие мощность на выходе тестируемого устройства
Выдержат ли калибровочные стандарты большую мощность? | Калибровочные стандарты, выдерживающие большую мощность
Температурные отклонения в настройках измерения | Требования по температуре к тестируемым устройствам и нагрузкам
У тестируемого устройства есть петля автоматической регулировки усиления (AGC) | Рекомендации по свипированию стимула для тестируемого устройства с цепью АРУ
Какие процедуры используются для измерения усилителей мощности? | Процедуры для измерения усилителей мощности

Примечание: Многие из внешних компонентов, приведенных в конфигурациях настройки измерений в данном руководстве имеются в наличии у Agilent Technologies. Например, Agilent продает ответвители, разветвители мощности и аттенюаторы. Обращайтесь на http://www.agilent.com/find/accessories и используйте функцию поиска для того чтобы найти информацию о компонентах которые вы возможно хотите приобрести. Также Вы можете получить техническую поддержку Agilent по телефону или факсу.

Конфигурации измерительного пульта PNA

Здесь показано как идентифицировать Ваш PNA.

Схемы конфигурации измерительных комплектов PNA:

PNA без конфигурируемого измерительного пульта | PNA с конфигурируемым измерительным пультом
E835xA | E835xA, опция 015
E880xA | E880xA, опция 014
N338xA | N338xA, опция 014
E836xA/B | E836xA/B, опция 014
N5230A | N5230A, опция 225, или 425, или 525
 | N5250A

Выходные усилители в настройке измерения

Если для более точного измерения, тестируемому устройству требуется входная мощность, большая чем может быть обеспечена анализатором, то в тестовой схеме необходимо предусмотреть выходной усилитель. (Смотрите диапазон мощностей Вашего анализатора в технических спецификациях.) Однако использование выходного усилителя может ограничить виды измерений и калибровок, которые можно выполнить. Также, Ваш выходной усилитель может не обеспечить для тестируемого устройства постоянный уровень мощности в интересующем диапазоне частот. Если для выходного усилителя требуется обеспечить выравнивающую обратную связь, смотрите Внешнее выравнивание для выходного усилителя, доступное только для моделей E835xA, E880xA, и N338xA.

Схемы конфигурации для цепей с использованием выходного усилителя:

Конфигурация | PNA без конфигурируемого измерительного пульта1 | PNA с конфигурируемым измерительным пультом
Один выходной усилитель | E835xA 2 E880xA 2 N338xA 2 E836xA/B 2 N5230A | E835xA, опция 015 3 E880xA, опция 014 3 N338xA, опция 014 3 E836xA/B, опция 014 3 N5230, опция 225, или 425, или 525 N5250A
Один выходной усилитель и один обратный ответвитель | E835xA 3 |
Два выходных усилителя | E835xA 4 | E835xA, опция 015 E880xA, опция 014 N338xA, опция 014 5 E836xA/B, опция 014 N5230A, опция 225, или 425, или 525 N5250A

1 Вы можете выбрать из других конфигураций выходных усилителей, приобретя обновление конфигурируемого измерительного пульта. Для анализаторов E835xA заказывайте опцию 015. Для всех других анализаторов заказывайте опцию 014. См. Опции PNA.

Ограничения (сноски 2 - 5):

2 · Разрешена только калибровка частотной неравномерности по перемычке для измерения прямой передачи с усилением (S21).

· Разрешены только 1-портовая калибровка отражения или калибровка частотной неравномерности (собственного нуля) при нагрузке ХХ или КЗ для измерения обратного отражения без усиления (S22).

· Обратные измерения с усилением мощности невозможны, если не перемещен выходной усилитель.

· Измерения отражения на порту 1 или измерения обратной передачи невозможны. Сигнал блокируется выходным усилителем.

3 Обратные измерения с усилением мощности невозможны, если не перемещен выходной усилитель.

4 Нет.

5 Только для N338xA, опция 014: Обратные измерения с усилением мощности невозможны на порту 3. Это объясняется тем, что у порта 3 нет каналов источник Source Out и ответвитель Coupler Thru.

Отключение автоматической калибровки по частоте при использовании выходных усилителей.

Если используется выходной усилитель или же когда для обеспечения поступления сигнала на внутренний опорный приемник удаляется кабель-перемычка на передней панели, Вы можете увидеть индикатор потери фазовой синхронизации. Такое может произойти если в схеме измерения используется узкополосный фильтр или ответвитель.

Если появляется указание о потере фазовой синхронизации, PNA автоматически перекалибрует перестроечную кривую внутреннего источника. Для того чтобы предотвратить перекалибровку PNA, отключайте автоматическую калибровку по частоте до тех пор, пока PNA все еще правильно производит фазовую автоподстройку.

Для того чтобы сделать это нажмите System, затем укажите Configure, а затем щелкните SICL/GPIB. По запросу наберите DIAG:AUTOCAL OFF.

PNA все еще может потерять фазовую синхронизацию вне полосы пропускания ответвителя или фильтра, но PNA не будет пытаться перекалибровать себя.

Примечание: Для получения лучших характеристик, мощность опорного приемника должна быть на 22 дБ (+/-5 дБ) ниже мощности на измерительном порту.

Внешнее выравнивание для выходных усилителей

Примечание: внешнее выравнивание невозможно для E8361A, E8362A/B, E8363A/B, E8364A/B, N5230, N5250.

Если полученная с усилением характеристика тестируемого устройства не настолько ровная как ожидалось, то это может быть объяснено характеристиками внешнего выходного усилителя. Если у выходной мощности есть неравномерность в интересующей нас полосе частот, то тестируемое устройство усилит эту неравномерность. Для компенсации неравномерности внешнего выходного усилителя Вы можете добавить в схему измерения свою собственную внешнюю выравнивающую цепь.

Как определить, нужно ли использовать внешнее выравнивание для выходного усилителя?

Используйте анализатор, для того чтобы измерить амплитуду неравномерности выходного усилителя. Если значение амплитуды неравномерности неприемлемо для требуемой точности измерений, то используйте внешнее выравнивание.

Примечание: Прежде чем измерять амплитуду неравномерности выходного усилителя убедитесь в том, что была проведена калибровка. Калибровка предотвратит шум (если он присутствует) от изменения вида измерений при каждом свипировании анализатора.

Как показано ниже на рисунке, выходной усилитель без внешнего выравнивания может иметь неравномерность, которая приведет к неравномерности характеристики тестируемого устройства.

Некоторые причины неравномерности выходного усилителя:

  • Низкое качество выходного усилителя (плохое согласование или неравномерность)

  • Шумы в напряжении источника питания выходного усилителя

  • Насыщение выходного усилителя

Какую конфигурацию использовать для внешнего выравнивания?

Примечание: внешнее выравнивание невозможно для E8361A, E8362A/B, E8363A/B, E8364A/B.

Схемы конфигурации для использования цепей внешнего выравнивания:

Конфигурация внешнего выравнивания | Стандартные анализаторы | Анализаторы с опциями 014 и 015
Один выходной усилитель | E835xA E880xA N338xA | E835xA, опция 015 E880xA, опция 014 N338xA, опция 014
Один выходной усилитель и один обратный ответвитель | E835xA |
Два выходных усилителя и два обратных ответвителя | E835xA |
Два выходных усилителя |  | E835xA, опция 015 E880xA, опция 014 N338xA, опция 014

Уровни мощности для внешнего выравнивания

Для надлежащей работы фазовой автоподстройки и ALC (автоматической регулировки уровня) мощность измерительного порта анализатора должна поддерживаться в диапазоне между +10 dBm и -15 dBm . Если на выходе постоянного тока детекторного диода не используется внешний предусилитель постоянного тока, то мощность, приложенная ко входу детекторного диода, должна поддерживаться в диапазоне между +10 dBm и -20 dBm. Этот диапазон мощностей детекторного диода необходим для достижения достаточной мощности постоянного тока для надлежащей работы АРУ. Должен применяться детекторный диод с отрицательным выходом, такой как в Agilent 3330C (информацию об этом детекторном диоде можно найти на http://www.agilent.com/find/accessories.) Выход постоянного тока детектора подсоединен напрямую (с помощью коаксиального кабеля) к разъему на задней панели анализатора "Вход внешнего детектора" "Ext Detector Input."

Дополнительная информация о схемах внешнего выравнивания:

  • Напряжение на выходе детекторного диода, прикладываемое к входу внешнего детектора анализатора, подстраивает мощность источника так чтобы в реальном времени достичь ровной частотной характеристики тестируемого устройства.

  • Для правильной работы внешнего выравнивания, напряжение на входе внешнего детектора должно быть в диапазоне между -0.002 мВ пост. тока и -6 В пост. тока, в зависимости от частоты и уровня мощности.

  • Слишком большое изменение мощности опорного сигнала может привести к тому, что функция внешнего выравнивания станет неэффективной, из-за ограниченного диапазона управления мощностью источника анализатора.

Смотрите схемы внешнего выравнивания, которые используют предусилитель постоянного тока (рекомендуются, если входной уровень мощности детекторного диода ниже -20 dBm).

Примечание: При выполнении калибровки поддерживайте активность процесса выравнивания мощности источника такой, какой она будет во время измерений.

Какие строки меню анализатора выбирать для внешнего выравнивания?

Примечание: внешнее выравнивание невозможно для E8361A, E8362A/B, E8363A/B, E8364A/B.

E835xA:

  1. Выберите меню Sweep.

  2. Выберите Sweep Setup. Установите флажок External ALC.

  3. Выберите меню Channel.

  4. Выберите Power. В разделе Attenuator Control диалогового окна снимите флажок из окошка Auto.

Только для E880xA и N338xA:

  1. Выберите меню Sweep.

  2. Выберите Sweep Setup. Установите флажок External ALC.

Больше информации об использовании внешнего выравнивания можно найти на http://www.tm.agilent.com. Нажмите "Library" и используйте функцию поиска для поиска "ALC." (автоматической регулировки уровня)

Выбор калибровки измерений

Примечание: Калибровку необходимо выполнять, когда все аппаратные средства установлены на месте. Например, включите все выходные усилители, кабели, аттенюаторы или ответвители, которые будут использоваться при измерениях тестируемого устройства. Подробнее о калибровке см. Выбор калибровки измерений.

ВНИМАНИЕ: Используя калибровки КЗ и ХХ, убедитесь в том, что уровень входящей мощности достаточно низок, так чтобы отраженный сигнал не превысил допустимый максимум на входе приемника анализатора.

Выбор калибровки определяется используемой конфигурацией измерения.

Ниже приведены схемы конфигураций и выбор калибровок для измерений больших мощностей:

Направление измерения | PNA без конфигурируемого измерительного пульта | PNA с конфигурируемым измерительным пультом | Выбор калибровки
Прямое | E835xA | E835xA, опция 015 E880xA, опция 014 N338xA, опция 014 E836xA/B, опция 014 N5230A, опция 225, или 425, или 525 N5250A | 2-портовая калибровка1 1-портовая калибровка2
Прямое (только однопортовая калибровка) | E835xA E880xA N338xA E836xA/B N5230A |  | Калибровка частотной неравномерности по перемычке3 1-портовое отражение4 Калибровка частотной неравномерности по нагрузке ХХ/КЗ4
Прямое и обратное | E835xA | E835xA, опция 015 E880xA, опция 014 N338xA, опция 014 E836xA/B, опция 014 N5230A, опция 225, или 425, или 525 N5250A | 2-портовая калибровка5 1-портовая калибровка6
Прямое и обратное (измерения без усиления) | E835xA E880xA N338xA E836xA/B N5230A |  | 2-портовая калибровка7 1-портовая калибровка8

1 (TRL или SOLT) Для измерений прямых передачи и отражения большой мощности. Также для измерений обратных передачи и отражения без усиления.

2 (Калибровка частотной неравномерности по перемычке, 1-портовое отражение, или калибровка частотной неравномерности по нагрузке ХХ/КЗ) Для измерений прямых передачи или отражения большой мощности. Или, для измерений обратных передачи и отражения без усиления.

3 Для измерений прямой передачи большой мощности.

4 Для измерений обратного отражения без усиления.

5 (TRL или SOLT) Для измерений прямых и обратных передачи и отражения большой мощности.

6 (Калибровка частотной неравномерности по перемычке, 1-портовое отражение, или калибровка частотной неравномерности по нагрузке ХХ/КЗ) Для измерений прямых или обратных передачи или отражения большой мощности.

7 (TRL или SOLT) Для измерений прямых и обратных передачи и отражения без усиления.

8 (Калибровка частотной неравномерности по перемычке, 1-портовое отражение, или калибровка частотной неравномерности по нагрузке ХХ/КЗ) Для измерений прямых или обратных передачи или отражения без усиления.

Рекомендации по уровню мощности для калибровки

Для наилучшей точности измерений производите калибровку при наивысшем возможном значении мощности до начала ослабления приемником. Этот уровень мощности зависит от частоты измеряемого отклика. (Информацию о максимальной входной мощности приемника смотрите в технических характеристиках анализатора.)

Только для анализаторов с перемычками на передней панели: Уровень мощности приемника может быть измерен с помощью измерителя мощности, где внешние цепи подключаются к:

  • каналу Rcvr A In или (для E835xA) каналу A In

  • каналу Rcvr A In или (для E835xA) каналу B In

При калибровке (когда тестируемое устройство удалено) установите такую мощность чтобы получить на приемнике уровень мощности который гарантировано минимизирует сжатие (нелинейные искажения) приемником. При измерении (когда тестируемое устройство установлено) установите мощность необходимую для поддержания безопасного уровня мощности на приемнике.

Компоненты, уменьшающие мощность на выходе тестируемого устройства

Максимальная входная мощность приемника анализатора не должна превышаться. (Информацию о максимальной входной мощности приемника смотрите в технических характеристиках анализатора). Если тестируемое устройство имеет высокий уровень выходной мощности, то она должна быть снижена до уровня при котором он может быть безопасно обработан приемником анализатора. Как показано на следующем рисунке, при тестировании усилителя базовой станции CDMA для снижения выходной мощности усилителя устанавливаются некоторые или все приведенные ниже компоненты:

  • На выходе усилителя может быть установлен внешний ответвитель большой мощности. К плечу направленной связи ответвителя подключается специальная нагрузка, которая может рассеивать большую мощность.

  • К входному порту анализатора может быть подсоединен внешний аттенюатор большой мощности.

Пункт | Описание | Пункт | Описание
a | ПОРТ 1 | e | Направленный ответвитель, поставляется пользователем
b | ПОРТ 2 | f | Нагрузка, поставляется пользователем
c | Усилитель базовой станции CDMA, поставляется пользователем |  |
d | Регулируемый аттенюатор (опциональный), поставляется пользователем. (Если Ваш PNA E835x оборудован опцией 015, или любой другой PNA оборудован опцией 016, то они имеют аттенюатор приемника и им не требуется внешнее ослабление мощности. См. Опции анализатора). |  |

Для того чтобы защитить приемник от слишком большой входной мощности, выполните следующие шаги для определения значений ослабления внешнего аттенюатора (или внутреннего аттенюатора приемника, если установлены опции 015 или 016), ответвителя или нагрузки (или обоих).

    1. Определите максимальную мощность на выходе усилителя [Пример: 40 dBm).

    2. Вычтите 15 дБ (значение коэффициента связи направленного ответвителя внутри анализатора) [Пример: 40 dBm - 15dBm = 25 dBm).

    3. Отнимите уровень мощности требуемый на приемнике [Пример: 25 dBm - (-10 dBm)].

    4. Результат - это соответствующее значение для внешнего аттенюатора (или внутреннего аттенюатора приемника, если установлены опции 015 или 016), ответвителя и нагрузки или обоих [Пример: 35 дБ].

Примечание: проверьте по спецификации могут ли ответвитель, нагрузка и аттенюатор выдержать соответствующую мощность.

Больше информации о тестировании усилителей CDMA ищите на http://www.tm.agilent.com. Нажмите "Library" и используйте функцию поиска для поиска усилителей CDMA.

Калибровочные стандарты, выдерживающие большую мощность

  • Стандарты Линия, ХХ, КЗ и Перемычка (line, open, short, и thru) не имеют проблем при больших уровнях мощности, поскольку не рассеивают энергию.

  • Энергию рассеивает нагрузка. Для того чтобы предотвратить повреждение нагрузки, прочтите ее спецификацию, чтобы удостовериться в том, что она сможет выдержать такой уровень мощности.

ВНИМАНИЕ: При калибровке КЗ или ХХ, убедитесь в том, что уровень входящей мощности достаточно низок, для того чтобы отраженный сигнал не превысил допустимый максимум на входе приемника анализатора. Информацию об уровне, при котором возникает повреждение приемника, смотрите в технических характеристиках анализатора.

Если вы используете Модуль электронной калибровки (ECal), то информацию о максимальной входной мощности смотрите в его технических характеристиках.

Требования по температуре к тестируемым устройствам и нагрузкам

При измерениях больших мощностей для большей точности необходимо принимать во внимание темературные условия, при которых они происходили. Например:

  • Реакция тестируемого устройства большой мощности может сильно отличаться при различных температурах. Измерения должны производиться, когда усилитель находится при требуемой температуре.

  • Следует дождаться температурной стабилизации нагрузки, если характеристики ее полного сопротивления значительно изменяются с температурой.

Рекомендации по свипированию стимула для тестируемого устройства с цепью АРУ

Если измеряется усилитель с цепью АРУ (Автоматической регулировки усиления), то рекомендуется настроить анализатор так, чтобы свипирование происходило только в одной полосе частот. Это требует проведения отдельных измерений по каждому требуемому диапазону частот, но это гарантирует безопасность усилителя.

Проблемой усилителя (тестируемого устройства) содержащего цепь АРУ является отключение мощности источника, подаваемой на усилитель. Проблема возникает, когда источник мощности анализатора при свипировании пересекает границы диапазонов. Если используется только один диапазон частот, то анализатор поддерживает мощность постоянной во время свипирования или возврата. При переключении диапазона частот анализатор выключает мощность источника во время свипирования или возврата.

Когда источник мощности выключается, цепь АРУ усилителя, увеличивая его коэффициент усиления, пытается это компенсировать для того чтобы сохранить уровень мощности на выходе постоянным. Когда выключение заканчивается и снова начинается свипирование, анализатор возобновляет подачу сигнала, внезапно снова восстанавливая мощность на входе усилителя, который уже увеличил усиление. Если цепь АРУ не может отреагировать достаточно быстро, то кратковременный скачок мощности на выходе может повредить или уничтожить тестируемый усилитель и приемник анализатора.

Просмотрите пересечения полос частот Вашего анализатора.

Процедуры для измерений усилителей мощности

ВНИМАНИЕ: Избегайте дорогостоящих ремонтных работ анализатора серии PNA. См. Защита от электростатического разряда.

  1. Выберите правильную конфигурацию анализатора для тестируемого устройства и необходимых измерений. Пока что не подсоединяйте тестируемое устройство.

  2. Установите предварительные настройки анализатора.

  3. В случае необходимости отрегулируйте мощность источника анализатора:

    • Установите источник мощности анализатора так, чтобы он находился в линейной области выходной характеристики усилителя (обычно на 10 дБ ниже точки сжатия 1 дБ).

    • Выберите внешний аттенюатор (если это необходимо) таким образом, чтобы мощность усилителя на выходе была бы снижена достаточно, для того чтобы избежать нелинейных искажений (сжатия) на приемнике или повреждения анализатора.

  4. Выберите желаемое измерение.

  5. Подключите тестируемое устройство.

  6. Выберите настройки для тестируемого устройства.

  7. Уберите тестируемое устройство и выполните калибровку измерений. Убедитесь в том, что Вы подключили все выходные усилители, кабели, аттенюаторы или ответвители, которые будут использоваться при измерениях тестируемого устройства.

  8. Сохраните состояние прибора в памяти.

  9. Повторно подсоедините тестируемое устройство.

  10. Установите масштаб отображаемых данных для оптимального просмотра и используйте маркеры для считывания результатов измерения.

  11. Распечатайте данные или сохраните их на диске.


Diagram: High-Pwr Amps, E835x, basic config

Diagram: (E835x) Basic Configuration

Explore the graphic with your mouse.


Diagram 1: High-Pwr Amps, E835x, fwd msmts

Diagram: (E835x) Configuration for High-Power Measurements in the Forward Direction (Single-Port Cal Only)

Explore the graphic with your mouse.


Diagram 2: High-Pwr Amps, E835x, fwd msmts

Diagram: (E835x) Configuration for High-Power Measurements in the Forward Direction (2-Port Cal)

Explore the graphic with your mouse.


Diagram 1: High-Pwr Amps, E835x, fwd & rev msmts

Diagram: (E835x) Configuration for Non-Boosted High-Power Measurements in both Forward & Reverse Directions

Explore the graphic with your mouse.


Diagram 3: High-Pwr Amps, E835x, fwd & rev msmts

Diagram: (E835x) Configuration for High-Power Measurements in both the Forward & Reverse Directions (2-Port Cal)

Explore the graphic with your mouse.


Diagram 1: High-Pwr Amps, E835x, w/ booster amp

Diagram: (E835x) Configuration using One Booster Amplifier

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - a booster amplifier, a forward coupler, and an attenuator.


Diagram 2: High-Pwr Amps, E835x, w/ booster amp

Diagram: (E835x) Configuration using One Booster Amplifier and a Reverse Coupler

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - a booster amp, a forward coupler, a reverse coupler (allows S11 measurements), and two attenuators.


Diagram 3: High-Pwr Amps, E835x, w/ 2 booster amps

Diagram: (E835x) Configuration using Two Booster Amplifiers

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - two booster amps, 2 forward couplers, 2 reverse couplers (allows S11 and S22 measurements), and 4 attenuators.


Diagram 1: High-Pwr Amps, E835x, ext level

Diagram: (E835x) External Leveling using One Booster Amplifier

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - a booster amplifier, forward coupler, power splitter, two attenuators, and a negative detector diode.


Diagram 2: High-Pwr Amps, E835x, ext level

Diagram: (E835x) External Leveling using One Booster Amplifier and a Reverse Coupler

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - a booster amp, forward coupler, reverse coupler (allows S11 measurements), power splitter, three attenuators, and a negative detector diode.


Diagram 3: High-Pwr Amps, E835x, ext level

Diagram: (E835x) External Leveling using Two Booster Amplifiers and Two Reverse Couplers

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - 2 booster amps, 2 forward couplers, 2 reverse couplers (allow S11 and S22 measurements), 2 power splitters, 6 attenuators, and a negative detector diode.


Diagram: High-Pwr Amps, E835x, cal pwr levels

Diagram: (E835x) Measuring Calibration Power Levels

Item | Description
a | Measure the receiver input power where your external circuitry connects here
b | DUT, customer supplied
c | PORT 1
d | PORT 2


Diagram: High-Pwr Amps, E835x Opt 015, basic config

Diagram: (E835x, Option 015) Basic Configuration

Explore the graphic with your mouse.


Diagram 1: High-Pwr Amps, E835x Opt 015, fwd msmts

Diagram: (E835xA, Option 015) Configuration for High-Power Measurements in the Forward Direction

Explore the graphic with your mouse.


Diagram 2: High-Pwr Amps, E835x Opt 015, fwd msmts

Diagram: (E835xA, Option 015) Configuration (with an Isolator) for High-Power Measurements in the Forward Direction

Explore the graphic with your mouse.


Diagram: High-Pwr Amps, E835x Opt 015, fwd & rev msmts

Diagram: (E835xA, Option 015) Configuration for High-Power Measurements in both Forward & Reverse Directions

Explore the graphic with your mouse.


Diagram 1: High-Pwr Amps, E835x Opt 015, w/ booster amp

Diagram: (E835x, Option 015) Configuration using One Booster Amplifier

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you: a booster amplifier, a forward coupler, and an attenuator.


Diagram 2: High-Pwr Amps, E835x Opt 015, w/ booster amp

Diagram: (E835xA, Option 015) Configuration Using Two Booster Amplifiers

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you: two booster amps, two forward couplers, and two attenuators.


Diagram 1: High-Pwr Amps, E835x Opt 015, ext level

Diagram: (E835x, Option 015) External Leveling using One Booster Amplifier

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - a booster amplifier, a forward coupler, power splitter, attenuators, and a negative detector diode.


Diagram 2: High-Pwr Amps, E835x Opt 015, ext level

Diagram: (E835xA, Option 015) External Leveling using Two Booster Amplifiers

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you: two booster amps, two forward couplers, attenuators, three power splitters, and a negative detector diode.


Diagram: High-Pwr Amps, E835x Opt 015, cal pwr levels

Diagram: (E835xA, Option 015) Measuring Calibration Power Levels


Diagram: High-Pwr Amps, Basic config

Diagram: Basic Configuration

  • E8361A. E8362A/B, E8363A/B, E8364A/B

  • N5230A

Explore the graphic with your mouse.

Item | Description
a | PORT 1
b | PORT 2
c | DUT, customer supplied


Diagram: High-Pwr Amps, E836x, fwd msmts

Diagram: Configuration for High-Power Measurements in the Forward Direction (Single-Port Cal Only)

  • E8361A, E8362A/B, E8363A/B, E8364A/B

  • N5230A

Explore the graphic with your mouse.

Item | Description | Item | Description
a | PORT 1 | e | Attenuator (for forward measurements), customer supplied
b | PORT 2 |  |
c | Booster amplifier, customer supplied |  |
d | DUT, customer supplied |  |


Diagram: High-Pwr Amps, E836x, fwd & rev msmts

Diagram: Configuration for Non-Boosted High-Power Measurements in both Forward and Reverse Directions

  • E8361A, E8362A/B, E8363A/B, E8364A/B

  • N5230A

Explore the graphic with your mouse.

Item | Description | Item | Description
a | PORT 1 | e | Attenuator (for forward measurements), customer supplied
b | PORT 2 |  |
c | Attenuator (for reverse measurements), customer supplied |  |
d | DUT, customer supplied |  |


Diagram: High-Pwr Amps, E836x w/ booster amp

Diagram: Configuration using a Booster Amp

  • E8361A, E8362A/B, E8363A/B, E8364A/B, N5230A

  • N5230A

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains a booster amplifier supplied by you.

Item | Description | Item | Description
a | PORT 1 | e | Attenuator (for forward measurements), customer supplied
b | PORT 2 |  |
c | Booster amplifier, customer supplied |  |
d | DUT, customer supplied |  |


Diagram: High-Pwr Amps, PNA with Configurable Test Set

Diagram: Basic Configuration

  • E8361A, E8362A/B, E8363A/B, E8364A/B, Option 014

  • N5230A Option 225, or 425, or 525

  • N5250A

Explore the graphic with your mouse.

Item | Description | Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN | o | DUT, customer supplied
b | RCVR R1 IN | i | CPLR ARM |  |
c | SOURCE OUT | j | PORT 2 |  |
d | CPLR THRU | k | CPLR THRU |  |
e | PORT 1 | l | SOURCE OUT |  |
f | CPLR ARM | m | RCVR R2 IN |  |
g | RCVR A IN | n | SOURCE OUT |  |


Diagram 1: High-Pwr Amps, E836x Opt 014, fwd msmts

Diagram: (E8361A, E8362A/B, E8363A/B, E8364A/B, Option 014) Configuration for High-Power Measurements in the Forward Direction

Explore the graphic with your mouse.

Item | Description | Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN | o | Attenuator, customer supplied
b | RCVR R1 IN | i | CPLR ARM | p | Booster amplifier, customer supplied
c | SOURCE OUT | j | PORT 2 | q | Directional coupler, customer supplied
d | CPLR THRU | k | CPLR THRU | r | DUT, customer supplied
e | PORT 1 | l | SOURCE OUT |  |
f | CPLR ARM | m | RCVR R2 IN |  |
g | RCVR A IN | n | SOURCE OUT |  |


Diagram 2: High-Pwr Amps, E836x Opt 014, fwd msmts

Diagram: Configuration (with an Isolator) for High-Power Measurements in the Forward Direction

  • E8361A, E8362A/B, E8363A/B, E8364A/B, Option 014

  • N5230A, Option 225, or 425, or 525

  • N5250A

Explore the graphic with your mouse.

Item | Description | Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN | o | Attenuator, customer supplied
b | RCVR R1 IN | i | CPLR ARM | p | Booster amplifier, customer supplied
c | SOURCE OUT | j | PORT 2 | q | Directional coupler, customer supplied
d | CPLR THRU | k | CPLR THRU | r | DUT, customer supplied
e | PORT 1 | l | SOURCE OUT | s | Isolator, customer supplied (for DUT output above +10 dBm)
f | CPLR ARM | m | RCVR R2 IN |  |
g | RCVR A IN | n | SOURCE OUT |  |


Diagram 1: High-Pwr Amps, E836x Opt 014, w/ booster amp

Diagram: Configuration using One Booster Amplifier

  • E8361A, E8362A/B, E8363A/B, E8364A/B, Option 014

  • N5230A, Option 225, or 425, or 525

  • N5250A

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you: a booster amplifier, a forward coupler, and attenuators.

Item | Description | Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN | o | Attenuator, customer supplied
b | RCVR R1 IN | i | CPLR ARM | p | Booster amplifier, customer supplied
c | SOURCE OUT | j | PORT 2 | q | Directional coupler, customer supplied
d | CPLR THRU | k | CPLR THRU | r | DUT, customer supplied
e | PORT 1 | l | SOURCE OUT | s | Isolator, customer supplied (for DUT output above +10 dBm)
f | CPLR ARM | m | RCVR R2 IN |  |
g | RCVR A IN | n | SOURCE OUT |  |


Diagram 2: High-Pwr Amps, E836x Opt 014, w/ booster amp

Diagram: Configuration Using Two Booster Amplifiers

  • E8361A, E8362A/B, E8363A/B, E8364A/B, Option 014

  • N5230A, Option 225, or 425, or 525

  • N5250A

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you: two booster amps, two forward couplers, and attenuators.

Item | Description | Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN | o | Attenuator, customer supplied
b | RCVR R1 IN | i | CPLR ARM | p | Booster amplifier, customer supplied
c | SOURCE OUT | j | PORT 2 | q | Directional coupler, customer supplied
d | CPLR THRU | k | CPLR THRU | r | DUT, customer supplied
e | PORT 1 | l | SOURCE OUT |  |
f | CPLR ARM | m | RCVR R2 IN |  |
g | RCVR A IN | n | SOURCE OUT |  |


Diagram: High-Pwr Amps, E836x Opt 014, fwd & rev msmts

Diagram: Configuration for High-Power Measurements in both Forward & Reverse Directions

  • E8361A, E8362A/B, E8363A/B, E8364A/B, Option 014

  • N5230A, Option 225, or 425, or 525

  • N5250A

Explore the graphic with your mouse.

Item | Description | Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN | o | Attenuator, customer supplied
b | RCVR R1 IN | i | CPLR ARM | p | Booster amplifier, customer supplied
c | SOURCE OUT | j | PORT 2 | q | Directional coupler, customer supplied
d | CPLR THRU | k | CPLR THRU | r | DUT, customer supplied
e | PORT 1 | l | SOURCE OUT |  |
f | CPLR ARM | m | RCVR R2 IN |  |
g | RCVR A IN | n | SOURCE OUT |  |


Diagram: High-Pwr Amps, E836x Opt 014, cal pwr levels

Diagram: Measuring Calibration Power Levels

Item | Description
a | Measure the receiver input power where your external circuitry connects here
b | DUT, customer supplied
c | PORT 1
d | PORT 2


Diagram: High-Pwr Amps, E880x, basic config

Diagram: (E880xA) Basic Configuration

Explore the graphic with your mouse.


Diagram: High-Pwr Amps, E880x, fwd msmts

Diagram: (E880xA) Configuration for High-Power Measurements in the Forward Direction (Single-Port Cal Only)

Explore the graphic with your mouse.


Diagram: High-Pwr Amps, E880x, fwd & rev msmts

Diagram: (E880xA) Configuration for Non-Boosted High-Power Measurements in both Forward and Reverse Directions

Explore the graphic with your mouse.


Diagram: High-Pwr Amps, E880x, w/ booster amp

Diagram: (E880xA) Configuration using a Booster Amp

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains a booster amplifier supplied by you.


Diagram: High-Pwr Amps, E880x, ext level

Diagram: (E880xA) External Leveling Configuration

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - a booster amplifier, forward coupler, attenuator, and negative detector diode.


Diagram: High-Pwr Amps, E880x Opt 014, basic config

Diagram: (E880xA, Option 014) Basic Configuration

Explore the graphic with your mouse.


Diagram 1: High-Pwr Amps, E880x Opt 014, fwd msmts

Diagram: (E880xA, Option 014) Configuration for High-Power Measurements in the Forward Direction

Explore the graphic with your mouse.


Diagram 2: High-Pwr Amps, E880x Opt 014, fwd msmts

Diagram: (E880xA, Option 014) Configuration (with an Isolator) for High-Power Measurements in the Forward Direction

Explore the graphic with your mouse.


Diagram: High-Pwr Amps, E880x Opt 014, fwd & rev msmts

Diagram: (E880xA, Option 014) Configuration for High-Power Measurements in both Forward and Reverse Directions

Explore the graphic with your mouse.


Diagram 1: High-Pwr Amps, E880x Opt 014, w/ booster amp

Diagram: (E880xA, Option 014) Configuration Using One Booster Amplifier

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - a booster amplifier, a forward coupler, an isolator, and attenuators.


Diagram 2: High-Pwr Amps, E880x Opt 014, w/ booster amp

Diagram: (E880xA, Option 014) Configuration Using Two Booster Amplifiers

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - two booster amplifiers, two forward couplers, two attenuators, and a power splitter.


Diagram 1: High-Pwr Amps, E880x Opt 014, ext level

Diagram: (E880xA, Option 014) External Leveling using One Booster Amplifier

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - a booster amplifier, a forward coupler, two attenuators, a power splitter, and a negative detector diode.


Diagram 2: High-Pwr Amps, E880x Opt 014, ext level

Diagram: (E880xA, Option 014) External Leveling using Two Booster Amplifiers

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - two booster amplifiers, two forward couplers, two attenuators, four power splitters, and a negative detector diode.


Diagram: High-Pwr Amps, E880x Opt 014, cal pwr levels

Diagram: (E880xA, Option 014) Measuring Calibration Power Levels

Item | Description
a | Measure the receiver input power where your external circuitry connects here
b | DUT, customer supplied
c | PORT 1
d | PORT 2


Diagram: High-Pwr Amps, N338x, basic config

Diagram: (N338x) Basic Configuration

Explore the graphic with your mouse.

Note: Either Port 2 or Port 3 can be used for testing a 2-Port DUT.


Diagram: High-Pwr Amps, N338x, fwd msmts

Diagram: (N338x) Configuration for High-Power Measurements in the Forward Direction (Single-Port Cal Only)

Explore the graphic with your mouse.

Note: Either Port 2 or Port 3 can be used for testing a 2-Port DUT.


Diagram: High-Pwr Amps, N338x, fwd & rev msmts

Diagram: (N338x) Configuration for Non-Boosted High-Power Measurements in both Forward and Reverse Directions

Explore the graphic with your mouse.

Note: Either Port 2 or Port 3 can be used for testing a 2-Port DUT.


Diagram: High-Pwr Amps, N338x, w/ booster amp

Diagram: (N338x) Configuration using a Booster Amplifier

Explore the graphic with your mouse.

Note: Either Port 2 or Port 3 can be used for testing a 2-Port DUT. The circuitry inside the yellow lines contains a booster amplifier supplied by you.


Diagram: High-Pwr Amps, N338x, ext level

Diagram: (N338x) External Leveling Configuration

Explore the graphic with your mouse.

Note: Either Port 2 or Port 3 can be used for testing a 2-Port DUT. The circuitry inside the yellow lines contains the following components supplied by you - a booster amplifier, a forward coupler, an attenuator, and a negative detector diode.


Diagram: High-Pwr Amps, N338x Opt 014, basic config

Diagram: (N338xA, Option 014) Basic Configuration

Explore the graphic with your mouse.

Note: Either Port 2 or Port 3 can be used for testing a 2-Port DUT.


Diagram 1: High-Pwr Amps, N338x Opt 014, fwd msmts

Diagram: (N338xA, Option 014) Configuration for High-Power Measurements in the Forward Direction

Explore the graphic with your mouse.


Diagram 2: High-Pwr Amps, N338x Opt 014, fwd msmts

Diagram: (N338xA, Option 014) Configuration (with an Isolator) for High-Power Measurements in the Forward Direction

Explore the graphic with your mouse.


Diagram: High-Pwr Amps, N338x Opt 014, fwd & rev msmts

Diagram: (N338xA, Option 014) Configuration for High-Power Measurements in both Forward and Reverse Directions

Explore the graphic with your mouse.


Diagram 1: High-Pwr Amps, N338x Opt 014, w/ booster amp

Diagram: (N338xA, Option 014) Configuration Using One Booster Amplifier

Explore the graphic with your mouse.

Note: Either Port 2 or Port 3 can be used for testing a 2-Port DUT. The circuitry inside the yellow lines contains the following components supplied by you - a booster amplifier, a forward coupler, and an attenuator.


Diagram 2: High-Pwr Amps, N338x Opt 014, w/ booster amp

Diagram: (N338xA, Option 014) Configuration Using Two Booster Amps

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - two booster amplifiers, two forward couplers, two attenuators and a power splitter.


Diagram 1: High-Pwr Amps, N338x Opt 014, ext level

Diagram: (N338xA, Option 014) External Leveling using One Booster Amplifier

Explore the graphic with your mouse.

Note: Either Port 2 or Port 3 can be used for testing a 2-Port DUT. The circuitry inside the yellow lines contains the following components supplied by you - a booster amplifier, a forward coupler, two attenuators, a power splitter and a negative detector diode.


Diagram 2: High-Pwr Amps, N338x Opt 014, ext level

Diagram: (N338xA, Option 014) External Leveling using Two Booster Amplifiers

Explore the graphic with your mouse.

Note: the circuitry inside the yellow lines contains the following components supplied by you - two booster amplifiers, two forward couplers, two attenuators, three power splitters, and a negative detector diode.


Diagram: High-Pwr Amps, N338x Opt 014, cal pwr levels

Diagram: (N338xA, Option 014) Measuring Calibration Power Levels

Note: Either Port 2 or Port 3 can be used for testing a 2-Port DUT.


Простота против безопасности

Простота против безопасной конфигурации

При обновлении встроенных программ PNA появляется диалоговое окно Choose Configuration (Выберите конфигурацию). Ее используют для определения установки уровня безопасности интерфейса DCOM в PNA. Более подробная информация о настройках безопасности для интерфейса DCOM, включая процедуру ручной настройки, находится в Конфигурирование COM-DCOM.

Далее следует сравнение настроек "Проще и более безопасно":

Простое подключение:

  • При дистанционном доступе к подключению конфигурирование PNA не требуется.

  • Любой пользователь локальной подсети может получить дистанционный доступ к PNA.

  • Пользователи других доменов сети могут подключаться к PNA.

Более безопасно:

  • Необходимо создание пользователей PNA или добавление PNA к домену

  • Администратор PNA может указывать пользователей или группы, которым разрешен удаленный доступ к приложению PNA


Изменение клиента сети

Если в сети ваших компьютеров используются серверы Novell NetWare, перед началом работы PNA в сети необходимо изменить его настройки. Если у вас нет точной информации, уточните в местном отделе ИТ.

Примечание: НЕ выполняйте деинсталляцию "Client for Microsoft Networks". Это помешает PNA функционировать должным образом.

Для удаления "Client for Microsoft Networks" (операции удаления и деинсталляции отличаются):

  1. На рабочем столе PNA щелкните по My Network Places правой кнопкой мыши

  2. Нажмите Properties (Свойства)

  3. Щелкните правой кнопкой мыши по Local Area Connection (Локальное подключение)

  4. Нажмите Properties

  5. Нажмите (удаление флажка) Client for Microsoft Networks

Для установки "Client Service for NetWare" (Обслуживание клиента в NetWare).

  1. Нажмите Install

  2. Убедитесь в том, что в поле Select Network Component Type (Выбор типа компонента сети) выбрано Client

  3. Нажмите Add

  4. Убедитесь в том, что в поле Select Network Client выбрано Client Service for NetWare

  5. Нажмите OK.


Устранение неполадок

Устранение неполадок PNA

Для выявления неполадок необходимо выполнить несколько проверок. Перед тем, как звонить в Agilent Technologies или возвращать изделие в сервисный центр необходимо провести следующие проверки.

  • Базовые проверки

  • Приложение PNA неожиданно завершается

  • Проверка векторов ошибок

  • Ознакомьтесь с руководством по обслуживанию

Другие разделы справочного руководства

Базовые проверки

В некоторых случаях проблема может быть решена повторным выполнением процедуры, при выполнении которой она произошла. Перед тем, как звонить в Agilent Technologies или возвращать изделие в сервисный центр выполните следующие проверки:

  1. Проверьте наличие напряжения в сети. Проверьте правильность подключения прибора.

  2. Убедитесь, что включено питание. Убедитесь, что горят зеленые светодиоды на кнопке питания и хотя бы на одном из тестовых портов. Это означает, что источник питания включен

  3. Проблемы с клавиатурой передней панели или периферийными устройствами могут быть вызваны перегрузкой шины USB. Отключите USB-устройства, перезагрузите PNA и заново подключите их. См. Включение.

  4. Если при подключении прибора были использованы другие кабели, коннекторы и прочее оборудование, проверьте правильность его подключения и работы.

  5. Перепроверьте процедуру измерения, проводимую перед возникновением неполадки. Проверьте, все ли параметры правильно настроены.

  6. Если прибор не работает должным образом, нажмите клавишу Preset для загрузки предопределенного набора настроек.

  7. Проверьте, соответствуют ли проводимые измерения и ожидаемые результаты спецификациям и возможностям устройства.

  8. Если есть подозрение, что проблема возникла из-за прошивки, то перед началом действий по устранению неполадок проверьте наличие последней версии прошивки.

  9. Убедитесь в правильности калибровки измерений. Для подробной информации см. раздел "Точная калибровка измерений".

  10. При наличии необходимого оборудования выполните операторскую проверку, описанную в главе 2 руководства по обслуживанию PNA, "Тестирование, проверка и настройка системы". Данное руководство можно загрузить с Web-сайта по адресу http://www.agilent.com/find/pna

Приложение PNA неожиданно завершается

При возникновении неожиданных неустранимых ошибок необходимо сообщить о них компании Agilent. При возникновении ошибки PNA пытается сохранить отладочную информацию о состоянии системы. PNA НЕ отправляет эту информацию компании Agilent.

Мы уважаем конфиденциальность наших клиентов. Однако отладочная информация помогает нам усовершенствовать PNA, что полезно как компании, так и клиентам. Пожалуйста, свяжитесь с нами, или отправьте сохраненную информацию по электронной почте на адрес na_support@agilent.com.

Для этого необходимо выполнить следующие действия:

  1. На экране появляется диалоговое окно, содержащее местонахождение каталога. Запишите это сообщение. Если вы пропустили это сообщение, путь к каталогу можно найти при помощи журнала событий Windows: На PNA нажмите Start, Settings, Control Panel, Administrative Tools, Event Viewer. Дважды щелкните по самой верхней строке (последнее событие). Путь к каталогу находится в поле Description.

  2. На экране может появиться диалоговое окно (см. ниже) для добавления комментариев, которые могут помочь воспроизвести ошибку.

  3. Найдите каталог (описанный в шаге 1), содержащий следующие файлы:

  • 835x.dmp – дамп файла 835x.exe с захватом контекста, в котором произошел сбой программы.

  • 835x.xml - информация о коде ошибки, версии ОС, загруженных на момент сбоя модулях и их версиях.

  • 835xCrashLog.txt: Текстовый файл с пользовательскими комментариями (см. шаг 2), если есть.

  4. Если PNA не подключен к локальной сети, или не настроен на отправку электронной почты, то скопируйте требуемые файлы на ПК. После этого отправьте их на na_support@agilent.com

Проверка векторов ошибок

Распечатывайте векторы ошибок по интервалам (неделя, месяц, и т.д.) для сравнения текущего вектора ошибок с распечатками. Стабильная система должна генерировать векторы ошибок с высокой повторяемостью продолжительное время, например 6 месяцев. При подозрении на скрытую проблему необходимо сравнить величины векторов ошибок с ранее сохраненными с использованием того же самого прибора и инструментария калибровки. См. Процедура мониторинга векторов ошибок.

  • Долговременная тенденция может указывать на смещение характеристик, износ коннекторов и кабеля, или постепенное ухудшение характеристик, требующее дальнейшего исследования и превентивного обслуживания. Однако вся система при этом может соответствовать общим спецификациям. Проблема часто решается простой чисткой и подгонкой коннекторов или проверкой кабелей.

  • Внезапный сдвиг в векторе ошибок отражает внезапный сдвиг в систематической ошибке и может свидетельствовать о необходимости дополнительных исследований.

При поиске неисправностей необходимо учитывать следующее:

  • На систематические ошибки и векторы ошибок могут влиять все части системы, включая кабели и калибровочные устройства.

  • Коннекторы должны быть чистыми, подогнанными, и соответствовать спецификации анализа вектора ошибок. Для подробной информации по чистке и подгонке коннекторов см. главу 2 руководства по обслуживанию PNA.

    • Для уменьшения ошибок нестабильности кабеля избегайте перегибов и растяжений измерительных кабелей.

    • При калибровке измерений используйте качественную соединительную технику. Интерфейс коннектора должен быть с высокой повторяемостью. Для подробной информации о технике соединений см. руководство по обслуживанию PNA.

  • Часто требуется повторить эту процедуру дважды (с двумя разными калибровками измерения) для установки степени надежности. Если результаты отличаются – проверьте коннекторы и кабели.

  • Для поиска незначительных скрытых проблем производительности используйте анализ вектора ошибок. При наличии очевидных отклонений общей ошибки измерения см. главу 3, "Устранение неполадок", руководство по обслуживанию PNA.

Ознакомьтесь с руководством по обслуживанию

Процедуры устранения неполадок описаны в руководстве по обслуживанию PNA. Оно поставляется на CD-ROM в комплекте с анализатором. Копию руководства по обслуживанию можно загрузить с нашего Web-сайта по адресу http://www.agilent.com/find/pna


Ошибки PNA

Сообщения об ошибках PNA

  • 500 - 750 Калибровка

  • 770 - 1000 Оборудование

  • 1000 - 1200 Измерения

  • 1281 - 1535 Синтаксический анализ

  • 1536 - 1650 Отображение

  • 1700 - 2000 Канал

  • 2048 - 2200 Общие

  • Стандартные ошибки SCPI

Примечание: Приведенные ниже идентификаторы событий EventID предоставляются для COM программирования. Подробнее см. Работа с событиями PNA

Информацию по сообщениям об ошибках PNA см. в (Сообщения об ошибках).

Ошибки калибровки

Сообщение: 512

"Изменен вторичный параметр (мощность, IFBW, время свипирования, шаговый режим) состояния калибровки."

Серьезность: информационное

Пояснение: Сомнительный результат калибровки, если один из данных вторичных параметров изменен после проведения калибровки.

Предложения: Если необходимы точные измерения с новыми настройками, повторите калибровку.

EventID: 68020200 (hex)

Сообщение: 513

"Калибровку нельзя завершить, пока не будут проведены все измерения по мерам для выбранного Cal Type (Тип калибровки)."

Серьезность: информационное

Пояснение: Вероятно, данное сообщение вызвано попыткой начать корректировку без предварительных измерений по всем калибровочным мерам

Предложения: Завершить измерения по калибровочным мерам

EventID: 68020201 (hex)

Сообщение: 514

"Повторно вызван калибровочный комплект с помощью файла, сохраненного анализатором с другой аппаратной конфигурацией."

Серьезность: информационное

Пояснение:

Предложения:

EventID: 68020202 (hex)

Сообщение: 515

"До того как включить коррекцию, необходимо провести калибровку. Номер канала - <x>, измерение - <x>."

Серьезность: информационное

Пояснение: Отсутствуют условия корректировки для указанного канала и измерения.

Предложения: Выполнить калибровку или вызвать ее повторно

EventID: 68020203 (hex)

Сообщение: 516

"Важные параметры текущего инструментального состояния не соответствуют параметрам калибровочного комплекта, поэтому корректировка отключена. Важные параметры инструментального состояния - это тип свипирования, стартовая частота, диапазон частот и количество точек."

Серьезность: информационное

Пояснение: нет

Предложения: Можно повторить калибровку с новыми настройками или вернуться к первоначальным настройкам, использованным при калибровке.

EventID: 68020204 (hex)

Сообщение: 517

"Интерполяция отключена, и вы изменили настройки входного сигнала первоначальной калибровки, поэтому корректировка отключена."

Серьезность: информационное

Пояснение: Наиболее точная калибровка выполняется только при использовании оригинальных настроек входного сигнала.

Предложения: Если вас устраивает пониженная точность, установите интерполяцию в положение ON, чтобы разрешить изменения настроек входного сигнала.

EventID: 68020205 (hex)

Сообщение: 518

"Интерполяция отключена, и вы установили корректировку в положение ON. Восстановлены предыдущие настройки входного сигнала для корректировки."

Серьезность: информационное

Пояснение: нет

Предложения: нет

EventID: 68020206 (hex)

Сообщение: 519

"Настройки входного сигнала для текущего инструментального состояния превышают параметры оригинальной калибровки, поэтому корректировка отключена."

Серьезность: информационное

Пояснение: Данные корректировки, выходящие за пределы настроек входного сигнала, не существуют.

Предложения: Выполнить широкополосную калибровку с увеличенным количеством точек и включенной интерполяцией, чтобы калибровка проходила по самому широкому возможному диапазону настроек частоты входного сигнала.

EventID: 68020207(hex)

Сообщение: 520

"Cal Type установлен на NONE для канала <x>, измерение <x>; выберите меню Calibration или нажмите клавишу Cal."

Серьезность: информационное

Пояснение: Операция калибровки не может выполняться без существующей калибровки или выбранного типа калибровки. Это ошибка появляется, если невозможно обнаружить калибровку. Кроме того, эта ошибка возникает при попытке программно провести калибровку при не выбранном типе калибровки.

Предложения Для того чтобы найти калибровку, выберите Cal Set, где находится калибровка, необходимая для текущих измерений. ИЛИ укажите тип калибровки перед началом процедуры калибровки.

EventID: 68020208 (hex)

Сообщение: 521

"Для установленных измерений не существует соответствующего типа калибровки, поэтому корректировка отключена либо не разрешена."

Серьезность: информационное

Пояснение: Калибровка для канала может применяться только к определенным S-параметрам. Например, 1-портовая калибровка для S11 не может применяться к 1-портовой калибровке для S22.

Предложения: Выберите тип калибровки, например, полную 2-портовую калибровку, которую можно применять ко всем выбираемым измерениям.

EventID: 68020209 (hex)

Сообщение: 522

"Невозможно установить выбранный тип калибровки."

Серьезность: информационное

Пояснение: "Применяйте команду SCPI - ROUTe:PATH:DEFine:PORT <num>,<num> для назначения типа порта полной 2-портовой калибровки."

Предложения:

EventID: 6802020A (hex)

Сообщение: 523

"Невозможно установить выбранный путь калибровки, так как он недопустим для текущего измерения."

Серьезность: информационное

Пояснение: "Применяйте команду SCPI - ROUTe:PATH:DEFine:PORT <num>,<num> для назначения типа порта полной 2-портовой калибровки, связанного с текущим измерением."

Предложения:

EventID: 6802020B (hex)

Сообщение: 524

"Калибровка источника питания выполнена."

Серьезность: информационное

Пояснение:

Предложения:

EventID: 6802020C (hex)

Сообщение: 525

"Вы указали более 7 калибровочных мер для одного или более классов калибровки."

Серьезность: информационное

Пояснение: Оставлено 7 вариантов.

EventID: 6802020D (hex)

Сообщение: 526

"Не обнаружена пользовательская калибровка для данного канала."

Серьезность: информационное

Пояснение: Невозможно проводить операцию калибровки без существующей калибровки.

Предложения: Для того чтобы найти калибровку, можно выбрать Cal Set, где находится калибровка, необходимая для текущего измерения.

EventID: 6802020E (hex)

Сообщение: 527

"Для данного типа калибровки нет необходимости в такой калибровочной мере."

Серьезность: информационное

Пояснение: Данная ошибка может появляться в результате ПРОГРАММНОГО запроса на измерение по ненужной калибровочной мере в процессе процедуры калибровки.

Предложения: Проверьте указанный тип калибровки или удалите запрос на измерение по калибровочной мере.

EventID: 6802020F (hex)

Сообщение: 528

"Невозможно сконфигурировать систему электронной калибровки. Проверьте подключение модуля к соответствующему разъему."

Серьезность: информационное

Пояснение: Невозможно установить соединение с модулем ECal при операции ECal. Калибровка не будет запущена до проверки наличия модуля ECal.

Предложения: Проверьте правильность подключения кабеля USB. Отключите кабель и подключите его повторно, чтобы убедиться в том, что анализатор распознает модуль.

EventID: 68020210 (hex)

Сообщение: 529

"ДАННЫЕ ВЫХОДЯТ ЗА ПРЕДЕЛЫ ДИАПАЗОНА: превышены проектные ограничения"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020211(hex)

Сообщение: 530

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: невозможно открыть резервный файл памяти модуля ECal"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020212 (hex)

Сообщение: 531

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: был запрещен доступ к резервному файлу памяти модуля ECal"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020213 (hex)

Сообщение: 532

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: ошибка при записи резервного файла памяти модуля ECal"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020214 (hex)

Сообщение: 533

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: ошибка при чтении резервного файла памяти модуля ECal"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020215 (hex)

Сообщение: 534

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: индекс массива выходит за пределы диапазона"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020216 (hex)

Сообщение: 535

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: ошибочный порядок массива"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020217 (hex)

Сообщение: 536

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: CPU"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020218 (hex)

Сообщение: 537

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: невозможно ERASE (стереть) модуль"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020219 (hex)

Сообщение: 538

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: невозможно WRITE (записать) модуль"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E802021A (hex)

Сообщение: 539

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: не обнаружена запись"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E802021B (hex)

Сообщение: 540

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: ошибочная команда при занятости системы"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E802021C (hex)

Сообщение: 541

"Electronic Cal: Невозможно обнаружить модуль ECal. Убедитесь в том, что модуль подключен к портам измерений."

Серьезность: ошибка

Пояснение: Отсутствует подключение РЧ к модулю ECal на шаге калибровки. Проведена попытка измерения размещения ECal, но сигнал не обнаружен.

Предложения: Подключите разъемы РЧ модуля ECal к портам, указанным для шага калибровки. Как правило, модулю ECal для измерений требуется как минимум -18dBm. Если для измерения требуется меньший уровень мощности, очистите поле Провести ориентировку, чтобы обойти шаг автоматического детектирования.

EventID: E802021D (hex)

Сообщение: 542

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: ОТСУТСТВУЕТ ПРОСТРАНСТВО для НОВОЙ КАЛИБРОВКИ, УДАЛИТЕ КАЛИБРОВКУ"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E802021E (hex)

Сообщение: 543

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: нет места"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E802021F (hex)

Сообщение: 544

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: ошибка массива"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020220 (hex)

Сообщение: 545

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: неравное количество рядов"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020221 (hex)

Сообщение: 546

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: мало ПОСТОЯННЫХ рядов"

Серьезность: ошибка

EventID: E8020222 (hex)

Сообщение: 547

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: мало переменных рядов"

Серьезность: ошибка

EventID: E8020223 (hex)

Сообщение: 548

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: неизвестная ошибка"

Серьезность: ошибка

EventID: E8020224 (hex)

Сообщение: 549

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: ошибка в модуле ecaldrvr.dll или недействительный № модуля "

Серьезность: ошибка

EventID: E8020225 (hex)

Сообщение: 550

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: непредусмотренный код ошибки драйвера ecal"

Серьезность: ошибка

EventID: E8020226 (hex)

Сообщение: 551

"ОШИБКА В ХОДЕ ВЫПОЛНЕНИЯ: непредусмотренная внутренняя ошибка драйвера"

Серьезность: ошибка

EventID: E8020227 (hex)

Сообщение: 552

"АППАРАТНАЯ ОШИБКА: нет доступа к интерфейсному модулю ECal"

Серьезность: ошибка

EventID: E8020228 (hex)

Сообщение: 553

"АППАРАТНАЯ ОШИБКА: невозможно разблокировать порт LPT, перезагрузитесь"

Серьезность: ошибка

EventID: E8020229 (hex)

Сообщение: 554

"АППАРАТНАЯ ОШИБКА: ошибка VNA"

Серьезность: ошибка

EventID: E802022A (hex)

Сообщение: 555

"АППАРАТНАЯ ОШИБКА: недостаточно данных, считанных из модуля ECal"

Серьезность: ошибка

EventID: E802022B (hex)

Сообщение: 556

"ОПЕРАЦИЯ ПРЕРВАНА ГЛАВНЫМ КОМПЬЮТЕРОМ"

Серьезность: ошибка

EventID: E802022C (hex)

Сообщение: 557

"ОПЕРАЦИЯ ПРЕРВАНА ПОЛЬЗОВАТЕЛЕМ"

Серьезность: ошибка

EventID: E802022D (hex)

Сообщение: 558

"НЕДОСТАТОЧНО ПАМЯТИ"

Серьезность: ошибка

EventID: E802022E (hex)

Сообщение: 559

"ЗАПРОС ПРЕРВАН: сообщения утеряны"

Серьезность: ошибка

EventID: E802022F (hex)

Сообщение: 560

"ЗАПРОС НЕЗАВЕРШЕН: НЕПОЛНОЕ ПРОГРАММНОЕ сообщение"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020230 (hex)

Сообщение: 561

"ЗАПРОС НЕЗАВЕРШЕН: НЕЧЕГО ОТВЕТИТЬ"

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020231 (hex)

Сообщение: 562

"ПЕРЕПОЛНЕНИЕ ОЧЕРЕДИ"

Серьезность: ошибка

EventID: E8020232 (hex)

Сообщение: 563

"КОНФЛИКТ НАСТРОЕК: НЕОБХОДИМЫ ДОПОЛНИТЕЛЬНЫЕ КАЛИБРОВОЧНЫЕ МЕРЫ"

Серьезность: ошибка

EventID: E8020233 (hex)

Сообщение: 564

"КОНФЛИКТ НАСТРОЕК: НЕ допустим адаптер Cal"

Серьезность: ошибка

EventID: E8020234 (hex)

Сообщение: 565

"КОНФЛИКТ НАСТРОЕК: НЕДОПУСТИМАЯ ПОСЛЕДОВАТЕЛЬНОСТЬ КОМАНД"

Серьезность: ошибка

EventID: E8020235 (hex)

Сообщение: 566

"КОНФЛИКТ НАСТРОЕК: КАЛИБРОВКА ОСТАНОВЛЕНА - ИЗМЕНЕНА НАСТРОЙКА VNA"

Серьезность: ошибка

EventID: E8020236 (hex)

Сообщение: 567

"КОНФЛИКТ НАСТРОЕК: Калибровка НЕ выполняется"

Серьезность: ошибка

EventID: E8020237 (hex)

Сообщение: 568

"КОНФЛИКТ НАСТРОЕК: Невозможно найти указанную панель GPIB"

Серьезность: ошибка

EventID: E8020238 (hex)

Сообщение: 569

"КОНФЛИКТ НАСТРОЕК: Невозможно найти/загрузить gpib32.dll"

Серьезность: ошибка

EventID: E8020239 (hex)

Сообщение: 570

"КОНФЛИКТ НАСТРОЕК: Невозможно найти/загрузить sicl32.dll"

Серьезность: ошибка

EventID: E802023A (hex)

Сообщение: 571

"КОНФЛИКТ НАСТРОЕК: Невозможно инициализировать VNA (неправильный адрес?)"

Серьезность: ошибка

EventID: E802023B (hex)

Сообщение: 572

"КОНФЛИКТ НАСТРОЕК: Невозможно загрузить драйвер порта LPT или драйвер DLL для USB"

Серьезность: ошибка

EventID: E802023C (hex)

Сообщение: 573

"КОНФЛИКТ НАСТРОЕК: недействительный режим свипирования калибровки."

Серьезность: ошибка

EventID: E802023D (hex)

Сообщение: 574

"КОНФЛИКТ НАСТРОЕК: недействительный тип калибровки"

Серьезность: ошибка

EventID: E802023E (hex)

Сообщение: 575

"КОНФЛИКТ НАСТРОЕК: недействительная калибровка"

Серьезность: ошибка

EventID: E802023F (hex)

Сообщение: 576

"КОНФЛИКТ НАСТРОЕК: неправильно указан номер панели GPIB"

Серьезность: ошибка

EventID: E8020240 (hex)

Сообщение: 577

"КОНФЛИКТ НАСТРОЕК: неправильно указан тип панели GPIB"

Серьезность: ошибка

EventID: E8020241 (hex)

Сообщение: 578

"КОНФЛИКТ НАСТРОЕК: недействительное состояние модуля"

Серьезность: ошибка

EventID: E8020242 (hex)

Сообщение: 579

"КОНФЛИКТ НАСТРОЕК: недействительные состояния"

Серьезность: ошибка

EventID: E8020243 (hex)

Сообщение: 580

"КОНФЛИКТ НАСТРОЕК: порт LPT должен находиться между 1 и 4"

Серьезность: ошибка

EventID: E8020244 (hex)

Сообщение: 581

"Невозможно сконфигурировать систему электронной калибровки. Проверьте правильность подключения модуля."

Серьезность: ошибка

EventID: E8020245 (hex)

Сообщение: 582

"КОНФЛИКТ НАСТРОЕК: указанный порт LPT не существует"

Серьезность: ошибка

EventID: E8020246 (hex)

Сообщение: 583

"КОНФЛИКТ НАСТРОЕК: используйте частотную область для калибровки"

Серьезность: ошибка

EventID: E8020247 (hex)

Сообщение: 584

"КОНФЛИКТ НАСТРОЕК: используйте свипирование шагового типа для калибровки."

Серьезность: ошибка

EventID: E8020248 (hex)

Сообщение: 585

"КОНФЛИКТ НАСТРОЕК: адрес VNA должен находиться между 0 и 30"

Серьезность: ошибка

EventID: E8020249 (hex)

Сообщение: 586

"КОНФЛИКТ НАСТРОЕК: неправильный драйвер порта LPT или драйвер DLL для USB"

Серьезность: ошибка

EventID: E802024A (hex)

Сообщение: 587

"СИНТАКСИЧЕСКАЯ ОШИБКА: в команде ECAL:DELAY должно быть 2 числа"

Серьезность: ошибка

EventID: E802024B (hex)

Сообщение: 588

"СИНТАКСИЧЕСКАЯ ОШИБКА: НЕПРАВИЛЬНАЯ СИНТАКСИЧЕСКАЯ СТРУКТУРА"

Серьезность: ошибка

EventID: E802024C (hex)

Сообщение: 589

"СИНТАКСИЧЕСКАЯ ОШИБКА: НЕИЗВЕСТНАЯ КОМАНДА"

Серьезность: ошибка

EventID: E802024D (hex)

Сообщение: 590

"Ошибочный порт или модуль для проводника РЧ"

Серьезность: ошибка

EventID: E802024E (hex)

Сообщение: 591

"Не обнаружена характеризация пользователя в модуле"

Серьезность: ошибка

EventID: E802024F (hex)

Сообщение: 592

Серьезность: информационное

"Не обнаружена калибровка источника питания для канала и порта источника текущего измерения."

Пояснение: Вы попытались включить калибровку источника питания, однако отсутствуют данные калибровки источника питания.

Предложения: Выполните калибровку источника питания

EventID: 68020250 (hex)

Сообщение: 593

Серьезность:информационное

"Калибровка источника питания свипированием не выполнена, поэтому отсутствует корректировка для канала и порта источника текущего измерения."

Пояснение: Вы попытались включить калибровку источника питания, однако данные калибровки источника неполные.

Предложения: Выполнить полную калибровку источника питания

EventID: 68020251 (hex)

Сообщение: 594

Серьезность: информационное

"Невозможно добавить новый график для просмотра в активном окне из-за превышения ограничения количества графиков в окне. Перед выполнением калибровки источника питания удалите график из окна."

Пояснение: Процедура калибровки источника питания пытается добавить график в активное окно. В активном окне уже находятся четыре графика.

Предложения: В активном окне должно находиться менее четырех графиков.

EventID: 68020252 (hex)

Сообщение: 595

Серьезность: информационное

"Невозможно добавить новое измерение для свипирования калибровки источника питания из-за превышения ограничения на количество измерений. Удалите измерение перед выполнением калибровки источника питания."

Пояснение: Процедура калибровки источника питания пытается добавить измерение. Максимальное количество измерений для PNA уже достигнуто.

Предложения: Удалите измерение.

EventID: 68020253 (hex)

Сообщение: 596

Серьезность: информационное

"Значение мощности калибровки, связанное с калибровкой источника питания порта %1 на канале %2 изменено при включенной калибровке. Калибровка не была отключена, однако значение мощности может больше не представлять калибровку."

Пояснение: Сомнительная точность калибровки источника питания.

Предложения: При необходимости большей точности проведите повторную калибровку источника питания.

EventID: 68020254 (hex)

Сообщение: 597

Серьезность: информационное

- Сообщение, переданное драйвером ваттметра для калибровки источника питания. -

Пояснение: Данная ошибка генерирована драйвером ваттметра и передана через PNA.

EventID: 68020255 (hex)

Сообщение: 598

"При сборе данных по стандарту скользящей нагрузки, движок не был правильно установлен для проведения круговой подгонки. Для определения направленности в одной или более точках был использован грубый импеданс калибровочной меры."

Серьезность: информационное

Пояснение: Для более точной характеризации меры необходимо достаточно сдвинуть скользящую нагрузку, чтобы обеспечить достаточную выборку на диаграмме Смита или вокруг круга. Недостаточность выборки может повлечь за собой неточность результатов.

Предложения: Для получения более точных результатов с применением скользящей нагрузки используйте несколько позиций движка, охватывающих полный диапазон перемещения от начала до конца слота.

EventID: 68020256 (hex)

Сообщение: 599

"Для данной функции необходим неиспользуемый канал, но он отсутствует. Освободите канал и повторите попытку."

Серьезность: информационное

Пояснение: Вы попытались просмотреть элемент калибровочного комплекта. Однако для просмотрщика калибровочного комплекта необходимо, чтобы результат отображался в канале, который сейчас не используется. В данный момент все каналы заняты. Невозможно отображение для требуемого элемента.

Предложения: Необходимо удалить как минимум один используемый в данный момент канал.

EventID: 68020257 (hex)

Сообщение: 600

"Интерполяция оригинальной калибровки не допустима, поскольку она выполнялась с помощью сегментированного свипирования. Корректировка отключена."

Серьезность: информационное

EventID: 68020258 (hex)

Сообщение: 601

"Предпочтения калибровки сохранены. Настройки предпочтений калибровки можно изменить в выпадающем меню 'Cal Preferences' (Предпочтения калибровки)."

Серьезность: информационное

Пояснение: Смотрите Предпочтения калибровки

EventID: 68020259 (hex)

Сообщение: 608

"Не установлен тип калибровки."

Серьезность: ошибка

Пояснение: Невозможно выполнять операцию калибровки без существующей калибровки или выбора соответствующего типа калибровки.

Предложения: Данная ошибка может появляться при невозможности обнаружить калибровку. Чтобы найти калибровку, можно выбрать калибровочный комплект, где находится калибровка, необходимая для текущих измерений. Данная ошибка также может появляться, если перед попыткой программного выполнения калибровки не установлен тип калибровки. Перед началом процедуры калибровки укажите тип калибровки.

EventID: E8020260 (hex)

Сообщение: 609

"Требуемая функция калибровки не реализована."

Пояснение: Для указанного типа калибровки возможны варианты. Например, для калибровки частотной неравномерности необходима одна калибровочная мера, для 1-портовой калибровки - 3 меры, для 2-портовой калибровки - 12 мер.

Предложения: Убедитесь в том, что проводятся измерения только по калибровочным мерам, необходимым для указанного типа калибровки.

EventID: E8020261 (hex)

Сообщение: 610

"Требуемый класс сбора данных для калибровки не действителен для выбранного типа калибровки, выберите другой тип сбора данных или другой тип калибровки."

EventID: E8020262 (hex)

Сообщение: 611

"Данные калибровочной меры, необходимой для выбранного типа калибровки, не обнаружены."

Серьезность: ошибка

Пояснение: Выполнена неудачная попытка по восстановлению данных указанной калибровочной меры из буфера необработанных измерений. В буфере должны находиться необработанные данные по калибровочным мерам, сохраненные во время процедуры калибровки.

Предложения: Убедитесь в том, что запрошенная мера необходима для текущего типа калибровки. Не все меры нужны для всех типов калибровок.

EventID: E8020263 (hex)

Сообщение: 612

" Не обнаружены данные по вектору ошибок, необходимые для выбранного типа калибровки."

Серьезность: ошибка

Пояснение: Выполнена неудачная попытка по восстановлению указанного вектора ошибок из буфера корректировки погрешности. В буфере должны находиться массивы корректировки погрешности для текущей калибровки.

Предложения: Убедитесь в том, что запрошенное условие погрешности необходимо для текущего типа калибровки. Не все условия погрешности нужны для всех типов калибровок.

EventID: E8020264 (hex)

Сообщение: 613

Не обнаружен набор данных калибровки.

Серьезность: ошибка

Пояснение: Выполнена неудачная попытка доступа к калибровочному комплекту. Это может означать, что калибровочный комплект удален или поврежден.

Предложения: Повторите попытку или выберите другой калибровочный комплект. Если калибровочный комплект появляется в списке калибровочных комплектов, возможно, его надо удалить.

EventID: E8020265 (hex)

Сообщение: 614

"Для указанного измерения отсутствует калибровка, действительная для проверки уровня доверительности. Выберите другое измерение или повторите процедуру, или проведите калибровку другого типа."

Серьезность: ошибка

Пояснение: Выбор измерения предотвращен, поэтому калибровка не будет отключена. Не все типы калибровок поддерживают все измерения. Например, 1-портовую калибровку для S11 нельзя применять для калибровки измерения S12. Если выбрано измерение, для которого не существует применимой калибровки, появляется информационное сообщение, и калибровка отключается.

Предложения: Используйте полную 2-портовую калибровку, совместимую с любым S-параметром.

EventID: E8020266 (hex)

Сообщение: 615

" Создан новый калибровочный комплект."

Серьезность: информационное сообщение.

Пояснение: Для вновь созданного калибровочного комплекта будет автоматически создано имя и проставлено время. Если это происходит в начале процедуры калибровки, калибровочный комплект не будет сохраняться в памяти до успешного завершения калибровки. Если калибровка будет отменена или неуспешно завершена, новый калибровочный комплект будет удален.

Предложения: информационное

EventID: 68020267

Сообщение: 617

Возможно, файл калибровочного комплекта: <x> поврежден и его невозможно удалить. Выйдите из приложения, удалите файл и перезапустите.

Серьезность: ошибка

Предложения: Файл калибровочного комплекта хранится в исходном каталоге приложения C:\Program Files\Agilent\Network Analyzer\PNACalSets.dat. Удалите этот файл и перезагрузите приложение.

EventID: E8020269 (hex)

Сообщение: 634

"Не выполнена загрузка файла калибровочного комплекта: <x>."

Серьезность: ошибка

Пояснение: В файле калибровочных комплектов находится набор комплектов. Файл расположен на жестком диске.

Предложения: Попытайтесь перезапустить приложение. Если сбои продолжаются, возможно, необходимо удалить данные калибровочного комплекта и перезапустить приложение. Файл калибровочного комплекта хранится в исходном каталоге приложения. C:\Program Files\Agilent\Network Analyzer\PNACalSets.dat. Удалите этот файл и перезапустите приложение.

EventID: E802027A (hex)

Сообщение: 635

"Не выполнено сохранение файла калибровочного комплекта: <x>."

Серьезность: ошибка

Пояснение: Ошибка операции с файлом. Операция сохранения прервана.

Предложения: Повторите попытку.

EventID: E802027B (hex)

Сообщение: 636

"Калибровочный комплект удален."

Серьезность: информационное

Пояснение: Один из калибровочных комплектов успешно удален из набора возможных калибровочных комплектов. Это могло произойти в результате требования пользователя или внутренней операции.

Предложения: нет

EventID: 6802027C (hex)

Сообщение: 637

"Версия файла калибровочного комплекта: <x> не совместима с текущим инструментом."

Серьезность: ошибка

Пояснение: Ошибка выбора версии может не допустить использования калибровочного комплекта. Это может происходить в результате обновлений инструмента.

Предложения: Если ошибка выбора версии - это результат обновления прошивки, необходимо переустановить старую версию прошивки для повторного использования файла калибровочного комплекта. Либо вновь создать калибровочные комплекты с текущей версией прошивки.

Файл калибровочного комплекта хранится в исходном каталоге приложения C:\Program Files\Agilent\Network Analyzer\PNACalSets.dat. Удалите этот файл и перезапустите приложение.

EventID: E802027D (hex)

Сообщение: 638

"Обнаружены несовместимые калибровочные комплекты: <x> из <y> загружены сохраненные калибровочные комплекты."

Серьезность: ошибка

Пояснение: Обнаружены ошибки в некоторых калибровочных комплектах, сохраненных в файле. Возможно, ошибки вызваны вопросами выбора версии, повредившими различные кнопки калибровочных комплектов.

Предложения: Используйте программу просмотра калибровочных комплектов для просмотра содержимого файлов. Удалите поврежденные файлы.

EventID: 6802027E (hex)

Сообщение: 639

"Не обнаружен файл калибровочного комплекта: <x>. Создан новый файл."

Серьезность: информационное

Пояснение: Файл калибровочного комплекта должен храниться на жестком диске. При запуске приложения проводится поиск и, если файл невозможно обнаружить, он загружается. Если файл не обнаружен, анализатор создаст новый файл и появится данное сообщение.

Предложения: нет

EventID: 6802027F (hex)

Сообщение: 640

"Указанный калибровочный комплект в данный момент используется."

Серьезность: ошибка

Пояснение: Это может означать конфликт из-за того, что несколько пользователей калибровочного комплекта пытаются выполнять калибровку.

Предложения: Сохраните инструментальное состояние. Предварительно настройте анализатор и повторно вызовите инструментальное состояние. Это может прервать выполняемые процессы.

EventID: E8020280 (hex)

Сообщение: 641

"Указанный калибровочный комплект не открыт."

Серьезность: ошибка

Пояснение: Возможно, несколько пользователей пытаются получить доступ к калибровочному комплекту.

Предложения: Отключите нескольких пользователей так, чтобы доступ к калибровочному комплекту имел только один пользователь.

EventID: E8020281 (hex)

Сообщение: 642

"Достигнуто максимальное количество калибровочных комплектов. Удалите старые или не используемые калибровочные комплекты перед попыткой создания новых."

Серьезность: ошибка

Предложения: Кроме того, вы можете удалить файл данных калибровочных комплектов.

Файл калибровочного комплекта хранится в исходном каталоге приложения. C:\Program Files\Agilent\Network_Analyzer\PNACalSets.dat. Удалите этот файл и перезапустите приложение.

EventID: E8020282 (hex)

Сообщение: 643

Не обнаружен требуемый сегмент таблицы потерь мощности.

Серьезность: ошибка

EventID: E8020283 (hex)

Сообщение: 644

"Перед включением коррекции необходима действительная калибровка."

Серьезность: ошибка

Пояснение: Обычно это указывает на то, что процедура калибровки не завершена, либо для выбранного измерения отсутствует действительная калибровка для текущего калибровочного комплекта.

Предложения: Для поиска калибровки можно выбрать Cal Set, где находятся калибровки, необходимые для текущих измерений. Эта ошибка может появляться, если перед попыткой программного выполнения калибровки не указан ее тип. Укажите тип калибровки перед началом процедуры калибровки.

EventID: E8020284 (hex)

Сообщение: 645

Данные калибровки для <x> несовместимы и не восстановлены. Повторите калибровку."

Серьезность: предупреждение

Пояснение: нет

Предложения: нет

EventID: A8020285 (hex)

Сообщение: 646

"Калибровочный комплект не загружен, слишком новая версия."

Серьезность: ошибка

Пояснение: Попытка работы старой версии прошивки с новой версией калибровочного комплекта. Версии несовместимы.

Предложения: Калибровочный комплект можно удалить. Кроме того, можно удалить файл калибровочных комплектов, если вы часто меняете версии прошивок и хотите избежать появления данной ошибки. Файл калибровочного комплекта хранится в исходном каталоге приложения. C:\Program Files\Agilent\Network Analyzer\PNACalSets.dat. Удалите этот файл и перезапустите приложение.

EventID: E8020286 (hex)

Сообщение: 647

"Не обнаружен пользовательский тип калибровки."

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E8020287 (hex)

Сообщение: 648

"Пользовательский алгоритм корректировки задерживает интерполяцию."

Серьезность: информационное

EventID: 68020288 (hex)

Сообщение: 649

"Пользовательская калибровка dll составляет исключение."

Серьезность: ошибка

EventID: E8020289 (hex)

Сообщение: 650

"Невозможно загрузить библиотеку ecal.dll"

Серьезность: ошибка

EventID: E802028A (hex)

Сообщение: 656

"Указанный аргумент - не действительный тип калибровки."

Серьезность: ошибка

EventID: E8020290 (hex)

Сообщение: 657

"Функция обнаружила существующие интерполированные данные"

Серьезность: информационное

EventID: 68020291 (hex)

Сообщение: 658

"Функция вычислила новые значения интерполяции."

Серьезность: информационное

EventID: 68020292 (hex)

Сообщение: 659

"Сбой при измерении на источнике питания."

Серьезность: ошибка

Предложения: Проверьте GPIB, настройки ваттметра и подключение датчика.

EventID: E8020293 (hex)

Сообщение: 660

"Обнаружен дублирующий сеанс. Закройте сеанс и повторите попытку."

Серьезность: ошибка

EventID: E8020294 (hex)

Сообщение: 661

"Сеанс не существует. Откройте сеанс и повторите попытку."

Серьезность: ошибка

Пояснение:

EventID: E8020295 (hex)

Сообщение: 662

"Неудачная попытка запуска пользовательской калибровки."

Серьезность: ошибка

Пояснение:

EventID: E8020296 (hex)

Сообщение: 663

"Зарос на измерение по калибровочной мере не выполнен."

Серьезность: ошибка

Пояснение: Убедитесь, что дан запрос на измерения по калибровочным мерам, определенным для данной калибровки.

EventID: E8020297 (hex)

Сообщение: 664

"Поскольку выбран Комплект электронной калибровки, нельзя менять параметр Комплекта механической калибровки."

Серьезность: ошибка

Пояснение:

EventID: E8020298 (hex)

Сообщение: 665

"Частоты активного канала ниже минимальных или превышают максимальные частоты модуля Ecal, заданные при производстве."

Предложения: Измените частоты канала или выберите другой модуль ECal.

Серьезность: ошибка

EventID: E8020299 (hex)

Сообщение: 666

"В калибровочном комплекте, выбранном для характеризации портов %1 модуля ECal отсутствует калибровка для портов %2 PNA."

Серьезность: ошибка

Предложения: Вернитесь для выбора другого калибровочного комплекта или для выполнения другой калибровки.

EventID: E802029A (hex)

Сообщение: 667

"В модуле ECal достаточно памяти только для сохранения максимум %1 точек в Характеризации пользователя %2."

Серьезность: ошибка

Предложения: Уменьшите количество точек или перезапишите другую характеризацию пользователя.

EventID: E802029B (hex)

Сообщение: 668

Входящие значения не монотонны. Невозможно интерполировать.

Серьезность: ошибка

EventID: E802029C (hex)

Сообщение: 669

Цель интерполирования выходит за пределы диапазона. Невозможно интерполировать.

Серьезность: ошибка

EventID: E802029D (hex)

Сообщение: 670

Ошибка управляемой калибровки: <>

Серьезность: ошибка

EventID: E802029E (hex)

Сообщение: 671

Необходимо инициализировать первое обращение к интерфейсу управляемой калибровки.

Серьезность: ошибка

EventID: E802029F (hex)

Сообщение: 672

Выбранный метод калибровки типа thru не распознан.

Серьезность: ошибка

EventID: E80202A0 (hex)

Сообщение: 673

Невозможно генерировать вектор ошибок.

Серьезность: ошибка

EventID: E80202A1 (hex)

Сообщение: 674

Управляемую калибровку необходимо проводить на активном канале

Серьезность: ошибка

EventID: E80202A2 (hex)

Сообщение: 675

Нельзя начинать использовать шаги калибровки до успешного вызова генерирования шагов.

Серьезность: ошибка

EventID: E80202A3 (hex)

Сообщение: 676

Заданный номер шага выходит за пределы диапазона. Номера шагов должны находиться между 1 и количеством шагов. 0 - это недопустимый номер шага.

Серьезность: ошибка

EventID: E80202A4 (hex)

Сообщение: 677

Выбран калибровочный комплект для канала: <n> без восстановления входного сигнала.

Серьезность: информационное

EventID: 680202A5 (hex)

Сообщение: 678

Выбран калибровочный комплект для канала: <n> с восстановлением входного сигнала.

Серьезность: информационное

EventID: 680202A6 (hex)

Сообщение: 679

Входной сигнал выбранного калибровочного комплекта нельзя применить к каналу.

Серьезность: информационное

EventID: 680202A7 (hex)

Сообщение: 680

Попытка измерить мощность при частоте, выходящей за пределы частотного диапазона, определенного для указанного датчика мощности. Выберите другой датчик или отрегулируйте диапазон этого датчика.

Серьезность: ошибка

EventID: E80202A8 (hex)

Сообщение: 681

Указанная частота выходит за предел частотного диапазона, определенного для ваттметров.

Серьезность: ошибка

EventID: E80202A9 (hex)

Сообщение: 682

Для калибровки по всему частотному диапазону, где проводятся текущие измерения, необходимы дополнительные калибровочные меры.

Серьезность: информационное

EventID: 680202AA (hex)

Сообщение: 683

PNA не преобразовал калибровочные комплекты для использования при не управляемой калибровке. Рекомендуемое действие - восстановить заданные по умолчанию значения Cal Kit.

Серьезность: ошибка

EventID: E80202AB (hex)

Сообщение: 684

PNA не преобразовал калибровочные комплекты для использования при не управляемой калибровке. Восстановлены заданные по умолчанию значения Cal Kit.

Серьезность: ошибка

EventID: E80202AC (hex)

Сообщение: 685

Ваттметр занят выполняемым процессом калибровки источника питания.

Серьезность: ошибка

EventID: E80202AD (hex)

Сообщение: 686

Калибровка источника питания не выполнена или загружена для определенного канала и порта источника.

Серьезность: ошибка

EventID: E80202AE (hex)

Сообщение: 687

Размер массива данных калибровки источника питания для указанного канала и порта источника не согласуется с количеством точек соответствующего входного сигнала.

Серьезность: ошибка

EventID: E80202AF (hex)

Сообщение: 688

Калибровка порта <n> источника питания на канале <n> отключена, так как массива корректировки больше не существует.

Серьезность: ошибка

EventID: E80202B0 (hex)

Сообщение: 689

Данную команду можно использовать только с измерением, созданным с указанным портом загрузки калибровки.

Серьезность: ошибка

EventID: E80202B1 (hex)

Сообщение: 690

Интерполяция отключена, и вы изменили настройки входного сигнала оригинальной корректировки, поэтому корректировка отключена.

Серьезность: ошибка

EventID: E80202B2 (hex)

Сообщение: 691

Настройки входного сигнала текущего инструментального состояния превышают параметры оригинальной калибровки, поэтому корректировка отключена.

Серьезность: ошибка

EventID: E80202B3 (hex)

Сообщение: 692

Фиксация: невозможно прочесть требуемый файл S2P. Возможно, проблема форматирования.

Серьезность: ошибка

EventID: E80202B4 (hex)

Сообщение: 693

Фиксация: невозможно открыть требуемый файл S2P.

Серьезность: ошибка

EventID: E80202B5 (hex)

Сообщение: 694

Фиксация: невозможно интерполировать требуемый файл S2P. Обычно это происходит из-за того, что частотный диапазон в файле - это подмножество текущего частотного диапазона канала.

Серьезность: ошибка

EventID: E80202B6 (hex)

Сообщение: 696

Фиксация: невозможно включить с Калибровкой частотной неравномерности, отключено.

Серьезность: ошибка

EventID: E80202B8 (hex)

Сообщение: 697

Невозможно выполнить выбранную калибровку для данного измерения.

Серьезность: ошибка

EventID: E80202B9 (hex)

Сообщение: 698

Сглаживание: Необходимо вызвать RemoveAllConnectors() до вызова AddConnector после попытки сглаживания.

Серьезность: ошибка

EventID: E80202BA (hex)

Сообщение: 699

Попытка получить данные калибровки до надлежащей инициализации системы.

Серьезность: ошибка

EventID: E80202BB (hex)

Сообщение: 700

Используйте IGuidedCalibration для калибровок многопортового типа.

Серьезность: ошибка

EventID: E80202BC (hex)

Сообщение: 701

Для управляемой калибровки необходимо, чтобы количество путей измерений по перемычке было как минимум равно количеству портов калибровки минус 1.

Серьезность: ошибка

EventID: E80202BD (hex)

Сообщение: 702

Указан путь перемычки с портом, не включенным в калибровку.

Серьезность: ошибка

EventID: E80202BE (hex)

Сообщение: 703

В наборе указанных путей перемычки не обнаружен один или более портов для калибровки.

Серьезность: ошибка

EventID: E80202BF (hex)

Ошибки оборудования

Сообщение: 770

Слишком большая входная мощность. Источник питания отключен.

Серьезность: предупреждение

EventID: A8030302 (hex)

Сообщение: 771

Источник питания восстановлен.

Серьезность: информационное

EventID: 68030303 (hex)

Сообщение: 772

"Драйвер spampnp.sys не действует. Проверьте аппаратное обеспечение системы. ! Данные будут симулированы. !"

Серьезность: ошибка

Пояснение: Приложение сетевого анализатора не может обнаружить панель DSP. Возможна неисправность аппаратуры или драйвера. Кроме того, это происходит при попытке запустить сетевой анализатор на рабочей станции.

EventID: E8030304 (hex)

Сообщение: 773

"Серийная шина прибора не действует."

Серьезность: ошибка

Пояснение: Возможно, в EEPROM инструмента находятся все единицы или все нули. Сбой серийной шины оборудования не допускает чтения EEPROM.

EventID: E8030305 (hex)

Сообщение: 848

"Утеряна фазовая синхронизация"

Серьезность: ошибка

Пояснение: Невозможна соответствующая блокировка источника прибора. Возможно, из-за неисправности аппаратуры, неудачной калибровки или некачественных значений EEPROM.

Предложения: Выполните калибровку источника. Нажмите System / Service / Adjustments / Source Calibration

EventID: E8030350 (hex)

Сообщение: 849

Синхронизация фазы восстановлена.

Серьезность: успешно

EventID: 0x28030351 (hex)

Сообщение: 850

"Неизвестная ошибка аппаратного оборудования."

Серьезность: ошибка

Пояснение: Неисправность аппаратуры не дает возможности связи с DSP.

EventID: E8030352 (hex)

Сообщение: 851

Утеряна связь с DSP.

Серьезность: ошибка

EventID: E8030353 (hex)

Сообщение: 852

Мощность РЧ отключена.

Серьезность: ошибка

EventID: E8030354 (hex)

Сообщение: 853

Мощность РЧ включена.

Серьезность: успешно

EventID: 28030355 (hex)

Сообщение: 854

Аппаратное обеспечение в порядке.

Серьезность: успешно

EventID: 28030356 (hex)

Сообщение: 855

"Не отрегулирован уровень источника."

Серьезность: ошибка

Пояснение: Не отрегулирован уровень источника при необходимой мощности. Обозначенная мощность может быть не точной.

Предложения: Попробуйте другой уровень мощности. Если проблемы продолжаются, проведите повторную калибровку источника.

EventID: E8030357 (hex)

Сообщение: 856

Источник отрегулирован.

Серьезность: успешно

EventID: 28030358 (hex)

Сообщение: 857

Перенапряжение на входе.

Серьезность: ошибка

EventID: E8030359 (hex)

Сообщение: 858

Перенапряжение на входе устранено.

Серьезность: успешно

EventID: 2803035A (hex)

Сообщение: 859

"Сбой калибровки Yig."

Серьезность: ошибка

Пояснение: Сбой внутренней самокалибровки настройки генератора YIG.

EventID: E803035B (hex)

Сообщение: 860

Выполнена калибровка Yig.

Серьезность: успешно

EventID: 2803035C (hex)

Сообщение: 861

"Сбой калибровки аналогового линейно изменяющегося сигнала."

Серьезность: ошибка

Пояснение: Сбой внутреннего аналогового свипирования калибровки линейно изменяющегося сигнала.

EventID: E803035D (hex)

Сообщение: 862

Аналоговый линейно изменяющийся сигнал калиброван.

Серьезность: успешно

EventID: 2803035E (hex)

Сообщение: 863

Повышена температура источника.

Серьезность: ошибка

EventID: E803035F (hex)

Сообщение: 864

Температура источника нормальная.

Серьезность: успешно

EventID: 28030360 (hex)

Сообщение: 865

"Сбой записи в EEPROM."

Серьезность: ошибка

Пояснение: Неудачная попытка сохранения данных калибровки в EEPROM. Возможно, сбой аппаратуры.

EventID: E8030361 (hex)

Сообщение: 866

Выполнена запись в EEPROM.

Серьезность: успешно

EventID: 28030362 (hex)

Сообщение: 867

Попытка записи , но порт установлен только на чтение.

Серьезность: ошибка

Пояснение: Попытка записи в порт ввода/вывода, но порт установлен только на ввод/чтение.

Предложения: Перед попыткой записи в порт установите порт данных на запись/вывод.

EventID: E8030363 (hex)

Сообщение: 868

" Попытка чтения с порта, установленного только на запись.

Серьезность: ошибка

Пояснение: Попытка чтения с порта ввода/вывода данных, но порт установлен только на вывод/запись.

Предложения: Перед попыткой чтения с порта установите порт данных на чтение/ввод.

EventID: E8030364 (hex)

Сообщение: 869

Неправильный идентификатор элемента аппаратного обеспечения.

Серьезность: ошибка

EventID: E8030365 (hex)

Сообщение: 870

Неправильно установлен уровень усиления.

Серьезность: ошибка

EventID: E8030366 (hex)

Сообщение: 871

Драйверу устройства не удалось выделить достаточно памяти. Попробуйте перезагрузиться.

Серьезность: ошибка

EventID: E8030367 (hex)

Сообщение: 872

Ошибка DSP. Свяжитесь со службой поддержки Agilent. Техническая информация: DSP, тип 1

Серьезность: ошибка

EventID: E8030368 (hex)

Сообщение: 873

Ошибка DSP. Свяжитесь со службой поддержки Agilent. Техническая информация: DSP, тип 2

Серьезность: ошибка

EventID: E8030369 (hex)

Сообщение: 874

Ошибка DSP. Свяжитесь со службой поддержки Agilent. Техническая информация: DSP, тип 3

Серьезность: ошибка

EventID: E803036A (hex)

Сообщение: 875

Ошибка DSP. Свяжитесь со службой поддержки Agilent. Техническая информация: DSP, тип 4

Серьезность: ошибка

EventID: E803036B (hex)

Сообщение: 876

Ошибка DSP. Свяжитесь со службой поддержки Agilent. Техническая информация: DSP, тип 5

Серьезность: ошибка

EventID: E803036C (hex)

Сообщение: 910

Прошивка не распознает аргумент подключения триггера, как допустимый.

Серьезность: ошибка

EventID: 0xE803038E (hex)

Сообщение: 911

Указанное подключение триггера не поддерживает такое поведение триггера

Серьезность: ошибка

EventID: E803038F (hex)

Сообщение: 912

Прошивка не распознает поведение триггера, как допустимое.

Серьезность: ошибка

EventID: E8030390 (hex)

Сообщение: 913

Указанное подключение триггера физически не существует в данном сетевом анализаторе

Серьезность: ошибка

EventID: E8030391 (hex)

Сообщение: 914

Невозможно установить "Принять триггер перед установкой", поскольку данная конфигурация аппаратуры не поддерживает краевое триггерное действие.

Серьезность: ошибка

EventID: E8030392 (hex)

Сообщение: 915

Невозможно установить "Включен вывод триггера", поскольку данная конфигурация аппаратуры не поддерживает BNC2.

Серьезность: ошибка

EventID: E8030393 (hex)

Сообщение: 916

Превышена максимальная задержка триггера.

Серьезность: ошибка

EventID: E8030394 (hex)

Сообщение: 917

Превышена минимальная задержка триггера.

Серьезность: ошибка

EventID: E8030395 (hex)

Ошибки измерения

Сообщение: 1024

Для того чтобы отобразить график из памяти или использовать его другим образом, сначала данные графика надо сохранить в память.

Серьезность: предупреждение

EventID: A8040400 (hex)

Сообщение: 1025

"Сбой правильного прекращения измерения. Приложение повреждено, его надо закрыть и перезапустить."

Серьезность: ошибка

Пояснение: Данное сообщение появляется при повреждении приложения PNA. Если появление ошибки продолжается, свяжитесь со службой поддержки

EventID: E8040401 (hex)

Сообщение: 1026

Сбой правильного прекращения измерения. Ненадлежащий выход из потока данных.

Серьезность: предупреждение

EventID: A8040402 (hex)

Сообщение: 1027

"Формат групповой задержки со временем CW, либо свипирования мощности подают ошибочные данные."

Серьезность: предупреждение

Пояснение: Формат групповой задержки несовместим с одночастотными свипированиями. Подаются ошибочные данные.

Предложения: Игнорируйте данные, выберите другой формат или тип свипирования.

EventID: A8040403 (hex)

Сообщение: 1028

Серьезность: информационное

"MSG_LIMIT_FAILED"

Пояснение: Сбой теста ограничительной линии.

EventID: 68040404 (hex)

Сообщение: 1029

Серьезность: информационное

"MSG_LIMIT_PASSED"

Пояснение: Тест ограничительной линии выполнен.

EventID: 68040405 (hex)

Сообщение: 1030

"Превышено максимальное допустимое количество измерений."

Серьезность: предупреждение

Пояснение: Смотрите в Графики, каналы и окна для PNA информацию о максимальном количестве измерений.

EventID: A8040406 (hex)

Сообщение: 1031

"Внутренняя ошибка сетевого анализатора. Непредвиденная ошибка в AddNewMeasurement."

Серьезность: предупреждение

Пояснение: Если продолжается появление данного сообщения, свяжитесь со службой поддержки.

EventID: A8040407 (hex)

Сообщение: 1032

"Не обнаружено измерение для выполнения выбранной информации. Операция не выполнена."

Серьезность: предупреждение

Пояснение: нет

Предложения: Создайте измерение перед выполнением данной операции.

EventID: A8040408 (hex)

Сообщение: 1033

Сбой команды Markers All Off (Отключение всех маркеров).

Серьезность: предупреждение

EventID: A8040409 (hex)

Сообщение: 1034

"Выбранный график не сохранен в памяти. Перед началом математических операций с графиком сохраните его в памяти."

Серьезность: предупреждение

Пояснение: Перед началом Trace Math (Обработка графика) график должен быть сохранен в памяти,

EventID: A804040A (hex)

Сообщение: 1035

"MSG_SET_AVERAGE_COMPLETE"

Серьезность: информационное

Пояснение: Информация для COM программирования. Достигнуто значение коэффициента усреднения.

EventID: 6804040B (hex)

Сообщение: 1036

"MSG_CLEAR_AVERAGE_COMPLETE"

Пояснение: Информация для COM программирования. НЕ достигнуто значение коэффициента усреднения.

EventID: 6804040C (hex)

Сообщение: 1037

"Для преобразования временного интервала необходимо как минимум 3 точки ввода. Преобразование отключено."

Серьезность: информационное

Пояснение: нет

Предложения: Увеличить количество точек.

EventID: 6804040D (hex)

Сообщение: 1038

Для сглаживания необходим скалярный формат, отключено.

Серьезность: информационное

EventID: 6804040E (hex)

Сообщение: 1039

Для данной версии прошивки невозможно вызвать калибровку мощности приемника.

Серьезность: предупреждение

EventID: A804040F (hex)

Сообщение: 1104

"Превышено ограничение количества измерений."

Серьезность: ошибка

Пояснение: За информацией об ограничениях для измерений обращайтесь к Графики, каналы и окна для PNA.

EventID: E8040450 (hex)

Сообщение: 1105

"Недопустимый параметр."

Серьезность: ошибка

Пояснение: Недопустимый параметр измерения, введенный программно.

EventID: E8040451 (hex)

Сообщение: 1106

"Измерение не обнаружено."

Серьезность: ошибка

Пояснение: Возможна любая из указанных причин:

Попытка калибровки, но уже достигнуто максимальное количество измерений.

Попытка провести проверку доверительности, но измерение отсутствует.

Попытка создать, активировать или отменить измерение через COM, удаленный с передней панели.

Попытка ввести не уникальное имя графика программным путем.

EventID: E8040452 (hex)

Сообщение: 1107

"Отсутствие допустимого графика в памяти."

Серьезность: ошибка

Пояснение: Перед началом выполнения Trace Math график должен находиться в памяти,

Предложения: Сохранить график в памяти.

EventID: E8040453 (hex)

Сообщение: 1108

"Не обнаружен опорный маркер."

Серьезность: ошибка

Пояснение: Попытка создать дельта маркер без предварительного создания опорного маркера (только COM).

EventID: E8040454 (hex)

Сообщение: 1109

"Графики данных и памяти больше не совместимы. Операция Trace Math отключена."

Серьезность: ошибка

Пояснение: предупреждение - настройка канала изменена при выполнении математической обработки графика.

Предложения: Сохраните другой график в памяти и снова включите обработку графика.

EventID: A8040455 (hex)

Сообщение: 1110

"Графики данных и памяти не совместимы. Для действительности математической обработки графика для графиков данных и графиков в памяти должны быть установлены одинаковые условия измерения."

Серьезность: ошибка

Пояснение: Попытка провести математическую обработку графика без совместимости графиков данных и памяти.

Предложения: Сохраните другой график памяти.

EventID: E8040456 (hex)

Сообщение: 1111

"Не обнаружен маркер полосы пропускания."

Серьезность: ошибка

Пояснение: Невозможно найти часть графика, соответствующую указанному критерию полосы пропускания.

EventID: E8040457 (hex)

Сообщение: 1112

"Пик не обнаружен."

Серьезность: ошибка

Пояснение: Невозможно найти часть графика, соответствующую указанному критерию пика.

Предложения: Смотрите Критерий маркера пика.

EventID: E8040458 (hex)

Сообщение: 1113

"Не обнаружено целевое значение поиска."

Серьезность: ошибка

Пояснение: Невозможно найти точку интерполированных данных, соответствующую значению поиска.

EventID: E8040459 (hex)

Сообщение: 1114

"Для измерения отражения, например S11, нужен вспомогательный порт для устранения неоднозначности 2-портовых измерений на многопортовых приборах."

Серьезность: ошибка

Пояснение:

EventID: E804045A (hex)

Сообщение: 1115

"Калибровка мощности приемника отключена, так как изменен тип измерения или порт источника, поэтому калибровка больше не действительна."

Серьезность: предупреждение

Пояснение:

EventID: A804045B (hex)

Сообщение: 1116

"Для калибровки мощности необходимо, чтобы активное измерение было измерением абсолютной мощности."

Серьезность: предупреждение

Пояснение:

EventID: A804045C (hex)

Сообщение: 1117

"В данный момент отсутствует калибровка мощности источника, связанная с каналом и портом источника активного измерения. До выполнения калибровки мощности приемника необходимо провести калибровку мощности источника или вызвать ее повторно."

Серьезность: предупреждение

Пояснение:

EventID: A804045D (hex)

Сообщение: 1118

"Операцию можно выполнять только при стандартном типе измерения."

Серьезность: ошибка

Пояснение:

EventID: E804045E (hex)

Сообщение: 1119

"Невозможно загрузить пользовательское измерение, так как оно не совместимо с аппаратным обеспечением сетевого анализатора."

Серьезность: ошибка

Пояснение:

Предложения:

EventID: E804045F (hex)

Сообщение: 1120

"Невозможно загрузить пользовательское измерение, так как оно не совместимо с программным обеспечением сетевого анализатора."

Серьезность: ошибка

Пояснение:

EventID: E8040460 (hex)

Сообщение: 1121

"Не выполнена операция загрузки пользовательского измерения по не определенной причине."

Серьезность: ошибка

Пояснение:

EventID: E8040461 (hex)

Сообщение: 1122

"Процесс обработки данных пользовательского измерения сгенерировал не обрабатываемое исключение и будет прерван. Возможно, программное обеспечение PNA в нестабильном состоянии, рекомендуется закрыть программное обеспечение PNA и перезагрузить."

Серьезность: ошибка

Пояснение:

EventID: E8040462 (hex)

Сообщение: 1123

"Операцию можно выполнить только с измерением пользовательского типа."

Серьезность: ошибка

Пояснение:

EventID: E8040463 (hex)

Сообщение: 1124

"Запрошенное пользовательское измерение не доступно."

Серьезность: ошибка

Пояснение:

EventID: E8040464 (hex)

Сообщение: 1125

"Запрошенный пользовательский алгоритм не обнаружен."

Серьезность: ошибка

Пояснение:

EventID: E8040465 (hex)

Сообщение: 1126

"Невозможно включить нормализацию, так как для измерения отсутствует допустимый буфер делителя."

Серьезность: ошибка

Пояснение:

EventID: E8040466 (hex)

Сообщение: 1127

"Невозможно предоставить необработанные данные, запрошенные измерением."

Серьезность: предупреждение

Пояснение:

EventID: A8040467 (hex)

Сообщение: 1128

"Выбранный тип свипирования не допускает преобразования и временную селекцию. Преобразование и временная селекция отключены. "

Серьезность: ошибка

Пояснение:

EventID: E8040468 (hex)

Сообщение: 1129

График памяти невозможно применить к данному измерению

Серьезность: ошибка

EventID: E8040469 (hex)

Сообщение: 1130

Нормализацию невозможно применить к данному измерению

Серьезность: ошибка

EventID: E804046A (hex)

Сообщение: 1131

В предоставленных данных ошибочное количество точек. Сохранение невозможно

Серьезность: ошибка

EventID: E804046B (hex)

Сообщение: 1132

В состоянии сохранение/повторный вызов сохранена ошибочная версия измерения. Загрузка невозможна

Серьезность: ошибка

EventID: E804046C (hex)

Сообщение: 1133

Для данной операции аргумент должен иметь формат данных - "naDataFormat_Polar"

Серьезность: ошибка

EventID: E804046D (hex)

Сообщение: 1134

Для данной операции аргумент должен иметь скалярный формат данных.

Серьезность: ошибка

EventID: E804046E (hex)

Сообщение: 1135

График памяти не допустим для текущей настройки измерения.

Серьезность: ошибка

EventID: E804046F (hex)

Сообщение: 1136

Данное измерение несовместимо с существующими измерениями на этом канале. Выберите другой канал.

Серьезность: ошибка

EventID: E8040470 (hex)

Сообщение: 1137

Корректировка расширения порта не доступна для измерений частоты смещения. Корректировка расширения порта отключена.

Серьезность: ошибка

EventID: E8040471 (hex)

Сообщение: 1138

Номера, назначаемые физическим портам для логических схем портов, должны быть уникальными.

Серьезность: ошибка

EventID: E8040472 (hex)

Ошибки синтаксического анализа

Сообщение: 1281

"Анализатору отправлена команда чтения без предварительного запроса данных соответствующей командой вывода. Отсутствуют данные в выходной очереди анализатора для удовлетворения запроса."

Серьезность: ошибка

EventID: 68050501 (hex)

Сообщение: 1282

"Перед тем, как анализатор сможет принять режим системного контроллера, необходимо удалить активный контроллер из шины, или контроллер должен освободить шину."

Серьезность: ошибка

EventID: E8050502(hex)

Сообщение: 1283

"Анализатор не получил передачи данных в полном объеме. Обычно это происходит в результате прерывания операции шины."

Серьезность: ошибка

EventID: E8050503 (hex)

Сообщение: 1284

"Изменен байт инструментального состояния."

Серьезность: информационное

EventID: 68050504 (hex)

Сообщение: 1285

"Полученная команда SCPI вызвала ошибку %1: "%2"."

Серьезность: информационное

EventID: 68050505 (hex)

Сообщение: 1286

"Сервер INET LAN запущен, как процесс номер %1."

Серьезность: информационное

EventID: 68050506 (hex)

Сообщение: 1360

"Не выполнена команда SCPI"

Серьезность: ошибка

EventID: E8050550 (hex)

Сообщение: 1361

" Устройство INET/LAN не доступно."

Серьезность: ошибка

EventID: E8050551 (hex)

Сообщение: 1362

"Не обнаружен драйвер INET/LAN. "

Серьезность: ошибка

EventID: E8050552 (hex)

Сообщение: 1363

"Не обнаружен драйвер INET/LAN."

Серьезность: ошибка

EventID: E8050553 (hex)

Сообщение: 1364

"Устройство INET/LAN не способно получить необходимые ресурсы. "

Серьезность: ошибка

EventID: E8050554 (hex)

Сообщение: 1365

"Устройство INET/LAN сгенерировало общую системную ошибку. "

Серьезность: ошибка

EventID: E8050555 (hex)

Сообщение: 1366

"Ошибочный адрес для устройства INET/LAN."

Серьезность: ошибка

EventID: E8050556 (hex)

Сообщение: 1367

"Не обнаружена библиотека INET I/O. "

Серьезность: ошибка

EventID: E8050557 (hex)

Сообщение: 1368

"Возникла ошибка в системе INET. "

Серьезность: ошибка

EventID: E8050558 (hex)

Сообщение: 1369

"Доступ к драйверу INET/LAN запрещен. "

Серьезность: ошибка

EventID: E8050559 (hex)

Сообщение: 1370

"Невозможно загрузить системное сообщение об ошибке dll."

Серьезность: ошибка

EventID: E805055A (hex)

Сообщение: 1371

"ErrorSystemMessage.dll не экспортирует необходимую функцию."

Серьезность: ошибка

EventID: E805055B (hex)

Сообщение: 1372

"Невозможно подключить пользовательскую библиотеку scpi"

Серьезность: ошибка

EventID: E805055C (hex)

Сообщение: 1373

"Невозможно подключить сообщения об ошибках scpi из библиотеки ErrorSystemMessage"

Серьезность: ошибка

EventID: E805055D (hex)

Сообщение: 1374

Устаревшая команда для данной версии программного обеспечения.

Серьезность: ошибка

EventID: E808055E (hex)

Сообщение: 1375

Вариант измерения CALC установлен на - нет. Используйте Calc:Par:Sel

Серьезность: ошибка

EventID: E808055F (hex)

Сообщение: 1535

"Синтаксический анализатор получил команду: %1."

Серьезность: информационное

EventID: 680505FF (hex)

Ошибки отображения 1536 - 1621

Сообщение: 1536

"Превышен максимум в 4 графика в каждом окне. График для <x> не будет добавлен в окно <x>."

Серьезность: предупреждение

Пояснение: нет

Предложения: Создайте график в другом окне. Смотрите Ограничения для окон PNA.

EventID: A8060600 (hex)

Сообщение: 1537

"Превышен максимум в 16 окон данных. Новое окно не будет создано."

Серьезность: предупреждение

Пояснение: нет

Предложения: Создайте график в существующем окне. Смотрите Ограничения для окон PNA.

EventID: A8060601 (hex)

Сообщение: 1538

"Отсутствуют окна данных. Невозможно завершить операцию."

Серьезность: предупреждение

Пояснение: Удаленная операция SCPI попыталась создать новое измерение при отсутствии окон

Предложения: Перед созданием нового измерения создайте новое окно. Смотрите пример Создание измерения с помощью SCPI

EventID: A8060602 (hex)

Сообщение: 1539

"В выбранном окне отсутствуют графики данных. Операция не завершена."

Серьезность: предупреждение

Пояснение: нет

EventID: A8060603 (hex)

Сообщение: 1540

"Невозможно выполнить запрос на размещение существующих измерений в окнах <x> из-за ограничения в <x> графиков в окне."

Серьезность: информационное

Пояснение: Функция размещения в окне не может поместить существующие графики в запрошенное количество окон, так как допускается только четыре графика в окне. Смотрите Размещение существующих измерений

Предложения: Создайте больше окон или удалите некоторые графики.

EventID: 68060604 (hex)

Сообщение: 1541

"Невозможно установить соединение с указанным принтером."

Серьезность: предупреждение

Пояснение: нет

Предложения: Обращайтесь к справочной информации о принтере

EventID: A8060605 (hex)

Сообщение: 1542

"Печать отменена."

Серьезность: информационное

EventID: 68060606 (hex)

Сообщение: 1616

"Окно не обнаружено."

Серьезность: ошибка

Пояснение: Указанное в вашей программе окно не существует.

Предложения: Запросите имя окна перед тем, как его указывать.

EventID: E8060650 (hex)

Сообщение: 1617

"Указан двойной ID окна."

Серьезность: ошибка

Пояснение: нет

EventID: E8060651 (hex)

Сообщение: 1618

"Превышено ограничение количества окон."

Серьезность: ошибка

Пояснение: Ограничение - 4 окна на экране.

EventID: E8060652 (hex)

Сообщение: 1619

"Превышено ограничение на количество графиков в окне."

Серьезность: ошибка

Пояснение: Существует ограничение в 4 графика на окно. Смотрите Графики, каналы и окна для PNA.

Предложения: Создайте график в другом окне

EventID: E8060653 (hex)

Сообщение: 1620

"График не обнаружен."

Серьезность: ошибка

Пояснение: Программа попыталась связаться с не существующим графиком.

Предложения: Запросите ID графика перед записью в него.

EventID: E8060654 (hex)

Сообщение: 1621

"Операционная система не распознает данный принтер."

Серьезность: предупреждение

EventID: A8060655 (hex)

Сообщение: 1622

Указан двойной ID графика.

Серьезность: ошибка

EventID: E8060656 (hex)

Ошибки канала 1792 -1878

Сообщение: 1792

"Свипирование завершено."

Серьезность: информационное

Пояснение: нет

Предложения: нет

EventID: 68070700 (hex)

Сообщение: 1793

"Все запущенные операции сбора данных завершены."

Серьезность: информационное

Пояснение:

EventID: 68070701 (hex)

Сообщение: 1794

"Последний триггер создал прерванное свипирование."

Серьезность: информационное

Пояснение:

EventID: 68070702 (hex)

Сообщение: 1795

"Для применения сегментированного свипирования необходимо отрегулировать список сегментов, чтобы в нем находился хотя бы один сегмент с более чем 0 точек."

Серьезность: информационное

Пояснение: Попытка изменения Тип свипирования для сегментированного свипирования, но заданные сегменты отсутствуют, либо в заданных сегментах нет точек свипирования

Предложения: Определите хотя бы один сегмент с одной точкой измерения как минимум. За дополнительной информацией обращайтесь к Сегментированное свипирование

EventID: 68070703 (hex)

Сообщение: 1796

"MSG_SET_CHANNEL_DIRTY"

Серьезность: информационное

Пояснение: Данное информационное сообщение появляется при изменении настройки канала при том, что канал еще использует данные, отобранные с предыдущей настройкой. Сообщение CLEAR появляется, когда отобраны новые данные для канала.

EventID: 68070704 (hex)

Сообщение: 1797

"MSG_CLEAR_CHANNEL_DIRTY"

Серьезность: информационное

Пояснение: Предыдущее сообщение SET появляется при изменении настройки канала при том, что канал еще использует данные, отобранные с предыдущей настройкой. Сообщение CLEAR появляется, когда отобраны новые данные для канала.

EventID: 68070705 (hex)

Сообщение: 1798

Время свипирования изменено с автоматического режима на ручной. При необходимости вернуться в автоматический режим введите значение 0 времени свипирования.

Серьезность: информационное

EventID: 68070706 (hex)

Сообщение: 1799

"Настройка свипирования завершена"

Серьезность: информационное

Пояснение: Данное событие возникает по завершении свипирования и соответствующих вычислений по свипированию. Обычно это происходит по завершению всех свипирований по каналу.

EventID: 68070707 (hex)

Сообщение: 1800

"Очистка свипирования завершена"

Серьезность: информационное

Пояснение: Данное событие происходит сразу же после события SET SWEEP COMPLETED. Оба события устанавливают и очищают бит "Свипирование завершено" (бит 4) регистра статуса устройства SCPI.

EventID: 68070708 (hex)

Сообщение: 1801

"Все свипирования завершены и обработаны"

Серьезность: информационное

Пояснение: Данное событие происходит после завершения всех свипирований и вычислений по свипированиям для канала.

EventID: 68070709 (hex)

Сообщение: 1802

Нижние частоты : изменены ограничения частоты.

Серьезность: информационное

EventID: 6807070A (hex)

Сообщение: 1803

Нижние частоты : изменено количество точек.

Серьезность: информационное

EventID: 6807070B (hex)

Сообщение: 1804

Нижние частоты : изменены ограничения частоты и количество точек.

Серьезность: информационное

EventID: 6807070C (hex)

Сообщение: 1872

"Канал не обнаружен."

Серьезность: ошибка

Пояснение: Ссылка на не существующий канал под программным управлением.

Предложения: Запросите номер канала, затем обращайтесь к нему по номеру.

EventID: E8070750 (hex)

Сообщение: 1873

"Не обнаружен запрошенный сегмент свипирования."

Серьезность: ошибка

Пояснение: Ссылка на не существующий сегмент свипирования под программным управлением.

EventID: E8070751 (hex)

Сообщение: 1874

"Список сегментов свипирования пуст."

Серьезность: ошибка

Пояснение: Невозможно указать сегментированное свипирование, если не будет задан хотя бы один сегмент. Такая ошибка может возникать только при дистанционном управлении.

EventID: E8070752 (hex)

Сообщение: 1875

"Количество точек в активном списке сегментированного свипирования равна 0."

Серьезность: ошибка

Пояснение: Невозможно указать сегментированное свипирование, если не будет задана хотя бы одна точка данных сегмента. Такая ошибка может возникать только при дистанционном управлении.

EventID: E8070753 (hex)

Сообщение: 1876

"Указанный аттенюатор-источник не допустим."

Серьезность: ошибка

Пояснение: Попытка установить свойства аттенюатора для объекта Канал PNA, не имеющего источника-аттенюатора.

EventID: E8070754 (hex)

Сообщение: 1877

"Невозможно выбрать логарифмическое свипирование частоты с текущим количеством точек. Уменьшите количество точек."

Серьезность: ошибка

Пояснение: Максимальное количество точек, допустимое для логарифмического свипирования - 401.

EventID: E8070755 (hex)

Сообщение: 1878

"Требуемое количество точек больше допустимого для логарифмического свипирования частоты."

Серьезность: ошибка

Пояснение: Максимальное количество точек, допустимое для логарифмического свипирования - 401.

EventID: E8070756 (hex)

Сообщение: 1879

"Частоты отклика превышают диапазон для прибора, поэтому смещение частоты отключено."

Серьезность: ошибка

Пояснение: Данная ошибка возвращается, если инструмент фиксирует, что результат расчета частот отклика для настройки свипирования входного сигнала и настроек смещения частоты, превышает ограничения для прибора. В таком случае прибор автоматически отключает смещение частоты, чтобы избежать ситуаций выхода за пределы диапазона.

Предложения: В такой ситуации измените настройки частот входного сигнала или смещения частоты так, чтобы частоты отклика входили в пределы для прибора. После этого можно снова включить смещение частоты.

EventID: E8070757 (hex)

Сообщение: 1880

Общее количество точек для всех заданных сегментов превосходит максимальное количество поддерживаемых точек. Сегменты не изменены.

Серьезность: ошибка

EventID: E8070758 (hex)

Сообщение: 1881

Данная копия объекта Каналы не использовалась для помещения каналов в режим удержания, поэтому работа с каналами не возобновилась.

Серьезность: ошибка

EventID: E8070759 (hex)

Сообщение: 1882

Номер порта выходит за пределы допустимого диапазона номеров портов.

Серьезность: ошибка

EventID: E807075A (hex)

Сообщение: 1883

Представлено больше портов, чем требуется для данной операции.

Серьезность: ошибка

EventID: E807075B (hex)

Общие ошибки

Сообщение: 2048

"Для запрошенной функции требуется возможность, которую предоставляет опция стандартного анализатора. Данная опция не установлена."

Серьезность: ошибка

Пояснение: нет

Предложения: Для просмотра опций анализатора нажмите Help \ About Network Analyzer. За дополнительной информацией обращайтесь к Опции PNA

EventID: 68080800 (hex)

Сообщение: 2049

"Запрашиваемая функция недоступна для данного прибора."

Серьезность: ошибка

Пояснение: нет

EventID: 68080801 (hex)

Сообщение: 2050

"Запрашиваемая функция несовместима с текущим инструментальным состоянием."

Серьезность: ошибка

Пояснение: нет

Предложения: нет

EventID: 68080802 (hex)

Сообщение: 2051

"Файл <x> сохранен."

Серьезность: информационное

Пояснение: нет

EventID: 68080803 (hex)

Сообщение: 2052

"Неудача попытки сохранить <x>."

Серьезность: ошибка

Пояснение: нет

Предложения: Если используется дискета, убедитесь в том, что она вставлена в дисковод и не переполнена. Проверьте наличие специальных символов в имени файла.

EventID: E8080804 (hex)

Сообщение: 2053

"Попытайтесь повторно вызвать файл, не вызванный из-за того, что не обнаружено <x>."

Серьезность: ошибка

Пояснение: нет

EventID: E8080805 (hex)

Сообщение: 2054

"Ошибочный заголовок <x>."

Серьезность: ошибка

Пояснение: нет

Предложения: Повторно скопируйте файл и / или удалите файл.

EventID: E8080806 (hex)

Сообщение: 2056

"Запрос на переход в состояние "спячки"."

Пояснение: нет

EventID: 68080808 (hex)

Сообщение: 2057

"Включение питания из автоматического состояния "спячки". Программа получила сообщение PBT_APMRESUMEAUTOMATIC."

Пояснение: нет

EventID: 68080809 (hex)

Сообщение: 2058

"Включение питания в режиме отложенного состояния "спячки". Программа получила сообщение PBT_APMRESUMESUSPEND."

Пояснение: нет

EventID: 6808080A (hex)

Сообщение: 2059

"Включение питания в режиме отложенного состояния "спячки". Программа получила сообщение PBT_APMRESUMECRITICAL."

Серьезность: предупреждение

Пояснение: нет

EventID: A808080B (hex)

Сообщение: 2060

"Включение питания при вызове восстановления UI в режиме неизвестного состояния "спячки". Программа не получила PBT_Message в течение выделенного времени и пытается провести восстановление."

Серьезность: предупреждение

Пояснение: нет

EventID: A808080C (hex)

Сообщение: 2061

"<x> уже существует. Файл перезаписывается."

Пояснение: Используется только для удаленных приложений

EventID: 6808080D (hex)

Сообщение: 2062

"Файл не сохранен."

Серьезность: ошибка

Пояснение: Используется только для удаленных приложений

EventID: E808080E (hex)

Сообщение: 2063

"Файл <x> вызван повторно."

Пояснение: Используется только для удаленных приложений

EventID: 6808080F (hex)

Сообщение: 2064

"Версия состояния в <x> считается устаревшей версией с таким кодом."

Серьезность: ошибка

Пояснение: Попытка повторно вызвать более не действительный файл.

Предложения: Необходимо повторно создать файл вручную.

EventID: E8080810 (hex)

Сообщение: 2065

"Версия состояния в <x> более новая, чем последняя версия, поддерживаемая данным кодом."

Серьезность: ошибка

Пояснение: Попытка повторно вызвать файл, созданный более новой версией приложения PNA.

Предложения: Необходимо повторно создать файл вручную.

EventID: E8080811 (hex)

Сообщение: 2066

"Ошибка при чтении файла <x>"

Серьезность: ошибка

Пояснение: Возможно, файл поврежден.

Предложения: Попытайтесь заново создать файл.

EventID: E8080812 (hex)

Сообщение: 2067

"Ошибка среды Windows: <x>"

Серьезность: ошибка

Пояснение: нет

EventID: E8080813 (hex)

Сообщение: 2068

Истекло время отправки сообщения, возврат: <x>.

Серьезность: ошибка

Пояснение: нет

EventID: E8080814 (hex)

Сообщение: 2069

"Изменение режима GPIB на Системный контроллер."

Серьезность: информационное

Пояснение: нет

EventID: 68080815 (hex)

Сообщение: 2070

"Изменение режима GPIB на Источник Приемник."

Серьезность: информационное

Пояснение: нет

EventID: 68080816 (hex)

Сообщение: 2071

"Сетевой анализатор невозможно перевести в режим Системный контроллер GPIB, пока установлено локальное состояние GPIB. Остановите все удаленные программы GPIB, которые, возможно, используют сетевой анализатор, нажмите кнопку Macro/Local и повторите попытку. "

Серьезность: информационное

Пояснение: Смотрите Операция LCL и RMT

Предложения: нажмите кнопку Macro/Local и повторите попытку.

EventID: 68080817 (hex)

Сообщение: 2120

"Данный метод невозможно осуществить через задержанный вызов COM."

Серьезность: ошибка

Пояснение: нет

Предложения: Используйте альтернативный метод, описанный в Документации по программированию COM

EventID: E8080878 (hex)

Сообщение: 2128

"Указанный формат не допустим."

Серьезность: ошибка

Пояснение: нет

EventID: E8080850 (hex)

Сообщение: 2129

"Исключение WINNT, зафиксированное уровнем автоматизации."

Серьезность: ошибка

Пояснение: нет

EventID: E8080851 (hex)

Сообщение: 2130

"Ошибочная спецификация порта."

Серьезность: ошибка

Пояснение: нет

EventID: E8080852 (hex)

Сообщение: 2131

"Не удалось найти принтер."

Серьезность: ошибка

Пояснение: нет

Предложения: Смотрите Подключение к принтеру

EventID: E8080853 (hex)

Сообщение: 2132

"Вызов вручную игнорирован."

Серьезность: ошибка

Пояснение: нет

EventID: E8080854 (hex)

Сообщение: 2133

"Неудача попытки установить триггер."

Серьезность: ошибка

Пояснение: нет

EventID: E8080855 (hex)

Сообщение: 2134

"Сбой выполнения макроса."

Серьезность: ошибка

Пояснение: нет

EventID: E8080856 (hex)

Сообщение: 2135

"Указанно не полное определение макроса."

Серьезность: ошибка

Пояснение:

EventID: E8080857 (hex)

Сообщение: 2137

"Ошибка длины блока данных."

Серьезность: ошибка

Пояснение: Смотрите Получение данных от анализатора

EventID: E8080859 (hex)

Сообщение: 2139

"Запрошенные данные не обнаружены."

Серьезность: ошибка

Пояснение: нет

EventID: E808085B (hex)

Сообщение: 2142

"Предоставленный параметр выходит за пределы диапазона, поэтому перед применением к прибору он ограничен до значения, входящего в диапазон."

Серьезность: успешно

Пояснение: нет

Предложения: Просмотрите ограничения диапазона перед отправкой программных команд.

EventID: 2808085E (hex)

Сообщение: 2143

Предоставленный параметр выходит за пределы диапазона, поэтому перед применением к прибору он ограничен до значения, входящего в диапазон.

Серьезность: ошибка

EventID: E808085F (hex)

Сообщение: 2144

"Запрос не выполнен. Не обнаружена требуемая лицензия."

Серьезность: ошибка

Пояснение: нет

EventID: E8080860 (hex)

Сообщение: 2145

"При удаленном обращении к передней панели возвращен результат <x>"

Серьезность: ошибка

Пояснение: Это может указывать на проблему с передней панелью

Предложения: Свяжитесь со службой технической поддержки

EventID: E8080861 (hex)

Сообщение: 2146

Операция повторного вызова не выполнена.

Серьезность: ошибка

Пояснение:

EventID: E8080862 (hex)

Сообщение: 2147

Неудача попытки сохранения файла.

Серьезность: ошибка

Пояснение:

EventID: E8080863 (hex)

Сообщение: 2148

Попытка повторного вызова файла не выполнена, так как файл не обнаружен.

Серьезность: ошибка

Пояснение:

EventID: E8080864 (hex)

Сообщение: 2149

Ошибочный заголовок вызываемого файла.

Серьезность: ошибка

Пояснение:

EventID: E8080865 (hex)

Сообщение: 2150

Версия вызываемого файла устарела и не совместима с данным прибором.

Серьезность: ошибка

Пояснение:

EventID: E8080866 (hex)

Сообщение: 2151

Версия вызываемого файла более новая, чем версия данного прибора. При удаленном обращении к передней панели возвращен результат %1

Серьезность: ошибка

Пояснение:

EventID: E8080867 (hex)

Сообщение 2152

"Передняя панель <x>

Серьезность: ошибка

Пояснение: нет

EventID: E8080868 (hex)

Сообщение 2153

"Сообщение передней панели"

Серьезность: информационное

Пояснение: нет

EventID: 68080869 (hex)

Сообщение 2154

"Система энергоснабжения <x>

Серьезность: ошибка

Пояснение: Работает более 1 экземпляра источника питания. Допустим только один. Это могло произойти после проведения экранирования, особенно при обновлении панели CPU.

Предложения: Попытайтесь перезагрузиться. Если проблема не устранена, свяжитесь со Службой поддержки клиентов.

EventID: E808086A (hex)

Сообщение 2155

"Система энергоснабжения <x>

Серьезность: информационное

Пояснение: нет

EventID: 6808086B (hex)

Сообщение 2156

"Невозможно загрузить или выгрузить драйвер Agilent Technologies GPIB."

Серьезность: ошибка

Пояснение: нет

Предложения: Если проблема не устранена, на рабочем столе PNA щелкните правой кнопкой мыши по My Computer. Нажмите Properties, затем - панель Hardware. Нажмите кнопку Device Manager. Разверните GPIB Devices. Щелкните правой кнопкой мыши и нажмите Uninstall all GPIB interfaces devices. Перезагрузите PNA.

EventID: E808086C (hex)

Сообщение 2157

"Невозможно загрузить или выгрузить драйвер National Instruments GPIB."

Серьезность: ошибка

Пояснение: нет

Предложения: Если проблема не устранена, на рабочем столе PNA щелкните правой кнопкой мыши по My Computer. Нажмите Properties, затем - панель Hardware. Нажмите кнопку Device Manager. Разверните GPIB Devices. Щелкните правой кнопкой мыши и нажмите Uninstall all GPIB interfaces devices. Перезагрузите PNA.

EventID: E808086D (hex)

Сообщение 2158

"Драйвер Agilent GPIB загружен, но не может запустить синтаксический анализатор."

Серьезность: ошибка

Пояснение: нет

EventID: E808086E (hex)

Сообщение: 2159

Передняя панель в дистанционном режиме.

Серьезность: предупреждение

EventID: A808086F (hex)

Сообщение: 2160

Невозможно обнаружить указанный ключ Registry.

Серьезность: ошибка

EventID: E8080870 (hex)

Сообщение: 2161

Зафиксированная ситуация перегрузки датчика, подключенного к передней панели.

Серьезность: предупреждение

EventID: A8080871 (hex)

Сообщение: 2162

Операция прекращена по времени.

Серьезность: ошибка

EventID: E8080872 (hex)

Сообщение 2163

"Сетевой анализатор выполнил заданную процедуру."

Серьезность: информационное

Пояснение: нет

EventID: 68080873 (hex)

Сообщение 2164

"Доступ к файлу запрещен."

Серьезность: ошибка

Пояснение: Это означает, что система не может открыть выходной файл для записи. Возможно, файл защищен от записи.

Предложения: Выберите другое имя файла в каталоге файлов, проверьте возможность записи для дискеты и жесткого диска.

EventID: E8080874 (hex)

Сообщение 2165

"Тип файла - структурированное хранение."

Серьезность: информационное

Пояснение: нет

EventID: 68080875 (hex)

Сообщение 2166

"Сбой операции триггера."

Серьезность: ошибка

Пояснение: нет

EventID: E8080876 (hex)

Сообщение 2167

"Ошибка - аргумент выходит за пределы диапазона."

Серьезность: ошибка

Пояснение: нет

Предложения: нет

EventID: E8080877 (hex)

Сообщение: 2169

Заданный объект COM не является пользовательским приложением

Серьезность: ошибка

EventID: E8080879 (hex)

Сообщение: 2170

Предоставленное eventID не распознано, как допустимое PNA eventID

Серьезность: ошибка

EventID: E808087A (hex)

Сообщение: 2171

Операция отменена.

Серьезность: ошибка

EventID: E808087B (hex)

Сообщение: 2172

Повышенный уровень безопасности невозможно отключить напрямую. Переустановить данный уровень безопасности можно только в предварительных настройках прибора или при повторном вызове инструментального состояния с пониженным уровнем безопасности.

Серьезность: ошибка

EventID: E808087C (hex)

Сообщение: 2173

Включен режим локальной блокировки. Приложение PNA не будет принимать информацию, вводимую с передней панели, клавиатуры или с помощью мыши до отключения этого режима через дистанционный интерфейс.

Серьезность: ошибка

EventID: E808087D (hex)

Сообщение: 2174

Запрос SnP не действителен для выбранного измерения.

Серьезность: ошибка

EventID: E808087E (hex)

Сообщение: 2175

Предварительные настройки не поддерживаются при открытом диалоговом окне помощника. Закройте диалог или помощника и повторите попытку.

Серьезность: ошибка

EventID: E808087F (hex)

Сообщение: 2176

Для запрашиваемой функции требуется возможность, предоставляемая опцией стандартного анализатора. Эта опция в данный момент не установлена.

Серьезность: ошибка

EventID: E8080880 (hex)

Сообщение: 2177

Неисправимая ошибка. Аварийный снимок памяти записан в <n>

Серьезность: ошибка

EventID: E8080881 (hex)

Сообщение: 2178

<n>

Серьезность: ошибка

EventID: E8080882 (hex)

Сообщение: 2179

Не удалось открыть gen.lic.

Серьезность: ошибка

EventID: E8080883 (hex)


Сообщения об ошибках

Ошибки PNA и операционной системы отображаются и записываются в файл журнала ошибок. Отображение ошибок PNA может быть настроено или вообще отключено.

  • Настройка отображения ошибок

  • Просмотр журнала ошибок

  • Список ошибок PNA

  • Ошибкм SCPI

Другие разделы справочного руководства

Error Preferences

По умолчанию сообщения об ошибках появляются на экране PNA на короткое время. Имеется возможность настроить отображение так, чтобы сообщения оставались на экране до нажатия кнопки ОК, а также полностью отключить вывод сообщений. Окно с сообщением об ошибке имеет кнопку Help для вызова подробной справочной информации.

Выбор настроек отображения ошибок

Для подробной информации см. интерфейс передней панели

Справка диалогового окна настроек отображения ошибок

Enable Messages Установите флажок для отображения всех ошибок PNA при их возникновении. Снимите флажок для отключения отображения ошибок. Ошибки в журнале ошибок можно просматривать независимо от этой опции.

Окна с сообщениями об ошибках калибровки

Timed Popups DОтображает сообщения на экране с продолжительностью, пропорциональной длине сообщения. После этого сообщение можно будет просмотреть только в журнале ошибок.

Confirmation Dialog boxes Сообщения об ошибках отображаются в стандартных диалоговых окнах. После этого диалоговое окно необходимо закрыть нажатием кнопки OK или Cancel, или нажать кнопку Help для получения более подробной информации об ошибке.

Просмотр журнала ошибок

Журнал ошибок PNA представляет собой список всех происшедших событий (события используются при программировании PNA с использованием COM.) Ошибки PNA являются подмножеством событий PNA. На экране PNA в реальном времени отображаются только события с кодом важности ERROR. При просмотре ошибок в журнале имеется возможность вызывать справку по конкретной ошибке, выбрав нужную ошибку и нажав кнопку Help.

Просмотр журнала ошибок

Для подробной информации см. интерфейс передней панели

Справка диалогового окна журнала ошибок (Error Log)

Network analyzer errors only Установите флажок для выбора только ошибок PNA. Снимите флажок для просмотра всех ошибок на данном компьютере.

Description Сообщение об ошибке, отображаемое на экране PNA.

A - Event ID номер сообщения об ошибке

B - Дата возникновения ошибки

C - время возникновения ошибки

D - Код важности – Все события имеют один из следующих кодов важности:

  • SUCcess - успешное завершение операции

  • INFormational - события, не влияющие на целостность измерений

  • WARning - события, при которых возможно нарушение целостности измерений

  • ERRor - события, при которых возможно серьезное нарушение целостности измерений

E - приложение, в котором произошла ошибка.

OK закрыть диалоговое окно

Help вызвать подробную информацию о выбранной ошибке

Очистка журнала ошибок:

  1. Из меню View выберите Minimize Application

  2. На рабочем столе нажмите Start, Settings, Control Panel

  3. На панели управления нажмите Administrative Tools

  4. В окне Administrative Tools нажмите Event Viewer

  5. В окне Event Viewer нажмите правой кнопкой Application Log

  6. Выберите Clear all Events

  7. Если требуется сохранить содержимое журнала в файл, нажмите Yes. В противном случае нажмите No

Восстановите приложение PNA, нажатием кнопки PNA Analyzer на панели задач


Аксессуары анализатора

  • Механический коаксиальный калибровочный инструмент

  • Механический волноводный калибровочный инструмент

  • Электронная калибровка (ECal)

  • Механический проверочный инструмент

  • Переходники и дополнительные наборы

  • Кабели для тестовых портов

  • Периферийные USB-устройства

  • Наборы для чистки коннекторов

  • Защита от электростатических разрядов

Другие разделы справочного руководства

Информация о продукции и заказах:

  • Тел. 1-800-452-4844 (8am-8pm EST)

  • Посетите сайт www.agilent.com/find/accessories
    Используйте функцию поиска по сайту для нахождения информации о нужном аксессуаре или просмотра всего каталога.

Аксессуары доступны для следующих типов коннекторов:

  • 50 Ом Type-N

  • 75 Ом Type-N

  • 3.5 мм

  • 7 мм (APC-7)

  • 7-16

  • 2.92 мм

  • 2.4 мм

  • 1.85 мм

  • 1 мм

Для полной системы измерений требуются кабели тестовых портов и инструментарий калибровки.

Инструментарий проверки используется для проверки характеристик скорректированной системы.

См. типы коннекторов для каждой модели PNA

Механический коаксиальный калибровочный инструмент

Модель | Тип коннектора | Верхняя граница частоты
85032B | Type-N (50 Ом) | 6 ГГц
85032F | Type-N (50 Ом) | 9 ГГц
85054B | Type-N (50 Ом) | 18 ГГц
85036E | Type-N (75 Ом) | 3 ГГц
85050B | 7 мм | 18 ГГц
85033D | 3.5 мм | 6 ГГц
85038A | 7-16 | 7.5 ГГц
85033E | 3.5 мм | 9 ГГц
85052B | 3.5 мм | 26.5 ГГц
85052C | 3.5 мм TRL | 26.5 ГГц
85056K | 2.92 мм | 50 ГГц
85056A | 2.4 мм | 50 ГГц
85058B/E (модель data-based) | 1.85 мм | 67 ГГц
85059A (модель data-based) | 1.00 мм | 110 ГГц

Механический волноводный калибровочный инструмент

Модель | Тип коннектора | Диапазон частот
X11644A | WR-90 | 8.2-12.4 ГГц
P11644A | WR-62 | 12.4-18 ГГц
K11644A | WR-42 | 18-26.5 ГГц
R11644A | WR-28 | 26.5-40 ГГц
Q11644A | WR-22 | 33-50 ГГц
U11644A | WR-19 | 40-60 ГГц
V11644A | WR-15 | 50-75 ГГц

Электронная калибровка (ECal)

Модель | Тип коннектора | Диапазон частот
Двухпортовый РЧ
85091C | 7 мм (APC-7) | 300 кГц-9 ГГц
85092C | Type-N (50 Ом) Порт B доступен с 3.5 мм или 7-16a | 300 кГц-9 ГГц
85093C | 3.5 мм Порт B доступен с Type-N (50 Ом) или 7-16a | 300 кГц-9 ГГц
85096C | Type-N (75 Ом) | 300 кГц-3 ГГц
85098C | 7-16a Порт B доступен с Type-N (50 Ом) или 3.5 мм | 300 кГц-7.5 ГГц
85099C | Type-F | 300 кГц-3 ГГц
Четырехпортовый РЧ
N4431A Option 010 | 3.5mm (f, гнездо) (четырехпортовый) | 300 кГц-9 ГГц
N4431A Option 020 | Type-N (f, гнездо) (четырехпортовый) | 300 кГц-9 ГГц
Двухпортовый микроволновый
N4690A | Type-N (50 Ом) | 10 МГц-18 ГГц
N4691A | 3.5 мм | 10 МГц-26.5 ГГц
N4692A | 2.92 мм | 10 МГц-40 ГГц
N4693A | 2.4 мм | 10 МГц-50 ГГц
N4694A | 1.85 мм | 10 МГц-67 ГГц
N4696A | 7 мм | 10 МГц-18 ГГц

a Limits ECal module high frequency to 7.5 ГГц.

Проверочные инструменты

Модель | Тип коннектора | Диапазон частот
85055A | Type-N (50 Ом) | 300 кГц-9 ГГц
85053B | 3.5 мм | 300 кГц-26.5 ГГц
85057B | 2.4 мм | .045-50 ГГц
R11645A | WR-28 | 26.5-40 ГГц
Q11645A | WR-22 | 33-50 ГГц

Переходники и дополнительные наборы

Модель | Описание
11878A | Переходник Type-N на 3.5 мм
11525A | Type-N (m, штекер) на 7 мм (APC-7)
11853A | Дополнительный набор Type-N
11900B | 2.4 мм (f, гнездо) на 2.4 мм (f, гнездо)
11900C | 2.4 мм (f, гнездо) на 2.4 мм (m, штекер)
85130G | Набор переходников для тестовых портов, 2.4 мм (f, гнездо) на 2.4 мм (m,f)
11901B | 2.4 мм (f, гнездо) на 3.5 мм (f, гнездо)
11901D | 2.4 мм (f, гнездо) на 3.5 мм (m, штекер)
85130F | Набор переходников для тестовых портов, 2.4 мм (f, гнездо) на 3.5 мм (m,f)
11902B | 2.4 мм (f, гнездо) на 7 мм (APC-7)
11920A | 1 мм (m, штекер) на 1 мм (m, штекер)
11920B | 1 мм (f, гнездо) на 1 мм (f, гнездо)
11920C | 1 мм (m, штекер) на 1 мм (f, гнездо)
11921A | 1 мм (m, штекер) на 1.85 мм (m, штекер)
11921B | 1 мм (f, гнездо) на 1.85 мм (f, гнездо)
11921C | 1 мм (m, штекер) на 1.85 мм (f, гнездо)
11921D | 1 мм (f, гнездо) на 1.85 мм (m, штекер)
11922A | 1 мм (m, штекер) на 2.4 мм (m, штекер)
11922B | 1 мм (f, гнездо) на 2.4 мм (f, гнездо)
11922C | 1 мм (m, штекер) на 2.4 мм (f, гнездо)
11922D | 1 мм (f, гнездо) на 2.4 мм (m, штекер)

Кабели для тестовых портов

Модель | Описание
N4697E | 1.85 мм (f, гнездо) на 1.85 мм (жесткий f) гибкий (один)
N4697F | 1.85 мм (жесткий f, f) на 1.85 мм (жесткий m, жесткий f) гибкий (набор)
N6315A | Type-N (m, штекер) на Type-N (f, гнездо), 16 дюймов (один)
N6314A | Type-N (m, штекер) на Type-N (m, штекер), 24 дюйма (один)
85133D | 2.4 мм (f, гнездо) на 2.4 мм (m,f) полужесткий (набор)
85133F | 2.4 мм (f, гнездо) на 2.4 мм (m,f) гибкий (набор)
85134D | 2.4 мм (f, гнездо) на 3.5 мм (m,f) полужесткий (набор)
85134F | 2.4 мм (f, гнездо) на 3.5 мм (m,f) гибкий (набор)

Периферийные USB-устройства

Модель | Описание
N4688A | Привод CD RW - с кабелем USB.
N4689A | 4-портовый хаб USB - для подключения дополнительных периферийных USB-устройств.
82357A | Интерфейс USB/GPIB - для управления устройствами GPIB через USB. Для подробной информации см. использование 82357A совместно с PNA

Наборы для чистки коннекторов

Номер детали | Описание
9301-1243 | Салфетки (маленькие), 100 шт.
8500-5344 | IPA 99.5% спирт, 30 мл.
8500-6659 | Сжатый воздух, 235 мл. баллончик
5021-7607 | Инструмент для удаления контактов типа N
1401-0225 | Стандартная заглушка типа N (m)
1401-0248 | Заглушка типа N (m) с защитой от электростатических разрядов
1401-0225 | Стандартная заглушка типа N (f)
1401-0247 | Заглушка типа N (f) с защитой от электростатических разрядов

Набор для защиты от электростатических разрядов

Номер детали | Описание
9300-1367 | Регулируемый антистатический браслет
9300-0980 | Кабель заземления для антистатического браслета (1,52 м)
9300-0797 | Антистатический коврик (0,61 м x 1,22 м) с кабелем заземления
9300-1126 | Антистатический ножной браслет


Интерфейс 82357A USB / GPIB

Адаптер Agilent 82357A создает интерфейс GPIB на базе одного из свободных портов USB на PNA.

  • Приложения

  • Установка

  • Конфигурирование

  • Подключение

  • Связь с оборудованием, подключенным к интерфейсу USB/GPIB

Приложения

Адаптер 82357A может использоваться со следующими приложениями PNA:

  • Преобразователь частоты (Frequency Converter Application - FCA) - 82357A поставляется с преобразователем частоты (опция 083). Если для управления PNA используется внешний ПК, то внешние источники должны быть подключены к этому интерфейсу. См. схему соединений ниже. Для подробной информации см. Конфигурирование внешнего гетеродина (external LO source).

Примечание: Если PNA был переведен в спящий режим во время измерений FCA с использованием внешнего источника под управлением FCA, и после этого произошла перезагрузка, появляется сообщение VISA "VI_ERROR_INV_OBJECT." Для того, чтобы эта проблема не возникала, после выхода из спящего режима необходимо переинициализировать интерфейс 82357 USB/GPIB. Для этого необходимо нажать кнопку Accept в окне инициализации интерфейса. На интерфейсе загорится зеленый светодиод READY.

  • Контроллер PNA - 82357A может использоваться PNA для управления другими устройствами GPIB. Это позволяет освободить главный интерфейс GPIB для других задач, таких как управление PNA с внешнего компьютера.

  • Калибровка источника мощности (Source Power Cal) - 82357A может использоваться для калибровки источника мощности.

Установка интерфейса 82357A USB / GPIB

  1. Загрузите и установите прошивку PNA версии 3.0 или выше. Для проверки версии прошивки нажмите Help затем About Network Analyzer.

  2. Обновите до последней версии библиотеки Agilent IO с компакт-диска, поставляемого с 82357A. При отсутствии компакт-диска загрузите их с веб-сайта www.Agilent.com (используйте поиск по строке 82357A)

Конфигурирование интерфейса 82357A USB / GPIB

При подключении 82357A к порту USB на PNA появляется следующее диалоговое окно:

В большинстве случаев эти настройки изменять не требуется. Интерфейс 82357A USB/GPIB конфигурируется автоматически на место последнего неиспользуемого интерфейса VISA. В большинстве случаев это GPIB2 если он не был сконфигурирован для других задач.

Если имя интерфейса VISA GPIB0 или GPIB1, то для корректной работы 82357A необходимо вернуть для этих интерфейсов настройки по умолчанию. См. конфигурирование для VISA / SICL.

Подключение интерфейса 82357A USB / GPIB

Ниже приведена схема подключения измерительного оборудования с GPIB при помощи интерфейса USB/GPIB.

  • Подключите интерфейс USB/GPIB к любому свободному порту USB на PNA.

  • Стандартный GPIB-интерфейс и интерфейсы USB/GPIB нельзя соединять вместе.

Связь с оборудованием, подключенным к интерфейсу USB/GPIB

  • Преобразователь частоты автоматически обнаруживает тестовое оборудование, подключенное к интерфейсу USB/GPIB.

  • Калибратор мощности источника автоматически обнаруживает измеритель мощности, подключенный к интерфейсу USB/GPIB.

  • Для управления через 82357A другими устройствами при помощи пользовательских программ, необходимо включить новый номер интерфейса GPIB при адресации устройств.


Обновление прошивки

Обновления прошивки PNA поставляются в виде самораспаковывающихся файлов Install Shield. Обновление включает в себя приложение PNA, контекстную справку и утилиты обслуживания. Примечание: Размер этого файла минимум 45 Мбайт.

Для обновления приложения PNA доступны следующие опции:

  • Auto-Check и AgileUpdate При наличии соединения с Internet эти утилиты автоматически проверяют наличие новых версий, загружают и устанавливают новую прошивку и связанные файлы при запуске приложения PNA. Перед этим выдается запрос.

  • Website Access Если PNA не имеет соединения с Internet, то можно загрузить прошивку на компьютере, имеющем выход в Internet и записать на носитель.

Смотрите также

PNA Cal Kits и обновления прошивки

Другие разделы справочного руководства

Auto-Check

При наличии доступа PNA в Internet, Auto-Check регулярно производит автоматическую проверку наличия новых версий прошивки PNA. При наличии новой версии появляется уведомление с запросом выполнить утилиту AgileUpdate, выполняющую загрузку прошивки.

При отсутствии доступа PNA в Internet, Auto-Check выдает напоминания через заданный интервал времени.

Утилита Auto-Check выполняется только при запуске приложения PNA. Во время выполнения приложения PNA обновления не проверяются до следующего перезапуска.

При запуске Auto-Check проверяет следующие условия:

  • Имеется ли активное подключение к Internet?

  • Активирована ли утилита Auto-Check?

  • Наступило ли время проверки обновления прошивки?

  • Найдена ли новая версия прошивки?

Если все эти условия выполняются, отображается следующее диалоговое окно.

Если эти условия не выполняются, а также для изменения настроек в любое время, нажмите System, Service, и AgileUpdate. В AgileUpdate нажмите AutoCheck. Последующие обновления прошивки их не меняют.

Справка по диалоговому окну PNA Auto-Check

Enable При запуске приложения PNA Auto-Check будет производить поиск новой версии прошивки на веб-сайте PNA через заданный интервал времени.

Disable При запуске приложения PNA Auto-Check не будет производить поиск новой версии прошивки на веб-сайте PNA.

Time Interval Период времени, с которым Auto-Check проверяет наличие обновлений прошивки.

OK запускает AgileUpdate.

Cancel До наступления следующего срабатывания никаких действий не производится.

AgileUpdate

Примечание: Для запуска этой утилиты необходимо войти в систему с правами администратора. См. Добавление пользователей анализатора.

В большинстве случаев для загрузки и установки новой версии прошивки PNA достаточно следующих шагов:

  1. Подключить PNA к Internet. Рекомендуется использовать скоростное подключение, поскольку загрузка прошивки при помощи модема может занять несколько часов.

  2. В меню System нажмите Service, затем AgileUpdate.

  3. Нажмите Check for Updates.

  4. Если были найдены обновления, нажмите Download & Install.

Справка по диалоговому окну AgileUpdate

Примечание: Компания Agilent уважает конфиденциальность своих клиентов. Программа AgileUpdate НЕ отправляет на сервер никакой информации с PNA. Она только загружает данные с сервера на PNA.

Restart Нажмите для перезапуска загрузки.

Configure Нажмите для запуска диалогового окна конфигурации.

Clean-up Нажмите для удаления устаревших загруженных пакетов с жесткого диска PNA.

Firmware History Доступна после нажатия Check for Updates.

Auto-Check вызывает диалоговое окно Auto-Check.

Item / Application Список доступных для загрузки с веб-сайта элементов.

  • Нажмите на элементы с пометкой i для получения подробной информации о загружаемом файле.

  • Элементы, помеченные красным, должны загружаться и устанавливаться индивидуально.

  • Многоязычная справка включает файлы на всех языках кроме английского.

Примечание: Файл справки поставляется с прошивкой. Поэтому, даже если оставить установленным только флажок прошивки, будет обновлена как прошивка, так и файл справки.

Select Source

Default Website Сайт компании Agilent, содержащий обновления прошивки.

Other Specified URL Указать в качестве местоположения прошивки другой сайт.

Install from File Нажмите для установки ранее загруженного пакета InstallShield.

Special Access Code... Введите код, полученный от технической поддержки компании Agilent. При его отсутствии оставьте поле пустым.

Make Latest Firmware Available... Установите этот флажок для загрузки последней версии прошивки, даже если она не обновилась.

Check for Updates Нажмите для поиска обновлений прошивки на сайте Agilent. При наличии новых версий их имена будут добавлены в список.

Download and Install Загрузить и установить найденные обновления. На некоторых файлах флажок может быть установлен автоматически. Убедитесь, что установлены нужные флажки. После этого нажмите кнопку для начала загрузки и установки обновлений.

Download Only Загрузить файлы на жесткий диск, но не устанавливать их автоматически. Для установки таких файлов необходимо будет нажать Install from File.

Справка по диалоговому окну Configuration

Примечание: Если AgileUpdate не может соединиться с сервером, попробуйте зайти на любой другой веб-сайт для проверки связи. В случае необходимости свяжитесь с системным администратором.

Proxy Setting

No Proxy or Default Proxy Выберите при подключении через локальную сеть. AgileUpdate автоматически возьмет настройки прокси из Internet Explorer.

Use specified Proxy / Port Нажмите для задания имени и порта прокси-сервера. Формат строки: ИмяПрокси:НомерПорта (номер порта обычно 8088).

Internet timeout Таймаут соединения. При использовании автоматически устанавливаемого коммутируемого соединения имеет смысл его увеличить.

Current Connection Status Отображает текущее состояние подключения PNA к Internet.

Примечание: Эти настройки НЕ сохраняются; их нужно повторно задавать при каждом запуске AgileUpdate.

Доступ к веб-сайту Agilent

Если нет прямого доступа к Internet, то для загрузки файлов с веб-сайта Agilent можно использовать любой другой компьютер, подключенный к Internet. После загрузки файлы необходимо передать по локальной сети с компьютера на анализатор.

  1. Зайдите на веб-страницу PNA по адресу http://www.agilent.com/find/PNA.

  2. Следуя ссылкам найдите страницу "PNA firmware".

  3. Выберите загружаемую прошивку.

  4. Сохраните программу на диск.

  5. Перепишите файл с компьютера на PNA по локальной сети или при помощи внешнего носителя.

  6. Дважды щелкните по этому файлу на PNA.

Внимание: Не пытайтесь устанавливать загруженные файлы на компьютере, они предназначены только для PNA. Установка их на обычном компьютере может привести к сбоям системы.


Конфигурации и опции PNA

Каждый анализатор комплектуется мышью и клавиатурой. В этом разделе приведена комплектация стандартных моделей анализаторов и их опциональных компонентов.

  • Модели PNA

    • Серия PNA-L

    • Микроволновые модели

    • Радиочастотные модели

    • Анализаторы миллиметровых волн

  • Опции и наборы для модернизации

  • Гарантийный срок

Список установленных опциональных компонентов можно посмотреть, нажав Help в меню About Network Analyzer

Компакт-диск с документацией более не входит в комплект поставки (начиная с февраля 2005).

Другие разделы справочного руководства

Серия PNA-L Модель N5230A

Щелкните по номеру опции для вызова блок-схемы.

Щелкните по типу коннектора для просмотра его спецификаций.

Опция

Диапазон частот

Измерительные порты

Коннектор

Опорные приемники

Измерительный набор1

020

300 кГц* ... 6 ГГц

2

3.5 мм штырьковый

2

Стандартный

025

300 кГц* ... 6 ГГц

2

3.5 мм штырьковый

2

Конфигурируемый

120

300 кГц* ... 13 ГГц

2

3.5 мм штырьковый

2

Стандартный

125

300 кГц* ... 13 ГГц

2

3.5 мм штырьковый

2

Конфигурируемый

220

10 МГц* ... 20 ГГц

2

3.5 мм штырьковый

2

Стандартный

225

10 МГц* ... 20 ГГц

2

3.5 мм штырьковый

2

Конфигурируемый

240

300 кГц* ... 20 ГГц

4

3.5 мм штырьковый

1

Стандартный

245

300 кГц* ... 20 ГГц

4

3.5 мм штырьковый

1

Конфигурируемый2

420

10 МГц* ... 40 ГГц

2

2.4 мм штырьковый

2

Стандартный

425

10 МГц* ... 40 ГГц

2

2.4 мм штырьковый

2

Конфигурируемый

520

10 МГц* ... 50 ГГц

2

2.4 мм штырьковый

2

Стандартный

525

10 МГц* ... 50 ГГц

2

2.4 мм штырьковый

2

Конфигурируемый

* Типовые спецификации

1 Измерительный набор

Стандартный Неконфигурируемый измерительный набор.

Конфигурируемый - Добавляет шесть перемычек на передней панели и два шаговых аттенюатора на 50 дБ.

2 Конфигурируемый - Добавляет девять перемычек на передней панели и один шаговый аттенюатор на 60 дБ.

Стандартные микроволновые модели (см. опции)

Щелкните по номеру модели анализатора для вызова блок-схемы.

Щелкните по типу коннектора для просмотра его спецификаций.

Модель PNA | Диапазон частот | Порты | Тип коннектора | Опорные приемники | Перемычки на передней панели
E8361A | 10 МГц* ... 67 ГГц (настраиваемый до 70 ГГц)** | 2 | 1.85 мм штырьковый | 2 | 0
E8362A | 45 МГц ... 20 ГГц | 2 | 3.5 мм штырьковый | 2 | 0
E8363A | 45 МГц ... 40 ГГц | 2 | 2.4 мм штырьковый | 2 | 0
E8364A | 45 МГц ... 50 ГГц | 2 | 2.4 мм штырьковый | 2 | 0
E8362B | 10 МГц* ... 20 ГГц | 2 | 3.5 мм штырьковый | 2 | 0
E8363B | 10 МГц* ... 40 ГГц | 2 | 2.4 мм штырьковый | 2 | 0
E8364B | 10 МГц* ... 50 ГГц | 2 | 2.4 мм штырьковый | 2 | 0
Легенда Снято с производства * Типовая спецификация применима для 10 ... 45 МГц ** Типовая спецификация применима для 67 ... 70 ГГц

Стандартные радиочастотные модели (см. опции)

Щелкните по номеру модели анализатора для вызова блок-схемы.

Щелкните по типу коннектора для просмотра его спецификаций.

Модель PNA | Диапазон частот | Порты | Тип коннектора | Опорные приемники | Перемычки на передней панели
E8356A | 300 кГц ... 3 ГГц | 2 | Type-N гнездо | 2 | 4
E8357A | 300 кГц ... 6 ГГц | 2 | Type-N гнездо | 2 | 4
E8358A | 300 кГц ... 9 ГГц | 2 | Type-N гнездо | 2 | 4
E8801A | 300 кГц ... 3 ГГц | 2 | Type-N гнездо | 1 | 0
E8802A | 300 кГц ... 6 ГГц | 2 | Type-N гнездо | 1 | 0
E8803A | 300 кГц ... 9 ГГц | 2 | Type-N гнездо | 1 | 0
N3381A | 300 кГц ... 3 ГГц | 3 | Type-N гнездо | 1 | 0
N3382A | 300 кГц ... 6 ГГц | 3 | Type-N гнездо | 1 | 0
N3383A | 300 кГц ... 9 ГГц | 3 | Type-N гнездо | 1 | 0

Анализаторы миллиметровых волн

Модель PNA

Диапазон частот

Порты

Тип коннектора

Опорные
приемники

Перемычки на передней панели

N5250A

10 МГц* ... 110 ГГц

2

1.0 мм

2

N5260A

* Типовая спецификация применима для 10 ... 45 МГц

Также имеются измерительные головки до 325 ГГц

Обновите существующую модель E836xB следующими опциями:

  • Опция H11

  • Измерительный набор N5260A

  • Модули расширения для миллиметровых волн (Millimeter-Wave VNA Frequency Extension Modules) компании Oleson Microwave Labs

Опции и наборы для модернизации

Приведенные ниже компоненты устанавливаются в момент покупки, некоторые из них доступны также в качестве дополнений. Для заказа обновления свяжитесь с дилером компании Agilent.

Опция

Поддерживаемые модели

Описание

006

E8356A
E8801A
N3381A

Расширение частотного диапазона до 6 ГГц.

Добавляет возможность работы на частоте 6 ГГц. Устанавливается в сервисном центре компании Agilent. Калибровка прибора (после модернизации) производится за дополнительную плату.

009

E8356/7A
E8801/2A
N3381/2A

Расширение частотного диапазона до 9 ГГц.

Добавляет возможность работы на частоте 9 ГГц. Устанавливается в сервисном центре компании Agilent. Калибровка прибора (после модернизации) производится за дополнительную плату.

010

Все

Измерение временных характеристик
Добавляет возможность измерения временных характеристик. При заказе этого набора необходимо указать серийный номер анализатора. Обновление программного обеспечения.

Подробнее

014

E8801/ 02/ 03A
N3381/ 82/ 83A
E8361A
E8362/ 63/ 64A
E8362/ 63/ 64B

Конфигурируемый измерительный пульт (Configurable test set)

Добавляет доступ к выходу источника и входу ответвителя через переднюю панель на измерительных портах 1 и 2. Добавляет доступ через переднюю панель ко всем приемникам, включая опорный.

Устанавливается в сервисном центре компании Agilent.

См. блок-схема PNA.

015

E8356/ 57/ 58A

Конфигурируемый измерительный пульт (Configurable test set)

Добавляет доступ к выходу источника и входу ответвителя через переднюю панель на измерительных портах 1 и 2.
Добавляет шаговые аттенюаторы на 35 дБ между ответвителями и приемниками.

Устанавливается в сервисном центре компании Agilent.

См. блок-схема PNA.

016

E8361A
E8362/ 63/ 64B

Шаговые аттенюаторы приемника

Добавляет два шаговых аттенюатора. (E8361A добавляет шаговые аттенюаторы на 50 дБ с разрешением 10 дБ; остальные модели - 35 дБ с разрешением 5 дБ.) Каждый аттенюатор устанавливается между измерительным портом и соответствующим приемником. Требует наличия опции UNL.

022

E8361A
E8362/ 63/ 64B

Расширенная память

Наращивает оперативную память до 512 МБ. Подробнее об ОЗУ PNA

080

E8361A
E8362/ 63/ 64B
N5230A

Смещение частоты

Позволяет устанавливать источники PNA независимо от того, на что настроены приемники. Эта возможность применяется при измерении смесителей, конвертеров и усилителей. Для управления дополнительным оборудованием имеется базовый пользовательский интерфейс и команды SCPI и COM. Требует наличия опции 014 или набора активных измерений (N5230A).

081

E8361A
E8362/ 63/ 64B

Опорный переключатель (Reference Switch)

Добавляет внутренний полупроводниковый переключатель в опорную цепь R1 для управления внешним опорным смесителем. Требует наличия опций 014 и 080

См. блок-схема опорного переключателя.

083

E8361A
E8362B/ 63B/ 64B

Приложение Преобразователь частоты (Frequency Converter Measurement Application)

Предоставляет простой пользовательский интерфейс для измерений потерь преобразования и абсолютной групповой задержки на смесителях и преобразователях. Исключительная точность амплитуды и фазы достигается благодаря использованию двух новых технологий калибровки: Калибровка измерителя мощности с корекцией согласования (match-corrected power meter calibration) и векторная калибровка смесителя (vector mixer calibration). Кроме того, приложение предоставляет автоматическое управление источниками сигнала Agilent. Требует наличия опций 014, 080 и 081.

Подробнее

098

E8356/ 57/ 58A

Модернизация процессорной платы

Замена платы с процессором 266 МГц на плату с процессором 500 МГц.

Устанавливается в сервисном центре компании Agilent. Как проверить скорость процессора PNA.

1E1

E8801/ 02/ 03A
N3381/ 82/ 83A

Шаговый аттенюатор на 70 дБ

Добавляет один шаговый аттенюатор на 70 дБ, переключаемый между источником и выходными портами для увеличения выходной мощности до -85 дБм. Примечание: Два шаговых аттенюатора на 70 дБ входят в стандартный комплект поставки PNA моделей E8356/ 57/ 58A.

Устанавливается в сервисном центре компании Agilent.

1E5

E8801/ 02/ 03A
N3381/ 82/ 83A

Задающий генератор (time base) с высокой стабильностью на 10 МГц

Заменяет генератор с частотой 10 импульсов в минуту генератором с частотой 1 импульс в минуту. Задающий генератор с высокой стабильностью входит в стандартный комплект поставки PNA моделей E8356/ 57/ 58A and E8362/ 63/ 64B.

H08

E8361A
E8362B/ 63B/ 64B

Приложение для импульсных измерений

Предоставляет приложение для измерений средней амплитуды импульса (average pulse) и значений амплитуды в заданной точке (point-in-pulse). Требует наличия опций H11, UNL, 014, 080, and 081.

Подробнее

H11

E8361A
E8362B/ 63B/ 64B

Доступ к промежуточной частоте (IF Access)

Предоставляет возможность доступа к промежуточной частоте PNA через заднюю панель:

  • Расширенный диапазон частот до 325 ГГц

  • Возможность импульсных измерений

  • Усовершенствованные антенные измерения

Требует наличия опций UNL, 014, 080, and 081.

Подробнее

UNL

E8361A
E8362/ 63/ 64A
E8362/ 63/ 64B

Расширение диапазона мощности и ответвители со смещением (bias tee)

Добавляет два шаговых аттенюатора и два ответвителя со смещением. (Для модели E8361A добавляются шаговые аттенюаторы на 50 дБ; для E8362/ 63/ 64A/B - на 60 дБ. Все аттенюаторы имеют разрешение 10 дБ.) Шаговый аттенюатор и ответвитель со смещением устанавливается между источником и измерительным портом 1, второй ответвитель – между источником и измерительным портом 2.

Устанавливается в сервисном центре компании Agilent.

Опции сертификации

Опция | Поддерживаемые модели | Описание
1A7 | E8361A E8362B/ 63B/ 64B N5250A | Полный набор измерительных данных, полученный при тестировании PNA на предмет соответствия заявленным спецификациям. Включает в себя калибровочную метку (calibration label), калибровочный сертификат (calibration certificate) и отчетные данные (data report). Соответствует стандарту ISO 9001.
UK6 | E8361A E8362B/ 63B/ 64B N5250A | Полный набор измерительных данных, полученный при тестировании PNA на предмет соответствия заявленным спецификациям. Включает в себя калибровочную метку, калибровочный сертификат ISO 17025, отчетные данные, погрешности измерения и защитные полосы по всем спецификациям. Соответствует стандартам ISO17025 и ISO 9001.

Документация и локализация

Печатные версии справки PNA в формате .pdf доступны на сайте Agilent.com. (Май.2005)

Компакт-диск с документацией более не входит в комплект поставки PNA (начиная с февраля 2005).

Для загрузки руководства по обслуживанию анализаторов или последней версии справки посетите веб-сайт http://www.agilent.com, найдите Вашу модель анализатора и нажмите Library.

Гарантийный срок

Реальный гарантийный срок зависит от даты заказа и типа покупки (с гарантией или без). Для уточнения свяжитесь с компанией Agilent Technologies, указав номер модели и серийный номер прибора.

Информация о сервисной поддержке компании Agilent доступна на веб-странице: www.agilent.com/find/tm_services


Option_Enable

Утилита включения опций

Утилита включения опций позволяет выполнять следующие действия:

  • Активизировать или удалять программные опции и некоторые аппаратные опции.

  • Восстанавливать данные опций после замены жесткого диска или другого хранилища данных.

  • Вводить или изменять серийный номер.

  • Ключевые слова

  • Запуск программы

  • Удаление опции

  • Установка опции

  • Восстановление данных опций

  • Установка или изменение серийного номера

Ключевые слова

Для добавления опций необходимы ключевые слова, предоставляемые компанией Agilent. Существует два типа ключевых слов:

  • Ключевые слова опций - для добавления программных опций.

  • Ключевые слова моделей могут требоваться при замене нескольких схем.

Временные и постоянные опции

Любая программная опция также может быть установлена временно на определенный период. Это позволяет бесплатно оценить ее функциональность.

Если лицензионный ключ, предоставленный компанией Agilent, имеет срок действия, необходимо указать, что опция "временная" и ввести дату окончания действия в соответствии с лицензией. Для того чтобы сделать эту опцию постоянной, Agilent предоставляет новое ключевое слово, преобразующее опцию в постоянный статус.

Ключевые слова предоставляются как для постоянных, так и для временных программных опций.

Запуск программы

  1. В меню System анализатора выберите Service, , и нажмите Option Enable.

  2. На первом экране отобразится номер модели, серийный номер и все установленные опции. Для активизации или удаления опции выберите ее из выпадающего списка доступных опций.

    • Если требуемой опции нет в списке, выберите последний элемент списка - Enter Unlisted Option. После этого введите трехзначное имя опции и нажмите Enter

Если была выбрана программная опция, происходят следующие действия:

  • Активизируется кнопка Remove

  • Становится видимой область ввода ключевых слов

  • Активизируется переключатель постоянных/временных опций

Если была выбрана аппаратная опция, происходят следующие действия:

  • Если уже были установлены какие-либо аппаратные опции, активизируется кнопка Remove.

  • Если имеются неактивные аппаратные опции, активизируется кнопка Enable.

Удаление опции

  1. Для удаления опции нажмите кнопку Remove.

  2. После удаления опции перезапустите приложение анализатора.

Примечание: При удалении лицензированных опций (например опция 010, Time Domain) удалится также и ключевое слово лицензии. Если эти опции могут пригодиться в будущем, перед удалением запишите ключевое слово. Для этого скопируйте файл "gen.lic" в другое место (например на дискету), или распечатайте на принтере. Этот файл находится в папке "C:\Program Files\Agilent\Network Analyzer" и содержит необходимую лицензионную информацию.

Установка опции

  1. Если область ввода ключевого слова активна, введите ключевое слово. (ключевые слова не чувствительны к регистру.)

  2. Нажмите Enable.

  3. После установки опции перезапустите приложение анализатора.

Восстановление данных опций

Эту возможность необходимо использовать в следующих ситуациях:

  • При замене жесткого диска

  • После замены схемы генератора опорной частоты

Эта процедура перестраивает информацию об опциях на жестком диске и в схеме генератора опорной частоты (главную и резервную).

  1. В строке меню Option Enable выберите Repair.

Примечание: Если вы не уверены, что необходимо запускать данную процедуру, запускайте ее, поскольку она не выполняет никаких деструктивных действий.

  2. Отображаются номера моделей и серийные номера с флажками.

  3. Установите необходимые флажки.

  4. Нажмите Begin Repair. Процедура проверяет файлы данных и выполняет необходимые действия по их восстановлению. Программа может запросить пользователя проверить некоторую информацию и процессы.

  5. Если был введен неправильный номер модели, программа запросит повторный ввод номера.

    • Помимо номера модели необходимо также указать ключевое слово. Если оно не написано на корпусе или вы его не знаете, обратитесь в компанию Agilent

    • После ввода требуемых данных нажмите Change Model. Этот процесс занимает около 30 секунд.

  6. После завершения нажмите Exit Repair.

  7. Если не нужно ставить еще опции, нажмите Exit.

Установка или изменение серийного номера

Установка или изменение серийного номера может понадобиться после замены некоторых схем.

  1. Для изменения серийного номера выберите Change Serial в меню Option Enable Отобразится текущий серийный номер. Если до этого серийный номер не был введен, появится сообщение "NONE".

  2. Введите новый серийный номер и нажмите Change Serial. (Серийный номер не чувствителен к регистру.)

Примечание: При вводе серийного номера необходимо соблюдать осторожность, поскольку дается только одна попытка ввода!

  3. Для изменения неправильного серийного номера необходим код сброса. Обратитесь в компанию Agilent для получения этого кода и повторной активации серийного номера. Введите код очистки в соответствующее поле и нажмите Change Serial.


Другие ресурсы

Доступны также следующие ресурсы, посвященные векторному анализу.

  • Ресурсы с документацией

  • Ресурсы сторонних производителей

Другие разделы справочного руководства

Ресурсы с документацией

Примечания по применению

В анализаторе имеется доступ к приведенным ниже примечаниям по применению.

  1. В меню Help нажмите Product Overview.

  2. Обзор продукта начинается с введения. Для пропуска вступительной части нажмите Main Menu.

  3. В главном меню нажмите Literature, и щелкните по заголовку нужного документа.

Эти документы также доступны на веб-сайте:

http://www.agilent.com/find/PNA

  • Application Development with the Agilent PNA Series of Network Analyzers, (номер издания 5980-2666ENUS).

  • Understanding and Improving Network Analyzer Dynamic Range, Agilent Application Note 1363-1 (номер издания 5980-2778EN).

  • The "Need for Speed" in Component Manufacturing Test, (номер издания 5980-2783EN).

  • Generate Component Data Sheets with Agilent's BenchLinkXL, (номер издания 5980-2781EN).

  • Connectivity Advances in a LAN-enabled Instument, (номер издания 5980-2782EN).

  • De-embedding and Embedding S-Parameter Networks Using the PNA Series Network Analyzer, Agilent Application Note 1364-1 (номер издания 5980-2784EN).

  • Advanced Filter Tuning Using TIme Domain, Agilent Application Note 1287-10 (номер издания 5980-2785EN).

  • Understanding the Fundamental Principles of Vector Network Analysis, Agilent Application Note 1287-1 (номер издания 5965-7707E).

  • Exploring the Architectures of Network Analyzers, Agilent Application Note 1287-2 (номер издания 5965-7708E).

  • Applying Error Correction to Network Analyzer Measurements, Agilent Application Note 1287-3 (номер издания 5965-7709E).

  • Network Analyzer Measurements: Filter and Amplifier Examples, Agilent Application Note 1287-4 (номер издания 5965-7710E).

  • Improving Throughput in Network Analyzer Applications, Agilent Application Note 1287-5 (номер издания 5966-3317E)

  • Using a Network Analyzer to Characterize High-Power Components, Agilent Application Note 1287-6 (номер издания 5966-3319E)

  • Simplified Filter Tuning Using Time-Domain Analysis, Agilent Application Note 1287-8 (номер издания 5968-5328E).

  • In-Fixture Measurements Using Vector Network Analysis, Agilent Application Note 1287-9 (номер издания 5968-5329E).

  • 8 Hints for Making Better Network Analyzer Measurements, Agilent Application Note AN 1291-1 (номер издания 5965-8166E)

  • Specifying Calibration Standards for the Agilent 8510 Network Analyzer, Agilent Product Note 8510-5A, (номер издания 5956-4352, or Agilent part number 08510-90352, February 1988).

  • In-Fixture Microstrip Device Measurements Using TRL* Calibration, Agilent Product Note 8720-2, (номер издания 5091-1943E, August 1991).

Ресурсы сторонних производителей

Для подробной информации об испытательных держателях свяжитесь с компанией:

Inter-Continental Microwave
1515 Wyatt Drive
Santa Clara, CA 95054-1524 USA
Telephone: (408) 727-1596
Fax: (408) 727-0105
Web site: www.icmicrowave.com
E-mail: icmfixture@aol.com

Для подробной информации о пробниках и аксессуарах свяжитесь с компанией:

Cascade Microtech, Inc.
2430 NW 206th Avenue
Beaverton, OR 97006 USA
Telephone: (503) 601-1000
Fax: (503) 601-1002
Web site: www.cascademicrotech.com
E-mail: sales@cmicro.com


SCPI Errors

Ошибки SCPI

Стандартные ошибки SCPI

Ошибки команд -100 … -200

Ошибки выполнения -200 … -299

Специфические ошибки устройств SCPI (-300 … -399)

Ошибки при выполнении запросов и системные ошибки (-400… -800)

Специфические ошибки PNA

Примечание: См. также Ошибки PNA

Ошибки команд -100 … -200

Ошибки команд GPIB представляют собой синтаксические ошибки IEEE 488.2. При возникновении подобных ошибок в регистре состояния события устанавливается бит ошибки.

-100 | std_command | Команда - Бит события (бит 5) указывает на синтаксическую или семантическую ошибку, или была введена команда GET, см. IEEE 488.2, 11.5.1.1.4.
-101 | std_invalidChar | Недопустимый символ - синтаксический элемент содержит символ, недопустимый для данного типа.
-102 | std_syntax | Синтаксическая ошибка - была введена неизвестная команда или несуществующий тип данных. Например, была получена строка, в то время как устройство не поддерживает строки.
-103 | std_invalidSeparator | Неправильный разделитель - интерпретатор обнаружил недопустимый символ вместо разделителя. Например, была пропущена точка с запятой.
-104 | std_wrongParamType | Тип данных - интерпретатор обнаружил недопустимый тип данных. Например, были получены блочные данные, в то время, как ожидались числовые или строковые.
-105 | std_GETNotAllowed | GET не разрешен - указывает, что с сообщением был получен триггер группового выполнения (GET). Исправьте программу так, чтобы GET не передавался.
-108 | std_tooManyParameters | Недопустимый параметр - указывает, что было получено больше параметров, чем описано в заголовке. Например, команда *ESE принимает только один параметр, следовательно, вызов *ESE 0,1 неправильный.
-109 | std_tooFewParameters | Отсутствует параметр - указывает, что было получено меньше параметров, чем описано в заголовке. Например, команда *ESE требует наличия параметра, следовательно, вызов *ESE неправильный.
-110 | std_cmdHeader | Заголовок команды - указывает на ошибку в заголовке команды. Эта ошибка возникает, если устройство не может определить более специфичный тип ошибки (-111… -119).
-111 | std_headerSeparator | Разделитель заголовка - при интерпретации заголовка был обнаружен символ, недопустимый в качестве разделителя.
-112 | std_IDTooLong | Слишком длинный идентификатор - заголовок содержит более 12 символов, см. IEEE 488.2, 7.6.1.4.1.
-113 | std_undefinedHeader | Заголовок не определен - заголовок синтаксически правильный, но не определен ни для какого устройства. Например, *XYZ не определен ни для какого устройства.
-114 | std_suffixOutOfRange | Недопустимое значение суффикса заголовка - неверное значение суффикса заголовка, присоединенного к мнемонике программы.
-120 | std_numericData | Числовые данные - This error, as well as errors
-121 | std_invalidCharInNumber | Недопустимый символ в числовом значении - при интерпретации числового значения обнаружен недопустимый символ. Например, буква в десятичном числе, или цифра "9" в восьмеричном.
-123 | std_exponentTooLarge | Слишком большая экспонента - величина экспоненты больше 32000, см. IEEE 488.2, 7.7.2.4.1.
-124 | std_decimalTooLong | Слишком много цифр - мантисса десятичного числа содержит более 255 цифр, не считая ведущих нулей, см. IEEE 488.2, 7.7.2.4.1.
-128 | std_numericNotAllowed | Числовые данные не допускаются - получено числовое значение, но устройство не принимает значения такого типа.
-130 | std_suffix | Суффикс - эта ошибка, так же как и ошибки -131…-139 возникает при интерпретации суффикса. Это сообщение используется в том случае, если устройство не может определить более конкретный тип ошибки.
-131 | std_badSuffix | Неправильный суффикс - Суффикс не соответствует синтаксису, описанному в IEEE 488.2, 7.7.3.2, или не совместим с данным устройством.
-134 | std_suffixTooLong | Слишком длинный суффикс - суффикс содержит более 12 символов, см. IEEE 488.2, 7.7.3.4.
-138 | std_suffixNotAllowed | Суффикс не допускается - суффикс был обнаружен после числового элемента, не разрешающего суффиксы.
-140 | std_charData | Символьные данные - This error, as well as errors
-141 | std_invalidCharData | Неправильные символьные данные - символьная строка содержит недопустимый символ, или полученный элемент не допустим для данного заголовка.
-144 | std_charDataTooLong | Слишком длинная символьная строка - символьная строка содержит более 12 символов, см. IEEE 488.2, 7.7.1.4.
-148 | std_charNotAllowed | Символьные данные не допускаются - были получены правильные символьные данные, но они запрещены устройством.
-150 | std_stringData | Строковые данные - This error, as well as errors
-151 | std_stringInvalid | Неправильные строковые данные - ожидается строковое значение, но получена неверная строка, см. IEEE 488.2, 7.7.5.2. Например, было получено сообщение END перед закрывающей кавычкой.
-158 | std_stringNotAllowed | Строковые данные не допускаются - получено строковое значение, но устройство не принимает значения такого типа.
-160 | std_blockData | Блочные данные - эта ошибка, так же как и ошибки -161 …-169 возникает при интерпретации элемента блочных данных. Это сообщение используется в том случае, если устройство не может определить более конкретный тип ошибки.
-161 | std_badBlock | Неправильные блочные данные - ожидаются блочные данные, но получено неверное значение, см. IEEE 488.2, 7.7.6.2. Например, было получено сообщение END до завершения передачи блока.
-168 | std_blockNotAllowed | Блочные данные не допускаются - получены блочные данные, но устройство не принимает значения такого типа.
-170 | std_expr | Выражение - эта ошибка, так же как и ошибки -171 …-179 возникает при интерпретации выражения. Это сообщение используется в том случае, если устройство не может определить более конкретный тип ошибки.
-171 | std_invalidExpression | Неправильное выражение - получено неверное выражение, см. IEEE 488.2, 7.7.7.2. Например, был получен неверный символ или не закрыта скобка.
-178 | std_exprNotAllowed | Выражения не допускаются - получено правильное выражение, но устройство не принимает значения такого типа.
-180 | std_macro | Макрос - эта ошибка, так же как и ошибки -181 …-189 возникает при определении или выполнении макроса. Это сообщение используется в том случае, если устройство не может определить более конкретный тип ошибки.
-181 | std_validOnlyInsideMacro | Неверное определение за пределами макроса - место заполнения параметра было обнаружено за пределами определения макроса.
-183 | std_invalidWithinMacro | Неверное определение внутри макроса - последовательность сообщений, отправленная командой *DDT или *DMC, семантически неправильная, см. IEEE 488.2, 10.7.6.3.
-184 | std_macroParm | Параметр макроса - неправильное количество или тип параметров в одной из команд макроса.

Ошибки выполнения -200 … -299

Эти ошибки возникают, если возникает ситуация, некорректная в данном состоянии прибора. Эти ошибки могут генерироваться действиями пользователя через удаленный или локальный интерфейс.

-200 | std_execGen | Выполнение - Этот бит события (бит 4) означает, что элемент PROGRAM DATA, следуемый за заголовком, находится за пределами допустимых значений, или несовместимый с возможностями устройства, см. IEEE 488.2, 11.5.1.1.5.
-201 | std_invalidWhileInLocal | Неверный в локальном режиме
-202 | std_settingsLost | Настройки потеряны из-за rtl
-203 | std_commandProtected | Защищенная команда - указывает, что корректная, защищенная паролем команда или запрос не может быть выполнен, поскольку эта команда была отключена.
-210 | std_trigger | Триггер
-211 | std_triggerIgnored | Триггер проигнорирован
-212 | std_armIgnored | Ветвь проигнорирована
-213 | std_initIgnored | Инициализация проигнорирована
-214 | std_triggerDeadlock | Взаимная блокировка триггера
-215 | std_armDeadlock | Взаимная блокировка ветви
-220 | std_parm | Параметр - Возникла ошибка, связанная с элементом данных программы.
-221 | std_settingsConflict | Конфликт настроек - программой был получен правильный элемент данных, но она не может быть выполнена при текущем состоянии устройства.
-222 | std_dataOutOfRange | Данные за допустимыми пределами - программой был получен правильный элемент данных, но она не может быть выполнена, поскольку интерпретированное значение выходит за допустимые пределы для данного устройства.
-223 | std_tooMuchData | Слишком много данных - был получен корректный блок данных, выражение или строковое значение, однако его размер превышает ограничение данного устройства.
-224 | std_illegalParmValue | Некорректное значение параметра - выбранное значение не входит в список данных значений.
-225 | std_noMemoryForOp | Недостаточно памяти - Устройству не хватает памяти для выполнения заданной операции.
-226 | std_listLength | Несоответствие длин списков - была предпринята попытка использовать структуру LIST, содержащую списки разных размеров.
-230 | std_dataCorruptOrStale | Поврежденные данные - процесс считывания начат, но не завершен с момента последнего доступа.
-231 | std_dataQuestionable | Подозрительные данные - имеются подозрения на недостаточную точность измерений.
-232 | std_invalidFormat | Неправильный формат
-233 | std_invalidVersion | Неправильная версия - программой был получен правильный элемент данных, но она не может быть выполнена, поскольку эта версия данных недопустима для данного устройства. Например, неподдерживаемая версия файла или неподдерживаемое устройство.
-240 | std_hardware | Аппаратная ошибка - указывает, что корректная команда или запрос не может быть выполнена из-за аппаратных ошибок на устройстве.
-241 | std_hardwareMissing | Отсутствует оборудование - указывает, что корректная команда или запрос не может быть выполнена из-за отсутствия нужного устройства. Например, не была установлена нужная опция.
-250 | std_massStorage | Дисковая память - произошел сбой дисковой памяти. Эта ошибка возникает, если устройство не может определить более специфичный тип ошибки (-251… -259).
-251 | std_missingMassStorage | Отсутствует дисковый накопитель - указывает, что корректная команда или запрос не может быть выполнена из-за отсутствия дискового накопителя.
-252 | std_missingMedia | Отсутствует носитель - указывает, что корректная команда или запрос не может быть выполнена из-за отсутствия носителя. Например, не вставлена дискета.
-253 | std_corruptMedia | Испорченный носитель - указывает, что корректная команда или запрос не может быть выполнена из-за того, что носитель испорчен. Например, испорченная или неотформатированная дискета.
-254 | std_mediaFull | Переполненный носитель - указывает, что корректная команда или запрос не может быть выполнена из-за того, что носитель переполнен. Например, на диске нет свободного места.
-255 | std_directoryFull | Переполненный каталог - указывает, что корректная команда или запрос не может быть выполнена из-за того, что каталог на носителе переполнен.
-256 | std_fileNotFound | Файл не найден - указывает, что корректная команда или запрос не может быть выполнена из-за того, что не найден требуемый файл.
-257 | std_fileName | Ошибка в имени файла - указывает, что корректная команда или запрос не может быть выполнена из-за того, что имя файла содержит ошибку. Например, была произведена попытка считать или скопировать несуществующий файл.
-258 | std_mediaProtected | Устройство защищено от записи - указывает, что корректная, защищенная паролем команда или запрос не может быть выполнен, поскольку носитель защищен от записи. Например, на карте памяти установлен переключатель защиты от записи.
-260 | std_expression | Выражение
-261 | std_math | Математическое выражение
-270 | std_macroExecution | Макрос - указывает на ошибку при выполнении макроса.
-271 | std_macroSyntax | Синтаксис макроса - указывает, что синтаксически корректный макрос, соответствующий IEEE 488.2, 10.7.2, не может быть выполнен из-за синтаксической ошибки в описании макроса.
-272 | std_macroExec | Выполнение макроса - указывает, что синтаксически корректный макрос не может быть выполнен из-за какой-либо ошибки в описании макроса, см. IEEE 488.2, 10.7.6.3.
-273 | std_badMacroName | Некорректная метка макроса - Метка макроса не соответствует определению в IEEE 488.2, 10.7.3.
-274 | std_macroPlaceholder Ma | Параметр макроса - Неправильно определен подставляемый параметр макроса, см. IEEE 4882, 10.7.3.
-275 | std_macroTooLong | Слишком длинное определение макроса - указывает, что синтаксически корректный макрос не может быть выполнен, поскольку его строковый блок слишком длинный для данного устройства, IEEE 488.2, 10.7.6.1.
-276 | std_macroRecursion | Рекурсивный макрос - указывает, что синтаксически корректный макрос не может быть выполнен, поскольку он является рекурсивным, см. IEEE 488.2, 10.7.6.6.
-277 | std_cantRedefineMacro | Переопределение макроса не допускается - была произведена попытка переопределения метки существующего макроса, см. IEEE 488.2, 10.7.6.4.
-278 | std_macroNotFound | Заголовок макроса не найден - указывает, что в *GMS? задана корректная метка макроса, но он не может быть выполнен, поскольку не был определен заголовок, см. IEEE 488.2, 10.13.
-280 | std_program | Программа
-281 | std_cantCreateProgram | Невозможно создать программу
-282 | std_illegalProgramName | Некорректное имя программы
-283 | std_illegalVarName | Некорректное имя переменной
-284 | std_programRunning | Программа выполняется в настоящий момент
-285 | std_programSyntax | Ошибка в синтаксисе программы
-286 | std_programRuntime | Ошибка времени выполнения в программе
-290 | std_memoryUse | Ошибка использования памяти
-291 | std_execOutOfMemory | Недостаточно памяти
-292 | std_nameNotFound | Запрошенное имя не существует.
-293 | std_nameAlreadyExists | Запрошенное имя уже существует
-294 | std_incompatibleType | Несовместимые типы

Специфические ошибки устройств SCPI (-300 … -399)

Специфические ошибки устройств возникают в тех случаях, когда анализатор определяет, что некоторые операции были завершены некорректно из-за проблем с оборудованием или прошивкой. Например, попытка пользователя установить недопустимое значение, приведет к специфической ошибке устройства. При возникновении подобных ошибок в регистре состояния события устанавливается бит специфической ошибки устройства.

-300 | std_deviceSpecific | Специфическая ошибка устройства - Этот бит события (бит 3) показывает, что операция с устройством завершена неудачно по какой-либо причине, например из-за переполнения, см. IEEE 488.2, 11.5.1.1.6.
-310 | std_system | Системная ошибка
-311 | std_memory | Ошибка памяти - указывает на физический сбой памяти устройства, например на ошибку четности.
-312 | std_PUDmemoryLost | Потеря данных в памяти PUD - потеря защищенных пользовательских данных, сохраненных командой *PUD, см. IEEE 488.2, 10.27.
-313 | std_calMemoryLost | Потеря данных в памяти калибровок - потеря калибровочных данных, сохраненных командой *CAL?, см. IEEE 488.2, 10.2.
-314 | std_savRclMemoryLost | Потеря данных в памяти сохранения настроек - потеря данных, сохраненных командой *SAV, см. IEEE 488.2, 10.33.
-315 | std_configMemoryLost | Потеря данных конфигурации - потеря конфигурационных данных, сохраненных устройством.
-320 | std_storageFault | Сбой хранилища - прошивка обнаружила ошибку при работе с хранилищем данных. Это не означает физическое повреждение или сбой оборудования накопителя.
-321 | std_outOfMemory | Недостаточно памяти - внутренняя операция требует больше памяти, чем доступно
-330 | std_selfTestFailed | Неудачное завершение самотестирования - неизвестная проблема с устройством. Подробное сообщение отсутствует. Устройство может требовать обслуживания.
-340 | std_calFailed | Неудачное завершение калибровки - неизвестная проблема при калибровке устройства. Подробное сообщение отсутствует.
-350 | std_queueOverflow | Переполнение очереди - в очереди закончилось свободное место, и произошла ошибка, которая не была записана. Этот код заносится в очередь на место кода, который вызвал ошибку.
-360 | std_comm | Коммуникации - Общая ошибка коммуникаций для устройств, которые не могут определить более подробный код ошибки (-361 .. -363)
-361 | std_parity | Ошибка четности в программном сообщении - Несовпадение бита четности при приеме данных (например, через последовательный порт).
-362 | std_framing | Ошибка кадрирования в программном сообщении -при приеме данных не обнаружен стоп-бит (например, через последовательный порт). Например, несовпадение скоростей портов.
-363 | std_inputBufferOverrun | Переполнение входного буфера - аппаратный или программный буфер последовательного порта переполнен данными.

Ошибки при выполнении запросов и системные ошибки (-400… -800)

Ошибка запроса возникает при потере данных в очереди вывода GPIB, а также при попытке считать данные из пустой очереди.

-400 | std_queryGen | Ошибка запроса - Бит события (бит 2) устанавливается при попытке считать данные из пустой очереди вывода или при потере данных в очереди вывода, см. IEEE488.2, 11.5.1.1.7.
-410 | std_interrupted | Запрос был прерван - работа измерительного набора была прервана новым программным сообщением до отправки сообщения RESPONSE, см. IEEE 488.2, 6.3.2.3.
-420 | std_unterminated | Незавершенный запрос - запрос был передан не полностью, см. IEEE 488.2, 6.3.2.2.
-430 | std_deadlocked | Взаимная блокировка - переполнение входного и выходного буфера, см. IEEE 488.2, 6.3.1.7.
-440 | std_responseNotAllowed | Незавершенный запрос после неопределенного ответа - запрос был получен в том же сообщении, что и запрос неопределенного ответа, см. IEEE 488.2, 6.5.7.5.
-500 | std_powerOn | Включение питания
-600 | std_userRequest | Пользовательский запрос
-700 | std_requestControl | Запрашивание управления
-800 | std_operationComplete | Завершение операции
.

Специфические для PNA ошибки SCPI

100 | dupWindNum | "Дублирование номера окна"
101 | windNumNotFound | "Номер окна не найден"
102 | failedWindCreate | "Ошибка при создании окна"
103 | noCalcParamSelection | "Измерение CALC установлено в none"
104 | dupMeasName | "Дублирование имени измерения"
105 | dataNotFound | "Запрашиваемые данные отсутствуют"
106 | measNotFound | "Запрашиваемое измерение не найдено"
107 | traceNotFound | "Запрашиваемый график не найден"
108 | notImplemented | "Мнемоника не реализована"
109 | noDocument | "Контейнер измерения не найден"
110 | dupTraceNum | "Дублирование номера графика"
111 | titleStrTooLong | "Длина заголовка превышает 50 символов"
112 | memoryNotFound | "Запрашиваемая память отсутствует"
113 | exceedMaxTraces | "Превышено допустимое количество графиков для окна"
114 | SerNumNotFound | "Серийный номер не найден. Пожалуйста, сохраните серийный номер."
115 | LoadFailed | "Состояние не загружено. Проверьте имя файла. "
116 | StoreFailed | "Состояние не сохранено. Проверьте имя файла и путь."
117 | File | "Произошла ошибка при работе с файлом. Проверьте имя файла и путь."
118 | measChanConflict | "Измерение не принадлежит указанному каналу"
119 | exceedMaxWindows | "Превышено допустимое количество окон с данными"
120 | markerNotFound | "Указанный маркер не найден."
121 | diagnostic | "Диагностика."
122 | channelNotFound | "Указанный канал не найден."
123 | exceedMaxMeasurements | "Превышено допустимое количество измерений"
124 | parameterOutOfRange | "Указанное значение выходит за допустимые пределы."
125 | userRangeNotValid | "Выбран неправильный пользовательский диапазон."
126 | referenceMarkerNotFound | "Маркер ссылок не активен."
127 | sweepSegmentNotFound | "Не найден сегмент свипирования".
128 | markerNotDelta | "Указанный маркер не является дельта-маркером."
129 | printoutFailed | "Ошибка при печати на принтере."
130 | memory_trace_not_compatible | "Несовместимая память. Графическая математика не применена."
131 | trace_math_reset | "Несовместимая память. Графическая математика отключена."
132 | hw_read_failed | "Аппаратный сбой чтения."
133 | hw_write_failed | "Аппаратный сбой записи."
134 | dsp_active | "Ошибка: DSP не остановлен."
135 | secure_memory | "Попытка доступа к защищенной области памяти."
136 | snum_protected | "Серийный номер защищен".
137 | snum_format_bad | "Неправильный формат серийного номера".
138 | snum_already_set | "Серийный номер уже установлен."
139 | hw_setting_failed | "Аппаратный сбой при установке."
140 | cal_access_failed | "Ошибка при доступе к калибровочным данным."
141 | db_access_failed | "Ошибка при доступе к БД."
142 | memory_range_exceeded | "Команда выходит за диапазон используемой памяти."
143 | lost_phase_lock | "Потеря синхронизации фаз."
144 | over_power | "Слишком высокая входная мощность."
145 | ee_wrt_failed | "Ошибка записи в ППЗУ."
146 | yig_cal_failed | "Ошибка калибровки YTO."
147 | ramp_cal_failed | "Ошибка калибровки пилообразного аналогового сигнала."
148 | dspcom_bad | "Ошибка связи с DSP."
149 | no_license_found | "Ошибка при выполнении запроса. Не найдена требуемая лицензия."
150 | argLimited | "Аргумент выходит за допустимые пределы."
151 | markerBWNotFound | "Пропускная способность маркера не найдена."
153 | peakNotFound | "Пиковое значение не найдено."
154 | targetNotFound | "Значение поиска цели не найдено."
155 | calNotImpl | "Запрашиваемая функция калибровки не реализована."
156 | calClassNotValidForCalType | "Измерение SENS:CORR:CCH установлено в none"
158 | calNotValidForConfidenceChe | "Выбранное измерение не имеет калибровок, допустимых для Confidence Check"
159 | invalidPort | "Указанный порт за допустимыми пределами"
160 | invalidPortPath | "ROUT:PATH:DEF:PORT x, y не совпадает с измерением; установлено значение по умолчанию"
161 | ioInvalidWrite | "Попытка записи в порт ввода/вывода, предназначенный только для чтения."
162 | ioInvalidRead | " Попытка чтения из порта ввода/вывода, предназначенного только для записи."
163 | calsetNotFound | "Указанный калибровочный набор не найден в хранилище."
164 | noCalSetSelected | "Для указанного канала не выбрана никакая калибровка."
165 | cantDeleteCalSetInUse | "Невозможно удалить используемый калибровочный набор."
166 | calsetStimChange | "Настройки стимула канала изменены для соответствия калибровочному набору."
167 | exceedMaxCalSets | "Превышено допустимое количество калибровочных наборов."
168 | calCouldNotTurnOn | "Перед включением коррекции необходимо произвести калибровку."
169 | standardMeasurementRequired | "Данная операция может быть выполнена только на стандартном типе измерений."
170 | noDivisorBuffer | "Перед включением нормализации необходимо выделить буфер делителя."
171 | invalidReceiverPowerCalParagraph | "Калибровка мощности приемника требует измерения абсолютной величины на одном из приемников."
172 | ecalCouldNotConfigure | "Невозможно сконфигурировать электронную калибровочную систему." Проверьте, подключен ли модуль к соответствующему коннектору."
173 | measHasNoMemoryAlg | "Данное измерение не поддерживает операции с памятью"
174 | measHasNoNormalizeAlg | "Данное измерение не поддерживает операции нормализации."
175 | userCharacterizationNotFound | "Не найдена характеризация пользователя в модуле электронной калибровки."
176 | measInvalidBufferSize | "Недопустимое количество точек в полученных данных. Сохранение данных невозможно."


Техническая поддержка

Выберите ваше местоположение на карте.

  • См. также www.agilent.com/find/assist

  • Или свяжитесь со специалистами по измерительным технологиям компании Agilent Technologies.

Другие разделы справочного руководства

United States:

(tel) (+1) 800 452 4844

(alt) (+1) 303 662 3999

(fax) (+1) 888 900 8921

Canada

(tel) 1 877 894 4414

(fax) 1 (905) 206 4120

Europe:

Austria

(tel) 0820 87 44 11*

(fax) 0820 87 44 22

Belgium

(tel) (+32) (0)2 404 9340

(alt) (+32) (0)2 404 9000

(fax) (+32) (0)2 404 9395

Denmark

(tel) (+45) 7013 1515

(alt) (+45) 7013 7313

(fax) (+45) 7013 1555

Finland

(tel) 08 0052 4000

(alt) (+358) 10 855 2100

(fax) (+358) 92 536 0176

France

(tel) 0825 010 700*

(alt) (+33) (0)1 6453 5623

(fax) 0825 010 701*

Germany

(tel) 01805 24 6333*

(alt) 01805 24 6330*

(fax) 01805 24 6336*

Ireland

(tel) (+353) (0)1 890 924 204

(alt) (+353) (0)1 890 924 206

(fax) (+353) (0)1 890 924 024

Israel

(tel) (+972) 3 9288 500

(fax) (+972) 3 9288 501

Italy

(tel) (+39) (0)2 9260 8484

(fax) (+39) (0)2 9544 1175

Luxemburg

(tel) (+32) (0)2 404 9340

(alt) (+32) (0)2 404 9000

(fax) (+32) (0)2 404 9395

Netherlands

(tel) (+31) (0)20 547 2111

(alt) (+31) (0)20 547 2000

(fax) (+31) (0)20 547 2190

Russia

(tel) (+7) 095 797 3963

(alt) (+7) 095 797 3900

(fax) (+7) 095 797 3901

Spain

(tel) (+34) 91 631 3300

(alt) (+34) 91 631 3000

(fax) (+34) 91 631 3301

Sweden

(tel) 0200 88 22 55*

(alt) (+46) (0)8 5064 8686

(fax) 020 120 2266*

Switzerland (French)

(tel) 0800 80 5353 opt. 2*

(alt) (+33) (0)1 6453 5623

(fax) (+41) (0)22 567 5313

Switzerland (German)

(tel) 0800 80 5353 opt. 1*

(alt) (+49) (0)7031 464 6333

(fax) (+41) (0)1 272 7373

Switzerland (Italian)

(tel) 0800 80 5353 opt. 3*

(alt) (+39) (0)2 9260 8484

(fax) (+41) (0)22 567 5314

United Kingdom

(tel) (+44) (0)7004 666666

(alt) (+44) (0)7004 123123

(fax) (+44) (0)7004 444555

Japan:

(tel) 0120 421 345

(alt) (+81) 426 56 7832

(fax) 0120 421 678

Latin America:

Mexico

(tel) (+52) 55 5081 9469

(alt) 01800 5064 800

(fax) (+52) 55 5081 9467

Brazil

(tel) (+55) 11 4197 3600

(fax) (+55) 11 4197 3800

Australia:

((tel) 1800 629 485

(alt) 1800 143 243

(fax) 1800 142 134

New Zealand

(tel) 0 800 738 378

(fax) 64 4 495 8950

Asia Pacific:

China

(tel) 800 810 0189

(alt) (+86) 10800 650 0021

(fax) 800 820 2816

Hong Kong

(tel) 800 930 871

(alt) (+852) 3197 7889

(fax) (+852) 2 506 9233

India

(tel) 1600 112 929

(fax) 000800 650 1101

Malaysia

(tel) 1800 888 848

(alt) 1800 828 848

(fax) 1800 801 664

Singapore

(tel) 1800 375 8100

(fax) (+65) 6836 0252

South Korea

(tel) 080 769 0800

(alt) (+82) 2 2004 5004

(fax) (+82) 2 2004 5115

Taiwan

(tel) 0800 047 866

(alt) 00801 651 317

(fax) 0800 286 331

Thailand

(tel) 1800 226 008

(alt) (+66) 2 268 1345

(fax) (+66) 2 661 3714


3.8_GHz_Freq_Adj

Регулировка частоты 3.8 ГГц

Эта программа подстраивает внутреннюю фиксированную частоту ЖИГ–генератора (3.8ГГц), изменяя значение DAC. Значение DAC хранится в энергонезависимой памяти анализатора.

Частота генератора не обязательно должна быть точно равна 3.8ГГц, обычно она может быть установлена с погрешностью до 12 КГц.

Совместимость с анализаторами спектра

Данная процедура совместима с анализаторами спектра Agilent 856x и 859x.

При отсутствии совместимого анализатора спектра выберите "NONE". После этого необходимо отрегулировать DAC вручную, просматривая сигнал 3.8 ГГц на другом анализаторе.

Процедура (только для совместимых анализаторов спектра)

Примечание: Амплитуда сигнала 3.8 ГГц низкая; обычно около -70 дБм. Не используйте при регулировке аттенюаторы, в большинстве анализаторов спектра по умолчанию используется ослабление на 10 дБ.

  1. Подключите вход анализатора спектра к выходу PORT 1 векторного анализатора.

  2. Соедините векторный анализатор и анализатор спектра кабелем GPIB . Убедитесь, что на этом соединении отсутствуют другие активные контроллеры.

  3. Установите GPIB-адрес анализатора спектра в 18.

  4. В меню System анализатора выберите Service, Adjustments, и нажмите 3.8 GHz Freq. Adjust.

  5. Нажмите Begin Adj. для подстройки внутреннего генератора на минимальную погрешность и сохранения результатов. После того, как в области состояния появляется сообщение о завершении регулировок, нажмите Exit.

Процедура (для несовместимых анализаторов спектра)

Примечание: Амплитуда сигнала 3.8 ГГц низкая; обычно около -70 дБм. Не используйте при регулировке аттенюаторы, в большинстве анализаторов спектра по умолчанию используется ослабление на 10 дБ.

  1. Подключите вход анализатора спектра к выходу PORT 1 векторного анализатора.

  2. Установите настройки анализатора спектра:

    • Центральная частота =3.8 ГГц

    • Диапазон – 100 МГц

    • Полоса = 10 кГц

    • Масштабирование для четкой видимости сигнала -70 дБм

  3. В меню System анализатора выберите Service, Adjustments, и нажмите 3.8 GHz Freq. Adjust.

  4. В меню Spectrum Analyzer, выберите опцию NONE.

  5. Нажмите Begin Adj.

  6. Приложение установит DAC в начальное значение, равное текущему сохраненному значению. Проверьте частоту сигнала на анализаторе спектра и сравните ее с 3.800 ГГц.

    • Если частота сигнала выше 3.8 ГГц, переместите ползунок влево для уменьшения значения DAC.

    • Если частота ниже 3.8 ГГц, переместите ползунок вправо для увеличения значения DAC.

Примечание: Допустимые значения DAC находятся в диапазоне 0 … 4095. Сдвиг генератора примерно 23 КГц на одно значение DAC.

  7. Установите значение DAC таким образом, чтобы получить частоту, максимально приближенную к 3.8 ГГц. При внесении значительных изменений в значение DAC, подождите несколько секунд для стабилизации частоты.

  8. Настройте анализатор спектра для наилучшего просмотра сигнала:

    • Частотный диапазон = 500 кГц

    • Полоса = 3 кГц

  9. Изменяйте значение DAC так, чтобы максимально приблизить частоту сигнала к 3.8 ГГц.

  10. После определения правильного значения DAC нажмите SAVE DAC для сохранения значения в ППЗУ. Нажмите Exit.

Примечание: При внесении значительных изменений в значение DAC необходимо повторить измерение через 15-30 минут. Это позволяет стабилизировать температурный эффект.


10_MHz_Ref_Freq_Adj

Регулировка опорной частоты 10 МГц

Эта процедура подстраивает частоту внутреннего генератора временной развертки (time-base) точно на 10МГц, изменяя значение DAC. Значение DAC хранится в энергонезависимой памяти анализатора. Эта процедура выполняется в следующих ситуациях:

  • После замены схемы генератора опорной частоты.

  • При значительном отклонении опорной частоты от заводского значения.

ВНИМАНИЕ: Диапазон подстройки около 20 Гц. Для измерения сигнала 10МГц требуется очень точная эталонная частота.

Совместимость частотомера

Эта процедура использует для связи с частотомером команды SCPI (через GPIB). Она работает с частотомерами серий Agilent 5313xA, 5315xA, 53181A, а также с более старыми серии 5350.

При отсутствии совместимых частотомеров выберите ручной (Manual) режим работы. В ручном режиме необходимо вручную вводить значение измеренной частоты.

Процедура только для GPIB-частотомеров

  1. Подключите частотомер к выходу опорной частоты 10 МГц на задней панели анализатора.

  2. Соедините анализатор и частотомер кабелем GPIB . Убедитесь, что на этом соединении отсутствуют другие активные контроллеры.

  3. Если возможно, подсоедините источник эталонной частоты к опорному входу частотомера.

  4. Установите GPIB-адрес частотомера в 03. Убедитесь, что на этом адресе отсутствуют другие устройства.

  5. В меню System анализатора выберите Service, Adjustments, и нажмите 10 MHz Freq. Adjust.

  6. Нажмите Begin Adj. Приложение настроит внутренний эталон на минимальную погрешность и сохранит результаты.

  7. Нажмите Read Freq для запуска следующего считывания сигнала 10 МГц.

  8. Нажмите Read DAC для просмотра текущего значения DAC хранящегося в энергонезависимой памяти анализатора (значение = 0 – 4095).

  9. После того, как в области состояния появляется сообщение о завершении регулировок, нажмите Exit.

Процедура для не-GPIB частотомеров

  1. Подключите частотомер к выходу опорной частоты 10 МГц на задней панели анализатора.

  2. Установите разрешение частотомера минимум в 1Гц.

  3. Если возможно, подсоедините источник эталонной частоты к опорному входу частотомера.

  4. В меню System анализатора выберите Service, Adjustments и нажмите 10 MHz Freq. Adjust.

  5. В списке Frequency Counter, выберите Manual.

  6. Нажмите Begin Adj.

  7. Приложение установит DAC в начальное значение. Введите смещение измеряемой частоты от 10 МГц. Если измеряемая частота меньше 10 МГц используйте знак минус (-) для указания отрицательной погрешности. Например:

    • Если частотомер показывает 10000003.5 Hz, введите 3.5 (или +3.5) в окне индикации.

    • Если частотомер показывает 9999997.8Hz, введите -2.2 в окне индикации.

  8. Регулировочный цикл повторяется минимум 3 раза, до тех пор, пока введенное значение не станет равно нулю.

    • Нажмите Read Freq для запуска следующего считывания сигнала 10 МГц.

    • Нажмите Read DAC для просмотра текущего значения DAC хранящегося в энергонезависимой памяти анализатора (значение = 0 – 4095).

  9. После того, как в области состояния появляется сообщение о завершении регулировок, нажмите Exit.

Примечание: Если частотомер неправильно измеряет частоту, имеет смысл ослабить входной сигнал, и/или установить входное сопротивление 50 Ом.


LO_Power_Adjustment

Регулировка мощности гетеродина

Данная процедура регулирует входную мощность гетеродина приемника при помощи изменения значения DAC. Значение DAC хранится в энергонезависимой памяти анализатора. Некоторые действия зависят от номера модели анализатора.

Совместимость измерителей мощности

Эта процедура совместима только с измерителями мощности серии Agilent EPM Могут быть использованы различные датчики. Для анализаторов с частотой 9ГГц и ниже используются датчики 8482 или E4412A. Для более высокочастотных устройств (20ГГц и выше), датчик должен быть рассчитан на максимальную частоту 20 ГГц. Частота выше 20 ГГц не измеряется, даже если максимальная частота анализатора 50 ГГц.

При использовании старых датчиков HP 84xx необходимо ввести в соответствующую калибровочную таблицу измерителя мощности EPM правильные калибровочные данные, однако для данной регулировки высокая точность не требуется. Допустимая погрешность составляет десятки дБ.

Процедура

  1. Включите анализатор и измеритель мощности и дайте им прогреться в течение 30 минут.

  2. Откалибруйте датчик мощности вручную и установите нулевую отметку. (Далее этот шаг можно будет пропускать)

  3. Соедините анализатор и измеритель мощности кабелем GPIB . Убедитесь, что на этом соединении отсутствуют другие активные контроллеры.

  4. Установите GPIB-адрес измерителя мощности в 13 (13 – по умолчанию; можно также использовать и другие адреса)

  5. Снимите верхнюю крышку анализатора.

  6. В меню System анализатора выберите Service, затем Adjustments, и нажмите LO Power Adjust.

  7. Подсоедините датчик мощности к выходу гетеродина, используя соответствующие адаптеры. Расположение выхода гетеродина может отличаться в зависимости от модели. Выберите в меню LO Power Adjust Setup для просмотра схемы расположения выходов.

  8. Для устройств с частотой 9 ГГц и ниже:
    Для запуска процедуры калибровки гетеродина нажмите Begin Adj Эта процедура подстраивает уровень для каждой гармоники (1..3) под допустимые интервалы значений. При внесении каких-либо изменений они автоматически сохраняются.

    Для устройств с частотой 20 ГГц и выше:
    При использовании датчика мощности 84xx нажмите Configure и выберите правильный номер модели. Нажмите Close. Нажмите Calibrate для запуска калибровки. Процесс калибровки занимает около 5 минут. После завершения калибровки нажмите Verify Cal для проверки текущей точности.
    Примечание:     Коррекционные константы устанавливаются в значения по умолчанию перед калибровкой. После запуска процесса калибровки для получения правильных данных необходимо дождаться его завершения.

  9. Нажмите Read DAC для просмотра текущего значения DAC (0 – 4095) хранящегося в энергонезависимой памяти анализатора для каждой гармоники (0-7).

  10. После того, как в области состояния появляется сообщение о завершении регулировок, нажмите Exit.

  11. Подключите обратно полугибкие кабели и верните на место крышки.


Регулировка мощности гетеродина смещения

Примечание: Эта регулировка производится только на анализаторах, поддерживающих режим смещения частоты (опция 080).

При регулировке мощности гетеродина смещения (Offset LO) устанавливается мощность гетеродина смещения на смесителе на постоянную величину во всех диапазонах. Для этого процесса требуется доступ к внутренним компонентам PNA, поскольку датчик подключается непосредственно к выходу гетеродина. Поскольку частота гетеродина не превышает 3 ГГц, можно использовать практически любой датчик. Данная регулировка относительно простая и занимает всего несколько минут.

Когда выполнять регулировку?

Данная регулировка выполняется в следующих ситуациях:

  • После модификации или замены приемника смещения частоты A13

  • После замены синтезатора A9 (в котором находятся корректировочные данные)

Проведение регулировки мощности гетеродина смещения Power adjustment

  1. Для запуска регулировки гетеродина смещения нажмите System, выберите Service, Adjustments, и нажмите Offset LO Adjust.

  2. Появится запрос на обнуление и калибровку датчика. (Это может быть выполнено до начала регулировки.)

  3. Подсоедините датчик к разъему J3 выхода А13 гетеродина, отсоединив существующий кабель (или просто отключив один конец), как показано на установочной схеме в программе.

  4. Подсоедините измеритель мощности к анализатору при помощи кабеля GPIB. Убедитесь, что GPIB-адрес, отображаемый в программе, совпадает с реальным адресом измерителя мощности (по умолчанию 13)

  5. Нажмите Adjust для начала измерения и следуйте инструкциям.

Программа автоматически производит регулировку для всех диапазонов, никаких действий пользователя не требуется. Этот процесс является итерационным, он повторяется несколько раз. На экране отображается процесс регулировки.

Опции меню Configure предназначены только для обслуживающего персонала.

После завершения регулировок нажмите Verify для проверки результатов.

При выходе приложение PNA автоматически перезапустится. Это займет несколько секунд.


Проверки, производимые оператором

  • Общие сведения

  • Выполнение проверок, производимых оператором

  • Справка по диалоговому окну Operators Check

Общие сведения

Проверки, производимые оператором, выполняются при получении нового анализатора, а также при необходимости убедиться в правильности его работы.

Примечание: Данные проверки не подразумевают тестирование на соответствие спецификациям. Для проверки соответствия анализатора спецификациям необходимо выполнить системные проверки (System Verification.)

В проверках, производимых оператором, используется критерий годен/не годен для определения явных проблем в работе следующего оборудования:

  • Повторяемость радиочастотного переключателя в измерительном наборе

  • Диапазоны ослабления сигналов аттенюаторов измерительных портов (если установлены)

  • Калибровка приемников

  • Частотная характеристика приемников

  • Фазовая автоподстройка частоты и поддержание амплитуды

  • Минимальный уровень шума и шум графика

Выполнение проверок, производимых оператором

  2. Подсоедините один или более эталонов (см. Конфигурирование).

  3. Нажмите Begin и Continue (в случае необходимости) и ждите появления сообщения "Operator's Check is complete!".

Для более подробной информации см. интерфейс передней панели

Данное диалоговое окно может выглядеть несколько иначе, в зависимости от номера модели анализатора и установленных опций. Некоторые проверки не выполняются при отсутствии соответствующих опций.

Справка по диалоговому окну Operators Check

Configure

Prompt for attachment of Short / Open При нехватке эталонов для измерительных портов будет выдаваться запрос на перемещение эталона на следующий порт. Подсоедините замыкающую или размыкающую перемычку (эталон) к порту 1 и нажмите Begin.

Shorts / Opens are attached to all ports Подсоедините замыкающие или размыкающие эталоны ко всем портам и нажмите Begin. Все порты проверяются без прерывания. На измерительных портах можно одновременно использовать размыкающие и замыкающие эталоны.

PNA Отображает информацию о тестируемом анализаторе.

Legend Отображает описание пиктограмм состояния проверок. Pending Pass отображает выполняемый этап тестирования.

Results Отображает текущее состояние каждого теста. Щелкните по названию теста для вызова подробного описания. Там также может находиться информация по устранению неполадок. При неудачном завершении какого-либо теста см. главу 3 руководства по обслуживанию PNA.

Begin запуск проверок.

View Results отображение результатов проверок в текстовом формате. Неудачные завершения помечены строкой ===>>>.

Этот текстовый файл может быть распечатан или сохранен под уникальным именем для сравнения с результатами последующих тестов.

Exit выход из программы с закрытием окна.


Фазовая подстройка усиления промежуточной частоты

Подстройка усиления в цепи ФАПЧ сигнала ПЧ

Анализаторы моделей E836x A/B имеют возможность подстройки усиления в цепи ФАПЧ сигнала промежуточной частоты. Амплитуда сигнала фазовой синхронизации подстраивается динамическим изменением усиления, как функция частоты и мощности. Постоянная амплитуда сигнала ФАПЧ необходима для обеспечения стабильности синхронизации.

Когда выполнять подстройку?

Данная подстройка выполняется в следующих ситуациях:

  • калибровка источника

  • заменяется сборка в цепи опорных приемников (R1,R2) is replaced.

  • была произведена замена материнской платы измерительного набора

  • была произведена замена платы синхронизации фазы

  • после замены сборки в цепи источника или приемника появляется сообщение об ошибке Phase Lock Lost

Выполнение подстройки усиления в цепи ФАПЧ

  1. В меню System выберите Service, Adjustments, затем IF Gain Adjustment.

  2. При наличии дополнительных опций, выберите их, в противном случае выберите None.

  3. К измерительным портам подключать ничего не требуется.

  4. Нажмите Begin Adj. Процесс подстройки занимает около минуты.

  5. Экран "advanced" предназначен только для обслуживающего персонала.


Проверка системы

Утилита проверки системы производит проверку системных спецификаций анализатора, автоматически измеряя величину и фазу всех четырех S-параметров для каждого проверяемого устройства, и сравнивая их со следующими значениями:

  • Значения заводских измерений из файлов на проверочном диске

  • Ограничительные линии на основе неопределенности измерений

Проверка системы требует использования калибровочного и проверочного наборов, сертифицированных при помощи процесса, удовлетворяющего требованиям NIST. Проверку системы нельзя использовать для сертификации этих наборов.

Для проверки базовой функциональности анализатора необходимо также выполнить проверку, производимую оператором.

  • Оборудование, используемое при проверке системы

  • Precautions for Handling Airlines

  • Flow Diagram of Procedure

  • Procedure for System Verification

  • If the System Fails the Verification Test

  • Interpreting the Verification Results

Примечание: Поскольку производительность измеряется для всех S-параметров, неопределенности фаз S11, S22, S33, и S44 pявляются менее важными при проверке производительности системы. Поэтому в распечатках ограничительные линии отсутствуют.

Оборудование, используемое при проверке системы

Для анализаторов моделей:

E8356A, E8357A, E8358A
N3381A, N3382A, N3383A
E8801A, E8802A, E8803A
(Измерительные порты Тип-N)

Тип оборудования | Тип-N | 3.5 мм
Калибровочный набор или модуль ECAL | 85032F 85092B | 85033E 85093B
Проверочный набор | 85055A | 85053B
Высокочастотные кабели | N6314A | См. Взаимозаменяемость кабелей

E8362A/B
N5230A (20 ГГц)
(Измерительные порты 3.5 мм)

Тип оборудования | 3.5 мм | Тип-N
Калибровочный набор или модуль ECAL | 85052B/C/D N4691A | 85054B/D N4690A
Проверочный набор | 85053B | 85055A
Высокочастотные кабели | Одинарный: 85131C/E Двойной: 85131D/F | Одинарный: 85132C/E Двойной: 85132D/F
Адаптеры | Нет | Одинарный: 85130C и один 7mm-to-Type-N из калибровочного набора 85054B Двойной: Два 7mm-to-Type-N из калибровочного набора 85054B

E8363A/B, E8364A/B
N5230A (40 или 50 ГГц)
(Измерительные порты 2.4 мм)

Тип оборудования | 2.4 мм | 3.5 мм | Тип-N
Калибровочный набор или модуль ECAL | 85056A/D N4693A | 85052B/C/D N4691A | 85054B/D N4690A
Проверочный набор | 85057B | 85053B | 85055A
Высокочастотные кабели | Одинарный: 85133C/E Двойной: 85133D/F | Одинарный: 85134C/E Двойной: 85134D/F | Одинарный: 85135C/E Двойной: 85135D/F
Адаптеры | Нет | Одинарный: 85130F Двойной: Нет | Одинарный: 85130E и два 7mm-to-Type-N из калибровочного набора 85054B Двойной: Два 7mm-to-Type-N из калибровочного набора 85054B

E8361A
(Измерительные порты 1.85 мм)

Тип оборудования | 1.85 мм | 2.4 мм 3.5 мм Тип-N
Калибровочный набор или модуль ECAL | 85058B N4694A | См. выше таблицу измерительных портов 2.4 мм
Проверочный набор | 85058V | См. выше таблицу измерительных портов 2.4 мм
Высокочастотные кабели | Одинарный: N4697E Двойной: N4697F | См. выше таблицу измерительных портов 2.4 мм
Адаптеры | Нет | См. выше таблицу измерительных портов 2.4 мм

Взаимозаменяемость кабелей

Кабели измерительных портов, предназначенные для PNA, характеризуются повторяемостью коннекторов, стабильностью амплитуды и фазы при изгибании, обратными потерями, вносимыми потерями и скоростью старения. Поскольку характеристики кабелей измерительных портов вносит значительный вклад в характеристики всей системы, некачественные кабели могут значительно повысить неопределенность измерений. Рекомендуется регулярно проверять кабели измерительных портов.

Если проверка системы выполняется с использованием кабеля, произведенного не компанией Agilent, убедитесь, что он удовлетворяет всем требованиям. См. руководство пользователя кабеля для подробной информации о спецификациях.

Взаимозаменяемость калибровочных наборов

Калибровочные наборы сторонних производителей не рекомендуются и не поддерживаются.

Предосторожности при работе с воздушными линиями

При использовании воздушных линий в проверочном наборе, необходимо учитывать следующие вещи.

  • Будьте осторожны, не подвергайте центр воздушной линии и внешний проводник механическим воздействиям. При падении эти устройства могут быть повреждены.

  • Используйте защиту от электростатических разрядов.

  • Перед работой вымойте руки или используйте перчатки, поскольку кожный жир может ухудшить электрические параметры.

Блок-схема процедуры

Ниже приведен алгоритм работы программы.

Процедура проверки системы

  1. Если необходимо получить распечатку результатов, подключите к анализатору принтер. Дайте анализатору прогреться в течение 30 минут.

  2. Вставьте дискету с программой проверки системы в дисковод анализатора.

  3. В меню System выберите Service, и нажмите System Verification. Появится окно System Verification.

Окно System Verification

  4. В списке Calibration Kit выберите используемый калибровочный набор или модуль Ecal. Соответствующий проверочный набор появится в окне Verification Kit.

  5. В окне Printer Output выберите одну из следующих опций.

    • Распечатать тестовые данные в табличном виде, включая данные измерений и границы неопределенности. См. пример табличных данных, ниже в данном разделе.

    • Print Graphs: Распечатать тестовые данные в графической форме. Графическая форма включает графики измеренных данных, заводские эталонные графики и границы неопределенности. См. пример графических данных, ниже в данном разделе.

    • File Tabular Data: Записывает тестовые данные в табличном виде в текстовый файл в папку C:\Program Files\Agilent\Network Analyzer\Documents\.

    • File Graphs: Записывает графическое изображение в формате .PNG в папку C:\Program Files\Agilent\Network Analyzer\Documents\.

Примечание: Для получения распечаток необходимо установить драйвер принтера Windows, и убедиться что принтер работает. Программное обеспечение анализатора печатает на принтере, установленном по умолчанию (см Printers в панели управления Windows).

  6. Для изменения количества проверяемых портов, изменения количества измеряемых устройств или использования ранее сохраненной калибровки, выберите закладку Configure и сделайте нужный выбор.

    • Для того, чтобы проверка системы была точной, ее необходимо производить после калибровки. После удаления или переподсоединения кабелей требуется повторная калибровка.

  7. Нажмите Run.

  8. Следуя инструкциям, подключайте необходимые проверочные устройства.

Примечание для трехпортового PNA:
Процедура проверки повторяется 3 раза. На первом этапе порты 1 и 2 измеряются в паре; после этого измеряется порт 1 и 3; и, наконец, порт 2 и 3.

Примечание для четырехпортового PNA:
Процедура проверки повторяется 2 раза. На первом этапе порты 1 и 2 измеряются в паре, после этого измеряется порт 3 и 4.

Пошаговое описание процесса

  1. В зависимости от выбранного пункта подменю Calibration меню Configure, пользователю предлагается использовать сохраненные калибровочные данные, или произвести полную двухпортовую калибровку при помощи выбранного калибровочного набора. При работе с Ecal, модуль Ecal подключается один раз; во время калибровки отправляется сообщение standby.

  2. Пользователю предлагается подсоединить первое проверочное устройство.

  3. Программа считывает для этого устройства данные заводских измерений и значения неопределенности этих данных (CITIfiles) с гибкого диска, поставляемого с проверочным набором.

  4. Программа отправляет данные заводских измерений, калибровочные данные, и данные о состоянии прибора в DLL калькулятора погрешности, вычисляющего значения неопределенности для данного анализатора.

  5. Сначала анализатор измеряет величину всех четырех S-параметров, каждый параметр в отдельном окне (lin mag для S11 и S22, log mag для S21 и S12). Каждый из измеренных на заводе S-параметров подается в соответствующее окно в качестве графика из памяти. Смещения ограничительных линий вычисляются как сумма неопределенностей данных заводских измерений и неопределенностей PNA, вычисленных DLL. Отображаются верхняя и нижняя граница (данных заводских измерений + сумма неопределенностей, данных заводских измерений - сумма неопределенностей). Анализатор начинает свипирование, тест по критерию включен, и результаты годен/ не годен отображаются в каждом из четырех окон.

  6. Пользователь нажимает кнопку, когда готов к просмотру результатов измерений фазы. В четырех окнах отображается информация о формате фазы, графики фазы из памяти, ограничительные линии фазы и результат теста годен/ не годен.

  7. Если проверка какого-либо из S-параметров (величина или фаза) завершается неудачно (FAIL), программа выдает подсказки по устранению неполадок, и предлагает повторить измерения или перейти к следующему устройству. При переходе к следующему устройству, данные заводских измерений для этого устройства считываются с гибкого диска, и снова передаются DLL для вычисления неопределенности. Информация во всех окнах обновляется и отображает измеренные данные для этого устройства.

  8. Программа производит аналогичные действия для всех устройств, после чего выводит окно с общей информацией о результатах теста годен/ не годен для каждого из четырех параметров каждого устройства.

Если тестирование завершилось неудачно

ВАЖНО: Проверьте все соединения. Не вынимайте кабели из измерительных портов анализатора. После этого придется повторять ранее произведенный процесс калибровки.

  1. Повторите процесс тестирования. Правильно подключайте каждое проверяемое устройство, обращайте внимание на правильное закручивание разъемов.

  2. Отключите, почистите, и снова подключите устройство, не прошедшее проверку. После этого повторите измерения на этом устройстве.

  3. Если проверка все равно завершается неудачно, проверьте калибровку измерений, просмотрев вектор погрешностей (описано в разделе "Доступ к векторам погрешностей через переднюю панель" на страницах 4-7 руководства по обслуживанию).

  4. См. также приведенные ниже графики.

Блок-схема неудачного завершения проверок

Интерпретирование результатов проверок

Ниже приведен пример результатов проверки с выбранной опцией Tabular Data в разделе Printer Output окна System Verification. Еще ниже приведен пример результатов проверки с выбранной опцией Measurement Plots в разделе Printer Output окна System Verification. Эти распечатки содержат сравнительную характеристику данных измерений и графических данных с соответствующими спецификациями неопределенности. Используйте эти распечатки для определения вхождения измеренных данных в допустимые пределы на всем диапазоне частот.

Табличные данные состоят из:

  • Частоты точек данных (в МГц).

  • Нижней ограничительной линии, определенной спецификацией общесистемной погрешности.

  • Результатов измерений.

  • Верхней ограничительной линии, определенной спецификацией общесистемной погрешности.

  • Статусом проверки (ГОДЕН или НЕ ГОДЕН) в данной точке.

Распечатка результатов проверки в табличном виде

Графические данные состоят из:

  • Верхних ограничительных точек, определенных спецификацией общесистемной погрешности.

  • Нижних ограничительных точек, определенных спецификацией общесистемной погрешности.

  • Данных заводских измерений.

  • Результатов измерений.

  • Имен и форматов измеряемых параметров (линейная величина или логарифмическая величина).

  • Серийного номера устройства (00810).

  • Устройства, используемого при измерении (Sys Ver аттенюатор 20 дБ).

Распечатка результатов проверки в графическом виде


Калибровка источника

Калибровка источника настраивает линейность характеристики мощности источника векторного анализатора во всем диапазоне частот. Эта регулировка предназначена только для обслуживания, а не для калибровки измерений.

Требуемое оборудование

Рекомендуемый измеритель мощности: E4419B
Альтернативные измерители мощности: E4419A or EPM-442A

Примечание: Тип датчика зависит от диапазона частот PNA. В зависимости от модели анализатора, для измерения всего диапазона частот может потребоваться два датчика.
Тип используемого кабеля и необходимость использования переходника зависит от типа коннекторов на передней панели анализатора.

Модель PNA | Датчики мощности | Кабель
E8356A | 8482A | N6314A
E8357A E8358A | 8482A и E4412A | N6314A
E8801A | 8482A | N6314A
E8802A E8803A | 8482A и E4412A | N6314A
N3381A | 8482A | N6314A
N3382A/N3383A | 8482A и E4412A | N6314A
E8361A | 8487A (использовать с адаптером 11900B) и V8486A (использовать с адаптером V281B) ** См. процедуру E8361A ниже | N4697-60001
E8362A / B | E4413A | 85131E
E8363A/B E8364A/B | 8487A (использовать с адаптером 11900B) | 85133E

См. Аксессуары PNA

Процедура

  1. Для получения информации о калибровочных параметрах датчиков мощности обращайтесь к соответствующей документации.

  2. Соедините анализатор и измеритель мощности кабелем GPIB.

  3. Убедитесь, что к измерителю мощности подсоединены датчики.

  4. В меню System анализатора выберите Service, Adjustments, и нажмите Source Calibration.

  5. После этого необходимо выбрать один из следующих вариантов:

    1. Нажмите Inspect Linearity для проверки линейности изменения мощности при переходе с одного уровня на другой. После завершения линейность мощности измерительного выхода должна соответствовать спецификациям данной модели анализатора.

    2. Нажмите Inspect Amplitude для анализа линейности мощности источника относительно частоты для трех уровней мощности: -5 дБм, 0 дБм и +5 дБм. После завершения точность мощности измерительного выхода должна соответствовать спецификациям данной модели анализатора.

    3. Нажмите Calibrate для запуска калибровки источника. Работа начинается с определения типа измерителя мощности и датчика. После этого программа предложит подключить датчики и кабели.

Подключение датчиков к PNA

Дополнительная информация

Проверяются все порты на всех анализаторах. Калибровка источника занимает от 20 до 90 минут, в зависимости от диапазона частот анализатора.

Устранение неполадок

При возникновении проблем с калибровкой источника см. главу "Устранение неполадок" руководства по обслуживанию PNA.

Процедура E8361A

Калибровка источника и приемника требует измерения мощности источника на всем диапазоне внутренних частот анализатора. Поскольку 8487A не может измерять с высокой точностью на частотах выше 50 ГГц, он может быть использован только на частотах до 46.2 ГГц. Для частот от 46.2 ГГц до 67 ГГц используется датчик V8486A с адаптером V281B.

Для получения наивысшей точности необходимо отправить V8486A и V281B компании Agilent для калибровки на частотах от 45 ГГц до 70 ГГц.

Для получения относительно высокой точности необходимо самостоятельно выполнить следующую процедуру для измерения поправочных коэффициентов от 46 до 50 ГГц. Данная процедура подразумевает, что поправочные коэффициенты уже загружены в измеритель мощности для обоих датчиков.

  1. На измерителе мощности добавьте 46 и 48 ГГц в таблицу калибровочных коэффициентов.

  2. Вызовите предварительно заданные настройки PNA

  3. Настройте PNA на 46 ГГц (незатухающая частота)

  4. Измерьте мощность на порту 1 при помощи 8487A. Запишите измеренное значение.

  5. Настройте PNA на 48 ГГц (незатухающая частота)

  6. Измерьте мощность на порту 1 при помощи 8487A. Запишите измеренное значение.

  7. Подсоедините V8486A, V281A, и 1.85 f-f адаптер к измерителю мощности.

  8. Настройте PNA на 46 ГГц (незатухающая частота)

  9. Подстраивайте значение в таблице калибровочных коэффициентов для 46ГГц до тех пор, пока измеренное значение мощности не совпадет со значением, измеренным на шаге 4.

  10. Настройте PNA на 48 ГГц (незатухающая частота)

  11. Подстраивайте значение в таблице калибровочных коэффициентов для 48ГГц до тех пор, пока измеренное значение мощности не совпадет со значением, измеренным на шаге 8.


Калибровка приемника

Калибровка приемника настраивает линейную характеристику приемников векторного анализатора во всем диапазоне частот. Эта регулировка предназначена только для обслуживания, а не для калибровки измерений.

Требуемое оборудование

Рекомендуемый измеритель мощности: E4419B
Альтернативные измерители мощности: E4419A или EPM-442A

Примечание: Тип датчика зависит от диапазона частот PNA. В зависимости от модели анализатора, для измерения всего диапазона частот может потребоваться два датчика.
Тип используемого кабеля и необходимость использования переходника зависит от типа коннекторов на передней панели анализатора.

Модель PNA | Датчики мощности | Кабель
E8356A | 8482A | N6314A
E8357A/E8358A | 8482A и E4412A | N6314A
E8801A | 8482A | N6314A
E8802A/E8803A | 8482A и E4412A | N6314A
N3381A | 8482A | N6314A
N3382A/N3383A | 8482A и E4412A | N6314A
E8361A | 8487A (использовать с адаптером 11900B) и V8486A (использовать с адаптером V281B) ** См. процедуру E8361A | N4697-60001
E8362A / B | E4413A | 85131E
E8363A/B E8364A/B | 8487A (использовать с адаптером 11900B) | 85133E

См. Аксессуары PNA

Процедура

  1. Для получения информации о калибровочных параметрах датчиков мощности обращайтесь к соответствующей документации.

  2. Соедините анализатор и измеритель мощности кабелем GPIB.

  3. Убедитесь, что к измерителю мощности подсоединены датчики.

  4. В меню System анализатора выберите Service, Adjustments,и нажмите Receiver Calibration.

  5. После этого необходимо выбрать один из следующих вариантов:

    1. Нажмите Inspect Flatness для анализа линейности частотной характеристики приемника. Поскольку явная спецификация линейности приемника отсутствует, при калибровке приемника происходит минимизация векторов погрешностей графиков передачи и отражения.

    2. Нажмите Calibrate для запуска калибровки приемника. Программа предложит подключить датчики, кабели и в случае необходимости - переходник (см. схемы ниже).

Подключение датчиков к PNA

Подключение переходника и кабеля между датчиком и PNA

Сквозное соединение при помощи специального кабеля

Дополнительная информация

При калибровке приемников проверяются все приемники PNA. Это занимает от 15 до 45 минут. Время зависит от диапазона частот и количества портов.

Устранение неполадок

При возникновении проблем с калибровкой приемника см. главу "Устранение неполадок" руководства по обслуживанию векторного анализатора.


Дисплей приемника

  • Использование дисплея приемника при устранении неполадок

  • Запуск дисплея приемника

Другие разделы справочного руководства

Использование дисплея приемника при устранении неполадок

TДисплей приемника может быть использован при устранении неполадок. Он позволяет изолировать сбойную функциональную группу в своей собственной системе измерений. Графики для каждого из приемников отображаются в отдельных окнах. Определение расхождения этих графиков может помочь в выявлении сбойного компонента.

Подробное описание дисплея приемника и диагностики с его помощью приведено в главе 3 руководства по обслуживанию PNA. Копию руководства по обслуживанию можно загрузить с нашего Web-сайта по адресу http://www.agilent.com/find/pna

Запуск дисплея приемника

Для более подробной информации см. интерфейс передней панели


Последовательная шина

Тестирование последовательной шины

Данный тест предназначен для всех моделей векторных анализаторов серии PNA. При замене следующих схем данный тест может работать неточно.

  • A8

  • A10

  • A11

  • A12

Производится последовательная проверка всех 32 узлов на частоте 300 кГц, а после этого всех узлов, значения которых меняются с частотой, на остальных 11 частотах. Все измеренные значения записываются в текстовый файл в папке service, кроме того, все измеренные значения, превышающие допуски, выделяются цветом.

Тестируемые компоненты и их номера узлов такие:

Плата | Номера узлов
A12 источник | 111 to 118
A10 опорная частота | 211 to 218
A11 ФАПЧ | 311 to 318
A8 синтезатор Fractional-N (дробный коэффициент деления частоты в цепи ОС) | 411 to 418

Запуск тестирования последовательной шины

Для подробной информации см. интерфейс передней панели

Примечание: При обнаружении каких-либо ошибок см. руководство по обслуживанию.


Калибровка прибора

Калибровкой прибора называется процесс измерения характеристик анализатора для проверки его соответствия спецификациям. Если какой-либо параметр характеристик не соответствует спецификациям, выполняются регулировки.

Для чего необходима калибровка?

Со временем активные компоненты анализатора стареют, что может привести к ухудшению характеристик . Необходимо периодически выполнять калибровку для обеспечения соответствия прибора заявленным спецификациям.

Как часто необходимо производить калибровку?

Спецификации прибора составлены с учетом отклонений на период свыше 12 месяцев. Следовательно, для обеспечения соответствия прибора спецификациям, необходимо производить его калибровку с интервалом в 12 месяцев. Для более точного соответствия стандартам калибровку можно производить чаще.

Как произвести калибровку?

Для проведения калибровки прибор необходимо отправить в сервисный центр компании Agilent Technologies.

Отправляемый анализатор должен быть полностью исправен, иначе придется заплатить еще и за его ремонт. Если анализатор содержит конфиденциальную информацию, и его жесткий диск нельзя отправить в сервисный центр, необходимо купить запасной жесткий диск, и установить его перед отправкой в сервисный центр. См. Техническая поддержка.

Для проведения калибровки прибора необходимо иметь:

  • Измерительное оборудование для калибровки прибора

  • Программное обеспечение для проверки характеристик

Какую калибровку выбрать?

Компания Agilent Technologies производит следующие типы калибровки приборов:

Стандартная | Включает сертификат калибровки, гарантирующий, что прибор откалиброван и работает в рамках заявленных спецификаций.
Опция UK6 | Включает измеренные калибровочные данные и стандартный сертификат, гарантирующий, что прибор откалиброван и работает в рамках заявленных спецификаций.
Опция M40 (Специальная) | Включает измеренные калибровочные данные и сертификат, гарантирующий, что прибор откалиброван в соответствии со стандартом ANSI Z540 и работает в рамках заявленных спецификаций.

Другие разделы справочного руководства


О доступе к ПЧ (Опция H11)

Опция H11 обеспечивает доступ с задней панели к цепям промежуточной частоты (ПЧ) PNA. Также вы можете устанавливать коэффициент усиления усилителей промежуточной частоты.

  • Как произвести настройки доступа к промежуточной частоте

  • Конфигурация усиления ПЧ

  • Конфигурация переключения ПЧ

Другие разделы по доступу к ПЧ

Стандартные характеристики системы N5250A

Как произвести настройки доступа к промежуточной частоте

Подробнее об использовании интерфейса передней панели

Конфигурация усиления ПЧ (IF Gain Configuration)

Настройка параметров усиления ПЧ позволяет вручную установить коэффициент усиления усилителя ПЧ PNA.

Справка по диалоговому окну IF Gain Configuration

Automatic - отметьте, для того чтобы позволить PNA установить усиление ПЧ автоматически. Уберите отметку, для того чтобы разрешить настройку усиления ПЧ вручную .

Примечание: Снятие отметки может привести к неточности измерений.

A, R1, R2, B Приемники

Auto Gain - PNA выбирает оптимальный уровень усиления для проведения импульсных измерений.

Low (Низкий) – усиление около 0 дБ

Med (Средний) – усиление около 17 дБ

Hi (Высокий) – усиление около 34 дБ

Конфигурация переключения ПЧ (IF Switch Configuration)

Настройка параметров переключения ПЧ позволяет выбрать входную цепь для усилителя ПЧ PNA.

Справка по диалоговому окну IF Switch Configuration

Доступно только с опцией H11

Normal (Обычный) - позволяет PNA выбрать входную цепь для усилителей ПЧ PNA.

External (Внешний) – всегда использует входы на задней панели для усилителей ПЧ PNA.


Конфигурация внешнего миллиметрового модуля

Конфигурирование внешнего модуля миллиметровых волн

Чтобы расширить диапазон частот вашего PNA можно использовать внешний миллиметровый модуль. Для того чтобы использовать эту функцию у вашего PNA должна иметься опция H11.

  • Ограничения PNA при использовании внешнего миллиметрового модуля

  • Как конфигурировать миллиметровые модули

Другие разделы по доступу к ПЧ

Ограничения PNA при использовании внешнего миллиметрового модуля

Настройки мощности При использовании внешнего миллиметрового модуля PNA не может управлять уровнем мощности на тестируемом устройстве выше 67 ГГц. Из-за этого ограничения, настройки мощности PNA будут функционировать неправильно. Некоторые из этих настроек это: уровень мощности при стандартном или сегментированном свипировании, калибровки мощности источника и приемника и интерполяция калибровки. У вашего модуля может быть ручное управление мощностью.

Измерения со сдвигом частоты При использовании внешнего миллиметрового модуля не поддерживаются измерения со сдвигом частоты, из-за большого количества конфигураций используемых при измерениях со сдвигом частоты.

Как конфигурировать миллиметровые модули

Узнайте больше об использовании интерфейса передней панели

Справка по диалоговому окну Millimeter Head Setup

Важные замечания

  • Внешний источник ТЕРЯЕТ СИНХРОНИЗАЦИЮ после выполнения предварительной настройки PNA, вызова состояния прибора или добавления канала. Если это произошло, то запустите снова данное диалоговое окно и нажмите OK. Мы настоятельно рекомендуем использовать только один канал для выполнения измерений с использованием внешних источников.

  • При измерениях до 110 ГГц фазовые шумы при использовании внутреннего источника PNA и внешних источников имеют сравнимые величины. Для максимальной точности измерений на частотах выше 110 ГГц настоятельно рекомендуется использовать внешние источники.

  • Поддерживаются только источники Agilent PSG.

Selected Module Выбранный модуль. Отображает выбранный в данный момент модуль. Для выбора и конфигурирования другого модуля нажмите Module Config.

Use External Sources Использовать внешний источник. Поставьте отметку для того чтобы использовать внешний источник, предоставляющий гетеродин (LO) для миллиметрового модуля.

Source Config Конфигурация источника. Нажмите чтобы вызвать диалоговое окно конфигурации внешнего источника. Это диалоговое окно также используется для того чтобы настроить внешние источники для приложения FCA. Пропустите ссылки на раздел FCA в справочнике.

Кроме того, приведенные ниже настройки этого диалогового окна НЕ важны для предварительной установки миллиметрового модуля:

  • Trigger Mode Режим запуска. Запуск по аппаратному перечню (Hardware List (BNC)) всегда используется для управления источниками РЧ и гетеродина для предварительной установки миллиметрового модуля. Читайте комментарии и следуйте схеме установки для двух внешних источников.

  • LO Calibration Калибровка гетеродина. Мощность на выходе источников устанавливается и контролируется опцией H11.

Справка по диалоговому окну Millimeter Module Configuration

Millimeter Module Configuration List Перечислены стандартные и созданные Вами конфигурации PNA.

New Нажмите чтобы создать новую конфигурацию миллиметрового модуля. Вызывает диалоговое окно Name. Введите уникальное (однозначно определяющее) название новой конфигурации используя только буквенно-цифровые символы и подчеркивание, затем нажмите OK.

Delete Удаляет конфигурацию миллиметрового модуля.

Restore Defaults Удаляет все конфигурации за исключением стандартных для PNA (и N5250A если он установлен).

Save Сохраняет текущие настройки на жесткий диск PNA.

Testport Frequency Range Определяет частоту пуска и останова выбранной конфигурации измерительных портов. После активации (нажмите Activate Selected Config) они будут отображаться как частоты пуска и останова PNA.

RF Freq Range Multiplier Частотный диапазон РЧ (указанный в сером поле), умноженный на эту величину = диапазону частот измерительного порта.

Используйте значение множителя, указанное в документации на миллиметровый модуль.

LO Freq Range Multiplier Частотный диапазон гетеродина (указанный в сером поле) умноженный на эту величину + 8.33 МГц = диапазону частот измерительного порта.

Примечание: Если диапазоны частот гетеродина и РЧ не будут находиться в пределах рабочего диапазона PNA, появится предупреждающее сообщение вместе с красным окном вокруг неправильного поля. Выберите большее или меньшее подходящее значение множителя для того чтобы исправить проблему.

Use Standard PNA operation when N5260A is NOT connected (Использовать стандартные операции PNA если N5260A не подсоединен). При нажатии Activate Selected Config анализатор проверяет подсоединен ли N5260A. Если он НЕ подсоединен и:

  • В данном окне стоит отметка, то выбранная конфигурация НЕ активируется, а используется стандартная конфигурация PNA.

  • Данное окно пустое, тогда выбранная конфигурация БУДЕТ активироваться в любом случае.

Cancel Закрывает диалоговое окно без сохранения изменений.

Close Выдает запрос на сохранение изменений, а затем закрывает диалоговое окно.

Activate Selected Config Сохраняет конфигурацию, а затем закрывает и перезапускает приложение PNA с новой конфигурацией. Для того чтобы перейти к другой конфигурации, включая и стандартную конфигурацию PNA, необходимо провести эту процедуру снова.


Приложение для импульсных измерений

Приложение для импульсных измерений (Pulsed Application)

Pulsed Application - программа на Visual Basic, которая предоставляет пользовательский интерфейс для проведения импульсных измерений.

  • Необходимые опции

  • Использование Pulsed Application

  • Конфигурирование генераторов импульсов и приемников

  • Формирование профиля импульса

  • Ослабление сигнала в зависимости от ширины стробирующего импульса

  • Импульсные измерения с преобразованием частоты

  • Создание собственного приложения Pulsed Application

Для получения более общей информации об импульсных измерениях посетите сайт www.Agilent.com и найдите AN 1408-11.

Другие разделы по доступу к ПЧ

Необходимые опции

Опция H08 PNA предоставляет приложение для импульсных измерений (Pulsed Application). Для опции H08 необходимо, чтобы у вашего PNA также были Опция 014 (доступ с передней панели) и Опция 080 (частота смещения). Для того чтобы использовать функцию временной селекции встроенного приемника в приложении Pulsed Application, у вашего PNA должна быть опция опция H11 аппаратных средств. Если у PNA нет требуемых опций, то на экране отображается соответствующее сообщение.

Использование приложения Pulsed Application

Запуск приложения Pulsed Application

  1. Нажимайте [image] пока не увидите Pulse, затем

    или

Узнайте больше об использовании интерфейса передней панели

Ввод данных с клавиатуры

цифровой ввод и навигационные клавиши PNA. Также для ввода величин, включая буквенные символы для префиксов (например, u для usec.) . После ввода величины сначала нажмите Ввод (Enter), а затем Tab для того чтобы перейти к следующему полю.

Ниже приведено изображение главного диалогового окна:

Pulsed Application Main справка по диалоговому окну

Примечание: на анализаторе может появиться сообщение об ошибке, утверждающее, что частота отклика превысила максимально разрешенную частоту.

Приложение Pulsed Application для частоты смещения (опция 080) PNA может установить некоторую величину отличную от нуля (значения, устанавливаемого по умолчанию). Если для частоты останова установлено значение максимальное для данной модели PNA, то появится сообщение об ошибке.

Для того чтобы исправить это, установите для частоты останова значение, которое, по крайней мере, на 2 кГц меньше максимально разрешенного. Например, если у вас 20 ГГц PNA и при установке для частоты останова 20 ГГц появляется сообщение об ошибке, тогда установите частоту останова 19.999998 ГГц.

Configure

Вы можете задействовать более одного канала для проведения измерений в импульсном режиме, но каналы должны использовать одни и те же настройки генератора импульсов.

С приложением Pulsed Application работает только генератор импульсов Agilent 81110A. Характеристики частоты повторения импульсов и скважности указаны в документации для 81110A.

Смотрите также:

Конфигурирование приемников

Измерения с преобразованием частоты

Edit / Undo Возвращает настройки приложения Pulsed Application к тем, для которых в последний раз нажималось Применить (Apply).

Desired PRF and IFBW Ввод желаемых значений. Если нажато Calculate, то одно или оба этих значения могут измениться.

Pulse Repetition Frequency: Частота повторения импульсов с генератора импульсов.

Receiver IF Bandwidth: Полоса пропускания ПЧ приемника PNA. Выберите параметр от 1 Гц до 10 кГц.

Fixed PRF Фиксированная Частота повторения импульсов. Если отмечено (установка по умолчанию), то алгоритм расчета НЕ устанавливает PRF, а изменяет только полосу ПЧ.

Modulation/Gates Модуляция источника и временные селекторы четырех приемников PNA могут иметь каждый свой или разделять общие выходы генератора импульсов. Разделяемые выходы имеет одинаковые значения ширины и задержки. Для того чтобы сконфигурировать и включить выходы нажмите Configure, а затем Pulse Generators, чтобы запустить диалоговое окно конфигурации генератора импульсов.

Width Ширина импульса.

Delay Задержка, которая возникает перед импульсом.

Duty Cycle Рассчитанная скважность источника и каждого из выбранных приемников.

Pulse Mode On Если в окне стоит отметка, то PNA может производить измерения в импульсном режиме. Информация в строке текущего состояния PNA указывает на следующее:

  • G Внутренние временные селекторы ПЧ включены.

  • F Фильтрация для импульсных измерений включена.

Apply Все выбранные значения отправляются на генератор импульсов и активные каналы PNA.

Calculate Все выбранные элементы рассчитываются и правильные значения PRF и IFBW вводятся в соответствующие поля. Если эти установки неприемлемы, попытайтесь изменить введенные ранее величины и снова нажмите Calculate. При достижении приемлемых значений нажмите Apply, для того чтобы передать эти величины на генератор импульсов и PNA.

Pulse Profile Запускает диалоговое окно Pulse Profile (форма импульса). То же, что и нажатие View / Pulse Profile.

Minimize Нажмите чтобы свернуть диалоговое окно и произвести изменения в приложении PNA.

Save Все настройки из приложения Pulsed Application сохраняются в файле *.ppf. Эти настройки НЕ сохраняются в состоянии прибора PNA.

Recall Восстанавливает предварительно сохраненные настройки из указанного файла *.ppf.

Close Закрывает диалоговое окно без сохранения изменений.

Конфигурирование генераторов импульсов и приемников

Из главного диалогового окна приложения Pulsed Application

Если эти настройки недоступны нажмите Calculate.

Pulsed Generator Configuration справка по диалоговому окну

Изменяет установки сигналов на выходе генератора импульсов Agilent 81110A. Можно изменить установки любого генератора импульсов 81110A с одним или двумя модулями вывода 81111A.

Модуляция источника и временные селекторы четырех приемников PNA могут иметь каждый свой или разделять общие выходы генератора импульсов. Для того чтобы подать сигнал с выхода генератора на один или более входов PNA используйте один и тот же GPIB адрес и выходной модуль для каждого входа PNA. Это приводит к тому что общие входные сигналы PNA будут иметь одинаковые значения Ширины и Задержки, выбранные в главном диалоговом окне.

Source Mod: Выход с которого подаются импульсы на источник.

A, B, R1, R2 IF Gate: Разъем на задней панели PNA принимающий стробирующий импульс.

GPIB Addr: GPIB адрес 81110A.

Output: Модуль устройства вывода 81111A.

Master: который использует опорный сигнал 10 МГц от PNA.

Enabled: ВКЛЮЧАЕТ выход импульсов.

High: Устанавливает уровень напряжения 'TTL-Высокий'

Low: Устанавливает уровень напряжения 'TTL-Низкий'

Ext Impedance: Импеданс тестируемого устройства

Complement: Когда это окошко пустое, то импульсом будет TTL ВЫСОКИЙ. Когда отмечено, то импульсом будет TTL НИЗКИЙ.

Using Internal PNA gates Когда это окошко отмечено, то значения напряжения, импеданса и дополнительные величины принудительно устанавливаются таким образом, чтобы предотвратить повреждение внутренних временных селекторов.

Receiver Gain Configuration справка по диалоговому окну

Вручную или автоматически устанавливает усиление для каждого приемника.

Auto - PNA выбирает оптимальный уровень усиления для проведения измерения в импульсном режиме.

Для того чтобы вручную установить усиление для каждого приемника используйте следующее.

Low - усиление около 0 дБ

Medium - усиление около 17 дБ

High - усиление около 24 дБ

Некоторые модели PNA имеют только две установки усиления вместо трех как это показано на предыдущем рисунке.

Формирование профиля импульса

Формирование профиля импульса предоставляет вид огибающей импульса во временной области. Формирование профиля выполняется с использованием техники измерений, которая "проводит" короткий "снимок", сделанный приемником, по всей ширине импульса. Это аналогично тому, как используется камера, для того чтобы сделать множество маленьких кадров широкого изображения, а затем эти кадры собираются так, чтобы сформировать один панорамный вид.

  • Формирование профиля импульса может быть выполнено с использованием относительных или абсолютных измерений.

  • Формирование профиля импульса выполняется на частоте одного гармонического колебания (CW).

Как выполнить формирование профиля импульса

Из главного диалогового окна приложения Pulsed Application

Если эти настройки недоступны нажмите Calculate.

Pulse Profile справка по диалоговому окну

Подробнее о формировании профиля импульса (см. выше)

Параметры времени

Start, Stop Комбинация этих двух параметров необходима для создания окна сборного профиля импульса. Для того чтобы увидеть весь импульс, значения пуска и останова должны быть по крайней мере такой же ширины как ширина импульса с модулируемого источника плюс значение задержки (из главного диалогового окна приложения Pulsed Application).

Step К каждому следующему снимку состояния добавляется данное значение пока не будет достигнуто значение останова. Поэтому количество точек для измерения профиля импульса можно рассчитать следующим образом: (Stop - Start) / Step. Чем больше количество точек, тем больше времени занимает проведение измерений.

Параметры измерения

CW Freq. Частота источника PNA.

Source Port Порт PNA, подающий мощность источника для измерений на одном приемнике (Приемники A, B, R1, R2)

Select a Measurement Доступны временные селекторы только тех приемников, которые сконфигурированы в диалоговом окне Конфигурирование генератора импульсов. Выберите из следующего:

Unratioed (single receiver) абсолютная величина (один приемник) - A, B, R1, R2

или

S-parameters (ratioed) S-параметры (относительная величина)

Измерения доступны в зависимости от того временные селекторы каких приемников сконфигурированы:

  • Для измерения S11, сконфигурируйте A и (опционально) R1.

  • Для измерения S21, сконфигурируйте B и (опционально) R1.

  • Для измерения S12, сконфигурируйте A и (опционально) R2.

  • Для измерения S22, сконфигурируйте B и (опционально) R2.

Если временной селектор опорного приемника (R1 или R2) НЕ включен в конфигурацию, то в качестве опоры используется среднее значение импульса с модулируемого источника.

Например:

Выбран S21, в конфигурацию включен ТОЛЬКО приемник B

Стробирующий импульс B проходит через импульс модулируемого источника.

Среднее значение импульса модулируемого источника используется в качестве опорного сигнала (не стробированного).

Coupled Gates (Связанные стробирующие импульсы) Доступны, если временные селекторы соответствующих приемников сконфигурированы для измерения относительных величин.

  • Uncoupled (box cleared) не связанные (отметка снята) Опорный стробирующий импульс ЗАФИКСИРОВАН в настройках задержки, в то время как измерительный стробирующий импульс проходит через импульс модулируемого источника.

Например:

Выбран S21, в конфигурацию включены стробирующие импульсы приемников B и R1, стробирующие импульсы не связаны Uncoupled

Стробирующий импульс B проходит через импульс модулируемого источника.

Стробирующий импульс R1 зафиксирован в настройках ширины и задержки импульса.

  • Coupled связанные (окно отмечено). Опорный стробирующий импульс движется одновременно с измерительным стробирующим импульсом с указанной величиной задержки.

Например:

Выбран S21, в конфигурацию включены стробирующие импульсы приемников B и R1, стробирующие импульсы связаны.

задержка стробирующего импульса B = 3 микросекунды, задержка стробирующего импульса R1 = 2 микросекунды,

Стробирующий импульс B проходит через импульс модулируемого источника.

Стробирующий импульс R1 зафиксирован в настройках ширины и задержки импульса.

Стробирующий импульс B опережает стробирующий импульс R1 на одну микросекунду.

Data Format Формат отображения данных Логарифмическая амплитуда, Линейная амплитуда или Фаза (доступна только если выбраны S-параметры).

Кнопки

Show Gates Показать стробирующие импульсы Позволяет изменять ширину и задержку стробирующего импульса приемника сразу видя результат.

Measure Измерение. Нажмите чтобы запустить измерение профиля импульса. Полоса над кнопкой показывает степень выполнения.

Marker to Delay Маркер для Задержки После выполнения измерения вы можете перетащить маркер дисплея в любую точку на графике. Нажмите эту кнопку и соответствующее маркеру время будет введено в поле задержки приемника в главном диалоговом окне.

Save Data Сохранить данные. Сохраняет данные временной области на жесткий диск PNA в любом из следующих форматов:

  • Touchstone (*.s1p)

  • Через запятую (*.prn)

  • Citifile (*.cti)

Подробнее об этих форматах данных.

Ослабление сигнала в зависимости от ширины стробирующего импульса

Ослабление сигнала в зависимости от ширины стробирующего импульса

PRF = 1 МГц

На двух приведенных ниже графиках показаны характеристики внутренних временных селекторов ПЧ при уменьшении ширины стробирующих импульсов.

Ниже увеличенное изображение затемненной области (см. выше).

  • Сплошная линия показывает теоретические потери в динамическом диапазоне из-за влияния скважности при использовании узкополосного детектирования.

  • Кривая (красная) линия показывает реально измеренную характеристику внутренних временных селекторов.

  • Минимальная ширина стробирующего импульса для отклонения на < 1дБ от теоретического значения составляет приблизительно 20 нс.

См. технические характеристики для опции H11 и опции H08.

Импульсные измерения с преобразованием частоты

Приложение Pulsed Application работает как с измерениями FCA (опция 083) так и со стандартными измерениями сдвига частоты (опция 080). В меню Configure выберите Converter Measurements. При их выборе эти настройки защищают приложение Pulsed Application от перезаписи величин сдвига частоты. Это может ограничить количество решений для PRF и IFBW которые получаются при нажатии Calculate в главном диалоговом окне приложения Pulsed Application.

Примечание: формирование импульса НЕ может быть выполнено при измерениях с преобразованием частоты.

Создание собственного приложения Pulsed Application

Вы можете использовать приложение Pulsed Application или создать свое собственное приложение Pulsed Application используя в качестве шаблона пример программы.

Для выполнения расчетов необходимых для проведения измерений в импульсном режиме приложение Pulsed Application использует клиентские .dll. Для передачи и возврата данных в agilentpnapulsed.dll используйте метод ConfigNarrowBand3. Затем воспользуйтесь командами SCPI или COM для управления PNA.

Установка и регистрация .dll для импульсных измерений на персональном компьютере

Для создания своего собственного приложения Pulsed Application или запуска приложения Pulsed Application с удаленного ПК необходимо выполнить следующее:

  1. Скопировать следующие файлы из PNA C:\program files\agilent\network analyzer\ в каталог на Вашем ПК.

    • agilentpnapulsed.dll

    • OffsetList.txt

    • prfbw.txt

    • prfbwmixer.txt

  2. Для того чтобы зарегистрировать ActiveX DLL в операционной системе Microsoft Windows:

    • Из командной строки ПК перейдите в католог в который были скопированы DLL.

    • Наберите: regsvr32 agilentpnapulsed.dll и нажмите Enter

Для того чтобы узнать как зарегистрировать DLL файлы в других операционных системах (не Windows) смотрите их справочные файлы.


Specs: E835x Analyzers

Technical Specifications for the E8356A, E8357A, E8358A
(Rev. 2005-07-12)

This is a complete list of the E8356A, E8357A, and E8358A network analyzer technical specifications.

  • To optimize viewing of uncertainty curves, click the Maximize button.

  • To view or print the .pdf version of the specifications, visit our web site at http://www.agilent.com/find/pna, and search for "E835xA Specifications"

  • The uncertainty curves contained in this document apply only to the setup conditions listed. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your PNA setup. View the equations used to generate the uncertainty curves.

  • Definitions

  • Corrected System Performance

    • System Dynamic Range

    • Type-N Connectors

    • 3.5 mm Connectors

    • 7-16 Connectors

  • Uncorrected Instrument Performance

  • Test Port Output Characteristics (Source)

  • Test Port and Receiver Input Characteristics

  • General Information

  • Front-panel Jumper Specs

  • Measurement Throughput Summary

  • Test Set Block Diagram

  • Test Set with Option 015 Block Diagram

See Specs for other PNA models

Definitions

All specifications and characteristics apply over a 25 °C ±5 °C range (unless otherwise stated) and 90 minutes after the instrument has been turned on.

Specification (spec.): Warranted performance. Specifications include guardbands to account for the expected statistical performance distribution, measurement uncertainties, and changes in performance due to environmental conditions.

Characteristic (char.): A performance parameter that the product is expected to meet before it leaves the factory, but that is not verified in the field and is not covered by the product warranty. A characteristic includes the same guardbands as a specification.

Typical (typ.): Expected performance of an average unit which does not include guardbands. It is not covered by the product warranty.

Nominal (nom.): A general, descriptive term that does not imply a level of performance. It is not covered by the product warranty.

Calibration: The process of measuring known standards to characterize a network analyzer's systematic (repeatable) errors.

Corrected (residual): Indicates performance after e rror c orrection (calibration). It is determined by the quality of calibration standards and how well "known" they are, plus system repeatability, stability, and noise.

Uncorrected (raw): Indicates instrument performance without error correction. The uncorrected performance affects the stability of a calibration.

Standard: When referring to the analyzer, this includes no options unless noted otherwise.

Corrected System Performance

The specifications in this section apply for measurements made with the E8356A, E8357A, and E8358A analyzer with the following conditions:

  • 10 Hz IF bandwidth

  • No averaging applied to data

  • Environmental temperature of 25 °C ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted

Note: The uncertainty curves contained in these specifications apply only to the setup conditions listed. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your PNA setup. View the equations used to generate the uncertainty curves.

  • System Dynamic Range

  • Type-N Connectors

  • 3.5 mm Connectors

  • 7-16 Connectors

Table 1. System Dynamic Range

Description | Specification (dB) | Characteristic (dB)
Dynamic rangea (at test port)
300 kHz to 25 MHzb | 125 |
25 MHz to 3 GHzb | 128 |
3 GHz to 6 GHz | 118 |
6 GHz to 9 GHz | 113 |
Dynamic rangec (at receiver input)
300 kHz to 25 MHzd |  | 140
25 MHz to 3 GHzd |  | 143
3 GHz to 6 GHz |  | 133
6 GHz to 9 GHz |  | 128

a The test port dynamic range is calculated as the difference between the test port rms noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account.
b May be limited to 100 dB at particular frequencies below 750 MHz due to spurious receiver residuals.
c The receiver input dynamic range is calculated as the difference between the receiver rms noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account. This set-up should only be used when the receiver input will never exceed its damage level. When the analyzer is in segment sweep mode, frequency segments can be defined with a higher power level when the extended dynamic range is required (i.e. the portion of the device's response with high insertion loss), and reduced power when receiver damage may occur (i.e. the portion of the devices's response with low insertion loss).
d May be limited to 115 dB at particular frequencies below 750 MHz due to spurious receiver residuals.

Note: Receiver Dynamic Range specifications are not included in this E8356/7/8A document.

Corrected System Performance with Type-N Connectors

  • 85032F Calibration Kit

  • 85092C Electronic Calibration Module

Note: This document provides technical specifications for the following calibration kits only: 85032F, 85092C, 85033E, 85093C and 85038A.

Table 2. Corrected System Performance With Type-N Device Connectors, 85032F Calibration Kit

Applies to the E8356A, E8357A, and E8358A analyzer, 85032F (Type-N, 50W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHz
Directivity | 49 | 46 | 40 | 38
Source Match | 41 | 40 | 36 | 35
Load Match | 49 | 45 | 39 | 37
Reflection Tracking | ±0.011 | ±0.021 | ±0.032 | ±0.054
Transmission Tracking | ±0.011 | ±0.019 | ±0.041 | ±0.051

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 3. Corrected System Performance With Type-N Device Connectors, Option 015 With 85032F Calibration Kit

Applies to the E8356A, E8357A, and E8358A analyzer with Option 015, 85032F (Type-N, 50W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHz
Directivity | 49 | 46 | 40 | 38
Source Match | 41 | 40 | 36 | 35
Load Match | 49 | 45 | 39 | 37
Reflection Tracking | ±0.011 | ±0.021 | ±0.032 | ±0.054
Transmission Tracking | ±0.011 | ±0.024 | ±0.052 | ±0.065

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 4. Corrected System Performance With Type-N Device Connectors, 85092C Electronic Calibration Module

Applies to the E8356A, E8357A, and E8358A analyzer, 85092C (Type-N, 50W) electronic calibration (ECal) module, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 Hz | 6 to 9 GHza
Directivity | 52 | 54 | 52 | 47
Source Match | 45 | 44 | 41 | 36
Load Match | 47 | 47 | 44 | 39
Reflection Tracking | ±0.040 | ±0.040 | ±0.060 | ±0.070
Transmission Tracking | ±0.039 | ±0.039 | ±0.068 | ±0.135

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 5. Corrected System Performance With Type-N Device Connectors, Option 015 With 85092C Electronic Calibration Module

Applies to the E8356A, E8357A, and E8358A analyzer with Option 015, 85092C (Type-N, 50W) electronic calibration (ECal) module, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHza
Directivity | 52 | 54 | 52 | 47
Source Match | 45 | 44 | 41 | 36
Load Match | 47 | 47 | 44 | 39
Reflection Tracking | ±0.040 | ±0.040 | ±0.060 | ±0.070
Transmission Tracking | ±0.039 | ±0.039 | ±0.068 | ±0.135

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Corrected System Performance with 3.5 mm Connectors

  • 85033E Calibration Kit

  • Option 015 with 85033E Calibration Kit

  • 85093C Electronic Calibration Module

  • Option 015 with 85093C Electronic Calibration Module

Table 6. Corrected System Performance With 3.5 mm Device Connector Type, 85033E Calibration Kit

Applies to the E8356A, E8357A, and E8358A analyzer, 85033E (3.5 mm, 50 W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHz
Directivity | 46 | 44 | 38 | 38
Source Match | 43 | 40 | 37 | 36
Load Match | 46 | 44 | 38 | 38
Reflection Tracking | ±0.006 | ±0.007 | ±0.009 | ±0.010
Transmission Tracking | ±0.011 | ±0.020 | ±0.041 | ±0.047

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 7. Corrected System Performance With 3.5 mm Device Connector Type, Option 015 With 85033E Calibration Kit

Applies to the E8356A, E8357A, and E8358A analyzer with Option 015, 85033E (3.5 mm, 50W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHz
Directivity | 46 | 44 | 38 | 38
Source Match | 43 | 40 | 37 | 36
Load Match | 46 | 44 | 38 | 38
Reflection Tracking | ±0.006 | ±0.007 | ±0.009 | ±0.010
Transmission Tracking | ±0.011 | ±0.025 | ±0.052 | ±0.059

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 8. Corrected System Performance With 3.5 mm Device Connector Type, 85093C Electronic Calibration Module

Applies to the E8356A, E8357A, and E8358A analyzer, 85093C (3.5 mm, 50 W) electronic calibration (ECal) module, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHza
Directivity | 52 | 52 | 51 | 47
Source Match | 44 | 44 | 39 | 34
Load Match | 47 | 47 | 44 | 40
Reflection Tracking | ±0.030 | ±0.040 | ±0.050 | ±0.070
Transmission Tracking | ±0.039 | ±0.049 | ±0.068 | ±0.116

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 9. Corrected System Performance With 3.5 mm Device Connector Type, Option 015 With 85093C Electronic Calibration Module

Applies to the E8356A, E8357A, and E8358A analyzer with Option 015, 85093C (3.5 mm, 50 W) electronic calibration (ECal) module, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHza
Directivity | 52 | 52 | 51 | 47
Source Match | 44 | 44 | 39 | 34
Load Match | 47 | 47 | 44 | 40
Reflection Tracking | ±0.030 | ±0.040 | ±0.050 | ±0.070
Transmission Tracking | ±0.039 | ±0.049 | ±0.068 | ±0.116

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Corrected System Performance with 7-16 Connectors

  • 85038A Calibration Kit

  • Option 015 with 85038A Calibration Kit

Table 10. Corrected System Performance With 7-16 Device Connector Type, 85038A Calibration Kit

Applies to the E8356A, E8357A, and E8358A analyzer, 85038A (7-16, 50 W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHza
Directivity | 40 | 40 | 36 | 36
Source Match | 37 | 37 | 34 | 34
Load Match | 39 | 39 | 35 | 35
Reflection Tracking | ±0.089 | ±0.089 | ±0.115 | ±0.115
Transmission Tracking | ±0.022 | ±0.031 | ±0.059 | ±0.062

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 11. Corrected System Performance With 7-16 Device Connector Type, Option 015 With 85038A Calibration Kit

Applies to the E8356A, E8357A, and E8358A analyzer with Option 015, 85038A (7-16, 50 W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHza
Directivity | 40 | 40 | 36 | 36
Source Match | 37 | 37 | 34 | 34
Load Match | 39 | 39 | 35 | 35
Reflection Tracking | ±0.089 | ±0.089 | ±0.115 | ±0.115
Transmission Tracking | ±0.022 | ±0.040 | ±0.075 | ±0.080

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Uncorrected Instrument Performance

Table 12. Uncorrected Instrument Performance

Description | Specification (dB)
 | 300 kHz to 1 MHz | 1MHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 GHz to 6 GHz | 6 GHz to 9 GHz
Directivity | 30 | 33 | 27 | 20 | 13
Source Match | 20 | 20 | 17 | 15 | 14
Source Match (Opt. 015) | 20 | 20 | 15 | 13 | 12
Load Match | 20 | 20 | 17 | 15 | 15
Load Match (Opt. 015) | 20 | 20 | 15 | 13 | 13
Reflection Tracking | ±1.5 | ±1.5 | ±1.5 | ±2.5 | ±3.0
Transmission Tracking | ±1.5 | ±1.5 | ±1.5 | ±2.5 | ±3.0

Test Port Output Characteristics (Source)

  • Output Frequency

  • Output Power

  • Output Signal Purity

Table 13. Test Port Output Frequency

Description | Specification | Supplemental Information
Range
E8356A | 300 kHz to 3.0 GHz |
E8357A | 300 kHz to 6.0 GHz |
E8358A | 300 kHz to 9.0 GHz |
Resolution | 1 Hz |
Source Stability |  | ±0.05 ppm, -0° to 40 °C, typical ±0.1 ppm/year, typical
CW Accuracy | ±1 ppm |

Table 14. Test Port Output Powera

Description | Specification | Supplemental Information
Level Accuracy
 |  | Variation from 0 dBm in power range 0 (step attenuator at 0 dB) ±1.5dB below 10 MHz
300 kHz to 10 MHz | ±1.5 dB |
10 MHz to 6 GHz | ±1.0 dB |
6 GHz to 9 GHz | ±2.0 dB |
Level Linearity
 |  | Variation from 0 dBm in power range 0
300 kHz to 9 GHz | ±0.3 dB | -15 to +5 dBm
300 kHz to 1 MHz | ±1.0 dB | +5 to +10 dBm
1 MHz to 6 GHz | ±0.5 dB | +5 to +10 dBm
Rangeb
300 kHz to 6 GHz | -85 to +10 dBm |
6 GHz to 9 GHz | -85 to +5 dBm |
Sweep Range
300 kHz to 6 GHz | 25 dB |
6 GHz to 9 GHz | 20 dB |
Level Resolution | 0.01 dB |

a Source output performance on port 1 only. Port 2 output performance is typical.

b Power to which the source can be set and phase lock is assured.

Table 15. Test Port Output Signal Purity

Description | Specification | Supplemental Information
Harmonics (2nd or 3rd)
at max output power (< 25 MHz) |  | < -25 dBc, typical
at max output power (25 MHz to 9 GHz) |  | < -25 dBc, characteristica
at 0 dBm output |  | < -35 dBc, typical
at -10 dBm output |  | < -38 dBc, typical, in power range 0 (step attenuator at 0 dB)
Non-harmonic Spurious
at max output |  | -30 dBc, typical for offset freq >1kHz
at -10 dBm output |  | -50 dBc, typical for offset freq >1kHz

a Typical below 25 MHz.

Test Port and Receiver Input Characteristics

  • Input Levels

  • Trace Noise

  • Reference Level and Stability

  • Dyn amic Accuracy

  • Group Delay

Table 16. Test Port and Receiver Input Levels

Description | Specification | Supplemental Information
Maximum Test Port Input Level
Test Ports 1 and 2:
300 kHz to 25 MHz | +10 dBm | < 0.6 dB compression
25 MHz to 3 GHz | +10 dBm | < 0.4 dB compression
3 GHz to 6 GHz | +10 dBm | < 0.7 dB compression
6 GHz to 9 GHz | +5 dBm | < 0.7 dB compression
Damage Level
Test Port 1, 2 |  | +30 dBm or ±30 VDC, typ.
R1, R2 IN |  | +15 dBm or ±5 VDC, typ.
A, B IN (standard) |  | +15 dBm or ±5 VDC, typ.
A, B IN (Opt. 015) |  | +15 dBm or ±0 VDC, typ.
Coupler IN (Opt. 015) |  | +33 dBm or ±0 VDC, typ.
Test Port Noise Floora
300 kHz to 25 MHzb |  |
10 Hz IF Bandwidth | ≤ -115 dBm |
1 kHz IF Bandwidth | ≤ -95 dBm |
25 MHz to 3 GHzb |  |
10 Hz IF Bandwidth | ≤ -118 dBm |
1 kHz IF Bandwidth | ≤ -98 dBm |
3 GHz to 9 GHz |  |
10 Hz IF Bandwidth | £ -108 dBm |
1 kHz IF Bandwidth | £ -88 dBm |
Receiver Noise Floora
300 kHz to 25 MHzc |  |
10 Hz IF Bandwidth | £ -130 dBm |
1 kHz IF Bandwidth | £ -110 dBm |
25 MHz to 3 GHzc |  |
10 Hz IF Bandwidth | £ -133 dBm |
1 kHz IF Bandwidth | £ -113 dBm |
6 GHz to 9 GHz |  |
10 Hz IF Bandwidth | £ -123 dBm |
1 kHz IF Bandwidth | £ -103 dBm |
Crosstalk
 |  | Between test ports 1 and 2, with short circuits at both ports
300 kHz to 1 MHz | <-120 dB |
1 MHz to 25 MHz | <-125 dB |
25 MHz to 3 GHz | <-128 dB |
3 GHz to 6 GHz | <-118 dB |
6 GHz to 9 GHz | <-113 dB |
Maximum Receiver Input Level (A, B, R1, R2)
300 kHz to 6 GHz |  | -6 dBm, typical
6 GHz to 9 GHz |  | -11 dBm, typical
Reference Input Level (R1, R2)d
300 kHz to 9 GHz |  | -10 to -35 dBm, typical
Maximum Coupler Input Level (Opt 015)
300 kHz to 9 GHz |  | +33 dBm, typical

a Total average (RMS) noise power calculated as the mean value of a linear magnitude trace expressed in dBm.

b May be limited to -90 dBm at particular frequencies below 750 MHz due to spurious receiver residuals.

c May be limited to -105 dBm at particular frequencies below 750 MHz due to spurious receiver residuals.

d Input level to maintain phase lock.

Table 17. Test Port Input (Trace Noise)

Description | Specification | Supplemental Information
Trace Noisea Magnitude
1 kHz IF Bandwidth | < 0.002 dB rms |
10 kHz IF Bandwidth | < 0.005 dB rms |
Trace Noisea Phase
1 kHz IF Bandwidth | < 0.010° rms |
10 kHz IF Bandwidth | < 0.035° rms |

a Trace noise is defined as a ratio measurement of a through or a full reflection, with the source set to 0 dBm.

Table 18. Test Port Input (Reference Level and Stability)

Description | Specification | Supplemental Information
Reference Level Magnitude
Range | ±200 dB |
Resolution | 0.001 dB |
Reference Level Phase
Range | ±500° |
Resolution | 0.01° |
Stability Magnitudea
300 kHz to 3 GHz |  | 0.02 dB/°C, typical
3 GHz to 6 GHz |  | 0.04 dB/°C, typical
6 GHz to 9 GHz |  | 0.06 dB/°C, typical
Stability Phasea
300 kHz to 3 GHz |  | 0.2°/°C, typical
3 GHz to 6 GHz |  | 0.3°/°C, typical
6 GHz to 9 GHz |  | 0.6°/°C, typical

a Stability is defined as a ratio measurement at the test port.

Table 19. Test Port Input (Dynamic Accuracy specificationa)

Accuracy of the test port input power reading is relative to the reference input power level. Applies to input ports 1 and 2 with the following conditions:

  • IF bandwidth = 10 Hz

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

300 kHz to 3 GHz 300 kHz to 3 GHz

300 kHz to 6 GHz 300 kHz to 6 GHz

300 kHz to 9 GHz 300 kHz to 9 GHz

a Dynamic accuracy is verified with the following measurements:

  • compression over frequency

  • IF linearity at a single frequency of 1.195 GHz and a reference level of -20 dBm

Table 20. Test Port Input (Group Delay)a

Description

Specification

Supplemental Information

Aperture (selectable)

(frequency span)/(number of points -1)

Maximum Aperture

20% of frequency span

Range

0.5 x (1/minimum aperture)

Maximum Delay

Limited to measuring no more than 180° of phase change within the minimum aperture.)

Accuracy

See graph below. Char.

The following graph shows group delay accuracy with type-N full 2-port calibration and a 10 Hz IF bandwidth. Insertion loss is assumed to be < 2 dB and electrical length to be ten meters.

In general, the following formula can be used to determine the accuracy, in seconds, of specific group delay measurement:

±Phase Accuracy (deg)/[360 × Aperture (Hz)]

Depending on the aperture and device length, the phase accuracy used is either incremental phase accuracy or worst case phase accuracy.

a Group delay is computed by measuring the phase change within a specified frequency step (determined by the frequency span and the number of points per sweep).

General Information

  • System Bandwidths

  • Front Panel

  • Rear Panel

  • Environment and Dimensions

Table 21. System Bandwidths

Description | Specification | Supplemental Information
IF Bandwidth Settings
Range |  | 1 Hz to 40 kHz in a 1, 2, 3, 5, 7,10 sequence up to 30 kHz, 35 kHz, 40kHz, nominal

Table 22. Front Panel Information

Description | Supplemental Information
RF Connectors
Type | Type-N, female; 50 W, nominal
Center Pin Protrusion | 0.204 to 0.207 in., characteristic
Probe Power
Connector | 3-pin connector, male
Positive Supply | +15 VDC ±2%, 400 mA, max, characteristic
Negative Supply | -12.6 VDC ±5%, 300 mA, max, characteristic
Display
Size | 21.3 cm (8.4 in) diagonal color active matrix LCD; 640 (horizontal) X 480 (vertical) resolution
Refresh Rate | Vertical 59.83 Hz; Horizontal 31.41 Hz
Display Range
Magnitude | ±200 dB (at 20 dB/div), max
Phase | ±180°, max
Polar | 10 pUnits, min 1000 Units, max
Display Resolution
Magnitude | 0.001 dB/div, min
Phase | 0.01°/div, min
Marker Resolution
Magnitude | 0.001 dB, min
Phase | 0.01°, min
Polar | 0.01 mUnit, min; 0.01°, min

Table 23. Rear Panel Information

Description | Supplemental Information
Test Port Bias Input
Connector | BNC, female
Maximum Voltage | ±30 VDC, typical
Maximum Current (no degradation in RF specifications) | ±200 mA, typical
Maximum Current | ±1 A, typical
Bias Input Connectors
Bias current | 500 mA, maximum
Bias voltage | 40 Volts, maximum
10 MHz Reference In
Connector | BNC, female
Input Frequency | 10 MHz ± 1 ppm, typical
Input Level | -15 dBm to +20 dBm, typical
Input I mpedance | 200 W, nom.
10 MHz Reference Out
Connector | BNC, female
Output Frequency | 10 MHz ± 1 ppm, typical
Signal Type | Sine Wave, typical
Output Level | +10 dBm ± 4 dB into 50 W, typical
Output Impedance | 50 W, nominal
Harmonics | <-40 dBc, typical
VGA Video Output
Connector | 15-pin mini D-Sub; Drives VGA compatible monitors
Devices Supported: | Resolutions:
Flat Panel (TFT) | 1024 X 768, 800 X 600, 640 X 480
Flat Panel (DSTN) | 800 X 600, 640 X 480
CRT Monitor | 1280 X 1024, 1024 X 768, 800 X 600, 640 X 480
 | Simultaneous operation of the internal and external displays is allowed, but with 640 X 480 resolution only. If you change resolution, you can only view the external display (internal display will "white out").
Test Set IO | 25-pin D-Sub connector, available for external test set control
Aux IO | 25-pin D-Sub connector, male, analog and digital IO
Handler IO | 36-pin IDC D-ribbon socket connector; all input/output signals are default set to negative logic; can be reset to positive logic via GPIB command
GPIB | 24-pin D-sub (Type D-24), female; compatible with IEEE-488.
Parallel Port (LPT1) | 25-pin D-Sub connector, female; provides connection to printers or any other parallel port peripheral
Serial Port (COM 1) | 9-pin D-Sub, male; compatible with RS-232
USB Port
 | Universal Serial Bus jack, Type A configuration (4 contacts inline, contact 1 on left); female
Contact 1 | Vcc: 4.75 to 5.25 VDC, 500 mA, maximum
Contact 2 | -Data
Contact 3 | +Data
Contact 4 | Ground
LAN | 10/100BaseT Ethernet; 8-pin configuration; auto selects between the two data rates
Line Power (A third-wire ground is required.)
Frequency at 110/115 V | 50/60/400 Hz
Voltage | 120/240 VAC (Power supply is auto switching.)
Maximum Watts | 500 Watts

Note: Option H08 and Option H11 specifications are not provided in this E8356/7/8A specifications document.

Table 24. Rear Panel Information (continued)

Description | Supplemental Information
External AM Input
Description | Input provides low-frequency AM modulation to test port output signal, or shifts the test port output. Zero volts input gives the power level set by the instrument, a positive voltage gives a higher level, and a negative voltage gives a lower level.
Connector | BNC, female
Input Sensitivity | 8 dB/V, typical
Bandwidth | 1 kHz, typical
Input Impedance | 1 kW, typical
External Detector Input
Description | Input from an external, negative polarity diode detector provides ALC for a test port remote from instrument's front panel
Connector | BNC, female
Input Sensitivity | -500 mV yields approximately -3 dBm at detector's input, typical
Bandwidth | 50 kHz, typical
Input Impedance | 1 kW, nominal

Table 25. Analyzer Environment and Dimensions

Description | Supplemental Information
General Environmental
RFI/EMI Susceptibility | Defined by CISPR Pub. 11, Group 1, Class A, and IEC 50082-1
ESD | Minimize using static-safe work procedures and an antistatic bench mat
Dust | Minimize for optimum reliability
Operating Environment
Temperature | 0 °C to +40 °C Instrument powers up, phase locks, and displays no error messages within this temperature range.
Error-Corrected Temperature Range | 25°C ± 5°C with less than 1°C deviation from calibration temp.
Humidity | 5% to 95% at +40 °C
Altitude | 0 to 4500 m (14,760 ft.)
Non-Operating Storage Environment
Temperature | -40 °C to +70 °C
Humidity | 0% to 90% at +65 °C (non-condensing)
Altitude | 0 to 15,240 m (50,000 ft.)
Cabinet Dimensions
 | Height | Width | Depth
Excluding front and rear panel hardware and feet | 223 mm 8.75 in | 426 mm 16.75 in | 427 mm 16.8 in
As shipped - includes front panel connectors, rear panel bumpers, and feet. | 235 mm 9.25 in | 435 mm 17.10 in | 470 mm 18.5 in
As shipped plus handles | 235 mm 9.5 in | 458 mm 18 in | 501 mm 19.70 in
As shipped plus rack-mount flanges | 235 mm 9.25 in | 483 mm 19 in | 470 mm 18.5 in
As shipped plus handles and flanges | 235 mm 9.25 in | 483 mm 19 in | 501 mm 19.70 in
Weight
Net | 24 kg (54 lb), nominal
Shipping | 32 kg (70 lb), nominal

Note: "Misc. Information" specifications are not included in this E8356/7/8A document.

Measurement Throughput Summary

  • Typical Cycle Time for Measurement Completion

  • Cycle Time with Changes in IF Bandwidth

  • Cycle Time with Changes in Number of Points

  • Data Transfer Time

  • Recall and Sweep Speed

Table 26. Typical Cycle Timea,b (ms)

 | Number of Points
 | 101 | 201 | 401 | 1601
Start 1.8 GHz, Stop 2 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 9 | 12 | 18 | 54
2-Port cal | 22 | 29 | 42 | 117
Start 300 kHz, Stop 3 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 39 | 47 | 56 | 96
2-Port cal | 80 | 101 | 121 | 204
Start 300 kHz, Stop 9 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 51 | 57 | 64 | 103
2-Port cal | 112 | 124 | 138 | 220

a Typical performance.
b Includes sweep time, retrace time and band-crossing time. Analyzer display turned off with
DISPLAY:ENABLE OFF. Add 21 ms for display on. Data for one trace (S11) measurement.

Table 27. Cycle Time vs. IF Bandwidtha

Applies to the Preset condition (201 points, correction off) except for the following changes:

  • CF = 1 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
IF Bandwidth (Hz) | Cycle Time (ms)b
40,000 | 8
35,000 | 9
30,000 | 11
20,000 | 13
10,000 | 28
7000 | 36
5000 | 48
3000 | 72
1000 | 196
300 | 620
100 | 1875
30 | 8062
10 | 17877

a Typical performance.
b Cycle time includes sweep and retrace time.

Table 28. Cycle Time vs. Number of Pointsa

Applies to the Preset condition (35 kHz IF bandwidth, correction off) except for the following changes:

  • CF = 1 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
Number of Points | Cycle Time (ms)b
3 | 4
11 | 4
51 | 5
101 | 6
201 | 9
401 | 16
801 | 29
1601 | 52

a Typical performance.
b Cycle time includes sweep and retrace time.

Table 29. Data Transfer Timea (ms)

 | Number of Points
 | 51 | 201 | 401 | 1601
SCPI over GPIB (program executed on external PC)b
32-bit floating point | 3 | 7 | 12 | 43
64-bit floating point | 4 | 12 | 22 | 84
ASCII | 7 | 64 | 124 | 489
SCPI over 100 Mbit/s LAN (program executed on external PC)b
32-bit floating point | 1 | 1 | 1 | 1
64-bit floating point | 1 | 1 | 1 | 2
ASCII | 5 | 15 | 26 | 96
SCPI (program executed in the analyzer)d
32-bit floating point | 1 | 1 | 2 | 3
64-bit floating point | 1 | 2 | 2 | 4
ASCII | 8 | 29 | 56 | 222
COM (program executed in the analyzer)e
32-bit floating point | 1 | 1 | 1 | 1
Variant type | 1 | 1 | 2 | 6
DCOM over 100 Mbit/s LAN (program executed on external PC)f
32-bit floating pointg | 1 | 1 | 1 | 2
Variant typeh | 1 | 3 | 6 | 19

a Typical performance of unit with new 500 MHz Pentium III Processor.
b Measured using a VEE 5.0 program running on a 600 MHz HP Kayak, National InstrumentsTM GPIB card.
Transferred complex S11 data , using "CALC:DATA?SDATA".
c Measured using a VEE 5.0 program running on a 600 MHz HP Kayak. Transferred complex S11 data,
using "CALC:DATA?SDATA". Speed dependent on LAN traffic, if connected to network.
d Measured using a VEE 5.0 program running inside PNA Series Analyzer. Transferred complex S11 data,
using "CALC:DATA?SDATA".
e Measured using a Visual Basic 6.0 program running inside PNA Series Analyzer. Transferred complex S11
data.

f Measured using a Visual Basic 6.0 program running on a 600 MHz HP Kayak. Transferred
complex S11 data. Speed dependent on LAN traffic, if connected to network.

g Used IArray Transfer.getComplex method for 32-bit floating point.

h Used meas.getData method for Variant data type.

Table 30. Recall and Sweep Speeda

Operations | Number of Window(s) | Number of Trace(s) | Recall Time (ms)
Recall | 1 | 1 | 49
Recall and Sweep | 1 | 1 | 59
Recall | 1 | 2 | 82
Recall and Sweep | 1 | 2 | 96
Recall | 1 | 4 | 159
Recall and Sweep | 1 | 4 | 203
Recall | 2 | 2 | 93
Recall and Sweep | 2 | 2 | 115
Recall | 3 | 4 | 158
Recall and Sweep | 3 | 4 | 218
Recall | 4 | 4 | 187
Recall and Sweep | 4 | 4 | 247
Recall | 4 | 8 | 340
Recall and Sweep | 4 | 8 | 507

a CF= 177 MHz, Span = 200 MHz, 201 points, 35 kHz IF BW

E8356A, E8357A, and E8358A – Simplified Test Set Block Diagram

E8356A, E8357A, and E8358A with Option 015 – Simplified Test Set Block Diagram


Specs: E880x Analyzers

Technical Specifications for the E8801A, E8802A, E8803A
(Rev. 2005-07-12)

This is a complete list of the E8801A, E8802A, and E8803A network analyzer technical specifications.

  • To optimize viewing of uncertainty curves, click the Maximize button.

  • To view or print the .pdf version of the specifications, visit our web site at http://www.agilent.com/find/pna, and search for "E880xA Specifications"

  • The uncertainty curves contained in this document apply only to the setup conditions listed. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your PNA setup. View the equations used to generate the uncertainty curves.

  • Definitions

  • Corrected System Performance

    • System Dynamic Range

    • Type-N Connectors

    • 3.5 mm Connectors

    • 7-16 Connectors

  • Uncorrected Instrument Performance

  • Test Port Output Characteristics (Source)

  • Test Port and Receiver Input Characteristics

  • General Information

  • Front-panel Jumper Specs (Option 014 only)

  • Measurement Throughput Summary

  • Test Set Block Diagram

  • Test Set with Option 015 Block Diagram

See Specs for other PNA models

Definitions

All specifications and characteristics apply over a 25 °C ±5 °C range (unless otherwise stated) and 90 minutes after the instrument has been turned on.

Specification (spec.): Warranted performance. Specifications include guardbands to account for the expected statistical performance distribution, measurement uncertainties, and changes in performance due to environmental conditions.

Characteristic (char.): A performance parameter that the product is expected to meet before it leaves the factory, but that is not verified in the field and is not covered by the product warranty. A characteristic includes the same guardbands as a specification.

Typical (typ.): Expected performance of an average unit which does not include guardbands. It is not covered by the product warranty.

Nominal (nom.): A general, descriptive term that does not imply a level of performance. It is not covered by the product warranty.

Calibration: The process of measuring known standards to characterize a network analyzer's systematic (repeatable) errors.

Corrected (residual): Indicates performance after e rror c orrection (calibration). It is determined by the quality of calibration standards and how well "known" they are, plus system repeatability, stability, and noise.

Uncorrected (raw): Indicates instrument performance without error correction. The uncorrected performance affects the stability of a calibration.

Standard: When referring to the analyzer, this includes no options unless noted otherwise.

Corrected System Performance

The specifications in this section apply for measurements made with the E8801A, E8802A, and E8803A analyzer with the following conditions:

  • 10 Hz IF bandwidth

  • No averaging applied to data

  • Environmental temperature of 25 °C ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted

Note: The uncertainty curves contained in these specifications apply only to the setup conditions listed. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your PNA setup. View the equations used to generate the uncertainty curves.

  • System Dynamic Range

  • Type-N Connectors

  • 3.5 mm Connectors

  • 7-16 Connectors

Table 1. System Dynamic Range

Description | Specification (dB) | Characteristic (dB)
Dynamic rangea (at test port)
300 kHz to 25 MHzb | 125 |
25 MHz to 3 GHzb | 128 |
3 GHz to 6 GHz | 118 |
6 GHz to 9 GHz | 115 |
Dynamic rangec (at receiver input)
300 kHz to 25 MHzd |  | 140
25 MHz to 3 GHzd |  | 143
3 GHz to 6 GHz |  | 133
6 GHz to 9 GHz |  | 130

a The test port dynamic range is calculated as the difference between the test port rms noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account.
b May be limited to 100 dB at particular frequencies below 750 MHz due to spurious receiver residuals.
c The receiver input dynamic range is calculated as the difference between the receiver rms noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account. This set-up should only be used when the receiver input will never exceed its damage level. When the analyzer is in segment sweep mode, frequency segments can be defined with a higher power level when the extended dynamic range is required (i.e. the portion of the device's response with high insertion loss), and reduced power when receiver damage may occur (i.e. the portion of the devices's response with low insertion loss).
d May be limited to 115 dB at particular frequencies below 750 MHz due to spurious receiver residuals.

Note: Receiver Dynamic Range specifications are not included in this E8801/2/3A document.

Corrected System Performance with Type-N Connectors

  • 85032F Calibration Kit

  • 85092C Electronic Calibration Module

Note: This document provides technical specifications for the following calibration kits only: 85032F, 85092C, 85033E, 85093C and 85038A.

Table 2. Corrected System Performance With Type-N Device Connectors, 85032F Calibration Kit

Applies to the E8801A, E8802A, and E8803A analyzer, 85032F (Type-N, 50W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 GHz to 6 GHz | 6GHz to 9 GHz
Directivity | 49 | 46 | 40 | 38
Source Match | 41 | 40 | 36 | 35
Load Match | 49 | 45 | 39 | 37
Reflection Tracking | ±0.011 | ±0.021 | ±0.032 | ±0.054
Transmission Tracking | ±0.012 | ±0.020 | ±0.055 | ±0.083

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 3. Corrected System Performance With Type-N Device Connectors, 85092C Electronic Calibration Module

Applies to the E8801A, E8802A, and E8803A analyzer, 85092C (Type-N, 50W) electronic calibration (ECal) module, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 GHz to 6 GHz | 6 to 9 GHza
Directivity | 52 | 54 | 52 | 47
Source Match | 45 | 44 | 41 | 36
Load Match | 47 | 47 | 44 | 39
Reflection Tracking | ±0.040 | ±0.040 | ±0.060 | ±0.070
Transmission Tracking | ±0.039 | ±0.039 | ±0.068 | ±0.136

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Corrected System Performance with 3.5 mm Connectors

  • 85033E Calibration Kit

  • 85093C Electronic Calibration Module

Table 4. Corrected System Performance With 3.5 mm Device Connector Type, 85033E Calibration Kit

Applies to the E8801A, E8802A, and E8803A analyzer, 85033E (3.5 mm, 50W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 GHz to 6 GHz | 6 GHz to 9 GHz
Directivity | 46 | 44 | 38 | 38
Source Match | 43 | 40 | 37 | 36
Load Match | 46 | 44 | 38 | 38
Reflection Tracking | ±0.006 | ±0.007 | ±0.009 | ±0.010
Transmission Tracking | ±0.012 | ±0.021 | ±0.057 | ±0.075

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 5. Corrected System Performance With 3.5 mm Device Connector Type, 85093C Electronic Calibration Module

Applies to the E8801A, E8802A, and E8803A analyzer, 85093C (3.5 mm, 50W) electronic calibration (ECal) module, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 GHz to 6 GHz | 6 GHz to 9 GHza
Directivity | 52 | 52 | 51 | 47
Source Match | 44 | 44 | 39 | 34
Load Match | 47 | 47 | 44 | 40
Reflection Tracking | ±0.030 | ±0.040 | ±0.050 | ±0.070
Transmission Tracking | ±0.039 | ±0.049 | ±0.068 | ±0.117

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 6. Corrected System Performance With 7-16 Device Connector Type, 85038A Calibration Kit

Applies to the E8801A, E8802A, and E8803A analyzer, 85038A (7-16, 50W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHza
Directivity | 40 | 40 | 36 | 36
Source Match | 37 | 37 | 34 | 34
Load Match | 39 | 39 | 35 | 35
Reflection Tracking | ±0.089 | ±0.089 | ±0.115 | ±0.115
Transmission Tracking | ±0.024 | ±0.033 | ±0.082 | ±0.103

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 7. Uncorrected Instrument Performance

Description | Specification (dB)
 | 300 kHz to 1 MHz | 1MHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 GHz to 6 GHz | 6 GHz to 9 GHz
Directivity | 30 | 33 | 27 | 20 | 13
Source Match | 18 | 18 | 16 | 11 | 8
Load Match | 20 | 20 | 17 | 13.5 | 13
Reflection Tracking | ±1.5 | ±1.5 | ±1.5 | ±2.5 | ±3.0
Transmission Tracking | ±1.5 | ±1.5 | ±1.5 | ±2.5 | ±3.0

Test Port Output Characteristics (Source)

  • Output Frequency

  • Output Power

  • Output Signal Purity

Table 8. Test Port Output Frequency

Description | Specification | Supplemental Information
Range:
E8801A | 300 kHz to 3.0 GHz |
E8802A | 300 kHz to 6.0 GHz |
E8803A | 300 kHz to 9.0 GHz |
Resolution: | 1 Hz |
Source Stability |  | ±1 ppm, 0°C to 40 °C, typical ±1ppm/year maximum
Source Stability (Option 1E5) |  | ±0.05 ppm, 0° to 70 °C, typical ±0.1 ppm/year maximum
CW Accuracy | ±3 ppm |
CW Accuracy (Option 1E5) | ±1 ppm |

Table 9. Test Port Output Powera

Description | Specification | Supplemental Information
Level Accuracy:
300 kHz to 6 GHz | ±1.0 dB | Variation from 0 dBm in power range 0
6 GHz to 9 GHz | ±2.0 dB | ±1.5dB below 10 MHz
Level Linearity:
 |  | Variation from 0 dBm in power range 0
300 kHz to 9 GHz | ±0.3 dB | -15 to +5 dBm
300 kHz to 1 MHz | ±1.0 dB | +5 to +10 dBm
1 MHz to 6 GHz | ±0.5 dB | +5 to +10 dBm
6 GHz to 9 GHz | ±0.5 dB | +5 to +7 dBm
Rangeb:
300 kHz to 6 GHz | -15 to +10 dBm |
6 GHz to 9 GHz | -15 to +7 dBm |
Rangeb:
(Option 1E1):
300 kHz to 6 GHz | -85 to +10 dBm |
6 GHz to 9 GHz | -85 to +7 dBm |
Sweep Range
300 kHz to 6 GHz | 25 dB |
6 GHz to 9 GHz | 22 dB |
Level Resolution | 0.01 dB |

a Source output performance on port 1 only. Port 2 output performance is typical.

b Power to which the source can be set and phase lock is assured.

Table 10. Test Port Output Signal Purity

Description | Specification | Supplemental Information
Harmonics (2nd or 3rd)
at max output power (< 25 MHz) |  | < -25 dBc, typical
at max output power (25 MHz to 9 GHz) |  | < -25 dBc, characteristica
at 0 dBm output |  | < -35 dBc, typical
at -10 dBm output |  | < -38 dBc, typical, in power range 0
Non-harmonic Spurious
at max output |  | -30 dBc, typical for offset freq>1kHz
at -10 dBm output |  | -50 dBc, typical for offset freq >1kHz

a Typical below 25 MHz.

Test Port and Receiver Input Characteristics

  • I nput Levels

  • Trace Noise

  • Reference Level and Stability

  • Dynamic Accuracy

  • Group Delay

Table 11. Test Port and Receiver Input Levels

Description | Specification | Supplemental Information
Maximum Test Port Input Level
Test Ports 1 and 2:
300 kHz to 25 MHz | +10 dBm | < 0.6 dB compression
25 MHz to 3 GHz | +10 dBm | < 0.4 dB compression
3 GHz to 6 GHz | +10 dBm | < 0.7 dB compression
6 GHz to 9 GHz | +5 dBm | < 0.7 dB compression
Damage Level
Test Port 1, 2 |  | +30 dBm or ±30 VDC, typ.
R, A, B (Opt. 014) |  | +15 dBm or ±5 VDC, typ.
Coupler Thru (Opt. 014) |  | +33 dBm or ±0 VDC, typ.
Test Port Noise Floora
300 kHz to 25 MHzb |  |
10 Hz IF Bandwidth | -115 dBm |
1 kHz IF Bandwidth | -95 dBm |
25 MHz to 3 GHzb |  |
10 Hz IF Bandwidth | -118 dBm |
1 kHz IF Bandwidth | -98 dBm |
3 GHz to 9 GHz |  |
10 Hz IF Bandwidth | £ -108 dBm |
1 kHz IF Bandwidth | £ -88 dBm |
Receiver Noise Floora
300 kHz to 25 MHzc |  |
10 Hz IF Bandwidth | £ -130 dBm |
1 kHz IF Bandwidth | £ -110 dBm |
25 MHz to 3 GHzc |  |
10 Hz IF Bandwidth | £ -133 dBm |
1 kHz IF Bandwidth | £ -113 dBm |
6 GHz to 9 GHz |  |
10 Hz IF Bandwidth | £ -123 dBm |
1 kHz IF Bandwidth | £ -103 dBm |
Crosstalk
 |  | Between test ports 1 and 2, with short circuits at both ports
300 kHz to 1 MHz | <-120 dB |
1 MHz to 25 MHz | <-125 dB |
25 MHz to 3 GHz | <-126 dB |
3 GHz to 6 GHz | <-117 dB |
6 GHz to 9 GHz | <-106 dB |
Maximum Receiver Input Level (A, B, R)
300 kHz to 6 GHz |  | -6 dBm, typical
6 GHz to 9 GHz |  | -9 dBm, typical
Reference Input Level (R)d
300 kHz to 9 GHz |  | -10 to -35 dBm, typical
Maximum Coupler Input Level (Opt 014)
300 kHz to 9 GHz |  | +33 dBm, typical

a Total average (RMS) noise power calculated as the mean value of a linear magnitude trace expressed in dBm.

b May be limited to -90 dBm at particular frequencies below 750 MHz due to spurious receiver residuals.

c May be limited to -105 dBm at particular frequencies below 750 MHz due to spurious receiver residuals.

d Input level to maintain phase lock.

Table 12. Test Port Input (Trace Noise)

Description | Specification | Supplemental Information
Trace Noisea Magnitude
1 kHz IF Bandwidth | < 0.002 dB rms |
10 kHz IF Bandwidth | < 0.005 dB rms |
Trace Noisea Phase
1 kHz IF Bandwidth | < 0.010° rms |
10 kHz IF Bandwidth | < 0.035° rms |

a Trace noise is defined as a ratio measurement of a through or a full reflection, with the source set to 0 dBm.

Table 13. Test Port Input (Reference Level and Stability)

Description | Specification | Supplemental Information
Reference Level Magnitude
Range | ±200 dB |
Resolution | 0.001 dB |
Reference Level Phase
Range | ±500° |
Resolution | 0.01° |
Stability Magnitudea
300 kHz to 3 GHz |  | 0.02 dB/°C, typical
3 GHz to 6 GHz |  | 0.04 dB/°C, typical
6 GHz to 9 GHz |  | 0.06 dB/°C, typical
Stability Phasea
300 kHz to 3 GHz 3 GHz to 6 GHz 6 GHz to 9 GHz |  | 0.2°/°C, typical 0.3°/°C, typical 0.6°/°C, typical

a Stability is defined as a ratio measurement at the test port.

Table 14. Test Port Input (Dynamic Accuracy specificationa)

Accuracy of the test port input power reading is relative to the reference input power level. Applies to input ports 1 and 2 with the following conditions:

  • IF bandwidth = 10 Hz

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

300 kHz to 3 GHz 300 kHz to 3 GHz

300 kHz to 6 GHz 300 kHz to 6 GHz

300 kHz to 9 GHz 300 kHz to 9 GHz

a Dynamic accuracy is verified with the following measurements:

  • compression over frequency

  • IF linearity at a single frequency of 1.195 GHz and a reference level of -20 dBm

Table 15. Test Port Input (Group Delay)a

Description

Specification

Supplemental Information

Aperture (selectable)

(frequency span)/(number of points -1)

Maximum Aperture

20% of frequency span

Range

0.5 x (1/minimum aperture)

Maximum Delay

Limited to measuring no more than 180° of phase change within the minimum aperture.)

Accuracy

See graph below. Char.

The following graph shows group delay accuracy with type-N full 2-port calibration and a 10 Hz IF bandwidth. Insertion loss is assumed to be < 2 dB and electrical length to be ten meters.

In general, the following formula can be used to determine the accuracy, in seconds, of specific group delay measurement:

±Phase Accuracy (deg)/[360 × Aperture (Hz)]

Depending on the aperture and device length, the phase accuracy used is either incremental phase accuracy or worst case phase accuracy.

a Group delay is computed by measuring the phase change within a specified frequency step (determined by the frequency span and the number of points per sweep).

General Information

  • System Bandwidths

  • Front Panel

  • Rear Panel

  • Environment and Dimensions

Table 16. System Bandwidths

Description | Specification | Supplemental Information
IF Bandwidth Settings
Range |  | 1 Hz to 40 kHz in a 1, 2, 3, 5, 7,10 sequence up to 30 kHz, 35 kHz, 40kHz, nominal

Table 17. Front Panel Information

Description | Supplemental Information
RF Connectors
Type | Type-N, female; 50 W, nominal
Center Pin Protrusion | 0.204 to 0.207 in., characteristic
Probe Power
Connector | 3-pin connector, male
Positive Supply | +15 VDC ±2%, 400 mA, max, characteristic
Negative Supply | -12.6 VDC ±5%, 300 mA, max, characteristic
Display
Size | 21.3 cm (8.4 in) diagonal color active matrix LCD; 640 (horizontal) X 480 (vertical) resolution
Refresh Rate | Vertical 59.83 Hz; Horizontal 31.41 Hz
Display Range
Magnitude | ±200 dB (at 20 dB/div), max
Phase | ±180°, max
Polar | 10 pUnits, min 1000 Units, max
Display Resolution
Magnitude | 0.001 dB/div, min
Phase | 0.01°/div, min
Marker Resolution
Magnitude | 0.001 dB, min
Phase | 0.01°, min
Polar | 0.01 mUnit, min; 0.01°,min

Table 18. Rear Panel Information

Description | Supplemental Information
10 MHz Reference In
Connector | BNC, female
Input Frequency | 10 MHz ± 1 ppm, typical
Input Level | -15 dBm to +20 dBm, typical
Input I mpedance | 200 W, nom.
10 MHz Reference Out
Connector | BNC, female
Output Frequency | 10 MHz ± 10 ppm, typical
Signal Type | Sine Wave, typical
Output Level | +10 dBm ± 4 dB into 50 W, typical
Output Impedance | 50 W, nominal
Harmonics | <-40 dBc, typical
VGA Video Output
Connector | 15-pin mini D-Sub; Drives VGA compatible monitors
Devices Supported | Resolutions
Flat Panel (TFT | 1024 X 768, 800 X 600, 640 X 480
Flat Panel (DSTN) | 800 X 600, 640 X 480
CRT Monitor | 1280 X 1024, 1024 X 768, 800 X 600, 640 X 480
 | Simultaneous operation of the internal and external displays is allowed, but with 640 X 480 resolution only. If you change resolution, you can only view the external display (internal display will "white out").
Test Set IO | 25-pin D-Sub connector, available for external test set control
Aux IO | 25-pin D-Sub connector, male, analog and digital IO
Handler IO | 36-pin IDC D-ribbon socket connector; all input/output signals are default set to negative logic; can be reset to positive logic via GPIB command
GPIB | 24-pin D-sub (Type D-24), female; compatible with IEEE-488.
Parallel Port (LPT1) | 25-pin D-Sub connector, female; provides connection to printers or any other parallel port peripherals
Serial Port (COM 1) | 9-pin D-Sub, male; compatible with RS-232
USB Port
 | Universal Serial Bus jack, Type A configuration (4 contacts inline, contact 1 on left); female
Contact 1 | Vcc: 4.75 to 5.25 VDC, 500 mA, maximum
Contact 2 | -Data
Contact 3 | +Data
Contact 4 | Ground
LAN | 10/100BaseT Ethernet, 8-pin configuration; auto selects between the two data rates
Line Power (A third-wire ground is required.)
Frequency | 50/60/400 Hz
Voltage | 120/240 VAC (Power supply is auto switching.)
Max | 500 Watts

Note: Option H08 and Option H11 specifications are not provided in this E8801/2/3A specifications document.

Table 19. Rear Panel Information (continued)

Description | Supplemental Information
External AM Input
Description | Input provides low-frequency AM modulation to test port output signal, or shifts the test port output. Zero volts input gives the power level set by the instrument, a positive voltage gives a higher level, and a negative voltage gives a lower level.
Connector | BNC, female
Input Sensitivity | 8 dB/V, typical
Bandwidth | 1 kHz, typical
Input Impedance | 1 kW, typical
External Detector Input
Description | Input from an external, negative polarity diode detector provides ALC for a test port remote from instrument's front panel
Connector | BNC, female
Input Sensitivity | -500 mV yields approximately -3 dBm at detector's input, typical
Bandwidth | 50 kHz, typical
Input Impedance | 1 kW, nominal

Table 20. Analyzer Environment and Dimensions

Description | Supplemental Information
General Environmental
RFI/EMI Susceptibility | Defined by CISPR Pub. 11, Group 1, Class A, and IEC 50082-1
ESD | Minimize using static-safe work procedures and an antistatic bench mat
Dust | Minimize for optimum reliability
Operating Environment
Temperature | 0 °C to +40 °C Instrument powers up, phase locks, and displays no error messages within this temperature range.
Error-Corrected Temperature Range | 25°C ± 5°C with less than 1°C deviation from calibration temp.
Humidity | 5% to 95% at +40 °C
Altitude | 0 to 4500 m (14,760 ft.)
Non-Operating Storage Environment
Temperature | -40 °C to +70 °C
Humidity | 0% to 90% at +65 °C (non-condensing)
Altitude | 0 to 15,240 m (50,000 ft.)
Cabinet Dimensions
 | Height | Width | Depth
Excluding front and rear panel hardware and feet | 223 mm 8.75 in | 426 mm 16.75 in | 427 mm 16.8 in
As shipped - includes front panel connectors, rear panel bumpers, and feet. | 235 mm 9.25 in | 435 mm 17.10 in | 470 mm 18.5 in
As shipped plus handles | 235 mm 9.25 in | 458 mm 18 in | 501 mm 19.70 in
As shipped plus rack-mount flanges | 235 mm 9.25 in | 483 mm 19 in | 470 mm 18.5 in
As shipped plus handles and flanges | 235 mm 9.25 in | 483 mm 19 in | 501 mm 19.70 in
Weight
Net | 24 kg (54 lb), nominal
Shipping | 32 kg (70 lb), nominal

Note: "Misc. Information" specifications are not included in this E8801/2/3A document.

Measurement Throughput Summary

  • T ypical Cycle Time for Measurement Completion

  • Cycle Time with Changes in IF Bandwidth

  • Cycle Time with Changes in Number of Points

  • Data Transfer Time

  • Recall and Sweep Speed

Table 21. Typical Cycle Timea,b (ms)

 | Number of Points
 | 101 | 201 | 401 | 1601
Start 1.8 GHz, Stop 2 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 7 | 10 | 16 | 52
2-Port cal | 27 | 36 | 55 | 164
Start 300 kHz, Stop 3 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 48 | 54 | 64 | 104
2-Port cal | 103 | 119 | 145 | 254
Start 300 kHz, Stop 9 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 51 | 57 | 64 | 103
2-Port cal | 112 | 124 | 138 | 220

a Typical performance.
b Includes sweep time, retrace time and band-crossing time. Analyzer display turned off with
DISPLAY:ENABLE OFF. Add 21 ms for display on. Data for one trace (S11) measurement..

Table 22. Cycle Time vs. IF Bandwidtha

Applies to the Preset condition (201 points, correction off) except for the following changes:

  • CF = 1 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
IF Bandwidth (Hz) | Cycle Time (ms)b
40,000 | 8
35,000 | 9
30,000 | 11
20,000 | 13
10,000 | 28
7000 | 36
5000 | 48
3000 | 72
1000 | 196
300 | 620
100 | 1875
30 | 8062
10 | 17877

a Typical performance.
b Cycle time includes sweep and retrace time.

Table 23. Cycle Time vs. Number of Pointsa

Applies to the Preset condition (35 kHz IF bandwidth, correction off) except for the following changes:

  • CF = 1 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
Number of Points | Cycle Time (ms)b
3 | 4
11 | 4
51 | 5
101 | 6
201 | 9
401 | 16
801 | 29
1601 | 52

a Typical performance.
b Cycle time includes sweep and retrace time.

Table 24. Data Transfer Timea (ms)

 | Number of Points
 | 51 | 201 | 401 | 1601
SCPI over GPIB (program executed on external PC)b
32-bit floating point | 3 | 7 | 12 | 43
64-bit floating point | 4 | 12 | 22 | 84
ASCII | 7 | 64 | 24 | 489
SCPI over 100 Mbit/s LAN (program executed on external PC)b
32-bit floating point | 1 | 1 | 1 | 1
64-bit floating point | 1 | 1 | 1 | 2
ASCII | 5 | 15 | 26 | 96
SCPI (program executed in the analyzer)d
32-bit floating point | 1 | 1 | 2 | 3
64-bit floating point | 1 | 2 | 2 | 4
ASCII | 8 | 29 | 56 | 222
COM (program executed in the analyzer)e
32-bit floating point | 1 | 1 | 1 | 1
Variant type | 1 | 1 | 2 | 6
DCOM over 100 Mbit/s LAN (program executed on external PC)f
32-bit floating pointg | 1 | 1 | 1 | 2
Variant typeh | 1 | 3 | 6 | 19

a Typical performance of unit with 500 MHz Pentium III processor.
b Measured using a VEE 5.0 program running on a 600 MHz HP Kayak, National InstrumentsTM GPIB card.
Transferred complex S11 data , using "CALC:DATA?SDATA".
c Measured using a VEE 5.0 program running on a 600 MHz HP Kayak. Transferred complex S11 data,
using "CALC:DATA?SDATA". Speed dependent on LAN traffic, if connected to network.
d Measured using a VEE 5.0 program running inside PNA Series Analyzer. Transferred complex S11 data,
using "CALC:DATA?SDATA".
e Measured using a Visual Basic 6.0 program running inside PNA Series Analyzer. Transferred complex S11
data.

f Measured using a Visual Basic 6.0 program running on a 600 MHz HP Kayak. Transferred
complex S11 data. Speed dependent on LAN traffic, if connected to network.

g Used IArray Transfer.getComplex method for 32-bit floating point.

h Used meas.getData method for Variant data type.

Table 25. Recall and Sweep Speeda

Operations | Number of Window(s) | Number of Trace(s) | Recall Time (ms)
Recall | 1 | 1 | 49
Recall and Sweep | 1 | 1 | 59
Recall | 1 | 2 | 82
Recall and Sweep | 1 | 2 | 96
Recall | 1 | 4 | 159
Recall and Sweep | 1 | 4 | 203
Recall | 2 | 2 | 93
Recall and Sweep | 2 | 2 | 115
Recall | 3 | 4 | 158
Recall and Sweep | 3 | 4 | 218
Recall | 4 | 4 | 187
Recall and Sweep | 4 | 4 | 247
Recall | 4 | 8 | 340
Recall and Sweep | 4 | 8 | 507

a CF=177 MHz, Span=200 MHz, 201 points, 35 kHz IF BW

E8801A, E8802A, and E8803A – Simplified Test Set Block Diagram

E8801A, E8802A, and E8803A with Option 014 – Simplified Test Set Block Diagram


Specs: N338x Analyzers

Technical Specifications for the N3381A, N3382A, N3383A
(Rev. 2005-07-12)

This is a complete list of the N3381A, N3382A, and N3383A network analyzer technical specifications.

  • To optimize viewing of uncertainty curves, click the Maximize button.

  • To view or print the .pdf version of the specifications, visit our web site at http://www.agilent.com/find/pna, and search for "N338xA Specifications"

  • The uncertainty curves contained in this document apply only to the setup conditions listed. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your PNA setup. View the equations used to generate the uncertainty curves.

  • Definitions

  • Corrected System Performance

    • System Dynamic Range

    • Type-N Connectors

    • 3.5 mm Connectors

    • 7-16 Connectors

  • Uncorrected Instrument Performance

  • Test Port Output Characteristics (Source)

  • Test Port and Receiver Input Characteristics

  • General Information

  • Front-panel Jumper Specs (Option 014 only)

  • Measurement Throughput Summary

  • Test Set Block Diagram

  • Test Set with Option 015 Block Diagram

See Specs for other PNA models

Definitions

All specifications and characteristics apply over a 25 °C ±5 °C range (unless otherwise stated) and 90 minutes after the instrument has been turned on.

Specification (spec.): Warranted performance. Specifications include guardbands to account for the expected statistical performance distribution, measurement uncertainties, and changes in performance due to environmental conditions.

Characteristic (char.): A performance parameter that the product is expected to meet before it leaves the factory, but that is not verified in the field and is not covered by the product warranty. A characteristic includes the same guardbands as a specification.

Typical (typ.): Expected performance of an average unit which does not include guardbands. It is not covered by the product warranty.

Nominal (nom.): A general, descriptive term that does not imply a level of performance. It is not covered by the product warranty.

Calibration: The process of measuring known standards to characterize a network analyzer's systematic (repeatable) errors.

Corrected (residual): Indicates performance after e rror c orrection (calibration). It is determined by the quality of calibration standards and how well "known" they are, plus system repeatability, stability, and noise.

Uncorrected (raw): Indicates instrument performance without error correction. The uncorrected performance affects the stability of a calibration.

Standard: When referring to the analyzer, this includes no options unless noted otherwise.

Corrected System Performance

The specifications in this section apply for measurements made with the N3381A, N3382A, and N3383A analyzer with the following conditions:

  • 10 Hz IF bandwidth

  • No averaging applied to data

  • Environmental temperature of 25 °C ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted

Note: The uncertainty curves contained in these specifications apply only to the setup conditions listed. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your PNA setup. View the equations used to generate the uncertainty curves.

  • System Dynamic Range

  • Type-N Connectors

  • 3.5 mm Connectors

  • 7-16 Connectors

Table 1. System Dynamic Range

Description | Specification (dB) | Characteristic (dB)
Dynamic rangea (at test port)
300 kHz to 25 MHzb | 125 |
25 MHz to 3 GHzb | 128 |
3 GHz to 6 GHz | 118 |
6 GHz to 9 GHz | 115 |
Dynamic rangec (at receiver input)
300 kHz to 25 MHzd |  | 140
25 MHz to 3 GHzd |  | 143
3 GHz to 6 GHz |  | 133
6 GHz to 9 GHz |  | 130

a The test port dynamic range is calculated as the difference between the test port rms noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account.
b May be limited to 100 dB at particular frequencies below 750 MHz due to spurious receiver residuals.
c The receiver input dynamic range is calculated as the difference between the receiver rms noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account. This set-up should only be used when the receiver input will never exceed its damage level. When the analyzer is in segment sweep mode, frequency segments can be defined with a higher power level when the extended dynamic range is required (i.e. the portion of the device's response with high insertion loss), and reduced power when receiver damage may occur (i.e. the portion of the devices's response with low insertion loss). Specification applies only when power is sourced from Port 1. If power is sourced from either Port 2 or Port 3, dynamic range decreases by 3 dB.
d May be limited to 115 dB at particular frequencies below 750 MHz due to spurious receiver residuals.

Note: Receiver Dynamic Range specifications are not included in this N3381/2/3A document.

Note: This document provides technical specifications for the following calibration kits only: 85032F, 85092C, 85033E, 85093C and 85038A.

Corrected System Performance with Type-N Connectors

  • 85032F Calibration Kit

  • 85092C Electronic Calibration Module

Table 2. Corrected System Performance With Type-N Device Connectors, 85032F Calibration Kit

Applies to the N3381A, N3382A, and N3383A analyzer, 85032F (Type-N, 50W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHz
Directivity | 49 | 46 | 40 | 38
Source Match | 41 | 40 | 36 | 35
Load Match | 49 | 45 | 39 | 37
Reflection Tracking | ±0.011 | ±0.021 | ±0.032 | ±0.054
Transmission Tracking | ±0.012 | ±0.020 | ±0.055 | ±0.083

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 3. Corrected System Performance With Type-N Device Connectors, 85092C Electronic Calibration Module

Applies to the N3381A, N3382A, and N3383A analyzer, 85092C (Type-N, 50W) electronic calibration (ECal) module, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHza
Directivity | 52 | 54 | 52 | 47
Source Match | 45 | 44 | 41 | 36
Load Match | 47 | 47 | 44 | 39
Reflection Tracking | ±0.040 | ±0.040 | ±0.060 | ±0.070
Transmission Tracking | ±0.039 | ±0.039 | ±0.068 | ±0.136

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Corrected System Performance with 3.5 mm Connectors

  • 85033E Calibration Kit

  • 85093C Electronic Calibration Module

Table 4. Corrected System Performance With 3.5 mm Device Connector Type, 85033E Calibration Kit

Applies to the N3381A, N3382A, and N3383A analyzer, 85033E (3.5 mm, 50W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHz
Directivity | 46 | 44 | 38 | 38
Source Match | 43 | 40 | 37 | 36
Load Match | 46 | 44 | 38 | 38
Reflection Tracking | ±0.006 | ±0.007 | ±0.009 | ±0.010
Transmission Tracking | ±0.012 | ±0.021 | ±0.057 | ±0.075

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 5. Corrected System Performance With 3.5 mm Device Connector Type, 85093C Electronic Calibration Module

Applies to the N3381A, N3382A, and N3383A analyzer, 85093C (3.5 mm, 50W) electronic calibration (ECal) module, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHza
Directivity | 52 | 52 | 51 | 47
Source Match | 44 | 44 | 39 | 34
Load Match | 47 | 47 | 44 | 40
Reflection Tracking | ±0.030 | ±0.040 | ±0.050 | ±0.070
Transmission Tracking | ±0.039 | ±0.049 | ±0.068 | ±0.117

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 6. Corrected System Performance With 7-16 Device Connector Type, 85038A Calibration Kit

Applies to the N3381A, N3382A, and N3383A analyzer, 85038A (7-16, 50W) calibration kit, N6314A test port cable, and a full 2-port calibration. Also applies to the following conditions:

  • IF bandwidth = 10 Hz

  • No averaging ap plied to data

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

  • Isolation calibration not omitted
Description | Specification (dB)
 | 300 kHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 to 6 GHz | 6 to 9 GHza
Directivity | 40 | 40 | 36 | 36
Source Match | 37 | 37 | 34 | 34
Load Match | 39 | 39 | 35 | 35
Reflection Tracking | ±0.089 | ±0.089 | ±0.115 | ±0.115
Transmission Tracking | ±0.024 | ±0.033 | ±0.082 | ±0.103

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 7. Uncorrected Instrument Performance

Description | Specification (dB)
 | 300 kHz to 1 MHz | 1MHz to 1.3 GHz | 1.3 GHz to 3 GHz | 3 GHz to 6 GHz | 6 GHz to 9 GHz
Directivity | 30 | 33 | 27 | 20 | 13
Source Match Ports 1 and 2 | 18 | 18 | 17 | 14 | 12
Source Match Port 3 only | 18 | 18 | 17 | 14 | 12
Load Match Ports 1 and 2 | 20 | 20 | 17 | 13.5 | 11.5
Load Match Port 3 only | 20 | 20 | 17 | 13.5 | 11.5
Reflection Tracking | ±1.5 | ±1.5 | ±1.5 | ±2.5 | ±3.0
Transmission Tracking | ±1.5 | ±1.5 | ±1.5 | ±2.5 | ±3.0

Test Port Output Characteristics (Source)

  • Output Frequency

  • Output Power

  • Output Signal Purity

Table 8. Test Port Output Frequency

Description | Specification | Supplemental Information
Range:
N3381A | 300 kHz to 3.0 GHz |
N3382A | 300 kHz to 6.0 GHz |
N3383A | 300 kHz to 9.0 GHz |
Resolution | 1 Hz |
Source Stability |  | ±1 ppm, 0° to 40 °C, typical ±1ppm/year maximum
Source Stability (Option 1E5) |  | ±0.05 ppm, 0° to 40 °C, typical ±0.1 ppm/year maximum
CW Accuracy | ±3 ppm |
CW Accuracy (Option 1E5) | ±1 ppm |

Table 9. Test Port Output Powera

Description | Specification | Supplemental Information
Level Accuracy
 |  | Variation from 0 dBm in power range 0 (step attenuator at 0 dB) ±1.5dB below 10 MHz
300 kHz to 6 GHz | ±1.0 dB |
6 GHz to 9 GHz | ±2.0 dB |
Level Linearity
 |  | Variation from 0 dBm in power range 0
300 kHz to 9 GHz | ±0.3 dB | -15 to +5 dBm
300 kHz to 1 MHz | ±1.0 dB | +5 to +10 dBm
1 MHz to 6 GHz | ±0.5 dB | +5 to +10 dBm
6 GHz to 9 GHz | ±0.5 dB | +5 to +7 dBm
Rangeb
300 kHz to 6 GHz | -15 to +10 dBm |
6 GHz to 9 GHz | -15 to +7 dBm |
Rangeb (Option 1E1)
300 kHz to 6 GHz | -85 to +10 dBm |
6 GHz to 9 GHz | -85 to +7 dBm |
Sweep Range
Port 1:
300 kHz to 6 GHz | 25 dB |
6 GHz to 9 GHz | 22 dB |
Level Resolution | 0.01 dB |

a Source output performance on port 1 only. Port 2 and port 3 output performance is typically 3 dB less.

b Power to which the source can be set and phase lock is assured.

Table 10. Test Port Output Signal Purity

Description | Specification | Supplemental Information
Harmonics (2nd or 3rd)
at max output power (< 25 MHz) |  | < -25 dBc, typical
at max output power (25 MHz to 9 GHz) |  | < -25 dBc, characteristica
at 0 dBm output |  | < -35 dBc, typical
at -10 dBm output |  | < -38 dBc, typical, in power range 0
Non-harmonic Spurious
at max output |  | -30 dBc, typical for offset freq>1kHz
at -10 dBm output |  | -50 dBc, typical for offset freq >1kHz

a Typical below 25 MHz.

Test Port and Receiver Input Characteristics

  • I nput Levels

  • Trace Noise

  • Reference Level and Stability

  • Dynamic Accuracy

  • Group Delay

Table 11. Test Port and Receiver Input Levels

Description | Specification | Supplemental Information
Maximum Test Port Input Level
300 kHz to 25 MHz | +10 dBm | <0.6 dB compression
25 MHz to 3 GHz | +10 dBm | <0.4 dB compression
3 GHz to 6 GHz | +10 dBm | <0.7 dB compression
6 GHz to 9 GHz | +7 dBm | <0.7 dB compression
Damage Level
Test Port 1, 2. 3 |  | +30 dBm or ±30 VDC, typ.
R, A, B, C (Opt. 014) |  | +15 dBm or ±5 VDC, typ.
Coupler Thru (Opt. 014) |  | +33 dBm or ±0 VDC, typ.
Test Port Noise Floora
300 kHz to 25 MHzb
10 Hz IF Bandwidth | ≤ -115 dBm |
1 kHz IF Bandwidth | ≤ -95 dBm |
25 MHz to 3 GHzb
10 Hz IF Bandwidth | ≤ -118 dBm |
1 kHz IF Bandwidth | ≤ -98 dBm |
3 GHz to 9 GHz
10 Hz IF Bandwidth | £ -108 dBm |
1 kHz IF Bandwidth | £ -88 dBm |
Receiver Noise Floora
300 kHz to 25 MHzc
10 Hz IF Bandwidth | £ -130 dBm, characteristic |
1 kHz IF Bandwidth | £ -110 dBm, characteristic |
25 MHz to 3 GHzc
10 Hz IF Bandwidth | ≤ -133 dBm, characteristic |
1 kHz IF Bandwidth | ≤ -113 dBm, characteristic |
6 GHz to 9 GHz
10 Hz IF Bandwidth | £ -123 dBm, characteristic |
1 kHz IF Bandwidth | £ -103 dBm, characteristic |
Crosstalk
(S21, S31):
300 kHz to 1 MHz | <-120 dB |
1 MHz to 25 MHz | <-125 dB |
25 MHz to 3 GHz | <-126 dB |
3 GHz to 6 GHz | <-117 dB |
6 GHz to 9 GHz | <-106 dB |
(S12, S13):
300 kHz to 1 MHz | <-120 dB |
1 MHz to 25 MHz | <-125 dB |
25 MHz to 3 GHz | <-126 dB |
3 GHz to 6 GHz | <-113 dB |
6 GHz to 9 GHz | <-106 dB |
(S23, S32):
300 kHz to 1 MHz | <-120 dB |
1 MHz to 3 GHz | <-125 dB |
3 GHz to 6 GHz | <-115 dB |
6 GHz to 9 GHz | <-107 dB |
Maximum Receiver Input Level (A, B, R, C)
300 kHz to 6 GHz |  | –6 dBm, typical
6 GHz to 9 GHz |  | –9 dBm, typical
Reference Input Level (R)d
300 kHz to 9 GHz |  | -10 to -35 dBm, typical
Maximum Coupler Input Level (Opt 014)
300 kHz to 9 GHz |  | +33 dBm, typical

a Total average (RMS) noise power calculated as the mean value of a linear magnitude trace expressed in dBm.

b May be limited to -90 dBm at particular frequencies below 750 MHz due to spurious receiver residuals.

c May be limited to -105 dBm at particular frequencies below 750 MHz due to spurious receiver residuals.

d Input level to maintain phase lock.

Table 12. Test Port Input (Trace Noise)

Description | Specification | Supplemental Information
Trace Noisea Magnitude
1 kHz IF Bandwidth | < 0.002 dB rms |
10 kHz IF Bandwidth | < 0.005 dB rms |
Trace Noisea Phase
1 kHz IF Bandwidth | < 0.010° rms |
10 kHz IF Bandwidth | < 0.035° rms |

a Trace noise is defined as a ratio measurement of a through or a full reflection, with the source set to 0 dBm.

Table 13. Test Port Input (Reference Level and Stability)

Description | Specification | Supplemental Information
Reference Level Magnitude
Range | ±200 dB |
Resolution | 0.001 dB |
Reference Level Phase
Range | ±500° |
Resolution | 0.01° |
Stability Magnitudea
300 kHz to 3 GHz |  | 0.02 dB/°C, typical
3 GHz to 6 GHz |  | 0.04 dB/°C, typical
6 GHz to 9 GHz |  | 0.06 dB/°C, typical
Stability Phasea
300 kHz to 3 GHz |  | 0.2°/°C, typical
3 GHz to 6 GHz |  | 0.3°/°C, typical
6 GHz to 9 GHz |  | 0.6°/°C, typical

a Stability is defined as a ratio measurement at the test port.

Table 14. Test Port Input (Dynamic Accuracy specificationa)

Accuracy of the test port input power reading is relative to the reference input power level. Applies to input ports 1 and 2 with the following conditions:

  • IF bandwidth = 10 Hz

  • Environmental temperature 25° ±5 °C, with < 1 °C deviation from calibration temperature

300 kHz to 3 GHz 300 kHz to 3 GHz

300 kHz to 6 GHz 300 kHz to 6 GHz

300 kHz to 9 GHz 300 kHz to 9 GHz

aDynamic accuracy is verified with the following measurements:

  • compression over frequency

  • IF linearity at a single frequency of 1.195 GHz and a reference level of -20 dBm

Table 15. Test Port Input (Group Delay)a

Description

Specification

Supplemental Information

Aperture (selectable)

(frequency span)/(number of points -1)

Maximum Aperture

20% of frequency span

Range

0.5 x (1/minimum aperture)

Maximum Delay

Limited to measuring no more than 180° of phase change within the minimum aperture.)

Accuracy

See graph below. Char.

The following graph shows group delay accuracy with type-N full 2-port calibration and a 10 Hz IF bandwidth. Insertion loss is assumed to be < 2 dB and electrical length to be ten meters.

In general, the following formula can be used to determine the accuracy, in seconds, of specific group delay measurement:

±Phase Accuracy (deg)/[360 × Aperture (Hz)]

Depending on the aperture and device length, the phase accuracy used is either incremental phase accuracy or worst case phase accuracy.

a Group delay is computed by measuring the phase change within a specified frequency step (determined by the frequency span and the number of points per sweep).

General Information

  • System Bandwidths

  • Front Panel

  • Rear Panel

  • Environment and Dimensions

Table 16. System Bandwidths

Description | Specification | Supplemental Information
IF Bandwidth Settings
Range |  | 1 Hz to 40 kHz in a 1, 2, 3, 5, 7,10 sequence up to 30 kHz, 35 kHz, 40kHz, nominal

Table 17. Front Panel Information

Description | Supplemental Information
RF Connectors
Type | Type-N, female; 50 W, nominal
Center Pin Protrusion | 0.204 to 0.207 in., characteristic
Probe Power
Connector | 3-pin connector, male
Positive Supply | +15 VDC ±2%, 400 mA, max, characteristic
Negative Supply | -12.6 VDC ±5%, 300 mA, max, characteristic
Display
Size | 21.3 cm (8.4 in) diagonal color active matrix LCD; 640 (horizontal) X 480 (vertical) resolution
Refresh Rate | Vertical 59.83 Hz; Horizontal 31.41 Hz
Display Range
Magnitude | ±200 dB (at 20 dB/div), max
Phase | ±180°, max
Polar | 10 pUnits, min 1000 Units, max
Display Resolution
Magnitude | 0.001 dB/div, min
Phase | 0.01°/div, min
Marker Resolution
Magnitude | 0.001 dB, min
Phase | 0.01°, min
Polar | 0.01 mUnit, min; 0.01°,min

Table 18. Rear Panel Information

Description | Supplemental Information
10 MHz Reference In
Connector | BNC, female
Input Frequency | 10 MHz ± 1 ppm, typical
Input Level | -15 dBm to +20 dBm, typical
Input I mpedance | 200 W, nom.
10 MHz Reference Out
Connector | BNC, female
Output Frequency | 10 MHz ± 10 ppm, typical
Signal Type | Sine Wave, typical
Output Level | +10 dBm ± 4 dB into 50 W, typical
Output Impedance | 50 W, nominal
Harmonics | <-40 dBc, typical
VGA Video Output
Connector | 15-pin mini D-Sub; Drives VGA compatible monitors
Devices Supported: | Resolutions:
Flat Panel (TFT) | 1024 X 768, 800 X 600, 640 X 480
Flat Panel (DSTN) | 800 X 600, 640 X 480
CRT Monitor | 1280 X 1024, 1024 X 768, 800 X 600, 640 X 480
 | Simultaneous operation of the internal and external displays is allowed, but with 640 X 480 resolution only. If you change resolution, you can only view the external display (internal display will "white out").
Test Set IO | 25-pin D-Sub connector, available for external test set control
Aux IO | 25-pin D-Sub connector, male, analog and digital IO
Handler IO | 36-pin IDC D-ribbon socket connector; all input/output signals are default set to negative logic; can be reset to positive logic via GPIB command
GPIB | 24-pin D-sub (Type D-24), female; compatible with IEEE-488.
Parallel Port (LPT1) | 25-pin D-Sub connector, female; provides connection to printers or any other parallel port peripherals
Serial Port (COM 1) | 9-pin D-Sub, male; compatible with RS-232
USB Port
 | Universal Serial Bus jack, Type A configuration (4 contacts inline, contact 1 on left); female
Contact 1 | Vcc: 4.75 to 5.25 VDC, 500 mA, maximum
Contact 2 | -Data
Contact 3 | +Data
Contact 4 | Ground
LAN | 10/100BaseT Ethernet, 8-pin configuration; auto selects between the two data rates
Line Power (A third-wire ground is required.)
Frequency | 50/60/400 Hz
Voltage | 120/240 VAC (Power supply is auto switching.)
Max | 500 Watts

Note: Option H08 and Option H11 specifications are not provided in this N3381/2/3A specifications document.

Table 19. Rear Panel Information (continued)

Description | Supplemental Information
External AM Input
Description | Input provides low-frequency AM modulation to test port output signal, or shifts the test port output. Zero volts input gives the power level set by the instrument, a positive voltage gives a higher level, and a negative voltage gives a lower level.
Connector | BNC, female
Input Sensitivity | 8 dB/V, typical
Bandwidth | 1 kHz, typical
Input Impedance | 1 kW, nominal
External Detector Input
Description | Input from an external, negative polarity diode detector provides ALC for a test port remote from instrument's front panel
Connector | BNC, female
Input Sensitivity | -500 mV yields approximately -3 dBm at detector's input, typical
Bandwidth | 50 kHz, typical
Input Impedance | 1 kW, typical

Table 20. Analyzer Environment and Dimensions

Description | Supplemental Information
General Environmental
RFI/EMI Susceptibility | Defined by CISPR Pub. 11, Group 1, Class A, and IEC 50082-1
ESD | Minimize using static-safe work procedures and an antistatic bench mat
Dust | Minimize for optimum reliability
Operating Environment
Temperature | 0 °C to +40 °C Instrument powers up, phase locks, and displays no error messages within this temperature range.
Error-Corrected Temperature Range | 25°C ± 5°C with less than 1°C deviation from calibration temp.
Humidity | 5% to 95% at +40 °C
Altitude | 0 to 4500 m (14,760 ft.)
Non-Operating Storage Environment
Temperature | -40 °C to +70 °C
Humidity | 0% to 90% at +65 °C (non-condensing)
Altitude | 0 to 15,240 m (50,000 ft.)
Cabinet Dimensions
 | Height | Width | Depth
Excluding front and rear panel hardware and feet | 223 mm 8.75 in | 426 mm 16.75 in | 427 mm 16.8 in
As shipped - includes front panel connectors, rear panel bumpers, and feet. | 235 mm 9.25 in | 435 mm 17.10 in | 470 mm 18.5 in
As shipped plus handles | 235 mm 9.25 in | 458 mm 18 in | 501 mm 19.70 in
As shipped plus rack-mount flanges | 235 mm 9.25 in | 483 mm 19 in | 470 mm 18.5 in
As shipped plus handles and flanges | 235 mm 9.25 in | 483 mm 19 in | 501 mm 19.70 in
Weight
Net | 24 kg (54 lb), nominal
Shipping | 32 kg (70 lb), nominal

Note: "Misc. Information" specifications are not included in this N3381/2/3A document.

Measurement Throughput Summary

  • T ypical Cycle Time for Measurement Completion

  • Cycle Time with Changes in IF Bandwidth

  • Cycle Time with Changes in Number of Points

  • Data Transfer Time

  • Recall and Sweep Speed

Table 21. Typical Cycle Timea,b (ms)

 | Number of Points
 | 101 | 201 | 401 | 1601
Start 1.8 GHz, Stop 2 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 8 | 11 | 17 | 53
2-Port cal | 27 | 36 | 55 | 164
Start 300 kHz, Stop 3 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 48 | 54 | 64 | 104
2-Port cal | 103 | 119 | 145 | 254
Start 300 kHz, Stop 9 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 45 | 55 | 61 | 99
2-Port cal | 99 | 119 | 133 | 212

a Typical performance.
b Includes sweep time, retrace time and band-crossing time. Analyzer display turned off with
DISPLAY:ENABLE OFF. Add 21 ms for display on. Data for one trace (S11) measurement.
c Option 010 only. Analyzer display turned off with DISPLAY:ENABLE OFF. Add 21 ms for display on. Data for one trace (S11) measurement.

Table 22. Cycle Time vs. IF Bandwidtha

Applies to the Preset condition (201 points, correction off) except for the following changes:

  • CF = 1 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
IF Bandwidth (Hz) | Cycle Time (ms)b
40,000 | 8
35,000 | 9
30,000 | 11
20,000 | 13
10,000 | 28
7000 | 36
5000 | 48
3000 | 72
1000 | 196
300 | 620
100 | 1875
30 | 8062
10 | 17877

a Typical performance.
b Cycle time includes sweep and retrace time.

Table 23. Cycle Time vs. Number of Pointsa

Applies to the Preset condition (35 kHz IF bandwidth, correction off) except for the following changes:

  • CF = 1 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
Number of Points | Cycle Time (ms)b
3 | 4
11 | 4
51 | 5
101 | 6
201 | 9
401 | 16
801 | 29
1601 | 52

a Typical performance.
b Cycle time includes sweep and retrace time.

Table 24. Data Transfer Timea (ms)

 | Number of Points
 | 51 | 201 | 401 | 1601
SCPI over GPIB (program executed on external PC)b
32-bit floating point | 3 | 7 | 12 | 43
64-bit floating point | 4 | 12 | 22 | 84
ASCII | 7 | 64 | 124 | 489
SCPI over 100 Mbit/s LAN (program executed on external PC)b
32-bit floating point | 1 | 1 | 1 | 1
64-bit floating point | 1 | 1 | 1 | 2
ASCII | 5 | 15 | 26 | 96
SCPI (program executed in the analyzer)d
32-bit floating point | 1 | 1 | 2 | 3
64-bit floating point | 1 | 2 | 2 | 4
ASCII | 8 | 29 | 56 | 222
COM (program executed in the analyzer)e
32-bit floating point | 1 | 1 | 1 | 1
Variant type | 1 | 1 | 2 | 6
DCOM over 100 Mbit/s LAN (program executed on external PC)f
32-bit floating pointg | 1 | 1 | 1 | 2
Variant typeh | 1 | 3 | 6 | 19

a Typical performance of unit with 500 MHz Pentium III processor.
b Measured using a VEE 5.0 program running on a 600 MHz HP Kayak, National InstrumentsTM GPIB card.
Transferred complex S11 data , using "CALC:DATA?SDATA".
c Measured using a VEE 5.0 program running on a 600 MHz HP Kayak. Transferred complex S11 data,
using "CALC:DATA?SDATA". Speed dependent on LAN traffic, if connected to network.
d Measured using a VEE 5.0 program running inside PNA Series Analyzer. Transferred complex S11 data,
using "CALC:DATA?SDATA".
e Measured using a Visual Basic 6.0 program running inside PNA Series Analyzer. Transferred complex S11
data.

f Measured using a Visual Basic 6.0 program running on a 600 MHz HP Kayak. Transferred
complex S11 data. Speed dependent on LAN traffic, if connected to network.

g Used IArray Transfer.getComplex method for 32-bit floating point.

h Used meas.getData method for Variant data type.

Table 25. Recall and Sweep Speeda

Operations | Number of Window(s) | Number of Trace(s) | Recall Time (ms)
Recall | 1 | 1 | 49
Recall and Sweep | 1 | 1 | 59
Recall | 1 | 2 | 82
Recall and Sweep | 1 | 2 | 96
Recall | 1 | 4 | 159
Recall and Sweep | 1 | 4 | 203
Recall | 2 | 2 | 93
Recall and Sweep | 2 | 2 | 115
Recall | 3 | 4 | 158
Recall and Sweep | 3 | 4 | 218
Recall | 4 | 4 | 187
Recall and Sweep | 4 | 4 | 247
Recall | 4 | 8 | 340
Recall and Sweep | 4 | 8 | 507

aCF=177MHz, Span=200 MHz, 201 points, 35 kHz IF BW

N3381A, N3382A, and N3383A – Simplified Test Set Block Diagram

N3381A, N3382A, and N3383A with Option 014 – Simplified Test Set Block Diagram


Specs: E8361A Analyzer

Technical Specifications for the E8361A
(Rev. 2005-07-12)

This is a complete list of the E8361A network analyzer technical specifications.

  • To optimize viewing of uncertainty curves, click the Maximize button.

  • To view or print the .pdf version of the specifications, visit our web site at http://www.agilent.com/find/pna, and search for "E8361A Specifications"

  • The uncertainty curves contained in this document apply only to the setup conditions listed. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your PNA setup. View the equations used to generate the uncertainty curves.

  • Definitions

  • Corrected System Performance

    • System Dynamic Range

    • Receiver Dynamic Range

    • 1.85mm Connectors

    • 2.4mm Connectors

  • Uncorrected System Performance

  • Test Port Output

  • Test Port Input

  • Dynamic Accuracy

  • Group Delay

  • General Information

  • Measurement Throughput Summary

  • Front-panel Jumper Specs (Option 014 only)

  • Test Set Block Diagrams

  • Test Set with Option 014 Block Diagrams

See Specs for other PNA models

Definitions

All specifications and characteristics apply over a 25 °C ±5 °C range (unless otherwise stated) and 90 minutes after the instrument has been turned on.

Specification (spec.): Warranted performance. Specifications include guardbands to account for the expected statistical performance distribution, measurement uncertainties, and changes in performance due to environmental conditions.

Characteristic (char.): A performance parameter that the product is expected to meet before it leaves the factory, but that is not verified in the field and is not covered by the product warranty. A characteristic includes the same guardbands as a specification.

Typical (typ.): Expected performance of an average unit which does not include guardbands. It is not covered by the product warranty.

Nominal (nom.): A general, descriptive term that does not imply a level of performance. It is not covered by the product warranty.

Calibration: The process of measuring known standards to characterize a network analyzer's systematic (repeatable) errors.

Corrected (residual): Indicates performance after e rror c orrection (calibration). It is determined by the quality of calibration standards and how well "known" they are, plus system repeatability, stability, and noise.

Uncorrected (raw): Indicates instrument performance without error correction. The uncorrected performance affects the stability of a calibration.

Standard: When referring to the analyzer, this includes no options unless noted otherwise.

Corrected System Performance

The specifications in this section apply for measurements made with the E8361A analyzer with the following conditions:

  • 10 Hz IF bandwidth

  • No averaging applied to data

  • System Dynamic Range

  • Receiver Dynamic Range

  • 1.85mm Connectors

  • 2.4mm Connectors

Table 1. System Dynamic Rangea

Description | Specification (dB) at Test Portb | Typical (dB) at Direct Receiver Access Inputc | Supplemental Information
Dynamic Range (in a 10 Hz BW)
Standard Configuration (E8361A - Standard)
10 MHz to 45 MHzd | 61 | NA |
45 MHz to 500 MHze | 87 | NA |
500 MHz to 750 MHz | 112 | NA |
750 MHz to 2 GHz | 111 | NA |
2 GHz to 10 GHz | 111 | NA |
10 GHz to 24 GHz | 114 | NA |
24 GHz to 30 GHz | 103 | NA |
30 GHz to 40 GHz | 104 | NA |
40 GHz to 45 GHz | 96 | NA |
45 GHz to 50 GHz | 100 | NA |
50 GHz to 60 GHz | 97 | NA |
60 GHz to 67 GHz | 94 | NA |
67 GHz to 70 GHzd | 94 | NA |
Configurable Test Set (E8361A - Option 014 or Option 014 and 080)
10 MHz to 45 MHzd | 61 | 99 |
45 MHz to 500 MHze | 87 | 102 |
500 MHz to 750 MHz | 112 | 125.5 |
750 MHz to 2 GHz | 111 | 125.5 |
2 GHz to 10 GHz | 111 | 125 |
10 GHz to 24 GHz | 112 | 128 |
24 GHz to 30 GHz | 101 | 117.5 | Option 016 degrades performance by 2 dB.
30 GHz to 40 GHz | 102 | 115
40 GHz to 45 GHz | 94 | 109
45 GHz to 50 GHz | 98 | 110.5
50 GHz to 60 GHz | 95 | 107
60 GHz to 67 GHz | 90 | 101 | Option 016 degrades performance by 3 dB.
67 GHz to 70 GHzd | 90 | 100
Configurable Test Set & Extended Power Range (E8361A - Option 014 & UNL or Option 014 & UNL & 080)
10 MHz to 45 MHzd | 61 | 99 |
45 MHz to 500 MHze | 87 | 102 |
500 MHz to 750 MHz | 112 | 125.5 |
750 MHz to 2 GHz | 111 | 124 |
2 GHz to 10 GHz | 111 | 124 |
10 GHz to 24 GHz | 112 | 125 |
24 GHz to 30 GHz | 101 | 114.5 | Option 016 degrades performance by 2 dB.
30 GHz to 40 GHz | 99 | 112
40 GHz to 45 GHz | 92 | 105
45 GHz to 50 GHz | 94 | 106.5
50 GHz to 60 GHz | 91 | 103
60 GHz to 67 GHz | 84 | 95 | Option 016 degrades performance by 3 dB.
67 GHz to 70 GHzd | 84 | 94

a The system dynamic range is calculated as the difference between the noise floor and the source maximum output power. System Dynamic Range is a specification when the source is set to Port 1, and a characteristic when the source is set to Port 2. The effective dynamic range must take measurement uncertainties and interfering signals into account as well as the insertion loss resulting from a thru cable connected between Port 1 and Port 2..
b The test port system dynamic range is calculated as the difference between the test port noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account as well as the insertion loss resulting from a thru cable connected between Port 1 and Port 2..
c The direct receiver access input system dynamic range is calculated as the difference between the receiver access input noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account. This set-up should only be used when the receiver input will never exceed its damage level. When the analyzer is in segment sweep mode, the analyzer can have predefined frequency segments which will output a higher power level when the extended dynamic range is required (i.e. devices with high insertion loss), and reduced power when receiver damage may occur (i.e. devices with low insertion loss). The extended range is only available in one-path transmission measurements.
d Typical performance.
e May be limited to 100 dB at particular frequencies below 500 MHz due to spurious receiver residuals. Methods are available to regain the full dynamic range.

Note: This E8361A document does NOT provide technical specifications for Receiver Dynamic Range.

Note: This E8361A document provides technical specifications for the following calibration kits and Ecal modules only: 85056A, 85058B, N4693A, N4694A. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your PNA setup.

Table 10. Uncorrected System Performancea

Specifications apply over environmental temperature of 23° ±3 °C, with < 1 °C deviation from the calibration temperature

Description | Specification | Supplemental Information
Directivity
 |  | typical:
10 MHz to 45 MHzb | 22 dB | 22 dB
45 MHz to 2 GHz | 24 dB | 27 dB
2 GHz to 10 GHz | 20 dB | 24 dB
10 GHz to 20 GHz | 16 dB | 20 dB
20 GHz to 30 GHz | 14 dB | 17 dB
30 GHz to 50 GHz | 13 dB | 17 dB
50 GHz to 60 GHz | 13 dB | 17 dB
60 GHz to 67 GHz | 10 dB | 18 dB
67 GHz to 70 GHzb | 14 dB | 14 dB
Source Match - Standard
 |  | typical:
10 MHz to 45 MHzb | 7 dB | 7 dB
45 MHz to 2 GHz | 18 dB | 23 dB
2 GHz to 10 GHz | 14 dB | 18 dB
10 GHz to 20 GHz | 12 dB | 15 dB
20 GHz to 30 GHz | 8 dB | 11.5 dB
30 GHz to 40 GHz | 7.5 dB | 10 dB
40 GHz to 45 GHz | 8 dB | 11 dB
45 GHz to 50 GHz | 7 dB | 10 dB
50 GHz to 60 GHz | 6 dB | 8.5 dB
60 GHz to 67 GHz | 5.5 dB | 7.5 dB
67 GHz to 70 GHzb | 7.5 dB | 7.5 dB
Source Match - Option 014
 |  | typical:
10 MHz to 45 MHzb | 7 dB | 7 dB
45 MHz to 2 GHz | 17 dB | 21 dB
2 GHz to 10 GHz | 12 dB | 17 dB
10 GHz to 20 GHz | 11 dB | 14 dB
20 GHz to 30 GHz | 10 dB | 13 dB
30 GHz to 40 GHz | 8.5 dB | 11 dB
40 GHz to 45 GHz | 8.5 dB | 11 dB
45 GHz to 50 GHz | 8.5 dB | 11.5 dB
50 GHz to 60 GHz | 6.5 dB | 9 dB
60 GHz to 67 GHz | 6 dB | 8.5 dB
67 GHz to 70 GHzb | 8.5 dB | 8.5 dB
Source Match - UNL & 014
 |  | typical:
10 MHz to 45 MHzb | 5 dB | 5 dB
45 MHz to 2 GHz | 15 dB | 20 dB
2 GHz to 10 GHz | 9 dB | 13 dB
10 GHz to 20 GHz | 7.5 dB | 10.5 dB
20 GHz to 30 GHz | 8.5 dB | 11 dB
30 GHz to 40 GHz | 8 dB | 11 dB
40 GHz to 45 GHz | 8.5 dB | 12 dB
45 GHz to 50 GHz | 8 dB | 12 dB
50 GHz to 60 GHz | 7 dB | 11 dB
60 GHz to 67 GHz | 6 dB | 10 dB
67 GHz to 70 GHzb | 10 dB | 10 dB
Load Match - Standard
 |  | typical:
10 MHz to 45 MHzb | 5.5 dB | 5.5 dB
45 MHz to 2 GHz | 9 dB | 10 dB
2 GHz to 10 GHz | 9 dB | 11 dB
10 GHz to 20 GHz | 8.5 dB | 10 dB
20 GHz to 30 GHz | 7 dB | 9 dB
30 GHz to 40 GHz | 6 dB | 8 dB
40 GHz to 45 GHz | 6.5 dB | 9 dB
45 GHz to 50 GHz | 6.5 dB | 8.5 dB
50 GHz to 60 GHz | 5.5 dB | 7.5 dB
60 GHz to 67 GHz | 5.5 dB | 7.5 dB
67 GHz to 70 GHzb | 5 dB | 5 dB
Load Match - Option 014
 |  | typical:
10 MHz to 45 MHzb | 5.5 dB | 5.5 dB
45 MHz to 2 GHz | 8.5 dB | 10 dB
2 GHz to 10 GHz | 8 dB | 10 dB
10 GHz to 20 GHz | 8 dB | 10 dB
20 GHz to 30 GHz | 7.5 dB | 10 dB
30 GHz to 40 GHz | 7 dB | 9.5 dB
40 GHz to 45 GHz | 7.5 dB | 9.5 dB
45 GHz to 50 GHz | 7.5 dB | 10 dB
50 GHz to 60 GHz | 6 dB | 8.5 dB
60 GHz to 67 GHz | 6 dB | 8.5 dB
67 GHz to 70 GHzb | 5 dB | 5 dB
Load Match - Option UNL & 014
 |  | typical:
10 MHz to 45 MHzb | 6 dB | 6 dB
45 MHz to 2 GHz | 8.5 dB | 10 dB
2 GHz to 10 GHz | 7 dB | 9 dB
10 GHz to 20 GHz | 6 dB | 9 dB
20 GHz to 30 GHz | 7.5 dB | 11 dB
30 GHz to 40 GHz | 8 dB | 11.5 dB
40 GHz to 45 GHz | 8 dB | 12 dB
45 GHz to 50 GHz | 8 dB | 12 dB
50 GHz to 60 GHz | 7.5 dB | 11.5 dB
60 GHz to 67 GHz | 6 dB | 10 dB
67 GHz to 70 GHzb | 13 dB | 13 dB
Reflection Tracking
 |  | typical:
10 MHz to 45 MHz |  | ±1.5 dB
45 MHz to 20 GHz |  | ±1.5 dB
20 GHz to 40 GHz |  | ±2.0 dB
40 GHz to 50 GHz |  | ±2.0 dB
50 GHz to 67 GHz |  | ±3.0 dB
67 GHz to 70 GHz |  | ±4.5 dB
Transmission Trackingc
 |  | typical:
10 MHz to 45 MHz |  | ±1.5 dB
45 MHz to 20 GHz |  | ±1.5 dB
20 GHz to 40 GHz |  | ±2.0 dB
40 GHz to 50 GHz |  | ±2.0 dB
50 GHz to 67 GHz |  | ±3.0 dB
67 GHz to 70 GHz |  | ±4.5 dB
Crosstalkd - Standard
10 MHz to 45 MHzb | -63 dB |
45 MHz to 500 MHz | -87 dB |
500 MHz to 2 GHz | -110 dB |
2 GHz to 10 GHz | -105 dB |
10 GHz to 24 GHz | -111 dB |
24 GHz to 30 GHz | -106 dB |
30 GHz to 40 GHz | -104 dB |
40 GHz to 45 GHz | -98 dB |
45 GHz to 50 GHz | -100 dB |
50 GHz to 60 GHz | -97 dB |
60 GHz to 67 GHz | -94 dB |
67 GHz to 70 GHzb | -94 dB |
Crosstalkd - Option 014
 |  | typical (for Option 080 enablede)
10 MHz to 45 MHzb | -63 dB | -63 dB
45 MHz to 500 MHz | -87 dB | -87 dB
500 MHz to 2 GHz | -110 dB | -110 dB
2 GHz to 10 GHz | -105 dB | -105 dB
10 GHz to 24 GHz | -111 dB | -111 dB
24 GHz to 30 GHz | -104 dB | -104 dB
30 GHz to 40 GHz | -102 dB | -102 dB
40 GHz to 45 GHz | -96 dB | -96 dB
45 GHz to 50 GHz | -98 dB | -98 dB
50 GHz to 60 GHz | -95 dB | -95 dB
60 GHz to 67 GHz | -90 dB | -90 dB
67 GHz to 70 GHzb | -90 dB | -90 dB
Crosstalkd - Option 014 & UNL
 |  | typical (for Option 080 enablede)
10 MHz to 45 MHzb | -63 dB | -63 dB
45 MHz to 500 MHz | -87 dB | -87 dB
500 MHz to 2 GHz | -110 dB | -110 dB
2 GHz to 10 GHz | -104 dB | -104 dB
10 GHz to 24 GHz | -108 dB | -108 dB
24 GHz to 30 GHz | -101 dB | -101 dB
30 GHz to 40 GHz | -99 dB | -99 dB
40 GHz to 45 GHz | -92 dB | -92 dB
45 GHz to 50 GHz | -94 dB | -94 dB
50 GHz to 60 GHz | -91 dB | -91 dB
60 GHz to 67 GHz | -84 dB | -84 dB
67 GHz to 70 GHzb | -84 dB | -84 dB

a Specifications apply over environment temperature of 23°C +/- 3°C, with less than 1°C deviation from the calibration temperature.

b Typical performance.

cTransmission tracking performance noted here is normalized to the insertion loss characteristics of the cable used so that the indicated performance is independent of the cable used.

d Measurement conditions: normalized to a thru, measured with two shorts, 10 Hz IF bandwidth, averaging factor of 16, alternate mode, source power set to the lesser of the maximum power out or the maximum receiver power.

e 0 Hz offset.

Table 11. Test Port Output

Description | Specification |  |  | Supplemental
Frequency Range
 | Standard | Options |  |
E8361A | 45 MHz to 67 GHz (Operates 10 MHz to 70 GHz) |  |  |
Nominal Powerc
 | Std and Options without UNL | Options with UNL |  |
E8361A | -15 dBm | -17 dBm |  |
Frequency Resolution
 | 1 Hz |  |  |
CW Accuracy
 | +/-1 ppm |  |  |
Frequency Stability
 |  |  |  | +/-0.05 ppm. -10° to 70° C, typical; +/-0.1 ppm/yr maximum, typical
Power Level Accuracya
 | Standard | Opt 014 | Opt 014 & UNL |
10 MHz to 45 MHzb | +/-1.5 dB | +/-1.5 dB | +/-1.5 dB |
45 MHz to 10 GHz | +/-1.5 dB | +/-1.5 dB | +/-1.5 dB | Variation from nominal power in range 0 (step attenuator at 0 dB)
10 GHz to 20 GHz | +/-1.5 dB | +/-1.5 dB | +/-2.0 dB
20 GHz to 30 GHz | +/-2.0 dB | +/-2.0 dB | +/-2.5 dB
30 GHz to 40 GHz | +/-3.0 dB | +/-3.0 dB | +/-3 dB
40 GHz to 45 GHz | +/-3.0 dB | +/-3.0 dB | +/-3 dB
45 GHz to 50 GHz | +/-3.5 dB | +/-3.5 dB | +/-3.5 dB
50 GHz to 60 GHz | +/-4.0 dB | +/-4.0 dB | +/-4.0 dB
60 GHz to 67 GHz | +/-4.0 dB | +/-4.0 dB | +/-4.5 dB
67 GHz to 70 GHzb | +/-4.0 dB | +/-4.0 dB | +/-4.5 dB
Power Level Linearityd
 |  |  |  | Any Option
Test reference is at the nominal power level (step attenuator at 0 dB)
10 MHz to 45 MHzb | +/-1.0 dB for power<=-5 dBmg |  |  |
45 MHz to 67 GHz | +/-1.0 dB for power<=-5 dBmg |  |  |
67 GHz to 70 GHzb | +/-1.0 dB for power<=-5 dBmg |  |  |
Power Rangea,e,f
Note: If power is set above the maximum specified leveled power, the test port output signal may show non-linear effects that are dependent on the DUT.
 | Standard | Opt 014 | Opt 014 & UNL |
10 MHz to 45 MHzb | -25 to -9 dBm | -25 to -9 dBm | -75 to -9 dBm |
45 MHz to 500 MHz | -25 to -3 dBm | -25 to -3 dBm | -75 to -3 dBm |
500 MHz to 750 MHz | -25 to 0 dBm | -25 to 0 dBm | -75 to 0 dBm |
750 MHz to 10 GHz | -27 to -1 dBm | -27 to -1 dBm | -77 to -1 dBm |
10 GHz to 30 GHz | -27 to -2 dBm | -27 to -3 dBm | -77 to -3 dBm |
30 GHz to 40 GHz | -27 to -1 dBm | -27 to -2 dBm | -77 to -5 dBm |
40 GHz to 45 GHz | -27 to -7 dBm | -27 to -8 dBm | -77 to -10 dBm |
45 GHz to 50 GHz | -27 to -1 dBm | -27 to -2 dBm | -77 to -6 dBm |
50 GHz to 60 GHz | -27 to -3 dBm | -27 to -4 dBm | -77 to -8 dBm |
60 GHz to 67 GHz | -27 to -5 dBm | -27 to -7 dBm | -77 to -13 dBm |
67 GHz to 70 GHzb | -27 to -5 dBm | -27 to -7 dBm | -77 to -13 dBm |
Power Sweep Range (ALC)
 | Standard | Opt 014 | Opt 014 & UNL | ALC range starts at maximum leveled output power and decreases by power level indicated in the table.
10 MHz to 45 MHzb | 16 dB | 16 dB | 16 dB
45 MHz to 500 MHz | 22 dB | 22 dB | 22 dB
500 MHz to 750 MHz | 25 dB | 25 dB | 25 dB
750 GHz to 10 GHz | 26 dB | 26 dB | 26 dB
10 GHz to 30 GHz | 25 dB | 24 dB | 24 dB
30 GHz to 40 GHz | 26 dB | 25 dB | 22 dB
40 GHz to 45 GHz | 20 dB | 19 dB | 17 dB
45 GHz to 50 GHz | 26 dB | 25 dB | 21 dB
50 GHz to 60 GHz | 24 dB | 23 dB | 19 dB
60 GHz to 67 GHz | 22 dB | 20 dB | 14 dB
67 GHz to 70 GHzb | 22 dB | 20 dB | 14 dB
Power Resolution
 | 0.01 dB |  |  |
Phase Noise
 |  |  |  | Any Option
10 kHz offset from center frequency, nominal power at test port
 |  |  |  | typical:
10 MHz to 45 MHz |  |  |  | -80 dBc
45 MHz to 10 GHz |  |  |  | -70 dBc
10 GHz to 24 GHz |  |  |  | -60 dBc
24 GHz to 70 GHz |  |  |  | -55 dBc
10 kHz offset from center frequency, nominal power at test port - Option 080 enabled
 |  |  |  | typical:
10 MHz to 45 MHz |  |  |  | -80 dBc
45 MHz to 10 GHz |  |  |  | -70 dBc
10 GHz to 24 GHz |  |  |  | -60 dBc
24 GHz to 70 GHz |  |  |  | -55 dBc
100 kHz offset from center frequency, nominal power at test port
 |  |  |  | typical:
10 MHz to 45 MHz |  |  |  | -90 dBc
45 MHz to 10 GHz |  |  |  | -90 dBc
10 GHz to 24 GHz |  |  |  | -85 dBc
24 GHz to 70 GHz |  |  |  | -75 dBc
100 kHz offset from center frequency, nominal power at test port - Option 080 enabled
 |  |  |  | typical:
10 MHz to 45 MHz |  |  |  | -85 dBc
45 MHz to 10 GHz |  |  |  | -80 dBc
10 GHz to 24 GHz |  |  |  | -70 dBc
24 GHz to 70 GHz |  |  |  | -60 dBc
1 MHz offset from center frequency, nominal power at test port
 |  |  |  | typical:
10 MHz to 45 MHz |  |  |  | -115 dBc
45 MHz to 10 GHz |  |  |  | -110 dBc
10 GHz to 24 GHz |  |  |  | -105 dBc
24 GHz to 70 GHz |  |  |  | -95 dBc
1 MHz offset from center frequency, nominal power at test port - Option 080 enabled
 |  |  |  | typical:
10 MHz to 45 MHz |  |  |  | -110 dBc
45 MHz to 10 GHz |  |  |  | -105 dBc
10 GHz to 24 GHz |  |  |  | -95 dBc
24 GHz to 70 GHz |  |  |  | -85 dBc
Harmonics (2nd or 3rd)
 |  |  |  | Any Option
 |  |  |  | typical:
10 MHz to 500 MHz |  |  |  | -10 dBc
500 MHz to 10 GHz |  |  |  | -15 dBc
10 GHz to 24 GHz |  |  |  | -23 dBc
24 GHz to 50 GHz |  |  |  | -16 dBc
50 GHz to 60 GHz |  |  |  | -13 dBc
60 GHz to 70 GHz |  |  |  | -19 dBc
Non-Harmonic Spurious (at Nominal Output Power)
10 MHz to 20 GHz |  |  |  | -50 dBc typical, for offset frequency > 1 kHz
20 GHz to 70 GHz |  |  |  | -30 dBc typical, for offset frequency > 1 kHz

a Test port output is a specification when the source is set to Port 1, and a characteristic when the source is set to Port 2.

b Typical performance.

c Preset power.

d Power Level Linearity is a specification when the source is set to Port 1, and a typical when the source is set to Port 2.

e Test port power is specified into nominal 50 ohms.

f Power to which the source can be set and phase lock is assured.

g +/-1.6 dB for power>-5 dBm.

Table 12: Test Port Input

Description | Specification |  | Supplemental
 | Standard or UNL | Opt 014 or 014 & UNL |
Test Port Noise Floor1
10 Hz IF Bandwidth
10 MHz to 45 MHz2 | <-70 dBm | <-70 dBm |
45 MHz to 500 MHz3, 4 | <-90 dBm | <-90 dBm |
500 MHz to 2 GHz | <-112 dBm | <-112 dBm |
2 GHz to 10 GHz | <-112 dBm | <-112 dBm |
10 GHz to 24 GHz | <-116 dBm | <-115 dBm |
24 GHz to 30 GHz | <-105 dBm | <-104 dBm | Option 016 degrades performance by 2 dB.
30 GHz to 40 GHz | <-105 dBm | <-104 dBm
40 GHz to 45 GHz | <-103 dBm | <-102 dBm
45 GHz to 50 GHz | <-101 dBm | <-100 dBm
50 GHz to 60 GHz | <-100 dBm | <-99 dBm
60 GHz to 67 GHz | <-99 dBm | <-97 dBm | Option 016 degrades performance by 3 dB.
67 GHz to 70 GHz2 | <-99 dBm | <-97 dBm
1 KHz IF Bandwidth
10 MHz to 45 MHz2 | <-50 dBm | <-50 dBm |
45 MHz to 500 MHz3, 4 | <-70 dBm | <-70 dBm |
500 MHz to 2 GHz | <-92 dBm | <-92 dBm |
2 GHz to 10 GHz | <-92 dBm | <-92 dBm |
10 GHz to 24 GHz | <-96 dBm | <-95 dBm |
24 GHz to 30 GHz | <-85 dBm | <-84 dBm | Option 016 degrades performance by 2 dB.
30 GHz to 40 GHz | <-85 dBm | <-84 dBm
40 GHz to 45 GHz | <-83 dBm | <-82 dBm
45 GHz to 50 GHz | <-81 dBm | <-80 dBm
50 GHz to 60 GHz | <-80 dBm | <-79 dBm
60 GHz to 67 GHz | <-79 dBm | <-77 dBm | Option 016 degrades performance by 3 dB.
67 GHz to 70 GHz2 | <-79 dBm | <-77 dBm
Test Port Noise Floor1 Option 080 enabled5
 |  |  | Option 014 or 014 & UNL (typical)
10 Hz IF Bandwidth
10 MHz to 45 MHz |  |  | <-70 dBm
45 MHz to 500 MHz3, 4 |  |  | <-90 dBm
500 MHz to 2 GHz |  |  | <-112 dBm
2 GHz to 10 GHz |  |  | <-112 dBm
10 GHz to 24 GHz |  |  | <-115 dBm
24 GHz to 30 GHz |  | Option 016 degrades performance by 2 dB. | <-104 dBm
30 GHz to 40 GHz |  |  | <-104 dBm
40 GHz to 45 GHz |  |  | <-102 dBm
45 GHz to 50 GHz |  |  | <-100 dBm
50 GHz to 60 GHz |  |  | <-99 dBm
60 GHz to 67 GHz |  | Option 016 degrades performance by 3 dB. | <-97 dBm
67 GHz to 70 GHz |  |  | <-97 dBm
1 KHz IF Bandwidth
 |  |  | typical:
10 MHz to 45 MHz |  |  | <-50 dBm
45 MHz to 500 MHz3, 4 |  |  | <-70 dBm
500 MHz to 2 GHz |  |  | <-92 dBm
2 GHz to 10 GHz |  |  | <-92 dBm
10 GHz to 24 GHz |  |  | <-95 dBm
24 GHz to 30 GHz |  | Option 016 degrades performance by 2 dB. | <-84 dBm
30 GHz to 40 GHz |  |  | <-84 dBm
40 GHz to 45 GHz |  |  | <-82 dBm
45 GHz to 50 GHz |  |  | <-80 dBm
50 GHz to 60 GHz |  |  | <-79 dBm
60 GHz to 67 GHz |  | Option 016 degrades performance by 3 dB. | <-77 dBm
67 GHz to 70 GHz |  |  | <-77 dBm
Direct Receiver Access Input Noise Floor1
 | Standard |  | Option 014 or 014 & UNL (typical)
10 Hz IF Bandwidth
10 MHz to 45 MHz2 |  |  | <-106 dBm
45 MHz to 500 MHz3, 4 |  |  | <-105 dBm
500 MHz to 2 GHz |  |  | <-125.5 dBm
2 GHz to 10 GHz |  |  | <-125 dBm
10 GHz to 24 GHz |  |  | <-128 dBm
24 GHz to 30 GHz |  | Option 016 degrades performance by 2 dB. | <-117.5 dBm
30 GHz to 40 GHz |  |  | <-117 dBm
40 GHz to 45 GHz |  |  | <-115 dBm
45 GHz to 50 GHz |  |  | <-112.5 dBm
50 GHz to 60 GHz |  |  | <-111 dBm
60 GHz to 67 GHz |  | Option 016 degrades performance by 3 dB | . <-108 dBm
67 GHz to 70 GHz2 |  |  | <-107 dBm
1 KHz IF Bandwidth
10 MHz to 45 MHz2 |  |  | <-86 dBm
45 MHz to 500 MHz3, 4 |  |  | <-85 dBm
500 MHz to 2 GHz |  |  | <-105.5 dBm
2 GHz to 10 GHz |  |  | <-105 dBm
10 GHz to 24 GHz |  |  | <-108 dBm
24 GHz to 30 GHz |  | Option 016 degrades performance by 2 dB. | <-97.5 dBm
30 GHz to 40 GHz |  |  | <-97 dBm
40 GHz to 45 GHz |  |  | <-95 dBm
45 GHz to 50 GHz |  |  | <-92.5 dBm
50 GHz to 60 GHz |  |  | <-91 dBm
60 GHz to 67 GHz |  | Option 016 degrades performance by 3 dB. | <-88 dBm
67 GHz to 70 GHz2 |  |  | <-87 dBm
Direct Receiver Access Input Noise Floor1 - Option 080 enabled5
 | Standard |  | Option 014
10 Hz IF Bandwidth
 |  |  | typical:
10 MHz to 45 MHz2 |  |  | <-106 dBm
45 MHz to 500 MHz3, 4 |  |  | <-105 dBm
500 MHz to 2 GHz |  |  | <-125.5 dBm
2 GHz to 10 GHz |  |  | <-125 dBm
10 GHz to 24 GHz |  |  | <-128 dBm
24 GHz to 30 GHz |  | Option 016 degrades performance by 2 dB. | <-117.5 dBm
30 GHz to 40 GHz |  |  | <-117 dBm
40 GHz to 45 GHz |  |  | <-115 dBm
45 GHz to 50 GHz |  |  | <-112.5 dBm
50 GHz to 60 GHz |  |  | <-111 dBm
60 GHz to 67 GHz |  | Option 016 degrades performance by 3 dB. | <-108 dBm
67 GHz to 70 GHz2 |  |  | <-107 dBm
1 KHz IF Bandwidth
 |  |  | typical:
10 MHz to 45 MHz2 |  |  | <-86 dBm
45 MHz to 500 MHz3, 4 |  |  | <-85 dBm
500 MHz to 2 GHz |  |  | <-105.5 dBm
2 GHz to 10 GHz |  |  | <-105 dBm
10 GHz to 24 GHz |  |  | <-108 dBm
24 GHz to 30 GHz |  | Option 016 degrades performance by 2 dB. | <-97.5 dBm
30 GHz to 40 GHz |  |  | <-97 dBm
40 GHz to 45 GHz |  |  | <-95 dBm
45 GHz to 50 GHz |  |  | <-92.5 dBm
50 GHz to 60 GHz |  |  | <-91 dBm
60 GHz to 67 GHz |  | Option 016 degrades performance by 3 dB. | <-88 dBm
67 GHz to 70 GHz2 |  |  | <-87 dBm
Receiver Compression Level (measured at test ports)
 | Specifications |  |  | Supplemental Information
 | Standard | Option 014 | 014 & UNL | Typical
10 MHz to 45 MHz2, 6 | negligible
45 MHz to 500 MHz6, 7 | <0.1 dB at -9.5 dBm8 and <0.25 dB at -3 dBm | <0.1 dB at -4.0 dBm8 and <0.25 dB at +3 dBm |  | <0.1 dB at +0.5 dBm8 and <0.25 dB at +8 dBm
500 MHz to 5 GHz | <0.1 dB at -8 dBm8 and <0.25 dB at -1 dBm | <0.1 dB at -8 dBm8 and <0.25 dB at -1 dBm | <0.1 dB at -7 dBm8 and <0.25 dB at 0 dBm | <0.1 dB at -4.0 dBm8 and <0.25 dB at +3 dBm
5 GHz to 30 GHz | <0.1 dB at -8.5 dBm8 and <0.25 dB at -2 dBm | <0.1 dB at -9 dBm8 and <0.25 dB at -2 dBm | <0.1 dB at -6 dBm8 and <0.25 dB at +1 dBm | <0.1 dB at -1.0 dBm8 and <0.25 dB at +6 dBm
30 GHz to 67 GHz | <0.1 dB at -10.5 dBm8 and <0.15 dB at -7 dBm | <0.1 dB at -6.0 dBm8 and <0.15 dB at -4 dBm | <0.1 dB at -9.5 dBm8 and <0.15 dB at -6 dBm | <0.1 dB at -2.0 dBm8, 9 and <0.15 dB at +2 dBm9
67 GHz to 70 GHz2 | NA
System Compression Level
 | Standard | Option 014 or 014 & UNL |
 | maximum leveled output power |  | See dynamic accuracy table
Third Order Intercept10 - Tone spacing from 100 kHz - 5 MHz
 |  |  | Any Option
 |  |  | typical
10 MHz to 500 MHz |  |  | +30 dBm
500 MHz to 24 GHz |  |  | +24 dBm
24 GHz to 40 GHz |  |  | +23 dBm
40 to 50 GHz |  |  | +24 dBm
50 to 67 GHz |  |  | +26 dBm
Third Order Intercept10 - Tone spacing from 5 MHz - 20 MHz
 |  |  | Any Option
 |  |  | typical
10 MHz to 500 MHz |  |  | NA
500 MHz to 24 GHz |  |  | +20 dBm
24 GHz to 40 GHz |  |  | +20 dBm
40 to 50 GHz |  |  | +22 dBm
50 to 67 GHz |  |  | +24 dBm
Third Order Intercept10 - Tone spacing from 20 MHz - 50 MHz
 |  |  | Any Option
 |  |  | typical
10 MHz to 500 MHz |  |  | NA
500 MHz to 24 GHz |  |  | +26 dBm
24 to 40 GHz |  |  | +24 dBm
40 to 50 GHz |  |  | +25 dBm
50 to 67 GHz |  |  | +27 dBm
Trace Noise Magnitude 1 kHz IF bandwidth. Ratio measurement, nominal power at test port.
 | Standard or 014 | 014 & UNL |
10 MHz to 45 MHz2 | <0.150 dB rms | <0.150 dB rms |
45 MHz to 500 MHz11, 4 | <0.010 dB rms | <0.010 dB rms |
500 MHz to 24 GHz | <0.006 dB rms | <0.006 dB rms |
24 GHz to 67 GHz | <0.006 dB rms | <0.009 dB rms |
67 GHz to 70 GHz2 | <0.006 dB rms | <0.009 dB rms |
Trace Noise Magnitude - Option 080 enabled2,5 1 kHz IF bandwidth. Ratio measurement, nominal power at test port.
 | Standard or 014 | 014 & UNL |
10 MHz to 45 MHz | <0.150 dB rms | <0.150 dB rms |
45 MHz to 500 MHz11, 4 | <0.010 dB rms | <0.010 dB rms |
500 MHz to 24 GHz | <0.006 dB rms | <0.006 dB rms |
24 GHz to 67 GHz | <0.009 dB rms | <0.012 dB rms |
67 GHz to 70 GHz | <0.009 dB rms | <0.012 dB rms |
Trace Noise Phase 1 kHz IF bandwidth. Ratio measurement, nominal power at test port.
 | Any Option |  |
10 MHz to 45 MHz2 | <0.800° rms |  |
45 MHz to 500 MHz4 | <0.100° rms |  |
500 MHz to 24 GHz | <0.060° rms |  |
24 GHz to 67 GHz | <0.100° rms |  |
67 GHz to 70 GHz2 | <0.100° rms |  |
Trace Noise Phase - Option 080 enabled2, 5 1 kHz IF bandwidth. Ratio measurement, nominal power at test port.
 |  |  | typical:
10 MHz to 45 MHz |  |  | <0.800° rms
45 MHz to 500 MHz4 |  |  | <0.100° rms
500 MHz to 24 GHz |  |  | <0.060° rms
24 GHz to 67 GHz |  |  | <0.100° rms
67 GHz to 70 GHz |  |  | <0.100° rms
Reference Level Magnitude
Range | +/-500 dB |  |
Resolution | 0.001 dB |  |
Reference Level Phase
Range | +/-500° |  |
Resolution | 0.01° |  |
Stability Magnitude12
 |  |  | Any Option
Typical ratio measurement, made at the test port.
10 MHz to 45 MHz |  |  | +/-0.05 dB/°C
45 MHz to 50 GHz |  |  | +/-0.02 dB/°C
50 GHz to 70 GHz |  |  | +/-0.04 dB/°C
Stability Phase12
 |  |  | Any Option
Typical ratio measurement, measured at the test port.
10 MHz to 45 MHz |  |  | +/-0.5°/°C
45 MHz to 20 GHz |  |  | +/-0.2°/°C
20 GHz to 40 GHz |  |  | +/-0.5°/°C
40 GHz to 70 GHz |  |  | +/-0.8°/°C
Damage Input Level
 |  |  | typical:
Test Port 1 and 2 |  |  | +27 dBm or +/-40 VDC
R1, R2 in |  |  | +15 dBm or +/-15 VDC
A, B in |  |  | +15 dBm or +/-7 VDC
Coupler Thru (Option 014 or 014 & UNL) |  |  | +27 dBm or +/-40 VDC
Coupler Arm (Option 014 or 014 & UNL) |  |  | +30 dBm or +/-7 VDC

1Total average (rms) noise power calculated as the mean value of a linear magnitude trace expressed in dBm.

2Typical performance.

3Noise floor may be degraded by 10 dB at particular frequencies (multiples of 5 MHz) due to spurious receiver residuals.

4 Specified value is for worst-case noise floor at 45 MHz

50 Hz offset

6 Coupler roll-off will reduce compression below 500 MHz. Ultimately, at 45 MHz, compression is negligible.

7 Specified value is for worst-case compression at 500 MHz.

8 This compression level comes from the dynamic accuracy curve with -30 dBm reference test port power.

9 Option 016 degrades performance by 3 dB.

10 TOI is a typical specification that applies while the network analyzer receiver is in its linear range.

11Trace noise magnitude may be degraded to 20 mdB rms at harmonic frequencies of the first IF (8.33 MHz) below 80 MHz.

12Stability is defined as a ratio measurement made at the test port.

Table 13. Dynamic Accuracy (Specificationa)

Accuracy of the test port input power reading relative to the reference input power level.

Note: If power is set above the maximum specified leveled power, the test port output signal may show non-linear effects that are dependent on the DUT

Dynamic Accuracy, 0.045 GHz

Dynamic Accuracy, 0.500 GHz

Dynamic Accuracy, 0.500 - 5 GHz

Dynamic Accuracy, 5 - 30 GHz

Dynamic Accuracy, 30 - 67 GHz

Dynamic Accuracy, 67 - 70 GHz

a Dynamic accuracy is verified with the following measurements:

  • compression over frequency

  • IF linearity at a single frequency of 1.195 GHz and a reference level of -20 dBm for an input power range of 0 to -120 dBm.

Table 14. Test Port Input (Group Delay)a

Description

Specification

Supplemental Information (typ.)

Aperture (selectable)

(frequency span)/(number of points -1)

Maximum Aperture

20% of frequency span

Range

0.5 x (1/minimum aperture)

Maximum Delay

Limited to measuring no more than 180° of phase change within the minimum aperture.)

Accuracy

See graph below. Char.

The following graph shows characteristic group delay accuracy with full 2-port calibration and a 10 Hz IF bandwidth. Insertion loss is assumed to be < 2 dB and electrical length to be ten meters.

In general, the following formula can be used to determine the accuracy, in seconds, of specific group delay measurement:

±Phase Accuracy (deg)/[360 × Aperture (Hz)]

Depending on the aperture and device length, the phase accuracy used is either incremental phase accuracy or worst case phase accuracy.

a Group delay is computed by measuring the phase change within a specified frequency step (determined by the frequency span and the number of points per sweep).

General Information

  • Miscellaneous Information

  • Front Panel

  • Rear Panel

  • Environment and Dimensions

Table 15. Miscellaneous Information

Description | Specification | Supplemental Information
System IF Bandwidth Range |  | 1 Hz to 40 kHz, nominal
CPU |  | Intel® 500 MHz Pentium® III

Table 16. Front Panel Information

Description | Supplemental Information
RF Connectors
E8361A
Type | 1.85 mm (male), 50 ohm, (nominal)
Center Pin Recession | 0.002 in. (characteristic)
Display
Size | 21.3 cm (8.4 in) diagonal color active matrix LCD; 640 (horizontal) X 480 (vertical) resolution
Refresh Rate | Vertical 59.83 Hz; Horizontal 31.41 kHz
Display Range
Magnitude | ±200 dB (at 20 dB/div), max
Phase | ±500°, max
Polar | 10 pUnits, min 1000 Units, max
Display Resolution
Magnitude | 0.001 dB/div, min
Phase | 0.01°/div, min
Marker Resolution
Magnitude | 0.001 dB, min
Phase | 0.01°, min
Polar | 0.01 mUnit, min; 0.01°,min

Table 17. Rear Panel Information

Description | Supplemental Information
10 MHz Reference In
Connector | BNC, female
Input Frequency | 10 MHz ± 10 ppm, typical
Input Level | -15 dBm to +20 dBm, typical
Input I mpedance | 200 W, nom.
10 MHz Reference Out
Connector | BNC, female
Output Frequency | 10 MHz ± 1 ppm, typical
Signal Type | Sine Wave, typical
Output Level | +10 dBm ± 4 dB into 50 W, typical
Output Impedance | 50 W, nominal
Harmonics | <-40 dBc, typical
Option H08 & H11 Rear Panel Connectors (Typical)
IF Connectors | A, R1, R2, B (BNC Connectors)
IF Connector Input Frequency | 8 1/3 MHz
Nominal Input Impedance at IF Inputs | 50 W
RF Damage Level to IF Connector Inputs | -20.0 dBm
DC Damage Level to IF Connector Inputs | 25 volts
0.1 dB Compression Point at IF Inputs | -27.0 dBm
Pulse Input Connectors1 | A, R1, R2, B (BNC Connectors)
Nominal Input Impedance at Pulse Inputs | 1 Kohm
Minimum IF Gate Width | 20 ns for less than 1 dB deviation from theoretical performance2.
DC Damage Level to Pulse Connector Inputs | 5.5 volts
Drive Voltage | TTL (0, +5.0) Volts
Rear Panel LO Power - Test Port Frequency
1.7 GHz to 20 GHz | -7 to –16 dBm
Rear Panel RF Power - Test Port Frequencies
1.7 GHz to 20 GHz | -2 to –12 dBm (at –5 dBm test port power3)
10 GHz to 16 GHz | 0 to –8 dBm (at –5 dBm test port power3)
16 GHz to 20 GHz | +5 to –1 dBm (at –5 dBm test port power3)
VGA Video Output
Connector | 15-pin mini D-Sub; Drives VGA compatible monitors
Devices Supported: |
 | Resolutions:
Flat Panel (TFT) | 1024 X 768, 800 X 600, 640 X 480
Flat Panel (DSTN) | 800 X 600, 640 X 480
CRT Monitor | 1280 X 1024, 1024 X 768, 800 X 600, 640 X 480
 | Simultaneous operation of the internal and external displays is allowed, but with 640 X 480 resolution only. If you change resolution, you can only view the external display (internal display will "white out").
Bias Input Connectors (Option UNL)
Bias current | 500 mA, maximum
Bias voltage | 40 Volts, maximum
Test Set IO
 | 25-pin D-Sub connector, available for external test set control
Aux IO
 | 25-pin D-Sub connector, male, analog and digital IO
Handler IO
 | 36-pin parallel I/O port; all input/output signals are default set to negative logic; can be reset to positive logic via GPIB command
GPIB
 | 24-pin D-sub (Type D-24), female; compatible with IEEE-488.
Parallel Port (LPT1)
 | 25-pin D-Sub miniature connector, female; provides connection to printers or any other parallel port peripherals
Serial Port (COM 1)
 | 9-pin D-Sub, male; compatible with RS-232
USB Port
 | One port on front panel and five ports on rear panel. Universal Serial Bus jack, Type A configuration (4 contacts inline, contact 1 on left); female
Contact 1 | Vcc: 4.75 to 5.25 VDC, 500 mA, maximum
Contact 2 | -Data
Contact 3 | +Data
Contact 4 | Ground
LAN
 | 10/100BaseT Ethernet, 8-pin configuration; auto selects between the two data rates
Line Power (A third-wire ground is required.)
Frequency | 50/60/400 Hz
Voltage | 120/240 VAC (Power supply is auto switching.)
Max | 500 Watts

1 Pulse input connectors are operational only with Option H08 (Pulse Measurement Capability) enabled.

2 Based on deviation from signal reduction equation: Signal Reduction (dB) = 20log10(Duty_cycle) = 20log10(pulse_width/period). Measured at Pulse Repetition Frequency (PFR) of 1 MHz.

3 Test port power has to be at a high enough level such that the “Drop Cal” does not occur. If Drop Cal occurs then the power out of the rear panel RF connector will drop by about 15 dB.

Table 18. Analyzer Environment and Dimensions

Description | Supplemental Information
General Environmental
RFI/EMI Susceptibility | Defined by CISPR Pub. 11, Group 1, Class A, and IEC 50082-1
ESD | Minimize using static-safe work procedures and an antistatic bench mat
Dust | Minimize for optimum reliability
Operating Environment
Temperature | 0 °C to +40 °C Instrument powers up, phase locks, and displays no error messages within this temperature range (except for "source unleveled" error message that may occur at temperatures outside the specified performance temperature range of 25 +/- 5°C).
Error-Corrected Temperature Range | 23°C ± 3°C with less than 1°C deviation from calibration temp.
Humidity | 5% to 95% at +40 °C
Altitude | 0 to 4500 m (14,760 ft.)
Non-Operating Storage Environment
Temperature | -40 °C to +70 °C
Humidity | 0% to 90% at +65 °C (non-condensing)
Altitude | 0 to 15,240 m (50,000 ft.)
Cabinet Dimensions
 | Height | Width | Depth
Excluding front and rear panel hardware and feet | 267 mm 10.5 in | 426 mm 16.75 in | 427 mm 16.8 in
As shipped - includes front panel connectors, rear panel bumpers, and feet. | 280 mm 11.0 in | 435 mm 17.1 in | 470 mm 18.5 in
As shipped plus handles | 280 mm 11.0 in | 458 mm 18 in | 501 mm 19.7 in
As shipped plus rack-mount flanges | 280 mm 11.0 in | 483 mm 19 in | 470 mm 18.5 in
As shipped plus handles and rack-mount flanges | 280 mm 11.0 in | 483 mm 19 in | 501 mm 19.70 in
Weight
Net
E8361A | 29 kg (64 lb), nominal
Shipping
E8361A | 36.3 kg (80 lb), nominal

Measurement Throughput Summary

  • Typical Cycle Time for Measurement Completion

  • Cycle Time vs IF Bandwidth

  • Cycle Time vs Number of Points

  • Data Transfer Time

Table 19 Typical Cycle Timea,b (ms) for Measurement Completion

 | Number of Points
 | 201 | 401 | 1601 | 16,001
Start 28 GHz, Stop 30 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 12 | 19 | 55 | 503
2-Port cal | 29 | 44 | 124 | 1112
Start 10 MHz, Stop 10 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 86 | 93 | 121 | 583
2-Port cal | 179 | 199 | 267 | 1301
Start 10 MHz, Stop 20 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 126 | 130 | 153 | 597
2-Port cal | 264 | 275 | 335 | 1321
Start 10 MHz, Stop 40 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 185 | 190 | 213 | 621
2-Port cal | 382 | 401 | 459 | 1374
Start 10 MHz, Stop 50 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 210 | 216 | 243 | 643
2-Port cal | 436 | 450 | 522 | 1405
Start 10 MHz, Stop 67 GHz, 35 kHz IF bandwidth
Uncorrected 1-port cal | 244 | 254 | 300 | 645
2-Port cal | 502 | 524 | 591 | 1423

a Typical performance.
b Includes sweep time, retrace time and band-crossing time. Analyzer display turned off with
DISPLAY:ENABLE OFF. Add 21 ms for display on. Data for one trace (S11) measurement.

Table 20. Cycle Time vs IF Bandwidtha

Applies to the Preset condition (201 points, correction off) except for the following changes:

  • CF = 28 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
IF Bandwidth (Hz) | Cycle Time (ms)b | Cycle Time (ms) Option 080 enabled
40,000 | 11 | 100
35,000 | 12 | 101
30,000 | 13 | 102
20,000 | 16 | 106
10,000 | 30 | 127
7000 | 38 | 138
5000 | 50 | 152
3000 | 74 | 182
1000 | 274 | 326
300 | 694 | 782
100 | 1905 | 2054
30 | 6091 | 6355
10 | 17916 | 18372

a Typical performance.
b Cycle time includes sweep and retrace time.

Table 21. Cycle Time vs Number of Pointsa

Applies to the Preset condition (35 kHz IF bandwidth, correction off) except for the following changes:

  • CF = 28 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
Number of Points | Cycle Time (ms)b
3 | 6
11 | 6
51 | 7
101 | 9
201 | 12
401 | 18
801 | 30
1601 | 55
16,001 | 497

a Typical performance.
b Cycle time includes sweep and retrace time.

Table 22. Data Transfer Time (ms)a

 | Number of Points
 | 201 | 401 | 1601 | 16,001
SCPI over GPIB (program executed on external PC)
32-bit floating point | 7 | 12 | 43 | 435
64-bit floating point | 12 | 22 | 84 | 856
ASCII | 64 | 124 | 489 | 5054
SCPI (program executed in the analyzer)
32-bit floating point | 1 | 2 | 3 | 30
64-bit floating point | 2 | 2 | 4 | 40
ASCII | 29 | 56 | 222 | 2220
COM (program executed in the analyzer)
32-bit floating point | <0.4 | 0.4 | 0.5 | 1.9
Variant type | 0.7 | 1 | 3 | 32
DCOM over LAN (program executed on external PC)
32-bit floating point | <0.8 | 1 | 1.5 | 7.1
Variant type | 1.8 | 2.7 | 8.5 | 80

a Typical performance

Note: Specifications for Recall & Sweep Speed are not provided for the E8361A analyzers.

Test Set Block Diagrams

E8361A - Standard Configuration and Standard Power Range

E8361A - Option UNL Standard Configuration with Extended Power Range and Bias - Tees

E8361A - Option UNL Standard Configuration with Extended Power Range and Bias - Tees, and Option 016, Receiver Attenuators

Test Set with Option 014 Block Diagrams

E8361A - Option 014 – Configurable Test Set and Standard Power Range

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

E8361A - Option 014 – Configurable Test Set and Standard Power Range, and Option 081 Reference Channel Transfer Switch

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

E8361A - Option 014 Configurable Test Set, and Option UNL Extended Power Range and Bias - Tees

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

E8361A - Option 014 Configurable Test Set, and Option UNL Extended Power Range and Bias - Tees, and Option 081 Reference Channel Transfer Switch

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

E8361A - Option 014 Configurable Test Set and Option UNL, Extended Power Range and Bias - Tees and Option 016 Receiver Attenuators

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

E8361A - Option 014 Configurable Test Set, and Option UNL Extended Power Range and Bias - Tees, and Option 016 Receiver Attenuators, and Option 081 Reference Channel Transfer Switch

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT


M1_Specs

Technical Specifications for the E8362A, E8363A, E8364A

Because the E8362A, E8363A, and E8364A network analyzer is no longer produced, the technical specifications are stored only on the Internet. To view or print the .pdf version of the specifications, visit our web site at http://www.agilent.com/find/pna, and search for "E836xA Specifications"

The uncertainty curves contained in this document apply only to the setup conditions listed. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your PNA setup. View the equations used to generate the uncertainty curves.


Specs: E836xB Analyzers

Technical Specifications for the E8362B, E8363B, E8364B
(Rev. 2005-07-12)

This is a complete list of the E8362B, E8363B, and E8364B network analyzer technical specifications.

  • To optimize viewing of uncertainty curves, click the Maximize button.

  • To view or print the .pdf version of the specifications, visit our web site at http://www.agilent.com/find/pna, and search for "E836xB Specifications"

  • The uncertainty curves contained in this document apply only to the setup conditions listed. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your PNA setup. View the equations used to generate the uncertainty curves.

  • Definitions

  • Corrected System Performance

    • System Dynamic Range

    • Receiver Dynamic Range

    • 2.4mm Connectors

    • 2.92mm Connectors

    • 3.5mm Connectors

    • 7mm Connectors

    • Type-N Connectors

    • WR-28 Connectors

    • WR-42 Connectors

    • WR-62 Connectors

    • WR-90 Connectors

  • Uncorrected System Performance

  • Test Port Output

  • Test Port Input

  • Dynamic Accuracy

  • Group Delay

  • General Information

  • Measurement Throughput Summary

  • Front-panel Jumper Specs (Option 014 only)

  • Test Set Block Diagrams

  • Test Set with Option 014 Block Diagrams

See Specs for other PNA models

Definitions

All specifications and characteristics apply over a 25 °C ±5 °C range (unless otherwise stated) and 90 minutes after the instrument has been turned on.

Specification (spec.): Warranted performance. Specifications include guardbands to account for the expected statistical performance distribution, measurement uncertainties, and changes in performance due to environmental conditions.

Characteristic (char.): A performance parameter that the product is expected to meet before it leaves the factory, but that is not verified in the field and is not covered by the product warranty. A characteristic includes the same guardbands as a specification.

Typical (typ.): Expected performance of an average unit which does not include guardbands. It is not covered by the product warranty.

Nominal (nom.): A general, descriptive term that does not imply a level of performance. It is not covered by the product warranty.

Calibration: The process of measuring known standards to characterize a network analyzer's systematic (repeatable) errors.

Corrected (residual): Indicates performance after e rror c orrection (calibration). It is determined by the quality of calibration standards and how well "known" they are, plus system repeatability, stability, and noise.

Uncorrected (raw): Indicates instrument performance without error correction. The uncorrected performance affects the stability of a calibration.

Standard: When referring to the analyzer, this includes no options unless noted otherwise.

Corrected System Performance

The specifications in this section apply for measurements made with the E836xB analyzer with the following conditions:

  • 10 Hz IF bandwidth

  • No averaging applied to data

  • Isolation calibration with an averaging factor of 8

  • System Dynamic Range

  • Receiver Dynamic Range

  • 2.4mm Connectors

  • 2.92mm Connectors

  • 3.5mm Connectors

  • 7mm-Connectors

  • Type-N Connectors

  • WR-28 Connectors

  • WR-42-Connectors

  • WR-62 Connectors

  • WR-90 Connectors

Table 1. System Dynamic Rangea

Description | Specification (dB) at Test Portb | Typical (dB) at Direct Receiver Access Inputc | Supplemental Information
Dynamic Range (in a 10 Hz BW)
Standard Configuration and Standard Power Range (E836xB - Standard)
10 MHz to 45 MHzd | 79 | NA |
45 MHz to 500 MHze | 94 | NA |
500 MHz to 2 GHz | 119 | NA |
2 GHz to 10 GHz | 122 | NA |
10 GHz to 20 GHz | 123 | NA |
20 GHz to 30 GHz | 114 | NA |
30 GHz to 40 GHz | 110 | NA |
40 GHz to 45 GHz | 109 | NA |
45 GHz to 50 GHz | 104 | NA |
Configurable Test Set and Standard Power Range (E836xB - Option 014)
10 MHz to 45 MHzd | 79 | 129 | Option 016 degrades performance by 2 dB.
45 MHz to 500 MHze | 94 | 132
500 MHz to 2 GHz | 119 | 138
2 GHz to 10 GHz | 122 | 137
10 GHz to 20 GHz | 121 | 136
20 GHz to 30 GHz | 111 | 123
30 GHz to 40 GHz | 107 | 119
40 GHz to 45 GHz | 105 | 116
45 GHz to 50 GHz | 100 | 111
Standard Configuration and Extended Power Range & Bias-Tees (E836xB - Option UNL)
10 MHz to 45 MHzd | 79 | NA | Option 016 degrades performance by 2 dB.
45 MHz to 500 MHze | 92 | NA
500 MHz to 2 GHz | 117 | NA
2 GHz to 10 GHz | 120 | NA
10 GHz to 20 GHz | 121 | NA
20 GHz to 30 GHz | 112 | NA
30 GHz to 40 GHz | 108 | NA
40 GHz to 45 GHz | 105 | NA
45 GHz to 50 GHz | 99 | NA
Configurable Test Set and Extended Power Range & Bias-Tees (E836xB - Option 014/UNL)
10 MHz to 45 MHzd | 79 | 129 | Option 016 degrades performance by 2 dB.
45 MHz to 500 MHze, f | 92 | 130
500 MHz to 2 GHzf | 117 | 136
2 GHz to 10 GHzf | 120 | 135
10 GHz to 20 GHzg | 119 | 134
20 GHz to 30 GHz | 109 | 121
30 GHz to 40 GHz | 105 | 117
40 GHz to 45 GHz | 101 | 112
45 GHz to 50 GHz | 95 | 106

a The system dynamic range is calculated as the difference between the noise floor and the source maximum output power. System dynamic range is a specification when the source is set to Port 1, and a characteristic when the source is set to Port 2. The effective dynamic range must take measurement uncertainties and interfering signals into account as well as the insertion loss resulting from a thru cable connected between Port 1 and Port 2..
b The test port system dynamic range is calculated as the difference between the test port noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account as well as the insertion loss resulting from a thru cable connected between Port 1 and Port 2..
c The direct receiver access input system dynamic range is calculated as the difference between the receiver access input noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account. This set-up should only be used when the receiver input will never exceed its damage level. When the analyzer is in segment sweep mode, the analyzer can have predefined frequency segments which will output a higher power level when the extended dynamic range is required (i.e. devices with high insertion loss), and reduced power when receiver damage may occur (i.e. devices with low insertion loss). The extended range is only available in one-path transmission measurements.
d Typical performance.
e May be limited to 100 dB at particular frequencies below 500 MHz due to spurious receiver residuals. Methods are available to regain the full dynamic range.

f E8362B only: Option H11 decreases value by 1 dB.

g E8362B only: Option H11 decreases value by 2 dB.

Table 2. Receiver Dynamic Rangea

Description | Specification (dB) at Test Portb | Typical (dB) at Direct Receiver Access Inputc |
Dynamic Range (in a 10 Hz BW)
Standard Configuration and Standard Power Range (E836xB - Standard) OR Standard Configuration and Extended Power Range & Bias Tees (E836xB - Option UNL)
10 MHz to 45 MHzd | 82 | NA |
45 MHz to 500 MHze | 94 | NA |
500 MHz to 2 GHz | 119 | NA |
2 GHz to 10 GHz | 122 | NA |
10 GHz to 20 GHz | 125 | NA |
20 GHz to 30 GHz | 114 | NA | Option 016 degrades performance by 2 dB.
30 GHz to 40 GHz | 111 | NA
40 GHz to 50 GHz | 111 | NA
Configurable Test Set and Standard Power Range (E836xB - Option 014) OR Configurable Test Set and Extended Power Range & Bias Tees (E836xB - Option 014/UNL)
10 MHz to 45 MHzd | 82 | 132 |
45 MHz to 500 MHze | 94 | 132 |
500 MHz to 2 GHz | 119 | 138 |
2 GHz to 10 GHz | 122 | 137 |
10 GHz to 20 GHz | 124 | 139 |
20 GHz to 30 GHz | 113 | 125 | Option 016 degrades performance by 2 dB.
30 GHz to 40 GHz | 110 | 122
40 GHz to 50 GHz | 109 | 120

a The receiver dynamic range is calculated as the difference between the noise floor and the receiver maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account.
b The test port receiver dynamic range is calculated as the difference between the test port noise floor and the receiver maximum input level. The effective dynamic range must take measurement uncertainties and interfering signals into account.
c The direct receiver access input receiver dynamic range is calculated as the difference between the direct receiver access input noise floor and the receiver maximum input level. The effective dynamic range must take measurement uncertainties and interfering signals into account. This set-up should only be used when the receiver input will never exceed its compression or damage level. When the analyzer is in segment sweep mode, the analyzer can have predefined frequency segments which will output a higher power level when the extended dynamic range is required (i.e. devices with high insertion loss), and reduced power when compression or receiver damage may occur (i.e. devices with low insertion loss). The extended range is only available in one-path transmission measurements.
d Typical performance.
e May be degraded by 10 dB at particular frequencies (multiples of 5 MHz) below 500 MHz due to spurious receiver residuals. Methods are available to regain the full dynamic range.

Note: This E836xB document provides technical specifications for the following calibration kits only: 85056A, 85056D, 85056K, 85052B, 85052C, 85052D, 85050B, 85050C, 85050D, 85054B, 85054D, K11644A, P11644A, R11644A, and the X11644A.

Table 33. Uncorrected System Performancea

Specifications apply over environmental temperature of 23° ±3 °C, with < 1 °C deviation from the calibration temperature

Description | Specification | Supplemental Information
Directivity
10 MHz to 45 MHzb | 23 dB |
45 MHz to 2 GHz | 24 dB |
2 GHz to 10 GHz | 22 dB |
10 GHz to 20 GHz | 16 dB |
20 GHz to 40 GHz | 16 dB |
40 GHz to 45 GHz | 15 dB |
45 GHz to 50 GHz | 13 dB |
Source Match - Standard
10 MHz to 45 MHzb | 11 dB |
45 MHz to 2 GHz | 23 dB |
2 GHz to 10 GHz | 16 dB |
10 GHz to 20 GHz | 14 dB |
20 GHz to 40 GHz | 10 dB |
40 GHz to 45 GHz | 9 dB |
45 GHz to 50 GHz | 7.5 dB |
Source Match - Opt UNL, 014 or 014/UNL
10 MHz to 45 MHzb | 11 dB |
45 MHz to 2 GHz | 18 dB |
2 GHz to 10 GHz | 14 dB |
10 GHz to 20 GHz | 12 dB |
20 GHz to 40 GHz | 9 dB |
40 GHz to 45 GHz | 8 dB |
45 GHz to 50 GHz | 6 dB |
Load Match - Standard
10 MHz to 45 MHzb | 11 dB |
45 MHz to 2 GHz | 23 dB |
2 GHz to 10 GHz | 14 dB |
10 GHz to 20 GHz | 10 dB |
20 GHz to 40 GHz | 9 dB |
40 GHz to 45 GHz | 9 dB |
45 GHz to 50 GHz | 8 dB |
Load Match - Opt UNL, 014 or 014/UNL
10 MHz to 45 MHzb | 11 dB |
45 MHz to 2 GHz | 17 dB |
2 GHz to 10 GHz | 13 dB |
10 GHz to 20 GHz | 10 dB |
20 GHz to 40 GHz | 9 dB |
40 GHz to 45 GHz | 9 dB |
45 GHz to 50 GHz | 7 dB |
Reflection Tracking
 |  | Typical:
10 MHz to 45 MHz |  | ±1.5 dB
45 MHz to 20 GHz |  | ±1.5 dB
20 GHz to 40 GHz |  | ±1.5 dB
40 GHz to 50 GHz |  | ±2.0 dB
Transmission Trackingc
 |  | Typical:
10 MHz to 45 MHz |  | ±3.0 dB
45 MHz to 2 GHz |  | ±1.5 dB
2 GHz to 10 GHz |  | ±2.0 dB
10 GHz to 20 GHz |  | ±2.5 dB
20 GHz to 40 GHz |  | ±3.5 dB
40 GHz to 45 GHz |  | ±4.0 dB
45 GHz to 50 GHz |  | ±4.5 dB
Crosstalkd - Standard
10 MHz to 45 MHzb | -65 dB |
45 MHz to 1 GHz | -85 dB |
1 GHz to 2 GHz | -100 dB |
2 GHz to 20 GHz | -110 dB |
20 GHz to 40 GHz | -108 dB |
40 GHz to 45 GHz | -105 dB |
45 GHz to 50 GHz | -100 dB |
Crosstalkd - Option UNL or 014
10 MHz to 45 MHzb | -65 dB |
45 MHz to 1 GHz | -85 dB |
1 GHz to 2 GHz | -100 dB |
2 GHz to 20 GHz | -109 dB |
20 GHz to 40 GHz | -106 dB |
40 GHz to 45 GHz | -103 dB |
45 GHz to 50 GHz | -98 dB |
Crosstalkd - Option 014/UNL
10 MHz to 45 MHzb | -65 dB |
45 MHz to 1 GHz | -85 dB |
1 GHz to 2 GHz | -98 dB |
2 GHz to 10 GHz | -108 dB |
10 GHz to 20 GHz | -107 dB |
20 GHz to 40 GHz | -104 dB |
40 GHz to 45 GHz | -100 dB |
45 GHz to 50 GHz | -95 dB |
Crosstalk - Option 080 enabledb,e
 |  | Typical:
10 MHz to 45 MHz |  | -65
45 MHz to 1 GHz |  | -85
1 GHz to 2 GHz |  | -100
2 GHz to 10 GHz |  | -109
10 GHz to 20 GHz |  | -110
20 GHz to 40 GHz |  | -106
40 GHz to 45 GHz |  | -103
45 GHz to 50 GHz |  | -98

a Specifications apply over environment temperature of 23°C +/- 3°C, with less than 1°C deviation from the calibration temperature.

b Typical performance.

cTransmission tracking performance is strongly dependent on cable used. These typical specifications are based on the use of the Agilent thru cable (part number 85133-60016).

d Measurement conditions: normalized to a thru, measured with two shorts, 10 Hz IF bandwidth, averaging factor of 16, alternate mode, source power set to the lesser of the maximum power out or the maximum receiver power.

e 0 Hz offset.

Table 34. Test Port Output

Description | Specification |  |  |  | Supplemental
Frequency Range
 | Standard | Opt 014 | Opt UNL | Opt 014/UNL |
E8362B | 10 MHz to 20 GHz |  |  |  |
E8363B | 10 MHz to 40 GHz |  |  |  |
E8364B | 10 MHz to 50 GHz |  |  |  |
Nominal Powerc
E8362B | 0 dBm | -5 dBm | -5 dBm | -5 dBm |
E8363/4B | -12 dBm | -17 dBm | -17 dBm | -17 dBm |
Frequency Resolution
 | 1 Hz |  |  |  |
CW Accuracy
 | +/-1 ppm |  |  |  |
Frequency Stability
 |  |  |  |  | +/-0.05 ppm. -10° to 70° C, typical; +/-0.1 ppm/yr maximum, typical
Power Level Accuracya
10 MHz to 45 MHzb | +/-2.0 dB | +/-2.0 dB | +/-2.0 dB | +/-2.0 dB |
45 MHz to 10 GHz | +/-1.5 dB | +/-1.5 dB | +/-1.5 dB | +/-1.5 dB | Variation from nominal power in range 0 (step attenuator at 0 dB)
10 GHz to 20 GHz | +/-2.0 dB | +/-2.0 dB | +/-2.0 dB | +/-2.0 dB
20 GHz to 40 GHz | +/-3.0 dB | +/-3.0 dB | +/-3.0 dB | +/-3.0 dB
40 GHz to 45 GHz | +/-3.0 dB | +/-3.5 dB | +/-3.0 dB | +/-3.5 dB
45 GHz to 50 GHz | +/-3.0 dB | +/-4.0 dB | +/-3.0 dB | +/-4.0 dB
Power Level Linearityd
10 MHz to 45 MHzb | +/-1.0 dBg |  |  |  | Test reference is at the nominal power level (step attenuator at 0 dB)
45 MHz to 20 GHz | +/-1.0 dBg
20 GHz to 40 GHz | +/-1.0 dBg
40 GHz to 50 GHz | +/-1.0 dBg
Power Rangea, e, f
10 MHz to 45 MHzb | -25 to +2 dBm | -25 to +2 dBm | -87 to +2 dBm | -87 to +2 dBm |
45 MHz to 10 GHz | -25 to +5 dBm | -25 to +5 dBm | -87 to +3 dBm | -87 to +3 dBmh |
10 GHz to 20 GHz | -24 to +3 dBm | -25 to +2 dBm | -86 to +1 dBm | -87 to 0 dBmi |
20 GHz to 30 GHz | -23 to 0 dBm | -25 to -2 dBm | -85 to -2 dBm | -87 to -4 dBm |
30 GHz to 40 GHz | -23 to -4 dBm | -25 to -6 dBm | -85 to -6 dBm | -87 to -8 dBm |
40 GHz to 45 GHz | -25 to -5 dBm | -27 to -7 dBm | -87 to -9 dBm | -87 to -11 dBm |
45 GHz to 50 GHz | -25 to -10 dBm | -27 to -12 dBm | -87 to -15 dBm | -87 to -17 dBm |
Power Sweep Range (ALC)
10 MHz to 45 MHzb | 27 dB | 27 dB | 29 dB | 29 dB |
45 MHz to 10 GHz | 30 dB | 30 dB | 30 dB | 30 dBj | ALC range starts at maximum leveled output power and decreases by power level indicated in the table.
10 GHz to 20 GHz | 27 dB | 27 dB | 27 dB | 27 dBk
20 GHz to 30 GHz | 23 dB | 23 dB | 23 dB | 23 dB
30 GHz to 40 GHz | 19 dB | 19 dB | 19 dB | 19 dB
40 GHz to 45 GHz | 20 dB | 20 dB | 18 dB | 16 dB
45 GHz to 50 GHz | 15 dB | 15 dB | 12 dB | 10 dB
Power Resolution
 | 0.01 dB |  |  |  |
Phase Noise
1 kHz offset from center frequency, nominal power at test port
 |  |  |  |  | Typical:
10 MHz to 10 GHz |  |  |  |  | -60 dBc
10 GHz to 20 GHz |  |  |  |  | -55 dBc
20 GHz to 50 GHz |  |  |  |  | -50 dBc
1 kHz offset from center frequency, nominal power at test port - Option 080 enabled
 |  |  |  |  | Typical:
10 MHz to 10 GHz |  |  |  |  | -60 dBc
10 GHz to 20 GHz |  |  |  |  | -60 dBc
20 GHz to 50 GHz |  |  |  |  | -50 dBc
10 kHz offset from center frequency, nominal power at test port
 |  |  |  |  | Typical:
10 MHz to 45 MHz |  |  |  |  | -70 dBc
45 MHz to 10 GHz |  |  |  |  | -70 dBc
10 GHz to 20 GHz |  |  |  |  | -65 dBc
20 GHz to 40 GHz |  |  |  |  | -55 dBc
40 GHz to 50 GHz |  |  |  |  | -55 dBc
10 kHz offset from center frequency, nominal power at test port - Option 080 enabled
 |  |  |  |  | Typical:
10 MHz to 45 MHz |  |  |  |  | -70 dBc
45 MHz to 10 GHz |  |  |  |  | -70 dBc
10 GHz to 20 GHz |  |  |  |  | -65 dBc
20 GHz to 40 GHz |  |  |  |  | -55 dBc
40 GHz to 50 GHz |  |  |  |  | -55 dBc
100 kHz offset from center frequency, nominal power at test port
 |  |  |  |  | Typical:
10 MHz to 10 GHz |  |  |  |  | -60 dBc
10 GHz to 20 GHz |  |  |  |  | -55 dBc
20 GHz to 50 GHz |  |  |  |  | -50 dBc
100 kHz offset from center frequency, nominal power at test port - Option 080 enabled
 |  |  |  |  | Typical:
10 MHz to 10 GHz |  |  |  |  | -75 dBc
10 GHz to 20 GHz |  |  |  |  | -70 dBc
20 GHz to 50 GHz |  |  |  |  | -65 dBc
1 MHz offset from center frequency, nominal power at test port
 |  |  |  |  | Typical:
10 MHz to 10 GHz |  |  |  |  | -106 dBc
10 GHz to 20 GHz |  |  |  |  | -103 dBc
20 GHz to 50 GHz |  |  |  |  | -90 dBc
1 MHz offset from center frequency, nominal power at test port - Option 080 enabled
 |  |  |  |  | Typical:
10 MHz to 10 GHz |  |  |  |  | -103 dBc
10 GHz to 20 GHz |  |  |  |  | -97 dBc
20 GHz to 50 GHz |  |  |  |  | -85 dBc
Harmonics (2nd or 3rd)
 |  |  |  |  | -23 dBc typical, in power range 0
Non-Harmonic Spurious (at Nominal Output Power)
10 MHz to 45 MHz |  |  |  |  | -50 dBc typical, for offset frequency > 1 kHz
45 MHz to 20 GHz |  |  |  |  | -50 dBc typical, for offset frequency > 1 kHz
20 GHz to 40 GHz |  |  |  |  | -30 dBc typical, for offset frequency > 1 kHz
40 GHz to 50 GHz |  |  |  |  | -30 dBc typical, for offset frequency > 1 kHz

a Test port output is a specification when the source is set to Port 1, and a characteristic when the source is set to Port 2.

b Typical performance.

c Preset power.

d Power Level Linearity is a specification when the source is set to Port 1, and a typical when the source is set to Port 2.

e Test port power is specified into nominal 50 ohms.

f Power to which the source can be set and phase lock is assured.

g +/-1.5 dB for power <= -23 dBm.

h E8362B only: Option H11 decreases maximum power level by 1 dB.

i E8362B only: Option H11 decreases maximum power level by 2 dB.

j E8362B only: Option H11 decreases power level by 1 dB.

k E8362B only: Option H11 decreases power level by 2 dB.

Table 35: Test Port Input

Description | Specification |  |  |  | Supplemental
 | Standard | Opt 014 | Opt UNL | Opt 014/UNL |
Test Port Noise Floora
10 Hz IF Bandwidth
10 MHz to 45 MHzb | <-77 dBm | <-77 dBm | <-77 dBm | <-77 dBm |
45 MHz to 500 MHzc | <-89 dBm | <-89 dBm | <-89 dBm | <-89 dBm |
500 MHz to 2 GHz | <-114 dBm | <-114 dBm | <-114 dBm | <-114 dBm |
2 GHz to 10 GHz | <-117 dBm | <-117 dBm | <-117 dBm | <-117 dBm |
10 GHz to 20 GHz | <-120 dBm | <-119 dBm | <-120 dBm | <-119 dBm |
20 GHz to 40 GHz | <-114 dBm | <-113 dBm | <-114 dBm | <-113 dBm | Option 016 degrades performance by 2 dB.
40 GHz to 50 GHz | <-114 dBm | <-112 dBm | <-114 dBm | <-112 dBm
1 KHz IF Bandwidth
10 MHz to 45 MHzb | <-57 dBm | <-57 dBm | <-57 dBm | <-57 dBm |
45 MHz to 500 MHzc | <-69 dBm | <-69 dBm | <-69 dBm | <-69 dBm |
500 MHz to 2 GHz | <-94 dBm | <-94 dBm | <-94 dBm | <-94 dBm |
2 GHz to 10 GHz | <-97 dBm | <-97 dBm | <-97 dBm | <-97 dBm |
10 GHz to 20 GHz | <-100 dBm | <-99 dBm | <-100 dBm | <-99 dBm |
20 GHz to 40 GHz | <-94 dBm | <-93 dBm | <-94 dBm | <-93 dBm | Option 016 degrades performance by 2 dB.
40 GHz to 50 GHz | <-94 dBm | <-92 dBm | <-94 dBm | <-92 dBm
Test Port Noise Floora,b Option 080 enabledd
10 Hz IF Bandwidth
10 MHz to 45 MHzb | <-77 dBm | <-77 dBm | <-77 dBm | <-77 dBm |
45 MHz to 500 MHzc | <-88 dBm | <-88 dBm | <-88 dBm | <-88 dBm |
500 MHz to 2 GHz | <-113 dBm | <-113 dBm | <-113 dBm | <-113 dBm |
2 GHz to 10 GHz | <-116 dBm | <-116 dBm | <-116 dBm | <-116 dBm |
10 GHz to 20 GHz | <-118 dBm | <-118 dBm | <-118 dBm | <-118 dBm |
20 GHz to 40 GHz | <-112 dBm | <-112 dBm | <-112 dBm | <-112 dBm | Option 016 degrades performance by 2 dB.
40 GHz to 50 GHz | <-111 dBm | <-111 dBm | <-111 dBm | <-111 dBm
1 KHz IF Bandwidth
10 MHz to 45 MHzb | <-57 dBm | <-57 dBm | <-57 dBm | <-57 dBm |
45 MHz to 500 MHzc | <-68 dBm | <-68 dBm | <-68 dBm | <-68 dBm |
500 MHz to 2 GHz | <-93 dBm | <-93 dBm | <-93 dBm | <-93 dBm |
2 GHz to 10 GHz | <-96 dBm | <-96 dBm | <-96 dBm | <-96 dBm |
10 GHz to 20 GHz | <-98 dBm | <-98 dBm | <-98 dBm | <-98 dBm |
20 GHz to 40 GHz | <-92 dBm | <-92 dBm | <-92 dBm | <-92 dBm | Option 016 degrades performance by 2 dB.
40 GHz to 50 GHz | <-91 dBm | <-91 dBm | <-91 dBm | <-91 dBm
Direct Receiver Access Input Noise Floora,b
10 Hz IF Bandwidth
10 MHz to 45 MHz |  | <-127 dBm |  | <-127 dBm |
45 MHz to 500 MHzc |  | <-127 dBm |  | <-127 dBm |
500 MHz to 2 GHz |  | <-133 dBm |  | <-133 dBm |
2 GHz to 10 GHz |  | <-132 dBm |  | <-132 dBm |
10 GHz to 20 GHz |  | <-134 dBm |  | <-134 dBm |
20 GHz to 40 GHz |  | <-125 dBm |  | <-125 dBm | Option 016 degrades performance by 2 dB.
40 GHz to 50 GHz |  | <-123 dBm |  | <-123 dBm
1 KHz IF Bandwidth
10 MHz to 45 MHz |  | <-107 dBm |  | <-107 dBm |
45 MHz to 500 MHzc |  | <-107 dBm |  | <-107 dBm |
500 MHz to 2 GHz |  | <-113 dBm |  | <-113 dBm |
2 GHz to 10 GHz |  | <-112 dBm |  | <-112 dBm |
10 GHz to 20 GHz |  | <-114 dBm |  | <-114 dBm |
20 GHz to 40 GHz |  | <-105 dBm |  | <-105 dBm | Option 016 degrades performance by 2 dB.
40 GHz to 50 GHz |  | <-103 dBm |  | <-103 dBm
Direct Receiver Access Input Noise Floora,b - Option 080 enabledd
10 Hz IF Bandwidth
10 MHz to 45 MHz |  | <-127 dBm |  | <-127 dBm |
45 MHz to 500 MHzc |  | <-126 dBm |  | <-126 dBm |
500 MHz to 2 GHz |  | <-132 dBm |  | <-132 dBm |
2 GHz to 10 GHz |  | <-131 dBm |  | <-131 dBm |
10 GHz to 20 GHz |  | <-133 dBm |  | <-133 dBm |
20 GHz to 40 GHz |  | <-124 dBm |  | <-124 dBm | Option 016 degrades performance by 2 dB.
40 GHz to 50 GHz |  | <-122 dBm |  | <-122 dBm
1 KHz IF Bandwidth
10 MHz to 45 MHz |  | <-107 dBm |  | <-107 dBm |
45 MHz to 500 MHzc |  | <-106 dBm |  | <-106 dBm |
500 MHz to 2 GHz |  | <-112 dBm |  | <-112 dBm |
2 GHz to 10 GHz |  | <-111 dBm |  | <-111 dBm |
10 GHz to 20 GHz |  | <-113 dBm |  | <-113 dBm |
20 GHz to 40 GHz |  | <-104 dBm |  | <-104 dBm | Option 016 degrades performance by 2 dB.
40 GHz to 50 GHz |  | <-102 dBm |  | <-102 dBm
Receiver Compression Level
10 MHz to 20 GHz | <0.1 dB at -5 dBmg and <0.45 dB at +5 dBm |  |  |  |
20 GHz to 30 GHz | <0.1 dB at -9.5 dBmg and <0.45 dB at 0 dBm |  |  |  |
30 GHz to 40 GHz | <0.1 dB at -12.5 dBmg and <0.45 dB at -3 dBm |  |  |  |
40 GHz to 50 GHz | <0.1 dB at -12.5 dBmg and <0.45 dB at -3 dBm |  |  |  |
System Compression Level
 | maximum output power |  |  |  | See dynamic accuracy table
Third Order Intercept - Tone spacing from 100 kHz - 5 MHz
 |  |  |  |  | Typical
10 MHz to 150 MHz |  |  |  |  | +33 dBm
150 MHz to 300 MHz |  |  |  |  | +34 dBm
300 MHz to 500 MHz |  |  |  |  | +30 dBm
500 MHz to 20 GHz |  |  |  |  | +24 dBm
20 to 40 GHz |  |  |  |  | +18 dBm
40 to 50 GHz |  |  |  |  | +15 dBm
Third Order Intercept - Tone spacing from 5 MHz - 20 MHz
 |  |  |  |  | Typical
10 MHz to 500 MHz |  |  |  |  | +20 dBm
500 MHz to 20 GHz |  |  |  |  | +20 dBm
20 to 40 GHz |  |  |  |  | +16 dBm
40 to 50 GHz |  |  |  |  | +15 dBm
Third Order Intercept - Tone spacing from 20 MHz - 50 MHz
 |  |  |  |  | Typical
10 MHz to 500 MHz |  |  |  |  | +26 dBm
500 MHz to 20 GHz |  |  |  |  | +26 dBm
20 to 40 GHz |  |  |  |  | +20 dBm
40 to 50 GHz |  |  |  |  | +19 dBm
Trace Noise Magnitude 1 kHz IF bandwidth. Ratio measurement, nominal power at test port.
10 MHz to 45 MHzb | <0.050 dB rms |  |  |  |
45 MHz to 500 MHze | <0.010 dB rms |  |  |  |
500 MHz to 20 GHz | <0.006 dB rms |  |  |  |
20 GHz to 40 GHz | <0.006 dB rms |  |  |  |
40 GHz to 50 GHz | <0.006 dB rms |  |  |  |
Trace Noise Magnitude - Option 080 enabledb,d 1 kHz IF bandwidth. Ratio measurement, nominal power at test port.
10 MHz to 45 MHzb | <0.060 dB rms |  |  |  |
45 MHz to 500 MHze | <0.010 dB rms |  |  |  |
500 MHz to 20 GHz | <0.006 dB rms |  |  |  |
20 GHz to 40 GHz | <0.007 dB rms |  |  |  |
40 GHz to 50 GHz | <0.008 dB rms |  |  |  |
Trace Noise Phase 1 kHz IF bandwidth. Ratio measurement, nominal power at test port.
10 MHz to 45 MHzb | <0.350° rms |  |  |  |
45 MHz to 500 MHz | <0.100° rms |  |  |  |
500 MHz to 20 GHz | <0.060° rms |  |  |  |
20 GHz to 40 GHz | <0.100° rms |  |  |  |
40 GHz to 50 GHz | <0.100° rms |  |  |  |
Trace Noise Phase - Option 080 enabledb,d 1 kHz IF bandwidth. Ratio measurement, nominal power at test port.
10 MHz to 45 MHz | <0.350° rms |  |  |  |
45 MHz to 500 MHze | <0.100° rms |  |  |  |
500 MHz to 20 GHz | <0.060° rms |  |  |  |
20 GHz to 40 GHz | <0.100° rms |  |  |  |
40 GHz to 50 GHz | <0.100° rms |  |  |  |
Reference Level Magnitude
Range | +/-200 dB |  |  |  |
Resolution | 0.001 dB |  |  |  |
Reference Level Phase
Range | +/-500° |  |  |  |
Resolution | 0.01° |  |  |  |
Stability Magnituded
Typical ratio measurement, made at the test port.
10 MHz to 45 MHz |  |  |  |  | +/-0.05 dB/°C
45 MHz to 20 GHz |  |  |  |  | +/-0.02 dB/°C
20 GHz to 40 GHz |  |  |  |  | +/-0.03 dB/°C
40 GHz to 50 GHz |  |  |  |  | +/-0.04 dB/°C
Stability Phased
Typical ratio measurement, measured at the test port.
10 MHz to 45 MHz |  |  |  |  | +/-0.5°/°C
45 MHz to 20 GHz |  |  |  |  | +/-0.2°/°C
20 GHz to 40 GHz |  |  |  |  | +/-0.5°/°C
40 GHz to 50 GHz |  |  |  |  | +/-0.8°/°C
Damage Input Level
Test Port 1 and 2 |  |  |  |  | +30 dBm or +/-40 VDC, typical
R1, R2 in |  |  |  |  | +15 dBm or +/-15 VDC, typical
A, B in |  |  |  |  | +15 dBm or +/-15 VDC, typical
Coupler Thru (Option 014 or UNL/014) |  |  |  |  | +30 dBm or +/-40 VDC, typical
Coupler Arm (Option 014 or UNL/014) |  |  |  |  | +30 dBm or +/-7 VDC, typical

aTotal average (rms) noise power calculated as the mean value of a linear magnitude trace expressed in dBm.

bTypical performance.

cNoise floor may be degraded by 10 dB at particular frequencies (multiples of 5 MHz) due to spurious receiver residuals.

d0 Hz offset

eTrace noise magnitude may be degraded to 20 mdB rms at harmonic frequencies of the first IF (8.33 MHz) below 80 MHz.

fStability is defined as a ratio measurement made at the test port.

g This compression level comes from the dynamic accuracy curve with -30 dBm reference test port power.

Table 36. Dynamic Accuracy (Specificationa)

Accuracy of the test port input power reading relative to the reference input power level.

*Below 800 MHz the coupling factor rolls off 20 dB per decade causing a shift in the dynamic accuracy curves. Please see the Uncertainty Calculator (http://www.agilent.com/find/na_calculator) for detailed compression values.

a Dynamic accuracy is verified with the following measurements:

  • Compression over frequency.

  • IF linearity at a single frequency of 1.195 GHz and a reference level of -20 dBm for an input power range of 0 to -120 dBm.

Table 37. Test Port Input (Group Delay)a

Description

Specification

Supplemental Information (typ.)

Aperture (selectable)

(frequency span)/(number of points -1)

Maximum Aperture

20% of frequency span

Range

0.5 x (1/minimum aperture)

Maximum Delay

Limited to measuring no more than 180° of phase change within the minimum aperture.)

Accuracy

See graph below. Char.

The following graph shows characteristic group delay accuracy with full 2-port calibration and a 10 Hz IF bandwidth. Insertion loss is assumed to be < 2 dB and electrical length to be ten meters.

In general, the following formula can be used to determine the accuracy, in seconds, of specific group delay measurement:

±Phase Accuracy (deg)/[360 × Aperture (Hz)]

Depending on the aperture and device length, the phase accuracy used is either incremental phase accuracy or worst case phase accuracy.

a Group delay is computed by measuring the phase change within a specified frequency step (determined by the frequency span and the number of points per sweep).

General Information

  • Miscellaneous Information

  • Front Panel

  • Rear Panel

  • Environment and Dimensions

Table 38. Miscellaneous Information

Description | Specification | Supplemental Information
System IF Bandwidth Range |  | 1 Hz to 40 kHz, nominal
CPU |  | Intel® 500 MHz Pentium® III

Table 39. Front Panel Information

Description | Supplemental Information
RF Connectors
E8362B
Type | 3.5 mm (male), 50 ohm, (nominal)
Center Pin Recession | 0.002 in. (characteristic)
E8363/4B
Type | 2.4 mm (male), 50 ohm, (nominal)
Center Pin Recession | 0.002 in. (characteristic)
Display
Size | 21.3 cm (8.4 in) diagonal color active matrix LCD; 640 (horizontal) X 480 (vertical) resolution; 59.83 Hz vertical refresh rate; 31.41 Hz horizontal refresh rate
Refresh Rate | Vertical 59.83 Hz; Horizontal 31.41 kHz
Display Range
Magnitude | ±200 dB (at 20 dB/div), max
Phase | ±500°, max
Polar | 10 pUnits, min 1000 Units, max
Display Resolution
Magnitude | 0.001 dB/div, min
Phase | 0.01°/div, min
Marker Resolution
Magnitude | 0.001 dB, min
Phase | 0.01°, min
Polar | 0.01 mUnit, min; 0.01°,min

Table 40. Rear Panel Information

Description | Supplemental Information
10 MHz Reference In
Connector | BNC, female
Input Frequency | 10 MHz ± 10 ppm, typical
Input Level | -15 dBm to +20 dBm, typical
Input Impedance | 200 W, nom.
10 MHz Reference Out
Connector | BNC, female
Output Frequency | 10 MHz ± 1 ppm, typical
Signal Type | Sine Wave, typical
Output Level | +10 dBm ± 4 dB into 50 W, typical
Output Impedance | 50 W, nominal
Harmonics | <-40 dBc, typical
Option H08 & H11 Rear Panel Connectors (typical)
IF Connectors | A, R1, R2, B (BNC Connectors)
IF Connector Input Frequency | 8 1/3 MHz
Nominal Input Impedance at IF Inputs | 50 W
RF Damage Level to IF Connector Inputs | -20.0 dBm
DC Damage Level to IF Connector Inputs | 25 volts
0.1 dB Compression Point at IF Inputs | -27.0 dBm
Pulse Input Connectors1 | A, R1, R2, B (BNC Connectors)
Nominal Input Impedance at Pulse Inputs | 1 Kohm
Minimum IF Gate Width | 20 ns for less than 1 dB deviation from theoretical performance2
DC Damage Level to Pulse Connector Inputs | 5.5 volts
Drive Voltage | TTL (0, +5.0) Volts
Rear Panel LO Power (Typical)
1.7 GHz- 20 GHz | -7 to -16 dBm
Rear Panel RF Power 8362B (Typical)
1.7 GHz to 20 GHz | -5 to 16 dBm (at 5 dBm test port power3)
Rear Panel RF Power 8363B/8364B (Typical)
1.7 GHz to 10 GHz | -2 to 12 dBm (at 5 dBm test port power3)
10 GHz to 16 GHz | 0 to 8 dBm (at 5 dBm test port power3)
16 GHz to 20 GHz | +5 to 1 dBm (at 5 dBm test port power3)
VGA Video Output
Connector | 15-pin mini D-Sub; Drives VGA compatible monitors
Devices Supported: |
 | Resolutions:
Flat Panel (TFT) | 1024 X 768, 800 X 600, 640 X 480
Flat Panel (DSTN) | 800 X 600, 640 X 480
CRT Monitor | 1280 X 1024, 1024 X 768, 800 X 600, 640 X 480
 | Simultaneous operation of the internal and external displays is allowed, but with 640 X 480 resolution only. If you change resolution, you can only view the external display (internal display will "white out").
Bias Input Connectors (Option UNL)
Bias current | 500 mA, maximum
Bias voltage | 40 Volts, maximum
Test Set IO
 | 25-pin D-Sub connector, available for external test set control.
Aux IO
 | 25-pin D-Sub connector, male, analog and digital IO.
Handler IO
 | 36-pin parallel I/O port; all input/output signals are default set to negative logic; can be reset to positive logic via GPIB command.
GPIB
 | 24-pin D-sub (Type D-24), female; compatible with IEEE-488.
Parallel Port (LPT1)
 | 25-pin D-Sub miniature connector, female; provides connection to printers or any other parallel port peripherals
Serial Port (COM 1) |
 | 9-pin D-Sub, male; compatible with RS-232
USB Port
 | One port on front panel and five ports on rear panel. Universal Serial Bus jack, Type A configuration (4 contacts inline, contact 1 on left); female
Contact 1 | Vcc: 4.75 to 5.25 VDC, 500 mA, maximum
Contact 2 | -Data
Contact 3 | +Data
Contact 4 | Ground
LAN
 | 10/100BaseT Ethernet, 8-pin configuration; auto selects between the two data rates
Line Power (A third-wire ground is required.)
Frequency | 50/60/400 Hz
Voltages | 120/240 VAC (Power supply is auto switching.)
Max | 500 Watts

1 Pulse input connectors are operational only with Option H08 (Pulse Measurement Capability) enabled.

2 Based on deviation from signal reduction equation: Signal Reduction (dB) = 20log10(Duty_cycle) = 20log10(pulse_width/period). Measured at Pulse Repetition Frequency (PFR) of 1 MHz.

3 Test port power has to be at a high enough level such that the Drop Cal does not occur. If Drop Cal occurs then the power out of the rear panel RF connector will drop by about 15 dB.

Table 41. Analyzer Environment and Dimensions

Description | Supplemental Information
General Environmental
RFI/EMI Susceptibility | Defined by CISPR Pub. 11, Group 1, Class A, and IEC 50082-1
ESD | Minimize using static-safe work procedures and an antistatic bench mat
Dust | Minimize for optimum reliability
Operating Environment
Temperature | 0 °C to +40 °C Instrument powers up, phase locks, and displays no error messages within this temperature range (except for "source unleveled" error message that may occur at temperature extremes).
Error-Corrected Temperature Range | 23°C ± 3°C with less than 1°C deviation from calibration temp.
Humidity | 5% to 95% at +40 °C
Altitude | 0 to 4500 m (14,760 ft.)
Non-Operating Storage Environment
Temperature | -40 °C to +70 °C
Humidity | 0% to 90% at +65 °C (non-condensing)
Altitude | 0 to 15,240 m (50,000 ft.)
Cabinet Dimensions
 | Height | Width | Depth
Excluding front and rear panel hardware and feet | 267 mm 10.5 in | 426 mm 16.75 in | 427 mm 16.8 in
As shipped - includes front panel connectors, rear panel bumpers, and feet. | 280 mm 11.0 in | 435 mm 17.1 in | 470 mm 18.5 in
As shipped plus handles | 280 mm 11.0 in | 458 mm 18 in | 501 mm 19.70 in
As shipped plus rack-mount flanges | 280 mm 11.0 in | 483 mm 19 in | 470 mm 18.5 in
As shipped plus handles and flanges | 280 mm 11.0 in | 483 mm 19 in | 501 mm 19.70 in
Weight
Net
E8362B | 28.6 kg (63.5 lb), nominal
E8363/4B | 29 kg (64 lb), nominal
Shipping
E8362B | 35.8 kg (79.5 lb), nominal
E8363/4B | 36.3 kg 80 lb), nominal

Measurement Throughput Summary

  • Typical Cycle Time for Measurement Completion

  • Cycle Time vs IF Bandwidth

  • Cycle Time vs Number of Points

  • Data Transfer Time

Table 42 Typical Cycle Timea,b (ms) for Measurement Completion

 | Number of Points
 | 201 | 401 | 1601 | 16,001
Start 28 GHz, Stop 30 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 12 | 19 | 55 | 503
2-Port cal | 29 | 44 | 124 | 1112
Start 10 MHz, Stop 10 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 86 | 93 | 121 | 583
2-Port cal | 179 | 199 | 267 | 1301
Start 10 MHz, Stop 20 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 126 | 130 | 153 | 597
2-Port cal | 264 | 275 | 335 | 1321
Start 10 MHz, Stop 40 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 185 | 190 | 213 | 621
2-Port cal | 382 | 401 | 459 | 1374
Start 10 MHz, Stop 50 GHz, 35 kHz IF bandwidth
Uncorrected, 1-port cal | 210 | 216 | 243 | 643
2-Port cal | 436 | 450 | 522 | 1405
Start 10 MHz, Stop 67 GHz, 35 kHz IF bandwidth
Uncorrected 1-Port cal | 244 | 254 | 300 | 645
2-Port cal | 502 | 524 | 591 | 1423

a Typical performance.
b Includes sweep time, retrace time and band-crossing time. Analyzer display turned off with
DISPLAY:ENABLE OFF. Add 21 ms for display on. Data for one trace (S11) measurement.

Table 43. Cycle Time vs IF Bandwidtha

Applies to the Preset condition (201 points, correction off) except for the following changes:

  • CF = 28 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
IF Bandwidth (Hz) | Cycle Time (ms)b | Cycle Time (ms) Option 080 enabled
40,000 | 11 | 100
35,000 | 12 | 101
30,000 | 13 | 102
20,000 | 16 | 106
10,000 | 30 | 127
7000 | 38 | 138
5000 | 50 | 152
3000 | 74 | 182
1000 | 274 | 326
300 | 694 | 782
100 | 1905 | 2054
30 | 6091 | 6355
10 | 17916 | 18372

a Typical performance.
b Cycle time includes sweep and retrace time.

Table 44. Cycle Time vs Number of Pointsa

Applies to the Preset condition (35 kHz IF bandwidth, correction off) except for the following changes:

  • CF = 28 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
Number of Points | Cycle Time (ms)b
3 | 6
11 | 6
51 | 7
101 | 9
201 | 12
401 | 18
801 | 30
1601 | 55
16,001 | 497

a Typical performance.
b Cycle time includes sweep and retrace time.

Table 45. Data Transfer Time (ms)a

 | Number of Points
 | 201 | 401 | 1601 | 16,001
SCPI over GPIB (program executed on external PC)
32-bit floating point | 7 | 12 | 43 | 435
64-bit floating point | 12 | 22 | 84 | 856
ASCII | 64 | 124 | 489 | 5054
SCPI (program executed in the analyzer)
32-bit floating point | 1 | 2 | 3 | 30
64-bit floating point | 2 | 2 | 4 | 40
ASCII | 29 | 56 | 222 | 2220
COM (program executed in the analyzer)
32-bit floating point | 1 | 1 | 1 | 6
Variant type | 1 | 2 | 6 | 68
DCOM over LAN (program executed on external PC)
32-bit floating point | 1 | 1 | 2 | 121
Variant type | 3 | 6 | 19 | 939

a Typical performance

Note: Specifications for Recall & Sweep Speed are not provided for the E836xB analyzers.

Test Set Block Diagrams

E836xB - Standard Configuration and Standard Power Range

E836xB - Option UNL Standard Configuration with Extended Power Range and Bias - Tees

E836xB - Option UNL Standard Configuration with Extended Power Range and Bias - Tees, and Option 016, Receiver Attenuators

Test Set with Option 014 Block Diagrams

E836xB - Option 014 – Configurable Test Set and Standard Power Range

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

E836xB - Option 014 – Configurable Test Set and Standard Power Range, and Option 081 Reference Channel Transfer Switch

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

E836xB - Option 014 Configurable Test Set, and Option UNL Extended Power Range and Bias - Tees

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

E836xB - Option 014 Configurable Test Set, and Option UNL Extended Power Range and Bias - Tees, and Option 081 Reference Channel Transfer Switch

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

E836xB - Option 014 Configurable Test Set and Option UNL, Extended Power Range and Bias - Tees and Option 016 Receiver Attenuators

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

E836xB - Option 014 Configurable Test Set, and Option UNL Extended Power Range and Bias - Tees, and Option 016 Receiver Attenuators, and Option 081 Reference Channel Transfer Switch

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT


Specs: N5230A Analyzer

Technical Specifications for the N5230A

Options 020/025, 120/125, 220/225, 420/425, or 520/525 (2-Port PNA)
(Rev. 2005-07-26)

This is a complete list of the N5230A Options 020, 025, 120, 125, 220, 225, 420, 425, 520, 525 network analyzer technical specifications.

  • To optimize viewing of uncertainty curves, click the Maximize button.

  • To view or print the .pdf version of the specifications, visit our web site at http://www.agilent.com/find/pna, and search for "N5230A Specifications"

  • This N5230A document provides technical specifications for the 85056A 2.4 mm, 85052B 3.5 mm, and 85032B Type-N calibration kits and the N4691A, and N4693A ECal modules. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your calibration kit and PNA setup.

  • Definitions

  • Corrected System Performance

    • System Dynamic Range

    • Extended Dynamic Range

    • 3.5mm Connectors

    • 2.4mm Connectors

    • Type-N Connectors

  • Uncorrected System Performance

  • Test Port Output

  • Test Port Input

  • Dynamic Accuracy

  • Group Delay

  • General Information

  • Measurement Throughput Summary

  • Front-panel Jumper Specs (Options 025, 125, 225, 425, 525)

  • Option 020, or 120, or 220, or 420, or 520 (Standard Test Set and Standard Power Range) Analyzer Block Diagram

  • Option 025, or 125, or 225, or 425, or 525 (Configurable Test Set and Extended Power Range) Analyzer Block Diagram

See Specs for other PNA models

Definitions

All specifications and characteristics apply over a 25 °C ±5 °C range (unless otherwise stated) and 90 minutes after the instrument has been turned on.

Specification (spec.): Warranted performance. Specifications include guardbands to account for the expected statistical performance distribution, measurement uncertainties, and changes in performance due to environmental conditions.

Characteristic (char.): A performance parameter that the product is expected to meet before it leaves the factory, but that is not verified in the field and is not covered by the product warranty. A characteristic includes the same guardbands as a specification.

Typical (typ.): Expected performance of an average unit which does not include guardbands. It is not covered by the product warranty.

Nominal (nom.): A general, descriptive term that does not imply a level of performance. It is not covered by the product warranty.

Calibration: The process of measuring known standards to characterize a network analyzer's systematic (repeatable) errors.

Corrected (residual): Indicates performance after error correction (calibration). It is determined by the quality of calibration standards and how well "known" they are, plus system repeatability, stability, and noise.

Uncorrected (raw): Indicates instrument performance without error correction. The uncorrected performance affects the stability of a calibration.

Standard: When referring to the analyzer, this includes no options unless noted otherwise.

Corrected System Performance

The specifications in this section apply for measurements made with the N5230A analyzer with the following conditions:

  • 10 Hz IF bandwidth

  • No averaging applied to data

  • Isolation calibration with an averaging factor of 8

  • System Dynamic Range

  • Extended Dynamic Range

  • 3.5mm Connectors

  • 2.4mm Connectors

  • Type-N Connectors

Table 1. System Dynamic Range1

Description | Specification (dB) at Test Port |  |  |  | Typical (dB) at Test Port
 | Options 020, 120 | Option 220 | Option 420 | Option 520 | Options 020, 120 | Option 220 | Option 420 | Option 520
Standard Configuration and Standard Power Range
300 kHz to 1 MHz | 103 | -- | -- | -- | -- | -- | -- | --
1 MHz to 10 MHz | 113 | -- | -- | -- | -- | -- | -- | --
10 MHz to 45 MHz | 122 | -- | -- | -- | -- | 103 | 89 | 89
45 MHz to 70 MHz2 | 122 | 101 | 90 | 90 | -- | -- | -- | --
70 MHz to 500 MHz2 | 122 | 105 | 90 | 90 | -- | -- | -- | --
500 MHz to 2 GHz | 122 | 110 | 110 | 110 | -- | -- | -- | --
2 GHz to 6 GHz | 122 | 110 | 110 | 110 | -- | -- | -- | --
6 GHz to 8 GHz | 120 | 110 | 110 | 110 | -- | -- | -- | --
8 GHz to 9 GHz | 120 | 110 | 100 | 100 | -- | -- | -- | --
9 GHz to 10.5 GHz | 116 | 110 | 100 | 100 | -- | -- | -- | --
10.5 GHz to 12.5 GHz | 111 | 110 | 100 | 100 | -- | -- | -- | --
12.5 GHz to 13.5 GHz | 109 | 108 | 100 | 100 | -- | -- | -- | --
13.5 GHz to 20 GHz | -- | 108 | 100 | 100 | -- | -- | -- | --
20 GHz to 31.25 GHz | -- | -- | 95 | 95 | -- | -- | -- | --
31.25 GHz to 40 GHz | -- | -- | 90 | 90 | -- | -- | -- | --
40 GHz to 50 GHz | -- | -- | -- | 79 | -- | -- | -- | --
Table 1. System Dynamic Range1 (Continued)
Description | Specification (dB) at Test Port |  |  |  | Typical (dB) at Test Port
 | Options 025, 125 | Option 225 | Option 425 | Option 525 | Options 025, 125 | Option 225 | Option 425 | Option 525
Configurable Test Set and Extended Power Range
300 KHz to 1 MHz | 102 | -- | -- | -- | -- | -- | -- | --
1 MHz to 10 MHz | 112 | -- | -- | -- | -- | -- | -- | --
10 MHz to 45 MHz | 121 | -- | -- | -- | -- | 103 | 88 | 88
45 MHz to 70 MHz2 | 121 | 101 | 90 | 90 | -- | -- | -- | --
70 MHz to 500 MHz2 | 121 | 105 | 90 | 90 | -- | -- | -- | --
500 MHz to 2 GHz | 121 | 110 | 110 | 110 | -- | -- | -- | --
2 GHz to 6 GHz | 121 | 110 | 110 | 110 | -- | -- | -- | --
6 GHz to 8 GHz | 120 | 110 | 110 | 110 | -- | -- | -- | --
8 GHz to 9 GHz | 120 | 110 | 100 | 100 | -- | -- | -- | --
9 GHz to 10.5 GHz | 116 | 110 | 100 | 100 | -- |  |  |
10.5 GHz to 12.5 GHz | 111 | 110 | 100 | 100 | -- | -- | -- | --
12.5 GHz to 13.5 GHz | 108 | 108 | 100 | 100 | -- | -- | -- | --
13.5 GHz to 20 GHz | -- | 108 | 100 | 100 | -- | -- | -- | --
20 GHz to 31.25 GHz | -- | -- | 92 | 92 | -- | -- | -- | --
31.25 GHz to 40 GHz | -- | -- | 87 | 87 | -- | -- | -- | --
40 GHz to 50 GHz | -- | -- | -- | 75 | -- | -- | -- | --

1 The system dynamic range is calculated as the difference between the noise floor and the specified source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account.
2 May be degraded by 10 dB at particular frequencies (multiples of 5 MHz) below 500 MHz due to spurious receiver residuals. Methods are available to regain the full dynamic range.

Receiver Dynamic Range technical specifications are not provided in this N5230A specs document.

Table 2. Extended Dynamic Range1

Description | Specification (dB) at Direct Receiver Access Input |  |  |  | Typical (dB) at Direct Receiver Access Input
 | Option 025, 125 | Option 225 | Option 425 | Option 525 | Option 025, 125 | Option 225 | Option 425 | Option 525
Configurable Test Set and Extended Power Range
300 kHz to 1 MHz | 118 | -- | -- | -- | -- | -- | -- | --
1 MHz to 10 MHz | 128 | -- | -- | -- | -- | -- | -- | --
10 MHz to 45 MHz | 137 | -- | -- | -- | -- | 115 | 109 | 109
45 MHz to 70 MHz2 | 137 | 113 | 111 | 111 | -- | -- | -- | --
70 MHz to 500 MHz2 | 137 | 117 | 111 | 111 | -- | -- | -- | --
500 MHz to 2 GHz | 137 | 122 | 122 | 122 | -- | -- | -- | --
2 GHz to 6 GHz | 137 |  |  |  |  |  |  |
6 GHz to 8 GHz | 136 | 122 | 122 | 122 | -- | -- | -- | --
8 GHz to 9 GHz | 136 |  |  |  |  |  |  |
9 GHz to 10.5 GHz | 132 | 122 | 112 | 112 | -- | -- | -- | --
10.5 GHz to 12.5 GHz | 127 | 122 | 112 | 112 | -- | -- | -- | --
12.5 GHz to 13.5 GHz | 124 | 120 | 112 | 112 | -- | -- | -- | --
13.5 GHz to 20 GHz | -- | 120 | 112 | 112 | -- | -- | -- | --
20 GHz to 31.25 GHz | -- | -- | 103 | 103 | -- | -- | -- | --
31.25 GHz to 40 GHz | -- | -- | 98 | 98 | -- | -- | -- | --
40 GHz to 50 GHz | -- | -- | -- | 83 | -- | -- | -- | --

1 The direct receiver access input extended dynamic range is calculated as the difference between the direct receiver access input noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account. This set-up should only be used when the receiver input will never exceed its compression or damage level. When the analyzer is in segment sweep mode, it can have predefined frequency segments which will output a higher power level when the extended dynamic range is required (i.e. devices with high insertion loss), and reduced power when receiver compression or damage may occur (i.e. devices with low insertion loss). The extended range is only available in one-path transmission measurements.
2 May be degraded by 10 dB at particular frequencies (multiples of 5 MHz) below 500 MHz due to spurious receiver residuals. Methods are available to regain the full dynamic range.

Corrected System Performance with 3.5mm Connectors (Tables 3 - 8)

Corrected System Performance with 2.4mm Connectors (Tables 9 - 12)

Corrected System Performance with Type-N Connectors (Tables 13 - 14)

Table 15. Uncorrected System Performance

Description | Specifications |  |  |  | Typical
 | Options 020, 025, 120, 125 | Options 220, 225 | Options 420, 425 | Options 520, 525 | Options 020, 025, 120, 125 | Options 220, 225 | Options 420, 425 | Options 520, 525
Directivity
300 kHz to 10 MHz | 16 dB | -- | -- | -- | -- | 23 dB | -- |
10 MHz to 45 MHz | 28 dB | -- | -- | -- | -- |  | 20 dB | 20 dB
45 MHz to 500 MHz | 28 dB | 24 dB | 23 dB | 23 dB | -- | -- | -- | --
500 MHz to 1 GHz | 28 dB | 27 dB | 23 dB | 23 dB | -- | -- | -- | --
1 GHz to 2 GHz | 25 dB | 27 dB | 23 dB | 23 dB | -- | -- | -- | --
2 GHz to 3 GHz | 25 dB | 21 dB | 21 dB | 21 dB | -- | -- | -- | --
3 GHz to 5 GHz | 20 dB | 21 dB | 21 dB | 21 dB | -- | -- | -- | --
5 GHz to 8 GHz | 17 dB | 21 dB | 21 dB | 21 dB | -- | -- | -- | --
8 GHz to 11.5 GHz | 17 dB | 16 dB | 16 dB | 16 dB | -- | -- | -- | --
11.5 GHz to 13.5 GHz | 15 dB | 16 dB | 16 dB | 16 dB | -- | -- | -- | --
13.5 GHz to 20 GHz | -- | 16 dB | 16 dB | 16 dB | -- | -- | -- | --
20 GHz to 40 GHz | -- | -- | 15 dB | 15 dB | -- | -- | -- | --
45 GHz to 50 GHz | -- | -- | -- | 13 dB | -- | -- | -- | --
Source Match
300 kHz to 10 MHz | 18 dB | -- | -- | -- | -- | -- | -- | --
10 MHz to 45 MHz | 25 dB | -- | -- | -- | - | 12 dB | 11 dB | 11 dB
45 MHz to 500 MHz | 25 dB | 20 dB | 17 dB | 17 dB | -- | -- | -- | --
500 MHz to 2 GHz | 21 dB | 17 dB | 17 dB | 17 dB | -- | -- | -- | --
2 GHz to 3 GHz | 19 dB | 12 dB | 12 dB | 12 dB | -- | -- | -- |
3 GHz to 8 GHz | 12 dB | 12 dB | 12 dB | 12 dB | -- | -- | -- | --
8 GHz to 9 GHz | 12 dB | 11 dB | 11 dB | 11 dB | -- | -- | -- |
9 GHz to 12.5 GHz | 10 dB | 11 dB | 11 dB | 11 dB | -- | -- | -- | --
12.5 GHz to 13.5 GHz | 8 dB | 10 dB | 11 dB | 11 dB | -- | -- | -- | --
13.5 GHz to 20 GHz | -- | 10 dB | 11 dB | 11 dB | -- | -- | -- | --
20 GHz to 40 GHz | -- | -- | 7 dB | 7 dB | -- | -- | -- | --
40 GHz to 50 GHz | -- | -- | -- | 6 dB | -- | -- | -- | --
Table 15. Uncorrected System Performance (Continued)
Description | Specifications |  |  |  | Typical
 | Options 020, 025, 120, 125 | Options 220, 225 | Options 420, 425 | Options 520, 525 | Options 020, 025, 120, 125 | Options 220, 225 | Options 420, 425 | Options 520, 525
Load Match
300 kHz to 10 MHz | 17 dB | -- | -- | -- | -- | -- | -- | --
10 MHz to 45 MHz | 22 dB | -- | -- | -- | -- | 15 dB | 13 dB | 13 dB
45 MHz to 500 MHz | 22 dB | 22 dB | 18 dB | 18 dB | -- | -- | -- | --
500 MHz to 2 GHz | 17 dB | 20 dB | 18 dB | 18 dB | -- | -- | -- | --
2 GHz to 3 GHz | 14 dB | 12 dB | 14 dB | 14 dB | -- | -- | -- | --
3 GHz to 8 GHz | 10 dB | 12 dB | 14 dB | 14 dB | -- | -- | -- | --
8 GHz to 9 GHz | 9 dB | 10 dB | 12 dB | 12 dB | -- | -- | -- | --
9 GHz to 12.5 GHz | 9 dB | 10 dB | 12 dB | 12 dB | -- | -- | -- | --
12.5 GHz to 13.5 GHz | 7 dB | 9 dB | 9 dB | 9.5 dB | -- | -- | -- | --
13.5 GHz to 20 GHz | -- | 9 dB | 9 dB | 9.5 dB | -- | -- | -- | --
20 GHz to 40 GHz | -- | -- | 8 dB | 8.5 dB | -- | -- | -- | --
40 GHz to 50 GHz | -- | -- | -- | 5 dB | -- | -- | -- | --
Table 15. Uncorrected System Performance (Continued)
Description | Specifications |  |  |  | Typical
 | Options 020, 025, 120, 125 | Options 220, 225 | Options 420, 425 | Options 520, 525 | Options 020, 025, 120, 125 | Options 220, 225 | Options 420, 425 | Options 520, 525
Crosstalk1
300 kHz to 10 MHz | -- | -- | -- | -- | 80 dB | -- | -- | --
10 MHz to 45 MHz | -- | -- | -- | -- | 115 dB | 88 dB | 88 dB | 88 dB
45 MHz to 500 MHz | -- | -- | -- | -- | 122 dB | 95 dB | 94 dB | 94 dB
500 MHz to 2 GHz | -- | -- | -- | -- | 122 dB | 96 dB | 95 dB | 95 dB
2 GHz to 8 GHz | -- | -- | -- | -- | 122 dB | 110 dB | 108 dB | 108 dB
8 GHz to 10.5 GHz | -- | -- | -- | -- | 120 dB | 116 dB | 113 dB | 113 dB
10.5 GHz to 12.5 GHz | -- | -- | -- | -- | 115 dB | 116 dB | 113 dB | 113 dB
12.5 GHz to 13.5 GHz | -- | -- | -- | -- | 109 dB | 115 dB | 112 dB | 112 dB
13.5 GHz to 20 GHz | -- | -- | -- | -- | -- | 115 dB | 112 dB | 112 dB
20 GHz to 40 GHz | -- | -- | -- | -- | -- | -- | 97 dB | 97 dB
40 GHz to 50 GHz | -- | -- | -- | -- | -- | -- | -- | 89 dB

1 Measurement conditions: normalized to a thru, measured with two shorts, 10 Hz IF bandwidth, averaging factor of 8, alternate mode, source power set to the specified maximum power output or the minimum receiver input power specified by the 0.1 dB compression power.

Table 16. Test Port Output1

Description | Specifications |  |  |  |  | Typicals
 | Options 020, 025 | Options 120, 125 | Options 220, 225 | Options 420, 425 | Options 520, 525 | Options 020, 025, 120, 125 | Options 220, 225 | Options 420, 425 | Options 520, 525
Frequency Range
N5230A | 300kHz to 6 GHz | 300kHz to 13.5 GHz | 10 MHz to 20 GHz | 10 MHz to 40 GHz | 10 MHz to 50 GHz | --
Nominal Power
Preset power; attenuator switch point 10 dB below nominal power
 | 0 dBm | 0 dBm | -5 dBm | -10 dBm | -15 dBm | --
Frequency Resolution
 | 1 Hz |  |  |  |  | --
CW Accuracy
 | +/-1 ppm |  |  |  |  | --
Frequency Stability
 | -- |  |  |  |  | +/-0.05 ppm. -10° to 70° C +/-0.1 ppm/yr maximum
Table 16. Test Port Output1 (Continued)
Description | Specifications |  |  |  |  |  | Typical
 | Options 020, 025, 120, 125 |  | Options 220, 225 | Options 420, 425 | Option 520 | Option 525 | Options 020, 025, 120, 125 | Option 220, 225 | Option 420, 425, 520, 525
Power Level Accuracy
Variation from nominal power in range 0
300 kHz to 10 MHz | +/-1.0 dB |  | -- | -- | -- | -- | -- | -- | --
10 MHz to 45 MHz | +/-1.0 dB |  | -- | -- | -- | -- | -- | +/-0.5 dB | +/-0.5 dB
45 MHz to 6 GHz | +/-1.0 dB |  | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB | -- | -- | --
6 GHz to 8 GHz | +/-1.5 dB |  | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB | -- | -- | --
8 GHz to 9 GHz | +/-1.5 dB |  | +/-1.0 dB | +/-1.5 dB | +/-1.5 dB | +/-1.5 dB | -- | -- | --
9 GHz to 10.5 GHz | +/-1.5 dB |  | +/-1.0 dB | +/-1.5 dB | +/-1.5 dB | +/-1.5 dB | -- | -- | --
10.5 GHz to 13.5 GHz | +/-2.0 dB |  | +/-1.0 dB | +/-1.5 dB | +/-1.5 dB | +/-1.5 dB | -- | -- | --
13.5 to 20 GHz | -- |  | +/-1.0 dB | +/-1.5 dB | +/-1.5 dB | +/-1.5 dB | -- | -- | --
20 GHz to 40 GHz | -- |  | -- | +/-2.5 dB | +/-2.5 dB | +/-2.5 dB | -- | -- | --
40 GHz to 50 GHz | -- |  | -- | -- | +/-3.5 dB | +/-3.5 dB | -- | -- | --
Table 16. Test Port Output1 (Continued)
 | Specifications |  |  |  |  |  |  |  | Typical
 | Options 020, 120 | Options 025, 125 | Options 220, 225 | Option 420 | Option 425 | Option 520 |  | Option 525 | Options as Indicated
Max Leveled Power
300 kHz to 10 MHz | 10 dBm | 9 dBm | -- | -- | -- | -- |  | -- | --
10 MHz to 45 MHz | 10 dBm | 9 dBm | -- | -- | -- | -- |  | -- | --
45 MHz to 6 GHz | 10 dBm | 9 dBm | 5 dBm | 0 dBm | 0 dBm | 0 dBm |  | 0 dBm | --
6 GHz to 9 GHz | 8 dBm | 8 dBm | 5 dBm | 0 dBm | 0 dBm | 0 dBm |  | 0 dBm | --
9 GHz to 12.5 GHz | 4 dBm | 4 dBm | 5 dBm | 0 dBm | 0 dBm | 0 dBm |  | 0 dBm | --
12.5 GHz to 13.5 GHz | 2 dBm | 1 dBm | 3 dBm | 0 dBm | 0 dBm | 0 dBm |  | 0 dBm | --
13.5 GHz to 20 GHz | -- | -- | 3 dBm | 0 dBm | 0 dBm | 0 dBm |  | 0 dBm | --
20 GHz to 40 GHz | -- | -- | -- | -5 dBm | -8 dBm | -5 dBm |  | -8 dBm | --
40 GHz to 50 GHz | -- | -- | -- | -- | -- | -11 dBm |  | -15 dBm | --
Power Level Linearity2
Test reference is at the nominal power level
300 kHz to 1 MHz | +/-4.5 dB | +/-4.5 dB | -- | -- | -- | -- |  | -- | +/-2.0 dB (Opt 020, 025, 120, 125)
1 MHz to 10 MHz | +/-1.0 dB | +/-1.0 dB | -- | -- | -- | -- |  | -- | --
10 MHz to 45 MHz | +/-2.0 dB | +/-2.0 dB | -- | -- | -- | -- |  | -- | +/-0.35 dB (Opt 220 & 225) +/-0.40 dB (Opt 420, 425, 520, 525)
45 MHz to 1 GHz | +/-2.0 dB | +/-2.0 dB | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB |  | +/-1.0 dB | --
1 GHz to 12.5 GHz | +/-1.5 dB | +/-1.5 dB | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB |  | +/-1.0 dB | --
12.5 GHz to 13.5 GHz | +/-1.5 dB | +/-1.5 dB | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB |  | +/-1.0 dB | --
13.5 GHz to 20 GHz | -- | -- | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB |  | +/-1.0 dB | --
20 GHz to 40 GHz | -- | -- | -- | +/-1.0 dB | +/-1.0 dB | +/-1.0 dB |  | +/-1.0 dB | --
40 GHz to 50 GHz | -- | -- | -- | -- | -- | +/-1.0 dB |  | +/-1.0 dB | --
Power Sweep Range (ALC)3
300 kHz to 10 MHz | 37 dB | 36 dB | -- | -- | -- | -- |  | -- | --
10 MHz to 45 MHz | 37 dB | 36 dB | -- | -- | -- | -- |  | -- | --
45 MHz to 6 GHz | 37 dB | 36 dB | 25 dB | 25 dB | 25 dB | 25 dB |  | 25 dB | --
6 GHz to 9 GHz | 35 dB | 35 dB | 25 dB | 25 dB | 25 dB | 25 dB |  | 25 dB | --
9 GHz to 12.5 GHz | 31 dB | 31 dB | 25 dB | 25 dB | 25 dB | 25 dB |  | 25 dB | --
12.5 GHz to 13.5 GHz | 29 dB | 28 dB | 23 dB | 25 dB | 25 dB | 25 dB |  | 25 dB | --
13.5 GHz to 20 GHz | -- | -- | 23 dB | 25 dB | 25 dB | 25 dB |  | 25 dB | --
20 GHz to 40 GHz | -- | -- | -- | 20 dB | 17 dB | 20 dB |  | 17 dB | --
40 GHz to 50 GHz | -- | -- | -- | -- | -- | 14 dB |  | 10 dB | --
Power Resolution
 |  |  |  |  |  |  |  |  | 0.01 dB
Table 16. Test Port Output1 (Continued)
Description | Specifications |  | Typical
 |  |  | Option 020, 120 |  | Option 025, 125 | Option 220 | Option 225 | Option 420, 520 | Option 425, 525
Power Range
300 kHz to 10 MHz | -- |  | -30 to +10 dBm |  | -90 to +9 dBm | -- | -- | -- | --
10 MHz to 45 MHz | -- |  | -30 to +10 dBm |  | -90 to +9 dBm | -27 to +14 dBm | -87 to +12 dBm | -27 to +9 dBm | -87 to +8 dBm
45 MHz to 6 GHz | -- |  | -30 to +10 dBm |  | -90 to +9 dBm | -27 to +14 dBm | -87 to +12 dBm | -27 to +8 dBm | -87 to +8 dBm
6 GHz to 9 GHz | -- |  | -30 to +8 dBm |  | -90 to +8 dBm | -27 to +14 dBm | -87 to +12 dBm | -27 to +8 dBm | -87 to +8 dBm
9 GHz to 12.5 GHz | -- |  | -30 to +4 dBm |  | -90 to +4 dBm | -27 to +14 dBm | -87 to +12 dBm | -27 to +8 dBm | -87 to +8 dBm
12.5 GHz to 13.5 GHz | -- |  | -30 to +2 dBm |  | -90 to +1 dBm | -27 to +10 dBm | -87 to +7 dBm | -27 to +5 dBm | -87 to +4 dBm
13.5 GHz to 20 GHz | -- |  | -- |  | -- | -27 to +10 dBm | -87 to +7 dBm | -27 to +5 dBm | -87 to +4 dBm
20 GHz to 40 GHz | -- |  | -- |  | -- | -- | -- | -27 to +1 dBm | -87 to -2 dBm
40 GHz to 50 GHz | -- |  | -- |  | -- | -- | -- | -27 to -5 dBm | -87 to -9 dBm
Power Settings
Minimum Power Setting | -- |  | -33 dBm |  | -93 dBm | -30 dBm | -90 dBm | -30 dBm | -90 dBm
Maximum Power Setting | -- |  | +20 dBm
Table 16. Test Port Output1 (Continued)
Description | Specifications |  |  | Typical
 | -- |  |  | Options 020, 025, 120, 125 |  |  | Options 220, 225, 420, 425, 520, 525
Phase Noise (Nominal power at test port)
 | -- |  |  | 10 kHz Offset | 100 kHz Offset | 1 MHz Offset | 10 kHz Offset | 100 kHz Offset | 1 MHz Offset
300 kHz to 10 MHz | -- |  |  | -86 dBc/Hz | -86 dBc/Hz | -95 dBc/Hz | -77 dBc/Hz | -77 dBc/Hz | -40 dBc/Hz
10 MHz to 1.5 GHz | -- |  |  | -86 dBc/Hz | -91 dBc/Hz | -95 dBc/Hz | -77 dBc/Hz | -77 dBc/Hz | -89 dBc/Hz
1.5 GHz to 3.125 GHz | -- |  |  | -83 dBc/Hz | -91 dBc/Hz | -95 dBc/Hz | -83 dBc/Hz | -91 dBc/Hz | -95 dBc/Hz
3.125 GHz to 6.25 GHz | -- |  |  | -77 dBc/Hz | -85 dBc/Hz | -89 dBc/Hz | -77 dBc/Hz | -85 dBc/Hz | -89 dBc/Hz
6.25 GHz to 12.5 GHz | -- |  |  | -71 dBc/Hz | -79 dBc/Hz | -83 dBc/Hz | -71 dBc/Hz | -79 dBc/Hz | -83 dBc/Hz
12.5 GHz to 13.5 GHz | -- |  |  | -65 dBc/Hz | -73 dBc/Hz | -77 dBc/Hz | -65 dBc/Hz | -73 dBc/Hz | -77 dBc/Hz
13.5 GHz to 20 GHz | -- |  |  | -- | -- | -- | -65 dBc/Hz | -73 dBc/Hz | -77 dBc/Hz
20 GHz to 40 GHz | -- |  |  | -- | -- | -- | -59 dBc/Hz | -67 dBc/Hz | -71 dBc/Hz
40 GHz to 50 GHz | -- |  |  | -- | -- | -- | -59 dBc/Hz | -67 dBc/Hz | -71 dBc/Hz
Table 16. Test Port Output1 (Continued)
Description | Specifications |  |  | Typicals
 | -- |  |  | Options 020, 025, 120, 125, 220, 225, 420, 520, 425, 525
Non-Harmonic Spurious (at Nominal Output Power)
300 kHz to 10 MHz | -- |  |  |
10 MHz to 13.5 GHz | -- |  |  | -50 dBc for offset frequency > 1 kHz
13.5 GHz to 20 GHz | -- |  |  |
20 GHz to 40 GHz | -- |  |  |
40 GHz to 50 GHz | -- |  |  | -30 dBc for offset frequency > 1 kHz
Table 16. Test Port Output1 (Continued)
Description | Specifications |  |  |  |  | Typical
 | -- |  |  |  |  | Option 020, 025, 120, 125 | Option 220, 225 | Option 420, 520 | Option 425, 525
Harmonics (2nd or 3rd) at Maximum Output Power
300 kHz to 10 MHz | -- |  |  |  |  | -17 dBc | -- | -- | --
10 MHz to 500 MHz | -- |  |  |  |  | -17 dBc | -22 dBc | -15 dBc | -15 dBc
500 MHz to 1 GHz | -- |  |  |  |  | -17 dBc | -22 dBc | -15 dBc | -15 dBc
1 GHz to 13.5 GHz | -- |  |  |  |  | -20 dBc | 22 dBc | -20 dBc | -20 dBc
13.5 GHz to 20 GHz | -- |  |  |  |  | -- | -22 dBc | -20 dBc | -20 dBc
20 GHz to 40 GHz | -- |  |  |  |  | -- | -- | -22 dBc | -22 dBc
40 GHz to 50 GHz | -- |  |  |  |  | -- | -- | -- | -22 dBc

1Performance specified on Port 1 only. Port 2 performance is a characteristic.

2Power level linearity specified on Port 1 only. Port 2 performance is Typical. Test reference is at the nominal power level.

3ALC range starts at maximum leveled power and decreases in power level by the dB amount specified here.

Table 17. Test Port Input

Description | Specification |  |  |  | Typical
 | Options 020, 025, 120, 125 | Options 220, 225 | Options 420, 425 | Options 520, 525 | Options 020, 025, 120, 125 | Options 220, 225 | Options 420, 425 | Options 520, 525
Test Port Noise Floor1
10 Hz IF Bandwidth |  |  |  |  |  |  |  |
300 kHz to 1 MHz | <-93 dBm | -- | -- | -- | <-103 dBm | -- | -- | --
1 MHz to 10 MHz | <-103 dBm | -- | -- | -- | <-110 dBm | -- | -- | --
10 MHz to 45 MHz | <-112 dBm | -- | -- | -- | <-116 dBm | <-89 dBm | <-80 dBm | <-80 dBm
45 MHz to 70 MHz | <-112 dBm | <-96 dBm | <-90 dBm | <-90 dBm | <-116 dBm | -- | -- | --
70 MHz to 500 MHz | <-112 dBm | <-100 dBm | <-90 dBm | <-90 dBm | <-116 dBm | -- | -- | --
500 MHz to 2 GHz | <-112 dBm | <-105 dBm | <-110 dBm | <-110 dBm | <-120 dBm | -- | -- | --
2 GHz to 4 GHz | <-112 dBm | <-105 dBm | <-110 dBm | <-110 dBm | <-120 dBm | -- | -- | --
4 GHz to 8 GHz | <-112 dBm | <-105 dBm | <-110 dBm | <-110 dBm | <-119 dBm | -- | -- | --
8 GHz to 10.5 GHz | <-112 dBm | <-105 dBm | <-100 dBm | <-100 dBm | <-119 dBm | -- | -- | --
10.5 GHz to 13.5 GHz | <-107 dBm | <-105 dBm | <-100 dBm | <-100 dBm | <-114 dBm | -- | -- | --
10.5 GHz to 13.5 GHz | -- | <-105 dBm | <-100 dBm | <-100 dBm | -- | -- | -- | --
13.5 GHz to 20 GHz | -- | <-105 dBm | <-100 dBm | <-100 dBm | -- | -- | -- | --
20 GHz to 31.25 GHz | -- | -- | <-100 dBm | <-100 dBm | -- | -- | -- | --
31.25 GHz to 40 GHz | -- | -- | <-95 dBm | <-95 dBm | -- | -- | -- | --
40 GHz to 50 GHz | -- | -- | -- | <-90 dBm | -- | -- | -- | --
1 KHz IF Bandwidth |  |  |  |  |  |  |  |
3000 kHz to 1 MHz | <-73 dBm | -- | -- | -- | <-83 dBm | -- | -- | --
1 MHz to 10 MHz | <-83 dBm | -- | -- | -- | <-90 dBm | -- | -- | --
10 MHz to 45 MHz | <-92 dBm | -- | -- | -- | <-96 dBm | <-69 dBm | <-60 dBm | <-60 dBm
45 MHz to 70 MHz | <-92 dBm | <-76 dBm | <-70 dBm | <-70 dBm | <-96 dBm | -- | -- | --
70 MHz to 500 MHz | <-92 dBm | <-80 dBm | <-70 dBm | <-70 dBm | <-96 dBm | -- | -- | --
500 MHz to 2 GHz | <-92 dBm | <-85 dBm | <-90 dBm | <-90 dBm | <-100 dBm | -- | -- | --
2 GHz to 4 GHz | <-92 dBm | <-85 dBm | <-90 dBm | <-90 dBm | <-100 dBm | -- | -- | --
4 GHz to 8 GHz | <-92 dBm | <-85 dBm | <-90 dBm | <-90 dBm | <-99 dBm | -- | -- | --
8 GHz to 10.5 GHz | <-92 dBm | <-85 dBm | <-80 dBm | <-80 dBm | <-99 dBm | -- | -- | --
10.5 GHz to 13.5 GHz | <-87 dBm | <-85 dBm | <-80 dBm | <-80 dBm | <-94 dBm | -- | -- | --
13.5 GHz to 20 GHz | -- | <-85 dBm | <-80 dBm | <-80 dBm | -- | -- | -- | --
20 GHz to 31.25 GHz | -- | -- | <-80 dBm | <-80 dBm | -- | -- | -- | --
31.25 GHz to 40 GHz | -- | -- | <-75 dBm | <-75 dBm | -- | -- | -- | --
40 GHz to 50 GHz | -- | -- | -- | <-70 dBm | -- | -- | -- | --
Table 17. Test Port Input (Continued)
Description | Specification |  |  |  | Typical
 | Options 025, 125 | Options 225 | Options 425 | Options 525 | Options 025, 125 | Options 225 | Options 425 | Options 525
Direct Receiver Access Input Noise Floor1 (Options 025, 125, 225, 425, and 525 only)
10 Hz IF Bandwidth |  |  |  |  |  |  |  |
300 kHz to 1 MHz | <-109 dBm | -- | -- | -- | -- | -- | -- | --
1 MHz to 10 MHz | <-119 dBm | -- | -- | -- | -- | -- | -- | --
10 MHz to 45 MHz | <-128 dBm | -- | -- | -- | -- | <-120 dBm | <-126 dBm | <-126 dBm
45 MHz to 70 MHz | <-128 dBm | <-108 dBm | <-111 dBm | <-111 dBm | -- | -- | -- | --
70 MHz to 500 MHz | <-128 dBm | <-112 dBm | <-111 dBm | <-111 dBm | -- | -- | -- | --
500 MHz to 2 GHz | <-128 dBm | <-117 dBm | <-122 dBm | <-122 dBm | -- | -- | -- | --
2 GHz to 8 GHz | <-128 dBm | <-117 dBm | <-122 dBm | <-122 dBm | -- | -- | -- | --
8 GHz to 10.5 GHz | <-128 dBm | <-117 dBm | <-112 dBm | <-112 dBm | -- | -- | -- | --
10.5 GHz to 13.5 GHz | <-128 dBm | <-117 dBm | <-112 dBm | <-112 dBm | -- | -- | -- | --
13.5 GHz to 20 GHz | <-123 dBm | <-117 dBm | <-112 dBm | <-112 dBm | -- | -- | -- | --
20 GHz to 31.25 GHz | -- | -- | <-111 dBm | <-111 dBm | -- | -- | -- | --
31.25 GHz to 40 GHz | -- | -- | <-106 dBm | <-106 dBm | -- | -- | -- | --
40 GHz to 50 GHz | -- | -- | -- | <-98 dBm | -- | -- | -- | --
1 KHz IF Bandwidth |  |  |  |  |  |  |  |
300 kHz to 1 MHz | <-89 dBm | -- | -- | -- | -- | -- | -- | --
1 MHz to 10 MHz | <-99 dBm | -- | -- | -- | -- | -- | -- | --
10 MHz to 45 MHz | <-108 dBm | -- | -- | -- | -- | <-100 dBm | <-106 dBm | <-106 dBm
45 MHz to 70 MHz | <-108 dBm | <-88 dBm | <-91 dBm | <-91 dBm | -- | -- | -- | --
70 MHz to 500 MHz | <-108 dBm | <-92 dBm | <-91 dBm | <-91 dBm | -- | -- | -- | --
500 MHz to 2 GHz | <-108 dBm | <-97 dBm | <-102 dBm | <-102 dBm | -- | -- | -- | --
2 GHz to 8 GHz | <-108 dBm | <-97 dBm | <-102 dBm | <-102 dBm | -- | -- | -- | --
8 GHz to 10.5 GHz | <-108 dBm | <-97 dBm | <-92 dBm | <-92 dBm | -- | -- | -- | --
10.5 GHz to 13.5 GHz | <-108 dBm | <-97 dBm | <-92 dBm | <-92 dBm | -- |  |  |
13.5 GHz to 20 GHz | <-103 dBm | <-97 dBm | <-92 dBm | <-92 dBm | -- | -- | -- | --
20 GHz to 31.25 GHz | -- | -- | <-91 dBm | <-91 dBm | -- | -- | -- | --
31.25 GHz to 40 GHz | -- | -- | <-86 dBm | <-86 dBm | -- | -- | -- | --
40 GHz to 50 GHz | -- | -- | -- | <-78 dBm | -- | -- | -- | --
Table 17. Test Port Input (Continued)
Description | Specification |  |  |  |  |  | Typical
 | Options 220, 225 |  | Options 420, 520 |  | Options 425, 525 |  | --
Compression Level
 | Power | Com- pression | Power | Com- pression | Power | Com- pression | -- | -- | --
10 MHz to 45 MHz2 | -- | -- | -- | -- | -- | -- | -- | -- | --
45 MHz to 500 MHz | +5 dBm | 0.10 dB | +5 dBm | 0.40 dB | +5 dBm | 0.40 dB | -- | -- | --
500 MHz to 2 GHz | +5 dBm | 0.15 dB | +5 dBm | 0.77 dB | +5 dBm | 0.67 dB | -- | -- | --
2 GHz to 8 GHz | +5 dBm | 0.21 dB | +5 dBm | 0.75 dB | +5 dBm | 0.55 dB | -- | -- | --
8 GHz to 12.5 GHz | +5 dBm | 0.21 dB | +5 dBm | 0.56 dB | +5 dBm | 0.51 dB | -- | -- | --
12.5 GHz to 20 GHz | +3 dBm | 0.20 dB | +5 dBm | 0.79 dB | +5 dBm | 0.69 dB | -- | -- | --
20 GHz to 31.25 GHz | -- | -- | 0 dBm | 0.60 dB | 0 dBm | 0.50 dB | -- | -- | --
31.25 GHz to 40 GHz | -- | -- | -3 dBm | 0.55 dB | -3 dBm | 0.60 dB | -- | -- | --
40 GHz to 50 GHz | -- | -- | -3 dBm | 0.66 dB | -3 dBm | 0.71 dB | -- | -- | --
Table 17. Test Port Input (Continued)
Description | Specification |  | Typical
 | Options 020, 120, 025, 125 |  | --
Compression Level (continued)
 | Power | Com- pression | -- | -- | --
300 kHz to 10 MHz | +8 dBm | 1.0 dB (0.1 dB at +5 dBm typ.) | -- | -- | --
10 MHz to 50 MHz | +8 dBm | 0.35 dB | -- | -- | --
50 MHz to 1GHz | +8 dBm | 0.35 dB | -- | -- | --
1 GHz to 6 GHz | +8 dBm | 0.25 dB | -- | -- | --
6 GHz to 8 GHz | +8 dBm | 0.25 dB | -- | -- | --
8 GHz to 12.5 GHz | +8 dBm | 0.30 dB | -- | -- | --
12.5 GHz to 13.5 GHz | +8 dBm | 0.40 dB | -- | -- | --
Table 17. Test Port Input (Continued)
Description | Specification |  | Typical
 | -- |  | Options 020, 120, 025, 125
Test Port Compression - 0.1 dB
 | -- | -- | Power | Compression
300 kHz to 10 MHz | -- | -- | +5 dBm | 0.1 dB
10 MHz to 1 GHz | -- | -- | +9 dBm | 0.1 dB
1 GHz to 12.5 GHz | -- | -- | +10 dBm | 0.1 dB
12.5 GHz to 13.5 GHz | -- | -- | +9 dBm | 0.1 dB
Table 17. Test Port Input (Continued)
Description | Specification |  |  |  | Typical
 | Options 220, 225 |  | Options 420, 520 | Options 425, 525 | Options 220, 225 |  | Options 420, 520 | Options 425, 525
Test Port Compression - 0.1 dB (continued)
300 kHz to 10 MHz | -- |  | -- | -- | -- |  | -- | --
10 MHz to 45 MHz2 | -- |  | -- | -- | negligible |  | negligible | negligible
45 MHz to 500 MHz | -- |  | -- | -- | +10 dBm |  | 0.0 dBm | +1.0 dBm
500 MHz to 2 GHz | -- |  | -- | -- | +9 dBm |  | 0.0 dBm | +1.0 dBm
2 GHz to 12.5 GHz | -- |  | -- | -- | +6 dBm |  | 0.0 dBm | +1.5 dBm
12.5 GHz to 13.5 GHz | -- |  | -- | -- | +6 dBm |  | -1.0 dBm | 0.0 dBm
13.5 GHz to 20 GHz | -- |  | -- | -- | +6 dBm |  | -1.0 dBm | 0.0 dBm
20 GHz to 31.25 GHz | -- |  | -- | -- | -- |  | -5.5 dBm | -3.0 dBm
31.25 GHz to 40 GHz | -- |  | -- | -- | -- |  | -8.5 dBm | -7.5 dBm
40 GHz to 50 GHz | -- |  | -- | -- | -- |  | -11.5 dBm | -10.0 dBm
Trace Noise Magnitude3 1 kHz IF bandwidth, ratioed measurement, nominal power at test port.
300 kHz to 10 MHz | -- |  | -- | -- | -- |  | -- | --
10 MHz to 45 MHz | -- |  | -- | -- | 0.004 dB rms |  | 0.015 dB rms | 0.015 dB rms
45 MHz to 500 MHz | 0.004 dB rms |  | 0.010 dB rms | 0.010 dB rms | -- |  | -- | --
500 MHz to 2 GHz | 0.004 dB rms |  | 0.006 dB rms | 0.006 dB rms | -- |  | -- | --
2 GHz to 10.5 GHz | 0.004 dB rms |  | 0.006 dB rms | 0.006 dB rms | -- |  | -- | --
10.5 GHz to 13.5 GHz | 0.006 dB rms |  | 0.010 dB rms | 0.010 dB rms | -- |  | -- | --
13.5 GHz to 20 GHz | 0.006 dB rms |  | 0.010 dB rms | 0.010 dB rms | -- |  | -- | --
20 GHz to 31.25 GHz | -- |  | 0.010 dB rms | 0.010 dB rms | -- |  | -- | --
31.25 GHz to 40 GHz | -- |  | 0.020 dB rms | 0.020 dB rms | -- |  | -- | --
40 GHz to 50 GHz | -- |  | -- | 0.020 dB rms | -- |  | -- | --
Table 17. Test Port Input (Continued)
Description | Specification |  |  |  | Typical
 | Options 020, 120, 025, 125 |  |  |  | Options 020, 120, 025, 125
Trace Noise Magnitude3 (continued)
100 kHz IF bandwidth, ratioed measurement, nominal power at test port
300 kHz to 10 MHz | 12 mdB |  |  |  | --
10 MHz to 6 GHz | 4 mdB |  |  |  | --
6 GHz to 10.5 GHz | 4 mdB |  |  |  | --
10.5 GHz to 13.5 GHz | 8 mdB |  |  |  | --
600 kHz IF bandwidth, ratioed measurement, nominal power at test port
300 kHz to 10 MHz | -- |  |  |  | 20 mdB
10 MHz to 6 GHz | -- |  |  |  | 8 mdB
6 GHz to 10.5 GHz | -- |  |  |  | 8 mdB
10.5 GHz to 13.5 GHz | -- |  |  |  | 10 mdB
Table 17. Test Port Input (Continued)
Description | Specification |  |  |  | Typical
 | Options 220, 225 |  | Options 420, 520 | Options 425, 525 | Options 220, 225 |  | Options 420, 520 | Options 425, 525
Trace Noise Phase3 1 kHz IF bandwidth, ratioed measurement, nominal power at test port.
300 kHz to 10 MHz |  |  |  |  |  |  |  |
10 MHz to 45 MHz | -- |  | -- | -- | 0.025° rms |  | 0.100° rms | 0.100° rms
45 MHz to 500 MHz | 0.060° rms |  | 0.100° rms | 0.100° rms | -- |  | -- | --
500 MHz to 2 GHz | 0.060° rms |  | 0.060° rms | 0.060° rms | -- |  | -- | --
2 GHz to 10.5 GHz | 0.060° rms |  | 0.060° rms | 0.060° rms | -- |  | -- | --
10.5 GHz to 13.5 GHz | 0.060° rms |  | 0.100° rms | 0.100° rms |  |  |  |
13.5 GHz to 20 GHz | 0.060° rms |  | 0.100° rms | 0.100° rms | -- |  | -- | --
20 GHz to 31.25 GHz | -- |  | 0.100° rms | 0.100° rms | -- |  | -- | --
31.25 GHz to 40 GHz | -- |  | 0.200° rms | 0.200° rms | -- |  | -- | --
40 GHz to 50 GHz | -- |  | -- | 0.200° rms | -- |  | -- | --
Table 17. Test Port Input (Continued)
Description | Specification |  |  |  | Technical
 | Options 020, 120, 025, 125 |  |  |  | Options 020, 120, 025, 125
Trace Noise Phase3 (continued)
100 kHz IF bandwidth, ratioed measurement, nominal power at test port
300 kHz to 10 MHz | 80 mdeg |  |  |  | --
10 MHz to 6 GHz | 30 mdeg |  |  |  | --
6 GHz to 10.5 GHz | 30 mdeg |  |  |  | --
10.5 GHz to 13.5 GHz | 60 mdeg |  |  |  | --
600 kHz IF bandwidth, ratioed measurement, nominal power at test port
300 kHz to 10 MHz | -- |  |  |  | 100 mdeg
10 MHz to 6 GHz | -- |  |  |  | 60 mdeg
6 GHz to 10.5 GHz | -- |  |  |  | 60 mdeg
10.5 GHz to 13.5 GHz | -- |  |  |  | 80 mdeg
Table 17. Test Port Input (Continued)
Description | Specification |  |  |  | Typical
 | Options 020, 025, 120, 125, 220, 225, 420, 425, 520, 525 |  |  |  | --
Reference Level Magnitude
Range | +/-200 dB |  |  |  |
Resolution | 0.001dB |  |  |  |
Reference Level Phase
Range | +/-500° |  |  |  |
Resolution | 0.01° |  |  |  |
Table 17. Test Port Input (Continued)
Description | Specification |  |  |  | Typical
 | -- | -- | -- | -- | Option 020, 025, 120, 125 | Option 220, 225 | Options 420, 425, 520, 525
Stability Magnitude4
300 kHz to 10 MHz | -- | -- | -- | -- | +/-0.015 dB/°C | -- | --
10 MHz to 45 MHz | -- | -- | -- | -- | +/-0.010 dB/°C | +/-0.015 dB/°C | +/-0.015 dB/°C
45 MHz to 500 MHz | -- | -- | -- | -- | +/-0.010 dB/°C | +/-0.010 dB/°C | +/-0.010 dB/°C
500 MHz to 2 GHz | -- | -- | -- | -- | +/-0.010 dB/°C | +/-0.010 dB/°C | +/-0.010 dB/°C
2 GHz to 4 GHz | -- | -- | -- | -- | +/-0.015 dB/°C | +/-0.020 dB/°C | +/-0.010 dB/°C
4 GHz to 8 GHz | -- | -- | -- | -- | +/-0.020 dB/°C | +/-0.020 dB/°C | +/-0.010 dB/°C
4 GHz to 13.5 GHz | -- | -- | -- | -- | +/-0.020 dB/°C | +/-0.030 dB/°C | +/-0.015 dB/°C
13.5 GHz to 20 GHz | -- | -- | -- | -- | -- | +/-0.030 dB/°C | +/-0.015 dB/°C
20 GHz to 40 GHz | -- | -- | -- | -- | -- | -- | +/-0.040 dB/°C
40 GHz to 50 GHz | -- | -- | -- | -- | -- | -- | +/-0.060 dB/°C
Stability Phase4
300 kHz to 10 MHz | -- | -- | -- | -- | +/-0.30°/°C | -- | --
10 MHz to 45 MHz | -- | -- | -- | -- | +/-0.025°/°C | +/-0.25°/°C | +/-0.25°/°C
45 MHz to 500 MHz | -- | -- | -- | -- | +/-0.035°/°C | +/-0.20°/°C | +/-0.22°/°C
500 MHz to 2 GHz | -- | -- | -- | -- | +/-0.050°/°C | +/-0.15°/°C | +/-0.22°/°C
2 GHz to 4 GHz | -- | -- | -- | -- | +/-0.10°/°C | +/-0.15°/°C | +/-0.10°/°C
4 GHz to 8 GHz | -- | -- | -- | -- | +/-0.15°/°C | +/-0.15°/°C | +/-0.10°/°C
8 GHz to 13.5 GHz | -- | -- | -- | -- | +/-0.30°/°C | +/-0.45°/°C | +/-0.15°/°C
13.5 GHz to 20 GHz | -- | -- | -- | -- | -- | +/-0.45°/°C | +/-0.15°/°C
20 GHz to 40 GHz | -- | -- | -- | -- | -- | -- | +/-0.40°/°C
40 GHz to 50 GHz | -- | -- | -- | -- | -- | -- | +/-0.40°/°C
Table 17. Test Port Input (Continued) |  |  |  |  |  |  |  |
Description | Specifications |  |  | Typical
 | -- |  |  | Options 020, 120 | Option 220, 420, 520 | Options 025, 125 | Options 225, 425 , 525
Damage Input Level
Test Port 1 and 2 | -- |  |  | +27 dBm or +/- 16 VDC | +30 dBm or +/-40 VDC | +27 dBm or +/- 16 VDC | +27 dBm or +/- 16 VDC
R1, R2 in | -- |  |  | -- | -- | +15 dBm or +/- 16 VDC | +15 dBm or +/-7 VDC
A, B in | -- |  |  | -- | -- | +15 dBm or +/- 16 VDC | +15 dBm or +/-7 VDC
Coupler Thru | -- |  |  | -- | -- | +27 dBm or +/- 16 VDC | +30 dBm or +/-40 VDC
Coupler Arm | -- |  |  | -- | -- | +15 dBm or +/- 0 VDC | +30 dBm or +/-7 VDC

1Total average (rms) noise power calculated as the mean value of a linear magnitude trace expressed in dBm.

2Coupler roll-off will reduce compression to a negligible level below 45 MHz.

31 kHz IF BW, ratioed measurement, nominal power at the test port.

4Stability is defined as a ratio measurement made at the test port.

Table 18. Dynamic Accuracy (Specificationa)

Accuracy of the test port input power reading relative to the reference input power level.

Options 020, 025, 120, 125

Dynamic Accuracy, 300 kHz - 1 MHz, Option 020, 025, 120, or 125

Dynamic Accuracy, 1 MHz- 10 MHz, Option 020, 025, 120, or 125

Dynamic Accuracy, 10 MHz- 1 GHz, Option 020, 025, 120, or 125

Dynamic Accuracy, 1 - 8 GHz, Option 020, 025, 120, or 125

Dynamic Accuracy, 8 - 10.5 GHz, Option 120 or 125

Dynamic Accuracy, 10.5 - 12.5 GHz, Option 120 or 125

Dynamic Accuracy, 12.5 - 13.5 GHz, Option 120 or 125

Options 220, 225

Dynamic Accuracy, 0.045 GHz, Option 220 or 225

Dynamic Accuracy, 0.500 GHz, Option 220 or 225

Dynamic Accuracy, 0.500 - 2 GHz, Option 220 or 225

Dynamic Accuracy, 2 - 12.5 GHz, Option 220 or 225

Dynamic Accuracy, 12.5 - 20 GHz, Option 220 or 225

Options 420, 425, 520, 525

Dynamic Accuracy, 0.045 GHz, Option 420, 425, 520, or 525

Dynamic Accuracy, 0.500 GHz, Option 420, 425, 520, or 525

Dynamic Accuracy, 0.500 - 2 GHz, Option 420, 425, 520, or 525

Dynamic Accuracy, 2 - 8 GHz, Option 420, 425, 520, or 525

Dynamic Accuracy, 8 - 12.5 GHz, Option 420, 425, 520, or 525

Dynamic Accuracy, 12.5 - 20 GHz, Option 420, 425, 520, or 525

Dynamic Accuracy, 20 - 31.25 GHz, Option 420, 425, 520, or 525

Dynamic Accuracy, 31.25 - 40 GHz, Option 420, 425, 520, or 525

Dynamic Accuracy, 40 - 50 GHz, Option 520 or 525

a Dynamic accuracy is verified with the following measurements:

  • compression over frequency

  • IF linearity at a single frequency of 1.195 GHz using a reference level of -20 dBm for an input power range of 0 to -110 dBm.

Table 19. Test Port Input (Group Delay)a

Description

Specification

Supplemental Information (typ.)

Aperture (selectable)

(frequency span)/(number of points -1)

Maximum Aperture

20% of frequency span

Range

0.5 x (1/minimum aperture)

Maximum Delay

Limited to measuring no more than 180° of phase change within the minimum aperture.)

Accuracy

See graph below. Char.

The following graph shows characteristic group delay accuracy with full 2-port calibration and a 10 Hz IF bandwidth. Insertion loss is assumed to be < 2 dB and electrical length to be ten meters.

In general, the following formula can be used to determine the accuracy, in seconds, of specific group delay measurement:

±Phase Accuracy (deg)/[360 × Aperture (Hz)]

Depending on the aperture and device length, the phase accuracy used is either incremental phase accuracy or worst case phase accuracy.

a Group delay is computed by measuring the phase change within a specified frequency step (determined by the frequency span and the number of points per sweep).

General Information

  • Miscellaneous Information

  • Front Panel

  • Rear Panel

  • Environment and Dimensions

Table 20. Miscellaneous Information

Description | Specification | Supplemental Information
System IF Bandwidth Range |  | 1 Hz to 250 kHz, nominal
CPU |  | Intel® 500 MHz Pentium® III

Table 21. Front Panel Information

Description

Supplemental Information

RF Connectors

N5230A

Type

Option 220 or 225: 3.5 mm (male), 50 ohm, (nominal)

Option 420, 425, 520, or 525: 2.4 mm (male), 50 ohm, (nominal)

Center Pin Recession

0.002 in. (characteristic)

Display

Size

21.3 cm (8.4 in) diagonal color active matrix LCD; 640 (horizontal) X 480 (vertical) resolution

Refresh Rate

Vertical 59.83 Hz; Horizontal 31.41 kHz

Pixels

When running the analyzer's built-in "Display Test1," one or more of the following symptoms indicate a faulty display assembly:

  • A complete row or column of "stuck on" or "dark" pixels.

  • More than six "stuck on" pixels (but not more than three green)

  • More than twelve "dark" pixels (but not more than seven of the same color)

  • Two or more consecutive "stuck on" pixels or three or more consecutive "dark" pixels (but no more than one set of two consecutive dark pixels")

  • "Stuck on" or "dark" pixels less than 6.5 mm apart (excluding consecutive pixels)

Display Range

Magnitude

±500 dB (at 20 dB/div), max

Phase

±500°, max

Polar

10 pUnits, min
1000 Units, max

Display Resolution

Magnitude

0.001 dB/div, min

Phase

0.01°/div, min

Marker Resolution

Magnitude

0.001 dB, min

Phase

0.01°, min

Polar

0.01 mUnit, min; 0.01°,min

1 Any PNA Service Guide contains instructions for running the analyzer's built-in "Display Test." You can view a PDF file of a Service Guide on the CD-ROM that you received with your PNA, or on the Web at http://www.agilent.com. After opening the PDF file, look in the left-side column and the click on the "Index" bookmark. From the index, click on "Display Test".

Table 22. Rear Panel Information

Description | Supplemental Information
10 MHz Reference In
Connector | BNC, female
Input Frequency | 10 MHz ± 10 ppm, Typical
Input Level | -15 dBm to +20 dBm, Typical
Input I mpedance | 200 W, nom.
10 MHz Reference Out
Connector | BNC, female
Output Frequency | 10 MHz ± 1 ppm, Typical
Signal Type | Sine Wave, Typical
Output Level | +10 dBm ± 4 dB into 50 W, Typical
Output Impedance | 50 W, nominal
Harmonics | <-40 dBc, Typical
VGA Video Output
Connector | 15-pin mini D-Sub; Drives VGA compatible monitors
Devices Supported: |
 | Resolutions:
Flat Panel (TFT) | 1024 X 768, 800 X 600, 640 X 480
Flat Panel (DSTN) | 800 X 600, 640 X 480
CRT Monitor | 1280 X 1024, 1024 X 768, 800 X 600, 640 X 480
 | Simultaneous operation of the internal and external displays is allowed, but with 640 X 480 resolution only. If you change resolution, you can only view the external display (internal display will "white out").
Test Set IO
 | 25-pin D-Sub connector, available for external test set control
Aux IO
 | 25-pin D-Sub connector, male, analog and digital IO
Handler IO
 | 36-pin parallel I/O port; all input/output signals are default set to negative logic; can be reset to positive logic via GPIB command
GPIB
 | 24-pin D-sub (Type D-24), female; compatible with IEEE-488.
Parallel Port (LPT1)
 | 25-pin D-Sub miniature connector, female; provides connection to printers or any other parallel port peripherals
Serial Port (COM 1)
 | 9-pin D-Sub, male; compatible with RS-232
USB Port
 | One port on front panel and five ports on rear panel. Universal Serial Bus jack, Type A configuration (4 contacts inline, contact 1 on left); female
Contact 1 | Vcc: 4.75 to 5.25 VDC, 500 mA, maximum
Contact 2 | -Data
Contact 3 | +Data
Contact 4 | Ground
Table 22. Rear Panel Information (Continued)
Description | Supplemental Information
LAN
 | 10/100BaseT Ethernet, 8-pin configuration; auto selects between the two data rates
Line Power (A third-wire ground is required.
Frequency | 50/60/400 Hz
Voltage | 120/240 VAC (Power supply is auto switching.)
Max | 500 Watts

Note: Option H08 and Option H11 are not available with the N5230A

Table 23. Analyzer Environment and Dimensions

Description | Supplemental Information
General Environmental
RFI/EMI Susceptibility | Defined by CISPR Pub. 11, Group 1, Class A, and IEC 50082-1
ESD | Minimize using static-safe work procedures and an antistatic bench mat
Dust | Minimize for optimum reliability
Operating Environment
Temperature | 0 °C to +40 °C Instrument powers up and displays no error messages within this temperature range (except for "source unleveled" error message that may occur at temperatures outside the specified performance temperature range of 25 +/- 5°C).
Error-Corrected Temperature Range | 23°C ± 3°C with less than 1°C deviation from calibration temp.
Humidity | 5% to 95% at +40 °C
Altitude | 0 to 4500 m (14,760 ft.)
Non-Operating Storage Environment
Temperature | -40 °C to +70 °C
Humidity | 0% to 90% at +65 °C (non-condensing)
Altitude | 0 to 15,240 m (50,000 ft.)
Cabinet Dimensions
 | Height | Width | Depth
Excluding front and rear panel hardware and feet | 267 mm 10.5 in | 426 mm 16.75 in | 427 mm 16.8 in
As shipped - includes front panel connectors, rear panel bumpers, and feet. | 280 mm 11.0 in | 435 mm 17.1 in | 470 mm 18.5 in
As shipped plus handles | 280 mm 11.0 in | 458 mm 18 in | 501 mm 19.7 in
As shipped plus rack-mount flanges | 280 mm 11.0 in | 483 mm 19 in | 470 mm 18.5 in
As shipped plus handles and rack-mount flanges | 280 mm 11.0 in | 483 mm 19 in | 501 mm 19.70 in
Weight
Net |
N5230A | 24.9 kg (55 lb), nominal
Shipping |  |  |
N5230A | 36.3 kg (80 lb), nominal

Measurement Throughput Summary

  • Typical Cycle Time for Measurement Completion

  • Cycle Time vs IF Bandwidth

  • Cycle Time vs Number of Points

  • Data Transfer Time

Table 24. Typical Cycle Timea (ms) for Measurement Completion

Description | Typical
 | Number of Points
 | 201 | 401 | 801 | 1601 | 16,001
Start 8 GHz, Stop 18 GHz, 30 kHz IF bandwidth
Uncorrected | 97.5 | 102.7 | 103.8 | 108.2 | 683.9
2-Port cal | 203.7 | 213.5 | 218.5 | 234.6 | 1504.3
Start 10 MHz, Stop 10 GHz, 30 kHz IF bandwidth
Uncorrected | 112.6 | 120.6 | 124.8 | 138.2 | 738.4
2-Port cal | 232.8 | 251.8 | 265.2 | 304.3 | 1623.4
Start 10 MHz, Stop 20 GHz, 30 kHz IF bandwidth
Uncorrected | 146 | 199.3 | 210.9 | 217.2 | 753.9
2-Port cal | 302.3 | 410.5 | 438.7 | 462.5 | 1660.5
Start 8 GHz, Stop 18 GHz, 50 kHz IF bandwidth
Uncorrected | 79.1 | 81 | 81.7 | 86.6 | 482
2-Port cal | 164.5 | 170.3 | 175.3 | 193.5 | 1104.7
Start 10 MHz, Stop 10 GHz, 50 kHz IF bandwidth
Uncorrected | 96.8 | 101.7 | 108.8 | 122.2 | 524.6
2-Port cal | 202.1 | 215.6 | 236.7 | 276.7 | 1198.8
Start 10 MHz, Stop 20 GHz, 50 kHz IF bandwidth
Uncorrected | 141.6 | 163.9 | 170.7 | 179.7 | 546.5
2-Port cal | 293.6 | 341 | 360 | 389.5 | 1248.8

a Includes sweep time, retrace time and band-crossing time. Analyzer display turned off with
DISPLAY:ENABLE OFF. Add 21 ms for display on. Data for one trace (S11) measurement.

Table 25. (Options 020/025, 120/125, only) Cycle Time vs IF Bandwidth

Applies to the Preset condition (201 points, correction off) except for the following changes:

  • CF = 10 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
Description | Typical Performance
IF Bandwidth (Hz) | Cycle Time (ms)a | Trace Noise (dB rms)
600,000 | 7 | 0.0035
360,000 | 7 | 0.0026
280,000 | 7 | 0.0022
200,000 | 7 | 0.0021
150,000 | 7 | 0.0016
100,000 | 7 | 0.0012
70,000 | 7 | 0.0011
50,000 | 9 | 0.0009
30,000 | 11 | 0.0008
20,000 | 14 | 0.0006
15,000 | 17 | 0.0005
10,000 | 28 | 0.0004
7000 | 37 | 0.0004
5000 | 48 | 0.0003
3000 | 72 | 0.0003
2000 | 102 | 0.0002
1500 | 130 | 0.0001
1000 | 218 | 0.0001
700 | 294 | 0.0001
500 | 399 | 0.0001
300 | 636 | 0.0001
200 | 932 | 0
100 | 1826 | 0
30 | 6004 | 0
10 | 17903 | 0
1 | 178398 | 0

a Cycle time includes sweep and retrace time.

Table 26. (Options 220/225, 420/425, 520/525 only) Cycle Time vs IF Bandwidth

Applies to the Preset condition (201 points, correction off) except for the following changes:

  • CF = 10 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)

Description | Typical
IF Bandwidth (Hz) | Cycle Time (ms)a | Cycle Time (ms) Option 080 enabled
250,000 | 8.9 | 37.9
200,000 | 9.3 | 39.3
150,000 | 9.9 | 40.1
100,000 | 10.5 | 41.8
70,000 | 11.5 | 43.6
50,000 | 12.8 | 45.4
30,000 | 15.4 | 50
20,000 | 18.3 | 53.9
15,000 | 21 | 57.5
10,000 | 27 | 65.8
7000 | 34 | 75.4
5000 | 48.5 | 93
3000 | 72.8 | 124
2000 | 108.8 | 169
1500 | 126.8 | 187.1
1000 | 272.5
700 | 357.7
500 | 460
300 | 697.7
200 | 1003.5
150 | 1307.8
100 | 1917.6
30 | 6173.8
10 | 18214.8
1 | 181699.2

a Cycle time includes sweep and retrace time.

Table 27. (Options 020/025, 120/125, only) Cycle Time vs Number of Points

Applies to the Preset condition (correction off) except for the following changes:

  • CF = 10 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
Description | Typical Performance
IF Bandwidth (Hz) | Number of Points | Cycle Time (ms)a
30,000 | 3 | 6.7
 | 11 | 7.4
 | 51 | 6.9
 | 101 | 7.8
 | 201 | 11.2
 | 401 | 18.3
 | 801 | 32.4
 | 1,601 | 59.4
 | 6,401 | 224.7
 | 16,001 | 556.9
100,000 | 3 | 6.7
 | 11 | 6.6
 | 51 | 6.8
 | 101 | 7
 | 201 | 7.5
 | 401 | 9
 | 801 | 13.5
 | 1,601 | 22.9
 | 6,401 | 75.3
 | 16,001 | 180.3
600,000 | 3 | 6.5
 | 11 | 6.6
 | 51 | 6.8
 | 101 | 6.9
 | 201 | 7.3
 | 401 | 8.1
 | 801 | 9.4
 | 1,601 | 12
 | 6,401 | 27.7
 | 16,001 | 59.3

a Cycle time includes sweep and retrace time.

Table 28. (Options 220/225, 420/425, 520/525 only) Cycle Time vs Number of Points

Applies to the Preset condition (correction off) except for the following changes:

  • CF = 10 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)

Description | Typical |
IF Bandwidth (Hz) | Number of Points | Cycle Time (ms)a
30,000 | 3 | 8
 | 11 | 8
 | 51 | 9.38
 | 101 | 11.4
 | 201 | 15.5
 | 401 | 23.6
 | 801 | 39.9
 | 1,601 | 71.6
 | 6,401 | 265.4
 | 16,001 | 650.8
50,000 | 3 | 7.7
 | 11 | 7.7
 | 51 | 8.7
 | 101 | 10.1
 | 201 | 13
 | 401 | 18.6
 | 801 | 29.8
 | 1,601 | 52.3
 | 6,401 | 184.5
 | 16,001 | 448.8
250,000 | 101 | 8.7
 | 201 | 9.05
 | 401 | 10.85
 | 801 | 14.42
 | 1,601 | 21.63
 | 6,401 | 61.1
 | 16,001 | 147.7

a Cycle time includes sweep and retrace time.

Table 29. Data Transfer Time (ms)

Description | Typical
 | Number of Points
 | 201 | 401 | 1601 | 16,001
SCPI over GPIB (program executed on external PC)
32-bit floating point | 7 | 12 | 43 | 435
64-bit floating point | 12 | 22 | 84 | 856
ASCII | 64 | 124 | 489 | 5054
SCPI (program executed in the analyzer)
32-bit floating point | 1 | 2 | 3 | 30
64-bit floating point | 2 | 2 | 4 | 40
ASCII | 29 | 56 | 222 | 2220
COM (program executed in the analyzer)
32-bit floating point | <0.4 | 0.4 | 0.5 | 1.9
Variant type | 0.7 | 1 | 3 | 32
DCOM over LAN (program executed on external PC)
32-bit floating point | <0.8 | 1 | 1.5 | 7.1
Variant type | 1.8 | 2.7 | 8.5 | 80

Note: Specifications for Recall & Sweep Speed are not provided for the N5230A analyzers.

Tables 30 - 35 Front-panel Jumper Specs (Options 025, 125, 225, 425, 525)

Test Set Block Diagrams

N5230A Option 020, or 120, or 220, or 420, or 520 (Standard Test Set and Standard Power Range)

N5230A Option 025, or 125, or 225, or 425, or 525 (Configurable Test Set and Extended Power Range)

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT


Specs: E836xB Analyzers

Typical System Performance for the N5250A
(Rev. 2004-08-02)

  • This is a complete list of the N5250A network analyzer typical system performance.

  • To view or print the .pdf version of this document, visit our web site at http://www.agilent.com, type 5988-9620EN in the Quick Search box, then click GO.

See Specs for other PNA models

Definitions

Typical : Expected performance of an average unit which does not include guardbands. It is not covered by the product warranty.

Standard: When referring to the analyzer, this includes no options unless noted otherwise.

Unlike the lengthy specifications documents for other PNA models, this document presents typical system performance for the following categories only:

  • System Dynamic Range

  • Test Port Power

  • Noise Floor

  • Test Port Damage Level

  • Option H11 Rear Panel Connectors

Typical System Performance

Table 1. System Dynamic Range

Frequency | 1.0 mm Test Port | 1.85 mm PNA Test Port | Waveguide Port
10 MHz to 45 MHz | 63 dB | 65 dB |
45 MHz to 500 MHz | 94 dB | 97 dB |
500 MHz to 2 GHz | 120 dB | 123 dB |
2 GHz to 10 GHz | 116 dB | 123 dB |
10 GHz to 24 GHz | 111 dB | 121 dB |
24 GHz to 30 GHz | 100 dB | 112 dB |
30 GHz to 40 GHz | 92 dB | 107 dB |
40 GHz to 45 GHz | 84 dB | 101 dB |
45 GHz to 50 GHz | 85 dB | 103 dB |
50 GHz to 60 GHz | 80 dB | 100 dB |
60 GHz to 67 GHz | 75 dB | 95 dB |
67 GHz to 70 GHz | 68 dB |  | 82 dB
70 GHz to 75 GHz | 74 dB |  | 87 dB
75 GHz to 80 GHz | 85 dB |  | 98 dB
80 GHz to 100 GHz | 89 dB |  | 101 dB
100 GHz to 110 GHz | 87 dB |  | 98 dB

Table 2. Test Port Power

Frequency | 1.0 mm Test Port (Std Configurationa or Opt 017b) | 1.85 mm PNA Port | Waveguide Port
10 MHz to 45 MHz | -8 dBm | -7 dBm |
45 MHz to 500 MHz | -3 dBm | -1 dBm |
500 MHz to 2 GHz | 0 dBm | 2 dBm |
2 GHz to 10 GHz | -2 dBm | 2 dBm |
10 GHz to 24 GHz | -5 dBm | 0 dBm |
24 GHz to 30 GHz | -7 dBm | 0 dBm |
30 GHz to 40 GHz | -10 dBm | -1 dBm |
40 GHz to 45 GHz | -15 dBm | -5 dBm |
45 GHz to 50 GHz | -12 dBm | -1 dBm |
50 GHz to 60 GHz | -17 dBm | -4 dBm |
60 GHz to 67 GHz | -22 dBm | -8 dBm |
67 GHz to 70 GHz | -9 dBm |  | -2 dBm
70 GHz to 75 GHz | -7 dBm |  | 0 dBm
75 GHz to 80 GHz | -6 dBm |  | +1 dBm
80 GHz to 100 GHz | -5 dBm |  | +1 dBm
100 GHz to 110 GHz | -8 dBm |  | -2 dBm

a Assumes a 30" cable from the PNA 1.85mm Test Port Out is used to provide the 10 MHz to 67 GHz source signal. The Standard configuration does not have a bias tee in the 1.0mm head.

b Assumes a 30" cable from the PNA Source Out bulkhead connector is used to provide the 10 MHz to 67 GHz source signal. Option 017 includes a bias tee in the 1.0mm head.

Table 3: Noise Floor

Frequency | 1.0mm Test Port | 1.85mm Test Port | Waveguide Port
10 MHz to 45 MHz | -71 dBm | -72 dBm |
45 MHz to 500 MHz | -97 dBm | -98 dBm |
500 MHz to 2 GHz | -120 dBm | -121 dBm |
2 GHz to 10 GHz | -118 dBm | -121 dBm |
10 GHz to 24 GHz | -116 dBm | -121 dBm |
24 GHz to 30 GHz | -107 dBm | -112 dBm |
30 GHz to 40 GHz | -102 dBm | -108 dBm |
40 GHz to 45 GHz | -99 dBm | -106 dBm |
45 GHz to 50 GHz | -97 dBm | -104 dBm |
50 GHz to 60 GHz | -97 dBm | -104 dBm |
60 GHz to 67 GHz | -92 dBm | -103 dBm |
67 GHz to 70 GHz | -77 dBm |  | -84 dBm
70 GHz to 75 GHz | -81 dBm |  | -87 dBm
75 GHz to 80 GHz | -91 dBm |  | -97 dBm
80 GHz to 100 GHz | -94 dBm |  | -100 dBm
100 GHz to 110 GHz | -95 dBm |  | -100 dBm

Table 4. Test Port Damage Level

Frequency | 1.0mm Test Port | 1.85mm Test Port | Waveguide Port
10 MHz to 110 GHz | 27 dBm | 27 dBm | 27 dBm

Table 5 Option H08 & H11 Rear Panel Connectors (typical)

IF Connectors | A, R1, R2, B (BNC Connectors)
IF Connector Input Frequency | 8 1/3 MHz
Nominal Input Impedance at IF Inputs | 50 W
RF Damage Level to IF Connector Inputs | -20.0 dBm
DC Damage Level to IF Connector Inputs | 25 volts
0.1 dB Compression Point at IF Inputs | -27.0 dBm
Pulse Input Connectors1 | A, R1, R2, B (BNC Connectors)
Nominal Input Impedance at Pulse Inputs | 1 Kohm
Minimum IF Gate Width | 20 ns for less than 1 dB deviation from theoretical performance2.
DC Damage Level to Pulse Connector Inputs | 5.5 volts
Drive Voltage | TTL (0, +5.0) Volts
Rear Panel LO Power – Test Port Frequency (see 836x H11 Specs for Test Port Frequencies up to 67 GHz)
67 GHz to 110 GHz3 | -7 to –13 dBm
Rear Panel RF Power - Test Port Frequencies (see 836x H11 Specs for Test Port Frequencies up to 67 GHz)
67 GHz to 76 GHz24 | -4 to –10 dBm
76 GHz to 96 GHz4 | +1 to –5 dBm
96 GHz to 110 GHz4 | +5 to –1 dBm

1 Pulse input connectors are operational only with Option H08 (Pulse Measurement Capability) enabled.

2 Based on deviation from signal reduction equation: Signal Reduction (dB) = 20log10(Duty_cycle) = 20log10(pulse_width/period). Measured at Pulse Repetition Frequency (PFR) of 1 MHz.

3 For rear panel LO port frequency, divide by 8

4 For rear panel RF port frequency, divide by 6

Note: Typical system performance for front panel jumpers is not provided for the N5250A.

Test Set Block Diagram

N5250A - Standard Network Analyzer

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT

Test Set with Option 016 Block Diagram

N5250A - Option 016 Receiver Attenuators Network Analyzer

Item | Description | Item | Description
a | SOURCE OUT | h | RCVR B IN
b | RCVR R1 IN | i | CPLR ARM
c | SOURCE OUT | j | PORT 2
d | CPLR THRU | k | CPLR THRU
e | PORT 1 | l | SOURCE OUT
f | CPLR ARM | m | RCVR R2 IN
g | RCVR A IN | n | SOURCE OUT


Глоссарий

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z

12-Term Error Correction 12-компонентная коррекция погрешности. См. Коррекция погрешности, 12-компонент.

1-Port Device 1-портовое устройство. Устройство с одним разъемом или одним межсоединением с цепями устройства. В качестве примера можно привести осциллограф и нагрузку.

2-Port Calibration, Full 2-портовая калибровка, полная. Смотрите 12-компонентная коррекция погрешности.

2-Port Device 2-портовое устройство. Устройство с двумя разъемами или другими межсоединениями с цепями устройства. Примеры: фильтры, устройства на ПАВ, аттенюаторы, устройства согласования и усилители.

3-Term Error Correction 3-компонентная коррекция ошибок. Смотрите Коррекция ошибок, 3-компоненты.

A

Active Channel Активный канал. Подсвеченный канал, на который воздействуют функции передней панели.

Active Function Readout Вывод данных активной функции. Зона экрана, где отображается активная функция и ее состояние. Активная функция - функция, выполненная последним нажатием кнопки или дистанционной программной командой.

Active Marker Активный маркер. Маркер на графике, положение которого можно менять с помощью средств управления передней панели или программными командами.

Active Trace Активный график. График, который обновляется информацией входящих сигналов.

ADC Преобразователь сигнала из аналогового в цифровой (Analog to Digital Converter)

Address Адрес. Идентификация (представлена именем, меткой или числом) регистра, места хранения либо другого источника или пункта назначения данных. Примеры - расположение станции в коммуникационной сети или расположение устройства в GP-IB.

ADM Динамический мультиплексор (Add-Drop Multiplexer)

Admittance (Y) Проводимость (Y). Значение, обратное импедансу (т.е. отношение силы тока к напряжению). Полная проводимость выражается формулой Y = G + jB(t).

ALC Автоматический контроль уровня (Automatic Level Control). Смотрите Автоматический контроль усиления.

AM Амплитудная модуляция

AM Group Delay Групповая задержка АМ. Методика измерения групповой задержки с помощью прибора с источником амплитудной модуляции (АМ). Фактическая задержка огибающей модулированного сигнала измеряется напрямую внешним скалярным детектором. Провести измерения на устройствах, искажающих амплитуду сигнала, невозможно. Это относится к усилителям с автоматическим контролем усиления (AGC) и устройствам с пределом насыщения или ограничением мощности.

Amplitude Modulation Амплитудная модуляция. Процесс, или результат процесса, изменения амплитуды несущего сигнала. В результирующем модулированном несущем сигнале содержится информация, которую можно восстановить путем демодуляции. Также смотрите Модуляция.

Analog Аналоговые. Общий класс устройств или цепей, где выходной сигнал является непрерывной функцией от входного сигнала.

Annotation Аннотация. Маркирование отдельной информации на дисплее (например, частота или мощность).

ANSI Американский национальный институт стандартов: национальная организация (члены - производители, организации, пользователи и поставщики услуг связи), утверждающая стандарты, аккредитующая группы разработки стандартов и сертификации программ, а также представляющая и координирующая интересы США в неправительственных и не международных структурах.

Aperture Апертура. Диапазон частот сетевого анализатора, используемый для расчета групповой задержки. Чем уже диапазон частот, тем точнее разрешение изменений групповой задержки, однако шум уменьшается расширением апертуры.

Array Массив. Набор чисел или символов, представляющий любую заданную функцию.

ASCII Американский стандартный код обмена информацией

Attenuation Ослабление. Указывает на уменьшение амплитуды сигнала. Разность между передаваемой и полученной мощностью, возникающая из-за потерь в оборудовании, линиях или передающих устройствах; как правило, выражается в децибелах.

Attenuator Аттенюатор. Высокочастотное или микроволновое устройство для снижения уровня мощности сигнала на точные, увеличивающиеся величины по всему частотному диапазону.

Automatic Calibration System Автоматическая система калибровки (AutoCal): Функция сетевых анализаторов Rohde&Schwarz.

Automatic Gain Control (AGC) Автоматический контроль усиления (AGC). Контур, который в усилителях и других активных устройствах используется для поддержания постоянного уровня мощности высокой частоты при изменении других параметров, например, частоты. Синоним: Автоматический контроль уровня (ALC)

Autoscale Автоматический выбор масштаба. Функция анализатора, оценивающая форму сигнала и регулирующая средства управления для повышения стабильности отображения.

AUX Вспомогательный (Auxiliary); относится к входному разъему задней панели.

Averaging Усреднение. Технология снижения шума, где каждое значение рассчитывается на основе последовательных свипирований и корректируется по пользовательскому коэффициенту. Каждое новое свипирование усредняется в график до тех пор, пока количество свипирований не будет равным коэффициенту усреднения.

B

B/R Отношение данных, выбранных в B, к данным, выбранным в R.

Band Pass Полоса пропускания. Диапазон частот, пропускаемых через устройство, например, фильтр. Частоты, выходящие за предел полосы пропускания, ограничиваются или ослабляются. Также смотрите Частота отсечки (Cutoff Frequency).

Bandwidth (BW) Ширина полосы пропускания (BW). Разность между частотами непрерывной полосы частот, в пределах которой устройство работает с заданными характеристиками.

Bandwidth Limit Ограничение по полосе пропускания. Условие, действующее при превышении системной ширины полосы пропускания и при выходе искажения сигнала за пределы рабочих характеристик.

Bandwidth Selectivity Избирательность полосы пропускания. Измерение способности фильтра устранять сигналы с несоответствующей амплитудой. Это соотношение ширины полосы пропускания в 60 dB к ширине полосы пропускания в 3 dB для заданного фильтра разрешения (ПЧ). Избирательность полосы пропускания указывает на крутизну амплитудно-частотных характеристик фильтра. Иногда избирательность полосы пропускания называют коэффициентом формы.

Binary Двоичный. Метод представления чисел двумя элементами (вкл или выкл, высокий уровень или низкий уровень, единица или нуль). Компактный формат для быстрой передачи информации к анализатору и от него.

BMP Побитовое отображение

Brightness Яркость. Смотрите Яркость цвета.

Broadband Device Широкополосное устройство. Устройство, действующее в очень широком диапазоне частот, и слабо реагирующее на сигналы, выходящие за пределы этого диапазона.

Buffer Буфер. Запоминающее устройство, используемое при передаче информации, для компенсации разности в скорости передачи между двумя устройствами.

Burst Carrier Пакетный носитель. Носитель, который периодически включается и выключается. Пакетный носитель может быть модулированным или не модулированным.

BUS Базовая система общего пользования

Bus Шина. Один или более проводников, используемый в качестве пути для доставки передаваемой информации от любого из нескольких источников или к любому из нескольких пунктов.

BW Ширина полосы пропускания

Byte Байт. Восемь битов данных, представляющих один символ, который обрабатывается как единое целое.

C

CAD Автоматизированное проектирование

CAE Автоматизированное конструирование

Calibration Калибровка. Для контрольно-измерительных приборов - процесс периодической (как правило, ежегодной) поверки соответствия работы прибора техническим характеристикам. После поверки выдается свидетельство о поверке.

Для сетевых анализаторов - процесс устранения систематических погрешностей при измерениях. Смотрите Корректировка погрешности.

Calibration Kit Калибровочный комплект. Аппаратное и программное обеспечение, необходимое для корректировки погрешности сетевого анализатора при отдельном измерении и/или тестовый набор.

Calibration, 2-Port Калибровка, 2-портовая. Смотрите Коррекция погрешности, 12-компонент.

Calibration, Blackburn Калибровка, Blackburn. Калибровки пути передачи с подключением согласования источника, включая 15 компонент калибровки. Синоним: 15-компонентная корректировка погрешности

Calibration, Frequency Response Калибровка, частотная характеристика. Простейшая процедура корректировки погрешности, корректирует только несколько из двенадцати возможных компонент систематической погрешности. Корректировки частотной характеристики можно проводить для измерений отражения, передачи и развязки.

Calibration, Interpolation Калибровка, интерполяция. Функция сетевого анализатора по выбору пользователя, рассчитывающая (интерполирующая) новые компоненты корректировки погрешности на основе существующих компонент при изменении параметров сетевого анализатора, например, полосы ПЧ, мощности или времени свипирования. Полученная корректировка погрешности не настолько точна, как при проведении полной 2-портовой калибровки.

Calibration, Port Extension Калибровка, расширение порта. Смотрите Расширение порта.

Calibration, Reference Plane Калибровка, плоскость измерения. Смотрите Плоскость измерения.

Calibration, Set Z Калибровка, установка Z. Устанавливает системный импеданс, как правило 50 или 75 ом.

Calibration, SOLT Калибровка, SOLT. Калибровка с использованием четырех известных типов калибровочных мер: Short-Open-Load-Through. Также называется: полная 2-потоввая калибровка и 12-компонентная корректировка погрешности. Также смотрите Корректировка погрешности.

Calibration, TRL and LRM Калибровка, TRL и LRM. Калибровку применяют в условиях, когда тестируемое устройство невозможно напрямую подключить к портам сетевого анализатора, (MMIC, микрополосковая линия, диоды с балочными выводами и т.д.). Калибровочные меры типа Thru-Reflect-Line (TRL) и M (Match) изготавливают и используют, поскольку меры высокого качества не всегда доступны. Требования к характеристикам этих мер не настолько жесткие, а калибровка не такая точная, как традиционная полная 2-портовая калибровка с применением мер S-O-L-T. Используются различные термины (TRL, LRL, LRM и т.д.), однако все они относятся к одному и тому же базовому методу калибровки.

Characteristic Impedance Характеристический импеданс. Импеданс, измеряемый в конце бесконечно длинной линии передачи.

Color Brightness Яркость цвета. Измерение интенсивности (яркости) цвета.

Command Команда. Набор инструкций, которые переводятся в действия прибора. Как правило, действия состоят из отдельных шагов, составляющих операцию.

Continuous Sweep Mode Непрерывный режим свипирования. Состояние анализатора, при котором графики автоматически обновляются при каждом выполнении условий переключения.

Controller Контроллер. Устройство, назначающее приемник и передатчик на передачу информации. Внешний компьютер, подключенный к прибору для управления его действием.

Corrected Корректированные измерения. Измерения, выполненные после проведения корректировки погрешности.

Coupler Ответвитель. Смотрите Направленный ответвитель.

CPU Центральный процессор

Crosstalk Перекрестные помехи. Появление сигнала на одном порту устройства под влиянием сигнала в любой другой точке. Измерением перекрестных помех является развязка.

Cursor Курсор. Указатель, генерируемый электронным способом, перемещающийся по экрану в целях управления.

Cutoff Frequency Частота отсечки. Для фильтров - частота, при которой ослабление сигнала составляет 3dB ниже полосы пропускания уровня сигнала, также называется точки 3dB.

CW Непрерывная волна (Continuous wave): одночастотный режим (в отличие от качающейся частоты).

D

DAC Преобразователь цифрового сигнала в аналоговый (Digital to Analog Converter)

dB Децибел - относительная единица измерения. Соотношение в dB задано следующим: 10 log10 (P1/P2), где P1 и P2 - это измеряемые мощности. Вместо арифметических или процентных соотношений предпочитают dB, так как если компоненты объединены в ряды, их воздействие на мощность, выраженное в dB, можно арифметически прибавлять и вычитать. Например, если аттенюатор в 3dB подключен к усилителю в 10dB, общее усиление двух компонентов составляет (-3dB + 10dB = +7dB).

dBm Абсолютная единица измерения в децибелах: 0dBm = 1 mW. Соглашение по dB (суммирование и вычитание) также применяется.

DBMS Система управления базами данных

DC Постоянный ток

Default Задано по умолчанию. Известный набор условий, который применяется при отсутствии условий, заданных пользователем.

Delay Задержка. Смотрите Групповая задержка.

Demodulation Демодуляция. Процесс восстановления информации с модулированного несущего сигнала в форме сигнала с теми же характеристиками, что и у оригинального модулирующего сигнала. Восстановление модулирующего сигнала выполняется детектированием сигнала.

Detection Детектирование. Процесс демодуляции несущих сигналов. Существует два основных способа детектирования сигнала в сетевых анализаторах: диодные детекторы (используются в широкополосных схемах) и гетеродинирование (применяется в узкополосных схемах).

Detector, Diode Детектор, диод. Устройство, применяемое для преобразования ВЧ сигнала до пропорционального уровня постоянного тока. Если сигнал модулирован по амплитуде, диод обрезает ВЧ несущий сигнал от модуляции. Многие источники, применяемые со скалярными анализаторами, модулируются по амплитуде сигналом 27.778 kHz, а затем детектируются сетевым анализатором. При диодном детектировании фазовая информация по несущему сигналу теряется.

Deviation from Linear Phase Отклонение от линейной фазы. Линейная фаза относится к природе фазового сдвига при прохождении сигнала через устройство. Фаза является линейной, если график фазового сдвига относительно частоты представляет собой прямую линию по линейным шкалам. Отклонение от линейной фазы вызывает искажение сигнала.

Digital Цифровой. Касается класса устройств или контуров, где выходной сигнал меняется дискретно.

Digital Demodulation Цифровая демодуляция. Описывает методику извлечения информации, использованной для модуляции сигнала. Алгоритмы обработки цифрового сигнала применяются к сигналу после его преобразования из аналоговой в цифровую форму (оцифрован).

Dimension Размерность. Указывает размер массива. Количество строк или столбцов массива.

Directivity Направленность. Для 3-портового направленного ответвителя, соотношение мощности на вспомогательном порту, когда сигнал проходит в прямом направлении, к мощности на вспомогательном порту при прохождении сигнала в обратном направлении.

Directional Coupler Направленный ответвитель. 3-портовое устройство, которое обычно используют для отдельного отбора измерений обратной (отраженной) волны в линии передачи.

Disk Диск. Магнитный носитель для хранения данных в форме круга.

Display Дисплей. Существительное: Смотрите Экран.

Глагол: отображение аннотаций и данных измерений на дисплее.

Display Detector Mode Режим детекции отображения. Способ обработки аналоговой видео информации перед переводом в цифровую форму и сохранением в памяти.

Display Dynamic Accuracy Отображение, динамическая точность. Неточность амплитуды, обычно в dB, в пределах динамического диапазона отображения.

Display Dynamic Range Отображение, динамический диапазон. Диапазон амплитуды в dB, к которому относится динамическая точность отображения.

Display Formats Форматы отображения. Графические форматы отображения данных измерений. Сюда входят: одноканальный, оверлей (несколько графиков на одной координатной сетке), раздельный (каждый график на отдельной координатной сетке).

Display Modes Режимы отображения. Способы, с помощью которых данные измерений представляются графически. Для сетевых анализаторов существуют следующие варианты: Декартова/прямоугольная система координат (система XY с логарифмическими или линейными размерами, фаза, групповая задержка, SWR, действительные или комплексные числа, а также dBV, dBmV и dBuV), полюсная (амплитуда и угол), амплитуда и фаза, и круговая диаграмма. Для сетевых анализаторов доступны не все режимы отображения. Кроме того, эта информация может отображаться на дисплее в виде разных комбинаций графиков. Общие режимы это: сдвоенный (возможность отображать более одного графика, как правило по одному частотному диапазону) и альтернативный (возможность отображать несколько графиков, каждый из которых имеет собственный тип и частотный диапазон).

Display Phase Dynamic Accuracy Фазовая динамическая точность отображения. Неточность измерения фазы, обычно в градусах для измерений, выражаемых в градусах.

Display Points Точки отображения. Общее количество точек замера при одном измерении. Значения могут выражаться в единицах частоты, мощности или времени. Количество точек часто определяет скорость измерения, разрешение и апертуру.

Display Trace Noise, Magnitude Отображение, шум графика, амплитуда. Неточность амплитуды графика, в dB, связана со случайным шумом в испытательной системе.

Display Trace Noise, Phase Отображение, шум графика, фаза. Неточность фазы графика, в градусах, связана со случайным шумом в испытательной системе.

Display Type Отображение, тип. Тип отображения на экране дисплея, встроенного в анализатор. Данные могут отображаться в виде растровых изображений (типа точечного изображения на компьютере) или как векторные изображения (линии, нарисованные на дисплее). Кроме того, может быть указан монохромный (один цвет) или цветной (два или более цветов) стандарт цвета и отображения. Также для IBM-совместимых персональных компьютеров могут быть указаны стандарты VGA или SVGA.

Distortion Искажение. Ухудшение качества сигнала из-за нелинейных характеристик устройства или системной функции преобразования. Искажение измеряется, как комбинация изменений амплитуды, частоты и фазы сигнала в точке вывода устройства или системы по сравнению с сигналом в точке входа.

Drift Смещение. Медленное изменение частоты сигнала.

DSP Цифровая обработка сигналов

DUT Тестируемое устройство

DVM Цифровой вольтметр

Dynamic Range Динамический диапазон. Для приемника - диапазон уровней сигнала от минимума до максимума, которые можно одновременно достоверно измерять. Динамический диапазон дает возможность измерения малых сигналов при наличии больших. Как правило, максимальную границу динамического диапазона определяют мощность источника и сжатие приемника. Минимальную границу по мощности обычно определяют остаточные отклики и уровень шума приемника.

E

ECal Смотрите Электронная калибровка.

Electrical Delay Электромагнитная инерция. Условная переменная длина линии передачи без потерь, которая добавляется или вычитается из ввода приемника для компенсации соединительных кабелей. Для других сетевых анализаторов - встроенный эквивалент механических или аналоговых "удлинителей линии".

Electronic Calibration (ECal) Электронная калибровка (ECal). Калибровочная система для электронной калибровки ВЧ и микроволнового вектора сетевых анализаторов. Электронная система калибровки создает 12-компонентную, 2-портовую модель ошибок, а затем проводит проверку достоверности калибровки. Система Ecal состоит из повторяемой, полупроводниковой калибровочной меры с переменным импедансом и центрального устройства управления, взаимодействующего с сетевыми анализаторами моделей 8510, 8720 и 8753 или модулем USB, который взаимодействует с сетевыми анализаторами типа PNA.

EMC Электромагнитная совместимость

EMI Электромагнитная интерференция: случайные помехи, генерируемые электронным оборудованием, или внешние. Типичные источники помех - транзитные линии питания, помехи источников питания с переключающими схемами и/или паразитное излучение генераторов. ЭМИ подавляется фильтрами для линий питания, экранированием и т.д.

Engage Включение. Для активации функции.

Enter Ввод. Процесс ввода информации.

EPROM Электронно программируемая постоянная память

Error Correction Коррекция погрешности. Для сетевых анализаторов - процесс устранения или уменьшения систематических (повторяемых) погрешностей измерения путем измерения на известных мерах из калибровочного комплекта. Синоним: калибровка измерения

Error Correction, 3-Term Коррекция погрешности, 3-компоненты. Используется для устранения систематических погрешностей измерения в устройствах с одним портом, таких как нагрузка.

Error Correction, 12-Term Коррекция погрешности, 12-компонент. Коррекция для 2-портовых устройств с использованием 6 параметров:
Направленность
Согласование в источнике
Согласование в нагрузке
Частотная характеристика отражения
Частотная характеристика передачи
Развязка

Чтобы полностью охарактеризовать 2-портовое устройство необходимо определить эти шесть параметров в прямом и обратном направлениях, что в целом составит 12 компонент. Пользователь обычно имеет возможность исключить развязку из процесса коррекции. Синоним: Full two-port error correction - полная 2-портовая коррекция погрешности

Error Correction, 1-Port Коррекция погрешности, 1-порт. Корректирует испытательный комплект по погрешностям направленности порта 1 или 2, частотной характеристики и согласования источника. Для проведения процесса необходимы три известных калибровочных меры, например, типа open, short и load.

Error Message Сообщение об ошибке. Сообщение на дисплее, указывающее на сбойную ситуацию. Сбойную ситуацию могут вызывать отсутствие оборудования или его неисправность, ошибочная операция пользователя или другие ситуации, требующие дополнительного внимания. В общем требуемое действие или операция не могут быть выполнены до устранения такой ситуации.

ESD Электростатический разряд

Ethernet Сеть Ethernet, соответствующая стандарту локальных сетей IEEE 802.3.

Ethernet address Адрес Ethernet. Шестнадцатеричное число, используемое для идентификации машины в сети. Каждому анализатору на производстве назначается уникальный адрес Ethernet, который хранится в ROM анализатора.

External trigger signal Внешний сигнал триггера. Сигнал TTL, который вводится в анализатор и инициирует свипирование измерения или подобное событие, что синхронизирует измерения с внешним источником пусковых сигналов.

F

Filter Фильтр. Пассивное устройство, пропускающее некоторые частоты и ослабляющие другие, в зависимости от типа и характеристик. Фильтр верхних частот пропускает частоты, превышающие частоту отсечки, фильтр нижних частот пропускает частоты ниже частоты отсечки, а полосовой фильтр пропускает частоты в заданном диапазоне.

Firmware Встроенное оборудование. Комплект из аппаратного обеспечения и системы команд. Аппаратное обеспечение и система команд встроены, и их нельзя изменять при нормальном функционировании. Система команд постоянно установлена в схему прибора и считается ROM (постоянное запоминающее устройство). Встроенное оборудование определяет рабочие характеристики прибора или оборудования.

Flatness Сглаженность. Амплитудная и фазочастотная характеристика тестируемого устройства (DUT), источника сигнала, приемника или их комбинации. Смотрите также Частотная характеристика.

FM Частотная модуляции

Frequency Частота. Количество периодических колебаний, вибраций или волн в единицу времени, обычно выражается в циклах в секунду или Герц (Hz).

Frequency Accuracy Точность воспроизведения частоты. Погрешность определения частоты сигнала или спектральной компоненты в абсолютном смысле или по отношению к другому сигналу или спектральному компоненту. Абсолютную и относительную точность воспроизведения частоты указывают отдельно.

Frequency Range Частотный диапазон. Диапазон частот, определенный как рабочая характеристика устройства или прибора.

Frequency Resolution Частотное разрешение. Способность сетевого анализатора измерять характеристики устройства при близких частотах и отображать их по отдельности. Разрешение для равных амплитудных характеристик определяет полоса ПЧ. Разрешение для неравных амплитудных характеристик определяет полоса ПЧ и избирательность полосы пропускания.

Frequency Response Частотная характеристика. Изменение полного размаха отображаемой амплитудной характеристики по указанному центральному частотному диапазону. Обычно частотная характеристика выражается в dB, относительно среднего значения между экстремумами.

Frequency Span Диапазон частот. Значение отображаемого частотного компонента. На дисплее диапазон представлен горизонтальной осью. В общем, диапазон частот задан, как общий диапазон по всему дисплею. В некоторых анализаторах диапазон частоты (ширина диапазона) представлен распределенным значением.

Frequency Stability Частотная устойчивость. Способность частотного компонента оставаться неизменным по частоте или амплитуде по кратким или длительным периодам времени. Устойчивость касается способности генератора фиксироваться на отдельной частоте в течение некоторого периода времени.

Front Panel Key Клавиша передней панели. Клавиши, расположенные на передней панели прибора. Метки на клавишах определяют функции, ими выполняемые. Примеры клавиш передней панели - кнопки с числами и шаговые переключатели.

Full 2-Port Calibration Полная 2-портовая калибровка. Смотрите Коррекция погрешности, 12-компонент.

Function Функция. Действие или задача, для выполнения которых предназначен отдельный предмет. Функции сетевого анализатора могут выполняться с помощью клавиш передней панели или через программные команды. Характеристики этих функций определяет встроенное оборудование прибора. В некоторых случаях выполнение функции с помощью DLP (загружаемая программа) дает возможность выполнять функцию путем выбора клавиши передней панели.

Fundamental Frequency Основная частота. Низшая частотная составляющая для любой формы волны, остальные компоненты являются гармониками. Чистая синусоида имеет только один компонент, основной.

G

Gb Гигабит

GB Гигабайт

GHz Гигагерц

GIF Формат графического обмена - стандартный графический формат для хранения растровых графических файлов.

Giga Приставка, означающая один миллиард.

GP I/0 Универсальный ввод / вывод, разъем, обычно с задней стороны прибора, обеспечивающий связь с испытательным оборудованием, внешними испытательными комплектами, переключателями и компьютерами, которые дают возможность синхронизировать прибор или внешнее оборудование. Пример - педальный переключатель, продолжающий циклы измерений, в это время оператор может обеими руками работать с испытательным оборудованием.

GPIB Универсальная интерфейсная шина - шина IEEE 488 представляет собой соединительную шину и протокол, которые дают возможность связи приборов и компьютера.

Graticule (or Grid) Координатная сетка (или сетка). Зона отображения формы волны на приборе. Отметки на рамке или оси помогают проводить визуальные измерения.

Group Delay Групповая задержка. Время прохождения сигнала через тестируемое устройство относительно частоты. Групповую задержку можно рассчитать дифференцированием характеристики ввода-фазы с учетом частоты. Смотрите также Групповая задержка амплитудной модуляции и Отклонение от линейной фазы.

GUI Графический интерфейс пользователя

H

Hardcopy Документальная копия. Копия данных на бумаге.

Hardkey Закрепленная клавиша. Клавиша на передней панели, выполняющая единственную функцию анализатора, или представляющая единственное меню функциональных клавиш.

Horizontal Reference Горизонтальный опорный уровень. Смотрите Опорный уровень.

Horizontal Resolution Разрешающая способность по горизонтали. Способность анализатора отбирать близко расположенные по горизонтали точки данных по полному свипированию.

Host Computer Главный компьютер. Компьютер или устройство, обеспечивающие обслуживание конечного пользователя, например, расчеты и доступ к базам данных, и выполняющие функции сетевого управления.

Host Name Имя хоста. Уникальное имя для идентификации каждого главного компьютера в сети. Имя хоста напрямую связано с IP -адресом и может его заменять. Имя хоста, как правило, создает пользователь или системный администратор.

HP Компания Hewlett-Packard

HPGL Язык графических символов Hewlett-Packard

HP-IB Интерфейсная шина Hewlett-Packard. Параллельный интерфейс, дающий возможность "организации опроса по шлейфу" более, чем одного устройства через порт компьютера или прибора. Протокол интерфейса определен в IEEE 488.2; эквивалент промышленному стандарту GPIB.

HTTP Протокол передачи гипертекстовых файлов: используется для обеспечения трафика по всемирной паутине (WWW).

Hue Оттенок. Величина цвета по шкале от красного через желтое, зеленое, синее и снова красное. Определенная градация цвета, тона, оттенка.

I

I/O Ввод/вывод

I/O Path Путь ввода/вывода

IEEE Институт инженеров по электротехнике и радиоэлектронике

IF ПЧ: частота, при которой сигнал обрабатывается после смешения.

Impedance Импеданс. Отношение напряжения к силе тока на порту контура, в омах.

Initialize Инициализация. Процесс, назначающий места размещения информации на диске для подготовки магнитного носителя к принятию файлов.

Input Ввод. Путь поступления сигнала в прибор.

В большинстве сетевых анализаторов 3 (помечены A, B и R) или 4 ввода (помечены A, B, R1 и R2). Вводы и каналы - это не одно и то же.

Input Attenuator Входной аттенюатор. Аттенюатор между входным разъемом и первым преобразователем спектра анализатора (также называется ВЧ аттенюатор). Входной аттенюатор используют для регулировки уровня сигнала первого преобразователя и для предотвращения нелинейных искажений из-за широкополосных сигналов или сигналов с высоким уровнем напряжения. Кроме того, применяют для установки динамического диапазона путем управления степенью искажения, генерируемого внутренне. У некоторых анализаторов изменение настроек входного аттенюатора меняет вертикальную позицию сигнала на дисплее, что соответственно меняет опорный уровень. В анализаторах Agilent, управляемых микропроцессором, меняется усиление ПЧ для компенсации изменений в настройках входного аттенюатора. Вследствие этого положение сигнала на дисплее и опорный уровень не меняются.

Insertion Loss Вносимая потеря. Разность между мощностью измеренной перед вставкой устройства и после нее. Ослабление между вводом и выводом устройства.

Intensity Интенсивность. Яркость; излучение отраженного света; яркость света.

Interface Интерфейс. Соединение, обеспечивающее общий канал связи между двумя или более приборами.

Intermodulation Distortion Искажение взаимной модуляции. Нежелательные частотные составляющие, появляющиеся из-за взаимодействия двух или более спектральных компонентов, проходящих через устройство с нелинейными характеристиками, например, преобразователь или усилитель. Нежелательные компоненты связаны с основными компонентами через суммы и разности основных частот и различных гармоник. Алгоритм: f1 ±f2, 2xf1 ±f2, 2xf2±f1, 3xf1 ±2x f2 и т.д.

Internet Интернет. Объединение двух или более отдельных сетей. Часто для обеспечения соединения используют шлюз или маршрутизатор.

Interpolate Интерполяция. Для определения значения сигнала между смежными точками с помощью процедуры или алгоритма.

IP Интернет-протокол

IP Address Адрес Интернет-протокола: уникальное число, назначенное каждому устройству, которое будет подключаться к сети TCP/IP. Перед началом работы анализатора в сети, администратор сети должен назначить IP-адрес. IP-адрес состоит из 32-битного значения с десятичной точкой: 4 октета (байта), разделенные точкой.

ISDN Цифровая сеть с комплексными услугами: Предоставление стандартных цифровых услуг по одному или нескольким каналам с коммутацией для передачи цифровых звука, данных или изображений, по каналу с коммутацией пакетов осуществляется управление и передача внеполосных сигналов. Кроме того, ISDN предоставляет набор стандартных и дополнительных функций, обеспечивающих производительность работы с информацией для пользователя, а также доступ к Интернету при скорости большей, чем в аналоговых системах.

ISO Международная организация по стандартизации

Isolation Развязка. Характеристика измерения защищенности одного сигнала от влияния другого смежного сигнала. Такое явление называется перекрестными помехами.

Isolator Развязка. ВЧ устройство, используемое для изоляции между проводниками и компонентами. Состоит из 3-портового циркулятора, третий порт завершается нагрузкой в 50 ом.

J

K

Kilo Кило-. Приставка, означающая одну тысячу.

KB Килобайт

Kb/s Килобайтов в секунду

L

LAN Локальная сеть

LANS Система локальных сетей

LCD Жидкокристаллический дисплей

LED Светоизлучающий диод

LIF Формат логического обмена (применяется для более старых дисководов/компьютеров HP)

Limit Lines Ограничительные линии. Ввод пользователя по линиям, который перекрывает данные измерения анализатора, чтобы разрешить автоматическое обнаружение данных, выходящих из допустимого диапазона. Аннотация Пропуск/неудача, аудио сигналы или электронный вывод могут переключаться для оповещения оператора или компьютерной программы, находящейся в режиме онлайн, о ситуации выхода за допустимые пределы.

Limit-Line File Файл ограничительной линии. Пользовательский файл в памяти с записями таблицы ограничений.

Limit-Line Table Таблица ограничений. Линейные сегменты ограничительной линии, которые хранятся в таблице ограничений. Таблицу можно вызывать повторно для редактирования линейных сегментов, потом сохранять в файл ограничительных линий.

Linear Device Линейное устройство. Устройство, где выходные значения постоянно пропорциональны входным.

LO Локальный генератор. В супергетеродинной системе локальный генератор объединяется с полученным сигналом, чтобы выдать сумму или разность, равную промежуточной частоте (ПЧ) приемника.

LO Feedthrough Перемычка локального генератора. Характеристика супергетеродинной системы при частоте первого локального генератора равной первой ПЧ.

Load Нагрузка. Одно-портовое микроволновое устройство для завершения проводника в его характеристическом импедансе.

Load Match Согласование в нагрузке. Измерение того, насколько завершающий импеданс нагрузки близок к импедансу идеальной линии пропускания. Согласование обычно измеряется, как потери на отражение или коэффициент стоячей волны (SWR) нагрузки.

Local Lock Out Локальная блокировка. Условие или команда, не допускающие ввода с передней панели анализатора (и отключающие локальную клавишу).

Local Operation Локальная операция. Для действия вручную с передней панели.

Log Логарифм

Log Display Логарифмическое отображение. Режим отображения, при котором вертикальное отклонение - это логарифмическая функция от амплитуды входного сигнала. Калибровка отображения устанавливается с помощью выбора значения позиции опорного уровня и коэффициента масштабирования в dB на деление.

LRM Линия-Отражение-Согласование. Смотрите Смотрите Калибровка, TRL и LRM.

M

Magnitude Значение амплитуды. Амплитуда сигнала, измеренного в точке характеристического импеданса без учета фазы. Смотрите также Скалярный.

Marker Маркер. Графический символ на графике с комментарием по характеристикам измерения в данной точке.

Marker Functions Функции маркера. Математическая или статистическая обработка данных одного или более маркеров для обеспечения оператора дополнительной информацией. Например, дельта-функция маркера рассчитывает и отображает разность между данными двух маркеров.

Maximum Input Level Максимальный уровень входного сигнала. Максимальная мощность сигнала, которую можно безопасно подавать на вход анализатора. Как правило, максимальный уровень входного сигнала для спектроанализаторов Agilent равен 1 W (+30 dBm).

MB Мегабайт

Measurement Uncertainty Погрешность измерения. Дискретная размерность погрешности в ситуации измерения. Калибровки предназначены для уменьшения размера погрешности. Ниже указаны источники ошибок, приводящих к погрешности измерения:

  • Систематические ошибки (дефекты калибровочных мер, разъемов, кабелей и приборов)

  • Случайные ошибки (шум, нестабильность разъема)

  • Смещение (источник и приборы)

Mega Мега-. Приставка, означающая один миллион.

Memory Память. Запоминающая среда, устройство или носитель записи, где можно хранить данные для последующего использования и восстанавливать их.

Memory Card Карта памяти. Небольшое запоминающее устройство, по форме напоминающее кредитную карту, где могут храниться данные или программы.

Menu Меню. Функции анализатора, которые появляются на дисплее, их можно выбирать нажатием клавиш передней панели. В результате выбора могут быть вызваны другие функции, составляющие группы, которые называются меню.

MHz Мегагерц

milli Милли- . Приставка, означающая одну тысячную.

Modem Модем. Модулятор/демодулятор

Modulation Модуляция. Процесс или результат процесса, изменения характеристики несущего сигнала сигналом - носителем информации, вследствие которого несущий сигнал становится носителем информации. Смотрите AM и FM.

Monitor Монитор. Любой внешний дисплей.

Monochrome Монохромный. Имеющий один цвет (тональность).

ms Миллисекунда

mW Милливатт: одна тысячная ватта

Multisync Многочастотный. Тип монитора, способного синхронизировать горизонтальное свипирование по разным частотам в пределах заданного диапазона.

N

Narrowband Узкополосный канал. В сетевом анализе - частотное разрешение приемника анализатора, достаточно узкое для разрешения амплитудных и фазовых характеристик узкополосных устройств. Как правило, суженая полоса пропускания уменьшает уровень шума приемника, обеспечивая дополнительный диапазон измерения амплитуды.

Narrowband Device Узкополосное устройство. Устройство с характеристиками прохождения, предназначенными для функционирования в очень узком частотном диапазоне, а также для обеспечения четких амплитудных характеристик в этом диапазоне. Например, фильтр полосы пропускания.

Network Analysis Анализ сетевыми методами. Характеризация устройства, контура или системы путем сравнения сигнала, входящего в устройство, с сигналом или сигналами, выходящими из устройства.

NIST Национальный институт стандартов и технологий

Nit Нит. Единица освещенности (фотометрическая яркость) - одна свеча на квадратный метр.

Noise Шум. Случайные колебания нежелательной или возмущающей энергии от искусственных или естественных источников в коммуникационной системе, которые влияют на информацию, переносимую сигналом, или искажают ее. Смотрите также Соотношение сигнала к шуму.

Noise Figure Коэффициент шума (F): Для двух-портового устройства - измерение того, как шум, генерируемый устройством, ухудшает соотношение сигнала к шуму для сигнала, проходящего через устройство при 290 градусах, выражается в dB.

Noise Floor Уровень шума. Внутренний шум анализатора. Часто уровень шума ограничивает то, насколько малую амплитуду сигнала можно измерять. При анализе сетевыми методами уровень шума измеряется при том, что тестовые порты завершаются нагрузками, полной 2-портовой коррекции погрешности, полоса ПЧ - 10 Hz, максимальной мощности тестового порта и без усреднения во время тестирования.

Non-Insertable Devices Не вставляемые устройства. При калибровке измерений - устройство, которое нельзя заменить сквозным проводником нулевой длины. Устройство имеет разъемы одного типа на каждом порту или разный тип разъемов для каждого порта.

Nonvolatile Memory Энергонезависимая память. Информация памяти сохраняется при отключении источника питания. Как правило, такую память питает аккумулятор. Также смотрите RAM с аварийным батарейным питанием.

Normalize Нормализация. Для вычитания одного графика из другого в целях устранения погрешности калибровочных данных или получения соответствующей информации.

O

Offset Смещение. Для перемещения или компенсирования на определенную величину. Применяется в приборах для смещения частот, ограничений, задержки, потерь, импеданса и т.д.

Output Attenuation Ослабление выходного сигнала. Способность ослаблять сигнал, источник, для контроля его уровнем мощности.

P

PC Персональный компьютер

PDF Формат переносимых документов (используется в сетях)

Parser, Command Синтаксический анализатор, команда. Считывает программные сообщения из входной очереди устройства в порядке их получения от контроллера. Синтаксический анализатор определяет действия, которые должен выполнить анализатор. Одна из важный функций синтаксического анализатора команд - определение позиции программного сообщения на дереве команд SCPI анализатора. Предполагается, что при сбросе синтаксического анализатора следующий полученных им элемент появится из основания дерева команд анализатора.

Peak Search Поиск пика. Функция анализатора, выполняющая поиск наибольшего значения характеристики и устанавливающая на нем маркер.

Phase Фаза. Дробная часть цикла, через который проходит колебание, измеряется в произвольной стартовой точке; обычно выражается в радианах или градусах. При анализе сетевыми методами, фазовая характеристика тестируемого устройства - это изменение фазы, как функция от частоты между входным воздействием и измеренным откликом.

Port Порт. Физическое входное или выходное соединение прибора или устройства.

Port Extension Расширение порта. Переопределение плоскости измерения на другую, отличающуюся от установленной при калибровке. Новая плоскость измерения определяется в секундах задержки от порта тестового комплекта.

Positive Peak Положительный пик. Максимум, мгновенное значение входящего сигнала.

Postscript (.ps files) Postscript (файлы .ps). Сохранение растровых графических файлов в защищенном формате для прямого использования принтерами.

Power, Max Input Мощность, максимальный входной сигнал. Верхний предел входной мощности, соответствующий техническим условиям. Для некоторых технических условий уровни максимальных входных сигналов могут быть разными. Например, обычно максимум мощности сжатия выше максимума нелинейного искажения.

Power, Safe Input Мощность, безопасный входной сигнал. Допустимая мощность входного сигнала, обычно в dBm, не повреждающая прибор.

Preset Заданный. Заранее установленное инструментальное состояние (также запускает самотестирование анализатора). Действие в результате нажатия клавиши Preset.

Protocol Протокол. Набор соглашений, указывающих способ форматирования и передачи информации по сети, а также способ связи компьютеров в сети.

Q

Q or Q Factor Q или Коэффициент Q. Отношение сохраненной энергии к потерям энергии в резонансном контуре. Высокое значение Q означает острую характеристику резонанса по отношению к частоте.

Query Запрос. Любая программная команда с отдельной функцией возврата отклика. Такие команды могут заканчиваться знаком вопроса (?). Опрашиваемые команды возвращают информацию компьютеру.

R

r + jx Выражение для импеданса в комплексной форме, где r представляет резистивную часть, а х - реактивную.

R Channel R канал. Опорный канал

RAM Оперативное запоминающее устройство или двусторонняя память: Зона хранения с возможностью доступа к каждому пункту хранения. Данные можно записывать в RAM или извлекать из него, однако данные хранятся временно. При отключении питания информация исчезает. Информация, созданная пользователем, которая появляется на дисплее, - это данные RAM.

ROM Постоянное запоминающее устройство: Зона хранения с возможностью только чтения; пользователь не может записывать данные или вносить изменения. Для приборов - зона хранения, где находятся "мозги" или функциональные программы; встроенное оборудование.

Receiver Приемник. Контур или система, предназначенная для получения и/или измерения сигналов в заданном частотном диапазоне.

Receiver Dynamic Range Приемник, динамический диапазон. Смотрите Динамический диапазон.

Reference Level Опорный уровень. Функция прибора, дает пользователю возможность установить значение амплитуды в опорной позиции. Для сетевых анализаторов также можно выбрать опорную позицию. Для некоторых спектроанализаторов опорная позиция зафиксирована в верхней части дисплея.

Reference Plane Плоскость измерения. Точка (в электрическом смысле), где предполагается, что для сетевого анализатора заканчиваются системные разъемы и фиксаторы, и начинается тестируемое устройство. Плоскость измерения устанавливается с помощью калибровочных мер с известной электрической длиной. Чем ближе плоскость измерения к тестируемому устройству, тем лучшей будет характеризация устройства из-за устранения погрешностей тестовой системы.

Reflection Отражение. Явление, при котором движущаяся волна ударяется о неоднородность и возвращается к оригинальному носителю.

Reflection Coefficient Коэффициент отражения. Соотношение отраженного напряжения к инцидентному напряжению в линии пропускания или контуре. Если линия пропускания завершается в точке характеристического импеданса, коэффициент отражения равняется нулю. Если линия закорочена или разомкнута, коэффициент равен 1. Смотрите также Обратные потери и SWR.

Reflection Measurements Измерения отражения. Измерения, характеризующие поведение входного и/или выходного сигнала тестируемого устройства. Измеряется как соотношение отраженного сигнала к инцидентному сигналу, как функции от частоты. Параметры - обратные потери, коэффициент отражения, импеданс и коэффициент стоячей волны, все, как функция от частоты. Смотрите также S-параметры.

Remote Дистанционный. Режим работы, при котором другое устройство (или компьютер) управляет прибором через HP-IB. В этом режиме клавиши передней панели прибора отключены. Функционирование передней панели называется локальным действием.

Remote Programming Дистанционное программирование. Автоматическое управление прибором с помощью компьютера, обычно через HP-IB, LAN или канал RS-232.

Resolution Разрешение. Способность приемника разделять два сигнала.

Resolution Bandwidth Разрешение полосы пропускания. Способность спектроанализатора дискретно отображать близкие характеристики (герц, герц децибел). Этот термин используется для определения ширины фильтра разрешения полосы пропускания спектроанализатора на некотором уровне ниже точки минимальной вносимой потери (максимальная точка отклонения на дисплее). Обычно задают разрешение полосы пропускания в 3 dB, но для некоторых случаев задают 6 dB.

Return Loss Обратные потери. Количество dB, определяющее величину, на которую отраженный сигнал ниже инцидентного. Если отражается нулевой сигнал, импеданс устройства равен характеристическому импедансу системы пропускания, а обратные потери бесконечны. Если отражается весь инцидентный сигнал, обратные потери равны нулю. Смотрите также S-параметры, Коэффициент отражения и SWR.

Reverse Measurement Обратное измерение. Измерение на устройстве от вывода к вводу.

RF Радиочастота (приблизительно от 50 kHz до 3 GHz). Обычно это относится к любому сигналу, который передается по воздуху.

ROM Постоянное запоминающее устройство

S

S/N Отношение сигнала к шуму

Sampler Дискретизатор. Электронный компонент, который фиксирует уровень сигнала и фазу по известному импедансу при равномерной частоте. Для точности измерений сетевыми анализаторами частота выборки должна быть достаточно большой и точно рассчитанной. Как правило, у сетевых анализаторов три или четыре дискретизатора или преобразователя.

Sampler Bounce Отражение дискретизатора. Просачивание или перекрестные помехи дискретизаторов сетевого анализатора. Задержка в перекрестных помехах, вызванная распространением просачивания при прохождении, влияет на отражение. Отражение дискретизатора вызывает повышение уровня шума в канале, снижая чувствительность анализатора.

Saturation Насыщенность. Уровень чистоты цвета на шкале цветов от белого до чистого цвета.

Scalar Скалярный. Параметр с амплитудой, но без фазы. Сетевой анализатор, измеряющий только амплитуду.

Scale Factor Коэффициент масштабирования. Отображение калибровки вертикальной оси в смысле единицы на деление.

SCPI Стандартные команды для программируемых приборов

Screen Экран. Физическая поверхность электронно-лучевой трубки или плоская панель, на которой отображаются результаты измерений, установочная информация, определения функциональных клавишах и другие показания прибора.

Self-Test Самопроверка. Группа тестов, выполняемая при включении питания (или как заданная процедура), которая проверяет правильность функционирования прибора.

Sensitivity Чувствительность. Минимальный входной сигнал, необходимый для генерирования заданного выходного сигнала с заданным соотношением сигнала к шуму или другим заданным критерием.

Для спектроанализатора - уровень наименьшей синусоиды, которую можно наблюдать, обычно при оптимизованных условиях минимального разрешения полосы пропускания, ослабление входного сигнала 0 dB и минимальной полосе пропускания для видео.

Нормализованное изменение средней частоты компоненты YIG в результате изменения тока в настроечной катушке, выражается в MHz/mA.

Serial Prefix Префикс серийного номера. Префикс из пяти символов, которым начинается серийный номер прибора; используется для указания версии встроенного оборудования или изменений в аппаратном оборудовании.

Server Сервер. Устройство для обслуживания других устройств сети, например, предоставления совместного доступа к файловой системе или принтеру.

Signal-to-Noise Ratio Отношение сигнала к шуму (SNR): Отношение амплитуды требуемого сигнала к амплитуде шумовых сигналов, обычно выражается в dB и терминах пиковых значений для импульсных помех и квадратного корня из значений случайных помех.

Single Sweep Mode Режим одинарного свипирования. Спектроанализатор проводит одно свипирование при выполнении условий срабатывания. Каждое свипирование вызывается нажатием соответствующей клавиши на передней панели или отправкой программной команды.

Small Signal Gain Compression Нелинейные искажения малого сигнала. Ситуация, при которой амплитуда измеряемого сигнала меньше фактической из-за перегрузки входного преобразователя сетевого анализатора; анализатор функционирует в нелинейном режиме. Для детекторов широкополосных анализаторов - сигнал, отличающийся от тестируемого, может ввести анализатор в режим нелинейных искажений, поэтому будут появляться сигналы еще более низкого уровня, чем фактический. В широкополосном режиме измеряется вся мощность, подающаяся на анализатор, а не только сигналы с интересующей частотой.

Smith Chart Диаграмма Смита. Графическое изображение комплексного коэффициента отражения на нормализованный комплексный импеданс. Круги на диаграмме представляют постоянное сопротивление, а радиальные линии, перпендикулярные к кругам, представляют постоянную реактивность. Центр диаграммы представляет характеристический импеданс системы пропускания. Любая точка диаграммы представляет отдельный комплексный импеданс. Линия диаграммы представляет изменение импеданса по частоте.

SOLT Калибровка Short-Open-Load-Through. Смотрите также Калибровка, SOLT.

Source Источник. Устройство, подающее сигнал; свипирующий генератор или синтезирующий свипировщик.

Source Amplitude Accuracy Точность амплитуды источника. Погрешность амплитуды показаний источника питания, в dB.

Source Amplitude Flatness Сглаженность амплитуды источника. Сглаженность амплитуды источника питания по указанному частотному диапазону, в dB.

Source Frequency Resolution Частотное разрешение источника. Наименьшая единица частоты, которую можно установить и/или измерить, в Hz.

Source Frequency Time Base Accuracy Номинальная частота, точность по времени. Измерение с устойчивостью частоты анализатора, измеряемой в долях на миллион (ppm. или 1 доля в 10E6). Например, устойчивость в ±5.0 ppm означает, что анализатор будет измерять 1 MHz с точностью ±5 x 10-6 x 10E6 Hz = +5 Hz.

Source Frequency Time Base Stability Номинальная частота, устойчивость по времени. Измерение точности анализатора по времени и температуре. Обычно точность по времени указывается на 1 год. Обычная устойчивость частоты по времени составляет ±10 ppm для 250 C± 50 C.

Source Harmonics Номинальные гармоники. Уровень гармоник, генерируемых источником сигнала анализатора, в dBc от основной.

Source Match Согласование в источнике. Измерение степени близости импеданса сигнала источника к импедансу идеальной линии пропускания тестовой системы. Обычно согласование измеряется, как обратные потери или коэффициент стоячей волны (SWR) источника.

Span Интервал. Конечная частота минус стартовая частота. Установка интервала определяет масштаб горизонтальной оси на дисплее анализатора.

Span Accuracy Точность интервала. Погрешность разделения любых двух сигналов с указанной частотой на дисплее.

S-Parameters (Scattering Parameters) S-параметры (параметры рассеивания). Соглашение, используемое для характеризации способа, которым устройство модифицирует поток сигналов с помощью сетевого анализатора. Для устройства с двумя портами существует четыре S-параметра: прямое прохождение (S21), обратное прохождение (S12), прямое отражение (S11) и обратное отражение (S22).

Stop/Start Frequency Конечная/Стартовая частота. Термины, используемые в связи с конечной и стартовой точками диапазона измерения частоты. Совместно они определяют интервал диапазона измерения.

Storage States Режимы хранения. Количество настроек, программ, графиков и других параметров, которые можно сохранить, каталогизировать и вызвать в любой момент времени.

Storage, Disk Хранение, диск. Внутренний или внешний цифровой диск для хранения тестовых данных, настроек прибора, программ IBASIC и других параметров измерения. К форматам хранения относятся MS-DOS (R) и стандарт LIF для НР с форматами данных двоичным, PCX, HP-GL или ASCII.

Structural Return Loss Структурные обратные потери. Слабые обратные потери в кабеле, связанные с периодическим дефектом, например, с периодическим пиком из-за неисправности кабельной катушки или дефекта намотки кабеля при производстве.

Supplemental Characteristics Дополнительные характеристики. Типичные, но не гарантированные рабочие характеристики, обозначаются, как "типичная", "номинальная" или "приблизительная".

Sweep Свипирование. Способность источника обеспечивать заданный уровень сигнала в заданном частотном диапазоне и в заданный период времени. Смотрите также Режим свипирования и Тип свипирования.

В режиме обработки данных - ряд последовательный измерений в точках ввода данных по заданной последовательности значений входного сигнала.

Sweep Mode Режим свипирования. Способ запуска или выбора свипирования, например, единичный, непрерывный, альтернативный или прерывистый.

Sweep Type Тип свипирования. Метод свипирования источника, например, линейный, логарифмический или с шагом частоты.

Sweeper Свипировщик. Источник сигнала, выходной сигнал которого постоянно изменяется по частоте.

SWR Коэффициент стоячей волны, рассчитывается, как (1 + p) / (1 -p) где p - коэффициент отражения.

Sync Синхронизация или синхронизированный

Syntax Синтаксис. Грамматические правила, определяющие способ структуризации команд операционной системы, языка программирования или приложений.

System Dynamic Range Динамический диапазон системы. Разность между максимальный уровнем входного сигнала приемника и уровнем шума приемника. Динамический диапазон системы применяется только к измерениям при прохождении, поскольку измерения отражения ограничиваются направленностью.

T

T/R Смотрите Прохождение/Отражение.

Termination Оконечная нагрузка. Нагрузка, подключенная к линии пропускания или другому устройству.

Test Limit Предельное условие испытаний. Допустимые результирующие уровни для любого заданного измерения.

Test Port Тестовый порт. Смотрите Порт.

Test Set Тестовый комплект. Набор аппаратуры (переключатели, ответвители, разъемы и кабеля) которые соединяют ввод и вывод тестируемого устройства с источником сетевого анализатора и приемника для проведения измерений по s-параметрам.

Third Order Intercept Перехват третьего уровня (TOI): Ввод мощности в нелинейное устройство, вызывающий искажение третьего порядка при том же уровне мощности. TOI - это измерение для определения характеристик искажения преобразователя или приемника. Чем выше значение, тем более устойчив приемник к внутреннему искажению.

Thru Линия Through: Калибровочная мера. Смотрите Калибровка, SOLT.

Tint Тон. Оттенок цвета.

Toggle Переключение. Для переключения состояний, обычно используется для переключения функции из состояния вкл в выкл и наоборот.

TOM Thru-Open-Match: Термин Rohde&Schwarz для описания метода калибровки.

Trace График. Ряд точек данных с информацией по частоте и характеристике. Часто ряд точек называют массивом. Количество графиков определяется прибором.

Tracking Слежение. Способность приемника анализатора настраиваться на номинальную частоту по частотному диапазону измерений. Неудовлетворительные результаты слежения по амплитуде и фазе возникают в связи с ослаблением контуров ПЧ приемника и задержке выходного сигнала тестируемого устройства.

Transfer Function Функция преобразования. Отношение выходного сигнала к входному сигналу, оба, как функция от частоты.

Transmission Пропускание. Смотрите Измерения пропускания.

Transmission Intermodulation Spurious Взаимная модуляция пропускания, паразитная. Измерение способности передатчика подавлять генерирование взаимного искажения. Иногда паразитную взаимную модуляцию называют ослаблением взаимной модуляции.

Измерения пропускания. Характеризация функции преобразования устройства, отношение выходного сигнала к входящему сигналу. Чаще всего измеряется усиление, вносимая потеря, коэффициент пропускания, фаза вставки и групповая задержка; все параметры измеряются по частоте. Смотрите также S-параметры.

Transmission/Reflection (T/R) Пропускание/Отражение. Касается набора измерений, выполняемых скалярным или векторным сетевым анализатором для характеризации поведения устройства по частоте. Смотрите также S-параметры.

Transparent Прозрачный. Нечто, невидимое пользователю. Как правило, это процедура, незаметная для пользователя.

Trigger Триггер. Сигнал, который побуждает прибор выполнять измерение. Для запуска пользователь может выбрать несколько опций, например, управление вручную, непрерывная работа или внешний запуск (для синхронизации измерений с внешним источником).

TRL Through-Reflect-Line. Смотрите Калибровка, TRL и LRM.

TTL Транзистор-транзистор логика

Two-Port Error Correction 2-портовая коррекция погрешности. Смотрите Коррекция погрешности, 12-компонент.

U

Uncorrected Неисправленные. Измерения, выполненные без коррекции погрешности.

Uncoupled Channels Несвязанные каналы. Настройки входного сигнала или приемника дают возможность независимой настройки каждого канала.

UNI Интерфейс пользователь - сеть: Точка, в которой пользователи подключены к сети.

Units Единицы. Размерности измеряемых величин. Как правило, единицы касаются величин амплитуды, поскольку они могут меняться. Для анализаторов с микропроцессорами возможные единицы это: dBm (dB относительно 1 mW, рассеянного в номинальном входном импедансе), dBmV (dB относительно 1 mV), dBW (dB относительно 1 1W), V (вольты), W (ватты).

V

Variable Переменная. Символ, значение которого меняется от одной итерации программы к другой, или в пределах каждой итерации программы.

Vector Вектор. Величина, у которой есть как амплитуда, так и фаза.

Сетевой анализатор способен измерять и амплитуду, и фазу.

VEE Система визуального программирования инженерных задач (программное обеспечение Agilent)

Velocity Factor Коэффициент усиления по скорости. Числовое значение, относящееся к скорости перемещения энергии по линиям пропускания с различными диэлектриками (.66 для полиэтилена). Используется для измерений по временному интервалу.

Vertical Resolution Вертикальное разрешение. Степень, до которой прибор может различать амплитуду между двумя сигналами.

Video Видео. Электрический сигнал, содержащий временную информации, интенсивность и цветовую информацию, которые при отображении дают визуальное изображение.

Video Bandwidth Полоса пропускания видео. Для спектроанализаторов - частота отсечки (точка 3 dB) регулируемого фильтра нижних частот в видео контуре. Если полоса пропускания видео меньше или равна разрешению полосы пропускания, видео контур не может в полной степени реагировать на более быстрые изменения выходного сигнала амплитудного детектора. В результате при просмотре в широкополосном режиме график сглаживается, либо уменьшается отклонение между пиками широкополосных сигналов, например, шума и импульсной РЧ. Степень усреднения или сглаживания - это функция от отношения полосы пропускания видео к разрешению полосы пропускания.

Video Filter Видео фильтр. Для спектроанализаторов - фильтр нижних частот после детектирования, определяющий полосу пропускания видео усилителя. Применяется для усреднения или сглаживания графика. Также смотрите Полоса пропускания видео.

VNA Векторный сетевой анализатор

W

Waveform Форма сигнала. Графическое представление амплитуды сигнала во времени.

Wireless Беспроводный. Термин, относящийся к различным технологиям, предоставляющим возможность офисной или домашней мобильной связи; "беспроводный в здании" - для расширенной мобильности в рабочей зоне, на территории или деловом комплексе. Кроме того, термин используют в значении "сотовый" относительно внешних или внутренних услуг мобильной связи.

WWW Всемирная паутина

X

Y

Z

Zero-Length Through Path Сквозной проводник нулевой длины. При калибровке измерений - прямое соединение двух тестовых кабелей без использования адаптеров или сквозной линии. Смотрите также Не вставляемые устройства.


Home

ВАЖНЫЕ ЗАМЕЧАНИЯ О ЖЕСТКОМ ДИСКЕ

История версий | Обслуживание / Спецификации
Сдвиг частоты | Подключение PNA
Импульсные измерения / Доступ к ПЧ | Использование справки


Измерения со сдвигом частоты

Для измерений со сдвигом частоты необходим источник PNA, который настраивается на частоту, отличную от частоты приемника PNA. Эта возможность предлагается в виде опции для некоторых моделей PNA.

Для просмотра опций, установленных на Вашем PNA, нажмите Help, и затем About Network Analyzer

  • Сдвиг частоты (Frequency Offset) (Опция 080) - Позволяет производить базовые измерения с преобразованием частоты.

  • Приложение Преобразователь частоты (Frequency Converter Application - FCA) (Опция 083) - Позволяет с легкостью выполнять очень точные измерения модуля и фазы с преобразованием частоты. См. известные применения.

  • Учебные материалы - Измерения определенных характеристик устройств с преобразователями частоты


3.5" привод дискеты

Возврат к передней панели

Для установки файлов на жесткий диск анализатора и сохранения файлов с данными из нализатора. Доступ к файлам на дискете - из Проводника Windows.

  • Емкость неформатированной дискеты: 2MB
  • Совместимость: High Density (2HD), и Normal Density (2DD)
  • Скорость передачи данных: 500 кбит/с


Разместить

Кнопка Arrange (Разместить)

Дает возможность выбора четырех положений окна: Наложение, Набор 2, Разбиение 3, Квадрант 4.

Подробнее о размещении на дисплее


Average

Кнопка Average (Среднее)

Дает возможность усреднить измерения, что снижает шум. Анализатор выполняет экспоненциальное усреднения указанного ряда свипирований.

Подробнее об усреднении


Кнопка Cal (Калибровка)

Кнопка Calibration (Калибровка)

Запускает калибровку измерения. При нажатии Menu/Dialog, Cal появляется Помощник по калибровке (Calibration Wizard). В ином случае после нажатия кнопки Cal появляется панель активного ввода.

Подробнее о калибровке


Кнопка Cancel (Отмена)

Закрывает диалоговое окно.


Кнопка Channel (Канал)

Дает возможность выбирать активный канал или удалять канал. Для изменения настроек канала он должен быть активным.

Подробнее о каналах


Chnl Set

Кнопки настройки канала (Channel Setup)

Возврат к передней панели

Щелкните на кнопке, чтобы узнать ее функцию:

Эти кнопки позволяют:

  • Сконфигурировать канал с различными настройками стимула.

  • Произвести калибровку измерений.

Подробнее о каналах


Кнопки команд

Возврат к передней панели

Щелкните на кнопке, чтобы узнать ее функцию:

Эти кнопки позволяют:

  • Вывести команды в диалоговое окно.

  • Отобразить меню или диалоговые окна.

  • Запустить справку анализатора.


Decimal Pop

Кнопка десятичной точки

Ввод десятичной точки для выделения дробной части числа.


Кнопки отображения (Display)

Возврат к передней панели

Щелкните на кнопке, чтобы узнать ее функцию:

Эти кнопки позволяют:

  • Управлять и создавать графики и окна.
  • Быстро сконфигурировать набор измерений.
  • Оформить отображение текущих измерений.

Подробнее об экране


Кнопка Enter (Ввод)

Ввод значений, выбранных для настроек измерения.


Кнопки ввода (Entry Keys)

Возврат к передней панели

Щелкните на кнопке, чтобы узнать ее функцию:

Эти кнопки позволяют ввести значения настроек измерения.


Кнопка Format (Формат)

Дает возможность выбрать формат, используемый анализатором для отображения данных измерений.

Подробнее о форматах данных


Перемычки передней панели

  • PNA с конфигурируемым измерительным пультом (Configurable Test Set)

  • Стандартный PNA, E835xA

Что такое конфигурируемый измерительный пульт?

Примечание: На стандартных анализаторах, кроме E835xA и N5250A, не установлены перемычки передней панели.

Перемычки передней панели для PNA с конфигурируемым измерительным пультом

Схемы конфигурации и характеристики:

  • E835xA, опция 015

  • E880xA, опция 014

  • N338xA, опция 014

  • E8361A опция 014

  • E8362A/B, 63A/B, 64A/B опция 014

  • N5230A, опция 225, или 425, или 525

  • N5250A (характеристики не доступны)

Используйте перемычки передней панели PNA с конфигурируемым измерительным пультом в следующих целях.

    • Тестирование устройств большой мощности путем добавления собственных внешних компонентов к пути измерения.
    • Конфигурирование пути прохождения сигнала для получения динамического диапазона до 143 дБ на измерительном порту с полной 12-портовой корректировкой погрешности. Для этого примените режим сегментированного свипирования и просто измените направление ответвителя для увеличенния динамического диапазона с помощью перемычек передней панели.

Перемычки передней панели на стандартном PNA E835xA

Схемы конфигурации и характеристики:

  • E835xA

Используйте стандартные перемычки передней панели E835xA для следующего:

    • Тестирование устройств большой мощности путем добавления собственных внешних компонент к пути измерения.
    • Обойдите ответвители измерительного порта и подайте сигналы на приемники напрямую, чтобы получить лучшее соотношение сигнал-шум. Калибровкой частотной неравномерности с помощью режима сегментированного свипирования получите динамический диапазон до 143 дБ.

За дополнительной информацией о перемычках передней панели обращайтесь к:

    • Измерения для усилителя большой мощности
    • Измерения динамического диапазона
    • Опции анализатора
    • Произвольное соотношение


Кнопка Help (Справка)

Запускает справку для анализатора (встроенная документация).


Перемычки

Кабели-перемычки передней панели

Возврат к передней панели

Эти коннекторы предоставляют прямой доступ к источнику и приемникам анализатора PNA. Это позволяет производить измерения при большой мощности и увеличивать динамический диапазон. Перемычки на передней панели являются ОПЦИОНАЛЬНЫМИ; не все PNA имеют эту функциональность.

Узнайте о перемычках ВАШЕГО анализатора PNA.


Limit (Ограничения)

Кнопка Limit Table (Таблица границ)

Отображает таблицу границ для создания теста годен / не годен на основе этих ограничительных сегментов.


Кнопка Макрос

Кнопка Макрос / Локальный режим

Если анализатор работает в автоматическом режиме, нажатие этой кнопки дает возможность анализатору реагировать на нажатия кнопок передней панели.

Если анализатор работает в обычном режиме, нажатие этой кнопки открывает доступ к набору макросов пользователя в виде исполняемых файлов. Можно назвать и сохранить до 12 макросов. Если повторно нажимать эту кнопку, в панели активного ввода будут появляться по три или четыре заголовка макросов.

Примечание: Для запуска исполняемых файлов из набора макросов на жестком диске анализатора должно быть установлено соответствующее приложение.


Math Mem

Кнопка Math / Memory

Дает возможность выбирать функции математической обработки и памяти для работы анализатора с данными.


Meas

Кнопка Measure (Измерение)

Дает возможность выбрать измерение S-параметров. В диалоговом окне также можно выбрать произвольное соотношение или измерение абсолютной мощности.


Meas Set

Кнопка Measure Setups (Настройки измерения)

Дает возможность выбора из четырех предварительно сконфигурированных настроек измерения.


Menu Di

Кнопка Menu / Dialog (Меню/Диалог)

Дает возможность просматривать меню с помощью кнопок навигации. Также позволяет нажатием кнопки Menu/Dialog, а затем кнопки в блоках Channel (Канал), Trace (График) или Utility (Утилита) отображать диалоговые окна.


Min Max

Кнопка Restore Up/Down (Восстановить больше/меньше)

Открывает выбранное окно измерения в полном размере, затем восстанавливает предыдущий размер окна.

Восстанавливает окно приложения PNA, если оно минимизировано.


Mkr

Кнопка Marker (Маркер)

Дает возможность активировать маркер и установить его значение. Маркеры предоставляют числовые значения измеряемых данных.


Mkr Func

Кнопка Marker Function (Функция маркера)

Дает возможность менять настройки измерений на основе положения активного маркера. Если маркер не отображается, эта кнопка активирует маркер.


Mkr Sch

Кнопка Marker Search (Поиск маркера)

Обеспечивает доступ к функциям поиска маркера. Если маркер не отображается, эта кнопка активирует его.


Mkr Tbl

Кнопка Marker Table (Таблица маркеров)

Отображает таблицу значений, в которой можно просмотреть данные по всем маркерам активного графика.


navkeys2

Кнопки навигации

Возврат к передней панели

Щелкните на кнопке, чтобы узнать ее функцию:

Эти кнопки позволяют перемещаться по меню и диалоговым окнам и делать выбор из панели активного ввода (active entry toolbar).

Left / Right

Перемещает влево и вправо по меню

Перемещает влево и вправо по закладкам диалоговых окон

Up / Down

Перемещает вверх и вниз по меню

В диалоговом окне:

  • Изменяет цифровое значение

  • Перемещает по пунктам в выпадающем списке

  • Перемещает по кнопкам опций в группе кнопкок опций

Click

Делает выбор также как и щелчок мыши

F1...F4 Keys

Делает выбор из панели активного ввода. Цвет кнопки соответствет варианту на панели активного ввода. Подробнее о кнопках активного ввода.


Numeric

Цифровые кнопки

Выбор значений настроек измерения; затем для завершения выбора нажмите Enter или G/n или M/u.


Кнопка OK

Закрывает окно диалога и вводит значения, введенные в окне.


On

Кнопка включения питания

Возврат к передней панели

Переключает анализатор между состояниями Включено и Спящий режим.

  • В состоянии Включено кнопка зеленая.

  • В спящем режиме кнопка светится желто-оранжевым цветом.

  • Для выключения анализатора нажмите кнопку питания и прибор сохранит состояние всех запущенных программ и выключит питание.

  • При повторном нажатии кнопки прибор загрузит состояния, которые были сохранены при отключении питания.

Этот переключатель не не отключает источник питания.


PMB Pop

Кнопка Plus - Minus - Backspace (Плюс-минус-возврат)

  • Если это первая кнопка нажатая при записи - переключает между положительным и отрицательным значениями.

  • Возвращает курсор и удаляет предыдущее введенное значение.


Кнопка Power (Мощность)

Дает возможность указать уровень мощности источника.


Кнопка Preset

Кнопка Preset (Заданные значения)

Устанавливает предварительно заданные (по умолчанию) настройки анализатора.


Кнопка Print (Печать)

Включает функцию печати, дает возможность выбирать установки печати и принтера.


Питание пробников (Probe Pwr)

Возврат к передней панели

3-контактные штыревые разъемы обеспечивают питание для активных пробников.

  • Верхний контакт: Корпус

  • Левый контакт: +15 В пост. тока ±2%, 400 мА максимум; защищен PTC @0.5A

  • Правый контакт: –12.6 В пост. тока ±5%, 300 мА максимум; защищен PTC @0.5A

(PTC = медленно действующий, автоматически сбрасываемый предохранитель)


Кнопка Recall (Повторный вызов)

Дает возможность повторно вызывать файл, где находятся данные инструментального состояния, калибровки измерения и измерений.


RPG

Ручка на передней панели

При повороте активное значение увеличивается или уменьшается.


Кнопка Save (Сохранить)

Дает возможность сохранить инструментальное состояние, данные калибровки и измерений в файл.


Масштаб

Кнопка Scale (Масштаб)

Дает возможность указать значение, используемое анализатором для масштабирования отображаемого отклика измерения. Кроме того, можно установить анализатор на автоматическое масштабирование по оси Y для размещения полного графика на экране.


Экран

Возврат к передней панели

Щелкните по области, чтобы узнать ее функцию.

Экран имеет следующие характеристики:

  • Активный матричный (TFT), 8.4 дюймов, ЖКИ

  • Разрешение: 640 x 480

  • Частота кадров: 59.83 Гц

  • Частота строк: 31.41 кГц

  • Яркость: >250 NIT

Конфигурирование экрана


Stop Span

Кнопка Stop / Span (Стоп/Интервал)

Дает возможность ввода значения для прекращения измерения или измерения по диапазону.


Strt Cntr

Кнопка Start / Center (Старт/Центр)

Дает возможность ввода значения для начала или центрирования диапазона измерения.


Swp Set

Кнопка Sweep Setup (Настройка свипирования)

Дает возможность определить то, как источник анализатора подает входной сигнал на тестируемое устройство.


Swp Type

Кнопка Sweep Type (Тип свипирования)

Дает возможность выбрать способ свипирования источником анализатора, а также свойства, связанные со свипированием.


Измерительные порты

Возврат к передней панели

Перечень типов коннекторов измерительных портов смотрите в Конфигурации PNA.

Измерительные порты PNA внутренне переключаются между источником и приемником, что позволяет измерять устройство в обоих направлениях.

Для индикации портов источника и приемника применяются два способа подсветки:

Для моделей анализатора PNA 9 ГГц и меньше (представлены выше):

  • Зеленый свет обозначает порт источника.

  • Оранжевый свет обозначает порт приемника.

Все другие модели PNA:

  • Светящееся изображение возле измерительного порта обозначает источник.

Примечание: Следующие модели PNA имеют три измерительных порта: N3381A, N3382A, N3383A.

См. Уровни повреждения входа


Кнопка Trace (График)

При первом нажатии появляется панель инструментов активного графика. При следующих нажатиях можно перемещаться между графиками измерений в окне, при этом они становятся активными. Изменения можно выполнять только для активных функций. Кроме того, эта кнопка дает возможность создавать или удалять графики с помощью клавиш функций.


Кнопки настройки графика (Trace Setup)

Возврат к передней панели

Щелкните на кнопке, чтобы узнать ее функцию:

Эти кнопки позволяют:

  • Сконфигурировать тип измерения

  • Извлечь данные из результатов


Кнопка Trigger (Триггер)

Кнопка Trigger (Запуск)

Дает возможность указать как запускать свипирование.


Кнопка Units (Единицы)

Завершает выбор значения назначением единицы измерения. Затем нажмите Enter для завершения ввода значения.


USB

Разъем USB

Возврат к передней панели

Этот разъем универсальной последовательной шины (USB) позволяет подключить клавиатуру, мышь, модуль ECAL или другие устройства USB.

  • Контакт 1: Vcc; от 4.75 до 5.25 В пост. тока, максимум 500 мА.
    Защищен автоматически сбрасываемым предохранителем 1A.

  • Контакт 2: – Данные

  • Контакт 3: + Данные

  • Контакт 4: Корпус

См. ограничения USB.


Сервисные кнопки

Utility Keys (Сервисные кнопки)

Возврат к передней панели

Нажмите на кнопку, чтобы узнать ее функцию:

Эти кнопки позволяют:

  • Распечатать результаты измерений.

  • Сохранить или вызвать следующее:

    • Инструментальное состояние (состояние прибора)

    • Калибровки измерений

    • Данные измерений

  • Запустить макросы.

  • Изменять размер окна.

  • Предварительно настраивать анализатор.


Window pop

Кнопка Окно (Window)

При первом нажатии появляется панель Window Active Toolbar, в которой можно создавать, выбирать, и удалять окна, используя функциональные кнопки.

Поочередное нажатие этой кнопки приводит к последовательному переключению открытых окон, делая каждое окно поочередно активным. Изменять размеры можно только у активного окна. Также окно должно быть активным для переключения между графиками этого окна.


Обзор доступа к ПЧ

Обзор доступа к ПЧ (IF Acces)

  • Об опции H11

  • Приложение для импульсных измерений (Опция H08)

  • Конфигурация внешнего модуля миллиметровых волн

  • Команды SCPI

  • Команды COM

  • Проверка Опции H11

Внимание: Избегайте дорогостоящих ремонтных работ анализатора серии PNA. См. Защита от электростатического разряда.


Accessing Data

Click a box or circle to view details:

See 8510 data processing mode.

Measurement - PNA receivers gather complex trace data which is ratioed if required by the parameter, such as S11 or A/B. Otherwise it is raw receiver data, such as A or B. See Measurement Parameters.

Averaging - If turned ON, data is averaged with specified number of measurement traces. See Averaging.

Data Access Point 0 - Get or Put RAW MEASUREMENT data using:

SCPI - Calc:Data SDATA (Correction OFF) or Calc:RDATA

COM - getData and putDataComplex - naRawData (0)

See Formatting Note

Acquired Cal Data - Calibration standards are measured. When the calibration is complete, complex data is stored in a Cal Set.

Data Access Point 6 - Get or Put RAW CAL ACQUISITION data using:

SCPI - None

COM - getStandardComplex and putStandardComplex

Calculate Error Terms - Error terms are calculated from Acquisition data using formulas which are appropriate for the selected calibration method. Complex error terms are stored in a Cal Set. See Systematic Errors.

Data Access Point 7 - Get or Put ERROR TERM data using:

SCPI - Calc:Data Error Terms

COM - Error Term commands

Apply Error Terms - If error correction is ON, error terms are applied to the raw measurement data. Otherwise, this data is identical to Raw Measurement Data.

Data Access Point 1 - Get or Put CORRECTED data using:

SCPI - Calc:Data SDATA (Correction ON)

COM - getData and putDataComplex - naCorrectedData (1)

See Formatting Note

Normalization - If performing Receiver power correction, "Divisor" (Data Access Point 5) correction data is applied to the measurement. See Receiver power calibration

Data Access Point 5 - Get or Put DIVISOR (POWER CAL) data using:

SCPI - Calc:Data SDIV

COM - getData and putDataComplex - naDivisor (5)

See Formatting Note

Trace Math - If turned ON, memory data is combined with measurement data using the selected math function. Available functions are: Data+Mem, Data-Mem, Data*Mem, and Data/Mem. See Math Operations.

Memory - Data that is stored as a result of a Data-To-Memory operation. Each measurement can have one memory trace. The memory data parallels the measurement data through the remaining processing blocks. For example, turning smoothing ON will smooth both the measurement and memory traces.

Data Access Point 3 - Get or Put MEMORY data using:

SCPI - Calc:Data SMEM

COM - getData and putDataComplex - naRawMemory (3)

See Formatting Note

Gating - If turned ON, Filter Gating is applied to the measurement data. Gating "virtually" removes undesired responses from selected regions of the trace. See Gating.

Phase Correction - If turned ON, applies electrical delay, phase offset, and port extensions. These are all separate features that are controlled individually. See Phase Measurement Accuracy.

Magnitude Offset - If entered, offset values are applied to the magnitude (real) portion of the data. See Magnitude Offset.

Time Domain - If turned ON, transforms the data from the frequency domain to the time domain. See Time Domain

Formatter - Complex data is converted into scalar data formats for screen display and remote access. For smoothed data, request the data in the same format as the displayed data. See Data Format

Smoother - If turned ON, removes discontinuities in the measurement and memory trace. See Smoothing.

Display - Displays the processed measurement, memory data, or both, in the format of your choice.

Data Access Point 2 - Get or Put MEAS RESULT data using:

SCPI - Calc:Data FDATA

COM - getData and putDataComplex - naMeasResult (2)

Data Access Point 4 - Get or Put MEMORY RESULT data using:

SCPI - Calc:Data FMEM

COM - getData and putDataComplex - naMemoryResult (4)

Formatting Note:

COM - getData allows you to request data from locations 0 to 5 in a format other than the displayed format. SMOOTHED data is only attainable from locations 2 & 4, and only when you request data in the same format as the displayed format.

SCPI - you can only request data in the displayed format.


CFCal Topic

Guided | ECAL | Save-Recall | Cal Sets | Correction | Cal Kits | Standards | Power Cal | Cal Data
New See Calibrating the PNA Using SCPI

Perform an Unguided Calibration
Launch Cal Wizard | SYST:CORR:WIZard | app.LaunchCalWizard
Set Cal Type | SENS:CORR:COLL:METHod | cal.SetCalInfo
Select a Cal Kit | SENS:CORR:COLLect:CKIT | app.CalKitType
Get a Handle to the Active Cal Kit |  | app.ActiveCalKit
Simultaneous 2-Port Calibration | SENS:CORR:TSTandards | cal.Simultaneous2PortAcquisition
Acquisition Direction | SENS:CORR:SFORward | cal.AcquisitionDirection
Measure a Standard | SENS:CORR:COLLect | cal.AcquireCalStandard
Calculate Errors | SENS:CORR:COLL:SAVE | cal.CalculateErrorCoeffecients
Isolation ON|OFF | SENS:CORR:ISOLation | cal.AcquireCalStandard
Perform a Guided Cal
Initiate a Guided Cal | SENS:CORR:COLL:GUID:INIT | Initialize
List valid Connector Types for a Port | SENS:CORR:COLL:GUID:CONN:CAT? | ValidConnectorType
List valid Cal Kits for a Port | SENS:CORR:COLL:GUID:CKIT:PORT:CAT? | CompatibleCalKits
Select a Connector Type | SENS:CORR:COLL:GUID:CONN:PORT | ConnectorType
Select a Cal Kit | SENS:CORR:COLL:GUID:CKIT:PORT | CalKitType
Set Thru Method | SENS:CORR:COLL:GUID:METHod | ThruCalMethod
Set Thru Port Pairs | SENS:CORR:COLL:GUID:THRU:PORT | ThruPortList
Return Number of Steps in a Cal | SENS:CORR:COLL:GUID:STEPs? | GenerateSteps
Return a Description of a Cal Step | SENS:CORR:COLL:GUID:DESC? | GetStepDescription
Measure a Cal Standard in a Guided Cal | SENS:CORR:COLL:GUID:ACQuire | AcquireCalStandard2
Calculate Error Terms from a Guided Cal | SENS:CORR:COLL:GUID:SAVE | GenerateErrorTerms
Perform an ECAL
Specify Module and Characterization | SENS:CORR:COLL:ACQ | cal.ECALCharacterizationEx
Do ECAL 1-Port | SENS:CORR:COLL:CKIT 99 | cal.DoECAL1PortEx
Do ECAL 2-Port | SENS:CORR:COLL:CKIT 99 | cal.DoECAL2PortEx
Get ECAL Module Info | SENS:CORR:COLL:CKIT:INF? SENS:CORR:CKIT:ECAL:INF? | cal.GetECALModuleInfoEx
Get list of ECal Modules attached to PNA | SENS:CORR:CKIT:ECAL:LIST? | cal.ECALModuleNumberList
Get list of characterizations in ECal module | SENS:CORR:CKIT:ECAL:CLISt? | cal.ECALCharacterizationIndexList
Perform Module Orientation during calibration | SENS:CORR:PREF:ECAL:ORI | cal.OrientECALModule
Maps ECAL Module to PNA Ports | SENS:CORR:PREF:ECAL:PMAP | cal.ECALPortMapEx
Confidence Check Parameter | SENS:CORR:CCH:PAR | cal.AcquireCalConfidenceCheckECALEx
Confidence Check Acquire | SENS:CORR:CCHeck | cal.AcquireCalConfidenceCheckECALEx
Confidence Check Done | SENS:CORR:CCH:DONE | cal.DoneCalConfidenceCheckECAL
Set ECAL module state | CONT:ECAL:MOD:STATe |
Recall / Save / Apply a Calibration or Error Term
Recall a Calibration | SENS:CORR:CSET | app.Recall
Apply a Calibration to a measurement | SENS:CORR:CSET |
Save a Calibration | SENS:CORR:CSET:SAVE | app.Save
Save or Recall an Error Term | CALC:DATA Scorr | Data Topic
Apply an Error Term after Uploading | SENS:CORR:COLLect:APPLy |
Cal Sets
Create a Cal Set |  | calMgr.CreateCalSet
Delete a Cal Set | SENS:CORR:CSET:DEL | calMgr.DeleteCalSet
List Cal Sets | SENS:CORR:CSET:CAT? | calMgr.GetCalSetCatalog
Get Cal Set Information |  | calMgr.GetCalSetUsageInfo
Select a Cal Set by GUID | SENS:CORR:CSET:GUID | calMgr.GetCalSetByGUID
Select a Cal Set from a channel |  | channel.SelectCalSet
Copy a Cal Set |  | CalSet.Copy
Save a Cal Set |  | CalSet.Save
Save Cal Sets | SENS:CORR:CSET:SAVE | app.SaveCalSets
Change the Description of a Cal Set | SENS:CORR:CSET:DESC | CalSet.Description
Change the Contents of a Cal Set |  | calset object
Recall a Cal Set |  | app.Recall
Correction Settings
Turn Correction ON|OFF for a channel | SENS:CORR | None
Turn Correction ON|OFF for a measurement | CALC:CORR | meas.ErrorCORR
Catalog the correction types | SENS:CORR:TYPE:CAT? | calMgr.GetCalTypes
Set correction type (standard measurements) | CALC:CORR:TYPE | meas.CalibrationType
Set correction type (custom measurements) | CALC:CORR:TYPE | meas.CalibrationTypeID
Interpolation ON|OFF | SENS:CORR:INT | meas.InterpolateCorrection
Extensions ON|OFF | SENS:CORR:EXT | portExtension.State
Port 1 Extensions Value | SENS:CORR:EXT:PORT | portExt.Port1
Port 2 Extensions Value | SENS:CORR:EXT:PORT | portExt.Port2
Receiver A Extensions Value | SENS:CORR:EXT:REC | portExt.InputA
Receiver B Extensions Value | SENS:CORR:EXT:REC | portExt.InputB
Relative Velocity | SENS:CORR:RVEL:COAX | app.VelocityFactor
Manage and Modify Cal Kits
Set a Cal Kit Active | SENS:CORR:COLL:CKIT | app.CalKitType
Clear all Cal Kits from PNA | SENS:CORR:CKIT:CLE |
Get a Handle to the Active Cal Kit |  | app.ActiveCalKit
Save All Cal Kits after Modifying |  | app.SaveKits
Load collection of Kits | SENS:CORR:CKIT:LOAD |
Load (Recall) All Cal Kits |  | app.RecallKits
Import a specified kit. | SENS:CORR:CKIT:IMPort |
Restore Cal Kit Default | SENS:CORR:COLL:CKIT:RESet | app.RestoreCalKitDefaults
Restore ALL Cal Kits Default | SENS:CORR:CKIT:INITialize | app.RestoreCalKitDefaultsAll
Build a Hybrid Cal Kit |  | app.BuildHybridKit
Set the Name of a Cal Kit | SENS:CORR:COLL:CKIT:NAME | calKit.Name
Set a description of a Cal Kit | SENS:CORR:COLL:CKIT:DESC |
Get the amount of installed kits | SENS:CORR:CKIT:COUNt? |
Set the Port Label of a Cal Kit |  | calKit.Portlabel
Modify Cal Standards
Select a Cal Standard | SENS:CORR:COLL:CKIT:STAN | calkit.GetCalStandard
Delete a standard | SENS:CORR:COLL:CKIT:STAN:REM |
Change description of a standard | SENS:CORR:COLL:CKIT:STAN:SDES |
Assign a Class to a Standard | SENS:CORR:COLL:CKIT:ORD1 | calKit.StandardForClass
Set Standard Type | SENS:CORR:COLL:CKIT:STAN:TYPE | calstd.Type
Add connector family name | SENS:CORR:COLL:CKIT:CONN:ADD |
Delete connector family name | SENS:CORR:COLL:CKIT:CONN:DEL |
List connector family names used in a Cal Kit | SENS:CORR:COLL:CKIT:CONN:CAT? |
Replace connector family name. | SENS:CORR:COLL:CKIT:CONN:FNAM |
Assign connector family name to a standard | SENS:CORR:COLL:CKIT:CONN:SNAMe |
Set Delay | SENS:CORR:COLL:CKIT:STAN:DEL | calstd.Delay
Set Loss | SENS:CORR:COLL:CKIT:STAN:LOSS | calstd.loss
Set Impedance | SENS:CORR:COLL:CKIT:STAN:IMP | calstd.Z0
Set Max Frequency | SENS:CORR:COLL:CKIT:STAN:FMAX | calstd.MaximumFrequency
Set Min Frequency | SENS:CORR:COLL:CKIT:STAN:FMIN | calstd.MinimumFrequency
Set Label | SENS:CORR:COLL:CKIT:STAN:LAB | calstd.Label
Set Medium (coax | waveguide) | SENS:CORR:COLL:CKIT:STAN:CHAR | calstd.Medium
Set Capacitance (C0 to C3) | SENS:CORR:COLL:CKIT:STAN:C0 | calstd.C0
Set Inductance (L0 to L3) | SENS:CORR:COLL:CKIT:STAN:L0 | calstd.L0
Set Arbitrary Impedance (TZReal, TZImag) | SENS:CORR:COLL:CKIT:STAN:TZReal | calstd.TZReal
TRL reference Plane | SENS:CORR:COLL:CKIT:TRL:RPL |
TRL Impedance | SENS:CORR:COLL:CKIT:TRL:IMP |
Source Power Calibration
GPIB Power Meter Address | SYST:COMM:GPIB:PMET:ADDR | pwrCal.PowerMeterGPIBAddress
Set source power cal method | SOUR:POW:CORR:COLL:METH | SetCalInfo2 Method
Turn correction ON|OFF | SOUR:POW:CORR | SourcePowerCorrection
Applies correction values after completing a source power cal acquisition sweep. | SOUR:POW:CORR:COLL:SAVE | ApplyPowerCorrectionValues
Returns the currently selected power sensor channel (A or B) for use at a specific frequency. |  | PowerAcquisitionDevice
Set power level | SOUR:POW:CORR:LEV | CalPower
Set power offset | SOUR:POW:CORR:OFFS | SourcePowerCalPowerOffset
Set settling tolerance | SOUR:POW:CORR:COLL:AVER:NTOL | ReadingsTolerance
Set max readings for settling | SOUR:POW:CORR:COLL:AVER:COUNt | ReadingsPerPoint
Set accuracy tolerance | SOUR:POW:CORR:COLL:ITER:NTOL | IterationsTolerance
Set max readings for accuracy | SOUR:POW:CORR:COLL:ITER:COUNt | MaximumIterationsPerPoint
Turn ON|OFF display of readings | SOUR:POW:CORR:COLL:DISP | SetCalInfo2 Method
Initiates a source power cal acquisition. | SOUR:POW:CORR:COLL:ACQ | AcquirePowerReadings
Aborts a source power cal acquisition sweep that is currently in progress. | SOUR:POW:CORR:COLL:ABOR | AbortPowerAcquisition
Launches the Power Meter Settings dialog on the PNA. |  | LaunchPowerMeterSettingsDialog
Frequency checking (ON|OFF) | SOUR:POW:CORR:COLL:FCH | UsePowerSensorFrequencyLimits
Check test port power |  | CheckPower
Power Sensor
Minimum Frequency | SOUR:POW:CORR:COLL:<>SEN | MinimumFrequency
Maximum Frequency | SOUR:POW:CORR:COLL:<>SEN | MaximiumFrequency
Power meter channel |  | PowerMeterChannel
Set sensor cal factor | SOUR:POW:CORR:COLL:<>SEN:RCF | ReferenceCalFactor
Set table type | SOUR:POW:CORR:COLL:TABL <>SEN |
Read/Write cal data | SOUR:POW:CORR:DATA | See Data
Use Loss table? | SOUR:POW:CORR:COLL:TABL:LOSS | UsePowerLossSegments
Cal Factor Table | SOUR:POW:CORR:COLL:TABL:SEL | CalFactorSegments Collection
Read number of segments in table | SOUR:POW:CORR:COLL:TABL:POIN? | Count
Segment number |  | SegmentNumber
Add segment |  | Add
Cal factor of the segment | SOUR:POW:CORR:COLL:TABL:DATA | CalFactor
Frequency of the segment | SOUR:POW:CORR:COLL:TABL:FREQ | Frequency
Power Loss Table | SOUR:POW:CORR:COLL:TABL:SEL | PowerLossSegments Collection
Read number of segments in table | SOUR:POW:CORR:COLL:TABL:POIN? | Count
Segment number |  | SegmentNumber
Add segment |  | Add
Frequency | SOUR:POW:CORR:COLL:TABL:FREQ | Frequency
Loss value | SOUR:POW:CORR:COLL:TABL:DATA | Loss
Receiver Power Cal
Set offset from test port power | CALC:CORR:OFFS:MAGN | LogMagnitudeOffset
Do normalization | CALC:NORM:IMM | DataToDivisor
Turn normalization ON | OFF | CALC:NORMALIZE | Normalization
Do interpolation | CALC:NORM:INT | InterpolateNormalization
Retrieve and Put Calibration Data
Retrieve Cal Data from the PNA | CALC:DATA scorr? or SDIV? | see Data Topic
Put Cal Data in the PNA | CALC:DATA scorr or SDIV | see Data Topic


CFBanner

File | View | Chan | Sweep | Cal | Trace | Scale | Marker | System | Mixer | Data
Description |  |  |  | SCPI |  |  |  | COM


CFChanTopic

Channel Preset | none - See SYST:PRES | app.Preset
Start Freq | SENS:FREQ:STAR | chan.StartFrequency
Stop Freq | SENS:FREQ:STOP | chan.StopFrequency
Center Freq | SENS:FREQ:CENT | chan.CenterFrequency
Span | SENS:FREQ:SPAN | chan.FrequencySpan
CW Frequency | SENS:FREQ:CW | chan.CWFrequency
Power Settings
Power ON | OFF | OUTP | app.SourcePowerState
Power Value | SOUR:POW1 | chan.TestPortPower
Port Selection | SENS:SWE:SRCP | chan.TestPortPower
Couple Ports OFF | ON | SOUR:POW:COUP | chan.CouplePorts
Attenuator Mode Auto|Manual | SOUR:POW:ATT:Auto | chan.Attenuator
Attenuation Value | SOUR:POW:ATT | chan.AttenuatorMode
Power Slope ON | OFF | SOUR:POW:SLOP:STAT |
Power Slope Value | SOUR:POW:SLOP | app.PowerSlope
Receiver Attenuation | SENS:POW:ATT | chan.ReceiverAttenuator
Averaging
Average ON|OFF | SENS:AVER | chan.Average
Average Factor | SENS:AVER:COUN | chan.AveragingFactor
Return the Average Count |  | chan.AveragingCount
Average Restart | SENS:AVER:CLE | chan.AveragingRestart
Frequency Offset
Offset mode ON | OFF | SENS:OFFS:STAT | chan.FrequencyOffsetState
Offset Frequency | SENS:OFFS:OFFS | chan.FrequencyOffsetFrequency
Read Offset Start Frequency | SENS:OFFS:STAR? |
Read Offset Stop Frequency | SENS:OFFS:STOP? |
Set Offset Multiplier | SENS:OFFS:MULT | chan.FrequencyOffsetMultiplier
Set Offset Divisor | SENS:OFFS:DIV | chan.FrequencyOffsetDivisor
Set CW Override | SENS:OFFS:CW | chan.FrequencyOffsetCWOverride
Test Set Switch | ROUT:PATH:LOOP:R1 | chan.R1InputPath
Manage Channels
Add |  | chans.Add
Make Active |  | app.ActiveChannel
Read Channel Number |  | chan.ChannelNumber
Read UNUSED channel numbers |  | chans.UnusedChannelNumbers
Read used channel numbers |  | chans.UsedChannelNumbers
Read Number of Channels |  | chans.Count
Set up a copy of the Channel |  | chan.CopyToChannel
IF Access
Set gain state (Auto | Manual) | SENS:IF:GAIN:ALL | chan.IFGainMode
Set gain level | SENS:IF:GAIN:LEVel | chan.IFGainLevel
Read gain level | SENS:IF:GAIN? | chan.IFGainLevel
Filter taps count | SENS:IF:FILT:SAMP:COUN | IFFilterSampleCount
Filter tap mode (Auto/Manual) | SENS:IF:FILT:SAMP:COUN:MODE | IFFilterSource
IF filter sample period | SENS:IF:FILT:SAMP:PERiod | IFFilterSamplePeriod
List valid sample periods | SENS:IF:FILT:SAMP:PER:CAT | IFFilterSamplePeriodList
Sample period mode (Auto/Manual) | SENS:IF:FILT:SAMP:PER:MOD | IFFilterSamplePeriodMode
IF gate state (ON / OFF) | SENS:IF:GATE:STATe | IFGateEnable
Set IF source path | SENS:IF:SOUR:PATH | chan.IFSourcePath


Data Access Map

 Raw Measurement Data Standard Acquisition Data Calibration Error Terms Memory Error Correction Trace Math Filter Gating Display Formatting Data Smoothing Display


CFData Topic

See a map of the data access locations

Get X-Axis values (variant) | SENS:X:VAL | Get X-axis Values
Get X-Axis values (typed) |  | Get X-Axis Values 2
Get X-Axis values (Meas object) |  | Get XAxisValues
Get Measurement Data FROM the Analyzer
Get complex data from the specified location. |  | IArrayTrans.getComplex
Get typed NAComplex data from the specified location. |  | IArrayTrans.getNAComplex
Get data pairs from the specified location. |  | IArrayTrans.getPairedData
Get scalar data from the specified location. |  | IArrayTrans.getScalar
Get variant data from the specified location in a SPECIFIED FORMAT. |  | meas.GetData
Specifies ASCII or REAL type for data transfers | Format:Data |
Get complex or formatted data from the measurement or memory result buffer | Calc:Data |
Get SnP data | Calc:Data:SnP | meas.GetSnPData
Put Measurement Data INTO the Analyzer
Put complex data into the specified location. |  | IArrayTrans.putComplex
Put typed NAComplex data into the specified location. |  | IArrayTrans.putNAComplex
Put scalar data into the measurement result location. |  | IArrayTrans.putScalar
Put complex Variant data into the specified location. |  | IArrayTrans.putDataComplex
Put complex or formatted data into the measurement or memory result buffer | Calc:Data |
Get Calibration Data FROM the Analyzer
Get complex Error Term data |  | ICalData.GetErrorTermComplex
Get variant Error Term data | Calc:Data? | CalSet.getErrorTerm
Get complex Standard data |  | ICalData2.getStandardComplex
Get variant Standard data |  | CalSet.getStandard
Put Calibration Data INTO the Analyzer
Put complex Error Term data |  | ICalData.putErrorTermComplex
Put variant Error Term data | Calc:Data | CalSet.putErrorTerm
Put complex Standard data |  | ICalData2.putStandardComplex
Put variant Standard data |  | CalSet.putStandard
Power Calibration Data
Get variant cal data | SOUR:POW:CORR:DATA | Get SourcePowerCalDataEx
Get typed cal data | SOUR:POW:CORR:DATA | Get SourcePowerCalDataScalarEx
Put variant cal data | SOUR:POW:CORR:DATA | Put SourcePowerCalDataEx
Put typed cal data | SOUR:POW:CORR:DATA | Put SourcePowerCalDataScalarEx
Get and Put Custom Measurement Data
Get and Put Custom data | Calc:Data | IArrayTransfer2 Interface


CFFile Topic

Save Instrument States (.cst, .sta, .cal) and .SnP files | MMEMory:STORe | app.Save
Read SnP data | CALC:DATA:SnP | meas.Get SnPData
Recall Files | MMEMory:LOAD | app.recall
Sets format for .SnP files | MMEM:STOR:TRAC:FORM:SNP | pref.SnPFormat
Saves formatted trace data to .cti file | MMEM:STOR:CITI:FORM | app.SaveCitiFormattedData
Saves unformatted trace data to .cti file | MMEM:STOR:CITI:DATA | app.SaveCitiDataData
Sets format for .cti files | MMEM:STOR:TRAC:FORM:CIT | pref.CitiContents
Sets content for .cti files | MMEM:STOR:TRAC:CONT:CIT | pref.CitiFormat
Read / Write data from / to an external controller | MMEMory:TRANsfer |
Manage Files
List Files | MMEMory:CATalog |
Copy Files | MMEMory:COPY |
Move Files | MMEMory:MOVE |
Delete Files | MMEMory:DELete |
Manage Folders
Change | MMEMory:CDIRectory |
Delete | MMEMory:RDIRectory |
Make | MMEMory:MDIRectory |
Print
Print | HCOPy | app.DoPrint
Print to File | HCOPy:FILE | app.PrintToFile


CFMarker Topic

ON|OFF | CALC:MARK | meas.MarkerState
Delete All Markers | CALC:MARK:AOFF | meas.DeleteAllMarkers
Delete Marker |  | meas.DeleteMarker
Viewing Marker readouts | View Topic | View Topic
Interpolate All Markers |  | meas.Interpolate
Interpolate Individ. Marker | CALC:MARK:DISC | mark.Interpolated
Type (Normal | Fixed) | CALC:MARK:TYPE | mark.Type
Format All Markers |  | meas.MarkerFormat
Format Individ. Marker | CALC:MARK:FORM | mark.Format
Get a handle to Ref marker |  | meas.GetReferenceMarker
Reference Marker On | Off | CALC:MARK:REF | meas.ReferenceMarkerState
Coupled Markers | CALC:MARK:COUP | app.CoupledMarkers
Delta Marker | CALC:MARK:DELT | mark.DeltaMarker
Read/Set Data Point number |  | mark.BucketNumber
Read/Set X-axis value | CALC:MARK:X | mark.Stimulus
Read/Set Y-axis value | CALC:MARK:Y | mark.Value
Function
Marker=> Center, Span, and so forth | CALC:MARK:SET |
Marker=> Center (Freq) |  | mark.SetCenter
Marker=> CW Freq |  | mark.SetCW
Marker=> Start (Freq) |  | mark.SetStart
Marker=> Stop (Freq) |  | mark.SetStop
Marker=> Elect. Delay |  | mark.SetElectricalDelay
Marker=> Ref. Level |  | mark.SetReferenceLevel
Search
Execute Search | CALC:MARK:FUNC:EXEC |
Select Search Function | CALC:MARK:FUNC |
Maximum | CALC:MARK:FUNC | mark.SearchMax
Minimum | CALC:MARK:FUNC | mark.SearchMin
Target (Value) | CALC:MARK:TARG | mark.TargetValue
Excursion Value | CALC:MARK:FUNC:APE:EXC | mark.PeakExcursion
Threshold Value | CALC:MARK:FUNC:APE:THR | mark.PeakThreshold
Assign Marker to Domain | CALC:MARK:FUNC:DOM:USER | mark.UserRange
Domain Range Start | CALC:MARK:FUNC:DOM:USER:START | mark.UserRangeMin
Domain Range Stop | CALC:MARK:FUNC:DOM:USER:STOP | mark.UserRangeMax
Tracking | CALC:MARK:FUNC:TRAC | mark.Tracking
Bandwidth (Target) | CALC:MARK:TARG | meas.BandwidthTarget
Search Filter Bandwidth | CALC:MARK:BWID | meas.SearchFilterBandwidth
Read Filter BandWidth | CALC:MARK:BWID | meas.FilterBW
Read Filter Center Freq | CALC:MARK:BWID | meas.FilterCF
Read Filter Loss | CALC:MARK:BWID | meas.FilterLoss
Read Filter Q | CALC:MARK:BWID | meas.FilterQ


CFMixer Topic

For Frequency Offset (opt 080) commands see Chan / Offset

Create or Load a Mixer Measurement (See SCPI and COM examples)
Create a custom measurement | CALC:CUST:DEF | App.CreateCustomMeasurementEx
Change a custom measurement | CALC:CUST:MOD |
Load a .mxr file | SENS:MIX:LOAD | LoadFile
Save a .mxr file | SENS:MIX:SAVE | SaveFile
Configure a Mixer Measurement
Calculate Input and Output frequencies | SENS:MIX:CALC | Calculate
Avoid Spurs | SENS:MIX:AVOidspurs | AvoidSpurs
X-axis display | CALC:MIX:XAXis | ActiveXAxisRange
Apply mixer settings | SENS:MIX:APPLy | Apply
Number of Stages (1 or 2) | SENS:MIX:STAG | LOStage
Set Input
Input start frequency | SENS:MIX:INP:FREQ:STAR | InputStartFrequency
Input stop frequency | SENS:MIX:INP:FREQ:STOP | InputStopFrequency
Input power level | SENS:MIX:INP:POW | InputPower
Numerator - Input Frac.Mult | SENS:MIX:INP:FREQ:NUM | InputNumerator
Denominator - Input Frac.Mult | SENS:MIX:INP:FREQ:DEN | InputDenominator
Toggles Nominal Incident Power (SMC Measurements) ON and OFF. | CALC:MIX:INP:POW:USEN | NominalIncidentPowerState
Set LO
LO name | SENS:MIX:LO:NAME | LOName
LO sweep mode (fixed or swept) | SENS:MIX:LO:FREQ:MODE | LORangeMode
LO fixed frequency | SENS:MIX:LO:FREQ:FIX | LOFixedFrequency
LO start frequency | SENS:MIX:LO:FREQ:STARt | LOStartFrequency
LO stop frequency | SENS:MIX:LO:FREQ:STOP | LOStopFrequency
LO power | SENS:MIX:LO:POW | LOPower
Numerator - LO Frac.Mult | SENS:MIX:LO:FREQ:NUM | LONumerator
Denominator - LO Frac.Mult | SENS:MIX:LO:FREQ:DEN | LODenominator
Input Greater / Less that LO | SENS:MIX:LO:FREQ:ILTI | IsInputGreaterThanLO
Set IF
Sideband (high or low) | SENS:MIX:IF:FREQ:SIDE | IFSideband
IF start frequency | SENS:MIX:IF:FREQ:STAR | IFStartFrequency
IF stop frequency | SENS:MIX:IF:FREQ:STOP | IFStopFrequency
Numerator - IF Frac.Mult | SENS:MIX:IF:FREQ:NUM | IFNumerator
Denominator - IF Frac.Mult | SENS:MIX:IF:FREQ:DEN | IFDenominator
Set Output
Sideband (high or low) | SENS:MIX:OUTP:FREQ:SIDE | OutputSideband
Output start frequency | SENS:MIX:OUTP:FREQ:STAR | OutputStartFrequency
Output stop frequency | SENS:MIX:OUTP:FREQ:STOP | OutputStopFrequency
Output fixed frequency | SENS:MIX:OUTP:FREQ:FIXed | OutputFixedFrequency
SMC (see SCPI and COM examples)
Create Cal object | None | CreateCustomCal
Begin Cal | SESS:INITiate | Initialize
Sets to ECAL or Mechanical | SMC:TWOP:OPTion | Do2PortEcal
Sets ECal module and characterization. | SESS:SMC:ECAL:CHAR | ECALCharacterization
Sets ECal THRU method | SESS:SMC:TWOP:METHod | ThruCalMethod
Sets ECAL auto-orientation ON or OFF | SESS:SMC:TWOP:ECAL:ORI | AutoOrient
Sets ECAL port map when orientation is off. | SESS:SMC:TWOP:ECAL:PORT | EcalOrientation
Select either omit or perform Isolation | SESS:SMC:TWOP:OMIT | OmitIsolation
Sets the source port for the power calibration. | SESS:SMC:PWRC:SRCPort | CalibrationPort
Set connector type for each port | SESS:CONN:PORT:SEL | ConnectorType
Set Cal Kit for the each port | SESS:CKIT:PORT:SEL | CalKitType
Returns the number of steps required by the Calibration | SESS:STEPs? | GenerateSteps
Returns the step description. | SESS:DESC? | GetStepDescription
Acquire a calibration measurement. | SESS:ACQ | AcquireStep
Ends the calibration | SESS:DONE |
Generate Error Terms | SESS:SAVE | GenerateErrorTerms
VMC (see SCPI and COM examples)
Create Cal object | None | CreateCustomCal
Begin Cal | SESS:INITiate | Initialize
Perform calibration or mixer characterization | SESS:VMC:OPERation | CharacterizeMixerOnly
Specify direction of mixer characterization | SESS:VMC:MIX:CHAR:CAL:REV | CharMixerReverse
Sets the Mixer characterization to ECal or Mech. | SESS:VMC:MIX:CHAR:CAL:OPT | Do1PortEcal
Sets ECAL auto-orientation ON or OFF | SESS:VMC:TWOP:ECAL:ORI | AutoOrient Property
Set filename of mixer characterization file | SESS:VMC:MIX:CHAR:CAL:FIL | CharFileName
Select ECal module and characterization to be used for mixer characterization | SESS:VMC:MIX:ECAL:CHAR | ECALCharacterization
Sets the port mapping for the mixer characterization. | SESS:VMC:MIX:ECAL:PORT | EcalOrientation1Port
Sets the 2-Port calibration to ECal or Mech. | SESS:VMC:TWOP:OPTion | Do2PortEcal
Select ECal module and characterization to be used for the calibration | SESS:VMC:TWOP:ECAL:CHAR | ECALCharacterization
Sets ECal method for performing the thru measurement | SESS:VMC:TWOP:METH | ThruCalMethod
Sets the port mapping for the calibration. | SESS:VMC:TWOP:ECAL:PORT | EcalOrientation2Port
Select either omit or perform Isolation | SESS:VMC:TWOP:OMIT | OmitIsolation
Set connector type for each port | SESS:CONN:PORT:SEL | ConnectorType
Set Cal Kit for the each port | SESS:CKIT:PORT:SEL | CalKitType
Returns the number of steps required by the Calibration | SESS:STEPs? | GenerateSteps
Returns the step description. | SESS:DESC? | GetStepDescription
Acquire a calibration measurement. | SESS:ACQ | AcquireStep
Ends the calibration | SESS:DONE |
Generate Error Terms | SESS:SAVE | GenerateErrorTerms


New Programming Commands

The following are new programming commands for PNA release 4.87:

Description | SCPI | COM
ECal Identification
Get list of user characterizations | SENS:CORR:CKIT:ECAL:CLISt? | ECALCharacterizationIndexList
Get list of ECal modules | SENS:CORR:CKIT:ECAL:LIST? | ECALModuleNumberList
Get ECal info. | SENS:CORR:CKIT:ECAL:INF? | GetECALModuleInfoEx (not new)

There are NO new programming commands for PNA release 4.86.

The following are new programming commands for PNA release 4.83:

Description | SCPI | COM
User Preset
User Preset | SYST:UPReset | UserPreset
Load User Preset file | SYST:UPReset:LOAD | UserPresetLoadFile
Save Current state as User Preset | SYST:UPReset:SAVE | UserPresetSaveState
Enable Front Panel for User Preset | SYST:UPReset:FPANel | UserPresetEnable
Material and Aux IO Capabilities
Sets trigger delay for a channel | SENS:SWE:TRIG:DEL | ExternalTriggerDelay
Controls Mat Handler Connector pin 21 (ready for trigger). | CONT:HAND:RTR:STAT | ReadyForTriggerState
Controls Mat Handler Connector pin 20 (index signal). | CONT:HAND:IND:STAT | matHand.IndexState
Returns the most recent Mat Handler pass/fail status value. | CONT:HAND:PASSfail:STATus? | object.PassFailStatus
Sets the Mat Handler pass/fail policy. | CONT:HAND:PASSfail:POLicy | object.PassFailPolicy
Returns the most recent Aux IO pass/fail status value. | CONT:AUX:PASSfail:STATus? | object.PassFailStatus
Sets the Aux IO Pass/Fail policy. | CONT:AUX:PASSfail:POLicy | object.PassFailPolicy
Shows or Hides Pass/Fail dialog box. | DISP:FSIGn | app.DisplayGlobalPassFail
Data Trace Offset
Phase Offset | CALC:OFFS:PHASe | meas.PhaseOffset
Magnitude Offset | CALC:OFFS:MAGN | meas.MagnitudeOffset
Magnitude Slope Offset | CALC:OFFS:MAGN:SLOP | meas.MagnitudeSlopeOffset
Miscellaneous
Set ECAL module state. | CONT:ECAL:MOD:STATe |
Guided Calibration capability |  | GuidedCalibration Object
Toggles Nominal Incident Power (SMC Measurements) ON and OFF. | CALC:MIX:INP:POW:USENominal | NominalIncidentPowerState
Read and Write Block data from/to an external controller. | MMEMory:TRANsfer |

The following are new programming commands for PNA release 4.2:

Description | SCPI | COM
GPIB Pass Through
Open a GPIB pass-through session | SYST:COMM:GPIB:RDEV:OPEN | N/A
Write commands to the GPIB pass-through device. | SYST:COMM:GPIB:RDEV:WRIT | N/A
Reads string data from the GPIB pass-through device. | SYST:COMM:GPIB:RDEV:READ? | N/A
Closes a GPIB pass-through session | SYST:COMM:GPIB:RDEV:CLOS | N/A
Closes ALL GPIB pass-through sessions | SYST:COMM:GPIB:RDEV:RES | N/A
Writes data (without header) to a pass-through device | SYST:COMM:GPIB:RDEV:WBINary | N/A
Writes data (with header) to a pass-through device | SYST:COMM:GPIB:RDEV:WBLock: | N/A
Time Domain Coupling / Distance Markers
Enable trace coupling | SENS:COUP:PAR | CoupleChannelParams
Set gate coupling parameters | CALC:FILT:COUP:PAR | CoupledParameters
Set transform coupling parameters | CALC:TRAN:COUP:PAR | CoupledParameters
Specify measurement type for distance markers | CALC:TRAN:TIME:MARK:MODE | DistanceMarkerMode
Specify units for distance markers | CALC:TRAN:TIME:MARK:UNIT | DistanceMarkerUnit
Set and return marker distance value | CALC:MARK:DIST | Distance
Miscellaneous
Accept trigger before armed | CONT:SIGN:TRIG:ATBA | AcceptTriggerBeforeArmed
Output trigger enable | CONT:SIGN:TRIG:OUTP | TriggerOutputEnabled
Set display window size | DISPlay:WINDow:SIZE |
Allow arbitrary segments | SENS:SEGM:ARB | AllowArbitrarySegments
Configure Pulsed App .dll | ConfigNarrowBand2 Method | ConfigNarrowBand2 Method

The following are new programming commands for PNA release 4.0:

Read about What's New

Description | SCPI | COM
CITI and SnP File Support
Saves formatted trace data to .cti file | MMEM:STOR:CITI: FORM | SaveCitiFormattedData
Saves unformatted trace data to .cti file | MMEM:STOR:CITI: DATA | SaveCitiDataData
Sets format for .cti files | MMEM:STOR:TRAC: FORM:CIT | CitiContents
Sets content for .cti files | MMEM:STOR:TRAC: CONT:CIT | .CitiFormat
Sets format for .SnP files | MMEM:STOR:TRAC: FORM:SNP | pref.SnPFormat
Read SnP data | Calc:Data:SNP? | meas.Get SnPData
IF Access / Pulsed Measurements
Set gain state (Auto | Manual) | SENS:IF:GAIN:ALL | chan.IFGainMode
Set gain level | SENS:IF:GAIN:LEVel | chan.IFGainLevel
Read gain level | SENS:IF:GAIN? | chan.IFGainLevel
Sets the number of taps in the IF filter. | SENS:IF:FILT:SAMP:COUN | IFFilterSampleCount
Sets the IF filter sample period time. | SENS:IF:FILT:SAMP:PER | IFFilterSamplePeriod
Returns the list of available IF filter sample periods for the instrument. | SENS:IF:FILT:SAMP:PER:CAT | IFFilterSamplePeriodList
Sets the IF filter sample period mode.(Auto or Manual) | SENS:IF:FILT:SAMP:PER:MODE | IFFilterSamplePeriodMode
Sets type of IF filter to be used. | SENS:IF:FILT:SAMP:COUN:MODE | IFFilterSource
Sets the state of the IF Gate. | SENS:IF:GATE:STAT | IFGateEnable Property
Returns the maximum allowed value for the IFFilterSampleCount. | SENS:IF:FILT:SAMP:COUN | MaximumIFFilterSampleCount
Returns the minimum allowed value for the IFFilterSampleCount. | SENS:IF:FILT:SAMP:COUN | MinimumIFFilterSampleCount
Set IF source path | SENS:IF:SOUR:PATH | chan.IFSourcePath
Fixed IF / Output (mixer)
Avoid spurs | SENS:MIXer:AVOidspurs | AvoidSpurs
X-axis display | CALC:MIXer:XAXis | ActiveXAxisRange
Apply mixer settings | SENS:MIX:APPLy | Apply
LO sweep mode (fixed or swept) | SENS:MIX:LO: FREQ:MODE | LORangeMode
LO start frequency | SENS:MIX:LO: FREQ:STARt | LOStartFrequency
LO stop frequency | SENS:MIX:LO: FREQ:STOP | LOStopFrequency
Output fixed frequency | SENS:MIX:OUTP: FREQ:FIXed | OutputFixedFrequency
Trigger Commands (* Replacement)
Source (Int | Ext | Manual)* |  | trigSetup.Source
Scope (Global | Channel)* |  | trigSetup.Scope
External Trigger Behavior |  | ExternalTrigger ConnectionBehavior
Read Continuous Mode |  | chan.IsContinuous
Read Groups |  | GetNumberOfGroups
Read Hold Mode |  | chan.IsHold
All channels in Hold |  | chans.Hold
All channels Resume |  | chans.Resume
Source Power Cal
Turn ON|OFF display of readings | SOUR:POW:CORR:COLL:DISP | SetCalInfo2 Method
Set settling tolerance | SOUR:POW:CORR:COLL:AVER:NTOL | ReadingsTolerance
Set max readings | SOUR:POW:CORR:COLL:ITER | MaximumIterationsPerPoint
Set accuracy tolerance | SOUR:POW:CORR:COLL:ITER:NTOL | IterationsTolerance
Set power offset | SOUR:POW:CORR:OFFS | SourcePowerCalPowerOffset
Use Reference receiver for fast iteration | SOUR:POW:CORR:COLL:METH | SetCalInfo2 Method
Selects the sensor channel (SMC only) | SOUR:POW:CORR:COLL:SEN:SEL | SetPowerAcquisitionDevice
Get source power cal variant data |  | Get SourcePowerCalDataEx
Put source power cal variant data |  | Put SourcePowerCalDataEx
Get source power cal typed data |  | GetSourcePowerCalDataScalarEx
Put source power cal typed data |  | PutSourcePowerCalDataScalarEx
Miscellaneous
Read UNUSED channel numbers |  | chans.UnusedChannelNumbers
Read USED channel numbers |  | chans.UsedChannelNumbers
Control the PNA via SICL |  | app.SICL Property
Arrange PNA display | DISP:ARRange <char> |
Print to file | HCOPy:FILE |
Sets Reduced IFBW | SENS:BWID:TRAC | chan.ReduceIFBW
Ensures successful "Step?" query | SENS:CORR:COLL:SESS:STEP |
Return X-Axis values | SENS:X:VAL |
Sets or returns the ON / OFF state of a marker |  | meas.MarkerState


Руководство по программированию

Поиск команд по функциям
Команды COM и SCPI распределены по группам в виде меню на экране PNA.

GPIB / SCPI | COM
Дерево команд | Объектная модель COM
Примеры программ | Примеры программ
Использование GPIB | Использование технологии COM

  • Новые команды программирования

  • Новое приложение Преобразователь кода

  • Устаревшие / Замененные команды

  • Карта доступа к данным

  • Дополнительную информацию по программированию PNA и примеры см. на :http://na.tm.agilent.com/pna/programming/


Replacement Commands

Obsolete Commands

As we expand the capability of the PNA, we will continue to develop new COM commands. Some of these new commands replace an existing command, giving it more functionality. Although the existing command will continue to work as usual, we recommend using the new command in code that you develop.

Here is a list of replacement commands:

Old Command | New Command
Acquire Cal Standard Method | Acquire Cal Standard2 Method
Create SParameter Method | Create SParameterEX Method
Calibrator.getErrorTerm | CalSet.getErrorTerm
Calibrator.getStandard | CalSet.getStandard
Calibrator.putErrorTerm | CalSet.putErrorTerm
Calibrator.putStandard | CalSet.putStandard
AcquireCalConfidenceCheckECAL | AcquireCalConfidenceCheckECALEx
DoECAL1Port Method | DoECAL1PortEx Method
DoECAL2Port Method | DoECAL2PortEx Method
ECALCharacterization Property | ECALCharacterizationEx Property
ECALPortMap_Property | ECALPortMapEx_Property
Get ECAL Module Info Method | Get ECALModuleInfoEx Method
IsECALModuleFound Property | IsECALModuleFoundEx Property
Trigger Signal Property | Source Property
Trigger Type Property | Scope Property
get SourcePowerCalData Method | Get SourcePowerCalDataEx Method
get SourcePowerCalDataScalar Method | Get SourcePowerCalDataScalarEx Method
put SourcePowerCalData Method | Put SourcePowerCalDataEx Method
put SourcePowerCalDataScalar Method | Put SourcePowerCalDataScalarEx Method
ConfigNarrowBand Method | ConfigNarrowBand2 Method
ConfigNarrowBand2 Method | ConfigNarrowBand3 Method


CFScale Topic

AutoScale | DISP:WIND:TRAC:Y:AUTO | Trce.Autoscale
AutoScale All | None | Trce.Autoscale
Per Division | DISP:WIND:TRAC:Y:PDIV | trce.YScale
Reference Level | DISP:WIND:TRAC:Y:RLEV | trce.ReferenceValue
Reference Position | DISP:WIND:TRAC:Y:RPOS | trce.ReferencePosition
Electrical Delay | CALC:CORR:EDEL:TIME | meas.ElectricalDelay
Phase Offset | CALC:OFFS:PHAS | meas.PhaseOffset
Magnitude Offset | CALC:OFFS:MAGN | meas.MagnitudeOffset
Magnitude Slope Offset | CALC:OFFS:MAGN:SLOP | meas.MagnitudeSlopeOffset


CFSweep Topic

IF Bandwidth | SENS:BWID | chan.IFBandwidth
Previous IF Bandwidth | None | chan.Previous_IFBandwidth
Next IFBandwidth | None | chan.Next_IFBandwidth
Reduce IF BW | SENS:BWID:TRACk | chan.ReduceIFBW
Number of Points | SENS:SWE:POIN | chan.NumberOfPoints
Sweep Time Value | SENS:SWE:TIME | chan.SweepTime
Sweep Type (Lin | Pwr | CW | Seg) | SENS:SWE:TYPE | chan.SweepType
Sweep Generation (Stepped | Analog) | SENS:SWE:GEN | chan.SweepGenerationMode
Dwell Time Value | SENS:SWE:DWEL | chan.DwellTime
Alternate Sweeps | SENS:COUP | chan.AlternateSweep
External ALC | SOUR:POW:DET | app.ExternalALC
Power Sweep
Start Power | SOUR:POW:STAR | chan.StartPower
Stop Power | SOUR:POW:STOP | chan.StopPower
Center | SOUR:POW:CENT | None
Span | SOUR:POW:SPAN | None
Segment Sweep
ON|OFF | SENS:SEGM | Seg.State
Add a segment | SENS:SEGM:ADD | Segs.Add
Delete a segment | SENS:SEGM:DEL | segments.Remove
Delete all segments | SENS:SEGM:DEL:ALL | None
Count the segments | SENS:SEGM:COUN | chans.Count
Read the segment number | None | seg.SegmentNumber
Segment Center Frequency | SENS:SEGM:FREQ:CENT | chan.centerFrequency
Segment Frequency Span | SENS:SEGM:FREQ:SPAN | chan.FrequencySpan
Segment Start Frequency | SENS:SEGM:FREQ:STAR | Chan.StartFrequency
Segment Stop Frequency | SENS:SEGM:FREQ:STOP | Chan.StopFrequency
Number of Points | SENS:SEGM:SWE:POIN | seg.NumberOfPoints
IF Bandwidth | SENS:SEGM:BWID | seg.IFBandwidth
IF Bandwidth Option | SENS:SEGM:BWID:CONT | segs.IFBandwidthOption
Source Power | SENS:SEGM:POW | chan.TestPortPower
Source Power Option | SENS:SEGM:POW:CONT | segs.SourcePowerOption
X-Axis Point Spacing | SENS:SEGM:X:SPAC | chan.XAxisPointSpacing
Allow Arbitrary Segments | SENS:SEGM:ARB | segs.AllowArbitrarySegments
Upload a segment table | None | SetAllSegmernts
Trigger Source (where trigger comes from)
Source (Int | Ext | Manual) | TRIG:SOUR | trigSetup.Source
Internal | Manual | INIT:CONT |
Trigger! (for Manual Source) | INIT | app.ManualTrigger
Scope (what is triggered)
Scope (Global | Channel) | TRIG:SCOP | trigSetup.Scope
Channel Settings (how the channel responds to triggers)
Continuous | SENS:SWE:MODE CONTinous | chan.Continuous
Read Continuous Mode |  | chan.IsContinuous
Number of Groups | SENS:SWE:GRO:COUN | chan.NumberOfGroups
Read Groups |  | chan.GetNumberOfGroups
Hold | SENS:SWE:MODE HOLD | chan.Hold
Hold Mode (read-only) |  | chan.IsHold
All channels in Hold | SYST:CHAN:HOLD | chans.Hold
All channels Resume | SYST:CHAN:RESume | chans.Resume
Single | SENS:SWE:GRO:COUN 1 | chan.Single
Trigger Mode (Point | Measurement) | SENS:SWE:TRIG:POIN | chan.TriggerMode
Restart | INIT |
Abort | ABOR | chan.Abort
External Trigger
External Trigger Behavior | CONT:SIGNal | ExternalTriggerConnectionBehavior
Trigger Delay | TRIG:DEL | app.TriggerDelay
Accept Trigger Before Armed | CONT:SIGN:TRIG:ATBA | AcceptTriggerBeforeArmed
Output trigger enable | CONT:SIGN:TRIG:OUTP | TriggerOutputEnabled


CFSystem Topic

Frequency Blanking | SEC:LEVel | app.SecurityLevel
Local Lockout | Local Lockout | app.LocalLockoutState
Preset | SYST:PRES *RST | app.Preset
Preset plus delete window | SYST:FPReset | app.Reset
Return Full computer name |  | app.SystemName
Set and return GPIB address |  | app.GPIBAddress
Set PNA to GPIB system controller or talker/listener |  | app.GPIBMode
Set and return SICL address |  | app.SICLAddress
Control the PNA via SICL |  | app.SICL
Quit application |  | app.Quit
System Impedance | SENS:CORR:IMP:INP:MAGN | SystemImpedanceZ0
User Preset
User Preset | SYST:UPReset | app.UserPreset
Load User Preset file | SYST:UPReset:LOAD | app.UserPresetLoadFile
Save Current state as User Preset | SYST:UPReset:SAVE | app.UserPresetSaveState
Enable Front Panel for User Preset | SYST:UPReset:FPANel | app.UserPresetEnable
Status Commands
Status Registers | GP-IB\Status |
*OPC;*WAI | GP-IB\Common_Commands |
Events
AllowAllEvents Method |  | app.AllowAllEvents
AllowEventCategory Method |  | app.AllowEventCategory
AllowEventMessage Method |  | app.AllowEventMessage
AllowEventSeverity Method |  | app.AllowEventSeverity
DisallowAllEvents Method |  | app.DisallowAllEvents
MessageText |  | app.MessageText
OnCalEvent |  | app.OnCalEvent
OnChannelEvent |  | app.OnChannelEvent
OnDisplayEvent |  | app.OnDisplayEvent
OnHardwareEvent |  | app.OnHardwareEvent
OnMeasurementEvent |  | app.OnMeasurementEvent
OnSCPIEvent |  | app.OnSCPIEvent
OnSystemEvent |  | app.OnSystemEvent
OnUserEvent |  | app.OnUserEvent
SetFailOnOverRange |  | app.SetFailOnOverRange
Macros
Execute Macro |  | app.ExecuteShortcut
Get Macro |  | app.GetShortcut
Delete Macro |  | app.DeleteShortCut
Put Macro |  | app.PutShortcut
Rear Panel Connector Controls
Material Handler I/O Connector | GP-IB\Control | MaterialHandler IO
Auxiliary IO Connector | GP-IB\Control | Aux IO
External Test Set Connector | GP-IB\Control | External Test Set
GPIB Pass Through
Open a GPIB pass-through session | SYST:COMM:GPIB:RDEV:OPEN |
Write string data to the GPIB pass-through device. | SYST:COMM:GPIB:RDEV:WRIT |
Write data to the GPIB pass-through device (with header). | SYST:COMM:GPIB:RDEV:WBLock |
Write data to the GPIB pass-through device (without header). | SYST:COMM:GPIB:RDEV:WBINary |
Reads string data from the GPIB pass-through device. | SYST:COMM:GPIB:RDEV:READ? |
Closes a GPIB pass-through session | SYST:COMM:GPIB:RDEV:CLOS |
Closes ALL GPIB pass-through sessions | SYST:COMM:GPIB:RDEV:RES |


CFTrace Topic

Create S-Parameter Meas. |  | app.CreateSParameter
Create Measurement | CALC:PAR:DEF | app.CreateMeasurement
Add Measurement |  | meass.Add
List Measurements | CALC:PAR:CAT |
Delete a measurement | CALC:PAR:DEL | Measurements.Remove
Delete ALL measurements | CALC:PAR:DEL:ALL |
Get a handle to a Trace |  | win.ActiveTrace
Select a Measurement | CALC:PAR:SEL | app.ActiveMeasurement
Read Channel Number |  | chan.ChannelNumber
Read Number of Measurements |  | chans.Count
Read Measurement Parameter |  | meas.Parameter
Set / Read Measurement Name |  | meas.Name
Read Measurement Number |  | meas.Number
Change Parameter | CALC:PAR:MOD | meas.ChangeParameter
Measurement Format | CALC:FORM | meas.Format
Math
Data Trace ON|OFF | DISP:WIND:TRAC |
Memory Trace ON|OFF | DISP:WIND:TRAC:MEM |
View Trace Type (Data|Memory|None) |  | meas.View
Data =>Memory | CALC:MATH:MEM | meas.DataToMemory
Trace Math (Add|Sub|Mult|Div) | CALC:MATH:FUNC | meas.TraceMath
Smoothing
Smoothing ON|OFF | CALC:SMO | meas.Smoothing
Smoothing Aperture | CALC:SMO:APER | meas.SmoothingAperture
Smoothing Points | CALC:SMO:POIN |
Statistics
Statistics ON|OFF | CALC:FUNC:STAT | meas.ShowStatistics
Statistics Range | CALC:FUNC:DOM:USER | meas.StatisticsRange
Domain Range Start | CALC:FUNC:DOM:USER:STAR | chan.UserRangeMin
Domain Range Stop | CALC:FUNC:DOM:USER:STOP | chan.UserRangeMax
Set Type (Pk-Pk|StdDev|Mean) | CALC:FUNC:TYPE |
Get All Statistics Data | CALC:FUNC:DATA | meas.GetFileterStatistics
Get Standard Deviation |  | meas.StandardDeviation
Get Mean |  | meas.Mean
Get Peak to Peak |  | meas.PeakToPeak
Limit Lines
Display Lines ON|OFF | CALC:LIM:DISP:STAT | Limttest.LineDisplay
Fail Sound ON|OFF | CALC:LIM:SOUN | Limttest.SoundOnFail
Testing ON|OFF | CALC:LIM:STAT | Trans.State
Global Pass Fail Status | CONT:HAND:PASS:STAT? | PassFailStatus
Limit Test Failed |  | meas.LimitTestFailed
Count Limit Lines |  | chans.Count
Read Test Results | GP-IB_Command_Finder\Status | limts.GetTestResult
Write Limit Line data | CALC:LIM:DATA | limts.SetAllSegments
Limit Line Type (Max|Min) | CALC:LIM:SEGM:TYPE | limts.Type
Begin Stimulus | CALC:LIM:SEGM:STIM:STAR | limtseg.BeginStimulus
End Stimulus | CALC:LIM:SEGM:AMPL:STOP | limtseg.EndStimulus
Begin Response | CALC:LIM:SEGM1:AMPL:STAR | limtseg.BeginResponse
End Response | CALC:LIM:SEGM1:AMPL:STOP | limtseg.EndResponse
Transform
Transform ON|OFF | CALC:TRAN:TIME:STAT | trans.State
Mode (LowPass, BandPass) | CALC:TRAN:TIME | trans.Mode
Start Time | CALC:TRAN:TIME:STAR | trans.Start
Stop Time | CALC:TRAN:TIME:STOP | trans.Stop
Center | CALC:TRAN:TIME:CENT | trans.Center
Span | CALC:TRAN:TIME:SPAN | trans.Span
Step Rise Time | CALC:TRAN:TIME:STAR | trans.StepRiseTime
Set Low Pass Frequency | CALC:TRAN:TIME:LPFR | trans.SetFrequencyLowPass
Enable trace coupling | SENS:COUP:PAR | CoupleChannelParams
Set transform coupling parameters | CALC:TRAN:COUP:PAR | trans.CoupledParameters
Specify measurement type for distance markers | CALC:TRAN:TIME:MARK:MODE | trans.DistanceMarkerMode
Specify units for distance markers | CALC:TRAN:TIME:MARK:UNIT | trans.DistanceMarkerUnit
Set and return marker distance value | CALC:MARK:DIST | mark.Distance
Gating
ON|OFF | CALC:FILT:TIME:STAT | gate.State
Type (BandPass, Notch) | CALC:FILT:TIME | gate.Type
Shape | CALC:FILT:GATE:TIME:SHAP | gat.Shape
Start | CALC:FILT:TIME:STAR | gate.Start
Stop | CALC:FILT:GATE:TIME:STOP | gate.Stop
Center | CALC:FILT:GATE:TIME:CENT | gate.Center
Span | CALC:FILT:GATE:TIME:SPAN | gate.Span
Set gate coupling parameters |  |
Window
Kaiser Beta | CALC:TRAN:TIME:KBES | trans.KaiserBeta
Impulse Width | CALC:TRAN:TIME:IMP:WIDT | trans.ImpulseWidth


CFView Topic

Speed up Measurements !
Measurement Trace On|Off | DISP:WIND:TRAC | meas.View
Display Update On|Off | DISP:ENAB | None
Window Update On|Off | DISP:WIND:ENABle | None
Analyzer Visible On|Off | None | app.Visible
Toolbars / Functions On|Off
Status Bar On|Off | DISP:ANN:STAT | app.ShowStatusBar
Toolbars On|Off | None | app.ShowToolbar
Tables On|Off | DISP:WIND:TABLe | win.ShowTable
Title Bars On|Off | None | app.ShowTitleBars
X-axis values On|Off | DISP:ANN:FREQ | app.ShowStimulus
Marker Readout On|Off | DISP:WIND:ANN:MARK:STAT | win.MarkerReadout
Trace Status buttons On|Off | DISP:WIND:ANN:TRAC:STAT | None
Memory Trace On|Off | DISP:WIND:TRAC:MEM | meas.View
Title Annotation On|Off | DISP:WIND:TITL | win.TitleState
Error Messages On|Off | DISP:ANN:MESS:STAT | app.DisplayAutomationErrors
Miscellaneous
Make a Title Annotation | DISP:WIND:TITL:DATA | win.Title
One Readout per Trace | DISP:WIND:ANN:MARK:SING | win.OneReadoutPerTrace
Marker Readout Size | DISP:WIND:ANN:MARK:SIZE | win.MarkerReadoutSize
Add a Window | DISP:WIND | wins.Add
Return Window Number(s) | DISP:CATalog? | win.WindowNumber
Activate a Window | None | app.ActivateWindow
Arrange Measurement Windows | DISP:ARRange | app.ArrangeWindows
Analyzer Window (Max |Min| Normal) | DISPlay:WIND:SIZE | app.WindowState


C++ Example

The following example uses the smart pointer created by Microsoft Visual Studio. The calls to CoInitialize and CoUninitialize open and close the COM libraries.

Also notice that the pointers local to the main routine are explicitly released. When smart pointers go out of scope, they will perform this duty implicitly. However, we are calling CoUninitialize before they have the chance to be destroyed, so we are obliged to release them.

// An example program to illustrate the use of #import to bind to the
// PNA type library.
//

#ifndef _UNICODE

#define _UNICODE

#endif

#include "stdafx.h"
#include "stdio.h"
#include "math.h"

/////////////////////////////////////////////
// import the network analyzer type library
/////////////////////////////////////////////
#import "C:\Program Files\Common Files\Agilent\Pna\835x.tlb"
 no_namespace, named_guids
/////////////////////////////////////////////
// include the error definitions for the PNA so we can implement
// error handling.
/////////////////////////////////////////////
#include "C:\Program Files\Common Files\Agilent\Pna\errorsystemmessage.h"

IApplicationPtr pNA; // top level application pointer
float fScalarData [1601]; // global buffer for data retrieval
float fScalarData2[1601];

DWORD dwCookie;

/////////////////////////////////////////////
// SetupChannel:
//
// input: pointer to the channel
//
// function: sets properties on the channel
/////////////////////////////////////////////
void SetupChannel(IChannelPtr pChannel)
{
pChannel->put_StartFrequency( 1.2E9 );
pChannel->put_StopFrequency ( 4.2E9 );
pChannel->put_NumberOfPoints ( 201);

}

/////////////////////////////////////////////
// AcquireData:
//
// input: pointer to the channel
//
// function: single sweeps the channel
/////////////////////////////////////////////
void AcquireData( IChannelPtr pChannel )
{
pChannel->Single( TRUE );
}

/////////////////////////////////////////////
// ReadData:
//
// input: pointer to the Measurement object
//
// function: reads data from the measurment's formatted
// result data buffer
/////////////////////////////////////////////
void ReadScalarData(IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 1601;
float* pData = fScalarData;

if(pDataTransfer){

pDataTransfer->getScalar( naMeasResult, naDataFormat_LogMag,
 &numVals, pData);

for (int i = 0; i < numVals; i++)
printf("%d\t%f\n",i,pData[i]);
}
TCHAR msg[100];
BSTR param;
pMeas->get_Parameter(&param);
swprintf(msg,L"Review %s data",param);
MessageBox(NULL,msg,L"User Message",0);
::SysFreeString(param);
}

void ReadComplexData(IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 1601;
float* pReal= fScalarData;
float* pImag = fScalarData2;

if(pDataTransfer){

pDataTransfer->getPairedData( naRawData, naRealImaginary, &numVals,
 pReal, pImag);

for (int i = 0; i < numVals; i++)
printf("%d\t%f\t%f\n",i,pReal[i], pImag[i]);
}
TCHAR msg[100];
BSTR param;
pMeas->get_Parameter(&param);
swprintf(msg,L"Review %s data",param);
MessageBox(NULL,msg,L"User Message",0);
::SysFreeString(param);
}
/////////////////////////////////////////////
// PutData:
//
// input: pointer to the Measurement object
//
// function: writes data to the measurment's raw data
// buffer
/////////////////////////////////////////////
void PutData( IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 201;

if(pDataTransfer){

NAComplex* pComplex = new NAComplex[numVals];

pComplex[0].Im = 0;
pComplex[0].Re = 1;
for (int i = 1; i < numVals; i++)
{
pComplex[i].Im = (float)sin(i)/i;
pComplex[i].Re = (float)cos(i)/i;
}

pDataTransfer->putNAComplex( naRawData, numVals, pComplex, naDataFormat_Polar);
delete [] pComplex;
}
}

/////////////////////////////////////////////
// printError
/////////////////////////////////////////////
void printError( HRESULT hr)
{
BSTR text;

hr = pNA->get_MessageText ((NAEventID) hr, &text);
MessageBox(NULL,text,L"Network Analyzer error",0);
::SysFreeString(text);
}

/////////////////////////////////////////////
// main
/////////////////////////////////////////////
int main(int argc, char* argv[])
{
HRESULT hr;
const long channel1 = 1;
const long window1 = 1;
const long srcport = 1;
IMeasurementPtr pMeasurement;
IChannelPtr pChannel;

// initialize COM libraries
CoInitialize(NULL);

try {
pNA = IApplicationPtr("AgilentPNA835x.Application.1");

pNA->put_Visible(TRUE);
pNA->Reset();

pNA->CreateMeasurement (channel1, "S21",srcport, 3);
hr = pNA->get_ActiveChannel( &pChannel);

if (SUCCEEDED (hr))
{
SetupChannel( pChannel);
AcquireData(pChannel);
}

hr= pNA->get_ActiveMeasurement( &pMeasurement);
if (SUCCEEDED(hr))
{
pMeasurement->put_Format( naDataFormat_Polar);
ReadScalarData( pMeasurement);
ReadComplexData( pMeasurement);
PutData(pMeasurement);
}
if (FAILED(hr))
{
printError(hr);
}

// make sure to release the remaining pointers
// before calling CoUninitialize

pMeasurement.Release();
pChannel.Release();
pNA.Release();
}
catch (_com_error err)
{
printError( err.Error() );
}

CoUninitialize();
return 0;
}


COM Example Intro

COM Example Programs

Calibrations
Perform a Guided Cal | VBScript
Perform an ECal | VBScript
CalSet_Examples | C++
Perform an ECAL Confidence Check | Visual Basic
Perform a Source Power Cal using COM | VBScript
Upload a Source Power Cal using COM | VBScript
FCA
Create Mixer Measurement and Perform SMC Calibration | Visual Basic
Create Mixer Measurement and Perform VMC Calibration | VBScript
Create an SMC Fixed Output Measurement | Visual Basic
Miscellaneous
Getting Trace Data from the PNA | Visual Basic
Upload Segment Table | Visual Basic
Create a Pulsed Measurement | Visual Basic
Limit Line Testing | Visual Basic
Events Example | Visual Basic

See more PNA programming information and examples at:http://na.tm.agilent.com/pna/programming/


Perform a Guided Cal using COM

Perform a Guided Calibration using COM

This example uses the GuidedCalibration interface to perform either a 2-port or 3-port calibration.

Learn more about Reading and Writing Calibration data using COM.

See Other COM Example Programs

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save on the PNA hard drive as Calibrate.vbs. Learn how to setup and run the macro.

Set pna = CreateObject("AgilentPNA835x.Application")
Set calMgr = pna.GetCalManager
Set guidedCal = calMgr.GuidedCalibration
Set chan = pna.ActiveChannel
chanNum = chan.ChannelNumber
' Initialize guided cal to be performed on the active channel.
' The boolean argument of True indicates to create
' a new calset for storing the calibration
guidedCal.Initialize chanNum, True

' To perform 3-port cal, comment the following
' Then uncomment the 3-port cal

' Do 2-port cal
TwoPortGuidedCal

' Do 3-port cal
' ThreePortGuidedCal

Sub TwoPortGuidedCal()
' Select the connectors
guidedCal.ConnectorType(1) = "APC 3.5 female"
guidedCal.ConnectorType(2) = "APC 3.5 male"
For i = 3 To pna.NumberOfPorts
guidedCal.ConnectorType(i)
 = "Not used"
Next
value = MsgBox("Connectors defined for Ports 1 and 2")
' Select the Cal Kit for each port being calibrated.
guidedCal.CalKitType(1) = "85052D"
guidedCal.CalKitType(2) = "85052D"
value = MsgBox("Cal kits defined for Ports 1 and 2")
' Initiate the calibration and query the number of steps
numSteps = guidedCal.GenerateSteps
' Measure the standards, compute and apply the cal
MeasureAndComplete(numSteps)
End Sub

Sub ThreePortGuidedCal()
' Select the connectors
guidedCal.ConnectorType(1) = "APC 3.5 female"
guidedCal.ConnectorType(2) = "APC 3.5 female"
guidedCal.ConnectorType(3) = "APC 3.5 female"
value = MsgBox("Connectors defined for Ports 1 to 3")
' Select the Cal Kit for each port being calibrated.
guidedCal.CalKitType(1) = "85052D"
guidedCal.CalKitType(2) = "85052D"
guidedCal.CalKitType(3) = "85052D"
value = MsgBox("Cal kits defined for Ports 1 to 3")
' Initiate the calibration
numSteps = guidedCal.GenerateSteps
' Measure the standards, compute and apply the cal
MeasureAndComplete(numSteps)
End Sub

Sub MeasureAndComplete(ByVal numSteps)
value = MsgBox("Number of steps is " + CStr(numSteps))
' Measure the standards
For i = 1 To numSteps
step =
 "Step " + CStr(i) + " of " + CStr(numSteps)
strPrompt
 = guidedCal.GetStepDescription(i)
value =
 MsgBox(strPrompt, vbOKOnly, step)
guidedCal.AcquireStep
 i
Next

' Conclude the calibration
guidedCal.GenerateErrorTerms
MsgBox ("Cal is done!")
End Sub


Perform an ECal

Perform an ECal using COM

This example uses the GuidedCalibration interface to perform a 2-port ECal calibration.

Learn more about Reading and Writing Calibration data using COM.

See Other COM Example Programs

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save on the PNA hard drive as ECal.vbs. Learn how to setup and run the macro.

Set pna = CreateObject("AgilentPNA835x.Application")
Set calMgr = pna.GetCalManager
Set guidedCal = calMgr.GuidedCalibration
Set chan = pna.ActiveChannel
chanNum = chan.ChannelNumber
' Initialize guided cal to be performed on the active channel.
' The boolean argument of True indicates to create a new calset
guidedCal.Initialize chanNum, True
' To perform 3-port cal, Uncomment the following
' Then comment the 2-port cal

' Do 2-port cal
TwoPortGuidedCal

' Do 3-port cal
' ThreePortGuidedCal

Sub TwoPortGuidedCal()
'Change the following to match the connectors on your ECal module
guidedCal.ConnectorType(1) = "APC 3.5 female"
guidedCal.ConnectorType(2) = "APC 3.5 female"
For i = 3 To pna.NumberOfPorts
guidedCal.ConnectorType(i) = "Not used"
Next
value = MsgBox("Connectors defined for Ports 1 and 2")
' Select the ECal module for each port being calibrated.
' Replace N4691-60004 with your own ECAL model followed by 'ECal'.
' Your ECal module must already be connected to a PNA USB port.

guidedCal.CalKitType(1) = "85092-60010 ECal"
guidedCal.CalKitType(2) = "85092-60010 ECal"

value = MsgBox("ECal Module defined for Ports 1 and 2")
' Initiate the calibration and query the number of steps
numSteps = guidedCal.GenerateSteps
' Measure the standards, compute and apply the cal
MeasureAndComplete(numSteps)
End Sub

Sub ThreePortGuidedCal()
''Change the following to match the connectors on your ECal module
guidedCal.ConnectorType(1) = "APC 3.5 female"
guidedCal.ConnectorType(2) = "APC 3.5 female"
guidedCal.ConnectorType(3) = "APC 3.5 female"

' Select the ECal module for each port being calibrated.
' Replace N4691-60003 with your own ECAL model followed by 'ECal'.
' Your ECal module must already be connected to a PNA USB port.
guidedCal.CalKitType(1) = "N4431-60003 ECal"
guidedCal.CalKitType(2) = "N4431-60003 ECal"
guidedCal.CalKitType(3) = "N4431-60003 ECal"

value = MsgBox("Cal kits defined for Ports 1 to 3")
' Initiate the calibration
numSteps = guidedCal.GenerateSteps
' Measure the standards, compute and apply the cal
MeasureAndComplete(numSteps)
End Sub

Sub MeasureAndComplete(ByVal numSteps)
value = MsgBox("Number of steps is " + CStr(numSteps))
' Measure the standards
For i = 1 To numSteps
step = "Step " + CStr(i) + " of " + CStr(numSteps)
strPrompt = guidedCal.GetStepDescription(i)
value = MsgBox(strPrompt, vbOKOnly, step)
guidedCal.AcquireStep i
Next

' Conclude the calibration
guidedCal.GenerateErrorTerms
MsgBox ("Cal is done!")
End Sub


AcquireCalConfidenceCheckECAL

Write-only

About ECAL Confidence Check

AcquireCalConfidenceCheckECAL Method - Obsolete

Description

Note: This property is replaced by AcquireCalConfidenceCheckECALex Method

Transfers confidence data from the specified ECal module into the measurement's memory trace. The data is transferred to the specified S-parameter on the same channel as this Calibrator object.

The characterization within the ECal module that the confidence data will be read from is specified by the ECALCharacterization property on the ICalibrator2 interface. The default value of the ECALCharacterization property is naECALFactoryCharacterization.

VB Syntax

cal.AcquireCalConfidenceCheckECAL Sparam[,ecalModule]

Variable

(Type) - Description

cal

A Calibrator (object)

Sparam

(String) S-parameter to transfer confidence data to. This parameter must be present on the same channel as the calibrator object.

ecalModule

(enum NAECALModule) – Optional argument. ECal module. Choose from:

0 - naECALModule_A (default, if unspecified)

1 - naECALModule_B

Return Type

None

Default

Not applicable

Examples

Cal.AcquireCalConfidenceCheckECAL "S11", naECALModule_A

C++ Syntax

HRESULT AcquireCalConfidenceCheckECAL( _bstr_t strParameter, enum NAECALModule ecalModule );

Interface

ICalibrator


ConfigNarrowBand2 Method

Write-Read
Learn about the Pulsed Application

ConfigNarrowBand2 Method Obsolete

Description

Note: This method has been replaced by ConfigNarrowBand3 Method

This command replaced ConfigNarrowBand Method. Two additional arguments have been added: FixedPRF and 85110 gen.

This subroutine determines, then returns, the proper configuration for pulsed measurements on the PNA using the spectral nulling technique. The configuration returned needs to be sent to the PNA and any other related external equipment such as pulse generators. The routine will take a desired Pulse Repetition Frequency (PRF) and measurement IFBW and return a possibly modified PRF and IFBW for proper pulsed operation on the PNA. The routine will also return the Sample Rate, Number of Taps, and Offset that must be sent to the PNA to configure it in pulsed mode using the spectral nulling technique.

Although the example below uses COM programming to communicate with the PNA, these commands can be replaced with SCPI equivalents.

Note: The pulsed application may set the offset frequency (option 080) of the PNA to some value other than zero (the default value). If the stop frequency is set to the maximum of the PNA model, then an error message may appear on the PNA stating that the response frequency has exceeded the maximum allowed frequency. To fix this, set the stop frequency to a value that is at least 2 KHz less than the maximum allowed.
For example, if you have a 20 GHz PNA, and the stop frequency is set to 20 GHz, and the error message appears, then set the stop frequency to 19.999998 GHz

VB Syntax

Pulsed.ConfigNarrowBand (PRF, NumTaps, BW, OffSet, SampleRate, Precision, FixedPRF, PG81110)

Variable

(Type) - Description

Pulsed

(interface) An interface to the agilentpnapulsed.dll application interface.

PRF

(Double) The Pulse Repetition Frequency.

[out] The pulse repetition frequency that has been optimized for use with the PNA. NOTE: This value may be different from the value requested.

[in] The desired pulse repetition frequency.

NumTaps

(Long) The number of taps to send to the PNA for pulsed operation.

BW

(Long) The PNA IF Bandwidth.

[out] The PNA IF bandwidth that has been optimized for use with the PNA. NOTE: This value may be different from the value requested.

[in] The desired PNA IF bandwidth.

Offset

(Double) The offset value to send to the PNA for pulsed operation. The offset value is used to adjust the PNA for the two different possible sample rates that may be returned.

SampleRate

(Double) The sample rate to send to the PNA for pulsed operation.

Precision

(Double) The precision variables sets the precision that will be used to decrement the PRF when running the configuration routines. This variable can be set to the precision required by the external pulse generators so that the configuration routine will not return a PRF that is not within the precision limits of the pulse generators.

FixedPRF

(Boolean)

1 (True) Signals the .DLL routine to NOT adjust the PRF value; rather adjust ONLY the IF Bandwidth. This is the default setting.

0 (False) Adjust both the PRF and IF Bandwidth values as necessary.

PG81110

(Boolean)

1 (True) You are using an Agilent 81110 as the pulse generator. This allows increased accuracy in adjustments for offset and PRF.

0 (False) Not using an Agilent 81110.

Return Type

Not Applicable

Default

Not Applicable

Example

See an example using this command.

C++ Syntax

HRESULT ConfigNarrowBand(double *pPRF, long *pNumTaps, long *pBW, double *pOffset, double *pSampleRate, int Precision)

Interface

AgilentPNAPulsed.Application


ConfigNarrowBand Method

Write-Read

Learn about the Pulsed Application

ConfigNarrowBand Method Obsolete

Description

This method is replaced with ConfigNarrowBand2 Method which includes two new arguments.

This subroutine determines, then returns, the proper configuration for pulsed measurements on the PNA using the spectral nulling technique. The configuration returned needs to be sent to the PNA and any other related external equipment such as pulse generators. The routine will take a desired Pulse Repetition Frequency (PRF) and measurement IFBW and return a possibly modified PRF and IFBW for proper pulsed operation on the PNA. The routine will also return the Sample Rate, Number of Taps, and Offset that must be sent to the PNA to configure it in pulsed mode using the spectral nulling technique.

Although the example below uses COM programming to communicate with the PNA, these commands can be replaced with SCPI equivalents.

Note: The pulsed application may set the offset frequency (option 080) of the PNA to some value other than zero (the default value). If the stop frequency is set to the maximum of the PNA model, then an error message may appear on the PNA stating that the response frequency has exceeded the maximum allowed frequency. To fix this, set the stop frequency to a value that is at least 2 KHz less than the maximum allowed.
For example, if you have a 20 GHz PNA, and the stop frequency is set to 20 GHz, and the error message appears, then set the stop frequency to 19.999998 GHz

VB Syntax

Pulsed.ConfigNarrowBand (PRF, NumTaps, BW, OffSet, SampleRate, Precision)

Variable

(Type) - Description

Pulsed

(interface) An interface to the agilentpnapulsed.dll application interface.

PRF

(Double) The Pulse Repetition Frequency.

[out] The pulse repetition frequency that has been optimized for use with the PNA. NOTE: This value may be different from the requested value.

[in] The desired pulse repetition frequency.

NumTaps

(Long) The number of taps to send to the PNA for pulsed operation.

BW

(Long) The PNA IF Bandwidth.

[out] The PNA IF bandwidth that has been optimized for use with the PNA. NOTE: This value may be different from the value requested.

[in] The desired PNA IF bandwidth.

Offset

(Double) The offset value to send to the PNA for pulsed operation. The offset value is used to adjust the PNA for the two different possible sample rates that may be returned.

SampleRate

(Double) The sample rate to send to the PNA for pulsed operation.

Precision

(Double) The precision variables sets the precision that will be used to decrement the PRF when running the configuration routines. This variable can be set to the precision required by the external pulse generators so that the configuration routine will not return a PRF that is not within the precision limits of the pulse generators.

Return Type

Not Applicable

Default

Not Applicable

Example

See an example using this command.

C++ Syntax

HRESULT ConfigNarrowBand(double *pPRF, long *pNumTaps, long *pBW, double *pOffset, double *pSampleRate, int Precision)

Interface

AgilentPNAPulsed.Application


Create SParameter Method

Write-only
About Measurement Parameters

CreateS-Parameter Method - Obsolete

Description

Note: This method is replaced by Create SParameterEX method which also allows the selection of a load port

This method creates a new S-Parameter measurement in an existing or new window.

VB Syntax

app.CreateSParameter chan,recvr,source,[window]

Variable

(Type) - Description

app

Application (object)

chan

(long integer) - Channel number of the new measurement

recvr

(long integer) - Port number of the receiver (1 or 2)

source

(long integer) - Port number of the source (1 or 2)

window

(long integer) - Optional argument. Window number of the new measurement. Choose 1 to 4. If unspecified, the S-Parameter will be created in the Active Window.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.CreateSParameter 1,2,1,1 'Creates a new S21 measurement in channel 1 and New window(1) app.CreateSParameter 1,2,1 'Creates a new S21 measurement in channel 1 and in the active window

C++ Syntax

HRESULT CreateSParameter(long ChannelNum, long RcvPort, long SrcPort, long windowNumber)

Interface

IApplication


Write-only

CreateCustomMeasurement Method

Description

This command is replaced with CreateCustomMeasurementEx Method.

Creates a new custom measurement.

VB Syntax

app.CreateCustomMeasurement chanNum,guid[,window]

Variable

(Type) - Description

app

(object) - An Application object

chanNum

(long) -Channel number used by the new measurement; can exist or be a new channel.

guid

(string) - the GUID (Globally Unique IDentifier) of the new custom measurement object. The new custom measurement must be installed and registered on the PNA. Should be in “registry format”. See example below.

window

(long) Optional argument. Number of the window the new custom measurement will be placed in. Choose 1 to 16. If unspecified, the measurement is placed in the active window.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.CreateCustomMeasurement 1, "{12345678-56D3-11D5-AD50-00108334AE98}" 'Not an actual custom measurement - for example purpose only

C++ Syntax

HRESULT CreateCustomMeasurement (long ChannelNum, BSTR guid, long windowNumber)

Interface

IApplication


DoECAL1Port Method

Write-only

About Calibration

DoECAL1Port Method - Obsolete

Description

Note: This property is replaced by DoECAL1PortEx Method.

Does a 1-Port calibration using an ECAL module. You must first have a 1-port measurement active to perform the calibration.

The characterization within the ECal module that will be used for the calibration is specified by the ECALCharacterization property on the ICalibrator2 interface. The default value of the ECALCharacterization property is naECALFactoryCharacterization.

VB Syntax

cal.DoECAL1Port [port][,module]

Variable

(Type) - Description

cal

A Calibrator (object)

port

(long integer) Optional argument - Port number to calibrate. Choose from:
1 - Calibrate port 1 (default if unspecified)
2 - Calibrate port 2

module

(enum NAEcalModule) Optional argument - ECAL module. Choose from:

0 - naECALModule_A - (default if unspecified)
1 - naECALModule_B

Return Type

None

Default

Not Applicable

Examples

cal.DoECAL1Port,2,naECALModule_B

C++ Syntax

HRESULT DoECAL1Port(long port, tagNAECALModule ecalModule);

Interface

ICalibrator


DoECAL2Port Method

Write-only
About Calibration

DoECAL2Port Method - Obsolete

Description

Note: This property is replaced by DoECAL2PortEx Method.

Does a 2-Port calibration using an ECAL module. You must first have a 2-port measurement active to perform the calibration.

The characterization within the ECal module that will be used for the calibration is specified by the ECALCharacterization property on the ICalibrator2 interface. The default value of the ECALCharacterization property is naECALFactoryCharacterization.

VB Syntax

cal.DoECAL2Port[portA][,portB][,module]

Variable

(Type) - Description

cal

A Calibrator (object)

portA

(long integer) Optional argument - Number of the receive port to calibrate.
Choose from:
1 - Calibrate port 1 (default, if unspecified)
2 - Calibrate port 2
3 - Calibrate port 3 (if the PNA has 3 ports)

portB

(long integer) Optional argument - Number of the source port to calibrate. Choose from:
1 - Calibrate port 1 (default, if unspecified)
2 - Calibrate port 2
3 - Calibrate port 3 (if the PNA has 3 ports)

module

(enum NAECALModule) – Optional argument. ECal module.

Choose from:
0 - naECALModule_A (default, if unspecified)
1 - naECALModule_B

Return Type

None

Default

Not Applicable

Examples

cal.DoECAL2Port,1,2,naECALModule_B

C++ Syntax

HRESULT DoECAL2Port(long rcvport, long srcPort, tagNAECALModule ecalModule);

Interface

ICalibrator


Get ECAL Module Info Method

Read-only

GetECALModuleInfo Method - Obsolete

Description

Note: This property is replaced by GetECALModuleInfoEx Method

Returns the following information about the connected ECAL module: model number, serial number, connector type, calibration date, min and max frequency.

The characterization within the ECal module that this information will be read from is specified by the ECALCharacterization property on the ICalibrator2 interface. The default value of the ECALCharacterization property is naECALFactoryCharacterization.

VB Syntax

moduleInfo = cal.GetECALModuleInfo (module)

Variable

(Type) - Description

moduleInfo

(string) - variable to store the module information

cal

A Calibrator (object)

module

(enum NAECALModule) – ECAL module. Choose from:

0 - naECALModule_A

1 - naECALModule_B

Return Type

String

Default

Not Applicable

Examples

info = cal.GetECALModuleInfo(naECALModule_A)

Example return string:

ModelNumber: 85092-60007, SerialNumber: 01386, ConnectorType: N5FN5F, PortAConnector: Type N (50) female, PortBConnector: Type N (50) female, MinFreq: 30000, MaxFreq: 9100000000, NumberOfPoints: 250, Calibrated: July 4 2002

C++ Syntax

HRESULT GetECALModuleInfo(tagNAECALModule ecalModule, BSTR* info);

Interface

ICalibrator


get SourcePowerCalData Method

Read-only

About Source Power Cal

getSourcePowerCalData Method - OBSOLETE

Description

Retrieves (as variant data type) requested source power calibration data, if it exists, from this channel.

Note: This method is replaced by GetSourcePowerCalDataEx Method.

Note: This method returns a variant which is less efficient than methods available on the ISourcePowerCalData interface

VB Syntax

data = chan.getSourcePowerCalData sourcePort

Variable

(Type) - Description

data

(variant) – Array to store the data.

chan

(object) – A Channel object

sourcePort

(long integer) – The source port for which calibration data is being requested.

Return Type

Variant array – automatically dimensioned to the size of the data.

Default

Not Applicable

Examples

Dim varData As Variant
Const port1 As Long = 1
varData = chan.getSourcePowerCalData port1
'Print the data
For i = 0 to chan.NumberOfPoints - 1
Print varData(i)
Next i

C++ Syntax

HRESULT getSourcePowerCalData(long sourcePort, VARIANT *pData);

Interface

IChannel


get SourcePowerCalDataScalar Method

Read-only

About Source Power Cal

getSourcePowerCalDataScalar Method - OBSOLETE

Description

Retrieves (as scalar values) requested source power calibration data, if it exists, from this channel.

Note: This method is replaced by GetSourcePowerCalDataScalarEx Method

Note: This method exists on a non-default interface. If you cannot access this method, use the getSourcePowerCalData Method on IChannel.

VB Syntax

chandata.getSourcePowerCalDataScalar sourcePort, numValues, data

Variable

(Type) - Description

chandata

(interface) – – An ISourcePowerCalData interface pointing to a Channel (object)

sourcePort

(long integer) – The source port for which calibration data is being requested.

numValues

(long integer) – Number of data values.

[out] – specifies number of data values returned.

[in] – specifies number of values being requested (this must not be larger than the capacity of the data array).

data

(single) – Array to store the data.

Return Type

Single

Default

Not Applicable

Examples

Dim numValues As Long
Dim scalarCalValues() As Single
Dim chanData As ISourcePowerCalData
Const port1 As Long = 1
numValues = app.ActiveChannel.NumberOfPoints
ReDim scalarCalValues(numValues)
Set chanData = app.ActiveChannel

chanData.getSourcePowerCalDataScalar port1, numValues, scalarCalValues(0)

'Print the data
For i = 0 to numValues - 1
Print scalarCalValues(i)
Next I

C++ Syntax

HRESULT getSourcePowerCalDataScalar(long sourcePort, long *pNumValues, float *pVals);

Interface

ISourcePowerCalData


Get Standard Method

Read-only
About Cal Sets

GetStandard Method - Obsolete

Description

Note: This method has been replaced by calSet.getStandard.

Retrieves data that was acquired for a specific cal standard. This method returns the actual measurement data - not the calculated error terms.

This method returns a variant which is less efficient than getStandardComplex on the ICalData interface.

Learn about reading and writing Calibration data.

VB Syntax

data = cal.getStandardclass,rcv,src

Variable

(Type) - Description

data

Variant array to store the data.

cal

A Calibrator (object)

class

(enum NACalClass) Standard to be measured. Choose from:

1 - naClassA

2 - naClassB

3 - naClassC

4 - naClassD

5 - naClassE

6 - naReferenceRatioLine

7 - naReferenceRatioThru

SOLT Standards

1 - naSOLT_Open

2 - naSOLT_Short

3 - naSOLT_Load

4 - naSOLT_Thru

5 - naSOLT_Isolation

TRL Standards

1 - naTRL_Reflection

2 - naTRL_Line_Reflection

3 - naTRL_Line_Tracking

4 - naTRL_Thru

5 - naTRL_Isolation

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

Return Type

(variant) - two-dimensional array (0:1, 0:NumberOfPoints-1)

Default

Not Applicable

Examples

Dim varStd As Variant
varStd = cal.getStandard(naSOLT_Thru,2,1)

C++ Syntax

HRESULT raw_getStandard(tagNACalClass stdclass, long ReceivePort, long SourcePort, VARIANT* pData)

Interface

ICalibrator


put SourcePowerCalData Method

Write-only
About Source Power Cal

putSourcePowerCalData Method

Description

Inputs source power calibration data (as variant data type) to this channel for a specific source port.

Note: This method is obsolete. It is replaced by PutSourcePowerCalDataEx Method

VB Syntax

chan.putSourcePowerCalData sourcePort, data

Variable

(Type) - Description

chan

(object) – A Channel object

sourcePort

(long integer) – The source port for which calibration data is being requested.

data

(variant) – Array of source power cal data being input.

Return Type

None

Default

Not Applicable

Examples

chan.putSourcePowerCalData 1, varData

C++ Syntax

HRESULT putSourcePowerCalData(long sourcePort, VARIANT varData);

Interface

IChannel


put SourcePowerCalDataScalar Method

Write-only.
About Source Power Cal

putSourcePowerCalDataScalar Method - OBSOLETE

Description

Note: This method is replaced by PutSourcePowerCalDataScalarEx Method

Inputs source power calibration data (as scalar values) to this channel for a specific source port.

VB Syntax

chandata.putSourcePowerCalDataScalar sourcePort, numValues, data

Variable

(Type) - Description

chandata

(interface) – – An ISourcePowerCalData interface pointing to a Channel (object)

sourcePort

(long integer) – The source port for which calibration data is being input.

numValues

(long integer) – Number of data values being input.

Note: If this does not equal the current number of points on the channel, the calibration will not be valid.

data

(single) – Array of source power cal data being input.

Return Type

None

Default

Not Applicable

Examples

Dim chanData As ISourcePowerCalData
Set chanData = app.ActiveChannel
chanData.putSourcePowerCalDataScalar 1, 201, scalarCalValues(0)

C++ Syntax

HRESULT putSourcePowerCalDataScalar(long sourcePort, long numValues, float *pVals);

Interface

ISourcePowerCalData


Put Standard Method - Obsolete

Write-only

PutStandard Method - Obsolete

Description

Note: This command is replaced by CalSet.putStandard.

Writes variant data to the error correction buffer holding measurement data acquired for a specific standard.

Learn about reading and writing Calibration data.

VB Syntax

cal.putStandard class,rcv,src,data

Variable

(Type) - Description

cal

A Calibrator (object)

class

(enum NACalClass) Standard. Choose from:

1 - naClassA

2 - naClassB

3 - naClassC

4 - naClassD

5 - naClassE

6 - naReferenceRatioLine

7 - naReferenceRatioThru

SOLT Standards

1 - naSOLT_Open

2 - naSOLT_Short

3 - naSOLT_Load

4 - naSOLT_Thru

5 - naSOLT_Isolation

TRL Standards

1 - naTRL_Reflection

2 - naTRL_Line_Reflection

3 - naTRL_Line_Tracking

4 - naTRL_Thru

5 - naTRL_Isolation

rcv

(long) - Receiver Port

src

(long) - Source Port

data

(variant) Two dimensional array (0:1, 0:points-1)

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim varStd (1,200) As Variant
cal.putStandard naSOLT_Thru, 2, 1, varStd

C++ Syntax

HRESULT raw_putStandard(tagNACalClass stdclass, long ReceivePort, long SourcePort, VARIANT varData)

Interface

ICalibrator


SetCalInfo (power) Method

Write-only

About Source Power Cal

SetCalInfo Method (for source power cals)

Description

Specifies the technique to be used for the source power calibration about to be performed, and the channel and source port for which it is to be performed.

VB Syntax

powerCalibrator.SetCalInfo calMethod, channel, sourcePort, calPower

Variable

(Type) - Description

powerCalibrator

(object) - A SourcePowerCalibrator object

calMethod

(enum NASourcePowerCalMethod) The method of gathering the source power correction data.

0 – naPowerMeter (the only method currently supported)

channel

(long integer) - Number of the PNA channel (not power meter channel) on which the source power cal will be performed. If the channel doesn’t already exist, it will be created.

sourcePort

(long integer) - Port number on which the source power cal will be performed.

calPower

(double) - Specifies the power level that is expected at the desired reference plane (input or output of DUT) following the source power cal.

Return Type

None

Default

Not Applicable

Examples

powerCalibrator.SetCalInfo naPowerMeter, 1, 1, -10

C++ Syntax

HRESULT SetCalInfo(tagNASourcePowerCalMethod calMethod, long channel, long sourcePort, double calPower);

Interface

ISourcePowerCalibrator


BalancedMeasurement Object

Note: These commands are ONLY available on 4-port PNA models with code release 5.0 and above.


BalancedTopology Object

Note: These commands are ONLY available on 4-port PNA models with code release 5.0 and above.


Fixturing Object

Note: These commands are ONLY available on 4-port PNA models with code release 5.0 and above.


GuidedCalibration Object

Description

Contains the methods and properties used to perform a Guided Calibration. From the GuidedCalibration object, you can perform 1,2,3, or 4-port calibrations using mechanical standards or ECal.

See the following examples using the GuidedCalibration object:

  • Performing a 2 or 3 port cal.

  • Perform an ECal calibration

Accessing the GuidedCalibration object

Dim app as AgilentPNA835x.Application
Dim CalMgr
Set CalMgr = App.GetCalManager
Dim guidedCal
Set guidedCal = CalMgr.GuidedCalibration

See Also:

PNA Automation Interfaces

The PNA Object Model

Method

Description

AcquireStep

IGuidedCalibration

Acquire data for a cal step.

GenerateErrorTerms

IGuidedCalibration

Generates the error terms for the calibration.

GenerateSteps

IGuidedCalibration

Request to generate a connection list and return the number of steps required.

GetStepDescription

IGuidedCalibration

Query description of a step.

Initialize

IGuidedCalibration

Initial setup with channel context for the remote cal object.

Property

Interface

See History

Description

CalKitType

IGuidedCalibration

Sets the calkit for the port.

CompatibleCalKits

IGuidedCalibration

Returns the list of calkits for the port.

ConnectorType

IGuidedCalibration

Sets the connector type for the port.

ThruCalMethod

IGuidedCalibration

Sets the THRU method for the calibration.

ThruPortList

IGuidedCalibration

Sets the thru connection port pairs. (Only for 4-port PNA models).

ValidConnectorTypes

IGuidedCalibration

Get Valid Connector Types.

IGuidedCalibration History

Interface | Introduced with PNA Rev:
IGuidedCalibration | 4.8


ECALPortMap_Property

Write/Read

ECALPortMap Property - Obsolete

Description

Note: This command is replaced by ECALPortMapEx

Specifies which ports of the ECal module are connected to which ports of the PNA for the DoECAL1Port and DoECAL2Port methods when the OrientECALModule property = False.

VB Syntax

cal.ECALPortMap = value

Variable

(Type) - Description

cal

A Calibrator (object)

value

(string)

(string) -Format this parameter in the following manner:

Aw,Bx,Cy,Dz

where

  • A, B, C, and D are literal ports on the ECAL module

  • w,x,y, and z are substituted for PNA port numbers to which the ECAL module port is connected.

Ports of the module which are not used are omitted from the string.

For example, on a 4-port ECal module with

  • port A connected to PNA port 2

  • port B connected to PNA port 3

  • port C not connected

  • port D connected to PNA port 1

the string would be: A2,B3,D1

DoECAL1Port or DoECAL2Port methods will fail if the port numbers passed to those methods are not in the string of this property and OrientECALModule property = False.

Return Type

String

Default

Not Applicable

Examples

Dim cal As Calibrator
Dim sPortMap As String
Set cal = PNAapp.ActiveChannel.Calibrator
cal.ECALPortMap = “a2,b1” 'Write
sPortMap = cal.ECALPortMap 'Read

C++ Syntax

HRESULT put_ECALPortMap(tagNAECALModule ecalModule, BSTR strPortMap);

HRESULT get_ECALPortMap(tagNAECALModule ecalModule, BSTR *strPortMap);

Interface

ICalibrator3


IsECALModuleFound Property

Read only
About ECAL

IsECALModuleFound Property - Obsolete

Description

Note: This property is replaced by IsECALModuleFoundEx Property.

Tests communication between the PNA and the specified ECal module.

VB Syntax

modFound = cal.IsECALModuleFound (module)

Variable

(Type) - Description

modFound

(boolean) - Variable to store the returned test result.

True - The PNA identified the presence of the specified ECal module.

False - The PNA did NOT identify the presence of the specified ECal module.

cal

(object) - A Calibrator object

module

(enum NAECALModule) – ECAL module. Choose from:

0 - naECALModule_A

1 - naECALModule_B

Return Type

Boolean

Default

Not applicable

Examples

Set cal = pna.ActiveChannel.Calibrator

moduleFound = cal.IsECALModuleFound(naECALModule_A)

C++ Syntax

HRESULT get_IsECALModuleFound(tagNAECALModule moduleNumber, VARIANT_BOOL *bModuleFound);

Interface

Calibrator


Control SCPI

Control Auxiliary Commands

Specifies the settings to remotely control the Auxilliary IO connector.

  • Click on a blue keyword to view the command details.

  • See a List of all SCPI commands.

  • See a pinout and detailed description of the Auxilliary IO connector.

CONTrol:AUXiliary:C[:DATA] <num>

(Read-Write) Reads and writes a 4-bit value to Port C on the Aux I/O connector. This port is connected internally to the Handler IO connector. Therefore this command will also affect the state of Port C on the Handler IO
Parameters |
<num> | Data value. Choose any number 0 to 15.
Examples | CONTrol:AUXiliary:C:DATA 15 For Positive Logic Port C lines C0, C1, C2, C3 go High or if in Negative Logic they go Low. CONTrol:AUXiliary:C:DATA? A returned value of 15 when in Positive Logic indicates Port C lines C0, C1, C2, C3 are High, or if in Negative Logic they are Low.
Query Syntax | CONTrol:AUXiliary:C:DATA?
Return Type | Numeric
Overlapped? | No
Default | 0

CONTrol:AUXiliary:C:LOGic <char>

(Read-Write) Reads and writes the logic mode of Port C on the AUX IO. This port is connected to Port C of the Handler IO connector. Therefore, it will have the same logic setting.

Parameters

<char>

Logic of Port C. Choose from:

POSitive - when a value of one is written the associate line goes High.

NEGative - when a value of one is written the associate line goes Low.

When Port C is in Output/Write mode, a change in logic causes the output lines to change state immediately. For example, Low levels change to High levels.

When Port C is in Input/Read mode, a change in logic does NOT cause the lines to change, but data read from Port C will reflect the change in logic.

Examples

CONT:AUX:C:LOG POS 'Positive logic is applied to Port C data.

Query Syntax

CONTrol:AUXiliary:C:LOGic?

Return Type

Character

Overlapped?

No

Default

NEGative

CONTrol:AUXiliary:C:MODE <char>

(Read-Write) Sets Port C to read or write mode. This port is connected to Port C of the Handler IO connector. Therefore, it will have the same mode setting.

NOTE: When Port C is set to INPut mode, data writes are NOT applied to the lines. MODE must be set to OUTPut mode before writing.

Parameters

<char>

INPut - set the port for reading

OUTPut - set the port for writing

Examples

CONT:AUX:C:MOD INP 'set Port C to Input Mode for reading.

CONTrol:AUXiliary:C:MODE? 'queries the input/output mode that the port set to.

Query Syntax

CONTrol:AUXiliary:C:MODE?

Return Type

Character

Overlapped?

No

Default

INPut

CONTrol:AUXiliary:FOOTswitch?

(Read only) Reads the Auxiliary connector Footswitch Input (pin 20 of the AUX IO connector).
Examples | CONT:AUX:FOOT? control:auxiliary:footswitch?
Return Type | Boolean True (or 1) = pressed False (or 0) = released
Overlapped? | No
Default | False (0) - Released

CONTrol:AUXiliary:FOOTswitch:MODe <char>

(Read-Write) This command sets the mode of the "FootSwitch In" line on the Auxiliary IO. These mode settings determine what occurs when the footswitch is pressed. Examine your results carefully when using these command modes. Refer to each mode description and associated notes, also see the FootSwitch In pin description in the Auxiliary IO connector documentation.

Parameters

<char>

IGNore - While in this mode any Footswitch presses are ignored.

SWEep - While in this mode a Footswitch press will trigger the sweep.

NOTE: The instrument must be in Manual Trigger Mode.

RECall - While in this mode a Footswitch press will recall an instrument state. When more than one state is available each footswitch press recalls the next state, then starts over from the beginning.

NOTE: It's possible to override the current mode with a recalled state. For instance when the current footswitch mode is RECall and the footswitch mode in the recalled state is IGNore the mode will change to IGNore. If this occurs additional footswitch presses will be ignored.

MACRo - While in this mode a Footswitch press will load and run a macro. When more than one macro are available each successive footswitch press loads and runs the next macro, then starts over from the beginning.

NOTE: It's possible to override the current mode when using the MACRo mode. For instance with the current footswitch mode set to MACRo and then running a macro containing a Preset the Preset will change the mode to IGNore because the default-preset mode is IGNore. If this occurs additional footswitch presses will be ignored.

Examples

CONT:AUX:FOOT:MODe MACRo This sets the footswitch mode to MACRo causing a macro to be loaded and run with a footswitch press.

CONTrol:AUXiliary:FOOTswitch:MODe? This query returns the footswitch mode setting.

Query Syntax

CONTrol:AUXiliary:FOOTswitch:MODE?

Return Type

Character

Overlapped?

No

Default

IGNore

CONTrol:AUXiliary:INPut:VOLTage?

(Read-Only) Reads the ADC input voltage from pin 14 of the AUX IO connector.
Examples | CONT:AUX:INPut:VOLT? control:auxiliary:input:voltage?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

CONTrol:AUXiliary:OUTPut[1|2]:MODe <char>

(Read-Write) This command sets the mode of the selected "Analog Out" line on the Auxiliary IO. The modes give the user the option to have the requested voltage applied immediately or not until the sweep is done. Also see the description for "Analog Out 1, 2" in the Auxiliary IO connector documentation.

Parameters

<char>

WAIT - While in this mode any voltage changes sent to the selected analog out will only get applied to the output between sweeps.

NOWait - While in this mode any voltage changes sent to the selected analog out will occur right away without waiting until the end of a sweep.

Examples

CONT:AUX:OUTP1:MOD WAIT This sets the mode so that voltages sent to "Analog Out 1" are only applied at the end of a sweep.

CONT:AUX:OUTP2:MOD? This query returns the current mode for "Analog Out 2".

Query Syntax

CONTrol:AUXiliary:OUTPut2:MODe?

'Reads the output mode

Return Type

Character

Overlapped?

No

Default

WAIT

CONTrol:AUXiliary:OUTPut<out>:VOLTage <num>

(Read-Write) Sets and reads voltages on the DAC/Analog Output 1 and Output 2 (pins 2 and 3) of the Auxiliary IO connector.
Parameters |
<out> | DAC output number. Choose from: 1 - DAC Output 1 (pin 2) 2 - DAC Output 2 (pin 3)
<num> | Output Voltage. Choose a voltage value between -10 and +10 volts
Examples | CONT:AUX:OUTP1:VOLT 5 control:auxiliary:output2:voltage 5
Query Syntax | CONTrol:AUXiliary:OUTPut<out>:VOLTage? 'Reads the output DAC voltage
Return Type | Numeric
Overlapped? | No
Default | 0

CONTrol:AUXiliary:PASSfail:LOGic <char>

(Read-Write) Sets the logic of the PassFail line (pin 12) on the AUX IO connector. This line is connected internally to the PassFail line of the Material Handler IO (pin 33).
Parameters |
<char> | Choose from: POSitive - Causes the PassFail line to have positive logic (high = pass, low = fail). NEGative - Causes the PassFail line to have negative logic (high = fail, low = pass).
Examples | CONT:AUX:PASS:LOG POS control:auxiliary:passfail:logic negative
Query Syntax | CONTrol:AUXiliary:PASSfail:LOGic?
Return Type | Character
Overlapped? | No
Default | POSitive

CONTrol:AUXiliary:PASSfail:MODe <char>

(Read-Write) Sets and reads the default logical pass/fail state. This is the state the pass/fail line stays in until a failure occurs (if the mode is NOWait), or until an end-of-sweep condition occurs (if the modes is PASS or FAIL).

The end-of-sweep condition is determined by the CONTrol:AUXiliary:PASSfail:SCOPe command.

Parameters

<char>

Choose from:
PASS - the line stays in PASS state until the end-of-sweep condition occurs, at which time the pass/fail line is set, and the pass/fail strobe (line 36) is activated.

FAIL - the line stays in FAIL state until the end-of-sweep condition occurs, at which time the pass/fail line is set, and the pass/fail strobe (line 36) is activated.

NOWait - the pass/fail line is set, and the pass/fail strobe (line 36) is activated as soon as a failure condition occurs.

Examples

CONT:AUX:PASS:MODE NOW
control:auxiliary:passfail:mode fail

Query Syntax

CONTrol:AUXiliary:PASSfail:MODE?

Return Type

Character

Overlapped?

No

Default

NOWait

CONTrol:AUXiliary:PASSfail:SCOPe <char>

(Read-Write) Sets and reads the scope of pass/fail testing. The pass/fail line can report the status of all measurements on each channel, or all measurements on all channels. This command selects which option to use.

Parameters

<char>

Choose from:

Channel - A pass/fail result is computed and written to the output pins at the end of all sweeps on a channel.

GLOBal - A pass/fail result is computed and written to the output pins at the end of all sweeps on a channel.

If the pass/fail mode is NOWait (as set by CONTrol:AUXiliary:PASSfail:MODe), the status and strobe pins are written immediately. Otherwise the pins are written as indicated above. Regardless of the mode value, the pass/fail line is returned to its default state (as set by the MODE command) at the end of channel or group of channels.

Examples

CONT:AUX:PASS:SCOP CHAN
control:auxiliary:passfail:scope sweep

Query Syntax

CONTrol:AUXiliary:PASSfail:SCOPe?

Return Type

Character

Overlapped?

No

Default

GLOBal

CONTrol:AUXiliary:PASSfail:POLicy <char>

(Read-Write) Sets the policy used to determine how global pass/fail is computed.
Parameters |
<char> | Name of the policy to use. Choose from: ALLTests - Pass/Fail Status returns PASS if all tests on all measurements pass. ALLMeas - Pass/Fail Status returns PASS if all measurements have associated tests, and all tests pass. FAIL is returned if even one measurement has no associated limit test. Only those measurements which are not in HOLD mode contribute to the pass/fail result.
Examples | CONT:AUX:PASS:POL ALLM control:auxiliary:passfail:policy alltests
Query Syntax | CONTrol:AUXiliary:PASSfail:POLicy?
Return Type | Character
Overlapped? | No
Default | ALLTests

CONTrol:AUXiliary:PASSfail:STATus?

(Read-Only) Returns the most recent pass/fail status value. Use this command as follows:

  1. Set the PNA trigger scope to ALL

  2. Set the PNA trigger source to MANUAL or EXTERNAL.

  3. Trigger the PNA.

  4. Use the *OPC? command to determine when the sweep is complete.

  5. Use the CONT:AUX:PASS:STAT? query to obtain the global pass/fail result.

Return Type

Character - One of the following is returned:

PASS - all measurements not in HOLD mode have been swept, and all associated limit tests have passed.

FAIL - all measurements not in HOLD mode have been swept, and one or more limit tests failed according to the specified Pass/Fail policy.

NONE - status cannot be determined because measurements are in progress.

Overlapped?

No

Default

Not Applicable

CONTrol:AUXiliary:SWEepend <char>

(Read-Write) Specifies the event that will cause the AUX IO Sweep End line (pin 11) to go to a low (false) state. The line will return to a high state after the appropriate calculations are complete. This line is connected internally to the Sweep End line of the Material Handler IO.
Parameters |
<char> | Choose from: Sweep - the line goes low when each sweep is complete. Channel - The line goes low when all of the sweeps for each channel is complete. Global - The line goes low when all the sweeps for all channels are complete.
Examples | CONT:AUX:SWE SWE control:auxiliary:sweepend channel
Query Syntax | CONTrol:AUXiliary:SWEepend?
Return Type | Character
Overlapped? | No
Default | SWEep


Control SCPI

Control External Test Set Commands

Specifies the settings to remotely control the External Test Set IO connector.

  • Click on a blue keyword to view the command details.

  • See a List of all SCPI commands.

  • See a pinout and detailed description of the External Test Set IO connector

CONTrol:EXTernal:TESTset:DATa <addr>,<data>

(Read-Write) Reads and writes 13 bits of data to the specified address using the AD0 through AD12 lines of the external test set connector. The instrument generates the appropriate timing signals (strobes the address, then the data) to control an external test set.
Parameters |
<addr> | Decimal equivalent of the 13 bit binary address.
<data> | Decimal equivalent of the 13 bit binary data
Examples | CONT:EXT:TEST:DATA 12,3 CONTrol:external:testset:data 12,3
Query Syntax | CONTrol:EXTernal:TESTset:DATA? <addr> 'Reads the decimal equivalent of the binary data from the specified address
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

CONTrol:EXTernal:TESTset:INTerrupt?

(Read-Only) Reads the boolean state of the Interrupt In line (pin 13) on the external test set connector.
Examples | CONT:EXT:TEST:INT? control:external:testset:interrupt?
Return Type | Boolean False (0) - the line is being held at a TTL High. True (1) - the line is being held at a TTL Low.
Overlapped? | No
Default | Not Applicable

CONTrol:EXTernal:TESTset:RAWData <data>

(Read-Write) Reads and writes 16 bits of data through the AD0 through AD12 and three timing lines of the external test set connector. Does NOT generate appropriate timing signals.

Use of this command requires detailed knowledge of all 16 bits. Refer to the Data format table.

Note: During a WRITE, Bit 13 must always be low. Otherwise Bit 0-12 will tristate

Parameters

<data>

Decimal equivalent of the binary data.

Format of data WRITTEN with RAWData:

Pin | Bit | Signal name
22 | 0 | AD0*
23 | 1 | AD1*
11 | 2 | AD2*
10 | 3 | AD3*
9 | 4 | AD4*
21 | 5 | AD5*
20 | 6 | AD6*
19 | 7 | AD7*
6 | 8 | AD8*
5 | 9 | AD9*
4 | 10 | AD10*
17 | 11 | AD11*
3 | 12 | AD12*
25 | 13 | RLW
24 | 14 | LDS
8 | 15 | LAS

* This Output will float if RLW (bit-13) is set high

Examples | CONT:EXT:TEST:RAWD 8001 CONTrol:external:testset:rawdata 1234
Query Syntax | CONTrol:EXTernal:TESTset:RAWData?
Return Format | Format of data READ with RAWData?
Pin | Bit | Signal name
22 | 0 | AD0*
23 | 1 | AD1*
11 | 2 | AD2*
10 | 3 | AD3*
9 | 4 | AD4*
21 | 5 | AD5*
20 | 6 | AD6*
19 | 7 | AD7*
6 | 8 | AD8*
5 | 9 | AD9*
4 | 10 | AD10*
17 | 11 | AD11*
3 | 12 | AD12*
2 | 13 | Sweep Holdoff In
13 | 14 | Interrupt In (inverted internally)
na | 15 | Always Zero, grounded internally
 | *These lines are dependent on the state of RLW (pin25). Writing a 0(low) to RLW will set lines AD0-AD12 to write mode. Writing a 1(high) to RLW will set lines AD0-AD12 to read mode.
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

CONTrol:EXTernal:TESTset:SWEepholdoff?

(Read-Only) Reads the Sweep Holdoff Iine (pin 2) on the external test set connector.
Examples | CONT:EXT:TEST:SWE? control:external:testset:sweepholdoff?
Return Type | Boolean TRUE (1) - the pin is set to a TTL High FALSE (0) - the pin is set to TTL Low
Overlapped? | No
Default | Not Applicable


Control SCPI

Control Handler Commands

Specifies the settings to remotely control the Material Handler IO connector.

  • Click on a blue keyword to view the command details.

  • See a List of all SCPI commands.

  • Learn about the Material Handler IO port.

CONTrol:HANDler:C:MODE <char>

(Read-Write) Sets and reads the direction of data flow for Port C.
Parameters |
<char> | Direction of flow. Choose from: INPut - Port C is used to input data OUTPut - Port C is used to output data
Examples | CONT:HAND:C:MODE INP control:handler:c:mode output
Query Syntax | CONTrol:HANDler:C:MODE?
Return Type | Character
Overlapped? | No
Default | INPut

CONTrol:HANDler:D:MODE <char>

(Read-Write) Sets and reads the direction of data flow for Port D.
Parameters |
<char> | Direction of flow. Choose from: INPut - Port D is used to input data OUTPut - Port D is used to output data
Examples | CONT:HAND:D:MODE INP control:handler:d:mode output
Query Syntax | CONTrol:HANDler:D:MODE?
Return Type | Character
Overlapped? | No
Default | Input

CONTrol:HANDler:<port>[:DATa] <num>

(Read-Write) Writes and reads data on the specified port.
Parameters |
<port> | Port identifier to set bits for. Choose from: A,B,C,D,E,F,G,H
<num> | The number of the data bits to set. Refer to the following table for the maximum number for each port. The minimum number for each port is 0.
Port | Max allowable <num> | MSB...........................................LSB 23...................................................0 |
A | 255 | A7...A0 | Write-only
B | 255 | B7...B0 | Write-only
C | 15 | C3...C0 | Read-Write
D | 15 | D3...D0 | Read-Write
E | 255 | D3...D0 + C3...C0 | Read-Write
F | 65535 | B7...B0 + A7...A0 | Write-only
G | 1048575 | C3...C0 + B7...B0 + A7...A0 | Write-only
H | 16777215 | D3...D0 + C3...C0 + B7...B0 + A7...A0 | Write-only
 | Note: When writing to port G, port C must be set to output mode When writing to port H, both port C and port D must be set to output mode. Use CONT:HAND:C:MODE OUTP and CONT:HAND:D:MODE OUTP
Examples | CONT:HAND:A 254 control:handler:c:data 12
Query Syntax | CONTrol:HANDler:<port>:DATA?
Return Type | Numeric
Overlapped? | No
Default | Not Applicable

CONTrol:HANDler[:EXTension]:INDex:STATe <bool>

(Read-Write) Determines the control of Material Handler connector Pin 20.
Parameters |
<char> | Choose from: ON (1) - Pin 20 is controlled by the Index signal OFF (0) - Pin 20 is controlled by Output Port B6
Examples | CONT:HAND:IND:STAT 1 control:handler:extension:index:state off
Query Syntax | CONTrol:HANDler[:EXTension]:INDex:STATe?
Return Type | Boolean
Overlapped? | No
Default | OFF

CONTrol:HANDler[:EXTension]:RTRigger:STATe <bool>

(Read-Write) Determines the control of Material Handler connector Pin 21.
Parameters |
<char> | Choose from: ON (1) - Pin 21 is controlled by the Ready for Trigger signal OFF (0) - Pin 21 is controlled by Output Port B7
Examples | CONT:HAND:RTR:STAT 1 control:handler:extension:rtrigger:state off
Query Syntax | CONTrol:HANDler[:EXTension]:RTRigger:STATe?
Return Type | Boolean
Overlapped? | No
Default | OFF

CONTrol:HANDler:INPut?

(Read-Only) Reads a hardware latch that captures high to low transitions on Input1 of the Material Handler IO. Reading the latch causes it to reset and is ready for the next transition. The hardware latch is only capable of capturing one transition per query. Additional transitions are ignored until after the next query. Momentarily driving Input1 high, then low, will cause a transition to be detected and latched.
Examples | CONT:HAND:INP? control:handler:input?
Return Type | Integer - Returns a value of zero or one. 0 - A high to low transition occurred at Input1 since the last time it was queried. 1 - No high to low transition occurred. After the query the latch is reset and is ready for the next input. If no low to high transitions occur additional queries will return zero.
Overlapped? | No
Default | Not Applicable

CONTrol:HANDler:LOGic <char>

(Read-Write) Sets the logic of the Data ports A-H on the Handler connector. Some of these lines are connected internally to the AuxIO.

Parameters

<char>

Choose from:
POSitive- Causes the Port lines to have positive logic (high = 1, low = 0).

NEGative- Causes the Port lines to have negative logic (high = 0, low = 1).

For ports that are in output (write) mode, a change in logic causes the output lines to change state immediately. For example, Low levels change immediately to High levels.

For ports that are in input (read) mode (C,D,E only), a change in logic will be reflected when data is read from that port. For example, if a line read 0, the next read after a logic change will read 1.

Examples

CONT:HAND:LOG POS
control:handler:logic negative

Query Syntax

CONTrol:HANDler:LOGic?

Return Type

Character

Overlapped?

No

Default

NEGative

CONTrol:HANDler:OUTPut<port>[:DATa] <num>

(Read-Write) Sets or reads the specified output line. Type 1 and Type 2 configurations: Returns the last value written to the selected output pin. Type 3 configuration: Returns the current state of the selected output pin. If an Input1 trigger occurs, the state may not be the same value as was written.
Parameters |
<port> | Output port. Choose from: 1 - output 1(default) 2 - output 2
<num> | 0 - Low 1 - High
Examples | CONT:HAND:OUTPut1 1 control:handler:output2:data 0
Query Syntax | CONTrol:HANDler:OUTPut<num>:DATA?
Return Type | Boolean
Overlapped? | No
Default | 0 - Low

CONTrol:HANDler:OUTPut<port>:USER[:DATa] <num>

(Read-Write) Sets or reads the specified USER output line. Type 1 and Type2 configurations: Returns the last value written to the selected output pin. Type3 configuration: Returns the current state of the selected output pin. If an Input1 trigger occurs, the state may not be the same value as was written. Learn about User Output.
Parameters |
<port> | USER Output port. Choose from: 1 - User output 1(default) 2 - User output port.
<num> | 0 - Low 1 - High
Examples | CONT:HAND:OUTPut1:USER 1 control:handler:output2:user:data 0
Query Syntax | CONTrol:HANDler:OUTPut<num>:USER:DATA?
Return Type | Boolean
Overlapped? | No
Default | 0 - Low

CONTrol:HANDler:PASSfail:LOGic <char>

(Read-Write) Sets the logic of the PassFail line of the Material Handler IO (pin 33). This line is connected internally to the PassFail line (pin 12) on the AUX IO connector.
Parameters |
<char> | Choose from: POSitive- Causes the PassFail line to have positive logic (high = pass, low = fail). NEGative- Causes the PassFail line to have negative logic (high = fail, low = pass).
Examples | CONT:HAND:PASS:LOG POS control:handler:passfail:logic negative
Query Syntax | CONTrol:HANDler:PASSfail:LOGic?
Return Type | Character
Overlapped? | No
Default | POSitive

CONTrol:HANDler:PASSfail:MODe <char>

(Read-Write) Sets and reads the default logical pass/fail state. This is the state the pass/fail line stays in until a failure occurs (if the mode is NOWait), or until an end-of-sweep condition occurs (if the mode is PASS or FAIL).

The end-of-sweep condition is determined by the CONTrol:HANDler:PASSfail:SCOPe command.

Parameters

<char>

Choose from:

PASS- the line stays in PASS state until the end-of-sweep condition occurs, at which time the pass/fail line is set, and the pass/fail strobe (line 36) is activated.

FAIL- the line stays in FAIL state until the end-of-sweep condition occurs, at which time the pass/fail line is set, and the pass/fail strobe (line 36) is activated.

NOWait- the pass/fail line is set, and the pass/fail strobe (line 36) is activated as soon as a failure condition occurs.

Examples

CONT:HAND:PASS:MODE NOW
control:handler:passfail:mode fail

Query Syntax

CONTrol:HANDler:PASSfail:MODE?

Return Type

Character

Overlapped?

No

Default

NOWait

CONTrol:HANDler:PASSfail:SCOPe <char>

(Read-Write) Sets and reads the scope of pass/fail testing. The pass/fail line on the material handler port can report the status of all measurements on each channel, or all measurements on all channels. This command selects which option to use.

Parameters

<char>

Choose from:

CHANnel - A pass/fail result is computed and written to the output pins at the end of all sweeps on a channel.

GLOBal - A pass/fail result is computed and written to the output pins at the end of all sweeps on a channel.

If the pass/fail mode is NOWait (as set by CONTrol:HANDler:PASSfail:MODe), the status and strobe pins are written immediately. Otherwise the pins are written as indicated above. Regardless of the mode value, the pass/fail line is returned to its default state (as set by the MODE command) at the end of channel or group of channels.

Examples

CONT:HAND:PASS:SCOP CHAN
control:handler:passfail:scope sweep

Query Syntax

CONTrol:HANDler:PASSfail:SCOPe?

Return Type

Character

Overlapped?

No

Default

GLOBal

CONTrol:HANDler:PASSfail:POLicy <char>

(Read-Write) Sets the policy used to determine how global pass/fail is computed.
Parameters |
<char> | Name of the policy to use. Choose from: ALLTests - Pass/Fail Status returns PASS if all tests on all measurements pass. ALLMeas - Pass/Fail Status returns PASS if all measurements have associated tests, and all tests pass. FAIL is returned if even one measurement has no associated limit test. Only those measurements which are not in HOLD mode contribute to the pass/fail result.
Examples | CONT:HAND:PASS:POL control:handler:passfail:policy
Query Syntax | CONTrol:HANDler:PASSfail:POLicy?
Return Type | Character
Overlapped? | No
Default | ALLTests

CONTrol:HANDler:PASSfail:STATus?

(Read-Only) Returns the most recent pass/fail status value. Use this command as follows:

  1. Set the PNA trigger scope to GLOBAL

  2. Set the PNA trigger source to MANUAL or EXTERNAL.

  3. Configure and enable Limit Testing

  4. Trigger the PNA.

  5. Use the *OPC? command to determine when the sweep is complete.

  6. Use the CONT:HAND:PASS:STAT? query to obtain the global pass/fail result.

Return Type

Character - One of the following is returned:

PASS - all measurements not in HOLD mode have been swept, and all associated limit tests have passed.

FAIL - all measurements not in HOLD mode have been swept, and one or more limit tests failed according to the specified Pass/Fail policy.

NONE - status cannot be determined because measurements are in progress.

Overlapped?

No

Default

Not Applicable

CONTrol:HANDler:SWEepend <char>

(Read-Write) Specifies the event that will cause the Handler Sweep End line to strobe. The strobe is at least 10ms in duration, and is activated when all calculations for the associated measurement are complete. This line is connected internally to the Sweep End line of the AUX IO connector.
Parameters |
<char> | Choose from: SWEep - the line goes low when each sweep is complete CHANnel - the line goes low when all the sweeps for each channel is complete. GLOBal - the line goes low when all sweeps for all channels are complete. The default state of the passFail line (before a measurement occurs) and after a failure occurs is set by CONTrol:HANDler:PASSfail:MODe
Examples | CONT:HAND:SWE SWE control:handler:sweepend channel
Query Syntax | CONTrol:HANDler:SWEepend?
Return Type | Character
Overlapped? | No
Default | GLOBal


Local Lockout

Local Lockout (LLO) Message

Normally, a GPIB instrument is put in remote mode by asserting the Remote Enable (REN) GPIB line. At that time, all front panel keys (except the Local key) are locked to prevent user interaction.

Sending the LLO message over the GPIB further locks out the keyboard, mouse, and Local key during execution of your GPIB program. The syntax of the LLO message depends on the GPIB driver you are using. Consult your GPIB software users manual.

The PNA requires these two actions to occur in order:

  1. Controller sends the LLO (Local Lockout) message

  2. Controller asserts the REN (Remote Enable) GPIB line

The PNA will then go into remote mode with full lockout capability.

This feature is also supported using SICL over LAN.


Status Keywords SCPI

Status Command Keywords

The following keywords can be appended to the node or nodes that represent the Status register you want to control.

  • :CONDition?

  • :ENABle

  • :ENABle?

  • :EVENt?

  • :MAP

  • :NTRansition

  • :PTRansition

Learn about Status Registers

:CONDition?

Monitors the conditions as they occur REAL TIME. That is, a condition may occur, and then clear before the condition is read. Reading this register returns a 16-bit decimal weighted number.

:ENABle <bit>

Enables register bits that will monitored using the service request (SRQ) method. (To use the direct read method, you do not have to enable the bit.)

Default value for STATus:QUEStionable:ENABle and STATus:OPERation:ENABle is 0: No bits enabled.

Default value for all other registers :ENABle <bits> is 32767; ALL BITS ENABLED.

Therefore it is ONLY necessary to send the ENABle keyword if you want to DISABLE some conditions. For example, to enable ONLY Trace1 (bit 2) of the LIMIT1 register (disable all other traces) , send: STATus:QUEStionable:LIMit1:ENABle 4

:ENABle?

Read the enable register to verify the bits that you enabled. Returns a 16 bit weighted sum of the bits that are enabled.

[:EVENt]?

Query only - This is the Default keyword for most registers. Use it to determine if a condition has occured. These bits remain set until they are read or otherwise cleared.

:MAP <bit>,<error>

Associates a bit is the User register with an error number. For example

STATus:QUEStionable:DEFine:USER2:MAP 0,-113

0 is the bit that will be set

-113 is the error

When error -113 "Undefined Header" occurs, bit 0 in the USER2 register will be set to 1.

:NTRansition <bits>

Write-Read - Negative Transition register bits set the condition to be set on the Negative going (True to False) transition. Use this register if you are only interested in a condition changing from True to False.

:NTRansition?

queries the register to verify that you set a negative transition.

:PTRansition <bits>

Write-Read - Positive Transition register bits set the condition to be set on the False to True transition. Use this register if you are only interested in the change of a condition from False to True.

:PTRansition?

Queries the register to verify that you set a positive transition.


FSimulatorBalun

Calc:FSimulator:Balun Commands

Note: These commands are ONLY available on 4-port PNA models with code release 5.0 and above.


FSimulatorSend

Calc:FSimulator:Send Commands

Note: These commands are ONLY available on 4-port PNA models with code release 5.0 and above.


Offset

Calc:Offset Commands

Allows the data trace magnitude and phase to be offset.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Magnitude Offset

  • Learn about Phase Offset

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:OFFSet:MAGNitude <num>

(Read-Write) Offsets the data trace magnitude by the specified value. To offset the data trace magnitude to a slope value that changes with frequency, use CALC:OFFS:MAGN:SLOP Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Offset value in dB.
Examples | CALC:OFFS:MAGN:4 calculate1:offset:magnitude -2
Query Syntax | CALCulate<cnum>:OFFSet:MAGNitude?
Return Type | Numeric
Overlapped? | No
Default | 0

CALCulate<cnum>:OFFSet:MAGNitude:SLOPe <num>

(Read-Write) Offsets the data trace magnitude to a value that changes linearly with frequency. The offset slope begins at 0 Hz. Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Offset slope value in dB/ 1GHz.
Examples | CALC:OFFS:MAGN:SLOP 1 'Offset slope set to 1dB/GHz calculate1:offset:magnitude:slope -2 'Offset slope set to -2dB/GHz
Query Syntax | CALCulate<cnum>:OFFSet:MAGNitude:SLOPe?
Return Type | Numeric
Overlapped? | No
Default | 0

CALCulate<cnum>:OFFSet:PHASe <num>[<char>]

(Read-Write) Sets the phase offset for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Offset phase value. Choose any number between: -360 and 360
<char> | Units for phase. OPTIONAL. Choose either: DEG - Degrees (default) RAD - Radians
Examples | CALC:OFFS:PHAS 10 calculate:offset:phase 20rad
Query Syntax | CALCulate:OFFSet:PHASe?
Return Type | Numeric, returned value always in degrees
Overlapped? | No
Default | 0 degrees


Getting and Putting Data

This Rocky Mountain Basic example does the following:

  1. Takes a sweep, and reads the formatted data trace into an array. The trace is read as a definite length block.

  2. Instructs you to remove DUT

  3. Downloads the trace back to the analyzer as an definite length block.

See Other SCPI Example Programs

100 DIM A$[10],Data1(1:51)
110 INTEGER Digits,Bytes
120 !
130 COM /Sys_state/ @Hp87xx,Scode
140 ! Identify I/O Port
150 CALL Iden_port
160 !
170 !
180 OUTPUT @Hp87xx;"SYST:PRES"
190 !
200 OUTPUT @Hp87xx;"CALC:PAR:SEL 'CH1_S11_1'"
210 !
220 ! Set up the analyzer to measure 51 data points.
230 OUTPUT @Hp87xx;"SENS1:SWE:POIN 51;*OPC?"
240 ENTER @Hp87xx;Opc
250 !
260 ! Take a single sweep, leaving the analyzer
270 ! in trigger hold mode.
280 OUTPUT @Hp87xx;"ABOR;:INIT1:CONT OFF;:INIT1;*WAI"
290 !
300 ! Select binary block transfer
310 OUTPUT @Hp87xx;"FORM:DATA REAL,64"
320 !
330 ! Request the channel 1 formatted data array
340 ! from the analyzer.
350 OUTPUT @Hp87xx;"CALC:DATA? FDATA"
360 !
370 ! Turn on ASCII formatting on the I/O path.
380 ! It is needed for reading the header
390 ! information.
400 ASSIGN @Hp87xx;FORMAT ON
410 !
420 ! Get the data header. "A$" will contain the
430 ! "#" character indicating a block data transfer.
440 ! "Digits" will contain the number of characters
450 ! for the number of bytes value which follows.
460 ENTER @Hp87xx USING "%,A,D";A$,Digits
470 !
480 ! Get the rest of the header. The number of
490 ! bytes to capture in the data array will be
500 ! placed in "Bytes". Note the use of "Digits"
510 ! in the IMAGE string.
515 !
520 ENTER @Hp87xx USING "%,"&VAL$(Digits)&"D";Bytes
525 PRINT "HEADER",A$,Digits,Bytes
530 !
540 ! Turn off ASCII formatting on the I/O path;
550 ! it is not needed for transferring binary
560 ! formatted data.
570 ASSIGN @Hp87xx;FORMAT OFF
580 !
590 ! Get the data.
600 ENTER @Hp87xx;Data1(*)
610 !
620 ! Turn on ASCII formatting again.
630 ASSIGN @Hp87xx;FORMAT ON
640 !
650 ! Get the "end of data" character.
660 ENTER @Hp87xx;A$
670 !
680 ! Display the first three numbers in the array.
690 DISP "Trace: ";Data1(1);Data1(2);Data1(3);"..."
700 !
710 ! Use this time to visually compare the
720 ! numbers to the visible data trace.
730 WAIT 5
740 !
750 ! Prompt the operator to disconnect the test
760 ! device and how to continue the program.
770 DISP "Disconnect the test device -- Press Continue"
780 PAUSE
790 !
800 ! Update the display line.
810 DISP "Taking a new sweep...";
820 !
830 ! Take a sweep so the display shows new data.
840 OUTPUT @Hp87xx;":INIT1;*WAI"
850 DISP " Done."
860 WAIT 5
870 !
880 ! Send the header for an indefinite block length
890 ! data transfer.
900 DISP "Downloading saved trace...";
915 ! The first byte '3' indicates the next three digits equal number of transfer bytes
916 ! The number of transfer bytes equals 8x the number of tracepoints.
920 OUTPUT @Hp87xx;"CALC:DATA FDATA, #3408";
930 !
940 ! Turn off ASCII formatting.
950 ASSIGN @Hp87xx;FORMAT OFF
960 !
970 ! Send the data array back to the analyzer.
980 OUTPUT @Hp87xx;Data1(*),END
990 !
1000 ! Turn on ASCII formatting again.
1010 ASSIGN @Hp87xx;FORMAT ON
1020 DISP " Done!"
1030 END
1040 !
1050 !**************************************************************
1060 ! Iden_port: Identify io port to use
1070 ! Description: This routines sets up the I/O port address for
1080 ! the SCPI interface. For "HP 87xx" instruments,
1090 ! the address assigned to @Hp87xx = 800 otherwise,
1100 ! 716.
1110 !**************************************************************
1120 SUB Iden_port
1130 COM /Sys_state/ @Hp87xx,Scode
1140 !
1150 IF POS(SYSTEM$("SYSTEM ID"),"HP 87")<>0 THEN
1160 ASSIGN @Hp87xx TO 800
1170 Scode=8
1180 ELSE
1190 ASSIGN @Hp87xx TO 716
1200 Scode=7
1210 END IF
1220 !
1230 SUBEND !Iden_port
1240 !


Perform Guided ECal

Perform Guided ECal using SCPI

This VBScript program performs a Guided ECal Calibration. While this example is good to use as a starting point for Guided ECal, the Guided comprehensive cal example has some advanced features that are not in this program.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as Guided.vbs. Learn how to setup and run the macro.

' Performing a 2-port cal (Ports 1 and 2)
Dim app
Dim scpi

' Create / Get the PNA application.
Set app = CreateObject("AgilentPNA835x.Application")
Set scpi = app.ScpiStringParser

' Specify the DUT connectors
' (for each connector of your DUT, one of the ECal module's ports must have
' that same connector, or else you cannot achieve the cal using that module).
scpi.Execute "sens:corr:coll:guid:conn:port1 ""APC 3.5 female"" "
scpi.Execute "sens:corr:coll:guid:conn:port2 ""APC 3.5 male"" "

' Note: If your PNA has more than 2 ports, you would need to uncomment
' one or both of these next two lines, to explicitly specify this is
' just a 2-port cal.
'scpi.Execute "sens:corr:coll:guid:conn:port3 ""Not used"" "
'scpi.Execute "sens:corr:coll:guid:conn:port4 ""Not used"" "
MsgBox "Connectors defined for Ports 1 and 2"

' Select the ECal module for each port being calibrated.
' Use the part number printed on your module (which in our case was N4691-60004),
' followed by the word 'ECal'. Your ECal module must already be connected
' via USB to the PNA.
scpi.Execute "sens:corr:coll:guid:ckit:port1 ""N4691-60004 ECal"" "
scpi.Execute "sens:corr:coll:guid:ckit:port2 ""N4691-60004 ECal"" "
MsgBox "Cal kits defined for Ports 1 and 2"

' Initiate the calibration and query the number of steps
scpi.Execute "sens:corr:coll:guid:init"
numSteps = scpi.Execute("sens:corr:coll:guid:steps?")
MsgBox "Number of steps is " + CStr(numSteps)

' Measure the standards
For i = 1 To numSteps
step = "Step " + CStr(i) + " of " + CStr(numSteps)
strPrompt = scpi.Execute("sens:corr:coll:guid:desc? " + CStr(i))
MsgBox strPrompt, vbOKOnly, step
scpi.Execute "sens:corr:coll:guid:acq STAN" + CStr(i)
Next

' Conclude the calibration
scpi.Execute "sens:corr:coll:guid:save"
MsgBox "Cal is done!"


Perform Guided Mechanical Cal

Perform Guided Mechanical Cal using SCPI

This VBScript program performs a Guided Calibration using Mechanical standards. While this example is good to use as a starting point for guided mechanical cal, the Guided comprehensive cal example has some advanced features that are not in this program.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as Guided.vbs. Learn how to setup and run the macro.

' Performing a 2-port cal (Ports 1 and 2)

Dim app
Dim scpi

' Create / Get the PNA application.
Set app = CreateObject("AgilentPNA835x.Application")
Set scpi = app.ScpiStringParser

' Specify the DUT connectors
scpi.Execute "sens:corr:coll:guid:conn:port1 ""APC 3.5 female"" "
scpi.Execute "sens:corr:coll:guid:conn:port2 ""APC 3.5 male"" "

' Note: If your PNA has more than 2 ports, you would need to uncomment
' one or both of these next two lines, to explicitly specify this is
' just a 2-port cal.
'scpi.Execute "sens:corr:coll:guid:conn:port3 ""Not used"" "
'scpi.Execute "sens:corr:coll:guid:conn:port4 ""Not used"" "
MsgBox "Connectors defined for Ports 1 and 2"

' Select the Cal Kit for each port being calibrated.
scpi.Execute "sens:corr:coll:guid:ckit:port1 ""85052D"" "
scpi.Execute "sens:corr:coll:guid:ckit:port2 ""85052D"" "
MsgBox "Cal kits defined for Ports 1 and 2"

' Initiate the calibration and query the number of steps
scpi.Execute "sens:corr:coll:guid:init"
numSteps = scpi.Execute("sens:corr:coll:guid:steps?")
MsgBox "Number of steps is " + CStr(numSteps)

' Measure the standards
For i = 1 To numSteps
step = "Step " + CStr(i) + " of " + CStr(numSteps)
strPrompt = scpi.Execute("sens:corr:coll:guid:desc? " + CStr(i))
MsgBox strPrompt, vbOKOnly, step
scpi.Execute "sens:corr:coll:guid:acq STAN" + CStr(i)
Next

' Conclude the calibration
scpi.Execute "sens:corr:coll:guid:save"
MsgBox "Cal is done!"


Perform Guided TRL Calibration

This VBScript file performs a 2-Port Guided TRL calibration on PNA analyzers. The program does the following:

  • Clear old measurements from the PNA

  • Create a new S22 measurement

  • Set an instrument state

  • Select the connectors and cal kit

  • Initiate a Guided calibration

  • Display a prompt as each new standard must be connected

  • Save the calibration to a newly created cal set.

Note: This program runs without error on all PNA code revisions EXCEPT 4.83 (Shipped in Jan 2005):

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the PNA. To do this, copy the following code into a text editor file such as Notepad and save it on the PNA hard drive as TRL.vbs. Learn how to setup and run the macro.

Dim App
Set App = CreateObject("AgilentPNA835x.Application")
App.Preset
Dim Meas
Dim step
Dim txtVa
Dim txtStep1ofN
Dim Parser
Dim prompt
Dim txtDat
Dim Chan

Rem Clear old measurements
App.Reset

Rem Create a new Measurement
Set Parser = App.SCPIStringParser
Parser.Parse "DISPlay:WINDow1:STATE ON"
Parser.Parse "CALCulate:PARameter:DEFine 'MyMeas',S12"
Parser.Parse "DISPlay:WINDow1:TRACe1:FEED 'MyMeas'"

Rem Initialize state
Set Chan = App.ActiveChannel
Chan.StartFrequency = 20.0e9
Chan.StopFrequency = 22.0e9
Chan.IFBandwidth = 1000
step = 4

Rem Begin a guided calibrations
Parser.Parse "SENS:CORR:COLL:GUID:CONN:PORT1 'APC 3.5 male'"
Parser.Parse "SENS:CORR:COLL:GUID:CONN:PORT2 'APC 3.5 female'"
Parser.Parse "SENS:CORR:COLL:GUID:CKIT:PORT1 '85052C'"
Parser.Parse "SENS:CORR:COLL:GUID:CKIT:PORT2 '85052C'"

Rem Select TRL cal method
Parser.Parse "SENS:CORR:COLL:GUID:METH TRL"
txtDat = Parser.Parse("SENS:CORR:COLL:GUID:METH?")
MsgBox("Method " + txtDat)
Parser.Parse "SENS:CORR:COLL:GUID:INIT"

Rem Query the number of steps
txtDat = Parser.Parse("SENS:CORR:COLL:GUID:STEP?")

Rem Display the number of steps
MsgBox("Number of steps is " + txtDat)

Rem Set the loop counter limit
step = txtDat

Rem  Measure
 the standards
For i = 1 To step
If i= 1 Then
prompt = Parser.Parse("sens:corr:coll:guid:desc? 1")
MsgBox(prompt)
Parser.Parse ("sens:corr:coll:guid:acq STAN1")
ElseIf i = 2 then
prompt = Parser.Parse("sens:corr:coll:guid:desc? 2")
MsgBox(prompt)
Parser.Parse ("sens:corr:coll:guid:acq STAN2")
ElseIf i = 3 then
prompt = Parser.Parse("sens:corr:coll:guid:desc? 3")
MsgBox(prompt)
Parser.Parse ("sens:corr:coll:guid:acq STAN3")
ElseIf i = 4 then
prompt = Parser.Parse("sens:corr:coll:guid:desc? 4")
MsgBox(prompt)
Parser.Parse ("sens:corr:coll:guid:acq STAN4")
End If
Next

Rem All standards have been measured.  Save
 the result
Parser.Parse "SENS:CORR:COLL:GUID:SAVE"
MsgBox("The TRL calibration has been completed")


SCPI Example Programs

Setup Measurements | Environment
Catalog Measurements | Visual Basic
Create a Measurement | VBScript
Channels, Windows, and Measurements using GPIB | Visual Basic
Setup Sweep Parameters | Visual Basic
Setup the Display | Visual Basic
Setup a Measurement | Visual C++
Calibrations New See Calibrating the PNA Using SCPI |
Guided - Comprehensive Cal | VBScript
Guided ECal | VBScript
Guided Mechanical | VBScript
Guided 1-port Mechanical Cal on Port 2 | VBScript
Guided TRL Calibration | VBScript
Unguided ECal | VBScript
Unguided 2-port Mechanical Cal | VBScript
Unguided 1-port Mechanical Cal on Port 2 | VBScript
Perform an ECAL Confidence Check | Visual Basic
Perform a Source and Receiver Power Cal | VB/VBS
Upload a Source Power Cal | Visual Basic
Perform a Sliding Load Cal | Visual Basic
Create a New Cal Kit | RMB
Modify a Calibration Kit | Visual Basic
FCA |
Create and Cal a VMC Measurement | Visual Basic
Create and Cal an SMC Measurement | Visual Basic
Create an SMC Fixed Output Measurement | VBScript
Miscellaneous |
Getting and Putting Data | Visual Basic
Getting and Putting Data (Definite Block Transfers) | RMB
Transfer Data using MMEM:TRANSfer | RMB
Establish a VISA Session | Visual Basic
Status Reporting | Visual Basic
Create a Custom Power Meter Driver | Visual Basic
GPIB Pass-Through | VBScript
PNA as Controller and Talker/Listener | Visual Basic

See more PNA programming information and examples at:http://na.tm.agilent.com/pna/programming/


Transfer Data using GPIB

The following RMB examples transfer data to and from a remote PC using the MMEM:TRANsfer command.

Transferring data FROM the PNA -- TO a remote PC:

30 !
40 ! Set up I/O paths
50 !
60 ! Network analyzer address
70 ASSIGN @Na TO 716
75 !
77 ! File to be stored on local computer
80 ! First time -- need to create the file.
90 ! After file name, number records set to 0 (ignored by WinOS)
95 ! Use "PURGE" command to delete if desired.
100 CREATE "mytestdata.s2p",0
110 ASSIGN @File TO "mytestdata.s2p"
120 !
122 ! TRANSFER the data (download)
123 !
125 ! Analyzer has file 'testdata.s2p' in default directory
130 OUTPUT @Na;":MMEM:TRAN? ""testdata.s2p"""
135 !
137 ! Now unravel the bytes coming back from the analyzer.
140 ENTER @Na USING "#,A";A$
150 ENTER @Na USING "#,A";Digit$
160 !
170 ! Create appropriate "image"
180 Img$="#,"&Digit$&"A"
190 !
200 ! Byte$ holds the number of bytes in string format
210 ENTER @Na USING Img$;Byte$
220 !
230 ! Allocate a buffer for holding the data
240 ALLOCATE Dat$[VAL(Byte$)]
250 !
260 ! Set up a different image for filling the buffer
270 Img$=Byte$&"A"
280 !
290 ! Retrieve the actual file data
300 ENTER @Na USING Img$;Dat$
305 !
307 ! Now save the file locally.
310 OUTPUT @File;Dat$
320 END

Transferring data FROM the remote PC - TO the PNA:

40 ! Set up I/O paths
50 !
60 ! Network analyzer address
70 ASSIGN @Na TO 716
77 ! File to be retrieved from local computer
78 ASSIGN @File TO "mytestdata.s2p"
79 !
120 !
122 ! TRANSFER the data
123 !
230 ! Allocate a buffer for holding the data
240 ALLOCATE Dat$[26236]
250 !
260 ! Get data from the file and fill Dat$
270 ENTER @File;Dat$
280 !
325 ! Data to be transferred to analyzer file 'testupld.s2p'
325 ! in default directory.
326 !
327 ! A specific block transfer designator must follow the
328 ! file name:
329 ! '#' specifies a block transfer.
330 ! '6' specifies 6 digits to follow.
331 ! '026236' matches the buffer size allocated above
332 ! not counting <NL><END> (new line and end of file).
430 OUTPUT @Na;":MMEM:TRAN ""testupld.s2p"",#6026236",Dat$
520 END


Использование технологии COM

В следующих разделах описан способ управления PNA при помощи технологии COM.

  • Использование COM и SCPI

  • Конфигурирование COM-DCOM

  • Основы технологии COM

  • Получение дескриптора объекта

  • Коллекции анализатора

  • Интерфейсы PNA

  • Типы данных COM

  • Работа с событиями PNA

  • Считывание и запись калибровочных данных при помощи COM

  • C++ и интерфейс COM

  • Использование COM в среде .NET

Дополнительная информация и примеры по использованию PNA доступны по адресу:http://na.tm.agilent.com/pna/programming/.


Использование GPIB

В следующих разделах находится полезная информация об управлении PNA с помощью SCPI и GPIB.

  • Основы GPIB

  • Правила и синтаксис SCPI

  • Калибровка PNA с помощью SCPI

  • Получение данных из анализатора с помощью SCPI

  • Конфигурирование SCPI LAN с помощью SICL / VISA

  • Чтение регистра состояния анализатора

  • Понятие синхронизации команд

Дополнительная информация и примеры по использованию PNA доступны по адресу:http://na.tm.agilent.com/pna/programming/


Входное смещение

Входные разъемы смещения

Ввод смещения тестового порта

Примечание: несмотря на наличие разъемов, смещение тестового порта может быть недоступным. Смещение тестового порта - это стандарт для моделей E8356A, E8357A и E8358A, доступный как опция UNL для других выбранных моделей PNA.

Данный разъем BNC(f) дает возможность применить внешнее смещение к тестовому порту.

  • Максимальное напряжение: ±40 В пост. тока, стандарт

  • Максимальная сила тока: ±500 мА, (±200 мА без ухудшения характеристик РЧ)*

Предохранитель смещения тестового порта:

Это двухштырьковый предохранитель без задержки по времени на 1A, 125 В

*Прибор будет соответствовать своим характеристикам РЧ до уровня в 200 мА. С возрастанием смещения постоянного тока, особенно при низких РЧ (обычно <100 МГц, но преимущественно >10 МГц), ухудшается скорректированное согласование источника низких частот и направленность. При РЧ выше 100 МГц и при смещении до 1А существует незначительное ухудшение скорректированного согласования источника и направленности.


Внешняя AM

Внешний входной разъем АМ

Данный разъем BNC(f) дает возможность подачи напряжения, обеспечивающего низкочастотную модуляцию АМ, на выходной сигнал тестового порта. Кроме того, можно подавать напряжение для сдвига уровня мощности выходного сигнала тестового порта. Входной сигнал с напряжением 0 вольт не влияет на уровень мощности. Подача положительного напряжения сдвигает мощность тестового порта до более высокого уровня. Отрицательное напряжение сдвигает мощность на более низкий уровень.

  • Входная чувствительность: 8 дБ/вольт, стандарт

  • Полоса пропускания: 1 кГц, стандарт

  • Входной импеданс: 1кОм

Примечание: Данный разъем устанавливается ТОЛЬКО для моделей на 3 ГГц, 6 ГГц и 9 ГГц.


Внешний детектор

Входной разъем внешнего детектора

Данный разъем BNC(f) дает возможность подачи постоянного тока с внешнего диодного детектора с отрицательной полярностью для управления уровнем мощности на тестовых портах. Для того, чтобы анализатор воспринимал данный внешний входной сигнал, необходимо отметить поле External ALC в диалоговом окне Sweep Setup (Настройка свипирования).

  • Входная чувствительность -500 мВ, дает приблизительно -3 dBm на входе детектора

  • Полоса пропускания: 50 кГц, стандарт

  • Входной импеданс: 1кОм стандарт

Примечание: Данный разъем устанавливается ТОЛЬКО для моделей на 3 ГГц, 6 ГГц и 9 ГГц.


ExtTrig

Вспомогательный разъем ввода/вывода

Данная вилка разъема DB-25 подходит для различных линий - аналоговых I/O, цифровых I/O, пусковых, а также линий питания. Смотрите Вспомогательный разъем I/O.


FRef

Опорные разъемы 10 МГц

Опорный входной сигнал 10 МГц

Данный разъем BNC(f) дает возможность работы анализатора с входным опорным сигналом.

Если на данном порту зафиксирован внешний опорный сигнал 10 МГц, он будет использован в качестве опорной частоты прибора вместо внутренней опорной частоты.

Характеристики порта REF lNPUT на 10 МГц:

  • Входная частота: 10 МГц

  • Входной уровень: от -15 до +20 dBm, стандарт

  • Входной импеданс: 200 Ом, номинальный

Опорный выходной сигнал 10 МГц

Данный разъем BNC(f) обеспечивает опорную частоту сигнала со следующими характеристиками:

  • Выходная частота:

  • 10 МГц ±1ppm (для моделей PNA - E8356/7/8A и E8362/3/4A)

  • 10 МГц ±10ppm (для моделей PNA - E8801/2/3A и N3381/2/3A)
    Для обновления закажите опцию 1E5.

  • Тип сигнала: синусоидальное колебание

  • Выходной уровень: 10 dBm ±4 dB на 50 Ом

  • Выходной импеданс: 50 Ом

  • Гармоники: < –40 dBc


GPIB

Разъем универсальной интерфейсной шины (GPIB)

Это 24-штырьковый гнездовой разъем типа D-24, совместимый с IEEE-488. Применяется для отправки и получения команд GPIB / SCPI. Изучите дополнительную информацию о GPIB.


Обработчик

Разъем обработчика ввода/вывода

Прямоугольный 36-штырьковый гнездовой разъем, обеспечивает следующее:

  • четыре независимых параллельных порта данных

  • девять сигнальных линий управления

  • одну линию заземления

  • одну линию питания

Все сигналы TTL-совместимы.

Примечание: На ранних моделях PNA на этом разъеме ставилась метка "GPIO". Ее использовали, чтобы пометить разъем, как не функциональный.

Смотрите подробную информацию в Разъем обработчика


Жесткий диск

Простой доступ к жесткому диску PNA моделей E836x A/B обеспечивается с задней панели. Подробная процедура представлена в руководстве по обслуживанию PNA, глава 7.

Копию руководства по обслуживанию можно загрузить с нашего веб-сайта http://www.agilent.com/find/pna


Разъемы доступа ПЧ

Возможны только с опцией H11

Драйверы тестового комплекта

Источник РЧ PNA и выводы LO для внешнего смешения.

Входной импульс

Обеспечивает возможность проводить импульсные измерения с опцией H08.

8.33 MHz IF IN

Обеспечивает доступ к линиям ПЧ приемника PNA.


Разъем LAN

Разъем локальной сети (LAN)

Данное соединение 10/100BaseT Ethernet имеет стандартную 8-штырьковую конфигурацию и автоматическое переключение между двумя скоростями передачи данных.


Параллельный

Разъем порта параллельного интерфейса (LPT1)

Гнездовой разъем DB-25 обеспечивает подключение к принтеру или любому другому периферийному устройству параллельного порта.

Примечание: На ранних моделях PNA для подключения к принтеру устанавливался разъем Centronics. На таких моделях PNA устанавливался адаптер (36-штырьковая вилка - 1284-C - на гнездовой 25-штырьковый) для соединения со стандартным кабелем параллельного принтера.


Последовательный

Разъем порта последовательного интерфейса (COM1)

RS-232 совместимый 9-штырьковый разъем типа вилка.


Тестовый комплект

Разъем ввода/вывода внешнего тестового комплекта

Гнездовой разъем DB-25, используется для управления внешними тестовыми комплектами. Шина внешнего тестового комплекта состоит из 13 мультиплексных адресных линий и линий данных, трех линий управления и линии прерывания с открытым коллектором. Возможно гирляндное подключение тестовых комплектов для одновременного управления до 16 тестовыми комплектами.

Примечание: Тестовый комплект ввода/вывода не совместим с тестовыми комплектами Agilent 8753.

Подробно смотрите Разъем внешнего тестового комплекта


Триггер IN_OUT

Триггер IN / OUT

Данные разъемы обеспечивают возможность передачи сигнала запуска с PNA и на него. Возможны ТОЛЬКО для E8361A, E836xB и N5230A моделей PNA. За дополнительной информацией по этим типам команд обращайтесь к Внешний запуск.


Разъем USB

Разъем универсальной последовательной шины (USB)

Разъем универсальной последовательной шины (USB) типа А дает возможность подключать клавиатуру, мышь, модуль ECAL или другие устройства USB.

  • Контакт 1: Vcc; от 4.75 до 5.25 В пост. тока, 500 мA, максимум.
    Защита - автоматически сбрасываемый предохранитель на 1A.

  • Контакт 2: - Данные

  • Контакт 3: +Данные

  • Контакт 4: заземление

Смотрите ограничения для USB


Концентратор USB

Концентратор универсальной последовательной шины (USB)

Концентратор USB включает в себя четыре USB порта для подачи питания к периферийным устройствам PNA.

Limitation: Общее потребление энергии для всех шести USB портов ограничено до 1.5 ампер. Если данное ограничение превышается, все USB порты отключаются до тех пор, пока устройство не будет удалено, и энергопотребление снизится до допустимого уровня. (При первом подключении модули Agilent ECAL - 8509x и N4431 потребляют значительно больше энергии, чем другие модули.)

  • Данный внутренний концентратор USB устанавливается на моделях PNA - E8361A, E8362B, E8363B и E8364B.

  • Он перемещен на модель PNA N5230A.


Вывод VGA

Выходной разъем адаптера видеографики (VGA)

Этот 15-штырьковый гнездовой разъем D-sub дает возможность подключения внешних VGA мониторов. Следующие настройки разрешения дают возможность одновременно просматривать дисплей PNA и удаленный монитор.

Внешнее устройство | Разрешение
Плоская панель (TFT) | 1024x768, 800x600, 640x480
Плоская панель (DSTN) | 800x600, 640x480
Монитор CRT | 1280x1024, 1024x768, 800x600, 640x480

Примечание: Если для анализатора установлено заданное по умолчанию разрешение (640 x 480) можно одновременно просматривать дисплей анализатора и внешний монитор. При изменении разрешения анализатора с панели управления на настройку, отличающуюся от заданной, можно просматривать только внешний монитор Для изменения разрешения: В меню System (Система) перейдите к Configure (Конфигурировать) и нажмите Control Panel (Панель управления). Затем щелкните по пиктограмме Display (Дисплей) и панели Settings (Настройки).


Руководство по администрированию

Выполнение задач администрирования

  • Учетные записи и пароли пользователей PNA

  • Свойства компьютера PNA

  • Восстановление системы

  • Выбор языка справки


Руководство по подключению

Подключение к сети и подсоединение анализатора

В следующих темах описано подключение к сети и взаимодействие с анализатором.

  • Учетные записи и пароли пользователей PNA

  • Подключение PNA к ПК

  • Простота против безопасной конфигурации

  • Конфигурирование COM-DCOM

  • Интерфейс 82357A USB / GPIB

  • Изменение клиента сети

  • Использование VNC для управления пользовательским интерфейсом PNA


Скрытие информации о частоте

Скрытие информации о частоте (Frequency Blanking)

Примечание: За информацией о том, как стереть память перед выходом PNA из безопасной зоны, обращайтесь к http://na.tm.agilent.com/pna/security.html.

Для безопасности вы можете не допустить появления информации о частоте на экране PNA и в распечатках.

Если установлен Low (низкий) или High (высокий) уровень безопасности, информация о частоте будет стираться в следующих позициях:

  • Отображение аннотации

  • Свойства калибровки

  • Все таблицы

  • Все панели инструментов

  • Все распечатки

  • Консоль GPIB
    При установке None или Low, информация не стирается.
    При установке High, консоль GPIB не активна.

Если установлен Low (низкий) или High (высокий) уровень безопасности, информация о частоте НЕ стирается в следующих позициях:

  • В информации диалогового окна Приложение преобразования частоты (опция 083) или в распечатке.

  • Сервисные программы.

  • Ваши программы COM или SCPI.

Реализация скрытия информации о частоте (Frequency Blanking)

Дополнительная информация об использовании интерфейса передней панели

Справка по диалоговому окну Security Setting (Настройка безопасности)

None - Вся информация о частоте отображается на экране и распечатках.

Low - Вся информация о частоте стирается. Но вы можете вернуть отображение информации о частоте, снова открыв это диалоговое окно и нажав None.

High - Вся информация о частоте стирается. Для того чтобы восстановить отображение информации о частоте, необходимо выполнить предварительную настройку PNA, или повторно вызвать инструментальное состояние, где уровень безопасности установлен на None или Low.


Quick Start Guide

Начало

Следующие разделы помогут Вам познакомиться с анализатором PNA:

  • Обзор передней панели

  • Обзор задней панели

  • Включение и выключение анализатора PNA

  • Интерфейс передней панели

  • Графики, каналы и окна

  • Базовая последовательность измерений

  • Использование справки

  • Восстановление операционной системы

  • Подключение анализатора и работа в сети

  • Выполнение задач администрирования

ОЧЕНЬ ВАЖНЫЕ ЗАМЕЧАНИЯ:

1. НЕ модифицируйте и НЕ реконфигурируйте операционную систему или программное обеспечение анализатора Agilent PNA.
2. Анализатор PNA не имеет антивирусной защиты. Настоятельно рекомендуется установить антивирусную защиту, если Вы будете подключать анализатор PNA к Интернет.

За дальнейшей информацией обращайтесь к замечаниям по ОС Windows.


VNC

Использование VNC для управления пользовательским интерфейсом PNA

VNC (Virtual Network Computing – виртуальное сетевое управление) дает возможность управлять пользовательским интерфейсом PNA с любого компьютера. На дисплее подключенного компьютера появляется дисплей PNA. Мышью и клавиатурой можно управлять как с PNA, так и с компьютера, хотя не одновременно.

PNA и компьютер должны быть подключены к интернет. Реактивность PNA при использовании VNC зависит от скорости подключения к интернет.

Все PNA поставляются с установленным VNC. Однако необходимо загрузить и установить программное обеспечение VNC на компьютер из http://www.realvnc.com/.

Следующая процедура поможет после установки сконфигурировать VNC для просмотра и управления приложением PNA с вашего компьютера.

На PNA, запуск VNC Server

Для этого:

  1. Нажмите View, затем Minimize Application (Свернуть окно приложения).

  2. Нажмите Start, Programs, RealVNC, Run VNC Server.

  • При первом запуске VNC Server необходимо установить пароль для контроля доступа с удаленных компьютеров.

  • Можно сконфигурировать меню запуска так, чтобы VNC запускался автоматически при загрузке PNA. Смотрите справку Windows.

На компьютере, запуск VNC Viewer

Для этого:

  1. Загрузите (http://www.realvnc.com/) и установите VNC на компьютере.

  2. На рабочем столе компьютера нажмите Start, Programs, RealVNC, Run VNC Viewer

  3. При запросе Hostname введите полное имя компьютера или IP адрес для PNA.

  4. При запросе пароля введите пароль, установленный при конфигурировании VNC на PNA.


Руководство по настройке

Настройка измерений

Вы можете настроить измерение, выполнив следующие шаги:

  • Предварительная настройка PNA

  • Выбор измеряемого параметра

  • Установка диапазона частот

  • Установка уровня мощности

  • Настройки свипирования

  • Установка формата данных и масштаба

  • Установка запуска

  • Предопределенные настройки измерений

  • Модификация экрана PNA

  • Копирование каналов

  • Уход за коннекторами

Внимание:: Избегайте дорогостоящих ремонтных работ анализатора серии PNA. См. Защита от электростатического разряда.


Trigger Model Animation

This SIMPLIFIED model can help you learn about the flexible triggering behavior of the analyzer. The triggering of channels is represented by dropping balls.

Although the triggering behavior it is NOT an exact model of the PNA, the following differences are subtle.

  • The timing of setting responses differs from the analyzer. For example, switching to Manual mode occurs immediately in the analyzer. The model waits until the current sweep is complete.

  • The model does not include External triggering.

  • Speedometer - controls the speed of the animation:

Speedometer | Trigger Source Internal Manual
 | Trigger Scope Global Channel

Continuous
Groups
Single
Hold
Point

Continuous
Groups
Single
Hold
Point

Continuous
Groups
Single
Hold
Point

About the trigger model

Read Text description of triggering behaviors.


Руководство по оптимизации измерений

Оптимизация измерений

Измерение имеет взаимозависимые установочные параметры. Установочные параметры можно менять, чтобы достичь цели измерения: большей производительности или большей точности измерения.

Увеличение производительности измерения

  • Достижение быстрого свипирования

  • Переключение между многократными измерениями

  • Скорость передачи данных

  • Использование макросов

Улучшение точности измерения

  • Увеличение динамического диапазона

  • Увеличение количества точек

  • Улучшение точности измерения фазы

  • Улучшение точности для электрически длинных устройств

  • Улучшение точности отражения для 2-портовых устройств с малыми потерями

  • Увеличение стабильности измерений

  • Уменьшение шума

  • Снижение перекрестных помех в приемнике

  • Уменьшение влияния вспомогательных средств тестирования

Внимание: Избегайте дорогостоящих ремонтных работ анализатора серии PNA. См. Защита от электростатического разряда.


Руководство по калибровке измерений

Калибровка измерений

  • Обзор калибровки

  • Выбор типа калибровки

  • Мастер калибровки

  • Использование калибровочных комплектов

  • Использование ECal

  • Точность калибровок

  • Достоверность калибровки

  • Погрешности измерений

  • Изменение калибровочных комплектов

  • Калибровочные стандарты (меры)

  • 3-портовые измерения

  • Калибровка мощности

  • Калибровка TRL

  • Макрос для приспособлений

Внимание: Избегайте дорогостоящих ремонтных работ анализатора серии PNA. См. Защита от электростатического разряда.


Анализ данных

  • Использование маркеров

  • Использование математических операций

  • Использование граничных линий для тестирования устройств

Внимание: Избегайте дорогостоящих ремонтных работ анализатора серии PNA. См. Защита от электростатического разряда.


Руководство по выводу данных

Печать, сохранение и вызов данных

  • Сохранение и вызов файла

  • Печать измерений, отображенных на экране

  • Подключение диска

Внимание: Избегайте дорогостоящих ремонтных работ анализатора серии PNA. См. Защита от электростатического разряда.


Specs: Front Panel Jumpers, E836xB, Opt 014

Specifications: Front-Panel Jumpers

Models E8362A/B, E8363A/B, and E8364A/B Option 014

NOTE: The standard E8362/3/4A/B has no front-panel jumpers.

  • Measurement Receiver Inputs (Rcvr A In, Rcvr B In)

  • Reference Receiver Inputs (Rcvr R1 In, Rcvr R2 In)

  • Reference Outputs (Reference 1 Source Out, Reference 2 Source Out)

  • Source Outputs (Port 1 Source Out, Port 2 Source Out)

  • Coupler Inputs (Port 1 Coupler Thru, Port 2 Coupler Thru)

  • Coupler Outputs (Port 1 Coupler Arm, Port 2 Coupler Arm)

Table 47: Measurement Receiver Inputs (Rcvr A In, Rcvr B In)

Description | Specification | Supplemental Information
Maximum Input Level
E8362A/B:
45 MHz to 500 MHz |  | -15 dBm, typical
500 MHz to 2 GHz |  | -11 dBm, typical
2 GHz to 10 GHz |  | -11 dBm, typical
10 GHz to 20 GHz |  | -11 dBm, typical
E8363A/B:
45 MHz to 500 MHz |  | -14 dBm, typical
500 MHz to 2 GHz |  | -10 dBm, typical
2 GHz to 10 GHz |  | -10 dBm, typical
10 GHz to 20 GHz |  | -10 dBm, typical
20 GHZ to 30 GHz |  | -14.5 dBm, typical
30 GHZ to 40 GHz |  | -16.5 dBm, typical
E8364A/B:
45 MHz to 500 MHz |  | - 14 dBm, typical
500 MHz to 2 GHz |  | - 10 dBm, typical
2 GHz to 10 GHz |  | - 10 dBm, typical
10 GHz to 20 GHz |  | - 10 dBm, typical
20 GHZ to 30 GHz |  | - 14.5 dBm, typical
30 GHZ to 40 GHz |  | - 16.5 dBm, typical
40 GHZ to 45 GHz |  | - 16 dBm, typical
45 GHZ to 50 GHz |  | - 15 dBm, typical
Noise Floor
E8362A/B:
 | 10 Hz IF Bandwidth |
45 MHz to 500 MHz | < -109 dBm |
500 MHz to 2 GHz | < -130 dBm |
2 GHz to 10 GHz | < -133 dBm |
10 GHz to 20 GHz | < -135 dBm |
 | 1 kHz IF Bandwidth |
45 MHz to 500 MHz | < -89 dBm |
500 MHz to 2 GHz | < -110 dBm |
2 GHz to 10 GHz | < -113 dBm |
10 GHz to 20 GHz | < -115 dBm |
E8363A/B:
 | 10 Hz IF Bandwidth |
45 MHz to 500 MHz | < -127 dBm |
500 MHz to 2 GHz | < -133 dBm |
2 GHz to 10 GHz | < -132 dBm |
10 GHz to 20 GHz | < -134 dBm |
20 GHZ to 40 GHz | < -125 dBm |
 | 1 kHz IF Bandwidth |
45 MHz to 500 MHz | < -107 dBm |
500 MHz to 2 GHz | < -113 dBm |
2 GHz to 10 GHz | < -112 dBm |
10 GHz to 20 GHz | < -114 dBm |
20 GHZ to 40 GHz | < -105 dBm |
E8364A/B:
 | 10 Hz IF Bandwidth |
45 MHz to 500 MHz | < - 127 dBm |
500 MHz to 2 GHz | < - 133 dBm |
2 GHz to 10 GHz | < - 132 dBm |
10 GHz to 20 GHz | < - 134 dBm |
20 GHZ to 40 GHz | < - 125 dBm |
40 GHZ to 50 GHz | < - 123 dBm |
 | 1 kHz IF Bandwidth |
45 MHz to 500 MHz | < -107 dBm |
500 MHz to 2 GHz | < -113 dBm |
2 GHz to 10 GHz | < -112 dBm |
10 GHz to 20 GHz | < -114 dBm |
20 GHZ to 40 GHz | < -105 dBm |
40 GHZ to 50 GHz | < -103 dBm |
Damage Level
E8362A/B |  | + 15 dBm, typical
E8363A/B |  | + 15 dBm, typical
E8364A/B |  | + 15 dBm, typical
Maximum DC Level
E8362A/B |  | + 15 V, typical
E8363A/B |  | + 15 V, typical
E8364A/B |  | + 15 V, typical

Table 48: Reference Receiver Inputs (Rcvr R1, Rcvr R2)

Description | Specification | Supplemental Information
Maximum Input Level
E8362A/B:
45 MHz to 500 MHz |  | -15 dBm, typical
500 MHz to 2 GHz |  | -11 dBm, typical
2 GHz to 10 GHz |  | -11 dBm, typical
10 GHz to 20 GHz |  | -11 dBm, typical
E8363A/B:
45 MHz to 500 MHz |  | -14 dBm, typical
500 MHz to 2 GHz |  | -10 dBm, typical
2 GHz to 10 GHz |  | -10 dBm, typical
10 GHz to 20 GHz |  | -9.5 dBm, typical
20 GHZ to 30 GHz |  | -14 dBm, typical
30 GHZ to 40 GHz |  | -15.5 dBm, typical
E8364A/B:
45 MHz to 500 MHz |  | - 14 dBm, typical
500 MHz to 2 GHz |  | - 10 dBm, typical
2 GHz to 10 GHz |  | - 10 dBm, typical
10 GHz to 20 GHz |  | - 9.5 dBm, typical
20 GHZ to 30 GHz |  | - 14 dBm, typical
30 GHZ to 40 GHz |  | - 15.5 dBm, typical
40 GHZ to 45 GHz |  | - 14 dBm, typical
45 GHZ to 50 GHz |  | - 15 dBm, typical
Damage Level
E8362A/B |  | + 15 dBm, typical
E8363A/B |  | + 15 dBm, typical
E8364A/B |  | + 15 dBm, typical
Maximum DC Level
E8362A/B |  | +/- 15 V, typical
E8363A/B |  | +/- 15 V, typical
E8364A/B |  | +/- 15 V, typical

Table 49: Reference Outputs (Reference 1 Source Out, Reference 2 Source Out)

Description | Specification | Supplemental Information
Maximum Output Level
E8362A/B:
45 MHz to 500 MHz |  | -24 dBm, typical
500 MHz to 2 GHz |  | -23 dBm, typical
2 GHz to 10 GHz |  | -23 dBm, typical
10 GHz to 20 GHz |  | -26 dBm, typical
E8363A/B:
45 MHz to 500 MHz |  | -11.5 dBm, typical
500 MHz to 2 GHz |  | -10.5 dBm, typical
2 GHz to 10 GHz |  | -11 dBm, typical
10 GHz to 20 GHz |  | -11 dBm, typical
20 GHZ to 30 GHz |  | -11 dBm, typical
30 GHZ to 40 GHz |  | -11 dBm, typical
E8364A/B:
45 MHz to 500 MHz |  | - 11.5 dBm, typical
500 MHz to 2 GHz |  | - 10.5 dBm, typical
2 GHz to 10 GHz |  | - 11 dBm, typical
10 GHz to 20 GHz |  | - 11 dBm, typical
20 GHZ to 30 GHz |  | - 11 dBm, typical
30 GHZ to 40 GHz |  | - 11 dBm, typical
40 GHZ to 45 GHz |  | - 11 dBm, typical
45 GHZ to 50 GHz |  | - 15 dBm, typical
Damage Level
E8362A/B |  | + 20 dBm, typical
E8363A/B |  | + 20 dBm, typical
E8364A/B |  | + 20 dBm, typical
Maximum DC Level
E8362A/B |  | +/- 15 V, typical
E8363A/B |  | +/- 15 V, typical
E8364A/B |  | +/- 15 V, typical

Table 50: Source Outputs (Port 1 Source Out, Port 2 Source Out)

Description | Specification | Supplemental Information
Maximum Output Level
E8362A/B, Option 014:
45 MHz to 500 MHz |  | 6 dBm, typical
500 MHz to 2 GHz |  | 7 dBm, typical
2 GHz to 10 GHz |  | 7 dBm, typical
10 GHz to 20 GHz |  | 4 dBm, typical
E8362A/B, Option 014 and UNL:
45 MHz to 500 MHz |  | 4 dBm, typical
500 MHz to 2 GHz |  | 5 dBm, typical
2 GHz to 10 GHz |  | 5 dBm, typical
10 GHz to 20 GHz |  | 2 dBm, typical
E8363A/B, Option 014:
45 MHz to 500 MHz |  | 5.5 dBm, typical
500 MHz to 2 GHz |  | 6.5 dBm, typical
2 GHz to 10 GHz |  | 6.5 dBm, typical
10 GHz to 20 GHz |  | 4 dBm, typical
20 GHZ to 30 GHz |  | 10 dBm, typical
30 GHZ to 40 GHz |  | -2 dBm, typical
E8363A/B, Option 014 and UNL:
45 MHz to 500 MHz |  | 3.5 dBm, typical
500 MHz to 2 GHz |  | 5 dBm, typical
2 GHz to 10 GHz |  | 5 dBm, typical
10 GHz to 20 GHz |  | 3.5 dBm, typical
20 GHZ to 30 GHz |  | 0 dBm, typical
30 GHZ to 40 GHz |  | -2.5 dBm, typical
E8364A/B, Option 014:
45 MHz to 500 MHz |  | 5.5 dBm, 0typical
500 MHz to 2 GHz |  | 6.5 dBm, typical
2 GHz to 10 GHz |  | 6.5 dBm, typical
10 GHz to 20 GHz |  | 4 dBm, typical
20 GHZ to 30 GHz |  | 1 dBm, typical
30 GHZ to 40 GHz |  | -2 dBm, typical
40 GHZ to 45 GHz |  | -3 dBm, typical
45 GHZ to 50 GHz |  | -7.5 dBm, typical
E8364A/B, Option 014 and UNL:
45 MHz to 500 MHz |  | 3.5 dBm, typical
500 MHz to 2 GHz |  | 5 dBm, typical
2 GHz to 10 GHz |  | 5 dBm, typical
10 GHz to 20 GHz |  | 3.5 dBm, typical
20 GHZ to 30 GHz |  | 0 dBm, typical
30 GHZ to 40 GHz |  | -2.5 dBm, typical
40 GHZ to 45 GHz |  | -5 dBm, typical
45 GHZ to 50 GHz |  | -10 dBm, typical
Damage Level
E8362A/B |  | 20 dBm, typical
E8363A/B |  | 20 dBm, typical
E8364A/B |  | 20 dBm, typical
Maximum DC Level
E8362A/B |  | 0 V, typical
E8363A/B |  | 0 V, typical
E8364A/B |  | 0 V, typical

Table 51: Coupler Inputs (Port 1 Cplr Thru, Port 2 Cplr Thru)

Description | Specification | Supplemental Information
Insertion Loss to Test Port
E8362A/B, Option 014:
45 MHz to 500 MHz |  | 0.5 dB, typical
500 MHz to 2 GHz |  | 1.5 dB, typical
2 GHz to 10 GHz |  | 1.5 dB, typical
10 GHz to 20 GHz |  | 1.5 dB, typical
E8362A/B, Option 014 and UNL:
45 MHz to 500 MHz |  | 1 dB, typical
500 MHz to 2 GHz |  | 2 dB, typical
2 GHz to 10 GHz |  | 2 dB, typical
10 GHz to 20 GHz |  | 2 dB, typical
E8363A/B, Option 014:
45 MHz to 500 MHz |  | 0.5 dB, typical
500 MHz to 2 GHz |  | 0.5 dB, typical
2 GHz to 10 GHz |  | 1.5 dB, typical
10 GHz to 20 GHz |  | 2 dB, typical
20 GHZ to 30 GHz |  | 3 dB, typical
30 GHZ to 40 GHz |  | 3.5 dB, typical
E8363A/B, Option 014 and UNL:
45 MHz to 500 MHz |  | 0.5 dB, typical
500 MHz to 2 GHz |  | 1 dB, typical
2 GHz to 10 GHz |  | 2 dB, typical
10 GHz to 20 GHz |  | 3 dB, typical
20 GHZ to 30 GHz |  | 4 dB, typical
30 GHZ to 40 GHz |  | 5 dB, typical
E8364A/B, Option 014:
45 MHz to 500 MHz |  | 0.5 dB, typical
500 MHz to 2 GHz |  | 0.5 dB, typical
2 GHz to 10 GHz |  | 1.5 dB, typical
10 GHz to 20 GHz |  | 2 dB, typical
20 GHZ to 30 GHz |  | 3 dB, typical
30 GHZ to 40 GHz |  | 3.5 dB, typical
40 GHZ to 45 GHz |  | 3.5 dB, typical
45 GHZ to 50 GHz |  | 4 dB, typical
E8364A/B, Option 014 and UNL:
45 MHz to 500 MHz |  | 0.5 dB, typical
500 MHz to 2 GHz |  | 1 dB, typical
2 GHz to 10 GHz |  | 2 dB, typical
10 GHz to 20 GHz |  | 3 dB, typical
20 GHZ to 30 GHz |  | 4 dB, typical
30 GHZ to 40 GHz |  | 5 dB, typical
40 GHZ to 45 GHz |  | 5.5 dB, typical
45 GHZ to 50 GHz |  | 6 dB, typical
Damage Level
E8362A/B |  | + 30 dBm, typical
E8363A/B |  | + 30 dBm, typical
E8364A/B |  | + 30 dBm, typical
Maximum DC Level
E8362A/B |  | +/- 40 V, typical
E8363A/B |  | +/- 40 V, typical
E8364A/B |  | +/- 40 V, typical

Table 52: Coupler Outputs (Port 1 Cplr Arm, Port 2 Cplr Arm)

Description | Specification | Supplemental Information
Damage Level
E8362A/B |  | + 30 dBm, typical
E8363A/B |  | + 30 dBm, typical
E8364A/B |  | + 30 dBm, typical
Maximum DC Level
E8362A/B |  | +/- 7 V, typical
E8363A/B |  | +/- 7 V, typical
E8364A/B |  | +/- 7 V, typical


Specs: Front Panel Jumpers, E8361A, Opt 014

Specifications: Front-Panel Jumpers

Model E8361A Option 014

NOTE: The standard E8361A has no front-panel jumpers.

  • Measurement Receiver Inputs (Rcvr A In, Rcvr B In)

  • Reference Receiver Inputs (Rcvr R1 In, Rcvr R2 In)

  • Reference Outputs (Reference 1 Source Out, Reference 2 Source Out)

  • Source Outputs (Port 1 Source Out, Port 2 Source Out)

  • Coupler Inputs (Port 1 Coupler Thru, Port 2 Coupler Thru)

  • Coupler Outputs (Port 1 Coupler Arm, Port 2 Coupler Arm)

Table 23: Measurement Receiver Inputs (Rcvr A In, Rcvr B In)

Description | Specification | Supplemental Information
Maximum Input Level
E8361A:
 |  | typical:
10 MHz to 45 MHz |  | - 12 dBm
45 MHz to 500 MHz |  | - 12 dBm
500 MHz to 2 GHz |  | - 10 dBm
2 GHz to 5 GHz |  | - 10 dBm
5 GHz to 10 GHz |  | - 7 dBm
10 GHz to 24 GHz |  | - 7 dBm
24 GHZ to 30 GHz |  | - 7 dBm
30 GHZ to 40 GHz |  | - 8 dBm
40 GHZ to 45 GHz |  | - 8 dBm
45 GHZ to 50 GHz |  | - 8 dBm
50 GHZ to 60 GHz |  | - 8 dBm
60 GHZ to 67 GHz |  | - 8 dBm
67 GHZ to 70 GHz |  | - 8 dBm
Damage Level
E8361A |  | + 15 dBm
Maximum DC Level
E8361A |  | + 15 V

Table 24: Reference Receiver Inputs (Rcvr R1, Rcvr R2)

Description | Specification | Supplemental Information
Maximum Input Level
E8361A:
 |  |  | Rcvr R1 with Option 081
 |  | typical:
10 MHz to 45 MHz |  | - 10 dBm | - 5.5 dBm
45 MHz to 500 MHz |  | - 9.5 dBm | - 5.0 dBm
500 MHz to 2 GHz |  | - 9 dBm | - 4.0 dBm
2 GHz to 5 GHz |  | - 7.5 dBm | - 2.0 dBm
5 GHz to 10 GHz |  | - 2.5 dBm | 3.0 dBm
10 GHz to 24 GHz |  | - 1.5 dBm | 4.5 dBm
24 GHZ to 30 GHz |  | - 0.50 dBm | 5.5 dBm
30 GHZ to 40 GHz |  | - 1 dBm | 5.5 dBm
40 GHZ to 45 GHz |  | - 0.5 dBm | 6.5 dBm
45 GHZ to 50 GHz |  | 0 dBm | 7.0 dBm
50 GHZ to 60 GHz |  | 0.5 dBm | 7.50 dBm
60 GHZ to 67 GHz |  | 1.00 dBm | 9.00 dBm
67 GHZ to 70 GHz |  | 1.50 dBm | 10.50 dBm
Damage Level
E8361A |  | + 15 dBm
Maximum DC Level
E8361A |  | +/- 15 V

Table 25: Reference Outputs (Reference 1 Source Out, Reference 2 Source Out)

Description | Specification | Supplemental Information
Maximum Output Level
E8361A:
 |  |  | Option 014 & UNL
 |  |  | Rcvr R1 with Option 081 | Without Option 081
 |  | typical:
10 MHz to 45 MHz |  | - 43 dBm | - 38.5 dBm | - 43 dBm
45 MHz to 500 MHz |  | - 17.5 dBm | - 13 dBm | - 17.5 dBm
500 MHz to 2 GHz |  | - 12.5 dBm | - 8.5 dBm | - 13.5 dBm
2 GHz to 5 GHz |  | - 10.5 dBm | - 6 dBm | - 11.5 dBm
5 GHz to 10 GHz |  | - 10.5 dBm | - 6 dBm | - 11.5 dBm
10 GHz to 24 GHz |  | - 9.5 dBm | - 6.5 dBm | - 12.5 dBm
24 GHZ to 30 GHz |  | - 9 dBm | - 6 dBm | - 12.0 dBm
30 GHZ to 40 GHz |  | - 9.5 dBm | - 6 dBm | - 12.5 dBm
40 GHZ to 45 GHz |  | - 13 dBm | - 10 dBm | - 17 dBm
45 GHZ to 50 GHz |  | - 8.5 dBm | - 5.5 dBm | - 12.5 dBm
50 GHZ to 60 GHz |  | - 9 dBm | - 6 dBm | - 13 dBm
60 GHZ to 67 GHz |  | - 10.5 dBm | - 8.5 dBm | - 16.5 dBm
67 GHZ to 70 GHz |  | - 9 dBm | - 6 dBm | - 15 dBm
Damage Level
E8361A |  | + 20 dBm
Maximum DC Level
E8361A |  | +/- 15 V

Table 26: Source Outputs (Port 1 Source Out, Port 2 Source Out)

Description | Specification |  | Supplemental Information
Maximum Output Level
E8361A
 |  |  | Option 014 & UNL
 |  | typical:
10 MHz to 45 MHz |  | -6.5 dBm | - 5 dBm
45 MHz to 500 MHz |  | -2.5 dBm | - 1 dBm
500 MHz to 2 GHz |  | -1 dBm | 1.5 dBm
2 GHz to 5 GHz |  | -1.5 dBm | 2.5 dBm
5 GHz to 10 GHz |  | -1.5 dBm | 2.5 dBm
10 GHz to 24 GHz |  | -2 dBm | 2 dBm
24 GHZ to 30 GHz |  | -3 dBm | 3 dBm
30 GHZ to 40 GHz |  | -1 dBm | 1.5 dBm
40 GHZ to 45 GHz |  | -2.5 dBm | - 3.5 dBm
45 GHZ to 50 GHz |  | -2 dBm | 1 dBm
50 GHZ to 60 GHz |  | 0 dBm | - 0.5 dBm
60 GHZ to 67 GHz |  | -2 dBm | - 4.5 dBm
67 GHZ to 70 GHz |  | -0.5 dBm | - 1 dBm
Damage Level
E8361A |  | 27 dBm
Maximum DC Level
E8361A |  | +/- 40 V

Table 27: Coupler Inputs (Port 1 Cplr Thru, Port 2 Cplr Thru)

Description | Specification |  | Supplemental Information
Insertion Loss to Test Port
E8361A
 |  |  | Option 014 & UNL
 |  | typical:
10 MHz to 45 MHz |  | 0.5 dB | 2 dB
45 MHz to 500 MHz |  | 0.5 dB | 0.5 dB
500 MHz to 2 GHz |  | 0.5 dB | 0.5 dB
2 GHz to 5 GHz |  | 1.5 dB | 0.5 dB
5 GHz to 10 GHz |  | 1.5 dB | 0.5 dB
10 GHz to 24 GHz |  | 2 dB | 1 dB
24 GHZ to 30 GHz |  | 2.5 dB | 1 dB
30 GHZ to 40 GHz |  | 3 dB | 1 dB
40 GHZ to 45 GHz |  | 3 dB | 1 dB
45 GHZ to 50 GHz |  | 3.5 dB | 1 dB
50 GHZ to 60 GHz |  | 4 dB | 1.5 dB
60 GHZ to 67 GHz |  | 4.5 dB | 2.00 dB
67 GHZ to 70 GHz |  | 6 dB | 3.50 dB
Damage Level
E8361A |  | + 27 dBm
Maximum DC Level
E8361A |  | +/- 40 V

Table 28: Coupler Outputs (Port 1 Cplr Arm, Port 2 Cplr Arm)

Description | Specification | Supplemental Information
Damage Level
E8361A |  | + 30 dBm
Maximum DC Level
E8361A |  | +/- 7 V


Front panel N5230, 225 425 525

Specifications: Front-Panel Jumpers

Model N5230A Options 025, 125, 225, 425, and 525

NOTE: The N5230A Options 020, 120, 220, 420, and 520 (Standard Test Set and Standard Power Range) have no front-panel jumpers.

  • Measurement Receiver Inputs (Rcvr A In, Rcvr B In)

  • Reference Receiver Inputs (Rcvr R1 In, Rcvr R2 In)

  • Reference Outputs (Reference 1 Source Out, Reference 2 Source Out)

  • Source Outputs (Port 1 Source Out, Port 2 Source Out)

  • Coupler Inputs (Port 1 Coupler Thru, Port 2 Coupler Thru)

  • Coupler Outputs (Port 1 Coupler Arm, Port 2 Coupler Arm)

Table 30: Measurement Receiver Inputs (Rcvr A In, Rcvr B In) 0.1dB Typical Compression

Description | Specification | Typical
 |  | Option 025, 125 | Option 225 | Options 425, 525
Maximum Input Level
300 kHz to 10 MHz | -- | -11 dBm | -- | --
10 MHz to 45 MHz | -- | -7 dBm | - 2 dBm | - 20 dBm
45 MHz to 500 MHz | -- | -7 dBm | - 2 dBm | - 19 dBm
500 MHz to 2 GHz | -- | -6 dBm | - 3 dBm | - 14 dBm
2 GHz to 12.5 GHz | -- | -6 dBm | - 6 dBm | - 14 dBm
12.5 GHz to 13.5 GHz | -- | -7 dBm | - 6 dBm | - 15 dBm
13.5 GHz to 20 GHz | -- | -- | - 6 dBm | - 15 dBm
20 GHZ to 31.25 GHz | -- | -- | -- | - 16 dBm
31.25 GHZ to 40 GHz | -- | -- | -- | - 21 dBm
40 GHZ to 45 GHz | -- | -- | -- | - 24 dBm
45 GHZ to 50 GHz | -- | -- | -- | - 22 dBm
Damage Level
N5230A | -- | + 15 dBm
Maximum DC Level
N5230A | -- | +/- 16 V | +/- 7 V

Table 31: Reference Receiver Inputs (Rcvr R1, Rcvr R2) @ Max Specified Output Power

Description | Specification | Typical
 |  | Option 025, 125 | Option 225 | Options 425, 525
Maximum Input Level
300 kHz to 10 MHz | -- | -15 dBm | -- | --
10 MHz to 500 MHz | -- | -13 dBm | - 18 dBm | - 28 dBm
500 MHz to 2 GHz | -- | -14 dBm | - 18 dBm | - 28 dBm
2 GHz to 6 GHz | -- | -14 dBm | - 19 dBm | - 28 dBm
6 GHz to 8 GHz | -- | -16 dBm | - 19 dBm | - 28 dBm
8 GHz to 9 GHz | -- | -16 dBm | - 21 dBm | - 27 dBm
9 GHz to 10.5 GHz | -- | -20 dBm | - 21 dBm | - 27 dBm
10.5 GHz to 12.5 GHz | -- | -22 dBm | - 21 dBm | - 27 dBm
12.5 GHz to 13.5 GHz | -- | -24 dBm | - 23 dBm | - 26 dBm
13.5 GHz to 20 GHz | -- | -- | - 23 dBm | - 26 dBm
20 GHZ to 31.25 GHz | -- | -- | -- | - 33 dBm
31.25 GHZ to 40 GHz | -- | -- | -- | - 27 dBm
40 GHZ to 45 GHz | -- | -- | -- | - 29 dBm
45 GHZ to 50 GHz | -- | -- | -- | - 28 dBm
Damage Level
N5230A | -- | + 15 dBm
Maximum DC Level
N5230A | -- | +/- 16 V | +/- 7 V

Table 32: Reference Outputs (Reference 1 Source Out, Reference 2 Source Out) @ Max Specified Output Power

Description | Specification | Typical
 |  | Option 025, 125 | Option 225 | Options 425, 525
Maximum Input Level
300 kHz to 10 MHz | -- | -15 dBm | -- | --
10 MHz to 500 MHz | -- | -13 dBm | - 18 dBm | - 28 dBm
500 MHz to 2 GHz | -- | -14 dBm | - 18 dBm | - 28 dBm
2 GHz to 6 GHz | -- | -14 dBm | - 19 dBm | - 28 dBm
6 GHz to 8 GHz | -- | -16 dBm | - 19 dBm | - 28 dBm
8 GHz to 9 GHz | -- | -16 dBm | - 20 dBm | - 27 dBm
9 GHz to 10.5 GHz | -- | -20 dBm | - 20 dBm | - 27 dBm
10.5 GHz to 12.5 GHz | -- | -22 dBm | - 20 dBm | - 27 dBm
12.5 GHz to 13.5 GHz | -- | -24 dBm | - 23 dBm | - 26 dBm
13.5 GHz to 20 GHz | -- | -- | - 23 dBm | - 26 dBm
20 GHZ to 31.25 GHz | -- | -- | -- | - 32 dBm
31.25 GHZ to 40 GHz | -- | -- | -- | - 26 dBm
40 GHZ to 45 GHz | -- | -- | -- | - 29 dBm
45 GHZ to 50 GHz | -- | -- | -- | - 28 dBm
Damage Level
N5230A | -- | + 20 dBm
Maximum DC Level
N5230A | -- | +/- 16 V | +/- 7 V

Table 33: Source Outputs (Port 1 Source Out, Port 2 Source Out) @ Max Specified Output Power

Description | Specification | Typical
 |  | Option 025, 125 | Option 225 | Options 425, 525
Maximum Input Level
300 kHz to 10 MHz | -- | +11 dBm | -- | --
10 MHz to 500 MHz | -- | +11 dBm | + 6 dBm | +1 dBm
500 MHz to 6 GHz | -- | +11 dBm | +7 dBm | +1 dBm
6 GHz to 9 GHz | -- | +10 dBm | +7 dBm | +1 dBm
9 GHz to 12.5 GHz | -- | +8 dBm | +7 dBm | +1 dBm
12.5 GHz to 13.5 GHz | -- | +5 dBm | +5 dBm | +3 dBm
13.5 GHz to 20 GHz | -- | -- | +5 dBm | +3 dBm
20 GHZ to 31.25 GHz | -- | -- | -- | -5 dBm
31.25 GHZ to 40 GHz | -- | -- | -- | -4 dBm
40 GHZ to 45 GHz | -- | -- | -- | - 11 dBm
45 GHZ to 50 GHz | -- | -- | -- | - 11 dBm
Damage Level
N5230A | -- | + 27 dBm | + 30 dBm
Maximum DC Level
N5230A | -- | +/- 16 V | +/- 7 V

Table 34: Coupler Inputs (Port 1 Cplr Thru, Port 2 Cplr Thru) Insertion Loss of Coupler Thru

Description | Specification | Typical
 |  | Option 025, 125 | Option 225 | Options 425, 525
Maximum Input Level
300 kHz to 10 MHz | -- | 2 dB | -- | --
10 MHz to 500 MHz | -- | 2 dB | 0.6 dB | 0.6 dB
500 MHz to 2 GHz | -- | 3 dB | 1.6 dB | 0.8 dB
2 GHz to 8 GHz | -- | 3 dB | 1.8 dB | 1 dB
8 GHz to 9 GHz | -- | 3 dB | 1.9 dB | 1 dB
9 GHz to 12.5 GHz | -- | 4 dB | 1.9 dB | 1 dB
12.5 GHz to 13.5 GHz | -- | 4 dB | 2.0 dB | 2 dB
13.5 GHz to 20 GHz | -- | -- | 2.0 dB | 2 dB
20 GHZ to 31.25 GHz | -- | -- | -- | 3 dB
31.25 GHZ to 50 GHz | -- | -- | -- | 4 dB
Damage Level
N5230A | -- | + 27 dBm | + 30 dBm
Maximum DC Level
N5230A | -- | +/- 16 V | +/- 40 V

Table 35: Coupler Outputs (Port 1 Cplr Arm, Port 2 Cplr Arm)

Description | Specification | Typical
 |  | Option 025, 125 | Option 225 | Option 425, 525
Damage Level
N5230A | -- | + 15 dBm | + 30 dBm
Maximum DC Level
N5230A | -- | 0 V | +/- 7 V


fp_q_opt_specs

Specifications: Front-Panel Jumpers

Model N5230A Option 245

Note: The N5230A Option 240 (Standard Test Set and Standard Power Range) has no front-panel jumpers.

Reference Receiver (1ea) | For each Port (4x)

(See block diagram)

  • Measurement Receiver Inputs (Rcvr A In, Rcvr B In, Rcvr C In, Rcvr D In)

  • Reference Receiver Inputs (Rcvr In)

  • Reference Outputs (Source Out)

  • Source Outputs (Port 1 Source Out, Port 2 Source Out, Port 3 Source Out, Port 4 Source Out)

  • Coupler Inputs (Port 1 Coupler Thru, Port 2 Coupler Thru, Port 3 Coupler Thru, Port 4 Coupler Thru)

  • Coupler Outputs (Port 1 Coupler Arm, Port 2 Coupler Arm)

Table 20: Measurement Receiver Inputs (Rcvr A In, Rcvr B In, Rcvr C In, Rcvr D In) 0.1dB Typical Compression

Description | Specification | Typical
 |  | Option 245
Maximum Input Level
300 kHz to 10 MHz | -- | - 11 dBm
10 MHz to 1 GHz | -- | - 7 dBm
1 GHz to 12.5 GHz | -- | - 6 dBm
12.5 GHZ to 20 GHz | -- | - 7 dBm
Damage Level
N5230A | -- | + 15 dBm
Maximum DC Level
N5230A | -- | +/- 16 V

Table 21: Reference Receiver Input (Rcvr In) @ Max Specified Output Power

Description | Specification | Typical
 |  | Option 245
Maximum Input Level
300 kHz to 10 MHz | -- | - 15 dBm
10 MHz to 45 MHz | -- | - 15 dBm
45 MHz to 500 MHz | -- | - 15 dBm
500 MHz to 4 GHz | -- | - 15 dBm
4 GHz to 6 GHz | -- | - 16 dBm
6 GHz to 10.5 GHz | -- | - 20 dBm
10.5 GHz to 15 GHz | -- | - 21 dBm
15 GHz to 20 GHz | -- | - 27 dBm
Damage Level
N5230A | -- | + 15 dBm
Maximum DC Level
N5230A | -- | +/- 16 V

Table 22: Reference Output (Source Out) @ Max Specified Output Power

Description | Specification | Typical
 |  | Option 245
Maximum Output Level
300 kHz to 10 MHz | -- | - 15 dBm
10 MHz to 45 MHz | -- | - 15 dBm
45 MHz to 500 MHz | -- | - 15 dBm
500 MHz to 4 GHz | -- | - 15 dBm
4 GHz to 6 GHz | -- | - 15 dBm
6 GHz to 10.5 GHz | -- | - 20 dBm
10.5 GHz to 15 GHz | -- | - 21 dBm
15 GHz to 20 GHz | -- | - 27 dBm
Damage Level
N5230A | -- | + 27 dBm
Maximum DC Level
N5230A | -- | +/- 16 V

Table 23: Source Outputs (Port 1 Source Out, Port 2 Source Out, Port 3 Source Out, Port 4 Source Out) @ Max Specified Output Power

Description | Specification | Typical
 |  | Option 245
Maximum Output Level
300 kHz to 10 MHz | -- | +10 dBm
10 MHz to 45 MHz | -- | + 10 dBm
45 MHz to 500 MHz | -- | + 10 dBm
500 MHz to 4 GHz | -- | + 10 dBm
4 GHz to 6 GHz | -- | + 9 dBm
6 GHz to 10.5 GHz | -- | + 4 dBm
10.5 GHz to 15 GHz | -- | + 1 dBm
15 GHZ to 20 GHz | -- | - 4 dBm
Damage Level
N5230A | -- | + 27 dBm
Maximum DC Level
N5230A | -- | +/- 16V

Table 24: Coupler Inputs (Port 1 Cplr Thru, Port 2 Cplr Thru, Port 3 Cplr Thru, Port 4 Cplr Thru) Insertion Loss of Coupler Thru

Description | Specification | Typical
 |  | Option 245
Insertion Loss to Test Port
300 kHz to 10 MHz |  | 1.5 dB
10 MHz to 45 MHz | -- | 1.5 dB
45 MHz to 500 MHz | -- | 1.5 dB
500 MHz to 4 GHz | -- | 2.0 dB
4 GHz to 6 GHz | -- | 2.5 dB
6 GHz to 10.5 GHz | -- | 2.5 dB
10.5 GHz to 15 GHz | -- | 3.0 dB
15 GHz to 20 GHz | -- | 3.0 dB
Damage Level
N5230A | -- | + 27 dBm
Maximum DC Level
N5230A | -- | +/- 16 V

Table 25: Coupler Outputs (Port 1 Cplr Arm, Port 2 Cplr Arm, Port 3 Cplr Arm, Port 4 Cplr Arm)

Description | Specification | Typical
 |  | Option 245
Damage Level
N5230A | -- | + 15 dBm
Maximum DC Level
N5230A | -- | 0 V


Specs: Front Panel Jumpers, E835x std, E835x Opt 015

Specifications: Front-Panel Jumpers

Models E8356A, E8357A, E8358A - Standard

  • Port 1

  • Port 2

Models E8356A, E8357A, E8358A - Option 015

  • Port 1

  • Port 2

E8356A, 57A, 58A, Standard - Port 1

Use these SMA (female) connectors to develop custom measurements.

Receiver A Direct-Access Jumper

  • The upper "A" connector comes from the coupled arm of the Port 1 coupler.

  • The lower connector goes directly to the input of receiver "A." If Option 015 is installed, the path goes directly to a switchable attenuator and then to the receiver input.
Want to upgrade your analyzer? See information on Front-Panel Jumpers with Option 015.

For the A Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Noise Floor; rms (10 Hz Bandwidth):

<–130 dBm (300 kHz to 25 MHz)
<–123 dBm (3 GHz to 6 GHz)
<–123 dBm (6 GHz to 9 GHz)

Damage Level: +15 dBm

Maximum DC Level: +/-5 V

Return Loss:

>17 dB (300 kHz to 3 GHz)
>12 dB (3 GHz to 6 GHz)
>7 dB (6 GHz to 9 GHz)

Reference Channel R1 Jumper

  • The upper connector comes from the transfer switch Reference 1 output.

  • The lower connector goes directly to the R1 receiver input.

For the R1 Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Damage Level: >+15 dBm

Minimum Level to Maintain Phase-Lock:

–35 dBm (300 kHz to 3 GHz)
–25 dBm (3 GHz to 9 GHz)

For the Reference Output: (with an External Input to Lock the Source)

Output Level:

–5 to –30 dBm (300 kHz to 6 GHz)
–10 to –35 dBm (6 GHz to 9 GHz)

Source Match Return Loss:

16 dB (300 kHz to 3 GHz)
14 dB (3 GHz to 9 GHz)

Damage Level: >+15 dBm

Maximum DC Level: 40V

E8356A, 57A, 58A, Standard - Port 2

Use these SMA (female) connectors to develop custom measurements.

Receiver B Direct-Access Jumper

  • The upper "B" connector comes from the coupled arm of the Port 2 coupler.

  • The lower connector goes directly to the input of receiver "B." If Option 015 is installed, the path goes directly to a switchable attenuator and then to the receiver input.
Want to upgrade your analyzer? See information on Front-Panel Jumpers with Option 015.

For the B Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Noise Floor; rms (10 Hz Bandwidth):

<–130 dBm (300 kHz to 25 MHz)
<–123 dBm (3 GHz to 6 GHz)
<–123 dBm (6 GHz to 9 GHz)

Damage Level: +15 dBm

Maximum DC Level: +/-5 V

Return Loss:

>17 dB (300 kHz to 3 GHz)
>12 dB (3 GHz to 6 GHz)
>7 dB (6 GHz to 9 GHz)

Reference Channel R2 Jumper

  • The upper connector comes from the transfer switch Reference 2 output.

  • The lower connector goes directly to the R2 receiver input.

For the R2 Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Damage Level: >+15 dBm

Minimum Level to Maintain Phase-Lock:

–35 dBm (300 kHz to 3 GHz)
–25 dBm (3 GHz to 9 GHz)

For the Reference Output: (with an External Input to Lock the Source)

Output Level:

–5 to –30 dBm (300 kHz to 6 GHz)
–10 to –35 dBm (6 GHz to 9 GHz)

Source Match Return Loss:

16 dB (300 kHz to 3 GHz)
14 dB (3 GHz to 9 GHz)

Damage Level: >+15 dBm

Maximum DC Level: 40V

E8356A, 57A, 58A, Option 015 - Port 1

Use these SMA (female) connectors to develop custom measurements.

Receiver A Direct-Access Jumper

  • The upper "A" connector comes from the coupled arm of the Port 1 coupler.

  • The lower connector goes directly to the input of receiver "A." With Option 015, the path goes directly to a switchable attenuator and then to the receiver input.

For the A Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Noise Floor; rms (10 Hz Bandwidth):

<–130 dBm (300 kHz to 25 MHz)
<–123 dBm (3 GHz to 6 GHz)
<–123 dBm (6 GHz to 9 GHz)

Damage Level: +15 dBm

Maximum DC Level: +/-5 V

Return Loss:

>17 dB (300 kHz to 3 GHz)
>12 dB (3 GHz to 6 GHz)
>7 dB (6 GHz to 9 GHz)

Reference Channel R1 Jumper

  • The upper connector comes from the transfer switch Reference 1 output.

  • The lower connector goes directly to the R1 receiver input.

For the R1 Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Damage Level: >+15 dBm

Minimum Level to Maintain Phase-Lock:

–35 dBm (300 kHz to 3 GHz)
–25 dBm (3 GHz to 9 GHz)

For the Reference Output: (with an External Input to Lock the Source)

Output Level:

–5 to –30 dBm (300 kHz to 6 GHz)
–10 to –35 dBm (6 GHz to 9 GHz)

Source Match Return Loss:

16 dB (300 kHz to 3 GHz)
14 dB (3 GHz to 9 GHz)

Damage Level: >+15 dBm

Maximum DC Level: 40V

Port 1 Test-Port Jumper

  • The upper "source out" connector comes from the transfer switch Port 1 output.

  • The lower "coupler in" connector goes directly to the main input of Port 1 coupler. This is where a power amplifier can be inserted to boost the test port power.

For the Source Output:

Output Level:

+12 to –83 dBm (300 kHz to 6 GHz)
+7 to –88 dBm (6 GHz to 9 GHz)

Source Match: 15 dB at 9 GHz

For the Input to the Coupler:

Insertion Loss to Test Port 1:

<3.5 dB at 3 GHz
<5 dB at 9 GHz

Maximum Input Power: 2 Watts, CW

Damage Level: 4 Watts, CW

E8356A, 57A, 58A, Option 015 - Port 2

Use these SMA (female) connectors to develop custom measurements.

Receiver B Direct-Access Jumper

  • The upper "B" connector comes from the coupled arm of the Port 2 coupler.

  • The lower connector goes directly to the input of receiver "B." With Option 015, the path goes directly to a switchable attenuator and then to the receiver input.

For the B Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Noise Floor; rms (10 Hz Bandwidth):

<–130 dBm (300 kHz to 25 MHz)
<–123 dBm (3 GHz to 6 GHz)
<–123 dBm (6 GHz to 9 GHz)

Damage Level: +15 dBm

Maximum DC Level: +/-5 V

Return Loss:

>17 dB (300 kHz to 3 GHz)
>12 dB (3 GHz to 6 GHz)
>7 dB (6 GHz to 9 GHz)

Reference Channel R2 Jumper

  • The upper connector comes from the transfer switch Reference 2 output.

  • The lower connector goes directly to the R2 receiver input.

For the R2 Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Damage Level: >+15 dBm

Minimum Level to Maintain Phase-Lock:

–35 dBm (300 kHz to 3 GHz)
–25 dBm (3 GHz to 9 GHz)

For the Reference Output: (with an External Input to Lock the Source)

Output Level:

–5 to –30 dBm (300 kHz to 6 GHz)
–10 to –35 dBm (6 GHz to 9 GHz)

Source Match Return Loss:

16 dB (300 kHz to 3 GHz)
14 dB (3 GHz to 9 GHz)

Damage Level: >+15 dBm

Maximum DC Level: 40V

Port 2 Test-Port Jumper

  • The upper "source out" connector comes from the transfer switch Port 2 output.

  • The lower "coupler in" connector goes directly to the main input of Port 2 coupler. This is where a power amplifier can be inserted to boost the test port power.

For the Source Output:

Output Level:

+12 to –83 dBm (300 kHz to 6 GHz)
+7 to –88 dBm (6 GHz to 9 GHz)

Source Match: 15 dB at 9 GHz

For the Input to the Coupler:

Insertion Loss to Test Port 2:

<3.5 dB at 3 GHz
<5 dB at 9 GHz

Maximum Input Power: 2 Watts, CW

Damage Level: 4 Watts, CW


Specs: Front Panel Jumpers, E880x Opt 014

Specifications: Front-Panel Jumpers

Models E8801A, E8802A, E8803A Option 014

  • Port 1

  • Port 2

Specifications: Front-Panel Jumpers, Port 1

Option 014 Analyzer

NOTE: The standard analyzer (E8801A/ E8802A/ E8803A) has no front-panel jumpers.

Use these SMA (female) connectors to develop custom measurements.

Receiver A Direct-Access Jumper

  • The "Cplr Arm" connector comes from the coupled arm of the Port 1 coupler.

  • The "Rcvr A In"connector goes directly to the input of receiver "A."

For the A Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Noise Floor; rms (10 Hz Bandwidth):

<–130 dBm (300 kHz to 25 MHz)
<–123 dBm (3 GHz to 6 GHz)
<–123 dBm (6 GHz to 9 GHz)

Damage Level: +15 dBm

Maximum DC Level: +/-5 V

Return Loss:

>17 dB (300 kHz to 3 GHz)
>12 dB (3 GHz to 6 GHz)
>7 dB (6 GHz to 9 GHz)

Reference Channel R Jumper

  • The "Source Out" connector comes from the source Reference output.

  • The "Rcvr R In" connector goes directly to the R receiver input.

For the R Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Damage Level: >+15 dBm

Minimum Level to Maintain Phase-Lock:

–35 dBm (300 kHz to 3 GHz)
–25 dBm (3 GHz to 9 GHz)

For the Reference Output: (with an External Input to Lock the Source)

Output Level:

–5 to –30 dBm (300 kHz to 6 GHz)
–10 to –35 dBm (6 GHz to 9 GHz)

Source Match Return Loss:

16 dB (300 kHz to 3 GHz)
14 dB (3 GHz to 9 GHz)

Damage Level: >+15 dBm

Maximum DC Level: 40V

Port 1 Test-Port Jumper

  • The upper "Source Out" connector comes from the transfer switch Port 1 output.

  • The lower "Coupler Thru" connector goes directly to the main input of Port 1 coupler. This is where a power amplifier can be inserted to boost the test port power.

For the Source Output:

Output Level:

+12 to –83 dBm (300 kHz to 6 GHz)
+7 to –88 dBm (6 GHz to 9 GHz)

Source Match: 15 dB at 9 GHz

For the Input to the Coupler:

Insertion Loss to Test Port 1:

<3.5 dB at 3 GHz
<5 dB at 9 GHz

Maximum Input Power: 2 Watts, CW

Damage Level: 4 Watts, CW

Specifications: Front-Panel Jumpers, Port 2

Option 014 Analyzer

NOTE: The standard analyzer (E8801A/ E8802A/ E8803A) has no front-panel jumpers.

Use these SMA (female) connectors to develop custom measurements.

Receiver B Direct-Access Jumper

  • The upper "Cplr Arm" connector comes from the coupled arm of the Port 2 coupler.

  • The "Rcvr B In" connector goes directly to the input of receiver "B."

For the B Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Noise Floor; rms (10 Hz Bandwidth):

<–130 dBm (300 kHz to 25 MHz)
<–123 dBm (3 GHz to 6 GHz)
<–123 dBm (6 GHz to 9 GHz)

Damage Level: +15 dBm

Maximum DC Level: +/-5 V

Return Loss:

>17 dB (300 kHz to 3 GHz)
>12 dB (3 GHz to 6 GHz)
>7 dB (6 GHz to 9 GHz)

Port 2 Test-Port Jumper

  • The upper "Source Out" connector comes from the transfer switch Port 2 output.

  • The lower "Coupler Thru" connector goes directly to the main input of Port 2 coupler. This is where a power amplifier can be inserted to boost the test port power.

For the Source Output:

Output Level:

+12 to –83 dBm (300 kHz to 6 GHz)
+7 to –88 dBm (6 GHz to 9 GHz)

Source Match: 15 dB at 9 GHz

For the Input to the Coupler:

Insertion Loss to Test Port 2:

<3.5 dB at 3 GHz
<5 dB at 9 GHz

Maximum Input Power: 2 Watts, CW

Damage Level: 4 Watts, CW


Specs: Front Panel Jumpers, N338x Opt 014

Specifications: Front-Panel Jumpers

Models N3381A, N3382A, N3383A Option 014

  • Port 1

  • Port 2 and Port 3

Specifications: Front-Panel Jumpers, Port 1

Option 014 Analyzer

NOTE: The standard analyzer (N3381A/ N3382A/ N3383A) has no front-panel jumpers.

Use these SMA (female) connectors to develop custom measurements.

Receiver A Direct-Access Jumper

  • The "Cplr Arm" connector comes from the coupled arm of the Port 1 coupler.

  • The "Rcvr A In" connector goes directly to the input of receiver "A."

For the A Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Noise Floor; rms (10 Hz Bandwidth):

<–130 dBm (300 kHz to 25 MHz)
<–123 dBm (3 GHz to 6 GHz)
<–123 dBm (6 GHz to 9 GHz)

Damage Level: +15 dBm

Maximum DC Level: +/-5 V

Return Loss:

>17 dB (300 kHz to 3 GHz)
>12 dB (3 GHz to 6 GHz)
>7 dB (6 GHz to 9 GHz)

Reference Channel R Jumper

  • The "Source Out" connector comes from the source Reference output.

  • The "Rcvr R In" connector goes directly to the R receiver input.

For the R Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Damage Level: >+15 dBm

Minimum Level to Maintain Phase-Lock:

–35 dBm (300 kHz to 3 GHz)
–25 dBm (3 GHz to 9 GHz)

For the Reference Output: (with an External Input to Lock the Source)

Output Level:

–5 to –30 dBm (300 kHz to 6 GHz)
–10 to –35 dBm (6 GHz to 9 GHz)

Source Match Return Loss:

16 dB (300 kHz to 3 GHz)
14 dB (3 GHz to 9 GHz)

Damage Level: >+15 dBm

Maximum DC Level: 40V

Port 1 Test-Port Jumper

  • The upper "Source Out" connector comes from the transfer switch Port 1 output.

  • The lower "Coupler Thru" connector goes directly to the main input of Port 1 coupler. This is where a power amplifier can be inserted to boost the test port power.

For the Source Output:

Output Level:

+12 to –83 dBm (300 kHz to 6 GHz)
+7 to –88 dBm (6 GHz to 9 GHz)

Source Match: 15 dB at 9 GHz

For the Input to the Coupler:

Insertion Loss to Test Port 1:

<3.5 dB at 3 GHz
<5 dB at 9 GHz

Maximum Input Power: 2 Watts, CW

Damage Level: 4 Watts, CW

Specifications: Front-Panel Jumpers, Port 2 and Port 3

Option 014 Analyzer

NOTE: The standard analyzer (N3381A/ N3382A/ N3383A) has no front-panel jumpers.

Use these SMA (female) connectors to develop custom measurements.

Receiver B Direct-Access Jumper

  • The upper "Cplr Arm" connector comes from the coupled arm of the Port 2 coupler.

  • The "Rcvr B In" connector goes directly to the input of receiver "B."

For the B Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Noise Floor; rms (10 Hz Bandwidth):

<–130 dBm (300 kHz to 25 MHz)
<–123 dBm (3 GHz to 6 GHz)
<–123 dBm (6 GHz to 9 GHz)

Damage Level: +15 dBm

Maximum DC Level: +/-5 V

Return Loss:

>17 dB (300 kHz to 3 GHz)
>12 dB (3 GHz to 6 GHz)
>7 dB (6 GHz to 9 GHz)

Port 2 Test-Port Jumper

  • The upper "Source Out" connector comes from the transfer switch Port 2 output.

  • The lower "Coupler Thru" connector goes directly to the main input of Port 2 coupler. This is where a power amplifier can be inserted to boost the test port power.

For the Source Output:

Output Level:

+10 to –85 dBm (300 kHz to 6 GHz)
+7 to –88 dBm (6 GHz to 9 GHz)

Source Match: 15 dB at 9 GHz

For the Input to the Coupler:

Insertion Loss to Test Port 2:

<3.5 dB at 3 GHz
<5 dB at 9 GHz

Maximum Input Power: 2 Watts, CW

Damage Level: 4 Watts, CW

Receiver C Direct-Access Jumper

  • The upper "Cplr Arm" connector comes from the coupled arm of the Port 3 coupler.

  • The "Rcvr C In" connector goes directly to the input of receiver "C."

For the C Receiver Input:

Maximum Input Level:

–6 dBm; <0.4 dB Compression (300 kHz to 3 GHz)
–6 dBm; <0.8 dB Compression (3 GHz to 6 GHz)
–11 dBm; <0.8 dB Compression (6 GHz to 9 GHz)

Noise Floor; rms (10 Hz Bandwidth):

<–130 dBm (300 kHz to 25 MHz)
<–123 dBm (6 GHz to 9 GHz)

Damage Level: +15 dBm

Maximum DC Level: +/-5 V

Return Loss:

>17 dB (300 kHz to 3 GHz)
>12 dB (3 GHz to 6 GHz)
>7 dB (6 GHz to 9 GHz)


Specs: Manual-identify the PNA

Identify Your Analyzer

Please select the PNA model of the specifications you would like to see.

<=Back

Select your PNA model:

E8356A E8357A E8358A | E8801A E8802A E8803A | N3381A N3382A N3383A | N5230A (2-port) | N5230A (4-port)
E8361A | E8362A E8363A E8364A | E8362B E8363B E8364B | N5250A |

Click


Specs: Using Cal Kits with 7mm Connectors

E836xB Corrected System Performance with 7mm Connectors

85050B Calibration Kit:

    • Standard Configuration and Standard Power Range (E836xB)

    • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

85050C Calibration Kit:

    • Standard Configuration and Standard Power Range (E836xB)

    • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

85050D Calibration Kit:

    • Standard Configuration and Standard Power Range (E836xB)

    • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Table 15. 85050B Calibration Kit
Standard Configuration and Standard Power Range
(E836xB)

Applies to the, E836xB analyzers, 85050B (7mm) calibration kit, 85132F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 18 GHz
Directivity | 52 | 52
Source Match | 48 | 41
Load Match | 52 | 47
Reflection Tracking | ±0.003 +0.02/°C | ±0.047 +0.02/°C
Transmission Tracking | ±0.004 +0.02/°C | ±0.032 +0.02/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 16. 85050B Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E836xB analyzers, 85050B (7mm) calibration kit, 85132F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 18 GHz
Directivity | 52 | 52
Source Match | 48 | 41
Load Match | 52 | 47
Reflection Tracking | ±0.003 +0.02/°C | ±0.047 +0.02/°C
Transmission Tracking | ±0.008 +0.02/°C | ±0.034 +0.02/°C

Transmission Uncertainty (Specifications)

*Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

*Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Table 17. 85050C Calibration Kit
Standard Configuration and Standard Power Range
(E836xB)

Applies to the, E836xB analyzers, 85050C (7mm) calibration kit, 85132F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 18 GHz
Directivity | 52 | 60
Source Match | 48 | 60
Load Match | 52 | 60
Reflection Tracking | ±0.003 +0.02/°C | ±0.000 +0.02/°C
Transmission Tracking | ±0.004 +0.02/°C | ±0.004 +0.02/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 18. 85050C Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E836xB analyzers, 85050C (7mm) calibration kit, 85132F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 18 GHz
Directivity | 52 | 60
Source Match | 48 | 60
Load Match | 52 | 60
Reflection Tracking | ±0.003 +0.02/°C | ±0.000 +0.02/°C
Transmission Tracking | ±0.008 +0.02/°C | ±0.005 +0.02/°C

Transmission Uncertainty (Specifications)

*Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

*Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Table 19. 85050D Calibration Kit
Standard Configuration and Standard Power Range
(E836xB)

Applies to the, E836xB analyzers, 85050D (7mm) calibration kit, 85132F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 18 GHz
Directivity | 40 | 40
Source Match | 39 | 35
Load Match | 40 | 37
Reflection Tracking | ±0.010 +0.02/°C | ±0.100 +0.02/°C
Transmission Tracking | ±0.013 +0.02/°C | ±0.072 +0.02/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 20. 85050D Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E836xB analyzers, 85050D (7mm) calibration kit, 85132F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 18 GHz
Directivity | 40 | 40
Source Match | 39 | 35
Load Match | 40 | 37
Reflection Tracking | ±0.010 +0.02/°C | ±0.100 +0.02/°C
Transmission Tracking | ±0.025 +0.02/°C | ±0.078 +0.02/°C

Transmission Uncertainty (Specifications)

*Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

*Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)


Specs: Using Cal Kits with 1.85mm Connectors

E8361A Corrected System Performance with 1.85mm Connectors

85058B Calibration Kit:

  • Standard Configuration and Standard Power Range (E8361A)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
    (E8361A - Option 014, UNL, 016, 080, and 081)

N4694A ECal Module:

  • Standard Configuration and Standard Power Range (E8361A)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
    (E8361A - Option 014, UNL, 016, 080, and 081)

Table 2. 85058B Calibration Kit
E8361A - Standard Configuration and Standard Power Range

Applies to the E8361A analyzers, 85058B (1.85mm) calibration kit, N4697F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 10 to 45 MHz1 | 45 MHz to 2 GHz | 2 to 10 GHz | 10 to 20 GHz
Directivity | 35 | 35 | 41 | 38
Source Match | 34 | 34 | 44 | 40
Load Match | 35 | 35 | 41 | 37
Reflection Tracking | ±0.019 +0.02/°C | ±0.019 +0.02/°C | ±0.010 +0.02/°C | ±0.033 +0.03/°C
Transmission Tracking | ±0.164 +0.02/°C | ±0.081 +0.02/°C | ±0.036 +0.02/°C | ±0.063 +0.03/°C

1 Typical performance.

Description | Specification (dB)
 | 20 to 35 GHz | 35 to 50 GHz | 50 to 60 GHz | 60 to 67 GHz
Directivity | 37 | 37 | 34 | 34
Source Match | 34 | 34 | 44 | 40
Load Match | 34 | 35 | 41 | 37
Reflection Tracking | ±0.019 +0.02/°C | ±0.019 +0.02/°C | ±0.010 +0.02/°C | ±0.033 +0.03/°C
Transmission Tracking | ±0.164 +0.02/°C | ±0.081 +0.02/°C | ±0.036 +0.02/°C | ±0.063 +0.03/°C

Transmission Uncertainty (Specifications)

1 Typical performance.

1 Typical performance.

Reflection Uncertainty (Specifications)

1 Typical performance.

1 Typical performance.

Table 3. 85058B Calibration Kit
E8361A - Fully Optioned (Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E8361A analyzers, 85058B (1.85mm) calibration kit, N4697F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 10 to 45 MHz1 | 45 MHz to 2 GHz | 2 to 10 GHz | 10 to 20 GHz
Directivity | 35 | 35 | 41 | 38
Source Match | 34 | 34 | 44 | 40
Load Match | 34 | 35 | 41 | 37
Reflection Tracking | ±0.019 +0.02/°C | ±0.019 +0.02/°C | ±0.010 +0.02/°C | ±0.033 +0.03/°C
Transmission Tracking | ±0.177 +0.02/°C | ±0.093 +0.02/°C | ±0.053 +0.02/°C | ±0.096 +0.03/°C

1 Typical performance.

Description | Specification (dB)
 | 20 to 35 GHz | 35 to 50 GHz | 50 to 60 GHz | 60 to 67 GHz
Directivity | 37 | 37 | 34 | 34
Source Match | 34 | 34 | 44 | 40
Load Match | 34 | 35 | 41 | 37
Reflection Tracking | ±0.019 +0.02/°C | ±0.019 +0.02/°C | ±0.010 +0.02/°C | ±0.033 +0.03/°C
Transmission Tracking | ±0.177 +0.02/°C | ±0.093 +0.02/°C | ±0.053 +0.02/°C | ±0.096 +0.03/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (Option 014, UNL, 016, 080, and 081)

1 Typical performance.

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (Option 014, UNL, 016, 080, and 081)

1 Typical performance.

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (Option 014, UNL, 016, 080, and 081)

1 Typical performance.

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (Option 014, UNL, 016, 080, and 081)

1 Typical performance.

Table 4. N4694A Calibration Kit
E8361A - Standard Configuration and Standard Power Range

Applies to the, E8361A analyzers, N4694A (1.85mm) ECal module, N4697F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 10 to 40 MHz1 | 40 MHz to 2 GHz | 2 to 20 GHz | 20 to 30 GHz
Directivity | 33 | 50 | 50 | 46
Source Match | 25 | 38 | 39 | 35
Load Match | 30 | 39 | 40 | 38
Reflection Tracking | ±0.050 +0.02/°C | ±0.040 +0.02/°C | ±0.040 +0.02/°C | ±0.050 +0.03/°C
Transmission Tracking | ±0.255 +0.02/°C | ±0.118 +0.02/°C | ±0.135 +0.02/°C | ±0.139 +0.03/°C

1 Typical performance.

Description | Specification (dB)
 | 30 to 40 GHz | 40 to 50 GHz | 50 to 60 GHz | 60 to 67 GHz
Directivity | 44 | 42 | 41 | 38
Source Match | 25 | 38 | 39 | 35
Load Match | 30 | 39 | 40 | 38
Reflection Tracking | ±0.040 +0.02/°C | ±0.040 +0.02/°C | ±0.040 +0.02/°C | ±0.050 +0.03/°C
Transmission Tracking | ±0.105 +0.02/°C | ±0.118 +0.02/°C | ±0.135 +0.02/°C | ±0.139 +0.03/°C

Transmission Uncertainty (Specifications)

1 Typical performance.

1 Typical performance.

Reflection Uncertainty (Specifications)

1 Typical performance.

1 Typical performance.

Table 5. N4694A Calibration Kit
E8361A - Fully Optioned (Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E8361A analyzers, N4694A (1.85mm) ECal module, N4697F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 10 to 40 MHz1 | 40 MHz to 2 GHz | 2 to 20 GHz | 20 to 30 GHz
Directivity | 33 | 50 | 50 | 46
Source Match | 25 | 38 | 39 | 35
Load Match | 30 | 39 | 39 | 38
Reflection Tracking | ±0.050 +0.02/°C | ±0.040 +0.02/°C | ±0.040 +0.02/°C | ±0.050 +0.03/°C
Transmission Tracking | ±0.260 +0.02/°C | ±0.121 +0.02/°C | ±0.139 +0.02/°C | ±0.138 +0.03/°C

1 Typical performance.

Description | Specification (dB)
 | 30 to 40 GHz | 40 to 50 GHz | 50 to 60 GHz | 60 to 67 GHz
Directivity | 44 | 42 | 41 | 38
Source Match | 25 | 38 | 39 | 35
Load Match | 30 | 39 | 39 | 38
Reflection Tracking | ±0.050 +0.02/°C | ±0.040 +0.02/°C | ±0.040 +0.02/°C | ±0.050 +0.03/°C
Transmission Tracking | ±0.260 +0.02/°C | ±0.121 +0.02/°C | ±0.139 +0.02/°C | ±0.138 +0.03/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (Option 014, UNL, 016, 080, and 081)

1 Typical performance.

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (Option 014, UNL, 016, 080, and 081)

1 Typical performance.

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (Option 014, UNL, 016, 080, and 081)

1 Typical performance.

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (Option 014, UNL, 016, 080, and 081)

1 Typical performance.

This document does not present specifications for the 85058E Calibration Kit. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the data and curves for the 85058E Calibration Kit or your PNA setup. View the equations used to generate the uncertainty curve.


Specs: Using Cal Kits with 2.4mm Connectors

E8363/4B Corrected System Performance with 2.4mm Connectors

85056A Calibration Kit:

  • Standard Configuration and Standard Power Range (E8363/4B)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

85056D Calibration Kit:

  • Standard Configuration and Standard Power Range (E8363/4B)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Table 3. 85056A Calibration Kit
Standard Configuration and Standard Power Range
(E8363/4B)

Applies to the E8363/4B analyzers, 85056A (2.4mm) calibration kit, 85133F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 42 | 42 | 38 | 36
Source Match | 41 | 38 | 33 | 31
Load Match | 42 | 42 | 37 | 35
Reflection Tracking | ±0.001 +0.02/°C | ±0.008 +0.02/°C | ±0.020 +0.02/°C | ±0.027 +0.03/°C
Transmission Tracking | ±0.010 +0.02/°C | ±0.049 +0.02/°C | ±0.105 +0.02/°C | ±0.170 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 4. 85056A Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E8363/4B analyzers, 85056A (2.4mm) calibration kit, 85133F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 42 | 42 | 38 | 36
Source Match | 41 | 38 | 33 | 31
Load Match | 42 | 42 | 37 | 35
Reflection Tracking | ±0.001 +0.02/°C | ±0.008 +0.02/°C | ±0.020 +0.02/°C | ±0.027 +0.03/°C
Transmission Tracking | ±0.019 +0.02/°C | ±0.053 +0.02/°C | ±0.109 +0.02/°C | ±0.182 +0.03/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Table 5. 85056D Calibration Kit
Standard Configuration and Standard Power Range
(E8363/4B)

Applies to the, E8363/4B analyzers, 85056D (2.4mm) calibration kit, 85133F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 42 | 34 | 26 | 26
Source Match | 40 | 30 | 24 | 23
Load Match | 42 | 33 | 25 | 25
Reflection Tracking | ±0.002 +0.02/°C | ±0.029 +0.02/°C | ±0.079 +0.02/°C | ±0.075 +0.03/°C
Transmission Tracking | ±0.011 +0.02/°C | ±0.121 +0.02/°C | ±0.347 +0.02/°C | ±0.462 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 6. 85056D Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E8363/4B analyzers, 85056D (2.4mm) calibration kit, 85133F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 42 | 34 | 26 | 26
Source Match | 40 | 30 | 24 | 23
Load Match | 42 | 33 | 25 | 25
Reflection Tracking | ±0.002 +0.02/°C | ±0.029 +0.02/°C | ±0.079 +0.02/°C | ±0.075 +0.03/°C
Transmission Tracking | ±0.022 +0.02/°C | ±0.130 +0.02/°C | ±0.365 +0.02/°C | ±0.498 +0.03/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)


Specs: Using Cal Kits with 2.4mm Connectors

E8361A Corrected System Performance with 2.4mm Connectors

85056A Calibration Kit:

  • Standard Configuration and Standard Power Range (E8361A)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
    (E8361A - Option 014, UNL, 016, 080, and 081)

N4693A Electronic Calibration Module

  • Standard Configuration and Standard Power Range (E8361A)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
    (E8361A - Option 014, UNL, 016, 080, and 081)

Table 6. 85056A Calibration Kit
E8361A - Standard Configuration and Standard Power Range

Applies to the E8361A analyzers, 85056A (2.4mm) Calibration Kit, 85133F flexible test port cable set, and a full 2-port calibration. (2.4 mm connectors are mateable with 1.85 mm connectors.) Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 42 | 42 | 38 | 36
Source Match | 41 | 38 | 33 | 31
Load Match | 42 | 42 | 37 | 35
Reflection Tracking | ±0.001 +0.02/°C | ±0.008 +0.02/°C | ±0.020 +0.02/°C | ±0.027 +0.03/°C
Transmission Tracking | ±0.035 +0.02/°C | ±0.060 +0.02/°C | ±0.146 +0.02/°C | ±0.181 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 7. 85056A Calibration Kit
E8361A - Fully Optioned (Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E8361A analyzers, 85056A (2.4mm) Calibration Kit, 85133F flexible test port cable set, and a full 2-port calibration. (2.4 mm connectors are mateable with 1.85 mm connectors.) Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 42 | 42 | 38 | 36
Source Match | 41 | 38 | 33 | 31
Load Match | 42 | 41 | 37 | 35
Reflection Tracking | ±0.001 +0.02/°C | ±0.008 +0.02/°C | ±0.020 +0.02/°C | ±0.027 +0.03/°C
Transmission Tracking | ±0.040 +0.02/°C | ±0.086 +0.02/°C | ±0.123 +0.02/°C | ±0.155 +0.03/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E8361A - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E8361A - Option 014, UNL, 016, 080, and 081)

Table 8. N4693A Electronic Calibration Module
E8361A - Standard Configuration and Standard Power Range

Applies to the, E8361A analyzers, N4693A (2.4mm) Electronic Calibration Module, 85133F flexible test port cable set, and a full 2-port calibration. (2.4 mm connectors are mateable with 1.85 mm connectors.) Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 55 | 49 | 43 | 41
Source Match | 46 | 42 | 35 | 30
Load Match | 43 | 41 | 37 | 36
Reflection Tracking | ±0.030 +0.02/°C | ±0.040 +0.02/°C | ±0.060 +0.02/°C | ±0.080 +0.03/°C
Transmission Tracking | ±0.059 +0.02/°C | ±0.079 +0.02/°C | ±0.110 +0.02/°C | ±0.125 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 9. N4693A Electronic Calibration Module
E8361A - Fully Optioned (Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E8361A analyzers, N4693A(2.4mm) Electronic Calibration Module, 85133F flexible test port cable set, and a full 2-port calibration. (2.4 mm connectors are mateable with 1.85 mm connectors.) Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 55 | 49 | 43 | 41
Source Match | 46 | 42 | 35 | 30
Load Match | 43 | 41 | 37 | 36
Reflection Tracking | ±0.030 +0.02/°C | ±0.040 +0.02/°C | ±0.060 +0.02/°C | ±0.080 +0.03/°C
Transmission Tracking | ±0.060 +0.02/°C | ±0.082 +0.02/°C | ±0.106 +0.02/°C | ±0.121 +0.03/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E8361A - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E8361A - Option 014, UNL, 016, 080, and 081)

This document does not present specifications for the 85056D or 85056K Calibration Kit. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the data and curves for the 85056D or 85056K Calibration Kit or your PNA setup. View the equations used to generate the uncertainty curve


Specs: Using Cal Kits with 2.4mm Connectors

N5230A Corrected System Performance with 2.4mm Connectors

Options 220/225, 420/425, and 520/525

85056A Calibration Kit:

  • N5230A - Option 420 or 520 (Standard Test Set and Standard Power Range

  • N5230A Option 425 or 525
    Configurable Test Set and Extended Power Range

N4693A Electronic Calibration Module

  • N5230A - Option 420 or 520
    Standard Test Set and Standard Power Range

  • N5230A Option 425 or 525
    Configurable Test Set and Extended Power Range

Table 9. 85056A Calibration Kit
N5230A - Option 420 or 520 (Standard Test Set and Standard Power Range)

Applies to the N5230A Option 420 or 520 analyzers, 85056A (2.4mm) Electronic Calibration Module, 85133F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 42 | 42 | 38 | 36
Source Match | 41 | 38 | 33 | 31
Load Match | 42 | 42 | 37 | 35
Reflection Tracking | ±0.001 +0.02/°C | ±0.008 +0.02/°C | ±0.020 +0.02/°C | ±0.027 +0.03/°C
Transmission Tracking | ±0.019 +0.02/°C | ±0.060 +0.02/°C | ±0.129 +0.02/°C | ±0.211 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 10. 85056A Calibration Kit
N5230A - Option 425 or 525 (Configurable Test Set and Extended Power Range)

Applies to the N5230A Option 425 or 525 analyzers, 85056A (2.4mm) Electronic Calibration Module, 85133F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 42 | 42 | 38 | 36
Source Match | 41 | 38 | 33 | 31
Load Match | 42 | 42 | 37 | 35
Reflection Tracking | ±0.001 +0.02/°C | ±0.008 +0.02/°C | ±0.020 +0.02/°C | ±0.027 +0.03/°C
Transmission Tracking | ±0.019 +0.02/°C | ±0.057 +0.02/°C | ±0.124 +0.02/°C | ±0.211 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 11. N4693A Electronic Calibration Module
N5230A - Option 420 or 520 (Standard Test Set and Standard Power Range)

Applies to the N5230A Option 420 or 520 analyzers, N4693A (2.4mm) Electronic Calibration Module, 85133F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 55 | 49 | 43 | 41
Source Match | 46 | 42 | 35 | 30
Load Match | 43 | 41 | 37 | 36
Reflection Tracking | ±0.030 +0.02/°C | ±0.040 +0.02/°C | ±0.060 +0.02/°C | ±0.080 +0.03/°C
Transmission Tracking | ±0.056 +0.02/°C | ±0.079 +0.02/°C | ±0.107 +0.02/°C | ±0.130 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 12. N4693A Electronic Calibration Module
N5230A - Option 425 or 525 (Configurable Test Set and Extended Power Range)

Applies to the N5230A Option 425 or 525 analyzers, N4693A(2.4mm) Electronic Calibration Module, 85133F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 40 GHz | 40 to 50 GHz
Directivity | 55 | 49 | 43 | 41
Source Match | 46 | 42 | 35 | 30
Load Match | 43 | 41 | 37 | 36
Reflection Tracking | ±0.030 +0.02/°C | ±0.040 +0.02/°C | ±0.060 +0.02/°C | ±0.080 +0.03/°C
Transmission Tracking | ±0.056 +0.02/°C | ±0.078 +0.02/°C | ±0.107 +0.02/°C | ±0.130 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

This N5230A document does not present specifications for the 85056D or 85056K Calibration Kit. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the data and curves for the 85056D and 85056K Calibration Kit or your PNA setup. View the equations used to generate the uncertainty curves.


Specs: Using Cal Kits with WR28 Connectors

E8363/4B Corrected System Performance with WR-28 Connectors

R11644A Calibration Kit:

  • Standard Configuration and Standard Power Range (E8363/4B)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Table 25. R11644A Calibration Kit
Standard Configuration and Standard Power Range
(E8363/4B)

Applies to the, E8363/4B analyzers, R11644A (WR-28) calibration kit, 85133F flexible test port cable set with the R281A and R281B launch sets, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 26.5 to 40 GHz
Directivity | 50
Source Match | 50
Load Match | 50
Reflection Tracking | ±0.000 +0.03/°C
Transmission Tracking | ±0.018 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 26. R11644A Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E8363/4B analyzers, R11644A (WR-28) calibration kit, 85133F flexible test port cable set with the R281A and R281B launch sets, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 26.5 to 40 GHz
Directivity | 50
Source Match | 50
Load Match | 50
Reflection Tracking | ±0.000 +0.03/°C
Transmission Tracking | ±0.019 +0.03/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)


Specs: Using Cal Kits with 2.92mm Connectors

E8363/4B Corrected System Performance with 2.92mm Connectors

85056K Calibration Kit:

  • Standard Configuration and Standard Power Range (E8363/4B)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Table 7. 85056K Calibration Kit
Standard Configuration and Standard Power Range
(E8363/4B)

Applies to the, E8363/4B analyzers, 85056K (2.92mm) calibration kit, 85133F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 20 GHz | 20 to 40 GHz
Directivity | 42 | 42 | 40
Source Match | 40 | 40 | 35
Load Match | 42 | 41 | 38
Reflection Tracking | ±0.018 +0.02/°C | ±0.018 +0.02/°C | ±0.067 +0.03/°C
Transmission Tracking | ±0.011 +0.02/°C | ±0.042 +0.02/°C | ±0.089 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 8. 85056K Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E8363/4B analyzers, 85056K (2.92mm) calibration kit, 85133F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 20 GHz | 20 to 40 GHz
Directivity | 42 | 42 | 40
Source Match | 40 | 40 | 35
Load Match | 42 | 41 | 38
Reflection Tracking | ±0.018 +0.02/°C | ±0.018 +0.02/°C | ±0.067 +0.03/°C
Transmission Tracking | ±0.021 +0.02/°C | ±0.046 +0.02/°C | ±0.094 +0.03/°C

Transmission Uncertainty (Specifications

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)


Specs: Using Cal Kits with 3.5mm Connectors

E836xB Corrected System Performance with 3.5mm Connectors

85052B Calibration Kit:

    • Standard Configuration and Standard Power Range (E836xB)

    • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
      (E836xB - Option 014, UNL, 016, 080, and 081)

85052C Calibration Kit:

    • Standard Configuration and Standard Power Range (E836xB)

    • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
      (E836xB - Option 014, UNL, 016, 080, and 081)

85052D Calibration Kit:

    • Standard Configuration and Standard Power Range (E836xB)

    • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
      (E836xB - Option 014, UNL, 016, 080, and 081)

Table 9. 85052B Calibration Kit
Standard Configuration and Standard Power Range
(E836xB)

Applies to the, E836xB analyzers, 85052B (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 26.5 GHz
Directivity | 48 | 44 | 44
Source Match | 40 | 31 | 31
Load Match | 48 | 44 | 44
Reflection Tracking | ±0.003 +0.02/°C | ±0.006 +0.02/°C | ±0.006 +0.03/°C
Transmission Tracking | ±0.009 +0.02/°C | ±0.088 +0.02/°C | ±0.104 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 10. 85052B Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E836xB analyzers, 85052B (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 26.5 GHz
Directivity | 48 | 44 | 44
Source Match | 40 | 31 | 31
Load Match | 48 | 44 | 44
Reflection Tracking | ±0.003 +0.02/°C | ±0.006 +0.02/°C | ±0.006 +0.03/°C
Transmission Tracking | ±0.017 +0.02/°C | ±0.091 +0.02/°C | ±0.106 +0.03/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
(E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
(E836xB - Option 014, UNL, 016, 080, and 081)

Table 11. 85052C Calibration Kit
Standard Configuration and Standard Power Range
(E836xB)

Applies to the, E836xB analyzers, 85052C (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description |  | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 26.5 GHz
Directivity | 48 | 50 | 50
Source Match | 40 | 50 | 50
Load Match | 48 | 50 | 50
Reflection Tracking | ±0.003 +0.02/°C | ±0.000 +0.02/°C | ±0.000 +0.03/°C
Transmission Tracking | ±0.009 +0.02/°C | ±0.014 +0.02/°C | ±0.018 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 12. 85052C Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E836xB analyzers, 85052C (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description |  | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 26.5 GHz
Directivity | 48 | 50 | 50
Source Match | 40 | 50 | 50
Load Match | 48 | 50 | 50
Reflection Tracking | ±0.003 +0.02/°C | ±0.000 +0.02/°C | ±0.000 +0.03/°C
Transmission Tracking | ±0.017 +0.02/°C | ±0.016 +0.02/°C | ±0.019 +0.03/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
(E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
(E836xB - Option 014, UNL, 016, 080, and 081)

Table 13. 85052D Calibration Kit
Standard Configuration and Standard Power Range
(E836xB)

Applies to the, E836xB analyzers, 85052D (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description |  | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 26.5 GHz
Directivity | 42 | 36 | 30
Source Match | 37 | 28 | 25
Load Match | 42 | 36 | 30
Reflection Tracking | ±0.003 +0.02/°C | ±0.008 +0.02/°C | ±0.011 +0.03/°C
Transmission Tracking | ±0.014 +0.02/°C | ±0.131 +0.02/°C | ±0.250 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 14. 85052D Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E836xB analyzers, 85052D (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description |  | Specification (dB)
 | 45 MHz to 2 GHz | 2 to 20 GHz | 20 to 26.5 GHz
Directivity | 42 | 36 | 30
Source Match | 37 | 28 | 25
Load Match | 42 | 36 | 30
Reflection Tracking | ±0.003 +0.02/°C | ±0.008 +0.02/°C | ±0.011 +0.03/°C
Transmission Tracking | ±0.026 +0.02/°C | ±0.138 +0.02/°C | ±0.261 +0.03/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
(E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
(E836xB - Option 014, UNL, 016, 080, and 081)


Specs: Using Cal Kits with 3.5mm Connectors

N5230A Corrected System Performance with 3.5mm Connectors

Options 020/025, 120/125, 220/225, 420/425, and 520/525

Options 220/225, 420/425, 520/525: From 10 MHz to 45 MHz, performance is characterized as "typical". To generate these typical values, please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator.

85052B Calibration Kit

    • N5230A - Option 020/120
      Standard Test Set and Standard Power Range

    • N5230A - Option 025/125
      Configurable Test Set and Extended Power Range

    • N5230A - Option 220
      Standard Test Set and Standard Power Range

    • N5230A Option 225
      Configurable Test Set and Extended Power Range

N4691A Electronic Calibration (ECal) Module

    • N5230A - Option 220
      Standard Test Set and Standard Power Range

    • N5230A Option 225
      Configurable Test Set and Extended Power Range

Table 3. 85052B Calibration Kit
N5230A - Option 020/120 (Standard Test Set and Standard Power Range)

Applies to the N5230A Option 020/120 analyzers, 85052B (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 300 kHz to 10 MHz | 10 MHz to 2 GHz | 2 GHz to 8 GHz | 8 to 13.5 GHz
Directivity | 48 | 48 | 44 | 44
Source Match | 40 | 40 | 33 | 31
Load Match | 48 | 48 | 44 | 44
Reflection Tracking | ±0.003 +0.02/°C | ±0.003 +0.02/°C | ±0.003 +0.03/°C | ±0.006 +0.03/°C
Transmission Tracking | ±0.017 +0.02/°C | ±0.015 +0.02/°C | ±0.075 +0.03/°C | ±0.131 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 4. 85052B Calibration Kit
N5230A - Option 025/125 (Configurable Test Set and Extended Power Range)

Applies to the N5230A Option 025/125 analyzers, 85052B (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 300 kHz to 10 MHz | 10 MHz to 2 GHz | 2 GHz to 8 GHz | 8 to 13.5 GHz
Directivity | 48 | 48 | 44 | 44
Source Match | 40 | 40 | 33 | 31
Load Match | 48 | 48 | 44 | 44
Reflection Tracking | ±0.003 +0.02/°C | ±0.003 +0.02/°C | ±0.003 +0.03/°C | ±0.006 +0.03/°C
Transmission Tracking | ±0.017 +0.02/°C | ±0.015 +0.02/°C | ±0.075 +0.03/°C | ±0.131 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 5. 85052B Calibration Kit
N5230A - Option 220 (Standard Test Set and Standard Power Range)

Applies to the, N5230A Option 220 analyzers, 85052B (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 500 MHz | 500 MHz to 2 GHz | 2 to 8 GHz | 8 to 20 GHz
Directivity | 48 | 48 | 44 | 44
Source Match | 40 | 40 | 33 | 31
Load Match | 48 | 48 | 44 | 44
Reflection Tracking | ±0.003 +0.02/°C | ±0.003 +0.02/°C | ±0.003 +0.03/°C | ±0.006 +0.03/°C
Transmission Tracking | ±0.010 +0.02/°C | ±0.014 +0.02/°C | ±0.062 +0.03/°C | ±0.104 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 6. 85052B Calibration Kit
N5230A - Option 225 (Configurable Test Set and Extended Power Range)

Applies to the, N5230A Option 225 analyzers, 85052B (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 500 MHz | 500 MHz to 2 GHz | 2 to 8 GHz | 8 to 20 GHz
Directivity | 48 | 48 | 44 | 44
Source Match | 40 | 40 | 33 | 31
Load Match | 48 | 48 | 44 | 44
Reflection Tracking | ±0.003 +0.02/°C | ±0.003 +0.02/°C | ±0.003 +0.03/°C | ±0.006 +0.03/°C
Transmission Tracking | ±0.010 +0.02/°C | ±0.014 +0.02/°C | ±0.062 +0.03/°C | ±0.104 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 7. N4691A Electronic Calibration Module
N5230A - Option 220 (Standard Test Set and Standard Power Range)

Applies to the, N5230A Option 220 analyzers, N4691A (3.5mm) electronic calibration module, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 500 MHz | 500 MHz to 2 GHz | 2 to 8 GHz | 8 to 20 GHz
Directivity | 56 | 56 | 54 | 49
Source Match | 47 | 47 | 45 | 44
Load Match | 46 | 46 | 42 | 40
Reflection Tracking | ±0.050 +0.02/°C | ±0.051 +0.02/°C | ±0.070 +0.03/°C | ±0.090 +0.03/°C
Transmission Tracking | ±0.051 +0.02/°C | ±0.056 +0.02/°C | ±0.074 +0.03/°C | ±0.101 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 8. N4691A Electronic Calibration Module
N5230A - Option 225 (Configurable Test Set and Extended Power Range)

Applies to the, N5230A Option 225 analyzers, N4691A Electronic Calibration Module, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 500 MHz | 500 MHz to 2 GHz | 2 to 8 GHz | 8 to 20 GHz
Directivity | 56 | 56 | 54 | 49
Source Match | 47 | 47 | 45 | 44
Load Match | 46 | 46 | 42 | 40
Reflection Tracking | ±0.050 +0.02/°C | ±0.050 +0.02/°C | ±0.070 +0.03/°C | ±0.090 +0.03/°C
Transmission Tracking | ±0.051 +0.02/°C | ±0.051 +0.02/°C | ±0.074 +0.03/°C | ±0.101 +0.03/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

This N5230A document does not present specifications for the 85052C or 85052D Calibration Kit. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the data and curves for the 85052C or the 85052D Calibration Kit or your PNA setup. View the equations used to generate the uncertainty curves.


Specs: Using Cal Kits with 3.5mm Connectors

N5230A Corrected System Performance with 3.5mm Connectors1

Options 240/245

1 From 300 kHz to 10 MHz, performance is characterized as "typical". To generate these typical values, please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator.

85052B Calibration Kit

    • N5230A - Option 240 - Standard Test Set and Standard Power Range

    • N5230A Option 245 - Configurable Test Set and Extended Power Range

N4691A Electronic Calibration (ECal) Module

    • N5230A - Option 240 - Standard Test Set and Standard Power Range

    • N5230A Option 245 - Configurable Test Set and Extended Power Range

Note: For any Sii reflection measurement:
· Sjj = 0.
For any Sij transmission measurement:
· Sji = Sij when Sij £ 1
· Sji = 1/Sij when Sij ³ 1
· Skk = 0 for all k

Table 3. 85052B Calibration Kit
N5230A - Option 240 (Standard Test Set and Standard Power Range)

Applies to the, N5230A Option 240 analyzers, 85052B (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 10 MHz to 500 MHz | 500 MHz to 2 GHz | 2 to 8 GHz | 8 to 20 GHz
Directivity | 48 | 48 | 44 | 44
Source Match | 40 | 40 | 33 | 31
Load Match | 48 | 48 | 44 | 44
Reflection Tracking | ±0.003 +0.010/°C | ±0.003 +0.010/°C | ±0.003 +0.020/°C | ±0.006 +0.030/°C
Transmission Tracking | ±0.017 +0.010/°C | ±0.017 +0.010/°C | ±0.062 +0.020/°C | ±0.125 +0.030/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 4. 85052B Calibration Kit
N5230A - Option 245 (Configurable Test Set and Extended Power Range)

Applies to the, N5230A Option 245 analyzers, 85052B (3.5mm) calibration kit, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 10 MHz to 500 MHz | 500 MHz to 2 GHz | 2 to 8 GHz | 8 to 20 GHz
Directivity | 48 | 48 | 44 | 44
Source Match | 40 | 40 | 33 | 31
Load Match | 48 | 48 | 44 | 44
Reflection Tracking | ±0.003 +0.010/°C | ±0.003 +0.010/°C | ±0.003 +0.020/°C | ±0.006 +0.030/°C
Transmission Tracking | ±0.017 +0.010/°C | ±0.017 +0.010/°C | ±0.062 +0.020/°C | ±0.125 +0.030/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 5. N4691A Electronic Calibration Module
N5230A - Option 240 (Standard Test Set and Standard Power Range)

Applies to the, N5230A Option 240 analyzers, N4691A (3.5mm) electronic calibration module, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 500 MHz | 500 MHz to 2 GHz | 2 to 8 GHz | 8 to 20 GHz
Directivity | 56 | 56 | 54 | 49
Source Match | 47 | 47 | 45 | 44
Load Match | 46 | 46 | 45 | 43
Reflection Tracking | ±0.050 +0.010/°C | ±0.050 +0.010/°C | ±0.070 +0.020/°C | ±0.090 +0.030/°C
Transmission Tracking | ±0.055 +0.010/°C | ±0.056 +0.010/°C | ±0.057 +0.020/°C | ±0.071 +0.030/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 6. N4691A Electronic Calibration Module
N5230A - Option 245 (Configurable Test Set and Extended Power Range)

Applies to the, N5230A Option 245 analyzers, N4691A (3.5 mm) Electronic Calibration Module, 85131F flexible test port cable set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 45 MHz to 500 MHz | 500 MHz to 2 GHz | 2 to 8 GHz | 8 to 20 GHz
Directivity | 56 | 56 | 54 | 49
Source Match | 47 | 47 | 45 | 44
Load Match | 46 | 46 | 45 | 43
Reflection Tracking | ±0.050 +0.010/°C | ±0.050 +0.010/°C | ±0.070 +0.020/°C | ±0.090 +0.030/°C
Transmission Tracking | ±0.055 +0.010/°C | ±0.056 +0.010/°C | ±0.057 +0.020/°C | ±0.071 +0.030/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

This N5230A document does not present specifications for the 85052C or 85052D Calibration Kit. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the data and curves for the 85052C or the 85052D Calibration Kit. View the equations used to generate the uncertainty curves.


Specs: Using Cal Kits with WR42 Connectors

E8363/4B Corrected System Performance with WR-42 Connectors

K11644A Calibration Kit:

  • Standard Configuration and Standard Power Range (E8363/4B)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Table 27. K11644A Calibration Kit
Standard Configuration and Standard Power Range
(E8363/4B)

Applies to the, E8363/4B analyzers, K11644A (WR-42) calibration kit, 85134F flexible test port cable set with the K281C launch set,, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 18 to 20 GHz | 20 to 26.5 GHz
Directivity | 50 | 50
Source Match | 50 | 50
Load Match | 50 | 50
Reflection Tracking | ±0.000 +0.02/°C | ±0.000 +0.02/°C
Transmission Tracking | ±0.014 +0.02/°C | ±0.018 +0.02/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 28. K11644A Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E8363/4B analyzers, K11644A (WR-42) calibration kit, 85134F flexible test port cable set with the K281C launch set,, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 18 to 20 GHz | 20 to 26.5 GHz
Directivity | 50 | 50
Source Match | 50 | 50
Load Match | 50 | 50
Reflection Tracking | ±0.000 +0.02/°C | ±0.000 +0.02/°C
Transmission Tracking | ±0.016 +0.02/°C | ±0.019 +0.02/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)


Specs: Using Cal Kits with WR62 Connectors

E836xB Corrected System Performance with WR-62 Connectors

P11644A Calibration Kit:

  • Standard Configuration and Standard Power Range (E836xB)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Table 29. P11644A Calibration Kit
Standard Configuration and Standard Power Range
(E836xB)

Applies to the, E836xB analyzers, P11644A (WR-62) calibration kit, 85132F flexible test port cable set with the P281B and P281C launch sets, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 12.4 to 18 GHz
Directivity | 50
Source Match | 50
Load Match | 50
Reflection Tracking | ±0.000 +0.02/°C
Transmission Tracking | ±0.014 +0.02/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 30. P11644A Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E836xB analyzers, P11644A (WR-62) calibration kit, 85132F flexible test port cable set with the P281B and P281C launch sets, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 12.4 to 18 GHz
Directivity | 50
Source Match | 50
Load Match | 50
Reflection Tracking | ±0.000 +0.02/°C
Transmission Tracking | ±0.016 +0.02/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)


Specs: Using Cal Kits with WR90 Connectors

E836xB Corrected System Performance with WR-90 Connectors

X11644A Calibration Kit:

  • Standard Configuration and Standard Power Range (E836xB)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Table 31. X11644A Calibration Kit
Standard Configuration and Standard Power Range
(E836xB)

Applies to the, E836xB analyzers, X 11644A (WR-90) calibration kit, 85133F flexible test port cable set with the X281A and X281C launch sets, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 8.2 to 12.4 GHz
Directivity | 50
Source Match | 50
Load Match | 50
Reflection Tracking | ±0.000 +0.02/°C
Transmission Tracking | ±0.014 +0.02/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 32. X11644A Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E836xB analyzers, X 11644A (WR-90) calibration kit, 85133F flexible test port cable set with the X281A and X281C launch sets, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 8.2 to 12.4 GHz
Directivity | 50
Source Match | 50
Load Match | 50
Reflection Tracking | ±0.000 +0.02/°C
Transmission Tracking | ±0.016 +0.02/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch (E836xB - Option 014, UNL, 016, 080, and 081)


Specs: Using Cal Kits with Type-N Connectors

E836xB Corrected System Performance with Type-N Connectors

85054B Calibration Kit:

  • Standard Configuration and Standard Power Range (E836xB)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
    (E836xB - Option 014, UNL, 016, 080, and 081)

85054D Calibration Kit:

  • Standard Configuration and Standard Power Range (E836xB)

  • Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
    (E836xB - Option 014, UNL, 016, 080, and 081)

Table 21. 85054B Calibration Kit
Standard Configuration and Standard Power Range
(E836xB)

Applies to the, E836xB analyzers, 85054B (Type-N) calibration kit, 85132F flexible test port cable set with 85130C adapter set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 18 GHz
Directivity | 48 | 42
Source Match | 45 | 33
Load Match | 48 | 41
Reflection Tracking | ±0.001 +0.02/°C | ±0.015 +0.02/°C
Transmission Tracking | ±0.006 +0.02/°C | ±0.079 +0.02/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 22. 85054B Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E836xB analyzers, 85054B (Type-N) calibration kit, 85132F flexible test port cable set with 85130C adapter set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 18 GHz
Directivity | 48 | 42
Source Match | 45 | 33
Load Match | 48 | 41
Reflection Tracking | ±0.001 +0.02/°C | ±0.015 +0.02/°C
Transmission Tracking | ±0.011 +0.02/°C | ±0.083 +0.02/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
(E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
(E836xB - Option 014, UNL, 016, 080, and 081)

Table 23. 85054D Calibration Kit
Standard Configuration and Standard Power Range
(E836xB)

Applies to the, E836xB analyzers, 85054D (Type-N) calibration kit, 85132F flexible test port cable set with 85130C adapter set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 18 GHz
Directivity | 40 | 34
Source Match | 39 | 29
Load Match | 40 | 34
Reflection Tracking | ±0.003 +0.02/°C | ±0.027 +0.02/°C
Transmission Tracking | ±0.013 +0.02/°C | ±0.136 +0.02/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 24. 85054D Calibration Kit
Fully Optioned (E836xB - Option 014, UNL, 016, 080, and 081)

Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch

Applies to the, E836xB analyzers, 85054D (Type-N) calibration kit, 85132F flexible test port cable set with 85130C adapter set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.045 to 2 GHz | 2 to 18 GHz
Directivity | 40 | 34
Source Match | 39 | 29
Load Match | 40 | 34
Reflection Tracking | ±0.003 +0.02/°C | ±0.027 +0.02/°C
Transmission Tracking | ±0.025 +0.02/°C | ±0.145 +0.02/°C

Transmission Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
(E836xB - Option 014, UNL, 016, 080, and 081)

Reflection Uncertainty (Specifications)

* Configurable Test Set, Extended Power Range & Bias-Tees, Receiver Attenuators, Frequency Offset Mode, and Reference Channel Transfer Switch
(E836xB - Option 014, UNL, 016, 080, and 081)


Specs: Using Cal Kits with Type-N Connectors

N5230A Corrected System Performance with Type-N Connectors

Options 020/025

85032B Calibration Kit

    • N5230A - Option 020
      Standard Test Set and Standard Power Range

    • N5230A - Option 025
      Configurable Test Set and Extended Power Range

Table 13. 85032B Calibration Kit
N5230A - Option 020 (Standard Test Set and Standard Power Range)

Applies to the, N5230A Option 020 analyzers, 85032B (Type-N) calibration kit, 85132F flexible test port cable set with 85130C adapter set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.300 to 1 MHz | 1 to 10 MHz | 10 to 45 MHz | 45 MHz to 6 GHz
Directivity | 50 | 50 | 47 | 40
Source Match | 42 | 42 | 37 | 31
Load Match | 50 | 41 | 47 | 38
Reflection Tracking | ±0.009 +0.01/°C | ±0.009 +0.01/°C | ±0.019 +0.01/°C | ±0.069 +0.02/°C
Transmission Tracking | ±0.013 +0.01/°C | ±0.007 +0.01/°C | ±0.021 +0.01/°C | ±0.101 +0.02/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)

Table 14. 85032B Calibration Kit
N5230A - Option 025 (Configurable Test Set and Extended Power Range)

Applies to the, N5230A Option 025 analyzers, 85032B (Type-N) calibration kit, 85132F flexible test port cable set with 85130C adapter set, and a full 2-port calibration. Also applies to the following condition:

Environmental temperature 23° ±3 °C, with < 1 °C deviation from calibration temperature

Description | Specification (dB)
 | 0.300 to 1 MHz | 1 to 10 MHz | 10 to 45 MHz | 45 MHz to 6 GHz
Directivity | 50 | 50 | 47 | 40
Source Match | 42 | 42 | 37 | 31
Load Match | 50 | 50 | 47 | 38
Reflection Tracking | ±0.009 +0.01/°C | ±0.009 +0.01/°C | ±0.019 +0.01/°C | ±0.069 +0.02/°C
Transmission Tracking | ±0.013 +0.01/°C | ±0.007 +0.01/°C | ±0.021 +0.01/°C | ±0.101 +0.02/°C

Transmission Uncertainty (Specifications)

Reflection Uncertainty (Specifications)


q_specs

Technical Specifications for the N5230A

Options 240 and 245 (4-Port PNA)
(Rev. 2005-07-12)

This is a complete list of the N5230A Options 240, 245 network analyzer technical specifications.

  • To optimize viewing of uncertainty curves, click the Maximize button.

  • To view or print the .pdf version of the specifications, visit our web site at http://www.agilent.com/find/pna, and search for "N5230A Specifications"

  • This N5230A document provides technical specifications for the 85052B calibration kit and the N4691A ECal module. Please download our free Uncertainty Calculator from http://www.agilent.com/find/na_calculator to generate the curves for your calibration kit and PNA setup.

  • Definitions

  • Corrected System Performance

    • System Dynamic Range

    • Extended Dynamic Range

    • 3.5mm Connectors

  • Uncorrected System Performance

  • Test Port Output

  • Test Port Input

  • Dynamic Accuracy

  • Group Delay

  • General Information

  • Measurement Throughput Summary

  • Front-panel Jumper Specs (Option 245 only)

  • Option 240 Analyzer Block Diagram

  • Option 245 Analyzer Block Diagram

See Specs for other PNA models

Definitions

All specifications and characteristics apply over a 25 °C ±5 °C range (unless otherwise stated) and 90 minutes after the instrument has been turned on.

Specification (spec.): Warranted performance. Specifications include guardbands to account for the expected statistical performance distribution, measurement uncertainties, and changes in performance due to environmental conditions.

Characteristic (char.): A performance parameter that the product is expected to meet before it leaves the factory, but that is not verified in the field and is not covered by the product warranty. A characteristic includes the same guardbands as a specification.

Typical (typ.): Expected performance of an average unit which does not include guardbands. It is not covered by the product warranty.

Nominal (nom.): A general, descriptive term that does not imply a level of performance. It is not covered by the product warranty.

Calibration: The process of measuring known standards to characterize a network analyzer's systematic (repeatable) errors.

Corrected (residual): Indicates performance after e rror c orrection (calibration). It is determined by the quality of calibration standards and how well "known" they are, plus system repeatability, stability, and noise.

Uncorrected (raw): Indicates instrument performance without error correction. The uncorrected performance affects the stability of a calibration.

Standard: When referring to the analyzer, this includes no options unless noted otherwise.

Corrected System Performance

The specifications in this section apply for measurements made with the N5230A analyzer with the following conditions:

  • 10 Hz IF bandwidth

  • No averaging applied to data

  • Isolation calibration with an averaging factor of 8

  • System Dynamic Range

  • Extended Dynamic Range

  • 3.5mm Connectors

Table 1. System Dynamic Range at Test Port 1

Description | Specification (dB) at Test Port | Typical (dB) at Test Port
Standard configuration and standard power range (Option 240)
300 KHz to 10 MHz2 | -- | 111 dB
10 MHz to 4 GHz2 | 120 dB | 128 dB
4 GHz to 6 GHz | 118 dB | 129 dB
6 GHz to 10.5 GHz | 115 dB | 127 dB
10.5 GHz to 15 GHz | 107 dB | 119 dB
15 GHz to 20 GHz | 103 dB | 116 dB
Configurable test set and extended power range (Option 245)
300 KHz to 10 MHz2 | -- | 111 dB
10 MHz to 4 GHz2 | 120 dB | 128 dB
4 GHz to 6 GHz | 118 dB | 128 dB
6 GHz to 10.5 GHz | 113 dB | 125 dB
10.5 GHz to 15 GHz | 105 dB | 117 dB
15 GHz to 20 GHz | 98 dB | 115 dB

1 The system dynamic range is calculated as the difference between the noise floor and the specified source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account.

2 May be degraded by 10 dB at particular frequencies (multiples of 5 MHz) below 500 MHz due to spurious receiver residuals. Methods are available to regain the full dynamic range.

Table 2. Extended Dynamic Range at Direct Receiver Access Input1

Configurable test set and extended power range (Option 245)
 | Specification (dB) | Typical (dB)
300 KHz to 10 MHz2 | -- | 127 dB
10 MHz to 4 GHz2 | 136 dB | --
4 GHz to 6 GHz | 134 dB | --
6 GHz to 10.5 GHz | 129 dB | --
10.5 GHz to 15 GHz | 121 dB | --
15 GHz to 20 GHz | 114 dB | --

1 The direct receiver access input extended dynamic range is calculated as the difference between the direct receiver access input noise floor and the source maximum output power. The effective dynamic range must take measurement uncertainties and interfering signals into account. This set-up should only be used when the receiver input will never exceed its compression or damage level. When the analyzer is in segment sweep mode, it can have predefined frequency segments which will output a higher power level when the extended dynamic range is required (i.e. devices with high insertion loss), and reduced power when receiver compression or damage may occur (i.e. devices with low insertion loss). The extended range is only available in one-path transmission measurements.

2 May be degraded by 10 dB at particular frequencies (multiples of 5 MHz) below 500 MHz due to spurious receiver residuals. Methods are available to regain the full dynamic range.

Corrected System Performance with 3.5mm Connectors (Tables 3 - 6)

Receiver Dynamic Range technical specifications are not provided in this N5230A specs document.

Table 7. Uncorrected System Performance1

Description | Specification | Typical
 | Options 240, 245 | Options 240, 245
Directivity
300 KHz to 10 MHz | -- | -23 dB
10 MHz to 1 GHz | -28 dB | --
1 GHz to 3 GHz | -25 dB | --
3 GHz to 5 GHz | -20 dB | --
5 GHz to 11.5 GHz | -17 dB | --
11.5 GHz to 20 GHz | -15 dB | --
Source Match
300 KHz to 10 MHz | -- | -8 dB
10 MHz to 1 GHz | -12 dB | --
1 GHz to 3 GHz | -12 dB | --
3 GHz to 5 GHz | -12 dB | --
5 GHz to 10.5 GHz | -12 dB | --
10.5 GHz to 11.5 GHz | -10 dB | --
11.5 GHz to 20 GHz | -8 dB | --
Load Match
300 KHz to 10 MHz | -- | -9 dB
10 MHz to 1 GHz | -20 dB | --
1 GHz to 3 GHz | -20 dB | --
3 GHz to 5 GHz | -18 dB | --
5 GHz to 11.5 GHz | -12 dB | --
11.5 GHz to 16 GHz | -7 dB | --
16 GHz to 20 GHz | -7.5 dB | --
Crosstalk2
300 KHz to 5 MHz | -- | -70 dB
5 MHz-10 MHz | -- | -100 dB
10 MHz to 45 MHz | -- | -110 dB
45 MHz to 4 GHz | -- | -122 dB
4 GHz to 6 GHz | -- | -123 dB
6 GHz to 10.5 GHz | -- | -120 dB
10.5 GHz to 15 GHz | -- | -115 dB
15 GHz to 20 GHz | -- | -110 dB

1 Specifications apply over environmental temperature of 25 °C ±5 °C, with less than 1°C variation from the calibration temperature.

2 Measurement conditions: normalized to a thru, measured with two shorts, 10 Hz IF bandwidth, averaging factor of 8, alternate mode, source power set to the lesser of the maximum power out or the maximum receiver power.

Table 8. Test Port Output1

Description | Specification |  | Typical
 | Opt 240 | Opt 245 | Opt 240 | Opt 245
Frequency Range
 | 300 KHz to 20 GHz |  | --
Nominal Power
 | -5 dBm | -8 dBm | Preset power; attenuator switch point 10 dB below nominal power
Frequency Resolution
 | 1 Hz |  | --
CW Accuracy
 | +/-1 ppm |  | --
Frequency Stability
 | -- |  | +/-0.05 ppm. -10° to 70° C +/-0.1 ppm/yr maximum
Description | Specification |  | Typical
 | Opt 240 | Opt 245 | Opt 240 | Opt 245
Power Level Accuracy
Variation from nominal power in range 0
300 KHz to 10 MHz | -- | -- | +/-1.0 dB | +/-1.0 dB
10 MHz to 2 GHz | +/-1.0 dB | +/-1.0 dB | -- | --
2 GHz to 10.5 GHz | +/-1.5 dB | +/-1.5 dB | -- | --
10.5 GHz to 20 GHz | +/-2.5 dB | +/-2.5 dB | -- | --
Max Leveled Power
300 KHz to 10 MHz | -- | -- | +8 dBm | +8 dBm
10 MHz to 4 GHz | +8 dBm | +8 dBm | +12 dBm | +11 dBm
4 GHz to 6 GHz | +6 dBm | +6 dBm | +10 dBm | +9 dBm
6 GHz to 10.5 GHz | +3 dBm | +1 dBm | +8 dBm | +6 dBm
10.5 GHz to 15 GHz | 0 dBm | -2 dBm | +5 dBm | +3 dBm
15 GHz to 20 GHz | -3 dBm | -8 dBm | +2 dBm | -1 dBm
Power Level Linearity
Specified on Port 1 only. Ports 2, 3, 4 performance is Typical. Test reference is at the nominal power level.
300 KHz to 10 MHz | -- | -- | +/-2.0 dB | +/-2.0 dB
10 MHz to 1 GHz | +/-2.0 dB | +/-2.0 dB | -- | --
1 GHz to 20 GHz | +/-1.5 dB | +/-1.5 dB | -- | --
Power Sweep Range (ALC)
ALC range starts at maximum leveled power and decreases by the dB amount specified here.
300 KHz to 10 MHz | -- | -- | 35 dB | 35 dB
10 MHz to 4 GHz | 33 dB | 33 dB | -- | --
4 GHz to 6 GHz | 31 dB | 31 dB | -- | --
6 GHz to 10.5 GHz | 28 dB | 26 dB | -- | --
10.5 GHz to 15 GHz | 25 dB | 23 dB | -- | --
15 GHz to 20 GHz | 22 dB | 17 dB | -- | --
Description | Specification |  | Typical
 | Opt 240 | Opt 245 | Opt 240 | Opt 245
Power Resolution
 | 0.01 dB | 0.01 dB | -- | --
Power Range
300 KHz to 10 MHz | -- | -- | -27 to +8 dBm | -87 to +8 dBm
10 MHz to 45MHz | -- | -- | -27 to +12 dBm | -87 to +11 dBm
45 MHz to 4 GHz | -- | -- | -27 to +12 dBm | -87 to +11 dBm
4 GHz to 6 GHz | -- | -- | -27 to +10 dBm | -87 to +9 dBm
6 GHz to 10.5 GHz | -- | -- | -27 to +8 dBm | -87 to +6 dBm
10.5 GHz to 15 GHz | -- | -- | -27 to +5 dBm | -87 to +3 dBm
15 GHz to 20 GHz | -- | -- | -27 to +2 dBm | -87 to -1 dBm
Power Settings
Minimum Power Setting | -- | -- | -30 dBm | -90 dBm
Maximum Power Setting | -- | -- | +20 dBm | +20 dBm
Harmonics (2nd or 3rd) at Maximum Output Power
In-band Source Harmonics
300 KHz to 10 MHz | -- | -- | -17 dBc
10 MHz to 1 GHz | -- | -- | -17 dBc
1 GHz to 20 GHz | -- | -- | -20 dBc
Non-Harmonic Spurious (at Nominal Output Power)
300 KHz to 20 GHz | -- | -- | -50 dBc for offset frequency > 1 KHz

1 Performance specified on Port 1 only; Ports 2, 3, and 4 performance is typical. Test reference is at the nominal power level.

Table 8. Test Port Output (Continued)
Phase Noise (Nominal power at test port) | Typical Performance
 | 10 kHz Offset | 100 kHz Offset | 1 MHz Offset
300 KHz to 10 MHz | -86 dBc/Hz | -86 dBc/Hz | -95 dBc/Hz
10 MHz to 1.5 GHz | -86 dBc/Hz | -91 dBc/Hz | -95 dBc/Hz
1.5 GHz to 3.125 GHz | -83 dBc/Hz | -91 dBc/Hz | -95 dBc/Hz
3.125 GHz to 6.25 GHz | -77 dBc/Hz | -85 dBc/Hz | -89 dBc/Hz
6.25 GHz to 12.5 GHz | -71 dBc/Hz | -79 dBc/Hz | -83 dBc/Hz
12.5 GHz to 20 GHz | -65 dBc/Hz | -73 dBc/Hz | -77 dBc/Hz

Table 9. Test Port Input

Description | Specification | Typical
 | Options 240, 245 | Options 240, 245
Test Port Noise Floor
Total average (rms) noise power calculated as the mean value of a linear magnitude trace expressed in dBm.
10 Hz IF Bandwidth
300 KHz to 10 MHz | -- | <-103 dBm
10 MHz to 500 MHz | <-112 dBm | <-116 dBm
500 MHz to 4 GHz | <-112 dBm | <-120 dBm
4 GHz to 10.5 GHz | <-112 dBm | <-119 dBm
10.5 GHz to 15 GHz | <-107 dBm | <-114 dBm
15 GHz to 20 GHz | <-106 dBm | <-114 dBm
1 KHz IF Bandwidth
300 KHz to 10 MHz | -- | <-83 dBm
10 MHz to 500 MHz | <-92 dBm | <-96 dBm
500 MHz to 4 GHz | <-92 dBm | <-100 dBm
4 GHz to 10.5 GHz | <-92 dBm | <-99 dBm
10.5 GHz to 15 GHz | <-87 dBm | <-94 dBm
15 GHz to 20 GHz | <-86 dBm | <-94 dBm
Direct Receiver Access Input Noise Floor (Option 245 Only)
Total average (rms) noise power calculated as the mean value of a linear magnitude trace expressed in dBm.
10 Hz IF Bandwidth
300 KHz to 10 MHz | -- | <-119 dBm
10 MHz to 500 MHz | <-128 dBm | <-132 dBm
500 MHz to 4 GHz | <-128 dBm | <-136 dBm
4 GHz to 10.5 GHz | <-128 dBm | <-135 dBm
10.5 GHz to 15 GHz | <-123 dBm | <-130 dBm
15 GHz to 20 GHz | <-122 dBm | <-130 dBm
1 KHz IF Bandwidth
300 KHz to 10 MHz | -- | <-99 dBm
10 MHz to 500 MHz | <-108 dBm | <-112 dBm
500 MHz to 4 GHz | <-108 dBm | <-116 dBm
4 GHz to 10.5 GHz | <-108 dBm | <-115 dBm
10.5 GHz to 15 GHz | <-103 dBm | <-110 dBm
15 GHz to 20 GHz | <-102 dBm | <-110 dBm
Description | Specification |  | Typical
 | Options 240, 245 |  | Options 240, 245
Compression Level (at +8 dBm except as noted)
 | Power | Com- pression | Power | Com- pression
300 KHz to 10 MHz | -- | -- | +5 dBm | 0.10 dB
10 MHz to 50 MHz | +8 dBm | 0.35 dB | -- | --
50 MHz to 1 GHz | +8 dBm | 0.35 dB | -- | --
1 GHz to 8 GHz | +8 dBm | 0.25 dB | -- | --
8 GHz to 12.5 GHz | +8 dBm | 0.30 dB | -- | --
12.5 GHz to 20 GHz | +8 dBm | 0.55 dB | -- | --
Test Port Compression - 0.1 dB
300 KHz to 10 MHz | -- | -- | +5 dBm | --
10 MHz to 1 GHz | -- | -- | +9 dBm | --
1 GHz to 12.5 GHz | -- | -- | +10 dBm | --
12.5 GHz to 20 GHz | -- | -- | +9 dBm | --

Table 9. Test Port Input (Continued)
Description | Specification |  | Typical
 | Option 240 | Option 245 | Option 240 | Option 245
Trace Noise Magnitude
Ratioed measurement, nominal power at test port.
100 KHz IF bandwidth
300 KHz to 10 MHz | -- | -- | .015 dB rms | .030 dB rms
10 MHz to 10.5 GHz | .006 dB rms | .008 dB rms | .004 dB rms | .005 dB rms
10.5 GHz to 20 GHz | .010 dB rms | .014 dB rms | .007 dB rms | .009 dB rms
600 KHz IF bandwidth
300 KHz to 10 MHz | -- | -- | .015 dB rms | .030 dB rms
10 MHz to 10.5 GHz | -- | -- | .013 dB rms | .015 dB rms
10.5 GHz to 20 GHz | -- | -- | .017 dB rms | .023 dB rms
100 KHz IF bandwidth
Measured at Maximum Specified Power
300 KHz to 10 MHz | -- | -- | .005 dB rms | .010 dB rms
10 MHz to 2 GHz | -- | -- | .001 dB rms | .003 dB rms
2 GHz to 10.5 GHz | -- | -- | .002 dB rms | .003 dB rms
10.5 GHz to 20 GHz | -- | -- | .006 dB rms | .009 dB rms
Trace Noise Phase
Ratioed measurement, nominal power at test port.
100 KHz IF bandwidth
300 KHz to 10 MHz | -- | -- | 0.110 deg rms | 0.180 deg rms
10 MHz to 10.5 GHz | 0.05 deg rms | 0.07 deg rms | 0.025 deg rms | 0.035 deg rms
10.5 GHz to 20 GHz | 0.08 deg rms | 0.10 deg rms | 0.050 deg rms | 0.060 deg rms
600 KHz IF bandwidth
300 KHz to 10 MHz | -- | -- | 0.110 deg rms | 0.180 deg rms
10 MHz to 10.5 GHz | -- | -- | 0.080 deg rms | 0.100 deg rms
10.5 GHz to 20 GHz | -- | -- | 0.120 deg rms | 0.160 deg rms
100 KHz IF bandwidth
Measured at Maximum Specified Power
300 KHz to 10 MHz | -- | -- | 0.040 deg rms | 0.050 deg rms
10 MHz to 2 GHz | -- | -- | 0.007 deg rms | 0.012 deg rms
2 GHz to 10.5 GHz | -- | -- | 0.012 deg rms | 0.015 deg rms
10.5 GHz to 20 GHz | -- | -- | 0.040 deg rms | 0.060 deg rms
Reference Level Magnitude
Range | +/-200 dB | +/-200 dB | -- | --
Resolution | 0.001dB | 0.001dB | -- | --
Reference Level Phase
Range | +/-500° | +/-500° | -- | --
Resolution | 0.01° | 0.01° | -- | --
Stability Magnitude
Stability is defined as a ratio measurement made at the test port.
300 KHz to 10 MHz | -- | -- | +/-0.015 dB/°C
10 MHz to 2 GHz | -- | -- | +/-0.010 dB/°C
2 GHz to 4 GHz | -- | -- | +/-0.015 dB/°C
4 GHz to 16 GHz | -- | -- | +/-0.020 dB/°C
16 GHz to 19 GHz | -- | -- | +/-0.025 dB/°C
19 GHz to 20 GHz | -- | -- | +/-0.030 dB/°C
Stability Phase
Stability is defined as a ratio measurement made at the test port.
300 KHz to 10 MHz | -- | -- | +/-0.360°/°C
10 MHz to 45 MHz | -- | -- | +/-0.020/°C
45 MHz to 500 MHz | -- | -- | +/-0.030°/°C
500 MHz to 2 GHz | -- | -- | +/-0.050°/°C
2 GHz to 4 GHz | -- | -- | +/-0.100°/°C
4 GHz to 8 GHz | -- | -- | +/-0.150°/°C
8 GHz to 16 GHz | -- | -- | +/-0.300°/°C
16 GHz to 20 GHz | -- | -- | +/-0.350°/°C

Table 9. Test Port Input (Continued)
 | Typical Performance
Damage Input Level | Opt 240 | Opt 245
Test Port 1,2,3, and 4 | +27 dBm or +/-16 VDC | +27 dBm or +/-16 VDC
Receivers R,A,B,C,D | -- | +15 dBm or +/-16 VDC
Source out (reference) | -- | +27 dBm or +/-16 VDC
Source out (test ports) | -- | +27 dBm or +/-16 VDC
Coupler Thru | -- | +27 dBm or +/-16 VDC
Coupler Arm | -- | +15 dBm or +/-0 VDC

Table 10. Dynamic Accuracy (Specificationa)

Accuracy of the test port input power reading relative to the reference input power level.

Dynamic Accuracy, 0.045 GHz

Dynamic Accuracy, 0.500 GHz

Dynamic Accuracy, 1- 2 GHz

Dynamic Accuracy, 2 - 12.5 GHz

Dynamic Accuracy, 12.5 - 20 GHz

a Dynamic accuracy is verified with the following measurements:

  • compression over frequency

  • IF linearity at a single frequency of 1.195 GHz using a reference level of -20 dBm for an input power range of 0 to -110 dBm.

Table 11. Test Port Input (Group Delay)a

Description

Supplemental Information (typ.)

Aperture (selectable)

(frequency span)/(number of points -1)

Maximum Aperture

20% of frequency span

Range

0.5 x (1/minimum aperture)

Maximum Delay

Limited to measuring no more than 180° of phase change within the minimum aperture.)

Accuracy

See graph below. Char.

The following graph shows characteristic group delay accuracy with full 2-port calibration and a 10 Hz IF bandwidth. Insertion loss is assumed to be < 2 dB and electrical length to be ten meters.

For any Sij Group Delay measurement, Sii = 0, Sij = 1, Sji = 0, Skl = 0 for all kl ¹ ij

In general, the following formula can be used to determine the accuracy, in seconds, of specific group delay measurement:

±Phase Accuracy (deg)/[360 × Aperture (Hz)]

Depending on the aperture and device length, the phase accuracy used is either incremental phase accuracy or worst case phase accuracy.

a Group delay is computed by measuring the phase change within a specified frequency step (determined by the frequency span and the number of points per sweep).

General Information

  • Miscellaneous Information

  • Front Panel

  • Rear Panel

  • Environment and Dimensions

Table 12. Miscellaneous Information

Description | Supplemental Information
System IF Bandwidth Range | 1 Hz to 600 kHz, nominal
CPU | Intel® 500 MHz Pentium® III

Table 13. Front Panel Information

Description | Supplemental Information
RF Connectors
Type | Option 240 or 245: 3.5 mm (male), 50 ohm, (nominal)
Center Pin Recession | 0.002 in. (characteristic)
Display
Size | 21.3 cm (8.4 in) diagonal color active matrix LCD; 640 (horizontal) X 480 (vertical) resolution
Refresh Rate | Vertical 59.83 Hz; Horizontal 31.41 kHz
Display Range
Magnitude | ±500 dB (at 20 dB/div), max
Phase | ±500°, max
Polar | 10 pUnits, min 1000 Units, max
Display Resolution
Magnitude | 0.001 dB/div, min
Phase | 0.01°/div, min
Marker Resolution
Magnitude | 0.001 dB, min
Phase | 0.01°, min
Polar | 0.01 mUnit, min; 0.01°,min

Table 14. Rear Panel Information

Description | Supplemental Information
10 MHz Reference In
Connector | BNC, female
Input Frequency | 10 MHz ± 10 ppm, Typical
Input Level | -15 dBm to +20 dBm, Typical
Input Impedance | 200 W, nom.
10 MHz Reference Out
Connector | BNC, female
Output Frequency | 10 MHz ± 1 ppm, Typical
Signal Type | Sine Wave, Typical
Output Level | +10 dBm ± 4 dB into 50 W, Typical
Output Impedance | 50 W, nominal
Harmonics | <-40 dBc, Typical
VGA Video Output
Connector | 15-pin mini D-Sub; Drives VGA compatible monitors
Devices Supported | Resolutions:
Flat Panel (TFT) | 1024 X 768, 800 X 600, 640 X 480
Flat Panel (DSTN) | 800 X 600, 640 X 480
CRT Monitor | 1280 X 1024, 1024 X 768, 800 X 600, 640 X 480
 | Simultaneous operation of the internal and external displays is allowed, but with 640 X 480 resolution only. If you change resolution, you can only view the external display (internal display will "white out").
Test Set IO
 | 25-pin D-Sub connector, female, available for external test set control
Aux IO
 | 25-pin D-Sub connector, male, analog and digital IO
Handler IO
 | 36-pin parallel I/O port; all input/output signals are default set to negative logic; can be reset to positive logic via GPIB command female.
GPIB
 | 24-pin D-sub (Type D-24), female; compatible with IEEE-488.
Parallel Port (LPT1)
 | 25-pin D-Sub miniature connector, female; provides connection to printers or any other parallel port peripherals
Serial Port (COM 1)
 | 9-pin D-Sub, male; compatible with RS-232
USB Port
 | One port on front panel and five ports on rear panel. Universal Serial Bus jack, Type A configuration (4 contacts inline, contact 1 on left); female
Contact 1 | Vcc: 4.75 to 5.25 VDC, 500 mA, maximum
Contact 2 | -Data
Contact 3 | +Data
Contact 4 | Ground
LAN
 | 10/100BaseT Ethernet, 8-pin configuration; auto selects between the two data rates
Line Power (A third-wire ground is required.)
Frequency | 50/60/400 Hz
Voltage | 120/240 VAC (Power supply is auto switching.)
Max | 500 Watts

Note: Option H08 and Option H11 are not available with the N5230A network analyzer.

Table 15. Analyzer Environment and Dimensions

Description | Supplemental Information
General Environmental
RFI/EMI Susceptibility | Defined by CISPR Pub. 11, Group 1, Class A, and IEC 50082-1
ESD | Minimize using static-safe work procedures and an antistatic bench mat
Dust | Minimize for optimum reliability
Operating Environment
Temperature | 0 °C to +40 °C Instrument powers up and displays no error messages within this temperature range (except for "source unleveled" error message that may occur at temperatures outside the specified performance temperature range of 25 +/- 5°C).
Error-Corrected Temperature Range | 23°C ± 3°C with less than 1°C deviation from calibration temp.
Humidity | 5% to 95% at +40 °C
Altitude | 0 to 4500 m (14,760 ft.)
Non-Operating Storage Environment
Temperature | -40 °C to +70 °C
Humidity | 0% to 90% at +65 °C (non-condensing)
Altitude | 0 to 4500 m (14,760 ft.)

Cabinet Dimensions
 | Height | Width | Depth
Excluding front and rear panel hardware and feet | 267 mm 10.5 in | 426 mm 16.75 in | 427 mm 16.8 in
As shipped - includes front panel connectors, rear panel bumpers, and feet. | 280 mm 11.0 in | 435 mm 17.1 in | 470 mm 18.5 in
As shipped plus handles | 280 mm 11.0 in | 458 mm 18 in | 501 mm 19.7 in
As shipped plus rack-mount flanges | 280 mm 11.0 in | 483 mm 19 in | 470 mm 18.5 in
As shipped plus handles and rack-mount flanges | 280 mm 11.0 in | 483 mm 19 in | 501 mm 19.70 in
Weight
Net | 24.9 kg (55 lb), nominal
Shipping | 36.3 kg (80 lb), nominal

Measurement Throughput Summary

  • Typical Cycle Time for Measurement Completion

  • Cycle Time vs IF Bandwidth

  • Cycle Time vs Number of Points

  • Data Transfer Time

Table 16 Typical Cycle Timea (ms) for Measurement Completion

Description | Typical Performance
 | Number of Points
 | 201 | 401 | 801 | 1601 | 16,001
Start 8 GHz, Stop 18 GHz, 600 kHz IF bandwidth
Uncorrected | 26.2 | 26.7 | 27.6 | 29.2 | 76.5
4-Port cal | 93.0 | 104.1 | 125.2 | 164.0 | 939.6
Start 300 kHz, Stop 10 GHz, 600 kHz IF bandwidth
Uncorrected | 24.8 | 28.0 | 30.4 | 35.0 | 91.8
4-Port cal | 87.5 | 109.0 | 134.6 | 180.5 | 990.8
Start 300 kHz, Stop 20 GHz, 600 kHz IF bandwidth
Uncorrected | 38.3 | 40.2 | 43.6 | 46.6 | 93.8
4-Port cal | 140.2 | 158.3 | 190.0 | 224.2 | 1012.3
Start 8 GHz, Stop 18 GHz, 100 kHz IF bandwidth
Uncorrected | 43.1 | 56.9 | 60.9 | 62.1 | 193.4
4-Port cal | 160.4 | 222.2 | 248.8 | 274.5 | 1291.1
Start 300 kHz, Stop 10 GHz, 100 kHz IF bandwidth
Uncorrected | 41.8 | 48.3 | 51.1 | 53.7 | 209.9
4-Port cal | 155.1 | 180.0 | 214.2 | 260.5 | 1362.7
Start 300 kHz, Stop 20 GHz, 100 kHz IF bandwidth
Uncorrected | 51.4 | 76.4 | 94.0 | 99.8 | 211.4
4-Port cal | 190.3 | 292.4 | 379.8 | 419.8 | 1378.7
Start 8 GHz, Stop 18 GHz, 50 kHz IF bandwidth
Uncorrected | 47.1 | 75.1 | 94.6 | 97.3 | 380.9
4-Port cal | 171.6 | 290.1 | 381.0 | 410.0 | 1894.4
Start 300 kHz, Stop 10 GHz, 50 kHz IF bandwidth
Uncorrected | 49.1 | 67.2 | 72.7 | 75.9 | 395.1
4-Port cal | 180.0 | 261.4 | 293.1 | 330.6 | 1941.2
Start 300 kHz, Stop 20 GHz, 50 kHz IF bandwidth
Uncorrected | 54.9 | 87.1 | 131.2 | 154.4 | 396.3
4-Port cal | 207.0 | 337.7 | 523.9 | 633.6 | 1948.2

a Includes sweep time, retrace time and band-crossing time. Analyzer display turned off with
DISPLAY:ENABLE OFF. Add 21 ms for display on. Data for one trace (S11) measurement.

Table 17. Cycle Time vs IF Bandwidth

Applies to the Preset condition (201 points, correction off) except for the following changes:

  • CF = 10 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
Description | Typical Performance
IF Bandwidth (Hz) | Cycle Time (ms)a | Trace Noise
600,000 | 7.523394495 | 0.003533948
360,000 | 7.54179941 | 0.002688865
280,000 | 7.5703125 | 0.002287365
200,000 | 7.71344 | 0.002102872
150,000 | 7.762206897 | 0.001696417
100,000 | 7.806733333 | 0.001284263
70,000 | 7.874966555 | 0.001170092
50,000 | 9.076777778 | 0.000987238
30,000 | 11.46182377 | 0.0008445
20,000 | 14.72636574 | 0.000647383
15,000 | 17.5863125 | 0.000534657
10,000 | 28.64310448 | 0.000477914
7000 | 37.16706481 | 0.000439644
5000 | 48.58746512 | 0.000350175
3000 | 72.52639344 | 0.00030881
2000 | 102.2277778 | 0.000279538
1500 | 130.7245 | 0.00015128
1000 | 218.5535 | 0.000154337
700 | 294.1385333 | 0.000135211
500 | 399.9245455 | 0.000125675
300 | 636.411 | 0.000103409
200 | 932.7632 | 0
100 | 1826.966667 | 0
30 | 6004.446 | 0
10 | 17903.564 | 0
1 | 178398.611 | 0

a Cycle time includes sweep and retrace time.

Table 18. Cycle Time vs Number of Points

Applies to the Preset condition (correction off) except for the following changes:

  • CF = 10 GHz

  • Span = 100 MHz

  • Display off (add 21 ms for display on)
Description | Typical Performance
IF Bandwidth (Hz) | Number of Points | Cycle Time (ms)a
30,000 | 3 | 6.7
 | 11 | 7.4
 | 51 | 6.9
 | 101 | 7.8
 | 201 | 11.2
 | 401 | 18.3
 | 801 | 32.4
 | 1,601 | 59.4
 | 6,401 | 224.7
 | 16,001 | 556.9
100,000 | 3 | 6.7
 | 11 | 6.6
 | 51 | 6.8
 | 101 | 7
 | 201 | 7.5
 | 401 | 9
 | 801 | 13.5
 | 1,601 | 22.9
 | 6,401 | 75.3
 | 16,001 | 180.3
600,000 | 3 | 6.5
 | 11 | 6.6
 | 51 | 6.8
 | 101 | 6.9
 | 201 | 7.3
 | 401 | 8.1
 | 801 | 9.4
 | 1,601 | 12
 | 6,401 | 27.7
 | 16,001 | 59.3

a Cycle time includes sweep and retrace time.

Table 19. Data Transfer Time (ms)

Description | Typical Performance
 | Number of Points
 | 201 | 401 | 1601 | 16,001
SCPI over GPIB (program executed on external PC)
32-bit floating point | 7 | 12 | 43 | 435
64-bit floating point | 12 | 22 | 84 | 856
ASCII | 64 | 124 | 489 | 5054
SCPI (program executed in the analyzer)
32-bit floating point | 1 | 2 | 3 | 30
64-bit floating point | 2 | 2 | 4 | 40
ASCII | 29 | 56 | 222 | 2220
COM (program executed in the analyzer)
32-bit floating point | <0.4 | 0.4 | 0.5 | 1.9
Variant type | 0.7 | 1 | 3 | 32
DCOM over LAN (program executed on external PC)
32-bit floating point | <0.8 | 1 | 1.5 | 7.1
Variant type | 1.8 | 2.7 | 8.5 | 80

Note: Specifications for Recall & Sweep Speed are not provided for the N5230A analyzers.

Tables 20 - 25 Front-panel Jumper Specs (Option 245 only)

Test Set Block Diagrams

N5230A Option 240 (Standard Test Set and Standard Power Range)

N5230A Option 245 (Configurable Test Set and Extended Power Range)

Item | Description | Item | Description | Item | Description
a | RCVR R IN | h | CPLR THRU | o | RCVR D IN
b | SOURCE OUT | i | CPLR ARM | p | CPLR ARM
c | SOURCE OUT | j | RCVR B IN | q | CPLR THRU
d | CPLR THRU | k | RCVR C IN | r | SOURCE OUT
e | CPLR ARM | l | CPLR ARM |  |
f | RCVR A IN | m | CPLR THRU |  |
g | SOURCE OUT | n | SOURCE OUT |  |


u_curve_equations

Equations Used to Generate Uncertainty Curves

Print this document.

This topic contains the measurement uncertainty equations used to generate the uncertainty curves in the Specifications document. It also contains general information about determining system measurement uncertainties.

Learn about the following subjects:

  • Measurement Uncertainty Equations

    • Forward Reflection Uncertainty

    • Forward Transmission Uncertainty

    • Reverse Reflection Uncertainty

    • Reverse Transmission Uncertainty

  • Sources of Systematic Errors

  • Sources of Random Errors

  • Determining Expected System Performance

  • Determining Cable Stability Terms (CR1, CR2, CTM1, CTM2, CTP1, CTP2)

  • Measurement Errors

  • What is Measurement Calibration?

  • Why is Calibration Necessary?

Measurement Uncertainty Equations

Any measurement result is the vector sum of the actual test device response plus all error terms. The precise effect of each error term depends on its magnitude and phase relationship to the actual test device response. When the phase of an error response is not known, phase is assumed to be worst case (-l80x° to +180°).

View the abbreviations for residual systematic errors used in the equations.

View the abbreviations for random errors used in the error models and equations.

Forward Reflection Uncertainty

Equation 1: Forward Reflection Magnitude Uncertainty

Equation 2: Forward Reflection Phase Uncertainty

Forward Transmission Uncertainty

Equation 3: Forward Transmission Magnitude Uncertainty

Equation 4: Forward Transmission Phase Uncertainty

Reverse Reflection Uncertainty

Equation 5: Reverse Reflection Magnitude Uncertainty

Equation 6: Reverse Reflection Phase Uncertainty

Reverse Transmission Uncertainty

Equation 7: Reverse Transmission Magnitude Uncertainty

Equation 8: Reverse Transmission Phase Uncertainty

Sources of Systematic Errors

The residual (after measurement calibration) systematic errors result from imperfections in the calibration standards.
For reflection measurements, the associated residual errors are:

  • residual directivity

  • residual load match

  • residual source match

  • residual reflection tracking

For transmission measurements, the additional residual errors are:

  • residual crosstalk

  • residual load match

  • residual source match

  • residual transmission tracking

The listing below shows the abbreviations used for residual systematic errors that are in the uncertainty equations.

  • EDF = forward residual directivity

  • ESR = reverse residual source match

  • ESF = forward residual source match

  • ERR = reverse residual reflection tracking

  • ERF = forward residual reflection tracking

  • EXR = reverse crosstalk

  • EXF = forward crosstalk

  • ELR = reverse load match

  • ELF = forward load match

  • ETR = reverse transmission tracking

  • ETF = forward transmission tracking

  • AM = magnitude dynamic accuracy

  • EDR = reverse residual directivity

  • AP = phase dynamic accuracy

All measurements are affected by dynamic accuracy. Dynamic accuracy includes: errors during internal self-calibration routines, gain compression in the microwave frequency converter (sampler) at high signal levels, errors generated in the synchronous detectors, localized non-linearities in the IF filter system, and from LO leakage into the IF signal paths.

Sources of Random Errors

The random error sources are

  • noise

  • connector repeatability

  • interconnecting cable stability

There are two types of noise in any measurement system:

  1. low level noise (noise floor)

  2. high level noise (trace noise)

Low level noise is the broadband noise floor of the receiver which can be reduced through averaging or by changing the IF bandwidth.

High level noise or trace noise is due to the noise floor of the receiver, and the phase noise of the LO source inside the test set. It is worsened by reducing the IF bandwidth. Using a high stability 10 MHz time base can reduce high level noise.
A high stability time base is standard with PNA models E8356/7/8A and E8362/3/4A. It is available as Option 1E5 with PNA models E8801/2/3A and N3381/2/3A. Option 1E5 replaces a 10 ppm time base with a 1 ppm time base.

Connector repeatability is the random variation encountered when connecting a pair of RF connectors. Variations in both reflection and transmission can be observed.

Cable stability is dependent on the cable used and the amount of cable movement between calibration and measurement.

The listing below shows the abbreviations used for random errors in the error models and uncertainty equations.

  • NF = noise floor

  • CTM2 = port 2 cable magnitude transmission stability

  • NT = trace noise

  • CTP2 = port 2 cable phase transmission stability

  • CR1 = port 1 cable reflection stability

  • RR1 = port 1 connector reflection repeatability

  • CTM1 = port 1 cable magnitude transmission stability

  • RT1 = port 1 connector transmission repeatability

  • CTP1 = port 1 cable phase transmission stability

  • RR2 = port 2 connector reflection repeatability

  • CR2 = port 2 cable reflection stability

  • RT2 = port 2 connector transmission repeatability

Determining Expected System Performance

Improper connection techniques and contact surfaces can degrade measurement accuracy.

Proper connection techniques include using a torque wrench with proper torque limits, ensuring that the connector pin depths meet specifications, ensuring that the center conductor of sliding loads is properly set, and observing proper handling procedures for beadless airlines.

Contact surface errors are caused by improper cleaning procedures, scratches, worn plating, and rough seating.

View more information on connector care

If proper connection techniques and connector care is observed, the following table provides an indication of connector repeatability.

Connector Repeatability (RR1, RR2, RT1, and RT2)
Connector Type |  | Connector Type
Frequency Range | Repeatability | Frequency Range | Repeatability
2.4-mm |  | 3.5-mm
0 to 2 GHz | 0.0002 | 0 to 2 GHz | 0.0001
2 to 20 GHz | 0.0004 | 2 to 8 GHz | 0.0003
20 to 36 GHz | 0.0006 | 8 to 20 GHz | 0.0006
36 to 40 GHz | 0.0008 | 20 to 26.5 GHz | 0.0010
7-mm |  | Type-N
0 to 2 GHz | 0.0001 | 0 to 2 GHz | 0.0006
2 to 8 GHz | 0.0003 | 2 to 8 GHz | 0.0006
8 to 18 GHz | 0.0006 | 8 to 18 GHz | 0.0010
Type-F |  | Waveguide
0 to 3 GHz | 0.0006 | 0 to 40 GHz | 0.0002

Determining Cable Stability Terms
(CR1, CR2, CTM1, CTM2, CTP1, CTP2)

Cable stability is dependent on the cable used and the amount of cable movement between calibration and measurement. Values for cable reflection stability are determined by connecting a fixed load to the free end of the cable and measuring the change in reflection coefficient after flexing the cable through the normal range of cable movement for a particular setup. Cable transmission stability is determined by connecting a short to the free end of the cable and measuring the change in reflection coefficient due to changes in cable position.

Graphics 1-3 demonstrate concepts useful in determining cable stability. In each case, a cable (part number 8120-4779) was connected to port 1, with a fixed load connected to the free end. A reference trace is obtained by measuring S11 with the free end held close to port 2 and storing the results in memory. Two additional S11 measurements are made; one with the cable flexed out to its straight position and the other with the cable positioned back to the same location as reference trace. As shown in Graphic 1, the flexed position demonstrates the effect of moving the cable after calibration. The repeatability trace demonstrates the stability of the cable when moved to its original position.

Graphic 1

Graphic 1 demonstrates the concepts useful in determining cable reflection stability. A fixed load is connected to the free end. The DATA-MEM feature provides an indication of the cable reflection stability. A 60-dB peak on the chart yields a reflection stability estimated as 10(−60/20) or 0.001.

Graphic 2

Graphic 2 and Graphic 3 demonstrate the concepts useful in determining cable transmission stability. A short is connected to the free end. The DATA/MEM feature provides an indication of the two-way cable transmission stability. The one-way transmission magnitude stability is determined by dividing the two-way magnitude measurement by two before it is converted to linear. A 0.013-dB peak on the chart yields transmission magnitude stability estimated as 10(0.013/40) −1 or 0.00075. The one-way transmission phase stability is determined by dividing the two-way phase measurement by two.

Graphic 3

Cable movement often has a much larger effect on phase measurements than magnitude measurements.

  • Measurement Errors

  • What is Measurement Calibration?

  • Why is Calibration Necessary?


Инструментарий диагностики и регулировки

Для поддержки максимальной производительности PNA существуют следующие программы и утилиты.

  • Регулировка опорной частоты 10 МГц

  • Регулировка частоты 3.8 ГГц

  • Регулировка мощности гетеродина

  • Регулировка мощности гетеродина смещения

  • Проверки, производимые оператором

  • Подстройка усиления в цепи ФАПЧ сигнала ПЧ

  • Калибровка приемника

  • Дисплей приемника

  • Последовательная шина

  • Калибровка источника

  • Проверка системы

  • Проверка Опции H11


Данные ЕЕ по умолчанию

Настройки EE по умолчанию производятся только на заводе или сервисном центре. Поэтому они недоступны из меню настроек PNA.

Для использования этой утилиты необходимо ввести пароль. Эта утилита работает только на моделях N5230A и N5340A. При нормальной работе анализатора эту регулировку производить не следует.

При данной регулировке устанавливаются значения EE по умолчанию для следующих 5 схем:

  1. Синтезатор источника

  2. Синтезатор гетеродина

  3. Умножитель источника

  4. Умножитель гетеродина

  5. MA26 – Усилитель модулятора (при наличии)

Значения по умолчанию для каждой схемы могут быть установлены индивидуально. Также имеется функция подстройки, используемая в том случае, если значений по умолчанию недостаточно.

При использовании функции подстройки необходимо подсоединить датчик мощности (макс. частота 26.5 ГГц) к выходам настраиваемой схемы.

Для проверки правильности текущих настроек имеется функция проверки.


Проверка Опции H11

Утилита проверки опции Н11 предназначена для проверки функциональности опции Н11 анализатора. Производятся проверки соответствующих входов и выходов Н11 и сравнение полученных данных с заводскими значениями. Эти тесты используются совместно с проверками, производимыми оператором и системными проверками для тестирования функциональности анализатора. Подробнее об Опции H11.

  • Запуск проверки опции Н11

  • Справка по диалоговому окну Option H11 Verification

Запуск проверки опции Н11

Для подробной информации см. интерфейс передней панели

Справка по диалоговому окну Option H11 Verification

Программа проверки опции Н11 последовательно производит все тесты, перечисленные в закладке Configure.

ВАЖНО: Тестируемый анализатор должен иметь следующую конфигурацию:

  • Все соединения на внешние устройства и измерительные наборы должны быть отключены от коннекторов опции Н11 и коннектора ввода/вывода измерительного набора на задней панели анализатора.

  • В диалоговом окне Millimeter Module Configuration установите следующие настройки:

    • PNA модели E8361A - выберите Agilent N5250A, и установите флажок Use Standard PNA operation when N5260A is NOT connected.

    • Другие модели PNA - выберите - Select Standard PNA.

Закладка Run

Список измерительного оборудования представляет собой список оборудования, необходимого для выполнения ВСЕХ тестов (рекомендуется).

Start нажмите для выполнения тестов, выбранных на закладке Configure.

Exit выйти из программы проверки опции H11.

Закладка Configure

По умолчанию выбираются все проверки. В целях выявления конкретных неполадок имеется возможность выбирать только некоторые проверки, устанавливая или снимая флажки.

Проверка мощности

Выходная мощность измеряется для каждого выбранного радиочастотного и гетеродинного коннектора измерительного набора на задней панели. Результаты отображаются на фоне ограничительных линий, отражающих ожидаемые уровни, измеренные на заводе.

Требуемое оборудование:

  • Поддерживаемый PNA измеритель мощности и датчик мощности на 26.5 ГГц (Рекомендуется: Измеритель мощности Agilent E4418/19 и датчик мощности E4413A). Установить адрес GPIB = 13.

  • Кабели GPIB и датчика.

  • Для модели E8361A требуется устройство для эмуляции измерительного набора N5260A, подключенного к порту ввода/вывода измерительных наборов. Остальные модели PNA не требуют данного устройства.

    • Сервисная служба компании Agilent: Используйте тестер ввода/вывода измерительных наборов E8361-60063.

    • Остальные: На серийно выпускаемом штекерном коннекторе DB-25 поставьте перемычку между контактами 12 и 22. См. схему коннекторов ввода/вывода измерительного набора. Вставьте штекерный коннектор в коннектор ввода/вывода измерительного набора на задней панели PNA.

Проверка входа внешней ПЧ и перекрестных помех

Сигнал 8.33 МГц подается на каждый выбранный коннектор ПЧ 8.33 МГц на задней панели. Сигнал измеряется на каждом выбранном приемнике. Результаты отображаются на фоне ограничительных линий, отражающих ожидаемые уровни, измеренные на заводе.

Требуемое оборудование:

  • Функциональный генератор 33120A. Установить адрес GPIB = 10.

  • Аттенюатор 10 дБ (Agilent 8493B или аналогичный) и BNC-адаптеры.

  • Кабели GPIB и BNC

Проверка внешнего импульсного входа

Последовательность импульсов подается на каждый выбранный коннектор импульсного входа на задней панели. Сигнал измеряется на каждом выбранном приемнике. Результаты отображаются на фоне ограничительных линий, отражающих ожидаемые уровни, измеренные на заводе.

Примечание: Шумный импульсный генератор может привести к ложному сбою шага "1% скважности на импульсном входе" проверки внешнего импульсного входа. A noisy pulse generator can cause a false failure of the "1% Duty Cycle Pulse Input" portion of the External Pulse Input Test.

Требуемое оборудование:

  • Импульсный генератор 8110A или 81110A. Установить адрес GPIB = 11.

  • Кабели GPIB и BNC

Проверка коннекторов ввода/вывода для измерительного набора

Проверяет возможность анализатора определять и управлять внешним измерительным набором через коннектор ввода/вывода для измерительного набора на задней панели.

Требуемое оборудование:

  • Сервисная служба компании Agilent: Используйте тестер ввода/вывода измерительных наборов E8361-60063.

  • Остальные: Используйте цифровой вольтметр для измерения уровня напряжения ТТЛ на следующих выводах, используя вывод 1 в качестве заземления:

    • Выводы: 3, 4, 5, 6, 8, 9, 10, 11, 17, 19, 20, 21, 22, 23, 24

    • См. См. схему коннекторов ввода/вывода для измерительных наборов для определения распайки выводов.

    • Программа переключает все выводы в HIGH, а после этого в LOW.

    • TTL HIGH должно показывать около +5.0 В.

    • TTL LOW должно показывать около +0.1 В.

Закладка Help

Отображает номер версии программы проверки опции H11 и информацию о тестируемом анализаторе.

Advanced Help Нажмите для отображения раздела справки.

View Results Появляется после завершения тестирования. Нажмите для отображения результатов проверок в текстовом формате. Неудачные завершения помечены строкой ===>>> Fail. Этот текстовый файл может быть распечатан или сохранен под уникальным именем для сравнения с результатами последующих тестов.


Профилактика неисправностей жесткого диска PNA

Профилактика неисправностей жесткого диска PNA - ВАЖНО

Наиболее частая причина сбоев PNA – проблемы с жестким диском (HDD). Эти проблемы обычно можно предупредить, и, в большинстве случаев, устранить (см. Устранение проблем с жестким диском PNA). Ниже приведены рекомендации, позволяющие предотвратить выход из строя жесткого диска.

Не модифицируйте и не переконфигурируйте операционную систему

Операционная система Microsoft Windows, установленная на анализаторе, специально оптимизирована компанией Agilent для повышения производительности PNA.

  • Не устанавливайте на PNA стандартную версию Windows.

  • Не изменяйте продвинутые настройки и групповые политики.

  • Не создавайте и не удаляйте разделы на жестком диске PNA.

  • Не удаляйте учетную запись Agilent.

  • Не изменяйте ключи реестра Agilent.

Установите антивирусную защиту

Антивирусное ПО не входит в комплект поставки анализатора. При подключении PNA к Internet настоятельно рекомендуется использовать антивирус.

Кроме того, для защиты от вирусов желательно использовать фаервол. Однако, некоторые фаерволы запрещают PNA работать с DCOM.

Установите критические обновления Windows

PNA всегда поставляется с последними пакетами обновлений, доступными на момент производства. Для улучшенной безопасности рекомендуется всегда поддерживать последнюю версию. ПРИМЕЧАНИЕ: Пользователям Windows XP рекомендуется сразу обновиться до SP2.

Установите последние обновления безопасности с веб-сайта Microsoft Windows Update: http://windowsupdate.microsoft.com

Используйте AgileUpdate

При наличии соединения с Internet, используйте программу AgileUpdate для получения последней версии прошивки. На PNA нажмите System, Service, AgileUpdate для запуска автоматического обновления прошивки до последней версии.

При отсутствии соединения с Internet прошивка обновляется с компакт-диска или flash-накопителя. При обновлении никогда не пропускайте изменения старшего номера версии. Например, при обновлении с A.02.xx на A.04.xx, установите сначала A.03.xx, а после этого обновите на A.04.xx

Отключайте шнур питания только тогда, когда индикатор кнопки Power светится желтым

Выдергивание шнура питания или нажатие кнопки power в течение 4 секунд во время работы может привести к повреждению жесткого диска. Для подробной информации см. Включение и выключение анализатора PNA.

Имеются неполадки с жестким диском?

При наличии проблем, вызванных сбойным жестким диском, см. раздел Устранение проблем с жестким диском PNA.


Обзор справочного руководства

  • Устранение неполадок PNA

  • Спецификации

  • Сообщения об ошибках

  • Аксессуары анализатора

  • Интерфейс 82357A USB / GPIB

  • Обновление прошивки

  • Конфигурации и опции PNA

  • Инструментарий диагностики и регулировки

  • Другие ресурсы

  • Техническая поддержка

  • Калибровка прибора

Внимание: Избегайте дорогостоящих ремонтных работ анализатора серии PNA. См. Защита от электростатического разряда.


Учебное руководство

  • Анализатор цепей. Основы (презентация)

  • Уход за коннекторами

  • Защита от электростатического разряда

  • Измерения во временной области

Перечень измерений устройств

  • Абсолютная мощность на выходе

  • Амплитудно-фазовые искажения

  • Комплексный импеданс

  • Отклонение от линейной фазы

  • Усиление и линейность АЧХ

  • Нелинейность амплитудной характеристики

  • Групповая задержка

  • Измерения усилителей мощности

  • Модель согласования импедансов (анимация)

  • Измерения фазы

  • Развязка в обратном направлении

  • Измерения отражения

  • Модель отраженных волн (анимация)

Внимание: Избегайте дорогостоящих ремонтных работ анализатора серии PNA. См. Защита от электростатического разряда.